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Adobe Flash Professional CS6 Project 6 guide

How to publish a Flash document
You develop content in Adobe Flash Professional CS6 by using a Flash FLA document. These documents have a .fla 
extension and can be opened and edited in Flash.


For other people to see your movie, you publish it in a format that is accessible by other software. You use the Publish 
Settings dialog box or the Publish section in the document Properties panel to determine which formats to publish.


Publishing a Flash document for the web
By default, the Publish command creates a Flash SWF file, an HTML document that inserts your Flash content in a 
browser window, and a JavaScript file labeled AC_OETags.js that lets your SWF file play automatically in active 
content-compliant browsers. 


To publish a Flash document for the web:


1. Start Flash and open the document you want to publish.


2. Make sure nothing on the Stage is selected (Edit > 
Deselect All). 


3. In the Properties panel (Window > Properties), expand 
the Publish section (Figure 1).


In the Properties panel, you can select the Target runtime 
for the document and select the ActionScript version that 
matches your document.


4. Click to open the Target menu (Figure 2).


You can publish the document for the Flash Player 
runtime, as an Adobe AIR application, or for playback on 
a device running Flash Lite. For web publishing, you 
select a target version of the Flash Player.


You can publish a document for the most current version 
of the Flash Player or for older versions of the Flash 
Player. 


Note: Some features available in an ActionScript 3 
document may not run properly in older versions of the 
Flash Player. It’s usually best to publish for the most 
current version of the Flash Player.


5. Select a target Flash Player version.


Figure 1 Properties panel, Publish section


Figure 2 Target menu
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6. Click Publish Settings in the Properties panel.


The Publish Settings dialog box appears (Figure 3). It 
shows the most recently selected options. Notice you can 
also select the target runtime and ActionScript version in 
the Publish Settings dialog box.


The default, Flash publishes a Flash (.swf) file, and an 
HTML Wrapper. These are the correct selections if you 
are publishing your content to run in a web browser. 


7. In the list of publish format options, make sure the Flash 
(.swf) and HTML Wrapper options are both selected.


8. Click on the Flash (.swf) option to display the Flash 
publish settings on the right (Figure 4). Be careful not to 
deselect the option.


The default location for published files is to place them in 
the same location as the FLA file. To select a new 
location for the published files, you can click the folder 
icon beside the Output File text box, navigate to the new 
location, and click Save.


You can adjust the JPEG image quality. A higher value 
produces better looking images and larger files.


To make highly compressed JPEG images look 
smoother, select the option Enable JPEG Deblocking. 
This reduces artifacts resulting from JPEG compression. 


To set the audio sample rate and compression for all 
streaming sounds or event sounds in the SWF file, click 
the current Audio Stream or Audio Event setting and 
select new options as needed. 


Note: A streaming sound plays as soon as enough data 
for the first few frames downloads; it is synchronized to 
the timeline. An event sound does not play until it 
downloads completely, and it continues to play until 
stopped.


To override settings for individual sounds specified in the 
Sound section of the Properties panel, select the option 
Override Sound Settings. 


Note: If the Select Override Sound Settings option is 
deselected, Flash scans all stream sounds in the document 
(including sounds in imported video) and publishes all 
stream sounds at the highest individual setting. This can 
increase file size if one or more stream sounds has a high 
export setting. 


To export sounds suitable for devices, including mobile 
devices, instead of the original library sound, select the 
option Export Device Sounds. 


Figure 3 Publish Settings dialog box


Figure 4 Flash (.swf) publish settings
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9. Click the HTML Wrapper option on the left to display the 
HTML publish settings on the right (Figure 5). Be 
careful not to deselect the option.


You can select the template to use for creating the Flash 
HTML page the contains your SWF file. A Flash HTML 
template is a file that contains HTML code and flexible 
template code consisting of a special type of variables 
(which differ from ActionScript variables). When you 
publish a SWF file, Flash replaces these variables with 
the HTML publish options you select in the Publish 
Settings dialog box and produces an HTML page with 
your SWF file embedded.


If you are publishing to Flash Player version 4 or later, 
select Detect Flash Version. Flash version detection 
configures your document to detect the version of Flash 
Player that the user has and sends the user to an 
alternative HTML page if the user does not have the 
targeted player.


By default, the file dimensions are set to match that of the 
movie you’re publishing. You can specify new 
dimensions in pixels or as a percent of the current movie 
size.


There are four Playback control options (Figure 6). 
These include:


• Paused At Start pauses the SWF file until a user 
clicks a button or selects Play from the shortcut 
menu. (Default) The option is deselected and the 
content begins to play as soon as it is loaded.


• Loop repeats the content when it reaches the last 
frame. Deselect this option to stop the content when 
it reaches the last frame. This is on by default. 


• Display Menu shows a shortcut menu when users 
right-click (Windows) or Control-click (Mac OS) the 
SWF file. To show only About Flash in the shortcut 
menu, deselect this option. This option is selected by 
default.


• Device Font substitutes anti-aliased (smooth-edged) 
system fonts for fonts not installed on the user’s 
system. 


To determine the trade-off between processing time and 
appearance, you can open the Quality menu and select 
from six quality options that range from Low to Best 
(Figure 6). 


Figure 5 HTML publish settings


Figure 6 HTML playback and Quality options
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To modify the style of the window that contains your 
HTML file, you can open the Window Mode menu 
(Figure 7) and select from four window options:


• Window uses the HTML background color behind 
the content.


• Opaque Windowless sets the background of the 
Flash content to opaque, obscuring anything under 
the content. Lets HTML content appear above or on 
top of content.


• Transparent Windowless sets the background of the 
Flash content to transparent, allowing the HTML 
content to appear above and below the content. This 
requires viewing in a browser that supports 
windowless content.


• Direct turns on hardware acceleration. By default 
this is turned off. 


You can use the settings in the Scale and Alignment 
section of the HTML publish settings (Figure 8) to 
control how the SWF content is aligned in the HTML 
page. You can also specify if and how a browser scales 
the SWF content when a user changes the size of their 
browser window. 


10. Click Publish at the bottom of the Publish Settings dialog 
box.


Flash publishes files in the same folder as your FLA or to 
another output location that you specified. 


11. Click OK to save these settings for the current file and to 
close the Publish Settings dialog box.


Note: After setting publish options, you can choose 
File > Publish to publish without opening the Publish 
Settings dialog box.


12. To view the published document, open the folder that 
contains the published file and double-click the HTML 
file. 


The HTML file opens in your default web browser and 
displays the SWF content.


Figure 7 HTML Window Mode menu


Figure 8 HTML scale and alignment settings
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Publishing a Windows or Mac OS projector file
To create a self-contained application file that runs without the Flash Player installed, publish your Flash document as 
a Windows or Mac OS projector file.


To publish a projector file:


1. Start Flash and open the document you want to publish.


2. Make sure nothing on the Stage is selected (Edit > 
Deselect All). 


3. In the Properties panel (Window > Properties), expand 
the Publish section.


4. Click Publish Settings to open the Publish Settings dialog 
box.


5. Select Win Projector or Mac Projector from the list of 
publish format options (Figure 9).


6. Click Publish to publish the projector file, or click OK to 
save your publish settings and publish at a later time. Figure 9 Publish format options


Publishing an Adobe AIR application
You can also publish Adobe Flash Professional CS6 documents as Adobe AIR applications. The Adobe AIR runtime 
makes it possible to deploy your Flash movie as a stand-alone desktop application that runs without opening a web 
browser. You can also publish Adobe AIR applications that run on popular mobile devices, including Android phones 
and tablets as well as iOS devices (iPhones and iPads). You can even create an Adobe AIR app that runs on your 
television.


To publish an Adobe AIR application:


1. Start Flash and open the document you want to publish.


2. Make sure nothing on the Stage is selected (Edit > 
Deselect All).  


3. In the Properties panel (Window > Properties), expand 
the Publish section.


4. Click Publish Settings to open the Publish Settings dialog 
box.


5. Select Flash (.swf) from the list of publish format options 
(Figure 10).


Figure 10 Publish format options
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6. In the Publish Settings dialog box, open the Target menu 
(Figure 11). 


7. Select a target runtime option that matches your target 
device, such as AIR 3.2 for Anroid.or AIR 3.2 for 
Desktop.


8. Click Publish.


The AIR Settings dialog box opens to the Signature tab 
(Figure 12). The first thing you need to do is select or 
create a certificate for the AIR application.


9. Click Create (Windows) or New (Mac OS) to create a 
new certificate.


The Create Self-Signed Digital Certificate dialog box 
(unamed in Mac OS) appears (Figure 13). All fields must 
be filled in to create the new certificate


10. Complete the form, including the password fields. 


11. Click in the Save As text box and enter a name for the 
certificate.


12. Click Browse (Windows) or the folder icon (Mac OS), 
select a target location for the new certificate, and click 
Save.


13. Click OK to create the certificate.


A confirmation message appears when the certificate is 
created.


14. Click OK to close the message.


15. Click in the Password text box and enter the password 
you created for the new certificate.


Figure 11 Publish Settings Target menu


Figure 12 AIR Settings dialog box


Figure 13 Create Self-Signed Digital Certificate 
dialog box
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16. Click the General tab in the AIR Settings dialog box.


You can enter a file name for the AIR installer file (.air) 
and enter a name and version number for the application 
(Figure 14).


You can include other information, including a 
description and copyright messaging. 


17. Click Publish to create the AIR application or click OK 
to save your publish settings and publish at a later time.


Flash publishes the AIR application and a message 
appears when the process is complete.


18. Click OK to close the message, and then click OK twice 
to close the AIR Settings and Publish Settings dialog 
boxes.


19. Open the folder you designated as the location for the 
published AIR application. 


The folder contains the AIR installer file (Figure 15). 
You share this file with users who can double-click the 
AIR file to install and run the application. 


Figure 14 AIR Settings dialog box, General tab


Figure 15 Published AIR application files
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Exporting Flash content as an image
Sometimes you may want to export Flash content as an image for use in another document. You can export Flash 
content in JPEG, PNG, or GIF format. 


To export Flash content as an image:


1. Start Flash and open the document you want to publish.


2. Make sure nothing is selected on the Stage. 


3. Open the Properties panel (if it is not already open) and 
expand the Publish section.


4. Click Publish Settings to open the Publish Settings dialog 
box(Figure 16).


5. Select a graphic file type for the image in the list of 
publish format options in the Publish Settings dialog box.


6. If you want to change the names of the image, enter new 
name in the Output file field.


By default, every file type uses the same name as the 
FLA file. Only the file extensions are different.


7. Click Publish to create the image.


By default, files are published in the same folder as the 
FLA file.


Figure 16 Publish Settings dialog box
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Peer Review


Name: _______________________________________________________ Date: ________________________


Project: _____________________________________________________


Overview
Revision is an important part of the design process. In addition to conducting review and redesign cycles personally 
and with your client, you can also benefit from peer review. Additionally, peer review occurs in many professional 
environments and it will be good practice to start on this essential skill now.


When giving peer review, be sure your points are both positive and negative. Give your critiques as suggestions, not 
commands. When receiving peer review, do not be disenchanted or feel that you did a bad job based on one review. 
Every review is different, and what one person does not approve of, the next person may find exemplary.


Process for presenting work for peer review


• When presenting your work for peer review, state the purpose, audience, and goals of your document and 
point out any concerns you have.


• To conclude, summarize the reviewer’s suggestions and offer a plan for revision.


Guidelines for giving comments and suggestions


• Before making any comments, review the entire document and make sure you understand the designer’s 
intentions. Or, if being presented work by a designer, your first response should be to reiterate the designer’s 
purpose, audience, and goals.


• After the designer’s purpose, audience, and goals are clear, ask questions of the designer, make comments, 
and offer suggestions.


• Point out both the strengths and the weaknesses of the document (design, layout, typography, and so on).


• Offer suggestions, not commands. For instance, do not use “should,” as in “You should do this….” Instead, 
use “I” statements, such as “I see that…” or “I’m confused about....”


• Be respectful and considerate of your peer’s feelings. Do not say or write anything you wouldn’t want to 
receive yourself—there is no reason to be rude.


• Make sure your comments are clear and specific so your peer knows what you are referring to. It is 
important to give specific examples and point to design principles, image composition, layout guidelines, 
and so on to make your point. Such comments as “this is unclear” or “this is too vague,” are too general to be 
helpful. Rather make a comment like, “I’m confused by this image because there is no caption identifying 
what it is”).


• If you are writing your comments, reread them before passing them on to your peer. Make sure all your 
comments make sense and are easy to follow.
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How to create a button symbol


Button symbols
Buttons give visitors a way to control parts of a movie. You can use button symbols to create interactive buttons that 
respond to mouse clicks, rollovers, or other visitor interaction. Button symbols are four-frame interactive movie clips. 
The first three frames display the button’s three possible states: Up, Over, and Down. The fourth frame, Hit, defines 
the active area of the button. The timeline for a button doesn’t play like other movies; it reacts to pointer movement 
and actions by jumping to and displaying the appropriate frame.


You can create the image that represents your buttons in several ways. For example, you can use an existing graphic 
as the button, or you can create a shape by using the drawing tools.


Create a button
You will create a new button symbol that contains two layers. One layer will contain a shape representing the 
background of the button. The second layer will include a text label for the button. You will change the background 
and text label in the Over and Down states of the button to create the rollover effect.


To create a button:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Select Insert > New Symbol.


The Create New Symbol dialog box appears (Figure 1).


3. Select Button for Type, name the button, and click OK.


You are now in symbol-editing mode and viewing a 
separate timeline for the button symbol. The Up frame 
contains a keyframe (Figure 2).


Each frame on the timeline of a button symbol has a 
specific function:


• Up state: Represents the button’s appearance 
whenever the pointer is not over the button.


• Over state: Represents the button’s appearance when 
the pointer is over it.


• Down state: Represents the button’s appearance as it 
is clicked.


• Hit state: Defines the area that will respond to a 
mouse click. This area will be invisible in the 
published movie.


4. Make sure the Up frame is selected.


5. Use the drawing tools to create a shape for your button. 
Use the Properties panel to set the fill and stroke colors 
for the Up state of the button.


6. Select the Over state and select Insert > Timeline > 
Keyframe to add a keyframe.


Adding this keyframe copies the button graphic from the 
Up frame to the Over frame.


Figure 1 Create New Symbol dialog box


Figure 2 Button frames: Up, Over, Down, Hit
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7. Select the Over keyframe and use the Selection tool to 
select the button.


8. Change the fill or stroke color of the button shape.


When visitors roll over the button, the button will appear 
as you see it in the Over frame.


9. Insert keyframes in the Down and Hit frames of the layer.


This copies the button graphic from the Over frame to the 
Down and Hit frames.


10. Insert a new layer and name it Text.


11. Select the Up frame of the Text layer.


This frame already contains a keyframe.


12. Use the Text tool to type text on the button shape.


13. Use the Properties panel to adjust the font, size, and color 
of the text so it fits nicely on your button shape.


14. Use the Selection tool or the Up, Down, Left, and Right 
Arrow keys to position the text on the button shape.


15. Insert a keyframe in the Over frame of the Text layer.


16. Select the text and use the Properties panel to change 
some feature of the text in the Over frame, such as color.


17. Insert a keyframe in the Down frame. If you want the text 
to change appearance when the button is clicked, edit the 
appearance of the text in the Down frame.


The timeline should now appear as it does in the example 
(Figure 3).


Now you can insert an instance (copy) of the button 
symbol into the main timeline of your movie.


18. Click Scene 1 (Figure 4) to exit symbol-editing mode 
and return to the main timeline.


19. Select Window > Library to display the Library panel.


The new button symbol appears in the Library panel 
(Figure 5).


Note: You must select the symbol in the library to see the 
symbol in the preview pane.


20. Drag the button symbol from the Library panel onto the 
Stage.


21. Select Control > Test Movie > In Flash Professional to 
test the movie.


When you roll over the button with the pointer, you see 
the changes you defined in the Over frames for the 
button. If you edited the Down state of the button, this 
will be visible when you click the button.


22. Close the preview window.


Figure 3 Button timeline


Figure 4 Symbol-editing mode


Figure 5 Library panel, with the button selected
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Adding sound to a button
You can also add sounds to a button so visitors hear a sound when they interact with the button.


To add sound to a button:


1. Continue from where you left off in the preceding 
activity.


2. Use the Selection tool to double-click the button.


You enter symbol-editing mode for the button.


3. Insert a new layer and name it Sound.


4. Select File > Import > Import To Library to import a 
short sound into the library. 


You can acquire royalty-free sounds from sites such as 
www.flashkit.com.


5. On the Sound layer, add a keyframe to correspond with 
the button state to which you want to add a sound.


For example, to play a sound when visitors roll over the 
button, add the keyframe to the Over state.


6. Click the new keyframe.


7. In the Sound section of the Properties panel, select a 
sound file in the Name menu (Figure 6).


The sound waveform appears in the Sound layer in the 
Timeline panel (Figure 7).


8. Select Event in the Sync menu (Figure 6).


The sound will play when visitors interact with the 
button.


9. Select Control > Test Movie > In Flash Professional to 
test the movie.


When you interact with the button, you hear the sound.


10. Close the preview window.


Figure 6 Properties panel, sound properties


Figure 7 Timeline panel


Name menuSync menu


Sound waveform
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Adding control with actions
Right now the button looks great, but it doesn’t perform any action. You can remedy this by adding ActionScript code 
to your movie. The ActionScript code contains the instructions for what do when someone interacts with the button. 
Buttons give visitors control over the movie. You can use a button to stop the movie, start and stop sounds, restart the 
movie (after stopping it), or jump to different frames within the movie and continue playing. 


The ActionScript code references a button’s instance on the Stage, not the symbol stored in the library. This lets you 
use the same button symbol to perform different actions, depending on where it appears in your movie. 


To add control with actions:


1. Continue from where you left off in the preceding 
activity.


2. Select the button instance to which you want to add an 
action.


3. Click in the Instance Name box in the Properties panel 
(Figure 8) and enter a unique name to identify the button 
instance. The name should be descriptive, such as 
sound_btn, and cannot contain spaces. 


4. In the main timeline of your movie, create a new layer 
named Actions.


5. Make sure there is a keyframe in the Actions layer that 
corresponds to the keyframe where your button first 
appears on the Stage. Select this keyframe in the Actions 
layer.


Note: If your button doesn’t appear on this frame, Flash 
generates an error message when you publish the movie 
because the ActionScript you include on this frame refers 
to an object that isn’t on the Stage yet.


6. Select Window > Actions to display the Actions panel.


7. If you don’t see the parameters area in the Actions panel, 
click the Script Assist button.


8. In the Actions toolbox on the left side of the panel, select 
the AddEventListener method for the IEventDispatcher 
class.


To find the AddEventListener method, expand 
Flash.Events, and then expand IEventDispatcher and then 
Methods.


9. Double-click the AddEventListener method to add it to 
the Script pane (Figure 9).


10. Click in the Object box in the parameters area of the 
Actions panel.


The Insert Target Path button is now active.


11. Click the Insert Target Path button.


The Insert Target Path dialog box appears (Figure 10).


12. Select the Relative option and select the instance name of 
your button. Click OK to close the dialog box.


Figure 8 Properties panel


Figure 9 AddEventListener method 


Figure 10 Insert Target Path dialog box
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13. In the Actions toolbox on the left side of the panel, select 
the CLICK property from the MouseEvent class.


To find the CLICK property, expand Flash.Events, and 
then expand MouseEvent and then Properties.


14. In the Script pane, select the AddEventListener() line to 
display the parameters for this method. Then, in the 
parameters area, click in the Type box.


15. In the Actions toolbox, double-click the CLICK property.


Script Assist adds the property to your code as 
MouseEvent.CLICK (Figure 11).


16. In the Listener box in the parameters area, type a name 
for the function that should execute when the button is 
clicked. You can use any name you like, but make sure 
the name of the function is unique and contains no 
spaces.


The function name appears in the Script pane as you type. 
You have named the function, but you haven’t created it 
yet.


17. In the Actions toolbox, select the function keyword from 
Language Elements. 


To find the function keyword, expand Language 
Elements. Then expand Statements, Keywords & 
Directives, and expand Definition Keyword.


18. Double-click the function keyword in the Actions 
toolbox.


The code for creating a function appears in the Script 
pane.


19. In the parameters area of the Script pane, type the name 
of your function in the Name box.


Note: You must type the function name exactly as you 
typed it for the AddEventListener function. Function 
names are case-sensitive.


20. In the parameters area of the Script pane, type 
event:MouseEvent in the Parameters box (Figure 12).


In this box, you are naming a variable (event) and 
indicating what type of variable it is (MouseEvent).


21. In the Actions toolbox on the left side of the panel, select 
the StopAll method for the SoundMixer class.


To find the StopAll method, expand Flash.Media, expand 
Methods, and then expand SoundMixer.


Figure 11 CLICK property in the Script pane


Figure 12 Function code in the Script pane
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22. Select the function in the Script pane and double-click 
the StopAll method in the Actions toolbox.


The method is added to the function (Figure 13).


23. Now when visitors click the button, all sounds currently 
playing in the movie will stop. Figure 13 StopAll method in the Actions panel


For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, 
select Help > Flash Help. Select ActionScript 3.0 And Components, select Programming ActionScript 3.0, and select 
Getting Started With ActionScript).

How to create a button symbol © 2012 Adobe Systems Incorporated
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How to create a prototype
In this guide, you learn how to use Fireworks CS6 to combine a design comp and a wireframe to create an interactive 
prototype for a widget.


A prototype is a semi-functional interactive model that delivers a preview of the look, feel, and functionality of your 
web project (Figure 1). Prototypes made in Fireworks can also be exported to formats that can be opened in 
Dreamweaver and previewed in a web browser.


Figure 1 Fireworks prototype (left), as viewed in a web browser (right)


Prototyping workflow
By combining the Pages panel with other powerful Fireworks features, you can quickly create interactive web and 
software prototypes. You can convert a finalized prototype to a functioning site by simply exporting it to HTML and 
CSS files for use in Dreamweaver and a web browser. Use the following workflow to transform your previously 
created design comp into a fully functioning interactive prototype. 


1. Create the pages


In the Pages panel, create the desired number of pages or screens for your initial design. As the design evolves, you 
can add or subtract pages as needed.


2. Lay out common design elements


On the canvas, lay out design elements you want to share across multiple pages, such as navigation bars and 
background images.


3. Share common elements across multiple pages


When you share common elements, a single change automatically updates all affected pages. Use a master page to 
share elements or share layers to copy subsets of elements.
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4. Add unique elements to individual pages


On each page, add unique design, navigation, or form elements. In the Common Library panel, you’ll find many 
buttons, text boxes, and pop-up menus that speed up the design process. 


5. Simulate user navigation with links


From web objects such as slices, hotspots, and navigation buttons, link between the various pages of your prototype.


6. Export the finished interactive prototype


Fireworks offers multiple output formats for your prototype, all of which retain hypertext links for page navigation.


Workflow steps 1-3
In this section, you open your original design comp, create the number of pages required for the prototype, and use 
guides to set page element alignment. 


A single Fireworks PNG file can contain multiple pages, providing a perfect way to prototype web and application 
interfaces. Each page contains unique settings for canvas size and color, image resolution, and guides. You set these 
options either on a per-page basis or globally across all pages in a document. Other than the Web Layer, each page 
also contains a unique set of layers. For common elements, however, you can use a master page or share layers across 
pages.


To share common design elements across pages:


1. Start Fireworks and open a previously created design 
comp that was saved as a PNG.


2. Open the Layers panel (Window > Layers) to display it 
on the right side of the workspace.


3. Click the eye icon to turn off visibility in layers that will 
not be shared across multiple layers. For example, any 
logos, navigation, and footer elements will remain on all 
prototype pages and should remain visible (Figure 2).


4. Click the Pages tab to display the Pages panel (Window > 
Pages) (Figure 3).


5. Select the current page in the Pages panel, and choose Set 
As Master Page from the panel Options menu.


6. At the bottom of the Pages panel, click the Add Page 
button to a blank page. Add new pages until you have the 
number of pages shown in your design comp.


The new pages display the master page in the 
background.


7. Double-click the new page names and rename them to 
appropriately describe their functions. 


8. Confirm that rulers and guides are visible. If they are not, 
select View > Rulers and View > Guides > Show Guides.


Figure 2 Layers panel


Figure 3 Pages panel


Turn off 
visibility


Options menuAdd Page 
button
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9. Select the master page in the Pages panel (Figure 4).


10. Create a grid of guides that divide up the design comp 
into logical sections such as page header, logo area, 
navigation, main content areas, and footer (Figure 5).


Placing guides on the master page ensures they display 
across any shared pages in the layout.


To create a horizontal or vertical guide, drag from the 
corresponding ruler to the edge of an element in the 
content area.


Note: You can change the guide color to be more visible 
against different backgrounds. To change the guide color, 
select Edit > Preferences (Windows) or Fireworks > 
Preferences (Mac OS), and select the Guides And Grids 
category.


11. Confirm Smart Guides are visible and active by selecting 
View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.


Note: Smart Guides are temporary snap-to guides that 
help you create, align, edit, and transform objects relative 
to other objects.


12. Select File > Save.


Figure 4 Pages panel, active page selected


Figure 5 Creating a guides grid in the master page


Workflow step 4
In the next few steps, you add unique design elements to individual pages.


You can use the HTML elements available in the HTML folder in the Common Library. The HTML folder contains 
HTML elements such as buttons, drop-down list objects, and text fields. You can edit the properties of these elements 
in the Symbol Properties panel. The HTML components include headings1-6 and link elements.


To add HTML elements to individual pages:


1. In the Pages panel, select a page (not the master page) to 
which you want to add unique elements. 


2. Open the Common Library panel (Window > Common 
Library) (Figure 6).


3. Double-click the HTML folder (Windows) or click the 
HTML disclosure triangle (Mac OS) to display the 
selection of available components. 


Figure 6 Common Library panel
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4. To use an HTML element, drag the component from the 
Common Library panel to the Fireworks canvas.


For example, you can drag the Heading 1 component 
from the Common Library and place it in the Heading 
area you defined by using guides in the previous section 
(Figure 7).


5. On the canvas, select the component.


6. In the Symbol Properties panel (Window > Symbol 
Properties), adjust parameters such as text, color, font, 
size, and other settings (Figure 8). 


For example, you might format the Heading 1 component 
using the same parameters you set in the original design 
comp.


7. Continue adding HTML elements, text blocks, graphics, 
and images to the individual pages as needed. Use the 
Pages panel to navigate between pages. You can also 
copy and paste elements between pages.


The object here is to build out each of the individual 
pages to simulate the content of your fully functioning 
website.


8. Select File > Save when you have completed laying out 
the page-level content of your prototype.  


Figure 7 Drag a component from the Common 
Library 


Figure 8 Symbol Properties panel


Workflow steps 5 and 6
You can design CSS-based layouts in a Fireworks document and then convert them to HTML pages with CSS rules 
that replicate your layouts. CSS-based layouts provide a standards-based approach and give a cross-browser friendly 
code. In this final section you export your finished interactive prototype as CSS-based HTML and images files. 
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Slices are the basic building blocks for creating interactivity in Fireworks. Slices are web objects that ultimately exist 
as HTML code. You can view, select, and rename them through the Web Layer in the Layers panel. Slicing cuts up a 
Fireworks document into smaller pieces and exports each piece as a separate file (Figure 9). When you select CSS 
and Images in the export step, Fireworks converts the layout into HTML and CSS code by using an export engine that 
analyzes the placement of the objects. 


Figure 9 Slicing cuts a document into multiple pieces, which are exported as separate files


Slicing an image provides three major advantages:


• Optimizes images for fastest downloading.


• Adds interactivity so images can respond to mouse events.


• Eases updates for parts of web pages that frequently change (for example, photos and names on an 
employee-of-the-month page).


Observe a few rules while creating slices for CSS-based layouts to get expected results:


Rule 1: Use rectangles to export text and slices to export images. The export engine exports text placed in rectangles. 
Because only images that are covered by rectangular slices are exported, place slices on the images you want to 
export. These slices tell the export engine where the images are.


Rule 2: Avoid overlapping of objects. The export engine treats text, images, and rectangles as rectangular blocks. It 
examines the size and position of these objects to determine the logical rows and columns to place them in the layout. 
Carefully place the objects so their boundaries do not overlap. 


Rule 3: Plan the layout for rows and columns. The export engine looks for logical partitions where a clear line of 
sight can be placed between objects or groups of objects. Enclose your column layouts in a rectangle to prevent the 
export engine from inserting a logical row that breaks the column layout.


Rule 4: Treat the document as two-dimensional. When you design your page, use rectangles to enclose objects that 
you want to treat as children of the rectangle. The export engine detects such export relationships. The export engine 
scans the child elements for logical rows and columns as in Rule 3.


In addition to these rules, observe the following: 


• The export engine exports only primitive rectangles. To export the rounded corners of rectangles, place 
rectangular slices over them.


• To export the strokes of rectangles, place rectangular slices over rectangles that have them.


• To export symbols, place a rectangular slice over them.


• To export filters you have applied to text or rectangles, place rectangular slices over them.
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To add navigation links and export a CSS layout:


1. Select the master page in the Pages panel.


2. From the Tools panel, select the Slice tool and confirm 
the Show Slices And Hotspots button is selected 
(Figure 10).


3. Using the guides for reference, draw a slice over a 
navigation element on the master page (Figure 11).


4. Select the slice with the Pointer tool.


5. In the Properties panel, set the Link to a page you 
previously defined by using the Pages panel. 


For example, a slice has been drawn over the Shop shape, 
and the link set to Shop.htm (Figure 12). Because this 
slice is located on the master page, every page inherits 
the linked slice when the interactive prototype is 
exported.


6. Continue adding slices and links to navigation elements 
as needed.


7. Add slices to the areas between the navigation elements 
and around the outside of the main body content areas 
(Figure 13).


You add page-level content slices in the next steps.


8. Navigate to an individual page by selecting it in the 
Pages panel.


9. Use the Slice tool and guides to create slices inside the 
main body content area not otherwise sliced up as part of 
the master page.


You may need to apply several slices to cover an entire 
layout. Take care not to overlap slices as you draw on the 
canvas.


10. Use the Pointer tool to select any slices in the layout that 
contain text you want to convert to HTML text.


Figure 10 Tools panel


Figure 11 Draw a slice object


Figure 12 Set Link in the Properties panel


Figure 13 Slice up the master page.


Slice tool


Show Slices And Hotspots
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11. With the slice object selected, select HTML from the 
Type pop-up menu in the Properties panel (Figure 14).


An HTML slice designates an area where ordinary 
HTML text appears in the browser that you may want to 
edit later in Dreamweaver (Figure 15).


12. Continue adding slices until all the content areas of all 
the individual pages are covered.


13. Choose File > Export.


The Export dialog box appears (Figure 16).


14. From the Export pop-up menu, choose CSS and Images 
(.htm).


15. From the Pages pop-up menu, choose All Pages.


16. Select the Put Images In Subfolder option in the Export 
dialog box.


17. Click Options to set the HTML page properties.


The HTML Setup dialog box appears (Figure 17).


18. If you have a background image, click Browse to specify 
a background and set the tiling:


• Select No Repeat to display the image only once.


• Select Repeat to repeat, or tile, the image both 
horizontally and vertically.


• Select Repeat-x to tile the image horizontally.


• Select Repeat-y to tile the image vertically.


19. Select the page alignment on the browser as left, center, 
or right.


20. Select the attachment scrolling as either fixed or scroll.


21. Click OK to close the HTML Setup dialog box.


22. Click Save (Windows) or Export (Mac OS). 


The layout is exported to CSS and images HTML format.


Figure 14 Properties panel


Figure 15 Layout slices


Figure 16 Export dialog box


Figure 17 HTML Setup dialog box


HTML slices
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23. Navigate to the location of the saved files. Click on one of the HTML files and test that the prototype links work 
as expected (Figure 18).


Figure 18 Fireworks prototype viewed in a web browser
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Digital Design Project 6 worksheet

Project plan


Team name: __________________________________________________ Date: ________________________


Client name: _________________________________________________


Think through the phases of your client project and identify the estimated time and the date when each task will be 
finished. Identify an owner for each task who will make sure the task is completed.


Project phases Estimated hours Date due Owner


Define


Goals and target audience


Content and asset 
collection


Content and style 
information


Delivery requirements


Structure


Information architecture


Design document


Flowchart


Wireframes


Design


Design comps


Design review
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Redesign


Production storyboard


Prototype wireframe


Build and test


Site production


Technical test and bug list


Usability test


Revision


Test of revised site


Final presentation


Final revision


Launch


Search Engine 
Optimization (SEO)


Promotion plan


Put site online


Total time: = Final deadline


Project phases Estimated hours Date due Owner
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How to use CSS starter layouts
When creating a new document in Dreamweaver, you can choose one that already contains a CSS layout. 
Dreamweaver comes with many different CSS layouts from which to choose (Figure 1). The predesigned CSS 
layouts provide the following types of columns:


• Liquid layouts specify column width as a percentage of the site visitor’s browser width. The design adapts if 
the site visitor makes the browser wider or narrower, but does not change based on the site visitor’s text 
settings.


• Fixed layouts specify column width in pixels. The column does not resize based on the size of the browser or 
the site visitor’s text settings.


The New Document dialog box also includes two options for HTML5 and CSS layouts.


Figure 1 New Document dialog box


Using a starter layout
Starter layouts are available as an option in the New Document dialog box.


To use a starter layout:


1. Start Dreamweaver.


2. Select  File > New.


The New Document dialog box opens (Figure 1).


3. Select the Blank Page category if not already selected.


4. For Page Type, select HTML.


Attach Style Sheet button
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5. For Layout, select the CSS layout you want to use. 


You can choose from 16 different layouts. The Preview 
window shows the layout and gives a brief description of 
the selected layout.


The selection illustrated in Figure 1 is a 2-column liquid 
layout with a left sidebar, header, and footer is selected.


6. Select a location for the layout’s CSS from the Layout 
CSS pop-up menu:


• Add To Head adds CSS for the layout to the head of 
the page you’re creating.


• Create New File adds CSS for the layout to a new 
external CSS stylesheet and attaches the new 
stylesheet to the page you’re creating.


• Link To Existing File lets you specify an existing 
CSS file that already contains the CSS rules needed 
for the layout. This option is particularly useful when 
you want to use the same CSS layout (the CSS rules 
for which are contained in a single file) across 
multiple documents.


7. Do one of the following: 


• If you selected Add To Head from the Layout CSS 
pop-up menu (the default option), click Create. 


• If you selected Create New File from the Layout 
CSS pop-up menu, click Create, and then specify a 
name for the new external file in the Save Style 
Sheet File As dialog box. 


• If you selected Link To Existing File from the 
Layout CSS pop-up menu, add the external file to 
the Attach CSS File text box by clicking the Attach 
Style Sheet button, completing the Attach External 
Style Sheet dialog box, and clicking OK. When 
you’re finished, click Create in the New Document 
dialog box.


Note: When you select the Link To Existing File 
option, the file you specify must already have the 
rules for the CSS file contained within it.


When you put the layout CSS in a new file or link to an 
existing file, Dreamweaver automatically links the file to 
the HTML page you’re creating.


The layout opens in Dreamweaver (Figure 2).


8. (Optional) You can modify some aspects of a page (font, 
font size, colors and margins) after it’s created by 
selecting Modify > Page Properties to open the Page 
Properties dialog box (Figure 3).


Figure 2 Dreamweaver CSS starter layout


Figure 3 Page Properties dialog box
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How to resize, rotate, and crop images
You will frequently want to resize and crop an image after opening it in Photoshop from a digital camera or scanner. 
Cropping means cutting some parts of the image away so only the parts you want remain.


Backing up your original
Before making any changes to an image, you should always save the image with a new filename. You will have the 
most flexibility if you save it as a PSD—Photoshop’s native format. You can generate TIFFs (for print) and JPEGs 
(for the web) from a single PSD file. For example, PSD files preserve layers, so the layers are available when you 
reopen the file.


Resizing images
When working in Photoshop, it is generally best to leave your image at as high a resolution as possible to allow for 
greater flexibility when generating images.


About pixel dimensions and resolution


The pixel dimensions (image size or height and width) of a bitmap image is a measure of the number of pixels along 
an image’s width and height. Resolution is the fineness of detail in a bitmap image and is measured in pixels per inch 
(ppi). The more pixels per inch, the greater the resolution. Generally, an image with a higher resolution produces a 
better printed image quality.


• For images to print well, they generally should have a resolution of 300 ppi.


• For most web pages, you can safely save images at 72 ppi. Because most monitors do not display resolutions 
higher than this, you can reduce file size by reducing resolution.


Note: Monitor technology and Internet connection speeds are continually evolving. However, the 72-ppi standard 
continues to be widely used, and for the most part, you can’t go wrong with it.


The combination of pixel dimension and resolution determines the amount of image data. Unless an image is 
resampled, the amount of image data remains the same as you change either the pixel dimension or resolution. If you 
change the resolution of a file, its width and height change accordingly to maintain the same amount of image data. 
And, vice versa. 
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In Photoshop, you can see the relationship between image size and resolution in the Image Size dialog box 
(Figure 1). 


To change resolution of an image:


Changing an image’s resolution affects not only its on-screen 
size but also its image quality and its printed characteristics.


1. Open an image in Photoshop.


2. Save the image with a new name.


This step preserves the original image in case you want to 
revert to it. You should always make a copy of the 
original before making changes.


3. Choose Image > Image Size.


The Image Size dialog box opens (Figure 1).


Notice that the dialog box lists two major categories of 
information about the size of the image.


• Pixel Dimensions refers to the actual number of 
pixels contained in the image. The number of pixels 
represents the amount of data in the image. Unless 
you select the Resample Image option, number of 
pixels remains the same as you resize and change the 
resolution of the image.


• Document Size refers to how the document appears 
when printed. Document size is also a starting point 
for how the document will appear in another 
document, such as an InDesign file. In later projects, 
you will place Photoshop images in InDesign files.


4. Make sure the Resample Image option is not selected.


The Resample option changes the amount of data or 
information in the image as you resize. For now, it’s best 
to leave this option deselected. 


Note: You can use resampling to make enlargements. 
However, because resampling can only estimate pixels, it 
is best to use a picture with a larger resolution in the first 
place.


5. Change the Resolution value.


Observe that the other two numbers for width and height 
change accordingly. For example, suppose an image set 
at 300 dpi measures approximately 13 by 9 inches. The 
same image when set to 72 dpi measures approximately 
54 by 36 inches (Figure 2). 


6. Click OK to close the Image Size dialog box.


Figure 1 Image Size dialog box with resolution at 
300 dpi


Figure 2 Image Size dialog box with resolution 
changed to 72 ppi
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Reducing an image’s size (pixel dimensions)


Although you will often want to keep pixel information, sometimes you need to reduce the total (pixel) size of an 
image. This step removes pixels and reduces file size. You will usually do this when preparing the image for the web 
or other electronic medium; for print, you will generally want to simply change the document’s size. (Of course, you 
may want to reduce file size for other reasons, such as to preserve hard disk space or to speed up image rendering.)


To reduce an image’s pixel dimensions:


1. Choose Image > Image Size.


The Image Size dialog box opens (Figure 3).


In the previous steps you attended only to the resolution, 
or document size of the image. This time you will ignore 
that area and focus on the pixel dimensions.


2. Select the Resample Image option near the bottom of the 
dialog box. 


Observe that the Pixel Dimensions menus and the 
Constrain Proportions option become active.


This option automatically changes the width as you 
change the height, and vice versa. For example, if you 
start with an image of 2000-pixel width and 1000-pixel 
height (a 2:1 width/height ratio) and change the width to 
1000 pixels, the height automatically changes to 500 
pixels when Constrain Proportions is checked. Generally, 
selecting this option is a good idea.


Note: You can ignore Scale Styles for now. This option 
comes into play only when you have styles applied to 
layers.


3. Choose Bicubic Sharper from the Resample Image menu. 


This option is best for reductions.


4. In the Pixel Dimensions Width box, enter the desired 
width in pixels.


You can also choose a percentage by changing the unit 
beside the Width box from Pixels to Percent.


5. Click OK to change the image’s pixel dimensions.


Note: After the size reduction, you should apply the 
Unsharp Mask filter to the image by choosing Filter > 
Sharpen > Unsharp Mask. This will clear up any 
blurriness that results from the reduction.


Figure 3 Image Size dialog box
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Rotating images
There may be times when you open an image in Photoshop to find that it is not in its proper orientation. Alternatively, 
a photograph that you have taken is just a little bit crooked. There are easy ways to fix both of these situations.


To rotate an image:


The Image Rotation commands let you rotate or flip an entire 
image. The commands do not work on individual layers or 
parts of layers, paths, or selection borders. If you want to 
rotate a selection or layer, use the Transform or Free 
Transform commands.


1. Choose Image > Image Rotation (Figure 4), and choose 
one of the following commands from the submenu:


• 180° Rotates the image by a half-turn.


• 90° CW Rotates the image clockwise by a quarter-
turn.


• 90° CCW Rotates the image counterclockwise by a 
quarter-turn.


• Arbitrary Rotates the image by the angle you 
specify. If you choose this option, enter an angle 
between 0 and 359.99 in the Angle text box. Select 
°CW or °CCW to rotate clockwise or 
counterclockwise. Then click OK.


2. Choose File > Save to save the rotated image. 
Figure 4 The Image Rotation submenu


Cropping Images
You’ll often take pictures that are larger than you need, or you'll want to reframe an image to remove unnecessary 
parts. Taking pictures that are larger than you need, at as high a resolution as possible, gives you flexibility in 
selecting parts of an image to crop. Cropping is the process of removing portions of an image to create focus or 
strengthen the composition. 


You can crop an image in Photoshop by selecting an area with one of the selection tools and using the Image > Crop 
command. The Crop tool in the Tools panel provides additional options for cropping images. You can use the Crop 
tool to select an area to crop, or set the Crop tool to trim an image to a specified aspect ratio. This guide covers how 
to use the Crop tool.


Grid overlays


A variety of grids for overlaying an image you are cropping are available from the View menu in the Options bar. The 
Rule of Thirds grid, for example, illustrates a general rule of thumb in the visual arts. This grid consists of two 
equally spaced horizontal and vertical lines. Visual interest and a strengthened composition are created when objects 
are placed along (or at the intersection of) these horizontal and vertical lines. 


To crop an image by using the Crop tool:


1. Click the Crop tool in the Tools panel (Figure 5). 


The pointer changes to the Crop tool.


Figure 5 Crop tool
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2. Choose a crop option from the list of menu of preset 
aspect ratios in the Options bar (Figure 6). 


For example, you may choose Unconstrained, which 
allows you to crop an image to dimensions that you 
specify. Alternatively, you can select from a series of 
preset aspect ratios, such as Original Ratio or other 
common ratios, such as 16:9, also known as widescreen. 
If you are processing several images and want to 
maintain a specific crop size, you can save your 
customized setting by using the Save Preset option.


3. Choose an overlay grid from the View menu in the 
Options bar (Figure 7).


4. Create a marquee selection by dragging over the part of 
the image you want to keep (Figure 8). 


The selection doesn’t have to be precise—you can adjust 
it in the next step.


A Rule of Thirds grid appears.


5. If necessary, adjust the cropping selection:


• To move the selection to another position, place the 
pointer inside the bounding box and drag.


• To scale the selection, drag a handle in any of the 
corners. To constrain the proportions, hold down 
Shift as you drag a corner handle. 


• To rotate the selection, position the pointer outside 
the bounding box (the pointer becomes a curved 
arrow), and drag. To move the center point around 
which the marquee rotates, drag the circle at the 
center of the bounding box. The selection can’t be 
rotated in Bitmap mode.


6. If necessary, use the Straighten tool to correct for camera 
tilt. Click the Straighten tool in the Options bar and then 
drag along a line in the image that you want to make 
vertical or horizontal.


7. Once you are satisfied with the crop area, press Enter 
(Windows) or Return (Mac OS).


The image is trimmed to the selected region (Figure 9).


Figure 6 Menu of preset aspect ratios


Figure 7 Menu of preset View options


Figure 8 Crop area selected


Figure 9 Crop applied
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How to resize content for multiple screens
Many mobile devices are on the market and their screen sizes vary. A common challenge when developing mobile 
applications (or web content for mobile devices) is to make your content look the same (or at least look good) on 
every device. You want to make sure your content fits each screen perfectly. You can meet this challenge in a couple 
of ways: You can design mobile applications that target a specific device and screen size—reusing and resizing 
content to build separate versions for each device. Or you can use ActionScript and auto-scaling features to create a 
single version that automatically scales to match each screen. 


Creating and sizing content for multiple screens
If you’re creating multiple versions of the same content and adjusting a design to match multiple screen sizes, you 
can use the following features in Adobe Flash Professional CS6 to adapt your content for each device. 


• Use Save As to create a new file based on an existing file.


• Use Adaptive Scaling to resize content objects automatically to match the screen size.


• Adjust content objects manually by using Free Transform or by changing values in the Properties panel.


• Copy and paste layers and content from one Flash Professional document to another.


To save an existing document as a new file:


1. Open the Flash Professional document you want to adapt 
for multiple screens.


2. Select File > Save As.


The Save As dialog box appears.


3. Enter a name for the new document and click Save.


You now have an exact copy of the original file. You can 
adapt the file for another screen by changing the 
document’s publish settings, adjusting the document 
dimensions, and scaling its content.


4. In the Publish section of the Properties panel, select a 
new target runtime from the Target menu (Figure 1). 


In this example, we designed the application for Android 
mobile devices. You can change the target to AIR For 
IOS to create a version for the Apple iPhone or other iOS 
device.


After setting up the new document, you need to edit the 
document dimensions to match those of the new target 
screen. 


When you change document dimensions, you can use 
Adaptive Scaling to help resize your content to match.


Figure 1 Properties panel, Publish section 
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To use adaptive and manual scaling to resize content:


1. Select Edit > Preferences (Windows) or Flash > 
Preferences (Mac OS) and select the General Category in 
the Preferences dialog box.


2. Make sure both Scale Content options (Align Top Left 
and Include Locked And Hidden Layers) are selected 
(Figure 2).


The second option ensures that when Adaptive Scaling is 
enabled, the content in locked and hidden layers will 
scale along with the rest of the document.


3. Click OK to confirm the document preferences.


4. In the Properties section of the Properties panel, click the 
Edit Document Properties button (Figure 3). 


The Document Settings dialog box appears (Figure 4).


Notice the current size of the document. In this example 
it’s 480 x 800, the default size for AIR for Android apps. 
If you were adapting this design to match an iOS device 
screen, you’d change the document size to 640 x 960, the 
default dimensions for AIR for iOS apps.  


5. Change the document dimensions to 640 (width) and 960 
(height), or other dimensions that match your target 
screen.


6. Dimensions represent the size of the Stage. 


When you change the Stage dimensions, you also have 
the option to turn on Adaptive Scaling options. These 
include:


• Adjust 3D Perspective Angle: Adjusts the position 
and orientation of 3D objects on the Stage to 
maintain their appearance relative to the edges of the 
Stage.


• Scale Content With Stage: Automatically scales the 
contents of the Stage relative to the change in Stage 
size.


7. Select Scale Content With Stage.


Note: If your document includes 3D objects, you also 
want to select the option to adjust the 3D perspective 
angle.


8. Click OK.


The Stage area changes size. Flash Professional does its 
best to scale the content to match the Stage. Depending 
on how accurate the scaling, you may need to manually 
fine-tune the size of some content objects. 


In this example, Flash Professional came close to 
matching the content to the Stage, but some minor 
adjustments are needed (Figure 5).


Figure 2 Preferences dialog box, Scale Content 
options 


Figure 3 Properties panel, Properties section


Figure 4 Document Settings dialog box 


Figure 5 Resized document and content 


Edit Document Properties button
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9. Select Edit > Select All.


This selects all content objects in the current frame. You 
can resize the mixed selection as a single object by using 
the Free Transform tool or by changing the Position And 
Size values in the Properties panel (Figure 6). 


10. Enter new dimensions for the mixed selection by 
changing the width (W:) and height (H:) values in the 
Position And Size section of the Properties panel. 


The group scales together to match the new dimensions 
(Figure 7).


Note: You may need to resize other content objects that 
appear in the timeline. Resizing the content can also 
distort your artwork when the new document dimensions 
have a different aspect ratio (height to width) than the 
original document.


Figure 6 Properties panel, Position And Size 


Figure 7 Manually scaled content 
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To copy layers and content from one document to another:


1. Open a completed Flash Professional document that you 
want to adapt to another screen.


2. Open a new blank document and specify settings to 
match the new target device. 


3. Use the document tab in the Flash Professional 
workspace to switch back to the file that contains your 
finished content (Figure 8).


4. Select the top layer in the Timeline panel.


5. Shift-click the bottom layer in the Timeline panel.


This selects all layers and content in the timeline 
(Figure 9). 


Note: You can also select individual layers or multiple 
noncontiguous layers by holding down Ctrl (Windows) 
or Command (Mac OS) as you select.


6. Right-click (Windows) or Control-click (Mac OS) and 
select Copy Layers from the context menu.


7. Use the document tab to change to your new blank 
document.


The new document includes one empty layer named 
Layer 1.


8. Right-click (Windows) or Control-click (Mac OS) 
Layer 1 in the Timeline panel and select Paste Layers.


The layers are added to the new document’s timeline 
directly above Layer 1 (Figure 10).


9. Select Window > Library to open the Library panel in the 
new document.


The new document’s library includes every object from 
the source file (Figure 11).


Figure 8 Document tabs


Figure 9 Timeline panel, source document


Figure 10 Timeline panel, new document


Figure 11 Library panel, new document
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Using ActionScript code to scale content to multiple screens
At times you need your content to scale automatically to fit each end user’s screen. For example, a mobile app needs 
to rotate and scale when users turn their tablets from portrait to landscape orientation. You may also be developing 
web content that you want mobile users to access from any device. This content needs to scale to adapt to each user’s 
screen size.


One way to accomplish this is to use ActionScript code that controls content scaling. In this guide you create a new 
document and use ActionScript code to control document scaling. To test the ActionScript code that controls object 
position and scaling, you create content objects and give them instance names that match the references to these 
objects in the sample ActionScript code.   


To use ActionScript to scale content to multiple screens:


1. Start Flash Professional and open a new AIR For Android 
document with white as the document background color.


2. Select View > Magnification > Fit In Window so you can 
see the entire Stage. 


3. Create the following sample objects in the application:


Note: You can import artwork or use the drawing tools to 
create the sample content objects (Figure 12).


• Background layer: Artwork that fills or extends 
beyond the Stage. For this example, we used the 
Deco tool to create a Vine Fill pattern. Convert the 
background artwork to a movie clip symbol and 
name the instance back_art. 


• Text layer: TLF text that fills the lower quarter of the 
Stage and is the same width as the Stage. Name the 
TLF text instance main_txt.


• Image layer: Add an image or draw a simple shape. 
Position the shape above the text. Convert it to a 
movie clip symbol and name the instance 
main_image.


• Title layer: Use the text tool to create a sample title. 
Position it near the top of the screen. Convert the 
title to a movie clip symbol and name the instance 
app_title.


The Timeline panel now includes the layers and sample 
content to add the position and scale ActionScript code 
(Figure 13). 


Before you add the code, however, you need to test the 
movie to see how it scales.


Figure 12 Background image 


Figure 13 Timeline panel 
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4. Make sure nothing is selected on the Stage. 


5. In the Properties panel, change Publish Target from AIR 
3.2 For Android to a Flash Player version—for example 
Flash Player 11.2 (Figure 14).


Changing to Flash Player will let you test in Flash 
Professional and resize the preview window.


6. Select Control > Test Movie > In Flash Professional.


7. Drag the edges of the preview window to see what 
happens to the content when the window or screen size is 
different from the original dimensions of the application. 


Because the content does not scale automatically along 
with the screen size, it gets cut off (Figure 15). 


8. Close the preview window.


9. Insert a new layer in the Timeline panel and name it 
Actions.


10. Select Window > Actions to open the Actions panel.


Figure 14 Properties panel, Publish settings 


Figure 15 Sizing the preview window 
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11. Enter or copy and paste the following code into the Action panel to prevent the Stage from scaling automatically:
//This code is to prevent the stage from scaling until you tell it to.


stage.scaleMode = StageScaleMode.NO_SCALE;


stage.align = StageAlign.TOP_LEFT;


12. Enter or copy and paste the following Event Listener to listen for when the window is resized and call the 
setPosition function to size and position objects on the Stage:


stage.addEventListener(Event.RESIZE, resizeLayout);


function resizeLayout(e:Event):void


{


setPosition();


}


13. Enter or copy and paste the following code for the setPosition function that scales and positions the objects in the 
movie based on the size and position of the Stage: 


function setPosition():void


{


//Position elements according to the stage.stageWidth and stage.stageHeight


   main_txt.autoSize = TextFieldAutoSize.LEFT;


   main_txt.width = stage.stageWidth + 10;


   main_txt.y = stage.stageHeight - main_txt.height;


   app_title.x = stage.stageWidth / 2;


   main_image.x = app_title.x;


   main_image.y = main_txt.y - main_image.height;


   back_art.height = stage.stageHeight;


   back_art.width = back_art.height;


   if (stage.stageWidth > stage.stageHeight){


      back_art.width = stage.stageWidth;


      back_art.height = back_art.width


   }


   back_art.x = stage.stageWidth/2;


   back_art.y = stage.stageHeight/2;


}
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14. Close the Actions panel.


15. Select Control > Test Movie > In Flash Professional.


16. Drag the edges of the preview window to see what 
happens to the content when the window or screen size is 
different from the original dimensions of the application. 


The content scales automatically to match the screen size 
and objects are repositioned as well as possible to match 
the intended design (Figure 16). 


17. Close the preview window.


18. In the Properties panel, change Publish Target back to 
AIR 3.2 For Android and click the Edit Application 
Settings button (Figure 17).


The AIR For Android Settings dialog box appears.


19. On the General tab, select Auto Orientation (Figure 18).


The app will automatically alternate between portrait and 
landscape view when users turn their mobile devices.


20. Select the Deployment tab and select Emulator Release 
(Figure 19).


This tells Flash Professional that you are testing the 
application instead of publishing the app for installation 
on a device.


21. Click OK to save your changes and close the dialog box.


Figure 16 Sizing the preview window 


Figure 17 Properties panel


Figure 18 AIR For Android Settings dialog box, 
General tab


Figure 19 AIR For Android Settings dialog box, 
Deployment tab


Edit Application Settings button
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22. In the Properties panel, click the Edit ActionScript 
Settings button (Figure 20).


The Advanced ActionScript 3.0 Settings dialog box 
appears (Figure 21).


23. Select the Library Path tab.


24. Open the Default Linkage menu in the Runtime Shared 
Library Settings section of the dialog box and choose 
Merged Into Code (Figure 21).


25. Click OK.


This embeds any shared libraries such as TLF Text 
libraries used to format text and prevents Flash 
Professional errors when you test or publish the mobile 
application. 


Figure 20 Properties panel


Figure 21 Advanced ActionScript 3.0 Settings 
dialog box


Edit ActionScript Settings button
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26. Select Control > Test Movie > In AIR Debug Launcher 
(Mobile).


The application opens and the Device preview window 
appears (Figure 22). It shows how the app appears on an 
Android device in the vertical (portrait) position.


27. (Windows) Open the Device menu and select Rotate 
Right (Figure 23).


The app rotates to horizontal (landscape) orientation and 
its contents scale and reposition to fit the screen 
(Figure 24).


28. (Mac OS) Make sure the Accelerometer section is 
visible. Drag the Z axis slider to either the left or right 
until the number of degrees is –90 or 90, respectively. 


You can also select the degree value for the Z axis and 
enter –90 or 90.


The device rotates 90 degrees and the app appears in 
horizontal (landscape) orientation. Its contents scale and 
reposition to fit the screen.


Figure 22 Device preview window


Figure 23 Device menu


Figure 24 Horizontal (landscape) orientation
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How to draw and create shapes
You can add artwork to your Adobe Flash Professional CS6 documents in two ways: You can import images or draw 
original artwork in Flash by using the drawing tools in the Tools panel. 


Drawings you create in Flash are vector graphics. Vector graphics describe images by using lines and curves called 
vectors that also include color and position properties. When you edit a vector graphic, you modify the properties of 
the lines and curves that describe its shape. You can move, resize, reshape, and change the color of a vector graphic 
without changing the quality of its appearance. Vector graphics are resolution independent; that is, they can be 
displayed on output devices of varying resolutions without losing any quality. 


The files you import to Flash can be either vector graphics or bitmap images. Bitmap images (also known as raster 
images) are made up of pixels in a grid. Pixels are picture elements: tiny dots of individual color that make up what 
you see on your screen. A JPEG photograph is an example of a bitmap image. Because bitmaps are resolution 
dependent, it's difficult to increase or decrease their size without losing some image quality. Bitmap images are 
typically much larger in file size than vector graphics. 


The bitmap images you import to Flash can also be turned into vector drawings in two ways: You can break them 
apart to create a single vector shape or you can trace the bitmap to create a collection of vector shapes that resemble 
the original bitmap image.


In this guide you use the drawing tools to create and modify vector graphics. You also import bitmap images and 
convert them to vector shapes by using the Break Apart and Trace Bitmap commands.


Drawing with basic lines and shapes
One way to become familiar with the Flash drawing tools is to create something simple using basic lines and shapes.


Flash has two drawing modes: Merge Drawing and Object Drawing. Merge Drawing blends shapes when they 
overlap on the Stage. Shapes drawn on top of other shapes will merge, which means if you select one of the shapes 
and move it, the underneath shape is cut away (Figure 1).


Object drawing treats your shapes as grouped objects that can overlap without affecting each other (Figure 1). 


You can change between drawing modes by enabling or disabling Object Drawing in the Tools panel.


Figure 1 Merge Drawing (left) and Object Drawing (right)


Selecting drawing tools and setting properties


Flash drawing tools are available in the Tools panel. When you select a drawing tool, the properties for that tool 
appear in the Properties panel and any options for the selected tool appear at the bottom of the Tools panel. (You may 
need to enlarge the Flash window to see tool options.)


Most drawing tools have several properties in common, but each tool has a few unique properties.
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To set drawing tool properties:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Select the Oval tool in the Tools panel.


The Oval tool properties appear in the Properties panel 
(Figure 2). If the Properties panel isn’t open, select 
Window > Properties.


In the Properties panel, you can set the color, style, and 
size of the outer stroke of a shape. You can also change 
the color of the shape’s inner fill. 


You can select from several stroke types, such as solid or 
dashed lines.


Selecting the Hinting option enables stroke hinting. 
Stroke hinting adjusts line and curve anchors on full 
pixels to prevent blurry vertical or horizontal lines.


Cap settings control how the end of a path appears.


• None: The path ends flush—there is no cap.


• Round: Adds a round cap that extends beyond the 
path end by half the stroke width.


• Square: Adds a square cap that extends beyond the 
path end by half the stroke width.


Join settings define how two path segments meet 
(Figure 3). 


• Miter: Forms a sharp angle at the junction of two 
paths. To avoid beveling a mitered corner, enter a 
Miter value greater than 0.


• Round: Creates a smooth, rounded connection 
between two paths. 


• Bevel: Creates a beveled edge where two paths meet. 


The options in the Properties panel are slightly different 
for each drawing tool. For example, the Oval tool 
includes Start Angle, End Angle, and Inner Radius 
properties. 


The Rectangle tool includes Corner Radius properties for 
creating rounded corners (Figure 4).


If you are creating lines with the Brush tool or with the 
Pencil tool in Smooth mode, you can set the Smoothing 
value (Figure 5). Smoothing controls how Flash smooths 
out the curves in the lines you draw or paint. You can 
specify a value from 0 to 100. 


Figure 2 Properties panel, Oval tool


Figure 3 Join options (left to right): Miter, Round, 
Bevel


Figure 4 Rectangle tool corner radius options


Figure 5 Pencil and Brush tool Smoothing option


Stroke color Fill colorHinting option
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3. Make sure the Oval tool is still selected.


A tool’s modifier options are located in the options area 
at the bottom of the Tools panel (Figure 6). You may 
need to enlarge the Flash window to see tool options.


Options that are common to most Flash shape-drawing 
tools include:


• Stroke Color and Fill Color: Open a color palette 
to change stroke or fill color. In Merge Drawing 
mode, you must select a color before you begin 
drawing. You can also select stroke and fill colors 
in the Properties panel. 


• Black And White: Resets the stroke and fill colors 
to black stroke and white fill.


• Swap Colors: Swaps the current stroke and fill 
colors.


• Object Drawing: Toggles Object Drawing mode 
on and off. This is how you change between Merge 
Drawing and Object Drawing.


• Snap To Objects: Toggle the Snap To Objects 
feature on and off. This is off by default.


Figure 6 Tools panel, Oval tool modifier options


Creating a simple drawing with lines and shapes


A good way to become familiar with the Flash drawing tools is to create something very basic. In this activity, you 
use lines and shapes to create a simple drawing.


To draw in Merge Drawing mode:


1. Select the Oval tool in the Tools panel (if it’s not 
already selected). 


2. In the options section of the Tools panel, make sure 
Object Drawing is deselected.  


For now, you want to be in Merge Drawing mode.


3. Select a fill color for the shape, such as blue.


Note: You can select a fill color in the Properties panel 
or in the Tools panel.


4. Select a stroke color, such as black.


5. In the Properties panel, change the Stroke Height value 
to 15.


6. On the lower-center of the Stage, drag to draw an oval 
that is about 2 inches tall (Figure 7). 


Note: If you want to draw a perfect circle, hold down 
Shift as you drag the Oval tool on the Stage.


Figure 7 Oval shape with stroke and fill


Stroke color


Fill color


Black And White
Swap Colors


Object Drawing


Snap To Objects
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7. In the Properties panel, change the Oval tool fill color, 
perhaps to red.


8. Hold down Shift and drag on the Stage to create a perfect 
circle. Make it about the same size as the first oval and be 
sure the two shapes do not touch or overlap (Figure 8).


Note: If you make a mistake or don’t like what you’ve 
drawn, press Ctrl+Z (Windows) or Command+Z (Mac 
OS) to undo your drawing and start over.


9. Use the Selection tool to click the outline (stroke) of the 
top circle.


Only the outer stroke is selected.


10. Click the center (fill) of the top circle to select it.


Now only the fill is selected.


11. Double-click the fill of the top circle. 


The entire object (stroke and fill) is selected.


Note: If you double-click the stroke, only the stroke is 
selected. To select both the stroke and fill, you must 
double-click the fill.


12. With the top circle selected, drag it to the top portion of 
the bottom circle (Figure 9). 


13. Click away from the shapes to deselect them and then 
click once in the center of the top circle to select only its 
fill.


14. Press the Delete key.


Because you are drawing in merge mode, the selected fill 
disappears along with everything below it (Figure 10).


Next you draw in Object Drawing mode.


Figure 8 Two shapes with different fills


Figure 9 Drag to overlap the shapes


Figure 10 Merged shapes

How to draw and create shapes © 2012 Adobe Systems Incorporated







Adobe Flash Professional CS6 Project 5 guide

To draw in Object Drawing mode:


1. Select the Oval tool and then select the Object Drawing 
modifier in the options section at the bottom of the Tools 
panel (Figure 6).


2. Change the stroke color to light blue and the fill color to 
black. Change the Stroke Height value to 10.


3. Anywhere on the Stage, Shift-drag to draw a small circle 
in Object Drawing mode (Figure 11).


In Object Drawing mode, the shape’s stroke and fill are 
grouped as one object and share the same selection box. 


4. Use the Selection tool to select the circle you just drew, 
and in the Properties panel, change the Width (W) and 
Height (H) values to approximately 25 (Figure 12).


Note: You can click the Lock Width And Height Values 
Together option to constrain or unconstrain the height 
and width of the shape (Figure 12). 


5. With the small blue and black circle still selected, 
select Modify  > Convert to Symbol.


The Convert To Symbol dialog box appears (Figure 13).


6. Type blue_eye for Name, choose Graphic as the symbol 
Type, and click OK.


7. Open the Library panel, and drag another instance of the 
eye symbol to the Stage.


8. Use the Selection tool to drag both instances of the eye 
symbol into the empty space in the top circle shape 
(Figure 14).


You can place Object Drawings or symbols over other 
shapes without affecting the underlying shape.


One you place a symbol on the Stage, you can swap it for 
another symbol in the library. You do that next.


Figure 11 Small circle created in Object Drawing 
mode


Figure 12 Properties panel, Position And Size


Figure 13 Convert To Symbol dialog box


Figure 14 Shapes converted to symbols


Lock Width And Height Value 
Together option
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To swap symbol instances:


1. Create another small eye shape, only this time make the 
stroke color green. 


2. Convert the green eye shape to a new graphic symbol 
named green_eye.


Now you can create some characters with blue eyes and 
others with green eyes.


3. Use the Selection tool to select one of the blue_eye 
symbols on the Stage. 


4. In the Properties panel, click Swap (Figure 15).


The Swap Symbol dialog box appears (Figure 16).


5. Select the green_eye symbol in the Swap Symbol dialog 
box and click OK.


You have swapped the symbol on the Stage. Your 
character has one green eye and one blue eye 
(Figure 17).


6. Swap the other eye with a green eye so they match.


Next you use PolyStar tool to create a nose.


Figure 15 Properties panel, Swap button


Figure 16 Swap Symbol dialog box


Figure 17 Swapped symbols on the Stage
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To draw polygons and stars:


1. Select > Edit > Deselect All to make sure nothing is 
selected on the Stage.


2. Select the PolyStar tool in the Tools panel.


Note: The PolyStar tool shares the same space in the 
Tools panel as the Rectangle and Oval tools.


3. Open the Properties panel and change the fill color to 
black and the stroke color to None. 


Note: To set a stroke or fill color to None, click the color 
swatch in the Properties panel or in the Tools panel to 
open the color palette and click the None option 
(Figure 18). 


4. In the Tool Settings section of the Properties panel, click 
Options.


The Tool Settings dialog box appears (Figure 19). You 
can create polygons or stars.


5. In the Style menu, choose Polygon. Set the number of 
sides to 3 (to create a triangle), and click OK.


6. Drag to draw a triangle with one vertex pointing down 
(Figure 20).


7. In the Tools panel, select the Free Transform tool.


Free Transform selection handles appear around the 
selected shape (Figure 21).


8. Position the pointer over the lower-right selection handle 
of the triangle shape, and drag inward to reduce the size 
of the shape (Figure 21).


Note: You can hold down Shift as you drag to constrain 
the proportions of the shape. You can also resize the 
shape by entering Width (W) and Height (H) values in 
the Properties panel.


9. Use the Selection tool to select and drag the triangle 
below the eyes in your drawing (Figure 22).


Next you use the Line tool to create a mouth.


Figure 18 Stroke color palette


Figure 19  Tool Settings dialog box


Figure 20  Polygon shape


Figure 21  Free Transform selection


Figure 22  Position the triangle to create a nose


None
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To draw paths by using the Line, Pencil, and Brush tools:


1. Select the Line tool in the Tools panel.


2. In the Properties panel, select a stroke color and change 
the stroke height to 4.


3. Drag to draw a horizontal line below the triangle you just 
created (Figure 23).


4. Use the Selection tool to click an empty area of the Stage 
to deselect the line without selecting another shape.


5. Position the pointer along the bottom edge of the line and 
drag downward to modify the line (Figure 24).


6. Select the Brush tool in the Tools panel.


Notice the stroke options are disabled for the Brush tool 
in the Properties panel.


7. Select a fill color for the Brush tool in the Properties 
panel.


You can set painting options for the brush in the options 
section of the Tools panel (Figure 25).


• Object Drawing Mode: Toggle Object Drawing 
Mode on or off. 


• Lock Fill: When you select the Lock Fill modifier 
with the Brush or Paint Bucket tool and paint with 
the tool, the bitmap or gradient fill extends across the 
objects you paint on the Stage. 


• Brush Mode: Select from five painting modes.


• Paint Normal: Paints over lines and fills on the 
same layer.


• Paint Fills: Paints fills and empty areas, leaving 
lines unaffected.


• Paint Behind: Paints in blank areas of the Stage 
on the same layer, leaving other lines and fills 
unaffected.


• Paint Selection: Applies a new fill to the 
selection when you select a fill in the Fill Color 
control or the Fill box in the Properties panel, 
the same as selecting a filled area and applying a 
new fill.


• Paint Inside: Paints the fill in which you start a 
brush stroke and never paints lines. If you start 
painting in an empty area, the fill doesn’t affect 
any existing filled area.


• Brush Size and Brush Shape: Select a size and shape 
for the brush.


Figure 23  Position the triangle to create a mouth


Figure 24  Reshape the line to make a smile


Figure 25  Brush modifiers in the Tools panel


Lock Fill


Brush Size


Brush Mode


Brush Shape


Object Drawing Mode

How to draw and create shapes © 2012 Adobe Systems Incorporated







Adobe Flash Professional CS6 Project 5 guide

8. Experiment with the Brush tool by making several brush 
strokes on the Stage. 


In this example, we used the Brush to make antennae for 
the bug-like character who has been taking shape 
throughout this activity (Figure 26).


9. Select the Pencil tool in the Tools panel.


Notice the fill color option is disabled for the Pencil tool 
in the Properties panel.


10. Select a stroke color and set a stroke height for the Pencil.


Flash offers three pencil drawing modes, available in the 
options section of the Tools panel.


• Straighten: Draws straight line segments.


• Smooth: Draws curvy lines with smooth curves.


• Ink: Draws freehand lines with no modification 
applied.


11. Use the Pencil tool to put some final touches on your 
drawing (Figure 27). 


Note: Because you are still in Object Drawing mode, 
overlapping your existing shapes will not affect them.


Now you’ve created your entire character and have 
several shapes arranged on the stage.


Figure 26  Brush strokes used to create antennae


Figure 27  Smooth pencil lines used to create arms 
and legs
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Creating decorative fills by using the Deco tool
Designing the settings in a Flash movie or the virtual world in a game can be similar to designing sets or locations in 
a live-action movie. You don’t need to be a fine artist to include stylish backgrounds in Flash. By using the Deco 
(decorative) tool with its various drawing effects, you can turn symbols into complex geometric patterns with creative 
artistic fills.


Some Deco tool drawing effects, such as the Tree Brush or Lightning Brush, do not use symbols. Other Deco tool 
drawing effects, such as Grid Fills, require that you select a symbol in the document library to use as the artwork for 
the decorative fill.


The Symmetry effect


Use the Deco tool Symmetry effect to arrange symbols symmetrically around a central point.


To apply the Symmetry effect:


1. Open a Flash document that contains symbols or open a 
new blank Flash document (ActionScript 3.0) and use the 
shape tools to create a few new graphic symbols. 


Note: Smaller symbols work best when you are creating 
decorative fills. 


2. Select the Deco tool in the Tools panel.


Properties for the Deco tool appear in the Properties 
panel (Figure 28).


3. Select Symmetry Brush from the Drawing Effect menu in 
the Properties panel (Figure 29).


4. In the Properties panel, click the Edit button.


The Select Symbol dialog box appears. It shows the 
symbols in the library (Figure 30).


You can use any movie clip or graphic symbol in the 
library with the Symmetry Brush effect. This symbol-
based effect gives you a great deal of creative control 
over artwork you create in Flash.


5. Select one of the symbols you created and click OK.


Figure 28 Properties panel, Deco tool


Figure 29 Drawing Effect menu


Figure 30 Select Symbol dialog box


Deco tool
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6. In the Properties panel, choose one of the options from 
the Advanced Options menu (Figure 31). 


• Reflect Across Line: Flips the shapes an equal 
distance apart across an invisible line that you 
specify.


• Reflect Across Point: Places two shapes an equal 
distance apart around a fixed point that you specify.


• Rotate Around: Rotates the shapes in the symmetry 
around a fixed point that you designate. The default 
reference point is the center point of the symmetry. 
To rotate the object around its center point, drag in a 
circular motion.


• Grid Translation: Creates a grid by using the shapes 
in the Symmetry effect you are drawing. Each click 
of the Deco tool on the Stage creates a grid of 
shapes. Adjust the height and width of the shapes by 
using the x and y coordinates defined by the 
Symmetry Brush handles.


7. Click the Stage where you want the Symmetry Brush 
artwork to appear (Figure 32).


8. Use the Symmetry Brush handles to adjust the size of the 
symmetry and the number of symbol instances. 


9. Select Edit > Select All and press Delete. 


You will start the next activity with an empty Stage.


Figure 31 Advanced Options menu


Figure 32 Placing symbols with the Symmetry 
Brush
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The Grid Fill effect


You can use the Grid Fill effect to fill the Stage, a symbol, or a closed region with a symbol from the library. After 
you draw a Grid Fill on the Stage, if you move or resize the filled symbol, the Grid Fill moves or resizes accordingly.


The Grid Fill effect creates a repeating tiled background or an area or shape with a custom pattern. The default 
symbol for the Grid Fill effect is a 25-by-25-pixel black rectangular shape with no stroke.


To apply the Grid Fill effect:


1. Select the Deco tool, and select Grid Fill from the 
Drawing Effect menu in the Properties panel (Figure 33).


You can use any movie clip or graphic symbol in the 
library with the Grid Fill effect. You can use the same 
symbol for all tiles or combine up to four symbols. The 
default shape is a small black square. You an change the 
color used for the default shape by clicking the color 
swatch for each tile and picking a new color.


2. In the Properties panel, click the Tile 1 Edit button to 
select a symbol from the library.


The Select Symbol dialog box appears, listing symbols in 
the document library.


3. Select a symbol in the Select Symbol dialog box and 
click OK.


You can use the following advanced options in the 
Properties panel to specify the horizontal and vertical 
spacing and the scale of the fill shape.


• Horizontal Spacing: Specifies the horizontal 
distance in pixels between shapes used in the Grid 
Fill.


• Vertical Spacing: Specifies the vertical distance in 
pixels between shapes used in the Grid Fill.


• Pattern Scale: Enlarges or shrinks an object 
horizontally (along the x axis) and vertically (along 
the y axis).


After you apply the Grid Fill effect, you cannot change 
the advanced options to alter the fill pattern.


4. Click the Stage or click within a shape or symbol where 
you want the Grid Fill pattern to appear.


The pattern fills the area (Figure 34). If you want the 
entire grid filled with the same symbol, select that 
symbol for all four tiles in the Properties panel.


5. Select Edit > Select All and press Delete. 


You will start the next activity with an empty Stage.


Figure 33 Deco tool Grid Fill properties


Figure 34 Grid Fill pattern
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The 3D Brush effect


You can use the 3D Brush effect to spray symbols so they appear to be in front of each other. After you draw a 3D 
Brush on the Stage, if you resize or otherwise change the filled symbol, the 3D Brush changes accordingly.


To apply the 3D Brush effect:


1. Select the Deco tool, and select 3D Brush from the 
Drawing Effect menu in the Properties panel (Figure 35).


Similar to the Grid Fill effect, you can choose the 
symbols or default shapes to use when drawing.


2. In the Properties panel, click the Object 1 Edit button to 
select a symbol from the library.


The Select Symbol dialog box appears.


You can use any movie clip or graphic symbol in the 
library with the 3D Brush effect.


3. Select a symbol in the Select Symbol dialog box and 
click OK.


You can use the following advanced options in the 
Properties panel.


• Max Objects: Specifies the total number of shapes 
used in the 3D Brush.


• Spray Area: Specifies the area covered in each spray 
of the 3D Brush.


• Perspective: Specifies that objects appear in front of 
each other.


• Distance Scale: Specifies how far in front of each 
other objects appear to be.


• Random Scale Range: Specifies the degree to which 
objects vary in size.


• Random Rotation Range: Specifies the degree to 
which objects are rotated.


Note: After you apply the 3D Brush effect, you cannot 
change the advanced options to alter the fill pattern.


4. Drag the pointer across the Stage to draw with the 3D 
Brush (Figure 36).


As you drag, Flash paints a pattern using the objects you 
selected in the Properties panel. 


5. Select Edit > Select All and press Delete. 


You will start the next activity with an empty Stage.


Figure 35 Deco tool 3D Brush properties 


Figure 36 Placing symbols with the 3D Brush 
effect
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The Vine Fill effect


You can use the Vine Fill effect to fill the Stage, a symbol, or a closed region with a vine-like pattern. You can 
substitute your own artwork for the leaves and flowers by selecting symbols from the library. The resulting pattern is 
contained in a movie clip that itself contains the symbols that make up the pattern.


To apply the Vine Fill effect:


1. Select the Deco tool, and select Vine Fill from the 
Drawing Effect menu in the Properties panel (Figure 37).


By default, the Vine Fill effect uses a leaf and flower as 
the artwork for the fill. You can change these to custom 
symbols by clicking the Edit buttons and selecting 
symbols in the document library.


You can set the following Advanced Options in the 
Properties panel:


• Branch Angle: Specifies the angle of the branch 
pattern.


• Branch Color: The color box to the right of Branch 
Angle. Specifies the color for the branch.


• Pattern Scale: Adjusts an object by enlarging or 
reducing it both horizontally (along the x axis), and 
vertically (along the y axis).


• Segment Length: Specifies the length of the 
segments between leaf and flower nodes.


• Animate Pattern: Specifies that each iteration of the 
effect is drawn to a new frame in the Timeline. This 
option creates a frame-by-frame animated sequence 
of the flower pattern as it is drawn.


• Frame Step: Specifies how many frames to span per 
second of the effect being drawn.


Note: After you apply the Vine Fill effect, you cannot 
change the advanced options in the Properties panel to 
alter the fill pattern.


2. Click the Stage or click within the shape or symbol where 
you want the Vine Fill pattern to appear.


The pattern fills the area (Figure 38).


3. Select Edit > Select All and press Delete. 


You will start the next activity with an empty Stage.


Figure 37 Deco tool Vine Fill properties


Figure 38 Vine Fill pattern
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Converting text and bitmap images to vector shapes
In addition to drawing vector shapes in Flash, you can import bitmap graphics, such as photographs, and convert 
them to vector artwork. Converting large bitmaps to vectors can significantly reduce the file size of your document.


Flash provides two ways to convert a bitmap image to a vector shape: Break Apart converts the entire bitmap into a 
single shape. Trace Bitmap analyzes the colors in the bitmap image and creates a collection of merged shapes.


Using the Break Apart command


The Break Apart command appears in the Modify menu.


You can break apart bitmaps and text to create vector shapes. When you break apart text, you can use the resulting 
shape in an animation that morphs the shape into another shape. 


When objects or symbols are grouped, using Break Apart ungroups them into separate objects. You may need to use 
Break Apart several times to completely ungroup objects before you can convert them into vector drawings. 


To break apart text:


1. Use the Text tool to create some text. Use the Selection 
tool to select the text.


2. Select Modify > Break Apart.


The text is ungrouped into separate letters (Figure 39). 
You can now select and modify each letter as a separate 
object, but they are still not vector shapes, as shown in 
the Properties panel (Figure 41). You need to break them 
apart a second time to convert them to vector shapes.


3. Select Modify > Break Apart again.


Flash converts the selected letters into several shapes 
(Figure 40), as shown at the top of the Properties panel 
(Figure 41). 


4. Select Edit > Select All and press Delete. 


You will start the next activity with an empty Stage.


Figure 39 Text broken into separate objects


Figure 40 Letter objects broken into shapes


Figure 41 Properties panel, shape properties
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To break apart a bitmap image:


1. Select the bitmap you want to break apart.


Note: To import a bitmap image, you can choose File > 
Import > Import To Stage, select the file to import, and 
click Open. 


2. Select Modify > Break Apart.


Flash converts the bitmap image to a shape, as shown at 
the top of the Properties panel (Figure 42).


The selected image is filled with a consistent pattern to 
show it’s selected as a single shape object (Figure 43).


3. Click away from the shape or select Edit > Deselect All 
to deselect the shape.


4. Click the shape again to select it.


The entire shape is selected as a single object.


5. Select Modify > Combine Objects > Union.


The shape is grouped as a single drawing object, as 
shown in the Properties panel (Figure 44). You can now 
apply stroke and fill properties.


6. Select Edit > Select All and press Delete.


Figure 42 Properties panel, shape properties


Figure 43 Selected shape


Figure 44 Properties panel, drawing object
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Using Trace Bitmap


In this activity, you trace the same bitmap you broke apart in the previous activity to see the difference between Break 
Apart and Trace Bitmap.


To trace a bitmap image:


1. Select the bitmap you want to break apart.


Note: If you’ve already imported the image, you can drag 
a fresh copy of the image from the Library panel to the 
Stage. 


2. Select Modify > Bitmap > Trace Bitmap.


The Trace Bitmap dialog box appears (Figure 45). 
Tracing will occur based on colors and lines in the image. 
You can adjust how sensitive Flash is when analyzing the 
bitmap. 


3. Click OK to accept the default Trace Bitmap settings.


Flash traces the bitmap and creates an artistic rendering 
of the image. The resulting object is a vector shape, as 
shown in the Properties panel.


4. Click away from the image or select Edit > Deselect All 
to deselect the shape.


5. Click in the image again.


Only a portion of the image is selected (Figure 46). 
When you trace a bitmap, the resulting vector drawing is 
a collection of merged shapes.


Figure 45 Trace Bitmap dialog box


Figure 46 Traced bitmap converted to shapes
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Using adaptive scaling to produce a Flash document for multiple screens
It used to be that one of the most time-consuming tasks of designing content in Flash was to size and optimize your 
movie for multiple screen sizes. With Adobe Flash Professional CS6, you can now choose to scale the contents of 
your document when you change the Stage size. All objects on the Stage, including symbols, shapes, paths, motion 
paths, and bitmap images across all scenes, are scaled together.


To scale a document by using adaptive scaling:


1. Select Modify > Document.


The Document Settings dialog box appears (Figure 47). 


When you change the Dimensions settings of the 
document, the Scale Content With Stage option becomes 
active. This option activates adaptive scaling.


2. To change the document dimensions, select Scale 
Content With Stage, and click OK.


The content resizes along with the Stage.


3. Select Edit > Undo Modify FLA Document to return the 
Stage and content to their original dimensions.


Figure 47 Document Settings dialog box
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How to make Flash content accessible
You can make Adobe Flash Professional CS6 content accessible to people with disabilities. Here are some steps you 
can take to make your web content more accessible to those with visual, motor, or hearing impairments:


• Expose the information to screen readers. People with visual impairments use screen-reader software that 
provides a spoken description of what is on the screen. In Flash movies, you can decide which objects in your 
movie will be read by screen readers. 


• Make text or images resizable. Some visitors might have difficulty reading small text or seeing small graphics. 
Allow users to zoom in on these elements, taking advantage of scalable vector graphics in SWF files.


• Provide audio narration. Consider providing an audio narration for visitors without a screen reader, or where 
screen readers might not work, such as with video content.


• Provide captions for audio narrations. Some visitors might not be able to hear an audio narration for your site or 
a video. Consider providing captions for these visitors.


• Do not rely solely on color to communicate information. Many visitors might be color blind. If you rely on color 
to communicate information, provide text or speech equivalents.


Historically, many online presentations (such as videos) provide alternative ways for visually impaired visitors to 
access the content, for instance, a textual description of a video. However, Flash provides textual information directly 
to the screen reader. Although this usually means you need to make additional settings or ActionScript in a FLA file, 
you do not have to create a completely separate version.


The following objects are accessible by default in Flash movies and are included in the information Flash Player 
provides to screen-reader software:


• Text


• Input text fields


• Buttons


• Movie clips


• Entire movies


Turning accessibility on and off
By default, your Flash movie is accessible to screen readers. Static text is automatically read. Other objects, such as 
buttons and movie clips, are announced by using a label that is applied to the object by Flash. Default labels are 
general terms such as button, but you can provide more specific terms.


Using the Accessibility panel, you can turn accessibility on or off for the entire movie or for selected objects. The 
following are some best practices when making objects accessible:


• Provide your own name and description for each accessible object except text. (Because text is read by screen 
readers, you don’t need to provide descriptions.)


• Add descriptive labels to buttons, such as next or previous.


• Add labels and descriptions to movie clips if they depict an animation that is not explained in text on the page.


• Turn accessibility off for an object, such as an animation, that does not add new information to the explanatory 
text on a page. In particular, if you use audio, turn off accessibility for any text that duplicates the audio content.


• Try to let visitors control their movement through a website by using buttons, such as next or previous.


• Make sure visitors can move through your site by using the keyboard.
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To turn accessibility on and off:


1. Select Window > Other Panels > Accessibility.


The Accessibility panel appears (Figure 1).


By default, the entire movie is accessible, and automatic 
labeling is turned on.


2. Deselect the Make Movie Accessible option to turn 
accessibility off. Select that option again to turn 
accessibility on.


Figure 1 Accessibility panel


Flash sites can have complex layouts, structure, and navigation. This complexity can make navigation difficult for 
visitors with screen readers. A good idea is to provide a general description of the entire website to help orient screen-
reader users to the structure of the site. You can add such a description through the Accessibility panel.


To add a description of the Flash website:


1. Select Edit > Deselect All to make sure nothing on the 
Stage is selected and ensure that the Accessibility panel is 
setting properties for the entire movie.


2. In the Description text box, enter a description of the 
movie (Figure 2).


Figure 2 Website description in Accessibility panel
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To add a name and description to an object:


1. On the Stage, click a button or movie clip.


The Accessibility panel changes to show the options for 
the selected object.


2. Enter a name and description for the object (Figure 3).


Screen readers will read the entered information when the 
playhead reaches the frame in which the object first 
appears.


Figure 3 Name and description of object


To turn accessibility off for an object:


1. On the Stage, click an object that does not add 
information to the page, such as an animation.


It is especially important to turn off accessibility for 
looping objects so screen readers do not read the same 
information over and over again.


2. In the Accessibility panel, deselect Make Object 
Accessible.


Screen readers will skip the object.


Often there are situations when a movie clip contains other movie clips that do not require separate text descriptions. 
In these cases, create a description for the parent movie clip and turn off Make Child Objects Accessible (Figure 2) 
so that only necessary information is sent to the screen reader.
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Controlling the tab order of Flash content
To maintain accessibility for visitors with motor impairments, it is important to provide keyboard access to all objects 
in your Flash website. You can do so by setting a tab index for each object. The tab index determines the order in 
which visitors move through elements of your site--buttons, links, and other interactive content--when they press the 
Tab key.


To set tab order:


1. Make sure the Accessibility panel is open (select 
Window > Other Panels > Accessibility).


2. Select the object or text where you want visitors to begin.


3. In the Tab Index box, enter 1 (Figure 4).


4. Repeat steps 2 and 3 for all other objects on the Stage, 
incrementing the tab index number for each object.


5. Select View > Show Tab Order.


The tab index number you entered appears next to the 
instance on the Stage.


Note: Tab index order also controls the order in which 
many screen readers read Flash content. However, to 
control reading order for all screen readers, you need to 
set a Tab index through ActionScript. See Flash Help for 
more details.


Figure 4 Accessibility panel


Testing Flash content for accessibility
As with other content, you should test your Flash content for accessibility before publishing it.


Here are some recommendations for accessibility testing:


• Download several screen readers and test your movie by playing it in a browser with the screen reader enabled. 
Make sure text read by the screen reader is not duplicated by audio you provide.


• Verify that visitors can navigate your content effectively when using only the keyboard. You should test 
keyboard navigation both with a screen reader and without a screen reader, because keyboard access can differ 
when a screen reader is present.


• Test the movie with actual visitors. If it is important that your content is accessible, have it tested by people with 
disabilities.


• Check tab index number by looking at the numbers that appear next to the instances on the Stage.
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How to check files in and out
If you’re working in a collaborative environment, you can check files in and out from local and remote servers. If 
you’re the only person working on the remote server, you can use the Put and Get commands without checking files 
in or out.


Checking out a file is the equivalent of declaring “I’m working on this file now—don’t touch it!” When a file is 
checked out, the name of the person who checked out the file is displayed in the Files panel, along with a red check 
mark (if a team member checked out the file) or green check mark (if you checked out the file) next to the file’s icon.


Checking in a file makes the file available for other team members to check out and edit. When you check in a file 
after editing it, your local version becomes read-only and a lock symbol appears beside the file in the Files panel to 
prevent you from making changes to the file.


Dreamweaver does not make checked-out files read-only on the remote server. If you transfer files with an 
application other than Dreamweaver, you can overwrite checked-out files. However, in applications other than 
Dreamweaver, the LCK file is visible next to the checked-out file in the file hierarchy to help prevent such accidents.


Setting up a Check In/Check Out system on a remote server
Check with your instructor or your site administrator to to see if a site has already been set up. If so, you may be able 
to skip this section and proceed directly to the next section, “Checking out files.”


To set up a Check In/Check Out system on a remote server:


1. Start Dreamweaver.


2. Select Site > Manage Sites.


3. Select a site and click Edit.


4. In the Site Setup dialog box, select the Servers category 
and select an existing server and click the Edit Existing 
Server button (Figure 1).


The Basic view of the Server Setup dialog box opens.


5. Click the Advanced button. 


The Advanced view of the Server Setup dialog box opens 
(Figure 2).


6. Select Enable File Check-out if you are working in a 
team environment (or working alone but from several 
different machines).


This option is useful to let others know that you checked 
out a file for editing, or to alert yourself that you may 
have left a more recent version of a file on another 
machine. 


If you do not see Check In/Out options, it means that you 
have not set up a remote server.


7. Select the Check Out Files When Opening option if you 
want to automatically check out files when you double-
click to open them from the Files panel. 


Using File > Open to open a file doesn’t check the file 
out, even when this option is selected.


Figure 1 Site Setup dialog box


Figure 2 Server Setup dialog box, Advanced view


Edit Existing Server
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8. Set the remaining options:


Check-out Name The check-out name appears in the Files 
panel alongside any files that are checked out; this 
enables team members to communicate with the right 
person if a file they need is checked out.


Note: If you work alone from several different machines, 
use a different check-out name on each machine (for 
example, AmyR-HomeMac and AmyR-SchoolPC), so 
you’ll know where the latest version of the file is if you 
forget to check it in.


Email Address If you enter an e-mail address, then when 
you check out a file, your name appears in the Files panel 
as a link (blue and underlined) next to that file. If a team 
member clicks the link, their default e-mail program 
opens a new message with the user’s e-mail address and a 
subject that corresponds to the file and site name.


9. Click Save to close the Advanced view of the Server 
Setup dialog box.


10. Click Save to close the Site Setup dialog box.


11. Click Done to close the Manage Sites dialog box.


Checking out files
After the Check In/Check Out system is set up, you can check in and check out files on a remote server by using the 
Files panel (Figure 3).


Figure 3 Dreamweaver Files panel, expanded view with Remote and Local panes


Expand/Collapse Connect/Disconnect to Remote Host Check Out File(s)


Check In File(s)Refresh
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To check out files on a remote server:


1. Start Dreamweaver. Select your local site in the Files 
panel.


2. Click the Expand/Collapse button in the Files panel 
(Figure 4).


The Files panel expands to show both local and remote 
sites in separate panes (Figure 3).


3. Click the Connects To Remote Host button.


You are now connected to your remote site. The remote 
and local site panes are side-by-side. You can also toggle 
between these two windows when the Files panel is 
collapsed.


4. Select one or more files in the Remote Site pane and click 
the Check Out File(s) button at the top of the Files panel.


The Dependent Files dialog box appears (Figure 5).


Dependent files are files that are used or displayed in one 
of your selected files. They include any images or movies 
displayed on the page, as well as external style sheets 
linked to the page.


5. To download dependent files along with the selected 
files, click Yes. Otherwise, click No.


Dreamweaver displays a check mark beside each file you 
check out, along with your name.


Figure 4 Files panel


Figure 5 Dependent Files dialog box


Checking in files
You can edit checked-out files on your workstation. When you finish working on checked-out files, remember to 
check them back in so other team members can access them. 


To check in files to a remote server:


1. In the Files panel, select your local site from the Site 
menu.


Expand/Collapse 
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2. Select one or more checked-out or new files in the Local 
Files pane of the Files panel.


A green check mark next to a file name indicates that the 
file is currently checked out by you. A red check mark 
indicates that the file is checked out by another team 
member. You can click the Refresh button to find out the 
current status of files on the remote site (Figure 6).


3. Click the Check In button at the top of the Files panel 
(Figure 5).


The Dependent Files dialog box appears (Figure 7).


4. To check in dependent files along with the selected files, 
click Yes. Otherwise, click No. 


In the expanded view of the Files panel, Dreamweaver 
displays a lock icon in the Local Files pane next to each 
file you check in, and it clears the check mark that was 
displayed in the Remote Site pane when you checked out 
the file (Figure 8).


Provided your site administrator has enabled it, you can 
view or print any locked file in the Local Files pane. The 
lock icon reminds you that you cannot edit the file and 
save it, however, unless you first check it out.


5. Click the Expand/Collapse button to collapse the Files 
panel.


Figure 6 Checking in files 


Figure 7 Dependent Files dialog box


Figure 8 Checked in file


Undoing check out
Sometimes, after you check a file out and make changes to it, you may want to discard these changes. The Undo 
Check Out command enables you to check a file in without saving changes.


To undo check out:


1. In the Files panel, select your local site from the Site 
menu.


2. Select one or more checked-out files in the Local Files 
pane of the Files panel.


3. Right-click (Windows) or Control-click (Mac OS) and 
select Undo Check Out in the context menu.


Refresh
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Using Subversion
Many web designers and developers use software called version control software to collaborate. Version control 
software saves a copy of each file every time a user makes a change to the file. Dreamweaver integrates with a 
popular program called Subversion. Once your site administrator has set up a Subversion repository in your 
environment, you can connect your site to Subversion. For more information on configuring a site to work with 
Subversion, see Dreamweaver Help. 


Note: Many users find it helpful to use a third party diff tool that allows you to compare different versions of a file. To 
find such a program, use a web search engine such as Google to search for “diff tool.”


Getting the latest versions of files


The first time you set up a site with Subversion connected, you need to make a copy the repository files to your local 
computer.


To copy repository files to your computer:


1. Make sure that your administrator has set up an SVN 
connection.


2. Make sure the Files panel is open and Local View is 
selected. 


3. Right-click (Windows) or Control-click (Mac OS) the 
root folder in the Files panel and choose Version Control 
> Get Latest Versions from the context menu (Figure 9).


All files are copied to your local computer.


At any point, you can repeat these steps on any folder or 
file to get the latest file version of a file or file(s).


Figure 9 Files panel context menu
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Checking in files with Subversion


With Subversion enabled, you check in files just as you would normally. However, once you check in files, a dialog 
box opens asking you to commit the file to Subversion.


To check in files with Subversion:


1. Select a checked out file in the Files panel.


The CheckIn dialog box opens (Figure 10).


2. Enter a note on the version, so that other users will know 
what edits you made.


3. Click Commit.


The file is checked in and added to the repository.


Figure 10 CheckIn dialog box


Adding files to the repository


A blue plus sign on a file in the Files panel denotes a file that does not yet exist in the SVN repository.


To add a new file to the repository:


1. Make sure that your administrator has set up an SVN 
connection.


2. Make sure the Files panel is open.


3. Select the file you want to add to the repository and click 
the Check In File(s) button (Figure 11).


4. Make sure that the file is selected for Commit in the 
Commit dialog box and click OK.


Figure 11 File not added to repository


File not added to repository


Check In File(s)
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Viewing versions of files


Each time you or another user checks in a file, Suversion saves a copy of the file, retaining all previously saved 
versions. At any point, you or another user can revert a file to a previous version.


To view the version history for a file:


1. Make sure that your administrator has set up an SVN 
connection.


2. Make sure the Files panel is open and Local View is 
selected. 


3. Right-click (Windows) or Control-click (Mac OS) the 
root folder in the Files panel and choose Version Control 
> Show Revisions from the context menu.


The Revision History dialog box opens (Figure 12).


Figure 12 Revision History dialog box


To revert to an earlier version:


1. View a file’s version history.


2. Click a version to select it.


3. Click the Promote To Current button.


A dialog box opens asking if you want the selected 
revision to become the new head revision.


4. Click Yes.


The selected revision becomes the new current revision 
and a dialog box opens asking if you want to load a file 
from outside Dreamweaver.


Note: Because Subversion is not part of Dreamweaver, 
Dreamweaver checks to make sure the file change was 
intended.


Note: If you want to switch back to the original version, 
simply select it in the Revision History dialog box.
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How to get started with ActionScript
ActionScript 3.0 is the scripting language of Adobe Flash Professional CS6. You can use ActionScript to add 
complex interactivity, playback control, and data display to your application. For example, you might want to animate 
a picture of a boy walking. By adding ActionScript, you could have the animated boy follow the pointer around the 
screen, stopping whenever he collides with a piece of animated furniture.


ActionScript is an object-oriented programming language. Object-oriented programming is a way to organize the 
code in a program, using code to define objects and then sending messages back and forth between those objects.


You don’t have to be a programmer to take advantage of ActionScript (see “Using Script Assist mode” later in this 
guide). But the following concepts will help:


• Class: The code that defines an object. This code consists of properties, methods, and events. Think of the 
blueprint of a house: you can’t live in the blueprint, but you need it so you can build the house. You use 
classes to create objects.


• Object: An instance of a class. When you instantiate an object (create an instance of it), you declare what 
class it is created from and set its properties. You can create as many objects as you want from a single 
class—if you have a bicycle class, you can create many bicycle objects, each with its own properties (one 
bicycle might be red while another might be green).


• Property: One of the pieces of data bundled together in an object. A property helps define an object—it 
provides the object’s characteristics. A song object might have properties named melody and title. You set 
the properties of an object when you create the object, but you can change them later as needed. A property 
is a variable that belongs to an object.


• Variable: A name that represents a value in the computer’s memory. As you write code, you write the 
variable’s name as a placeholder for the value. This allows you to write code even if you don’t know all the 
possible values a user might provide. If you create a variable firstName, you can tell your program to 
display the user’s first name without knowing in advance what the user’s first name is.


• Method: An action that can be performed by an object. For example, the class horse might have a method 
called gallop(). When the method gallop() is called, it shows an animation of the horse galloping from one 
point to another.


• Function: A block of code that carries out specific tasks and can be reused in your program. For example, 
you might create a function called checkEmail() to verify that a user has provided text that can actually be 
used as an e-mail address. If you ever want to update the function, you only have to do it once instead of in 
each place where e-mail addresses must be validated. You can also think of a method as a function attached 
to an object.


• Event: Something that happens in a Flash movie that ActionScript is aware of and can respond to. Many 
events are related to user interaction—for example, a user clicking a button or pressing a key on the 
keyboard. The technique for specifying certain actions that should be performed in response to particular 
events is known as event handling.


If you’ve worked with symbols in Flash, you’re already used to working with objects. Imagine you’ve defined a 
movie clip symbol—say a drawing of a rectangle—and you’ve placed a copy of it on the Stage. That movie clip 
symbol is also an object in ActionScript; it’s an instance of the MovieClip class. The main timeline of a Flash movie 
also belongs to the MovieClip class.


You can modify various characteristics of any movie clip. When a movie clip is selected, the Properties panel shows 
some of the characteristics you can change, such as its X coordinate or its width. Or you can make color adjustments 
such as changing the clip’s alpha (transparency). Other Flash tools let you make more changes, such as using the Free 
Transform tool to rotate the rectangle. Any way you can modify a movie clip symbol in the Flash authoring 
environment you can also do in ActionScript. In ActionScript, you use the methods of the MovieClip class to 
manipulate or change the properties of your movie clip.
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For more about object-oriented programming, see Programming ActionScript 3.0, “Object-oriented Programming in 
ActionScript” (in Flash, select Help > Flash Help).


Using Script Assist mode
You can add ActionScript in the authoring environment by using the Actions panel (Figure 1). The Script Assist 
mode in the Actions panel can simplify the coding process.


Figure 1 Actions panel in Script Assist mode


In Script Assist mode, you can add ActionScript to your Flash document without writing the code yourself. You 
select actions from the Actions toolbox and set the options for each action in the parameters area. You must know a 
little about what functions to use to accomplish specific tasks, but you don’t have to learn syntax (the grammar of 
ActionScript). Many designers and nonprogrammers use this mode.


One of the first things to learn is how to stop your movie at a certain spot. You will also learn how to send the 
playhead to a particular frame in the movie.


Actions toolbox


Script navigator


Parameters area


Script Assist 
button


Script pane
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To use ActionScript to stop a movie:


1. Start Flash and open a movie. Create a layer in your 
movie named actions. In the frame that corresponds to 
the end of your movie, insert a new keyframe.


2. If the keyframe is not selected, select it by clicking it.


3. Select Window > Actions to display the Actions panel.


4. If you don’t see the parameters area in the Actions panel, 
click the Script Assist button in the upper-right corner 
(Figure 2).


Classes are organized into packages. You want to add a 
stop() action to a movie clip (in this case, your timeline is 
the movie clip), so you must locate the MovieClip class. 
The MovieClip class is part of the Flash.Display 
package.


5. In the Actions toolbox on the left side of the Actions 
panel, scroll down and click the Flash.Display package to 
display the classes it contains.


6. Scroll down again to find the MovieClip class and click 
to expand it (Figure 3).


7. Click Methods to view the methods available for the 
MovieClip class.


Figure 2 Actions panel


Figure 3 Movie Clip class


Script Assist button
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8. Scroll down to the Stop method. Do one of the following: 


• Double-click the Stop method.


• Drag the Stop method into the Script pane.


Code for applying the Stop method appears in the Script 
pane (Figure 4). The first line (import 
flash.display.MovieClip();) imports the code necessary 
for the MovieClip class. The second line is the Stop 
action itself. The code not_set_yet indicates you need to 
finish the code. You can use Script Assist to do this.


9. Click in the Object field in the parameters area of the 
Actions panel.


The Insert Target Path button is now active. The target 
path helps you locate the object you are trying to control.


10. Click the Insert Target Path button (Figure 4).


The Insert Target Path dialog box appears (Figure 5).


11. Select the Relative option and click Root.


This sets the target path to this.


12. Click OK to close the Insert Target Path dialog box.


The completed script for the Stop method appears in the 
Script pane (Figure 6). This code will cause your movie 
to stop playing at the end of the movie, Frame 20.


Note: In ActionScript, this is used the same way that you 
would refer to yourself as “me” instead of using your full 
name. Remember that the main timeline is an instance of 
the MovieClip class. In Figure 6, Flash uses this to refer 
to the movie clip that Frame 20 belongs to.


13. Close the Actions panel.


Figure 4 Stop method


Figure 5 Insert Target Path dialog box


Figure 6 Stop method applied to frame 20


Insert Target Path button


Frame number
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Event handling
The technique for specifying certain actions that should be performed in response to particular events is known as 
event handling. Event handling consists of three important elements:


• The event source: Which object will trigger the event? For example, which button will be clicked, or which 
Loader object is loading the image?


• The event: What is going to happen, what interaction do you want to respond to? Identifying the event is 
important, because an object can trigger (and listen for) several events.


• The response: What action(s) do you want performed when the event happens?


When an ActionScript program is running, Adobe Flash Player just sits and waits for certain events to happen, and 
when those events happen, the player runs the specific ActionScript code you’ve specified for those events. For the 
program to know what events are important, you must create an event listener. Flash Player executes an event listener 
in response to specific events.


Adding an event listener is a two-step process:


• First, you create a function or class method for Flash Player to execute in response to the event. This function is 
sometimes called the listener function.


• Second, you use the addEventListener() method to connect the listener function with the target of the event. The 
addEventListener() method tells Flash what object to listen to, what event to listen for, and what function to 
execute in response.


To use ActionScript to go to another frame:


1. Create a button users can click to go to a particular frame 
in your movie. Make sure you place the button on the 
Stage (Figure 7).


2. Select the button and use the Properties panel to give the 
button a unique instance name (Figure 8).


3. In the main timeline of your movie, create a layer named 
actions.


4. Create a keyframe in the actions layer that corresponds to 
the keyframe where your button first appears on the 
Stage. Select this keyframe in the actions layer.


Note: If your button doesn’t appear in this frame, Flash 
will generate an error message because you are referring 
to an object that isn’t on the Stage yet.


5. Select Window > Actions to display the Actions panel.


6. If you don’t see the parameters area in the Actions panel, 
click the Script Assist button.


7. In the Actions toolbox on the left side of the Actions 
panel, scroll down and click the Flash.Events package to 
display the classes it contains.


8. Scroll down to the IEventDispatcher class and click it to 
open it.


9. Click Methods to display methods for the 
IEventDispatcher class.


Figure 7 Button instance


Figure 8 Button instance


Instance name
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10. .Double-click the addEventListener method to add it to 
the Script pane (Figure 9).


11. Click in the Object field in the parameters area of the 
Actions panel.


The Insert Target Path button is now active.


12. Click the Insert Target Path button.


The Insert Target Path dialog box appears (Figure 10).


13. Select the Relative option and select the instance name of 
your button. Click OK to close the dialog box.


The event listener is attached to the instance of your 
button (Figure 11). 


Next, you select an event to listen for.


Figure 9 The addEventListener method in the 
Actions toolbox


Figure 10 Insert Target Path dialog box


Figure 11 Event listener code in the Script pane

How to get started with ActionScript © 2012 Adobe Systems Incorporated







Adobe Flash Professional CS6 Project 5 guide

14. In the Actions toolbox on the left side of the panel, select 
the CLICK property from the MouseEvent class 
(Figure 12).


To find the CLICK property, open Flash.Events, open 
MouseEvent, and open Properties.


15. In the Script pane, select the addEventListener() line to 
display the parameters for this method. Then, in the 
parameters area, click in the Type field.


16. In the Actions toolbox, double-click the CLICK property.


Script Assist adds the property to your code as  
MouseEvent.CLICK (Figure 13).


Now your code will listen for a click on the button. To 
tell the event listener how to respond when that click 
occurs, you next create a function.


17. In the parameters area, type a name for your function in 
the Listener field, such as startMovie. You can use any 
name you like, but make sure the name of the function is 
unique and contains no spaces (Figure 14).


The function name appears in the Script pane as you type. 
You have named the function, but you haven’t created it 
yet.


18. In the Actions toolbox, select the function keyword from 
Language Elements.


To find the function keyword, expand Language 
Elements. Then expand Statements, Keywords & 
Directives, and expand Definition Keyword.


19. Double-click the function keyword in the Actions 
toolbox.


The code for creating a function appears in the Script 
pane (Figure 15).


20. In the parameters area of the Script pane, type the name 
of your function in the Name field.


Note: You must type the function name exactly as you 
typed it for the AddEventListener function in Step 17. 
Function names are case-sensitive.


21. In the parameters area of the Script pane, type 
event:MouseEvent in the Parameters field.


In this field, you are naming a variable (event) and 
indicating what type of variable it is (MouseEvent).


Figure 12 CLICK property in the Actions toolbox


Figure 13 CLICK property in the Script pane


Figure 14 Function name in the Listener field


Figure 15 Function code
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22. In the parameters area of the Script pane, select Void 
from the Type pop-up menu.


Some functions return a value when called. The keyword 
void indicates that this function does not return a value.


Now you can tell the function what you want it to do 
when the CLICK event occurs.


23. In the Actions toolbox on the left side of the panel, select 
the GotoAndPlay method for the Flash.Display class 
(Figure 16).


To find the GotoAndPlay method, expand Flash.Display, 
and then expand MovieClip and Methods.


24. Select the function in the Script pane and double-click 
the GotoAndPlay method in the Actions toolbox.


The method is added to the function (Figure 17).


25. Click in the Object field in the parameters area of the 
Actions panel.


The Insert Target Path button is now active.


26. Click the Insert Target Path button to display the Insert 
Target Path dialog box.


27. Select the Relative option and select the movie clip you 
want to play when the button is clicked. If you want the 
movie in the main timeline to play, select Root to set the 
target path to this.


28. Click OK to close the Insert Target Path dialog box.


29. In the Frame field, type the number of the frame you 
want to send the playhead to. For example, if you want 
the movie to start from the beginning, type the number 1 
to play the movie’s first frame.


30. Close the Actions panel.


31. Save the movie.


32. Select Control > Test Movie > In Flash Professional to 
test the movie.


33. Select File > Close to close the preview window.


Figure 16 GotoAndPlay method


Figure 17 GotoAndPlay method in the Script pane


For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, 
select Help > Flash Help).
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Using code snippets
In the Code Snippets panel you can start using simple ActionScript 3.0 very quickly, without knowledge of 
programming or ActionScript 3.0. You can add ActionScript 3.0 code to your Flash file to enable common 
functionality. Here are some of the code snippets you might use:


• Drag And Drop. Users can drag the symbol around the Stage.


• Move With Keyboard Arrows. Users can move the symbol with the keyboard arrows.


• Click To Go To Frame And Stop. The playhead moves to a specific frame and then stops when users click the 
symbol.


• Click To Play/Stop Sound. A sound plays when users click the symbol.


Adding a code snippet to a movie clip symbol instance


You can add code snippets to movie clip symbol instances. Symbols are stored in the library. Whenever you place a 
symbol on the Stage, you are actually placing an instance of the symbol on the Stage. For ActionScript to act on a 
symbol instance, you must give the instance a name.


To add a code snippet to a movie clip symbol instance:


1. Draw an object on the Stage, such as an oval.


2. Convert the object to a Movie Clip symbol.


3. With the object selected, open the Properties panel. 


4. In the Instance Name text box, enter a name for the 
symbol instance (Figure 18). 


5. Select Windows > Code Snippets.


The Code Snippets panel opens (Figure 19).


6. With the movie clip instance still selected, double-click 
the Animation folder in the Code Snippets panel.


Figure 18 Properties panel.


Figure 19 Code Snippets panel
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7. Select the Move With Keyboard Arrows code snippet.


8. Click the Add To Current Frame button in the Code 
Snippets panel (Figure 20).


The Actions panel opens, showing the ActionScript in the 
code snippet (Figure 21).


The Move With Keyboard Arrows code snippet lets users 
move the movie clip with the keyboard arrows when the 
movie runs. For information on other code snippets, see 
Flash Help.


9. After looking at the ActionScript you added, close the 
ActionScript window.


When you added the code snippet, Flash added a new 
layer in the Timeline panel named Actions (Figure 22).  
The ActionScript for the code snippet appears in a new 
keyframe in the Actions layer.


10. Test the movie. Observe that the object moves with the 
keyboard arrows.


Figure 20 Code Snippets panel


Figure 21 Actions panel


Figure 22 Timeline panel
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How to work with text
Adobe Flash Professional CS6 lets you add text to a Flash application in two formats:


• You can add Text Layout Framework (TLF) text.


• You can add Classic text.


Using the Text Layout Framework
TLF text provides the following enhancements over Classic text:


• You can adjust a wider range of character aspects, such as leading and tracking.


• You can rotate text more easily.


• You can flow text across multiple containers, as it does in a magazine page layout.


• You can better control the attributes of Asian text.


• You can create right-to-left text.


The Text Layout Framework is available as an option in the Properties panel. 


TLF text requires that ActionScript 3.0 and Flash Player 10 or later are specified in the publish settings of your FLA 
file. See the guide “How to publish a Flash document” for more information about publish settings.


To create TLF text:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Click the Text tool.


3. Make sure the Properties panel is open. If not, select 
Window > Properties.


4. Select TLF Text from the Text Engine menu (Figure 1).


5. Move the pointer to the Stage.


The pointer changes to a cross hair with the letter T 
attached to it.


6. Drag to create a container (Figure 2).


7. Release the mouse button and click in the container.


8. Type some text (Figure 3).


Figure 1 Text Engine menu.


Figure 2 Dragging to create a container


Figure 3 Text container
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Managing text flow for TLF text


If you fill a Flash TLF text container with more text than fits within the bounding box, a red plus symbol appears. 
This red plus indicates the text is overset. Overset text is text that does not fit in the container.You can solve the 
problem of overset text by making the container bigger, but often you will want to continue the text in another 
container, either on the same page or on another page. This is called text flow. 


For example, in Figure 4 the upper container is overset and needs to flow to the lower text container.


Figure 4 Overset text


In Figure 5, the two containers have been linked, as indicated by a line between the Out port of the top container and 
the In port of the bottom container.


Figure 5  Linked containers


Out port of text container In port of text container
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To flow text:


1. Use the Selection tool to select a container.


2. Click the Out port in the lower-right corner of the 
selected container.


The pointer changes to the loaded text icon, an arrow 
with small lines of text (Figure 6).


3. Then do one of the following:


• To link to an existing container, position the pointer 
over the target container. The pointer changes to the 
link text icon, an arrow with chain links (Figure 7). 
Click the container to link the two containers.


• To link to a new container, click or drag on an empty 
part of the Stage. Clicking creates an object of the 
same size and shape as the original; dragging lets 
you determine the size of the container.


The containers are now linked and text will flow between 
them (Figure 8).


Figure 6 Loaded text icon


Figure 7 Link text icon


Figure 8 Result of linking to a text container
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Using Classic text
You can specify three types of Classic text in the Properties panel: Static, Dynamic, and Input. The default type is 
Static. Use Static text when the text will not change, such as button and form labels. Use Dynamic text for text that 
will change as the movie plays, such as text pulled from an external database in response to a viewer’s request. Use 
Input text for requesting input from the viewer, such as a user name and password—input text is similar to a form 
field.


To use Classic text:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. In the Tools panel, select the Text tool.


3. Make sure the Properties panel is open. If not, select 
Window > Properties.


4. Select Classic Text from the Text Engine menu 
(Figure 9).


5. In the Properties panel, make sure that Static Text is 
selected in the Text Type menu (Figure 9).


6. Move the pointer to the Stage.


The pointer changes to a cross hair with the letter T 
attached to it.


7. To create an expanding-width text field, click on the 
Stage.


The text field contains a flashing insertion point. This is 
where text appears as you type. The round handle 
indicates the text field is an expanding-width one-line 
static text field (Figure 11).


8. Type the text.


The text field expands as you type.


9. Click away from the text to deselect it.


10. To create a fixed-width text field, drag on the Stage to 
create a text box. Make the box about as wide as you 
think is necessary to fit your text.


A text field is created. This text field has a square handle 
in the upper right corner (Figure 12). The square handle 
indicates that the text field is a fixed-width static text 
field.


Figure 9 Text Engine menu


Figure 10 Text Type menu


Figure 11 Expanding-width one-line static text 
field


Figure 12 Fixed-width static text field


Round handle


Square handle
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11. Type the text.


The text you type wraps to a new line when it reaches the 
right edge of the text field.


12. Drag the square handle to the right until the text is on a 
single line.


Note: Double-clicking a square handle changes it to a 
round handle and changes the text field to an expanding-
width one-line static text box.


13. Click away from the text to deselect it.


Formatting both TLF and Classic text
You can apply basic character formatting to TLF or Classic text, such as font family, font type, font style, and font 
color. You can also adjust tracking, adjust leading, and apply anti-aliasing to both formats.


To apply basic formatting to text:


1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic). 


2. In the Character section of the Properties panel, choose a 
different font family in the Font Family menu, such as 
Verdana (Figure 13).


3. Choose a different font style, such as italic or bold.


4. Set a different font size, such as 14, by using the Size 
scrubber. (You can also click the scrubber and type a 
value for Size.).


5. Choose a different font color by clicking the Color box 
and doing one of the following:


• Select a color from the Color palette (Figure 14).


• Enter a hexadecimal color value in the upper-left 
corner (Figure 14).


• Click the Color Picker icon and select a color from 
the system color picker. (When setting the text color, 
use only solid colors, not gradients. To apply a 
gradient to text, break the text apart and convert the 
text to its component lines and fills.)


6. In the Paragraph section of the Properties panel, choose 
an alignment for the text, such as left, centered, right, or 
justify.


Note: For TLF text, Flash provides additional Justify 
alignment options for the last line of text, such as Justify 
With Last Line Aligned To Start or Justify With Last Line 
Aligned To Center.


Figure 13 Properties panel, Character section


Figure 14 Color palette


Hexidecimal color 
value


Color Picker icon
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Adjusting leading and tracking


To improve readability and meet design goals, you can adjust the spacing between lines and characters—leading and 
tracking—for both TLF and Classic text.


Adjusting leading


Leading refers to the space between lines. In Classic text, leading is referred to as line spacing. You are probably used 
to differentiating between single-spaced and double-spaced text. By adjusting leading, you can fine-tune the space 
between lines. By default, leading is set to 120% of the text’s height for TLF text and 0 for Classic text. 


To adjust leading:


1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic).


2. Do one of the following:


• For TLF text, drag the Leading scrubber in the 
Character section of the Properties panel 
(Figure 15). You can also click the current Leading 
value and enter a new value. 


• For Classic text, drag the Line Spacing scrubber in 
the Paragraph section of the Properties panel 
(Figure 16). You can also click the current Spacing 
value and enter a new value.


The result of decreased leading is less space between 
lines of text. Increasing leading adds more space between 
lines of text (Figure 17).


Figure 15 Properties panel, Character section


Figure 16 Properties panel, Paragraph section


Figure 17 Increased leading
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Adjusting tracking


Tracking refers to the space between characters across a line of text. In Classic text, tracking is referred to as letter 
spacing. You adjust tracking to space the letters further apart or closer together.


To adjust tracking:


1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic).


2. Do one of the following:


• For TLF text, drag the Tracking scrubber in the 
Character section of the Properties panel 
(Figure 18). You can also click the current Tracking 
value and enter a new value.


• For Classic text, drag the Letter Spacing scrubber in 
the Character section of the Properties panel 
(Figure 19). You can also click the current Letter 
Spacing value and enter a new value.


The result of decreased tracking is less space between 
characters. Increasing tracking adds more space between 
characters (Figure 20).


Figure 18 Properties panel, Character section


Figure 19 Properties panel, Character section


Figure 20 Increased tracking
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Applying anti-aliasing


Anti-aliasing lets you smooth the edges of on-screen text. Anti-aliasing is especially useful for small font sizes. When 
anti-aliasing is enabled, all text in the current selection is affected. Anti-aliasing operates with text of all point sizes in 
the same way. You can apply anti-aliasing to TLF text or Classic text.


You can select from the following anti-aliasing options:


Use Device Fonts: The SWF file will use fonts installed on the viewer’s computer to display the fonts. This option 
doesn’t increase the size of the SWF file.You should use this option only with commonly installed fonts, such as 
Verdana or Arial.


Readability: Allows for improved legibility of embedded fonts, particularly at small sizes. To use this option, you 
must embed the font. When you embed fonts, Flash copies the font into the SWF file so that the font does not need to 
be present on the viewer’s computer. This increases the size of the SWF file slightly.


Animation: Creates a smoother animation of text by ignoring alignment and kerning information. To use this option, 
you must embed the font. When you embed fonts, Flash copies the font into the SWF file, so that the font does not 
need to be present on the viewer’s computer. This increases the size of the SWF file slightly. Animation anti-aliasing 
will be hard to read if font size is smaller than 10 points.


For Classic text, you can select two additional anti-aliasing options:


Bitmap Text (No Anti-alias): Useful for displaying small font sizes. Bitmap fonts do not contain outlines, which helps 
keep the file size of a published Flash document to a minimum.


Custom Anti-alias: Modify thickness and sharpness to control the effect anti-alias has on your text.


To set anti-aliasing:


1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic).


2. Choose an anti-aliasing option, such as Readability, from 
the Anti-Alias menu in the Character section of the 
Properties panel (Figure 21).


Figure 21 Anti-alias menu for TLF text
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Note: The Font Embedding Warning dialog box opens if 
you select Readability or Animation after selecting Use 
Device Fonts (Figure 22). You can click Embed to open 
the Font Embedding dialog box (Figure 23) and select 
which fonts to embed. You can click Not Now to 
continue without embedding fonts.


You can also open the Font Embedding dialog box by 
clicking Embed in the Character section of the Properties 
panel.


Figure 22 Font Embedding Warning dialog box


Figure 23 Font Embedding dialog box


Applying filters to text
To add interest or fulfill other design goals, you can apply graphics filters to both TLF and Classic text in Flash. 
These filters can make text appear to be raised, give text a shadow, or give text a glow. Graphics filters are available 
in the Filters section of the Properties panel.


Applying the Drop Shadow filter to text


The Drop Shadow filter makes it appear that text or an object is casting a shadow.


To add the Drop Shadow filter to text:


1. Use the Selection tool to select a text container (TLF) or 
field (Classic) with text.


Note: You cannot select the text itself to apply the filter.


2. In the Properties panel, display the Filters section 
(Figure 24).


Note: You may need to scroll down in the Properties 
panel to see the Filters section because it's at the bottom 
of the panel.


3. Click the Add Filter button in the lower-left corner of the 
panel.


Figure 24 Properties panel, Filter section


Add Filter button
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4. Select Drop Shadow in the Filters menu (Figure 25).


The text includes a drop shadow (Figure 26).


You can adjust the characteristics of the Drop Shadow, 
such as its color, in the Filters section of the Properties 
panel (Figure 27).


Figure 25 Filters menu


Figure 26 Drop shadow


Figure 27 Drop shadow properties


Other filters


You can apply several other filters to text to create interesting visual effects.


Blur


The Blur filter softens the edges and details of objects. Applying a blur to an object can make it appear to be behind 
other objects, or make an object appear to be in motion. Adjust the amount and direction of blur by using the X and Y 
text boxes.
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Glow


The Glow filter lets you apply a color around the edges of an object.


• Glow: Make the object appear to shine.


• Inner Glow: Apply the glow only within the boundaries of the object.


• Knockout: Remove the object and leave the glow. The object appears outlined in glow.


Bevel


Applying a bevel applies a highlight to the object that makes it appear to be raised above the background surface.


• Inner Bevel: Give the object a three-dimensional look by applying highlights and a shadow to the inside of the 
object.


• Outer Bevel: Give the object a three-dimensional look by applying highlights and a shadow to the outside of the 
object.


• Full Bevel: Apply both inner bevel and outer bevel effects to the object.


You can alter the bevel’s shadow and highlight colors, the type of bevel (inner, outer, or full), its strength, and the 
angle of light that falls on it.


Gradient Glow


Applying a gradient glow produces a glow look with a gradient color across the surface of the glow. The gradient 
glow requires one color at the beginning of the gradient with an Alpha value of 0. You cannot move the position of 
this color, but you can change the color.


Gradient Bevel


Applying a gradient bevel produces a raised look that makes an object appear to be raised above the background, with 
a gradient color across the surface of the bevel. The gradient bevel requires one color in the middle of the gradient 
with an Alpha value of 0.


Adjust color


You can use the Adjust Color filter to finely control the color attributes of the selected object, including contrast, 
brightness, saturation, and hue.


• Brightness: Make the object brighter or darker.


• Contrast: Increase or decrease the distinction between light and dark.


• Saturation: Increase the intensity of color. For example, raising saturation on blue text makes the text a more 
vibrant blue.


• Hue: Increase or decrease the shade of the color.
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Digital Design Project 4 guide

How to plan a portfolio
The content and purpose of a portfolio can vary widely. Student portfolios typically contain examples of work as well 
as text descriptions and reflections on each piece. Three types of web portfolios showcase work, document progress 
through a project, or highlight skill growth. Examples of these three types follow.


Showcase portfolio


A showcase portfolio highlights its owner’s expertise by showing examples of best work. A student showcase would 
include a selection of finished images, designs, and websites. It might also provide a reflection in the piece or 
document of the process students followed to create it. Following is a sample category outline with associated files:


Image work


• Digital camera photographs


• Optimized images


Design work


• Widget


• Web graphics


• Rich media


Client website


• Wireframes


• Design comps


• Storyboard


• Prototype


• Completed website (illustrated on mutiple screen types)
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Portfolio flowchart


This is a sample flowchart for a showcase portfolio:
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Skill growth portfolio


A skill growth portfolio shows multiple samples of work in the same project to demonstrate increasing skill. For 
example, students include several versions of their page banners to show how the design evolved. This portfolio can 
also include reflection and discussion of redesigns. Following is a sample category outline with associated files:


Design work


Widget


• Widget (early version)


• Widget (final version)


• Wireframe self review


Client website


Wireframe


• Wireframe (early version)


• Wireframe (final version)


• Wireframe client review


Design comp


• Design comp (early version)


• Design comp (final version)


• Design comp client review


Storyboard


• Storyboard (early version)


• Storyboard (final version)


• Storyboard client review


Prototype


• Prototype (early version)


• Prototype (final version)


• Prototype client review
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Portfolio flowchart


This is a sample flowchart for a skill growth portfolio:
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Project progress portfolio


A project progress portfolio contains a more complete selection of work around a particular project. The portfolio 
reflects the span of work done on a project—showing stages from early ideas to completion. An example would be to 
show all the work students did while learning about Adobe Fireworks CS6. The portfolio would include wireframes 
and storyboards, early versions, final versions, peer review, and self-review. For this portfolio type, students will need 
to scan worksheets and other handwritten documents to create web-ready versions.
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Student portfolio


Planning a website by using information architecture is a common practice for professional designers. Designers 
create a flowchart that shows all the pages in the site and how they connect. The flowchart can also describe the 
purpose and audience for a site and provide organized lists of content.


Create a flowchart for your portfolio that shows the organization and content of your work in this course. Include the 
following:


1. Describe the purpose of the portfolio.


2. Include a list of assets in the portfolio, and organize files and projects into categories.


3. Using your category outline from step 2 as a guide, draw a flowchart for your web portfolio.
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How to create a wireframe
A wireframe is a visual guide representing the basic elements of a website. Wireframes are used to describe the 
conceptual structure or information architecture of a website or application. A well-designed wireframe includes 
three key elements: interface design, navigation system, and main content areas (Figure 1). The functional 
relationships between these element are highlighted, where detailed graphics, typographic style, and colors are 
typically not emphasized. 


Fireworks is an ideal tool to mock up wireframes. Use the following guidelines to help you create a wireframe of your 
widget or website.


Figure 1 Wireframe proposal


Wireframing workflow
This worklow outlines the general steps for developing a wireframe from scratch. The result is to a fully-functional 
interactive prototype.


1. Create pen-and-ink draft 


Using pen and paper, sketch a home page or home screen. Include all major layout design elements you want to share 
across multiple pages or screens such as navigation, content areas, titles, and logos. Consider these questions:


• Graphics What graphics will you include? Where will you place the graphics on the page or screen?


• Text What text will you include? Where will you place text on the page or screen?


• Navigation According to your flowchart, the home page or screen directly links to what pages or screens 
(what are the menu items)? Where will you place these links on your home page or screen?


2. Scan and import your draft


Use a scanner to make a digital copy of your draft wireframe, import it into Fireworks.


3. Lay out common design elements


With the sketched draft for reference, use basic drawing tools and guides in Fireworks to block out the main design 
elements in the wireframe.
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4. Create multiple wireframe pages or screens


In the Pages panel, create the desired number of pages or screens for your initial design. As the design evolves, you 
can add or subtract pages or screens as needed.


5. Add unique elements to individual pages or screens


On each page, add unique design, navigation, or form elements. In the Common Library panel, you can find many 
buttons, text boxes, and pop-up menus that speed up the design process.


6. Simulate user navigation with links


Use web objects such as slices, hotspots, or navigation buttons to link the various pages or screens of your prototype.


7. Export the finished, interactive wireframe


Fireworks offers multiple output formats for your prototype, all of which retain hypertext links for navigation within 
the prototype.


Creating a wireframe with Adobe Fireworks CS6
Use Fireworks to create a basic two-page interactive wireframe document. 


Workflow steps 1 to 3


In this section, you  sketch out your wireframe, scan and import it into Fireworks, and lay out comon design elements. 


To create a wireframe from a sketch:


1. Using pen and paper, sketch your wireframe. Include all 
major components, such as navigation, content areas, 
titles, and logos.


2. Scan the sketch into your computer. 


3. Start Fireworks and create a new document 1024 pixels 
wide and 700 pixels high. 


Note: These dimensions are those of a typical web page. 
The dimensions may differ if you're designing a widget.


4. Open the Layers panel, and create or rename two layers: 


• Wireframe


• Wireframe Sketch


Make sure the Wireframe Sketch layer is below the 
Wireframe layer (Figure 2).


5. With the Wireframe Sketch layer selected, choose File > 
Import.


The Import dialog box opens.


6. Navigate to the file you scanned in step 2, and click 
Import (Windows) or Open (Mac OS).


7. Click in the upper-left corner of the canvas to place the 
imported sketch at that location. 


You need to scale the sketch to fit the canvas. Click the 
imported sketch to select it.


Figure 2 Wireframe and Wireframe Sketch layers 
added to the Layers panel
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8. The sketch may extend beyond the edges, or not fully fit  
inside the canvas. 


9. In the Properties panel, select the Constrain Proportions 
option (Figure 3).


10. In the Width Pixel Dimension text box, type 1024, and 
confirm the X and Y coordinates are set to 0.


11. Press Tab.


The image resizes to fit the canvas width.


12. In the Layers panel, lock the Wireframe Sketch layer.


This sketch layer will be the background reference to lay 
out the wireframe elements.


13. Select the Wireframe layer.


14. Make sure rulers and guides are visible. If not, select 
View > Rulers and View > Guides > Show Guides.


15. To create a horizontal or vertical guide, click then drag 
from the corresponding ruler respectively to the edges of 
the logo area, the main content area, and the first 
navigation button (Figure 4).


Note: Guide color can be changed to be more visible 
against different backgrounds. To change the guide color, 
select Edit > Preferences (Windows) or Fireworks > 
Preferences (Mac OS)  and select the Guides And Grids 
category.


16. Select View > Guides > Lock Guides.


Locking the guides prevents you from moving them 
unintentionally.


17. Select View > Guides > Snap To Guides.


The snapping feature enables you to align objects 
precisely with the guides as long as you get close. You 
can control how close you have to get (Snap Distance) in 
Guides And Grids. preferences.


18. Select the Rectangle tool from the Tools panel.


19. In the Properties panel, make the following changes 
(Figure 5):


a. Select None from the Fill pop-up menu.


b. Select Basic > Soft Line from the Stroke pop-up 
menu.


c. Set Stroke color to dark grey.


d. Set Stroke width to 10 pixels.


20. Using the guides, draw a rectangle around the main 
content area, and logo area of the sketch (Figure 6).


As you draw, the rectangles snap to the guides.


Figure 3 Properties panel


Figure 4 Imported sketch with guides added


Figure 5 Rectangle Properties panel


Figure 6 Rectangles drawn around page elenents


Width Pixel Dimension text box


Constrain 
Proportions 
option


X and Y Positions


No Fill option
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21. Select the Rounded Rectangle tool from the Tools panel.


22. Draw a rounded rectangle around the first navigation 
button of your wireframe (Figure 7).


23. Use the Pointer tool to select the rounded rectangle. Alt-
drag (Windows) or Option-drag (Mac) to the left to create 
a copy of the rectangle, and place it over the second 
navigation button in your wireframe.


Note: You may see a Fireworks warning box telling you 
that editing sub-elements of an Auto Shape may cause it 
to behave unpredictably. Select the Don’t Show Again 
option and click OK to dismiss.


24. Select Edit > Repeat Duplicate. 


This action creates a second copy with the same gap 
space between copies.


25. Continue repeating duplicates until you have created as 
many navigation buttons as needed for your wireframe 
sketch (Figure 8).


Now it's time to add the text labels. 


26. Choose Select > Deselect.


27. From the Tools panel, select the Text tool.


28. In the Properties panel, click the Fill color box and 
choose a dark color. Set the justification to Center 
Alignment and the Text Size to 30.


29. Click once in the logo rectangle and enter the text Logo.


30. Make sure Smart Guides are visible and active. If not, 
select View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.


31. Drag the text block to center it in the rectangle, and 
continue adding text labels for the navigation buttons and 
main content area.


The Smart Guides help you to create, align, edit, and 
transform objects relative to other objects.


32. Choose View > Guides > Show Guides to hide guides.


33. Once you are satisfied with the position of the text and 
rectangle elements, click the eye icon next to the 
Wireframe Sketch layer to turn off visibility of the 
background layer. 


With the sketch layer turned off, your image should look 
similar to Figure 9.


34. Select File > Save As and save the file as a PNG.


Figure 7 Rounded rectangle drawn around 
navigation button


Figure 8 Three copies of the rounded buttons 


Figure 9 Completed wireframe sketch

How to create a wireframe © 2012 Adobe Systems Incorporated







Adobe Fireworks CS6 Project 2 guide

Workflow steps 4 and 5


Now that you have created the very basic wireframe of the page or screen layout, the next step is to create a few pages 
or screens showing various content. Fireworks CS6 enables you to create as many pages or screens as needed, with 
shared and unique items on each page.


To create multiple wireframe pages or screens:


1. Open the Pages panel (Window > Pages) if it isn't already 
displayed on the right side of the workspace (Figure 10).


2. Right-click (Windows) or Control-click (Mac OS) the 
current page in the Pages panel, and choose Set As 
Master Page from the context menu.


3. At the bottom of the Pages panel, click the Add Page 
button twice to add two blank pages.  


The new pages display the master page in the 
background.


4. Double-click the new page names to rename them, 
respectively, as Home and Shop (or whatever name you 
are using for the  second page of your wireframe). 


5. Navigate to the Home page by selecting it in the Pages 
panel (Figure 11).


6. Use the Text tool to add a page title at the top of the main 
content area.


7. Navigate to the Shop page by selecting it in the Pages 
panel, and use the Text tool to add a page title at the top 
of the main content area in the same way as on the Home 
page.


8. Select the Rectangle tool from the Tools panel.


9. In the Properties panel, select neutral colors for Fill and 
Stroke.


10. Draw a rectangle in the main content area of the second 
page, beside the page title. This rectangle stands in as a 
placeholder for a Shop page image or text page content 
(Figure 12).


11. Select File > Save.


Figure 10 Pages panel


Figure 11 Pages panel, Home page selected


Figure 12 Adding page-level placeholder content


Pages options
menu


Add Page 
button
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Workflow step 6


In this section, you use hotspot web objects to create navigation buttons or links between the two pages of your 
prototype.


To add navigation to a wireframe:


1. Navigate to the master page by selecting it in the Pages 
panel.


2. From the Tools panel, select the Rectangle Hotspot tool 
(Figure 13).


3. Draw a hotspot over the Logo rectangle area. 


4. Draw another hotspot over the first rounded rectangle 
area (Figure 14).


5. Select the first hotspot with the Pointer tool.


6. In the Properties panel, set Link to Home.htm 
(Figure 15).


7. Select the second hotspot and set Link in the Properties 
panel to Shop.htm (or to whatever you named the second 
page).


Because the hotspots are located on the master page, 
every page will be linked to the others when export the 
Fireworks file to an interactive PDF.


8. Select File > Save.


Figure 13 Tools panel


Figure 14 Drawing hotspots


Figure 15 Properties panel


Workflow step 7


Export an interactive prototype of your wireframe to both PDF and functional HTML (Figure 16). 


An interactive PDF is ideal for facilitating the client review process because the client can click through the flow of 
the site or widget, and make comments as needed by using the tools available in Adobe Acrobat. 


Fireworks generates pure HTML that can be read by most web browsers and HTML editors. You can then preview 
your wireframe interactivity and edit these files in Dreamweaver.


Figure 16 Export wireframes from Fireworks


Rectangle Hotspot tool


Link menu
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To export an interactive PDF:


1. Choose File > Export.


The Export dialog box opens (Figure 17).


2. From the Export pop-up menu, choose Adobe PDF. 


3. Confirm that the option View PDF After Export is 
selected.


4. Specify a filename and location, and then click Save 
(Windows) or Export (Mac OS).


The wireframe is exported to PDF and opens in Acrobat.


5. Test that the wireframe links work as expected 
(Figure 18).  


Figure 17 Export dialog box


Figure 18 Testing links in Acrobat PDF


To export to HTML and images:


1. Choose File > Export.


The Export dialog box opens.


2. Navigate to a folder on your hard drive in which to 
export.


3. From the Export pop-up menu, choose HTML And 
Images.


4. Select All Pages from the Pages menu.


5. To store images in a separate folder, select the option Put 
Images In Subfolder. You can select a specific folder or 
use the Fireworks default Images subfolder.


View PDF After Export option
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6. Specify a filename, and then click Save  (Windows) or 
Export (Mac OS).


After export, you'll see the files Fireworks exported on 
your hard drive. Images and an HTML file are generated 
in the location you specified in the Export dialog box.


7. Navigate to the location of the saved file, open 
Home.htm in a browser, and test whether the wireframe 
links work as expected (Figure 19).


Figure 19 Testing HTMLin a browser
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How to add text


Adding text to a document
To add text to a Dreamweaver document, you can type text directly in the Document window, or you can cut and 
paste text. You modify text by using the Properties panel (Figure 1). 


Figure 1 Properties panel, HTML mode


There are many additional options to working with text such as bulleted and numbered lists, adding special 
characters, and more. To learn more about adding text to a document, please see “Working with text,” in 
Dreamweaver Help.


To add text:


1. Start Dreamweaver.


2. Select File > New to create a new document.


The New Document dialog box opens (Figure 2).


3. In the Blank Page category of the New Document dialog 
box, select HTML Page Type to create a plain HTML 
page.


4. In the Layout column, select None. 


5. Click the Create button.


The new HTML page opens.


6. In the Document toolbar, click the Show Code And 
Design View button (Figure 3).


The flashing insertion point is located at the top of the 
new document in the Design view.


Note: In an existing document, you can click to place the 
insertion point where you want new text to begin.


7. Type some text or paste text copied in another application 
in the Design view document window.


8. Press Enter (Windows) or Return (Mac OS) to begin a 
new paragraph.


Dreamweaver applies the default Paragraph style to your 
text, as shown in the Properties panel (Figure 1).


Observe in Code view that Dreamweaver applies 
paragraph tags around the two new paragraphs 
(Figure 4).


9. Save the new document (File > Save).


Figure 2 New Document dialog box


Figure 3 Document window view options


Figure 4 HTML paragraph tags in Code view
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10. In the dialog box that appears, navigate to the root folder 
of your site.


11. Open the Properties panel (Window > Properties), if it 
isn’t already open, and click the HTML button to display 
the HTML Properties panel.


Dreamweaver has two Properties panels, integrated into 
one: the CSS Properties panel and the HTML Properties 
panel. In this section, you HTML Properties panel to 
apply basic HTML markup tags. In the next section you 
will use the CSS Properties panel.


When you first begin typing, there is no paragraph 
formatting applied to the text, as shown by the word 
None in the Format menu in the Properties panel.  


12. In the File Name box, type index to name the file.


Note: Avoid using spaces and special characters in file 
and folder names, and do not begin a filename with a 
numeral. In particular, do not use special characters (such 
as é, ç, or ¥) or punctuation marks (such as colons, 
slashes, or periods) in the names of files you intend to put 
on a remote server; many servers change these characters 
during upload, which will cause any links to the files to 
break.


13. Click Save.


Applying basic CSS formatting to paragraphs and text


You can also use the text Properties panel to apply Cascading Style Sheet (CSS) formatting (Figure 5). When you 
apply CSS formatting rules, Dreamweaver writes properties to the head of the document or to a separate style sheet. 
By default, Dreamweaver uses Cascading Style Sheets (CSS) to format text.


Figure 5 Properties panel, CSS mode


CSS formatting is a best practice over HTMLformatting . CSS gives web designers and developers greater control 
over web page design, while providing improved features for accessibility and reduced file size. Using CSS is a way 
to control the style of a web page without compromising its structure. By separating visual design elements (fonts, 
colors, margins, and so on) from the structural logic of a web page, CSS gives web designers visual and typographic 
control without sacrificing the integrity of the content. 


The CSS Properties panel lets you access Targeted Rules, as well as create new ones. A Targeted Rule is a rule you 
are editing in the CSS Properties panel. When you have an existing style applied to text, the rule affecting the text’s 
format appears when you click inside the text on the page. You can also use the Targeted Rule pop-up menu to create 
new CSS rules, new in-line styles, or apply existing classes to selected text. If you’re creating a new rule, you’ll need 
to complete the New CSS Rule dialog box. You will learn more about CSS and the New CSS Rule dialog box in later 
Dreamweaver guides.
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To apply CSS formatting to paragraphs and text:


1. Drag to highlight the paragraphs of text you added to the 
page.


2. In the Properties panel, click the CSS button to display 
the CSS Properties panel.


3. Use the Font menu to change the default font to Georgia, 
Times New Roman, Times, serif.


The New CSS Rule dialog box opens (Figure 6).


4. Review the settings in the New CSS Rule dialog box, in 
particular notice the Selector Name fields (Figure 7).


This shows that all instances of the paragraph element in 
the HTML document will be set with the same font 
family.


5. Click OK to close the New CSS Rule dialog box.


The new font family is applied to the selected paragraphs 
in Design view.


6. Observe in Code view that Dreamweaver store styles 
created with CSS directly in the document in the head 
section of the page (Figure 8).


7. (Optional) Click in a paragraph, or drag to highlight a 
section of text and apply new formatting such as bold, 
and Align Center. 


Observe in Code view how the body p CSS tag is updated 
to reflect the changes.


Figure 6 New CSS Rule dialog box


Figure 7 Detail of New CSS Rule dialog box


Figure 8 Detail of New CSS Rule, code view


Copying text from another document
One way to add text to a Dreamweaver document is to copy and paste text from another document.


To copy text from another document:


1. Open the document from which you want to copy text.


2. Select the text and select Edit > Copy.


3. Start Adobe Dreamweaver CS6.


4. Open the Dreamweaver document in which you want to 
paste the text.
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5. Position the insertion point in the page where you want to 
paste the copied text.


6. Select Edit > Paste.


The new text appears in the Dreamweaver document.


Note: Copied text may lose some of its original 
formatting, including line breaks and paragraph breaks. 
To insert a blank line after a section of text, position the 
insertion point at the end of the last text line and press 
Enter (Windows) or Return (Mac OS). To create a line 
break at the insertion point, press Shift+Enter (Windows) 
or Shift+Return (Mac OS).


7. To change the format of any new text in the document, 
select the text and apply a CSS rule or create a new CSS 
rule based on the format of the new text.


Linking text to other pages and e-mail addresses
After you’ve set up a Dreamweaver site to store your website documents and have created HTML pages, you’ll want 
to create connections from your documents to other documents. Before creating a link, make sure you understand 
how absolute, document-relative, and site root–relative paths work.  You can create several types of links in a 
document:


• A link to another document or to a file, such as a graphic, movie, PDF, or sound file.


• A named anchor link, which jumps to a specific location in a document.


• An e-mail link, which creates a new blank e-mail message with the recipient’s address already filled in.


• Null and script links, which you use to attach behaviors to an object or to create a link that executes 
JavaScript code. 


In this section, you will use the Point-To-File icon to create a links to another page (Figure 9), and the Properties 
panel Link boxto add a link to an e-mail address. Dreamweaver creates the links to other pages in your site using 
document-relative paths. For more information about links and other linking options, see the “Linking and 
navigation” section of Dreamweaver Help. We will also look at linking in more depth in later activities.


Figure 9 Properties panel, HTML mode


Point-to-File iconDestination link
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To create a link to another document in your site:


1. Create a new, blank page within your site and name it 
contact, and save the new document (File > Save).


Note: Always save a new file before creating a 
document-relative path; a document-relative path is not 
valid without a definite starting point.


You should now have two files open in the document 
window: index.html, and contact.html.


2. Click the Show Code And Design View button in the 
Document toolbar.


3. In the index.html page, in the Design view, create a new 
paragraph break and type the text Contact us.


4. Drag to select the just-created text.


5. Click the HTML button in the Properties panel.


6. Click on the Point-To-File icon (Figure 9).


The cursor converts to a crosshair icon and arrow.


7. Drag the arrow to the contact.html file to make a link.


The selected text is now formatted as a link, as indicated 
by the default blue underline (Figure 10). The 
destination is displayed in the Properties panel Link text 
box, and the a href html tages are appled to the text.


8. Save the file.


Figure 10 E-mail link, Code view (top) and Design 
view (bottom)


To create an e-mail link:


1. Click on the contact.html tab in the document window.


2. In the Design view, type the text Contact us.


3. Select just-created text in the Document window’s 
Design view. 


4. In the Link box of the Properties panel, type mailto: 
followed by an e-mail address (Figure 11). 


Do not type any spaces between the colon and the e-mail 
address.


5. Press Enter (Windows) or Return (Mac OS).


The selected text is now formatted as an e-mail link.


6. Save the file.


Figure 11 Properties panel, detail view
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How to set up a local root folder and site structure
A Dreamweaver site is a collection of all the files and assets in your website. You can create web pages on your 
computer, upload them to a web server, and maintain the site by transferring updated files whenever you save them. 
You can also edit and maintain websites that were created without using Dreamweaver.


What is a Dreamweaver “site”?
In Dreamweaver the term “site” refers to a local or remote storage location for the documents that belong to a 
website. A Dreamweaver site provides a way to organize and manage all of your web documents, upload your site to 
a web server, track and maintain your links, and manage and share files. You should define a site to take full 
advantage of Dreamweaver features.


Note: To define a Dreamweaver site, you only need to set up a local folder. To transfer files to a web server or to 
develop web applications, you must also add information for a remote site and testing server.


A Dreamweaver site consists of as many as three parts, or folders, depending on your development environment and 
the type of website you are developing:


Local root folder stores the files you’re working on. Dreamweaver refers to this folder as your “local site.” This 
folder is typically on your local computer, but it can also be on a network server.


Remote folder stores your files for testing, production, collaboration, and so on. Dreamweaver refers to this folder as 
your “remote site” in the Files panel. Typically, your remote folder is on the computer where your web server is 
running. The remote folder holds the files that users access on the Internet. Together, the local and remote folders 
enable you to transfer files between your local hard disk and web server, making it easy to manage files in your 
Dreamweaver sites. You work on files in the local folder, and then publish them to the remote folder when you want 
other people to view them.


Testing server folder is the folder where Dreamweaver processes dynamic pages. 


Understanding local and remote folder structure
When you want to use Dreamweaver to connect to a remote folder, you specify the remote folder in the Servers 
category of the Site Setup dialog box. The remote folder that you specify (also referred to as the “host directory”) 
should correspond to the local root folder of your Dreamweaver site. (The local root folder is the top-level folder of 
your Dreamweaver site.) Remote folders, like local folders, can have any title, but commonly, Internet Service 
Providers (ISPs) name the top-level remote folders for individual user accounts public_html, pub_html, or something 
similar. If you are in charge of your own remote server, and can name the remote folder anything you want, it is a 
good idea for your local root folder and remote folder to have the same name.


Figure 1 shows a sample local root folder on the left and a sample remote folder on the right. The local root folder on 
the local machine maps directly to the remote folder on the web server, rather than to any of the remote folder’s sub 
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folders, or folders that exist above the remote folder in the directory structure.


Figure 1 Sample local root folder (left), and sample remote folder (right)


Note: The above example illustrates one local root folder on the local machine, and one top-level remote folder on 
the remote web server. If, however, you are maintaining a number of Dreamweaver sites on your local machine, you 
would need an equal number of remote folders on the remote server. In such a case the above example would not 
apply, and you would instead create different remote folders within the public_html folder, and then map them to their 
corresponding local root folders on your local machine.


When you first establish a remote connection, the remote folder on the web server is usually empty. Then, when you 
use Dreamweaver to upload all of the files in your local root folder, the remote folder populates with all of your web 
files. The directory structure of the remote folder and the local root folder should always be the same. (That is, there 
should always be a one-to-one correspondence between the files and folders in your local root folder, and the files and 
folders in your remote folder.) If the structure of the remote folder doesn’t match the structure of the local root folder, 
Dreamweaver uploads files to the wrong place, where they might not be visible to site visitors. Additionally, image 
and link paths can easily break when folder and file structures are not in synch. The remote folder must exist before 
Dreamweaver can connect to it. If you don’t have a designated folder that acts as your remote folder on the web 
server, create one or ask your ISP’s server administrator to create one for you.


Setting up a local root folder
To set up a local version of your site, all you need to do is specify the local folder where you’ll store all of your site 
files. The local folder can be on your local computer or on a network server.


To set up a local root folder:


1. Identify or create the folder on your computer where you 
want to store the local version of your site files. (The 
folder can be anywhere on your computer.) You’ll specify 
this folder as your local site in Dreamweaver.


This folder is called the local root folder.


2. Start Dreamweaver.
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3. Choose Site > New Site.


The Site Setup dialog box opens (Figure 2).


4. In the Site Setup dialog box, make sure the Site category 
is selected. (It should be selected by default.)


5. In the Site Name text box, enter a name for your site. 
This name appears in the Files panel and in the Manage 
Sites dialog box; it does not appear in the browser.


6. In the Local Site Folder text box, click the Browse To 
Folder icon, browse to and select the local root folder you 
created, and click Select (Windows) or Choose (MacOS).


Your local root folder is defined in Dreamweaver.


7. Click Save to close the Site Setup dialog box. 


You can now begin working on your local site files in 
Dreamweaver.


On the right side of the Dreamweaver workspace, the 
Files panel displays the folders and files of your site 
(Figure 4). 


Note: When you’re ready, you can fill out the other 
categories in the Site Setup dialog box, including the 
Servers category, where you can specify a remote folder 
on your remote server.


Figure 2 Site Setup dialog box, Site category


Figure 3 Choose Root Folder dialog box


Figure 4 Files panel


Modifying site information
The Manage Sites dialog box is your gateway into various Dreamweaver site functions. From this dialog box, you can 
initiate the process for creating a new site, editing an existing site, duplicating a site, removing a site, or importing or 
exporting a site’s settings.
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To modify site information:


1. Select Site > Manage Sites.


The Manage Sites dialog box opens (Figure 5).


2. Select the site name and click the Edit button.


The Site Setup dialog box opens (Figure 2).


3. Click a button to select one of the options, make any 
changes you need to make, and click Save or Cancel to 
close the Site Setup dialog box. Click Done to close the 
Manage Sites dialog box..


Figure 5 Manage Sites dialog box


Edit The Currently Selected Site
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How to maintain consistency
Consistency is an important element of usability—the measure of how well visitors can accomplish tasks when using 
your website. Consistency is especially important for larger sites that contain multiple pages and content created in 
Adobe Flash Professional CS6. The more you make these pages look and feel alike, the more comfortable visitors 
will be while using them.


You should keep elements within your site consistent, but also, whenever possible, follow the conventions of other 
sites. For example, many sites locate the main navigation at the top of each page. Unless you have a very good reason 
to locate the main navigation elsewhere, you should also locate it at the top of the page. (Although design innovation 
is desirable, making sure as many visitors as possible can use your website is more important.)


Consistency is especially important in the following areas:


Navigation: Not only should navigational controls be available on every page, but they should also look the same on 
each page. Navigation should tell visitors where they are in the site’s organization, using, for example, a highlighted 
button. It should also let visitors move to other site areas easily.


Colors: Similar objects should have the same or similar colors, and different objects should have different colors. Use 
a limited palette of colors on your site. You can do so easily by tracking colors in the Swatches panel.


Buttons: Generally, all buttons should look the same or similar—with the same font, drop shadow, and beveling, for 
example. Sometimes visitors have difficulty knowing what to click, and keeping buttons similar helps them use what 
they’ve learned on a previous page. You can use the library to reuse buttons across different pages. (This has the 
added advantage of reducing the file size of your site.)


Fonts: Use a limited group of fonts. Usually, you will not need more than two or three fonts for even a large site.


Graphics: Keep graphics similar on each page. You can use the library to reuse images across different pages.


Transitions: Use similar transitions between pages. For example, if one page fades into the next page, use fades for all 
page transitions. Transitions should also have similar timing; if one lasts three seconds, they should all last three 
seconds.


Scroll bars: Many usability experts recommend using a scroll bar that looks as similar as possible to those used in 
desktop software. Make these look the same on every page.


Sound: Use sound consistently throughout your site pages. If, for example, a button on one page makes a sound when 
your visitors roll over it, you should have all buttons on all pages make such a sound.


Layout: All the pages in your site should have a similar layout: the navigation should be in the same place on every 
page, for example. Interactive areas should also be in the same place. If one page has a simple game, for example, and 
another page has an interactive chart, position these in the same area. You can use Flash templates to maintain 
consistent layouts across different pages.
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Creating a template
Templates are a good way to keep your website pages consistent. You can include navigation, fonts, graphics, and 
layout in a template so these elements appear consistent throughout your site.


To create a template:


1. Start Flash.


2. Add content to a document to serve as a template, such as 
navigation, images, buttons, and background.


3. Select File > Save As Template.


The Save As Template dialog box opens (Figure 1).


Note: If a dialog box appears first, stating that SWF 
history data will be cleared if saved as template, click 
Save As Template.


4. Enter a name for the template.


5. Select a category in the Category pop-up menu, or enter a 
new category name.


6. Enter a description for the template.


This description appears in the New From Template 
dialog box.


7. Click Save.


The template is now available as an option in the New 
From Template dialog box.


Figure 1 Save As Template dialog box
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How to create a design comp
A comprehensive artwork (comp for short) is a design proposal presented by the designer to the client for approval. 
Web design comps provide a rough visual draft of the overall user interface (including graphics, interface design 
elements, navigation system, and main content areas) before specific content is placed (Figure 1).


Fireworks provides an ideal prototyping environment, seamlessly converting design comps into real-world widgets, 
websites, and applications.


Figure 1 Design comp 


The web design process
The typical web design process may be comprised of several stages, including any of the following:


1. Brief provides a statement of technical, design, and idea goals for the web project.


2. Research involves a range of investigative activities including a review of related web designs, analysis of 
competitor sites, user flows, personas, market analysis, use cases, and more.


3. Brainstorming is a conceptualizing stage based on the brief and research stages in which many ideas are 
generated in a short amount of time. 


4. Creative solution follows the brainstorming phase in which briefs, research, and ideas are combined to 
create a clear design direction. This stage can include technical specifications, information architecture 
diagrams, functioning wireframes, and design comps. This stage is often iterative, a repeating process in 
which problems are solved, designs are presented to clients for feedback, website functionality is developed 
and tested, and revisions are made.


5. Production fully realizes the web project. Design comps are finalized and integrated into the wireframe 
prototype, and the web project is scaled up to full production. 


As you can see, the design comp is an important piece of the web design process from the creative solution right to 
the production stage. 


Consider the following questions as you plan and build your design comp for a web project.
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Organizing content


How you organize content on a page highlights important features and elements of your web project. Important 
elements might be higher in the page, larger in size, or in stronger colors. Include rough descriptions of navigation, 
copy layout, graphic allocation, key headers, and other elements that appear on a screen. Identifying common 
structures between pages helps visitors understand they are in the same site as they navigate from page to page.


• Will your page banner be on each page? If yes, is it in the same place? Is it the same size?


• What font will you use for titles or headings on your content pages?


• What color will you use for titles or headings on your content pages?


• What font will you use for descriptions on your content pages?


• What color will you use for descriptions?


Navigation


For visitors of your website or application to understand the content, you must provide clear navigation. Visitors need 
to know where they are in a site, where they need to go, and how to get back to where they came from. Having a 
consistent layout grid helps orient visitors and keeps them from feeling lost. Using consistent buttons, links, and 
graphics on each page maintains a sense of place. As visitors move from page to page, provide familiar visual cues 
and navigational aids.


Here are some questions to answer:


• Where will you place the navigation bar on the page?


• What content will be on the navigation bar?


• Will the navigation bar be on every page?


• How will your navigation bar help visitors know which page they are on?


Creating a design comp with Adobe Fireworks CS6 
The following steps describe a typical proces to follow when using Fireworks to create a design comp. The design 
comp process described here uses previously-prepared files including a background image, logo, text, and a 
photographic image.


To create the canvas and import files:


1. Start Fireworks and create a new document using the 
dimensions for your web project. 


2. With Layer 1 selected, choose File > Import.


The Import dialog box (Windows) or Import File dialog 
box (Mac OS) opens.


3. Navigate to a background image you want to use, and 
click Import (Windows) or Open (Mac OS).


4. Click in the upper-left corner of the canvas to place the 
imported background at that location. 


The background image is placed on the canvas.
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5. In the Properties panel, confirm that the X and Y 
coordinates are both set to 0 (Figure 2).


6. Choose File > Import.


The Import dialog box (Windows) or Import File dialog 
box (Mac OS) opens.


7. Navigate to a logo file and click Import (Windows) or 
Open (Mac OS).


The Import Page dialog box opens (Figure 3).  


A single Fireworks PNG file can contain multiple pages. 
When you insert a PNG file, or page, containing objects 
from the master layer, the master page is converted to an 
ordinary layer, and imported. 


8. Click the Import button (Windows) or Open button (Mac 
OS) in the Import Page dialog box.


9. On the canvas, click near the top edge and to the right of 
the upper-left corner to place the imported logo at that 
location.


The logo image is placed on the canvas. 


10. Choose File > Import.


The Import dialog box (Windows) or Import File dialog 
box (Mac OS) opens.


11. Navigate to a photograph file and click Import 
(Windows) or Open (Mac OS).


12. On the canvas, click in the main content area to place the 
imported logo at that location.


The photograph is placed on the canvas. 


13. Select File > Save As and save the file as a PNG.


Figure 2 Properties panel, bitmap mode


Figure 3 Import Page dialog box


To use drawing tools, fills, and the alignment panel:


1. From the Tools panel, select the Rectangle tool.


2. In the Properties panel, click the Gradient Fill button.


The Edit Gradient pop-up window opens (Figure 4). 


3. Set the gradient type to Linear, if not already selected.


Figure 4 Properties panel, Edit Gradient window


X and Y 


Gradient Fill Color swatches


Gradient type


Solid Fill
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4. Click the color swatch on the left and select a dark-gray 
color such as HEX value #222222 (Figure 5) .


5. Click the color swatch on the right and select a slightly 
lighter gray color such as HEX value #333333.


6. Click the Gradient Fill button again to close the Edit 
Gradient window.


7. Drag to draw a rectangle shape at the bottom of the 
canvas.


This rectangle will become the web page footer.


8. Choose Select > Deselect.


9. From the Tools panel, select the Rounded Rectangle tool.


10. In the Properties panel, click the Solid Fill button and 
choose a light-gray color such as HEX value #CCCCCC.


Note: You could choose instead to add a gradient fill to 
the rounded rectangle shape.


11. Click the Solid Fill button again to close the color pop-up 
window.


12. In the Properties panel, set Stroke Color to white (HEX 
value #FFFFFF), and confirm Tip Size is 1, and Stroke 
Category is 1-Pixel Soft (Figure 6).


13. Make sure Smart Guides are visible and active. If not, 
select View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.


14. Drag on the canvas to draw a rounded rectangle suitable 
for use as a button.


15. Select the rounded rectangle shape.


16. Select Edit > Duplicate three times to create a total of 
four buttons.


As you repeat the command, duplicates of the selected 
object appear in a cascading arrangement from the 
original. Duplicates appear 10 pixels lower and 10 pixels 
to the right of the previous duplicate. The most recently 
duplicated object becomes the selected object.


17. Select the Pointer tool and drag a rounded rectangle over 
to the right until the Smart Guides appear along the top, 
and right edge of the object (Figure 7).


18. Arrange the remaining shapes in a row between the first 
and the last rounded rectangle. 


Don’t worry about the spacing, you’ll take care of that in 
the next few steps.


19. Choose Window > Align to open the Align panel 
(Figure 9).


20. Shift-click the four rounded rectangle shapes, either on 
the canvas, or in the Layers panel.


Figure 5 Color pop-up window


Figure 6 Properties panel, shape mode


Figure 7 Aligning objects using Smart Guides


Figure 8 The Align panel


Stroke Color Tip Size Stroke Category


Align 
Vertical 
Center


Space 
Evenly 
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21. In the Align panel, click the Align Vertical Center button 
and the Space Evenly Horizontally button.


The rounded rectangle shapes are vertically aligned and 
spaced evenly on the canvas.


22. Select File > Save.


To use text tools:


1. Select the Text tool from the Tools panel.


Text in a Fireworks document appears inside a text block 
(a rectangle with handles).


2. Set text characteristics in the Properties panel (Figure 9):


• Font Family: Georgia


• Font Style: Regular


• Font Size: 46


• Font Color: HEX value #ECECEC


3. Click on the canvas just below the logo to create an auto-
sizing text block.


An auto-sizing text block expands horizontally as you 
type and shrinks when you remove text. Auto-sizing text 
blocks are created by default when you click on the 
canvas with the Text tool and start typing.


4. Type Shop. 


5. Choose Select > Deselect.


6. With the Text tool still selected, change Font Family to 
Verdana, and Text Size to 16 and confirm the text is left 
aligned.


7. Drag on the canvas between the Shop title and the 
photograph to create a fixed-width text block 
(Figure 10).


A fixed-width text block allows you to control the width 
of wrapped text. Fixed-width text blocks are created by 
default when you drag to draw a text block using the Text 
tool. 


8. Add placeholder text to simulate two or three paragraphs 
of text.


9. To move the text block, drag it with the Pointer tool. To 
resize it, drag a resize handle.


10. Choose Select > Deselect.


11. Select the Text tool, and change Font Family to Georgia, 
Text Size to 21, and Text Color to dark gray (HEX value 
#222222).


Figure 9 Properties panel, text mode


Figure 10 Drag with Text tool to create a fixed-
width text block


Font Family


Font Style


Font Color


Alignment


Font Size
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12. Click on the first rounded rectangle to create an auto-
sizing text block.


13. Type Shop.


14. Select the Pointer tool and drag the text block until the 
horizontal and vertical Smart Guides appear so that the 
text is centered over the rounded rectangle (Figure 11).


15. Shift-click the text block and the rounded rectangle and 
choose Modify > Group.


16. Repeat steps 12 to 15 to create three more navigation 
buttons for Designer, Our Shop, and Blog.


17. Create a text block at the bottom of the page, over the 
dark-gray footer rectangle and add some footer text.


18. Select File > Save.


Figure 11 Use Smart Guides to align text and 
objects
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		• Will your page banner be on each page? If yes, is it in the same place? Is it the same size?

		• What font will you use for titles or headings on your content pages?

		• What color will you use for titles or headings on your content pages?

		• What font will you use for descriptions on your content pages?

		• What color will you use for descriptions?





		Navigation

		For visitors of your website or application to understand the content, you must provide clear navigation. Visitors need to know where they are in a site, where they need to go, and how to get back to where they came from. Having a consistent layout g...

		Here are some questions to answer:

		• Where will you place the navigation bar on the page?

		• What content will be on the navigation bar?

		• Will the navigation bar be on every page?

		• How will your navigation bar help visitors know which page they are on?







		Creating a design comp with Adobe Fireworks CS6

		The following steps describe a typical proces to follow when using Fireworks to create a design comp. The design comp process described here uses previously-prepared files including a background image, logo, text, and a photographic image.

		To create the canvas and import files:

		Figure 2 Properties panel, bitmap mode

		Figure 3 Import Page dialog box



		To use drawing tools, fills, and the alignment panel:

		Figure 4 Properties panel, Edit Gradient window

		Figure 5 Color pop-up window

		Figure 6 Properties panel, shape mode

		Figure 7 Aligning objects using Smart Guides

		Figure 8 The Align panel



		To use text tools:

		Figure 9 Properties panel, text mode

		Figure 10 Drag with Text tool to create a fixed- width text block

		Figure 11 Use Smart Guides to align text and objects
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Writing for the web
Writing for the web is very different from other writing. Users read information online differently than information in 
print. Online readers coming to a site after an online search often don’t know if a website will meet their needs. If 
they do not find the information they are looking for, they will deem the site of little value, no matter how well it is 
designed or how easy to use. You can create clear, usable content by writing for varying levels of reader interest. Your 
goal should be to give all readers their desired level of information as quickly as possible. 


The following tips apply to writing content for web pages. Be sure to take these best practices into account when 
writing content for your client website.  


Online reading behavior


Studies have discovered the following bahaviors among online users:


• They judge websites in a fraction of a second.


• They scan content, hunting for the information they’re after. They don’t read word-for-word.


• They read more slowly from screens than from print. 


• Distractions and competition from online messaging, Facebook, and so on make it hard to keep users’ attention. 


• Because so much information is available online, users determine quickly if content is worth reading. 


Knowing your audience


To write effectively, you need to know your audience:


• Determine a range of interest levels among your audience and try to write for that range of interest (none to 
some, little to strong, only strong, and so on).


• Create a user persona for each kind of user to help you determine how to get their attention. 


• Write as if you are speaking to your audience in person.


• Consider users of various reading levels. 


• Make sure all content is accessible.


Writing guidelines


Guidelines for effective communication:


• Use clear, simple, familiar language. 


• Avoid jargon, acronyms, and abbreviations.


• Use an active and objective voice.


• Be direct and concise, getting quickly important points.


• Put the conclusion first so readers know what to expect from the content.


Chunk content


• Chunk means a manageable bit—a small piece of information a user can easily find and understand. 


• Bold important words or phrases.


• Use lists.


• Keep content short.
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• Use fragments or phrases instead of prose style. If you can cut a word, cut it.


Organizing page content


Titles


The title is the first piece of information a user scans. Make it clear, inviting, and meaningful.


Headings and subheadings


• Headings should be short, direct, and powerful.


• Subheadings should be descriptive, so users easily learn what each section is about. Use subheadings frequently 
(every few paragraphs) to keep user moving through content in easy chunks.


Sentences and paragraphs


• Shorter is better.


• Sentences should be no longer than about 20 words. 


• Each sentence should be limited to one idea. 


• Paragraphs should have no more than about 6 sentences.


• Each paragraph should be limited to one or two ideas.


Lists


• Lists are easy to scan because content is vertical. 


• Content presented in lists is usually more succinct.


Links


• Link to related information.


• Use descriptive link text so users know where they are going.


Design elements


• Use callouts, bold, and italics to make text easier to scan.


• Substitute pictures and other visual elements for text when appropriate.


Writing for mobile devices


• Reading on a mobile device is more difficult than on a desktop computer.


• When writing for mobile users, focus attention on the essential content.


• Defer secondary content to secondary pages.


• Writing for mobile readers requires even harsher editing than writing for the web. Mobile use implies less 
patience for filler copy.


• When in doubt, leave it out. 


Best practices


• Analyze and emulate great web writing. 


• Provide accurate descriptions and keywords for search engines.


• Use web writing guidelines when repurposing print documents for the web.


• Create a style guide.
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• Test your content: 


• Make sure all links work and are relevant. 


• Make sure all titles and summaries provide information about the contents of the page. 


• Read content from the view of your defined personas and make sure all users will find information quickly 
and accurately. 
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Project 6 worksheet

Digital narrative analysis and scripting


Narrative description


Answer the following questions to help you set up your narrative.


What type of narrative is it? ______________________________________________________________________


Who is the primary audience? _____________________________________________________________________


What is the message of the narrative? (Summarize in one sentence.) ______________________________________


How does the narrative enhance the overall goals of the site?  ___________________________________________


Write a narrative that stays within the following criteria:


• The audio recording for the narrative does not exceed 45 seconds.


• The length of the movie does not exceed one minute.


• The number of written and spoken words is fewer than 50.


• The narrative contains at least one transition effect.


• The narrative contains at least one filmmaking technique.


• The narrative contains no more than five different filmmaking and transition techniques.
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Digital Design Project 3 worksheet

File management


Student name:_________________________________________________ Date: ________________________


Part I


As you create a file management strategy, describe the method you use by answering the following questions:


Questions


How are you categorizing the files?


How does your file organization help you find particular 
files?


How easy to understand are your file and folder names?


File management notes


--------------------------------------------------------------------
-                                                                                            

© 2012 Adobe Systems Incorporated File management 1







Project 3 worksheet Digital Design


2


Part II


Write the name of the file you are searching for, its content, and the location in which you found it. Then answer the 
questions that follow.


Example:


Filename: carrot.gif


File content: science


File location: john_doe/science/images/carrot.gif


Filename: ____________________________________


File content: __________________________________


File location: _________________________________


Was it difficult to find this file? Why or why not?


Was the file located in a folder you expected? If not, 
where did you expect the file to be located?


Did the names of the folders and files make sense to 
you? Why or why not?


Filename: ____________________________________


File content: __________________________________


File location: __________________________________


Was it difficult to find this file? Why or why not?


Was the file located in a folder you expected? If not, 
where did you expect the file to be located?


Did the names of the folders and files make sense to 
you? Why or why not?

File management © 2012 Adobe Systems Incorporated
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How to deploy for multiple screens
Ethan Marcotte, a developer in Boston, coined the phrase responsive design to describe a website that adapts to the 
size of the viewer’s screen. A demonstration site built by Ethan Marcotte illustrates this concept; visit http://
www.alistapart.com/d/responsive-web-design/ex/ex-site-FINAL.html to experience responsive design (Figure 1). 
Notice that as you narrow the width of the browser window, the text reflows and the images get slightly smaller. Once 
the browser window is less than 1300 pixels wide, the images stack into two rows but continue to become smaller as 
the window narrows. When the browser narrows to 600 pixels, the content again reflows. The navigation bar moves 
to the top of the page and the image behind the logo disappears. This is all being done through percentage-based 
widths for content known as a flexible grid. For viewers, it means the content will always be properly formatted to fit 
the screens or devices on which they are viewing the it.


Figure 1 A responsive design website at three browser widths


Adobe Dreamweaver CS6 streamlines the task of building responsive design websites for multiple screens with its 
integrated Fluid Grid Layouts and CSS media queries. Dreamweaver uses Fluid Grid Layouts to create designs that 
scale themselves to multiple screen sizes and devices. CSS3 Media Queries is a more advanced option used to define 
custom CSS files for mobile, tablet, and desktop devices, permitting device-specific user interfaces to be built on the 
same HTML markup.  


Fluid Grid Layouts
Fluid Grid Layouts provides for flexible content resizing within a browser window. The browser on a device checks 
the embedded media query and uses the corresponding CSS code to display the web page. You can create a new 
document that works across multiple screens by using the Fluid Grid Layouts option (Figure 2). 


Figure 2 New Document dialog box, Fluid Grid Layout category
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To create a Fluid Grid Layout:


1. Start Dreamweaver. 


2. Select File > New Fluid Grid Layout.


The New Document dialog box appears (Figure 2).


3. In the Mobile, Tablet, and Desktop text boxes, set the 
number of grids to 2, 3, and 4, respectively.


4. Under Mobile, set the % Of Column Width to 10.


This number defines the gutter or space between each 
pair of columns in the grid.


5. Set the overall width percentage of the Mobile, Tablet, 
and Desktop layouts to 100, 100, and 88, respectively.


The grid widths are 100% for the mobile phone and tablet 
layouts. On the desktop, the width of the grid is 88%, 
which means that it will fill out 88% of the browser 
window and center the content, with equal space (6%) on 
each side.


6. Click Create. 


The Save Style Sheet File As dialog box appears 
(Figure 3).


7. Save the CSS file as grids.css in your site root folder.


The layout opens in Design view.


8. Select File > Save and save the document as grids.html 
in your site root folder.


The Copy Dependent Files dialog box appears. The files 
boilerplate.css and respond.min.js work together to  
normalize and adjust the content to display across many 
devices.


9. Click Copy in the Copy Dependent Files dialog box.


The layout is currently set to Mobile. In turn, click the 
Tablet icon and the Desktop icon in the Status bar at the 
bottom of the Document window (Figure 5) to compare 
the Fluid Grid Layouts.


10. Click the Mobile icon to switch back to the two-column 
Mobile layout.


It is a best practice in responsive design to focus on 
“mobile first,” because this format forces you to 
concentrate on content first, visual design second. 


Notice that one block of content is already in place at the 
top of the layout (Figure 6).


Figure 3 Save Style Sheets File As dialog box


Figure 4 Copy Dependant Files dialog box


Figure 5 Status bar


Figure 6 Fluid Grid Layout, Mobile layout


Mobile icon Tablet icon Desktop icon


Layout div 
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11. Open the Properties panel (Window > Properties).


12. In Design view, click the outline of the layout div 
(Figure 6) to select it.


The Div ID information appears in the Properties panel 
(Figure 7).


13. Enter header in the Div ID name text box.


14. Open the Insert panel (Window > Insert), if it is not 
already open.


15. Select Layout from the Category pop-up menu.


16. Click the Insert Fluid Grid Layout Div Tag button 
(Figure 8).


The Insert Fluid Grid Layout Div Tag dialog box appears 
(Figure 9).


17. Enter nav in the ID text box.


The option Start New Row is selected by default. This 
tells Dreamweaver and the browser to make this content 
fill the entire width of the current grid layout. Deselecting 
this option allows the element to float beside another 
element on the page. 


18. Click OK to insert the div tag into the page.


A Fluid Grid Layout div is nothing more than an HTML 
<div> element with a unique ID assigned to it.


19. Click the Insert Fluid Grid Layout Div Tag button to 
insert another Fluid Grid Layout div into the page and 
rename it content. 


You now have three stacked divs (labeled Header, Nav, 
and Content) across two columns in the Mobile layout 
(Figure 10).


20. Click the Tablet icon (Figure 5) to switch to the Tablet 
layout.


21. In Design view, click to select the Nav div.


22. Drag the right handle to narrow the width of the div to fill 
only the left column (Figure 11).


23. Click to select the Content div, and resize it to span two 
columns. 


Figure 7 Properties panel


Figure 8 Insert panel, Layout category


Figure 9 Insert Fluid Grid Layout Div Tag dialog 
box


Figure 10 Three divs across two columns


Figure 11 Resize div in Design view


Div ID name text box

© 2012 Adobe Systems Incorporated How to deploy for multiple screens 3







Project 3 guide Adobe Dreamweaver CS6


4


24. Click the Move Up A Row button on the right side of the Content div (Figure 12).


The Content div moves up a row, beside the Nav div (Figure 13).


Figure 12 Divs in Tablet layout, before move


Figure 13 Divs in Tablet layout, after move


25. Click the Desktop icon (Figure 5) at the bottom of the Document window to switch to the Desktop layout.


26. Arrange the divs so the Nav div spans one column and the Content div spans the remaining three columns in the 
four-column Desktop layout (Figure 14). 


You may need to scroll to see the right ends of the divs.


Figure 14 Divs in Desktop layout


27. Click grid.css in the Related Files bar at the top of the 
document window (Figure 15).


Split view opens, showing grids.css in Code view.


28. Scroll in Code view to locate the beginnings of the 
Mobile, Tablet, and Desktop layout code sections (at 
about lines 29, 58, and 89, respectively) (Figure 16).


Each time you add a Fluid Grid Layout div element to the 
page, a rule is created in the CSS for each device. Notice 
the “@media” declarations, which indicate the beginning 
of a media query. The Tablet media query, appears at 
about line 60, and it only applies when a screen has a 
width of at least 481px–in other words, most mobile 
phones would ignore these rules because their screens are 
not that wide.


29. Select File > Save All to save the document and the 
dependent files.


Figure 15 Related Files bar


Figure 16 CSS code view detail


Move Up A Row
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Preview layout
Once you’ve established a suitable Fluid Grid Layout for your content across all of the devices, you can add content 
and preview it by using the Multiscreen Preview function in Dreamweaver (Figure 17).


Figure 17 Multiscreen Preview panel


To preview the Fluid Grid Layout:


1. Use the Insert panel to add an assortment of graphics, 
text, and links to the grid.html file. You can fine-tune the 
layout of page elements by using the CSS panel.


2. Toggle among the Mobile, Tablet, and Desktop layouts to 
compare them (Figure 18). 


Figure 18 Content in Mobile layout
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3. Click the Multiscreen button in the Control panel at the 
top of the Document window (Figure 19).


The Multiscreen Preview panel opens (Figure 17).


Multiscreen Preview supports the following screen types:


• Phone (default screen size: 320 x 300 pixels)


• Tablet (default screen size: 768 x 300 pixels)


• Desktop (default screen width: 1126 pixels)


Note: If you know the dimensions of any other devices 
you want to target, you can specify additional 
orientations and styles for different devices by using the 
Design/Live View Sizes menu (Figure 20). For example, 
you can create a screen dimension of 480 x 272 pixels for 
a Sony PSP device.


The phone, tablet, and desktop dimensions used for 
previewing are set to default sizes. However, you can 
change the default sizes by clicking the Viewport Sizes 
button in the Multiscreen Preview panel.


Note: Do not use the Multiscreen Preview panel as a 
browser. It is not intended to display dynamic media such 
as movies and audio clips.


Figure 19 Control panel


Figure 20 Design/Live View Sizes menu


Design/Live View Sizes menu
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CSS Media Queries
CSS media queries extends the concept of Fluid Grid Layouts. Advanced users might consider using CSS3 media 
queries to target designs for multiple devices by specifying a different CSS file for each unique device.


You can access the Media Queries dialog box (Figure 21) by using the Design/Live View Sizes menu (Figure 20). 


Note: The Media Query Manager is not currently compatible with Fluid Grid Layouts.


Figure 21 Media Queries dialog box


For more detailed information about media queries, please see Dreamweaver Help.
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How to organize content 
Adobe Flash Professional CS6 documents can involve hundreds of different elements. Organizing these will make 
developing Flash content much easier.


Organize the library
You can create folders to organize your files in the library of a Flash document.


To create folders in the library:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


By default, the Library panel is open on the right-side of 
the workspace (Figure 1). If the Library panel is not 
open, select Window > Library to open it.


2. To create a folder in the library, choose New Folder in the 
Library panel menu or click the New Folder button 
(Figure 1).


The new folder is added to the library.


Folders are represented by file folder icons.


3. Name the folder and drag files into the folder.


You can even store folders within other folders.


4. Double-click a folder icon to see or hide its contents.


You can also see or hide the contents of a folder by 
clicking the disclosure triangle beside the folder.


Figure 1 Library panel


New Folder button
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Organize layers in the Timeline panel
Organize your layers by using descriptive layer names, putting layers in a logical order, and creating folders. Use 
separate layers or folders for sound files, ActionScript, frame labels, and frame comments. This helps you find these 
items quickly to edit them.


To organize layers:


1. To change the name of a layer, double-click the name and 
enter a new name.


2. You can change the order of layers by dragging a layer up 
or down in the stack.


Note: It is recommended that you place ActionScript in a 
layer named actions and labels in a layer named labels, 
typically at the top of the layer stack. Background layers 
go at the bottom of the stack.


3. To create a layer folder, click the New Folder button at 
the bottom of the Timeline panel (Figure 2) and give the 
folder a new name.


4. Drag layers into folders to keep them organized.


Figure 2 Timeline panel


Label keyframes
You can label certain frames to indicate when changes occur on the timeline.


To label a keyframe:


1. Select a frame you want to label.


2. In the Properties panel, enter the label in the Name text 
box (Figure 3).


The label appears on the timeline (Figure 4).


Note: Avoid long names to minimize file size and also to 
keep the label from spanning too many frames.


Figure 3 Name text box


Figure 4 Frame labels in the timeline


New Folder button


Frame label
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Project 6


Digital narratives
Timing: 20 to 28 hours


Project overview


In this project, students use Adobe Flash Professional CS6 to create a digital narrative for an existing 
website about a school club or sports team. Students discover how to use techniques in Flash to create 
various film effects and then apply those techniques to building a narrative. Students learn how rich media 
and animation they can create with Flash improves digital communication. They develop Flash skills 
through projects focused on a variety of filmmaking techniques and then apply those skills to planning and 
building a digital narrative.


The focus of this project is using interaction and animation for communication, taking a deeper look at 
audience and audience needs, and using Flash to enhance a visitor’s experience by using digital narratives.


Student product: Digital narrative


Note: Portions of the Digital narratives project align to the Adobe Certified Associate, Rich Media 
Communication objectives. Within the instruction steps and technical guides, the specific learning 
objectives for the exam are referenced with the following format: 1.1  


Project objectives


At the completion of the project, students will have developed the following skills:


Project management skills


• Defining purpose, goal, and audience


• Assigning team roles and tasks


• Defining and prioritizing tasks


• Following a project plan 


• Understanding roles and assigning roles and 
tasks


• Determining functional requirements of 
application


• Designing for a client


• Following up and following through on roles


Design skills


• Designing a custom experience


• Designing for audience(s)


• Providing multiple design ideas


• Applying principles of graphic design


• Developing thorough and accurate storyboards


• Designing for accessibility


• Creating designs that meet client requirements


• Synthesizing and displaying complex 
information


• Making sketches for interactive experiences


Research and communication skills


• Researching examples of rich media


• Understanding the role and purpose of digital 
narratives


• Analyzing effective use of digital narratives


• Creating a project plan


• Writing scripts for a digital narrative


• Conducting a review and redesign cycle


• Communicating with peers 


• Researching audience and appropriate sites


• Using Flash effectively


• Connecting goals with user interaction
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Technical skills


Flash


• Importing and compressing audio


• Optimizing file size


• Producing Flash video


• Working with text and text effects


• Using drawing tools


• Organizing layers and libraries


• Working with layers


• Working with bitmaps


• Publishing and testing movies


• Using animation methods


• Creating accessible Flash content


• Saving and using motion presets


Fireworks


• Creating a wireframe


• Creating design comps


Project materials
• Adobe Flash Professional CS6 installed on all 


machines


• Adobe Fireworks CS6 installed on all machines


• Worksheet: Examples of effects


• Presentation: Web project production phases


• Guide: Principles and rules of copyright


• Worksheet: Client interview


• Worksheet: Project plan


• Worksheet: Design document


• Worksheet: Digital narrative analysis and 
scripting


• Presentation: Introduction to design principles


• Presentation: Introduction to page design 
principles


• Guide: Design principles for Flash content


• Worksheet: Narrative summary and storyboard


• Electronic file: sf_fog.fla


• Electronic file: sf_fog.swf


• Fireworks guide: How to create a wireframe


• Fireworks guide: How to create a design comp


• Flash guide: How to maintain consistency


• Flash guide: How to organize content


• Flash guide: How to optimize Flash content


• Flash guide: How to import sound


• Flash guide: How to import images


• Flash guide: How to produce Flash video for 
the web


• Flash guide: How to apply colors and gradients


• Flash guide: How to work with text


• Flash guide: How to use filmmaking 
techniques


• Flash guide: How to create visual effects


• Flash guide: How to create transitions with 
motion tweens


• Flash guide: How to use a motion guide with a 
motion tween animation


• Electronic file: bounce_example.fla


• Electronic file: pan-zoom_example.fla


• Electronic file: fade_example.fla


• Flash guide: How to create animations


• Flash guide: How to ease tweens


• Flash guide: How to make Flash content 
accessible


• Flash guide: How to test a Flash project


• Worksheet: How to evaluate a digital narrative


• Flash guide: How to publish a Flash document


Background preparation resources
• Technical and content information


• Key terms


• ISTE NETS*S Standard for Students


• Adobe Certified Associate, Rich Media Communication objectives
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Project steps


1. Introduce students to the goals of the project:


• Learn about digital stories, narratives, and filmmaking techniques. 


• Learn and apply design principles for Flash.


• Work with and design for a client. 


• Build a home page and one or two content pages of an accessible, Flash-enabled, rich media 
website that tells a story or narrative of the client.


• Publish a Flash website.


2. Discuss how Flash allows designers and developers to deliver filmmaking and traditional animation 
techniques over the web by offering media-rich effects and animation with support for video and audio 


content, smaller file sizes, and easier authoring.1.2 Questions to guide the discussion around these 
effects might include the following:


• How do filmmaking and animation techniques enhance a website?


• Why might the developer have used Flash instead of HTML?


3. Introduce the concept of digital stories and narratives. Explain that a digital narrative is usually a short 
narrative created by combining still and moving images and music or other sounds. You might look at 
several types of online narratives: documentaries, personal opinions, cartoons, and animations. You 
might also look at non-web narratives such as commercials. As you view the examples, focus on how 
digital narratives usually have one or two types of actions: the content moves or movement within the 
content and instances when users must perform an action to access the content. Some places to find 
online narratives:


• Computer History Museum’s website tells the story of the 2000-year history of computing in both 
linear and nonlinear ways: www.computerhistory.org/revolution/


• Waterlife is a preview for a documentary film similar to the cinematography and storytelling from 
the film. Especially interesting are the navigations, which mimic the motion of water: 
http://waterlife.nfb.ca/


• We Choose The Moon was designed to celebrate the fortieth anniversary of the Apollo 11 Lunar 
landing by developing an interactive re-creation of the event: www.wechoosethemoon.org/


• Arizona State University and the Institute of Human Origins created this documentary: 
www.becominghuman.org/node/interactive-documentary


4. Ask students to analyze and discuss each narrative you present. You might structure their analysis with 
the following questions:


• What type of narrative is it (such as documentary, cartoon, or personal opinion)? Describe how the 
words and visuals are used to make it this type of narrative.


• What is the primary audience? Describe how the words and visuals target this specific audience.1.1


• How relevant is the narrative content to the overall purpose of the site? 1.1, 1.2


• What is the message of the narrative? (Summarize in one sentence.)


• How long is the narrative piece? Does it seem too long for the amount of visual action? Does it 
seem too short? Why or why not? 


• How does the narrative meet the site purpose, address the target audience, and enhance the overall 
goals of the site? 1.1, 1.2
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5. As you present the example narratives, point out some of the following: 2.1


• Including effective audio and video 


• Showing continuity and transitions


• Indicating multiple-levels of information in transitions


• Illustrating change over time


• Getting layers of information from one area of the screen


• Enriching graphics


• Visualizing three-dimensional structures


• Attracting attention


• Creating interaction


6. Finally, discuss the sites the students viewed that used filmmaking techniques such as transition and 
visual effects. Explain that certain filmmaking techniques can be incorporated into classic, motion, 
shape, and text tweens to enhance the narrative capabilities of Flash. 4.10 Discuss the following as a 
class; then ask pairs of students to review the sites you showed and complete the Examples of effects 
worksheet to understand how filmmaking techniques enhance websites:


• Pan, tilt, and zoom effect: Moving the camera horizontally across a scene is called a pan. Moving 
the camera up or down across a scene is called a tilt. Moving the camera away from or toward a 
subject in a scene is called a zoom.


• Camera angles: The rule of thirds and adjusting the viewing angle can help emphasize a certain 
aspect of the subject.


• Cross fades: A transitional effect for moving from one image to another. With this technique, one 
image appears to fade in while another fades out. Another version of the cross fade is a color fade: 
dissolving between multiple color instances of the same object.


• Bounce effect: A moving object rebounds before stopping. This technique grabs attention and can 
focus the visitor on an area of the screen.


• Transitions: Multiple techniques (such as flipping, fading, and color fading) used to move from 
one section of a digital narrative to another. 


Worksheet: Examples of effects


Defining a digital narrative
(Suggested time: 100–150 minutes)


7. Introduce your students to the design and development process, and briefly discuss and define the 
phases of a web project: 


• Defining the project 


• Structuring the narrative 


• Designing the narrative 


• Building and testing the narrative


• Publishing or launching the narrative


Presentation: Web product production phases 1.5


Note: Be sure to discuss common problems and issues in project management, such as scope creep 
(when the project gets bigger than originally planned) and overly ambitious design plans within time 
constraints.1.5
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8. Have a class discussion to identify criteria for deciding if content should be implemented by using rich 


media.2.1, 4.1 Discuss using Flash video and how to introduce it into the project. Review copyright 
considerations when using video and images in the project.


Guide: Principles and rules of copyright 1.4


9. Break students into teams and discuss ways to select an element for which they might create a 
narrative. Explain that they will look at their client’s site and identify two or three ways they can 
incorporate a digital narrative. As they conduct their review, ask them to take notes summarizing the 
client’s audience, purpose, and goals. 1.1 Additionally, suggest that they find sections of a website for 
which a narrative would enhance the visitor’s experience on that site, such as:


• Giving the history of a client


• Presenting an opinion on a specific issue related to the site


• Promoting an event or product described on the site


• Providing a visual explanation of a particularly complex topic mentioned on the site


• Entertaining site visitors as they look for information on the site


• Educating or training site visitors


Note: You may wish to have a selection of clients who work well with this exercise. Students will 
benefit from having clients with websites where a digital narrative could be included in a way that 
aligns with the design principles for Flash content.


10. Allow students time to come up with two or three ideas from the previous list with rationales for each 


idea. Ask them to prepare their ideas so they can present them to their clients.1.6


11. Ask students to interview their clients, specifically asking them how they would like to use rich media. 
Remind students that in addition to interviewing, they will present their digital narrative ideas and 
rationales and agree with the client on the type of digital narrative to create. 


Worksheet: Client interview 1.6


Structuring a digital narrative
(Suggested time: 50–100 minutes)


12. Once the client interview has been completed and they have their approved approach, ask students to 
create a project plan and design a solution document. Explain to students that there is a section of the 
design solution document for flowcharts but they will fill in that part when they learn about flowcharts 
later in the project.


Worksheet: Project plan 1.5


Worksheet: Design document 1.5, 2.4


13. Ask students to write a short narrative for their client websites, indicating the goals, audience, and 
message of the narrative, the length of time it will take to view the narrative, and the delivery 
requirements for the narrative (such as download speed, screen resolution, and Internet connection 


speed).4.1 You might present the following criteria to help contain the project:


• The audio recording for the narrative does not exceed 45 seconds.


• The length of the movie does not exceed one minute.
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• The number of written and spoken words is not more than 50.


• The narrative contains at least one transition effect.


• The narrative contains at least one filmmaking technique.


• The narrative contains no more than five different filmmaking and transition techniques.


You might also suggest that students consider using one of the techniques they learned in Project 5, 
such as creating masks or path animations.


Worksheet: Digital narrative analysis and scripting


Designing a digital narrative
(Suggested time: 450–550 minutes)


14. Review design principles and page design principles and introduce design principles specifically for 
creating Flash content, specifically how the user and technical requirements can impact a design. 


Presentation: Introduction to design principles 2.2


Presentation: Introduction to page design principles 2.2


Guide: Design principles for Flash content 1.1, 1.2, 4.1


15. Introduce animation storyboards and flowcharts by showing students examples of storyboards used to 
create cartoons, films, or other narratives. 2.4 You might highlight the following ideas:


• Flowcharts describe the overall information architecture or flow of the movie, and storyboards are 
detailed versions of the flowchart.


• Storyboards do not need great drawings, just rough sketches to visually represent the scenes.


• Although detailed drawings are not necessary in these storyboards, they all contain detailed 
descriptions of animations, interactions (such as dialog boxes), and sounds.


• Flash storyboards are similar to cartoon animation storyboards but give details about text, images 
(drawn and imported), video, audio, and effects (such as fading, color changing, rotation, and 
zooming).


• Designers make storyboards for each section of a narrative. Sections occur when there is a logical 
break or transition in the script (when a new image is displayed or an action happens). Often you 
create a storyboard for another designer or programmer; keep this in mind when you decide what 
level of detail to include in your instructions.


16. Go through the narrative summary and storyboard elements while highlighting and explaining these 
elements in a completed summary and storyboard. (You could use sf_fog.swf to show students a 
produced version of the narrative that is illustrated in the Narrative summary and storyboard 
worksheet.)


Narrative summary elements:


• Flowchart


• General movie settings


◦ Main project folder, together with image, video, and audio subfolders


◦ Frame rate, background color, and movie dimensions


Storyboard elements:







© 2012 Adobe Systems Incorporated Digital narratives 7


• Sketches of each section, indicating objects or images and their placement on the Stage at the 
beginning of the section (initial state) and at the end of the section (final state)


• Section descriptions for both the initial state and the final state of the section


◦ Displayed text


◦ Description of images drawn in Flash


◦ Filenames for imported images, video clips, and sounds


◦ Description of imported images


◦ Text of any voice recording


◦ Any other general color or setting descriptions for the section, such as background, 
transparency, or object size


• Transition description


◦ Description of any effects (such as fading, movement, or color change) that can be created 
with text effects, motion tweens, classic tweens, or shape tweens


Worksheet: Narrative summary and storyboard 2.4


Electronic file: sf_fog.fla


Electronic file: sf_fog.swf


17. Ask students to create digital narrative flowcharts (reminding them to use their design documents) and 


storyboards based on their scripts, using the worksheet.2.4 Some items for students to keep in mind as 
they build their flowcharts and storyboards include the following:


• The narrative look and feel should be consistent with the site into which it will be placed.2.2


• The narrative should exemplify effective design principles.2.2


• Elements included in the narrative should be accessible. Discuss why accessibility is important to 
website sponsors as well as site visitors. Identify elements of a SWF file that can be read by screen 
readers.1.3, 2.3


• Text should be formatted to enhance readability. Discuss minimum font sizes, use of screen fonts, 
when to use serif and sans serif fonts, use of font color, use of alignment and text placement, line 
spacing, and indentation.2.3


• The delivery requirements should influence the rich media elements related to the narrative 
(colors, Stage size, accessibility features, file size, use of audio or video).4.1


18. Using their narratives, flowcharts, and storyboards, ask students to create wireframes and design 
comps of the various screens of their digital narratives. You can give the students the choice of hand-
drawing them or producing them in Fireworks.


Fireworks guide: How to create a wireframe


Fireworks guide: How to create a design comp


19. Ask students to prepare a presentation for the client showcasing their narrative summary and 
storyboard, wireframes, and design comps. Remind them to take notes of their client meeting, 
especially requested changes. Ask each team to get approval for color and font samples, layout, and 


navigation designs. The presentation could include the following:1.6


• Introduction that highlights how the narrative meets the site’s goals and audience


• Narrative summary and storyboard
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• Wireframes and design comps of the home page and content pages


• Question-and-answer session in which the client gives feedback


20. Ask students to make changes in the design document that reflect the understanding reached with the 
client. 


Building a digital narrative
(Suggested time: 400–500 minutes)


21. Explain they will now create a homepage and one or two content pages based on the narrative 
summary and storyboard, wireframe, and design comps. Discuss how to design rich media with 
consistency. 


Flash guide: How to maintain consistency 2.1


Flash guide: How to organize content 2.5, 3.3, 4.7, 4.10


22. Ask students to collect or develop assets for their narratives.


• Record audio if there is to be a spoken narrative.


• Gather images, sound loops, and video.


23. Before teams begin production, review optimal asset use and file management in Flash. Techniques 
include the following:


• Optimize images in Fireworks before importing them into Flash. This step reduces image file size 
before creating effects in Flash.


• Apply appropriate audio compression settings to the document.


• Name layers and organize layers into folders.


• Organize items such as buttons, graphics, movie clips, and imported images into folders in the 
Library.


• Label frames to organize sections of the document.


• Set appropriate JPEG quality when publishing.


Flash guide: How to optimize Flash content 3.8, 4.14


24. To help the teams prepare to build their digital narratives in Flash, demonstrate the following: 
importing images, importing sound, producing Flash videos for the web, the benefits of making FLV 
files for Adobe AIR. 


Flash guide: How to import sound 4.12


Flash guide: How to import images 4.3


Flash guide: How to produce Flash video for the web 3.7, 4.13


25. Introduce the Text Layout Framework (TLF) in Flash and show how students can use this robust text 
engine to work with complex text. Demonstrate some of the features for working with text, such as 
adjusting leading and tracking, applying anti-aliasing, and managing multicolumn text flow with TLF 
text. Briefly demonstrate how students can use graphic filters to create text effects.


Flash guide: How to work with text 4.4, 4.5
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Note: If students are preparing for the Rich Media Communication certification exam, take time to 
outline the extensive feature set of the Text Layout Framework. Features to explain include using 
multilingual typography, right-to-left scripts, using XML to dynamically style text, using the rich 
typographic controls (ligatures, typographic case, digit case, digit width, advanced kerning, tracking, 
leading, super- and subscript, discretionary hyphens, hypertext, and baseline shift), using threaded text 
blocks, inline graphics, support for tabs, and embedded font support.4.4


26. Refer to the sites the students viewed earlier and remind them that certain filmmaking techniques can 
be incorporated into classic, motion, shape, and text tweens to enhance the narrative capabilities of 
Flash. Discuss the differences between the classic and motion tweening methods and explain why 
classic tweening is advantageous for certain animations. Using the “I do, we do, you do” method and 
the electronic files, demonstrate the following:


• Pan, tilt, and zoom effect


• Camera angles


• Cross fades


• Bounce effect


• Transitions


• Using classic tweens to create a filmmaking technique


Flash guide: How to use filmmaking techniques 4.10


Flash guide: How to create visual effects 4.2, 4.6, 4.8


Flash guide: How to create transitions with motion tweens 3.6, 4.10


Flash guide: How to use a motion guide with a motion tween animation 4.10


Flash guide: How to create animations 3.6, 4.10


Flash guide: How to ease tweens 4.10


Electronic file: bounce_example.fla


Electronic file: pan-zoom_example.fla


Electronic file: fade_example.fla


27. Discuss the use of motion presets to save and reuse animations. Discuss the benefits of saving custom 
animations and being able to reuse them by easily applying them to objects. Demonstrate how to save 


and apply a motion preset.2.1, 4.10


28. You might highlight some technical aspects of Flash you are asking students to use when creating the 
effects:


• Frame rate and how it affects playback, timing, and published movie size 3.3


• Frame labels and the benefits of using them when transitioning to a new scene 4.10


29. Review accessibility and discuss how to make Flash content accessible. Discuss the following: 


• Importance of including accessible content in rich media elements 1.3


• Elements of a SWF that can be read by screen readers, such as alternative text on images and 
buttons 1.3, 2.3
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• Accessibility requirements when producing rich media: 1.3, 2.3


◦ Creating text equivalent for graphic elements


◦ Enabling user control over reading order of Flash content


◦ Captioning audio content


◦ Making looping elements inaccessible


◦ Allowing users to control motion


◦ Enabling keyboard access for all controls


◦ Enabling tabbing


Flash guide: How to make Flash content accessible 1.3, 2.3, 4.15


30. Allow time for your students to build their digital narratives, reminding them of the project constraints 
and the requirement to only build a home page and one or two content pages. Discuss the following 
steps as a guide to their production process:


• Set up the document.


◦ Create a new document in Flash and set document properties.3.4


◦ Import images, audio, and video.4.3, 4.12, 4.13


◦ Organize the Library.2.5, 4.7


◦ Save the document file. 


• Build the narrative. (These steps are not sequential but provide a checklist of tasks to complete, as 
indicated on the storyboard.)


◦ Create new assets, such as drawings and text. Format text to enhance readability. 2.3, 4.2


◦ Convert objects to symbols as appropriate. 4.6


◦ Create layers for different elements and organize the layers into folders. (Usually a good idea 
is to get all elements into the Flash document and then go back and animate them.) 3.3


◦ Set audio compression options. 4.14


◦ Insert and label keyframes at appropriate points in the narrative, including the beginning of 
each section. 4.10


◦ Add effects. 4.10


◦ Make the content accessible. 4.15


Note: You may want to tell your students to use additional technical guides from Project 5 to help 
them build their digital narratives. 


Testing a digital narrative
(Suggested time: 100–150 minutes)


31. As teams finish their narratives, have them do the following: 


• Test and publish the document.


• Test and refine each section and transition.


• Test the completed movie.


• Check spelling.


Flash guide: How to test a Flash project 5.1
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32. Explain that teams will conduct a review and redesign of each other’s narratives that includes feedback 
on usability and accessibility. Ask students to swap narratives with another team, briefly explaining the 
intended message, goals, and audience of the narrative. Then allow teams time to review each other’s 
digital narratives. Questions to guide their review might include the following:


• Does the narrative convey the intended message and address the stated goals?


• How do the effects and visual content enhance or detract from the overall message and goals of the 
narrative?


• How does the text and audio content of the narrative enhance or detract from the overall message 
and goals of the narrative?


• How well do the effects and visual content reach the intended audience?


• How relevant is the content to the overall site into which it is placed?


• How well does the text and audio content of the narrative reach the intended audience?


• Does the narrative fall within the required time and word limits?


• How accessible is the content to visitors with disabilities?


Worksheet: How to evaluate a digital narrative 1.6, 5.2


33. At the end, have one evaluating team member summarize the project’s strengths. After both teams 
have reviewed the designs of the other team, ask teams to implement any changes based on comments 


during the design review.1.6


Publishing a digital narrative
(Suggested time: 50–100 minutes)


34. Ask students to publish their final digital narratives. Discuss additional options for publishing Flash 
documents, such as:


• Explore alternative publication destination options, such as mobile devices or Adobe AIR, and 
consider adding metadata to SWF files with Extensible Metadata Platform (XMP) labeling 
technology.2.1


• Test the published movie before and after it is uploaded to the web.


Flash guide: How to publish a Flash document 4.14


35. Have students create a presentation to the client to deliver the digital narrative, identifying the 


following:1.6


• How the narrative is designed for their audience 1.1


• How rich media supports the site’s goals and message 1.1, 1.2


• How the effects and techniques work to reach the intended audience 1.1, 1.2
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Extension activities


You can extend the project in the following ways:


• Understanding narratives and scripts: If students need an additional activity for understanding how to 
connect a script with its visual elements, have them choose a narrative from one of the sites discussed 
at the beginning of the activity. Ask students to transcribe the first 30 seconds (including all screen text 
and spoken dialog). Then ask students to analyze the transcription and visual narrative by explaining 
how effectively the word choice and visual detail work together to create a coherent message.


• Non-website narratives: If you do not have a website for which students can create a narrative, you 
might have them create a digital narrative for a site they select or for an issue that is important to them.


• Real scripts: To reinforce the concept that the script is the key to a good narrative, ask students to look 
at a movie screenplay online at www.simplyscripts.com/movie.html. Then ask students to compare the 
screenplay to scenes from the actual movie (video).


◦ How is the scene set?


◦ How are characters introduced?


◦ How are effects implied or stated in the script?


Assessment
• Project rubric


Background preparation resources
• Review the student step-by-step guides referenced in this project.


• To view video tutorials aligned with the skills required to complete this project, visit the Digital Design 
CS6 show on Adobe TV: http://tv.adobe.com/show/digital-design-cs6/


• For more teaching and learning resources on digital narratives, Flash, and other topics in this project, 
search for resources from the community on the Adobe Education Exchange: 
http://edexchange.adobe.com


• For an overview of the interface and for more information on the technical aspects of Flash, see Flash 
Help. 


Digital narratives


• Examples of effects created in Flash:


◦ Pan: www.wechoosethemoon.org/


◦ Zoom: http://waterlife.nfb.ca/


◦ Camera angle: www.wechoosethemoon.org/


◦ Cross fade transition: http://waterlife.nfb.ca/


◦ Simple fade transition: www.computerhistory.org/revolution/


• Second Story’s site contains links to a variety of websites with interactive features on subjects ranging 
from the visual arts, architecture, and music to history, geography, and the sciences: 
www.secondstory.com 


• Waterlife is a preview for a documentary film similar to the cinematography and storytelling from the 
film. Especially interesting are the navigations, which mimic the motion of water: 
http://waterlife.nfb.ca/
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• We Choose The Moon was designed to celebrate the fortieth anniversary of the Apollo 11 Lunar 
landing by developing an interactive re-creation of the event: www.wechoosethemoon.org/


• Arizona State University and the Institute of Human Origins created this documentary: 
www.becominghuman.org/node/interactive-documentary


• Computer History Museum’s website tells the story of the 2,000-year history of computing in both 
linear and nonlinear ways: www.computerhistory.org/revolution/ 


• 30 Second Bunny Theater, a Flash-based narrative lesson plan on the Adobe Education Exchange: 
http://edexchange.adobe.com/posts/ce3eae923d


Storyboards


• Sample cartoon storyboard: www.brianlemay.com/storyboards/storyboard1.html


• Information on creating storyboards for digital stories from the University of Houston, The 
Educational Uses of Digital Storytelling website: 
http://digitalstorytelling.coe.uh.edu/storyboarding.html


• Information on use of storyboards for multimedia storytelling: 
http://multimedia.journalism.berkeley.edu/tutorials/starttofinish/storyboarding/


• Organizing Flash animations with storyboards: 
www.peachpit.com/guides/content.aspx?g=flash&seqNum=381


Key terms
• accessibility


• animation storyboard


• bounce effect


• color fade


• compression


• cross fade


• emphasizing subject


• filmmaking technique


• flowchart


• gradient


• graphic filter


• logical divisions of a narrative


• message


• narrative


• optimize (file size)


• panning


• readability


• script


• Text Layout Framework (TLF), TLF text


• tilting


• time frame


• transition


• zooming in and out
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ISTE NETS*S Standard for Students


This project is aligned to the ISTE NETS*S Technology Standards. Depending on the subject and content 
area the student selects you may research your own state content standards to see how this project aligns to 
your state requirements.


ISTE NETS*S: Curriculum and Content Area Standards – NETS for Students


1. Creativity and Innovation


Students demonstrate creative thinking, construct knowledge, and develop innovative products and 
processes using technology. Students:


a. apply existing knowledge to generate new ideas, products, or processes.


b. create original works as a means of personal or group expression.


c. use models and simulations to explore complex systems and issues.


2. Communication and Collaboration


Students use digital media and environments to communicate and work collaboratively, including at a 
distance, to support individual learning and contribute to the learning of others. Students:


a. interact, collaborate, and publish with peers, experts or others employing a variety of digital 
environments and media.


b. communicate information and ideas effectively to multiple audiences using a variety of media and 
formats


d. contribute to project teams to produce original works or solve problems.


3. Research and Information Retrieval


Students apply digital tools to gather, evaluate, and use information. Students:


a. plan strategies to guide inquiry.


b. locate, organize, analyze, evaluate, synthesize, and ethically use information from a variety of 
sources and media. 


c. evaluate and select information sources and digital tools based on the appropriateness to specific 
tasks.


4. Critical Thinking and Problem Solving


Students use critical thinking skills to plan and conduct research, manage projects, solve problems and 
make informed decisions using appropriate digital tools and resources. Students::


b. plan and manage activities to develop a solution or complete a project.


d. use multiple processes and diverse perspectives to explore alternative solutions.


5. Digital Citizenship


Students understand human, cultural, and societal issues related to technology and practice legal and 
ethical behavior. Students:


a. advocate and practice safe, legal, and responsible use of information and technology.


b. exhibit a positive attitude toward using technology that supports collaboration, learning, and 
productivity.


6. Technology Operations and Concepts


Students demonstrate a sound understanding of technology concepts, systems, and operations. 
Students:


a. understand and use technology systems.
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b. select and use applications effectively and productively.


c. troubleshoot systems and applications.


d. transfer current knowledge to learning of new technologies.


Adobe Certified Associate, Rich Media Communication objectives


1.1 Identify the purpose, audience, and audience needs for rich media content.


1.2 Identify rich media content that is relevant to the purpose of the media in which it will be used 
(websites, mobile devices, and so on).


1.3 Understand options for producing accessible rich media content.


1.4 Demonstrate knowledge of standard copyright rules (related terms, obtaining permission, and citing 
copyrighted material). 


1.5 Understand project management tasks and responsibilities.


1.6 Communicate with others (such as peers and clients) about design and content plans.


2.1 Identify general and Flash-specific best practices for designing rich media content for the web, mobile 
apps, and AIR applications.


2.2 Demonstrate knowledge of design elements and principles.


2.3 Identify general and Flash-specific techniques to create rich media elements that are accessible and 
readable.


2.4 Use a storyboard to design rich media elements.


2.5 Organize a Flash document.


3.3 Use the Timeline.


3.4 Adjust document properties.


3.6 Use the Motion Editor.


3.7 Understand Flash file types.


3.8 Identify best practices for managing the file size of a published Flash document.


4.1 Make rich media content development decisions based on your analysis and interpretation of design 
specifications.


4.2 Use tools on the Tools panel to select, create, and manipulate graphics and text.


4.3 Import and modify graphics.


4.4 Create text. 


4.5 Adjust text properties. 


4.6 Create objects and convert them to symbols, including graphics, movie clips, and buttons.


4.7 Understand symbols and the library.


4.8 Edit symbols and instances.


4.10 Create animations (changes in shape, position, size, color, and transparency).


4.12 Import and use sound. 
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4.13 Add and export video. 


4.14 Publish and export Flash documents.


4.15 Make a Flash document accessible.


5.1 Conduct basic technical tests.


5.2 Identify techniques for basic usability tests.


Assessment


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations


Examples of 
effects


Absent or incomplete. Students can identify 
filmmaking effects and 
transition effects. Students 
can articulate where each 
effect is used and share 
examples of the technique. 


Students can successfully 
identify filmmaking effects 
and transition effects. 
Students can clearly 
articulate where each 
effect is best used and 
share examples that would 
be appropriate for the 
technique. 


Client 
interview


Absent or incomplete. The interview identifies 
the client’s goals, the target 
audience, and the intended 
purpose of the digital 
narrative. The interview 
identifies the content and 
information crucial to the 
narrative. The interview 
identifies the client’s 
preferred design 
requirements and includes 
any additional relevant 
questions.


The interview clearly 
identifies the client’s goals, 
the target audience, and the 
intended purpose of the 
digital narrative. The 
interview clearly identifies 
the content (both original 
and repurposed) and 
information crucial to the 
narrative. The interview 
clearly identifies the 
client’s preferred design 
requirements and 
documents specific 
examples. The interview 
includes additional 
relevant and thorough 
questions to get or clarify 
specific information.


Project plan Absent or incomplete. Students plan and set 
reasonable milestones for 
their narrative project and 
set final deadlines to plan 
each phase of the project. 
The tasks reflect equal 
workload among team 
members.


Students plan and set 
reasonable milestones for 
their narrative project and 
set final deadlines to plan 
each phase of the project. 
Milestones include 
detailed descriptions of 
each task, and the tasks 
reflect equal workload 
among team members.
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Design 
solution 
document


Absent or incomplete. Students create design 
documents that include 
narrative goals, objectives, 
and messages; audience; 
delivery requirements; 
content overview; 
flowchart; font and color 
samples; and visual design 
mocks.


Students create design 
documents that include 
detailed analysis on the 
narrative goals, objectives, 
and messages; audience; 
delivery requirements; 
content overview; 
flowchart; font and color 
samples; and visual design 
mocks.


Digital 
narrative 
script


Absent or incomplete. Students write a script that 
meets the narrative’s 
criteria.


Students produce a 
coherent and well-written 
script that meets the 
narrative’s criteria and 
enhances the goals of the 
overall site.


Digital 
narrative 
summar y and 
storyboard


Absent or incomplete. Students identify the 
necessary elements of 
animation storyboards and 
flowcharts. Students create 
a detailed animation 
flowchart and storyboard 
for their narrative project.


Students analyze and 
evaluate the elements of 
animation storyboards and 
flowcharts and articulate 
the purposes they serve. 
Students create a detailed 
animation flowchart and 
storyboard for their 
narrative project, including 
specific design principles 
that will be employed.


Wireframes Absent or incomplete. Students create wireframes 
based on design principles 
and delivery requirements 
to organize content and 
navigation for the digital 
narrative.


Students create wireframes 
based on design principles 
and delivery requirements 
to organize content and 
navigation for the digital 
narrative. Students support 
each decision on elements 
in the wireframes with data 
and information gathered 
from research and clients.


Design 
comps


Absent or incomplete. Students create design 
comps that accurately 
reflect audience, goals, 
color choices, mood, 
images, text, and 
navigation choices. The 
selected comps reflect a 
variety of approaches to 
the design.


Students create design 
comps that accurately 
reflect audience, goals, 
color choices, mood, 
images, text, and 
navigation choices. The 
selected comps reflect a 
variety of approaches to 
the design. Students can 
clearly articulate the ways 
design principles are 
implemented to impact the 
audience.


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations
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Digital 
narrative 
evaluation


Absent or incomplete. Student’s evaluation 
details how the narrative 
content meets intended 
goals, audience, and 
purpose; ways the 
techniques employed 
contribute to the overall 
message of the narrative; 
and how the content is 
accessible to all audiences. 


Student’s evaluation 
details how the narrative 
content meets intended 
goals, audience, and 
purpose; ways the 
techniques employed 
contribute to the overall 
message of the narrative, 
and how the content is 
accessible to all audiences. 
Student evaluations also 
include a design evaluation 
identifying which design 
principles help achieve the 
intended goals of the 
project. 


Testing digital 
narratives


Absent or incomplete. Student teams evaluate and 
articulate technical and 
user issues for the 
producers to fix in the final 
production. 


Student teams evaluate and 
clearly articulate technical 
and user issues for the 
producers to fix in the final 
production.


Final digital 
narratives


Absent or incomplete. Student teams create 
necessary assets and 
successfully build a 
narrative based on the 
design comps, flowchart, 
and storyboard. The 
narrative includes a home 
page and at least one 
content page. The narrative 
has clear goals, audience, 
and purpose. Student teams 
improve the narratives 
based on peer reviews and 
present final version to 
clients clearly and 
concisely.


Student teams create 
necessary assets and 
successfully build a 
narrative based on the 
design comps, flowchart, 
and storyboard. The 
narrative includes a home 
page and two or more 
content pages and clearly 
employs design principles. 
The narrative is clearly 
designed for a specific 
audience and through its 
design clearly displays its 
goals and purpose. Student 
teams improve the 
narratives based on peer 
reviews and present final 
version to clients clearly 
and concisely. Students 
lead final presentation 
meeting and connect 
original design proposal to 
finished product.


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations
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Teamwork N/A Student collaborates with 
other students as required 
to provide feedback or 
assistance. Fulfills 
assigned team roles and 
contributes equally to 
project work. Sometimes 
consults with other team 
members on major project 
decisions but makes 
minimal effort to help 
others build skills.


Student collaborates freely 
with other students to 
provide feedback or 
assistance. Fulfills 
assigned team roles and 
contributes equally to 
project work. Consults 
with other team members 
on major project decisions 
and voluntarily helps 
others build skills to 
complete the project.


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations
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How to add a Google map
A common element in mobile applications is the display of maps and directions. One way to include a map in your 
mobile app is to use ActionScript code to integrate with the Google Maps web service.


The map integration is handled entirely by ActionScript, so you don’t need to add components.


Integrating with Google Maps 
To integrate with Google Maps, add the ActionScript code to a keyframe at the location in the timeline where the map 
should appear. In this example, the document includes a Content layer and an Actions layer. The map screen is 
located at Frame 20 in the timeline, so the ActionScript must also appear at Frame 20 in the Actions layer.


To integrate with Google Maps:


1. Open the Flash document for the mobile application you 
want to display a Google map.  


2. In the Timeline panel, locate the keyframe that represents 
the location of the map (Figure 1).


3. Click in the Code or Actions layer that corresponds to the 
map screen in the timeline. 


If your timeline doesn’t have a Code or Actions layer, 
add one and insert a blank keyframe at the location of the 
map screen.


4. Select Window > Actions to open the Actions panel. 
Make sure Script Assist is turned off.


Figure 1 Timeline panel 


5. Enter or copy and paste the following code to integrate with the map service:
import flash.media.StageWebView;


var webView:StageWebView = new StageWebView();


webView.viewPort = new Rectangle( 0, 80, this.stage.stageWidth,


this.stage.stageHeight-80);


webView.stage = this.stage;


webView.loadURL("http://maps.google.com/maps?f=q&source=s_q&hl=en&geocode=&q= \


san+francisco&aq=&sll=37.0625,-95.677068&sspn= \


46.092115,63.808594&ie=UTF8&hq=&hnear=San+Francisco,+California&z=12");


function fl_ClickToGoToAndStopAtFrame_maphome(event:MouseEvent):void


{


webView.dispose();


gotoAndStop(1);


}


The code for the map creates a Stage Web View and places it into a view port on the Stage. Note the negative 80 
position. This is to set to 80 pixels the height that the header occupies in the example. The Web View then loads 
a Google map URL and uses Google’s mobile web interface for browsing maps. 


Keyframe for map screen
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6. Select Control > Test Movie > In AIR Debug Launcher 
(Mobile).


The application opens in the preview window and the 
Simulator appears.


7. Navigate to the map screen, if you’re not already there.


The page displays the Google map (Figure 2). 


Note: You can change the default location of the map by 
editing the URL in the Actions panel.


8. Open a browser window and navigate to Google Maps.


9. Enter the address for the location you want the map to 
display.


10. Google Maps updates to the location you entered.


11. Click the Link button in the browser window (Figure 3).


Google Maps shows the URL for the current map. Copy 
the URL. 


12. Return to Flash and open the Actions panel.


13. Replace the current URL by selecting it in the Actions 
panel and pasting the new URL you copied from Google 
Maps. 


Note: When you select the URL, be careful not to select 
the quotation marks. The URL you paste should be 
contained within the quotation marks. Examine the 
sample ActionScript code in Step 5 to see an example. 


14. Select Control > Test Movie > In AIR Debug Launcher 
and navigate to the map screen to see the map.


Figure 2 Preview window 


Figure 3 Google maps

How to add a Google map © 2012 Adobe Systems Incorporated
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How to import images
Although Adobe Flash Professional CS6 provides great drawing tools of its own, you will often want to use images 
from other sources. In Flash, you can import photographs, vector drawings created in other applications, existing 
graphics such as company logos, and so on. As a designer you need to decide when it’s best to create images in Flash 
and when you need to import images. You make these decisions based on design requirements, file size requirements, 
and available resources.


Image formats supported by Flash
Flash supports a range of images for import. Generally, you want to get these to their desired size and form by using 
an image-editing program before you import them into Flash.


Some of the most commonly used image formats are:


• PNG: This is the file format Adobe Fireworks CS6 uses, and Flash supports roundtrip editing between Flash and 
Fireworks. This means you can open a PNG in Fireworks from within Flash, edit it in Fireworks, and view these 
changes in Flash immediately. Any layers in the Fireworks document can be preserved in Flash.


• JPEG: This is the standard file format for web photos. JPEGs can be compressed. Use Adobe Photoshop CS6 to 
perform necessary compression before importing. You can also open a JPEG from within Flash, edit it in 
Photoshop and view these changes in Flash immediately.


• GIF and BMP: These should be optimized for file size prior to import, using Photoshop.


• Adobe Photoshop CS6 files: When importing a Photoshop (PSD) file, Flash can preserve many of the attributes 
that were applied in Photoshop, and provides options for maintaining the visual fidelity of the image and further 
modifying the image.


• Adobe Illustrator CS6 vector files: You can import Illustrator (AI) files into Flash, complete with vectors, layers, 
frames, and symbols.


Bitmap and vector images


Bitmap images are composed of different-colored pixels that combine to make an image. Graphics and photographs 
saved as GIFs or JPEGs are both bitmapped formats. When you create bitmaps, you essentially decide the color for 
each pixel.


Bitmap images are resolution dependent. This means the size and quality of the image depends on the number of 
pixels per inch in the image. Images saved for onscreen display have a resolution of 72 pixels per inch because that’s 
all most monitors can handle, whereas images saved for print can require 300 pixels per inch (or more).


In contrast to bitmaps, vector graphics are not created pixel-by-pixel. Instead, vector graphics use a series of 
commands to determine a line’s shape, location, thickness, and color. The actual shape is rendered (or drawn) on the 
screen at view time.


Flash’s native format is vector, because vector images produce smaller file sizes. However, as the previous list 
indicates, you can import bitmapped images into Flash when you need them.

© 2012 Adobe Systems Incorporated How to import images 1







Project 6 guide Adobe Flash Professional CS6


2


Importing images to the Stage
When you import an image to the Stage, it is also placed in the document’s library.


1. Start Flash and open the document into which you want 
to import an image.


2. Select the keyframe where the image should appear.


3. Select File > Import > Import To Stage.


The Import dialog box appears (Figure 1).


4. Browse to the folder with the desired image and select 
the image.


5. Click Open.


The image appears on the Stage. The image has also been 
added to the library.


Note: To edit the image in another application, right-
click (Windows) or Control-click (Mac OS) the image in 
the Library panel to open the context menu. The context 
menu includes two Edit With commands (Figure 2). One 
targets the most recent application you used for round-
trip editing, such as Adobe Photoshop CS6. The other 
lets you navigate to a different bitmap editing 
application. When you open the image for editing in 
another application, the changes you make are reflected 
in Flash.


Figure 1 Import dialog box


Figure 2 Context menu


Importing images into the library
When you import an image into the library, the image is ready for use but not immediately added to the Stage.


To import an image into the library:


1. Start Flash and open the document into which you want 
to import an image.


2. Select File > Import > Import To Library.


The Import dialog box (Windows) or Import To Library 
dialog box (Mc OS) appears.


3. Browse to the folder with the desired image and select 
the image.


4. Click Open.


5. If the Library panel is not open, select Window > Library.


The image appears in the Library panel (Figure 3).


6. Select the image to preview it in the Library panel.


Figure 3 Library with imported image
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Importing Photoshop and Illustrator images
Because programs such as Illustrator and Photoshop support layers, Flash lets you preserve these characteristics 
during import. The instructions below describe how to import an Illustrator source image—importing a Photoshop 
image is very similar.


To import an Illustator image:


1. Start Flash and open the document into which you want 
to import the Illustrator source image


Note: While there are no known issues about importing 
AI files created in earlier versions of Illustrator, Adobe 
recommends importing AI files created by using 
Illustrator CS6. If you encounter issues importing AI files 
created in earlier version of Illustrator, open the file in 
Illustrator CS6, and save the AI file as a CS6 compatible 
file and re-import it into Flash.


2. Select the keyframe where the vector file should appear.


3. Select File > Import > Import To Stage.


The Import dialog box opens.


4. Browse to the folder with the desired vector file and 
select it.


5. Click Open.


The Import Illustrator Document To Stage dialog box 
opens (Figure 4).


You can select which layers to import. You can choose 
whether to import layers in the source image as layers or 
as separate frames. Select each layer to set various import 
options for that layer.


Note:  If there is an Incompatibility Report button before 
the Convert Layers To menu, click it. Make changes as 
required to the Illustrator image and start the import 
process again.


6. Click OK.


Flash imports the Illustrator image, which appears on the 
Stage.


Figure 4 Import Illustrator Document To Stage 
dialog box
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Importing an XFL document
An XFL file is a type of Flash file that stores the same information as a FLA file, but in XML format. Other Adobe 
applications, such as Adobe After Effects CS6, can export files in XFL format. This allows you to work on a project 
in a separate application first and then continue working with it in Flash.


You can open and work with XFL files in Flash in the same way you would open an FLA file. When you open an 
XFL file in Flash, you can then save the file as a FLA file. For more information on XFL files, see Flash Help.


To import an XFL file:


1. In another Adobe application, such as After Effects, 
export your work as an XFL file.


The application preserves all of the layers and objects of 
the original file in the XFL file.


2. In Flash, choose File > Open and navigate to the XFL 
file. Click Open.


The XFL file opens in Flash in the same way as an FLA 
file. All of the layers of the original file appear in the 
timeline and the original objects appear in the Library 
panel.


You can now work with the file normally.


3. To save the file, choose File > Save.

How to import images © 2012 Adobe Systems Incorporated
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Usability and Accessibility


Student name:_________________________________________________ Date: ________________________


URL: ________________________________________________________________________________________


Site name: ____________________________________________________________________________________


Usability
What types of navigation elements are used: buttons, hyperlinks, images, something else? One type or several? 
Describe each type of navigation element.


As you navigate, how many clicks does it generally take to get to information you are seeking?


As you navigate, do you get to the information you are expecting?
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Is the site structure apparent?


How long does it take for pages to load?


Does the website look the same in different browsers, on different operating systems, or on different devices?


Is the text readable? Is the text uniquely styled? If so, does the styling add value to the purpose?

Usability and Accessibility © 2012 Adobe Systems Incorporated
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What are the elements of the visual layout? How do these elements make it easier or more difficult for visitors?


Are there clear titles, headings, or other visual elements that specifically help organize the information?


Accessibility
Do the images have alternative text so screen readers can read the description?


Are all the links, including embedded links, labeled so they can stand alone?
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If data tables are used, do they have header rows or header columns?


Are there clear titles and headings that help organize the information for someone using a screen reader?


Is the navigation scheme positioned conveniently for someone using a screen reader?


Is color the only element used to convey emphasis?
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Is the degree of color contrast and color brightness between foreground and background elements high enough for 
people with visual impairments?
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		Usability and Accessibility

		Student name: Date:

		URL:

		Site name:

		Usability

		What types of navigation elements are used: buttons, hyperlinks, images, something else? One type or several? Describe each type of navigation element.

		As you navigate, how many clicks does it generally take to get to information you are seeking?

		As you navigate, do you get to the information you are expecting?

		Is the site structure apparent?

		How long does it take for pages to load?

		Does the website look the same in different browsers, on different operating systems, or on different devices?

		Is the text readable? Is the text uniquely styled? If so, does the styling add value to the purpose?

		What are the elements of the visual layout? How do these elements make it easier or more difficult for visitors?

		Are there clear titles, headings, or other visual elements that specifically help organize the information?

		Accessibility

		Do the images have alternative text so screen readers can read the description?

		Are all the links, including embedded links, labeled so they can stand alone?

		If data tables are used, do they have header rows or header columns?

		Are there clear titles and headings that help organize the information for someone using a screen reader?

		Is the navigation scheme positioned conveniently for someone using a screen reader?

		Is color the only element used to convey emphasis?

		Is the degree of color contrast and color brightness between foreground and background elements high enough for people with visual impairments?











//IMPORT CLASSESimport fl.controls.List;import flash.net.URLLoader;import flash.events.Event;import flash.net.URLRequest;//BACK BUTTONbutton_back_newshome.addEventListener(MouseEvent.CLICK, fl_ClickToGoToAndStopAtFrame_newshome);//HOME BUTTONfunction fl_ClickToGoToAndStopAtFrame_newshome(event:MouseEvent):void{	gotoAndStop(1);}
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How to add rich media to a web page
To add interest and interactivity, you can easily add rich media to web pages. Rich media includes most kinds of 
video, Flash videos, audio files, and interactive Flash content. 


When building web pages that will be viewed across different devices and screen sizes, consider using HTML5. 
HTML5 video is emerging to become the new standard way to show video on the web. Dreamweaver supports the 
HTML5 <video> tag that allow users to play video files in a browser, without an external plug-in or player 
(Figure 1). 


Figure 1 Viewing HTML5 video in a browser


HTML5 video
There are a few steps you need to accomplish before setting up your web page for HTML5 rich media.


• Create a video in H264 format. You can use the Adobe Media Encoder CS6 or the website www.online-
convert.com to convert video into a range of formats. If you want viewers to be able to play your video in a 
Firefox browser, you should also create a WebM or Flash (FLV) version of your video. 


• Create a poster image that is the same size and orientation as the video. This graphic provides a splash 
screen for viewers to see while the video is downloading. If no poster is specified, a browser will display the 
first frame of the video.


• Include a folder named video in your site, and place the video file and poster image in it.


Once a video is embedded in a page, you can use Live view in the Document window to render and preview rich 
media.


Note: Although you can embed rich media in your web page, Live view does not always render all videos. The audio 
and video tags are supported in Dreamweaver by using the Apple QuickTime plug-in. In Windows, if the Apple 
QuickTime plug-in is not installed, then the web page does not render the media content.
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To create the HTML5 page and video:


1. Start Dreamweaver.


2. Select File > New. 


The New Document dialog box opens (Figure 2).


3. Click the Blank Page category link if not already open, 
and select HTML from the Page Type column, and 
<none> from the Layout column.


4. Select the HTML5 document type from the DocType 
pop-up menu.


5. Click the Create button.


6. Save the new document (File > Save).


The Save As dialog box opens.


7. Navigate to your Dreamweaver site folder, name the file, 
and click Save.


8. Click the Split button in the Document toolbar at the top 
of the document window (Figure 3).


Code view and Design view are visible in the document 
window.


You work in Code view in the next steps as you set up the 
video player with the specifications for your own video 
files. 


9. In Code view, locate the <body> tag, and place the 
insertion point at the end of the the opening body tag.


10. Press Enter (Windows) or Return (Mac OS) to create a 
new line for code.


11. Type <vi and then press Tab to complete the beginning of 
the <video tag.


12. Press the spacebar and type src and then press Tab to 
complete the the source parameter.


The Browse link appears (Figure 4).


13. Click the Browse link to open the Select File dialog box.


14. Navigate to the H.264 video file you saved to the video 
folder and double-click that file to select it.


15. Press the spacebar and then double-click Controls from 
the list of code hints (Figure 5).


This adds a parameter to tell the browser to display 
playback controls with the video.


16. Press the spacebar and type po and then press Tab to 
complete the the poster parameter.


The Browse link appears.


Figure 2 New Document dialog box


Figure 3 Document toolbar


Figure 4 Code hints


Figure 5 Code hints


DocType pop-up menu
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17. Click the Browse link to open the Select File dialog box.


18. Navigate to the poster file you saved to the video folder and double-click that file to select it.


19. Press the spacebar and type prel and then press Tab to complete the the preload parameter.


20. Select Auto from the list of available options. 


The preload parameter tells the browser to load the entire video when the page loads.


Figure 6 Sample code


21. Place the insertion point after the closing preload quote.


22. Press the spacebar and then type ></.  


Dreamweaver will complete the closing tag </video>.


23. Place the insertion point before the closing tag </video>.


24. Press Enter (Windows) or Return (Mac OS) twice to create a blank line for code.


25. Enter (or copy and paste) the following code just before the closing video tag:


<p>Your browser does not support HTML5 video. Click here to download it.</p>


You’ve added text that will display in browsers that don't support HTML5, but you need to add a link to the file 
so users can download it.


26. In Code view, highlight the sentence Click Here To Download It.


27. Click in the Design window to update the preview.


28. Drag the Point-To-File icon  (target icon) at the right of the Link box in the Property inspector and point to the 
video in the Files panel.


A link is created to the video file as in Figure 7.


Figure 7 Sample code


29. Save the file (File > Save).
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30. Select File > Preview In Browser, and select a browser to 
preview the video in a web browser (Figure 8).


Figure 8 Test movie in browser


Troubleshooting support for Firefox


To this point, you’ve embedded a video file in a web page using the HTML5 Video element (tag), and added a link 
that displays a message if a viewer tries to watch the video in a browser that doesn't support HTML5. This approach 
works well across versions of current browsers including Chrome, Safari, and Internet Explorer.  Unfortunately, the 
video won't play in Firefox because it does not support H.264 video. Because Firefox does support HTML5, the text 
link to open the video in a new browser window also won't display. This problem is typical of the kind of issues you'll 
encounter with HTML5 video: it’s still a work in progress. 


You can check with the W3C for the latest information about browser support for HTML5 video at www.w3.org/
wiki/HTML/Elements/video.


To add support for a Firefox browser:


1. Add a simple message after the closing video tag:


<p>Firefox viewers click here to watch the 
video.</p>


2. Create a link to a version of the video in one of the 
formats that Firefox supports, such as WebM or Flash 
Video (FLV).
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About FLA, SWF, and FLV file types
Before you use Dreamweaver to insert content created with Adobe Flash, you should be familiar with the following 
file types:


FLA file (.fla) the source file for any project, created in Flash. This file type can be opened only in Flash (not in 
Dreamweaver or in browsers). In Flash, you can publish a FLA file as a SWF file to use in browsers.


SWF file (.swf) a compiled version of the FLA (.fla) file, optimized for viewing on the web. This file can be 
played back in browsers and previewed in Dreamweaver, but cannot be edited in Flash. 


FLV file (.flv) a video file that contains encoded audio and video data that can be played in Flash® Player. If you 
have a QuickTime or Windows Media video file, use an encoder such as Flash® Video Encoder or Sorensen 
Squeeze to convert the video file to an FLV file. 


Adding FLV video to a web page


You can easily add FLV video to your web pages without using the Flash authoring tool. You must have an encoded 
FLV file before you begin.  Dreamweaver inserts a SWF component that displays the FLV file; when viewed in a 
browser, this component displays the selected FLV file, as well as a set of playback controls. You can also use Live 
view to provide a non-editable, more realistic rendering of how the page will appear in a browser. Live view does not 
replace the Preview In Browser command, but provides another way of seeing what your page looks like “live,” 
without having to leave the Dreamweaver workspace.


To add an FLV video to a web page:


1. Start Dreamweaver and open the document in which you 
want to insert the FLV video.


2. Place the insertion point in Design view where you want 
to add the FLV video.


3. Select Insert > Media > FLV.


The Insert FLV dialog box opens (Figure 9).


4. Click the Browse button to the right of the URL text box.


5. Locate and select the Flash video (FLV), and then click 
OK (Windows) or Open (Mac OS).


6. In the Insert FLV dialog box, select Progressive 
Download Video from the Video Type pop-up menu. 


The Progressive Download Video option enables visitors 
to see movies as they download instead of waiting until 
the entire movie has downloaded.


Note: The Streaming Video option requires the use of 
Adobe Flash Media Server.


7. Fill in the Width and Height boxes.


Dreamweaver requires this information to include the 
video.


8. Select a skin from the Skin pop-up menu.


This determines the appearance of the Flash video 
playback controls (Figure 10).


Figure 9 Insert FLV dialog box


Figure 10 Flash video in a browser with Clear Skin  
selected
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9. Select the Auto Play option to cause the video to play 
when the page loads.


10. Select the Auto Rewind option to cause the video to 
rewind automatically when it reaches the end.


11. Click OK to close the dialog box and insert the video.


A Flash Video placeholder appears in your document 
(Figure 11).


Note: If the Copy Dependent Files dialog box opens, 
click OK to copy the necessary scripts to your site for 
proper playback of the video.


12. Save the document. 


13. In Design view, click the Live View button in the 
Document toolbar.


Figure 11 Flash Video placeholder


Adding  Flash movies (SWF files) to a web page


You add a Flash movie just as you would an image, by browsing to and selecting the Flash file. The file extension of 
Flash movies is SWF.


To add a SWF file to a web page:


1. Start Adobe Dreamweaver and open the document in 
which you want to insert the Flash movie.


2. Place the insertion point in Design view where you want 
to add the Flash movie.


3. Select the Common category in the Insert panel.


4. Click the down arrow on the Media button and select 
SWF in the pop-up menu (Figure 12).


The Select SWF dialog box opens (Figure 13).


Figure 12 Media pop-up menu


Figure 13 Select SWF dialog box
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5. Locate and select the Flash movie (SWF), and then click 
OK (Windows) or Open (Mac OS).


The Object Tag Accessibility Attributes dialog box opens 
(Figure 14).


6. In the Title text box, type a brief title to identify the 
movie’s contents. Then click OK.


A Flash content placeholder, rather than a scene from the 
Flash movie itself, appears in your document 
(Figure 15). This is because the page is pointing to the 
Flash SWF file. When a visitor opens this page, the 
browser plays the SWF file.


To determine how the movie plays when the page loads, 
you set options in the Properties panel.


7. Make sure the Flash content placeholder is selected.


8. In the Properties panel (Figure 15), select the Loop 
option to cause the movie to repeat as long as the visitor 
is on the page. Or, if you don’t want the movie to loop, 
make sure that the Loop option is not checked.


9. Select the Autoplay option to cause the movie to play 
when the page loads.


10. To test the movie, click Play.


Dreamweaver plays the Flash file in the document, 
showing you what visitors will see when they view the 
page in a browser.


11. When you are finished viewing the Flash movie, click 
Stop in the Properties panel.


Figure 14 Object Tag  Accessibility Attributes 
dialog box


Figure 15 Flash movie placeholder in the Document window and Properties panel
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Editing a SWF file from Dreamweaver in Flash


If you have both Flash and Dreamweaver installed, you can select a SWF file in a Dreamweaver document and use 
Flash to edit it. Flash does not edit the SWF file directly; it edits the source document (FLA file) and re-exports the 
SWF file.


To edit a SWF file from Dreamweaver:


1. In Dreamweaver, open the Properties panel (Window > 
Properties).


2. In Design view, click the SWF file placeholder to select 
it; then in the Properties panel, click Edit.


3. In Flash, browse to locate and then select the FLA file. 
Edit the FLA file as you choose.


The Flash edit bar indicates that you are modifying the 
file from within Dreamweaver (Figure 16).


4. When you finish making edits, click Done in the Flash 
edit bar (in the upper-left corner of the workspace). 


Flash updates the FLA file and re-exports it as a SWF 
file.


5. Return to Dreamweaver.


6. To view the updated file in the document, click Play in 
the Properties panel (Figure 17) or press F12 to preview 
your page in a browser window.


Figure 16 Flash edit bar


Figure 17 Flash movie, Play mode, in the Dreamweaver Document window
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Adding audio to a web page
You can add sound to a web page. There are several different types of sound files and formats, including .wav, .midi,  
.mp3, and .ogg . Some factors to consider before deciding on a format and method for adding sound are its purpose, 
your audience, file size, sound quality, and differences in devices and web browsers. 


There are two methods for adding audio to a web page: Use a plug-in or encode your page using HTML5.


When using a plug-in, remember that sound files can be handled differently and inconsistently by different browsers. 
For more information about common audio file formats along with some of the advantages and disadvantages of each 
for web design, see Dreamweaver Help, Audio File Formats.


HTML5 provides additional flexibility for adding audio files to web pages without a plug-in. However, devices and 
web browsers must support the new standard for the audio to work properly. You use the <audio> element to embed 
an audio file on a web page. As with HTML5 video files, be sure to convert your audio files into three supported 
formats: .ogg, mp3, and .wav. These sources are listed in the <audio> tag, and the browser will use the first 
recognized format.


Note: When incorporating sound files in your web pages, carefully consider their appropriate use in your web site 
and how visitors to your site use these media resources. Always provide a control to either enable or disable the 
playing of the sound, in the event that visitors don’t want to listen to the audio content.


To add an audio file by using a plug-in:


1. Start Dreamweaver and open the document in which you want to add sound.


2. In Design view, place the insertion point where you want to embed the file and select Insert > Media > Plugin.


3. Browse for the audio file and click OK (Windows) or Open (Mac OS).


4. Enter a width and height in the W and H text boxes in the Properties panel or by resizing the plug-in placeholder 
in the Document window (Figure 18).


These values determine the size at which the audio controls are displayed in the browser. Audio controls have no 
fixed dimension so find a size that is suitable for the web page in which it is used. For the example in Figure 18, 
the size is set to 257 W x 128 H. 


5. Save the file.


6. Select File > Preview In Browser, and then select a browser to preview the audio in a web browser.


Figure 18 Audio plug-in placeholder in the Document window and Properties panel
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To add an audio file by using HTML5:


1. Create a new HTML5 document, or open an existing HTML5 document in which you want to add audio.


2. Click the Split button in the Document toolbar at the top of the document window.


3. In Code view, enter (or copy and paste) the following code between the <body> tags, substituting your folder 
and filename paths for the placeholders in the code:
<audio controls>


  <source src="folder/song-title.ogg" type="audio/ogg" />


  <source src="folder/song-title.mp3" type="audio/mpeg" />


  <source src="folder/song-title.wav" type="audio/wav" /> 


   <p>Your browser does not support the audio element.</p>


</audio> 


The control attribute adds audio controls, like play, pause, and volume. The text at the end of the <audio> tag is 
for browsers that do not support the element.


The folder and filename paths for the sample site are shown in Figure 19. 


Figure 19 Sample code


4. Save the document. 


5. Select File > Preview In Browser, and then select a browser to preview the audio in a web browser (Figure 20).


Figure 20 Test audio in browser
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The Dreamweaver Insert panel
In Adobe Dreamweaver CS6, the Insert panel contains buttons for inserting various types of objects, such as images 
and forms, into a Dreamweaver document.


You can use the Insert panel to create or insert content in eight categories:


• The Common category contains buttons for inserting the most commonly used objects, such as links, 
images, and tables.


• The Layout category gives you options to insert tables, table elements, div tags, frames, and Spry widgets. 
You can view tables in either Standard (default) mode or Expanded Tables mode. 


• The Forms category contains buttons for creating forms and inserting form elements.


• The Data category lets you insert dynamic elements such as recordsets, repeated regions, and record 
insertion and update forms.


• The Spry category lets you insert “widgets” that display data from other files and various interface elements 
(such as navigation bars and menus) that rely on JavaScript and CSS. (Spry widgets are not covered in this 
study, but you can read find out more about them in Dreamweaver Help (select Help > Dreamweaver Help 
and look for the section called “Building Spry pages visually.”)


• The jQuery Mobile category provides content layout options, input, UI and form controls for developing 
mobile applications using Dreamweaver.


• The InContext Editing category is used to enable end users to make simple edits to their web pages without 
help from you or additional software on their computers. Adobe InContext Editing (ICE) is an online hosted 
service that provides simple content editing capabilities within a web browser. 


• The Text category is used for working in Code view and enables you to insert a variety of text- and list-
formatting tags, such as b, em, p, h1, and ul.


• Use the Favorites category to customize a list of Insert panel buttons for fast access. You can customize this 
category by right-clicking (Windows) or Control-clicking (Mac OS) the Insert panel.


The Insert panel menu
You switch between these categories by using the Insert panel menu, which is located at the top of the Insert panel 
(Figure 1). To hide or show the Insert panel select Window > Insert.


Figure 1 Insert panel, Category pop-up menu
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To display the pop-up menu for a button, click the disclosure triangle beside the button’s icon (Figure 2).


Figure 2 Insert panel, Images pop-up menu
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Symbols, instances, and the library


Symbols and instances
A symbol is a graphic, button, or movie clip you create once in Adobe Flash Professional CS6 and can use any 
number of times throughout your movie. Any symbol you create is automatically placed in a storage area called the 
library for the current document.


An instance is a copy of a symbol located on the Stage or on the Pasteboard (the gray area around the Stage). An 
instance can be different from its symbol in color, size, and function. To create an instance of a symbol, drag the 
symbol from the library onto the Stage or Pasteboard. Once you have created an instance, you can use the Color 
Effect options in the Properties panel to change its brightness, tint, alpha, or RGB color settings.


Editing the symbol automatically updates all of its instances, but applying effects to an instance of a symbol updates 
only that instance.


Using symbols offers a number of advantages. Symbols add interactivity to your documents. They save space and 
reduce the download time of your finished movie because Flash does not have to save duplicate information for each 
instance. For example, if you create an animated wheel symbol, you can use several instances of the symbol to create 
the wheels on a train. The result is a much smaller file than if you had created each wheel separately. Symbols also 
help you maintain consistency throughout your Flash document. For example, if you have buttons throughout your 
document, using symbols ensures that all buttons look alike. You can easily edit all instances of buttons in a 
document at once when you use symbols to create them. You can also share symbols between different documents.


When you create a new drawing in Flash, you’re creating a shape, not a symbol. You can convert any shape to a 
symbol by selecting it and then selecting Modify > Convert To Symbol.


Libraries
The library is a container in each movie where Flash stores and organizes symbols, sounds, bitmap graphics, video, 
and other elements. The library is attached to the document you’re working on. By default, the Libary panel is open in 
the right-side of the workspace next to the Properties panel (Figure 1). If it’s not open, select Window > Library. If 
you share your document with someone else, and they open it on their computer, they will see the same library 
objects. You can also open libraries from other documents by selecting File > Import > Open External Library. As 
your documents become more complex, you’ll find it helpful to use folders to sort your content into related groups 
within the library.


Figure 1 Library panel
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Types of symbols
Flash has three types of symbols: graphic, button, and movie clip.


Each symbol has a unique timeline and Stage, complete with layers. When you create a symbol, you choose the 
symbol type, depending on how you want to use the symbol in your document.


• Use graphic symbols for static images and to create reusable pieces of animation that are tied to the main 
timeline. Graphic symbols operate in sync with the main timeline. Interactive controls and sounds won’t work in 
an animation sequence contained in a graphic symbol.


• Use button symbols to create interactive buttons that respond to mouse clicks, rollovers, and other site visitor 
actions. You define the graphics associated with various button states and then assign actions to a button 
instance.


• Use movie clip symbols to create reusable pieces of animation. A movie clip has its own timeline that is 
independent from the main timeline—think of it as a sub-timeline nested inside the main timeline. Movie clips 
can contain interactive controls, sounds, and even other movie clip instances.


Creating symbols
You create symbols in one of two ways:


• Select Insert > New Symbol. This creates a new symbol to which you must add content.


• Select an existing shape (that you’ve drawn) or image (that you’ve imported) and select Modify > Convert To 
Symbol.

Symbols, instances, and the library © 2012 Adobe Systems Incorporated
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How to add images
Images are common elements of most websites. You add images by inserting them from an existing file. 


In this activity, you create a simple web page by adding an image to the page.


Adding images
Many different types of graphic file formats exist, but three graphic file formats are generally used in web pages—
GIF, JPEG, and PNG. GIF and JPEG file formats are the best supported and can be viewed by most browsers. 


When you insert an image into a Dreamweaver document, a reference to the image file is generated in the HTML 
source code. To ensure that this reference is correct, the image file must be in the current site. If it is not in the current 
site, Dreamweaver asks whether you want to copy the file into the site.


After you insert an image, you can set image tag accessibility attributes that can be read by screen readers for visually 
impaired users. These attributes can be edited in HTML code.


To add an image:


1. Click on the index.html tab in the document window.


2. Position the insertion point where you want to add an 
image.


3. Select Insert > Image.


The Select Image Source dialog box opens (Figure 1).


4. Browse to the folder that contains the image you want to 
place in the document.


5. Select the image.


A preview of the image appears in the right side of the 
dialog box (Windows).


6. Click OK (Windows) or Choose (Mac OS).


If the image is not in your site folder, Dreamweaver asks 
if you want to copy the file there (Figure 2). If the image 
is already stored in your site, you can skip steps 8 and 9.


Figure 1 Select Image Source dialog box


Figure 2 File outside of root folder warning 
message


7. Click Yes.
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The Copy File As dialog box appears (Figure 3). By 
default the image will be copied to the root folder of your 
site. You can store the image in the root folder, or place 
the image in a subfolder of your site.


8. Browse to a folder in your site where you want to store 
the file, or click the Create New Folder button to create 
the destination images folder, and click Save.


The Image Tag Accessibility Attributes dialog box opens 
(Figure 4). This dialog box enables you to add a 
description to the image so that screen readers can 
interpret it.


9. Enter a brief description. You can also provide a link to a 
file with a longer description.


10. Click OK.


The image is added to your document.


11. Save the file.


Figure 3 Copy File As dialog box


Figure 4 Image Tag Accessibility Attributes dialog 
box


Set image properties
The Images Properties panel allows you to set properties for an image (Figure 5). If you do not see all of the image 
properties, click the expander arrow in the lower-right corner.


Figure 5 Properties panel, Image mode


These are a few of the commonly-used image options you can set in the Properties panel:


• W and H the width and height of the image, in pixels. Dreamweaver automatically updates these text boxes 
with the image’s original dimensions when you insert an image in a page. If you set W and H values that do 
not correspond to the actual width and height of the image, the image may not display properly in a browser. 
(To restore the original values, click the W and H text box labels, or the Reset image size button that appears 
to the right of the W and H text boxes in entering a new value.) 


Note: You can change these values to scale the display size of this image instance, but this does not reduce 
download time, because the browser downloads all image data before scaling the image. To reduce 
download time and to ensure that all instances of an image appear at the same size, use an image-editing 
application to scale images.


• Src specifies the source file for the image. Click the folder icon to browse to the source file, or type the path.


Create New File
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• Link specifies a hyperlink for the image. Drag the Point-To-File icon to a file in the Files panel, click the 
folder icon to browse to a document on your site, or manually type the URL.


• Align an image and text on the same line.


• Alt specifies alternative text that appears in place of the image for text-only browsers or for browsers that 
have been set to download images manually. For visually impaired users who use speech synthesizers with 
text-only browsers, the text is spoken out loud. In some browsers, this text also appears when the pointer is 
over the image. 


To set alignment of an image:


1. Select the image you placed in the document in the 
previous section (Figure 6).


2. Click the Align option menu and set the image alignment 
to Left  (Figure 7).


The image aligns left, and the text wraps around the 
image (Figure 8).


3. Save the file.


Figure 6 Selected image


Figure 7 Properties panel, Align options


Figure 8 Image left-aligned
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How to create animations


Overview of tweening
A tween is an animation you create by specifying a value for an object property in one frame and another value for 
that same property in another frame. Adobe Flash Professional CS6 calculates the values for that property between 
those two frames. The term “tween” comes from the phrase “in between.” You can tween movie clip, graphic, and 
button symbols and text fields.


A tween span is a group of frames in the timeline in which an object on the Stage can have one or more properties 
changed over time. A tween span appears in the timeline as a group of frames in a single layer with a blue or green 
background. You can select a tween span as a single object and drag it from one location in the timeline to another, 
including to another layer. Only one object on the Stage can be animated in each tween span. This object is called the 
target object of the tween span.


A property keyframe is a frame within a tween span where you explicitly define one or more property values for the 
tween target object. Each property you define has its own property keyframes. If you set more than one property in a 
single frame, the property keyframes for each of those properties reside in that frame. You can view each property of 
a tween span and its property keyframes in the Motion Editor. You can also choose which types of property 
keyframes to display in the timeline from the tween span context menu.


Beginning with Adobe Flash Professional CS4, the concepts of keyframe and property keyframe differ from earlier 
versions of Flash. The term keyframe refers to a frame in the timeline in which a change occurs, such as a symbol 
instance appearing on the Stage for the first time. The term property keyframe, new to Flash CS4, refers to a value 
defined for a property at a specific time or frame in a motion tween.


Types of Flash Animation
Motion tweens: Set properties for an object, such as position and alpha transparency in one frame and again in another 
frame, and Flash interpolates the property values of the frames in between. Motion tweens are useful for animation 
that consists of continuous motion or transformation of an object. Motion tweens appear in the timeline as a 
contiguous span of frames you can select as a single object by default. Motion tweens are powerful and simple to 
create.


Shape tweens: Draw a shape at one frame in the timeline and change that shape or draw another shape at another 
frame. Flash then interpolates the intermediate shapes for the frames in between, creating the animation of one shape 
morphing into another.


Classic tweens: Classic tweens are similar to motion and shape tweens, but you can create some specific animated 
effects not possible with span-based tweens. For example, you can apply eases to the groups of frames between the 
keyframes within the tween instead of across the entire length of a tween span. (To ease only specific frames of a 
motion tween, you must create a custom ease curve.) You can also use classic tweens to animate between two color 
effects, such as tint and alpha transparency, while motion tweens can apply only one color effect per tween.


Inverse kinematic (IK) poses: You can stretch and bend shape objects and link groups of symbol instances to make 
them move together in naturalistic ways. If you position the shape object or linked instances in different ways in 
separate frames, Flash interpolates the positions in the frames in between. Inverse kinematics poses help make 
character animation quick and easy.


Note: You will learn more about how to use inverse kinematic poses in the “How to create character animations” 
guide.


Motion tweens
You apply motion tweens only to symbol instances and text. All other objects must be converted to symbols before 
you can animate them by using a motion tween. 
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A motion tween begins with a target symbol instance in the first keyframe of the tween span. You create motion by 
adding a property keyframe somewhere later in the timeline and changing the symbol properties, such as position, 
scale, or rotation. You can edit the individual properties of each symbol instance by using the Properties panel or the 
Motion Editor. You can also drag a symbol instance to a new location on the Stage or manipulate it by using the Free 
Transform tool. 


Note: A tween span can have only one target object. If you add a second symbol to a tween span, the new symbol 
replaces the original one. That means you can deliberately replace the target object of a tween by dragging a different 
symbol from the library onto the tween span in the timeline. 


To create a motion tween:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Draw a shape on the Stage.


The shape appears in keyframe 1 of Layer 1.


3. Using the Selection tool (Figure 1), double-click to 
select the shape fill and stroke, if present. 


4. Choose Modify > Convert To Symbol. 


The Convert To Symbol dialog box appears (Figure 2).


Note: Applying a motion tween to a shape automatically 
converts the shape to a symbol.


5. Type a new name for the symbol in the Name text box, 
select Graphic for Type, and click OK (Figure 2).


6. Select frame 10.


7. Select Insert > Timeline > Frame. (The motion tween will 
last for 10 frames.)


When you insert a frame, Flash fills the area between the 
last frame (on the current layer) and the new frame with 
the same content (Figure 3). Frames 1 through 10 all 
contain the new symbol.


8. Make sure frame 10 (the end frame for the motion tween) 
is selected and select Insert > Motion Tween.


9. With frame 10 still selected in the timeline, select the 
symbol on the Stage (with a single click). Make one or 
more of the following changes:


Color change: In the Properties panel, select Tint from 
the Color Effect Style menu. Select 100% for the Tint 
Amount and change the color in the Tint Color box 
(Figure 4).


Fading: In the Properties panel, select Alpha from the 
Color Effect Style menu. Reduce the percentage of the 
Alpha Amount for more transparency. For example, an 
Alpha value of 0% makes the object disappear.


Position: Use the Selection tool to move the object to a 
different position on the Stage. A motion path appears. 
The points on this motion path are editable.


Figure 1 Tools panel


Figure 2 Convert To Symbol dialog box


Figure 3 Inserted frame


Figure 4 Properties panel


Selection tool
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Size: Select the object. Then select Modify > Transform > 
Free Transform. Drag the object handles to increase size, 
decrease size, or rotate the object.


10. Click away from the symbol on the Stage to deselect it 
and select frame 1 in the timeline. 


In the timeline, the motion tween is represented by a solid 
blue background running from the start keyframe to the 
end keyframe (Figure 5). When you changed the 
properties of the symbol in frame 10, frame 10 was 
automatically converted to a property keyframe.


With the target object selected in frame 1, the tween’s 
properties appear in the Properties panel (Figure 6).


11. Adjust one or more properties of the motion tween in the 
Properties panel.


• Ease: Controls how fast the object starts or ends the 
motion tween. For example, a high number makes an 
object begin tweening quickly and end slowly.


• Rotate: Rotates the object clockwise or 
counterclockwise a designated number of times.


• Path: If you add a guide layer, the object is linked to 
the path drawn on the guide layer.


• Sync Graphic Symbols option: Starts and stops the 
tweening of all objects on the Stage at the same time.


12. Select the Motion Editor panel (Figure 7).


You can view and adjust all tween properties and 
property keyframes in the Motion Editor. 


• You can add or remove property keyframes for 
individual properties.


• You can move property keyframes to different 
frames within the tween.


• You can add or remove filters or color effects and 
adjust their settings.


• You can add different preset eases to individual 
properties and property categories.


• You can create custom ease curves.


• You can enable roving for individual property 
keyframes for X, Y, and Z properties. Roving allows 
the property keyframe to move to different frames or 
between individual frames to create smooth motion.


Figure 5 Motion tween in the timeline


Figure 6 Motion tween properties


Figure 7 Motion Editor panel
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13. Select Control > Test Movie > In Flash Professional to 
test the movie.


14. Select File > Close to close the preview window.


15. Select the Timeline panel.


16. To see all phases of the tween at the same time, click the 
Onion Skin button at the bottom of the Timeline panel 
(Figure 8).


17. Drag the onion skinning frame handles (they appear as 
brackets with circles on them at the top of the timeline) to 
span the frames in which the object appears.


All the intermediate steps of the tween are visible on the 
Stage (Figure 9).


18. Turn off onion skinning by clicking the Onion Skin 
button again.


19. Save the movie.


Figure 8 Onion Skin button (shown selected)


Figure 9 Onion skinning visible


Shape tweens
In shape tweening, you draw a vector shape at one specific frame in the timeline and change that shape or draw 
another shape at another specific frame. Flash then interpolates the intermediate shapes for the frames in between, 
creating the animation of one shape morphing into another.


Note: Shape tweens work best with simple shapes. Avoid shapes with cutouts or negative spaces in them. Experiment 
with the shapes you want to use to determine the results. You can use shape hints to tell Flash which points on the 
beginning shape should correspond to specific points on the end shape. Shape tweens can use much more computer 
memory than motion tweens, so it is best to use shape tweens sparingly.


Onion Skin button
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To create a shape tween:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


Frame 1 in Layer 1 already contains a blank keyframe.


2. Begin by adding a shape to the Stage:


Drawn objects: Select a shape tool (Rectangle, Oval, or 
PolyStar) and draw a shape on the Stage.


Text: Select the Text tool and type a word or phrase on the 
Stage. Then select the text and select Modify > Break 
Apart. This breaks the words into separate letters. With 
the letters still selected, select Modify > Break Apart 
again to convert the letters into shapes.


Outside images: Select File > Import > Import To Stage 
to import an image. If the image is a bitmap, you must 
break it apart. If the image is a grouped vector drawing, 
you must ungroup it completely. To break apart a bitmap, 
select Modify > Break Apart. To ungroup an image, 
select Modify > Ungroup.


Note: You might need to select Modify > Break Apart or 
Modify > Ungroup multiple times until the object 
becomes a shape, as indicated in the Properties panel.


3. Using the Selection too, select frame 10.


4. Select Insert > Timeline > Keyframe.


The tween will last for 10 frames.


5. Make sure frame 10 is still selected and make one or 
more of the following changes to your shape:


Amorphous shape change: Click the Stage with the 
Selection tool to deselect the object. Bring the Selection 
tool close to the object to grab an edge (Figure 10). Drag 
the edge to modify the shape (Figure 11). The result is an 
amorphous shape change (Figure 12).


Different shape: To morph between your original shape 
and a new object, delete the object in keyframe 10 and 
draw a new object.


Note: Select Modify > Break Apart if the drawn object is 
not a shape.


Text: To morph between your original shape and some 
text, delete the object in keyframe 10 and type the text on 
the Stage. Select Modify > Break Apart until the text 
block is a shape, as indicated in the Properties panel.


Outside image: To morph between your original shape 
and a new image you import, delete the object in 
keyframe 10 and select File > Import to bring in the 
outside image. Select Modify > Break Apart to make the 
object a shape, as indicated in the Properties panel.


Figure 10 Select an edge of the shape


Figure 11 Drag to modify the shape


Figure 12 Amorphous shape change
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6. Click anywhere inside the tween span on the timeline and 
select Insert > Shape Tween.


Green shading with an arrow between keyframes 
indicates a shape tween span (Figure 13).


7. Select frame 1 on the timeline (on the current layer).


This is the start frame for the animation.


8. In the Tweening section of the Properties panel, adjust 
one or more properties of the Shape tween (Figure 14):


Ease: Controls how fast the object starts or ends the 
shape tween. For example, a high number begins the 
tweening quickly and ends slowly.


Blend (Distributive): Creates an animation in which the 
intermediate shapes are smoother and more irregular.


Blend (Angular): Creates an animation that preserves 
corners and straight lines in the intermediate shapes.


9. Select Control > Test Movie > In Flash Professional to 
test the movie.


10. Close the preview window.


11. To see all phases of the tween at the same time, click the 
Onion Skin button at the bottom of the Timeline panel.


12. Drag the frame handles (they appear as brackets with 
circles on them at the top of the timeline) to span the first 
10 frames of Layer 1.


The steps of the tween are all visible on the Stage.


13. Turn off onion skinning by clicking the Onion Skin 
button again.


Figure 13 Shape tween span


Figure 14 Properties panel


Classic tweens
In classic tween animation, you define keyframes at points in the animation and Flash creates the contents of the 
frames in between. The interpolated frames of a classic tween animation appear as light blue shading with an arrow 
drawn between keyframes. Because Flash documents save the shapes in each keyframe, create keyframes only at 
those points in the artwork where something changes.


You can create certain types of animated effects by using classic tweens that not possible with motion tweens.


• Add animation to symbol instances, object groups, or text


• Add timeline effects


• Paste motion tween properties


• Apply custom ease-in/ease-out settings


Note: Advanced uses of classic tweens, such as those listed here, will be dealt with in greater detail in Project 6. The 
following exercise outlines the steps for creating a simple classic tween, which serves as a basic introduction to 
classic tweening and the procedural differences between classic and motion tweening.
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To create a classic tween:


1. Start Flash and open a blank document 
(ActionScript 3.0). 


Frame 1 in Layer 1 already contains a blank keyframe.


2. Begin by adding a symbol to the Stage.


Note: You may need to add a shape, image, or text first 
and convert the object to a new symbol.


3. Select frame 10.


4. Select Insert > Timeline > Keyframe.


The tween will last for 10 frames (Figure 15).


5. Make sure frame 10 is still selected and move the symbol 
to a new position on the Stage.


6. Click between frames 1 and 10 in the timeline and select 
Insert > Classic Tween. 


The classic tween appears as light blue with an arrow 
(Figure 16).


7. Select frame 1 on the timeline (on the current layer).


This is the start frame for the animation.


8. Adjust the position, color, or scale of the symbol in the 
starting keyframe.


9. Select frame 10, and adjust the position, color, or scale of 
the symbol to be as you want the animation to end.


10. Select Control > Test Movie > In Flash Professional to 
test the movie.


11. Close the preview window.


Figure 15 Start and end keyframes


Figure 16 Classic tween span

© 2012 Adobe Systems Incorporated How to create animations 7





		How to create animations

		Overview of tweening

		Types of Flash Animation

		Motion tweens

		Shape tweens

		Classic tweens













Adobe Dreamweaver CS6 Project 3 guide

How to lay out a web page with CSS
A CSS page layout uses the Cascading Style Sheets format, rather than traditional HTML tables or frames, to 
organize the content on a web page. The basic building block of the CSS layout is the div tag—an HTML tag that in 
most cases acts as a container for text, images, and other page elements. When you create a CSS layout, you place div 
tags on the page, add content to them, and position them in various places. Unlike table cells, which are restricted to 
existing somewhere within the rows and columns of a table, div tags can appear anywhere on a web page. You can 
position div tags absolutely (by specifying x and y coordinates), or relatively (by specifying their distance from other 
page elements). You can also position div tags by specifying floats, paddings, and margins—the preferred method by 
today’s web standards.


Creating CSS layouts from scratch can be difficult because there are so many ways to do it. You can create a simple 
two-column CSS layout by setting floats, margins, paddings, and other CSS properties in a nearly infinite number of 
combinations. Additionally, the problem of cross-browser rendering causes certain CSS layouts to display properly in 
some browsers and improperly in others. Dreamweaver makes it easy for you to build pages with CSS layouts by 
providing 16 pre-designed layouts that work across different browsers.


Using the pre-designed CSS layouts is the easiest way to create a page with a CSS layout, but you can also create CSS 
layouts by using absolutely-positioned elements (AP elements). An AP element in Dreamweaver is an HTML page 
element—specifically, a div tag or any other tag—that has an absolute position assigned to it (Figure 1). The 
limitation of Dreamweaver AP elements, however, is that since they are absolutely positioned, their positions never 
adjust on the page in relation to the size of the browser window.


Once you become more experienced you will be able to create page layouts by inserting div tags manually and 
applying CSS positioning styles to them.


Figure 1 AP elements in the Dreamweaver Document window


Inserting an AP div tag
Start this activity by creating a new, blank page and inserting an AP div tag. AP elements can contain text, images, or 
any other content that you can place in the body of an HTML document.
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To insert an AP div tag:


1. Start Dreamweaver.


2. Select File > New.


The New Document dialog box opens (Figure 2).


3. With the Blank Page category selected, click HTML 
under Page Type and <none> under Layout.


4. Click Create.


A new untitled HTML document opens.


5. Save the new page.


The new file is added to the Files panel.


6. Select the Layout category in the Insert panel and 
confirm the Standard mode button is selected (Figure 3)


7. Click the Draw AP Div button.


The mouse pointer chanages to a cross when you move it 
over the Document window.


8. To create the div that will define an area of your page, 
drag a rectangle in the Dreamweaver document. 


9. Click the border of the div to select it.


Handles appear along the border (Figure 4) and the div 
properties appear in the Properties panel. 


Figure 2 New Document dialog box


Figure 3 Insert panel, Layout category


Figure 4 Div inserted and selected
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10. Make sure the Properties panel is open (Figure 5). 


It is docked at the bottom of the screen. If the Properties 
panel is not open, select Window > Properties.


11. Click in the CCS-P Element ID box and enter a name for 
the div. 


Choose a unique name that will help you remember the 
div’s contents, such as header or navigation.


Note: “CSS-P” is a commonly accepted abbreviation for 
“CSS Positioning”.


12. Click the Bg Color box and select a color in the color 
picker. 


The div changes to the selected color. 


13. Click once outside the new div to deselect it. 


A thin black line appears around the div. This line does 
not appear in a browser. If you do not see the line, select 
View > Visual Aids > CSS Layout Outlines.


14. Continue adding divs for all the sections on your page. 
You can place divs directly alongside one another 
(Figure 6).


15. Open the AP Elements panel (Window > AP Elements).


You’ll see that Dreamweaver has added the new divs to 
the list of AP Elements (Figure 7). 


Note: Select Prevent Overlaps to constrain the positions 
of AP elements when they are created, moved, and 
resized, so that they don’t overlap.


16. Save your page.


Figure 5 Properties panel


Figure 6 Multiple divs on page


Figure 7 AP Elements panel


Resizing divs
You can resize an individual div or simultaneously resize multiple divs to make them the same width and height.


Note: If the Prevent Overlaps option is selected in the AP Elements panel, you will not be able to move a div so that 
it overlaps another div.


CSS-P Element ID box
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To resize a div:


1. Select a div by clicking its border or by clicking the div’s 
name in the AP Elements panel.


2. Do one of the following to resize the div:


• To resize by dragging, drag any of the div’s resize 
handles (Figure 8).


• To resize one pixel at a time, hold down Control 
(Windows) or Option (Mac OS) while pressing an 
arrow key.


Note: The arrow keys move the right and bottom 
borders of the div; you can’t resize the top and left 
borders with this technique.


• In the Properties panel, type values for width (W) 
and height (H).


Figure 8 Resize by dragging


Moving divs
You can move divs in Design view in much the same way you move objects in most basic graphics applications.


Note: If the Prevent Overlaps option is selected in the AP Elements panel, you will not be able to move a div so that 
it overlaps another div.


To move a div:


1. Select one or more divs.


2. Do one of the following:


• To move by dragging, drag the div’s selection handle 
(Figure 9).


• To move one pixel at a time, use the arrow keys.


Figure 9 Moving a div


Adding content to divs
You can add images, text, and other content (such as Flash movies) to your divs just as you would elsewhere in a web 
page.


To add content to a div:


1. To insert an image in a div, click in the div and select 
Insert > Image.


Note: Make sure the div is sized large enough to hold the 
image or other content. If the div is sized smaller than the 
image, the div may not display correctly in all browsers.


Div resize handle


Selection handle
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2. In the Select Image Source dialog box, locate and select 
an image to insert (such as a page banner). Then click OK 
(Windows) or Open (Mac OS).


The image appears in the div (Figure 10).


3. To format the image in the div, select the image and 
select formatting elements in the Properties panel.


4. To add text to a div, click in the div and type text or paste 
text copied from another document.


Figure 10 Div with image added


Viewing div tags by using Live view
You can use a feature called Inspect mode in Live view to view the code generated by adding the div tags.  


To view div tags using by using Inspect mode in Live view:


1. Click the Live button in the Control panel (Figure 11).


Live view is enabled. This means that the page appears as 
it will in a web browser.


2. Click the Live button again to deactivate Live view.


3. Click the Split button. 


Code and Design view (Split view) view is enabled. This 
lets you see the code alongside the design display. 


4. Click the Live button again to activate Live Code view.


5. In the Design view, click on a div’s selection handle, or 
an image placed within a div and observe that the div tag 
is highlighted in the Code view (Figure 11).


Figure 11 Split Code/Live view


DivHighlighted tag


Live button
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Principles and rules of copyright
Copyright is protection for intellectual property.


Intellectual property consists of anything an individual has written or created. It might be music, text, pictures, 
photographs, sounds, and so on.


Fair use doctrine is part of the copyright laws. It states that limited portions of material may be used without written 
permission for certain purposes, such as reporting the news or schoolwork. It doesn’t define “limited,” though, so be 
sure you don’t overuse material. The fair use doctrine requires you to give credit to the author or creator of any 
material you use.


Creative Commons is a set of copyright licenses that allow for the distribution of copyrighted works. The range of 
four conditonal licences provide a set of “baseline rights”that allow for the distribution of copyrighted work 
worldwide, without change, at no charge. The four conditions include: Attribution, Noncommercial, No Derivative 
works, and Share-alike. Creative Commons licenses permit the mixing and matching of conditions to produce 
suitable copyright licences conditions. For more info, see: http://creativecommons.org/


Derivative works are copyrighted materials that have been altered or changed. Such material is protected by copyright 
laws. If you alter a copyrighted photograph by using computer software, that photograph is still protected, and you 
may not use it without written permission.


Academic standards for copyrighted material are higher than others. Because scholars and researchers study so many 
different ideas and are responsible for sharing those ideas with the world, they are required to satisfy higher standards 
of honesty. They must give credit not only when quoting someone else’s exact words but also for the ideas those 
words represent. As a researcher, you cannot paraphrase what someone else says and not give credit for it.


Bibliographies are lists of sources that have been used in research. When using the Internet for research or for design 
work, you need to give credit where it is due. Often, people who use graphics and images from the Internet for 
publication on their own web page create a list of image credits rather than a bibliography.


Rules of Copyright
1. You cannot use copyrighted material without written permission from the creator of the material (or from its 


copyright holder).


2. Material can be protected even if it does not display the © symbol. Even if no mention is made regarding 
copyright, you must assume that all material from another source is protected.


3. Penalties for violating copyright laws can range from mild to severe. If you break the copyright law, you might 
simply receive an e-mail message from the author asking you to stop using the material. If you publish the 
material on a website, the webmaster might shut down your site. Or you could be sued by the author or 
prosecuted by federal authorities.


4. To make sure you are not violating any copyright law, it is important that you do the following:


• Write or send e-mail to the author or creator and ask permission to use the material. Do not use it until you 
are given permission. 


• Follow the directions on the site regarding use of material. You might be asked to create a link on your page 
or to notify the author or creator. 


• Most important: Do not use any material if you don’t have written permission. 
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5. Copyright notice is no longer required to obtain protection, but it is often beneficial. Copyright notice for 
visually perceptible material should contain the following three elements:


• The symbol © (the letter C in a circle), or the word “Copyright,” or the abbreviation “Copr.”


• The year of first publication


• The name of the owner of copyright


◦ Example: © 2012 Adobe Systems Incorporated


6. Copyright notice for phonorecords and sound recordings should contain the following three elements.


• The symbol ℗ (the letter P in a circle)


• The name of the owner of copyright


• The year of first publication


7. The copyright notice should be affixed in such a way as to “give reasonable notice of the claim of copyright.”


For more information on copyrights, visit the United States Copyright Office on the Internet at www.copyright.gov. 
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How to check links
Use the Check Links feature to search for broken links and orphaned files (files that still exist in the site but that 
aren’t linked to by any other files in the site) (Figure 1). You can search an open file, a portion of a local site, or an 
entire local site.


Checking links in a local site


Figure 1 Link Checker panel


Dreamweaver verifies links only to documents within the site; Dreamweaver compiles a list of external links in the 
selected document or documents but does not verify them.


You can also identify and delete files that are no longer used by other files in your site.


To check links in a local site:


1. Start Dreamweaver.


2. In the Files panel, select a site from the Current Sites 
pop-up menu.


3. Select Site > Check Links Sitewide.


The Broken Links report appears in the Link Checker 
panel (Figure 1).


4. In the Link Checker panel, select External Links or 
Orphaned Files from the Show pop-up menu to view 
another report. 


A list of files that fit the report type you selected appears 
in the Link Checker panel.


Note: If you select Orphaned Files as your report type, 
you can delete orphaned files from the Link Checker 
panel by selecting a file in the list and pressing the Delete 
key. 


5. Fix any broken links and check the links again.


Note: To clear the current Link Checker results, select 
Clear Results from the Link Checker Options menu.


Figure 2 Files panel


Link Checker Options menu


Current 
Sites menu
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How to optimize images
You can use the Optimize panel to specify optimization settings for images to be used in web pages. Exporting 
graphics from Adobe Fireworks CS6 is a two-step process. Before you export, you must optimize graphics—select 
options that make the graphics look as good as possible while restricting file size so that the graphics download as 
fast as possible.


The first step is to determine which type of file you plan to export, such as GIF, PNG, or JPEG:


• GIF (Graphic Interchange Format) is a bitmap image format best used for images with large areas of solid, 
flat color, such as simple illustrations, logos, and text. GIFs support transparency and store up to 8 bits per 
pixel that allow a single image to use 256 distinct colors. GIFs also support animations.


• PNG (Portable Network Graphics) was created to improve upon the limitations of GIFs . PNG supports 8-bit 
color and can display up to 256 colors. PNG also supports 24- and 32-bit color, suitable for compressing 
continuous-tone images. However, this may produce much larger files than GIF or JPEG format. The 
advantage of using PNG 24 and PNG 32 is they can preserve up to 256 levels of transparency in an image.


• JPEG (Joint Photograph Experts Group) is a bitmap image format best used for photographs or for images 
with subtle changes in color, gradations, or lighting. JPEG is generally used for photographic images or 
images with gradients and many colors. JPEG format does not support transparency or animation. 


Each graphic file format in Fireworks has a set of optimization options. For web file formats such as GIF and PNG, 
you can specify the amount of compression. By using the Optimize panel, you can optimize JPEGs by setting 
compression and smoothing options.


Options for GIF optimization
In the Optimize panel, you can specify the amount of compression for GIFs (Figure 1).  Fireworks optimization 
settings are similar for all 8-bit graphic file formats, which includes GIFs. 


Figure 1 GIF Optimize panel in Fireworks


Saved Settings: Use Saved Settings to select a preset image-quality setting for export. For GIF, these include GIF Web 
216, GIF WebSnap 256, GIF WebSnap 128, GIF Adaptive 256, and Animated GIF WebSnap 128.


Matte: If you want to anti-alias an image for multiple exports with different-colored backgrounds, click the Matte 
color box and select a color for the background of the image. This is useful for creating a smoother border for the 
image, particularly if the image will appear on web pages with different-colored backgrounds. 


Colors: Control the number of colors in the image. This number is automatically configured from the Saved Settings 
selection. Decreasing the number of colors decreases the file size but can also lower image quality.


Saved Settings


Export File Format


Indexed Palette


Transparency


Add Color To Transparency
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Dither: The Dither option is useful for images with many color gradations. Dithering approximates colors not in the 
current color palette by alternating two similar colors. Increasing the Dither setting can greatly increase file size, so 
consider using JPEG format instead of dithering the image.


Loss: Lower the image quality on export. Higher loss settings can yield smaller files but lower image quality. A loss 
setting of 0 is preferable, but if you need to reduce the file size of the image, a loss setting between 5 and 15 typically 
yields the best results.


Transparency: Remove the background color or halos around an image so in a web browser the background of the 
web page is visible through those areas. (This capability is a key advantage of exporting images as GIFs.) Index 
Transparency removes the background color. Alpha Transparency removes the background of an image if its canvas 
color is transparent. Use the Add Color To Transparency button (Figure 1) to remove specific colors from the image.


Optimizing a GIF image


With Adobe Fireworks CS6, you can compare different versions of the same graphic to create the best quality with 
the smallest file size. As you experiment with different optimization settings, use the 2-Up and 4-Up buttons to test 
and compare a graphic's appearance and estimated file size (Figure 2). 


Figure 2 Comparing GIF optimization settings


To optimize a GIF image:


1. Open a completed graphic in Fireworks.


4-Up Button
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2. In the Optimize panel, select GIF from the Export File Format menu (Figure 1). Then select the type of GIF you 
want from the Indexed Palette menu. 


Adaptive or Web Adaptive is best for most small web images.


3. Click the 4-Up button to compare different versions of the image (Figure 2).


Make sure the image is visible. (If necessary, use the Hand tool to drag the image into the middle.) 


4. Use the Pointer tool to select in turn each of the three alternate versions of the original image, and try different 
settings in the Optimize panel to find the smallest file size with the most acceptable quality:


• To adjust the image for many color gradations, increase the Dither setting.


• To make the file smaller, increase Loss (usually between 5 and 15).


• To remove the background color or halos around the image, select Index Transparency.


• To remove specific colors from the image, use the Add Color To Transparency button. This capability is a 
key advantage of exporting images as GIFs.


As you try different settings, note the file size and download time for each quality level.


5. To export the image version you prefer, click it and select File > Export. Name the file with a .gif extension.


6. To save the richest version of the file, select File > Save As and save the image as a Fireworks PNG file (with a 
.png extension).


Options for PNG optimization
GIF is the standard format for compressing images with flat color and crisp detail, such as line art, logos, or 
illustrations with type. Like the GIF format, the PNG-8 format efficiently compresses solid areas of color while 
preserving sharp detail. Fireworks optimization settings are similar for all 8-bit graphic file formats such as GIF, PNG 
8, TIFF 8, BMP 8, and PICT 8 (Figure 3).


PNG-24 is suitable for compressing continuous-tone images; however, it produces much larger files than JPEG 
format. The advantage of using PNG-24 is that it can preserve up to 256 levels of transparency in an image.


Figure 3 PNG-8 Optimize panel


Export File Format: Use this menu to select an image-quality setting for export. For PNG, these include PNG 8, PNG 
24, and PNG 32.


Export File Format


Transparency


Saved Settings
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Matte: If you want to anti-alias an image for multiple exports with different-colored backgrounds, click the Matte 
color box and select a color for the background of the image. This is useful for creating a smoother border for the 
image, particularly if the image will appear on web pages with different-colored backgrounds. 


Colors: Control the number of colors in the image. Decreasing the number of colors decreases the file size but can 
also lower image quality.


Dither: The Dither option is useful for images with many color gradations. Dithering approximates colors not in the 
current color palette by alternating two similar colors. Increasing the Dither setting can greatly increase file size, so 
consider using JPEG format instead of dithering the image.


Transparency: Remove the background color or halos around an image so in a web browser the background of the 
web page is visible through those areas. Index Transparency removes the background color. Alpha Transparency 
removes the background of an image if its canvas color is transparent. Use the Add Color To Transparency button to 
remove specific colors from the image.


Optimizing a PNG image


With Fireworks, you can compare different versions of the same PNG file to create the best quality with the smallest 
file size. As you experiment with different optimization settings, use the 2-Up and 4-Up buttons to test and compare a 
graphic's appearance and estimated file size (Figure 4). 


Figure 4 Comparing PNG optimization settings


To optimize a PNG image:


1. Open the completed graphic in Fireworks.


2. In the Optimize panel, select PNG 8 from the Export File Format menu.


3. Click the 4-Up button to compare different versions of the image (Figure 4). 


Make sure the image is visible in the display area. (If necessary, use the Hand tool to drag the image into the 
middle.)
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4. Use the Pointer tool to select in turn each of the three alternate versions of the original image, and try different 
settings in the Optimize panel to find the smallest file size with the most acceptable quality.


You can adjust the following settings for PNG 8:


• To adjust the image for many color gradations, increase the Dither setting.


• To remove the background color or halos around the image, select Index Transparency.


• To remove specific colors from the image, use the Add Color To Transparency button. 


You can adjust the following setting for PNG 24 and PNG 32:


• To select a matte color, click the Matte color swatch and select a color in the color picker.


• To save an image with multilevel transparency (up to 256 levels), select Transparency. The Matte option is 
disabled since multilevel transparency allows an image to blend with any background color.


As you try different settings, note the file size and download time for each quality level.


5. To export the image version you prefer, click it and select File > Export. Name the file with a .png extension.


Options for JPEG optimization
Using the Optimize panel, you can optimize JPEGs by setting compression and smoothing options (Figure 5). JPEGs 
are always saved and exported in 24-bit color, so you can't optimize a JPEG by editing its color palette. The color 
table is empty when a JPEG image is selected.


Figure 5 JPEG Optimize panel


Saved Settings: Select from preset image-quality settings for export. For JPEG, these include JPEG Better Quality and 
JPEG Smaller File.


Matte: If you want to anti-alias an image for multiple exports with different-colored backgrounds, click the Matte 
color box and select a color for the background of the image. This is useful for creating a smoother border for the 
image, particularly if the image will appear on web pages with different-colored backgrounds.


Quality: Adjust the quality of the image. Lower quality decreases file size; higher quality increases file size.


Selective Quality: Adjust the quality of only the selected part of the image while leaving the rest of the image intact. 
Areas of particular interest in an image can be compressed at a higher quality level than the rest of the image. Used 
with a JPEG mask.


Smoothing: Blurs hard edges in the image and reduces file size.


Export File Format


Saved Setings
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Optimizing a JPEG image


With Adobe Fireworks CS6, you can compare different versions of the same graphic to create the best quality with 
the smallest file size. As you experiment with different optimization settings, use the 2-Up and 4-Up buttons to test 
and compare a JPEG file's appearance and estimated file size (Figure 6).


Figure 6 Comparing JPEG optimization settings


To optimize a JPEG image:


1. Open the completed graphic in Fireworks.


2. In the Optimize panel, select JPEG from the Export File Format menu.


3. Select the 4-Up button to compare different versions of the image (Figure 6). 


Make sure the image is visible in the display area. (If necessary, use the Hand tool to drag the image into the 
middle.)


4. Use the Pointer tool to select in turn each of the three alternate versions of the original image, and try different 
settings in the Optimize panel to find the smallest file size with the most acceptable quality. 


• From the Saved Settings menu, select JPEG - Better Quality or JPEG - Smaller File for preset quality values.


• Try different values for the Quality setting.


• To make the file smaller, increase the Smoothing.


As you try different settings, note the file size and download time for each quality level.


5. To export the image version you prefer, click it and select File > Export. Name the file with a .jpg extension.
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6. To save the richest version of the file, select File > Save As and save the file as a Fireworks PNG file (with a .png 
extension).


Using a JPEG mask for further optimization (optional)


In some cases, you may want to leave points of interest in the image relatively uncompressed, while compressing 
background areas more heavily. You can do so by using a JPEG mask.


To create a JPEG mask:


1. Click the Original button to return to the (single) original 
image.


2. Use the Marquee or Lasso tool to outline the point of 
interest in your image.


3. With the point of interest selected, choose Select > Select 
Inverse.


This selects everything except the point of interest of the 
image. A marquee surrounds the inverse selection 
(Figure 7). 


4. To make changes only to the region outside the point of 
interest, select Modify > Selective JPEG > Save 
Selection As JPEG Mask. 


A highlight color appears on everything except the point 
of interest of the image.


In the Optimize panel, you can now make changes to the 
value for Selective Quality. Reducing this number retains 
the image quality of the point of interest but reduces the 
quality of the background and thereby reduces the file 
size. 


5. Click the Preview button to see the effect of your 
changes.


Figure 7 Inverse selection
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How to analyze Flash content
This guide and worksheet provide an example analysis of a Flash website and a worksheet for students to use in their 
evaluation of a Flash website. 


Sample analysis
This sample analysis of a Flash website illustrates some techniques designers use to target a specific audience.


URL: georgewashington.si.edu/


Name of the site: George Washington: A National Treasure


What is the main type of audience the site is targeting? How does the site target this audience?


The main audience includes teachers who might use the information on this site for a unit on George Washington, 
history, culture, or art.


Identify the following Flash techniques and explain what part of the site uses them:


Motion tweens


When you launch the site, the white and red bars that expand and contract are a motion tween, as is the white star 
that appears.


Shape tweens


The white star that turns into the profile of George Washington is possibly a shape tween.


Movie clips


The rotating star that appears when your pointer is over the words “Explore the Portrait” is a movie clip.


Buttons


After you enter the portrait and click “Explore the Portrait,” the boxes at the top of the portrait, labeled Symbolic, 
Biographic, and Artistic, are all buttons. The numbers that appear on the portrait are also buttons.


Sound (How many sounds do you hear? How many times does the sound seem to loop?)


There are no sounds in the portrait.


stop actions


There is probably a stop action placed after the red and white stripes complete their motion tweens, to hold visitors at 
a screen before they decide to enter the portrait.


go to and play actions


There is most likely a go to and play action set on each of the main buttons over the portrait and the numerical 
buttons on the portrait.


Combinations of symbols (such as buttons that contain animated movie clips)


The “Enter the Portrait” button on the initial screen is a combination of a button and a movie clip, because the movie 
clip appears only when the pointer is over the button.
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Challenge:
For the complicated effects you see, suggest combinations or types of techniques that might be involved in creating 
them.


When the pointer rolls over one of the numbers on the portrait, these buttons fade all other parts of the image out and 
highlight the section of the image to which the number is attached. These buttons most likely contain an action that 
calls a movie clip to begin playing when the Over state is reached on the button. The movie clip fades out all aspects 
of the picture except the aspect related to the number you select.


Describe a surprising technique.


The magnifying glass is a surprising technique that adds to the overall feel of the site. Drag the pane up from the 
bottom of the portrait to magnify the portion of the portrait under the pane.


Describe a challenging technique.


The magnifying glass is a challenging technique. It most likely involves the use of programming with ActionScript.


Describe unidentified techniques.


It is difficult to tell how the magnifying glass might be achieved.


Describe a creative design.


A creative effect is the fading out and zooming in on aspects of the portrait when you click a number button.
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Worksheet
Student name:_________________________________________________ Date:________________________


Examine some websites, games, or applications that use Flash to see examples of the techniques designers use to 
target a variety of audiences. Use this worksheet to record your observations.


URL: ________________________________________________________________________________________


Name of the site: _______________________________________________________________________________


What is the main type of audience the site is targeting? How does the site target this audience?


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


Identify the following Flash techniques and explain what part of the site uses them:


Motion tweens


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


Shape tweens


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


Movie clips


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


Buttons


_____________________________________________________________________________________________


_____________________________________________________________________________________________
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_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


Sound (How many sounds do you hear? How many times does the sound seem to loop?)


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


stop actions


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


go to and play actions


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


Combinations of symbols (such as buttons that contain animated movie clips)


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


Challenge:
For the complicated effects you see, suggest combinations or types of technical techniques that might be involved to 
create them.


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________
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Describe a surprising technique.


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


Describe a challenging technique.


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


Describe unidentified techniques.


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


Describe a creative design.


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________
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//This causes the timeline to stop on frame 1stop();button_news.addEventListener(MouseEvent.CLICK, fl_ClickToGoToAndStopAtFrame_news);function fl_ClickToGoToAndStopAtFrame_news(event:MouseEvent):void{	gotoAndStop("News");}button_map.addEventListener(MouseEvent.CLICK, fl_ClickToGoToAndStopAtFrame_map);function fl_ClickToGoToAndStopAtFrame_map(event:MouseEvent):void{	gotoAndStop("Map");}



© 2012 Adobe Systems Incorporated.  All Rights Reserved.



Copyright 2012 Adobe Systems Incorporated.  All rights reserved. 

INTRODUCTION TO DESIGN PRINCIPLES

MOVEMENT, BALANCE, UNITY, CONTRAST, EMPHASIS, LINE, AND COLOR





















®





© 2012 Adobe Systems Incorporated.  All Rights Reserved.



Design elements

		Design elements are the building blocks of graphics.

		Line

		Color 

		Shape 

		Texture 



*
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Lines

		Lines can be straight or curved.

		How are lines used in the composition on this slide?



*
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Color definitions

		Hue is another word for color.

		Chroma is the intensity or purity of color.

		Tint is a color mixed with white.

		Tone is a color mixed with gray.

		Shade is a color mixed with black.



*
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Color wheels

		Analogous colors are adjacent to each other on the color wheel.

		Complementary colors are opposite each other on the color wheel.



*



*









© 2012 Adobe Systems Incorporated.  All Rights Reserved.



Color in design

		Use color to label or show hierarchy.

		Use color to represent or imitate reality.

		Use color to unify, separate, or emphasize.

		Use color to decorate.

		Use color consistently.



*



*









© 2012 Adobe Systems Incorporated.  All Rights Reserved.



Shapes

		Shapes are enclosed objects that can be created by line or created by color and value changes that define their edges. 



*



*
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Texture

		Texture is the surface look of an object created by varying dark and light areas.

		Roughness

		Smoothness

		Depth



 

*





*
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Design principles

		Design principles are ways in which elements are used together.

		Movement 

		Balance 

		Emphasis 

		Unity 



*



*









© 2012 Adobe Systems Incorporated.  All Rights Reserved.



Movement

		Movement is the use of lines, color, and repetition to create the illusion of motion.

		Curved forms or lines 

		Repetition of geometric forms 

		Fuzzy lines or outlines



*















*
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Lines

		Lines can indicate motion or direction.

		How are lines used in the composition on this slide?



*



*
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Balance

		Balance is the act of comparing or estimating two things, one against the other, and the contrast between:

		Empty space (white space) and filled space

		Text and images

		Color and no colors and different colors

		Textures against flat colors



*









*

Ask students if they can think of other types of balance: texture and no texture (smooth), size and scale, elements of a composition.
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Balance in composition

		There are three different types of balance when using color, shape, and position:

		Symmetry

		Asymmetry

		Radial symmetry



*



*
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Symmetrical or formal balance

		You can usually identify at least one of three lines of symmetry.

		Horizontal

		Vertical

		Diagonal



*



*
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Symmetrical balance

*



*

The rectangle has three lines of symmetry: Horizontal (blue), Vertical (red), Diagonal (yellow).

The triangle has only one line of symmetry: center or, in this orientation, Vertical. You can draw two other lines of symmetry from any of the vertices to the center of the opposite side.
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Examples of symmetrical balance

*



*
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Examples of asymmetrical balance

*



*
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Examples of radial balance

*



*
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Unity

		Unity: The correct balance of composition or color that produces a harmonious effect.

		What is the focus of the message?



*



*
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Emphasis

		Emphasis: To express with  particular stress or force.

		What message is stressed here?



*



*
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Summary

		The basis of good design is use of design elements and their thoughtful application in the form of design principles.

		Clearly identify what you are trying to accomplish — use design to convey your message.

		Brainstorm alternatives.



*



*
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How to use CSS starter layouts
When creating a new document in Dreamweaver, you can choose one that already contains a CSS layout. 
Dreamweaver comes with many different CSS layouts from which to choose (Figure 1). The predesigned CSS 
layouts provide the following types of columns:


• Liquid layouts specify column width as a percentage of the site visitor’s browser width. The design adapts if 
the site visitor makes the browser wider or narrower, but does not change based on the site visitor’s text 
settings.


• Fixed layouts specify column width in pixels. The column does not resize based on the size of the browser or 
the site visitor’s text settings.


The New Document dialog box also includes two options for HTML5 and CSS layouts.


Figure 1 New Document dialog box


Using a starter layout
Starter layouts are available as an option in the New Document dialog box.


To use a starter layout:


1. Start Dreamweaver.


2. Select  File > New.


The New Document dialog box opens (Figure 1).


3. Select the Blank Page category if not already selected.


4. For Page Type, select HTML.


Attach Style Sheet button
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5. For Layout, select the CSS layout you want to use. 


You can choose from 16 different layouts. The Preview 
window shows the layout and gives a brief description of 
the selected layout.


The selection illustrated in Figure 1 is a 2-column liquid 
layout with a left sidebar, header, and footer is selected.


6. Select a location for the layout’s CSS from the Layout 
CSS pop-up menu:


• Add To Head adds CSS for the layout to the head of 
the page you’re creating.


• Create New File adds CSS for the layout to a new 
external CSS stylesheet and attaches the new 
stylesheet to the page you’re creating.


• Link To Existing File lets you specify an existing 
CSS file that already contains the CSS rules needed 
for the layout. This option is particularly useful when 
you want to use the same CSS layout (the CSS rules 
for which are contained in a single file) across 
multiple documents.


7. Do one of the following: 


• If you selected Add To Head from the Layout CSS 
pop-up menu (the default option), click Create. 


• If you selected Create New File from the Layout 
CSS pop-up menu, click Create, and then specify a 
name for the new external file in the Save Style 
Sheet File As dialog box. 


• If you selected Link To Existing File from the 
Layout CSS pop-up menu, add the external file to 
the Attach CSS File text box by clicking the Attach 
Style Sheet button, completing the Attach External 
Style Sheet dialog box, and clicking OK. When 
you’re finished, click Create in the New Document 
dialog box.


Note: When you select the Link To Existing File 
option, the file you specify must already have the 
rules for the CSS file contained within it.


When you put the layout CSS in a new file or link to an 
existing file, Dreamweaver automatically links the file to 
the HTML page you’re creating.


The layout opens in Dreamweaver (Figure 2).


8. (Optional) You can modify some aspects of a page (font, 
font size, colors and margins) after it’s created by 
selecting Modify > Page Properties to open the Page 
Properties dialog box (Figure 3).


Figure 2 Dreamweaver CSS starter layout


Figure 3 Page Properties dialog box
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How to ease tweens
Easing is a technique for modifying the way Adobe Flash Professional CS6 calculates the property values between 
property keyframes in a tween. Without easing, Flash calculates these values so the change to the value is the same in 
each frame. You can use easing to adjust the rate of change to the values for more natural or more complex animation.


An ease is a mathematical curve you apply to the property values of a tween. The final effect of the tween is the result 
of the combination of the range of property values in the tween and the ease curve.


You can apply easing in the Motion Editor for motion tweens or in the Properties panel for classic tweens. Eases 
applied in the Motion Editor can affect a single property, a group of properties, or all properties of a tween. Eases 
applied in the Properties panel affect a single property or all of the properties included in a tween.


Flash includes a range of preset eases you can apply for simple or complex effects. In the Properties panel or Motion 
Editor, you can also create your own custom ease curves.


One of the many common uses of easing is when you have edited a motion path on the Stage and enabled roving 
keyframes to make the speed of motion consistent in each segment of the path. You can then use easing to add more 
realistic acceleration and deceleration at the ends of the path.


Easing individual properties for motion tweens in the Motion Editor
You can apply a preset ease to an individual property or a category of properties in the Motion Editor. In the following 
steps, you first create a motion tween and then add a preset ease to the tween.


To apply a preset ease:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Draw a shape on the Stage.


3. Using the Selection tool, double-click to select the shape 
fill and stroke, if present.


4. Choose Modify > Convert To Symbol. 


The Convert To Symbol dialog box appears.


5. Type a new name for the symbol in the Name text box, 
select Graphic for Type, and click OK.


6. Insert a frame at frame 40.


7. Make sure frame 40 (the end frame for the motion tween) 
is selected and select Insert > Motion Tween.


8. With frame 40 still selected, use the Selection tool to 
move the object to a different position on the Stage.


9. In the timeline, select the motion tween by clicking 
anywhere in the tween span between the start and end 
frames. 


10.  Select Motion Editor tab (Figure 1).


11. In the Motion Editor, scroll down to Eases, click the Add 
Ease button (plus sign) and select an ease, such as Stop 
And Start (Medium) (Figure 2).


Figure 1 Timeline and Motion Editor tabs


Figure 2 Add Ease button in the Motion Editor


Add Ease button
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12. Scroll up to Basic Motion, and select the ease you just 
added from the Selected Ease menu (Figure 3).


13. Press Enter (Windows) or Return (Mac OS) to preview 
the eased tween.


Note: You can also click the Play/Pause at the bottom of 
the Motion Editor to play and pause the movie.


If you chose the Stop And Start (Medium) ease, for 
example, the tween will stop briefly and then begin 
again.


14. Click the Play/Pause button to stop the preview.


15. Adjust the eases in the tween until you achieve the 
desired effect. 


See the following section for information about adjusting 
ease curves.


Figure 3 Basic Motion Selected Ease menu


Figure 4 Motion Editor playback controls


Editing ease curves for motion tweens in the Motion Editor
Eases are displayed as ease curves in the right side of the Motion Editor. You can edit the shape of preset ease curves 
and create custom ease curves.


To edit ease curves for motion tweens:


• To edit a preset ease curve, change its values in the Value 
column in the Motion Editor (Figure 5). To do so, click 
on the value and drag to the left (negative) or right 
(positive) or type a new value.


• For simple ease curves, the value is a percentage 
representing the strength of the application of the 
ease curve to the property curve. Positive values 
increase the ease at the end of the curve. Negative 
values increase the ease at the beginning of the 
curve.


• For ease curves that are waves, such as the sine wave 
or sawtooth wave, the value represents the number of 
half-cycles in the wave.


• To edit a preset ease, first add it to the list of 
available eases by using the Add Ease button in the 
Ease section of the Motion Editor.


• To edit a custom ease curve, add it to the list of eases 
and then edit the curve by using the same techniques 
for editing any other Bezier curve.


Figure 5 Editing a simple ease curve


Play/Pause button
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Easing individual properties for classic tweens in the Properties panel 
For classic tweens, the Motion Editor is not available. You create eases for classic tweens by using the Properties 
panel.


To ease a classic tween:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Add a symbol to the Stage.


Note: You may need to add a shape, image, or text first 
and convert the object to a new symbol.


3. Select frame 40 in the timeline.


4. Select Insert > Timeline > Keyframe.


The tween will last for 40 frames.


5. Make sure frame 40 is still selected and move the symbol 
to a new position on the Stage.


6. Click on the tween span in the timeline and select 
Insert > Classic Tween. 


The classic tween span is light blue with an arrow 
(Figure 6).


7. Select frame 40, select the symbol on the Stage, and 
adjust the position, color, or scale of the symbol to be as 
you want the animation to end.


8. In the timeline, click anywhere in the tween span (but not 
on a keyframe) to select the classic tween.


9. In the Tweening section of the Properties panel, enter an 
Ease value to determine the strength of the ease, such as 
-60 (Figure 7).


Note: A negative value creates an “ease in.” A positive 
value creates an “ease out.”


10. To preview the animation on the Stage, press Enter 
(Windows) or Return (Mac OS).


Note: You can also click the Play/Pause at the bottom of 
the Timeline panel (Figure 4) to play and pause the 
movie.


Figure 6 Classic tween span in the timeline


Figure 7 Properties panel, Tweening section


Ease value
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Editing ease curves for classic tweens in the Properties panel 
In the Properties panel, you can edit the shape of ease curves to create custom ease ins and ease outs.


To edit ease curves:


1. In the timeline, select the classic tween that you created 
in the previous steps. 


2. Click the Edit Easing button next to the Ease value field 
in the Properties panel (Figure 8). 


The Custom Ease In / Ease Out dialog box appears 
(Figure 9).


3. (Optional) To display the curve for a property, deselect 
Use One Setting For All Properties, and select a property 
in the menu (Figure 10).


You can add control points anywhere along the curve to 
help you manipulate the curve.


4. Click on the curve in the Custom Ease In/Ease Out dialog 
box to add a new control point. 


5. To increase the speed of the object, drag the control point 
up; to slow down the speed of the object, drag it down.


Figure 8 Properties panel, Tweening section 


Figure 9 Custom Ease In / Ease Out dialog box


Figure 10 Easing property menu


Edit Easing button
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6. To further adjust the ease curve and fine-tune the ease 
value of the tween, drag the vertex handles (Figure 11).


7. To view the animation on the Stage, click the play button 
in the lower left corner of the Ease In / Ease Out dialog 
box (Figure 11).


8. Adjust the curve until you achieve the desired effect.


9. Click OK to confirm your changes and close the Ease In/
Ease Out dialog box.


Note: If you use the Custom Ease In / Ease Out dialog 
box to apply a custom ease to a frame, the Ease value edit 
box displays '--'. If you use the edit box or the pop up 
slider to apply an ease value to a frame, the Custom Ease 
graph is set to the equivalent curve, and the Use One 
Setting For All Properties option is selected.


Figure 11 Ease curve


Play button Vertex handles
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Project 3


Web development and 
deployment
Timing: 20 to 35 hours


Project overview


In this project, student teams use their client-approved design documents for the technical build of a 
website. Teams will learn about technical features to enhance the look and feel, consistency, and usability 
of their websites. They will also learn how to conduct technical and usability tests of their client websites 
and make any necessary revisions.


The main focus of this project is for students to develop reusable content, templates, and Cascading Style 
Sheets (CSS) based on the page layout described in their design documents and production storyboards. 
The emphasis is on collaboratively building websites for their clients by using web standards to complete 
their home pages and content pages. Each team will test and deploy its site, make any necessary revisions 
based on client review, and then redeploy the site. Teams will create a presentation for their clients 
explaining how the site accomplishes the client goals.


Student product: Client website


Note: Portions of the Web development and deployment project align to the Adobe Certified Associate, 
Web Communication objectives. Within the instruction steps and technical guides, the specific learning 
objectives for the exam are referenced with the following format: 1.1  


Project objectives


At the completion of the project, students will have developed the following skills:


Project management skills


• Following and executing a project plan


• Following and executing a wireframe and 
prototype


• Following up and following through on roles 
and responsibilities


• Defining and prioritizing tasks


• Producing deliverables and meeting deadlines 


• Managing files and using file-naming 
conventions


• Executing a review and redesign cycle


• Executing quality assurance tests


Design skills


• Providing consistency and accessibility


• Providing universal navigation


• Integrating images, text, and multimedia


• Planning graphics and multimedia based on 
needs and audience


• Creating web pages using web standards


• Designing with CSS


• Organizing pages with CSS


• Understanding HTML


• Using basic HTML


• Creating templates and reusable designs


• Adapting content for readability and emphasis


• Designing for multiple screens


• Considering screen size and device 
requirements
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• Incorporating layout and color consistently


• Designing a quality assurance test


Research and communication skills


• Communicating ideas clearly


• Presenting a website to a group


• Taking notes on critique


• Providing meaningful but not overly critical 
feedback


• Listening and interpreting information and 
feedback


• Demonstrating the realization of redesign goals


• Conducting usability analysis


• Creating quality assurance tests


Technical skills


Fireworks


• Optimizing images


• Creating buttons


• Creating navigation bars


• Creating pop-up menus


Photoshop


• Resizing images


• Rotating images


• Cropping images


Dreamweaver


• Understanding the Dreamweaver workspace


• Setting up a web project


• Setting document properties


• Using the Insert, Files, and Assets panels


• Inserting images


• Inserting text


• Creating lists


• Creating data tables


• Creating image maps


• Using CSS starter layouts


• Using CSS text styles


• Creating, modifying, and troubleshooting CSS


• Creating templates


• Developing a website for multiple screens


• Checking files in and out


• Inserting HTML5 video


• Checking links


• Testing in Adobe BrowserLab


• Publishing web files


Project materials
• Adobe Fireworks CS6 installed on all machines


• Adobe Photoshop CS6 installed on all 
machines


• Adobe Dreamweaver CS6 installed on all 
machines


• Dreamweaver guide: Overview of the Adobe 
Dreamweaver CS6 workspace


• Dreamweaver guide: How to set up a local root 
folder and site structure


• Dreamweaver guide: How to set document 
properties


• Dreamweaver guide: How to use CSS starter 
layouts


• Guide: File-naming conventions


• Worksheet: File management


• Dreamweaver guide: How to manage files and 
links by using the Files panel


• Guide: Introduction to HTML and CSS


• Dreamweaver guide: How to lay out a web 
page with CSS


• Dreamweaver guide: How to create and edit a 
CSS rule


• Dreamweaver guide: How to create lists


• Presentation: Reusable design


• Dreamweaver guide: How to use the Assets 
panel


• Dreamweaver and Fireworks guide: How to 
create interactive navigation


• Fireworks guide: How to optimize images


• Photoshop guide: How to resize, rotate, and 
crop images


• Dreamweaver guide: How to work with 
external Cascading Style Sheets
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• Dreamweaver guide: How to troubleshoot 
Cascading Style Sheets


• Dreamweaver guide: How to use templates


• Dreamweaver guide: How to check files in and 
out


• Dreamweaver guide: How to add text from 
another document


• Dreamweaver guide: How to use CSS text 
styles


• Dreamweaver guide: The Dreamweaver Insert 
panel


• Dreamweaver guide: How to create links


• Dreamweaver guide: How to create data tables


• Dreamweaver guide: How to add rich media to 
a web page


• Electronic file: Sample_Flash-Movie.fla


• Electronic file: Sample_Flash-Movie.swf


• Electronic file: Sample_Flash-Video.flv


• Electronic file: Sample_HTML5-Video.webm


• Electronic file: Sample_HTML5-video.mp4


• Electronic file: Sample_HTML5-video.ogv


• Electronic file: Sample_audio.mp3


• Dreamweaver guide: How to create forms


• Dreamweaver guide: How to create image 
maps


• Presentation: Web design for multiple screens


• Dreamweaver guide: How to deploy for 
multiple screens


• Guide: Technical features and their design 
solutions


• Dreamweaver guide: How to check links


• Dreamweaver guide: How to preview and test a 
web project


• Worksheet: Design review


• Dreamweaver guide: How to publish web files


• Worksheet: How to promote a website


• Worksheet: Review and redesign


Background preparation resources
• Technical and content information


• Key terms


• ISTE NETS*S Standard for Students


• Adobe Certified Associate, Web Communication objectives


Project steps


1. Introduce students to the goals of the project. Explain that they will use their design documents, 
storyboards, and prototypes from Project 2 to build, test, and publish their client websites:


• Learn web development best practices


• Implement reusable designs


• Build a website with web standards


• Design for multiple screens


• Conduct technical and usability tests


• Publish, present, and launch a website
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Web development best practices
(Suggested time: 150–250 minutes)


2.  Explain that students will use Adobe Dreamweaver for the production of the website for which they 
defined, structured, and created a prototype in Project 2. Remind students to continually refer to and 
assess their project plans throughout the site build to make sure they are on task, team members are 


aware of responsibilities, and deliverables are completed by the expected due dates.1.6


3. Ask students to start Dreamweaver. Briefly review the Dreamweaver interface that was introduced in 
Project 1. Review how to work with panels, how to access preset workspaces, and how to customize 
the workspace.


Dreamweaver guide: Introduction to the Adobe Dreamweaver CS6 workspace 3.1, 3.6


4. Briefly discuss the options for setting up a web project:


• How to determine the kind of web project to create. Discuss the differences between HTML1.x, 
HTML4, and HTML5 DOCTYPES.4.1


• How to create a new blank page.4.3


• How to create a new blank template, a page from a template, and a page from a sample.5.5


• How to use and modify CSS starter layouts.5.8 


• How to use templates.5.5


• How to use Fluid Grid Layouts for mobile, tablet, and desktop versions of a website layout. 


• How to set up a local root folder and site structure.4.2


• How to define and modify document properties.5.1


Dreamweaver guide: How to set up a local root folder and site structure 4.2


Dreamweaver guide: How to set document properties 3.3, 5.1


Dreamweaver guide: How to use CSS starter layouts 5.8


Note:More instruction on how to set up and use templates and Fluid Grid Layouts is available later in 
this project.


5. Ask students to open a new document, save it, define the site structure, and name the file index.html. 


Discuss the following: 4.3


• Extensions for filenames and what each means (e.g., .html, .htm, .php)


• Using index.html or default.html as the default filename for a home page


• Rules and best practice for naming HTML files (e.g., maximum characters, forbidden characters, 
lowercase letters, underscores and spaces)


6. Use a class brainstorm to introduce file management, generating reasons for file organization. 4.3 
Questions to ask the class include:


• What is file management?


• Why is it important?


• How might you organize a set of files?
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7. Ask students to propose ways they might organize their files in Dreamweaver and conventions that 
might help manage their files and folders, such as using names that help others recognize the contents 
of a folder or file. Decide as a class what conventions you will use.


Guide: File-naming conventions 4.3


Worksheet: File management


8. Briefly introduce students to the Files panel in Dreamweaver. Ask students to open Dreamweaver and 
look at the Files panel. Discuss and define the following terms, relating them to interface elements in 
the Files panel:


• Dreamweaver site map


• Get files


• Put files


• FTP


• Local host


• Testing and remote servers


• Publish


To round out students’ knowledge of the Files panel, show them how to use the panel to maintain site 
files and links.


Dreamweaver guide: How to manage files and links by using the Files panel 3.5, 6.4


9. Briefly review the principles of using HTML to code a web page and CSS to specify the layout and 
styles for a website. In this discussion, emphasize and demonstrate the following: 


• HTML and CSS as web standards and the current iterations of HTML5 and CSS3


• Specific HTML tags such as HEAD, TITLE, BODY, H1-H6, P, EM, STRONG, A HREF, TABLE, 
TR, TD, OL, LI, UL


• Using HTML5 best practices such as DOCTYPE so a browser knows what version of HTML the 
page is written in and can render it correctly, meta charset so a browser knows the character-set of 
the website, and semantic markup tags to enhance the website’s structure 


• New HTML5 elements and their capabilities, such as section, article, aside, hgroup, header, footer, 
nav, figure, video, audio, embed, wbr, and canvas 


Guide: Introduction to HTML and CSS 4.1, 5.2, 5.6


10. Explain how to control the design and layout of a page by placing div tags and then adding content to 
them. The rectangles students drew for images, text blocks, and navigation on their wireframes 
represent div tags in their Dreamweaver documents. Explain the difference between absolute, relative, 
fixed, and static positioning of div tags. Explain how they can use CSS3 to create web-page layout 
features such as tabs, animated drop-down menus, and accordions. Using the “I do, we do, you do” 
method, demonstrate how to place div tags corresponding to the blocks of information students 


sketched in their wireframes. 2.5


Dreamweaver guide: How to lay out a web page with CSS 5.2


Note: You might discuss the use of tables in the past for web-page layout. Explain to students that 
using div tags instead of tables creates a cleaner implementation of design and that CSS-based layouts 
are now the standard layout method in professional web design.
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11. From the specifications in their design documents, ask students to build a home page using CSS. 
Explain that students should create the CSS layout and add the CSS rules and styles for their website as 
outlined in their design document. To help them, demonstrate the following technical features: 


• How to use the CSS Styles panel to create and edit CSS rules 5.8


• How to use the Property panel to apply a style to a paragraph 3.3, 5.3


• How to use the Property panel to set off a block quotation by indenting it 3.3, 5.3


• How to use the Page properties dialog box to set document properties 5.1


Dreamweaver guide: How to create and edit a CSS rule 5.8


Note: Depending on the level of your students, you may want to discuss vendor prefixes. Until web 
standards are accepted across all modern web browsers, vendor prefixes are often needed within CSS 
style sheets. 


Implementing a reusable design
(Suggested time: 250–350 minutes)


12. Introduce and discuss the benefits of reusable design. Topics to cover include:


• How web standards such as CSS help make designs reusable and enable quick global changes


• How reusable designs can make for less work on future projects


• How such things as code snippets, templates, CSS Starter Layouts, and other elements can be 
reused


• How reusable design is especially helpful when designing for multiple devices


• How reusable design can help keep a website current even in older browsers


Presentation: Reusable design 5.8


13. Discuss the importance of templates, assets, and libraries as tools for promoting consistency in website 
design. Other techniques with which students should be familiar are managing reusable assets in the 
Assets panel, using library objects, applying styles to text, using standard fonts, and using web-safe 


colors.2.1


Note: You may want to discuss includes at this point. Explain that includes are sections of HTML that 
include content of one or more files from another web page. They are especially helpful for items such 
as logos, navigation, and copyright information that are repeated on most, or all, of your web pages. 
You can program includes to be client-side (cached on the client and viewable locally without a web 
server) or server-side (files on the web server).


14. Discuss the types of elements that can be stored in the Assets panel. Briefly demonstrate how to add an 
element to the Assets panel and how to place an element in a document by dragging or by using the 
Insert button. 


Dreamweaver guide: How to use the Assets panel 3.4


15. Using their wireframes, storyboards, and prototypes, ask each team to decide what will be on all pages 


of the site.2.5 Explain how using style sheets and templates for content pages helps keep the site 


consistent while the team produces the site.2.1
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16. Explain that Adobe Fireworks enables you to design the look and functionality of interactive graphics 
(such as buttons, links, and rollovers) and save them as HTML so you can import them into a 
Dreamweaver document. Explain that virtual buttons can have four states: Up, Over, Down, and Over 
While Down. The first three states are the most common. Demonstrate the following: 


• How to create a three-state button in Fireworks and how to set the active area for a button


• How to create a navigation bar in Fireworks


• How to create rollover images in Fireworks


• How to export to Dreamweaver


Fireworks and Dreamweaver guide: How to create interactive navigation 4.9


17. Explain that students will now begin to build out the assets and graphics for their client sites. Ask 
students to use Photoshop, Illustrator, and/or Fireworks to create the common graphic elements from 
their final comps, such as creating a navigation bar in Fireworks. Remind them that the look of their 
graphics should coordinate with their site designs. 


18. Explain that students should export graphics in a web-optimized file type and size. Introduce the file 
types available for graphics: GIF, JPEG, and PNG. Discuss how the file types differ and when it is 
appropriate to use each type of file. You might also distinguish between a Fireworks native PNG and a 


flattened PNG image. 4.5


19. Using large GIF and JPEG sample images, introduce the Optimize panel in Fireworks or the steps for 
resizing images in Photoshop and demonstrate to students the methods available for optimizing an 
image. Ask each team to optimize a JPEG or GIF. All JPEG groups should have the same image, and 
all GIF groups should have the same image. Have students save the images in two ways: graphic file as 
small as possible and graphic file as small as possible while keeping as much image quality as 
possible.


Fireworks guide: How to optimize images


Photoshop guide: How to resize, rotate, and crop images


20. Ask some teams to share their optimized images and discuss the benefits of optimization and the 
balance necessary to preserve quality.


21. Ask students to import each asset and graphic element, such as logos, buttons, and mottos, from 
Photoshop, Illustrator, or Fireworks into the Dreamweaver Assets panel, including the library, for later 
use throughout the site. Explain they will use these graphics on their home and content page templates 
and encourage them to create as many reusable assets and graphics as possible and use them across 
their content pages. 


22. Demonstrate how to edit and scale images in Dreamweaver and how to edit Photoshop (using 


Photoshop Smart Objects) and Fireworks assets from within Dreamweaver. 4.5, 5.4
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Building a website
(Suggested time: 300–400 minutes)


23. Once students have built their assets and graphic elements, remind students of their previous 
experience using CSS. Demonstrate how to use internal and embedded style sheets. Demonstrate how 
to turn internal styles into a new external style sheet. Ask students to start creating external style sheets 
for their client sites as they follow along with the demonstration. After the demonstration, have the 
students continue creating the style sheets for their client sites, applying what they have learned about 
creating and editing styles to implement the styles required by their design comps for the home page 
they created.


Dreamweaver guide: How to work with external Cascading Style Sheets 5.8


Dreamweaver guide: How to troubleshoot Cascading Style Sheets 5.8


Note: If you want students to learn specific technical techniques to prepare for the Adobe Certified 
Associate, Web Communication exam, introduce the Code Navigator, CSS Inspect, and Live view as 
useful tools for identifying the CSS rules applied to a web page; demonstrate how to use selector types 
such as descendent selectors, classes, the tag selector, pseudo class selectors, and group selectors; and 
show students how they can troubleshoot CSS issues by using tools such as CSS layout backgrounds.


24. Ask student teams to use Dreamweaver to create a template for their content pages, following their 
storyboards. Their templates should incorporate the style sheets they created. Students may need to 
supplement their style sheets with new styles or create new style sheets for their content pages. 
Encourage them to use div tags, paragraph styles for headings, and indentation to create and maintain a 
page structure and a meaningful content hierarchy. Students should insert the graphics they created in 
Photoshop, Illustrator, and/or Fireworks. Make sure they add editable regions and save their files as 
templates.


Dreamweaver guide: How to use templates 5.5


Note: If students are preparing for the Adobe Certified Associate, Web Communication exam, 
introduce the benefits of creating templates with sections for page content that can be edited through a 
web content management system such as In Context Editing.4.5 This allows clients to make simple text 
changes to the web pages themselves. 


25. Ask students to use their templates to create the rest of the pages for their client websites, inserting 
elements from the Assets panel as appropriate. Explain that by using a template, all team members can 
work on the pages while maintaining uniformity of site design. 


26. Now that students have a working knowledge of Dreamweaver, explain that you will go over some 
best practices for helping teams have efficient collaboration and organization. Introduce and 
demonstrate the following: 


• Explain that Subversion integration allows multiple team members to combine their individual 
edits into one comprehensive Dreamweaver document that has reconciled the edits made to the 
document. 


• Discuss how these procedures support collaboration within a team and eliminate the possibility 
that two team members may simultaneously make different changes to a file. 


• Discuss how subversion integration contributes to the best practices for working with a team.
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• Demonstrate the procedure for checking Dreamweaver files in and out; moving, copying, and 
deleting shared files; synchronizing changes with a remote Subversion SVN repository; and hiding 
files with File Cloaking.


Dreamweaver guide: How to check files in and out 6.4


Note: Knowledge of Subversion integration and check in/check out functions are part of the Adobe 
Certified Associate, Web Communication exam. If you are unable to install Subversion, introduce and 
discuss the usefulness of these features to prepare your students for the exam.


27. Students can now begin adding text, images, links, rich media, and other content to their content pages. 


Review how to add text to web pages, including adding lists.4.4, 5.3 Demonstrate how to use CSS text 
styles to define text styles across their websites. Demonstrate how to access and use web-hosted fonts. 


Dreamweaver guide: How to add text from another document 4.12


Dreamweaver guide: How to create lists 5.3


Dreamweaver guide: How to use CSS text styles 5.3, 5.8


Note: If students aren’t sure how to copy and paste text from a word-processing document and how to 
import text from a word-processing document, show them.


28. Review how to add graphics and links to content pages by using the Insert panel. Ask students to insert 
images, text, and other assets they may have, including those from the Assets panel and library. 


Dreamweaver guide: The Dreamweaver Insert panel 3.2, 4.5


29. Discuss the differences among the types of links: absolute, site-root-relative, and document-relative. 
Discuss link targets: _blank, _self, _parent, and _top. Discuss named anchors and ID attributes. Ask 
students to link some text on their home page to text on their content pages.


Dreamweaver guide: How to create links 4.6


30. Demonstrate how to add, adjust, and modify data tables to content pages. 


Dreamweaver guide: How to create data tables 4.11


Note: If students are preparing for the Adobe Certified Associate, Web Communication exam, be sure 
to cover creating data tables and importing tabular data from a Microsoft Excel spreadsheet.4.12 
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31. Discuss the best practices for adding video, audio, and other rich media elements to a web page. 
Discuss the difference between HTML5 and Flash video, especially for older browsers that don’t 
support HTML5 and mobile devices that may not support Flash video. Demonstrate how to insert 
Flash and HTML5 video into a web page. Demonstrate how to add audio to a web page. Demonstrate 
how to add Flash SWF files to a web page and edit them from within Dreamweaver. 


Dreamweaver guide: How to add rich media to a web page 4.7, 4.8


Electronic file: Sample_Flash-Video.flv


Electronic file: Sample_HTML5_video.ogv


Electronic file: Sample_HTML5_video.webm


Electronic file: Sample_HTML5_video.mp4


Electronic file: Sample_audio.mp3


Electronic file: Sample_Flash-Movie.swf


32. Students might create one or more of the technical features described in the following guides, based on 
the needs of their clients. You might want to demonstrate any of the technical features teams plan to 
implement.


Dreamweaver guide: How to create forms 4.13


Dreamweaver guide: How to create image maps 4.10


Note: If students are preparing for the Adobe Certified Associate, Web Communication exam, 
demonstrate how to build image maps. Alternatively, you can introduce your students to CSS image 
sprites. CSS image sprites enable multiple images to be turned into a single CSS background that is 
capable of revealing the correct parts of the multifaceted image.


Note: If you want students to learn specific technical techniques to prepare for the Adobe Certified 
Associate, Web Communication exam, you might have them build test pages or sample features to 
show their clients how the technical features would be implemented or as a learning exercise for 
students to complete as they wait for feedback from clients.


Designing for multiple screens
(Suggested time: 50–150 minutes)


33. Review the concept from Project 2 of designing and developing for multiple screens in Dreamweaver. 
Discuss various devices for viewing web content and making design decisions based on the screens. 


Presentation: Web design for multiple screens 1.5, 2.1, 2.2


34. Discuss the methods for dynamically delivering appropriate content for viewers’ screens. Students can 
use Fluid Grid Layouts to create a layout that responsively adjusts to a viewer’s screen size. Or 
students can use CSS3 media queries to define tablet, phone, and desktop form factors and specify 
custom CSS files for each device form factor. 


35. Ask your students to use either Fluid Grid Layouts or CSS Media Queries to prepare their client sites 
for at least one screen other than a desktop.


Dreamweaver guide: How to deploy for multiple screens 1.5, 2.1, 2.2
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Testing a website
(Suggested time: 150–300 minutes)


36. Introduce the topic of quality assurance by asking students about their perception of quality assurance.


• What is quality assurance?


• What steps would you take to guarantee quality?


37. Ask students to begin the process of technical testing by making a checklist—also called a test plan—
of the technical features they need to test as those features are specified in their design documents and 


storyboards. The checklists might include the following:6.1


• Test links to ensure they go to proper destinations and check for broken links by using the Link 
Checker panel in Dreamweaver. 


• Check for layout elements that should appear on every page (for example, navigation bars and 
banners across the top). 


• Check the spelling of all text (such as content paragraphs and button labels) on every page. 


• Use Adobe BrowserLab to check that the site works in at least the three major browsers—Internet 
Explorer, Mozilla Firefox, and Safari—and on both Windows and Macintosh computers.


• Check that the site works on a device other than a laptop. 


• Check that all images have alternative text and meet other accessibility requirements.1.4


Guide: Technical features and their design solutions


Dreamweaver guide: How to check links 6.1


Dreamweaver guide: How to preview and test a web project 2.2, 6.1


38. You might want to pair teams to test each other’s sites or have members of each team follow the test 
checklist on their own site. Make sure testers write down the bugs and problems they find so the team 
knows everything they need to fix. 


39. Introduce the topic of usability testing by asking students about their perception of usability testing.6.2


• What is usability testing?


• How would you conduct a usability test?


• Why is it important to question site visitors?


• Why is it important to watch visitors as they go through your site?


• What types of things should you look for when you watch site visitors?


• When watching site visitors, how will you know they are having trouble?


• When watching site visitors, how will you know when they like what they see on your site?


Note: If students are preparing for the Adobe Certified Associate, Web Communication exam, discuss 
various methods for collecting ongoing user feedback and site-evaluation information, such as forms, 
site reports, e-mail requesting feedback, surveys, and so on.6.3 


40. Usability observation looks for latent behavior, behavior of which the site visitor is unaware. Latent 
behavior is found in body language or facial expressions visitors are unable to verbalize. Some 
examples follow:


• Site visitors might wave the pointer around the screen for a short while, looking for something, but 
might not document that the item was difficult to find.
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• Site visitors might sigh or frown because they are tired of waiting for an image to load after 
clicking a link. This behavior indicates that an image file is too large, but the visitor might not 
document this occurrence.


41. To prepare for usability testing, ask student teams to make a usability-test interview sheet for testers to 
fill out as they go through the site. You might want to send your students to the All Things Web site at 
www.pantos.org/atw/35317.html for interview worksheet ideas.


42. For usability testing, pair students from different teams. Ask one partner to test the other’s site, 
following the usability-test worksheet. The other partner should observe the tester and document the 
tester’s actions, looking for latent behavior. After the first tester finishes, have partners switch roles 


and perform the usability test for the other student’s site.6.2


43. From the peer feedback and personal notes, ask students to propose written solutions and implement 
them. If they do not plan to implement a proposed solution, make sure they document why they choose 
not to do so.


44. Ask teams to revise their sites based on the information from the technical and usability tests.


45. In preparation for publishing and launching their sites to their clients, ask teams to conduct an overall 
design review. Pair teams and have them explain their client’s goals and audience; then have them 
conduct a design review of the client’s website by evaluating the following strengths of the site’s 


design:2.4, 6.2


• Consistency


• Ease of use


• Use of  color


• Universal navigation


• Layout


• Links


• Usability


• Accessibility


Worksheet: Design review


46. Allow teams time to make any necessary changes based on the design review.


Publishing a website
(Suggested time: 50–150 minutes)


47. Introduce students to the concept of publishing a website. Explain the general idea of taking files from 
students’ local root folders on their computers and putting them in a location on a remote server.


48. Explain to students that although there are various ways to publish, they will be using Dreamweaver to 
publish their web files. Demonstrate how to set up a remote site. Discuss the contents of the dialog 
boxes you encounter as you demonstrate the steps for setting up a remote site.


Dreamweaver guide: How to publish web files 6.5
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Note: You might ask students to generate a list of other techniques they could use to publish files. 
Point out to your students the differences between web servers and FTP servers as they relate to 
publishing a Dreamweaver site. Discuss the common practice in web design and development firms of 
publishing to a testing server or internal development server prior to live publication.


49. If students have access to a remote server, allow time for them to publish their sites.6.5


Note: If you can’t allow students to publish their own files, you might spend more time discussing the 
steps you demonstrate and engaging in extension activities to help students better understand the 
publishing process.


50. Ask students to use a web browser to open their newly published sites, navigate to each page, and 
make sure all files were successfully published and function as they should.


Presenting and launching a website
(Suggested time: 50–150 minutes)


51. Explain that when a client is working with a large web development firm, the client may expect that 
different teams within the firm will execute various aspects of the web production process. Although 
most web designers would not be responsible for launching and marketing a site, this process is 
important to understand. 


52. Introduce Search Engine Optimization (SEO) and describe the primary components of a website that 
search engines crawl to find relevant search results. Encourage each team to identify the key terms that 
might be useful to include in the meta tags of their sites to make their pages easier for search engines to 
find. Demonstrate how to add head content to a web page and have students insert head content on 


their web pages to optimize discovery by search engines.5.7 


53. Ask students to investigate how to use web search engines to promote or market a website. They can 
find information on search engines on the Submission Tips page at http://searchenginewatch.com/
webmasters/. Students should explore and contrast the following options:


• Find a search engine that offers free submission of websites. Make a list of their submission 
procedures.


• Find a search engine or promotion site for which you pay to submit your site. State the cost and 
discuss whether the benefits of the service are worth the cost.


Worksheet: How to promote a website 


54. Ask students to create formal presentations and then present the sites to their clients. Make sure at least 


one team member takes notes on the client’s comments.2.6


55. Allow students time to redesign their sites based on client feedback. Ask students to finalize and 
publish their websites. 
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Extension activities


You can extend the project in the following ways:


• Multi-screen: Have students take the websites they built and adapt them for a third device and/or 
screen size.


• HTML5: Students can extend their website content to take advantage of the new elements in HTML5, 
such as section, article, aside, header, footer, and canvas. For more information about these new 
elements, see http://dev.w3.org/html5/markup/elements.html#elements 


• Advanced topics in CSS: If students seem to be more advanced, you might have them research the 
Dreamweaver help system and articles from the CSS Developer Center (www.adobe.com/devnet/
dreamweaver/css.html) to understand how they can use CSS for positioning.


• Peer teaching: If some teams use a guide to learn about a technical feature, have them hold a mini-
seminar to teach the rest of the class. Their presentation could include the following: 


◦ A working example


◦ Short explanations of when and why to use the feature (design challenges it helps to solve)


◦ Step-by-step demonstration of how to create the feature


• Using local experts: Assign students as resource specialists. For example, have four students act as 
local experts to help others use a software product. With these extra hands and heads, you will be able 
to manage the classroom without being the sole software expert. As students become more familiar 
with the software, more students will be able to serve as local experts.


• Distributed skill-building: Another way to teach Dreamweaver skills is to distribute skill expertise 
among the students. Demonstrate and briefly introduce skills such as creating data tables, inserting 
images, using text and text properties, and inserting outside content by using copy-and-paste or file 
import. Following this brief introduction, divide the students into small groups and ask each group to 
become experts for one of the skills, applying it to a content page they create. After they have mastered 
their specific skill, ask each group to present the application of the skill to the class and explain their 
methodology. This explanation and presentation will help others understand how to use the technique 
while they continue to work on their content pages.


• Sample usability guideline: Setting visitor performance and preference goals helps developers build 
better websites. It can also make usability testing more effective. For example, some Internet sites have 
set a goal that information will be found 80% of the time and in less than one minute.


• Publishing techniques: Form small groups of students to research techniques on publishing websites. 
Consider techniques students might encounter if they were to publish from a home computer, such as 
using FTP clients or wizards from site-hosting services such as Yahoo. After each group has learned 
about its technique, have the group briefly present it to the class. Their presentation might include the 
positive and negative points of using the technique, a short demonstration or handout explaining how 
to use the technique, and a description of the technology behind the technique.


• More tags, prefixes, and includes: To further challenge students, ask student groups to look up a 
website and identify the tags, prefixes, and includes and what each does in rendering the web page. 


Assessment
• Project rubric
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Background preparation resources
• Review the student step-by-step guides referenced in this project.


• To view video tutorials aligned with the skills required to complete this project, visit the Digital Design 
CS6 show on Adobe TV: http://tv.adobe.com/show/digital-design-cs6/


• For more teaching and learning resources on web design, planning and other topics in this project, 
search for resources from the community on the Adobe Education Exchange: 
http://edexchange.adobe.com


• For an overview of the interface and for more information on the technical aspects of Fireworks, see 
Fireworks Help. 


• For an overview of the interface and for more information on the technical aspects of Dreamweaver, 
see Dreamweaver Help. 


Reusable design


• Basic and advanced techniques of Cascading Style Sheets: the CSS Technology Center at 
www.adobe.com/devnet/dreamweaver/css.html


• CSS Zen Garden. A demonstration of what can be accomplished through CSS-based design: 
www.csszengarden.com/ 


• Typekit: https://typekit.com/


• Google web fonts: www.google.com/webfonts#HomePlace:home


Building a website


• Using Cascading Style Sheets in the CSS Support Center: 
www.adobe.com/devnet/dreamweaver/css.html 


• Description of meta tags and how to build them when building your pages: 
http://searchenginewatch.com/webmasters/article.php/2167931 


• HTML Primer: www.htmlprimer.com 


• Writing HTML tutorial: www.mcli.dist.maricopa.edu/tut/


Testing a website


• Adobe’s Website Production Management Techniques (read the information under Build and Test on 
the right side of the page): www.adobe.com/resources/techniques/ 


• Web usability checklist: http://drdobbs.com/184412660


• Adobe Website Production Management Techniques Client Survey: 
www.adobe.com/resources/techniques/resources/define/client_survey.rtf


Launching a website


• Adobe’s Website Production Management Techniques (select Launch on the right side of the page for 
a checklist of tasks students might want to engage in after launching their sites): 
www.adobe.com/resources/techniques/ 


• Google Search Engine Optimization (SEO) Starter Guide:
www.google.com/webmasters/docs/search-engine-optimization-starter-guide.pdf
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Key terms
• absolute link


• accessibility


• alternative text


• Cascading Style Sheets (CSS)


• check in


• check out


• Class style


• CSS3


• document-relative link


• Dreamweaver library


• Dreamweaver template


• file cloaking


• FTP


• HTML5


• hyperlink


• ID style


• link


• link target


• meta tags


• named anchor


• pathname


• search engines


• server


• site-root-relative link


• subversion integration


• synchronizing


• technical testing


ISTE NETS*S Standard for Students


This project is aligned to the ISTE NETS*S Technology Standards. Depending on the subject and content 
area the student selects you may research your own state content standards to see how this project aligns to 
your state requirements.


ISTE NETS*S: Curriculum and Content Area Standards – NETS for Students


1. Creativity and Innovation


Students demonstrate creative thinking, construct knowledge, and develop innovative products and 
processes using technology. Students:


a. apply existing knowledge to generate new ideas, products, or processes.


b. create original works as a means of personal or group expression.


2. Communication and Collaboration


Students use digital media and environments to communicate and work collaboratively, including at a 
distance, to support individual learning and contribute to the learning of others. Students:


a. interact, collaborate, and publish with peers, experts or others employing a variety of digital 
environments and media.


b. communicate information and ideas effectively to multiple audiences using a variety of media and 
formats


d. contribute to project teams to produce original works or solve problems


3. Research and Information Retrieval


Students apply digital tools to gather, evaluate, and use information. Students:


b. locate, organize, analyze, evaluate, synthesize, and ethically use information from a variety of 
sources and media. 


c. evaluate and select information sources and digital tools based on the appropriateness to specific 
tasks
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4. Critical Thinking and Problem Solving


Students use critical thinking skills to plan and conduct research, manage projects, solve problems and 
make informed decisions using appropriate digital tools and resources. Students:


b. plan and manage activities to develop a solution or complete a project.


d. use multiple processes and diverse perspectives to explore alternative solutions


5. Digital Citizenship


Students understand human, cultural, and societal issues related to technology and practice legal and 
ethical behavior. Students:


a. advocate and practice safe, legal, and responsible use of information and technology.


b. exhibit a positive attitude toward using technology that supports collaboration, learning, and 
productivity. 


d. exhibit leadership for digital citizenship.


6. Technology Operations and Concepts


Students demonstrate a sound understanding of technology concepts, systems, and operations. 
Students:


a. understand and use technology systems.


b. select and use applications effectively and productively.


c. troubleshoot systems and applications.


d. transfer current knowledge to learning of new technologies. 


Adobe Certified Associate, Web Communication objectives


1.4 Demonstrate knowledge of website accessibility standards that address the needs of people with visual 
and motor impairments.


1.5 Make website development decisions based on your analysis and interpretation of design 
specifications.


1.6 Understand project management tasks and responsibilities.


2.1 Demonstrate general and Dreamweaver-specific knowledge of best practices for designing a website, 
such as maintaining consistency, separating content from design, using standard fonts, and utilizing 
visual hierarchy.


2.2 Produce website designs that work equally well on various operating systems, browser versions/
configurations, and devices.


2.4 Identify basic principles of website usability, readability, and accessibility.


2.5 Demonstrate knowledge of flowcharts, storyboards, and wireframes to create web pages and a site map 
(site index) that maintain the planned website hierarchy.


2.6 Communicate with others (such as peers and clients) about design plans.


3.1 Identify elements of the Dreamweaver interface.


3.2 Use the Insert bar.


3.3 Use the Property inspector.


3.4 Use the Assets panel.
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3.5 Use the Files panel.


3.6 Customize the workspace.


4.1 Demonstrate knowledge of Hypertext Markup Language.


4.2 Define a Dreamweaver site.


4.3 Create, title, name, and save a web page.


4.4 Add text to a web page.


4.5 Insert images and apply alternative text on a web page.


4.6 Link web content, using hyperlinks, e-mail links, and named anchors.


4.7 Include video and sound in a web page. 


4.8 Add animation and interactivity to content. 


4.9 Insert navigation bars, rollover images, and buttons created in a drawing program on a web page.


4.10 Build image maps.


4.11 Import tabular data to a web page.


4.12 Import and display a Microsoft Word or Microsoft Excel document to a web page.


4.13 Create forms.


5.1 Set and modify document properties.


5.2 Organize web page layout with relative and absolutely-positioned div tags and CSS styles.


5.3 Modify text and text properties.


5.4 Modify images and image properties.


5.5 Create web page templates.


5.6 Use basic HTML tags to set up an HTML document, format text, add links, create tables, and build 
ordered and unordered lists.


5.7 Add head content to make a web page visible to search engines.


5.8 Use CSS to implement a reusable design.


6.1 Conduct basic technical tests.


6.2 Identify techniques for basic usability tests.


6.3 Identify methods for collecting site feedback.


6.4 Manage assets, links, and files for a site.


6.5 Publish and update site files to a remote server.
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Assessment


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations


Client website Absent or incomplete. Students complete a client 
site that conveys the site’s 
goals, purpose, and 
audience. The client site 
follows the wireframes, 
design comps, storyboards, 
and prototypes the client 
approved. The client site 
implements reusable 
design elements such as 
CSS and templates and 
adheres to web standards. 
The client site is published 
and works across 
browsers. 


Students complete a client 
site that clearly conveys 
the site’s goals, purpose, 
and audience. The client 
site follows the 
wireframes, design comps, 
storyboards, and 
prototypes the client 
approved. The site clearly 
employs design principles. 
The client site successfully 
implements reusable 
design elements such as 
CSS and templates and 
adheres to web standards. 
The client site is 
successfully published and 
works across browsers, as 
well as for multiple 
screens. 


Technical test Absent or incomplete. Students create test plans 
to test technical aspects of 
the client’s site. Students 
test sites in Adobe 
BrowserLab, document 
any bugs, and fix the bugs.


Students create detailed 
test plans to test all 
technical aspects of the 
client’s site. Students test 
sites in Adobe 
BrowserLab, document 
any bugs, and fix the bugs.


Usability test Absent or incomplete. Students create user 
feedback forms and run 
usability tests with peers. 
Students document 
observations of user 
subjects and gather reports 
for user feedback from the 
test. Design teams 
implement all feasible 
suggestions from user test.


Students create detailed 
user feedback forms and 
run usability tests with 
multiple peers. Students 
clearly document 
observations of user 
subjects and gather 
detailed reports for user 
feedback from the test. 
Design teams implement 
all suggestions from user 
test and provide clear 
articulation of the impact 
these changes had on the 
overall site.
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Client 
presentation


Absent or incomplete. Students present the client 
site to the client, 
highlighting how the client 
site accomplishes the client 
goals, meets audience 
needs, and addresses client 
content and technical 
requirements and propose 
the launch plan.


Students present the client 
site to the client, 
highlighting how the client 
site accomplishes the client 
goals, meets audience 
needs, and addresses client 
content and technical 
requirements and propose 
the launch plan. Students 
evaluate successful 
strategies employed during 
the production and offer a 
plan for how the client can 
go forward with managing 
and maintaining their site.


Teamwork N/A Student teams track 
milestones and due dates in 
project plan. They work 
with all members of the 
team to distribute work 
equally and meet 
deadlines.


Student teams track 
milestones and due dates in 
project plan. They work 
with all members of the 
team to distribute work 
equally and meet 
deadlines. Student teams 
use technologies such as 
check in and check out and 
develop workflows that 
help all team members 
work efficiently.


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations
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Designing for multiple screens

		With so many devices used to view content on the Internet, web designers must now consider how a site appears and functions on multiple screens.

		A few considerations:

		Target devices and their screen sizes

		How effectively a design scales to multiple screen sizes

		How a design appears when viewed in landscape and portrait views

		Readability of the content on small screens, such as on mobile phones

		How users interact with a site, such as navigating pages or zooming screens

		Compatibility with operating systems on devices



*

  

  

  

  



*

The question of viewing a site in landscape or portrait is important if viewers will access the site from a mobile device with auto rotation enabled. 

Compatibility with different runtimes and operating systems: It used to be that a web designer had to consider whether a site would display properly in multiple browsers, but now a designer must also consider whether features and functionality of the site work in browsers, Android devices, iOS devices, Nokia devices, Motorola devices, and so on.
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Designing for multiple screens

Decide which devices you’re targeting:

		Standard desktop monitors

		Wide-screen desktop monitors

		Laptops and netbooks

		Mobile devices such as

		Smartphones (iOS, Android, 

BlackBerry, and Windows)

		Tablets, such as iPad, Samsung Galaxy, and Kindle Fire







*



Desktop standard monitors are 4x3 aspect ratio

Desktop wide-screen monitors are 16x9 aspect ratio

*
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Trends in web design for multiple screens

You can design web content for multiple screens.  Each approach has its benefits and challenges.

		Create a responsive or flexible design that adapts automatically to each user’s screen.

		Create multiple versions of the same website and redirect users to the appropriate version of your content.

		Create native mobile applications aimed at specific mobile devices and operating systems. Suggest that mobile users download and install the mobile app instead of using their mobile web browser to view the web version of the content.





*



Multiple versions and redirecting users:  Another method for delivering a mobile design is to build an especially optimized layout for handheld devices.  For example, you create an experience specifically for your mobile users without taking away from the experience of desktop users. For this to work, you will have to route traffic on your site depending on the user’s browser agent. For example, if a mobile device user visits your site (yousitename.com), then they will automatically be redirected to  the mobile alternative URL.

*
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Responsive designs

		A responsive or flexible design scales and adapts your content to the screen and capabilities of each device. 

		Because so many devices in use, a cross-device web design is difficult to create, but there are some ways to make each website more responsive.

		The basic idea of responsive web design is that a website should respond to the device it’s being viewed on. For example:

		Adapting the layout to suit screen sizes (from widescreen desktops to phones)

		Resizing images to suit the screen resolution

		Using lower-resolution images for mobile devices

		Simplifying page elements for mobile use

		Hiding nonessential elements on smaller screens

		Providing larger, finger-friendly links and buttons for mobile users

		Detecting and responding to mobile features such as geolocation and device orientation



*

  

  

  

  



*









Copyright 2012 Adobe Systems Incorporated.  All rights reserved. 



When designing web content for multiple screens, you’ll need to consider how things such as page layout, fonts, navigation, buttons, and rich media affect your site’s usability when viewed on different devices.

Consider the following best practices: 

		Begin with a detailed design plan; research your target audience and devices.

		Use a consistent theme throughout your design.

		Simplify navigation and content layouts.

		Use icons to save space and improve usability.

		Include white space for better readability, especially on smaller screens.

		Limit the need to scroll, or use vertical scrolling only for longer pages. 

		Limit the use of large images (large file sizes).

		Optimize content for faster access and a better user experience.



Design best practices

*

  

  

  

  



*









Copyright 2012 Adobe Systems Incorporated.  All rights reserved. 



Consider these additional best practices: 

		Use video and audio sparingly (unless your site depends on it).

		Take into consideration devices without a mouse or other pointing device. For example, can viewers use the site touch screens?

		Use cookies sparingly.

		Enable automatic sign-in for secure content.

		Use Fluid Grid Layouts and CSS Media Queries in Adobe Dreamweaver CS6 to create flexible designs for multiple screens.

		Test on multiple devices or use device emulators.



Design best practices

*

  

  

  

  



*

Use cookies sparingly if one of your target screens is a mobile device. Cookie support cannot be relied upon since it may be disabled either in the device or by the mobile network. 

Enable automatic sign-in for secure content. This is especially important on a mobile device where data input is more difficult than on a desktop. If automatic sign-in is enabled, then your application should also include a link or button to sign out.

One way to test it to deploy your application on each target device. Another option is to test with device emulators. For example, Adobe Flash Professional CS6 includes a built-in mobile simulator for testing accelerometer, input, and geolocation features in a mobile application. Search online and you’ll find emulators for most devices, including Android, iPhone, Blackberry, and Windows—just to name a few.
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One of the most common challenges in designing for the small screens of mobile devices is to balance creativity with ease-of-use. Anything that simplifies your layout and navigation will work to your advantage.

These design strategies help users find and view what they’re looking for:

		Keep buttons large, with extra padding and spacing. Many devices have touch screens on which bigger buttons mean easier clicking.

		Keep navigation simple. Don’t flood a navigation bar with several options; instead choose five or fewer, and create sub-navigation if necessary. 

		Vertical navigation menus make viewing longer lists easier on many mobile input devices. 

		Use buttons (or icons) instead of standard text links for navigation.

		Avoid pop-ups or spawned windows.



Keep navigation simple

*

  

  

  

  



*
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Fluid Grid Layouts

		Adobe Dreamweaver CS6 streamlines the task of building adaptive designs for multiple screens with its integrated fluid grid.

		You can use CSS3 to create Fluid Grid Layouts that scale themselves to multiple screen sizes.



*

  

  

  

  



*
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Fluid Grid Layouts

*

  

  

  

  

In this example, a Fluid Grid Layout displays the page in a web browser.



*
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Fluid Grid Layouts

*

  

  

  

  

The Fluid Grid Layout displays the same page on a tablet.



*
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Fluid Grid Layouts

*

  

  

  

  

An now, the same page on a mobile phone.



*
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CSS media queries

The challenge is to ensure that your websites look good not only on a big screen but also on a tiny phone and everything in between.

		Media queries are an excellent way to deliver different styles to different devices, providing the best experience for each type of user. 

		A part of the CSS3 specification, media queries expand the role of the media attribute that controls how your styles are applied. 

		It has been common practice for years to use a separate style sheet for printing web pages by specifying media="print."  Media queries take this idea to the next level by allowing designers to target styles based on a number of device properties, such as screen width and orientation.



*

  

  

  

  



*
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CSS media queries

Here is an example of a simple media query:

<link rel="stylesheet" type="text/css"

 media="screen and (max-device-width: 480px)"

 href=“stylesheet.css" />

*

  

  

  

  

		If the browser displays this page on a screen that is less than 480 pixels wide, load stylesheet.css

		CSS3 also includes orientation (portrait or landscape), device-width, min-device-width, and many more media queries.

		View the examples on the next three slides to see how CSS Media Queries display the same website on three very different screens.





*
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CSS media queries

In this example, a media query is used to display the page in a web browser.

*

  

  

  

  

When viewed on a desktop, the page has a two-column layout.



*
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CSS media queries

The media query is used to display the same page on a tablet screen.

*

  

  

  

  

The layout switches to a single column to fit the narrower screen of a tablet.



*
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CSS media queries

And now, on a mobile phone.

*

  

  

  

  

Media queries restyle the page to fit the constraints of a much smaller screen.



*
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Summary

		Smart phones, tablets, and other mobile devices are everywhere, and demand for the same content on multiple screens is growing. 

		As content designers, many of the principles you’ve learned for web design apply to the creation of mobile content, but there are some important differences.

		The challenge for web designers is to ensure that your websites look good not only on a big screen but also on a tiny phone and everything in between. 

		When creating web content, you need to decide which devices you want your sites to be viewed. If you’re targeting multiple screens, consider creating a separate site targeted at each device, or make your site flexible or responsive to multiple screens.

		You can create flexible content by using Adobe Dreamweaver CS6 Fluid Grid Layouts and CSS media queries.



*

  

  

  

  



*














Adobe Flash Professional CS6 Project 6 guide

How to use a motion guide with a motion tween 
animation
In Adobe Flash Professional CS6, motion guides appear when you create motion tweens. By using a motion guide, 
you can move an object along an editable path. 


To move an object along a path by using a motion guide:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Add a symbol or text object to the Stage. 


Note: You may need to add a shape or image first and 
convert the object to a symbol.


3. In the Timeline panel, select the layer that contains the 
symbol or text you wish to animate.


4. Select Insert > Motion Tween.


Notice the tween in the timeline (Figure 1).


5. On the Stage, move the object and notice the motion 
guide appears (Figure 2).


6. Click and drag a point on the motion guide. Edit as many 
points of the guide as you choose (Figure 3).


Figure 1 Layer with motion tween applied


Figure 2 Motion guide


Figure 3 Editing the motion guide
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7. Turn onion skinning on to see how the object moves 
along the path (Figure 4).


Note: To turn onion skinning on or off, click the Onion 
Skin button at the bottom of the Timeline panel. Drag the 
onion skinning frame handles at the top of the timeline to 
align with the start and end of the tween span.


8. Select Control > Test Movie > In Flash Professional to 
preview the movie.


Observe that the object moves along the guide.


9. Close the preview window.


Figure 4 Onion skinning turned on


Onion Skin button
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Digital Design Project 4 guide

How to design for usability
Good web usability is defined as: easy to use, quick to learn, and providing an overall satisyfying experience. A well-
designed, usable site aims to enhance the user experience by elevating a website’s percieved efficiency, elegance, and 
clarity.


Usability is a combination of factors including design, information architecture, accessibility, and support across 
various devices. Usability.gov (usability.gov/basics/index.html) provides a list of these important factors:


• Ease of learning How fast can a user who has never seen the user interface before learn it sufficiently well to 
accomplish basic tasks?


• Efficiency of use Once an experienced user has learned to use the system, how fast can he or she accomplish 
tasks?


• Memorability If a user has used the system before, can he or she remember enough to use it effectively the 
next time or does the user have to start over again learning everything?


• Error frequency and severity How often do users make errors while using the system, how serious are these 
errors, and how do users recover from these errors?


• Subjective satisfaction How much does the user like using the system?


Compare the two Coast Middle School examples shown in Figure 1. The before and after screenshots demonstrate 
the difference between poor web usability, and a subsequent site redesign that results in much-improved user 
experience.


Figure 1 Examples poor web usability (left) and improved web usability (right)


Consider the following as you plan the content and navigation of your website project.


Content
How you organize content on a page highlights important features and elements of your site. Important elements 
might be higher in the page, larger in size, or in stronger colors. Include rough descriptions of navigation, copy 
layout, graphic allocation, key headers, and other elements that appear on a screen. Identifying common structures 
between pages helps visitors understand they are in the same site as they navigate from page to page.


• Will your page banner be on each page? If yes, is it in the same place? Is it the same size?


• What font will you use for titles or headings on your content pages?


• What color will you use for titles or headings on your content pages?

© 2012 Adobe Systems Incorporated How to design for usability 1
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• What font will you use for descriptions on your content pages?


• What color will you use for descriptions?


Navigation
For visitors of your website to understand the content, you must provide clear navigation. Visitors need to know 
where they are in a site, where they need to go, and how to get back to where they came from. Having a consistent 
layout grid helps orient visitors and keeps them from feeling lost. Using consistent buttons, links, and graphics on 
each page maintains a sense of place. As visitors move from page to page, provide familiar visual cues and 
navigational aids.


• Where will you place the navigation bar on the page?


• What content will be on the navigation bar?


• Will the navigation bar be on every page?


• How will your navigation bar help visitors know which page they are on?


Resources
Get more information about web usability best practices from these resources:


• usability.gov is the primary government source for information on usability and user-centered design.


• www.useit.com website for leading web usability consultant, Jakob Nielsen.

How to design for usability © 2012 Adobe Systems Incorporated
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How to retouch photos
Other than correcting color, one of the most common tasks you will perform in Adobe Photoshop is retouching 
photos to correct imperfections, edit out undesired parts of the photo, and correct problems that result from the photo-
taking process. This guide covers several ways to retouch photos using the Retouching tools (Figure 1), including 
use of the Spot Healing Brush tool, the Red Eye tool, the Patch tool, and the Content-Aware Move tool. Use these 
tools individually, or in combination to fine-tune your photo retouching tasks. 


Figure 1 Retouching tools


Using the History panel
Because retouching can require trial and error, you should know how to use the History panel to undo steps.


Like most computer users, you’re probably aware of the Undo command available in many applications. This 
command lets you undo the effects of whatever command you’ve just applied.


Photoshop takes the Undo command several steps further with the History panel. The History panel keeps track of the 
last 20 commands you’ve applied to an image, allowing you to revert to any one of these. When you execute a 
command, such as transforming an image or adding text, these are added to the History panel. The commands appear 
in the list in the order in which you performed them. Each command is listed with the name of the tool or command 
you used to change the image.


You can also take a “snapshot” of a particular set of commands, allowing you to revert to this snapshot later.


Note: Although the History panel is great, it does consume memory (RAM), as do layers. So, if you’re working with 
a complex, multilayered image, you may want to reduce the number of History commands saved. You can do so by 
choosing Edit > Preferences > Performance (Windows) or Photoshop > Preferences > Performance (Mac OS).


To use the History panel: 


1. Open an image in Photoshop.


2. Click the History button in the right-side panel set (or 
choose Window > History) to open the History panel 
(Figure 2).


3. Execute several commands—such as selecting a part of 
the image, applying a filter, and adding a layer.


The point is to add some commands to the History panel.


Figure 2 History panel


History 
button
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4. Click one of the earlier commands, such as Move 
(Figure 3).


Observe that the image reverts to its appearance at the 
time this command was executed. Any commands 
executed afterward are temporarily discarded and appear 
dimmed. In Figure 3, for example, the Eraser, Paint 
Bucket and New Layer are dimmed and the effects no 
longer appear in the image.


At this point, the later commands are still available in the 
panel (if you select either). However, if you execute 
another command, the dimmed commands will be 
permanently discarded.


5. To delete a command, select it and then click the Delete 
icon (Figure 3).


The image permanently reverts to the command prior to 
the deleted command.


Figure 3 Earlier command selected


Taking a snapshot


You can use the Snapshot feature to capture the image as it appears at any point in the list of History commands. Once 
you’re satisfied with an image, it’s a good idea to take a snapshot.


To take a snapshot:


1. Click the History command you want to capture.


2. Click the Snapshot icon (Figure 4).


3. Scroll to the top of the History panel as necessary to view 
the snapshot (Figure 3).


4. To revert to the snapshot, click it as you would any other 
History command. 


You can compare different snapshots by clicking on 
them.


Figure 4 Snapshots in the History panel


Using the Spot Healing Brush tool
The Spot Healing Brush tool quickly removes blemishes and other imperfections in your photos. The Spot Healing 
Brush works similarly to the Healing Brush: it paints with sampled pixels from an image or pattern and matches the 
texture, lighting, transparency, and shading of the sampled pixels to the pixels being healed. Unlike the Healing 
Brush, the Spot Healing Brush doesn’t require you to specify a sample spot. The Spot Healing Brush automatically 
samples from around the retouched area. 


Note: If you need to retouch a large area or need to better define the source sampling area, you can use the Healing 
Brush instead of the Spot Healing Brush.


Delete icon


Take a 
Snapshot 
icon


Snapshots
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To use the Spot Healing Brush tool:


1. Click the Spot Healing Brush tool in the Tools panel.


The pointer changes to a brush. Usually the brush appears 
as a circle.


2. You can change the size or shape of the brush in the 
Options bar (Figure 5). 


The brush should be large enough to cover the entire 
spot, with some room around the edges.


3. Confirm that the Content-Aware option is selected.


Content-Aware seamlessly fills the selection with similar 
image content from nearby. For the best results, create a 
selection that extends slightly into the area you want to 
replicate. 


4. Position the Spot Healing Brush tool over the area you 
want to correct (Figure 6).


5. Click to apply the correction (Figure 7).


Figure 5 Brush options


Figure 6 Spot Healing brush positioned over a 
blemish


Figure 7 Spot Healing brush applied


Using the Red Eye tool
When you take photos with a flash, red eye can often result. You can quickly correct red eye in flash photos of people 
or animals with the Red Eye tool.


Spot Healing Brush tool
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To use the Red Eye tool:


1. Click the Red Eye tool in the Tools panel (Figure 8).


2. Position the Red Eye tool over the pupil you want to 
correct. 


3. If you are not satisfied with the result, undo the 
correction, set one or more of the following options in the 
options bar (Figure 9), and click the red eye again.


Pupil Size increases or decreases the area affected by the 
Red Eye tool.


Darken Amount sets the darkness of the correction. 


4. Click to apply the correction (Figure 10).


Figure 8 Red Eye tool 


Figure 9 Red Eye tool options


Figure 10 Red Eye tool applied


Using the Patch tool
The Patch tool lets you repair a selected area with pixels from another area or a pattern. The Patch tool matches the 
texture, lighting, and shading of the sampled pixels to the source pixels, making an imperfection disappear into the 
surrounding image. You can also use the Patch tool to clone isolated areas of an image. 


Note: When repairing with pixels from the image, select a small area to produce the best result.


To use the Patch tool:


1. Identify the object you want to remove from an image.


For example, you can remove the lightpost from the 
tourist landmark photo shown in Figure 11.


Figure 11 Initial image to be patched
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2. Select the Patch tool.


3. Drag in the image to select the area you want to repair, 
and confirm that the Source option is selected in the 
options bar (Figure 12). 


Note: You can also make a selection prior to selecting the 
Patch tool.


4. To adjust the selection, do one of the following:


• Shift-drag in the image to add to the existing 
selection.


• Alt-drag (Windows) or Option-drag (Mac OS) in the 
image to subtract from the existing selection.


• Alt+Shift-drag (Windows) or Option+Shift-drag 
(Mac OS) in the image to select an area intersected 
by the existing selection.


5. Position the pointer inside the selection, and drag the 
selection border to the area from which you want to 
sample (Figure 13). When you release the mouse button, 
the originally selected area is patched with the sampled 
pixels (Figure 14).


Figure 12 Patch tool options


Figure 13 Drag the selection to the sample area


Figure 14 The patched image


Using the Content-Aware Move tool
The Content-Aware Move tool functions in a similar way to the Patch tool, with the exception that dragging a 
selection relocates a selected part of an image to a new location. The Content-Aware Move tool automatically 
samples from around the selection area are to blend together the moved content with the background pixels.

© 2012 Adobe Systems Incorporated How to retouch photos 5







Project 1 guide Adobe Photoshop CS6


6


To use the Content-Aware Move tool:


1. Identify the object you want to move in an image.


For example, continuing work on the tourist landmark 
photo shown in Figure 11, it might be preferable to move 
the right-most building away from the looming office 
building on the left.


2. Drag in the image to select the area you want to move. Be 
sure to leave enough of a margin that edge-region pixels 
can be suitably blended with background pixels.


Note: You can also make a selection prior to selecting the 
Patch tool.


3. To adjust the selection, do one of the following:


• Shift-drag in the image to add to the existing 
selection.


• Alt-drag (Windows) or Option-drag (Mac OS) in the 
image to subtract from the existing selection.


• Alt+Shift-drag (Windows) or Option+Shift-drag 
(Mac OS) in the image to select an area intersected 
by the existing selection.


4. Position the pointer inside the selection, and drag the 
selection border to the area from which you want to move 
the selection (Figure 15). When you release the mouse 
button, the originally selected area is moved (Figure 16).


Figure 15 Dragging the image content to be moved


Figure 16 The final retouched image
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		How to retouch photos

		Other than correcting color, one of the most common tasks you will perform in Adobe Photoshop is retouching photos to correct imperfections, edit out undesired parts of the photo, and correct problems that result from the photo- taking process. This ...

		Other than correcting color, one of the most common tasks you will perform in Adobe Photoshop is retouching photos to correct imperfections, edit out undesired parts of the photo, and correct problems that result from the photo- taking process. This ...



		Figure 1 Retouching tools

		Using the History panel

		Because retouching can require trial and error, you should know how to use the History panel to undo steps.

		Like most computer users, you’re probably aware of the Undo command available in many applications. This command lets you undo the effects of whatever command you’ve just applied.

		Photoshop takes the Undo command several steps further with the History panel. The History panel keeps track of the last 20 commands you’ve applied to an image, allowing you to revert to any one of these. When you execute a command, such as transfo...

		You can also take a “snapshot” of a particular set of commands, allowing you to revert to this snapshot later.

		Note: Although the History panel is great, it does consume memory (RAM), as do layers. So, if you’re working with a complex, multilayered image, you may want to reduce the number of History commands saved. You can do so by choosing Edit > Preferenc...

		To use the History panel:

		Figure 2 History panel

		Figure 3 Earlier command selected



		Taking a snapshot

		You can use the Snapshot feature to capture the image as it appears at any point in the list of History commands. Once you’re satisfied with an image, it’s a good idea to take a snapshot.

		To take a snapshot:

		Figure 4 Snapshots in the History panel







		Using the Spot Healing Brush tool

		The Spot Healing Brush tool quickly removes blemishes and other imperfections in your photos. The Spot Healing Brush works similarly to the Healing Brush: it paints with sampled pixels from an image or pattern and matches the texture, lighting, trans...

		Note: If you need to retouch a large area or need to better define the source sampling area, you can use the Healing Brush instead of the Spot Healing Brush.

		To use the Spot Healing Brush tool:

		Figure 5 Brush options

		Figure 6 Spot Healing brush positioned over a blemish

		Figure 7 Spot Healing brush applied





		Using the Red Eye tool

		When you take photos with a flash, red eye can often result. You can quickly correct red eye in flash photos of people or animals with the Red Eye tool.





		To use the Red Eye tool:

		Figure 8 Red Eye tool

		Figure 9 Red Eye tool options

		Figure 10 Red Eye tool applied

		Using the Patch tool

		The Patch tool lets you repair a selected area with pixels from another area or a pattern. The Patch tool matches the texture, lighting, and shading of the sampled pixels to the source pixels, making an imperfection disappear into the surrounding ima...

		Note: When repairing with pixels from the image, select a small area to produce the best result.

		To use the Patch tool:

		Figure 11 Initial image to be patched

		Figure 12 Patch tool options

		Figure 13 Drag the selection to the sample area

		Figure 14 The patched image





		Using the Content-Aware Move tool

		The Content-Aware Move tool functions in a similar way to the Patch tool, with the exception that dragging a selection relocates a selected part of an image to a new location. The Content-Aware Move tool automatically samples from around the selectio...





		To use the Content-Aware Move tool:

		Figure 15 Dragging the image content to be moved

		Figure 16 The final retouched image
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PAGE DESIGN PRINCIPLES
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Balance

Balance is the act of comparing or estimating two things, one against the other, and the contrast between:

		Empty space (white space) and filled space

		Text and images

		Color and no colors and different colors

		Textures against flat colors



*









- Ask students if they can think of other types of balance: texture and no texture (smooth), size and scale, elements of a composition.

*
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Balance in page composition

Three different types of balance when laying out pages

		Symmetry

		Asymmetry

		Radial symmetry



*
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Symmetrical or formal balance

You can usually identify at least one of three lines of symmetry.

		Horizontal

		Vertical

		Diagonal



*
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Symmetrical balance

*



		The rectangle has three lines of symmetry: horizontal (blue), vertical (red), diagonal (yellow)

		The triangle only has one line of symmetry: center or vertical. You can draw two other lines of symmetry from any of the vertices to the center of the opposite side.



*
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Examples of symmetrical balance

*

http://builtwithmomentum.com/
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Examples of asymmetrical balance

*

http://vani.com.mx/
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Examples of radial balance

*

www.soleilnoir.net/believein/#/ideas
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Emphasis

Emphasis: To express with particular stress or force

	    What message is stressed in this slide?

*
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Color definitions

		Hue is another word for color.

		Chroma is the intensity or purity of color.

		Tint is a color mixed with white.

		Tone is a color mixed with gray.

		Shade is a color mixed with black.



*
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Color and contrast

		Using color can enhance or detract from a composition.

www.lighthouse.org/color_contrast.htm

		Color wheels help determine which colors are in greatest contrast.









	Use Adobe Kuler to try out new color schemes:

	kuler.adobe.com/

*
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Color wheels

		Analogous colors are adjacent to each other on the color wheel.

		Complementary colors are opposite each other on the color wheel.



*
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Color in design

		Use color to label or show hierarchy.

		Use color to represent or imitate reality.

		Use color to unify, separate, or emphasize.

		Use color to decorate.

		Use color consistently.



*
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Summary

		The basis of good page design is use of design elements and their thoughtful application in the form of design principles.

		Clearly identify what you are trying to accomplish—use design to convey your message.

		Brainstorm alternatives.



*
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How to set document properties
For each page you create in Dreamweaver, you can specify layout and formatting properties by using the Page 
Properties dialog box (Figure 1). The Page Properties dialog box lets you specify the default font family and font 
size, background color, margins, link styles, and many other aspects of page design. You can assign new page 
properties for each new page you create, and modify those for existing pages. You can also change the Document 
Type Declaration in the Title/Encoding category of the Page Properties dialog box. For example, if you wanted to 
alter a document’s DTD from HTML 4.1 to HTML 5. Changes you make in the Page Properties dialog box apply to 
the entire page.


Dreamweaver gives you two methods for modifying page properties: CSS or HTML. Adobe recommends using CSS 
to set backgrounds and modify page properties.


Figure 1 Page Properties dialog box


Using CSS to set font, colors, margins, and background image properties
Use the Page Properties dialog box to specify several basic page layout options for your web pages, including the 
font, background color, and background image.


To set layout and formatting options for a page:


1. Open a document in Adobe Dreamweaver CS6.


2. Select Modify > Page Properties or click the Page 
Properties button in the text Properties panel.


The Page Properties dialog box opens (Figure 1).
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3. Select the Appearance (CSS) category and set the 
options.


Page Font specifies the default font family to use for the 
page. Dreamweaver uses the font family you specify 
unless another font is specifically set for a text element.


Size specifies the default font size to use in the page. 
Dreamweaver uses the font size you specify unless 
another font size is specifically set for a text element.


Text Color specifies the default color to render fonts with.


Background Color sets a background color for your page. 
Click the Background color box and select a color from 
the color picker (Figure 2).


Background Image sets a background image for the page. 
Click the Browse button, then browse to and select the 
image. Alternatively, enter the path to the background 
image in the Background Image text box. Dreamweaver 
tiles (repeats) the background image if it does not fill the 
entire window, just as browsers do.


Repeat text specifies how the background image will be 
displayed on the page:


• Select the No-repeat option to display the 
background image only once.


• Select the Repeat option to repeat, or tile, the image 
both horizontally and vertically.


• Select the Repeat-x option to tile the image 
horizontally.


• Select the Repeat-y option to tile the image 
vertically.


Left Margin and Right Margin specify the size of the left 
and right page margins. 


Top Margin and Bottom specify the size of the top and 
bottom page margins.


4. When you’ve finished making changes, click Apply to 
set the properties, and click OK to close the dialog box.


Figure 2 Set Background Color in the Page 
Properties dialog box

How to set document properties © 2012 Adobe Systems Incorporated
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Digital Design Project 2 worksheet

Client interview


Team name: __________________________________________________ Date: ________________________


Reviewer name: _______________________________________________


Interview topics


◦ Goals and target audience


◦ Content


◦ Design requirements


◦ Delivery requirements


Goals and target audience


Identify three long-term goals of your website.


What should the site inspire the audience to do after they visit?


Identify some immediate goals of your website.

© 2012 Adobe Systems Incorporated Client interview 1
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Name some key information you want the audience to gain from your site.


Describe content expectations of your target audience.


Other questions:

Client interview © 2012 Adobe Systems Incorporated
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Audience background


Describe characteristics of your target audience.


What is the age range of your target audience?


What is the reading level of your target audience?


Does your target audience have special requirements or disabilities?


How often is your target audience online?


Describe the most common use of the web by your target audience.

© 2012 Adobe Systems Incorporated Client interview 3
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Use a few adjectives to describe how you want the target audience to perceive your site. (Examples: prestigious, 
friendly, corporate, fun, forward-thinking, innovative, cutting-edge, serious, crazy.)


Other questions:


Content


What should be the title of your site?


What topics should be covered in your site?

Client interview © 2012 Adobe Systems Incorporated
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Other questions:


Design requirements


Are there any organization colors, fonts, graphics, or logos that should be included in the design?


Are there any colors or fonts you don’t want used on this site?

© 2012 Adobe Systems Incorporated Client interview 5
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What are some websites you like? Describe specific elements you like about each site, such as navigation, colors, 
layout, and other design elements.


Other questions:


Delivery requirements


What browsers (and what versions of these browsers) should this site support?


• Internet Explorer


• Mozilla Firefox


• Safari


• Google Chrome


• Other:


What platforms should this site support?


• Macintosh


• Windows


• Other:

Client interview © 2012 Adobe Systems Incorporated
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What devices should this site support?


• Mobile phones:


• Tablet computers:


• Other:

© 2012 Adobe Systems Incorporated Client interview 7
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How to test a Flash project
Testing your Adobe Flash Professional CS6 content before you publish it is very important. This is especially true 
when publishing a movie for multiple screens. For example, may find your movie appears to play fine in a web 
browser, only to discover that it displays incorrectly on the Apple iPad or your mobile phone.


When testing your Flash content, it’s a good idea to perform technical, spelling, grammar, and usability tests. If 
you’re creating a mobile application, you’ll need to perform additional tests of features that are unique to mobile 
applications, including accelerometer, touch-screen, and geolocation functionality. 


Conducting a technical test
A technical test answers questions such as the following:


• Do all the buttons work properly, according to the flowchart?


• Do the text, graphics, animation, and sound match the storyboard?


• Is there proper layout and coordination of text, graphics, animation, and sound as specified in the storyboard?


• Does the content in your mobile application react as expected when the device is rotated, tilted, or laid flat?


• Do touch screen features such as click and drag, press and tap, or two-finger tap work properly?


• Do screen gesture features such as swipe and zoom work properly?


To answer these questions, test the Flash content in each target screen or device. You can test SWF content in the 
Adobe Flash Player or in a web browser. You can test mobile application content by physically connecting your 
computer to a mobile device or by using the Adobe Flash device simulator.


Previewing Flash content in the Adobe Flash Player


To test a SWF file without embedding the content in an HTML file, you can open the movie in the Adobe Flash 
Player.


To preview a SWF in the Adobe Flash Player:


1. Select Control > Test Movie > In Flash Professional.


The SWF file opens in the Flash Player window.


2. Click through the content of your movie to see how it 
runs. Make sure the buttons function properly and that 
the text, graphics, animations, and sound are properly 
coordinated.


3. Close the preview window.


Previewing Flash content in a browser


You can also test how your content will play in a web page by using the Publish Preview command. For example, if 
you plan to publish the content as an HTML file for the web, you can preview the content in an HTML file.


To preview Flash content in a browser:


1. Select File > Publish Preview > HTML.


An HTML document containing the SWF file for your content opens in your default web browser.


2. Click through the content of your movie to see how it 
runs in a web browser. Make sure the buttons function 
properly and that the text, graphics, animations, and 
sound are properly coordinated.


3. Close the browser window.
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Previewing a Flash mobile application by using the Flash device simulator


The Adobe Flash Professional CS6 device simulator enables you simulate running your application on a target mobile 
device. The device simulator is only available when your Flash document publish target is a mobile device, such as 
AIR 3.2 For Android or AIR 3.2 For iOS, as shown in the document Properties panel (Figure 1).


Figure 1 Properties panel


To preview a mobile app in the Flash device simulator:


1. Select File > Test Movie > In AIR Debug Launcher 
(Mobile).


The Simulator appears and your application opens in the Device preview window (Figure 2). You can use the 
sliders or change values in the Accelerometer, Touch And Gesture, and Geolocation sections to simulate 
common mobile application features.


Figure 2 Simulator and Device preview windows


Flash document 
publish target
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2. In the Accelerometer section of the Simulator window, 
change the X, Y, and Z values or drag the sliders to 
simulate rotating and tilting the mobile device 
(Figure 3).


3. Click the Reset button to return to the default values.


4. Expand the Touch And Gesture section in the Simulator 
window and select the Touch Layer option (Figure 4).


You can adjust and test the functionality of touch and 
gesture features, such as tapping and swiping. When you 
position the pointer over the preview window, it has a 
yellow circle attached to simulate a finger-tip (Figure 5). 
You can change the size and pressure by using the values 
at the bottom of the Simulator window.


Figure 3 Simulator, Accelerometer section


Figure 4 Simulator, Touch and Gesture section


Figure 5 Touch And Gesture simulation pointer


Reset 
button
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5. Select the feature you want to adjust or test and use the 
mouse pointer in the preview window to test the selected 
feature.   


Instructions for testing the selected feature appear at the 
bottom of the Simulator window (Figure 6).


6. Expand the Geolocation section in the Simulator window 
(Figure 7).


If your application includes geolocation features, you can 
test those here. For example, you may have an 
application that returns a list of local restaurants based on 
the longitude and latitude (location) of the device. To test 
this feature you would enter test Latitude and Longitude 
values, click Send, and evaluate the results in the Device 
preview window.


7. When you’re finished testing your mobile app, close the 
Simulator and Device preview windows.


Figure 6 Touch And Gesture option instructions


Figure 7 Simulator, Geolocation section
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Proofing the Flash content
There is no better way to proof your Flash content than to read each screen or page carefully several times, checking 
against your storyboard. Read text slowly and aloud to check for spelling and grammar errors. Have someone who is 
less familiar with your project proofread the content too.


You can also use the built-in spell checker. Before Flash will check spelling in a document, you must select your spell 
checking options in the Spelling Setup dialog box (Figure 8). Select Text > Spelling Setup to open the Spelling Setup 
dialog box.


Figure 8 Spelling Setup dialog box


To check spelling:


1. Select Text > Spelling Setup.


The Spelling Setup dialog box appears.


2. Review the options in the dialog box and make any 
changes you like.


3. Click OK to close the Spelling Setup dialog box.


4. Select Text > Check Spelling.


The Check Spelling dialog box opens (Figure 9).


5. Use the Check Spelling dialog box as you would any 
other spell checker. For example, click Change to change 
a misspelled word to the word in the Change To text box. Figure 9 Check Spelling dialog box
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Conducting a usability test
Usability tests are sessions in which you observe visitors as they use your application. Their feedback can help you 
improve the application’s organization, navigation, text, use of color, and other factors. To conduct a usability test, 
you need to do the following:


1. Define the audience for your usability test. This audience should resemble the actual users of your application.


2. Develop your goals for the usability testing project. Start by asking the following questions: What should the 
intended audience be able to get out of the application? What do you want to learn about your application? Are 
there any problem areas you’re especially concerned about, such as an unconventional navigation bar?


3. Create a test script. This is a list of tasks the test’s moderator will ask the tester to accomplish. The script should 
also include feedback and follow-up questions to be posed by the moderator. Phrase the questions asked, tasks 
presented, and opinions sought in a way that allows participants to feel they are contributing to the project rather 
than being tested by the moderator. Ask questions such as Do you like the colors? Can you read the text? Where 
would you click to get information on the company/organization?


4. Recruit your testers. Use the characteristics you initially defined for your audience. In addition to these 
characteristics, choose testers for practicality. For example, they should live close enough to the testing location 
to get there easily. You want to make the process as simple as possible for your testers. For maximum efficiency, 
usability professionals recommend a minimum of eight testers.


5. Provide a comfortable, quiet, private testing environment. Ideally, you should videotape participants. Set up the 
camera so it does not point directly at either the participant or the screen, but instead is angled in a way that 
includes both the screen and some part of the user. In professional software testing, there are usually two 
cameras: one camera records the tester's face and another records the screen. Test moderators then analyze the 
session by viewing both recordings side-by-side so that the tester’s reaction can be compared to what the tester is 
doing.


6. Observe the tester (or analyze the video). Look for latent behavior, behavior of which the participants are 
unaware. Latent behavior is found in body language or facial expressions that participants do not verbalize. An 
example of latent behavior is participants moving the pointer around the screen for a short while, looking for 
something, but not documenting that the item was difficult to find. Another example is participants sighing or 
frowning after clicking a link because they are tired of waiting for an image to load; this behavior indicates that 
an image file is too large, but the participant might not document this occurrence.


7. After completing the tests, compile and review your data. As you do so, keep your participants’ comments 
central. Resist the temptation to impose your own opinion. For example, if several users complain about the 
location of a menu, avoid concluding that “they’ll get used to it once they use it.”


For additional information, go to: http://www.utexas.edu/learn/usability/index.html or en.wikipedia.org/wiki/
Usability_testing

How to test a Flash project © 2012 Adobe Systems Incorporated
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How to use filmmaking techniques
Web designers have an entire history of filmmaking techniques to draw from and inspire them when creating digital 
content for the web. With Adobe Flash Professional CS6, you can simulate traditional film techniques. As you design 
Flash movies, think of creative ways to incorporate these effects and look for opportunities to create new effects that 
may in turn inspire traditional filmmaking.


You can create the following popular filmmaking techniques with Flash:


• Pan, tilt, and zoom effects: Moving the camera horizontally across a scene is known as a pan. Moving the camera 
up or down across a scene is known as a tilt. Moving the camera away from or toward a subject in a scene is 
known as a zoom.


• Camera angles: Using the rule of thirds and adjusting the viewing angle can help emphasize a certain aspect of 
your subject.


• Cross fades: One image appears to fade in while another fades out, a transitional effect for moving from one 
image to another.


• Bounce effect: A moving object rebounds before stopping. This technique grabs attention and can focus viewers 
on an area of the screen. This effect is sometimes combined with a sudden sound effect, such as a “boing” or tire 
screech.


Create a pan, tilt, or zoom effect by using classic tweens
To set a scene in a movie, the camera moves over a large scene and then zooms in to a specific point. A pan (or tilt) 
followed by a zoom is a good technique to introduce a digital narrative. Zooming in focuses the viewer’s attention on 
a particular part of the image.


To create a pan and zoom effect:


1. Open an existing Flash document or create and save a 
new Flash document (ActionScript 3.0).


2. Import an image to the Stage and convert the image to a 
movie clip symbol.


Note: To create a pan, tilt, or zoom, the image must be 
larger than the Stage. In the example, the image is about 
twice as large as the Stage (Figure 1).


3. Align the left edge of the image to the left edge of the 
Stage.  


The image should cover the Stage from top to bottom and 
extend well beyond the right edge of the Stage.


Figure 1 Image shown to the right of the Stage
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4. Click the Outline toggle button in the layer that contains 
the movie clip symbol (Figure 2).


The image (and any other content on the layer) is 
displayed as an outline.


Outline mode makes it possible to see the border of an 
object and the Stage or other objects below it (Figure 3). 


5. In the timeline, select the frame where you want the pan 
to end and select Insert > Timeline > Keyframe.


The timeline now contains start and end keyframes for 
the tween (Figure 4).


6. Turn off Outline mode by clicking the Outline toggle 
button again.


Note: Turning off Outline mode makes it easier to select 
and reposition the image.


7. Select the end keyframe. Drag the instance of the movie 
clip symbol to the left until the right edge of the image is 
aligned with the right edge of the Stage and extends off 
the Stage to the left.


Note: You can hold down the Shift key as you drag to 
maintain the vertical position of the image. 


8. Select the starting keyframe and select Insert > Classic 
Tween.


Flash adds the classic tween span between the start and 
end keyframes (Figure 5).


This classic tween moves the symbol horizontally across 
the Stage (a pan). The second keyframe that ends the 
classic tween will also serve as the starting point for the 
next tween.


9. Select Control > Test Movie > In Flash Professional to 
preview the pan.


The image pans left, as if the camera were panning right. 


10. Close the preview window.


Figure 2 Timeline panel


Figure 3 Outline mode


Figure 4 Timeline panel


Figure 5 Classic tween span


Outline toggle button


Start and end keyframes
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11. Add a third keyframe further along in the time line. 


12. Insert another classic tween between the second and third 
keyframes (Figure 6).


13. Select the third keyframe and select Modify > Transform 
> Scale.


Note: You can also select the Transform tool in the Tools 
panel.


Transform handles appear on the image (Figure 7).


14. Shift-drag one of the corner transform handles to resize 
the image.  


In this example, we made the image larger to create the 
zoom in effect.


Note: You can make the image smaller to create the 
zoom out effect, but the image needs to be larger enough 
to cover the boundaries of the Stage at all times.


15. With the image still selected, select Modify > Align > 
Align To Stage.


16. Select Modify > Align > Horizontal Center.


17. Select Modify > Align > Vertical Center.


The image will now zoom to the center of the image.


18. Select the second keyframe (the start of the second 
classic tween).


19. In the Tweening section of the Properties panel, increase 
the easing to a value between 60 and 100 (Figure 8).


The zoom will start quickly and slow down as it arrives at 
the resting point.


20. In the Timeline panel, click the New Layer button 
(Figure 9).


21. Rename the new layer actions (Figure 9).


22. Select the last frame of the actions layer and insert a new 
keyframe.


Figure 6  Classic tween span between the second 
and third keyframes


Figure 7 Transform handles


Figure 8 Properties panel, Tweening section


Figure 9 New Layer button in the Timeline panel


New Layer button
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23. Select Window > Actions to open the Actions panel 
Make sure The Actions toolbox is open and Script Assist 
is turned on (Figure 10).


Note: If the Actions toolbox is hidden, click the triangle 
or drag the vertical bar to open it. If you don’t see the 
parameters area in the Actions panel, click the Script 
Assist button.


You need to place a stop command at the end of the 
timeline to prevent the movie from looping continuously. 


24. In the Actions toolbox, choose flash.display > MovieClip 
> Methods and locate the stop method.


25. Double-click the stop method to add it to the Script pane 
in the Actions panel (Figure 11). 


Note: You can also locate the stop and other methods by 
using the Index located at the bottom of the Actions 
toolbox.


26. In the Script pane, select stop method. Then click in the 
Object text box in the parameters area of the Actions 
panel.


27. Click the Insert Target Path button (Figure 11).


The Insert Target Path dialog box appears (Figure 12).


28. Select the Relative option and select root to stop the main 
timeline from playing when the play head reaches the last 
keyframe in the movie.


29. Click OK to close the Insert Target Path dialog box.


The Script pane shows the correct code for stopping the 
movie (Figure 13). The object “this” refers to the root of 
the current timeline.


30. Close the Actions panel.


31. Select Control > Test Movie > In Flash Professional. 


This time the image pans, zooms, and then stops.


32. Close the preview window.


Figure 10 Actions panel


Figure 11 Stop method in the Script pane in the 
Actions panel


Figure 12 Insert Target Path dialog box


Figure 13 Stop method in the Script pane


Script Assist button


Parameters pane


Actions toolbox


Insert Target Path button Stop method
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Adding frame labels
You may want to add frame labels to the keyframes. Frame labels help you remember (and help other designers 
understand) what is happening in a particular frame.


To add a frame label:


1. Add a new layer called labels as the top layer of the 
timeline. 


2. Select the blank keyframe in frame 1 of the labels layer.


This aligns with the beginning of the first tween (the 
beginning of the camera pan).


3. In the Label section of the Properties panel, click in the 
Name box and type a label, such as “panning right” 
(Figure 14). Press Enter (Windows) or Return (Mac OS) 
to confirm the label.


The label appears in the timeline (Figure 15).


4. Insert a blank keyframe in the labels layer that 
corresponds to the start of the second tween. 


5. Add a second frame label above the start of the second 
tween and name it “zoom.”


Figure 14 Properties panel, Label section


Figure 15 Frame label in the timeline


Further ideas
• For a documentary: Slow the process down to reflect the pace of the narrative. For example, a slow pan and 


zoom go well with a documentary style narrative.


• For humor or action: Make the zoom-in portion of the pan quick and somewhat unsteady, as if you are looking 
for the subject of the scene. You might zoom in and out several times during a pan to show you are looking for 
something.


• For drama: Pan or tilt the scene without a zoom. This method presents a sweeping landscape, such as a mountain 
range leading to the ocean. Because it takes in the majority of the landscape, the effect adds depth and 
seriousness to the tone of the narrative.
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Camera angles
When you have several images on the screen in a digital narrative, you can use some tricks for emphasis. Use the rule 
of thirds and adjust the viewing angle to emphasize a certain aspect of the subject.


• The rule of thirds states that if you divide the screen into a 3-by-3 grid, the intersections of the lines are areas 
where the eye will focus. Line up the items of focus at these intersections on the screen.


• You can add importance to a subject by presenting the subject as seen from below. Likewise, you can diminish 
the importance of a subject as seen from above.


Even though the girl isn’t in the center of Figure 16, she 
catches your eye because she is near the intersection of 
the rule-of-thirds lines.


Looking up at the man having a moment in Figure 17 
makes him look powerful. Angling the camera down on 
him would make him look smaller and less powerful.


Figure 16 Rule of thirds


Figure 17 Camera angle

How to use filmmaking techniques © 2012 Adobe Systems Incorporated







Adobe Flash Professional CS6 Project 6 guide

Create cross fades by using classic tweens
A transitional effect for moving from one image to another is to fade one image out as you fade the other in.


To create a cross fade:


1. Open a new Flash document (ActionScript 3.0).


2. Import two images into the document library.


3. Select the first blank keyframe in layer 1 and drag one of 
the images to the Stage. Convert the image to a movie 
clip symbol and center it on the Stage.


4. Add keyframes at frames 20 and 30 in layer 1 
(Figure 18).


The photo will display until frame 20 and then fade out 
between frames 20 and 30. 


Note: You can place the keyframes anywhere you want 
to adjust the length of time the photo displays and the 
duration of the fade. You can also adjust these later by 
adding or removing frames.


5. Select the third (last) keyframe in layer 1. This will be the 
end of the fade.


6. Select the photo on the Stage. In the Color Effect section 
of the Properties panel, open the Style menu and choose 
Alpha (Figure 19).


The Alpha transparency value changes to the most recent 
setting you applied. The default is 0%.


7. Make sure the Alpha value is set to 0%.


The image is transparent on the Stage.


8. Select the second keyframe in layer 1 and select Insert > 
Classic Tween.


A classic tween span appears between frames 20 and 30 
(Figure 20).


9. Play the movie in the Timeline panel to see the image 
fade out.


Next you add the second image and create the fade in 
effect.


10. Add a new layer in the timeline above the first layer.


11. Insert a blank keyframe at frame 20 in the new layer. This 
will be the start of the second photo fading in 
(Figure 21).


Figure 18 Keyframes for the first photo


Figure 19 Color Effect Style menu


Figure 20 Classic tween 


Figure 21 Start of the second photo fade in 
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12. Drag the second image from the Library panel to the 
Stage. Convert the image to a movie clip symbol and 
center the image on the Stage.


13. Insert keyframes at frame 30 and 50 (or later) in the new 
layer (Figure 22).


After fading in, the second photo will play to frame 50. 
You can put this farther down the timeline to display the 
second image longer.


14. Select frame 20 in the top layer and select the photo on 
the Stage.


15. In the Properties panel, open the Color Effect Style menu 
and choose Alpha. Change the Alpha value to 0%. (It 
should switch to zero automatically).


The second photo is now transparent and you can see the 
first photo underneath it.


16.  With frame 20 still selected in the top layer, select Insert 
> Classic Tween. 


The second image starts transparent in frame 20 and 
fades in just as the first image is fading out (Figure 23).


17. Select Control > Test Movie > In Flash Professional to 
preview the movie.


18. Close the preview window.


Figure 22 Keyframes for the second image fade 


Figure 23 Fade in and fade out tweens
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Create a bounce effect by using classic tweens
Some animated text and images that move onto the Stage will seem more life-like if you add a little bounce to them 
when they reach their stopping point. This is an old animation technique acknowledging that any moving object 
carries momentum and thus rebounds a bit before it comes to a stop.


To create a bounce effect:


1. Open a new Flash document (ActionScript 3.0).


2. Begin by adding a symbol to the Stage. 


In this example we used the Oval tool to create a ball and 
converted the shape to a movie clip symbol.


3. Position the symbol near the left side of the Stage 
(Figure 24).


4. Insert a keyframe at frame 30.


5. Make sure the new keyframe is still selected and move 
the symbol to the right so that it touches the edge of the 
Stage (Figure 25).


6. Insert a keyframe at frame 40. 


7. Make sure the new keyframe is still selected and move 
the ball back to the left a little (Figure 26).


8. Insert a classic tween between frames 1 and 30.


9. Insert another classic tween between frames 30 and 40 
(Figure 27).


10. Click anywhere in the second classic tween span.


11. In the Tweening section of the Properties panel, change 
the Ease value to 80.


The ball will appear to hit the edge of the Stage wall and 
bounce back, then slow ease to a full stop. You can fine 
tune the timing of the effect by adding or removing 
frames and by adjusting the easing values.


12. Add a new layer in the Timeline panel and name it 
actions.


13. Insert a blank keyframe in the actions layer at the end of 
the movie. In this example, that’s frame 40. 


14. With the blank keyframe in the action layer selected, 
open the Action Script panel and add the stop method. 
Set the Object parameter to this to stop the main timeline 
from playing when the movie reaches the last frame 
(Figure 28).


15. Select Control > Test Movie > In Flash Professional.


The ball moves across the screen and bounces off the 
stage wall before coming to a stop.


16. Close the preview window.


Figure 24 Symbol in frame 1


Figure 25 Symbol in frame 30.


Figure 26 Symbol in frame 40.


Figure 27 Classic tweens


Figure 28 Stop method
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How to create visual effects
With Adobe Flash Professional CS6 filters (graphics effects), you can add interesting visual effects to text, buttons, 
and movie clips. You can change text, shapes, and symbols in many ways by adding filters. This guide illustrates how 
to apply specific effects to shapes, how to edit effects, and how to remove effects. You can apply any number of 
effects by using this technique.


Applying graphic filters to symbols
In the following steps, you first create a shape, convert the shape to a symbol, and then apply a filter to the symbol.


For more information on creating shapes in Flash, see the guide “How to draw and create shapes.” For more 
information on creating symbols, see the guides “Symbols, instances, and the library” and “How to work with 
symbols.”


To create a visual effect:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. From the Tools panel, select a shape tool, such as the 
Rectangle tool.


3. In the Properties panel, select properties for the shape.


4. Draw your shape on the Stage.


You need to convert the shape to a symbol before you can 
add a filter.


5. Select the shape on the Stage.


Note: If your shape includes a stroke and fill or more 
than one object drawing, be sure to select the entire shape 
or group. 


6. Convert the shape to a movie clip symbol or a button 
symbol.


Note: The object must be a movie clip or button symbol 
to add a filter. You cannot add filters to graphic symbols.


7. Make sure the symbol is still selected on the Stage and 
expand the Filters section in the Properties panel.


8. Click the Add Filter button in the lower-left corner of the 
Properties panel to open the Add Filter menu (Figure 1).


9. Select a filter, such as Bevel. 


Flash applies the filter to the symbol (Figure 2). Figure 1 Properties panel


Figure 2 Bevel filter


Add Filter 
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10. Examine the filter properties in the Properties panel 
(Figure 3).


11. Experiment with the bevel properties to see the affect on 
the symbol. For example, change the highlight color or 
increase the Blur and Distance values.


Note: To change the color of the symbol instead of the 
effect’s shadow or highlight, you must open the symbol 
and edit its underlying shape.


12. With the symbol still selected, click the Add Filter button 
and apply another filter, such as Blur.


Flash adds the second filter to the symbol, as shown in 
the Properties panel (Figure 5). It does not replace the 
existing filter.


Figure 3 Bevel filter properties


Figure 4 Modified Bevel filter


Figure 5 Two filters on the same symbol
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Removing and disabling visual effects
You can remove or disable an effect after you have applied it.


To remove or disable an effect:


1. Select the object from which you want to remove a filter.


2. In the Properties panel, select the header for the filter you 
want to remove.


You can disable a filter (turn it off without removing it). 
You can also remove the filter from the symbol.


3. Click the Enable Or Disable Filter button (eye) at the 
bottom of the Properties panel (Figure 6).


The filter no longer appears on the symbol, but it still 
exists in the Properties panel for the selected object.


The properties for the filter are hidden and a red X 
appears in the filter header in the Properties panel 
(Figure 7).


4. Click the Delete Filter button (trash can) at the bottom 
the Properties panel (Figure 6).


The effect is removed completely from the symbol and 
the Properties panel.


Figure 6  Properties panel


Figure 7  Disabled Blur filter in the Properties 
panel


Enable Or 
Disable Filter 


Delete Filter button


Filter header
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Review and redesign


Student name:_________________________________________________ Date: ________________________


The questions on this worksheet will help you think about reviewing and redesigning your web project.


Questions are in the following categories:


• Meeting initial goals


• Requiring new goals


• Reflecting good design principles


• Reflecting good usability and accessibility principles


• Maintaining consistency


• Producing web projects that work equally well on various operating systems, browser versions/configurations, 
and devices


• Planning redesign changes


Meeting initial goals
What were your initial goals for the web project?


Does the web project you built match the initial goals? Why or why not?
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Requiring new goals
Do you have new goals in mind for the web project? If so, what are these and why are you changing your goals?


Reflecting good design principles
What design elements and principles did you originally incorporate into the web project?


Do you want to include new design elements or principles in your web project? If so, what are they and why do you 
want to include them?


Reflecting good usability and accessibility principles
What usability and accessibility principles did you originally incorporate into the web project?
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What changes do you need to make to better reflect the best practices for producing a web project that is highly 
usable and accessible?


Maintaining consistency
What techniques did you use in your web project to maintain consistency?


What changes do you need to make to better reflect the best practices for maintaining consistency?


Producing web projects that work equally well on various operating systems, browser 
versions/configurations, and devices
What operating systems, browsers, and devices did you target for your web project?
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What techniques did you use to make sure your web project worked well on the targeted operating systems, browsers, 
and devices?


What changes do you need to make to increase the usability of your web project on the targeted operating systems, 
browsers, and devices?


Are there additional operating systems, browsers, or devices your would like your web project to work well on? If so, 
what are they and why do you want to include them? What new techniques will you have to use or changes will you 
have to make to deliver your web projects on the additional operating systems, browsers, and devices?


Planning redesign changes
Based on how you answered the questions above, what changes do you need to make to your web project? Sketch 
your changes below in addition to writing about them.
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Sketch of design changes
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How to organize content 
Adobe Flash Professional CS6 documents can involve hundreds of different elements. Organizing these will make 
developing Flash content much easier.


Organize the library
You can create folders to organize your files in the library of a Flash document.


To create folders in the library:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


By default, the Library panel is open on the right-side of 
the workspace (Figure 1). If the Library panel is not 
open, select Window > Library to open it.


2. To create a folder in the library, choose New Folder in the 
Library panel menu or click the New Folder button 
(Figure 1).


The new folder is added to the library.


Folders are represented by file folder icons.


3. Name the folder and drag files into the folder.


You can even store folders within other folders.


4. Double-click a folder icon to see or hide its contents.


You can also see or hide the contents of a folder by 
clicking the disclosure triangle beside the folder.


Figure 1 Library panel


New Folder button
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Organize layers in the Timeline panel
Organize your layers by using descriptive layer names, putting layers in a logical order, and creating folders. Use 
separate layers or folders for sound files, ActionScript, frame labels, and frame comments. This helps you find these 
items quickly to edit them.


To organize layers:


1. To change the name of a layer, double-click the name and 
enter a new name.


2. You can change the order of layers by dragging a layer up 
or down in the stack.


Note: It is recommended that you place ActionScript in a 
layer named actions and labels in a layer named labels, 
typically at the top of the layer stack. Background layers 
go at the bottom of the stack.


3. To create a layer folder, click the New Folder button at 
the bottom of the Timeline panel (Figure 2) and give the 
folder a new name.


4. Drag layers into folders to keep them organized.


Figure 2 Timeline panel


Label keyframes
You can label certain frames to indicate when changes occur on the timeline.


To label a keyframe:


1. Select a frame you want to label.


2. In the Properties panel, enter the label in the Name text 
box (Figure 3).


The label appears on the timeline (Figure 4).


Note: Avoid long names to minimize file size and also to 
keep the label from spanning too many frames.


Figure 3 Name text box


Figure 4 Frame labels in the timeline


New Folder button


Frame label
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Analyzing websites


Student name:_________________________________________________ Date: ________________________


URL:________________________________________________________


Site name:____________________________________________________


Category: ____________________________________________________


Visual Layout
Describe the visual elements on the home page. What caught your eye first?


How does the graphic design (balance, emphasis, color, tone, visual hierarchy, and so on) communicate the content?


If there are images on the page, do they add value to the content, or are they for decoration and appeal? If they add 
value, describe how.
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How quickly did the page draw? Was it worth the wait?


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


How well does the layout of text help viewers understand the main points of the site content? Does the text layout and 
style follow an appropriate visual hierarchy? If so, how does the visual hierarchy help viewers understand the 
content? 


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


_____________________________________________________________________________________________


Consistency Structures
Are any of the elements repeated on subsequent pages? Are the elements decorative or part of the navigation? 


Does the repetition help or hinder the overall purpose of the website? 
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How consistent is the placement of the navigation scheme? 


How consistent is the use of color? 


How consistent are fonts and font sizes? In what ways do the text styles vary?


Color Scheme
Does the color scheme add to the purpose or tone of the site?
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How does the color scheme help or hinder in conveying the purpose of the site?


Content Bias
Can you tell why the site was created? Is there an organization associated with the site, and if so, what type of 
organization? 


Is it clear which portions of the site’s content are fact and which are opinion?


Is there any bias in the information presented? Is there a hidden purpose?
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Content Currency
When was the information first placed on the page?


When was it last revised?


Are there any other indications that this information is current? What is the quality of the related links?


Content Source
Who is responsible for this site?
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What qualifications or expertise does the author have to write about the topic on this site?


Is there a way to verify the legitimacy of the author, such as an e-mail address, phone number, or mailing address?


Who sponsors this site? Has the site been reviewed or won any awards?


What is the domain extension of the site? What does this extension tell you about the site?
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Content Corroboration
What other sites have information on this topic?


Is the information the same?


Are these other sources valid?
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How to publish a Flash document
You develop content in Adobe Flash Professional CS6 by using a Flash FLA document. These documents have a .fla 
extension and can be opened and edited in Flash.


For other people to see your movie, you publish it in a format that is accessible by other software. You use the Publish 
Settings dialog box or the Publish section in the document Properties panel to determine which formats to publish.


Publishing a Flash document for the web
By default, the Publish command creates a Flash SWF file, an HTML document that inserts your Flash content in a 
browser window, and a JavaScript file labeled AC_OETags.js that lets your SWF file play automatically in active 
content-compliant browsers. 


To publish a Flash document for the web:


1. Start Flash and open the document you want to publish.


2. Make sure nothing on the Stage is selected (Edit > 
Deselect All). 


3. In the Properties panel (Window > Properties), expand 
the Publish section (Figure 1).


In the Properties panel, you can select the Target runtime 
for the document and select the ActionScript version that 
matches your document.


4. Click to open the Target menu (Figure 2).


You can publish the document for the Flash Player 
runtime, as an Adobe AIR application, or for playback on 
a device running Flash Lite. For web publishing, you 
select a target version of the Flash Player.


You can publish a document for the most current version 
of the Flash Player or for older versions of the Flash 
Player. 


Note: Some features available in an ActionScript 3 
document may not run properly in older versions of the 
Flash Player. It’s usually best to publish for the most 
current version of the Flash Player.


5. Select a target Flash Player version.


Figure 1 Properties panel, Publish section


Figure 2 Target menu
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6. Click Publish Settings in the Properties panel.


The Publish Settings dialog box appears (Figure 3). It 
shows the most recently selected options. Notice you can 
also select the target runtime and ActionScript version in 
the Publish Settings dialog box.


The default, Flash publishes a Flash (.swf) file, and an 
HTML Wrapper. These are the correct selections if you 
are publishing your content to run in a web browser. 


7. In the list of publish format options, make sure the Flash 
(.swf) and HTML Wrapper options are both selected.


8. Click on the Flash (.swf) option to display the Flash 
publish settings on the right (Figure 4). Be careful not to 
deselect the option.


The default location for published files is to place them in 
the same location as the FLA file. To select a new 
location for the published files, you can click the folder 
icon beside the Output File text box, navigate to the new 
location, and click Save.


You can adjust the JPEG image quality. A higher value 
produces better looking images and larger files.


To make highly compressed JPEG images look 
smoother, select the option Enable JPEG Deblocking. 
This reduces artifacts resulting from JPEG compression. 


To set the audio sample rate and compression for all 
streaming sounds or event sounds in the SWF file, click 
the current Audio Stream or Audio Event setting and 
select new options as needed. 


Note: A streaming sound plays as soon as enough data 
for the first few frames downloads; it is synchronized to 
the timeline. An event sound does not play until it 
downloads completely, and it continues to play until 
stopped.


To override settings for individual sounds specified in the 
Sound section of the Properties panel, select the option 
Override Sound Settings. 


Note: If the Select Override Sound Settings option is 
deselected, Flash scans all stream sounds in the document 
(including sounds in imported video) and publishes all 
stream sounds at the highest individual setting. This can 
increase file size if one or more stream sounds has a high 
export setting. 


To export sounds suitable for devices, including mobile 
devices, instead of the original library sound, select the 
option Export Device Sounds. 


Figure 3 Publish Settings dialog box


Figure 4 Flash (.swf) publish settings
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9. Click the HTML Wrapper option on the left to display the 
HTML publish settings on the right (Figure 5). Be 
careful not to deselect the option.


You can select the template to use for creating the Flash 
HTML page the contains your SWF file. A Flash HTML 
template is a file that contains HTML code and flexible 
template code consisting of a special type of variables 
(which differ from ActionScript variables). When you 
publish a SWF file, Flash replaces these variables with 
the HTML publish options you select in the Publish 
Settings dialog box and produces an HTML page with 
your SWF file embedded.


If you are publishing to Flash Player version 4 or later, 
select Detect Flash Version. Flash version detection 
configures your document to detect the version of Flash 
Player that the user has and sends the user to an 
alternative HTML page if the user does not have the 
targeted player.


By default, the file dimensions are set to match that of the 
movie you’re publishing. You can specify new 
dimensions in pixels or as a percent of the current movie 
size.


There are four Playback control options (Figure 6). 
These include:


• Paused At Start pauses the SWF file until a user 
clicks a button or selects Play from the shortcut 
menu. (Default) The option is deselected and the 
content begins to play as soon as it is loaded.


• Loop repeats the content when it reaches the last 
frame. Deselect this option to stop the content when 
it reaches the last frame. This is on by default. 


• Display Menu shows a shortcut menu when users 
right-click (Windows) or Control-click (Mac OS) the 
SWF file. To show only About Flash in the shortcut 
menu, deselect this option. This option is selected by 
default.


• Device Font substitutes anti-aliased (smooth-edged) 
system fonts for fonts not installed on the user’s 
system. 


To determine the trade-off between processing time and 
appearance, you can open the Quality menu and select 
from six quality options that range from Low to Best 
(Figure 6). 


Figure 5 HTML publish settings


Figure 6 HTML playback and Quality options
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To modify the style of the window that contains your 
HTML file, you can open the Window Mode menu 
(Figure 7) and select from four window options:


• Window uses the HTML background color behind 
the content.


• Opaque Windowless sets the background of the 
Flash content to opaque, obscuring anything under 
the content. Lets HTML content appear above or on 
top of content.


• Transparent Windowless sets the background of the 
Flash content to transparent, allowing the HTML 
content to appear above and below the content. This 
requires viewing in a browser that supports 
windowless content.


• Direct turns on hardware acceleration. By default 
this is turned off. 


You can use the settings in the Scale and Alignment 
section of the HTML publish settings (Figure 8) to 
control how the SWF content is aligned in the HTML 
page. You can also specify if and how a browser scales 
the SWF content when a user changes the size of their 
browser window. 


10. Click Publish at the bottom of the Publish Settings dialog 
box.


Flash publishes files in the same folder as your FLA or to 
another output location that you specified. 


11. Click OK to save these settings for the current file and to 
close the Publish Settings dialog box.


Note: After setting publish options, you can choose 
File > Publish to publish without opening the Publish 
Settings dialog box.


12. To view the published document, open the folder that 
contains the published file and double-click the HTML 
file. 


The HTML file opens in your default web browser and 
displays the SWF content.


Figure 7 HTML Window Mode menu


Figure 8 HTML scale and alignment settings
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Publishing a Windows or Mac OS projector file
To create a self-contained application file that runs without the Flash Player installed, publish your Flash document as 
a Windows or Mac OS projector file.


To publish a projector file:


1. Start Flash and open the document you want to publish.


2. Make sure nothing on the Stage is selected (Edit > 
Deselect All). 


3. In the Properties panel (Window > Properties), expand 
the Publish section.


4. Click Publish Settings to open the Publish Settings dialog 
box.


5. Select Win Projector or Mac Projector from the list of 
publish format options (Figure 9).


6. Click Publish to publish the projector file, or click OK to 
save your publish settings and publish at a later time. Figure 9 Publish format options


Publishing an Adobe AIR application
You can also publish Adobe Flash Professional CS6 documents as Adobe AIR applications. The Adobe AIR runtime 
makes it possible to deploy your Flash movie as a stand-alone desktop application that runs without opening a web 
browser. You can also publish Adobe AIR applications that run on popular mobile devices, including Android phones 
and tablets as well as iOS devices (iPhones and iPads). You can even create an Adobe AIR app that runs on your 
television.


To publish an Adobe AIR application:


1. Start Flash and open the document you want to publish.


2. Make sure nothing on the Stage is selected (Edit > 
Deselect All).  


3. In the Properties panel (Window > Properties), expand 
the Publish section.


4. Click Publish Settings to open the Publish Settings dialog 
box.


5. Select Flash (.swf) from the list of publish format options 
(Figure 10).


Figure 10 Publish format options
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6. In the Publish Settings dialog box, open the Target menu 
(Figure 11). 


7. Select a target runtime option that matches your target 
device, such as AIR 3.2 for Anroid.or AIR 3.2 for 
Desktop.


8. Click Publish.


The AIR Settings dialog box opens to the Signature tab 
(Figure 12). The first thing you need to do is select or 
create a certificate for the AIR application.


9. Click Create (Windows) or New (Mac OS) to create a 
new certificate.


The Create Self-Signed Digital Certificate dialog box 
(unamed in Mac OS) appears (Figure 13). All fields must 
be filled in to create the new certificate


10. Complete the form, including the password fields. 


11. Click in the Save As text box and enter a name for the 
certificate.


12. Click Browse (Windows) or the folder icon (Mac OS), 
select a target location for the new certificate, and click 
Save.


13. Click OK to create the certificate.


A confirmation message appears when the certificate is 
created.


14. Click OK to close the message.


15. Click in the Password text box and enter the password 
you created for the new certificate.


Figure 11 Publish Settings Target menu


Figure 12 AIR Settings dialog box


Figure 13 Create Self-Signed Digital Certificate 
dialog box
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16. Click the General tab in the AIR Settings dialog box.


You can enter a file name for the AIR installer file (.air) 
and enter a name and version number for the application 
(Figure 14).


You can include other information, including a 
description and copyright messaging. 


17. Click Publish to create the AIR application or click OK 
to save your publish settings and publish at a later time.


Flash publishes the AIR application and a message 
appears when the process is complete.


18. Click OK to close the message, and then click OK twice 
to close the AIR Settings and Publish Settings dialog 
boxes.


19. Open the folder you designated as the location for the 
published AIR application. 


The folder contains the AIR installer file (Figure 15). 
You share this file with users who can double-click the 
AIR file to install and run the application. 


Figure 14 AIR Settings dialog box, General tab


Figure 15 Published AIR application files
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Exporting Flash content as an image
Sometimes you may want to export Flash content as an image for use in another document. You can export Flash 
content in JPEG, PNG, or GIF format. 


To export Flash content as an image:


1. Start Flash and open the document you want to publish.


2. Make sure nothing is selected on the Stage. 


3. Open the Properties panel (if it is not already open) and 
expand the Publish section.


4. Click Publish Settings to open the Publish Settings dialog 
box(Figure 16).


5. Select a graphic file type for the image in the list of 
publish format options in the Publish Settings dialog box.


6. If you want to change the names of the image, enter new 
name in the Output file field.


By default, every file type uses the same name as the 
FLA file. Only the file extensions are different.


7. Click Publish to create the image.


By default, files are published in the same folder as the 
FLA file.


Figure 16 Publish Settings dialog box
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Design principles for Flash content
When designing Adobe Flash Professional CS6 content, consider the following principles.


User-centered design
What you are presenting with Flash is dictated by the user, otherwise known as the audience. You must know your 
audience: how large it is, who they are, where they come from, what their goals are, and what obstacles they may face 
when accessing your Flash content. Some variables to consider include:


• Language and culture


• Impairments


• Interests


• Experience with technology


Purpose
What is the main purpose of your Flash presentation? Is  it a corporate website, a software application, an 
entertainment site, a game, or an instructional demonstration? Having a clearly described purpose will help you 
consider different technological, graphic, and usability factors.


Technology
Be aware of the technical requirements it will take to implement, deliver, and access your presentation. Elements to 
consider are:


• Hosting and ISPs


• Web servers


• Browser and e-mail security


• External application needs, such as Java


• Media playback components, such as sound cards and speakers


• Display sizes (Will you be designing for more than one screen size or device?)


• Processor speeds and other characteristics of the delivery devices (computers or mobile devices, for example) 


Content
The content of your site takes into consideration all other design principles. The content should be appropriate for 
your audience, and it should align with the site’s purpose. The content should be well organized, consistent in 
presentation, and technologically suited for your users. Make sure the media you include enhances your message and 
does not distract from it. Increase the readability of text elements by applying appropriate font types, sizes, and 
colors. Use graphics and photographs that are meaningful and that complement other content.


Consistency
As you design your content, use a consistent frame theme, color scheme, and navigation system. Such consistency not 
only unifies the design, it helps your content be more usable, because users can recognize and use familiar elements. 
For example, use the same button style and menu system for all the pages on your website.


For most presentations and web content, use simple navigational objects. Use standard designs for all buttons, scroll 
bars, and menus.
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Control
Provide simple navigational objects for the users. Use standard designs for all buttons, scroll bars, menus, and 
language, and do not hide navigational elements.


Consider accessibility guidelines when designing the navigational system.
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Introduction to digital photography
Digital photography has come a long way in a few years. It's fast, efficient, and more cost-effective than the old ways. 
And best of all, digital photography just keeps getting easier and more enjoyable.


So many advantages
• Digital takes the fear out of photography by letting you take as many pictures as you want.


• You can see right away if you got the picture you want, and you can delete pictures you don’t want.


• Upload pictures and share them with friends and family anytime, anywhere using a computer—or even a 
mobile phone.


• Digital costs less because you don’t buy film and you don’t pay to print photos you don’t want.


• People use digital photography in their work every day—police officers, real estate agents, insurance agents, 
fire fighters, scientists, and doctors, just to name a few.


Getting started with digital photography
Think you need a digital camera to have fun with digital photography? Think again. All you need is access to a 
computer and you’re ready to go. 


Taking pictures 


There are several ways you can get pictures ready for a computer: 


• Scan existing prints and burn a CD. Scan pictures that you’ve already taken. Whether you have a scanner 
at home or school, or have access to scanning services through a photo developer, getting favorite photos on 
a CD lets you quickly and easily copy these cherished memories to a computer for editing, printing, and 
sharing. 


• At a one-hour photo shop request a CD instead of prints. When you take pictures with a film camera and 
take them to a one-hour photo shop for developing, have the pictures put on a CD instead of getting prints. 
This way you’ll still have access to all the benefits digital photography offers. 


• Use a digital camera. There are lots of different types of digital cameras. Before you buy, make a list of the 
“must have” features to find the right one for you. 


Making pictures beautiful 


The great joy of taking pictures is being able to share them with friends, family, teachers, and students. The 
possibilities are truly endless with digital. You can 


• create a slide show for a school project 


• put together a photo album that shows the progress of a class over the school year 


• make CDs 


• print greeting cards, calendars, and posters 


• design mouse pads, coffee mugs, and more 


Digital is fast, fun, and easy. All you need is your imagination and a few mouse clicks—and you’re there. Want to do 
more with your digital photos? Use Adobe Photoshop and watch your creativity flow.
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Digital cameras: How we got here
One of the coolest things about digital photography is that you can see your picture right away. With just a few clicks 
of the mouse you can download, organize, edit, and share all of your digital photos. Sounds simple, right? But did you 
know it took more than 150 years to get digital cameras where they are today? 


Photography is the art of capturing light. And that’s what the very first camera did. Called a camera obscura, it had a 
big piece of glass that reflected a picture on a wall or canvas.


Back in the day


A Frenchman named Louis-Jacques Mandé Daguerre invented photography in 1839. Looking at pictures of people 
and places was popular home entertainment in the 1850s—a lot like watching TV is today. Most pictures were taken 
to show things the way people wished to see things. 


A new type of photography called photojournalism started about the time of the U.S. Civil War. Designed to 
document the reality of the battlefields, American photojournalism was pioneered by Mathew B. Brady. When 
newspapers printed Brady’s photos, people saw how powerful a photo could be.


George Eastman designed the first camera for the general public in 1888. Called a Kodak camera, it was easy to use 
and had enough film for 100 pictures. Color photography was invented in 1907, but it wasn’t until 1935 that it 
became popular.


The first digital camera was made in 1994. If you wanted to buy one, it would cost $18,000 for 1 megapixel. 
Technology has come a long way in the last 10 years. You can buy a digital camera with up to 10 megapixels for less 
than $100.


The power of digital


Digital photography is used not only to take fun pictures, but also in important ways by people in a lot of different 
professions: police, health care, lawyers, educators, insurance agents, real estate agents, scientists, and many others.


It lets us see things we’d never seen before. The Hubble Space Telescope has sent digital images from deep outer 
space since 1990. In fact, it’s probably the biggest digital camera ever made—it’s the size of a school bus.


One picture showed the first planet found outside our solar system. The planet is almost three times bigger than our 
largest planet, Jupiter. But it’s not just the big stuff that digital helps us see. It also lets us see the smallest of things 
such as human cells and microscopic particles.


Take a minute and think about how you could use digital photography. Would it be to take pictures of your puppy or 
kitten once a week to chart its growth? Or would it be to start an art project? Digital photography lets you experience 
photos like never before. Hang on because it’s going to be a wild ride.


Top 10 digital myths
The early days of digital photography had some problems. Cameras were expensive. Photo quality was not good. 
There weren’t a lot of tools to handle digital photos. 


Since then digital cameras have gotten a lot better. So have the photos they make. The tools available to manage 
photos have made digital easier than ever, too. 


But there are still some people who have a negative view of digital photography. So here are the Top 10 myths—
exposed: 


1. A digital photo is not as good as film. Today’s digital cameras produce great-looking photos, even in large 
print sizes. Film is good and improving, too. But digital easily keeps pace.


2. Digital cameras are big and heavy. There are a lot of small, featherweight digital cameras that have loads 
of features. They create top-quality photos, too.
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3. Digital cameras are slow. For a long time, digital cameras were slower than their film cousins. Every year, 
digital cameras get faster.


4. Digital photography is expensive. Digital keeps getting cheaper. Someday soon it won’t cost any more 
than film.


5. It takes too long to transfer pictures to a computer. Get a USB or FireWire memory card reader to make 
quick transfers. The fastest card readers can transfer your photos up to six times (6x) the data rate of a 
standard CD-ROM.


6. It’s hard to view and edit digital photos. Not any more. For example, Adobe Photoshop is surprisingly 
easy to learn and use.


7. It’s hard to make prints from digital photos. Printing digital photos is easy. You can print at home, or on 
the Internet by using an online photo service.


8. Prints from digital photos look bad. It is almost impossible to tell the difference between digital prints and 
traditional film prints.


9. It’s hard to organize and store digital photos. Adobe Bridge, is a visual file browser that helps take the 
guesswork out of finding the image file you need. There are two versions of Adobe Bridge to choose from: 
the full version which opens a seperate, full image browser window and works across the Creative Suite 
software family, or Mini Bridge, which allows you to access images directly within the Photoshop interface. 
Protect your original photo files—also called digital negatives—by burning a CD and listing its contents on 
the disk.


10. Digital photography is too much fun. Sorry, this one’s true!
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Overview of the Adobe Flash Professional CS6 
workspace
In this guide, you learn how to do the following:


• Identify the elements of the Adobe Flash Professional CS6 workspace


• Customize the layout of the workspace


• Define the tools and features in the workspace


Workspace


Figure 1 Flash workspace


Timeline panel Motion Editor Stage Properties panel Tools panel
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Arranging the Flash workspace


You can create a custom workspace by moving and manipulating panels, such as adding, removing, docking, 
grouping, or collapsing them. You can save these custom workspaces and switch among them. Flash provides several 
preset workspaces, arranged for particular tasks or types of users.


To switch between workspaces:


1. Start Flash and choose File > New (ActionScript 3.0). 


An empty Flash document opens.


2. Select a preset workspace (such as Designer) in the 
workspace switcher at the top of the workspace 
(Figure 2).


The panels are rearranged.


Figure 2 Workspace switcher at the top of the 
workspace


To create a custom workspace:


1. Start Flash and choose File > New (ActionScript 3.0). 


An empty Flash document opens.


2. Make changes to an existing workspace, such as by 
opening new panels or closing open panels.


3. Choose Window > Workspace > New Workspace (or 
choose New Workspace in the workspace switcher).


The New Workspace dialog box opens (Figure 3).


4. Enter a name for the new workspace.


5. Click OK.


The workspace is now available through the workspace 
switcher.


Figure 3 New Workspace dialog box


Stage
The Stage is the white, rectangular area of the Adobe Flash Professional CS6 workspace (Figure 1). Objects you 
place on the Stage will appear in your published movie. Objects placed in the pasteboard (the gray area around the 
Stage) will not appear in the finished movie, but you can place objects there until you want them to appear on the 
Stage.
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Timeline panel
The Timeline panel is where you control the images and sounds in your Flash document (Figure 4). The timeline is 
divided into frames. In the timeline, you work with these frames to organize and control the content of your 
document. You place frames in the timeline in the order you want the objects in the frames to appear in your finished 
content.


A keyframe indicates a change occurring in the timeline, for example a keyframe can indicate the moment at which a 
graphic image appears or changes in the movie. A keyframe can also be a frame that includes ActionScript code to 
control some aspect of your document. You can also add a blank keyframe to the timeline as a placeholder for 
symbols you plan to add later or to explicitly leave the frame blank.


A property keyframe is a frame in which you define a change to an object’s properties for an animation. Flash can 
tween, or automatically fill in, the property values between property keyframes to produce fluid animations. Because 
property keyframes let you produce animation without drawing each individual frame, they make creating animation 
easier. A series of frames containing tweened animation is called a motion tween.


Current frame, frame rate, and elapsed time are all shown at the bottom of the Timeline panel. The playhead, 
represented by a red rectangle with a long red line, shows the current frame you are viewing on the timeline. You can 
click a frame to move the playhead to that frame, or you can drag the playhead back and forth on the timeline to 
quickly view all or any part of your animation.


Layers in the Timeline panel provide a way to organize the elements of your movie. You can draw and edit objects on 
one layer without affecting objects on another layer. Layers control the stacking order of objects—the order moves 
from top to bottom, so objects displayed in front are in the top layer, while objects displayed in back are in the bottom 
layer. This allows you to place objects in front of or behind one another. To change the order of layers, drag the layer 
name to a new position. The layer controls appear on the left side of the Timeline panel. Each layer has an option for 
hiding or showing the layer, locking it, and displaying its contents as outlines.


Figure 4  Timeline panel
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Edit bar
The edit bar, at the top of the Stage, lets you quickly navigate between different parts of your Flash document 
(Figure 5). It lets you switch between scenes and symbols. You can also change the magnification level of the Stage. 


Figure 5 Edit bar


Panels
Panels provide easy access to controls that help you work with the content in your document (Figure 6). By default, 
the Properties panel and the Library panel are docked to the right side of the workspace. Any available panel can be 
opened by selecting it in the Window menu. By default, several panels are collapsed to icons to make them easy to 
open while reducing clutter in the workspace. To open and close these iconic panels (Figure 6) click their icons.


You can undock panel groups, add panels to a group, undock individual panels, rearrange the order of docked panels, 
and collapse and close panel groups. To undock a panel, drag it by its tab or title bar away from its current position. 
You can drag it into another dock or make it free-floating.


Figure 6 Panels
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Change Magnification


Current Scene


Panel menuPanelsIconic panels
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Tools panel
The tools in the Tools panel let you draw, paint, select, and modify artwork, as well as change the view of the Stage 
(Figure 7). The Options area at the bottom of the Tools panel lets you modify a tool you have selected. If the Tools 
panel is not visible, you can display it by selecting Window > Tools. To select a tool, just click it. (You can also use 
the shortcut key shown in parentheses in the tool tip that appears when you rest the pointer over a tool for a few 
seconds.) Properties for the selected tool appear in the Properties panel. 


Figure 7 Flash Tools panel
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Selection tools


Selection tool (black arrow): Click an object to select it. Drag a selected object to move it.


Subselection tool (white arrow): Select and move points of an object or edit paths between adjacent points.


Free Transform tool: Resize or rotate selected objects by dragging. 


Gradient Transform tool: Transform a gradient or bitmap fill by adjusting the size, direction, or center of the fill.


3D Rotation tool: Rotate movie clip instances in 3D space. A 3D rotation control appears on top of selected objects 
on the Stage. The X control is red, the Y control is green, and the Z control is blue. 


3D Translation tool: Move movie clip instances in 3D space. When you select a movie clip with the tool, its axes, X, 
Y, and Z, appear on the Stage on top of the object. The X axis is red, the Y axis is green, and the Z axis is blue.


Lasso tool: Drag to select an area.


Drawing tools


Pen tool: Create straight or curved lines. You can also create Bezier curves. 


Add Anchor Point tool: Add new anchor points to an existing path.


Delete Anchor Point tool: Delete anchor points from a path.


Convert Anchor Point tool: Convert the points on a path between corners to smooth points.


Text tool: Create or edit text and text fields.


Line tool: Draw straight lines.


Rectangle tool: Create rectangles or squares composed of fills and strokes, just fills, or just strokes. Also has the 
PolyStar tool (create either polygon or star shapes—you can set how many points both shapes have), the Oval tool 
(create circles and ovals), the Rectangle Primitive tool, and the Oval Primitive tool. Primitive shapes are individual 
objects that can be edited in the Properties panel.


Pencil tool: Create lines in any of three modes—straighten, smooth, or ink. 


Brush tool: Create shapes with fills only. Also has the 


Spray Brush tool: The Spray Brush acts like a particle sprayer, letting you “brush” a pattern of shapes onto the Stage 
at one time. By default, the Spray Brush emits a spray of dot particles using the currently selected fill color. However, 
you can use the Spray Brush tool to apply a movie clip or graphic symbol as a pattern.


Deco Drawing tool: Apply an effect to a selected object. Choose effects from the Properties panel.


Bone tool: Inverse kinematics (IK) is a method for animating an object or set of objects in relation to each other using 
an articulated structure of bones. This tool allows you to add bones to a set of objects in relation to each other.


Bind tool: Inverse kinematics tool that allows you to click a control point or a bone with this Bind tool and display the 
connections between the bones and control points. You can then change the connections in a variety of ways.


Paint Bucket tool: Add fill inside a shape or change the fill color.


Ink Bottle tool: Change the color or width of a line, or add a stroke to a shape.


Eyedropper tool: Sample a color from swatches or anywhere on the screen.


Eraser tool: Erase parts of an image.


View tools


Hand tool: Drag the Stage to view another part of your document.


Zoom tool: Zoom in or out to view more or less of the Stage. To zoom out, hold down the Alt key (Windows) or the 
Option key (Mac OS).
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Color tools


Stroke Color: Set the stroke color.


Fill Color: Set the fill color.


Properties panel
The Properties panel provides easy access to the most commonly used attributes of the current selection, either on the 
Stage or in the timeline. You can make changes to the object or document attributes in the Properties panel without 
accessing the menus or other panels that also control these attributes.


Depending on what is currently selected, the Properties panel displays information and settings for the current 
document, text, symbol, shape, bitmap, video, group, frame, or tool. For example, in the Properties panel you can edit 
the document size or select publish settings, including the target Flash Player and ActionScript versions. 


When two or more different types of objects are selected, the Properties panel displays the total number of objects 
selected. By default, the Properties panel is visible; you can hide or show it by selecting Window > Properties. The 
illustrations (Figure 8) show the properties for a Flash document and a text object, respectively.


Figure 8  Properties panel for a Flash document (left) and a text object (right)
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Design review


Student name:_________________________________________________ Date: ________________________


Design team name:_____________________________________________


Client name: __________________________________________________


Client URL: __________________________________________________


Summary


After understanding the client’s goals and audience, conduct a design review of the client’s website:


• One team member summarizes the client’s audience, purpose, and goals to confirm the group’s understanding.


• The team evaluates the strengths of the site’s design. Consider the following design elements:


◦ Consistency


◦ Ease of use


◦ Use of color


◦ Universal navigation


◦ Layout


◦ Links


◦ Usability


◦ Accessibility


◦ Mobile device considerations


• The team discusses improvements they would suggest to the site design.


• One team member summarizes the strengths of the site.


Consistency


What elements are repeated on content pages to help identify the entire site?
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How does the repetition help or hinder the overall purpose of the website?


When coming to the site, how do visitors know where they are, where they can go next, and whether they remain in 
the same site as they go from page to page?


How well do the pages comply with web standards (for example, are links blue and underlined)?


Universal navigation


Where is the main navigation for the site located, and how consistent is it from page to page?
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How do visitors return to the home page from every other page in the site?


How do visitors control their movement in the site (for example, is there always a way to return to the previous page 
they visited)?


Layout


Is the page layout logical or does the design look randomly placed?


How does the relative size and placement of text and images imply relative importance?
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How often do you need to scroll down the page to find important elements?


If there are images, how clear are they?


How do images add value to the content or are they only for decoration and appeal?


How does the color scheme contribute to the purpose or tone of the site?
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Usability


How clearly are links labeled?


Is the time it takes for a page to load worth the wait?


How easily are visitors able to find information?


How easily are visitors able to return to essential sections of the site (if at all)?
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Accessibility


Are all images labeled with alternative text?


To what extent are the text and titles clear and easy to read for all visitors (color, size, and so on)?


Do image links and hotspots (image maps) have alternative text?


Mobile device considerations


Does the website properly display on the screen size of the target mobile devices?
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Is the website content optimized for the screen size of the target mobile devices? 


Is the time it takes for the website to load on the target mobile devices worth the wait?
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How to create a button symbol


Button symbols
Buttons give visitors a way to control parts of a movie. You can use button symbols to create interactive buttons that 
respond to mouse clicks, rollovers, or other visitor interaction. Button symbols are four-frame interactive movie clips. 
The first three frames display the button’s three possible states: Up, Over, and Down. The fourth frame, Hit, defines 
the active area of the button. The timeline for a button doesn’t play like other movies; it reacts to pointer movement 
and actions by jumping to and displaying the appropriate frame.


You can create the image that represents your buttons in several ways. For example, you can use an existing graphic 
as the button, or you can create a shape by using the drawing tools.


Create a button
You will create a new button symbol that contains two layers. One layer will contain a shape representing the 
background of the button. The second layer will include a text label for the button. You will change the background 
and text label in the Over and Down states of the button to create the rollover effect.


To create a button:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Select Insert > New Symbol.


The Create New Symbol dialog box appears (Figure 1).


3. Select Button for Type, name the button, and click OK.


You are now in symbol-editing mode and viewing a 
separate timeline for the button symbol. The Up frame 
contains a keyframe (Figure 2).


Each frame on the timeline of a button symbol has a 
specific function:


• Up state: Represents the button’s appearance 
whenever the pointer is not over the button.


• Over state: Represents the button’s appearance when 
the pointer is over it.


• Down state: Represents the button’s appearance as it 
is clicked.


• Hit state: Defines the area that will respond to a 
mouse click. This area will be invisible in the 
published movie.


4. Make sure the Up frame is selected.


5. Use the drawing tools to create a shape for your button. 
Use the Properties panel to set the fill and stroke colors 
for the Up state of the button.


6. Select the Over state and select Insert > Timeline > 
Keyframe to add a keyframe.


Adding this keyframe copies the button graphic from the 
Up frame to the Over frame.


Figure 1 Create New Symbol dialog box


Figure 2 Button frames: Up, Over, Down, Hit
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7. Select the Over keyframe and use the Selection tool to 
select the button.


8. Change the fill or stroke color of the button shape.


When visitors roll over the button, the button will appear 
as you see it in the Over frame.


9. Insert keyframes in the Down and Hit frames of the layer.


This copies the button graphic from the Over frame to the 
Down and Hit frames.


10. Insert a new layer and name it Text.


11. Select the Up frame of the Text layer.


This frame already contains a keyframe.


12. Use the Text tool to type text on the button shape.


13. Use the Properties panel to adjust the font, size, and color 
of the text so it fits nicely on your button shape.


14. Use the Selection tool or the Up, Down, Left, and Right 
Arrow keys to position the text on the button shape.


15. Insert a keyframe in the Over frame of the Text layer.


16. Select the text and use the Properties panel to change 
some feature of the text in the Over frame, such as color.


17. Insert a keyframe in the Down frame. If you want the text 
to change appearance when the button is clicked, edit the 
appearance of the text in the Down frame.


The timeline should now appear as it does in the example 
(Figure 3).


Now you can insert an instance (copy) of the button 
symbol into the main timeline of your movie.


18. Click Scene 1 (Figure 4) to exit symbol-editing mode 
and return to the main timeline.


19. Select Window > Library to display the Library panel.


The new button symbol appears in the Library panel 
(Figure 5).


Note: You must select the symbol in the library to see the 
symbol in the preview pane.


20. Drag the button symbol from the Library panel onto the 
Stage.


21. Select Control > Test Movie > In Flash Professional to 
test the movie.


When you roll over the button with the pointer, you see 
the changes you defined in the Over frames for the 
button. If you edited the Down state of the button, this 
will be visible when you click the button.


22. Close the preview window.


Figure 3 Button timeline


Figure 4 Symbol-editing mode


Figure 5 Library panel, with the button selected
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Adding sound to a button
You can also add sounds to a button so visitors hear a sound when they interact with the button.


To add sound to a button:


1. Continue from where you left off in the preceding 
activity.


2. Use the Selection tool to double-click the button.


You enter symbol-editing mode for the button.


3. Insert a new layer and name it Sound.


4. Select File > Import > Import To Library to import a 
short sound into the library. 


You can acquire royalty-free sounds from sites such as 
www.flashkit.com.


5. On the Sound layer, add a keyframe to correspond with 
the button state to which you want to add a sound.


For example, to play a sound when visitors roll over the 
button, add the keyframe to the Over state.


6. Click the new keyframe.


7. In the Sound section of the Properties panel, select a 
sound file in the Name menu (Figure 6).


The sound waveform appears in the Sound layer in the 
Timeline panel (Figure 7).


8. Select Event in the Sync menu (Figure 6).


The sound will play when visitors interact with the 
button.


9. Select Control > Test Movie > In Flash Professional to 
test the movie.


When you interact with the button, you hear the sound.


10. Close the preview window.


Figure 6 Properties panel, sound properties


Figure 7 Timeline panel


Name menuSync menu


Sound waveform
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Adding control with actions
Right now the button looks great, but it doesn’t perform any action. You can remedy this by adding ActionScript code 
to your movie. The ActionScript code contains the instructions for what do when someone interacts with the button. 
Buttons give visitors control over the movie. You can use a button to stop the movie, start and stop sounds, restart the 
movie (after stopping it), or jump to different frames within the movie and continue playing. 


The ActionScript code references a button’s instance on the Stage, not the symbol stored in the library. This lets you 
use the same button symbol to perform different actions, depending on where it appears in your movie. 


To add control with actions:


1. Continue from where you left off in the preceding 
activity.


2. Select the button instance to which you want to add an 
action.


3. Click in the Instance Name box in the Properties panel 
(Figure 8) and enter a unique name to identify the button 
instance. The name should be descriptive, such as 
sound_btn, and cannot contain spaces. 


4. In the main timeline of your movie, create a new layer 
named Actions.


5. Make sure there is a keyframe in the Actions layer that 
corresponds to the keyframe where your button first 
appears on the Stage. Select this keyframe in the Actions 
layer.


Note: If your button doesn’t appear on this frame, Flash 
generates an error message when you publish the movie 
because the ActionScript you include on this frame refers 
to an object that isn’t on the Stage yet.


6. Select Window > Actions to display the Actions panel.


7. If you don’t see the parameters area in the Actions panel, 
click the Script Assist button.


8. In the Actions toolbox on the left side of the panel, select 
the AddEventListener method for the IEventDispatcher 
class.


To find the AddEventListener method, expand 
Flash.Events, and then expand IEventDispatcher and then 
Methods.


9. Double-click the AddEventListener method to add it to 
the Script pane (Figure 9).


10. Click in the Object box in the parameters area of the 
Actions panel.


The Insert Target Path button is now active.


11. Click the Insert Target Path button.


The Insert Target Path dialog box appears (Figure 10).


12. Select the Relative option and select the instance name of 
your button. Click OK to close the dialog box.


Figure 8 Properties panel


Figure 9 AddEventListener method 


Figure 10 Insert Target Path dialog box

How to create a button symbol © 2012 Adobe Systems Incorporated







Adobe Flash Professional CS6 Project 7 guide

13. In the Actions toolbox on the left side of the panel, select 
the CLICK property from the MouseEvent class.


To find the CLICK property, expand Flash.Events, and 
then expand MouseEvent and then Properties.


14. In the Script pane, select the AddEventListener() line to 
display the parameters for this method. Then, in the 
parameters area, click in the Type box.


15. In the Actions toolbox, double-click the CLICK property.


Script Assist adds the property to your code as 
MouseEvent.CLICK (Figure 11).


16. In the Listener box in the parameters area, type a name 
for the function that should execute when the button is 
clicked. You can use any name you like, but make sure 
the name of the function is unique and contains no 
spaces.


The function name appears in the Script pane as you type. 
You have named the function, but you haven’t created it 
yet.


17. In the Actions toolbox, select the function keyword from 
Language Elements. 


To find the function keyword, expand Language 
Elements. Then expand Statements, Keywords & 
Directives, and expand Definition Keyword.


18. Double-click the function keyword in the Actions 
toolbox.


The code for creating a function appears in the Script 
pane.


19. In the parameters area of the Script pane, type the name 
of your function in the Name box.


Note: You must type the function name exactly as you 
typed it for the AddEventListener function. Function 
names are case-sensitive.


20. In the parameters area of the Script pane, type 
event:MouseEvent in the Parameters box (Figure 12).


In this box, you are naming a variable (event) and 
indicating what type of variable it is (MouseEvent).


21. In the Actions toolbox on the left side of the panel, select 
the StopAll method for the SoundMixer class.


To find the StopAll method, expand Flash.Media, expand 
Methods, and then expand SoundMixer.


Figure 11 CLICK property in the Script pane


Figure 12 Function code in the Script pane
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22. Select the function in the Script pane and double-click 
the StopAll method in the Actions toolbox.


The method is added to the function (Figure 13).


23. Now when visitors click the button, all sounds currently 
playing in the movie will stop. Figure 13 StopAll method in the Actions panel


For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, 
select Help > Flash Help. Select ActionScript 3.0 And Components, select Programming ActionScript 3.0, and select 
Getting Started With ActionScript).
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How to draw and create shapes
You can add artwork to your Adobe Flash Professional CS6 documents in two ways: You can import images or draw 
original artwork in Flash by using the drawing tools in the Tools panel. 


Drawings you create in Flash are vector graphics. Vector graphics describe images by using lines and curves called 
vectors that also include color and position properties. When you edit a vector graphic, you modify the properties of 
the lines and curves that describe its shape. You can move, resize, reshape, and change the color of a vector graphic 
without changing the quality of its appearance. Vector graphics are resolution independent; that is, they can be 
displayed on output devices of varying resolutions without losing any quality. 


The files you import to Flash can be either vector graphics or bitmap images. Bitmap images (also known as raster 
images) are made up of pixels in a grid. Pixels are picture elements: tiny dots of individual color that make up what 
you see on your screen. A JPEG photograph is an example of a bitmap image. Because bitmaps are resolution 
dependent, it's difficult to increase or decrease their size without losing some image quality. Bitmap images are 
typically much larger in file size than vector graphics. 


The bitmap images you import to Flash can also be turned into vector drawings in two ways: You can break them 
apart to create a single vector shape or you can trace the bitmap to create a collection of vector shapes that resemble 
the original bitmap image.


In this guide you use the drawing tools to create and modify vector graphics. You also import bitmap images and 
convert them to vector shapes by using the Break Apart and Trace Bitmap commands.


Drawing with basic lines and shapes
One way to become familiar with the Flash drawing tools is to create something simple using basic lines and shapes.


Flash has two drawing modes: Merge Drawing and Object Drawing. Merge Drawing blends shapes when they 
overlap on the Stage. Shapes drawn on top of other shapes will merge, which means if you select one of the shapes 
and move it, the underneath shape is cut away (Figure 1).


Object drawing treats your shapes as grouped objects that can overlap without affecting each other (Figure 1). 


You can change between drawing modes by enabling or disabling Object Drawing in the Tools panel.


Figure 1 Merge Drawing (left) and Object Drawing (right)


Selecting drawing tools and setting properties


Flash drawing tools are available in the Tools panel. When you select a drawing tool, the properties for that tool 
appear in the Properties panel and any options for the selected tool appear at the bottom of the Tools panel. (You may 
need to enlarge the Flash window to see tool options.)


Most drawing tools have several properties in common, but each tool has a few unique properties.
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To set drawing tool properties:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Select the Oval tool in the Tools panel.


The Oval tool properties appear in the Properties panel 
(Figure 2). If the Properties panel isn’t open, select 
Window > Properties.


In the Properties panel, you can set the color, style, and 
size of the outer stroke of a shape. You can also change 
the color of the shape’s inner fill. 


You can select from several stroke types, such as solid or 
dashed lines.


Selecting the Hinting option enables stroke hinting. 
Stroke hinting adjusts line and curve anchors on full 
pixels to prevent blurry vertical or horizontal lines.


Cap settings control how the end of a path appears.


• None: The path ends flush—there is no cap.


• Round: Adds a round cap that extends beyond the 
path end by half the stroke width.


• Square: Adds a square cap that extends beyond the 
path end by half the stroke width.


Join settings define how two path segments meet 
(Figure 3). 


• Miter: Forms a sharp angle at the junction of two 
paths. To avoid beveling a mitered corner, enter a 
Miter value greater than 0.


• Round: Creates a smooth, rounded connection 
between two paths. 


• Bevel: Creates a beveled edge where two paths meet. 


The options in the Properties panel are slightly different 
for each drawing tool. For example, the Oval tool 
includes Start Angle, End Angle, and Inner Radius 
properties. 


The Rectangle tool includes Corner Radius properties for 
creating rounded corners (Figure 4).


If you are creating lines with the Brush tool or with the 
Pencil tool in Smooth mode, you can set the Smoothing 
value (Figure 5). Smoothing controls how Flash smooths 
out the curves in the lines you draw or paint. You can 
specify a value from 0 to 100. 


Figure 2 Properties panel, Oval tool


Figure 3 Join options (left to right): Miter, Round, 
Bevel


Figure 4 Rectangle tool corner radius options


Figure 5 Pencil and Brush tool Smoothing option


Stroke color Fill colorHinting option
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3. Make sure the Oval tool is still selected.


A tool’s modifier options are located in the options area 
at the bottom of the Tools panel (Figure 6). You may 
need to enlarge the Flash window to see tool options.


Options that are common to most Flash shape-drawing 
tools include:


• Stroke Color and Fill Color: Open a color palette 
to change stroke or fill color. In Merge Drawing 
mode, you must select a color before you begin 
drawing. You can also select stroke and fill colors 
in the Properties panel. 


• Black And White: Resets the stroke and fill colors 
to black stroke and white fill.


• Swap Colors: Swaps the current stroke and fill 
colors.


• Object Drawing: Toggles Object Drawing mode 
on and off. This is how you change between Merge 
Drawing and Object Drawing.


• Snap To Objects: Toggle the Snap To Objects 
feature on and off. This is off by default.


Figure 6 Tools panel, Oval tool modifier options


Creating a simple drawing with lines and shapes


A good way to become familiar with the Flash drawing tools is to create something very basic. In this activity, you 
use lines and shapes to create a simple drawing.


To draw in Merge Drawing mode:


1. Select the Oval tool in the Tools panel (if it’s not 
already selected). 


2. In the options section of the Tools panel, make sure 
Object Drawing is deselected.  


For now, you want to be in Merge Drawing mode.


3. Select a fill color for the shape, such as blue.


Note: You can select a fill color in the Properties panel 
or in the Tools panel.


4. Select a stroke color, such as black.


5. In the Properties panel, change the Stroke Height value 
to 15.


6. On the lower-center of the Stage, drag to draw an oval 
that is about 2 inches tall (Figure 7). 


Note: If you want to draw a perfect circle, hold down 
Shift as you drag the Oval tool on the Stage.


Figure 7 Oval shape with stroke and fill


Stroke color


Fill color


Black And White
Swap Colors


Object Drawing


Snap To Objects
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7. In the Properties panel, change the Oval tool fill color, 
perhaps to red.


8. Hold down Shift and drag on the Stage to create a perfect 
circle. Make it about the same size as the first oval and be 
sure the two shapes do not touch or overlap (Figure 8).


Note: If you make a mistake or don’t like what you’ve 
drawn, press Ctrl+Z (Windows) or Command+Z (Mac 
OS) to undo your drawing and start over.


9. Use the Selection tool to click the outline (stroke) of the 
top circle.


Only the outer stroke is selected.


10. Click the center (fill) of the top circle to select it.


Now only the fill is selected.


11. Double-click the fill of the top circle. 


The entire object (stroke and fill) is selected.


Note: If you double-click the stroke, only the stroke is 
selected. To select both the stroke and fill, you must 
double-click the fill.


12. With the top circle selected, drag it to the top portion of 
the bottom circle (Figure 9). 


13. Click away from the shapes to deselect them and then 
click once in the center of the top circle to select only its 
fill.


14. Press the Delete key.


Because you are drawing in merge mode, the selected fill 
disappears along with everything below it (Figure 10).


Next you draw in Object Drawing mode.


Figure 8 Two shapes with different fills


Figure 9 Drag to overlap the shapes


Figure 10 Merged shapes
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To draw in Object Drawing mode:


1. Select the Oval tool and then select the Object Drawing 
modifier in the options section at the bottom of the Tools 
panel (Figure 6).


2. Change the stroke color to light blue and the fill color to 
black. Change the Stroke Height value to 10.


3. Anywhere on the Stage, Shift-drag to draw a small circle 
in Object Drawing mode (Figure 11).


In Object Drawing mode, the shape’s stroke and fill are 
grouped as one object and share the same selection box. 


4. Use the Selection tool to select the circle you just drew, 
and in the Properties panel, change the Width (W) and 
Height (H) values to approximately 25 (Figure 12).


Note: You can click the Lock Width And Height Values 
Together option to constrain or unconstrain the height 
and width of the shape (Figure 12). 


5. With the small blue and black circle still selected, 
select Modify  > Convert to Symbol.


The Convert To Symbol dialog box appears (Figure 13).


6. Type blue_eye for Name, choose Graphic as the symbol 
Type, and click OK.


7. Open the Library panel, and drag another instance of the 
eye symbol to the Stage.


8. Use the Selection tool to drag both instances of the eye 
symbol into the empty space in the top circle shape 
(Figure 14).


You can place Object Drawings or symbols over other 
shapes without affecting the underlying shape.


One you place a symbol on the Stage, you can swap it for 
another symbol in the library. You do that next.


Figure 11 Small circle created in Object Drawing 
mode


Figure 12 Properties panel, Position And Size


Figure 13 Convert To Symbol dialog box


Figure 14 Shapes converted to symbols


Lock Width And Height Value 
Together option
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To swap symbol instances:


1. Create another small eye shape, only this time make the 
stroke color green. 


2. Convert the green eye shape to a new graphic symbol 
named green_eye.


Now you can create some characters with blue eyes and 
others with green eyes.


3. Use the Selection tool to select one of the blue_eye 
symbols on the Stage. 


4. In the Properties panel, click Swap (Figure 15).


The Swap Symbol dialog box appears (Figure 16).


5. Select the green_eye symbol in the Swap Symbol dialog 
box and click OK.


You have swapped the symbol on the Stage. Your 
character has one green eye and one blue eye 
(Figure 17).


6. Swap the other eye with a green eye so they match.


Next you use PolyStar tool to create a nose.


Figure 15 Properties panel, Swap button


Figure 16 Swap Symbol dialog box


Figure 17 Swapped symbols on the Stage
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To draw polygons and stars:


1. Select > Edit > Deselect All to make sure nothing is 
selected on the Stage.


2. Select the PolyStar tool in the Tools panel.


Note: The PolyStar tool shares the same space in the 
Tools panel as the Rectangle and Oval tools.


3. Open the Properties panel and change the fill color to 
black and the stroke color to None. 


Note: To set a stroke or fill color to None, click the color 
swatch in the Properties panel or in the Tools panel to 
open the color palette and click the None option 
(Figure 18). 


4. In the Tool Settings section of the Properties panel, click 
Options.


The Tool Settings dialog box appears (Figure 19). You 
can create polygons or stars.


5. In the Style menu, choose Polygon. Set the number of 
sides to 3 (to create a triangle), and click OK.


6. Drag to draw a triangle with one vertex pointing down 
(Figure 20).


7. In the Tools panel, select the Free Transform tool.


Free Transform selection handles appear around the 
selected shape (Figure 21).


8. Position the pointer over the lower-right selection handle 
of the triangle shape, and drag inward to reduce the size 
of the shape (Figure 21).


Note: You can hold down Shift as you drag to constrain 
the proportions of the shape. You can also resize the 
shape by entering Width (W) and Height (H) values in 
the Properties panel.


9. Use the Selection tool to select and drag the triangle 
below the eyes in your drawing (Figure 22).


Next you use the Line tool to create a mouth.


Figure 18 Stroke color palette


Figure 19  Tool Settings dialog box


Figure 20  Polygon shape


Figure 21  Free Transform selection


Figure 22  Position the triangle to create a nose


None
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To draw paths by using the Line, Pencil, and Brush tools:


1. Select the Line tool in the Tools panel.


2. In the Properties panel, select a stroke color and change 
the stroke height to 4.


3. Drag to draw a horizontal line below the triangle you just 
created (Figure 23).


4. Use the Selection tool to click an empty area of the Stage 
to deselect the line without selecting another shape.


5. Position the pointer along the bottom edge of the line and 
drag downward to modify the line (Figure 24).


6. Select the Brush tool in the Tools panel.


Notice the stroke options are disabled for the Brush tool 
in the Properties panel.


7. Select a fill color for the Brush tool in the Properties 
panel.


You can set painting options for the brush in the options 
section of the Tools panel (Figure 25).


• Object Drawing Mode: Toggle Object Drawing 
Mode on or off. 


• Lock Fill: When you select the Lock Fill modifier 
with the Brush or Paint Bucket tool and paint with 
the tool, the bitmap or gradient fill extends across the 
objects you paint on the Stage. 


• Brush Mode: Select from five painting modes.


• Paint Normal: Paints over lines and fills on the 
same layer.


• Paint Fills: Paints fills and empty areas, leaving 
lines unaffected.


• Paint Behind: Paints in blank areas of the Stage 
on the same layer, leaving other lines and fills 
unaffected.


• Paint Selection: Applies a new fill to the 
selection when you select a fill in the Fill Color 
control or the Fill box in the Properties panel, 
the same as selecting a filled area and applying a 
new fill.


• Paint Inside: Paints the fill in which you start a 
brush stroke and never paints lines. If you start 
painting in an empty area, the fill doesn’t affect 
any existing filled area.


• Brush Size and Brush Shape: Select a size and shape 
for the brush.


Figure 23  Position the triangle to create a mouth


Figure 24  Reshape the line to make a smile


Figure 25  Brush modifiers in the Tools panel


Lock Fill


Brush Size


Brush Mode


Brush Shape


Object Drawing Mode
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8. Experiment with the Brush tool by making several brush 
strokes on the Stage. 


In this example, we used the Brush to make antennae for 
the bug-like character who has been taking shape 
throughout this activity (Figure 26).


9. Select the Pencil tool in the Tools panel.


Notice the fill color option is disabled for the Pencil tool 
in the Properties panel.


10. Select a stroke color and set a stroke height for the Pencil.


Flash offers three pencil drawing modes, available in the 
options section of the Tools panel.


• Straighten: Draws straight line segments.


• Smooth: Draws curvy lines with smooth curves.


• Ink: Draws freehand lines with no modification 
applied.


11. Use the Pencil tool to put some final touches on your 
drawing (Figure 27). 


Note: Because you are still in Object Drawing mode, 
overlapping your existing shapes will not affect them.


Now you’ve created your entire character and have 
several shapes arranged on the stage.


Figure 26  Brush strokes used to create antennae


Figure 27  Smooth pencil lines used to create arms 
and legs
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Creating decorative fills by using the Deco tool
Designing the settings in a Flash movie or the virtual world in a game can be similar to designing sets or locations in 
a live-action movie. You don’t need to be a fine artist to include stylish backgrounds in Flash. By using the Deco 
(decorative) tool with its various drawing effects, you can turn symbols into complex geometric patterns with creative 
artistic fills.


Some Deco tool drawing effects, such as the Tree Brush or Lightning Brush, do not use symbols. Other Deco tool 
drawing effects, such as Grid Fills, require that you select a symbol in the document library to use as the artwork for 
the decorative fill.


The Symmetry effect


Use the Deco tool Symmetry effect to arrange symbols symmetrically around a central point.


To apply the Symmetry effect:


1. Open a Flash document that contains symbols or open a 
new blank Flash document (ActionScript 3.0) and use the 
shape tools to create a few new graphic symbols. 


Note: Smaller symbols work best when you are creating 
decorative fills. 


2. Select the Deco tool in the Tools panel.


Properties for the Deco tool appear in the Properties 
panel (Figure 28).


3. Select Symmetry Brush from the Drawing Effect menu in 
the Properties panel (Figure 29).


4. In the Properties panel, click the Edit button.


The Select Symbol dialog box appears. It shows the 
symbols in the library (Figure 30).


You can use any movie clip or graphic symbol in the 
library with the Symmetry Brush effect. This symbol-
based effect gives you a great deal of creative control 
over artwork you create in Flash.


5. Select one of the symbols you created and click OK.


Figure 28 Properties panel, Deco tool


Figure 29 Drawing Effect menu


Figure 30 Select Symbol dialog box


Deco tool
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6. In the Properties panel, choose one of the options from 
the Advanced Options menu (Figure 31). 


• Reflect Across Line: Flips the shapes an equal 
distance apart across an invisible line that you 
specify.


• Reflect Across Point: Places two shapes an equal 
distance apart around a fixed point that you specify.


• Rotate Around: Rotates the shapes in the symmetry 
around a fixed point that you designate. The default 
reference point is the center point of the symmetry. 
To rotate the object around its center point, drag in a 
circular motion.


• Grid Translation: Creates a grid by using the shapes 
in the Symmetry effect you are drawing. Each click 
of the Deco tool on the Stage creates a grid of 
shapes. Adjust the height and width of the shapes by 
using the x and y coordinates defined by the 
Symmetry Brush handles.


7. Click the Stage where you want the Symmetry Brush 
artwork to appear (Figure 32).


8. Use the Symmetry Brush handles to adjust the size of the 
symmetry and the number of symbol instances. 


9. Select Edit > Select All and press Delete. 


You will start the next activity with an empty Stage.


Figure 31 Advanced Options menu


Figure 32 Placing symbols with the Symmetry 
Brush
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The Grid Fill effect


You can use the Grid Fill effect to fill the Stage, a symbol, or a closed region with a symbol from the library. After 
you draw a Grid Fill on the Stage, if you move or resize the filled symbol, the Grid Fill moves or resizes accordingly.


The Grid Fill effect creates a repeating tiled background or an area or shape with a custom pattern. The default 
symbol for the Grid Fill effect is a 25-by-25-pixel black rectangular shape with no stroke.


To apply the Grid Fill effect:


1. Select the Deco tool, and select Grid Fill from the 
Drawing Effect menu in the Properties panel (Figure 33).


You can use any movie clip or graphic symbol in the 
library with the Grid Fill effect. You can use the same 
symbol for all tiles or combine up to four symbols. The 
default shape is a small black square. You an change the 
color used for the default shape by clicking the color 
swatch for each tile and picking a new color.


2. In the Properties panel, click the Tile 1 Edit button to 
select a symbol from the library.


The Select Symbol dialog box appears, listing symbols in 
the document library.


3. Select a symbol in the Select Symbol dialog box and 
click OK.


You can use the following advanced options in the 
Properties panel to specify the horizontal and vertical 
spacing and the scale of the fill shape.


• Horizontal Spacing: Specifies the horizontal 
distance in pixels between shapes used in the Grid 
Fill.


• Vertical Spacing: Specifies the vertical distance in 
pixels between shapes used in the Grid Fill.


• Pattern Scale: Enlarges or shrinks an object 
horizontally (along the x axis) and vertically (along 
the y axis).


After you apply the Grid Fill effect, you cannot change 
the advanced options to alter the fill pattern.


4. Click the Stage or click within a shape or symbol where 
you want the Grid Fill pattern to appear.


The pattern fills the area (Figure 34). If you want the 
entire grid filled with the same symbol, select that 
symbol for all four tiles in the Properties panel.


5. Select Edit > Select All and press Delete. 


You will start the next activity with an empty Stage.


Figure 33 Deco tool Grid Fill properties


Figure 34 Grid Fill pattern
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The 3D Brush effect


You can use the 3D Brush effect to spray symbols so they appear to be in front of each other. After you draw a 3D 
Brush on the Stage, if you resize or otherwise change the filled symbol, the 3D Brush changes accordingly.


To apply the 3D Brush effect:


1. Select the Deco tool, and select 3D Brush from the 
Drawing Effect menu in the Properties panel (Figure 35).


Similar to the Grid Fill effect, you can choose the 
symbols or default shapes to use when drawing.


2. In the Properties panel, click the Object 1 Edit button to 
select a symbol from the library.


The Select Symbol dialog box appears.


You can use any movie clip or graphic symbol in the 
library with the 3D Brush effect.


3. Select a symbol in the Select Symbol dialog box and 
click OK.


You can use the following advanced options in the 
Properties panel.


• Max Objects: Specifies the total number of shapes 
used in the 3D Brush.


• Spray Area: Specifies the area covered in each spray 
of the 3D Brush.


• Perspective: Specifies that objects appear in front of 
each other.


• Distance Scale: Specifies how far in front of each 
other objects appear to be.


• Random Scale Range: Specifies the degree to which 
objects vary in size.


• Random Rotation Range: Specifies the degree to 
which objects are rotated.


Note: After you apply the 3D Brush effect, you cannot 
change the advanced options to alter the fill pattern.


4. Drag the pointer across the Stage to draw with the 3D 
Brush (Figure 36).


As you drag, Flash paints a pattern using the objects you 
selected in the Properties panel. 


5. Select Edit > Select All and press Delete. 


You will start the next activity with an empty Stage.


Figure 35 Deco tool 3D Brush properties 


Figure 36 Placing symbols with the 3D Brush 
effect
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The Vine Fill effect


You can use the Vine Fill effect to fill the Stage, a symbol, or a closed region with a vine-like pattern. You can 
substitute your own artwork for the leaves and flowers by selecting symbols from the library. The resulting pattern is 
contained in a movie clip that itself contains the symbols that make up the pattern.


To apply the Vine Fill effect:


1. Select the Deco tool, and select Vine Fill from the 
Drawing Effect menu in the Properties panel (Figure 37).


By default, the Vine Fill effect uses a leaf and flower as 
the artwork for the fill. You can change these to custom 
symbols by clicking the Edit buttons and selecting 
symbols in the document library.


You can set the following Advanced Options in the 
Properties panel:


• Branch Angle: Specifies the angle of the branch 
pattern.


• Branch Color: The color box to the right of Branch 
Angle. Specifies the color for the branch.


• Pattern Scale: Adjusts an object by enlarging or 
reducing it both horizontally (along the x axis), and 
vertically (along the y axis).


• Segment Length: Specifies the length of the 
segments between leaf and flower nodes.


• Animate Pattern: Specifies that each iteration of the 
effect is drawn to a new frame in the Timeline. This 
option creates a frame-by-frame animated sequence 
of the flower pattern as it is drawn.


• Frame Step: Specifies how many frames to span per 
second of the effect being drawn.


Note: After you apply the Vine Fill effect, you cannot 
change the advanced options in the Properties panel to 
alter the fill pattern.


2. Click the Stage or click within the shape or symbol where 
you want the Vine Fill pattern to appear.


The pattern fills the area (Figure 38).


3. Select Edit > Select All and press Delete. 


You will start the next activity with an empty Stage.


Figure 37 Deco tool Vine Fill properties


Figure 38 Vine Fill pattern
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Converting text and bitmap images to vector shapes
In addition to drawing vector shapes in Flash, you can import bitmap graphics, such as photographs, and convert 
them to vector artwork. Converting large bitmaps to vectors can significantly reduce the file size of your document.


Flash provides two ways to convert a bitmap image to a vector shape: Break Apart converts the entire bitmap into a 
single shape. Trace Bitmap analyzes the colors in the bitmap image and creates a collection of merged shapes.


Using the Break Apart command


The Break Apart command appears in the Modify menu.


You can break apart bitmaps and text to create vector shapes. When you break apart text, you can use the resulting 
shape in an animation that morphs the shape into another shape. 


When objects or symbols are grouped, using Break Apart ungroups them into separate objects. You may need to use 
Break Apart several times to completely ungroup objects before you can convert them into vector drawings. 


To break apart text:


1. Use the Text tool to create some text. Use the Selection 
tool to select the text.


2. Select Modify > Break Apart.


The text is ungrouped into separate letters (Figure 39). 
You can now select and modify each letter as a separate 
object, but they are still not vector shapes, as shown in 
the Properties panel (Figure 41). You need to break them 
apart a second time to convert them to vector shapes.


3. Select Modify > Break Apart again.


Flash converts the selected letters into several shapes 
(Figure 40), as shown at the top of the Properties panel 
(Figure 41). 


4. Select Edit > Select All and press Delete. 


You will start the next activity with an empty Stage.


Figure 39 Text broken into separate objects


Figure 40 Letter objects broken into shapes


Figure 41 Properties panel, shape properties
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To break apart a bitmap image:


1. Select the bitmap you want to break apart.


Note: To import a bitmap image, you can choose File > 
Import > Import To Stage, select the file to import, and 
click Open. 


2. Select Modify > Break Apart.


Flash converts the bitmap image to a shape, as shown at 
the top of the Properties panel (Figure 42).


The selected image is filled with a consistent pattern to 
show it’s selected as a single shape object (Figure 43).


3. Click away from the shape or select Edit > Deselect All 
to deselect the shape.


4. Click the shape again to select it.


The entire shape is selected as a single object.


5. Select Modify > Combine Objects > Union.


The shape is grouped as a single drawing object, as 
shown in the Properties panel (Figure 44). You can now 
apply stroke and fill properties.


6. Select Edit > Select All and press Delete.


Figure 42 Properties panel, shape properties


Figure 43 Selected shape


Figure 44 Properties panel, drawing object
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Using Trace Bitmap


In this activity, you trace the same bitmap you broke apart in the previous activity to see the difference between Break 
Apart and Trace Bitmap.


To trace a bitmap image:


1. Select the bitmap you want to break apart.


Note: If you’ve already imported the image, you can drag 
a fresh copy of the image from the Library panel to the 
Stage. 


2. Select Modify > Bitmap > Trace Bitmap.


The Trace Bitmap dialog box appears (Figure 45). 
Tracing will occur based on colors and lines in the image. 
You can adjust how sensitive Flash is when analyzing the 
bitmap. 


3. Click OK to accept the default Trace Bitmap settings.


Flash traces the bitmap and creates an artistic rendering 
of the image. The resulting object is a vector shape, as 
shown in the Properties panel.


4. Click away from the image or select Edit > Deselect All 
to deselect the shape.


5. Click in the image again.


Only a portion of the image is selected (Figure 46). 
When you trace a bitmap, the resulting vector drawing is 
a collection of merged shapes.


Figure 45 Trace Bitmap dialog box


Figure 46 Traced bitmap converted to shapes
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Using adaptive scaling to produce a Flash document for multiple screens
It used to be that one of the most time-consuming tasks of designing content in Flash was to size and optimize your 
movie for multiple screen sizes. With Adobe Flash Professional CS6, you can now choose to scale the contents of 
your document when you change the Stage size. All objects on the Stage, including symbols, shapes, paths, motion 
paths, and bitmap images across all scenes, are scaled together.


To scale a document by using adaptive scaling:


1. Select Modify > Document.


The Document Settings dialog box appears (Figure 47). 


When you change the Dimensions settings of the 
document, the Scale Content With Stage option becomes 
active. This option activates adaptive scaling.


2. To change the document dimensions, select Scale 
Content With Stage, and click OK.


The content resizes along with the Stage.


3. Select Edit > Undo Modify FLA Document to return the 
Stage and content to their original dimensions.


Figure 47 Document Settings dialog box
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Introduction to HTML and CSS
Before you learn about Cascading Style Sheets (CSS), you should have a basic understanding of HTML, the 
programming language used to create web pages.


The structure and appearance of a web page is controlled by its underlying code. The programming language used to 
write this code for web pages is Hypertext Markup Language, or HTML.


If you view the code for most web pages, you will see line after line of ordinary text, surrounded by short commands 
called HTML tags. These tags are placed in brackets at the beginning and end of blocks of text and tell a web browser 
how to display or interact with information between the tags. Tags are enclosed by angle brackets (<>) and usually 
come in pairs with a start (or opening) and end (or closing) tag. The example shows two HTML tags that tell a web 
browser where a paragraph of text begins and ends (Figure 1). The HTML tags themselves are not displayed in the 
browser.


Figure 1 Sample HTML tags


When you create a web page by using Dreamweaver in Design view, the HTML code is created automatically. These 
are common tags you will see when working in Dreamweaver:


• <html></html> describes the web page


• <head></head> describes the header of the web page


• <body></body> describes visible page content


• <h1></h1> displays a heading, ranging in size from 1 (biggest) to 6 (smallest)


• <p></p> formats text as a paragraph


• <strong></strong> bolds text


• <em></em> emphasizes text, displays as italics


• <br> creates a line break


• <a href="http://www.example.com"></a> creates a link to a web page


Note: Dreamweaver uses code coloring to help you identify general categories of tags and code elements in Code 
view. 


Although HTML includes tags for displaying text, images, tables, and other page elements, it has limited precision in 
page layout and formatting—a frustration for many designers. 


Cascading Style Sheets (CSS) is a collection of formatting rules that control the appearance of content (such as 
HTML tags) in a web page. Using CSS styles to format a page separates content from presentation. The content of 
your page—the HTML code and tags—resides in the HTML file, and the CSS rules defining the presentation of the 
code reside in another file (an external style sheet) or in another part of the HTML document (usually the head 
section). Separating content from presentation mean you can more easily maintain the appearance of your site from a 
central location, because you don’t need to update every property on every page whenever you want to make a 
change. Separating content from presentation also results in simpler and cleaner HTML code, which provides shorter 
browser loading times and simplifies navigation for people with accessibility issues (for example, those using screen 
readers).


<p>This is a paragraph of text.</p>


Paragraph starting tag Paragraph ending tag
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If you have worked with styles in other programs, such as a word processor, you are already familiar with the basic 
function of CSS. In CSS, a style is simply a rule describing how to format content on a web page. A CSS (style sheet) 
is a collection of these rules.


About CSS rules
A CSS formatting rule consists of two parts: the selector and the declaration (or in most cases, a block of 
declarations). The selector is a term (such as p, h1, a class name, or an id) that identifies the formatted element. The 
declaration block defines the style properties. In the following example, h1 (a heading tag) is the selector, and 
everything that falls between the braces ({and }) is the declaration block (defining the properties of the h1 heading):


h1 { 


font-family: Georgia, "Times New Roman", Times, serif;


font-size: 18px;


text-transform: uppercase;


color: #090; 


}


An individual declaration consists of two parts: the property (such as font-family) and value (such as Georgia). In the 
previous CSS rule, a particular style has been created for h1 tags; the text for all h1 tags linked to this style will be 18 
pixels in size, Georgia font, and uppercase, and [color 090]. 


The style (which comes from a rule, or a collection of rules) resides in a place separate from the actual text it’s 
formatting—usually in an external style sheet or in the head section of an HTML document. Thus, one rule for h1 
tags can apply to many tags at once (and in the case of external style sheets, the rule can apply to many tags at once on 
many different pages) (Figure 2). In this way, CSS provides extremely easy update capability. When you update a 
CSS rule in one place, the formatting of all the elements that use the defined style is automatically updated to the new 
style.


Figure 2 Updating a CSS rule in one place updates all elements


There are three main types of CSS:


Class style: Similar to the styles you use in word processing and page layout programs. For example, you may 
want to format all body text in 10-point, Arial, dark green type. You can create a class style with these attributes 
and then apply this style to all body text in your website. Class names must begin with a period and can contain 
any combination of letters and numbers (for example, .myhead1). 
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HTML tag style: Applies global formatting to individual HTML tags rather than to individual selections. 
Suppose you want to modify the Heading 1 paragraph style to appear always in purple text. Instead of creating a 
class style and applying it to every heading in the document, you can create an HTML tag style with these 
attributes and apply it to the Heading 1 <h1> tag. In effect, you are redefining the HTML tag.


ID style: A unique identifier (ID) for a style applied to headers, banners, menus, and other elements present in 
only one location in the document. Used once within a document or page. IDs must begin with a pound (#) sign 
and can contain any combination of letters and numbers (for example, #myID1). 


CSS rules can reside in the following locations:


Internal (or embedded) CSS style sheets are collections of CSS rules included in a style tag in the head section of 
an HTML document.


External CSS style sheets are collections of CSS rules stored in a separate, external CSS (.css) file (not an HTML 
file). You link this file to one or more pages in a website by using a link or an @import rule in the head section of 
a document. 


Evolution of HTML and CSS
HTML and CSS are web standards that are constantly evolving. 


HTML5 is the fifth iteration of HTML and adds tags to support multimedia elements and dynamic graphics in 
modern web browsers and across various devices. CSS3 defines a new set of modular rules for how HTML content is 
presented in web browsers.


In Dreamweaver, you can create and edit HTML5-based web pages. Dreamweaver provides code hints for HTML5 
elements and CSS3 styles when you build pages in the Code View window. Starter layouts are also available for 
building HTML5 pages from scratch.


You should observe the following best practices when authoring HTML5 pages:


• Use <!doctype html> to tell browsers the web page is formatted with HTML5.


• Use <meta charset="utf-8"> to tell browsers which character-set is in use in the document.


• Use the semantic markup tags <article>,  <section>, <header>,  <nav>, and others to bring a higher 
level of structural meaning to HTML5 documents.


• Design and test content across a range of browsers and devices that support HTML5 capabilities.


Review these HTML5 and CSS3 resources from the W3C:


• W3C HTML5 specifications: http://dev.w3.org/html5/spec/single-page.html


• HTML5 differences from HTML4: www.w3.org/TR/html5-diff/


• W3C CSS home page: www.w3.org/Style/CSS/ 
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How to publish web files
Once you’ve specified a local site in Dreamweaver, you can specify a remote server for your site as well. The remote 
server (often referred to as the web server) is where you publish your site files so that people can view them online. 
The remote server is simply another computer like your local computer, with a collection of files and folders on it. 
You specify a folder for your site on the remote server, just as you specified a folder for your local site on your local 
computer (Figure 1). Dreamweaver refers to the specified remote folder as your remote site.


Figure 1 Basic screen of the Servers category, Site Setup dialog box


When you set up a remote folder, you select a connection method for Dreamweaver to upload files to your web server 
and download files from your web server. The most typical connection method is FTP, but Dreamweaver also 
supports local/network, FTPS, SFTP, WebDav, and RDS connection methods. If you don’t know which connection 
method to use, ask your teacher or your school server administrator.


Connecting to a remote site
Many websites let you publish files through FTP (File Transfer Protocol). You connect to a remote site by using the 
Site Definition dialog box in Adobe Dreamweaver CS6. 


To connect to a remote site by FTP:


1. Select Site > Manage Sites.


The Manage Sites dialog box opens (Figure 2).


2. Double-click the name of the site you want to connect 
remotely.


The Site Setup dialog box opens.


Figure 2 Manage Sites dialog box
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3. Click the Servers category in the left column.


The Servers category of the Site Setup dialog box opens (Figure 3).


Figure 3 Basic screen of the Servers category, Site Setup dialog box


4. Click the Add New Server button (+).


5. Enter the FTP access information as directed by your teacher (Figure 1).


6. Click Test to test the connection.


Dreamweaver confirms the connection.


7. Click Save.


The new server appears in the list of servers in the Site Setup dialog box.


8. Click Save to close the Site Setup dialog box.


9. Click Done to close the Manage Sites dialog box.


Add New Server
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Uploading, Synchronizing, and downloading files
Once you establish an FTP connection, you can use the Get and Put commands to transfer files from the Files panel 
(Figure 4).


Figure 4 Expanded Files panel


When you transfer a document between a local and remote folder using the Files panel, you have the option of 
transferring the document’s dependent files. Dependent files are images, external style sheets, and other files 
referenced in your document that a browser loads when it loads the document.


Note: It’s usually a good idea to download dependent files when checking out a new file, but if the latest versions of 
the dependent files are already on the local disk, there’s no need to download them again. This is also true for 
uploading and checking in files: no need if up-to-date copies are already at the remote site.


To upload the entire site for the first time:


1. In the Files panel (Window > Files), select the files to 
upload.


2. Click the Expand/Collapse button in the Files panel 
toolbar (Figure 4).


The Files panel expands.


3. Click the Connects To Remote Host button in the Files 
panel toolbar.


Dreamweaver connects to the web server.


4. Select the root folder for your site in the Local (right) 
pane.


5. Click the Put Files button in the Files panel toolbar.


6. You may be presented with a dialog box asking if you 
wish to put the entire site. Click OK.


Dreamweaver uploads the site’s files and opens the 
Background File Activity dialog box (Figure 5).


Note: To upload one or more folders or files without 
uploading the entire site, select them and click the Put 
Files button.


Figure 5 Background File Activity dialog box


Connects/Disconnects Remote Host Get Files Put Files Synchronize Expand/CollapseRefresh
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To upload a revised version of an existing file:


1. Select the file you have revised.


2. Click the Put Files button in the Files panel toolbar.


Dreamweaver uploads the revised file.


Synchronizing the files on your local and remote sites


After you’ve created files in your local and remote sites, you can synchronize the files between the two sites.


Before you synchronize your sites, you can verify which files you want to put, get, delete, or ignore. Dreamweaver 
also confirms which files have been updated after you complete the synchronization.


To synchronize files:


1. (Optional) Select specific files or folders in the Files 
panel or go to the next step to synchronize the entire site.


2. Click the Synchronize button in the Files panel toolbar to 
synchronize files.


The Synchronize Files dialog box opens (Figure 6).


3. Select the direction in which you want to copy the files:


Put Newer Files To Remote uploads all the local files that 
don’t exist on the remote server or have changed since 
the last upload.


Get Newer Files From Remote downloads all the remote 
files that don’t exist locally or have changed since the last 
download.


Get And Put Newer Files places the most recent versions 
of all the files on both the local and the remote sites.


4. Choose whether to delete the files on the destination site 
that don’t have counterparts on the origin site. (This is 
not available if you select Get and Put from the Direction 
menu.)


If you select Put Newer Files To Remote and you select 
the Delete option, then any files in your remote site for 
which there are no corresponding local files are deleted. 
If you select Get Newer Files From Remote, then any 
files in your local site for which there are no 
corresponding remote files are deleted.


Figure 6 Synchronize Files dialog box 
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5. Click Preview.


Dreamweaver analyzes the local and remote folders, and 
then the Synchronize dialog box opens (Figure 7).


Note: Before you can synchronize the files, you must 
preview the actions Dreamweaver performs to 
accomplish this task. 


If the newest version of each chosen file is already in 
both locations and nothing needs to be deleted, an alert 
appears informing you that no synchronization is 
necessary. Otherwise, the Synchronize dialog box 
appears to let you change the actions (put, get, delete, and 
ignore) for those files before executing the 
synchronization.


6. Verify the action that will be performed for each file.


7. Click OK to synchronize the files.


Figure 7 Synchronize dialog box 


Downloading files to work on them


Once your website has been published, you may want to download a file so you can revise it. You do so through the 
Remote Site pane, on the left side of the expanded Files panel.


To download a file:


1. Click the Refresh button in the Files panel toolbar 
(Figure 4) to make sure the files in the Remote Site pane 
are up-to-date.


2. Select a file to download.


3. Click the Get Files button.


If the file has any dependent files, the Dependent Files 
dialog box opens (Figure 8). 


Note: If you do not click Yes within 30 seconds, the 
Dependent Files dialog box automatically closes and 
dependent files are not downloaded.


4. Click Yes.


Dreamweaver copies the file and its dependent files to 
your local folder. The downloaded files appear in the 
right pane of the expanded Files panel.


5. Click the Disconnects From Remote Host button, and 
then collapse the Files panel.


Figure 8 Dependent Files dialog box 
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Peer Review


Name: _______________________________________________________ Date: ________________________


Project: _____________________________________________________


Overview
Revision is an important part of the design process. In addition to conducting review and redesign cycles personally 
and with your client, you can also benefit from peer review. Additionally, peer review occurs in many professional 
environments and it will be good practice to start on this essential skill now.


When giving peer review, be sure your points are both positive and negative. Give your critiques as suggestions, not 
commands. When receiving peer review, do not be disenchanted or feel that you did a bad job based on one review. 
Every review is different, and what one person does not approve of, the next person may find exemplary.


Process for presenting work for peer review


• When presenting your work for peer review, state the purpose, audience, and goals of your document and 
point out any concerns you have.


• To conclude, summarize the reviewer’s suggestions and offer a plan for revision.


Guidelines for giving comments and suggestions


• Before making any comments, review the entire document and make sure you understand the designer’s 
intentions. Or, if being presented work by a designer, your first response should be to reiterate the designer’s 
purpose, audience, and goals.


• After the designer’s purpose, audience, and goals are clear, ask questions of the designer, make comments, 
and offer suggestions.


• Point out both the strengths and the weaknesses of the document (design, layout, typography, and so on).


• Offer suggestions, not commands. For instance, do not use “should,” as in “You should do this….” Instead, 
use “I” statements, such as “I see that…” or “I’m confused about....”


• Be respectful and considerate of your peer’s feelings. Do not say or write anything you wouldn’t want to 
receive yourself—there is no reason to be rude.


• Make sure your comments are clear and specific so your peer knows what you are referring to. It is 
important to give specific examples and point to design principles, image composition, layout guidelines, 
and so on to make your point. Such comments as “this is unclear” or “this is too vague,” are too general to be 
helpful. Rather make a comment like, “I’m confused by this image because there is no caption identifying 
what it is”).


• If you are writing your comments, reread them before passing them on to your peer. Make sure all your 
comments make sense and are easy to follow.





		Peer Review

		Name: Date:

		Project:

		Overview

		Revision is an important part of the design process. In addition to conducting review and redesign cycles personally and with your client, you can also benefit from peer review. Additionally, peer review occurs in many professional environments and i...

		When giving peer review, be sure your points are both positive and negative. Give your critiques as suggestions, not commands. When receiving peer review, do not be disenchanted or feel that you did a bad job based on one review. Every review is diff...



		Process for presenting work for peer review

		• When presenting your work for peer review, state the purpose, audience, and goals of your document and point out any concerns you have.

		• To conclude, summarize the reviewer’s suggestions and offer a plan for revision.



		Guidelines for giving comments and suggestions

		• Before making any comments, review the entire document and make sure you understand the designer’s intentions. Or, if being presented work by a designer, your first response should be to reiterate the designer’s purpose, audience, and goals.

		• After the designer’s purpose, audience, and goals are clear, ask questions of the designer, make comments, and offer suggestions.

		• Point out both the strengths and the weaknesses of the document (design, layout, typography, and so on).

		• Offer suggestions, not commands. For instance, do not use “should,” as in “You should do this….” Instead, use “I” statements, such as “I see that…” or “I’m confused about....”

		• Be respectful and considerate of your peer’s feelings. Do not say or write anything you wouldn’t want to receive yourself—there is no reason to be rude.

		• Make sure your comments are clear and specific so your peer knows what you are referring to. It is important to give specific examples and point to design principles, image composition, layout guidelines, and so on to make your point. Such commen...

		• If you are writing your comments, reread them before passing them on to your peer. Make sure all your comments make sense and are easy to follow.
















Digital Design Project 3 worksheet


© 2012 Adobe Systems Incorporated How to promote a website 1


How to promote a website


Team name: __________________________________________________ Date: ________________________


Investigate how to use search engines on the web to promote a website. When you submit the URL for your site to a 
search engine, people can locate your site based on information you provide about your site.


Conduct a web search for “search engine submission” for search engine submission tips.


Find a search engine that offers free submission of websites.


Site name and URL: ____________________________________________________________________________


Submission procedure: __________________________________________________________________________


Find a search engine or promotion site for which you pay to submit your site.


Site name and URL: ____________________________________________________________________________


Cost to submit: ________________________________________________________________________________


Submission procedure: __________________________________________________________________________


Is this search engine or promotion site worth the cost? Why or why not? ___________________________________
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What is reusable design? 

		Developing elements–such as patterns, components, frameworks, assets, and content–that can be used in a variety of contexts while maintaining their usefulness each time they are reused. 

		Reusable does not mean perfect: Nearly everything that is designed will likely need to be adapted each time it is reused, so all elements should be adaptable, depending on the context in which they are used. 



*
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What are the benefits of reusable design?

		Ensures consistency across web projects. 

		Enables making updates and global changes easily, quickly, and from anywhere.

		Often results in less work on future projects.

		Useful when designing for multiple devices, especially by creating mobile-optimized components.

		Provides an archive of design decisions.

		Allows for portability between team members, so it doesn’t matter who works on the project or at what stage they work on it.

		Enables a reusable framework that includes standardized style sheets and directories that can be adapted for each new project.



*
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Web standards and reuse

		CSS

		Fosters consistency in the look and feel of web projects. 

		Fosters consistency in the appearance of pages across multiple browsers and platforms.

		Enables instant global changes.

		Produces style sheets that can be reused for all types of web projects.

		Enables adaption of a design to multiple devices and screen sizes.

		HTML5

		Enables content to be viewed on a variety of browsers.

		Accounts for graceful degradation–meaning content will appear as it should in older browsers.

		Ensures accessible content.



*





© 2012 Adobe Systems Incorporated.  All Rights Reserved. 



Best practices

		Use CSS starter pages and HTML templates (especially for navigation) and adapt as necessary for each project. 

		Create a structured framework using CSS starter pages and templates to start new projects. Framework can include: 

		a template index page

		CSS style sheets

		Directories for images, scripts, vendor prefixes, and server and/or client-side includes 

		Use CSS Fluid Grids, media queries, and flexible images for responsive design across multiple screens and devices.





*



		Web fonts are temporarily downloaded to display text in fonts that need not be installed on a site visitor's computer. There are two methods for delivering web fonts to site visitors: subscription-based hosted services that license fonts for use and free open-source fonts. Web fonts can be accessed remotely from a web server or can be downloaded and embedded into a website. 

		Code snippets are small pieces of HTML, Javascript, and CSS code that you can reuse in a web project, often used for widgets.



*
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Best practices

		Create reusable assets (images, logos, video, sound) for web projects.

		Use web fonts to make content consistent and readable in all browsers and devices.

		Use code snippets to integrate features such as shopping carts, calendars, and polls. 

		Always determine copyright protections when reusing assets or code.

		Create libraries of reusable patterns, components, and frameworks.

		Document patterns and components, including descriptions of the contexts in which they are useful. 



*
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Patterns and components

		Patterns and components are reusable design solutions for specific problems. 

		A pattern describes the behavior of a user (for example, logging in) and how different designs can support a particular behavior pattern. Use patterns to create global solutions to common design problems that can then be adapted for a specific context.

		A component is usually specific code with elements such as text, links, buttons, checkboxes, and images that can be easily reused as a chunk of a web page or grid. Each component is a small portion of the page that is reusable and independent of other chunks.

		Designers can utilize patterns and components in wireframes and mockups.



*



Reference: Modular Web Design: Creating Reusable Components for User Experience Design and Documentation: http://my.safaribooksonline.com/book/web-development/usability/9780321638311

*
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Chunking and assembling 

		Components eventually need to be combined and arranged into whole pages. Chunking and assembling allow designers to see how components fit into variations of single and multiple pages. 

		Chunking breaks a web page up so the components are used as building blocks for specific regions on a page. 

		Once all components are identified and designed, assemble the components to make up single or multiple pages.



*



Reference: Modular Web Design: Creating Reusable Components for User Experience Design and Documentation: http://my.safaribooksonline.com/book/web-development/usability/9780321638311

*
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Conclusion

		Reusable design: 

		Enables designers to use a variety of elements multiple times in multiple ways in a variety of contexts

		Maintains its value and usefulness across projects 

		Saves time and money 

		Is adaptable to each context and project

		Uses patterns, components, and frameworks to respond to user behaviors and quickly build projects

		Applies web standards

		Should be documented and archived



*





*
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How to organize content 
Adobe Flash Professional CS6 documents can involve hundreds of different elements. Organizing these will make 
developing Flash content much easier.


Organize the library
You can create folders to organize your files in the library of a Flash document.


To create folders in the library:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


By default, the Library panel is open on the right-side of 
the workspace (Figure 1). If the Library panel is not 
open, select Window > Library to open it.


2. To create a folder in the library, choose New Folder in the 
Library panel menu or click the New Folder button 
(Figure 1).


The new folder is added to the library.


Folders are represented by file folder icons.


3. Name the folder and drag files into the folder.


You can even store folders within other folders.


4. Double-click a folder icon to see or hide its contents.


You can also see or hide the contents of a folder by 
clicking the disclosure triangle beside the folder.


Figure 1 Library panel


New Folder button
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Organize layers in the Timeline panel
Organize your layers by using descriptive layer names, putting layers in a logical order, and creating folders. Use 
separate layers or folders for sound files, ActionScript, frame labels, and frame comments. This helps you find these 
items quickly to edit them.


To organize layers:


1. To change the name of a layer, double-click the name and 
enter a new name.


2. You can change the order of layers by dragging a layer up 
or down in the stack.


Note: It is recommended that you place ActionScript in a 
layer named actions and labels in a layer named labels, 
typically at the top of the layer stack. Background layers 
go at the bottom of the stack.


3. To create a layer folder, click the New Folder button at 
the bottom of the Timeline panel (Figure 2) and give the 
folder a new name.


4. Drag layers into folders to keep them organized.


Figure 2 Timeline panel


Label keyframes
You can label certain frames to indicate when changes occur on the timeline.


To label a keyframe:


1. Select a frame you want to label.


2. In the Properties panel, enter the label in the Name text 
box (Figure 3).


The label appears on the timeline (Figure 4).


Note: Avoid long names to minimize file size and also to 
keep the label from spanning too many frames.


Figure 3 Name text box


Figure 4 Frame labels in the timeline


New Folder button


Frame label
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How to create and edit a CSS rule
You can create and edit a CSS rule in two locations: the Properties panel and the CSS Styles panel. When you apply 
CSS styles to text by using the Properties panel or menu commands, CSS rules are embedded in the head of the 
current document. You can also use the CSS Styles panel to create and edit CSS rules and properties. 


In this guide, you review CSS rules, create and apply a class-style CSS rule by using the Properties panel, and modify 
an HTML tag-style rule by using the CSS Styles panel.


About CSS rules
A CSS formatting rule consists of two parts: the selector and the declaration (or in most cases, a block of 
declarations). The selector is a term (such as p, h1, a class name, or an id) that identifies the formatted element. The 
declaration block defines the style properties. In the following example, h1 (a heading tag) is the selector, and 
everything that falls between the braces ({and }) is the declaration block (defining the properties of the h1 heading):


h1 { 


font-family: Georgia, "Times New Roman", Times, serif;


font-size: 18px;


text-transform: uppercase;


color: #090; 


}


An individual declaration consists of two parts: the property (such as font family) and value (such as Georgia). In the 
previous CSS rule, a particular style has been created for h1 tags; the text for all h1 tags linked to this style will be 18 
pixels in size, Georgia font, uppercase, and bright green (hex value #090). 


The style (which comes from a rule, or a collection of rules) resides in a place separate from the actual text it’s 
formatting—usually in an external style sheet or in the head section of an HTML document. Thus, one rule for h1 
tags can apply to many tags at once (and in the case of external style sheets, the rule can apply to many tags at once on 
many different pages) (Figure 1). In this way, CSS provides extremely easy update capability. When you update a 
CSS rule in one place, the formatting of all the elements that use the defined style is automatically updated to the new 
style.


Figure 1 Updating a CSS rule in one place updates all elements
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There are three main types of CSS:


Class style: Similar to the styles you use in word processing and page layout programs. For example, you may 
want to format all body text in 10-point, Arial, dark green type. You can create a class style with these attributes 
and then apply this style to all body text in your website. Class names must begin with a period and can contain 
any combination of letters and numbers (for example, .myhead1). 


HTML tag style: Applies global formatting to individual HTML tags rather than to individual selections. 
Suppose you want to modify the Heading 1 paragraph style to appear always in purple text. Instead of creating a 
class style and applying it to every heading in the document, you can create an HTML tag style with these 
attributes and apply it to the Heading 1 <h1> tag. In effect, you are redefining the HTML tag.


ID style: A unique identifier (ID) for a style applied to headers, banners, menus, and other elements present in 
only one location in the document. Used once within a document or page. IDs must begin with a pound (#) sign 
and can contain any combination of letters and numbers (for example, #myID1). 


CSS rules can reside in the following locations:


Internal (or embedded) CSS style sheets are collections of CSS rules included in a style tag in the head section of 
an HTML document.


External CSS style sheets are collections of CSS rules stored in a separate, external CSS (.css) file (not an HTML 
file). You link this file to one or more pages in a website with a link or an @import rule in the head section of a 
document. 


Creating a new CSS rule from the Properties panel
In the CSS Properties panel, you can access Targeted Rules and create new ones (Figure 2). A Targeted Rule is a rule 
you are editing in the CSS Properties panel. When you have an existing style applied to text, the rule affecting the 
text’s format appears when you click inside the text on the page. You can also use the Targeted Rule pop-up menu to 
create new CSS rules and new in-line styles or apply existing classes to selected text. 


Figure 2 Properties panel, CSS mode


How you edit your CSS depends on selection level. To access rules that apply to a current selection only, you can use 
the Targeted Rule pop-up menu in the CSS Properties panel. To access all CSS rules for a page, you can use the CSS 
Styles panel. The CSS Styles panel will be reviewed in the next guide.


In this section, you use the Properties panel to create a simple CSS class-style rule to format a block of text.
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To create a new CSS rule in the Properties panel:


1. Start Dreamweaver.


2. Select File > New to create a new document.


The New Document dialog box appears (Figure 3).


3. In the Blank Page category of the New Document dialog 
box, select HTML Page Type to create a plain HTML 
page.


4. In the Layout column, select None. 


5. Click the Create button.


The new HTML page opens.


6. In the Document toolbar, click the Show Code And 
Design Views (Split) button (Figure 4).


Being able to view the code that Dreamweaver generates 
for creating styles will be useful to help you understand 
and write your own CSS syntax later on.


7. Type some text or paste text copied in another application 
in the Design view Document window. 


8. Press Enter (Windows) or Return (Mac OS) to create a 
new paragraph and add additional text.


9. Open the Properties panel (Window > Properties), if it 
isn’t already open, and click the CSS button to display 
the CSS Properties panel (Figure 2).


10. Use the Font menu to change the Font to Georgia, Times 
New Roman, Times, Serif (Figure 5).


The New CSS Rule dialog box appears (Figure 6).


Note: It is a good practice to assign a font combination 
instead of a single font. This ensures that most page 
visitors will view page text the same way. A browser uses 
the first font in the combination that is installed in the 
visitor’s system. If none of the fonts in the combination is 
installed, the browser displays the text as specified by the 
visitor’s browser preferences. 


Figure 3 New Document dialog box


Figure 4 Document window view options


Figure 5 Properties panel Font menu


Figure 6 New CSS Rule dialog box


Show Code And Design Views button
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11. In the Selector Type menu, select Class (Can Apply To 
Any HTML Element) (Figure 7).


12. Click in the Selector Name text box and type .myStyle 
(Figure 8).


Note: CSS rules must begin with a period and cannot 
contain spaces or special characters.


13. In the Rule Definition menu, select (This Document 
Only) (Figure 9).


This tells Dreamweaver to create and store the CSS (style 
sheet) in the current document only. The new style will 
not be available for use in other documents.


To create an external CSS document for your entire 
website, you would choose (New Style Sheet File). This 
is discussed in a later guide.


14. Click OK to close the New CSS Rule dialog box.


The new font is applied to the paragraph that contains the 
insertion point. The name of the style appears in the 
Targeted Rule box in the Properties panel (Figure 10).


Note: Because you didn’t select a specific word or 
character, you can continue to define this rule by 
applying additional formatting.


15. In the Properties panel, change the size to 18.


The font size in the paragraph that contains the insertion 
point changes accordingly.


Figure 7 New CSS Rule dialog box, Selector Type 
options


Figure 8 New CSS Rule dialog box, Selector 
Name options


Figure 9  New CSS Rule dialog box, Rule 
Definition options


Figure 10 Targeted Rule in the Properties panel
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16. Click the Color box in the Properties panel and select a 
new color for the text.


The Properties panel shows the targeted rule (.myStyle) 
and its formatting. The targeted rule is applied to the 
paragraph that contains the insertion point (Figure 11).


You can use this CSS rule to format additional text in 
your document.


Observe in Code view that Dreamweaver stores styles 
created with CSS directly in the head section of the 
document (Figure 12).


Figure 11 Formatted paragraph text


Figure 12 Detail of new CSS rule, Code view
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Applying CSS styles
After you create a CSS rule, you can use it to give your entire document or website a consistent appearance. You can 
apply a CSS rule to text by using the Properties panel.


To apply a CSS style:


1. Click anywhere in the paragraph that doesn’t have the 
new CSS style.


2. In the Properties panel, select myStyle (the new CSS rule 
you just created) from the Targeted Rule menu 
(Figure 13).


The new style is applied to the other paragraph 
(Figure 14).


Note: If you edit the CSS style, both paragraphs will be 
updated automatically and consistently. You will learn 
more about creating and modifying CSS in a later guide.


Figure 13 Targeted Rule menu


Figure 14 CSS style applied to both paragraphs


Using the CSS Styles panel
In the CSS Styles panel you can track the CSS rules and properties affecting a currently selected page element 
(Current mode) or all of the rules and properties available to the document (All mode). A button at the top of the 
panel enables you to switch between the two modes. You can also use the CSS Styles panel to modify CSS properties 
in both All and Current modes. 
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The CSS Styles panel in Current mode


In Current mode, the CSS Styles panel displays three panes: a Summary For Selection pane that displays the CSS 
properties for the current selection in the document, a Rules pane that displays the location of selected properties (or 
a cascade of rules for the selected tag, depending on your selection), and a Properties pane where you can edit CSS 
properties for the rule applied to the selection (Figure 15).


Figure 15 CSS Styles panel, Current mode


The CSS Styles panel in All mode


In All mode, the CSS Styles panel displays two panes: an All Rules pane, and a Properties pane. The All Rules pane 
displays a list of rules defined in the current document as well as all rules defined in style sheets attached to the 
current document. You can use the Properties pane to edit CSS properties for any rule selected in the All Rules pane 
(Figure 16).


Figure 16 CSS Styles panel, All mode


New CSS Rule Edit RuleAttach Style Sheet
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To add a CSS rule by using the CSS Styles panel:


1. Start Dreamweaver.


2. Create a new HTML document.


3. Save and name the Dreamweaver document.


4. Type some text in the document. Make sure no 
formatting is applied to the text (Figure 17).


5. Make sure the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


6. To create a new style, click the New CSS Rule button (+) 
at the bottom of the panel (Figure 15).


The New CSS Rule dialog box appears (Figure 18).


7. In the Selector Type pop-up menu, select Class. 


This option creates a new Class rule.


8. In the Selector Name text box, type a name for the style 
such as .warning.


Note: Class rule names must begin with a period and 
cannot contain spaces or special characters. If you forget 
to type the period, Dreamweaver adds this automatically.


9. In the Rule Definition pop-up menu, select (This 
Document Only) or (New Style Sheet File). 


The option (This Document Only) defines the style as 
part of the document’s internal style sheet. The option 
(New Style Sheet File) defines the style as part of an 
external style sheet.


Note: If you choose to create an external style sheet by 
selecting (New Style Sheet File), you are prompted to 
select a location for the new style sheet (.css) document.


10. Click OK.


The CSS Rule Definition dialog box appears (Figure 19).


11. Select options for Type, such as the following: 


• Select Arial, Helvetica, Sans-serif in the Font-
Family pop-up menu


• Select 12 from the Font-Size pop-up menu, and 
select px (pixels) for the measurement unit.


• Type #CC0033 in the Color text box, or select a 
color in the color picker.


Figure 17 Text with no formatting applied


Figure 18 New CSS Rule dialog box


Figure 19 CSS Rule Definition dialog box, Type 
options 
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12. To change the formatting of text blocks, select Block in 
the Category pane.


The Block category of the CSS Rule Definition dialog 
box opens (Figure 20).


13. In the Letter-Spacing text box, you can make changes 
such as typing 3 and selecting pixels for the measurement 
unit.


This setting adds space between letters. 


14. In the Text-Indent box, you can make changes such as 
typing 5 and selecting pixels for the measurement unit.


15. Click OK.


The CSS Rule Definition dialog box closes.


16. Select the document text.


17. Make sure the Properties panel is open and the HTML 
option is selected.


The Properties panel is docked at the bottom of the 
screen. If it is not open, select Window > Properties.


18. Select warning, or the name of your style, from the Class 
pop-up menu (Figure 21).


19. In the document, deselect the text by positioning the 
mouse pointer next to it and clicking once.


Observe that the format of the text has changed 
(Figure 22).


20. Make sure the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


21. Make sure All is selected in the CSS Styles panel. If no 
styles are listed under <style> in the All Rules pane, click 
the plus (+) symbol (Windows) or the disclosure triangle 
(Mac OS).


Observe that the newly created CSS rule now appears 
under <style> in the All Rules pane, indicating the new 
rule is part of a CSS style sheet. Also observe that if you 
select the style name in the All Rules pane, properties for 
the style appear in the Properties pane.


Figure 20 CSS Rule Definition dialog box, Block 
options 


Figure 21 Text Properties panel


Figure 22 Formatting applied to text
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Edit styles


After you create styles, you can still make changes to them by using the Edit Rule button.


To edit styles:


1. To view a style sheet’s rules, click the plus symbol 
(Windows) or disclosure triangle (Mac OS) beside 
<style> in the All Rules pane of the CSS Styles panel.


Dreamweaver displays the style sheet’s rules 
(Figure 23). 


2. Select the rule or style you want to edit.


3. At the bottom of the CSS Styles panel, click the Edit Rule 
button.


The CSS Rule Definition dialog box for the selected style 
appears (Figure 24).


4. Make formatting changes in the CSS Rule Definition 
dialog box. Then click OK.


The changes take effect immediately. 


If you are editing an external style sheet, the same 
changes are applied to any other documents attached to 
this style sheet.


Figure 23 CSS Styles panel


Figure 24 CSS Rule Definition dialog box


Edit Rule 
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How to design for usability
Good web usability is defined as: easy to use, quick to learn, and providing an overall satisyfying experience. A well-
designed, usable site aims to enhance the user experience by elevating a website’s percieved efficiency, elegance, and 
clarity.


Usability is a combination of factors including design, information architecture, accessibility, and support across 
various devices. Usability.gov (usability.gov/basics/index.html) provides a list of these important factors:


• Ease of learning How fast can a user who has never seen the user interface before learn it sufficiently well to 
accomplish basic tasks?


• Efficiency of use Once an experienced user has learned to use the system, how fast can he or she accomplish 
tasks?


• Memorability If a user has used the system before, can he or she remember enough to use it effectively the 
next time or does the user have to start over again learning everything?


• Error frequency and severity How often do users make errors while using the system, how serious are these 
errors, and how do users recover from these errors?


• Subjective satisfaction How much does the user like using the system?


Compare the two Coast Middle School examples shown in Figure 1. The before and after screenshots demonstrate 
the difference between poor web usability, and a subsequent site redesign that results in much-improved user 
experience.


Figure 1 Examples poor web usability (left) and improved web usability (right)


Consider the following as you plan the content and navigation of your website project.


Content
How you organize content on a page highlights important features and elements of your site. Important elements 
might be higher in the page, larger in size, or in stronger colors. Include rough descriptions of navigation, copy 
layout, graphic allocation, key headers, and other elements that appear on a screen. Identifying common structures 
between pages helps visitors understand they are in the same site as they navigate from page to page.


• Will your page banner be on each page? If yes, is it in the same place? Is it the same size?


• What font will you use for titles or headings on your content pages?


• What color will you use for titles or headings on your content pages?
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• What font will you use for descriptions on your content pages?


• What color will you use for descriptions?


Navigation
For visitors of your website to understand the content, you must provide clear navigation. Visitors need to know 
where they are in a site, where they need to go, and how to get back to where they came from. Having a consistent 
layout grid helps orient visitors and keeps them from feeling lost. Using consistent buttons, links, and graphics on 
each page maintains a sense of place. As visitors move from page to page, provide familiar visual cues and 
navigational aids.


• Where will you place the navigation bar on the page?


• What content will be on the navigation bar?


• Will the navigation bar be on every page?


• How will your navigation bar help visitors know which page they are on?


Resources
Get more information about web usability best practices from these resources:


• usability.gov is the primary government source for information on usability and user-centered design.


• www.useit.com website for leading web usability consultant, Jakob Nielsen.
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Overview of Adobe Fireworks CS6 workspace
In this guide, you’ll learn how to do the following:


• Work with the Adobe Fireworks CS6 workspace: tools, Document windows, menus, and panels.


• Customize the workspace.


• Change the magnification of a document.


• Navigate through a document by using tools and panels.


Exploring the workspace
When you start Adobe Fireworks for the first time and open a document, the workspace includes the Application bar, 
Tools panel, Properties panel, menus, and other panels (Figure 1). The Document window appears in the center of the 
workspace. The Tools panel, on the left side of the workspace, contains labeled categories, including Bitmap, Vector, 
and Web tool groups. The Properties panel appears below the Document window and initially displays document 
properties. It updates as you work on a document. When you select a tool, the Properties panel displays properties and 
options for that tool; when you select an object in the document, it displays properties and options for that object. 
Other panels are initially docked in groups along the right side of the workspace.


Figure 1 Adobe Fireworks CS6 workspace


You create and manipulate documents and files in Fireworks by using various elements of the workspace, such as 
panels, bars, and windows. Any arrangement of these elements is called a workspace. The workspaces of applications 
in the Adobe Creative Suite 6 family share the same appearance so you can move between the applications easily. 
You can also adapt each application to the way you work by selecting from a variety of preset workspaces or by 
creating arrangements of your own.


• Application bar across the top contains a workspace switcher, menus (Windows only), and other application 
controls. On the Mac for certain products, you can show or hide it by selecting Window > Application Bar.


Application 
bar


Document 
window


Tools panel


Properties 
panel


Workspace 
switcher


Panels
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• Document window displays the file you’re working on. Document windows can be tabbed and, in certain 
cases, grouped and docked.


• Tools panel contains tools for creating and editing images, artwork, page elements, and so on. Related tools 
are grouped.


• Properties panel displays options and properties of the currently selected element.


• Panels help you monitor and modify your work. Examples include the Layers, Align, and Document Library 
panels. Panels can be grouped, stacked, or docked.


Customizing the workspace
You can create a custom workspace by moving and manipulating Document windows and panels. You can also save 
workspaces and switch among them. 


To create a custom workspace:


1. Move and manipulate the workspace layout in Fireworks 
to suit your needs (Figure 2).


2. From the workspace switcher, select Save Current 
(Figure 3).


The New Workspace dialog box appears (Figure 4).


3. Type a name for the workspace.


4. Click OK to close the New Workspace dialog box.


Figure 2 Custom workspace layout


Figure 3 Workspace switcher


Figure 4 New Workspace dialog box
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5. Click the Workspace switcher.


Notice that your new workspace appears in the 
Workspace Layouts menu.


Even if you make changes, you can return to the 
workspace you saved by selecting it from the menu or 
from the workspace switcher (Figure 5).


Figure 5 Selecting a saved workspace from the 
workspace switcher


Opening a file in Fireworks
In general, you open document and image files the same way you do in other programs. New documents in Fireworks 
are saved as Portable Network Graphic (PNG) documents. PNG is the native file format for Fireworks.


Graphics created in Fireworks can be exported to or saved in several web and graphic formats. Regardless of the 
optimization and export settings you select, the original Fireworks PNG file is preserved to allow easy editing later. 


To create a new document:


1. Select File > New. 


The New Document dialog box appears (Figure 6).


2. Change any of the preset values as desired:


• Modify the document size.


• Change the document resolution.


• Set a canvas color:


White sets the canvas background to white.


Transparent creates an invisible background. 


Custom use the color picker to set a custom 
background color.


3. Click OK. 


Figure 6 New Document dialog box
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Tools panel overview
The Tools panel is organized into six categories: Select, Bitmap, Vector, Web, Colors, and View (Figure 7). When 
you select a tool, the Properties panel displays options and settings for that tool. You can undock the Tools panel to fit 
your preferred window and panel layout.


Click a tool in the Tools panel to select it. The Tools panel also contains several hidden tools related to the visible 
tools. Hidden tools are indicated by a triangle to the right of a tool icon. Click the tool icon and hold down the mouse 
button to reveal a menu of the hidden tools.


The name of the tool and its keyboard shortcut appear when you hover the pointer over the tool—this text is called a 
tooltip. 


Figure 7 Tools panel
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How to use the Zoom tool to navigate your document
You can use the Zoom tool to change the magnification level in your document.


To change the magnification of your document:


1. Open a document and examine the zoom level at the 
bottom of the Document window (Figure 8).


This represents the current enlargement view of the 
image, or zoom level.


2. Select the Zoom tool by clicking the Zoom tool icon in 
the Tools panel (Figure 9) or by pressing Z, the keyboard 
shortcut for the Zoom tool.


3. Click anywhere in the Document window.


The image zooms in according to a preset percentage 
level. The location you clicked is the center of the 
enlarged view.


4. Using the Zoom tool, drag a rectangle to enclose a region 
of the document (Figure 10).


The selection enlarges to fill the entire Document 
window.


5. To zoom out, hold down the Alt key (Windows) or the 
Option key (Mac OS) as you click (Figure 11).


Figure 8 Zoom level


Figure 9 Tools panel


Figure 10 Selecting a rectangular region


Figure 11 Zooming out in a document


Zoom tool
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How to move around a document with the Hand tool
The Hand tool moves a document within the Document window. This is useful if you want to see a part of the 
document that is currently out of view.


To use the Hand tool:


1. Zoom into an area of your document until some of the 
content is out of view (Figure 12).


Scroll bars appear when part of the document is not 
visible in the Document window.


2. Select the Hand tool from the Tools panel (Figure 13). 


3. Using the Hand tool, drag to move around and view 
different parts of the document (Figure 14).


Figure 12 Document window with scroll bars


Figure 13 Tools panel


Figure 14 Using the Hand tool to move a 
document around


Hand tool
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Using the Properties panel
The Properties panel is context-sensitive. It displays properties and options of the object, the tool, or the document 
that is currently selected. By default, the Properties panel is docked at the bottom of the workspace.


The Properties panel can be open at half height, displaying two rows of properties, or at full height, displaying four 
rows. You can also fully collapse the Properties panel while leaving it in the workspace. Either double-click the panel 
tab or click the arrow in the upper-left corner of the panel to cycle through these three states.


To use the Selection tool and Properties panel:


1. With a document open, choose the Selection tool from 
the Tools panel and then select an object in your 
document.


Notice that the Properties panel information includes 
such things as the image type, size, and position of that 
object (Figure 15).


2. Next, choose the Type tool (and select a region of text, if 
available).


The Properties panel changes to show options that 
provide control over text formatting (Figure 16).


Figure 15 Properties panel, bitmap mode


Figure 16 Properties panel, text mode


Working with layers
Layers divide a Fireworks document into discrete planes, as though the components of the illustration were drawn on 
separate tracing paper overlays. Each object in a document resides on a layer (Figure 17). You can either create 
layers before you draw or add layers as needed. The canvas is below all layers and is not itself a layer.


Figure 17 Model of layers in Fireworks
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The Layers panel displays the current state of all layers in the page of a document (Figure 18). The  active layer is 
highlighted. The stacking order is the order in which objects appear in the document and determines how objects on 
one layer overlap objects on another. Fireworks places the most recently created layer on the top of the stack. You can 
rearrange the order of layers and of objects within layers, and you can create sub layers and move objects onto them.


Masks and opacity and blend mode controls are also shown in the Layers panel. 


Figure 18 Layers panel


Expand/Collapse Layer


Active Layer


Lock/Unlock Layer


Show/Hide Layer


New/Duplicate Layer New Sub Layer New Bitmap Image


Delete Layer
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Course overview and setup 
Digital Design: Foundations of Web Design is a two-semester, project-based curriculum that teaches 
digital communication skills in the context of the professional web design and development process, 
using Adobe web tools. Digital Design develops four key skill areas: 


• Project management and collaboration 


• Design 


• Research and communication 


• Professional web-authoring tools 


Students develop these key skills in a spiral—each project adds more challenging skills onto the 
foundation proficiencies. 


Digital Design addresses each of these areas, using a project-based approach. Each project has phases that 
follow a design and development process, from project planning to evaluation and launch. To simulate a 
professional work environment, students gradually migrate their design work from an individual process 
to a group process. Design and technical work by its very nature is iterative, so the projects contain 
activities that require students to evaluate and then redesign and rework their communications. Specific 
attention has been paid to developing concepts and principles for thorough, effective design.  


The following diagram shows the sequence and flow of the projects: 
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First semester projects 


The first semester of Digital Design (Projects 1–4) develops skills that lay the foundation for producing 
web-ready communications: design principles, design documents, storyboards, web development, shared 
project management skills such as interviewing and project scheduling, peer review, and redesign. Project 
activities focus on developing effective communications that can be deployed on the web. Students 
develop a widget, a variety of graphic images, a client website, and a web portfolio. A great deal of 
flexibility is implied in the curriculum. 


The key skills emphasized in this semester are: 


• “Soft” skills such as interviewing and responding to feedback 


• Designing a website for clients 


• Problem solving that helps support multiple perspectives 


• Reflection about the design process and effective communication 


• Peer teaching and evaluation in a collaborative environment 


• Technical web publishing 


In the first semester, students use Adobe Photoshop CS6 and Adobe Fireworks CS6 to develop static and 
interactive graphics. They use Adobe Dreamweaver CS6 to design and build websites. This content 
prepares students for the Adobe Certified Associate, Web Communication using Adobe Dreamweaver 
CS6 examination. 


Second semester projects 
The second semester of Digital Design (Projects 5–8) builds on student design and development skills by 
focusing on rich media development. Students continue to work individually or on teams and produce 
rich media communications such as interactive games, digital narratives and mobile applications. They 
focus on effective rich media design, multimedia storyboarding, design specifications, and iterative 
development with clients. They produce design documents and visual comps that clients review. They 
develop rich media designs that solve specific communication challenges. They build technical skills to 
address client needs. 


The key skills emphasized in this semester are: 


• “Soft” skills such as interviewing and responding to feedback 


• Communication with clients, using design documents or specifications 


• Design and redesign according to client specifications 


• Technical multimedia skills such as film effects and transitions 


• Design solutions, including effective navigation systems and digital narratives 


In the second semester, students learn Adobe Flash Professional CS6 to apply design solutions requiring 
rich media and interactivity. This content prepares students for the Adobe Certified Associate, Rich 
Media Communication using Adobe Flash Professional CS6 examination. 
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Alternate methods for utilizing Digital Design 
If your circumstances do not allow you to use Digital Design as a yearlong curriculum, there are other 
ways to structure the content to fit certain time, skill, and course structure limitations. 


Product-based instruction 


You can use a product-based approach that focuses primarily on teaching how to use Adobe Fireworks 
CS6, Adobe Dreamweaver CS6, or Adobe Flash CS6. The technical guides included in the Digital Design 
projects are alternatively packaged by individual product. For example, download the PDF Portfolio of all 
the Dreamweaver CS6 guides if you solely plan to teach Dreamweaver skills to your students. 


You are encouraged to be creative with a product-based approach while attempting to incorporate an 
activity-based teaching method. In that vein, you can still use all or pieces of the individual projects to 
teach specific products. The table below details the specific steps in each project that align to each 
product. 
 


 Dreamweaver Fireworks Flash 


Project 1: Widgets Steps 10-36 Steps 17-26  


Project 2: Web design and planning Steps 5-8 Steps 25-40  


Project 3: Web development and 
deployment 


Steps 3-14, 21-37, 
47-50 


Steps 16-22  


Project 4: Web portfolio Steps 14-21 Steps 11-13  


Project 5: Interactive game   Steps 4-6, 12-30 


Project 6: Digital narratives  Step 18 Steps 6-8, 14-34 


Project 7: Mobile application  Step 9 Steps 10-20 


Project 8: Final web portfolio    


Individual projects 


Depending on the skill level of students, you can utilize individual projects from the Digital Design 
curriculum, without completing the other projects in the curriculum sequence. For example, an educator 
teaching a gaming course might only wish to teach the interactive game project. Additionally, you can 
adapt the instruction and utilize technical guides from previous projects to teach an individual project. 


Be creative! 


You are encouraged to utilize the Digital Design curriculum as a jumping off point to developing your 
own projects and curriculum that is customized for your classroom. By utilizing the existing product 
technical guides, you can formulate complete instructional projects based on particular areas of interest. If 
you do create your own projects or curriculum, please share them with the community on the Adobe 
Education Exchange (http://edexchange.adobe.com) where you can also browse for additional resources 
that are useful for teaching with the Adobe Creative Suite 6.  
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Digital Design skills matrix 
 


 Project 
management Design Research and 


communication Technical 


Project 1: Widgets 
Focus: 
• Understand how CSS 


is used to create 
consistency 


• Principles of good 
design 


• Wireframe a web page 
• Customize a widget 
• Evaluating and 


comparing websites 
Time: 8-12 hours 
(2–3 weeks) 


• Designing for a 
specific audience 
and purpose 


• Understanding 
the phases of 
web 
development 


• Designing for 
their audience(s) 


• Applying design 
principles 


• Creating 
wireframes 


• Creating design 
comps 


• Learning basic 
HTML and 
HTML5 


• Understanding 
CSS 


• Applying design 
aspects such as 
color, design, 
layout, contrast, 
and composition 


• Integrating 
images and text 


• Planning 
graphics based 
on needs and 
audience 


• Understanding 
the role and 
purpose of 
widgets 


• Analyzing and 
critiquing 
widgets and 
websites 


• Evaluating and 
analyzing content 
validity 


• Evaluating and 
analyzing 
website 
navigation 


• Understanding 
copyright issues 
and fair-use 
guidelines 


• Advocating and 
practicing legal 
use of images 


• Collecting and 
analyzing 
audience needs 
and purpose to 
inform design 


• Participating in 
peer review 


• Communicating 
and presenting 
design decisions 


• Giving feedback 
on a project 


 


Fireworks 
• Understanding the 


Fireworks 
workspace 


• Creating a 
wireframe 


• Creating design 
comps 


• Preparing images 
Photoshop 
• Understanding the 


Photoshop 
workspace 


• Resizing, rotating, 
and cropping 
images 


• Correcting color 
• Retouching 


images 
• Generating 


multiple file 
formats 


Dreamweaver 
• Understanding the 


Dreamweaver 
workspace 


• Setting up a web 
project 


• Using the Insert 
panel 


• Inserting images 
• Inserting text 
• Using the Widget 


Browser 
• Inserting a widget 


into an HTML 
web page 


• Editing and 
customizing CSS 
rules 


• Using the CSS 
Styles panel 


• Publishing web 
files 
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 Project 
management Design Research and 


communication Technical 


Project 2: Web design 
& planning 
Focus: 
• Professional web 


design process 
• Designing for a client 
• Design-team process 


for website 
development 


• Team-client interaction 
and communication 


Time: 12–18 hours 
(3–4 weeks) 


• Developing a 
project plan 


• Developing a 
design solution 
document 


• Analyzing to 
select best 
examples 


• Synthesizing 
content based on 
analysis and 
reflection 


• Managing and 
organizing 
multiple tasks 
involved in 
design versus 
production 


• Understanding 
roles and 
responsibilities 


• Meeting 
deliverables 


• Communicating 
ideas and 
information 
through simple 
wireframes 


• Providing 
multiple design 
ideas 


• Synthesizing 
information from 
design review 
meetings 


• Creating 
wireframes 


• Creating design 
comps 


• Creating 
storyboards 


• Creating 
prototypes 


• Applying design 
principles 


• Applying 
information 
architecture 


• Designing for 
usability and 
accessibility 


• Designing 
consistent 
website pages 


• Understanding 
and applying 
design aspects 
such as color 
theory, layout, 
contrast, and 
composition 


• Designing for 
usability and 
accessibility  


• Designing for a 
specific audience 
and purpose 


• Planning 
graphics and rich 
media content 
based on needs 
and audience 


• Designing for a 
client while 
meeting client 
requirements 


• Evaluating and 
analyzing content 
validity 


• Editing website 
content 


• Evaluating and 
analyzing 
website 
navigation 


• Understanding 
and practicing 
legal use of 
images 


• Understanding 
tools for creating 
animation and 
interactive 
content 


• Critiquing 
designs 


• Communicating 
purpose and goal 


• Communicating 
and presenting 
design decisions 


• Giving feedback 
on a project 


• Asking questions 
to focus and 
clarify 


• Listening and 
interpreting 
feedback 


• Understanding 
and addressing 
client design 
issues 


Dreamweaver 
• Understanding 


accessibility 
Fireworks 
• Understanding the 


Fireworks 
workspace 


• Creating a 
wireframe 


• Creating design 
comps 


• Creating a 
prototype  


• Exporting a 
prototype to 
Dreamweaver 
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 Project 
management Design Research and 


communication Technical 


Project 3: Website 
development & 
deployment 
Focus: 
• Effective team 


collaboration 
• Designing for a client 
• Develop reusable 


content 
• Use web standards 
• Review and redesign 


process 
• Accessible web content 
Time: 20–35 hours 
(5–7 weeks) 


• Following and 
executing a 
project plan 


• Following and 
executing a 
wireframe and 
prototype 


• Following up and 
following 
through on roles 
and 
responsibilities 


• Defining and 
prioritizing tasks 


• Producing 
deliverables and 
meeting 
deadlines  


• Managing files 
and using file-
naming 
conventions 


• Executing a 
review and 
redesign cycle 


• Executing 
quality assurance 
tests 


• Providing 
consistency and 
accessibility 


• Providing 
universal 
navigation 


• Integrating 
images, text, and 
multimedia 


• Planning 
graphics and 
multimedia based 
on needs and 
audience 


• Creating web 
pages using web 
standards 


• Designing with 
CSS 


• Organizing pages 
with CSS 


• Understanding 
HTML 


• Using basic 
HTML 


• Creating 
templates and 
reusable designs 


• Adapting content 
for readability 
and emphasis 


• Designing for 
multiple screens 


• Considering 
screen size and 
device 
requirements 


• Incorporating 
layout and color 
consistently 


• Designing a 
quality assurance 
test 


• Communicating 
ideas clearly 


• Presenting a 
website to a 
group 


• Taking notes on 
critique 


• Providing 
meaningful but 
not overly 
critical feedback 


• Listening and 
interpreting 
information and 
feedback 


• Demonstrating 
the realization of 
redesign goals 


• Conducting 
usability analysis 


• Creating quality 
assurance tests 


Dreamweaver 
• Understanding the 


Dreamweaver 
workspace 


• Setting up a web 
project 


• Setting document 
properties 


• Using the Insert, 
Files, and Assets 
panel 


• Inserting images 
• Inserting text 
• Creating lists 
• Creating data 


tables 
• Creating image 


maps 
• Using CSS starter 


layouts 
• Using CSS text 


styles 
• Creating, 


modifying, and 
troubleshooting 
CSS 


• Creating 
templates 


• Developing a 
website for 
multiple screens 


• Checking files in 
and out 


• Inserting HTML5 
video 


• Checking links 
• Testing in Adobe 


BrowserLab 
• Publishing web 


files 
Fireworks 
• Optimizing 


images 
• Creating buttons 
• Creating 


navigation bars 
• Creating pop-up 


menus 
• Resizing and 


cropping images 
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 Project 
management Design Research and 


communication Technical 


Project 4: Web 
portfolio 
Focus: 
• Electronic portfolio 


design 
• Plan, implement, and 


test website designs 
• Content development 
• Consistency in website 


design 
• Peer critique and 


presentation 
Time: 5–10 hours 
(1 – 2 weeks) 


• Planning and 
creating a web 
portfolio 


• Organizing and 
managing 
content 


• Creating 
flowcharts 


• Designing 
consistent pages 


• Designing for a 
specific audience 
and purpose 


• Providing 
consistency and 
accessibility 


• Providing 
universal 
navigation 


• Adapting content 
for readability 
and emphasis 


• Investigating and 
researching 
career areas 
within web 
design and 
development 


• Communicating 
information to 
particular 
audiences 


• Defining the 
goals and uses of 
a portfolio 


• Soliciting and 
providing 
feedback 


• Writing and 
editing website 
content 


Fireworks 
• Optimizing 


images 
• Creating buttons 
• Creating 


navigation bars 
• Creating pop-up 


menus 
• Exporting to 


Dreamweaver 
Photoshop 
• Resizing and 


rotating images 
Dreamweaver 
• Setting document 


properties 
• Using the Assets 


panel 
• Using CSS starter 


layouts 
• Using CSS text 


styles 
• Creating, 


modifying, and 
troubleshooting 
Cascading Style 
Sheets 


• Creating 
templates 


• Creating forms 
• Publishing web 


files 
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 Project 
management Design Research and 


communication Technical 


Project 5: Interactive 
game 
Focus: 
• Animation and rich 


media for interaction 
• Building Flash skills 
• Enhancing user 


experience 
• Evaluating rich media 
Time: 23–30 hours 
(5–6 weeks) 


• Evaluating user 
experience on the 
web for different 
techniques used 
in rich media 


• Determining 
game purpose, 
audience, and 
goal 


• Determining 
available 
resources and 
skill level for 
game 
development 


• Writing a 
proposal for the 
game, with 
attention to 
scenarios and 
audience 
characterization 


• Designing a 
custom 
experience 


• Making screen 
sketches for 
interactive 
experiences 


 


• Researching, 
evaluating and 
analyzing the use 
of Flash in online 
gaming 


• Evaluating and 
analyzing various 
game types 


• Researching 
audience and 
overall gaming 
landscape 


• Researching 
currently 
available games 


• Researching 
appropriate uses 
of multimedia in 
gaming 


• Assessing team’s 
technological 
developer skill 
level  


• Connecting goals 
of the game with 
user interaction 
and experience 


• Communicating 
and presenting 
design decisions 


• Critiquing 
designs 


• Communicating 
purpose and 
goals 


• Writing scripts 
for a game 
narrative 


Flash  
•  Understanding 


the Flash 
workspace 


• Using drawing 
tools  


• Working with 
layers 


• Organizing layers 
and libraries 


• Using animation 
methods 


• Creating 
interactive buttons 


• Working with 
bitmaps 


• Using basic 
ActionScript 


• Using animation 
methods 


• Creating and 
modifying text 


• Creating Timeline 
effects 


• Creating 
transparent 
buttons 


• Saving and using 
motion presets 


• Publishing Flash 
documents 
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 Project 
management Design Research and 


communication Technical 


Project 6: Digital 
narratives 
Focus: 
• Animation and rich 


media for 
communication 


• Deeper look at 
audience and audience 
needs 


• Enhance visitor’s 
experience by using 
narratives 


• Accessible rich media 
content 


Time: 20–28 hours 
(4–5 weeks) 


• Defining 
purpose, goal, 
and audience 


• Assigning team 
roles and tasks 


• Defining and 
prioritizing tasks 


• Following a 
project plan  


• Understanding 
roles and 
assigning roles 
and tasks 


• Determining 
functional 
requirements of 
application 


• Designing for a 
client 


• Following up and 
following 
through on roles 


• Designing a 
custom 
experience 


• Designing for 
audience(s) 


• Providing 
multiple design 
ideas 


• Applying 
principles of 
graphic design 


• Developing 
thorough and 
accurate 
storyboards 


• Designing for 
accessibility 


• Creating designs 
that meet client 
requirements 


• Synthesizing and 
displaying 
complex 
information 


• Making sketches 
for interactive 
experiences 


• Researching 
examples of rich 
media 


• Understanding 
the role and 
purpose of digital 
narratives 


• Analyzing 
effective use of 
digital narratives 


• Creating a 
project plan 


• Writing scripts 
for a digital 
narrative 


• Conducting a 
review and 
redesign cycle 


• Communicating 
with peers  


• Researching 
audience and 
appropriate sites 


• Using Flash 
effectively 


• Connecting goals 
with user 
interaction 


Flash 
• Importing and 


compressing 
audio 


• Optimizing file 
size 


• Producing Flash 
video 


• Working with text 
and text effects 


• Using drawing 
tools 


• Organizing layers 
and libraries 


• Working with 
layers 


• Optimizing file 
size 


• Working with 
bitmaps 


• Publishing and 
testing movies 


• Using animation 
methods 


• Creating 
accessible Flash 
content 


• Saving and using 
motion presets 


Fireworks 
• Creating a 


wireframe 
• Creating design 


comps 
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 Project 
management Design Research and 


communication Technical 


Project 7: Mobile 
application 
Focus: 
• Usability and 


consistency 
• Mobile application 


development 
• Individual and peer 


review 
Time: 15–21 hours 
(3–4 weeks) 


• Defining 
purpose, goal, 
and users 


• Synthesizing and 
recommending 
changes during 
design process 


• Connecting 
content and style 
to user needs 


• Making 
wireframes 


• Making design 
comps 


• Consideration of 
screen sizes 


• Designing for 
multiple devices 
and outputs 


• Designing for 
usability 


• Researching 
existing 
application 
marketplaces 


• Analyzing 
similar 
applications 


• Creating user 
scenarios 


• Selecting what 
information is 
important 


• Conducting peer 
review 


• Critiquing 
designs 


• Providing 
meaningful but 
not overly 
critical feedback 


• Connecting goals 
of the application 
with user 
interaction and 
experience 


• Writing and 
editing content 
for application 


• Conducting 
usability analysis 


Flash 
• Optimizing file 


size 
• Creating and 


modifying text 
• Working with text 


and text effects 
• Creating 


interactive buttons 
• Using drawing 


tools 
• Organizing layers 


and libraries 
• Working with 


layers 
• Creating 


transparent 
buttons 


• Writing 
ActionScript 


• Using the Device 
Simulator 


• Publishing mobile 
applications 


Fireworks 
• Creating a 


wireframe 
• Creating design 


comps 
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 Project 
management Design Research and 


communication Technical 


Project 8: Final web 
portfolio  
Focus: 
• Electronic portfolio 


design 
• Usable, effective 


websites 
• Consistency in website 


design 
• Peer critique and 


presentation 
Time: 2–3 hours 
(3–4 days) 


• Conducting a 
review workshop 


• Providing 
constructive 
criticism 


• Planning and 
updating an 
existing web 
portfolio 


• Organizing and 
managing 
content 


• Creating 
flowcharts 


• Creating a launch 
plan 


• Designing 
consistent pages 


• Designing for a 
specific audience 
and purpose 


• Providing 
universal 
navigation 


• Providing 
consistency and 
accessibility 


• Adapting content 
for readability 
and emphasis 


• Evaluating and 
assessing skills 


• Evaluating and 
assessing an 
existing portfolio 


• Writing and 
editing portfolio 
content 


• Presenting a web 
portfolio to a 
group 


• Soliciting and 
providing 
feedback 


• Taking notes on 
critique 


• Investigating and 
researching 
career areas 
within web 
design and 
development 


• Planning for 
future careers 


• Understanding 
and practicing 
lifelong career 
skills: 


• Job research 
skills 


• Presentation 
skills 


Dreamweaver 
• Updating a web 


portfolio 
• Adding rich 


media to a web 
portfolio 
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Classroom computer setup  
We’ve included the technical information you will need to get your computer lab or classroom ready to 
implement the Digital Design curriculum.  


Adobe Fireworks CS6 


Install Fireworks on all workstations. System requirements are noted below and installation procedures 
are included with the software. For updates to system requirements, visit: 
www.adobe.com/go/fireworks_systemreqs  
Windows 


• Intel® Pentium® 4 or AMD Athlon® 64 processor  
• Microsoft® Windows® XP with Service Pack 2 (Service Pack 3 recommended) or Windows 7 
• 1 GB of RAM (2GB recommended)  
• 1GB of available hard-disk space for installation; additional free space required during installation 


(cannot install on removable flash storage devices)  
• 1280x1024 display with 16-bit video card  
• DVD-ROM drive  
• This software will not operate without activation. Broadband Internet connection and registration are 


required for software activation, validation of subscriptions, and access to online services.* Phone 
activation is not available. 


Macintosh 
• Multicore Intel® processor 
• Mac OS X v.10.6 or v10.7 
• 1 GB of RAM (2GB recommended) 
• 1GB of available hard-disk space for installation; additional free space required during installation 


(cannot install on a volume that uses a case-sensitive file system or on removable flash storage 
devices) 


• 1280x1024 display with 16-bit video card 
• DVD-ROM drive  
• This software will not operate without activation. Broadband Internet connection and registration are 


required for software activation, validation of subscriptions, and access to online services.* Phone 
activation is not available. 


Adobe Photoshop CS6 


Install Photoshop CS6 on all workstations. System requirements and installation procedure are included 
with the software. For updates to system requirements, visit: www.adobe.com/go/photoshop_systemreqs  


Windows 


• Intel® Pentium® 4 or AMD Athlon® 64 Processor 
• Microsoft® Windows® XP with Service Pack 3 or Windows 7 with Service Pack 1 
• 1 GB of RAM 







© 2012 Adobe Systems Incorporated Course overview and setup 15 


• 1 GB of available hard-disk space for installation; additional free space required during installation 
(cannot install on removable flash-based storage devices) 


• 1,024 x 768 display (1,280 x 800 recommended) resolution display with 16-bit color and 256MB 
(512MB recommended) of VRAM 


• OpenGL 2.0-capable system 
• DVD-ROM drive 
• This software will not operate without activation. Broadband Internet connection and registration are 


required for software activation, validation of subscriptions, and access to online services. Phone 
activation is not available.  


*Some GPU-enabled features are not supported on Windows XP. 


 Macintosh 


• Multicore Intel® processor with 64-bit support 
• Mac OS X v10.6.8 or v10.7 
• 1 GB of RAM 
• 2 GB of available hard-disk space for installation; additional free space required during installation 


(cannot install on a volume that uses a case-sensitive file system or on removable flash-based storage 
devices) 


• 1,024 x 768 display (1,280 x 800 recommended) resolution display with 16-bit color and 256MB 
(512MB recommended) of VRAM 


• OpenGL 2.0-capable system  
• DVD-ROM drive 
• This software will not operate without activation. Broadband Internet connection and registration are 


required for software activation, validation of subscriptions, and access to online services. Phone 
activation is not available. 


Adobe Illustrator CS6 


Install Illustrator CS6 on all workstations. System requirements and installation procedure are included 
with the software. For updates to system requirements, visit: www.adobe.com/go/illustrator_systemreqs  


Windows 


• Intel® Pentium® 4 or AMD Athlon® 64 processor 
• Microsoft® Windows® XP with Service Pack 3 or Windows 7 with Service Pack 1 
• 1 GB of RAM (3 GB recommended) for 32 bit; 2 GB of RAM (8 GB recommended) for 64 bit.  
• 2 GB of available hard-disk space for installation; additional free space required during installation 


(cannot install on removable flash-based storage devices) 
• 1,024 x 768 display (1,280 x 800 recommended) with 16-bit video card 
• DVD-ROM drive* 
• Some features in Adobe® Bridge rely on a DirectX 9–capable graphics card with at least 64MB of 


VRAM 
• This software will not operate without activation. Broadband Internet connection and registration are 


required for software activation, validation of subscriptions, and access to online services. Phone 
activation is not available. 
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 Macintosh 


• Multicore Intel® processor with 64-bit support 
• Mac OS X v10.6.8 or v10.7 
• 2 GB of RAM (8 GB recommended) 
• 2 GB of available hard-disk space for installation; additional free space required during installation 


(cannot install on a volume that uses a case-sensitive file system or on removable flash-based storage 
devices) 


• 1,024 x 768 display (1,280 x 800 recommended) with 16-bit video card 
• DVD-ROM drive* 
• This software will not operate without activation. Broadband Internet connection and registration are 


required for software activation, validation of subscriptions, and access to online services. Phone 
activation is not available. 


 
*Versions of Illustrator sold in Continental Europe require a DVD-ROM drive compatible with dual-layer 
DVDs 


Adobe Dreamweaver CS6 


Install Dreamweaver on all workstations. System requirements are noted below and installation procedure 
are included with the software. For updates to system requirements, visit: 
www.adobe.com/go/dreamweaver_systemreqs  


Windows 


• Intel® Pentium® 4 or AMD Athlon® 64 processor  
• Microsoft® Windows® XP with Service Pack 2 (Service Pack 3 recommended); Windows Vista® 


Home Premium, Business, Ultimate, or Enterprise with Service Pack 1; or Windows 7 
• 512MB of RAM 
• 1GB of available hard-disk space for installation; additional free space required during installation 


(cannot install on removable flash storage devices)  
• 1,280x800 display with 16-bit video card 
• Java™ Runtime Environment 1.6 (included) 
• DVD-ROM drive  
• QuickTime 7.6.6 software required for HTML5 media playback 
• This software will not operate without activation. Broadband Internet connection and registration are 


required for software activation, validation of subscriptions, and access to online services. Phone 
activation is not available. 


Macintosh 
• Multicore Intel® processor 
• Mac OS X v.10.6 or v10.7 
• 512MB of RAM 
• 1.8GB of available hard-disk space for installation; additional free space required during installation 


(cannot install on a volume that uses a case-sensitive file system or on removable flash storage 
devices) 


• 1,280x800 display with 16-bit video card 
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• Java™ Runtime Environment 1.6 (included) 
• DVD-ROM drive  
• QuickTime 7.6.6 software required for HTML5 media playback 
• This software will not operate without activation. Broadband Internet connection and registration are 


required for software activation, validation of subscriptions, and access to online services. Phone 
activation is not available. 


Adobe Flash Professional CS6 


Install Flash on all workstations. System requirements are noted below and installation procedures are 
included with the software. For updates to system requirements, visit: 
www.adobe.com/go/flash_systemreqs  


Windows  
• Intel® Pentium® 4 or AMD Athlon® 64 processor  
• Microsoft® Windows® XP with Service Pack 3 or Windows 7 
• 2 GB of RAM (3 GB recommended)  
• 3.5GB of available hard-disk space; additional free space required during installation (cannot install 


on removable flash storage devices)  
• 1,024x768 display (1,280x800 recommended)  
• Java™ Runtime Environment 1.6 (included) 
• DVD-ROM drive  
• QuickTime 7.6.6 software required for multimedia features  
• Some features in Adobe Bridge rely on a Direct X 9-capable graphics card with at least 64MB of 


VRAM 
• This software will not operate without activation. Broadband Internet connection and registration are 


required for software activation, validation of subscriptions, and access to online services. Phone 
activation is not available.  


Macintosh 
• Multicore Intel® processor  
• Mac OS X v.10.6 or v10.7 
• 2 GB of RAM (3 GB recommended)  
• 4 GB of available hard-disk space for installation; additional free space required during installation 


(cannot install on a volume that uses a case-sensitive file system or on removable flash storage 
devices) 


• 1,024x768 display (1,280x800 recommended) 
• Java™ Runtime Environment 1.6 (included) 
• DVD-ROM drive  
• QuickTime 7.6.6 software required for multimedia features  
• This software will not operate without activation. Broadband Internet connection and registration are 


required for software activation, validation of subscriptions, and access to online services. Phone 
activation is not available.  
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Adobe Flash Player 11 


Windows 
• 2.33GHz or faster x86-compatible processor, or Intel® Atom™ 1.6GHz or faster processor for 


netbooks 
• Microsoft® Windows® XP (32-bit), Windows Server® 2003 (32-bit), Windows Server 2008 (32-bit), 


Windows Vista® (32-bit), Windows 7 (32-bit and 64-bit) 
• Internet Explorer 7.0 and above, Mozilla Firefox 4.0 and above, Google Chrome, Safari 5.0 and 


above, Opera 11 
• 128MB of RAM (1GB of RAM recommended for netbooks); 128MB of graphics memory  


Macintosh 
• Intel Core™ Duo 1.33GHz or faster processor 
• Mac OS X v10.6 or v10.7 
• Safari 5.0 and above, Mozilla Firefox 4.0 and above, Google Chrome, Opera 11 
• 256MB of RAM; 128MB of graphics memory 


Linux 
• 2.33GHz or faster x86-compatible processor, or Intel Atom 1.6GHz or faster processor for netbooks 
• Red Hat® Enterprise Linux (RHEL) 5.6 or later (32-bit and 64-bit), openSUSE® 11.3 or later (32-bit 


and 64-bit), Ubuntu 10.04 or later (32-bit and 64-bit) 
• Mozilla Firefox 4.0 or Google Chrome 
• 512MB of RAM; 128MB of graphics memory 
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Classroom enrichment 
Many techniques can help enhance students’ experience as they engage in these projects and also help 
you manage the content and technology. When you set up your computer lab or classroom for working on 
technology-based projects, the suggestions below can help create a successful learning experience for 
your Digital Design students. 


Acceptable use policies 


To promote good digital citizenship and to help students feel ownership of the technology and tools they 
use, discuss acceptable use policies with students. Your institution might already have a policy, but 
discuss with students appropriate use of the Internet and technology tools and have them apply their 
understanding to various misuse scenarios to determine consequences. Work with students to create a 
class policy to protect the rights and privileges of fellow students and class hardware/software. Propose 
rules for good team dynamics and peer critiques. 


File Management 


To save time in assessing student work, make sure all classroom materials and student work are properly 
saved and posted (preferably on a school server). The following guidelines will help: 


Student folders: All students should have a folder for all of their work. Folder names might include 
student’s last name, first initial, and class period (such as “per7_m_smith”). 


Backups: Students might want to keep flash drives, local copies, or school backup server copies of their 
folders. 


Working from home: Students can work from home, but make sure they find a way to transfer their work 
to the school computers (such as FTP, e-mail, flash drive, or school server). 


Turning in work: If students work from home by e-mail, make sure you have effective file virus 
protection and that all work is clearly labeled for ease of identification and organization (for example, 
per7_logo_m_smith). 


Legal issues: If you plan to publish student work on the web, check into your school’s rules about putting 
pictures or names of students on the web. It might be appropriate for students not to include their full 
names or e-mail addresses. 


Classroom environment 


Using technology as part of any lesson in the classroom can lead to management issues unrelated to the 
content being covered. Here are some tips and techniques that can help you manage the technology while 
reinforcing key concepts: 
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Good design posters: Because the course focuses on good design techniques, you might want to print and 
laminate examples of well-designed websites and post them throughout the classroom. A variation 
might be to post examples of “good” and “bad” site designs on opposite sides of the classroom. The 
good and bad design examples should include both HTML sites and Adobe Flash sites. You might 
also have students compile a list of good design criteria throughout the course and post it in the 
classroom. 


Help center: Create a library of print materials for software and design techniques in a corner of the 
classroom where students can browse for answers to challenging questions. 


Running questions list: List technical questions for student research on a large piece of paper or 
chalkboard in the classroom. As the questions are answered, write the answers below them. 


Student leaders: Designate lead students with strong technical skills to be the first person contacted for 
software or hardware questions and issues so students do not break up the lesson time with 
technology questions. You might rotate this role among different sets of students, empowering them 
to take more initiative with their learning. 


Questioning process: You might face some running around when students have open time to work on 
projects. To alleviate this, urge students to try to find the answer themselves first and rely on the 
teacher second and to continue working without waiting for an answer. For example, you might 
request students to look in the help system first and ask their neighboring peers before they ask the 
teacher. You might also provide students with props to place on their monitors as a silent signal that 
they want help. 


Technology extension: As students work on their projects, some will come across techniques that have not 
been demonstrated to the class. When student groups learn a new technique on their own, ask them to 
present it to the class. The group should show the resulting product, share step-by-step how they 
completed it, and have the class complete the same steps while group members walk around to help 
others learn the technique. 


Using constructive comments: Working in teams requires students to become better communicators. 
During the web design process, students will sometimes need to critique each others’ work. Giving 
feedback requires students to be sensitive to the feelings of others. To help students become better 
communicators, you might spend some time brainstorming with the class to identify constructive 
comments and words. This class-generated list can be posted as a reminder for everyone when giving 
a critique of a fellow student’s work. 


Ethical content use and production 


In many projects students will gather, manipulate, and create images and websites. Emphasize the social 
responsibility students have to each other and their audience to help them build good practices as they 
take these skills to future programs and jobs. Some areas to focus on include: 


Content validity: As students research content online, have them continually consider and evaluate 
content bias, currency, and source corroborating. You might cover some search techniques such as 
those provided by November Learning:  
http://novemberlearning.com/resources/information-literacy-resources/.  


Copyright: Emphasize the need to gain permission to use graphics, images, video, and audio produced by 
others and to copyright their own original work. 


Limited resources (digital cameras, video cameras, etc):  


Consider having students work in groups instead of individually. 


Consider connecting all computers into a local network to encourage collaborative learning. 







© 2012 Adobe Systems Incorporated Course overview and setup 21 


You might divide computers into learning stations, perhaps grouped by subject areas or activities (digital 
media center, web research center, etc.). 


You might consider splitting up the activities associated with the project. Have some students use the 
equipment to gather their data while others spend time researching the topic at hand, planning their 
time with the equipment for what they might capture, or building an aspect of the project. Rotate 
groups to ensure all students are occupied at all times. 


Professional skills 


This course is designed to introduce students to professional experiences. You can reinforce the ideas 
around professional behavior and work in a few ways. 


• Soft skills: When communicating with clients, students need soft skills to help them interview and 
review their work with clients. You might have students practice interviewing each other or conduct 
practice interviews with you as they develop skills for speaking with clients. 


• Project tracking: Reinforce the need to plan appropriate schedules and manage time. You might 
consider having students give brief daily status reports of how they are doing on time per task. Guide 
students in reprioritizing and updating their project plans when needed. 


• Team-work: Helping students develop individually and as productive team members is a challenging 
task. You might reinforce the importance of both types of development by evaluating their individual 
performance as well as the ways they contribute to team goals, work to solve any team conflicts, and 
collaborate with other teams to adopt successful practices. 


Professional environment: To prepare students to work with clients and help them develop professional 
attitudes, you might want to give them weekly points for displaying professional attitudes and skills, 
such as the following: 


• Punctuality 


• Dressing well when interviewing peers and clients 


• Promptly replying to peers and clients 


• Listening to suggestions and working well in groups 


Professional designers: Students can benefit greatly from speaking with a professional web designer or 
developer. You could arrange a field trip to a design studio or ask a designer to visit your classroom. 
Key topics to address with the designer  


• Teamwork and collaboration 


• Effective design 


• Samples of the designer’s work and the challenges they presented 


• Use of professional software, such as Adobe products, in the web and rich media fields 


• Critique of student work 
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Teaching across disciplines 


You could team-teach some projects with teachers from other departments to help traditional content area 
teachers integrate technology into their courses while helping students develop skills in academic areas 
such as writing, reading, math, and science. You can have students go into the other teacher’s classroom 
for a change of atmosphere, or bring the other teacher into your classroom. This is especially helpful with 
the following topics: 


Graphic design: An art teacher can address topics such as line, rule of thirds, and typography. 


Web page design: An art teacher can address topics such as composition, color, and shape. 


Web page design and production: A business or career exploration teacher can discuss the qualifications, 
salary, and skills required for working in the web design field. A marketing teacher can enhance the 
discussion around audience and purpose. 


Web page content: A literature teacher could emphasize writing for different audiences as students engage 
in web projects that include different clients. 
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Skills overview rubric 
This general skills rubric is a tool for assessing various aspects of major web and rich-media projects. 
Although each activity has its own rubric, you might use the following to help you assess particular 
aspects of projects further. Select the items that apply to a particular project. 


Design skills 


Category Does not meet 
expectations 


Meets expectations Exceeds expectations 


Composition There is no use of white 
space, symmetry, and 
focal point. Site pages 
(and elements within 
pages) are cut off 
inappropriately at their 
borders or are surrounded 
by excessive white space. 


There is some use of 
white space, symmetry, 
and focal point. Site 
pages (and elements 
within pages) usually fit 
appropriately within their 
borders. 


White space, symmetry, 
and focal point are used 
effectively. Site pages 
(and elements within 
pages) fit within their 
borders in a pleasing 
manner. 


Color Colors clash and do little 
for the theme of the 
design. Background color 
interferes with text and 
images. Colors make text 
less readable. 


Colors are somewhat 
complementary. 
Background color 
coordinates with images 
and text design. Colors do 
not interfere with 
readability. 


Colors work together, 
reinforcing the theme of 
the design. Background 
color enhances images 
and text design. Colors 
strongly support 
readability. 


Typography Text is not easily 
readable. White space is 
not used effectively. 
Fonts and text effects 
interfere with the design 
and readability. 


Text is readable. Type 
sizes communicate 
information and are 
compatible with overall 
site design. White space 
around text supports 
readability and design. 
Fonts and text effects are 
compatible with the 
design and readability. 


Text is readable, and 
selected fonts support 
design goals. Type sizes 
reflect desired emphasis. 
White space around text 
strongly supports 
readability and design. 
Fonts and text effects add 
to mood and tone. Fonts 
enhance readability 
through color, size, and 
contrast. 


Usability Site navigation appears 
on some pages, and not 
all links function 
properly. Navigation does 
not allow users access to 
all main pages in the site 
and is not intuitive to use. 
Some site pages take a 
noticeable time to load, 
and the delays are caused 
by irrelevant elements. 


Site navigation appears 
on all pages, and all links 
function properly. 
Navigation gives users 
access to most main 
pages in the site and is 
intuitive to use. Some site 
pages take a noticeable 
time to load, but most 
delays are worth the wait. 


Consistent site navigation 
appears on all pages, and 
all links function 
properly. Navigation 
gives users access to all 
main pages in the site and 
is intuitive to use. Site 
pages load in a 
reasonable time, and any 
noticeable delays are 
worth the wait. 
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Category Does not meet 
expectations 


Meets expectations Exceeds expectations 


Use of technical 
elements 
(Dreamweaver, 
Fireworks, 
Photoshop, 
Illustrator, or 
Flash) 


Use of technical elements 
and effects does not 
enhance the user’s 
experience or consistently 
support the overall goals 
and message of the site. 


Use of technical elements 
and effects consistently 
supports the overall goals 
and message of the site 
but does not enhance the 
user’s experience. Use of 
such elements or effects 
is not excessive or 
distracting. 


Use of technical elements 
and effects adds to the 
overall design of the site 
by enhancing the user’s 
experience and 
supporting the goals and 
message of the site. Use 
of such elements or 
effects is not excessive or 
distracting. 


Storyboard Storyboard provides 
incomplete or 
contradictory production 
information. 


Storyboard is complete 
but somewhat difficult to 
interpret. 


Storyboard is thorough, 
complete, and very clear. 


Technical skills 


Category Does not meet 
expectations 


Meets expectations Exceeds expectations 


Accessibility Very few graphical site 
elements, such as images 
and buttons, have 
alternative text tags. 


Some graphical site 
elements, such as images 
and buttons, have 
alternative text tags. 


All graphical site 
elements, such as images 
and buttons, have 
alternative text tags. 


Drawing Illustrations and buttons 
are poorly drawn, not 
always using appropriate 
drawing and effects tools. 


Illustrations and buttons 
are drawn in a sufficient 
manner, using a range of 
drawing and effects tools. 


Illustrations and buttons 
are cleanly and clearly 
drawn, effectively using 
the full range of drawing 
and effects tools. 


Color panels Color is not consistently 
applied and panels are 
usually not configured for 
the web. 


Color is consistently 
applied most of the time, 
and panels are usually 
configured for the web. 


Color is consistently 
applied, and panels are 
configured for the web. 


Optimization The quality of images is 
not sufficient, or the file 
size is too large. 


Images have a 
satisfactory balance of 
quality and file size. 


Images have an excellent 
balance of quality and file 
size. 


Tool use Student frequently has to 
ask what tool to use to 
create desired elements 
and effects. Does not 
independently use 
available information 
about the tools. Does not 
use tools efficiently. 


Student usually knows 
what tool to use to create 
desired elements and 
effects but sometimes 
needs to be reminded to 
use available information 
about the tools. Uses 
most tools efficiently. 


Student knows what tool 
to use to create desired 
elements and effects or 
uses resources effectively 
and independently to find 
out. Uses tools 
efficiently. 
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Research and communication skills 


Category Does not meet 
expectations 


Meets expectations Exceeds expectations 


Design process The design process does 
not include all 
appropriate elements, 
such as sketches, site 
map, storyboard, and 
review comments. The 
final product does not 
completely reflect the 
storyboard and feedback. 


The design process 
includes elements such as 
sketches, site map, 
storyboard, and review 
comments. The final 
product reflects the 
storyboard, with some 
revisions based on 
feedback. 


The design process 
includes all appropriate 
elements, such as 
sketches, site map, 
storyboard, and review 
comments. The final 
product accurately 
reflects the storyboard, 
including storyboard 
revisions based on 
feedback and thoughtful 
design decisions made 
during production. 


Feedback Reviews of other 
students’ designs do not 
adequately address 
content and design. 
Feedback does not use 
informative vocabulary 
and is often not 
constructive. 


Reviews of other 
students’ designs provide 
some analysis of content 
and design. Feedback 
uses some informative 
vocabulary and connects 
comments to design and 
content. Feedback is not 
always constructive. 


Reviews of other 
students’ designs provide 
thorough and insightful 
analysis of content and 
design. Feedback uses 
clear and informative 
vocabulary and connects 
comments to design and 
content. Feedback is 
always constructive. 


Presentation Design presentations 
provide little information 
on the goals, design 
concepts, and 
requirements of a project. 


Design presentations 
cover the goals, design 
concepts, and 
requirements of a project. 


Design presentations 
clearly and completely 
state the goals, design 
concepts, and 
requirements of a project. 


Team 
collaboration 


Student does not 
collaborate with other 
students to provide 
feedback or assistance. 
Fulfills assigned team 
roles but does not 
contribute equally to 
project work. Does not 
consult with other team 
members before making 
major project decisions. 
Does not help others 
build skills. 


Student collaborates with 
other students as required 
to provide feedback or 
assistance. Fulfills 
assigned team roles and 
contributes equally to 
project work. Sometimes 
consults with other team 
members on major 
project decisions but 
makes minimal effort to 
help others build skills. 


Student collaborates 
freely with other students 
to provide feedback or 
assistance. Fulfills 
assigned team roles and 
contributes equally to 
project work. Consults 
with other team members 
on major project 
decisions and voluntarily 
helps others build skills 
to complete the project. 
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Project management skills 


Category Does not meet 
expectations 


Meets expectations Exceeds expectations 


Progressive 
design 


Student does not use a 
design document or peer 
feedback.  


Student uses design 
documents to guide the 
design process. 
Inconsistently uses peer 
feedback to guide the 
redesign process. 


Student consistently uses 
design documents to 
guide the design and 
development process. 
Thoughtfully uses peer 
feedback to guide the 
redesign process. 


File 
management 


Student files and folders 
are inconsistently named 
and not logically 
organized. File 
organization is not seen 
as an important task. 


Most student files and 
folders are named and 
organized logically on 
both local and remote 
drives. File organization 
evolves as project work 
progresses. 


Student files and folders 
are consistently named 
and logically organized 
on both local and remote 
drives. File organization 
is created at the start of a 
project. 


Task review Student does not respond 
to feedback, or student 
redesigns without 
deciding whether the 
feedback improves the 
content and design of the 
project. 


Student responds to 
feedback, deciding which 
feedback improves the 
content and design of the 
project. Incorporates 
some of this feedback 
into redesign. 


Student responds 
thoughtfully and 
completely to feedback, 
deciding which feedback 
most effectively improves 
the content and design of 
the project. Incorporates 
this feedback into 
redesign of a project. 


Time 
management 


Student does not 
effectively allot time for 
the phases of the design 
and development process. 
Completes few phases on 
schedule. 


Student allots time for 
each phase of the design 
and development process 
through a project plan. 
Completes most phases 
on schedule. 


Student thoughtfully and 
effectively allots time for 
each phase of the design 
and development process 
through a project plan. 
Completes all phases on 
schedule. 
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ISTE NETS*S Standards for 
Students 
The International Society for Technology in Education (ISTE) is the trusted source for professional 
development, knowledge generation, advocacy, and leadership for innovation. These standards, identified 
throughout the Digital Design curriculum, are integrated into the various activities students engage in 
during each project.  


I.    Creativity and Innovation 
Students demonstrate creative thinking, construct knowledge, and develop innovative products and 
processes using technology.  Students: 


A. apply existing knowledge to generate new ideas, products, or processes. 


B. create original works as a means of personal or group expression 


C. use models and simulations to explore complex systems and issues. 


D. identify trends and forecast possibilities. 


II.  Communication and Collaboration 
Students use digital media and environments to communicate and work collaboratively, including at a 
distance, to support individual learning and contribute to the learning of others.  Students: 


A. interact, collaborate, and publish with peers, experts or others employing a variety of digital 
environments and media. 


B. communicate information and ideas effectively to multiple audiences using a variety of media 
and formats. 


C. develop cultural understanding and global awareness by engaging with learners of other cultures. 


D. contribute to project teams to produce original works or solve problems. 


III.  Research and Information Fluency 
Students apply digital tools to gather, evaluate, and use information.  Students:   


A. plan strategies to guide inquiry. 


B. locate, organize, analyze, evaluate, synthesize, and ethically use information from a variety of 
sources and media. 


C. evaluate and select information sources and digital tools based on the appropriateness to specific 
tasks. 


D. process data and report results. 


IV. Critical Thinking, Problem-Solving & Decision-Making 
Students use critical thinking skills to plan and conduct research, manage projects, solve problems 
and make informed decisions using appropriate digital tools and resources.  Students: 


A. identify and define authentic problems and significant questions for investigation. 


B. plan and manage activities to develop a solution or complete a project. 
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C. collect and analyze data to identify solutions and/or make informed decisions. 


D. use multiple processes and diverse perspectives to explore alternative solutions. 


V. Digital Citizenship 
Students understand human, cultural, and societal issues related to technology and practice legal and 
ethical behavior.  Students: 


A. advocate and practice safe, legal, and responsible use of information and technology. 


B. exhibit a positive attitude toward using technology that supports collaboration, learning, and 
productivity. 


C. demonstrate personal responsibility for lifelong learning. 


D. exhibit leadership for digital citizenship. 


VI. Technology Operations and Concepts 
Students demonstrate a sound understanding of technology concepts, systems and operations.  
Students: 


A. understand and use technology systems. 


B. select and use applications effectively and productively. 


C. troubleshoot systems and applications. 


D. transfer current knowledge to learning of new technologies. 
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Adobe Certified Associate 
objectives 
Over the last few years, Adobe conducted research to identify the foundation skills students need to create 
effective communication using different digital media tools. Adobe met with educators and design 
professionals and surveyed businesses and educational institutions around the world. The research 
resulted in objectives that cover design, project planning, communication, and technology. The following 
set of essential learning objectives are a part of the Adobe Certified Associate exams in Web 
Communication and Rich Media Communication and are integrated throughout Digital Design. 


Web Communication using Dreamweaver CS6 objectives 


Setting project requirements  


1.1 Identify the purpose, audience, and audience needs for a website. 


1.2 Identify web page content that is relevant to the website purpose and appropriate for the target 
audience. 


1.3 Demonstrate knowledge of standard copyright rules (related terms, obtaining permission, and citing 
copyrighted material).  


1.4 Demonstrate knowledge of website accessibility standards that address the needs of people with 
visual and motor impairments. 


1.5 Make website development decisions based on your analysis and interpretation of design 
specifications. 


1.6 Understand project management tasks and responsibilities. 


Planning site design and page layout 


2.1 Demonstrate general and Dreamweaver-specific knowledge of best practices for designing a 
website, such as maintaining consistency, separating content from design, using standard fonts, and 
utilizing visual hierarchy. 


2.2 Produce website designs that work equally well on various operating systems, browser 
versions/configurations, and devices.  


2.3 Demonstrate knowledge of page layout design concepts and principles. 


2.4 Identify basic principles of website usability, readability, and accessibility. 


2.5 Demonstrate knowledge of flowcharts, storyboards, and wireframes to create web pages and a site 
map (site index) that maintain the planned website hierarchy. 


2.6 Communicate with others (such as peers and clients) about design plans. 


Understanding the Adobe Dreamweaver CS6 interface 


3.1 Identify elements of the Dreamweaver interface. 


3.2 Use the Insert bar. 
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3.3 Use the Property inspector. 


3.4 Use the Assets panel. 


3.5 Use the Files panel. 


3.6 Customize the workspace. 


Adding content by using Dreamweaver CS6 


4.1 Demonstrate knowledge of Hypertext Markup Language. 


4.2 Define a Dreamweaver site. 


4.3 Create, title, name, and save a web page. 


4.4 Add text to a web page. 


4.5 Insert images and apply alternative text on a web page. 


4.6 Link web content, using hyperlinks, e-mail links, and named anchors. 


4.7 Include video and sound in a web page.  


4.8 Add animation and interactivity to content.  


4.9 Insert navigation bars, rollover images, and buttons created in a drawing program on a web page.  


4.10 Build image maps. 


4.11 Import tabular data to a web page. 


4.12 Import and display a Microsoft Word or Microsoft Excel document to a web page. 


4.13 Create forms. 


Organizing content by using Dreamweaver CS6 


5.1 Set and modify document properties. 


5.2 Organize web page layout with relative and absolutely-positioned div tags and CSS styles. 


5.3 Modify text and text properties. 


5.4 Modify images and image properties. 


5.5 Create web page templates. 


5.6 Use basic HTML tags to set up an HTML document, format text, add links, create tables, and build 
ordered and unordered lists. 


5.7 Add head content to make a web page visible to search engines.  


5.8 Use CSS to implement a reusable design.  


Evaluating and maintaining a site by using Dreamweaver CS6 


6.1 Conduct technical tests.  


6.2 Identify techniques for basic usability tests. 


6.3 Identify methods for collecting site feedback. 


6.4 Manage assets, links, and files for a site.  


6.5 Publish and update site files to a remote server.  
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Rich Media Communication using Flash Professional CS6 objectives 


Setting project requirements 


1.1 Identify the purpose, audience, and audience needs for rich media content. 


1.2 Identify rich media content that is relevant to the purpose of the media in which it will be used 
(websites, mobile devices, and so on). 


1.3 Understand options for producing accessible rich media content. 


1.4 Demonstrate knowledge of standard copyright rules (related terms, obtaining permission, and citing 
copyrighted material).  


1.5 Understand project management tasks and responsibilities. 


1.6. Communicate with others (such as peers and clients) about design and content plans. 


Identifying rich media design elements 


2.1 Identify general and Flash-specific best practices for designing rich media content for the web, 
mobile apps, and AIR applications. 


2.2 Demonstrate knowledge of design elements and principles. 


2.3 Identify general and Flash-specific techniques to create rich media elements that are accessible and 
readable. 


2.4 Use a storyboard to design rich media elements. 


2.5 Organize a Flash document. 


Understanding Adobe Flash Professional CS6 interface 


3.1 Identify elements of the Flash interface. 


3.2 Use the Property inspector. 


3.3 Use the Timeline. 


3.4 Adjust document properties. 


3.5 Use Flash guides and rulers. 


3.6 Use the Motion Editor. 


3.7 Understand Flash file types. 


3.8 Identify best practices for managing the file size of a published Flash document. 


Building rich media elements by using Flash Professional CS6 


4.1 Make rich media content development decisions based on your analysis and interpretation of design 
specifications. 


4.2 Use tools on the Tools panel to select, create, and manipulate graphics and text. 


4.3 Import and modify graphics. 


4.4 Create text.  


4.5 Adjust text properties.  


4.6 Create objects and convert them to symbols, including graphics, movie clips, and buttons. 
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4.7 Understand symbols and the library. 


4.8 Edit symbols and instances. 


4.9 Create masks. 


4.10 Create animations (changes in shape, position, size, color, and transparency). 


4.11 Add simple controls through ActionScript 3.0. 


4.12 Import and use sound.  


4.13 Add and export video.  


4.14 Publish and export Flash documents.  


4.15 Make a Flash document accessible.  


Evaluating rich media elements by using Flash Professional CS6 


5.1 Conduct basic technical tests. 


5.2 Identify techniques for basic usability tests. 













Adobe Flash Professional CS6 Project 7 guide

How to publish a mobile application
You create AIR for Android and AIR for iOS mobile applications with Adobe Flash Professional CS6 by working in 
a FLA file. These documents have a .fla extension and you can open and edit the in Flash.


For people to install your app on their mobile devices, they need access to a valid installation file. You create this file 
by opening your finished FLA document and publishing the mobile application. You use the Publish Settings dialog 
box or the Publish Settings section in the document Properties panel to specify which formats to publish.


Note: In this guide, you confirm publish settings and then publish the application. For information on creating a new 
mobile application document and specifying application settings, see the guide “How to set up a mobile application 
file.” For more information on Flash publish settings, see the guide “How to publish a Flash document.”


Confirming publish settings
When you created your mobile application file, you specified application and publish settings. When you are finish 
creating the application in Flash, you can view and confirm these settings before publishing. 


To confirm publish settings:


1. Open the FLA document used to create your mobile 
application.


2. Make sure nothing on the Stage is selected and, in the 
Properties panel, click Publish Settings.


The Publish Settings dialog box appears (Figure 1). 


3. Make sure that only Flash (.swf) is selected in the Publish 
list on the left. You don’t need to publish an HTML 
wrapper or other files for the mobile application.


4. Confirm the Target and Script settings for the application 
(Figure 2).


The Target should list the name of the application type 
you’re publishing. For a Flash mobile application, this is 
either AIR 3.2 For Android or AIR 3.2 For IOS. 


Figure 1 Publish Settings dialog box 


Figure 2 Target and Script settings in the Publish 
Settings dialog box


Settings button
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5. Click the Settings button (Figure 2).


Note: This button is labeled Edit Application Settings in 
the Properties panel.


The AIR For Android Settings or AIR For IOS Settings 
dialog box appears, with the General tab selected 
(Figure 3). The options differ depending on which type 
of mobile application you’re publishing.


If you’re publishing for Android devices, the output file 
has the .apk filename extension. If you’re publishing for 
iOS devices, the extension is .ipa. 


6. Confirm the General application settings and then click 
the Deployment tab.


The Deployment tab (Figure 4) shows the security 
certificate for the application. You created this when you 
set up your application.


7. Enter the password for the certificate and select 
Remember Password For This Session.


The remaining options on the Deployment differ 
depending on which type of mobile application you’re 
publishing. You can publish Android apps as a Device 
release, Emulator release, or Debug release. You can 
choose to embed the AIR runtime or direct users where to 
download AIR when they install the application.


If you want Flash to automatically copy the application to 
an Android device after publishing, you can connect the 
device by USB cable and select Install Application On 
The Connected Android Device.


If publishing for iOS, you’ll also need to include your 
Provisioning Profile and App ID. For iOS apps, you 
specify which type of deployment you want, such as 
device testing, device debugging, or publishing to the 
Apple App store.


Figure 3 AIR For Android Settings dialog box, 
General tab 


Figure 4 AIR For Android Settings dialog box, 
Deployment tab
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8. Select the Icons tab and confirm that you’ve selected 
icons for the application.


The Icons tab shows the icons you’ve selected to 
associate with the application (Figure 5). If you have not 
selected icons for the application, you can do that here.


9. Select the Languages tab and confirm the supported 
languages.


The Languages tab lists languages you can support in the 
application (Figure 6). 


Notice you can publish from the AIR For Android 
Settings (or AIR For IOS Setting) dialog box by clicking 
Publish.


10. Click OK to confirm the application settings and close 
the dialog box.


You return to the Publish Settings dialog box. You can 
also publish the application here by clicking Publish. 


Before you publish, it’s a good idea to test the 
application.


11. Click OK to confirm your publish settings and close the 
dialog box. Figure 5 AIR For Android Settings dialog box, 


Icons tab 


Figure 6 AIR For Android Settings dialog box, 
Languages tab
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Testing and publishing the application
Before you publish the application, you can test it on your computer or on a mobile device that is connected to your 
computer by USB and has USB debugging enabled.


When you test the application on your computer, Flash opens the app in a preview window and starts the Simulator. 
The Simulator is a device emulator that you can use to test mobile features such as accelerometer, touch screen, and 
geolocator. For more information on using the Simulator, see the guide “How to test a Flash project.”


In the following steps, you test the application on your computer and then publish it. 


To test and publish the application:


1. Choose Control > Test Movie > In AIR Debug Launcher 
(Mobile).


The application opens in the Device preview window 
(Figure 7) and the Simulator appears (Figure 8). You can 
use the sliders in the Simulator or change values in the 
Accelerometer, Touch And Gesture, and Geolocation 
sections to simulate common mobile application features.


2. Test the buttons, navigation, and any other features in the 
application.


3. Close the Device preview window.


Closing the Device preview window closes the Simulator 
automatically.


4. Select File > Publish to publish the application with the 
settings you specified.


The APK (Android) or IPA (iOS) application files are 
added to the project folder you specified. 


Use these files to deploy and install the application on the 
target mobile devices. Figure 7 Device preview window 


Figure 8 Simulator 
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		How to publish a mobile application

		Confirming publish settings

		Testing and publishing the application
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WEBSITE PRODUCTION PHASES

DEFINE, STRUCTURE, DESIGN, BUILD AND TEST, LAUNCH





















®
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Define

		Set goals, target audience, content, and delivery requirements for project.

		Develop a project plan.

		Outline the content production process.



*



Ask students if they can think of other types of balance: texture and no texture (smooth), size and scale, elements of a composition.

*
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Structure

		Information architecture and design documents.

		Flowchart to outline the overall structure of the site.

		Wireframes to show basic structure of site pages.



*





Home
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Design

		Provide two or more design comps.

		Review comps with client. 

		Redesign based on feedback.

		Develop production storyboard.

		Design prototype wireframe.



*
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Build and test

		Build site production based on storyboards.

		Do technical, accessibility, and usability testing, recording bugs, and design-change requirements.

		Make revisions based on test results.

		Repeat technical and usability testing of revised site.

		Present site to client and do final revision.



*



The rectangle has three lines of symmetry: horizontal (blue), vertical (red), diagonal (yellow)

The triangle only has one line of symmetry: center or vertical. You can draw two other lines of symmetry from any of the vertices to the center of the opposite side.

*
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Launch

		Outline a launch plan including promotion, and search engine optimization. 



*
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BALANCE, EMPHASIS, AND COLOR

PAGE DESIGN PRINCIPLES
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Balance

Balance is the act of comparing or estimating two things, one against the other, and the contrast between:

		Empty space (white space) and filled space

		Text and images

		Color and no colors and different colors

		Textures against flat colors



*









- Ask students if they can think of other types of balance: texture and no texture (smooth), size and scale, elements of a composition.

*
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Balance in page composition

Three different types of balance when laying out pages

		Symmetry

		Asymmetry

		Radial symmetry



*
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Symmetrical or formal balance

You can usually identify at least one of three lines of symmetry.

		Horizontal

		Vertical

		Diagonal



*
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Symmetrical balance

*



		The rectangle has three lines of symmetry: horizontal (blue), vertical (red), diagonal (yellow)

		The triangle only has one line of symmetry: center or vertical. You can draw two other lines of symmetry from any of the vertices to the center of the opposite side.



*
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Examples of symmetrical balance

*

http://builtwithmomentum.com/
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Examples of asymmetrical balance

*

http://vani.com.mx/
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Examples of radial balance

*

www.soleilnoir.net/believein/#/ideas
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Emphasis

Emphasis: To express with particular stress or force

	    What message is stressed in this slide?

*
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Color definitions

		Hue is another word for color.

		Chroma is the intensity or purity of color.

		Tint is a color mixed with white.

		Tone is a color mixed with gray.

		Shade is a color mixed with black.



*
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Color and contrast

		Using color can enhance or detract from a composition.

www.lighthouse.org/color_contrast.htm

		Color wheels help determine which colors are in greatest contrast.









	Use Adobe Kuler to try out new color schemes:

	kuler.adobe.com/

*
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Color wheels

		Analogous colors are adjacent to each other on the color wheel.

		Complementary colors are opposite each other on the color wheel.



*
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Color in design

		Use color to label or show hierarchy.

		Use color to represent or imitate reality.

		Use color to unify, separate, or emphasize.

		Use color to decorate.

		Use color consistently.



*
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Summary

		The basis of good page design is use of design elements and their thoughtful application in the form of design principles.

		Clearly identify what you are trying to accomplish—use design to convey your message.

		Brainstorm alternatives.



*
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Project 1


Widgets
Timing: 8 to 12 hours


Project overview


In this project, students will use their knowledge of design principles, HTML, and CSS to customize an 
existing widget. Through analyzing widgets and websites, they will learn to identify purpose and audience 
and to use design principles to emphasize purpose and audience. They will also learn about the phases of 
web production and about publishing web projects.


The main focus of this project is for students to learn and understand how CSS is used to create 
consistency and allow for easy site-wide changes. The emphasis is on employing their understanding of 
design principles to inform the modifications and customizations they make to the widget’s Cascading 
Style Sheet. 


Student product: Customized widget


Note: Portions of the Widget project align to the Adobe Certified Associate, Web Communication 
objectives. Within the instruction steps and technical guides, the specific learning objectives for the exam 
are referenced with the following format: 1.1  


Project objectives


At the completion of the project, students will have developed the following skills:


Project management skills


• Designing for a specific audience and purpose


• Understanding the phases of web development


Design skills


• Designing for their audience(s)


• Applying design principles


• Creating wireframes


• Creating design comps


• Learning basic HTML


• Understanding CSS


• Applying design aspects such as color, design, 
layout, contrast, and composition


• Integrating images and text


• Planning graphics based on needs and audience


Research and communication skills


• Understanding the role and purpose of widgets


• Analyzing and critiquing widgets and websites


• Evaluating and analyzing content validity


• Evaluating and analyzing website navigation


• Understanding copyright issues and fair-use 
guidelines


• Advocating and practicing legal use of images


• Collecting and analyzing audience needs and 
purpose to inform design


• Participating in a peer review


• Communicating and presenting design 
decisions


• Giving feedback on a project


Technical skills


Fireworks


• Understanding the Fireworks workspace
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• Creating a wireframe


• Creating design comps


• Preparing images


Photoshop


• Understanding the Adobe Photoshop interface


• Resizing, rotating, and cropping images


• Correcting color


• Retouching images


• Generating multiple file formats


Dreamweaver


• Understanding the Dreamweaver workspace


• Creating a new document


• Using the Insert panel


• Inserting images


• Inserting text


• Using the Widget Browser


• Inserting a widget into an HTML web page


• Editing and customizing CSS rules


• Using the CSS Styles panel


• Publishing web files


Project materials
• Adobe Fireworks CS6 installed on all machines


• Adobe Photoshop CS6 installed on all 
machines


• Adobe Dreamweaver CS6 installed on all 
machines


• Digital cameras


• Presentation: Introduction to design principles


• Presentation: Introduction to page design 
principles


• Worksheet: Analyzing websites


• Presentation: Introduction to HTML and CSS


• Guide: Introduction to HTML and CSS


• Presentation: Web project production phases


• Fireworks guide: Overview of Adobe 
Fireworks CS6 workspace


• Fireworks guide: How to create a wireframe


• Electronic file: 
slideshow_widget_wireframe.fw.png


• Electronic file: 
spry_slideshow_widget_comp1.fw.png


• Electronic file: 
spry_slideshow_widget_comp2.fw.png


• Fireworks guide: How to create a design comp 


• Guide: Peer review


• Guide: Introduction to digital photography


• Guide: Principles and rules of copyright


• Photoshop guide: Overview of the Adobe 
Photoshop CS6 workspace


• Fireworks guide: How to prepare photographs 


• Photoshop guide: How to resize, rotate, and 
crop images


• Photoshop guide: How to correct color


• Photoshop guide: How to retouch photos


• Photoshop guide: How to generate different file 
formats


• Dreamweaver guide: Overview of Adobe 
Dreamweaver CS6 workspace


• Dreamweaver guide: How to use the Adobe 
Dreamweaver Widget Browser


• Dreamweaver guide: How to work with text 
and images


• Dreamweaver guide: The Dreamweaver Insert 
panel


• Dreamweaver guide: How to create and edit a 
CSS rule


• Dreamweaver guide: How to publish web files
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Background preparation resources
• Technical and content information


• Key terms


• ISTE NETS*S Standard for Students


• Adobe Certified Associate, Web Communication objectives


Project steps


1. Introduce students to the goals of the project.


• Introduce design principles


• Introduce HTML and CSS


• Analyze widgets and websites


• Introduce wireframing and design comps


• Select and prepare images


• Edit and customize CSS rules


• Add a widget to an HTML web page


Introduction to design principles
(Suggested time: 50–100 minutes)


2. Introduce the concept of using design principles to evaluate and inform web design. Use the following 
presentation to introduce specific design principles.


Presentation: Introduction to design principles 2.3


3. Show students at least two websites, one that is well designed and one that is not, and discuss them in 
relation to consistency and visual hierarchy. Ask students to identify the design elements on the sample 
websites. Identify visual elements on some of the web pages that can support content hierarchy, such 
as navigation scheme, the use of color, text headings, fonts (color, emphasis, and size), indentation and 
alignment, paragraph headings, and lists.


Presentation: Introduction to page design principles 2.3


4. Time permitting, discuss some or all of these design tips from Don’t Make Me Think: A Common Sense 
Approach to Web Usability, by Steve Krug (Que Books, 2005):


• Make the most important things prominent: larger, bolder, near the top, with more white space.


• Relate similar content visually: grouped by heading, lined up, with similar look or size, grouped in 
an area.


• Nest content visually: use boxes in boxes, have headings and indented subheadings to show 
elements as parts of groups.
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How to analyze a widget
(Suggested time: 50–100 minutes)


5. Now that students have an understanding of design principles, introduce the use of widgets on web 
pages. Have a class discussion on the role and purpose of widgets, especially within a larger website. 
Because widgets vary in kind and definition, some guiding discussion points are:


• Widgets are useful applications that can be embedded on a web page, blog, or social media page to 
perform a specific function. They display information and invite users to act in a number of ways. 


• A widget is a piece of self-enclosed code (usually a combination of HTML, CSS, and JavaScript) 
that is often created by reusing existing code or HTML Snippets. 


• Some widgets are simple and provide an enhanced user experience. Examples include accordions, 
tabbed panels, buttons, dialog boxes, pop-up windows, selection boxes, toggle switches, and slide 
shows.


• Some widgets are small applications that open up to a larger application. Examples of this kind of 
widget include stock quotes and news; search boxes for Google, eBay and other popular search-
based websites; clocks and counters; games; feeds; and more.


6. Show students a variety of widgets and help them identify the specific purpose and functionality of 


each.1.2 Discuss the following: 


• What is the purpose of the widget?


• What is its functionality?


• Who is the audience?


• Who created the widget?


Note: You might gather some popular widgets showing various functionalities and purposes. The 
Adobe Dreamweaver Widget Browser includes a variety of widgets to show your students. To access 
the Widget Browser in Dreamweaver, create a new HTML document and, under Insert, select Widget 
and then select Widget Browser in the dialog box. The Widget Browser is an Adobe AIR application 
you will be required to install on your computer. You will need to create a free Adobe ID to access the 
Widget Browser and download widgets. Student computers will need access to the Widget Browser for 
this project, so take the installation and Adobe ID requirements into consideration when you are 
preparing to teach the project.


How to analyze websites
(Suggested time: 50–100 minutes)


7. Now that you have discussed widgets, explain that you will now look at websites. Begin with a general 
class discussion about the purpose and audience of a website. Identify the kind of information that 
determines purpose, audience, and audience needs. Focus the discussion on websites that have sections 
targeted to a variety of audiences. For example, you might contrast the PBS site for adults, 
www.pbs.org, with their site for kids, www.pbskids.org, discussing the following:


• Purpose of the site


• Audience for the site


• How the site uses design principles to emphasize purpose and audience


8. Demonstrate website analysis techniques.2.1 Criteria for evaluating sites might include the following:


• Design
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• Visual layout


• Consistency structures


• Color scheme


• Visual hierarchy elements


• Content


• Bias


• Currency


• Source


• Ability to corroborate information


9. Divide the class into small groups and ask each group to evaluate your school’s website for design and 
content. 


Worksheet: Analyzing websites 1.1, 1.2, 1.3, 1.5, 2.3


Note: If your school does not have a website or the website is not conducive to this activity, you can 
use another website that is relevant to your students. 


10. When students have finished evaluating your school’s website for design and consistency elements, 
open the website in a web browser, select Source (or Page Source) from the View menu, and show 
students the source code. Briefly explain what HTML is and how it works. Briefly explain Cascading 
Style Sheets and why it is important to use CSS when creating designs.


Presentation: Introduction to HTML and CSS 2.1, 4.1


Guide: Introduction to HTML and CSS 2.1, 4.1


11. Briefly demonstrate what tags to include on every HTML document (<HTML>, <HEAD>, <TITLE>, 


<BODY>).4.1, 5.6


12. Briefly discuss the importance of CSS as follows:2.1


• Simplifies text formatting


• Enables design of consistent-looking pages


• Enables site-wide changes


13. Briefly discuss best practices for using CSS and introduce the three main types of CSS styles: Class, 


Tag, and ID.2.1 Using the source code, show students where and how CSS was used on the school’s 
website.


Wireframes, design comps, and customizing a widget
(Suggested time: 100–150 minutes)


14. Explain that in another project they will go through each phase of the production process. However, for 
this project they will only be working with wireframes and design comps to assist them in customizing 
the Spry Image Slideshow with Filmstrip for use on the school’s website.


Note: If your school does not have a website or the website is not conducive to this activity, you can 
add the widget to another website. 
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15. Briefly discuss and define the phases of a web project:


• Define:


◦ Goals, target audience, content, and delivery requirements for the project


◦ Project plan


◦ Content production


• Structure:


◦ Information architecture and design document


◦ Flowchart to portray the overall structure of the site


◦ Wireframes to block out the basic structure of site pages


• Design:


◦ Design of comps to provide detailed alternative designs


◦ Review of comps with client to ascertain client’s design preferences


◦ Redesign based on client feedback


◦ Production storyboard


◦ Prototype


• Build and test:


◦ Site production based on storyboards


◦ Technical and usability testing, recording bugs and design-change requirements


◦ Revision based on test results


◦ Technical and usability testing of revised site


◦ Final presentation to client and final revision


• Launch:


◦ Launch plan


Presentation: Web project production phases 1.6


16. Ask students to think about their widget and the design elements that would make it consistent. Some 
guiding questions:


• What font will you use for titles or headings?


• What color will you use for titles or headings?


• What font will you use for descriptions?


• What color will you use for the description font?


• How will your navigation bar and text navigation help visitors know where they are?


17. Introduce students to the interface, terminology, and basic panels and tools in Adobe Fireworks CS6. 
Briefly demonstrate how to create a wireframe in Fireworks, explaining that students will re-create a 
wireframe of their school’s website, showing where the widget will be placed on the page. A 


wireframe of the Spry Image Slideshow widget is included for students to use in this exercise.2.5 


Fireworks guide: Overview of Adobe Fireworks CS6 workspace


Fireworks guide: How to create a wireframe


Electronic file: slideshow_widget_wireframe.fw.png
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18. Allow students time to re-create a wireframe of the home page on their school website. 


19. Introduce the concept of a design comp, an electronic drawing that shows a detailed design of a web 


page or project. Show a sample design comp to discuss and emphasize the following:2.4


• Mood: A comp is the first impression of what a project will really look like. The comp should 
immediately convey an appropriate message, such as fun, serious, youthful, organized, trendy, or 
family-oriented.


• Color: Colors should be well coordinated, fit the mood and tone of the project, and provide enough 
contrast for legibility. Discuss web-safe colors and decide whether it’s appropriate for students to 
design only with web-safe colors. Time permitting, show Adobe Kuler (http://kuler.adobe.com) to 
students and explain how they can use this web service to create and save custom color palettes for 
any visual design project.


• Fonts: Vary fonts sparingly to be effective; consider how size and weight draw attention. Most 
web-based projects are designed with one or two fonts, using size, color, and boldface for further 
distinction. Make sure the contrast between the font and background colors is adequate to make 
the text legible. Discuss which fonts are common on Windows and Macintosh operating systems.


• Images: Images reflect content and mood. Photographs should be of highest quality. Text used 
with an image should be close enough to be visually associated with the image. An organization 
logo should be properly positioned, sized, and so on.


• Text: Web visitors are more likely to skim than to read carefully. The biggest challenge is to use 
only as much text as is necessary to convey key messages. Organize the text so visitors can scan it 
to find relevant information.


• Navigation elements: Buttons, menus, and navigation bars should all reflect the site’s mood and 
integrate effectively with site colors, fonts, and images.


Electronic file: spry_slideshow_widget_comp1.fw.png


Electronic file: spry_slideshow_widget_copm2.fw.png


20. Ask each student to make at least one design comp of the Spry Image Slideshow with Filmstrip, using 
Fireworks. 


Fireworks guide: How to create a design comp


21. After individuals have completed their comps, ask several students to share their design comps with 
the class for feedback. 


Guide: Peer review 2.6


Selecting and preparing images
(Suggested time: 50–100 minutes)


22. Explain that students need to select images to use in their slide-show widgets.


Note: You may want to supply images for students to select from or have students use digital cameras 
and take photographs of images around the school. You can use the following guides if you are asking 
students to take their own images: 


Guide: Introduction to digital photography
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23. Emphasize the importance of copyright and protecting one’s work by discussing copyright rules, fair-
use guidelines, and intellectual property. Instruct the students to investigate whether they need 
permission to use any of their images. Have them provide the appropriate type of copyright citations 
and have them copyright their own work.


Guide: Principles and rules of copyright 1.3


Note: Depending on your students’ knowledge of copyright issues, you might want to discuss some or 
all of the following: knowing when permission must be obtained; the difference between copyrighted 
material, fair use, intellectual property, and derivative works; and how to indicate that content is 
copyrighted.


24. Explain that most images need to be edited. Allow students time to edit their images in Adobe 
Fireworks CS6 or Adobe Photoshop CS6 and introduce them to the interface, terminology, and basic 
panels. Discuss and demonstrate the purpose of layers in both Photoshop and Fireworks.


Photoshop guide: Overview of the Adobe Photoshop CS6 workspace


25. Using the “I do, we do, you do” method, discuss and demonstrate the following techniques to help 
students make their pictures the best they can be for their slide shows:


• Navigating images: Demonstrate the tools for navigating images, rotating the canvas, and panning 
and zooming.


• Cropping and straightening: Use the Crop tool to remove unwanted elements of a photograph.


• Resizing: Use the image and canvas size tools to adjust the size of the image.


• Adjusting color: Use the tools in the adjustment panel to automatically correct color.


• Retouching: Use the Clone Stamp to remove unwanted elements, use the Spot Healing Brush to 
touch up small areas, or use the Red Eye tool to remove red eye.


• Resolution: Use Resolution Check to prepare the image for web output.


• Experimenting: Experiment and keep track of your changes by using the History panel and remove 
unwanted steps with the Undo panel.


Fireworks guide: How to prepare photographs


Photoshop guide: How to resize, rotate, and crop images


Photoshop guide: How to correct color


Photoshop guide: How to retouch photos


Photoshop guide: How to generate different file formats


Note: As you demonstrate the editing tools, you may want to discuss the idea of nondestructive editing 
and emphasize to students the importance of using adjustment layers, filters, and other methods for 
making edits to their photos without changing the original images.


26. Have students edit and size their images appropriately for both the slide-show images and their 
respective thumbnail images for the filmstrip. Explain that they also need to choose the order in which 
their images should appear in the slide show. The required sizes for the Spry Image Slideshow with 
Filmstrip are:


• Horizontal images: 800 px wide by 533 px high


• Vertical images: 533 px wide by 800 px high


• Horizontal thumbnails: 200 px wide by 133 px high
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• Vertical thumbnails: 133 px wide by 200 px high


Editing and customizing CSS rules
(Suggested time: 100–150 minutes)


27. Introduce students to the interface, terminology, and workspaces in Adobe Dreamweaver CS6. Using 
the “I do, we do, you do” method, discuss and demonstrate the following techniques:


• Identifying elements of the Dreamweaver interface


• Using the workspace switcher and customizing the Dreamweaver workspace


• Showing the views: Design, Code, Split, Live


• Creating a new document 4.3


Dreamweaver guide: Overview of Adobe Dreamweaver CS6 workspace 3.1, 3.6


28. Introduce the Adobe Dreamweaver Widget Browser. Explain that the Widget Browser is an application 
that lets you preview and configure widgets using a visual interface. You can use the Widget Browser 
to add widgets to Adobe Dreamweaver so you can easily insert them in your web pages. Demonstrate 
how to add the Spry Image Slideshow with Filmstrip to My Widgets. Demonstrate how to save the 
widget files to a computer. Demonstrate how to insert the Spry Image Slideshow with Filmstrip into a 
Dreamweaver HTML document and/or open the widget files from the saved location on the computer.


Dreamweaver guide: How to use the Adobe Dreamweaver Widget Browser


29. Explain that students will now insert their images. In Code or Split view, show students the location of 
the slide-show images. Using the “I do, we do, you do” method, demonstrate how to insert their 
images into the Spry Image Slideshow with Filmstrip and how to resize their images from within 
Dreamweaver. 


Dreamweaver guide: How to work with text and images 4.4, 4.5, 5.4


Dreamweaver guide: The Dreamweaver Insert panel 3.2


30. Remind students of when they looked at the school’s CSS. Explain that they will now change the font, 
text, color, borders, and so on in the Spry Image Slideshow with Filmstrip’s CSS style sheet according 


to their design comp.5.1


Note: Dreamweaver provides an option for customizing the widget from within the Widget Browser, 
but by doing so the students will not learn how to make direct changes to a CSS style sheet. You can 
mention that in the future students can customize the CSS styles in the widget from within the Widget 
Browser. 


31. Demonstrate how to open the widget’s Cascading Style Sheet file (basic_fs.css) from the CSS styles 
panel. Using the styles in the CSS file, go through the style features on the CSS Styles panel to show 
students the types of styles and rules used to create the CSS in the Spry Image Slideshow with 
Filmstrip widget.


Dreamweaver guide: How to create and edit a CSS rule 3.3, 5.1, 5.2, 5.8
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32. Ask your students to customize the basic_fs.css file according to their design comps. Ask students to 
select a style in the CSS Styles panel and make changes to an existing property. Then ask them to make 
a change to the features of the style to see how the change is implemented on the page. (They can click 
Apply to see changes without closing the dialog box if they use the Edit Style button.)


Note: Time permitting, have students create a new style and add it to the CSS file. 


33. Demonstrate how to use Live view to see how their widgets look and function according to changes 


they make to the CSS file. Encourage them to make any necessary revisions.5.2


Adding a customized widget to a web page
(Suggested time: 50–100 minutes)


34. Once the students have finalized their widgets, have them save their widget files. Explain that widgets 
are saved as Spry folders, with all relevant CSS, JavaScript, images, and so on.


35. Explain that students will now publish and/or display their widgets. Choose from several options, 
depending on time and resources. Have your students publish and/or display their widgets in one of the 
following ways: 


• If you don’t have access to a web server, have students use Preview In Browser to display the 
HTML page with their widget. Explain that to preview their widget in a web browser, they need to 
select File > Preview In Browser and select their preferred web browser. If they have not already 
saved their HTML file, they will be required to do so before previewing it. 


• Have students publish the blank HTML page with the inserted widget to a web server.


• Obtain the HTML file for your school’s home page and have students insert their widgets where 
they were intended to go based on their wireframes and either preview the home page or publish it 
to a web server. 


Dreamweaver guide: How to publish web files 6.5


Note: If you are preparing your students for the Adobe Certified Associate, Web Communication 
exam, publishing files to a remote server is a certification objective and should be covered here. 
However, students will also have the opportunity to publish a website in Project 3: Web development 
and deployment. 


Presenting their work
(Suggested time: 30–50 minutes)


36. Ask several or all of your students to present their widgets to the class, explaining where they would 
place the widget on the school’s home page, the reasons for the placement, and what customizations 


they made and why.2.6
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Extension activities


You can extend the project in the following ways:


• More design investigation: Add more graphic design exploration to this activity by having students use 
the Internet to find examples of each design principle.


• Research: To provide students with a deeper foundation in Cascading Style Sheets, you might have 
teams of students spend some time researching topics and then present their findings to the class. 
Topics could include the following:


◦ The emergence of CSS


◦ The current standards around CSS from the W3C


◦ The benefits of using CSS


• Student Seminar Introduction: You might ask a small student group to review Using Dreamweaver or 
the online Dreamweaver Support Center (in the Dreamweaver Help menu) to research how to set up 
the local site and root folder. This group can then report to the class the reasoning for setting up the site 
and why doing so is important.


• Reflection supplement: Ask students to write up the decisions they made in planning their widgets. 
This document will help students reflect on their process and provide a framework for the next time 
they plan a website.


• Interview: To help students better understand the importance of creating a wireframe for a website, 
find a web designer students can interview about the planning process.


• Technical Help in the Classroom: To encourage students to develop self-sufficiency when seeking 
help, you can assign a small group or pair of students to research challenging skills and present their 
findings to the class. Ask them to define key terms (such as optimization) and to explain the relevance 
of these terms to the task at hand. Then ask students to give a three- to five-minute oral report at the 
beginning of class, demonstrating the skill and reporting their findings.


• Fast finishers: For students who finish early, ask them to export their widget to Flash and build a 
mobile or tablet widget or have them publish their widget as a mobile application using Dreamweaver 
and PhoneGap (http://phonegap.com).


Assessment
• Project rubric


Background preparation resources
• Review the student step-by-step guides referenced in this project.


• To view video tutorials aligned with the skills required to complete this project, visit the Digital Design 
CS6 show on Adobe TV: http://tv.adobe.com/show/digital-design-cs6/


• For more teaching and learning resources on widgets and other topics in this project, search for 
resources from the community on the Adobe Education Exchange: 
http://edexchange.adobe.com


• For an overview of the interface and for more information on the technical aspects of Fireworks, see 
Fireworks Help. 


• For an overview of the interface and for more information on the technical aspects of Dreamweaver, 
see Dreamweaver Help. 
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• For an overview of the interface and for more information on the technical aspects of Photoshop, see 
Photoshop Help. 


• If needed, review this site with more information on copyright: http://fairuse.stanford.edu.


Widgets


• Explanation of widgets and free gallery: www.widgetbox.com/info/widgets/explanation/ and 
www.widgetbox.com/widgets/


• Introduction to widgets: www.webopedia.com/DidYouKnow/Internet/2007/widgets.asp


• Explanation of HTML snippets: http://support.sitekreator.com/html_snippet.html


• Daily listing of free web resources: www.webresourcesdepot.com


• Adobe Dreamweaver Widget Browser: http://labs.adobe.com/technologies/widgetbrowser/


• How to use the Dreamweaver Widget Browser: 
www.adobe.com/devnet/dreamweaver/articles/using_widget_browser.edu.html


• Explanation of the Spry framework: http://labs.adobe.com/technologies/spry/home.html


Photography


• Information on image composition for beginners: 
www.connectedphotographer.com/issues/issue200411/00001426001.html


• Tips on digital photography composition: 
http://digital-photography-school.com/blog/digital-photography-composition-tips


• A variety of information about digital cameras: 
www.malektips.com/digital_cameras_help_and_tips.html


• Links to tips for taking great pictures: 
www.kodak.com/ek/US/en/Consumer_Products/Tips_Projects_Center/Tips_from_the_Pros.htm


• Tips for image composition and definitions on the elements of visual design: 
http://photoinf.com/General/Robert_Berdan/Composition_and_the_Elements_of_Visual_Design.htm


Key terms
• Cascading Style Sheets (CSS)


• copyright


• design comp


• design principles


• HTML


• HTML5


• widget


• wireframe
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ISTE NETS*S Standard for Students


This project is aligned to the ISTE NETS*S Technology Standards. Depending on the subject and content 
area the student selects you may research your own state content standards to see how this project aligns to 
your state requirements.


ISTE NETS*S: Curriculum and Content Area Standards – NETS for Students


1. Creativity and Innovation


Students demonstrate creative thinking, construct knowledge, and develop innovative products and 
processes using technology. Students:


a. apply existing knowledge to generate new ideas, products, or processes.


b. create original works as a means of personal or group expression.


2. Communication and Collaboration


Students use digital media and environments to communicate and work collaboratively, including at a 
distance, to support individual learning and contribute to the learning of others. Students:


a. interact, collaborate, and publish with peers, experts or others employing a variety of digital 
environments and media.


3. Research and Information Retrieval


Students apply digital tools to gather, evaluate, and use information. Students:


b. locate, organize, analyze, evaluate, synthesize, and ethically use information from a variety of 
sources and media. 


4. Critical Thinking and Problem Solving


Students use critical thinking skills to plan and conduct research, manage projects, solve problems and 
make informed decisions using appropriate digital tools and resources. Students::


b. plan and manage activities to develop a solution or complete a project.


5. Digital Citizenship


Students understand human, cultural, and societal issues related to technology and practice legal and 
ethical behavior. Students:


a. advocate and practice safe, legal, and responsible use of information and technology.


6. Technology Operations and Concepts


Students demonstrate a sound understanding of technology concepts, systems, and operations. 
Students:


a. understand and use technology systems.


b. select and use applications effectively and productively.
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Adobe Certified Associate, Web Communication objectives


1.1 Identify the purpose, audience, and audience needs for a website.


1.2 Identify web page content that is relevant to the website purpose and appropriate for the target 
audience.


1.3 Demonstrate knowledge of standard copyright rules (related terms, obtaining permission, and citing 
copyrighted material).


1.5 Make website development decisions based on your analysis and interpretation of design 
specifications.


1.6 Understand project management tasks and responsibilities.


2.1 Demonstrate general and Dreamweaver-specific knowledge of best practices for designing a website, 
such as maintaining consistency, separating content from design, using standard fonts, and utilizing 
visual hierarchy.


2.3 Demonstrate knowledge of page layout design concepts and principles.


2.4 Identify basic principles of website usability, readability, and accessibility.


2.5 Demonstrate knowledge of flowcharts, storyboards, and wireframes to create web pages and a site map 
(site index) that maintain the planned website hierarchy.


2.6 Communicate with others (such as peers and clients) about design plans.


3.1 Identify elements of the Dreamweaver interface.


3.2 Use the Insert bar.


3.3 Use the Property inspector.


3.6 Customize the workspace.


4.1 Demonstrate knowledge of Hypertext Markup Language


4.3 Create, title, name, and save a web page.


4.4 Add text to a web page.


4.5 Insert images and apply alternative text on a web page.


5.1 Set and modify document properties.


5.2 Organize web-page layout with relative and absolutely positioned div tags and CSS styles.


5.4 Modify images and image properties.


5.6 Use basic HTML tags to set up and HTML document, format text, add links, create tables, and build 
ordered and unordered lists.


5.8 Use CSS to implement reusable design


6.5 Publish and update site files to a remote server.
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Assessment


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations


Website 
evaluation


Absent or incomplete. Website evaluation 
includes visual 
representation with 
copyright documentation, 
analysis of design features, 
and content validity. 


Website evaluation 
includes visual 
representation with 
copyright documentation.
Evaluations include a 
complete analysis of 
design features and content 
validity as they relate to 
effectiveness of site for its 
audience and purpose. 


Widget 
wireframe


Absent or incomplete. Wireframe re-creates 
school website and 
includes placement of 
widget. It is based on 
design principles and 
includes information on 
placement and navigation 
choices. Students clearly 
explain design decisions 
for the widget.


Wireframe re-creates 
school website and 
includes placement of 
widget. It is based on 
design principles and 
includes information on 
placement and navigation 
choices. Students clearly 
explain design decisions 
for the widget. 
Explanations also include 
synthesis of information 
from widget and website 
analysis.


Design comp Absent or incomplete. Student’s design comps 
accurately reflect audience, 
goals, color choices, mood, 
images, text, and 
navigation choices. The 
selected comps reflect a 
variety of approaches to 
the design. The design 
comps match the overall 
design of the website the 
widget is designed for. 


Student’s design comps 
accurately reflect audience, 
goals, color choices, mood, 
images, text, and 
navigation choices. The 
selected comps reflect a 
variety of approaches to 
the design. The design 
comps match the overall 
design of the website the 
widget is designed for and 
the students can clearly 
articulate the ways the 
design principles are 
implemented to impact the 
audience.


Image 
manipulation


Absent or incomplete. Student correctly uses 
color correction, selection 
tools, and retouching tools 
to manipulate images and 
focus the composition on 
the subject. Alterations to 
the image support the 
original meaning of the 
image.


Student correctly and 
appropriately uses color 
correction, selection tools, 
and retouching tools to 
manipulate images and 
focus the composition on 
the subject. Alterations to 
the image support the 
original meaning of the 
image.
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Widget Absent or incomplete. Student understands CSS 
styles and uses them to 
customize a widget. 
Student creates CSS styles, 
using a combination of 
redefined styles and new 
styles. Students publish 
their widgets on an HTML 
web page.


Student understands and 
clearly articulates CSS 
styles and their uses in 
customizing a widget. 
Student creates CSS styles, 
using a combination of 
redefined styles and new 
styles. Students publish 
their widgets on the school 
website.


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations
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Usability


Student name:_________________________________________________ Date: ________________________


URL: ________________________________________________________________________________________


Site name: ____________________________________________________________________________________


What types of navigation elements are used: buttons, hyperlinks, images, something else? One type or several? 
Describe each type of navigation element.


As you navigate, how many clicks does it generally take to get to information you are seeking?


As you navigate, do you get to the information you are expecting?
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Is the site structure apparent?


How long does it take for pages to load?


Does the website look the same in different browsers, on different operating systems, or on different devices?


Is the text readable? Is the text uniquely styled? If so, does the styling add value to the purpose?

Usability © 2012 Adobe Systems Incorporated
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What are the elements of the visual layout? How do these elements make it easier or more difficult for visitors?


Are there clear titles, headings, or other visual elements that specifically help organize the information?

© 2012 Adobe Systems Incorporated Usability 3
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Peer Review


Name: _______________________________________________________ Date: ________________________


Project: _____________________________________________________


Overview
Revision is an important part of the design process. In addition to conducting review and redesign cycles personally 
and with your client, you can also benefit from peer review. Additionally, peer review occurs in many professional 
environments and it will be good practice to start on this essential skill now.


When giving peer review, be sure your points are both positive and negative. Give your critiques as suggestions, not 
commands. When receiving peer review, do not be disenchanted or feel that you did a bad job based on one review. 
Every review is different, and what one person does not approve of, the next person may find exemplary.


Process for presenting work for peer review


• When presenting your work for peer review, state the purpose, audience, and goals of your document and 
point out any concerns you have.


• To conclude, summarize the reviewer’s suggestions and offer a plan for revision.


Guidelines for giving comments and suggestions


• Before making any comments, review the entire document and make sure you understand the designer’s 
intentions. Or, if being presented work by a designer, your first response should be to reiterate the designer’s 
purpose, audience, and goals.


• After the designer’s purpose, audience, and goals are clear, ask questions of the designer, make comments, 
and offer suggestions.


• Point out both the strengths and the weaknesses of the document (design, layout, typography, and so on).


• Offer suggestions, not commands. For instance, do not use “should,” as in “You should do this….” Instead, 
use “I” statements, such as “I see that…” or “I’m confused about....”


• Be respectful and considerate of your peer’s feelings. Do not say or write anything you wouldn’t want to 
receive yourself—there is no reason to be rude.


• Make sure your comments are clear and specific so your peer knows what you are referring to. It is 
important to give specific examples and point to design principles, image composition, layout guidelines, 
and so on to make your point. Such comments as “this is unclear” or “this is too vague,” are too general to be 
helpful. Rather make a comment like, “I’m confused by this image because there is no caption identifying 
what it is”).


• If you are writing your comments, reread them before passing them on to your peer. Make sure all your 
comments make sense and are easy to follow.
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How to create image maps
An image map is an image that has been divided into regions, or hotspots. When a visitor clicks a hotspot on your 
web page, an action occurs; for example, another web page opens. An example is a geographic map that links each 
country in the map to another page in your site or an external website containing information about that country.


Creating an image map
1. Start Adobe Dreamweaver CS6 and open the document 


in which you want to create an image map.


2. Make sure the Common category is selected in the Insert 
panel.


3. Click the down arrow on the Images button and select 
Image from the pop-up menu (Figure 1).


The Select Image Source dialog box opens.


4. Locate an image for the image map, select it, and click 
OK (Windows) or Open (Mac OS).


The Image Tag Accessibility Attributes dialog box opens.


5. Enter alternate text for the image, and then click OK.


The image is added to the page (Figure 2).


6. Select the image in the Document window. 


7. In the Properties panel, type a name for the image map in 
the Map text box.


Note: Naming conventions for image maps follow the 
same rules as filenames: no spaces or special characters.


Figure 1 Insert panel Images pop-up menu


Figure 2 Image added to document
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8. Select one of the hotspot tools located below the Map 
name, and draw a rectangle, circle, or polygon around a 
part of the image (Figure 3).


As soon as you begin drawing, you are prompted to enter 
an Alt tag for the hotspot.


9. Click OK, enter a descriptive name in the Alt text box in 
the Properties panel, and then finish drawing the hotspot.


10. After drawing your hotspot, add a link to a page in your 
site or to an external URL by using the Link text box 
(Figure 4).


Note: If you’re linking to a page outside of your site, it is 
a best practice to set the Target menu to 
target="_blank". This causes the link to open in a 
new browser window, so that the page doesn’t appear to 
be part of your site.


11. Repeat steps 8–10 to add other hotspots in the image 
map.


12. Save the page.


13. Select File > Preview In Browser and select a browser 
from the submenu to preview the page and test each link.


Figure 3 Image map drawn with the Polygon 
Hotspot tool 


Figure 4 Properties panel
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How to manage files and links by using the Files panel
The Files panel in Dreamweaver helps you manage files and links. Use the Files panel to open, add, rename, or delete 
files and folders. Use the Files panel to modify links.


Opening files
Use the Files panel to view and manage the files in your Dreamweaver site. 


To open a file:


1. In the Files panel (Window > Files), select a site, server, 
or drive from the Current Sites pop-up menu (Figure 1).


2. In the Local Files section, navigate to the file you want to 
open.


3. Do one of the following:


• Double-click the files's icon.


• Right-click (Windows) or Control-click (Mac OS) 
the file's icon, then select Open.


Note: If Check In/Check Out is enabled, Dreamweaver 
will check the file out before it opens the file. If another 
visitor has checked out the file, Dreamweaver will warn 
you about the file’s status and let you know who has it 
checked out. You can then decide whether to continue 
opening the file or not.


Figure 1 Dreamweaver Files panel 


Renaming files
When you rename a file in the Files panel, Dreamweaver can automatically change links that point to this file. For 
this reason, it is always preferable to rename site files by using the Files panel instead of renaming them on your hard 
disk.


To rename a file:


1. In the Files panel, select the file or folder you want to 
rename.


2. Do one of the following to activate the name of the file or 
folder:


• Click the name, pause, and then click again.


• Right-click (Windows) or Control-click (Mac OS) 
the file or folder icon, and then select Edit > 
Rename.


3. Type the new name over the existing name.


4. Press Enter (Windows) or Return (Mac OS).


If any site links point to the file or folder, the Update 
Files dialog box opens (Figure 2).


5. Click Update to change links that point to the renamed 
file or to a file in the renamed folder.


Figure 2 Update Files dialog box


Current Sites menu
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Deleting files
When you delete a file or folder, Dreamweaver will warn you if links in other documents point to the file or folder. 


To delete a file:


1. Click the file or folder in the Files panel you want to 
delete.


1. Press Delete.


If any site links point to the file or folder, the Delete Files 
warning opens (Figure 3), giving you the opportunity to 
change the links before you delete the file.


To delete the file anyway, click Yes. To cancel your 
request to delete the file, click No.


Figure 3 Delete files dialog box


Changing links to a file
You can also change links to a file through the Files panel. It is a good practice to change links before you delete a file 
to which other files are linked.


To change links to a file:


1. Select a file in the Files panel.


1. Select Site > Change Link Sitewide.


The Change Link Sitewide dialog box opens (Figure 4).


2. In the Into Links To text box, enter the name of the file to 
which new links should point.


3. Click OK.


The Update Files dialog box opens (Figure 5).


4. Click Update.


Figure 4 Change Links Sitewide dialog box


Figure 5 Update Files dialog box


Creating a new folder
Use folders to keep your site well organized. For example, most websites use a folder named images to store all the 
images for the site.


To create a new folder:


1.  Select the site root folder (or another folder in which you 
want to create a nested folder).

How to manage files and links by using the Files panel © 2012 Adobe Systems Incorporated
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2. In the Files panel menu (Figure 6), select File > New 
Folder.


Dreamweaver creates a new folder inside the selected 
folder. The folder name is selected.


3. Enter a name for the new folder and press Enter 
(Windows) or Return (Mac OS).


Figure 6 Files panel


Panel menu
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How to use the Assets panel
You can use the Assets panel in Dreamweaver CS6 to manage assets in the current site (Figure 1). The Assets panel 
displays assets for the site associated with the active document in the Document window. A library item is a special 
category of assets that can automatically update all instances of a library item whenever you edit the item


Figure 1 Assets panel with Site list displayed


The Assets panel provides two ways to view assets:


Site list shows all of the assets in your site, including colors and URLs that are used in any document in your site.


Favorites list shows only the assets you’ve explicitly chosen. To switch between these two views, select either 
the Site or Favorites radio button above the preview area. (These two views are not available for the Templates 
and Library categories.)


In both lists, assets fall into one of the following categories: 


Images image files in GIF, JPEG, or PNG formats.


Colors colors used in documents and style sheets, including colors of text, backgrounds, and links.


URLs external links in your current site documents, including FTP, gopher, HTTP, HTTPS, JavaScript, e-mail 
(mailto), and local file (file://) links. 


Flash files in any version of Adobe Flash. The Assets panel displays only SWF files (compressed files created 
with Flash), not FLA (Flash source) files.


Shockwave files in any version of Adobe Shockwave.


Movies QuickTime or MPEG files.


Scripts JavaScript or VBScript files. Scripts in HTML files (rather than in independent JavaScript or VBScript 
files) do not appear in the Assets panel.


Templates master page layouts used on multiple pages. Modifying a template automatically modifies all pages 
attached to it.


Library items design elements that you use in multiple pages; when you modify a library item, all pages 
containing that item are updated.


Asset categories:


Insert button


Edit button


Preview area


Images
Colors


URLs
SWF 


Shockwave


Movies


Scripts


Templates


Library
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By default, assets in a category are listed alphabetically by name, but you can sort them by type and several other 
criteria. You can also preview assets and resize the columns and the preview area.


Add an asset to a document
You can insert most assets into a document by dragging them into Code view or Design view in the Document 
window, or by using the Insert button in the Assets panel. You can either insert colors and URLs or apply them to 
selected text in Design view. (URLs can also be applied to other elements in Design view, such as images.)


To add an asset to a document:


1. Start Dreamweaver.


2. In Design view, place the insertion point where you want 
the asset to appear.


3. In the Assets panel, select from the asset category buttons 
at the left (Figure 1).


Note: Select any category except Templates. A template 
is applied to an entire document; it can’t be inserted into a 
document.


4. Select either Site or Favorites at the top of the panel, then 
select the asset.


5. Do one of the following:


• Drag the asset from the panel to the document 
(Figure 2). 


You can drag scripts into the head content area of the 
Document window; if that area isn’t visible, select 
View > Head Content.


• Select the asset in the panel and click the Insert 
button.


If the inserted asset is a color, it applies to text 
appearing after the insertion point. 


6. If you are adding an image asset, and enabled 
Accesibility preferences (Edit > Preferences > 
Accessibility in Windows, Dreamweaver > Preferences > 
Accessibility in Mac OS), you will be presented with the 
Image Tag Accessibility Attributes dialog box. Enter a 
description of the image in the Alternate Text box.


Figure 2 Drag asset from the Assets panel to the 
document window


Figure 3 Accessibilty dialog box


Edit an asset
When you edit an asset in the Assets panel, the behavior varies according to the asset type. For some assets, such as 
images, you use an external editor, which opens automatically if you have defined an editor for that asset type. You 
can edit colors and URLs in the Favorites list only. When you edit templates and library items, you make the changes 
within Dreamweaver.
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To edit an asset:


1. In the Assets panel, do one of the following:


• Double-click the asset.


• Select the asset, then click the Edit button. 


Note: If the asset must be edited in an external editor 
and one doesn’t open automatically, select Edit > 
Preferences (Windows) or Dreamweaver > 
Preferences (Mac OS), select the File Types/Editors 
category, and define an external editor for that asset 
type.


2. Make your changes.


For example, in Figure 4, Fireworks opens in order to 
edit a selected button asset.


3. When you finish, do one of the following:


• If the asset is file-based (anything other than a color 
or URL), save it (in the editor you used), and close 
the external editor.


• If the asset is a URL, click OK in the Edit URL 
dialog box.


Note: If the asset is a color, the color picker closes 
automatically after you pick a color. To dismiss the 
color picker without picking a color, press Esc.


The file is saved and updated within the Assets panel.


Figure 4 Editing a button in Fireworks


How to use libraries
You can use a library in Adobe Dreamweaver CS6 to store page elements such as images, text, sounds, or tables you 
want to reuse throughout your website (Figure 5). When you insert a library item, Dreamweaver inserts a link to the 
library item. If you later need to make changes to a library item, such as changing some text or an image, updating the 
library item automatically updates each instance of the item on every page into which you’ve inserted it.


Figure 5 Assets panel, Library category


Library button


Insert button


New Library Item


Edit button


Delete button
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Creating a library item


You create library items out of existing page elements.


To create a library item:


1. In the Document window, select the element (such as an 
image or text) to save as a library item.


2. In the Assets panel, click the Library button.


3. Click the New Library Item button  at the bottom of the 
panel (Figure 5).


4. Type a name for the new library item, then press Enter 
(Windows) or Return (Mac OS). (Figure 6).


Dreamweaver saves each library item as a separate file 
(with the file extension .lbi) in the Library folder of the 
site’s local root folder.


Figure 6 Naming a new library item


Inserting a library item


Once an item is added to the Library, you can insert it onto a page.


To insert a library item:


1. Position the insertion point in the Document window 
where you want to insert a library item.


2. In the Assets panel, click the Library button.


3. Drag a library item from the Assets panel to the 
Document window, or select an item and click the Insert 
button at the bottom of the panel (Figure 7).


Figure 7 Inserting a library item on a page


Editing a library item


Library items can be edited in their own window. The changes you make then apply to the library item everywhere 
you have previously inserted it.


To edit a library item:


1. In the Assets panel, click the Library button.


2. Select a library item.
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3. Click the Edit button at the bottom of the Assets panel.


Dreamweaver opens a new window for editing the library 
item (Figure 8). This window is much like a Document 
window. You can tell it is a library item by the .lbi 
filename extension on the document’s tab.


4. Edit the library item and then save your changes.


The Update Library Items dialog box opens, with a list of 
the files that use the library item (Figure 9).


5. Click Update to replace the original library item with 
your edited version in the files that use the library item. 


The Update Pages dialog box opens.


6. To see a report on the updating process, make sure Show 
Log is selected (Figure 10).


7. Click Close.


Figure 8 Library editing window


Figure 9 Update Library Items dialog box


Figure 10 Update Pages report
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Updating all documents to use current library items


If you do not choose to update documents that use library items as you edit individual library items, you can later 
update all pages in the site with the current version of all library items.


To documents to use current library items:


1. Select Modify > Library > Update Pages.


The Update Pages dialog box opens (Figure 11).


2. From the Look In pop-up menu, select Entire Site, and 
then select the site name from the adjacent pop-up menu. 


3. Make sure Library Items is selected in the Update 
section. 


4. Click Start.


Dreamweaver updates the documents and provides a 
report on the updating process (Figure 12). If you have 
updated documents at the time you edited library items, 
this report confirms that no additional updating was 
required.


5. Click Close.


Figure 11 Update Pages dialog box


Figure 12 Update Pages report
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Design document


Student name:_________________________________________________ Date: ________________________


URL: ________________________________________________________________________________________


Site name: ____________________________________________________________________________________


Project overview
List site challenges and proposed solutions. If possible, include examples from other sites that deal effectively with 
the listed challenges.


List site goals:


List site objectives:


List site messages:
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Provide a brief description of the intended audience for this site:


Delivery requirements
List the delivery requirements for this site (browsers supported, devices supported, minimum connection speed). Be 
sure to include any constraints the delivery requirements place on the site content.
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Site content
Give an inventory of the home page and content pages, including standard structures on the pages. Be sure to indicate 
the use of tables, headings, and indentation to maintain page structure consistency and hierarchy.


Site stucture
Draw a site map.
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Creative design
Use this space to brainstorm for font and color options, and design comps by sketching ideas by hand. Use these 
initial visual ideas as a foundation for your digital wireframes and website design comps.
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How to design for usability
Good web usability is defined as: easy to use, quick to learn, and providing an overall satisyfying experience. A well-
designed, usable site aims to enhance the user experience by elevating a website’s percieved efficiency, elegance, and 
clarity.


Usability is a combination of factors including design, information architecture, accessibility, and support across 
various devices. Usability.gov (usability.gov/basics/index.html) provides a list of these important factors:


• Ease of learning How fast can a user who has never seen the user interface before learn it sufficiently well to 
accomplish basic tasks?


• Efficiency of use Once an experienced user has learned to use the system, how fast can he or she accomplish 
tasks?


• Memorability If a user has used the system before, can he or she remember enough to use it effectively the 
next time or does the user have to start over again learning everything?


• Error frequency and severity How often do users make errors while using the system, how serious are these 
errors, and how do users recover from these errors?


• Subjective satisfaction How much does the user like using the system?


Compare the two Coast Middle School examples shown in Figure 1. The before and after screenshots demonstrate 
the difference between poor web usability, and a subsequent site redesign that results in much-improved user 
experience.


Figure 1 Examples poor web usability (left) and improved web usability (right)


Consider the following as you plan the content and navigation of your website project.


Content
How you organize content on a page highlights important features and elements of your site. Important elements 
might be higher in the page, larger in size, or in stronger colors. Include rough descriptions of navigation, copy 
layout, graphic allocation, key headers, and other elements that appear on a screen. Identifying common structures 
between pages helps visitors understand they are in the same site as they navigate from page to page.


• Will your page banner be on each page? If yes, is it in the same place? Is it the same size?


• What font will you use for titles or headings on your content pages?


• What color will you use for titles or headings on your content pages?
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• What font will you use for descriptions on your content pages?


• What color will you use for descriptions?


Navigation
For visitors of your website to understand the content, you must provide clear navigation. Visitors need to know 
where they are in a site, where they need to go, and how to get back to where they came from. Having a consistent 
layout grid helps orient visitors and keeps them from feeling lost. Using consistent buttons, links, and graphics on 
each page maintains a sense of place. As visitors move from page to page, provide familiar visual cues and 
navigational aids.


• Where will you place the navigation bar on the page?


• What content will be on the navigation bar?


• Will the navigation bar be on every page?


• How will your navigation bar help visitors know which page they are on?


Resources
Get more information about web usability best practices from these resources:


• usability.gov is the primary government source for information on usability and user-centered design.


• www.useit.com website for leading web usability consultant, Jakob Nielsen.
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Review and redesign


Student name:_________________________________________________ Date: ________________________


The questions on this worksheet will help you think about reviewing and redesigning your web project.


Questions are in the following categories:


• Meeting initial goals


• Requiring new goals


• Reflecting good design principles


• Reflecting good usability and accessibility principles


• Maintaining consistency


• Producing web projects that work equally well on various operating systems, browser versions/configurations, 
and devices


• Planning redesign changes


Meeting initial goals
What were your initial goals for the web project?


Does the web project you built match the initial goals? Why or why not?
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Requiring new goals
Do you have new goals in mind for the web project? If so, what are these and why are you changing your goals?


Reflecting good design principles
What design elements and principles did you originally incorporate into the web project?


Do you want to include new design elements or principles in your web project? If so, what are they and why do you 
want to include them?


Reflecting good usability and accessibility principles
What usability and accessibility principles did you originally incorporate into the web project?
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What changes do you need to make to better reflect the best practices for producing a web project that is highly 
usable and accessible?


Maintaining consistency
What techniques did you use in your web project to maintain consistency?


What changes do you need to make to better reflect the best practices for maintaining consistency?


Producing web projects that work equally well on various operating systems, browser 
versions/configurations, and devices
What operating systems, browsers, and devices did you target for your web project?
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What techniques did you use to make sure your web project worked well on the targeted operating systems, browsers, 
and devices?


What changes do you need to make to increase the usability of your web project on the targeted operating systems, 
browsers, and devices?


Are there additional operating systems, browsers, or devices your would like your web project to work well on? If so, 
what are they and why do you want to include them? What new techniques will you have to use or changes will you 
have to make to deliver your web projects on the additional operating systems, browsers, and devices?


Planning redesign changes
Based on how you answered the questions above, what changes do you need to make to your web project? Sketch 
your changes below in addition to writing about them.
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Sketch of design changes
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How to deploy for multiple screens
Ethan Marcotte, a developer in Boston, coined the phrase responsive design to describe a website that adapts to the 
size of the viewer’s screen. A demonstration site built by Ethan Marcotte illustrates this concept; visit http://
www.alistapart.com/d/responsive-web-design/ex/ex-site-FINAL.html to experience responsive design (Figure 1). 
Notice that as you narrow the width of the browser window, the text reflows and the images get slightly smaller. Once 
the browser window is less than 1300 pixels wide, the images stack into two rows but continue to become smaller as 
the window narrows. When the browser narrows to 600 pixels, the content again reflows. The navigation bar moves 
to the top of the page and the image behind the logo disappears. This is all being done through percentage-based 
widths for content known as a flexible grid. For viewers, it means the content will always be properly formatted to fit 
the screens or devices on which they are viewing the it.


Figure 1 A responsive design website at three browser widths


Adobe Dreamweaver CS6 streamlines the task of building responsive design websites for multiple screens with its 
integrated Fluid Grid Layouts and CSS media queries. Dreamweaver uses Fluid Grid Layouts to create designs that 
scale themselves to multiple screen sizes and devices. CSS3 Media Queries is a more advanced option used to define 
custom CSS files for mobile, tablet, and desktop devices, permitting device-specific user interfaces to be built on the 
same HTML markup.  


Fluid Grid Layouts
Fluid Grid Layouts provides for flexible content resizing within a browser window. The browser on a device checks 
the embedded media query and uses the corresponding CSS code to display the web page. You can create a new 
document that works across multiple screens by using the Fluid Grid Layouts option (Figure 2). 


Figure 2 New Document dialog box, Fluid Grid Layout category
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To create a Fluid Grid Layout:


1. Start Dreamweaver. 


2. Select File > New Fluid Grid Layout.


The New Document dialog box appears (Figure 2).


3. In the Mobile, Tablet, and Desktop text boxes, set the 
number of grids to 2, 3, and 4, respectively.


4. Under Mobile, set the % Of Column Width to 10.


This number defines the gutter or space between each 
pair of columns in the grid.


5. Set the overall width percentage of the Mobile, Tablet, 
and Desktop layouts to 100, 100, and 88, respectively.


The grid widths are 100% for the mobile phone and tablet 
layouts. On the desktop, the width of the grid is 88%, 
which means that it will fill out 88% of the browser 
window and center the content, with equal space (6%) on 
each side.


6. Click Create. 


The Save Style Sheet File As dialog box appears 
(Figure 3).


7. Save the CSS file as grids.css in your site root folder.


The layout opens in Design view.


8. Select File > Save and save the document as grids.html 
in your site root folder.


The Copy Dependent Files dialog box appears. The files 
boilerplate.css and respond.min.js work together to  
normalize and adjust the content to display across many 
devices.


9. Click Copy in the Copy Dependent Files dialog box.


The layout is currently set to Mobile. In turn, click the 
Tablet icon and the Desktop icon in the Status bar at the 
bottom of the Document window (Figure 5) to compare 
the Fluid Grid Layouts.


10. Click the Mobile icon to switch back to the two-column 
Mobile layout.


It is a best practice in responsive design to focus on 
“mobile first,” because this format forces you to 
concentrate on content first, visual design second. 


Notice that one block of content is already in place at the 
top of the layout (Figure 6).


Figure 3 Save Style Sheets File As dialog box


Figure 4 Copy Dependant Files dialog box


Figure 5 Status bar


Figure 6 Fluid Grid Layout, Mobile layout


Mobile icon Tablet icon Desktop icon


Layout div 
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11. Open the Properties panel (Window > Properties).


12. In Design view, click the outline of the layout div 
(Figure 6) to select it.


The Div ID information appears in the Properties panel 
(Figure 7).


13. Enter header in the Div ID name text box.


14. Open the Insert panel (Window > Insert), if it is not 
already open.


15. Select Layout from the Category pop-up menu.


16. Click the Insert Fluid Grid Layout Div Tag button 
(Figure 8).


The Insert Fluid Grid Layout Div Tag dialog box appears 
(Figure 9).


17. Enter nav in the ID text box.


18. The option Start New Row is selected by default. 


This tells Dreamweaver and the browser to make this 
content fill the entire width of the current grid layout. 
Deselecting this option allows the element to float beside 
another element on the page. 


19. Click OK to insert the div tag into the page.


A Fluid Grid Layout div is nothing more than an HTML 
<div> element with a unique ID assigned to it.


20. Click the Insert Fluid Grid Layout Div Tag button to 
insert another Fluid Grid Layout div into the page and 
rename it content. 


You now have three stacked divs (labeled Header, Nav, 
and Content) across two columns in the Mobile layout 
(Figure 10).


21. Click the Tablet icon (Figure 5) to switch to the Tablet 
layout.


22. In Design view, click to select the Nav div.


23. Drag the right handle to narrow the width of the div to fill 
only the left column (Figure 11).


24. Click to select the Content div, and resize it to span two 
columns. 


Figure 7 Properties panel


Figure 8 Insert panel, Layout category


Figure 9 Insert Fluid Grid Layout Div Tag dialog 
box


Figure 10 Three divs across two columns


Figure 11 Resize div in Design view


Div ID name text box
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25. Click the Move Up A Row button on the right side of the Content div (Figure 12).


The Content div moves up a row, beside the Nav div (Figure 13).


Figure 12 Divs in Tablet layout, before move


Figure 13 Divs in Tablet layout, after move


26. Click the Desktop icon (Figure 5) at the bottom of the Document window to switch to the Desktop layout.


27. Arrange the divs so the Nav div spans one column and the Content div spans the remaining three columns in the 
four-column Desktop layout (Figure 14). 


You may need to scroll to see the right ends of the divs.


Figure 14 Divs in Desktop layout


28. Click grid.css in the Related Files bar at the top of the 
document window (Figure 15).


Split view opens, showing grids.css in Code view.


29. Scroll in Code view to locate the beginnings of the 
Mobile, Tablet, and Desktop layout code sections (at 
about lines 29, 58, and 89, respectively) (Figure 16).


Each time you add a Fluid Grid Layout div element to the 
page, a rule is created in the CSS for each device. Notice 
the “@media” declarations, which indicate the beginning 
of a media query. The Tablet media query, appears at 
about line 60, and it only applies when a screen has a 
width of at least 481px–in other words, most mobile 
phones would ignore these rules because their screens are 
not that wide.


30. Select File > Save All to save the document and the 
dependent files.


Figure 15 Related Files bar


Figure 16 CSS code view detail


Move Up A Row
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Preview layout
Once you’ve established a suitable Fluid Grid Layout for your content across all of the devices, you can add content 
and preview it by using the Multiscreen Preview function in Dreamweaver (Figure 17).


Figure 17 Multiscreen Preview panel


To preview the Fluid Grid Layout:


1. Use the Insert panel to add an assortment of graphics, 
text, and links to the grid.html file. You can fine-tune the 
layout of page elements by using the CSS panel.


2. Toggle among the Mobile, Tablet, and Desktop layouts to 
compare them (Figure 18). 


Figure 18 Content in Mobile layout
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3. Click the Multiscreen button in the Control panel at the 
top of the Document window (Figure 19).


The Multiscreen Preview panel opens (Figure 17).


Multiscreen Preview supports the following screen types:


• Phone (default screen size: 320 x 300 pixels)


• Tablet (default screen size: 768 x 300 pixels)


• Desktop (default screen width: 1126 pixels)


Note: If you know the dimensions of any other devices 
you want to target, you can specify additional 
orientations and styles for different devices by using the 
Design/Live View Sizes menu (Figure 20). For example, 
you can create a screen dimension of 480 x 272 pixels for 
a Sony PSP device.


The phone, tablet, and desktop dimensions used for 
previewing are set to default sizes. However, you can 
change the default sizes by clicking the Viewport Sizes 
button in the Multiscreen Preview panel.


Note: Do not use the Multiscreen Preview panel as a 
browser. It is not intended to display dynamic media such 
as movies and audio clips.


Figure 19 Control panel


Figure 20 Design/Live View Sizes menu


Design/Live View Sizes menu
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CSS Media Queries
CSS media queries extends the concept of Fluid Grid Layouts. Advanced users might consider using CSS3 media 
queries to target designs for multiple devices by specifying a different CSS file for each unique device.


You can access the Media Queries dialog box (Figure 21) by using the Design/Live View Sizes menu (Figure 20). 


Note: The Media Query Manager is not currently compatible with Fluid Grid Layouts.


Figure 21 Media Queries dialog box


For more detailed information about media queries, please see Dreamweaver Help.
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How to lay out a web page with CSS
A CSS page layout uses the Cascading Style Sheets format, rather than traditional HTML tables or frames, to 
organize the content on a web page. The basic building block of the CSS layout is the div tag—an HTML tag that in 
most cases acts as a container for text, images, and other page elements. When you create a CSS layout, you place div 
tags on the page, add content to them, and position them in various places. Unlike table cells, which are restricted to 
existing somewhere within the rows and columns of a table, div tags can appear anywhere on a web page. You can 
position div tags absolutely (by specifying x and y coordinates), or relatively (by specifying their distance from other 
page elements). You can also position div tags by specifying floats, paddings, and margins—the preferred method by 
today’s web standards.


Creating CSS layouts from scratch can be difficult because there are so many ways to do it. You can create a simple 
two-column CSS layout by setting floats, margins, paddings, and other CSS properties in a nearly infinite number of 
combinations. Additionally, the problem of cross-browser rendering causes certain CSS layouts to display properly in 
some browsers and improperly in others. Dreamweaver makes it easy for you to build pages with CSS layouts by 
providing 16 pre-designed layouts that work across different browsers.


Using the pre-designed CSS layouts is the easiest way to create a page with a CSS layout, but you can also create CSS 
layouts by using absolutely-positioned elements (AP elements). An AP element in Dreamweaver is an HTML page 
element—specifically, a div tag or any other tag—that has an absolute position assigned to it (Figure 1). The 
limitation of Dreamweaver AP elements, however, is that since they are absolutely positioned, their positions never 
adjust on the page in relation to the size of the browser window.


Once you become more experienced you will be able to create page layouts by inserting div tags manually and 
applying CSS positioning styles to them.


Figure 1 AP elements in the Dreamweaver Document window


Inserting an AP div tag
Start this activity by creating a new, blank page and inserting an AP div tag. AP elements can contain text, images, or 
any other content that you can place in the body of an HTML document.
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To insert an AP div tag:


1. Start Dreamweaver.


2. Select File > New.


The New Document dialog box opens (Figure 2).


3. With the Blank Page category selected, click HTML 
under Page Type and <none> under Layout.


4. Click Create.


A new untitled HTML document opens.


5. Save the new page.


The new file is added to the Files panel.


6. Select the Layout category in the Insert panel and 
confirm the Standard mode button is selected (Figure 3)


7. Click the Draw AP Div button.


The mouse pointer chanages to a cross when you move it 
over the Document window.


8. To create the div that will define an area of your page, 
drag a rectangle in the Dreamweaver document. 


9. Click the border of the div to select it.


Handles appear along the border (Figure 4) and the div 
properties appear in the Properties panel. 


Figure 2 New Document dialog box


Figure 3 Insert panel, Layout category


Figure 4 Div inserted and selected
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10. Make sure the Properties panel is open (Figure 5). 


It is docked at the bottom of the screen. If the Properties 
panel is not open, select Window > Properties.


11. Click in the CCS-P Element ID box and enter a name for 
the div. 


Choose a unique name that will help you remember the 
div’s contents, such as header or navigation.


Note: “CSS-P” is a commonly accepted abbreviation for 
“CSS Positioning”.


12. Click the Bg Color box and select a color in the color 
picker. 


The div changes to the selected color. 


13. Click once outside the new div to deselect it. 


A thin black line appears around the div. This line does 
not appear in a browser. If you do not see the line, select 
View > Visual Aids > CSS Layout Outlines.


14. Continue adding divs for all the sections on your page. 
You can place divs directly alongside one another 
(Figure 6).


15. Open the AP Elements panel (Window > AP Elements).


You’ll see that Dreamweaver has added the new divs to 
the list of AP Elements (Figure 7). 


Note: Select Prevent Overlaps to constrain the positions 
of AP elements when they are created, moved, and 
resized, so that they don’t overlap.


16. Save your page.


Figure 5 Properties panel


Figure 6 Multiple divs on page


Figure 7 AP Elements panel


Resizing divs
You can resize an individual div or simultaneously resize multiple divs to make them the same width and height.


Note: If the Prevent Overlaps option is selected in the AP Elements panel, you will not be able to move a div so that 
it overlaps another div.


CSS-P Element ID box
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To resize a div:


1. Select a div by clicking its border or by clicking the div’s 
name in the AP Elements panel.


2. Do one of the following to resize the div:


• To resize by dragging, drag any of the div’s resize 
handles (Figure 8).


• To resize one pixel at a time, hold down Control 
(Windows) or Option (Mac OS) while pressing an 
arrow key.


Note: The arrow keys move the right and bottom 
borders of the div; you can’t resize the top and left 
borders with this technique.


• In the Properties panel, type values for width (W) 
and height (H).


Figure 8 Resize by dragging


Moving divs
You can move divs in Design view in much the same way you move objects in most basic graphics applications.


Note: If the Prevent Overlaps option is selected in the AP Elements panel, you will not be able to move a div so that 
it overlaps another div.


To move a div:


1. Select one or more divs.


2. Do one of the following:


• To move by dragging, drag the div’s selection handle 
(Figure 9).


• To move one pixel at a time, use the arrow keys.


Figure 9 Moving a div


Adding content to divs
You can add images, text, and other content (such as Flash movies) to your divs just as you would elsewhere in a web 
page.


To add content to a div:


1. To insert an image in a div, click in the div and select 
Insert > Image.


Note: Make sure the div is sized large enough to hold the 
image or other content. If the div is sized smaller than the 
image, the div may not display correctly in all browsers.


Div resize handle


Selection handle
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2. In the Select Image Source dialog box, locate and select 
an image to insert (such as a page banner). Then click OK 
(Windows) or Open (Mac OS).


The image appears in the div (Figure 10).


3. To format the image in the div, select the image and 
select formatting elements in the Properties panel.


4. To add text to a div, click in the div and type text or paste 
text copied from another document.


Figure 10 Div with image added


Viewing div tags by using Live view
You can use a feature called Inspect mode in Live view to view the code generated by adding the div tags.  


To view div tags using by using Inspect mode in Live view:


1. Click the Live button in the Control panel (Figure 11).


Live view is enabled. This means that the page appears as 
it will in a web browser.


2. Click the Live button again to deactivate Live view.


3. Click the Split button. 


Code and Design view (Split view) view is enabled. This 
lets you see the code alongside the design display. 


4. Click the Live button again to activate Live Code view.


5. In the Design view, click on a div’s selection handle, or 
an image placed within a div and observe that the div tag 
is highlighted in the Code view (Figure 11).


Figure 11 Split Code/Live view


DivHighlighted tag


Live button
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Design review


Student name:_________________________________________________ Date: ________________________


Design team name:_____________________________________________


Client name: __________________________________________________


Client URL: __________________________________________________


Summary


After understanding the client’s goals and audience, conduct a design review of the client’s website:


• One team member summarizes the client’s audience, purpose, and goals to confirm the group’s understanding.


• The team evaluates the strengths of the site’s design. Consider the following design elements:


◦ Consistency


◦ Ease of use


◦ Use of color


◦ Universal navigation


◦ Layout


◦ Links


◦ Usability


◦ Accessibility


◦ Mobile device considerations


• The team discusses improvements they would suggest to the site design.


• One team member summarizes the strengths of the site.


Consistency


What elements are repeated on content pages to help identify the entire site?
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How does the repetition help or hinder the overall purpose of the website?


When coming to the site, how do visitors know where they are, where they can go next, and whether they remain in 
the same site as they go from page to page?


How well do the pages comply with web standards (for example, are links blue and underlined)?


Universal navigation


Where is the main navigation for the site located, and how consistent is it from page to page?
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How do visitors return to the home page from every other page in the site?


How do visitors control their movement in the site (for example, is there always a way to return to the previous page 
they visited)?


Layout


Is the page layout logical or does the design look randomly placed?


How does the relative size and placement of text and images imply relative importance?
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How often do you need to scroll down the page to find important elements?


If there are images, how clear are they?


How do images add value to the content or are they only for decoration and appeal?


How does the color scheme contribute to the purpose or tone of the site?
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Usability


How clearly are links labeled?


Is the time it takes for a page to load worth the wait?


How easily are visitors able to find information?


How easily are visitors able to return to essential sections of the site (if at all)?
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Accessibility


Are all images labeled with alternative text?


To what extent are the text and titles clear and easy to read for all visitors (color, size, and so on)?


Do image links and hotspots (image maps) have alternative text?


Mobile device considerations


Does the website properly display on the screen size of the target mobile devices?
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Is the website content optimized for the screen size of the target mobile devices? 


Is the time it takes for the website to load on the target mobile devices worth the wait?
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How to troubleshoot Cascading Style Sheets
While CSS provides lots of advantages for specifying page appearance, you can run into problems with how pages 
appear, especially when you have multiple tags applied to the same text. This guide offers some ways to troubleshoot 
problems with CSS.


Using the Tag selector
The Tag selector is located in the Status bar and shows, in hierarchical order, the tags that apply to the currently 
selected page element. You can then click any tag in the hiearchy to see everything contained by the tag.


To use the Tag selector:


1. Select text, an image, or another page element. 


The Tag selector displays tags that apply to the selection. 
In the example (Figure 1), the selected text (interpreting 
the tag list from right to left) is bolded (<strong>), a list 
item (<li>), part of an unordered list (<ul>), within a div 
named maintext. (All page elements are contained within 
<body>.)


2. Click one of the tags to see what it contains (Figure 2).


Figure 1 Tag selector in the Status bar at the 
bottom of the Document window


Figure 2 Contents of selected tag
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Coloring divs to diagnose layout problems 
When you use divs for page layout, it can help to add a different background color to each element on the  page. With 
different background colors added to each element, you can spot problems such as overlapping elements or elements 
that are rendering differently than you intended them to. For example, the page in the example (Figure 3) has text that 
is misaligned, gaps in the page border, and other problems. Because all elements in the middle section have the same 
background color (white), it is difficult to tell which div is causing the problem.


Figure 3 Page with CSS layout problems


Adding different background colors to all divs (Figure 4) lets you see that the div containing the image overlaps the 
left column of text, and is overlapped by the div below it. You can then correct the problems by changing the 
dimensions of the div containing the image, and making other changes.


Figure 4 Background colors added to divs
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To add background colors to div tags:


1. Start Dreamweaver and open a file that uses CSS and 
absolutely positioned div elements.


2. Open the CSS Styles Panel (Window > CSS Styles).


3. Repeat the following steps for each div:


a. Double-click the CSS rule corresponding to the div 
tag to open the CSS Rule Definition dialog box.


b. Select Background  in the Category pane (Figure 5).


c. Select a background color from the color picker.


d. Click OK.


The background color is applied to the selected div. Figure 5 Setting background color
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How to use CSS text styles
Web typography is an important creative tool web designers use to express style and emotion that enhances the goal 
and overall message of a website. 


Image-based text gives you control of your web typography, but several limitations have led to the decline of this 
approach: increased file size, decreased accessibility, problems with search engine discoverability, and practical 
limitations on the amount of text.


Cascading Style Sheets provide a higher level of styling control over web typography, without the drawbacks of 
image-based test. With CSS, web page text results in smaller file size, greater accessibility, and improved usability 
across devices, browsers, and platforms. CSS specifies a series of font properties for a web browser to use when 
displaying text in a web page. 


Web designers seeking a broader font selection or more expressive typography (Figure 1) may choose to use web 
fonts. Web fonts are temporarily downloaded to display text in fonts that site visitors don’t need installed on their 
computers. 


Figure 1 Example of a website using web fonts: http://lostworldsfairs.com/moon/
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Changing text styles
To understand web fonts betters, consider how fonts are defined by using CSS. CSS font properties define the font 
family, boldness, size, and style of text. A font declaration for an HTML paragraph tag looks something like this:


Changing text styles for web pages is easy in the CSS Styles panel.


To change text styles:


1. Start Dreamweaver.


2. Open a document in which you want to edit a CSS font 
property.


3. Open the CSS Styles panel (Window > CSS Styles), if it 
isn’t already open (Figure 2).


4. Double-click an existing rule or property in the top pane 
of the CSS Styles panel.


The CSS Rule Definition dialog box appears (Figure 3).  


5. Change or specify any of the following properties in the 
dialog box. If a property is not important to you, don’t 
select or enter a value for that property.


Font-family sets the font family (or series of families) for 
the style. Browsers display text in the first font in the 
series that is installed on the viewer’s system. 


Font-size defines the size of the text. You can choose a 
specific size by selecting the number and the unit of 
measurement, or you can choose a relative size.


Font-style provides the options Normal, Italic, and 
Oblique. 


Line-height sets the height of the line on which the text is 
placed. This setting is traditionally called leading. 


Text-decoration adds an underline, overline, or line-
through to the text, makes the text blink, or removes any 
decoration set elsewhere.


Font-weight applies a specific or relative amount of 
boldface to the font. Normal is equivalent to 400; Bold is 
equivalent to 700. 


Font-variant sets the small caps variant on text. 
Dreamweaver does not display this attribute in the 
Document window. 


Text-transform capitalizes the first letter of each word in 
the selection or sets the text to all uppercase or lowercase. 


Color sets the text color. 


6. When you have finished, click OK. Observe the effect of 
your changes in Design view.


Figure 2 CSS Styles panel


Figure 3 CSS Rule Definition dialog box
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Using web fonts
By using the CSS @font-face embedding technique, modern web browsers download and use a wide range of font 
styles. There are two methods for delivering web fonts to site visitors: subscription-based hosted services that license 
fonts for use and free open-source fonts.


Most subscription-based, third-party services host fonts on their servers and deliver specific fonts whenever a website 
is viewed. This often requires adding code to your site, and the service instructs you on how to do so. Examples of 
subscription-based services are Adobe’s Typekit (www.typekit.com), Kernest, and Typotheque. 


Google web fonts is the service of choice for free open-source web fonts. Like subscription-based font services, 
Google offers a hosted web font service, as well as letting you download font collections for saving to a web server. 


To use Google web fonts, you must first visit the Google web fonts website and choose one or more font styles, 
review your selection, and integrate web fonts into your CSS (Figure 4). Use one of the following procedures:   


• Remote web fonts: Copy the provided link code into the <head> section of your HTML document.


• Embedded web fonts: Download the collection as a ZIP file and save to your web server.


Figure 4 Google web fonts website


In this section, you learn how to use the Google remote web font service and how to download and use Google web 
fonts. 


To use remote Google web fonts:


1. Visit the Google web fonts site at www.google.com/
webfonts. 


You may be required to register.
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2. Search or browse the selection of font families; then click 
the Add To Collection button next to each font you want 
to use.


3. Click the Review button to compare and refine your 
collection and to see the styles in a customizable sample 
layout.


4. Click the Use button, and verify the settings.


5. In Step 3 on the Use page, copy the Standard link code 
(Figure 5).


The code is saved to the clipboard.


6. Open a Dreamweaver HTML document in which you 
want to add Google web fonts.


7. Select Split view in the Document toolbar (Figure 6).


Code view and Design view are visible in the Document 
window.


8. Locate the opening <head> tag of the document, and 
place the insertion point immediately after the closing 
bracket of the tag. 


9. Press Enter (Windows) or Return (Mac OS) to create a 
line break.


10. Select Edit > Paste to add the saved clipboard code to the 
head section of the document (Figure 7). 


11. Open the CSS Styles panel (Window > CSS Styles), if it 
isn’t already open, and select All at the top of the panel.


12. Click an existing rule or style in the All Rules pane of the 
CSS Styles panel to display its properties in the 
Properties pane.


13. Return to the Google web fonts Use page, and copy the 
name of the font family you want to use in your web page  
from the list in Step 4 (Figure 8).


14. Return to Dreamweaver. In the CSS Styles panel, double-
click the rule to which you want to apply the Google web 
font.


The CSS Rule Definition dialog box appears.


15. Paste the copied font-family name into the Font-Family 
text box (Figure 3).


16. Select File > Save All.


17. Select File > Preview In Browser, and then select a 
browser where you can preview the remote Google web 
font (Figure 9).


Figure 5 Step 3 of the Use page, Google web fonts


Figure 6 Document toolbar in Dreamweaver


Figure 7 Link to Google web fonts in the head 
section


Figure 8 Step 4 of the Use page, Google web fonts 


Figure 9 Google web fonts used in headings
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To dowload and embed Google web fonts:


1. Visit the Google web fonts site at www.google.com/
webfonts. 


2. You may be required to register


.


3. Search or browse the selection of font families; then click 
the Add To Collection button next to each font you want 
to use.


4. Click the Review button to compare and refine your 
collection and to see the styles in a customizable sample 
layout.


5. Click the Use button, and verify the settings.


6. Click the Download Your Collection link in the upper-
right corner of the Use page (Figure 10).


The Download The Fonts In Your Collection dialog box 
appears (Figure 11).


7. Click the Download The Font Families In Your 
Collection As A Zip-file link to download the files to 
your computer.


8. Unzip the file and save to the location of your choice. 


9. Open the folder containing the downloaded font and 
make note of the file type. 


It will have one of four types of web font extensions: 
EOT, WOFF, TTF, or SVG. You will need this 
information in the next few steps. The font in the 
example folder is Bree Serif, Regular, and it is a TTF 
font. 


10. Switch to Dreamweaver.


11. Select Modify > Web Fonts.


The Web Fonts Manager dialog box appears (Figure 13).


Figure 10 Download your Collection link


Figure 11 Download The Fonts In Your Collection 
dialog box


Figure 12 Downloaded fonts


Figure 13 Web Fonts Manager dialog box
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12. Click the Add Font button.


The Add Web Font dialog box appears (Figure 14).


13. Click the folder icon beside the file type of your 
downloaded font, navigate to the location of the saved 
font, and select it.


14. Click Open in the Open dialog box.


The font is added to the Add Web Font dialog box.


15. Click OK to close the Add Web Font dialog box.


The font is added to the Web Fonts Manager dialog box.


16. Click Done to close the Web Fonts Manager dialog box.


17. Open the CSS Styles panel (Window > CSS Styles), if it 
isn’t already open, and select All at the top of the panel.


18. In the All Rules pane, double-click the rule to which you 
want to apply the Google web font.


The CSS Rule Definition dialog box appears.


19. In the Font-Family menu, select the Google web font that 
you downloaded and added.


20. Select File > Save All.


21. Select File > Preview In Browser, and then select a 
browser where you can preview the embedded Google 
web font (Figure 9).


Figure 14 Add Web Font dialog box
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Writing for the web
Writing for the web is very different from other writing. Users read information online differently than information in 
print. Online readers coming to a site after an online search often don’t know if a website will meet their needs. If 
they do not find the information they are looking for, they will deem the site of little value, no matter how well it is 
designed or how easy to use. You can create clear, usable content by writing for varying levels of reader interest. Your 
goal should be to give all readers their desired level of information as quickly as possible. 


The following tips apply to writing content for web pages. Be sure to take these best practices into account when 
writing content for your client website.  


Online reading behavior


Studies have discovered the following bahaviors among online users:


• They judge websites in a fraction of a second.


• They scan content, hunting for the information they’re after. They don’t read word-for-word.


• They read more slowly from screens than from print. 


• Distractions and competition from online messaging, Facebook, and so on make it hard to keep users’ attention. 


• Because so much information is available online, users determine quickly if content is worth reading. 


Knowing your audience


To write effectively, you need to know your audience:


• Determine a range of interest levels among your audience and try to write for that range of interest (none to 
some, little to strong, only strong, and so on).


• Create a user persona for each kind of user to help you determine how to get their attention. 


• Write as if you are speaking to your audience in person.


• Consider users of various reading levels. 


• Make sure all content is accessible.


Writing guidelines


Guidelines for effective communication:


• Use clear, simple, familiar language. 


• Avoid jargon, acronyms, and abbreviations.


• Use an active and objective voice.


• Be direct and concise, getting quickly important points.


• Put the conclusion first so readers know what to expect from the content.


Chunk content


• Chunk means a manageable bit—a small piece of information a user can easily find and understand. 


• Bold important words or phrases.


• Use lists.


• Keep content short.
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• Use fragments or phrases instead of prose style. If you can cut a word, cut it.


Organizing page content


Titles


The title is the first piece of information a user scans. Make it clear, inviting, and meaningful.


Headings and subheadings


• Headings should be short, direct, and powerful.


• Subheadings should be descriptive, so users easily learn what each section is about. Use subheadings frequently 
(every few paragraphs) to keep user moving through content in easy chunks.


Sentences and paragraphs


• Shorter is better.


• Sentences should be no longer than about 20 words. 


• Each sentence should be limited to one idea. 


• Paragraphs should have no more than about 6 sentences.


• Each paragraph should be limited to one or two ideas.


Lists


• Lists are easy to scan because content is vertical. 


• Content presented in lists is usually more succinct.


Links


• Link to related information.


• Use descriptive link text so users know where they are going.


Design elements


• Use callouts, bold, and italics to make text easier to scan.


• Substitute pictures and other visual elements for text when appropriate.


Writing for mobile devices


• Reading on a mobile device is more difficult than on a desktop computer.


• When writing for mobile users, focus attention on the essential content.


• Defer secondary content to secondary pages.


• Writing for mobile readers requires even harsher editing than writing for the web. Mobile use implies less 
patience for filler copy.


• When in doubt, leave it out. 


Best practices


• Analyze and emulate great web writing. 


• Provide accurate descriptions and keywords for search engines.


• Use web writing guidelines when repurposing print documents for the web.


• Create a style guide.
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• Test your content: 


• Make sure all links work and are relevant. 


• Make sure all titles and summaries provide information about the contents of the page. 


• Read content from the view of your defined personas and make sure all users will find information quickly 
and accurately. 
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Principles and rules of copyright
Copyright is protection for intellectual property.


Intellectual property consists of anything an individual has written or created. It might be music, text, pictures, 
photographs, sounds, and so on.


Fair use doctrine is part of the copyright laws. It states that limited portions of material may be used without written 
permission for certain purposes, such as reporting the news or schoolwork. It doesn’t define “limited,” though, so be 
sure you don’t overuse material. The fair use doctrine requires you to give credit to the author or creator of any 
material you use.


Creative Commons is a set of copyright licenses that allow for the distribution of copyrighted works. The range of 
four conditonal licences provide a set of “baseline rights”that allow for the distribution of copyrighted work 
worldwide, without change, at no charge. The four conditions include: Attribution, Noncommercial, No Derivative 
works, and Share-alike. Creative Commons licenses permit the mixing and matching of conditions to produce 
suitable copyright licences conditions. For more info, see: http://creativecommons.org/


Derivative works are copyrighted materials that have been altered or changed. Such material is protected by copyright 
laws. If you alter a copyrighted photograph by using computer software, that photograph is still protected, and you 
may not use it without written permission.


Academic standards for copyrighted material are higher than others. Because scholars and researchers study so many 
different ideas and are responsible for sharing those ideas with the world, they are required to satisfy higher standards 
of honesty. They must give credit not only when quoting someone else’s exact words but also for the ideas those 
words represent. As a researcher, you cannot paraphrase what someone else says and not give credit for it.


Bibliographies are lists of sources that have been used in research. When using the Internet for research or for design 
work, you need to give credit where it is due. Often, people who use graphics and images from the Internet for 
publication on their own web page create a list of image credits rather than a bibliography.


Rules of Copyright
1. You cannot use copyrighted material without written permission from the creator of the material (or from its 


copyright holder).


2. Material can be protected even if it does not display the © symbol. Even if no mention is made regarding 
copyright, you must assume that all material from another source is protected.


3. Penalties for violating copyright laws can range from mild to severe. If you break the copyright law, you might 
simply receive an e-mail message from the author asking you to stop using the material. If you publish the 
material on a website, the webmaster might shut down your site. Or you could be sued by the author or 
prosecuted by federal authorities.


4. To make sure you are not violating any copyright law, it is important that you do the following:


• Write or send e-mail to the author or creator and ask permission to use the material. Do not use it until you 
are given permission. 


• Follow the directions on the site regarding use of material. You might be asked to create a link on your page 
or to notify the author or creator. 


• Most important: Do not use any material if you don’t have written permission. 
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5. Copyright notice is no longer required to obtain protection, but it is often beneficial. Copyright notice for 
visually perceptible material should contain the following three elements:


• The symbol © (the letter C in a circle), or the word “Copyright,” or the abbreviation “Copr.”


• The year of first publication


• The name of the owner of copyright


◦ Example: © 2012 Adobe Systems Incorporated


6. Copyright notice for phonorecords and sound recordings should contain the following three elements.


• The symbol ℗ (the letter P in a circle)


• The name of the owner of copyright


• The year of first publication


7. The copyright notice should be affixed in such a way as to “give reasonable notice of the claim of copyright.”


For more information on copyrights, visit the United States Copyright Office on the Internet at www.copyright.gov. 

Principles and rules of copyright © 2012 Adobe Systems Incorporated
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Flash file types

		The format in which you edit Flash documents has the file extension FLA.

		The format in which you export Flash documents for viewing in the Flash player has the file extension SWF.

		By default, SWF movies contain XMP metadata—information about the file available to web search engines and viewable in Adobe Bridge. 

		The format that lets multiple people work on separate parts of the Flash file, and that works with Adobe programs such as After Effects, has the file extension XFL. 



*





© 2012 Adobe Systems Incorporated.  All Rights Reserved. 



Flash workspace

*

Tools

Layers

Panels

Stage

Motion 

Editor

Timeline

Menu

bar





© 2012 Adobe Systems Incorporated.  All Rights Reserved. 



Stage

		You compose movie content on the Stage.

		Set Stage size by selecting Modify > Document.

		To specify the Stage size in pixels, enter values in the Width and Height boxes. The minimum size is 1 x 1 pixels; the maximum is 2880 x 2880 pixels.

		To minimize document size, select the Contents option to the right of Match (but first create all of the objects on the Stage).

		To set the Stage size to the maximum available print area, select the Printer option. 



*
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Tools panel

Tools create the content of a movie.

		Selection tools: Select, scale, distort, rotate objects

		Drawing tools: Draw, paint, create text, and erase objects

		View tools: Zoom and pan

		Color tools: Set stroke and fill colors

		Options: Modify the currently selected tool



*
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Panels

Panels provide additional tools for creating and editing movies.

		Click the panel to view additional options for the current panel.

		You can hide or show panels by using the options on the Window menu.



*

Panels
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Timeline panel

		You can organize and control the content of a movie over time.



*
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Frames
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Frames and keyframes 

		Frames: Like films, Flash movies divide lengths of time into frames, which are organized on the timeline.

		Keyframes: Frames that define a change in what is displayed in a movie or include frame actions to modify a movie. When you open a new blank movie document, it contains one layer with one blank keyframe.



*
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Frames and keyframes 
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Layers

		Layers are like multiple film strips stacked on top of each other, each with a different element that appears on the Stage. 

		Graphics

		Animations

		Text

		Sounds

		Buttons

		Frame actions



*
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Symbols and libraries

		Symbols are elements you reuse within a movie to reduce file size.

		Types of symbols include graphics, buttons, movie clips, sound files, and text.

		A library is where you store and organize symbols.

		When you drag a symbol from a library to the Stage, you create an instance of the symbol.



*
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Advantages of using symbols

		Easy editing: If you change the symbol in the library, all instances of the symbol are updated automatically.

		Smaller file sizes: Symbols are downloaded only once, regardless of the number of instances you include in the movie. This reduces the size of your published movies and decreases download times.



*
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Animation with tweening

		Tweening: A tween is an animation that is created by specifying a state for an object property in one frame and another state for that same object in another frame. Flash calculates the values for that object’s properties in between those two frames. The term tween comes from the phrase “in between.”

		Flash supports three different types of tweening. 

		Motion tweens are powerful and simple to create.  Motion tweens allow you to create most tweened effects. 

		Classic tweens are more complex to create, but provide certain capabilities that motion tweens do not.

		Shape tweens allow you draw a shape at one specific frame in the Timeline, and change that shape or draw another shape at another specific frame. Flash then interpolates the intermediate shapes for the frames in between, creating the animation of one shape morphing into another.

		Inverse Kinematics (IK): IK is a method for animating an object or set of objects in relation to each other by using an articulated structure of bones. Bones allow symbol instances and shape objects to move in complex and naturalistic ways with a minimum of design effort. For example, with inverse kinematics you can easily create character animation, such as arms, legs, and facial expressions.



*
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Motion tweening

		Motion tweens can only have one object instance associated with them and use property keyframes instead of keyframes.

		Motion tween spans can be stretched and resized in the timeline and are treated as a single object.

		With motion tweens, eases apply across the entire length of a motion tween span. Easing only specific frames of a motion tween requires the creation of a custom ease curve.

		The Motion Editor enables you to view all Motion tween properties and their property keyframes. 



*
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Classic tweening

		Classic tweens use keyframes.  Keyframes are frames in which a new instance of an object appears. 

		Classic tweens consist of groups of individually selectable frames in the timeline.

		With classic tweens, eases can be applied to the groups of frames between the keyframes within the tween. 



*
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Shape tweening

Shape tweens work best with simple shapes. Avoid shapes with cutouts or negative spaces in them. Experiment with the shapes you want to use to determine the results. You can use shape hints to tell Flash which points on the beginning shape should correspond to specific points on the end shape.

You can also tween the position and color of shapes within a shape tween.

To apply shape tweening to groups, instances, or bitmap images, break these elements apart.

To apply shape tweening to text, break the text apart twice to convert the text to objects.

*
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Inverse Kinematics (IK)

		Inverse kinematics lets you can create natural motion. 

		You can use the Bones tool to add IK animation to symbol instances and shapes.

		To animate text by using IK, first convert the text to a symbol first. 

		Add bones to separate symbol instances or to the interior of a single shape. 

		When one bone moves, the other connected bones move in relation to the bone that initiated the movement. To animate by using inverse kinematics, you need only to specify the start and end positions of objects. 



You can use IK in Flash in two ways. 

The first is to articulate a series of symbol instances by adding bones to connect 

each instance to another instance. The bones allow the chain of symbol instances 

to move together.

The second way is to add an armature to the interior of a shape object. The shape can 

be created in merge drawing mode or object drawing mode. The bones allow you to 

move and animate parts of the shape without the need to draw different versions of 

the shape or create a shape tween.

*
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Sound

		First, import a sound file into the library.

		Add sound to a movie by dragging an instance of the sound into a frame.

		To minimize file size, loop shorter sounds (to make them repeat).



*
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Actions

		ActionScript statements instruct a movie to do something while it is playing. ActionScript can be attached to a frame or to an object: 

		Frames: ActionScript attached to a frame is triggered when the movie plays that frame.

		Objects: ActionScript attached to an object is triggered when the viewer interacts with the object, such as moving the pointer over a hotspot or clicking a button.



*
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Understanding frames and keyframes
Like films, Adobe Flash Professional CS6 documents divide lengths of time into frames. In the timeline, you work 
with these frames to organize and control the content of your document. You place frames in the timeline in the order 
you want the objects in the frames to appear in your finished content. 


Frames define increments on the timeline (Figure 1). The order in which frames appear on the timeline determines 
the order in which they appear when a Flash document plays. You can arrange keyframes on the timeline to edit the 
sequence of events in an animation.


A keyframe is a frame where a change occurs in the timeline. For example, a keyframe can indicate where a new 
symbol instance appears in the timeline. A keyframe can also be a frame that includes ActionScript code to control 
some aspect of your document. You can also add a blank keyframe to the timeline as a placeholder for symbols you 
plan to add later or to explicitly leave the frame blank.


A property keyframe is a frame in which you define a change to an object’s properties for an animation. Flash can 
tween, or automatically fill in, the property values between the property keyframes in order to produce fluid 
animations. Because property keyframes let you produce animation without drawing each individual frame, they 
make creating animation easier. A series of frames containing tweened animation is called a motion tween.


A tweened frame is any frame that is part of a tween.


A static frame is any frame that is not part of a tween.


You arrange keyframes and property keyframes in the timeline to control the sequence of events in your document 
and its animation.


A keyframe is indicated on the timeline with a solid black circle. The frame where a keyframe span ends has a small 
white rectangle. A blank keyframe is indicated by an empty circle.


Figure 1 Frames


You can do the following with frames or keyframes:


• Insert frames, keyframes, and blank keyframes.


• Remove frames, keyframes, and blank keyframes.


• Convert frames to keyframes or blank keyframes.


• Drag frames and keyframes to a new location on the same layer or on a different layer.


• Copy and paste frames and keyframes.


Blank keyframe


End of keyframe spanStatic keyframe


Property keyframe in 
a classic tween


Property keyframe in 
a motion tween
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Representing animations in the timeline
Flash distinguishes tweened animation from frame-by-frame animation in the timeline by displaying different 
indicators in each frame that contains content. The following frame content indicators appear in the timeline:


A span of frames with a blue background indicates a motion tween (Figure 2). A black dot in the first frame of the 
span indicates that the tween span has a target object assigned to it. Black diamonds indicate the last frame and any 
other property keyframes. Property keyframes are frames that contain property changes explicitly defined by you. By 
default, Flash displays all types of property keyframes. All other frames in the span are interpolated by Flash, 
depending on the properties changed in these keyframes. A ball that moves across the Stage, for example, might have 
an initial keyframe that positions it on the left of the Stage, and another keyframe that positions it on the right. All 
other positions of the ball—moving from left to right—are interpolated in the frames between the two keyframes.


Figure 2 Motion tween


A hollow dot in the first frame indicates that the target object of the motion tween has been removed. The tween span 
still contains its property keyframes and can have a new target object applied to it (Figure 3).


Figure 3 Blank target frame


A span of frames with a green background indicates an inverse kinematics (IK) pose layer (Figure 4). Pose layers 
contain IK armatures and poses. Each pose appears in the timeline as a black diamond. Flash interpolates the 
positions of the armature in the frames between poses.


Figure 4 Inverse Kinematic (IK) pose layer


A black dot at the beginning keyframe, with a black arrow and blue background, indicates a classic tween (Figure 5).


Figure 5 Classic tween


A dashed line indicates that a classic tween is broken or incomplete, such as when a final keyframe is missing 
(Figure 6).


Figure 6 Broken or incomplete classic tween


A black dot at the beginning keyframe with a black arrow and a light green background indicates a shape tween 
(Figure 7).


Figure 7 Shape tween

Understanding frames and keyframes © 2012 Adobe Systems Incorporated







Adobe Flash Professional CS6 Project 5 guide

A black dot indicates a single keyframe containing content. Light gray frames after a single keyframe contain the 
same content with no changes. These frames have a vertical black line and a hollow rectangle at the last frame of the 
span (Figure 8).


Figure 8 Continuous span of the same content


A small “a” indicates that the frame is assigned a frame action in the Actions panel (Figure 9). 


Figure 9 Frame action


A red flag indicates that the frame contains a label (Figure 10).


Figure 10 Frame labels


A green double slash indicates that the frame contains a comment (Figure 11).


Figure 11 Frame comment


A gold anchor indicates that the frame is a named anchor (Figure 12).


Figure 12 Named anchor
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Why is writing for the web different from other writing?

		Users read information online differently than information in print.

		Online readers coming to a site after an online search often don’t know if a website will meet their needs. 

		If they do not quickly find the information they are looking for, they will deem the site of little value, no matter how well it is designed or how easy to use.

		Clear, usable content can be achieved by writing for readers with varying levels of interest. A writer’s goal should be to give all readers their desired level of information as quickly as possible. 



*
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Online reading behavior

Studies have discovered the following behaviors of online users:

		They judge websites in a fraction of a second.

		They scan content, hunting for the information they’re after, as opposed to reading word-for-word. 

		They read more slowly from screens than from print.

		Distractions and competition from online messaging, Facebook, and so on make it hard to keep users’ attention.

		Because so much information is available online, users need to determine quickly if content is worth reading and spending time with.



*
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Know your audience

		Your audience: 

		Once you identify your audience, determine various interest levels of your overall audience and try to write for each level (none, little, some, strong, and so on). 

		Create a user persona for each kind of user to help you determine how to get their attention. 

		Write as if you are speaking to your audience in person.

		Writing for all users: 

		Consider users of various reading levels. 

		Make sure all content is accessible.



*
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Writing guidelines

		Guidelines for effective communication

		Use clear, simple, and familiar language. 

		Avoid jargon, acronyms, and abbreviations.

		Use an active and objective voice.

		Be direct and concise, getting to the important points quickly.

		Put the conclusion first so readers know exactly what they will get from the content.

		Chunk content

		Chunk means a manageable bit – a small piece of information a user can easily find and understand. 

		Bold important words or phrases.

		Use lists.

		Keep content short and create space for scanning it easily.

		Use fragments or phrases instead of prose style – if you can cut a word, cut it.



*





*
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Organizing page content

		Titles

		The title is the first piece of information a user scans. Make it clear, inviting, and meaningful.

		Headings and subheadings

		Headings should be short, direct, and powerful.

		Subheadings should be descriptive so users easily learn what each section is about. Use subheadings frequently (every few paragraphs) to keep user moving through content in easy chunks.

		Sentences and paragraphs – shorter is better

		Sentences should be no longer than about 20 words. 

		Each sentence should be limited to one idea. 

		Paragraphs should have no more than about 6 sentences.

		Each paragraph should be limited to one or two ideas.



*
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Organizing page content

		Lists

		Lists are easy to scan because content is vertical. 

		Content presented in lists is usually more succinct.

		Links

		Use descriptive link text so users know where they are going.

		Link to related information.

		Design elements

		Use callouts, bold, and italics to make text easier to scan.

		Use pictures and other visual elements in place of text when appropriate.



*
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Writing for mobile devices

		Reading content on mobile devices is more difficult that reading content on a desktop computer.

		When writing for mobile users, focus their attention on the essential content.

		Defer secondary content to secondary pages to maintain focus on the most essential content.

		Writing for mobile readers requires even harsher editing than writing for the Web. Mobile use implies less patience for filler copy.

		When in doubt, leave it out. 



*

Source: http://www.useit.com/papers/webwriting/
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Best practices

		Analyze and emulate great web writing. 

		Provide accurate descriptions and keywords for search engines.

		Use web writing guidelines when repurposing print documents for the web.

		Create a style guide.

		Test your content: 

		Make sure all links work and are relevant. 

		Make sure all titles and summaries provide information about the contents of the page. 

		Read content from the view of your defined personas and make sure all users will find information quickly and accurately. 



*



For information about the differences between HTML4 and HTML5, see: http://dev.w3.org/html5/html4-differences/

*
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Conclusion

		The title, summary, and major headings should give users a broad overview of the topic. 

		The sentences and paragraphs should tell users a story. 

		Users want to take away the main ideas without being bogged down with specifics.



*











Project 6 worksheet

How to evaluate a digital narrative


Student name:_________________________________________________ Date: ________________________


Name of the project you are evaluating: ____________________________


Communication


Who is the intended audience?_____________________________________________________________________


What is the intended message? ____________________________________________________________________


Is the intended message clear? Why or why not? ______________________________________________________


What are the goals of the narrative? ________________________________________________________________


How do the effects and visual content enhance or detract from the overall message and goals of the narrative?


How do the text and audio content of the narrative enhance or detract from the overall message and goals?


How well do the effects and visual content reach the intended audience? ___________________________________


How well do the text and audio content of the narrative reach the intended audience? _________________________


Technical


Does the animation function properly? Why or why not? ________________________________________________


Do all of the buttons work? If not, what changes need to be made? ________________________________________
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Are the transitions smooth? If not, how can they be made smoother? ______________________________________


Does tweening occur as expected? If not, how can the problems be fixed? __________________________________


Is the size of the finished movie acceptable for the intended delivery?______________________________________


Comment on any over- or under-use of animation, sound, transitions, or effects. _____________________________


Usability
How easy is it to navigate through the narrative? Is the navigation predictable and easy to use? Is the text readable? 
Do images and other media elements load in a reasonable time? Is it easy to follow and understand animations?


Narrative criteria


Does the narrative fall within the required time and word limits?__________________________________________


Does the narrative include at least one transition and filmmaking technique? ________________________________


Does the narrative exceed five uses of effects or filmmaking techniques? ___________________________________


Does the audio narration exceed 45 seconds? _________________________________________________________


Does the narrative stay within the one-minute time limit? _______________________________________________

How to evaluate a digital narrative © 2012 Adobe Systems Incorporated
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How to publish web files
Once you’ve specified a local site in Dreamweaver, you can specify a remote server for your site as well. The remote 
server (often referred to as the web server) is where you publish your site files so that people can view them online. 
The remote server is simply another computer like your local computer, with a collection of files and folders on it. 
You specify a folder for your site on the remote server, just as you specified a folder for your local site on your local 
computer (Figure 1). Dreamweaver refers to the specified remote folder as your remote site.


Figure 1 Basic screen of the Servers category, Site Setup dialog box


When you set up a remote folder, you select a connection method for Dreamweaver to upload files to your web server 
and download files from your web server. The most typical connection method is FTP, but Dreamweaver also 
supports local/network, FTPS, SFTP, WebDav, and RDS connection methods. If you don’t know which connection 
method to use, ask your teacher or your school server administrator.


Connecting to a remote site
Many websites let you publish files through FTP (File Transfer Protocol). You connect to a remote site by using the 
Site Definition dialog box in Adobe Dreamweaver CS6. 


To connect to a remote site by FTP:


1. Select Site > Manage Sites.


The Manage Sites dialog box opens (Figure 2).


2. Double-click the name of the site you want to connect 
remotely.


The Site Setup dialog box opens.


Figure 2 Manage Sites dialog box
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3. Click the Servers category in the left column.


The Servers category of the Site Setup dialog box opens (Figure 3).


Figure 3 Basic screen of the Servers category, Site Setup dialog box


4. Click the Add New Server button (+).


5. Enter the FTP access information as directed by your teacher (Figure 1).


6. Click Test to test the connection.


Dreamweaver confirms the connection.


7. Click Save.


The new server appears in the list of servers in the Site Setup dialog box.


8. Click Save to close the Site Setup dialog box.


9. Click Done to close the Manage Sites dialog box.


Add New Server
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Uploading, Synchronizing, and downloading files
Once you establish an FTP connection, you can use the Get and Put commands to transfer files from the Files panel 
(Figure 4).


Figure 4 Expanded Files panel


When you transfer a document between a local and remote folder using the Files panel, you have the option of 
transferring the document’s dependent files. Dependent files are images, external style sheets, and other files 
referenced in your document that a browser loads when it loads the document.


Note: It’s usually a good idea to download dependent files when checking out a new file, but if the latest versions of 
the dependent files are already on the local disk, there’s no need to download them again. This is also true for 
uploading and checking in files: no need if up-to-date copies are already at the remote site.


To upload the entire site for the first time:


1. In the Files panel (Window > Files), select the files to 
upload.


2. Click the Expand/Collapse button in the Files panel 
toolbar (Figure 4).


The Files panel expands.


3. Click the Connects To Remote Host button in the Files 
panel toolbar.


Dreamweaver connects to the web server.


4. Select the root folder for your site in the Local (right) 
pane.


5. Click the Put Files button in the Files panel toolbar.


6. You may be presented with a dialog box asking if you 
wish to put the entire site. Click OK.


Dreamweaver uploads the site’s files and opens the 
Background File Activity dialog box (Figure 5).


Note: To upload one or more folders or files without 
uploading the entire site, select them and click the Put 
Files button.


Figure 5 Background File Activity dialog box


Connects/Disconnects Remote Host Get Files Put Files Synchronize Expand/CollapseRefresh
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To upload a revised version of an existing file:


1. Select the file you have revised.


2. Click the Put Files button in the Files panel toolbar.


Dreamweaver uploads the revised file.


Synchronizing the files on your local and remote sites


After you’ve created files in your local and remote sites, you can synchronize the files between the two sites.


Before you synchronize your sites, you can verify which files you want to put, get, delete, or ignore. Dreamweaver 
also confirms which files have been updated after you complete the synchronization.


To synchronize files:


1. (Optional) Select specific files or folders in the Files 
panel or go to the next step to synchronize the entire site.


2. Click the Synchronize button in the Files panel toolbar to 
synchronize files.


The Synchronize Files dialog box opens (Figure 6).


3. Select the direction in which you want to copy the files:


Put Newer Files To Remote uploads all the local files that 
don’t exist on the remote server or have changed since 
the last upload.


Get Newer Files From Remote downloads all the remote 
files that don’t exist locally or have changed since the last 
download.


Get And Put Newer Files places the most recent versions 
of all the files on both the local and the remote sites.


4. Choose whether to delete the files on the destination site 
that don’t have counterparts on the origin site. (This is 
not available if you select Get and Put from the Direction 
menu.)


If you select Put Newer Files To Remote and you select 
the Delete option, then any files in your remote site for 
which there are no corresponding local files are deleted. 
If you select Get Newer Files From Remote, then any 
files in your local site for which there are no 
corresponding remote files are deleted.


Figure 6 Synchronize Files dialog box 
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5. Click Preview.


Dreamweaver analyzes the local and remote folders, and 
then the Synchronize dialog box opens (Figure 7).


Note: Before you can synchronize the files, you must 
preview the actions Dreamweaver performs to 
accomplish this task. 


If the newest version of each chosen file is already in 
both locations and nothing needs to be deleted, an alert 
appears informing you that no synchronization is 
necessary. Otherwise, the Synchronize dialog box 
appears to let you change the actions (put, get, delete, and 
ignore) for those files before executing the 
synchronization.


6. Verify the action that will be performed for each file.


7. Click OK to synchronize the files.


Figure 7 Synchronize dialog box 


Downloading files to work on them


Once your website has been published, you may want to download a file so you can revise it. You do so through the 
Remote Site pane, on the left side of the expanded Files panel.


To download a file:


1. Click the Refresh button in the Files panel toolbar 
(Figure 4) to make sure the files in the Remote Site pane 
are up-to-date.


2. Select a file to download.


3. Click the Get Files button.


If the file has any dependent files, the Dependent Files 
dialog box opens (Figure 8). 


Note: If you do not click Yes within 30 seconds, the 
Dependent Files dialog box automatically closes and 
dependent files are not downloaded.


4. Click Yes.


Dreamweaver copies the file and its dependent files to 
your local folder. The downloaded files appear in the 
right pane of the expanded Files panel.


5. Click the Disconnects From Remote Host button, and 
then collapse the Files panel.


Figure 8 Dependent Files dialog box 
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The Dreamweaver Insert panel
In Adobe Dreamweaver CS6, the Insert panel contains buttons for inserting various types of objects, such as images 
and forms, into a Dreamweaver document.


You can use the Insert panel to create or insert content in eight categories:


• The Common category contains buttons for inserting the most commonly used objects, such as links, 
images, and tables.


• The Layout category gives you options to insert tables, table elements, div tags, frames, and Spry widgets. 
You can view tables in either Standard (default) mode or Expanded Tables mode. 


• The Forms category contains buttons for creating forms and inserting form elements.


• The Data category lets you insert dynamic elements such as recordsets, repeated regions, and record 
insertion and update forms.


• The Spry category lets you insert “widgets” that display data from other files and various interface elements 
(such as navigation bars and menus) that rely on JavaScript and CSS. (Spry widgets are not covered in this 
study, but you can read find out more about them in Dreamweaver Help (select Help > Dreamweaver Help 
and look for the section called “Building Spry pages visually.”)


• The jQuery Mobile category provides content layout options, input, UI and form controls for developing 
mobile applications using Dreamweaver.


• The InContext Editing category is used to enable end users to make simple edits to their web pages without 
help from you or additional software on their computers. Adobe InContext Editing (ICE) is an online hosted 
service that provides simple content editing capabilities within a web browser. 


• The Text category is used for working in Code view and enables you to insert a variety of text- and list-
formatting tags, such as b, em, p, h1, and ul.


• Use the Favorites category to customize a list of Insert panel buttons for fast access. You can customize this 
category by right-clicking (Windows) or Control-clicking (Mac OS) the Insert panel.


The Insert panel menu
You switch between these categories by using the Insert panel menu, which is located at the top of the Insert panel 
(Figure 1). To hide or show the Insert panel select Window > Insert.


Figure 1 Insert panel, Category pop-up menu
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To display the pop-up menu for a button, click the disclosure triangle beside the button’s icon (Figure 2).


Figure 2 Insert panel, Images pop-up menu
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How to work with external Cascading Style Sheets
Many web professionals find that using an external style sheet--a style sheet that exists in its own file--offers a 
number of advantages over including styles in the header of an HTML file. These advantages include:


• Flexibility: With CSS stored in one file, you can easily change the appearance of all documents that refer to 
the external style sheet.


• Consistency: All documents sharing the same style sheet will have a similar appearance.


Using an external style sheet separates form from content. Separating form from content is a widely-adopted principle 
in web design which allows, among other benefits, for content to be shared in a range of contexts. 


Exporting CSS rules to an external style sheet
You can convert an internal CSS style sheet to an external one by exporting it, removing the internal CSS style sheet, 
and attaching the exported CSS style sheet to one or more web pages. 


To export a style sheet:


1. Start Dreamweaver and open the CSS Styles Panel 
(Window > CSS Styles) (Figure 1).


2. Confirm that All is selected in the CSS Styles panel.


3. Select the CSS rule you want to move to an external style 
sheet.


Note: To move more than one rule at a time, you can 
Shift-click to select multiple rules that are next to each 
other. To select multiple rules that aren’t next to each 
other, you can Control-click (Windows) or Command-
click (Mac OS) the names of the rules.


4. Right-click (Windows) or Control-click (Mac OS) the 
selected rule(s) and select Move CSS Rules in the context 
menu.


The Move To External Style Sheet dialog box opens 
(Figure 2).


Figure 1 CSS Styles panel


Figure 2 Move To External Style Sheet dialog box
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5. Select A New Style Sheet and then click OK.


The Save Style Sheet File As dialog box opens 
(Figure 3).


6. Browse to a location for the CSS file, enter a name for the 
file, and click Save.


Note: It is good practice to place CSS files in their own 
folder and good practice to name that folder css.


Dreamweaver exports the CSS file.


Figure 3 Save Style Sheet File As dialog box


To delete an internal style sheet:


1. In the CSS Styles panel under All, select <style>.


2. Click the Delete Embedded Stylesheet button (Figure 4).


Dreamweaver removes the internal style sheet. If the 
internal style sheet contains any styles still being used on 
the page, the affected text reverts to its default 
formatting, or it takes on the formatting defined in the 
external style sheet.


Figure 4 CSS Styles panel


Delete Embedded Style Sheet button
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Attaching an external style sheet
Once you create an external style sheet and attach it to multiple documents, you can instantly change any style in all 
your documents by making changes to the external style sheet.


Note: Once you start using an external style sheet, it is best to make all text formatting changes through that style 
sheet. If you make formatting changes through the Properties panel, Dreamweaver will automatically create a new 
internal style sheet.


To attach an external style sheet:


1. Open a document in Dreamweaver.


2. Confirm that the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


3. Click the Attach Style Sheet button (Figure 5).


The Attach External Style Sheet dialog box opens 
(Figure 6).


4. Click Browse, navigate to your saved style sheet, select 
it, and click OK.


5. In the Attach External Style Sheet dialog box, click OK.


Dreamweaver attaches the style sheet to your document 
(Figure 7).


The style sheet’s rules are now available in the Properties 
panel. You may need to expand the style sheet to see its 
rules.


You can attach the same style sheet to multiple 
documents. When you make changes to the style sheet, 
those changes will appear in all documents the style sheet 
is attached to.


Figure 5 CSS Styles panel


Figure 6 Attach External Style Sheet dialog box


Figure 7 Attached style sheet


Attach Style Sheet button
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Creating external style sheets
You can also create external style sheets directly from the New Document dialog box. 


To edit create an external Style Sheet:


1. Select File > New to create a new document.


The New Document dialog box opens (Figure 8).


2. In the Blank Page category of the New Document dialog 
box, select CSS for Page Type.


3. Click Create. 


The untitled CSS page opens in Dreamweaver in Code 
View (Figure 9).


4. Save the document to the site root folder.


5. Return to the HTML document in which you previously 
applied a style by using the CSS Styles panel.


6. In Code View, drag to select the two or more styles you 
previously created. Be sure to include the selectors and 
everything that falls between, including the braces 
(Figure 10).


7. Select Edit > Cut.


8. Click the newly-created CSS document in the Document 
window.


9. Place the cursor on line 4, beneath the CSS comment.


10. Select Edit > Paste.


The copied CSS styles are pasted from the Clipboard into 
the CSS document.


11. Select File > Save.


12. Return to the HTML document in the document window.


Notice in the Design View that all formating for the text 
is gone. In the next steps, you re-apply the CSS styles by 
linking to the external CSS document you just created.


13. In the CSS Styles panel, click the Attach Style Sheet 
button in the lower-right corner of the pane (Figure 5).


The Attach External Style Sheet dialog box opens 
(Figure 11).


14. Click the Browse button and browse to the external CSS 
style sheet that you saved to your site root folder, and 
confirm that the Add As: Link option is selected.


15. Click OK.


A link to the CSS document is added to Head section of 
the  file, and the CSS rules are applied to the text in the 
HTML document.


16. Save the file.


Figure 8 New Document dialog box


Figure 9 New, blank CSS document


Figure 10 Selecting CSS styles


Figure 11 Attach External Style Sheet dialog box
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How to create animations


Overview of tweening
A tween is an animation you create by specifying a value for an object property in one frame and another value for 
that same property in another frame. Adobe Flash Professional CS6 calculates the values for that property between 
those two frames. The term “tween” comes from the phrase “in between.” You can tween movie clip, graphic, and 
button symbols and text fields.


A tween span is a group of frames in the timeline in which an object on the Stage can have one or more properties 
changed over time. A tween span appears in the timeline as a group of frames in a single layer with a blue or green 
background. You can select a tween span as a single object and drag it from one location in the timeline to another, 
including to another layer. Only one object on the Stage can be animated in each tween span. This object is called the 
target object of the tween span.


A property keyframe is a frame within a tween span where you explicitly define one or more property values for the 
tween target object. Each property you define has its own property keyframes. If you set more than one property in a 
single frame, the property keyframes for each of those properties reside in that frame. You can view each property of 
a tween span and its property keyframes in the Motion Editor. You can also choose which types of property 
keyframes to display in the timeline from the tween span context menu.


Beginning with Adobe Flash Professional CS4, the concepts of keyframe and property keyframe differ from earlier 
versions of Flash. The term keyframe refers to a frame in the timeline in which a change occurs, such as a symbol 
instance appearing on the Stage for the first time. The term property keyframe, new to Flash CS4, refers to a value 
defined for a property at a specific time or frame in a motion tween.


Types of Flash Animation
Motion tweens: Set properties for an object, such as position and alpha transparency in one frame and again in another 
frame, and Flash interpolates the property values of the frames in between. Motion tweens are useful for animation 
that consists of continuous motion or transformation of an object. Motion tweens appear in the timeline as a 
contiguous span of frames you can select as a single object by default. Motion tweens are powerful and simple to 
create.


Shape tweens: Draw a shape at one frame in the timeline and change that shape or draw another shape at another 
frame. Flash then interpolates the intermediate shapes for the frames in between, creating the animation of one shape 
morphing into another.


Classic tweens: Classic tweens are similar to motion and shape tweens, but you can create some specific animated 
effects not possible with span-based tweens. For example, you can apply eases to the groups of frames between the 
keyframes within the tween instead of across the entire length of a tween span. (To ease only specific frames of a 
motion tween, you must create a custom ease curve.) You can also use classic tweens to animate between two color 
effects, such as tint and alpha transparency, while motion tweens can apply only one color effect per tween.


Inverse kinematic (IK) poses: You can stretch and bend shape objects and link groups of symbol instances to make 
them move together in naturalistic ways. If you position the shape object or linked instances in different ways in 
separate frames, Flash interpolates the positions in the frames in between. Inverse kinematics poses help make 
character animation quick and easy.


Note: You will learn more about how to use inverse kinematic poses in the “How to create character animations” 
guide.


Motion tweens
You apply motion tweens only to symbol instances and text. All other objects must be converted to symbols before 
you can animate them by using a motion tween. 
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A motion tween begins with a target symbol instance in the first keyframe of the tween span. You create motion by 
adding a property keyframe somewhere later in the timeline and changing the symbol properties, such as position, 
scale, or rotation. You can edit the individual properties of each symbol instance by using the Properties panel or the 
Motion Editor. You can also drag a symbol instance to a new location on the Stage or manipulate it by using the Free 
Transform tool. 


Note: A tween span can have only one target object. If you add a second symbol to a tween span, the new symbol 
replaces the original one. That means you can deliberately replace the target object of a tween by dragging a different 
symbol from the library onto the tween span in the timeline. 


To create a motion tween:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Draw a shape on the Stage.


The shape appears in keyframe 1 of Layer 1.


3. Using the Selection tool (Figure 1), double-click to 
select the shape fill and stroke, if present. 


4. Choose Modify > Convert To Symbol. 


The Convert To Symbol dialog box appears (Figure 2).


Note: Applying a motion tween to a shape automatically 
converts the shape to a symbol.


5. Type a new name for the symbol in the Name text box, 
select Graphic for Type, and click OK (Figure 2).


6. Select frame 10.


7. Select Insert > Timeline > Frame. (The motion tween will 
last for 10 frames.)


When you insert a frame, Flash fills the area between the 
last frame (on the current layer) and the new frame with 
the same content (Figure 3). Frames 1 through 10 all 
contain the new symbol.


8. Make sure frame 10 (the end frame for the motion tween) 
is selected and select Insert > Motion Tween.


9. With frame 10 still selected in the timeline, select the 
symbol on the Stage (with a single click). Make one or 
more of the following changes:


Color change: In the Properties panel, select Tint from 
the Color Effect Style menu. Select 100% for the Tint 
Amount and change the color in the Tint Color box 
(Figure 4).


Fading: In the Properties panel, select Alpha from the 
Color Effect Style menu. Reduce the percentage of the 
Alpha Amount for more transparency. For example, an 
Alpha value of 0% makes the object disappear.


Position: Use the Selection tool to move the object to a 
different position on the Stage. A motion path appears. 
The points on this motion path are editable.


Figure 1 Tools panel


Figure 2 Convert To Symbol dialog box


Figure 3 Inserted frame


Figure 4 Properties panel


Selection tool
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Size: Select the object. Then select Modify > Transform > 
Free Transform. Drag the object handles to increase size, 
decrease size, or rotate the object.


10. Click away from the symbol on the Stage to deselect it 
and select frame 1 in the timeline. 


In the timeline, the motion tween is represented by a solid 
blue background running from the start keyframe to the 
end keyframe (Figure 5). When you changed the 
properties of the symbol in frame 10, frame 10 was 
automatically converted to a property keyframe.


With the target object selected in frame 1, the tween’s 
properties appear in the Properties panel (Figure 6).


11. Adjust one or more properties of the motion tween in the 
Properties panel.


• Ease: Controls how fast the object starts or ends the 
motion tween. For example, a high number makes an 
object begin tweening quickly and end slowly.


• Rotate: Rotates the object clockwise or 
counterclockwise a designated number of times.


• Path: If you add a guide layer, the object is linked to 
the path drawn on the guide layer.


• Sync Graphic Symbols option: Starts and stops the 
tweening of all objects on the Stage at the same time.


12. Select the Motion Editor panel (Figure 7).


You can view and adjust all tween properties and 
property keyframes in the Motion Editor. 


• You can add or remove property keyframes for 
individual properties.


• You can move property keyframes to different 
frames within the tween.


• You can add or remove filters or color effects and 
adjust their settings.


• You can add different preset eases to individual 
properties and property categories.


• You can create custom ease curves.


• You can enable roving for individual property 
keyframes for X, Y, and Z properties. Roving allows 
the property keyframe to move to different frames or 
between individual frames to create smooth motion.


Figure 5 Motion tween in the timeline


Figure 6 Motion tween properties


Figure 7 Motion Editor panel
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13. Select Control > Test Movie > In Flash Professional to 
test the movie.


14. Select File > Close to close the preview window.


15. Select the Timeline panel.


16. To see all phases of the tween at the same time, click the 
Onion Skin button at the bottom of the Timeline panel 
(Figure 8).


17. Drag the onion skinning frame handles (they appear as 
brackets with circles on them at the top of the timeline) to 
span the frames in which the object appears.


All the intermediate steps of the tween are visible on the 
Stage (Figure 9).


18. Turn off onion skinning by clicking the Onion Skin 
button again.


19. Save the movie.


Figure 8 Onion Skin button (shown selected)


Figure 9 Onion skinning visible


Shape tweens
In shape tweening, you draw a vector shape at one specific frame in the timeline and change that shape or draw 
another shape at another specific frame. Flash then interpolates the intermediate shapes for the frames in between, 
creating the animation of one shape morphing into another.


Note: Shape tweens work best with simple shapes. Avoid shapes with cutouts or negative spaces in them. Experiment 
with the shapes you want to use to determine the results. You can use shape hints to tell Flash which points on the 
beginning shape should correspond to specific points on the end shape. Shape tweens can use much more computer 
memory than motion tweens, so it is best to use shape tweens sparingly.


Onion Skin button
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To create a shape tween:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


Frame 1 in Layer 1 already contains a blank keyframe.


2. Begin by adding a shape to the Stage:


Drawn objects: Select a shape tool (Rectangle, Oval, or 
PolyStar) and draw a shape on the Stage.


Text: Select the Text tool and type a word or phrase on the 
Stage. Then select the text and select Modify > Break 
Apart. This breaks the words into separate letters. With 
the letters still selected, select Modify > Break Apart 
again to convert the letters into shapes.


Outside images: Select File > Import > Import To Stage 
to import an image. If the image is a bitmap, you must 
break it apart. If the image is a grouped vector drawing, 
you must ungroup it completely. To break apart a bitmap, 
select Modify > Break Apart. To ungroup an image, 
select Modify > Ungroup.


Note: You might need to select Modify > Break Apart or 
Modify > Ungroup multiple times until the object 
becomes a shape, as indicated in the Properties panel.


3. Using the Selection too, select frame 10.


4. Select Insert > Timeline > Keyframe.


The tween will last for 10 frames.


5. Make sure frame 10 is still selected and make one or 
more of the following changes to your shape:


Amorphous shape change: Click the Stage with the 
Selection tool to deselect the object. Bring the Selection 
tool close to the object to grab an edge (Figure 10). Drag 
the edge to modify the shape (Figure 11). The result is an 
amorphous shape change (Figure 12).


Different shape: To morph between your original shape 
and a new object, delete the object in keyframe 10 and 
draw a new object.


Note: Select Modify > Break Apart if the drawn object is 
not a shape.


Text: To morph between your original shape and some 
text, delete the object in keyframe 10 and type the text on 
the Stage. Select Modify > Break Apart until the text 
block is a shape, as indicated in the Properties panel.


Outside image: To morph between your original shape 
and a new image you import, delete the object in 
keyframe 10 and select File > Import to bring in the 
outside image. Select Modify > Break Apart to make the 
object a shape, as indicated in the Properties panel.


Figure 10 Select an edge of the shape


Figure 11 Drag to modify the shape


Figure 12 Amorphous shape change
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6. Click anywhere inside the tween span on the timeline and 
select Insert > Shape Tween.


Green shading with an arrow between keyframes 
indicates a shape tween span (Figure 13).


7. Select frame 1 on the timeline (on the current layer).


This is the start frame for the animation.


8. In the Tweening section of the Properties panel, adjust 
one or more properties of the Shape tween (Figure 14):


Ease: Controls how fast the object starts or ends the 
shape tween. For example, a high number begins the 
tweening quickly and ends slowly.


Blend (Distributive): Creates an animation in which the 
intermediate shapes are smoother and more irregular.


Blend (Angular): Creates an animation that preserves 
corners and straight lines in the intermediate shapes.


9. Select Control > Test Movie > In Flash Professional to 
test the movie.


10. Close the preview window.


11. To see all phases of the tween at the same time, click the 
Onion Skin button at the bottom of the Timeline panel.


12. Drag the frame handles (they appear as brackets with 
circles on them at the top of the timeline) to span the first 
10 frames of Layer 1.


The steps of the tween are all visible on the Stage.


13. Turn off onion skinning by clicking the Onion Skin 
button again.


Figure 13 Shape tween span


Figure 14 Properties panel


Classic tweens
In classic tween animation, you define keyframes at points in the animation and Flash creates the contents of the 
frames in between. The interpolated frames of a classic tween animation appear as light blue shading with an arrow 
drawn between keyframes. Because Flash documents save the shapes in each keyframe, create keyframes only at 
those points in the artwork where something changes.


You can create certain types of animated effects by using classic tweens that not possible with motion tweens.


• Add animation to symbol instances, object groups, or text


• Add timeline effects


• Paste motion tween properties


• Apply custom ease-in/ease-out settings


Note: Advanced uses of classic tweens, such as those listed here, will be dealt with in greater detail in Project 6. The 
following exercise outlines the steps for creating a simple classic tween, which serves as a basic introduction to 
classic tweening and the procedural differences between classic and motion tweening.
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To create a classic tween:


1. Start Flash and open a blank document 
(ActionScript 3.0). 


Frame 1 in Layer 1 already contains a blank keyframe.


2. Begin by adding a symbol to the Stage.


Note: You may need to add a shape, image, or text first 
and convert the object to a new symbol.


3. Select frame 10.


4. Select Insert > Timeline > Keyframe.


The tween will last for 10 frames (Figure 15).


5. Make sure frame 10 is still selected and move the symbol 
to a new position on the Stage.


6. Click between frames 1 and 10 in the timeline and select 
Insert > Classic Tween. 


The classic tween appears as light blue with an arrow 
(Figure 16).


7. Select frame 1 on the timeline (on the current layer).


This is the start frame for the animation.


8. Adjust the position, color, or scale of the symbol in the 
starting keyframe.


9. Select frame 10, and adjust the position, color, or scale of 
the symbol to be as you want the animation to end.


10. Select Control > Test Movie > In Flash Professional to 
test the movie.


11. Close the preview window.


Figure 15 Start and end keyframes


Figure 16 Classic tween span
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How to create data tables
In Adobe Dreamweaver CS6, you can use tables to format data. Tables are a powerful tool for presenting tabular data. 
A table consists of one or more rows; each row consists of one or more cells. After you create a table, you can easily 
modify both its appearance and its structure.


Although it is possible to use tables for page layout including text and images, this approach is now discouraged in 
favor of using CSS for layout. 


You can insert a new table from the Insert panel, or you can import a spreadsheet table created in a program such as 
Microsoft Excel. 


Inserting a table on a page
You can insert a table anywhere on a page, including within another table. You can quickly insert a standard table 
with three rows and three columns, or you can modify options to insert a custom table.


When you insert a table, a good idea is to set a header property for a row or column if you will use that row or column 
to provide labels for the information in the table. A header makes the table more accessible to people with visual 
impairments, because screen readers can recognize that a header contains labels. (Note that you must set a header row 
or column to provide such accessibility. It is not sufficient to use bold or centered text.)


To insert a table:


1. Open a document in Dreamweaver.


2. Place the insertion point in your document where you 
want the table to appear.


3. Select the Common category in the Insert panel, and 
make sure Standard mode is selected.


4. Click the Table button on the Insert panel (Figure 1).


The Table dialog box opens (Figure 2).


5. Enter the number of rows and columns.


6. Make changes to any of the options in the dialog box. For 
information about the options, click the Help button in 
the dialog box.


Applying a column header or row header in particular 
can improve the accessibility of a data table. The browser 
will display these headers slightly differently, and such 
headers are read by screen readers.


Figure 1 Common category in the Insert panel


Figure 2 Table dialog box

© 2012 Adobe Systems Incorporated How to create data tables 1







Project 3 guide Adobe Dreamweaver CS6


2


To set a header row or column:


1. In the Table dialog box (Figure 2), select one of the 
options in the Header section.


For example, if you create a table that lists a collection of 
books, with columns labeled Author, Title, and Year, you 
should set the top row as a header. By default, header 
rows or columns are bolded and centered (Figure 3). 
Screen readers can read this header.


2. Click OK.


The table appears in your document.


Figure 3 Table with top row set as header


Selecting table elements
You can select an entire table, a row, or a column, or you can select a contiguous block of cells within a table. After 
you’ve selected a table or cells, you can modify the appearance of the selection or of the text contained in the 
selection.


To select an entire table:


Do one of the following:


• Click the upper-left corner of the table or click 
anywhere on the bottom edge.


• Click in a table cell, and then select Modify > Table 
> Select Table.


Selection handles appear on the selected table’s lower 
and right edges (Figure 4).


Figure 4 Selection handles on a selected table


To select rows or columns:


1. Position the pointer to point at the left edge of a row or 
the top edge of a column.


2. When the pointer changes to a selection arrow, click to 
select the row or column, or drag to select multiple rows 
or columns (Figure 5).


Figure 5 A selected column in a table


To select a single cell:


Do one of the following:


• Click in the cell. Then drag to select the cell.


• Click in the cell. Then select Edit > Select All.
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Adding rows and columns
You can add a single row or column, or you can add multiple rows or columns at the same time.


To add a row:


1. Place the insertion point in a table cell, or select an entire 
row.


2. Do one of the following:


• In the Layout category in the Insert panel, click the 
Insert Row Above button or the Insert Row Below 
button (Figure 6).


• Select Insert > Table Objects > Insert Row Above or 
Insert > Table Objects > Insert Row Below.


A new row appears above or below the insertion point or 
the selected row.


Figure 6 Layout category in the Insert panel


To add a column:


1. Place the insertion point in a table cell, or select an entire 
column.


2. Do one of the following:


• In the Layout category in the Insert panel, click the 
Insert Column To The Left button or the Insert 
Column To The Right button (Figure 6).


• Select Insert > Table Objects > Insert Column To 
The Left or select Insert > Table Objects > Insert 
Column To The Right.


A new row appears to the left or right of the insertion 
point or the selected column.

© 2012 Adobe Systems Incorporated How to create data tables 3







Project 3 guide Adobe Dreamweaver CS6


4


Deleting rows and columns
You can delete a single row or column, or you can delete multiple rows or columns at the same time.


To delete rows or columns from a table:


1. Select one or more rows or columns.


2. Press Delete or Backspace.


To remove cell contents, but leave the cells intact:


1. Select one or more cells.


2. Select Edit > Clear or press Delete.


Note: If you select an entire row or column, and then 
select Edit > Clear or press Delete, Dreamweaver 
removes the entire row or column—not just their 
contents—from the table.


Resizing tables, rows, and columns
You can resize an entire table or individual rows and columns. When you resize an entire table, all the cells in the 
table resize proportionately.


To resize a table:


Select the table and do one of the following.


• To resize the table horizontally, drag the selection 
handle on the right.


• To resize the table vertically, drag the selection 
handle on the bottom.


• To resize in both dimensions, drag the selection 
handle at the lower-right corner.


To resize a column’s width:


Do one of the following: 


• Drag the right border of the column. 


• Select the column. In the Properties panel 
(Figure 7), change the number in the Column Width 
text box.


Figure 7 Table Properties panel


To resize a row’s height:


Do one of the following: 


• Drag the lower border of the row. 


• Select the row. In the Properties panel (Figure 7), 
change the number in the Row Height text box.


Column Width Row Height
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Modifying table properties
You can modify the properties of a table, its rows and columns, or its cells by using the Properties panel (Figure 8). 
Attention to table borders and cell padding (the amount of spacing between table cells) in particular can help you 
create effective table designs.


Figure 8 Table Properties panel


You can also set a row or column as a header by using the Properties panel. Table cell headers help make tables more 
useful and accessible (Figure 9).


Figure 9 Table cell Properties panel 


To modify table properties:


1. Select the table you want to modify.


2. Make changes to any of the options in the Properties 
panel (Figure 8).


To modify table row or column properties:


1. Select the row or column you want to modify.


2. Make changes to any of the options in the Properties 
panel.


To modify table cell properties:


1. In your document, select the cell or cells you want to 
modify.


2. Make changes to any of the options in the Properties 
panel (Figure 9).


To set a row or a column as header:


1. Select a row or column.


2. In the Properties panel, select the Header option.


The words in the row or column will appear centered and 
bolded (Figure 10).


Figure 10 Table with top row set as header
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Inserting a spreadsheet table
To insert a spreadsheet created in another application, such as Microsoft Excel, save the spreadsheet file in tab-
delimited (txt) or comma-separated-values format (csv). These tables are a quick way for setting up the layout for a 
catalog or directory of information.


To save a spreadsheet in TXT or CSV format:


1. Open a spreadsheet file in the program in which you 
created it, such as Microsoft Excel.


2. Select File > Save As.


3. For the file format, select either Text (Tab Delimited) or 
CSV (Comma Delimited) in the Save As Type 
(Windows) or Format (Mac OS) pop-up menu to save the 
spreadsheet as a data file.


4. Save and close the spreadsheet program.


To insert the spreadsheet into a Dreamweaver document:


1. Start Dreamweaver and open the document into which 
you want to insert the spreadsheet table.


2. Select the Data category in the Insert panel and click the 
Import Tabular Data button (Figure 11).


The Import Tabular Data dialog box opens (Figure 12)).


3. In the dialog box, click Browse and select the spreadsheet 
file. Click Open.


4. On the Delimiter pop-up menu (Figure 13), select Tab if 
you saved the spreadsheet file in tab-delimited format or 
select Comma if you saved the file in CSV format.


5. Click OK to close the Insert Tabular Data dialog box.


The contents of the spreadsheet file are displayed in a 
table on the page.


Figure 11 Import Tabular Data button on Insert 
panel


Figure 12 Import Tabular Data dialog box


Figure 13 Delimiter pop-up menu

How to create data tables © 2012 Adobe Systems Incorporated







Adobe Dreamweaver CS6 Project 3 guide

To sort table data: 


1. Select the table and select Commands > Sort Table.


The Sort Table dialog box opens (Figure 14). You can 
select which column to sort by and sort alphabetically or 
numerically. You can sort first by one column, and then 
sort the data further by a second column.


2. Select your sort preferences, and click OK.


Figure 14 Sort Table dialog box
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Design elements

		Design elements are the building blocks of graphics.

		Line

		Color 

		Shape 

		Texture 



*
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Lines

		Lines can be straight or curved.

		How are lines used in the composition on this slide?



*
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Color definitions

		Hue is another word for color.

		Chroma is the intensity or purity of color.

		Tint is a color mixed with white.

		Tone is a color mixed with gray.

		Shade is a color mixed with black.



*
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Color wheels

		Analogous colors are adjacent to each other on the color wheel.

		Complementary colors are opposite each other on the color wheel.



*



*
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Color in design

		Use color to label or show hierarchy.

		Use color to represent or imitate reality.

		Use color to unify, separate, or emphasize.

		Use color to decorate.

		Use color consistently.



*



*
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Shapes

		Shapes are enclosed objects that can be created by line or created by color and value changes that define their edges. 



*



*
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Texture

		Texture is the surface look of an object created by varying dark and light areas.

		Roughness

		Smoothness

		Depth



 

*





*
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Design principles

		Design principles are ways in which elements are used together.

		Movement 

		Balance 

		Emphasis 

		Unity 



*



*
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Movement

		Movement is the use of lines, color, and repetition to create the illusion of motion.

		Curved forms or lines 

		Repetition of geometric forms 

		Fuzzy lines or outlines



*















*
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Lines

		Lines can indicate motion or direction.

		How are lines used in the composition on this slide?



*



*
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Balance

		Balance is the act of comparing or estimating two things, one against the other, and the contrast between:

		Empty space (white space) and filled space

		Text and images

		Color and no colors and different colors

		Textures against flat colors



*









*

Ask students if they can think of other types of balance: texture and no texture (smooth), size and scale, elements of a composition.
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Balance in composition

		There are three different types of balance when using color, shape, and position:

		Symmetry

		Asymmetry

		Radial symmetry



*



*
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Symmetrical or formal balance

		You can usually identify at least one of three lines of symmetry.

		Horizontal

		Vertical

		Diagonal



*



*
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Symmetrical balance

*



*

The rectangle has three lines of symmetry: Horizontal (blue), Vertical (red), Diagonal (yellow).

The triangle has only one line of symmetry: center or, in this orientation, Vertical. You can draw two other lines of symmetry from any of the vertices to the center of the opposite side.
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Examples of symmetrical balance

*



*
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Examples of asymmetrical balance

*



*
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Examples of radial balance

*



*
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Unity

		Unity: The correct balance of composition or color that produces a harmonious effect.

		What is the focus of the message?



*



*









© 2012 Adobe Systems Incorporated.  All Rights Reserved.



Emphasis

		Emphasis: To express with  particular stress or force.

		What message is stressed here?



*



*
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Summary

		The basis of good design is use of design elements and their thoughtful application in the form of design principles.

		Clearly identify what you are trying to accomplish — use design to convey your message.

		Brainstorm alternatives.



*



*
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How to design for usability
Good web usability is defined as: easy to use, quick to learn, and providing an overall satisyfying experience. A well-
designed, usable site aims to enhance the user experience by elevating a website’s percieved efficiency, elegance, and 
clarity.


Usability is a combination of factors including design, information architecture, accessibility, and support across 
various devices. Usability.gov (usability.gov/basics/index.html) provides a list of these important factors:


• Ease of learning How fast can a user who has never seen the user interface before learn it sufficiently well to 
accomplish basic tasks?


• Efficiency of use Once an experienced user has learned to use the system, how fast can he or she accomplish 
tasks?


• Memorability If a user has used the system before, can he or she remember enough to use it effectively the 
next time or does the user have to start over again learning everything?


• Error frequency and severity How often do users make errors while using the system, how serious are these 
errors, and how do users recover from these errors?


• Subjective satisfaction How much does the user like using the system?


Compare the two Coast Middle School examples shown in Figure 1. The before and after screenshots demonstrate 
the difference between poor web usability, and a subsequent site redesign that results in much-improved user 
experience.


Figure 1 Examples poor web usability (left) and improved web usability (right)


Consider the following as you plan the content and navigation of your website project.


Content
How you organize content on a page highlights important features and elements of your site. Important elements 
might be higher in the page, larger in size, or in stronger colors. Include rough descriptions of navigation, copy 
layout, graphic allocation, key headers, and other elements that appear on a screen. Identifying common structures 
between pages helps visitors understand they are in the same site as they navigate from page to page.


• Will your page banner be on each page? If yes, is it in the same place? Is it the same size?


• What font will you use for titles or headings on your content pages?


• What color will you use for titles or headings on your content pages?
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• What font will you use for descriptions on your content pages?


• What color will you use for descriptions?


Navigation
For visitors of your website to understand the content, you must provide clear navigation. Visitors need to know 
where they are in a site, where they need to go, and how to get back to where they came from. Having a consistent 
layout grid helps orient visitors and keeps them from feeling lost. Using consistent buttons, links, and graphics on 
each page maintains a sense of place. As visitors move from page to page, provide familiar visual cues and 
navigational aids.


• Where will you place the navigation bar on the page?


• What content will be on the navigation bar?


• Will the navigation bar be on every page?


• How will your navigation bar help visitors know which page they are on?


Resources
Get more information about web usability best practices from these resources:


• usability.gov is the primary government source for information on usability and user-centered design.


• www.useit.com website for leading web usability consultant, Jakob Nielsen.
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How to create a design comp
A comprehensive artwork (comp for short) is a design proposal presented by the designer to the client for approval. 
Web design comps provide a rough visual draft of the overall user interface (including graphics, interface design 
elements, navigation system, and main content areas) before specific content is placed (Figure 1).


Fireworks provides an ideal prototyping environment, seamlessly converting design comps into real-world widgets, 
websites, and applications.


Figure 1 Design comp 


The web design process
The typical web design process may be comprised of several stages, including any of the following:


1. Brief provides a statement of technical, design, and idea goals for the web project.


2. Research involves a range of investigative activities including a review of related web designs, analysis of 
competitor sites, user flows, personas, market analysis, use cases, and more.


3. Brainstorming is a conceptualizing stage based on the brief and research stages in which many ideas are 
generated in a short amount of time. 


4. Creative solution follows the brainstorming phase in which briefs, research, and ideas are combined to 
create a clear design direction. This stage can include technical specifications, information architecture 
diagrams, functioning wireframes, and design comps. This stage is often iterative, a repeating process in 
which problems are solved, designs are presented to clients for feedback, website functionality is developed 
and tested, and revisions are made.


5. Production fully realizes the web project. Design comps are finalized and integrated into the wireframe 
prototype, and the web project is scaled up to full production. 


As you can see, the design comp is an important piece of the web design process from the creative solution right to 
the production stage. 


Consider the following questions as you plan and build your design comp for a web project.
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Organizing content


How you organize content on a page highlights important features and elements of your web project. Important 
elements might be higher in the page, larger in size, or in stronger colors. Include rough descriptions of navigation, 
copy layout, graphic allocation, key headers, and other elements that appear on a screen. Identifying common 
structures between pages helps visitors understand they are in the same site as they navigate from page to page.


• Will your page banner be on each page? If yes, is it in the same place? Is it the same size?


• What font will you use for titles or headings on your content pages?


• What color will you use for titles or headings on your content pages?


• What font will you use for descriptions on your content pages?


• What color will you use for descriptions?


Navigation


For visitors of your website or application to understand the content, you must provide clear navigation. Visitors need 
to know where they are in a site, where they need to go, and how to get back to where they came from. Having a 
consistent layout grid helps orient visitors and keeps them from feeling lost. Using consistent buttons, links, and 
graphics on each page maintains a sense of place. As visitors move from page to page, provide familiar visual cues 
and navigational aids.


Here are some questions to answer:


• Where will you place the navigation bar on the page?


• What content will be on the navigation bar?


• Will the navigation bar be on every page?


• How will your navigation bar help visitors know which page they are on?


Creating a design comp with Adobe Fireworks CS6 
The following steps describe a typical proces to follow when using Fireworks to create a design comp. The design 
comp process described here uses previously-prepared files including a background image, logo, text, and a 
photographic image.


To create the canvas and import files:


1. Start Fireworks and create a new document using the 
dimensions for your web project. 


2. With Layer 1 selected, choose File > Import.


The Import dialog box (Windows) or Import File dialog 
box (Mac OS) opens.


3. Navigate to a background image you want to use, and 
click Import (Windows) or Open (Mac OS).


4. Click in the upper-left corner of the canvas to place the 
imported background at that location. 


The background image is placed on the canvas.
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5. In the Properties panel, confirm that the X and Y 
coordinates are both set to 0 (Figure 2).


6. Choose File > Import.


The Import dialog box (Windows) or Import File dialog 
box (Mac OS) opens.


7. Navigate to a logo file and click Import (Windows) or 
Open (Mac OS).


The Import Page dialog box opens (Figure 3).  


A single Fireworks PNG file can contain multiple pages. 
When you insert a PNG file, or page, containing objects 
from the master layer, the master page is converted to an 
ordinary layer, and imported. 


8. Click the Import button (Windows) or Open button (Mac 
OS) in the Import Page dialog box.


9. On the canvas, click near the top edge and to the right of 
the upper-left corner to place the imported logo at that 
location.


The logo image is placed on the canvas. 


10. Choose File > Import.


The Import dialog box (Windows) or Import File dialog 
box (Mac OS) opens.


11. Navigate to a photograph file and click Import 
(Windows) or Open (Mac OS).


12. On the canvas, click in the main content area to place the 
imported logo at that location.


The photograph is placed on the canvas. 


13. Select File > Save As and save the file as a PNG.


Figure 2 Properties panel, bitmap mode


Figure 3 Import Page dialog box


To use drawing tools, fills, and the alignment panel:


1. From the Tools panel, select the Rectangle tool.


2. In the Properties panel, click the Gradient Fill button.


The Edit Gradient pop-up window opens (Figure 4). 


3. Set the gradient type to Linear, if not already selected.


Figure 4 Properties panel, Edit Gradient window


X and Y 


Gradient Fill Color swatches


Gradient type


Solid Fill
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4. Click the color swatch on the left and select a dark-gray 
color such as HEX value #222222 (Figure 5) .


5. Click the color swatch on the right and select a slightly 
lighter gray color such as HEX value #333333.


6. Click the Gradient Fill button again to close the Edit 
Gradient window.


7. Drag to draw a rectangle shape at the bottom of the 
canvas.


This rectangle will become the web page footer.


8. Choose Select > Deselect.


9. From the Tools panel, select the Rounded Rectangle tool.


10. In the Properties panel, click the Solid Fill button and 
choose a light-gray color such as HEX value #CCCCCC.


Note: You could choose instead to add a gradient fill to 
the rounded rectangle shape.


11. Click the Solid Fill button again to close the color pop-up 
window.


12. In the Properties panel, set Stroke Color to white (HEX 
value #FFFFFF), and confirm Tip Size is 1, and Stroke 
Category is 1-Pixel Soft (Figure 6).


13. Make sure Smart Guides are visible and active. If not, 
select View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.


14. Drag on the canvas to draw a rounded rectangle suitable 
for use as a button.


15. Select the rounded rectangle shape.


16. Select Edit > Duplicate three times to create a total of 
four buttons.


As you repeat the command, duplicates of the selected 
object appear in a cascading arrangement from the 
original. Duplicates appear 10 pixels lower and 10 pixels 
to the right of the previous duplicate. The most recently 
duplicated object becomes the selected object.


17. Select the Pointer tool and drag a rounded rectangle over 
to the right until the Smart Guides appear along the top, 
and right edge of the object (Figure 7).


18. Arrange the remaining shapes in a row between the first 
and the last rounded rectangle. 


Don’t worry about the spacing, you’ll take care of that in 
the next few steps.


19. Choose Window > Align to open the Align panel 
(Figure 9).


20. Shift-click the four rounded rectangle shapes, either on 
the canvas, or in the Layers panel.


Figure 5 Color pop-up window


Figure 6 Properties panel, shape mode


Figure 7 Aligning objects using Smart Guides


Figure 8 The Align panel
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21. In the Align panel, click the Align Vertical Center button 
and the Space Evenly Horizontally button.


The rounded rectangle shapes are vertically aligned and 
spaced evenly on the canvas.


22. Select File > Save.


To use text tools:


1. Select the Text tool from the Tools panel.


Text in a Fireworks document appears inside a text block 
(a rectangle with handles).


2. Set text characteristics in the Properties panel (Figure 9):


• Font Family: Georgia


• Font Style: Regular


• Font Size: 46


• Font Color: HEX value #ECECEC


3. Click on the canvas just below the logo to create an auto-
sizing text block.


An auto-sizing text block expands horizontally as you 
type and shrinks when you remove text. Auto-sizing text 
blocks are created by default when you click on the 
canvas with the Text tool and start typing.


4. Type Shop. 


5. Choose Select > Deselect.


6. With the Text tool still selected, change Font Family to 
Verdana, and Text Size to 16 and confirm the text is left 
aligned.


7. Drag on the canvas between the Shop title and the 
photograph to create a fixed-width text block 
(Figure 10).


A fixed-width text block allows you to control the width 
of wrapped text. Fixed-width text blocks are created by 
default when you drag to draw a text block using the Text 
tool. 


8. Add placeholder text to simulate two or three paragraphs 
of text.


9. To move the text block, drag it with the Pointer tool. To 
resize it, drag a resize handle.


10. Choose Select > Deselect.


11. Select the Text tool, and change Font Family to Georgia, 
Text Size to 21, and Text Color to dark gray (HEX value 
#222222).


Figure 9 Properties panel, text mode


Figure 10 Drag with Text tool to create a fixed-
width text block


Font Family


Font Style


Font Color


Alignment


Font Size
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12. Click on the first rounded rectangle to create an auto-
sizing text block.


13. Type Shop.


14. Select the Pointer tool and drag the text block until the 
horizontal and vertical Smart Guides appear so that the 
text is centered over the rounded rectangle (Figure 11).


15. Shift-click the text block and the rounded rectangle and 
choose Modify > Group.


16. Repeat steps 12 to 15 to create three more navigation 
buttons for Designer, Our Shop, and Blog.


17. Create a text block at the bottom of the page, over the 
dark-gray footer rectangle and add some footer text.


18. Select File > Save.


Figure 11 Use Smart Guides to align text and 
objects

How to create a design comp © 2012 Adobe Systems Incorporated
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How to import sound
In Adobe Flash Professional CS6, you can import sounds and integrate them into the timelines of your main 
document and symbols. For example, you can enhance user experience by adding short sound clips or audio loops to 
navigation elements. You can also add music or narration audio and synchronize that sound with moving objects to 
help tell a story or explain a concept.


Importing sound
You can import the following sound file formats into Flash:


• ASND Adobe Sound Document


• WAV (Windows only)


• AIFF (Mac OS only)


• MP3 (Windows or Mac OS)


If you have QuickTime 4 or later installed on your system, you can import these additional sound file formats:


• AIFF (Windows or Mac OS)


• Sound Designer II (Mac OS only)


• Sound Only QuickTime Movies (Windows or Mac OS)


• Sun AU (Windows or Mac OS)


• System 7 Sounds (Mac OS only)


• WAV (Windows or Mac OS)


When you import a sound file, it’s placed in the library. Then you can drag an instance (copy) of the sound onto the 
Stage. Sound files must be tied to keyframes.


You can synchronize a sound to your movie in several ways by using the Sync pop-up menu in the Properties panel:


• Event: An event sound plays when the playhead reaches the first keyframe containing the sound. It plays in its 
entirety, independent of the timeline, even if the movie stops. If a different instance of the same sound is started, 
the sounds will overlap.


• Start: The same as Event, except that if the sound is already playing, no new instance of the sound will begin 
playing.


• Stop: Silences the specified sound.


• Stream: Forces the movie to keep pace with the sound. If Flash can’t draw animation frames quickly enough, it 
skips frames. Unlike event sounds, stream sounds stop if the movie stops. Stream sounds can also produce a 
much smaller file size, although their quality tends to be poorer than event sounds.
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Importing a Sound
You import sounds into the library, then drag them onto the Stage to add them to the timeline.


To import a sound:


1. Start Flash and open a document.


2. Insert a new layer.


3. Double-click the new layer name, and rename it Sound.


4. Select File > Import > Import To Library.


The Import To Library dialog box appears (Figure 1).


5. Locate a sound file, select it, and click Open (Windows) 
or Import To Library (Mac OS).


Note: You can download free music loops and sound 
effect clips at www.flashkit.com, for example.


6. Select frame 1 on the Sound layer.


7. Make sure the Library panel is open. (If not, select 
Window > Library.)


The sound appears in the Library panel. To preview the 
sound, you can select it and click the Play button in the 
preview (upper) pane of the Library panel (Figure 2).


8. Drag a sound file from the Library panel onto the Stage.


The Sound layer must contain enough frames to play the 
entire sound. For example, if your movie is set for 12 
frames per second and your sound is 2 seconds long, the 
Sound layer must contain at least 24 frames. If you are 
adding sound to an existing movie, your movie might 
already be long enough to accommodate the sound.


9. If necessary, add frames to the Sound layer. To do this, 
click a frame down the timeline for the Sound layer, such 
as frame 24 for a 2-second movie at 12 fps, and select 
Insert > Frame.


The sound does not appear on the Stage but does appear 
on the timeline as a waveform (Figure 3). 


Note: You can also press the F5 key to insert a frame and 
press Shift-F5 to delete a frame.


Figure 1 Import To Library dialog box


Figure 2 Library panel


Figure 3 Sound in the timeline


Play button
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Editing sound settings
In the Properties panel, you can change settings for the sound, including making the sound fade in and fade out.


To edit sound settings:


1. Continue where you left off in the previous task.


2. Select the first keyframe in the Sound layer and adjust the 
settings for the sound in the Properties panel (Figure 4).


• Effect: Choose from previously created effects such 
as Fade In, Fade Out, keeping sound in only one 
channel (left or right), or fading sound from one 
channel to the other (Figure 5). Choosing Custom or 
clicking the Edit Sound Button (pencil) opens a 
sound-editing window where you can create your 
own fading effects (Figure 6). In the sound-editing 
window, called the Edit Envelope dialog box, adjust 
the sound handles to control sound volume in each 
channel.


• Sync: Choose Event, Start, Stop, or Stream.


• Loop: Set the number of times to have the sound 
replay.


Figure 4 Properties panel


Figure 5 Effect pop-up menu


Figure 6 Edit Envelope dialog box
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Sound compression
Sound files can drastically increase the file size of your movies. One way to control this is to set the compression for 
the sounds in Flash.


To compress sound:


1. Make sure the Library panel is open, and select a sound 
file.


2. Click the Properties button in the Library panel 
(Figure 7).


The Sound Properties dialog box appears (Figure 8).


3. Choose a compression method from the Compression 
menu (Figure 9) and click OK.


• ADPCM: This method sets the compression for 8-bit 
and 16-bit sound data. Use this when you export 
short event sounds such as button clicks.


• MP3: This method offers good compression and 
sound fidelity for longer stream sounds such as 
music tracks.


• Raw: This resamples the file but does not perform 
any compression.


• Speech: A good compression to use for speech sound 
files.


4. Save the movie.


5. Select Control > Test Movie > In Flash Professional.


Figure 7 Library Properties button


Figure 8 Sound Properties dialog box


Figure 9 Compression menu


Library Properties button
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Designing for multiple screens

		With so many devices used to view content on the Internet, web designers must now consider how a site appears and functions on multiple screens.

		A few considerations:

		Target devices and their screen sizes

		How effectively a design scales to multiple screen sizes

		How a design appears when viewed in landscape and portrait views

		Readability of the content on small screens, such as on mobile phones

		How users interact with a site, such as navigating pages or zooming screens

		Compatibility with operating systems on devices



*

  

  

  

  



*

The question of viewing a site in landscape or portrait is important if viewers will access the site from a mobile device with auto rotation enabled. 

Compatibility with different runtimes and operating systems: It used to be that a web designer had to consider whether a site would display properly in multiple browsers, but now a designer must also consider whether features and functionality of the site work in browsers, Android devices, iOS devices, Nokia devices, Motorola devices, and so on.
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Designing for multiple screens

Decide which devices you’re targeting:

		Standard desktop monitors

		Wide-screen desktop monitors

		Laptops and netbooks

		Mobile devices such as

		Smartphones (iOS, Android, 

BlackBerry, and Windows)

		Tablets, such as iPad, Samsung Galaxy, and Kindle Fire







*



Desktop standard monitors are 4x3 aspect ratio

Desktop wide-screen monitors are 16x9 aspect ratio

*
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Trends in web design for multiple screens

You can design web content for multiple screens.  Each approach has its benefits and challenges.

		Create a responsive or flexible design that adapts automatically to each user’s screen.

		Create multiple versions of the same website and redirect users to the appropriate version of your content.

		Create native mobile applications aimed at specific mobile devices and operating systems. Suggest that mobile users download and install the mobile app instead of using their mobile web browser to view the web version of the content.





*



Multiple versions and redirecting users:  Another method for delivering a mobile design is to build an especially optimized layout for handheld devices.  For example, you create an experience specifically for your mobile users without taking away from the experience of desktop users. For this to work, you will have to route traffic on your site depending on the user’s browser agent. For example, if a mobile device user visits your site (yousitename.com), then they will automatically be redirected to  the mobile alternative URL.

*
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Responsive designs

		A responsive or flexible design scales and adapts your content to the screen and capabilities of each device. 

		Because so many devices in use, a cross-device web design is difficult to create, but there are some ways to make each website more responsive.

		The basic idea of responsive web design is that a website should respond to the device it’s being viewed on. For example:

		Adapting the layout to suit screen sizes (from widescreen desktops to phones)

		Resizing images to suit the screen resolution

		Using lower-resolution images for mobile devices

		Simplifying page elements for mobile use

		Hiding nonessential elements on smaller screens

		Providing larger, finger-friendly links and buttons for mobile users

		Detecting and responding to mobile features such as geolocation and device orientation



*

  

  

  

  



*
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When designing web content for multiple screens, you’ll need to consider how things such as page layout, fonts, navigation, buttons, and rich media affect your site’s usability when viewed on different devices.

Consider the following best practices: 

		Begin with a detailed design plan; research your target audience and devices.

		Use a consistent theme throughout your design.

		Simplify navigation and content layouts.

		Use icons to save space and improve usability.

		Include white space for better readability, especially on smaller screens.

		Limit the need to scroll, or use vertical scrolling only for longer pages. 

		Limit the use of large images (large file sizes).

		Optimize content for faster access and a better user experience.



Design best practices

*

  

  

  

  



*
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Consider these additional best practices: 

		Use video and audio sparingly (unless your site depends on it).

		Take into consideration devices without a mouse or other pointing device. For example, can viewers use the site touch screens?

		Use cookies sparingly.

		Enable automatic sign-in for secure content.

		Use Fluid Grid Layouts and CSS Media Queries in Adobe Dreamweaver CS6 to create flexible designs for multiple screens.

		Test on multiple devices or use device emulators.



Design best practices

*

  

  

  

  



*

Use cookies sparingly if one of your target screens is a mobile device. Cookie support cannot be relied upon since it may be disabled either in the device or by the mobile network. 

Enable automatic sign-in for secure content. This is especially important on a mobile device where data input is more difficult than on a desktop. If automatic sign-in is enabled, then your application should also include a link or button to sign out.

One way to test it to deploy your application on each target device. Another option is to test with device emulators. For example, Adobe Flash Professional CS6 includes a built-in mobile simulator for testing accelerometer, input, and geolocation features in a mobile application. Search online and you’ll find emulators for most devices, including Android, iPhone, Blackberry, and Windows—just to name a few.
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One of the most common challenges in designing for the small screens of mobile devices is to balance creativity with ease-of-use. Anything that simplifies your layout and navigation will work to your advantage.

These design strategies help users find and view what they’re looking for:

		Keep buttons large, with extra padding and spacing. Many devices have touch screens on which bigger buttons mean easier clicking.

		Keep navigation simple. Don’t flood a navigation bar with several options; instead choose five or fewer, and create sub-navigation if necessary. 

		Vertical navigation menus make viewing longer lists easier on many mobile input devices. 

		Use buttons (or icons) instead of standard text links for navigation.

		Avoid pop-ups or spawned windows.



Keep navigation simple

*

  

  

  

  



*
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Fluid Grid Layouts

		Adobe Dreamweaver CS6 streamlines the task of building adaptive designs for multiple screens with its integrated fluid grid.

		You can use CSS3 to create Fluid Grid Layouts that scale themselves to multiple screen sizes.



*

  

  

  

  



*
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Fluid Grid Layouts

*

  

  

  

  

In this example, a Fluid Grid Layout displays the page in a web browser.



*
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Fluid Grid Layouts

*

  

  

  

  

The Fluid Grid Layout displays the same page on a tablet.



*
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Fluid Grid Layouts

*

  

  

  

  

An now, the same page on a mobile phone.



*
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CSS media queries

The challenge is to ensure that your websites look good not only on a big screen but also on a tiny phone and everything in between.

		Media queries are an excellent way to deliver different styles to different devices, providing the best experience for each type of user. 

		A part of the CSS3 specification, media queries expand the role of the media attribute that controls how your styles are applied. 

		It has been common practice for years to use a separate style sheet for printing web pages by specifying media="print."  Media queries take this idea to the next level by allowing designers to target styles based on a number of device properties, such as screen width and orientation.



*

  

  

  

  



*
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CSS media queries

Here is an example of a simple media query:

<link rel="stylesheet" type="text/css"

 media="screen and (max-device-width: 480px)"

 href=“stylesheet.css" />

*

  

  

  

  

		If the browser displays this page on a screen that is less than 480 pixels wide, load stylesheet.css

		CSS3 also includes orientation (portrait or landscape), device-width, min-device-width, and many more media queries.

		View the examples on the next three slides to see how CSS Media Queries display the same website on three very different screens.





*
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CSS media queries

In this example, a media query is used to display the page in a web browser.

*

  

  

  

  

When viewed on a desktop, the page has a two-column layout.



*
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CSS media queries

The media query is used to display the same page on a tablet screen.

*

  

  

  

  

The layout switches to a single column to fit the narrower screen of a tablet.



*
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CSS media queries

And now, on a mobile phone.

*

  

  

  

  

Media queries restyle the page to fit the constraints of a much smaller screen.



*
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Summary

		Smart phones, tablets, and other mobile devices are everywhere, and demand for the same content on multiple screens is growing. 

		As content designers, many of the principles you’ve learned for web design apply to the creation of mobile content, but there are some important differences.

		The challenge for web designers is to ensure that your websites look good not only on a big screen but also on a tiny phone and everything in between. 

		When creating web content, you need to decide which devices you want your sites to be viewed. If you’re targeting multiple screens, consider creating a separate site targeted at each device, or make your site flexible or responsive to multiple screens.

		You can create flexible content by using Adobe Dreamweaver CS6 Fluid Grid Layouts and CSS media queries.



*

  

  

  

  



*
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Tips for information architecture
Information architecture (IA) is a method of organizing and labeling a website structure to support usability. Careful 
consideration of the content and organization of a site is the first step to creating an effective user experience. Also 
referred to as information design, structuring is about connecting users to the content and organizing information 
intuitively. It is also about blueprinting the site from a functional perspective to communicate easily with a client and 
a team. Ultimately, understanding what users are looking for and allowing easy access to content and information is 
the overall goal. It’s all about ensuring that users can get what they came for. A well-designed information 
architecture is similar to a table of contents. It helps improve discoverability, efficiency, satisfaction, and overall 
usability of a website.


[Information architecture is]…creating consistent and functional systems for 


navigation,  graphics, page layout and title languages, so that the user knows 


where to go, what to do, and encourages him or her to return.


- Web Review, Peter Monville


The information architecture step usually falls within the structure phase of web project production, before you create 
wireframes, design comps, and prototypes. 


Consider the following best practices when creating a well-designed information architecture.


Research the needs of the audience and users
Who is your target audience? What kind of user are you trying to attract to the website? These important initial 
questions inform the way you structure content and information. You must create the information architecture of your 
site with your audience in mind.


Identify a clear purpose for the site
Always keep the goals in mind while you’re creating the information architecture. Every website needs a clear goal: 
to educate, inform, entertain, market, sell, or any combination of these. Establishing clear goals helps you structure 
effective information architecture.


Inventory and assemble site content
You may be working on a new website from scratch or redesigning an existing website. Regardless, it’s important to 
perform an inventory of content you already have and describe any new content to be created. The content is the core 
of the site, so you need to know if it is suitable for your audience and supports the overall goals of the site. Another 
consideration is presenting content across multiple screens and devices. You should structure content carefully so it 
presents well on a range of computers, tablets, and smartphones.


Assemble site content into logical groups
Content and structure are intertwined. Assembling content into logical groups helps establish clear and consistent site 
organization and facilitates the task of defining the information architecture.
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Create a site map
Your site’s structure is composed of the categories and logical groups you just created. A site map serves as a bird’s-
eye view of the project that enables you to see how the site is organized and how users will view the site’s content and 
information. The site map becomes a blueprint that shapes the structure of the site during the development process. 
The site map should show main areas of content and represent all the pages within each section (Figure 1). 


Figure 1 Example site map for Coast Middle School website


Design navigation systems
Clear navigation helps connect users with the content on your site. Buttons, links, and graphics can be used from each 
screen to maintain a sense of place. Users need to stay oriented to where they are in the site, where they need to go, 
and how to get back to where they came from. Having a consistent navigation helps orient users and keep them from 
feeling lost. As users move from page to page, make sure they find familiar visual cues and navigational aids.


Summary
The information architecture, a component of the structuring stage, is complete. You have created a content site map 
and designed a set of navigation elements. Don’t underestimate the importance of the structuring phase, as it’s crucial 
to successfully realizing the next phase: design and prototyping.

Tips for information architecture © 2012 Adobe Systems Incorporated





		Tips for information architecture

		Research the needs of the audience and users

		Identify a clear purpose for the site

		Inventory and assemble site content

		Assemble site content into logical groups

		Create a site map

		Design navigation systems

		Summary












Adobe Flash Professional CS6 Project 5 guide

How to use transparent or invisible buttons
If you create a button with no graphics in the Up, Over, or Down states, the button will be transparent. However, you 
can control how a transparent button will operate when a visitor clicks within the hit area. You can use transparent 
buttons in Adobe Flash Professional CS6 in the same way you use hot spots in an image map in Adobe Dreamweaver 
CS6.


Create a button
Your first step is to create a button symbol and add an instance of the button to the Stage.


To create a button:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Rename Layer 1 Graphics.


3. Insert a new layer and name it Button.


4. On the Graphics layer, add a photo or a graphic to the 
Stage.


The document illustrated in Figure 1 contains a photo of 
San Francisco. You can place transparent buttons over 
different areas of a photograph. Viewers can then click 
different parts of the photo to navigate to information 
about the subjects in the photograph. 


In this activity, you create a transparent button used to 
turn the hillside (in the background) into a clickable area 
linked to more information.


5. Select the Button layer.


6. Select the Rectangle tool.


7. Choose any color for the fill.


8. Set Stroke Color to No Color.


9. Draw a rectangle over an area in the photograph or 
graphic to which you want to add a button (Figure 2).


10. Select the Selection tool.


11. Click the rectangle to select it.


12. Select Modify > Convert To Symbol.


13. In the Convert to Symbol dialog box, type a name for the 
button in the Name text box.


14. Select Button as the Type.


15. Click OK.


The button is added to the library. The instance of the 
button remains on the Stage. 


Figure 1 Photograph 


Figure 2 Rectangle drawn over hill


Shape used to create the button 
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Make a button transparent
In the following steps, you add a keyframe to the Hit frame of the Button symbol timeline, then delete the button in 
the Up frame. The result is a button that is active, but not visible in the Flash document.


To make a button transparent:


1. Continue from where you left off in the preceding 
activity.


2. On the Stage, double-click the button instance.


The button opens in symbol-editing mode. The Up frame 
is selected in the Timeline panel.


3. Add a keyframe to the Hit frame.


4. Select the Up frame.


5. Press Delete.


The colored rectangle representing the button on the 
Stage disappears.


The Hit frame should be the only frame containing a 
colored rectangle on the Stage. The Up, Over, and Down 
frames are empty, which makes the button invisible. 
(Figure 3).


6. On the edit bar, click Scene 1 to exit symbol-editing 
mode and return to the main timeline.


The button is now transparent. Although you can still see 
it on the Stage (Figure 4), the button will not be visible 
when the movie plays.


In this example, the button represents the hills. You can 
now link this instance of the button to information about 
this part of the photo. 


You can also add other instances of the transparent button 
to other parts of the document, such as over other areas of 
the photo. You can use the Free Transform tool in the 
Tools panel to resize each instance of the button. 


Figure 3 Only the Button Hit frame has content


Figure 4 Transparent button over the photograph 
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Add ActionScript to launch a website
In the following steps, you use ActionScript code to instruct Flash to open a web page when a user clicks the 
transparent button. 


To add ActionScript to launch a website:


1. Continue from where you left off in the preceding 
activity.


2. Select the button instance to which you want to add an 
action.


3. Click in the Instance Name box in the Properties panel 
(Figure 5) and enter a unique name to identify the button 
instance. The name should be descriptive, such as 
hills_btn, and cannot contain spaces. 


4. In the main timeline of your movie, create a new layer 
named Actions.


5. Make sure there is a keyframe in the Actions layer that 
corresponds to the keyframe where your button first 
appears on the Stage. Select this keyframe in the Actions 
layer.


Note: If your button doesn’t appear on this frame, Flash 
generates an error message when you publish the movie 
because the ActionScript you include on this frame refers 
to an object that isn’t on the Stage yet.


6. Select Window > Actions to display the Actions panel.


7. If you don’t see the parameters area in the Actions panel, 
click the Script Assist button.


8. In the Actions toolbox on the left side of the panel, 
expand Flash.Events, EventDispatcher, and Methods. 
Double-click AddEventListener.


The AddEvent listener is added to the Script pane of the 
Actions panel (Figure 6).


9. Click in the Object box in the parameters area of the 
Actions panel.


The Insert A Target Path button is now active.


10. Click the Insert A Target Path button.


The Insert Target Path dialog box appears (Figure 7).


11. Select the Relative option, select the instance name of 
your button, and click OK.


12. In the Actions toolbox on the left side of the panel, 
expand Flash.Events, MouseEvent, and Properties. 
Locate the CLICK Property.


13. In the Script pane, select the AddEventListener() line to 
display the parameters for this method. Then click in the 
Type box in the parameters area.


Figure 5 Properties panel


Figure 6 AddEventListener method in the Actions 
panel


Figure 7 Insert Target Path dialog box

© 2012 Adobe Systems Incorporated How to use transparent or invisible buttons 3







Project 5 guide Adobe Flash Professional CS6


4


14. In the Actions toolbox, double-click the CLICK property.


Script Assist adds the property to your code as 
MouseEvent.CLICK (Figure 8).


15. In the Listener box in the parameters area, type a name 
for the function that should execute when a user clicks 
the button. You can use any name you like, but make sure 
the name of the function is unique and contains no 
spaces. (example: openURL) 


The function name appears in the Script pane as you type. 
You have named the function, but you haven’t created it 
yet.


16. In the Actions toolbox, expand Language Elements, 
Statements, Keywords & Directives, and Definition 
Keyword. 


17. Double-click Function in the Actions toolbox.


The code for creating a function appears in the Script 
pane.


18. In the parameters area of the Script pane, type the name 
of your function in the Name box.


Note: The function name must be typed exactly as you 
typed it for the AddEventListener function. Function 
names are case-sensitive.


19. In the parameters area of the Script pane, type 
event:MouseEvent in the Parameters box (Figure 9).


In this box, you are naming a variable (event) and 
indicating what type of variable it is (MouseEvent).


20. In the Actions toolbox on the left side of the panel, 
expand Flash.Net and Methods. 


21. Select the function line in the Script pane and double-
click the NavigateToURL method in the Actions toolbox.


The method is added to the function (Figure 10).


Figure 8 CLICK property in the Actions pane


Figure 9 Function parameters


Figure 10 NavigateToURL method in the Actions 
panel
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22. In the Request box, type:


new URLRequest( "http://www.adobe.com" ) 
(Figure 11).


Note: Be sure to include the spaces between the 
parentheses and the quotation marks.


You can replace www.adobe.com with a web address of 
your choice.


23. Collapse the Actions panel.


24. Save the document.


25. Select Control > Test Movie > In Flash Professional to 
test the button.


26. Click the area of the graphic on which you created the 
invisible button.


A browser window opens and navigates to the website 
you defined for the button.


Figure 11 URL entered in the Request box


For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, 
select Help > Flash Help).
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		How to use transparent or invisible buttons

		If you create a button with no graphics in the Up, Over, or Down states, the button will be transparent. However, you can control how a transparent button will operate when a visitor clicks within the hit area. You can use transparent buttons in Adob...

		Create a button

		Your first step is to create a button symbol and add an instance of the button to the Stage.

		To create a button:





		To create a button:

		Figure 1 Photograph

		Figure 2 Rectangle drawn over hill



		Make a button transparent

		In the following steps, you add a keyframe to the Hit frame of the Button symbol timeline, then delete the button in the Up frame. The result is a button that is active, but not visible in the Flash document.

		To make a button transparent:

		Figure 3 Only the Button Hit frame has content

		Figure 4 Transparent button over the photograph





		Add ActionScript to launch a website

		In the following steps, you use ActionScript code to instruct Flash to open a web page when a user clicks the transparent button.

		To add ActionScript to launch a website:

		Figure 5 Properties panel

		Figure 6 AddEventListener method in the Actions panel

		Figure 7 Insert Target Path dialog box

		Figure 8 CLICK property in the Actions pane

		Figure 9 Function parameters

		Figure 10 NavigateToURL method in the Actions panel

		Figure 11 URL entered in the Request box

		For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, select Help > Flash Help).
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Mobile application design and development
Play a game, buy (and read) a book, check your e-mail, select a restaurant, pay your bills, or find your way to the 
party. This is just some of what you can do while on the move. With the proliferation of smarter and cheaper mobile 
devices, people’s expectations for using mobile phones and tablets are rising rapidly. But as mobile devices 
increasingly make our lives easier, they also present new challenges for designers and developers of interfaces and 
applications. For example, limited mobile screen space and navigation restrictions require careful project planning 
and design. This guide presents guidelines and best practices for mobile application design and development.


Design best practices
In a perfect world, each device would simply scale and adapt your content to its screen and unique capabilities. But 
with the growing number of devices and competing mobile operating systems, you’ll need to develop native 
applications for your target devices—for example, one application for Apple iOS devices (iPads and iPhones) and 
alternatives for Android, Windows, BlackBerry, and other devices. The good news is that most mobile devices share 
similar challenges and capabilities, so well-planned designs that target one mobile screen can quickly be adapted to 
another. This is especially true if you create applications by using a tool such as Adobe Flash Professional CS6, 
which includes adaptive scaling and other multiscreen design features. 


As you embark on your journey into mobile application design, keep in mind the following guidelines and best 
practices:


• Begin with a detailed design plan.


• Research your target audience and devices.


• Use a consistent theme throughout your design.


• Include extra white space for better readability.


• Avoid the need to scroll by keeping menus and pages as short as possible. 


• Simplify navigation and content layouts.


• Use icons to save space and improve usability.


• Optimize content for faster access and a better user experience.


• Use video and audio sparingly (unless your application depends on it).
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Plan for success


Creating mobile applications is an iterative process (Figure 1). Start with a detailed design plan; then design, 
develop, test, refine, implement, and evaluate your design before you publish the final product for broad release. 


Figure 1 Iterative design and development process


Create a detailed plan


As you prepare your planning document, start by understanding your target audience and the purpose of the 
application. Use this analysis to identify both creative design and technical requirements. Your plan should define the 
following:


• Goals or purpose of the application (advertising, product marketing, education, entertainment, and so on)


• Target audience, including demographics such as age, gender, location, education, and technical experience


• Target screens or devices such as iOS and Android mobile phones, the iPad, or Kindle Fire


• Application flowchart and storyboard detailing content mapping, screens, and organizational hierarchy


• Navigation design, including menus, buttons, and any other method used to navigate content


• Look and feel, including visual themes, color schemes, fonts, and use of icons and images


• Input methods, such as touch screen, gestures, speech, or other methods


• Technology decisions such as whether to use cookies or client-side storage


• Privacy requirements such as informing users when personal data is being accessed by an application


• Testing plan, including how you’ll test both usability and technical delivery on target devices
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Use storyboards, flowcharts, and design compositions


Your design plan should include a flowchart and storyboard sketches or design compositions to illustrate screens and 
navigation (Figure 2). Share these to identify potential issues before committing to one design or another. 


Figure 2 Flowchart (left) and storyboard/design composition sketches (right)


Test for usability and technical issues early and often


Use rapid prototyping and wireframes, a simplified version of your design layout and artwork, to give clients and 
testers a better understanding of the final product (Figure 3). 


Develop a small portion of the overall content first, including as many of the final design elements as possible. Test 
and revise your design before producing additional screens.


Before releasing the application to a broad audience, share the application with a select group for early release and 
testing in a real-world environment. Solicit feedback to identify possible usability and technical issues (bugs). 


Figure 3 Wireframe
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Use consistent themes in design


The application user interface should maintain the same look and feel throughout. The color scheme and style of 
artwork, body text, links, icons, images, and navigation elements should remain consistent from one screen to 
another.   


Include white space in your designs


White space increases readability and usability. It’s an important element in any graphic user interface design, even 
mobile applications. In fact, it might be needed even more as screen sizes get smaller and users must isolate 
navigation options by using stubby fingertips or difficult-to-use pointing devices.


Minimize the need to scroll


Avoid horizontal scrolling—always. Some devices hide scroll bars, and others just don’t offer them. Some mobile 
devices, such as the iPhone and iPad, automatically scale and zoom, depending on the orientation (portrait or 
landscape); this reduces the need for scrolling, but not all devices have this capability.


If content must be scrolled, use vertical scrolling only. There are differing opinions on the use of vertical scrolling in 
mobile applications. Some users prefer to load a larger page once and scroll vertically to read or locate what they’re 
seeking. Others prefer to load smaller pages (faster) and navigate between pages as needed. When designing mobile 
content that requires long lists or pages, find out which method your target audience prefers during usability testing. 


Keep navigation simple


One of the most common challenges in designing for mobile devices is to balance creativity with ease-of-use in a 
very small screen area. Anything that simplifies the layout and navigation will work to your advantage.


Here are some tips that will help users quickly find and view what they’re looking for:


• Keep buttons large by using extra padding and spacing. Many mobile devices use touch-screen input, and 
bigger buttons mean easier clicking.


• Keep navigation simple. Don’t flood a navigation bar with too many options; choose five or fewer, and 
create sub-navigation as necessary. 


• Use vertical navigation menus to make viewing long lists a lot easier on many mobile input devices. 


• Use buttons (or icons) over standard text links for navigation.


• Avoid pop-ups or spawned windows.
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Use icons to save screen space and improve usability


One major trend in mobile design is the use of icons for buttons and navigation. Icons are easier to click than small 
text links and users can navigate more intuitively—a better user experience.


Figure 4 Icons save screen space and improve usability


Limit the use of large images


Most mobile applications download information from the Internet. Data needs to be current and available quickly. 
Mobile users want information fast and have low tolerance for long download times. Fans and customers can be won 
or lost in the few seconds it takes to load a picture or update a screen. Add this to the financial cost of mobile data 
plans and it’s clear that smaller and faster is better for business and user satisfaction. Limiting the use of large images 
or at least optimizing images and media can be the difference between a 50KB design and a 2MB layout of crippling 
intensity. 


For incredibly small screens, some images should be eliminated entirely. Anything that increases the need to scroll 
can be an issue, and even more so for slower mobile devices where simply downloading the image is enough of a 
problem. 


Optimize video and audio for mobile devices


Even with the bandwidth and processing issues that exist in the mobile environment, some applications demand video 
and sound. For example, an application for finding movie times won’t be very popular without access to movie 
trailers and short video clips. The key to using rich media in mobile applications is moderation and optimization. 
Here are a few considerations you should make when adding video and audio to a mobile application:


• Select a video or audio format that matches your target device. For example, Flash video files (FLV/F4V) 
are not compatible with some devices, such as iPhones or iPads.


• Optimize your files. You can use Adobe Media Encoder CS6 presets to create the proper file format and 
optimize files for most popular mobile devices.


• Disable autoplay features. Let users choose when they want to download video and audio files. Users find 
autoplay annoying because it often downloads data they don’t want, resulting in slower performance and 
unexpected data charges.
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Development best practices
Most applications need to store some form of data. For example, an e-mail application downloads and stores e-mail 
and contacts. A calendar application updates the current calendar and stores events. An application for tracking 
exercise or diet records stores daily user logs and may present unique content based on the user’s personal entries. 
The technologies used to implement these features can improve or impede the user experience and may differ among 
your target mobile devices. When you’re choosing one technology over another, always ask, “Will it improve the user 
experience?” 


Consider the following when developing content for mobile devices:


• Use cookies sparingly when the mobile application accesses content on the web.


• Inform users about the use of personal and device information.


• Minimize the use of device resources.


• Enable automatic sign-in for secure applications.


• Integrate with device capabilities and other mobile applications.


• Test on multiple devices or use device emulators.


Note: This is a partial list and refers to using technologies for delivering content and not to the processes or tools by 
which content is created.


Use cookies sparingly


Cookies store state information on a user’s device that can be used for authentication, identification of a user session, 
user’s preferences, shopping cart contents, or anything else for which text data might be stored on the user’s device. 
Cookies are appropriate for simple personalization data and are commonly used to store a token representing user 
identity to enable automatic sign-in. Information stored in cookies, however, is sent to the server for every request, so 
using them for excessive amounts of data can degrade performance, particularly on a mobile network.


Furthermore, cookie support may be disabled either in a mobile device or by the mobile network. For this reason, you 
should design applications to remain functional even if cookies are unavailable. 


Inform users about the use of personal and device information


Some mobile applications access personal data stored or generated by the device. For example, a local restaurant 
guide may use a built-in GPS feature to identify the current geographical longitude and latitude of the device to 
determine the exact location of the user. The application can then retrieve a list of nearby restaurants. 


Users should be informed of the types of information the application will use and whether that data will be exchanged 
with a server.


These notices should be provided when users first access the application or the first time the user’s information is 
accessed. Give users enough information to judge whether they want to allow the application access to their data. 


Minimize the use of device resources


An effective way to improve application performance is to minimize the use of device memory, processor power, and 
network bandwidth, which are more limited on mobile devices than on a desktop.


Enable automatic sign-in for secure applications


If an application requires login, it should prompt the user for credentials (user name and password) and provide the 
option to sign in automatically the next time the application starts. This is especially important on a mobile device 
where data input is more difficult than on a desktop. If automatic sign-in is enabled, your application should also 
include a link or button for signing out.
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Integrate with device capabilities and other mobile applications


Mobile devices include features that are not available in a web browser. For example, if you’ve used a mobile phone 
to look up the contact information for a business or service, you’ve probably used the click-to-call feature. Phone 
numbers appear as hyperlinks. When you click the link, the phone dials without the need to manually enter the phone 
number. 


Test on multiple devices or use device emulators


With such diversity in the mobile landscape, it goes without question that you should test your designs on as many 
platforms as you can manage. Walk into any mobile phone retailer and you’ll see the range and diversity of options in 
devices and screens—and the number of choices is growing. Because of competition and continuous innovation, 
standardization of these web-enabled devices is unlikely. 


One way to test your application is to deploy it on each target device. You can also test with device emulators. For 
example, Adobe Flash Professional CS6 includes a built-in mobile simulator for testing accelerometer, input, and 
geolocation features in a mobile application. By searching online, you’ll find emulators for most devices, including 
Android, iPhone, BlackBerry, Motorola, and Palm—just to name a few.


Conclusion
Smart phones, tablets, and other mobile devices are everywhere, and demand is growing for faster, smarter, and easy-
to-use applications. Many of the same principles you’ve learned for web design apply to the creation of mobile 
content, but with some important differences.


For more information on mobile web application best practices, visit www.w3.org/Mobile/.
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What is a storyboard?

		A storyboard is a scene-by-scene drawing of the sequence of action.

		Storyboards tell the story visually with enough detail for developers to know what to build. 



*



The anatomy of the storyboard can change by the specific usage. This is just one simple example for one graphic.

The notes are at the bottom and indicate the audience and purpose.

The audience are any professional members of the medical community wishing to have websites designed for them.

The purpose of the logo is to identify my design agency as focused on the medical community.

Note that the scale is indicated. The color scheme is true to how the finished product will look.

It is a play on my name and initials: G Miller

*
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Two basic types of storyboards

		Static – No action elements indicated. Used for a graphical design such as a logo or page banner.

		Animatic – Indicating action, movement, camera angles, or the passage of time. Typically used in making movies.



*
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Example of storyboards 

		Sample storyboard layout when multiple pages or scenes are part of the design.



*
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Why storyboard?

		Easier and cheaper to produce and test ideas on paper before production.

		Easier to generate alternate ideas as you think of them.

		Effective tool to check that the finished product is what it should be!



*
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How to create interactive navigation
There are several options for creating interactive navigation for your web pages: You can easily create:


• graphical buttons and navigation bars in Fireworks, and import them into Dreamweaver. 


• image-based, or HTML, pop-up menus in Fireworks, and place them in a Dreamweaver file.


• rollover images that add visual interest and interaction by using Dreamweaver.


Advanced users may consider using Fireworks to create CSS-based interactive navigation. You can use the CSS 
Properties panel to extract complex CSS3 properties for buttons, such as text, border radius, and gradients..


Creating buttons and navigation bars in Fireworks
Fireworks CS6 enables you to design the look and functionality of buttons, including links and rollover features. 
After you export these buttons from Fireworks, you can import them into Dreamweaver CS6.


Building buttons


In the following steps, you create a button for export into Dreamweaver.


To build a button:


1. Start Fireworks. 


2. Create a new document. 


3. Type 200 pixels for Width and 200 pixels for Height. Type 72 pixels/inch for Resolution.


Note: At the end of this exercise, you will trim the canvas to fit the button. 


4. Save the document in the images folder of your Dreamweaver website.


5. Select Edit > Insert > New Button.


The button editor opens and the Properties panel displays button properties (Figure 1).


Figure 1 Button Properties panel


6. Deselect the Enable option for 9-Slice Scaling Guides in the Properties panel. (To learn about 9-Slice Scaling 
Guides, select Help > Fireworks Help).


Buttons contain four states:


• Up (button untouched)


• Over (pointer over button)


• Down (button being clicked)


• Over While Down (pointer over while 
button held down)


You can view each state by selecting it in the State pop-up menu in the Properties panel (Figure 1). The current 
state of the new button is Up, as shown in the Properties panel.


State pop-up menu9-slice scaling guides Enable/Disable option
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7. Use the Rectangle tool or the Ellipse tool from the Tools panel to draw a shape for the Up state. Make the 
dimensions of the shape fit the size of your navigation bar.


8. To add depth to the button, click the Add Live Filters button in the Properties panel (the plus sign next to Filters), 
and then select a bevel option from the pop-up menu:


• Bevel and Emboss > Inner Bevel


• Bevel and Emboss > Outer Bevel


9. Using the Properties panel, add color to the button. 


10. Use the Text tool to add text to the button, and center-align the text. 


The color and text of the button should match the color and font design of your page.


11. Confirm the Smart Guides are visible and active. If not, select View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.


12. Select the Pointer tool. 


13. Drag the text block until the horizontal and vertical Smart Guides appear so that the text is centered over the 
shape (Figure 2).


Figure 2 Smart Guides


14. Select Window > Object & Layout > Align (Windows) or Window > Align (Mac OS) to open the Align panel.


15. Click the button at the top of the panel, if necessary, until the label Relative To Canvas is visible (Figure 3). 


Figure 3 Align Panel


16. Use the Pointer tool and shift-click to select both the button and the text.


17. Click the Align Horizontal Center and Align Vertical Center buttons.


Later you will duplicate this first button to create the other buttons. A centered shape aligns well with other 
duplicate buttons. If the text is centered, button labels with varying numbers of characters will all be well 
aligned.


Relative To Canvas or 
Relative To Object


Align Vertical CenterAlign Horizontal
Center

How to create interactive navigation © 2012 Adobe Systems Incorporated







Adobe Fireworks CS6 and Adobe Dreamweaver CS6 Project 4 guide

18. Click away from the shape and text to deselect them. In the Properties panel, select Over in the State pop-up 
menu (Figure 4).


Figure 4 Properties panel 


19. In the Properties panel, click Copy Up Graphic to copy the Up graphic to the Over button state (Figure 4). 


This saves you time and helps keep the look and position of the button consistent.


20. Decide how you want the button to look when the pointer rolls over the button. Then change the copied graphic 
by modifying the color or effects of the text or the shape.


21. Click away from the shape and text to deselect them. In the Properties panel, select Down in the State pop-up 
menu.


22. Click Copy Over Graphic to copy the Over graphic to this button state.


23. Decide how you want the button to look when visitors click the button. Add effects such as darkening the color.


24. (Optional) You can add a drop shadow to the shape by clicking Add Filters in the Properties panel, and then 
selecting Shadow And Glow > Drop Shadow.


For this project, you will skip the Over While Down state.


25. Click away from the shape and text to deselect them. In the Properties panel, select Active Area in the State pop-
up menu (Figure 4).


The active area of the button is shown by green shading and red lines. This shading indicates the area visitors can 
click to activate the button (Figure 5).


Figure 5 Button Active Area selected 


26. When you are satisfied with the states of your button in the Button Editor, click Page 1 at the top of the screen 
(Figure 6) to close the Button Editor and return to the Page 1 canvas.


Your button appears on the Fireworks Page 1 canvas and in the Document Library panel. 


Figure 6  Fireowrks Button Editor


State pop-up menu
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27. Click the button to select it. In the Link text box in the Properties panel, enter the name of a web page to link to 
this button (Figure 7).


Figure 7 Properties panel with Link text box


28. In the Alt text box, enter an alternative text label for the button.


Alternative text is displayed in place of the image when visitors elect not to display images in their browsers. 
Such text can also be voiced by screen readers for visitors who use them. Typically, alternative text for a button 
should be the same as the text displayed on the button.


29. Select Modify > Canvas > Fit Canvas to fit the canvas to the size of your button.


30. Select File > Save to save the new button.


Copying buttons and making the navigation bar


In the following steps, you duplicate the button you created in the previous steps to make the navigation bar.


To copy the buttons and make the navigation bar:


1. Change the size of the canvas to accommodate all the 
buttons on your navigation bar. Select Modify > Canvas 
> Canvas Size and edit the value for height or width in 
the Canvas Size dialog box.


If you have four buttons, for example, multiply the height 
or width of the first button by four (depending on 
whether your navigation bar is vertical or horizontal).


2. Select the first button. Move it to the top (or to the left 
edge) of the canvas. Select Edit > Clone.


A new instance of the button appears on top of the 
original button.


3. Drag the new button instance below  (or to the right of) 
the original button. You can also use the arrow keys to 
move the button.


4. Repeat steps 2 and 3 as many times as necessary to create 
the rest of your navigation bar (Figure 8). 


5. Click the second button and use the Properties panel to 
edit it. In the Text box, change the text to the name of the 
second button. Edit the information in the Link text box 
and the Alt text box as appropriate for this button.


6. Repeat step 5 for the remaining buttons (Figure 9).


7. To fit the canvas to your navigation bar, select Modify > 
Canvas > Fit Canvas.


8. Save the file.


Figure 8 Cloned buttons


Figure 9 Buttons with edited text labels

How to create interactive navigation © 2012 Adobe Systems Incorporated







Adobe Fireworks CS6 and Adobe Dreamweaver CS6 Project 4 guide

Exporting a navigation bar for use in Dreamweaver


Fireworks enables you to save interactive graphics (a button, for instance) as HTML so you can import working 
buttons into a Dreamweaver document.


To export a navigation bar for use in Dreamweaver:


1. Choose File > Export.


The Export dialog box opens (Figure 10).


2. Navigate to the folder in your local root folder where you 
want to save the navigation bar.


3. Give the navigation bar file a short descriptive name.


4. Make sure the Selected Slices Only option is not selected.


5. Make sure HTML And Images is selected in the Export 
pop-up menu.


6. Make sure the Include Areas Without Slices option is 
selected.


7. Select the Put Images In Subfolder option.


8. Click Save (Windows) or Export (Mac OS).


9. Save the Fireworks document, and close Fireworks.
Figure 10 Export dialog box


Inserting the navigation bar into a Dreamweaver document


Now that you’ve created the navigation bar, you can insert it into a Dreamweaver document. You do so by using an 
option in the Insert panel.


To insert the navigation bar into a Dreamweaver document:


1. Start Dreamweaver.


2. Open the page in which you want to insert the navigation 
bar and save the Dreamweaver document before 
importing.


3. Position the insertion point where you want the 
navigation bar to appear.
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4. In the Common category on the Insert panel, click the 
Images pop-up menu and select Fireworks HTML 
(Figure 11).


The Insert Fireworks HTML dialog box opens 
(Figure 12).


5. In the Insert Fireworks HTML dialog box, click the 
Browse button, and then locate and select your 
navigation bar HTML file. 


6. Click Open.


7. In the Insert Fireworks HTML dialog box, click OK.


The navigation bar appears on the page.


8. To edit a button, select the button and then use the 
Properties panel to change settings, such as the link or 
alternative text.


9. Check that the link address and the alternative text label 
are correct for each button.


10. Save the Dreamweaver document.


11. Select File > Preview In Browser and choose a browser 
from the submenu to test button rollover functions in a 
browser (Figure 13).


Figure 11 Insert panel


Figure 12 Fireworks HTML dialog box


Figure 13 Page previewed in browser
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How to create pop-up menus
Pop-up menus are menus that are displayed in a browser when a site visitor moves the pointer over or clicks a trigger 
image. Items in a pop-up menu can have URL links attached to them for navigation.


You can use pop-up menus to display multiple links within a small space. They provide navigation flexibility without 
long download times. You can define the appearance of the pop-up menu so it matches the overall look and feel of 
your website. A pop-up menu is similar to a table: each menu item is like a table cell. You can customize the menu by 
choosing from a selection of font types, cell colors, and background image styles.


Creating pop-up menus in Fireworks CS6


In the following steps, you will first create entries for a pop-up menu, then set the menu’s appearance and position.


To create entries for a pop-up menu:


1. Start Fireworks CS6.


2. Open or create the image that will trigger the pop-up 
menu.


Note: The trigger image may be a text object or a 
graphic. Be sure to set the canvas dimensions to account 
for the size of the pop-up menu; you can trim the canvas 
after you build the menu to adjust the size.


3. Click the trigger image to select it.


4. Select Edit > Insert > Rectangular Slice to insert a slice 
over the trigger image (Figure 14).


Note: To create a slice that is not rectangular, you can use 
the Polygon Slice tool. See Fireworks Help for more 
information.


When a slice is selected, a circle with cross hairs appears 
in the center of the slice. This is called a behavior handle.


5. Click the behavior handle and select Add Pop-up Menu 
from the context menu (Figure 15).


Figure 14 Sliced image


Figure 15 Behavior handle context menu


Behavior handle
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The Pop-up Menu Editor appears (Figure 16).


6. In the Content tab of the Pop-up Menu Editor, if the 
insertion point is not already in the Text box, click twice 
in that box. Enter the text for a menu item. Click in the 
Link box, and enter the name of the file it links to.


7. To add a new menu item, click the Add Menu (+) button 
and repeat step 6 (Figure 17).


8. To delete a menu item, select the item and click the 
Delete Menu (–) button.


9. After you have entered all the menu items, click Next or 
click the Appearance tab.


Figure 16 Pop-up menu editor


Figure 17 Pop-up Menu Editor with menu entries


Setting the appearance of a pop-up menu


On the Appearance tab of the Pop-up Menu Editor, you can format the text, apply graphic styles to the Over and Up 
states, and select vertical or horizontal orientation for the pop-up menu.


To set the appearance of a pop-up menu:


1. Continue where you left off in the previous task.


2. Select either HTML or Image for Cells (Figure 18).


Note: HTML sets the menu’s appearance using only 
HTML code; this setting produces pages with smaller file 
sizes. Image gives you a selection of graphic image styles 
to use as the cell background; this setting produces pages 
with larger file sizes.


3. Select Vertical Menu or Horizontal Menu from the 
Orientation pop-up menu near the top of the Appearance 
tab.


Settings you choose immediately appear in the preview 
window near the bottom of the Appearance tab.


4. Select font type, font size, and text styles for your menu 
items.


5. Select text and background (Cell) colors for Up State and 
Over State.


These states are similar to button states. The Up state of a 
menu item is its default appearance in the menu. The 
Over state is the appearance of the menu item when the 
pointer passes over it.


Figure 18 Appearance tab of Pop-up Menu Editor


Delete Menu button


Add Menu button
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6. If Image is selected as the cell type, select a graphical 
style for the Up state and the Over state (Figure 19).


7. Click Next or click the Advanced tab (Figure 20) if you 
want to change cell or border attributes.


Typically you can use the default settings in the 
Advanced tab.


Figure 19 Graphical style for cells


Figure 20 Advanced tab of Pop-up Menu Editor


To set the position of a pop-up menu:


1. Continue where you left off in the previous task.


2. Click Next or click the Position tab in the Pop-up Menu 
Editor (Figure 21).


3. Click a Menu Position button to position the pop-up 
menu relative to the trigger slice.


Note: Alternatively, you can enter X and Y coordinates. 
Coordinates of 0, 0 align the upper left corner of the pop-
up menu with the upper left corner of the trigger slice.


4. Click Done. Then save your file.


5. To preview your pop-up menu, select File > Preview In 
Browser and select a browser from the submenu. Figure 21 Position tab of Pop-up Menu Editor
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Editing a pop-up menu


You edit a pop-up menu through the same context menu with which you created the pop-up menu.


To edit a pop-up menu:


1. To edit a pop-up menu, select the slice to which your 
menu is attached and double-click the pop-up menu’s 
blue outline in the workspace, or click the behavior 
handle and select Edit Pop-up Menu (Figure 22).


The Pop-up Menu Editor opens.


2. Set options in the Pop-up Menu Editor just as you did 
when you created your pop-up menu.


Figure 22 Behavior handle context menu


Exporting a pop-up menu for use in Dreamweaver CS6


To save the pop-up menu so it will be active on your website, export the document as HTML.


To export a pop-up menu:


1. While still in Fireworks, trim any excess canvas 
surrounding your image by choosing Modify > Canvas > 
Trim Canvas.


2. Save the file.


3. Select File > Export.


The Export dialog box opens.


4. Navigate to your local root folder.


5. Give the pop-up menu a short, descriptive name.


6. Select HTML And Images in the Export menu.


7. Make sure the option Put Images In Subfolder is selected.


Note: Putting all the exported image files in a subfolder 
is a good way to manage those files.


8. Save (Windows) or Export (Mac OS).


9. Save your document and close Fireworks.


Importing a pop-up menu into Dreamweaver


You insert a pop-up menu into Dreamweaver as you would anything else, by using the Insert panel.


To insert a pop-up menu into Dreamweaver:


1. Start Dreamweaver.
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2. Open the document into which you want to import the 
pop-up menu.


3. Position the insertion point where you want the pop-up 
menu to appear. You can also place the pop-up menu 
within a div for more precise positioning of the menu.


4. Make sure the Common category is selected in the Insert 
panel. Click the down arrow on the Images button, and 
select Fireworks HTML (Figure 23).


The Insert Fireworks HTML dialog box opens 
(Figure 24).


5. Click Browse, select the pop-up menu HTML file, and 
click Open.


Note: The Images subfolder contains the sliced images 
for your pop-up menu.


6. OK to close the Insert Fireworks HTML dialog box.


The pop-up menu is inserted into your Dreamweaver 
document.


7. Save your Dreamweaver document. 


8. Select File > Preview In Browser and select a browser 
from the submenu to test the menu and the links for the 
menu items (Figure 25).


Figure 23 Insert panel


Figure 24 Fireworks HTML dialog box


Figure 25 Testing a pop-up menu


How to create rollover images
A rollover is an image that changes when the pointer moves across it. A rollover actually consists of two images: the 
primary image (the image displayed when the page first loads) and the rollover image (the image that appears when 
the pointer moves over the primary image).


Rollover images add highlighting or design effects by drawing viewer attention when the images are swapped. One 
example is a button that highlights or changes color when the pointer passes over it.


Creating a rollover image


You create a rollover image by inserting it from the Insert panel and then setting options in the Insert Rollover Image 
dialog box.


To create a rollover image:


1. Open Dreamweaver CS6 and open the document in 
which you want to create a rollover image.
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2. Make sure the Common category is selected in the Insert 
panel. Click the down arrow on the Images button and 
select Rollover Image from the pop-up menu 
(Figure 26).


The Insert Rollover Image dialog box opens (Figure 27).


3. Use the Insert Rollover Image dialog box to set up your 
rollover:


• Image Name: Type a name for the rollover image.


• Original Image: Click Browse and select the image 
to be displayed when the page loads.


• Rollover Image: Click Browse and select the image 
to be displayed when the pointer rolls over the 
original image.


• Alternate Text: Type the text you want to appear as 
alternate text for the image.


• When Clicked, Go To URL: Click Browse and select 
the file (or type the path to the file) to be opened 
when the image is clicked.


4. Click OK to close the dialog box.


5. Save the page.


6. Select File > Preview In Browser and select a browser 
from the submenu to preview the rollover image and test 
the link.


Figure 26 Insert panel


Figure 27 Insert Rollover Image dialog box


Figure 28 Testing a rollover image: up (top) and 
over (bottom)
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Developing interactive buttons using CSS
As CSS3 gains wider support in modern devices and browsers, design elements such as interactive buttons can now 
be constructed entirely in CSS. Advanced users may prefer to create CSS-based buttons from a Fireworks design. 
You can use the CSS Properties panel to extract a design object’s properties (rounded corners, opacity, and more) and 
map the properites to HTML elements by using CSS in Dreamweaver. 


In this section, you use Fireworks and Dreaweaver to build a simple set of CSS-based navigation buttons. Fireworks 
is used to create a shape, add text, and add a drop-shadow effect. Use the CSS Properties panel to extract the shape’s 
design elements, and add them to an HTML element in Dreamweaver.


Visit the Adobe Developer Center at www.adobe.com/devnet.html to learn more about how to extend and refine your 
CSS-based interactive navigation.


To create CSS-based interactive buttons:


1. Create a new document in Fireworks and make it 200 
pixels by 200 pixels, and set the Resolution to 72 pixels/
inch.


2. Use the Rectangle tool or the Ellipse tool from the Tools 
panel to draw a shape for the button. Make the 
dimensions of the shape fit the size of your navigation 
bar.


3. Use the Gradient Fill button to add a Gradient Shape and 
set fill colors.


4. Use the Properties panel to add color and gradient to the 
button.


5. Use the Text tool to add text to the button. 


6. Use the Smart Guides to center the text over the button 
shape.


In Figure 29, the sample button is a 145x35 pixel 
rounded rectangle with a red radial gradient. Text is 
Verdana, Bold, with font size set to 15 and color set to 
white. 


7. Choose the Pointer tool from the Tools panel and select 
the button shape on the canvas.


8. Select Window >  CSS Properties.


The CSS Properties panel opens and displays the list of 
CSS properties for the selected object (Figure 30).


You will return to the CSS Properties panel after the 
HTML elements have been created in Dreamweaver. 


9. Start Dreamweaver and select File > New.


10. In the New Document dialog box, select Blank Page, 
select HTML for Page tyep, and select <none> for 
Layout. Click Create.


Figure 29 Sample Fireworks button design


Figure 30 CSS Properties panel 


Copy All button
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11. Save the new document.


12. Click the Split button in the Document toolbar 
(Figure 31).


Code view and Design view are visible in the document 
window.


You will work in Code view in the next steps. 


13. In Code view, locate the <body> tag, place the insertion 
point at the end of the opening <body> tag, and press 
Enter (Windows) or Return (Mac OS).


Figure 31 Dreamweaver Document toolbar


14. Enter (or copy and paste) the following code between the <body> tags in the Code view. If you enter the code 
directly from the keyboard, watch for code hints as you type. You can save work by double-clicking the code 
pieces you need from the lists that appear.
<ul>
   <li class="button"><a href="#">Home</a></li>
</ul>


15. Copy the complete list item Home code inside the <ul> tags and paste it three times before the closing </ul> 
tag (Figure 32).


Figure 32 Sample code


16. Replace "Home" in the three copies with "Directions", "Hours", and "Facilities", respectively (Figure 33).


This code creates an unordered list, that is associated with a button class that is not yet defined. Each list item is 
a link.


Figure 33 Sample code


17. Open the CSS Styles panel (Window > CSS Styles). If a message reminds you that you've made coding changes, 
click the Refresh button in the CSS Styles panel.
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18. In the CSS Styles panel, click the New CSS Rule button 
(Figure 34). 


The New CSS Rule dialog box opens (Figure 35).


19. Open the Selector Type menu and select Class (Can 
Apply To Any HTML Element).


20. Type .button in the Selector Name text box. 


21. Click OK to close the New CSS Rule dialog box.


The CSS Rule Definition dialog box opens.


22. Click OK to close the CSS Rule Definition dialog box 
without setting any style options. 


You will use content from the Fireworks CSS Properties 
panel to apply style options to the new empty button rule.


23. Return to Fireworks and open the CSS Properties panel.


24. Select the button shape and click the Copy All button 
(Figure 30).


The CSS properties for the graphic are extracted and 
saved to the clipboard.


25. Switch to Dreamweaver.


26. In Code view, locate the <style> tag in the head section, 
place the insertion point between the open and closing 
curly brackets that follow the .button selector,  and press 
Enter (Windows) or Return (Mac OS).


27. Select Edit > Paste to insert the saved CSS properties into 
the button selector.


28. Click in the Design view to refresh.


The background of the list items in Design view changes. 


29. Click the Live button in the Document toolbar at the top 
of the Document window to preview the initial changes 
to the button list (Figure 36).


The button design still needs a bit of refinement.


30. Switch to Fireworks, select the button text, and click the 
Copy All button in the CSS Properties panel.


31. Return to Dreamweaver, locate the closing curly bracket 
of the button selector, and paste the contents of the 
clipboard inside the bracket.


32. In Code view, enter in the following code at the end of 
the button selector declaration:
list-style: none;
This removes the default list marker.


Figure 34 CSS Styles panel


Figure 35 New CSS Rule dialog box


Figure 36 Shape attributes applied to list items


New CSS Rule


Selector text box Selector Type menu
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33. Click in the Design view to refresh.


Notice the CSS styles are applied to the text in the Design 
view (Figure 37). However, the link text has assumed the 
default color for link attributes. This can be easily fixed 
by redefining the link attribute CSS style. 


Figure 37 Text attributes applied to list items


34. Enter (or copy and paste) the following code between the .button closing curly bracket, and the closing </
style> tag (Figure 38):
a:link {color: #ffffff; text-decoration:none;}
a:hover, a:active, a:focus {text-decoration: underline;}
a:visited {color: #ffffff;}


Figure 38 Sample code


35. Click in the Design view to refresh.


The link attributes are applied to the list items 
(Figure 39).


36. Test the items in the Live view to see how the text 
becomes underlined when the mouse hovers over a link.


The other selectors proviede a keyboard navigator the 
same hover experience as the person using a mouse.


The list item buttons remain close together.  


37. In Code view, place the insertion point after list-
style:none; at the end of the .button selector 
definition, and press Enter (Windows) or Return (Mac 
OS).


A list of code hints appears. As you type characters in 
Code view, you will see a list of candidates that 
automatically complete your entry.


38. Type marg. A list of options appears (Figure 40).


39. Double-click margin-top from the list of available 
options.


40. Type 10px;. 


The top margin for the list item is now set to 10 pixels. 
The semicolon closes the property-value pair.


Figure 39 Link attributes applied to list items


Figure 40 Code hints
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41. Click in the Design view.


The list item buttons are now separated by 10 pixels that's 
been added to the top margin of each button (Figure 41).


42. Select File > Preview In Browser, and then select a 
browser to preview the interactive CSS buttons in a web 
browser (Figure 42).


Figure 41 Margin attribute applied to list items


Figure 42 Test buttons in web browser
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Define

		Set goals, target audience, content, and delivery requirements for project.

		Develop a project plan.

		Outline the content production process.



*



Ask students if they can think of other types of balance: texture and no texture (smooth), size and scale, elements of a composition.

*
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Structure

		Information architecture and design documents.

		Flowchart to outline the overall structure of the site.

		Wireframes to show basic structure of site pages.



*





Home
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Design

		Provide two or more design comps.

		Review comps with client. 

		Redesign based on feedback.

		Develop production storyboard.

		Design prototype wireframe.



*
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Build and test

		Build site production based on storyboards.

		Do technical, accessibility, and usability testing, recording bugs, and design-change requirements.

		Make revisions based on test results.

		Repeat technical and usability testing of revised site.

		Present site to client and do final revision.



*



The rectangle has three lines of symmetry: horizontal (blue), vertical (red), diagonal (yellow)

The triangle only has one line of symmetry: center or vertical. You can draw two other lines of symmetry from any of the vertices to the center of the opposite side.

*
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Launch

		Outline a launch plan including promotion, and search engine optimization. 



*
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How to use a motion guide with a motion tween 
animation
In Adobe Flash Professional CS6, motion guides appear when you create motion tweens. By using a motion guide, 
you can move an object along an editable path. 


To move an object along a path by using a motion guide:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Add a symbol or text object to the Stage. 


Note: You may need to add a shape or image first and 
convert the object to a symbol.


3. In the Timeline panel, select the layer that contains the 
symbol or text you wish to animate.


4. Select Insert > Motion Tween.


Notice the tween in the timeline (Figure 1).


5. On the Stage, move the object and notice the motion 
guide appears (Figure 2).


6. Click and drag a point on the motion guide. Edit as many 
points of the guide as you choose (Figure 3).


Figure 1 Layer with motion tween applied


Figure 2 Motion guide


Figure 3 Editing the motion guide
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7. Turn onion skinning on to see how the object moves 
along the path (Figure 4).


Note: To turn onion skinning on or off, click the Onion 
Skin button at the bottom of the Timeline panel. Drag the 
onion skinning frame handles at the top of the timeline to 
align with the start and end of the tween span.


8. Select Control > Test Movie > In Flash Professional to 
preview the movie.


Observe that the object moves along the guide.


9. Close the preview window.


Figure 4 Onion skinning turned on


Onion Skin button
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Digital Design Project 2 worksheet

Design document


Student name:_________________________________________________ Date: ________________________


URL: ________________________________________________________________________________________


Site name: ____________________________________________________________________________________


Project overview
List site challenges and proposed solutions. If possible, include examples from other sites that deal effectively with 
the listed challenges.


List site goals:


List site objectives:


List site messages:
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Provide a brief description of the intended audience for this site:


Delivery requirements
List the delivery requirements for this site (browsers supported, devices supported, minimum connection speed). Be 
sure to include any constraints the delivery requirements place on the site content.
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Site content
Give an inventory of the home page and content pages, including standard structures on the pages. Be sure to indicate 
the use of tables, headings, and indentation to maintain page structure consistency and hierarchy.


Site stucture
Draw a site map.
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Creative design
Use this space to brainstorm for font and color options, and design comps by sketching ideas by hand. Use these 
initial visual ideas as a foundation for your digital wireframes and website design comps.
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		Design document

		Student name: Date:

		URL:

		Site name:

		Project overview

		List site challenges and proposed solutions. If possible, include examples from other sites that deal effectively with the listed challenges.

		List site goals:

		List site objectives:

		List site messages:

		Provide a brief description of the intended audience for this site:

		Delivery requirements

		List the delivery requirements for this site (browsers supported, devices supported, minimum connection speed). Be sure to include any constraints the delivery requirements place on the site content.

		Site content

		Give an inventory of the home page and content pages, including standard structures on the pages. Be sure to indicate the use of tables, headings, and indentation to maintain page structure consistency and hierarchy.

		Site stucture

		Draw a site map.

		Creative design

		Use this space to brainstorm for font and color options, and design comps by sketching ideas by hand. Use these initial visual ideas as a foundation for your digital wireframes and website design comps.
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How to create and edit a CSS rule
You can create and edit a CSS rule in two locations: the Properties panel and the CSS Styles panel. When you apply 
CSS styles to text by using the Properties panel or menu commands, CSS rules are embedded in the head of the 
current document. You can also use the CSS Styles panel to create and edit CSS rules and properties. 


In this guide, you review CSS rules, create and apply a class-style CSS rule by using the Properties panel, and modify 
an HTML tag-style rule by using the CSS Styles panel.


About CSS rules
A CSS formatting rule consists of two parts: the selector and the declaration (or in most cases, a block of 
declarations). The selector is a term (such as p, h1, a class name, or an id) that identifies the formatted element. The 
declaration block defines the style properties. In the following example, h1 (a heading tag) is the selector, and 
everything that falls between the braces ({and }) is the declaration block (defining the properties of the h1 heading):


h1 { 


font-family: Georgia, "Times New Roman", Times, serif;


font-size: 18px;


text-transform: uppercase;


color: #090; 


}


An individual declaration consists of two parts: the property (such as font family) and value (such as Georgia). In the 
previous CSS rule, a particular style has been created for h1 tags; the text for all h1 tags linked to this style will be 18 
pixels in size, Georgia font, uppercase, and bright green (hex value #090). 


The style (which comes from a rule, or a collection of rules) resides in a place separate from the actual text it’s 
formatting—usually in an external style sheet or in the head section of an HTML document. Thus, one rule for h1 
tags can apply to many tags at once (and in the case of external style sheets, the rule can apply to many tags at once on 
many different pages) (Figure 1). In this way, CSS provides extremely easy update capability. When you update a 
CSS rule in one place, the formatting of all the elements that use the defined style is automatically updated to the new 
style.


Figure 1 Updating a CSS rule in one place updates all elements
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There are three main types of CSS:


Class style: Similar to the styles you use in word processing and page layout programs. For example, you may 
want to format all body text in 10-point, Arial, dark green type. You can create a class style with these attributes 
and then apply this style to all body text in your website. Class names must begin with a period and can contain 
any combination of letters and numbers (for example, .myhead1). 


HTML tag style: Applies global formatting to individual HTML tags rather than to individual selections. 
Suppose you want to modify the Heading 1 paragraph style to appear always in purple text. Instead of creating a 
class style and applying it to every heading in the document, you can create an HTML tag style with these 
attributes and apply it to the Heading 1 <h1> tag. In effect, you are redefining the HTML tag.


ID style: A unique identifier (ID) for a style applied to headers, banners, menus, and other elements present in 
only one location in the document. Used once within a document or page. IDs must begin with a pound (#) sign 
and can contain any combination of letters and numbers (for example, #myID1). 


CSS rules can reside in the following locations:


Internal (or embedded) CSS style sheets are collections of CSS rules included in a style tag in the head section of 
an HTML document.


External CSS style sheets are collections of CSS rules stored in a separate, external CSS (.css) file (not an HTML 
file). You link this file to one or more pages in a website with a link or an @import rule in the head section of a 
document. 


Creating a new CSS rule from the Properties panel
In the CSS Properties panel, you can access Targeted Rules and create new ones (Figure 2). A Targeted Rule is a rule 
you are editing in the CSS Properties panel. When you have an existing style applied to text, the rule affecting the 
text’s format appears when you click inside the text on the page. You can also use the Targeted Rule pop-up menu to 
create new CSS rules and new in-line styles or apply existing classes to selected text. 


Figure 2 Properties panel, CSS mode


How you edit your CSS depends on selection level. To access rules that apply to a current selection only, you can use 
the Targeted Rule pop-up menu in the CSS Properties panel. To access all CSS rules for a page, you can use the CSS 
Styles panel. The CSS Styles panel will be reviewed in the next guide.


In this section, you use the Properties panel to create a simple CSS class-style rule to format a block of text.
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To create a new CSS rule in the Properties panel:


1. Start Dreamweaver.


2. Select File > New to create a new document.


The New Document dialog box appears (Figure 3).


3. In the Blank Page category of the New Document dialog 
box, select HTML Page Type to create a plain HTML 
page.


4. In the Layout column, select None. 


5. Click the Create button.


The new HTML page opens.


6. In the Document toolbar, click the Show Code And 
Design Views (Split) button (Figure 4).


Being able to view the code that Dreamweaver generates 
for creating styles will be useful to help you understand 
and write your own CSS syntax later on.


7. Type some text or paste text copied in another application 
in the Design view Document window. 


8. Press Enter (Windows) or Return (Mac OS) to create a 
new paragraph and add additional text.


9. Open the Properties panel (Window > Properties), if it 
isn’t already open, and click the CSS button to display 
the CSS Properties panel (Figure 2).


10. Use the Font menu to change the Font to Georgia, Times 
New Roman, Times, Serif (Figure 5).


The New CSS Rule dialog box appears (Figure 6).


Note: It is a good practice to assign a font combination 
instead of a single font. This ensures that most page 
visitors will view page text the same way. A browser uses 
the first font in the combination that is installed in the 
visitor’s system. If none of the fonts in the combination is 
installed, the browser displays the text as specified by the 
visitor’s browser preferences. 


Figure 3 New Document dialog box


Figure 4 Document window view options


Figure 5 Properties panel Font menu


Figure 6 New CSS Rule dialog box


Show Code And Design Views button

© 2012 Adobe Systems Incorporated How to create and edit a CSS rule 3







Project 3 guide Adobe Dreamweaver CS6


4


11. In the Selector Type menu, select Class (Can Apply To 
Any HTML Element) (Figure 7).


12. Click in the Selector Name text box and type .myStyle 
(Figure 8).


Note: CSS rules must begin with a period and cannot 
contain spaces or special characters.


13. In the Rule Definition menu, select (This Document 
Only) (Figure 9).


This tells Dreamweaver to create and store the CSS (style 
sheet) in the current document only. The new style will 
not be available for use in other documents.


To create an external CSS document for your entire 
website, you would choose (New Style Sheet File). This 
is discussed in a later guide.


14. Click OK to close the New CSS Rule dialog box.


The new font is applied to the paragraph that contains the 
insertion point. The name of the style appears in the 
Targeted Rule box in the Properties panel (Figure 10).


Note: Because you didn’t select a specific word or 
character, you can continue to define this rule by 
applying additional formatting.


15. In the Properties panel, change the size to 18.


The font size in the paragraph that contains the insertion 
point changes accordingly.


Figure 7 New CSS Rule dialog box, Selector Type 
options


Figure 8 New CSS Rule dialog box, Selector 
Name options


Figure 9  New CSS Rule dialog box, Rule 
Definition options


Figure 10 Targeted Rule in the Properties panel
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16. Click the Color box in the Properties panel and select a 
new color for the text.


The Properties panel shows the targeted rule (.myStyle) 
and its formatting. The targeted rule is applied to the 
paragraph that contains the insertion point (Figure 11).


You can use this CSS rule to format additional text in 
your document.


Observe in Code view that Dreamweaver stores styles 
created with CSS directly in the head section of the 
document (Figure 12).


Figure 11 Formatted paragraph text


Figure 12 Detail of new CSS rule, Code view
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Applying CSS styles
After you create a CSS rule, you can use it to give your entire document or website a consistent appearance. You can 
apply a CSS rule to text by using the Properties panel.


To apply a CSS style:


1. Click anywhere in the paragraph that doesn’t have the 
new CSS style.


2. In the Properties panel, select myStyle (the new CSS rule 
you just created) from the Targeted Rule menu 
(Figure 13).


The new style is applied to the other paragraph 
(Figure 14).


Note: If you edit the CSS style, both paragraphs will be 
updated automatically and consistently. You will learn 
more about creating and modifying CSS in a later guide.


Figure 13 Targeted Rule menu


Figure 14 CSS style applied to both paragraphs


Using the CSS Styles panel
In the CSS Styles panel you can track the CSS rules and properties affecting a currently selected page element 
(Current mode) or all of the rules and properties available to the document (All mode). A button at the top of the 
panel enables you to switch between the two modes. You can also use the CSS Styles panel to modify CSS properties 
in both All and Current modes. 
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The CSS Styles panel in Current mode


In Current mode, the CSS Styles panel displays three panes: a Summary For Selection pane that displays the CSS 
properties for the current selection in the document, a Rules pane that displays the location of selected properties (or 
a cascade of rules for the selected tag, depending on your selection), and a Properties pane where you can edit CSS 
properties for the rule applied to the selection (Figure 15).


Figure 15 CSS Styles panel, Current mode


The CSS Styles panel in All mode


In All mode, the CSS Styles panel displays two panes: an All Rules pane, and a Properties pane. The All Rules pane 
displays a list of rules defined in the current document as well as all rules defined in style sheets attached to the 
current document. You can use the Properties pane to edit CSS properties for any rule selected in the All Rules pane 
(Figure 16).


Figure 16 CSS Styles panel, All mode


New CSS Rule Edit RuleAttach Style Sheet
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To add a CSS rule by using the CSS Styles panel:


1. Start Dreamweaver.


2. Create a new HTML document.


3. Save and name the Dreamweaver document.


4. Type some text in the document. Make sure no 
formatting is applied to the text (Figure 17).


5. Make sure the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


6. To create a new style, click the New CSS Rule button (+) 
at the bottom of the panel (Figure 15).


The New CSS Rule dialog box appears (Figure 18).


7. In the Selector Type pop-up menu, select Class. 


This option creates a new Class rule.


8. In the Selector Name text box, type a name for the style 
such as .warning.


Note: Class rule names must begin with a period and 
cannot contain spaces or special characters. If you forget 
to type the period, Dreamweaver adds this automatically.


9. In the Rule Definition pop-up menu, select (This 
Document Only) or (New Style Sheet File). 


The option (This Document Only) defines the style as 
part of the document’s internal style sheet. The option 
(New Style Sheet File) defines the style as part of an 
external style sheet.


Note: If you choose to create an external style sheet by 
selecting (New Style Sheet File), you are prompted to 
select a location for the new style sheet (.css) document.


10. Click OK.


The CSS Rule Definition dialog box appears (Figure 19).


11. Select options for Type, such as the following: 


• Select Arial, Helvetica, Sans-serif in the Font-
Family pop-up menu


• Select 12 from the Font-Size pop-up menu, and 
select px (pixels) for the measurement unit.


• Type #CC0033 in the Color text box, or select a 
color in the color picker.


Figure 17 Text with no formatting applied


Figure 18 New CSS Rule dialog box


Figure 19 CSS Rule Definition dialog box, Type 
options 
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12. To change the formatting of text blocks, select Block in 
the Category pane.


The Block category of the CSS Rule Definition dialog 
box opens (Figure 20).


13. In the Letter-Spacing text box, you can make changes 
such as typing 3 and selecting pixels for the measurement 
unit.


This setting adds space between letters. 


14. In the Text-Indent box, you can make changes such as 
typing 5 and selecting pixels for the measurement unit.


15. Click OK.


The CSS Rule Definition dialog box closes.


16. Select the document text.


17. Make sure the Properties panel is open and the HTML 
option is selected.


The Properties panel is docked at the bottom of the 
screen. If it is not open, select Window > Properties.


18. Select warning, or the name of your style, from the Class 
pop-up menu (Figure 21).


19. In the document, deselect the text by positioning the 
mouse pointer next to it and clicking once.


Observe that the format of the text has changed 
(Figure 22).


20. Make sure the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


21. Make sure All is selected in the CSS Styles panel. If no 
styles are listed under <style> in the All Rules pane, click 
the plus (+) symbol (Windows) or the disclosure triangle 
(Mac OS).


Observe that the newly created CSS rule now appears 
under <style> in the All Rules pane, indicating the new 
rule is part of a CSS style sheet. Also observe that if you 
select the style name in the All Rules pane, properties for 
the style appear in the Properties pane.


Figure 20 CSS Rule Definition dialog box, Block 
options 


Figure 21 Text Properties panel


Figure 22 Formatting applied to text
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Edit styles


After you create styles, you can still make changes to them by using the Edit Rule button.


To edit styles:


1. To view a style sheet’s rules, click the plus symbol 
(Windows) or disclosure triangle (Mac OS) beside 
<style> in the All Rules pane of the CSS Styles panel.


Dreamweaver displays the style sheet’s rules 
(Figure 23). 


2. Select the rule or style you want to edit.


3. At the bottom of the CSS Styles panel, click the Edit Rule 
button.


The CSS Rule Definition dialog box for the selected style 
appears (Figure 24).


4. Make formatting changes in the CSS Rule Definition 
dialog box. Then click OK.


The changes take effect immediately. 


If you are editing an external style sheet, the same 
changes are applied to any other documents attached to 
this style sheet.


Figure 23 CSS Styles panel


Figure 24 CSS Rule Definition dialog box


Edit Rule 
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How to apply colors and gradients
Each Flash document holds its own color palette. You can use the Color panel to apply colors that aren’t in the default 
web-safe palette of 216 colors. You can create new colors and add them to the palette, which you can save for later 
use. You can also incorporate new colors into gradient fills and store your gradients for repeated use. A gradient is a 
multi-color fill in which one color gradually changes into another.


Gradients can be helpful when creating effects, such as glows, photo-realistic spheres, solar flares, and glowing 
buttons. With Adobe Flash Professional CS6 you can create two types of gradient fills—linear and radial.


Applying colors
You apply and manage colors by using the Color panel.


To apply colors:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Use the Oval tool to create a simple shape on the Stage.


3. You can adjust the fill and stroke colors by using the 
Properties panel. To apply a color that is not in the 
current palette, use the Color panel (Figure 1).


If the Color panel is not open, select Window > Color.


4. Make sure you have selected both the stroke and fill of 
your shape.


Note: To select the stroke and fill of your shape, double-
click the shape with the Selection tool.


5. In the Color panel, click the paint bucket icon (not the 
color box next to it) to select the Fill Color section. 
Choose a color in one of the following ways:


• You can select a new fill color in the palette by 
clicking Saturation and choosing a color in the Fill 
Color control (Figure 1). Drag the Brightness 
control to adjust the tint.


• You can select a new fill color by clicking Hue, 
dragging the Color control, and choosing a tint in the 
Fill Color control (Figure 2).


• You can also enter a hexadecimal number for the 
color. This is helpful if a client provides hexadecimal 
values. 


• You can also adjust red, green, and blue values by 
dragging their scrubbers. Use the Alpha slider to 
adjust the level of transparency.


6. To browse for a color, click and drag in the color picker. 
To adjust the tint, drag the Brightness control.


Figure 1 Color panel with Saturation selected


Figure 2 Color panel with Hue selected


Fill color control


Color picker


Brightness 
control


Hexadecimal 
value


Alpha


Saturation selected


Hue 
selected


Tint picker


Color control
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As you drag, the colors you point to are shown in the 
Current Color Swatch area and in the Fill Color control 
(Figure 3). (Once you release the mouse, the new color 
displays.)


Figure 3 Picking a new color


Add colors to the palette
Once you have mixed your own colors, you can use them to create a custom palette. You do this with the Color panel 
and the Swatches panel.


To add colors to the palette:


1. Make sure the Color panel is open.


If the Color panel is not open, select Window > Color.


Note: The Color panel and the Swatches panel exist in 
the same panel group (Figure 4).


2. In the Color panel, use the color picker or the RGB boxes 
to create a new color.


3. In the Color panel menu, select Add Swatch (Figure 4).


4. Click the Swatches tab to view the Swatches panel.


The new color swatch appears at the bottom of the palette 
in the Swatches panel (Figure 5).


Figure 4 Color and Swatches panels


Figure 5 Swatches panel


Current color
Old color


New color swatch
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Web-safe colors palette


By default, the Swatches panel displays the web-safe colors palette. This palette is designed to work for all visitors’ 
monitors, including those with older monitors that display only 256 colors. Although all newer monitors work with 
more than 256 colors, some web designers recommend continuing to use this palette so your pages appear consistent 
to all visitors. (An additional benefit is that it gives you a limited range of colors from which to choose; sometimes 
it’s easier to make good choices when these choices are limited.) If you’re sure all your viewers have newer monitors, 
you can deviate from this palette by using the Color panel.


Creating gradients
You create gradients by selecting a gradient type and adding colors to the gradient.


To create gradients:


1. Use the Selection tool to double-click the oval shape on 
the Stage.


The fill and stroke are both selected.


2. Make sure the Color panel and the Swatches panel are 
both visible.


If they are not, select Window > Color or Window > 
Swatches.


3. In the Color panel, select Radial Gradient in the Color 
Type menu (Figure 6). Selections in the Color Type 
menu determine the fill style of a shape.


This color type fills the selected shape with a radial 
gradient, composed of the two colors indicated by the 
color pointers under the gradient definition bar 
(Figure 7).


Note: By default, these colors may be set to black and 
white. 


You can have up to sixteen different colors in a gradient. 
To add more, click in the gradient definition bar 
(Figure 7).


Note: Radial gradients work best on elliptical shapes.


4. Make sure Extend Color is selected as the Flow option 
(Figure 7).


Flow lets you control colors applied past the limits of a 
gradient. The Flow options are Extend Color (the default 
mode), Reflect Color, and Repeat Color.


The gradient starts out black in the center (determined by 
the left-most color stop) and transitions to white 
(determined by the right-most color stop).


5. Double-click the left color stop under the gradient 
definition bar. Use the color picker to select a new color 
for the inner color of the gradient. The gradient definition 
bar changes color.


Figure 6 Gradient options in the Color panel


Figure 7 Gradient definition bar


Extend Color 


Color stops


Gradient 
definition bar 
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6. Click in the gradient definition bar to add a new color to 
the gradient.


A new color stop appears below the gradient definition 
bar in the Color panel (Figure 8).


7. With the new color stop still selected, click or drag in the 
color picker to select a new color for the gradient. You 
can also select colors by dragging the RGB scrubbers or 
entering a hexidecimal number (or by double-clicking the 
new color stop). 


8. Change the color of the right color stop to change the 
outer color of the gradient. 


Note: Selecting a lighter inner (left) color and a darker 
outer (right) color creates the illusion of a three 
dimensional sphere (Figure 9). 


9. Deselect the shape on the Stage to see the new gradient 
applied to your shape (Figure 10). Figure 8 Color panel


Figure 9 Gradient definition bar


Figure 10 Applied gradient
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Principles and rules of copyright
Copyright is protection for intellectual property.


Intellectual property consists of anything an individual has written or created. It might be music, text, pictures, 
photographs, sounds, and so on.


Fair use doctrine is part of the copyright laws. It states that limited portions of material may be used without written 
permission for certain purposes, such as reporting the news or schoolwork. It doesn’t define “limited,” though, so be 
sure you don’t overuse material. The fair use doctrine requires you to give credit to the author or creator of any 
material you use.


Creative Commons is a set of copyright licenses that allow for the distribution of copyrighted works. The range of 
four conditonal licences provide a set of “baseline rights”that allow for the distribution of copyrighted work 
worldwide, without change, at no charge. The four conditions include: Attribution, Noncommercial, No Derivative 
works, and Share-alike. Creative Commons licenses permit the mixing and matching of conditions to produce 
suitable copyright licences conditions. For more info, see: http://creativecommons.org/


Derivative works are copyrighted materials that have been altered or changed. Such material is protected by copyright 
laws. If you alter a copyrighted photograph by using computer software, that photograph is still protected, and you 
may not use it without written permission.


Academic standards for copyrighted material are higher than others. Because scholars and researchers study so many 
different ideas and are responsible for sharing those ideas with the world, they are required to satisfy higher standards 
of honesty. They must give credit not only when quoting someone else’s exact words but also for the ideas those 
words represent. As a researcher, you cannot paraphrase what someone else says and not give credit for it.


Bibliographies are lists of sources that have been used in research. When using the Internet for research or for design 
work, you need to give credit where it is due. Often, people who use graphics and images from the Internet for 
publication on their own web page create a list of image credits rather than a bibliography.


Rules of Copyright
1. You cannot use copyrighted material without written permission from the creator of the material (or from its 


copyright holder).


2. Material can be protected even if it does not display the © symbol. Even if no mention is made regarding 
copyright, you must assume that all material from another source is protected.


3. Penalties for violating copyright laws can range from mild to severe. If you break the copyright law, you might 
simply receive an e-mail message from the author asking you to stop using the material. If you publish the 
material on a website, the webmaster might shut down your site. Or you could be sued by the author or 
prosecuted by federal authorities.


4. To make sure you are not violating any copyright law, it is important that you do the following:


• Write or send e-mail to the author or creator and ask permission to use the material. Do not use it until you 
are given permission. 


• Follow the directions on the site regarding use of material. You might be asked to create a link on your page 
or to notify the author or creator. 


• Most important: Do not use any material if you don’t have written permission. 
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5. Copyright notice is no longer required to obtain protection, but it is often beneficial. Copyright notice for 
visually perceptible material should contain the following three elements:


• The symbol © (the letter C in a circle), or the word “Copyright,” or the abbreviation “Copr.”


• The year of first publication


• The name of the owner of copyright


◦ Example: © 2012 Adobe Systems Incorporated


6. Copyright notice for phonorecords and sound recordings should contain the following three elements.


• The symbol ℗ (the letter P in a circle)


• The name of the owner of copyright


• The year of first publication


7. The copyright notice should be affixed in such a way as to “give reasonable notice of the claim of copyright.”


For more information on copyrights, visit the United States Copyright Office on the Internet at www.copyright.gov. 

Principles and rules of copyright © 2012 Adobe Systems Incorporated
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Project 4


Web portfolios
Timing: 5 to 10 hours


Project overview


Portfolios communicate accomplishments, works in progress, or personal history. Individuals use 
portfolios to showcase their work when applying for a job. Traditionally a portfolio is a large book or 
leather case containing design samples. With the Internet, portfolios can be electronic, easily and quickly 
sharing a designer’s work with anyone in the world.


In this project, students create the elements of a web portfolio with Adobe Fireworks and Adobe 
Dreamweaver. They build a website that features work they have completed and work to be completed. As 
students create their portfolios, they plan, implement, and test their website designs; students then reflect 
on and evaluate their work. The presentation of a web portfolio can be just as important as its content.


Student product: Web portfolio


Note: Portions of the Web portfolios project align to the Adobe Certified Associate, Web Communication 
objectives. Within the instruction steps and technical guides, the specific learning objectives for the exam 
are referenced with the following format: 1.1  


Project objectives


At the completion of the project, students will have developed the following skills:


Project management skills


• Planning and creating a web portfolio


• Organizing and managing content


• Creating flowcharts


Design skills


• Designing consistent pages


• Designing for a specific audience and purpose


• Providing consistency and accessibility


• Providing universal navigation


• Adapting content for readability and emphasis


Research and communication skills


• Investigating and researching career areas 
within web design and development


• Communicating information to particular 
audiences


• Defining the goals and uses of a portfolio


• Soliciting and providing feedback


• Writing and editing website content


Technical skills


Fireworks


• Optimizing images


• Creating buttons


• Creating navigation bars


• Creating pop-up menus


• Exporting to Dreamweaver


Photoshop


• Resizing and rotating images


Dreamweaver


• Setting document properties


• Using the Assets panel


• Using CSS starter layouts


• Using CSS text styles


• Creating, modifying, and troubleshooting 
Cascading Style Sheets
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• Creating templates


• Creating forms


• Publishing web files


Project materials
• Adobe Fireworks CS6 installed on all machines


• Adobe Photoshop CS6 installed on all 
machines


• Adobe Dreamweaver CS6 installed on all 
machines


• Presentation: Writing for the web


• Guide: Writing for the web


• Guide: How to plan a portfolio


• Guide: Tips for information architecture


• Guide: How to design for usability


• Fireworks guide: How to create a wireframe


• Fireworks guide: How to create a design comp


• Fireworks guide: How to create interactive 
navigation


• Fireworks guide: How to optimize images


• Photoshop guide: How to resize, rotate, and 
crop images


• Dreamweaver and Fireworks guide: How to 
create interactive navigation


• Presentation: Web design for multiple screens 


• Dreamweaver guide: How to set document 
properties


• Dreamweaver guide: How to use CSS starter 
layouts


• Dreamweaver guide: How to use templates


• Dreamweaver guide: How to lay out a web 
page with CSS


• Dreamweaver guide: How create and edit a 
CSS rule


• Dreamweaver guide: How to use CSS text 
styles


• Dreamweaver guide: How to work with 
external Cascading Style Sheets


• Dreamweaver guide: How to use the Assets 
panel


• Dreamweaver guide: The Dreamweaver Insert 
panel 


• Guide: How to make websites accessible


• Dreamweaver guide: How to create forms


• Worksheet: Review and redesign


• Guide: Peer review


• Dreamweaver guide: How to check links


• Dreamweaver guide: How to deploy for multi-
screens


• Dreamweaver guide: How to preview and test a 
web project


• Dreamweaver guide: How to publish web files


Background preparation resources
• Technical and content information


• Key terms


• ISTE NETS*S Standard for Students


• Adobe Certified Associate, Web Communication objectives


Project steps


Designing a portfolio
(Suggested time: 100–150 minutes)


1. Introduce students to the goals of the project:







© 2012 Adobe Systems Incorporated Web portfolios 3


• Understand the goals and uses of portfolios.


• Research career areas in design and/or web design.


• Plan and create a flowchart for a portfolio.


• Select and organize content for a web portfolio.


• Construct, review, and redesign a web portfolio.


2. Discuss the concept of a portfolio, its purpose, and its audience.1.1


• What is a portfolio?


• What are the goals of a particular portfolio?


• What does a portfolio contain?


• Would it contain professional experiences? Coursework?


• How do you use a portfolio to communicate ideas?


• What could you use to communicate these ideas (for example, images, text, page layout, 
organization of the portfolio)?


• What are the long-term and short-term goals of a portfolio?


• Who is the audience for the portfolio?


3. Gather some examples of portfolios and show the class a variety of paper-based and online portfolios. 
Discuss their purpose and audience with the students.


4. Ask students to research career areas and job titles in web design and development and then select the 
focus for their portfolios based on their research. Career areas and job titles may include:


• Web designer


• Web developer


• Web applications developer


• Interaction designer


• User interface designer


• Front-end developer


Note: You might want to explain that in researching career areas they should document a specific job 
description with qualifications, expected skill set, expected technical knowledge, necessary training, 
and expected salary. You might also want to explain that they can collect websites containing specific 
job-related information and, if appropriate, link to them within their portfolios.


5. Explain the expectations of the portfolio. Some things to include might be:


• Portfolio introduction that explains their skill set, training, projects included in the portfolio, career 
interests and goals, and any professional experience


• An image or representative visual to use on the welcome page of their portfolio


• Narrative introductions to each project, explaining the ways their work highlights their skills


• Narrative introductions including specific examples comparing their skills with the career area 
they are interested in


• A learning plan that identifies skills or concepts they might be lacking at this point but would want 
to learn about and focus on during the next semester


• A web photo gallery of images to link to their work
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Note: You may consider reusing the Spry Widget Slideshow with Filmstrip from Project 1 and have 
students customize it to match their personal web portfolios.


6. Introduce the concept of writing for the web. Explain that the students need to create a narrative for 
their web portfolios. To do so they need to understand the following about best practices for creating 
web content: 


• Reading and scanning behaviors of their audience


• Writing for their audience


• Best practices for writing for the web


• Ways to optimize page content


• Best practices for working with organizations


• Methods for testing their content


Presentation: Writing for the web 1.2


Guide: Writing for the web


7. Pair students and ask them to consider the work they’ve done and to identify which files they could 
include in their portfolios.


8. When they have selected their content, allow students time to write an introduction for the portfolio.


9. Discuss how to organize the contents of the portfolio. Demonstrate how to create category outlines and 
corresponding flowcharts for the type of portfolio chosen.


Guide: Student portfolio


10. Review flowcharts and ask students to create a flowchart for their portfolios, including background 
information as follows:


• Describe the purpose of the portfolio.


• Create a list of assets in the portfolio and organize files and projects into categories.


• Using the category outline as a guide, draw a flowchart for the web portfolio.


Guide: How to plan a portfolio 2.5


Guide: Tips for information architecture 1.1, 1.2, 1.5, 2.5 


Guide: How to design for usability 2.4


11. Briefly review wireframes and design comps and ask students to create a wireframe and a few design 
comps for their portfolios. 


Fireworks guide: How to create a wireframe 2.5


Fireworks guide: How to create a design comp 2.3
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12. Ask your students to begin to write the narrative for the web portfolio for each project. For example, 
one way to integrate the client site (which students created in Projects 2 & 3) into the portfolio is to 
create a summary web page in the portfolio and link it to the client site, instead of adding a client site 
link to the main navigation. This summary page should contain a description of the client site, its 
goals, and its audience. The students can add the main navigation bar of their electronic portfolio to 
this summary page without any need to modify the client site.


13. Ask your students to build any assets and graphic elements for their portfolios. Remind students to edit 
and optimize their images. Ask students to use Photoshop, Illustrator, and/or Fireworks to create the 
common graphic page elements. Remind them that the look of their graphic elements should 
coordinate with their site designs.


Fireworks guide: How to optimize images 


Photoshop guide: How to resize, rotate, and crop images


Dreamweaver and Fireworks guide: How to create interactive navigation 4.9


Constructing a portfolio
(Suggested time: 100–250 minutes)


14. Remind students of the design principles and page design principles for website design. Remind 
students about designing for multiple screens and how to optimize website design and content for 
viewing on a variety of devices. 


Presentation: Web design for multiple screens 2.2


15. Remind students of the benefits of reusable design. Ask students to select the best design comp and 
then to use a combination of CSS, templates, and HTML to build their web portfolios based on their 


wireframes, flowcharts, and design comps.2.1


Dreamweaver guide: How to set document properties 3.3, 5.1


Dreamweaver guide: How to use CSS starter layouts 5.8


Dreamweaver guide: How to use templates 5.5


Dreamweaver guide: How to lay out a web page with CSS 5.2


Dreamweaver guide: How to create and edit a CSS rule 3.3, 5.1, 5.2, 5.8


Dreamweaver guide: How to use CSS text styles 5.3, 5.8


Dreamweaver guide: How to work with external Cascading Style Sheets 5.8


16. Ask students to add their images, written content, links, and so on to their web portfolios. Ask students 


to add alternative text to all images. 4.4, 4.5, 4.6


Dreamweaver guide: How to use the Assets panel 3.4


Dreamweaver guide: The Dreamweaver Insert panel 3.2, 4.5


Dreamweaver guide: How to make websites accessible 1.4, 2.4


Note: Ideally they will be able to reuse their assets from the Dreamweaver library or the Assets panel.
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17. Explain that because they will use this portfolio for potential employers, they may want to provide a 
contact or feedback form as a way for people to contact them. Using the “I do, we do, you do” method, 
demonstrate how to create a form. 


Dreamweaver guide: How to create forms 4.13


18. Ask students to finalize their web portfolio design and content.


Review and redesign of portfolio
(Suggested time: 50–100 minutes)


19. Have students work in groups and conduct technical tests and peer reviews of their web portfolios. 
Following are some possible guiding questions:


Design:


• Uniformity and consistency: 


◦ Are elements repeated on content pages to help identify the portfolio as a complete site? What 
attributes of the website maintain or violate consistency?


◦ Universal navigation: Where is the main navigation for the site located, and does it appear on 
all pages?


• Layout:


◦ Is the layout logical, or do page elements appear to be placed randomly? Does the page require 
excessive scrolling?


• Colors and fonts:


◦ Do the colors and fonts used for all design elements match the design comp?


• Links:


◦ Are the links labeled clearly?


• Usability:


◦ Does the page load quickly? 


◦ Can site visitors find information easily?


• Readability:


◦ Is there formatting that improves or reduces readability?


• Accessibility:


◦ Are all images labeled with alternative text (Alt tags)? 


◦ Are the text and titles clear and easy for all site visitors to read (color, size, and so on)?


◦ Do image links and hotspots (image maps) have alternative text labels? 


◦ What features can or cannot be read by screen readers?


Content:


• What is the purpose of the website? How does the purpose of the portfolio differ from the purpose 
of other websites, such as the client website? How does the purpose affect the content?


• Who is the intended audience for the website? How does the audience of the portfolio differ from 
the audience of other websites, such as the client website? How does the audience affect the 
content?


• Is the content relevant for the audience and the goals of the site?


• Does the content address the goals of the website?







© 2012 Adobe Systems Incorporated Web portfolios 7


• Do the content and structure match the flowchart and wireframes used to design them?


• Is the language level appropriate for the intended audience?


• Do the pages have any spelling errors, punctuation errors, or grammatical errors?


Worksheet: Review and redesign


Guide: Peer review 2.6


Dreamweaver guide: How to check links 6.1


Dreamweaver guide: How to deploy for multiple screens 1.5, 2.1, 2.2


Dreamweaver guide: How to preview and test a web project 6.1


20. Considering the feedback, allow students time to implement any changes to their portfolios based on 
the results of the technical test and peer review. 


21. Instruct students to finalize and publish their web portfolios.


Dreamweaver guide: How to publish web files 6.5


22. Ask students to present their portfolios to the class. They might want to include the first iterations of 
their portfolios in the presentation to show how they improved or changed their design or content and 


explain why they chose to make those changes.2.6


Extension activities


You can extend the project in the following ways:


• Portfolios: Ask students to plan a portfolio that showcases their best work from all their courses.


• Reflection supplement: Ask students to write up the decisions they made in the planning process for 
their portfolios. This document will help students reflect on their process and provide a framework for 
the next time they plan a website.


• Reviewing audience and purpose: Constructing a wireframe for a website is difficult the first time. 
Looking at examples of portfolios can help students better understand the possibilities for their own 
designs. Have a student seminar group find examples and report to the class about the audience and 
purpose of each portfolio. This presentation can serve as a good introduction to the activity.


• Fast finishers: For students who complete their portfolios early, have them use PhoneGap to create a 
mobile version of their portfolio.


Assessment
• Project rubric


Background preparation resources
• Review the student step-by-step guides referenced in this project.


• To view video tutorials aligned with the skills required to complete this project, visit the Digital Design 
CS6 show on Adobe TV: http://tv.adobe.com/show/digital-design-cs6/
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• For more teaching and learning resources on web portfolios and other topics in this project, search for 
resources from the community on the Adobe Education Exchange: http://edexchange.adobe.com


• For an overview of the interface and for more information on the technical aspects of Fireworks, see 
Fireworks Help. 


• For an overview of the interface and for more information on the technical aspects of Dreamweaver, 
see Dreamweaver Help. 


• For an overview of the interface and for more information on the technical aspects of Photoshop, see 
Photoshop Help. 


• •Review Website Production Management Techniques (select Content and Site View from the 
Structure menu on the right side of the screen): www.adobe.com/resources/techniques/structure/.


Information architecture and flowcharts


• Examples and instructions for visualizing information and using flowcharts: 
www.jjg.net/ia/visvocab/#page


• Resources about information architecture (click the topic Screen View for specific information about 
creating a storyboard or schematic and determining navigation): 
www.adobe.com/resources/techniques/structure/ 


• Information architecture tutorial: www.webmonkey.com/2010/02/information_architecture_tutorial/


Portfolios


• U.S. Department of Education, Office of Research and Improvement, Classroom Uses of Student 
Portfolios: www.ed.gov/pubs/OR/ConsumerGuides/classuse.html


• Advice from web professionals for building great web portfolios: 
www.smashingmagazine.com/2009/02/26/10-steps-to-the-perfect-portfolio-website/ and 
http://speckyboy.com/2011/05/08/building-a-great-web-design-portfolio-–-10-best-tips-40-examples/


• Five styles for organizing the content of a web portfolio: 
http://sixrevisions.com/web_design/five-popular-design-portfolio-website-styles/


• Examples of online portfolios:


◦ Twenty-five recommended web portfolios: 
http://sixrevisions.com/design-showcase-inspiration/25-impressive-portfolio-web-designs/ 


◦ Information and examples of a variety of electronic portfolios: 
http://eduscapes.com/tap/topic82.htm


◦ Elements of great portfolios with examples: 
http://webdesign.tutsplus.com/articles/general/elements-of-a-great-web-design-portfolio/


Web career information


• What is a web professional: http://www.markdubois.info/weblog/2012/01/what-is-a-web-professional/ 


• The World Organization of Webmasters (an organization providing community education and 
certification resources to Web professionals in all phases of their careers): http://webprofessionals.org/


Writing for the web


• Writing for the Web: Guidelines for MIT Libraries: http://libstaff.mit.edu/webgroup/writing/less.html


• Writing web content: http://www.usability.gov/pdfs/chapter15.pdf


• Content and usability: Writing for the web: 
http://www.webcredible.co.uk/user-friendly-resources/web-usability/web-content.shtml
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• Web writing for many interest levels: 
http://www.webcredible.co.uk/user-friendly-resources/web-usability/web-content.shtml


• Writing for the web: Tips and common mistakes we make: 
http://www.hongkiat.com/blog/writing-for-the-web-tips-common-mistakes-we-make/


• Writing for the web: http://www.useit.com/papers/webwriting/


Key terms
• audience


• flowchart


• information architecture


• portfolio


• purpose


• visualization


ISTE NETS*S Standard for Students


This project is aligned to the ISTE NETS*S Technology Standards. Depending on the subject and content 
area the student selects you may research your own state content standards to see how this project aligns to 
your state requirements.


ISTE NETS*S: Curriculum and Content Area Standards – NETS for Students


1. Creativity and Innovation


Students demonstrate creative thinking, construct knowledge, and develop innovative products and 
processes using technology. Students:


a. apply existing knowledge to generate new ideas, products, or processes.


b. create original works as a means of personal or group expression.


d. identify trends and forecast possibilities.


2. Communication and Collaboration


Students use digital media and environments to communicate and work collaboratively, including at a 
distance, to support individual learning and contribute to the learning of others. Students:


b. communicate information and ideas effectively to multiple audiences using a variety of media and 
formats


3. Research and Information Retrieval


Students apply digital tools to gather, evaluate, and use information. Students:


a. plan strategies to guide inquiry.


b. locate, organize, analyze, evaluate, synthesize, and ethically use information from a variety of 
sources and media. 


c. evaluate and select information sources and digital tools based on the appropriateness to specific 
tasks


4. Critical Thinking and Problem Solving


Students use critical thinking skills to plan and conduct research, manage projects, solve problems and 
make informed decisions using appropriate digital tools and resources. Students::


a. identify and define authentic problems and significant questions for investigation.


b. plan and manage activities to develop a solution or complete a project.


d. use multiple processes and diverse perspectives to explore alternative solutions
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5. Digital Citizenship


Students understand human, cultural, and societal issues related to technology and practice legal and 
ethical behavior. Students:


a. advocate and practice safe, legal, and responsible use of information and technology.


b. exhibit a positive attitude toward using technology that supports collaboration, learning, and 
productivity.


c. demonstrate personal responsibility for lifelong learning. 


6. Technology Operations and Concepts


Students demonstrate a sound understanding of technology concepts, systems, and operations. 
Students:


a. understand and use technology systems.


b. select and use applications effectively and productively.


d. transfer current knowledge to learning of new technologies. 
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Adobe Certified Associate, Web Communication objectives


1.1 Identify the purpose, audience, and audience needs for a website.


1.2 Identify web page content that is relevant to the website purpose and appropriate for the target 
audience.


1.4 Demonstrate knowledge of website accessibility standards that address the needs of people with visual 
and motor impairments.


1.5 Make website development decisions based on your analysis and interpretation of design 
specifications.


2.1 Demonstrate general and Dreamweaver-specific knowledge of best practices for designing a website, 
such as maintaining consistency, separating content from design, using standard fonts, and utilizing 
visual hierarchy.


2.2 Produce website designs that work equally well on various operating systems, browser versions/
configurations, and devices. 


2.3 Demonstrate knowledge of page layout design concepts and principles.


2.4 Identify basic principles of website usability, readability, and accessibility.


2.5 Demonstrate knowledge of flowcharts, storyboards, and wireframes to create web pages and a site map 
(site index) that maintain the planned website hierarchy.


2.6 Communicate with others (such as peers and clients) about design plans.


3.2 Use the Insert bar.


3.3 Use the Property inspector.


3.4 Use the Assets panel.


4.4 Add text to a web page.


4.5 Insert images and apply alternative text on a web page.


4.6 Link web content, using hyperlinks, e-mail links, and named anchors.


4.9 Insert navigation bars, rollover images, and buttons created in a drawing program on a web page. 


4.13 Create forms.


5.1 Set and modify document properties.


5.2 Organize web-page layout with relative and absolutely positioned div tags and CSS styles.


5.3 Modify text and text properties.?


5.5 Create web page templates.


5.8 Use CSS to implement reusable design


6.1 Conduct basic technical tests.


6.5 Publish and update site files to a remote server.
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Assessment


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations


Portfolio 
flowchart


Absent or incomplete. Flowchart shows clear 
organization of content and 
appropriate selection of 
content.


Flowchart shows clear 
organization of content and 
appropriate and complete 
selection of content 
relevant to goals and 
purpose.


Portfolio 
design comps


Absent or incomplete. Design comps are 
consistent with portfolio 
flowchart and include 
information on color, 
placement, and navigation 
choices. Students clearly 
explain design decisions 
for home-page plan.


Design comps are 
consistent with portfolio 
flowchart and include 
information on color, 
placement, and navigation 
choices. Students clearly 
explain design decisions 
for home-page plan. 
Explanations also include 
synthesis of information 
from portfolio analysis.


Web portfolio Absent or incomplete. Portfolio home page 
reflects design comps, and 
text navigation reflects 
flowchart elements. 
Portfolio content pages 
reflect flowchart elements, 
have a common structure, 
and include consistent 
design elements that 
improve usability for 
visitors. Portfolio content 
includes information about 
future goals, highlights 
exemplary projects that 
support goals, and includes 
good usability and 
accessibility.


Portfolio home page 
reflects design comps, and 
text navigation reflects 
flowchart elements. 
Design and layout of the 
home page reflect good 
application of design 
principles. Portfolio 
content pages reflect 
flowchart elements, have a 
common structure, and 
include consistent design 
elements that improve 
usability for visitors. 
Content pages apply 
principles learned through 
portfolio analysis. 
Portfolio content includes 
information about future 
goals, highlights 
exemplary projects that 
support goals, and includes 
good usability and 
accessibility.







© 2012 Adobe Systems Incorporated Web portfolios 13


Published 
portfolio


Absent or incomplete. Students can define terms 
related to website 
publishing and articulate 
the differences between 
local and remote sites. 
Students understand the 
main components of the 
Files panel used in remote 
site setup. Published 
portfolios function as they 
did when tested locally.


Students can define terms 
related to website 
publishing and articulate 
the differences between 
local and remote sites. 
Students understand and 
can explain to others the 
main components of the 
Files panel used in remote 
site setup and how the 
panel is used for 
publishing. Published 
portfolios function as they 
did when tested locally.


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations
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Adobe Photoshop CS6 Project 4 guide

How to resize, rotate, and crop images
You will frequently want to resize and crop an image after opening it in Photoshop from a digital camera or scanner. 
Cropping means cutting some parts of the image away so only the parts you want remain.


Backing up your original
Before making any changes to an image, you should always save the image with a new filename. You will have the 
most flexibility if you save it as a PSD—Photoshop’s native format. You can generate TIFFs (for print) and JPEGs 
(for the web) from a single PSD file. For example, PSD files preserve layers, so the layers are available when you 
reopen the file.


Resizing images
When working in Photoshop, it is generally best to leave your image at as high a resolution as possible to allow for 
greater flexibility when generating images.


About pixel dimensions and resolution


The pixel dimensions (image size or height and width) of a bitmap image is a measure of the number of pixels along 
an image’s width and height. Resolution is the fineness of detail in a bitmap image and is measured in pixels per inch 
(ppi). The more pixels per inch, the greater the resolution. Generally, an image with a higher resolution produces a 
better printed image quality.


• For images to print well, they generally should have a resolution of 300 ppi.


• For most web pages, you can safely save images at 72 ppi. Because most monitors do not display resolutions 
higher than this, you can reduce file size by reducing resolution.


Note: Monitor technology and Internet connection speeds are continually evolving. However, the 72-ppi standard 
continues to be widely used, and for the most part, you can’t go wrong with it.


The combination of pixel dimension and resolution determines the amount of image data. Unless an image is 
resampled, the amount of image data remains the same as you change either the pixel dimension or resolution. If you 
change the resolution of a file, its width and height change accordingly to maintain the same amount of image data. 
And, vice versa. 
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In Photoshop, you can see the relationship between image size and resolution in the Image Size dialog box 
(Figure 1). 


To change resolution of an image:


Changing an image’s resolution affects not only its on-screen 
size but also its image quality and its printed characteristics.


1. Open an image in Photoshop.


2. Save the image with a new name.


This step preserves the original image in case you want to 
revert to it. You should always make a copy of the 
original before making changes.


3. Choose Image > Image Size.


The Image Size dialog box opens (Figure 1).


Notice that the dialog box lists two major categories of 
information about the size of the image.


• Pixel Dimensions refers to the actual number of 
pixels contained in the image. The number of pixels 
represents the amount of data in the image. Unless 
you select the Resample Image option, number of 
pixels remains the same as you resize and change the 
resolution of the image.


• Document Size refers to how the document appears 
when printed. Document size is also a starting point 
for how the document will appear in another 
document, such as an InDesign file. In later projects, 
you will place Photoshop images in InDesign files.


4. Make sure the Resample Image option is not selected.


The Resample option changes the amount of data or 
information in the image as you resize. For now, it’s best 
to leave this option deselected. 


Note: You can use resampling to make enlargements. 
However, because resampling can only estimate pixels, it 
is best to use a picture with a larger resolution in the first 
place.


5. Change the Resolution value.


Observe that the other two numbers for width and height 
change accordingly. For example, suppose an image set 
at 300 dpi measures approximately 13 by 9 inches. The 
same image when set to 72 dpi measures approximately 
54 by 36 inches (Figure 2). 


6. Click OK to close the Image Size dialog box.


Figure 1 Image Size dialog box with resolution at 
300 dpi


Figure 2 Image Size dialog box with resolution 
changed to 72 ppi
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Reducing an image’s size (pixel dimensions)


Although you will often want to keep pixel information, sometimes you need to reduce the total (pixel) size of an 
image. This step removes pixels and reduces file size. You will usually do this when preparing the image for the web 
or other electronic medium; for print, you will generally want to simply change the document’s size. (Of course, you 
may want to reduce file size for other reasons, such as to preserve hard disk space or to speed up image rendering.)


To reduce an image’s pixel dimensions:


1. Choose Image > Image Size.


The Image Size dialog box opens (Figure 3).


In the previous steps you attended only to the resolution, 
or document size of the image. This time you will ignore 
that area and focus on the pixel dimensions.


2. Select the Resample Image option near the bottom of the 
dialog box. 


Observe that the Pixel Dimensions menus and the 
Constrain Proportions option become active.


This option automatically changes the width as you 
change the height, and vice versa. For example, if you 
start with an image of 2000-pixel width and 1000-pixel 
height (a 2:1 width/height ratio) and change the width to 
1000 pixels, the height automatically changes to 500 
pixels when Constrain Proportions is checked. Generally, 
selecting this option is a good idea.


Note: You can ignore Scale Styles for now. This option 
comes into play only when you have styles applied to 
layers.


3. Choose Bicubic Sharper from the Resample Image menu. 


This option is best for reductions.


4. In the Pixel Dimensions Width box, enter the desired 
width in pixels.


You can also choose a percentage by changing the unit 
beside the Width box from Pixels to Percent.


5. Click OK to change the image’s pixel dimensions.


Note: After the size reduction, you should apply the 
Unsharp Mask filter to the image by choosing Filter > 
Sharpen > Unsharp Mask. This will clear up any 
blurriness that results from the reduction.


Figure 3 Image Size dialog box
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Rotating images
There may be times when you open an image in Photoshop to find that it is not in its proper orientation. Alternatively, 
a photograph that you have taken is just a little bit crooked. There are easy ways to fix both of these situations.


To rotate an image:


The Image Rotation commands let you rotate or flip an entire 
image. The commands do not work on individual layers or 
parts of layers, paths, or selection borders. If you want to 
rotate a selection or layer, use the Transform or Free 
Transform commands.


1. Choose Image > Image Rotation (Figure 4), and choose 
one of the following commands from the submenu:


• 180° Rotates the image by a half-turn.


• 90° CW Rotates the image clockwise by a quarter-
turn.


• 90° CCW Rotates the image counterclockwise by a 
quarter-turn.


• Arbitrary Rotates the image by the angle you 
specify. If you choose this option, enter an angle 
between 0 and 359.99 in the Angle text box. Select 
°CW or °CCW to rotate clockwise or 
counterclockwise. Then click OK.


2. Choose File > Save to save the rotated image. 
Figure 4 The Image Rotation submenu


Cropping Images
You’ll often take pictures that are larger than you need, or you'll want to reframe an image to remove unnecessary 
parts. Taking pictures that are larger than you need, at as high a resolution as possible, gives you flexibility in 
selecting parts of an image to crop. Cropping is the process of removing portions of an image to create focus or 
strengthen the composition. 


You can crop an image in Photoshop by selecting an area with one of the selection tools and using the Image > Crop 
command. The Crop tool in the Tools panel provides additional options for cropping images. You can use the Crop 
tool to select an area to crop, or set the Crop tool to trim an image to a specified aspect ratio. This guide covers how 
to use the Crop tool.


Grid overlays


A variety of grids for overlaying an image you are cropping are available from the View menu in the Options bar. The 
Rule of Thirds grid, for example, illustrates a general rule of thumb in the visual arts. This grid consists of two 
equally spaced horizontal and vertical lines. Visual interest and a strengthened composition are created when objects 
are placed along (or at the intersection of) these horizontal and vertical lines. 


To crop an image by using the Crop tool:


1. Click the Crop tool in the Tools panel (Figure 5). 


The pointer changes to the Crop tool.


Figure 5 Crop tool
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2. Choose a crop option from the list of menu of preset 
aspect ratios in the Options bar (Figure 6). 


For example, you may choose Unconstrained, which 
allows you to crop an image to dimensions that you 
specify. Alternatively, you can select from a series of 
preset aspect ratios, such as Original Ratio or other 
common ratios, such as 16:9, also known as widescreen. 
If you are processing several images and want to 
maintain a specific crop size, you can save your 
customized setting by using the Save Preset option.


3. Choose an overlay grid from the View menu in the 
Options bar (Figure 7).


4. Create a marquee selection by dragging over the part of 
the image you want to keep (Figure 8). 


The selection doesn’t have to be precise—you can adjust 
it in the next step.


A Rule of Thirds grid appears.


5. If necessary, adjust the cropping selection:


• To move the selection to another position, place the 
pointer inside the bounding box and drag.


• To scale the selection, drag a handle in any of the 
corners. To constrain the proportions, hold down 
Shift as you drag a corner handle. 


• To rotate the selection, position the pointer outside 
the bounding box (the pointer becomes a curved 
arrow), and drag. To move the center point around 
which the marquee rotates, drag the circle at the 
center of the bounding box. The selection can’t be 
rotated in Bitmap mode.


6. If necessary, use the Straighten tool to correct for camera 
tilt. Click the Straighten tool in the Options bar and then 
drag along a line in the image that you want to make 
vertical or horizontal.


7. Once you are satisfied with the crop area, press Enter 
(Windows) or Return (Mac OS).


The image is trimmed to the selected region (Figure 9).


Figure 6 Menu of preset aspect ratios


Figure 7 Menu of preset View options


Figure 8 Crop area selected


Figure 9 Crop applied
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Digital Design Project 6 worksheet

Examples of effects


Effect How is it used? 
(Describe its use on the web-
site.)


Why is it used? 
(Explain how it adds value to 
the audience or message of 
the site.)


Pan: Move the camera horizontally 
across a scene.


Tilt: Move the camera vertically 
across a scene.


Zoom: Move the camera inward or 
outward.


Camera angle: Apply the rule of 
thirds or adjust the viewing angle.


Bounce: Make a moving object 
rebound before stopping.
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Cross-fade transition: Fade in one 
image while another fades out.


Flip transition: Make a flipping 
object appear to turn into another 
object that is flipping into view.


Simple fade transition: Fade an 
object in or out of view.


Color-fade transition: Gradually 
change the color of an object.


Rotation transition: Rotate an 
object in or out of view.


Effect How is it used? 
(Describe its use on the web-
site.)


Why is it used? 
(Explain how it adds value to 
the audience or message of 
the site.)

Examples of effects © 2012 Adobe Systems Incorporated
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How to generate different file formats
Different mediums—print, web, and video—require different file formats. This guide describes how to generate 
appropriate file formats for these mediums by using Adobe Photoshop CS6.


When generating any image in Photoshop, it’s important to remember that when you save an image, Photoshop saves 
the image as it appears onscreen. That is, if you have hidden some layers, they will not appear in the saved image.


Saving files for the web
For web pages, you will generally want to save photos in JPEG format. JPEG is used more than any other format for 
photos on web pages. (Other web formats include GIF—usually used for images with limited colors—and PNG—a 
less often used, but flexible format.)


JPEG is popular because it compresses well—that is, you can make files smaller without sacrificing quality. 
However, if you compress too much, file quality will suffer; the trick is to find the right balance between image 
quality and compression.


Photoshop makes this process easier through a command called Save For Web. You can use Save For Web to preview 
JPEGs with different compression settings before you save them.


Note: When you save a file for the web, it appears at its full pixel size. The document size does not affect how the 
image appears in a browser. For example, an image whose pixel size is 640 x 480 displays at that size in a browser. 
The document size affects only how the image prints.


To save a file as a JPEG:


1. Start Photoshop and open an image.


2. Choose File > Save For Web.


The Save For Web dialog box appears (Figure 1).


3. In the Optimized File Format pop-up menu, choose 
JPEG, if it is not selected. (Figure 2).


Figure 1 Save For Web dialog box


Figure 2 Optimized File Format menu 


Optimized File 
Format menu

© 2012 Adobe Systems Incorporated How to generate different file formats 1







Project 1 guide Adobe Photoshop CS6


2


4. Click the 2-Up tab to display both the original and a 
preview of the file to be saved (Figure 3).


5. Adjust quality by using either the Compression Quality 
pop-up menu or the Quality slider (Figure 4).


As you change settings, observe how the quality of the 
lower (preview) photo appears compared to the file size. 
Ideally, you want to find the right balance between 
preserving compressed image quality against smallest file 
size.


6. When you are satisfied, click Save.


Clicking Save automatically saves a copy of the image as 
a JPEG with the settings you indicated. The original 
image is left unchanged. For working purposes, you may 
want to incorporate some of the settings into the 
filename, such as “banner_medium.jpg” for an image 
saved as a medium-quality JPEG.


After you save, the original file stays open in Photoshop.


Note: If the original image is also a JPEG (many digital 
cameras use JPEG as a format), you need to save the 
copy in a different location from the original (or give it a 
different name) to avoid confusion.


Figure 3 Save For Web dialog box, 2-up mode


Figure 4 Save For Web settings


Generating files for print
Generating files for print use is different from saving images for the web: you use an uncompressed file format and 
you must be sure the file is at a high enough resolution (preferably 300 ppi) before you save it. It is always good to 
import the image into Photoshop at the highest possible resolution to give more flexibility in the kinds of images you 
can generate.


Note: You can print to a printer directly from any computer running Photoshop. The options described here are for 
sending an image to a printer, to another computer to be printed, or to another application.


Generating files for print involves three steps:


1. Setting the image resolution to 300 ppi.


2. Converting the image to CMYK (if the image is going to an offset print vendor).


3. Generating a print-friendly (compression-free or lossless) format, such as TIFF.


Compression 
Quality menu


Quality sliderOptimized File  
Format menu
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Setting resolution to 300 ppi


Setting a higher resolution is important to maintain flexibility and quality.


To set resolution to 300 ppi:


1. Open an image in Photoshop.


2. Choose Image > Image Size.


The Image Size dialog box appears (Figure 5).


3. Make sure the Resample Image option is not selected.


When you leave this option unselected, you ensure that 
you’re only changing the image’s resolution, not 
removing or adding pixels.


4. Enter 300 in the Resolution text box (Figure 5).


Make sure pixels/inch is selected as the units for 
Resolution.


5. Click OK.


Figure 5 Image Size dialog box


To preview an image at the size it will appear when printed, choose View > Print Size.


Converting images to CMYK


Computers use combinations of red, green, and blue (RGB) to display photos. Offset printing presses print full-color 
photos, using cyan (blue), magenta (red), yellow, and black. This is known as CMYK printing. If you are printing to 
an inkjet printer, you can leave the image in RGB mode, but if you are sending the image to an offset print vendor, 
you need to convert the image to CMYK.


To view how the image will appear in CMYK, choose View > Proof Setup > Working CMYK. (For some images, you 
may not observe any difference at all.) This preview is called a soft proof.


Note: Soft proofs are approximations. What you see onscreen depends on the quality and settings of your monitor as 
well as the lighting conditions of your work environment. You may observe different results when you actually print. 
Nevertheless, soft proofs can be useful.


Photoshop also enables you to preview how the image will appear on a range of different printers, including most 
Epson models and offset printing. To view these, choose View > Proof Setup > Custom.


To convert an image to CMYK:


1. Save a copy of the image.


2. Choose Image > Mode > CMYK Color.


3. If the image has layers, Photoshop asks whether you wish 
to flatten. Click Flatten.


(Because you saved a copy of the file, you can open the 
saved copy to recover the layers.)


Resolution text box

© 2012 Adobe Systems Incorporated How to generate different file formats 3







Project 1 guide Adobe Photoshop CS6


4


Generating TIFFs


After you convert the image to CMYK and make sure it is at the correct resolution, you can save it in a print-friendly 
format (a format with no compression, known as a lossless format). In this exercise, you will choose the TIFF format.


Note: Although TIFF is the most common lossless image format, you can also use EPS or an Adobe PDF.


To generate a TIFF:


1. Choose File > Save As.


The Save As dialog box appears (Figure 6).


2. In the Format box, choose TIFF (*.TIF, *.TIFF)  
(Windows) or TIFF (Mac OS).


3. Click Save. 


The TIFF Options dialog box appears (Figure 7).


4. Because the image is going to a printer, you do not need 
to compress it. Leave Image Compression set to None. 
Leave Pixel Order set to Interleaved.


Note: In practice, TIFF files are seldom compressed.


5. Set Byte Order to your operating system (Windows or 
Mac OS). 


6. Because the image is going to a printer, you also don’t 
need to save the layers. Make sure Discard Layers And 
Save A Copy is selected. 


This option flattens the layers in the image.


7. Click OK.


Note: If the image has only the Background layer, the 
option Discard Layers  And Save A Copy is not 
available.


Figure 6 Save As dialog box


Figure 7 TIFF Options dialog box


Format pop-up menu
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Printing images and saving print dialog settings


There may be occasions where you want to print a copy of your image to a local printer. Photoshop provides many 
printing options, including the following printing commands:


Print Displays the Print dialog box, where you can preview the print job and select the printer, number of copies, 
output options, and color management options. 


Print One Copy Prints one copy of a file without displaying a dialog box.


Once you have established a preferred combination of format and color management options, you can save the print 
dialog settings as a preset for use later.


To set Photoshop print options and print:


1. Choose File > Print.


The Print dialog box appears (Figure 8).


2. Do one or more of the following:


• Use the Printer menu to select a printer.


• Select the number of copies to print.


• Set the paper orientation to portrait or landscape.


• If needed, click the Print Settings button to set page setup options specific to your printer, printer drivers, 
and operating system, such as paper size and layout.


• Set Color Management and proofing options


• Adjust the position and scale of the image in relation to the selected paper size and orientation. 


• Set output options (Printing Marks and Functions)


3. Do one or more of the following:


• To print the image, click Print.


• To close the dialog box without changing the options, click Cancel.


• To preserve the options and close the dialog box, click Done.


Note: If you get a warning that your image is larger than the printable area of the paper, click Cancel, choose File 
> Print, and select the Scale To Fit Media option. 
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Figure 8 Print dialog box


Creating images for video
Photoshop can create images of various aspect ratios so that they appear properly on devices such as video monitors. 
You can select a specific video option (using the New dialog box) to compensate for scaling when the final image is 
incorporated into video.


Safe zones


The Film & Video preset also creates a document with nonprinting guides that delineate the action-safe and title-safe 
areas of the image (Figure 9). Using the options in the Size menu, you can produce images for specific video 
systems—NTSC, PAL, or HDTV.


Safe zones are useful when you edit for broadcast and videotape. Most consumer TV sets use a process called 
overscan, which cuts off a portion of the outer edges of the picture, allowing the center of the picture to be enlarged. 
The amount of overscan is not consistent across TVs. To ensure that everything fits within the area that most TVs 
display, keep text within the title-safe margins, and all other important elements within the action-safe margins.


Set printer and print job options


Position and size image


Preview print


Specify color management 
and proofing options


Set paper orientation Print Settings button


Printing Marks and Functions
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Figure 9 Video preset file size guides  in a new document


To create an image for use in video:


1. Create a new document.


The New document dialog box appears (Figure 10).


2. From the Preset menu in the New dialog box, choose the 
Film & Video preset.


3. Choose the size that is appropriate for the video system 
on which the image will be shown.


 In this case, the NTSC DV option is selected 
(Figure 11).


4. Click Advanced to specify a color profile and specific 
pixel aspect ratio.


Important: By default, nonsquare pixel documents open 
with Pixel Aspect Ratio Correction enabled. This setting 
scales the image so it appears as it would on the 
nonsquare-pixel output device (usually a video monitor).


5. Click OK to close the New document dialog box.


6. Click OK to close the message “Pixel aspect ratio 
correction is for preview purposes only. Turn it off for 
maximum image quality.”


The new document opens (Figure 9).


Figure 10 New document dialog box


Figure 11 Film and video size preset options


Action safe area (outer 
rectangle)


Title safe 
area (inner 
rectangle)
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7. To view the image as it would appear on a computer 
monitor (square pixel), choose View > Pixel Aspect Ratio 
Correction.


For example, in Figure 12, a circular image is shown 
displayed with Pixel Aspect Ratio Correction turned on 
and then turned off.


Note: You can simultaneously view an image with the 
Pixel Aspect Ratio Correction turned on and off. With the 
nonsquare pixel image open and Pixel Aspect Ratio 
Correction enabled, choose Window > Arrange > New 
Window For [name of document]. With the new window 
active, choose View > Pixel Aspect Ratio Correction to 
turn off the correction.


8. If you have a display device, such as a video monitor, 
connected to your computer, you can preview the 
document on the device by choosing File > Export > 
Render Video.


Note: When creating images for video, you can load a set 
of video actions (included with Photoshop) that automate 
certain tasks—such as scaling images to fit video pixel 
dimensions and setting the pixel aspect ratio.


Figure 12 Circle in NTSC DV (720 x 480 pixels) 
document viewed on computer (square pixel) 
monitor with Pixel Aspect Ratio Correction turned 
on (top) and Pixel Aspect Ratio Correction turned 
off (bottom)
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How to create an RSS feed
RSS (Rich Site Summary) is a format for delivering web content that continues to change over time. Some good 
examples are news-related, weather, and sports sites where the content and stories change continuously. Online 
publishers can syndicate their content as an RSS feed to anyone who wants it. Those who subscribe to the feed have 
access to the most current information available. 


RSS solves a problem for people who regularly visit the same website or search for the same types of content. It 
allows them to easily stay informed by retrieving the latest content from the sites that interest them the most. They 
save time by not needing to visit each site individually.


You can add RSS feeds to web pages and mobile applications. In this guide, you use an RSS feed to display up-to-the-
minute stories and articles in a mobile application.


An application needs three things to display an RSS feed: a text component to display a summary of the story, a list 
component to display a list of the top stories in the feed, and a Read More button to open the full story in a browser on 
the device (Figure 1). You add the components first and then write the ActionScript code to call the RSS feed, format 
the content, and display additional information when users click the Read More button. 


Figure 1 Mobile application screen displaying the Campus News RSS feed


Text Area 
component


List component


Button 
component
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Adding components for the RSS feed 
Adobe Flash Professional CS6 provides ready-to-use components for displaying dynamic content stored outside the 
application. Components are located in the Components panel.


In this example, we’ve set up a mobile application for a university campus guide, with a screen in the app set up to 
display a news feed. The screen already contains the background artworks. The following steps show how to add the 
components for the RSS feed.


To add components for the RSS feed:


1. Open the Flash Professional document for the mobile 
application you want to display the RSS feed.  


2. In the Timeline panel, select the keyframe that represents 
the location of the content you want to display 
(Figure 2).


3. Select Window > Components to open the Components 
panel (Figure 3).


4. Expand the User Interface folder in the Components 
panel.


The RSS feed can show a summary of each news story. 
You can use a TextArea component to display the 
summary.


5. Drag the TextArea component from the Components 
panel and place it in the upper-left corner of the area on 
the Stage where you want the news summary to appear 
(Figure 4).


You want the text to align in the top-left of the 
component, so you need to move the anchor point in the 
TextArea. You can do that by using the Free Transform 
tool.


Figure 2 Timeline panel 


Figure 3 Components panel 


Figure 4 TextArea component 
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6. Select the Free Transform tool.


7. Drag the anchor point (small circle) to the top-left corner 
of the TextArea component (Figure 5).


Next you resize the TextArea component to fit the 
summary text for the news feed.


8. Using the Free Transform tool, hold down the Alt key 
(Windows) or Option key (Mac OS) and drag the lower-
right corner of the TextArea component until it fills the 
top third of the screen. Make sure the component stays 
within the Stage boundary (Figure 6).


Note: Holding down the modifier key as you drag resizes 
the component from the top-left corner. You can also 
enter an exact size for the component in the Properties 
panel. In the example, the component is 479 x 220 pixels.


Next you add a List component for listing the menu of 
top news stories in the RSS feed. 


9. Drag a List component from the Components panel and 
place it below the TextArea component (Figure 7).


Figure 5 Dragging the anchor point 


Figure 6 Sizing the TextArea component 


Figure 7  List component 
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10. Move the anchor point to the top-left corner of the List 
component and resize the component so it fills the 
bottom two-thirds of the screen.


The TextArea and List components now fill the content 
area of the Campus News page in the mobile app 
(Figure 8).


11. Using the Selection tool, select the TextArea (top) 
component. In the Properties panel, enter rssStory in the 
Instance Name box (Figure 9). 


The ActionScript code will refer to this instance name.


Note: Instance names are case sensitive, so be sure to 
match the instance names exactly or you will receive 
errors when running the application.


12. Select the List (bottom) component. In the Properties 
panel, enter newsList in the Instance Name box.


Next you add the Read More button component for 
opening a URL in a browser to show more information 
about each news story.


13. Drag a Button component from the Components panel 
and place it in the lower-right corner of the TextArea 
(Figure 10). 


14. Use the Free Transform tool or the Properties panel to 
resize the button. 


In the example, the button is 135 x 60 pixels.


15. Using the Selection tool, select the button component. In 
the Properties panel, enter btn_ReadMore in the 
Instance Name box.


Figure 8  TextArea and List components 


Figure 9  Properties panel, instance name


Figure 10  Button component
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16. In the Component Parameters section of the Properties 
panel, enter Read More in the Label text box (Figure 11). 


The label appears on the button (Figure 12). The font is 
small, but you can adjust it by using ActionScript.


Figure 11  Properties panel, Component 
Parameters section


Figure 12  Label on the button component


Adding ActionScript code to create and format the RSS feed
Now that you have your components in place, you can add the ActionScript code to call the RSS feed, format the 
content, and display additional information when someone clicks the Read More button.


Each component is associated with an ActionScript class file that defines its methods and properties. You need to add 
these first.


To add ActionScript code to create and format the RSS feed:


1. Click in the Code or Actions layer that corresponds to the 
RSS content in the timeline (Figure 13). If your timeline 
doesn’t have a Code or Actions layer, add one and insert 
a blank keyframe at the same location as the RSS content.


2. Select Window > Actions to open the Actions panel. 
Make sure Script Assist is turned off.


Figure 13  Timeline panel


Actions 
layer


RSS actions 
keyframe


RSS content 
keyframe

© 2012 Adobe Systems Incorporated How to create an RSS feed 5







Project 7 guide Adobe Flash Professional CS6


6


3. Enter or copy and paste the following code to import the ActionScript classes needed by the application:
//IMPORT CLASSES


import fl.controls.List;


import flash.net.URLLoader;


import flash.events.Event;


import flash.net.URLRequest; 


4. Enter or copy and paste the following code to format the text and Read More button:
//NEWSLIST FORMATTING


var newsListTf:TextFormat = new TextFormat(); 


newsListTf.font = "Verdana"; 


newsListTf.color = 0xFFFFFF; 


newsListTf.size = 18; 


newsListTf.align = "left"; 


newsList.setRendererStyle("textFormat", newsListTf);


newsList.rowHeight = 100;


newsList.allowMultipleSelection = false;


//newsList.wordWrap = true;


//NEWSDISPLAY TEXT AREA FORMATTING


var rssStoryTf:TextFormat = new TextFormat(); 


rssStoryTf.font = "Verdana"; 


rssStoryTf.color = 0x6699CC; 


rssStoryTf.size = 22; 


rssStoryTf.align = "left"; 


rssStory.setStyle("textFormat", rssStoryTf);


//READMORE BUTTON FORMATTING


var buttonTf:TextFormat = new TextFormat(); 


buttonTf.font = "Verdana"; 


buttonTf.color = 0xFFFFFF; 


buttonTf.size = 22; 


btn_ReadMore.setStyle("textFormat", buttonTf);

How to create an RSS feed © 2012 Adobe Systems Incorporated







Adobe Flash Professional CS6 Project 7 guide

5. Enter or copy and paste the following code to create the RSS feed and URL event for the Read More button:


Note: The following code references an RSS feed located at http://rssfeeds.tv.adobe.com/adobe-higher-
education-solutions.xml. Replace this with the URL to an RSS feed that is appropriate for your mobile 
application.


//RSS FEED


var rssLoader:URLLoader = new URLLoader();


var rssURL:URLRequest = new URLRequest
("http://rssfeeds.tv.adobe.com/adobe-higher-education-solutions.xml");


rssLoader.addEventListener(Event.COMPLETE, rssLoaded);


newsList.addEventListener(Event.CHANGE, selectRssStory);


btn_ReadMore.addEventListener(MouseEvent.CLICK, goToURL);


rssLoader.load(rssURL);


var newsXML:XML = new XML();


var currentStoryURL:URLRequest = new URLRequest();


newsXML.ignoreWhitespace = true;


function rssLoaded(evt:Event):void


{


newsXML = new XML(rssLoader.data);


//trace(newsXML);


for(var item:String in newsXML.channel.item) {


//newsList.addItem({label: newsXML.channel.item[item].pubDate.substr(0, 16) 
//+": " + newsXML.channel.item[item].title } );


newsList.addItem({label: newsXML.channel.item[item].title.substr(0, 40) 
+" ..." } );


}


newsList.selectedIndex = 0;


//FIRST LOAD


currentStoryURL = new URLRequest(newsXML.channel.item[0].link);


rssStory.htmlText = newsXML.channel.item[0].description;


}


function selectRssStory(evt:Event):void 


{


rssStory.htmlText = newsXML.channel.item[evt.target.selectedIndex ].description;


currentStoryURL = new URLRequest(newsXML.channel.item[evt.target.selectedIndex 
].link);


}


function goToURL(event:MouseEvent):void


{


navigateToURL(currentStoryURL);


}
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6. Close the Actions panel.


7. Select Control > Test Movie > In AIR Debug Launcher 
(Mobile).


The application opens in the preview window and the 
Simulator appears.


8. Be sure you are at the page that contains your RSS feed.


The RSS feed displays a list of current news stories with 
summaries shown in the text area at the top. Clicking the 
Read More button opens a browser window with 
additional information (Figure 14). 


Note: The example shows an RSS feed in the Darby 
University Campus Guide mobile application 
(Figure 14). This application has a dark background. 


ActionScript controls the text formatting. If your text 
does not display well against the background colors in 
your application, edit the hexadecimal color values in the 
ActionScript code.


To change the appearance of the TextArea, List, and 
Button components, double-click a component and edit 
its elements in the component’s timeline.


Figure 14  Preview window
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		import fl.controls.List;
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		import flash.net.URLRequest;

		//NEWSLIST FORMATTING

		var newsListTf:TextFormat = new TextFormat();

		newsListTf.font = "Verdana";

		newsListTf.color = 0xFFFFFF;

		newsListTf.size = 18;

		newsListTf.align = "left";

		newsList.setRendererStyle("textFormat", newsListTf);
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		newsList.allowMultipleSelection = false;
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		//NEWSDISPLAY TEXT AREA FORMATTING

		var rssStoryTf:TextFormat = new TextFormat();

		rssStoryTf.font = "Verdana";

		rssStoryTf.color = 0x6699CC;

		rssStoryTf.size = 22;

		rssStoryTf.align = "left";

		rssStory.setStyle("textFormat", rssStoryTf);

		//READMORE BUTTON FORMATTING

		var buttonTf:TextFormat = new TextFormat();

		buttonTf.font = "Verdana";

		buttonTf.color = 0xFFFFFF;

		buttonTf.size = 22;

		btn_ReadMore.setStyle("textFormat", buttonTf);

		//RSS FEED

		var rssLoader:URLLoader = new URLLoader();

		var rssURL:URLRequest = new URLRequest ("http://rssfeeds.tv.adobe.com/adobe-higher-education-solutions.xml");

		rssLoader.addEventListener(Event.COMPLETE, rssLoaded);

		newsList.addEventListener(Event.CHANGE, selectRssStory);

		btn_ReadMore.addEventListener(MouseEvent.CLICK, goToURL);

		rssLoader.load(rssURL);

		var newsXML:XML = new XML();

		var currentStoryURL:URLRequest = new URLRequest();

		newsXML.ignoreWhitespace = true;

		function rssLoaded(evt:Event):void

		{

		newsXML = new XML(rssLoader.data);

		//trace(newsXML);

		for(var item:String in newsXML.channel.item) {

		//newsList.addItem({label: newsXML.channel.item[item].pubDate.substr(0, 16) //+": " + newsXML.channel.item[item].title } );

		newsList.addItem({label: newsXML.channel.item[item].title.substr(0, 40) +" ..." } );

		}

		newsList.selectedIndex = 0;

		//FIRST LOAD

		currentStoryURL = new URLRequest(newsXML.channel.item[0].link);

		rssStory.htmlText = newsXML.channel.item[0].description;

		}

		function selectRssStory(evt:Event):void

		{

		rssStory.htmlText = newsXML.channel.item[evt.target.selectedIndex ].description;

		currentStoryURL = new URLRequest(newsXML.channel.item[evt.target.selectedIndex ].link);

		}

		function goToURL(event:MouseEvent):void

		{

		navigateToURL(currentStoryURL);
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How to set up a mobile application
You can use Adobe Flash Professional CS6 to build Adobe AIR applications that run on either Android or iOS mobile 
devices. When you create a new document for Android or iOS, Flash chooses default settings based on common 
device screens, but you can change these in the New Document dialog box or in the Properties panel. 


Creating a new mobile application file in Flash
To create a mobile application in Flash, the first step is to open a new document and tell Flash which type of 
application you’re creating. 


To create a new mobile application file:


1. Create a new project folder on your hard drive. You can 
name it anything you want, such as My Mobile App.


2. Start Flash and select File > New.


The New Document dialog box appears (Figure 1). 


3. Make sure the General tab is selected.


You can create AIR applications for Android or iOS 
devices. The steps are the same. 


4. Select AIR For IOS in the Type list.


Notice the default document dimensions for iOS 
documents are 640 pixels wide by 960 pixels high 
(Figure 2).


5. Select AIR For Android in the Type list.


The default document dimensions for Android 
documents are 480 pixels wide by 800 pixels high. For 
this example, you set up a document for an Android 
device.


Note: You can adjust or reverse the width and height 
settings as needed, depending on your target device and 
the preferred orientation of your application.


6. Click the Background Color box and use the color picker 
to select a background color such as black for the new 
document (Figure 3).


7. Click OK.


The new document appears in the Flash workspace. Next 
you edit the AIR for Android application settings and 
create a digital certificate for publishing and sharing the 
application. 


8. Save the file in the folder you created for this project. 


Note: You can name it anything you want, but if you plan 
to make both Android and iOS versions of an application, 
it’s good to designate which file is which.


Figure 1 New Document dialog box 


Figure 2 New Document dialog box, AIR for iOS 
default settings 


Figure 3 New Document dialog box, AIR for 
Android settings 
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Editing application settings and creating a digital certificate
To publish an AIR for iOS or AIR for Android application, you must first specify the application settings and 
designate a digital security certificate. A digital certificate is an electronic file that works like an online password to 
verify the identity of a user or a computer or, in this case, the publisher of the application. When users install your 
application, they’re trusting you, as the developer, not to create an application that behaves maliciously. Because of 
the limitations of self-signed certificates, Adobe strongly recommends using a commercial certificate issued by a 
reputable certification authority for signing publicly released AIR applications. But for the purpose of demonstration, 
you create a new self-signed certificate for this application.


To edit application settings:


1. Open the Properties panel (Window > Properties) if it’s 
not already open.


In the Publish section of the Properties panel, the Publish 
Target is set to AIR 3.2 For Android (Figure 4). If you 
had opened a new AIR for iOS document, the Target 
would be set to AIR3.2 For IOS instead.


2. Click the Edit Application Settings button (Figure 4).


The AIR For Android Settings dialog box appears, with 
the General tab selected (Figure 5).


Notice that .apk is the filename extension of the default 
output file. This is an Android Package File (APK), 
indicating you are indeed creating an Android mobile 
application.


Note: When creating an AIR for iOS application, .ipa is 
the filename extension. IPA is the file type associated 
with iPhone, iPad, and iPod Touch. If you are creating an 
IPA file, the General tab of the AIR For IOS Settings 
dialog box also includes a Device option to generate a 
file made to run on the iPad, iPhone, or both.


3. Enter a name for the output file in the Output File box. 


Note: By default, the output file is created in the same 
folder as the FLA document.


4. Select the contents of the App Name box and enter a 
descriptive name for the application, such as Campus 
Guide.


The default version number is 1.0.0, which is fine 
because this is a new application that’s never been 
published.


You can set the Aspect ratio to Portrait, Landscape, or 
Auto. 


You can also set the application to display full-screen or 
to rotate automatically when the device is turned. 


Next, you select icons to represent the application.


Figure 4 Properties panel, Publish section 


Figure 5 AIR For Android Settings dialog box, 
General tab 


Edit Application Settings button
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5. Click the Icons tab.


This is where you link to your application icons. The icon 
is shown after you install the application and run it in the 
AIR for Android (or AIR for iOS) runtime. You can 
specify three sizes for the icon (72, 48, and 36 pixels) to 
allow for the different views in which the icon appears 
(Figure 6). 


Note: You can use Adobe Fireworks CS6, Adobe 
Illustrator CS6, or another graphics application to create 
your icon graphic files.  


6. Select Icon 36 x 36 and click the Browse For File button 
(Figure 6).


7. In the Open dialog box (Figure 7), browse to locate your 
icon graphic files, select the 36 x 36 pixel file you want to 
use for the icon, and click Open.


A preview of the icon appears in the dialog box 
(Figure 8).


8. If you’ve created icons in all three sizes, repeat Steps 6 
and 7 to select graphics for the other two file sizes. 


Note: If you do not supply an image for a particular icon 
size, AIR scales one of the supplied images to create the 
missing icon image.


Figure 6 AIR For Android Settings dialog box, 
Icons tab 


Figure 7 Open dialog box, selecting icon files 


Figure 8 AIR For Android Settings dialog box, 
Icon preview 


Browse For File button
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9. Click the Permissions tab.


Use the Permissions tab to set permissions for the 
services the application will access (Figure 9).


For example, if the application relies on RSS feeds or 
other Internet services, you’ll need to select the Internet 
option.   


10. Select all permissions required by the application, as 
specified in your project plan or design document.


Our sample application uses RSS feeds to display current 
news stories and will access Google maps to display 
current maps and directions. Click the name of any 
option to see its description.


11. Click the Languages tab and select all languages that are 
supported in the application (Figure 10).


Next, you create a self-signed certificate. You can use a 
self-signed certificate to produce a valid AIR installation 
file.  


Note: If you create an update for an AIR application that 
was signed with a self-signed certificate, you must use 
the same certificate to sign both the original and updated 
AIR files.


Figure 9 AIR For Android Settings dialog box, 
Permissions tab 


Figure 10 AIR For Android Settings dialog box, 
Languages tab 
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To create a digital certificate:


1. Click the Deployment tab and click Create (Figure 11).


The Create Self-Signed Digital Certificate dialog box 
appears (Figure 12). (In Mac OS, this dialog box does 
not have a title.)


2. Use the form to enter a publisher name, organization unit, 
and organization.


For publisher, you can use your name or the name of your 
school or business. For the organization, use the name of 
your school or business. For organization unit, you can 
enter a specific unit or department.


3. Select your country from the Country pop-up menu.


4. Click in the Password text box and enter a password that 
you’ll remember.


5. Click in the Confirm Password text box and re-enter the 
password to confirm the accuracy of your typing.


6. For the type of certificate, choose or confirm 1024-RSA.


This represents the type of encryption to use for the 
security key.


7. Click in the Save As text box and enter a name for the 
certificate. 


For this example, we used certificate as the name.


8. Click the Browse button (Windows) or the folder icon 
(Mac OS). Navigate to your project folder and click Save 
to ensure the certificate is saved in the same folder as 
your other project files.


9. Click OK to generate the certificate.


A confirmation message appears when the certificate is 
ready (Figure 13).


10. Click OK to close the confirmation message.


Figure 11 AIR For Android Settings dialog box, 
Deployment tab 


Figure 12 Create Self-Signed Digital Certificate 
dialog box 


Figure 13 Confirmation message 
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11. In the AIR For Android Settings (or AIR For IOS 
Settings) dialog box, enter the password you created for 
the certificate, and select Remember Password For This 
Session (Figure 14).


You can specify if this version of the application is for 
deploying, for testing with an emulator, or for debugging.


You have the option of embedding the AIR runtime with 
the application or directing users where to locate and 
download AIR on their device. 


If you are creating an Android application, the default 
setting is to get the AIR runtime from the Google 
Android Market.


12. Click OK to confirm your application settings.


Note: The AIR For IOS Settings are slightly different 
from the AIR For Android settings (Figure 15).


When publishing iOS applications, you indicate a  
provisioning profile document.


To install and test an iOS application on a device and to 
distribute that application, you must join the Apple iOS 
Developer program (a fee-based service). Once you join 
the iOS Developer program, you can access the iOS 
Provisioning Portal where you can obtain the following 
items and files you need from Apple to install an 
application on a device for testing and for subsequent 
distribution. These items and files include:


• Development and distribution certificates


• App IDs


• Development and distribution provisioning files


You can also indicate the type of iOS deployment: Quick 
Publishing For Device Testing, Quick Publishing For 
Device Debugging, Deployment - Ad Hoc, or 
Deployment - Apple App Store. 


Figure 14 AIR For Android Settings dialog box 


Figure 15 AIR For IOS Settings dialog box 
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How to use the Adobe Dreamweaver Widget Browser
A web widget is a web page component containing HTML, CSS, and JavaScript. Accordions, tabbed panels, and 
calendars are examples of web widgets.


You can make your own selection of the web widgets available in Dreamweaver by using the Adobe Widget Browser 
(Figure 1). The Widget Browser is an AIR application that lets you browse, configure, and preview widgets, using a 
visual interface.


Figure 1 Adobe Widget Browser


You can browse widgets on the Adobe Exchange by using the Adobe Widget Browser, but if you want to preview 
widgets, see details, or save widgets, you’ll need to create or sign in with an Adobe ID and password. When you open 
the Widget Browser, the application window displays the Adobe Exchange view by default. This view displays all of 
the widgets available on the Adobe Exchange—those created by Adobe as well as by third-party developers.


Once you’ve saved a web widget, you can easily insert it into a web page. 


To use the Widget Browser:


1. Start Dreamweaver.


2. Select File > New to create a new document.


The New Document dialog box appears (Figure 2).


Note: You can also open an existing document to which 
you want to add a web widget.


3. Click the Blank Page category link if it’s not already 
open, and select HTML from the Page Type column and 
<none> from the Layout column.


4. Click the Create button.


5. Save the new document (File > Save).


The Save As dialog box appears.
Figure 2 New Document dialog box

© 2012 Adobe Systems Incorporated How to use the Adobe Dreamweaver Widget Browser 1







Project 1 guide Adobe Dreamweaver CS6


2


6. Navigate to your Dreamweaver site folder, name the file, 
and click Save.


7. Select Widget Browser from the Extend Dreamweaver 
menu in the Application bar (Figure 3).


The Adobe Widget Browser appears (Figure 1).


Note: You may be presented with an End User License 
Agreement if this is the first launch of the Widget 
Browser. Review the EULA, and click Accept to close it. 


8. Click the Sign In button in the upper-right corner of the 
Widget Browser window.


9. Enter your Adobe ID and password, and click Sign In.


If you don’t have an Adobe ID, click the Create Account 
button and follow the onscreen instructions to create a 
(free) Adobe account.


10. In Adobe Exchange view, review the available widgets. 
You can sort widgets by name, date created, and so on.


11. Type Spry in the Filter text box (Figure 4) and press 
Enter (Windows) or Return (Mac OS).


Six options become available. 


12. Click the Spry Image Slideshow With Filmstrip widget 
(Figure 5).


When you click the widget, the Widget Browser displays 
the Details view for the widget. The Details view 
provides more information about the widget, such as 
author, date created, and a brief summary of how the 
widget works (Figure 6).


Figure 3 Extend Dreamweaver menu


Figure 4 Adobe Widget Browser detail


Figure 5 Spry Image Slideshow With Filmstrip 
widget


Figure 6 Spry Image Slideshow With Filmstrip, Details view


Filter text box
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13. To preview the widget as it would appear in a browser, 
either click it in the Details view or click the Preview 
button at the upper-right corner of the Widget Browser.


In Preview view, you can interact with the widget as you 
would in a browser. You can also select a preset to change 
the look of the widget, or see the widget’s code by 
clicking the Code tab.


14. In either the Detail or Preview view, click the Add To My 
Widgets button in the lower-right corner of the Widget 
Browser window.


15. Review the Widget License and click Accept to close. 


The Widget Added dialog box appears and informs you 
that the selected widget has been added to My Widgets.


16. Click the Go To My Widgets button.


17. Close the Adobe Widget Browser.


To insert a web widget into a Dreamweaver document:


1. In Dreamweaver, click on the page in Design view where 
you want to insert a web widget.


2. Select Insert > Widget. 


The Widget dialog box appears (Figure 7).


3. Select the Spry Image Slideshow With Filmstrip (1.0), if 
not already selected.


Note: Only the widgets you saved in the Adobe Widget 
Browser are listed in the Widget menu. You can also 
open the Widget Browser by using the link in the dialog 
box.


4. Select the Blue option from the Preset menu.


5. Click OK.


The Spry Image Slideshow With Filmstrip is inserted into 
the document (Figure 8).


Figure 7 Widget dialog box


Figure 8 Slideshow in Design view


Widget Browser link Widget menu Preset menu
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6. In the Document toolbar, click the Live button 
(Figure 9).


Viewing the Spry Image Slideshow in Live view allows 
you to preview and test the widget as it would appear in a 
web browser (Figure 10).


7. Save the file.


The Spry Image Slideshow With Filmstrip comes with a 
selection of preset images and text. You can customize 
the Spry Image Slideshow With Filmstrip widget by 
changing text, colors, and fonts and adding your own 
images.


Figure 9 Document window view options


Figure 10 Slideshow in Live view

How to use the Adobe Dreamweaver Widget Browser © 2012 Adobe Systems Incorporated





		How to use the Adobe Dreamweaver Widget Browser










Adobe Fireworks CS6 Project 2 guide

Overview of Adobe Fireworks CS6 workspace
In this guide, you’ll learn how to do the following:


• Work with the Adobe Fireworks CS6 workspace: tools, Document windows, menus, and panels.


• Customize the workspace.


• Change the magnification of a document.


• Navigate through a document by using tools and panels.


Exploring the workspace
When you start Adobe Fireworks for the first time and open a document, the workspace includes the Application bar, 
Tools panel, Properties panel, menus, and other panels (Figure 1). The Document window appears in the center of the 
workspace. The Tools panel, on the left side of the workspace, contains labeled categories, including Bitmap, Vector, 
and Web tool groups. The Properties panel appears below the Document window and initially displays document 
properties. It updates as you work on a document. When you select a tool, the Properties panel displays properties and 
options for that tool; when you select an object in the document, it displays properties and options for that object. 
Other panels are initially docked in groups along the right side of the workspace.


Figure 1 Adobe Fireworks CS6 workspace


You create and manipulate documents and files in Fireworks by using various elements of the workspace, such as 
panels, bars, and windows. Any arrangement of these elements is called a workspace. The workspaces of applications 
in the Adobe Creative Suite 6 family share the same appearance so you can move between the applications easily. 
You can also adapt each application to the way you work by selecting from a variety of preset workspaces or by 
creating arrangements of your own.


• Application bar across the top contains a workspace switcher, menus (Windows only), and other application 
controls. On the Mac for certain products, you can show or hide it by selecting Window > Application Bar.


Application 
bar


Document 
window


Tools panel


Properties 
panel


Workspace 
switcher


Panels
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• Document window displays the file you’re working on. Document windows can be tabbed and, in certain 
cases, grouped and docked.


• Tools panel contains tools for creating and editing images, artwork, page elements, and so on. Related tools 
are grouped.


• Properties panel displays options and properties of the currently selected element.


• Panels help you monitor and modify your work. Examples include the Layers, Align, and Document Library 
panels. Panels can be grouped, stacked, or docked.


Customizing the workspace
You can create a custom workspace by moving and manipulating Document windows and panels. You can also save 
workspaces and switch among them. 


To create a custom workspace:


1. Move and manipulate the workspace layout in Fireworks 
to suit your needs (Figure 2).


2. From the workspace switcher, select Save Current 
(Figure 3).


The New Workspace dialog box appears (Figure 4).


3. Type a name for the workspace.


4. Click OK to close the New Workspace dialog box.


Figure 2 Custom workspace layout


Figure 3 Workspace switcher


Figure 4 New Workspace dialog box
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5. Click the Workspace switcher.


Notice that your new workspace appears in the 
Workspace Layouts menu.


Even if you make changes, you can return to the 
workspace you saved by selecting it from the menu or 
from the workspace switcher (Figure 5).


Figure 5 Selecting a saved workspace from the 
workspace switcher


Opening a file in Fireworks
In general, you open document and image files the same way you do in other programs. New documents in Fireworks 
are saved as Portable Network Graphic (PNG) documents. PNG is the native file format for Fireworks.


Graphics created in Fireworks can be exported to or saved in several web and graphic formats. Regardless of the 
optimization and export settings you select, the original Fireworks PNG file is preserved to allow easy editing later. 


To create a new document:


1. Select File > New. 


The New Document dialog box appears (Figure 6).


2. Change any of the preset values as desired:


• Modify the document size.


• Change the document resolution.


• Set a canvas color:


White sets the canvas background to white.


Transparent creates an invisible background. 


Custom use the color picker to set a custom 
background color.


3. Click OK. 


Figure 6 New Document dialog box
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Tools panel overview
The Tools panel is organized into six categories: Select, Bitmap, Vector, Web, Colors, and View (Figure 7). When 
you select a tool, the Properties panel displays options and settings for that tool. You can undock the Tools panel to fit 
your preferred window and panel layout.


Click a tool in the Tools panel to select it. The Tools panel also contains several hidden tools related to the visible 
tools. Hidden tools are indicated by a triangle to the right of a tool icon. Click the tool icon and hold down the mouse 
button to reveal a menu of the hidden tools.


The name of the tool and its keyboard shortcut appear when you hover the pointer over the tool—this text is called a 
tooltip. 


Figure 7 Tools panel
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How to use the Zoom tool to navigate your document
You can use the Zoom tool to change the magnification level in your document.


To change the magnification of your document:


1. Open a document and examine the zoom level at the 
bottom of the Document window (Figure 8).


This represents the current enlargement view of the 
image, or zoom level.


2. Select the Zoom tool by clicking the Zoom tool icon in 
the Tools panel (Figure 9) or by pressing Z, the keyboard 
shortcut for the Zoom tool.


3. Click anywhere in the Document window.


The image zooms in according to a preset percentage 
level. The location you clicked is the center of the 
enlarged view.


4. Using the Zoom tool, drag a rectangle to enclose a region 
of the document (Figure 10).


The selection enlarges to fill the entire Document 
window.


5. To zoom out, hold down the Alt key (Windows) or the 
Option key (Mac OS) as you click (Figure 11).


Figure 8 Zoom level


Figure 9 Tools panel


Figure 10 Selecting a rectangular region


Figure 11 Zooming out in a document


Zoom tool

© 2012 Adobe Systems Incorporated Overview of Adobe Fireworks CS6 workspace 5







Project 2 guide Adobe Fireworks CS6


6


How to move around a document with the Hand tool
The Hand tool moves a document within the Document window. This is useful if you want to see a part of the 
document that is currently out of view.


To use the Hand tool:


1. Zoom into an area of your document until some of the 
content is out of view (Figure 12).


Scroll bars appear when part of the document is not 
visible in the Document window.


2. Select the Hand tool from the Tools panel (Figure 13). 


3. Using the Hand tool, drag to move around and view 
different parts of the document (Figure 14).


Figure 12 Document window with scroll bars


Figure 13 Tools panel


Figure 14 Using the Hand tool to move a 
document around


Hand tool

Overview of Adobe Fireworks CS6 workspace © 2012 Adobe Systems Incorporated







Adobe Fireworks CS6 Project 2 guide

Using the Properties panel
The Properties panel is context-sensitive. It displays properties and options of the object, the tool, or the document 
that is currently selected. By default, the Properties panel is docked at the bottom of the workspace.


The Properties panel can be open at half height, displaying two rows of properties, or at full height, displaying four 
rows. You can also fully collapse the Properties panel while leaving it in the workspace. Either double-click the panel 
tab or click the arrow in the upper-left corner of the panel to cycle through these three states.


To use the Selection tool and Properties panel:


1. With a document open, choose the Selection tool from 
the Tools panel and then select an object in your 
document.


Notice that the Properties panel information includes 
such things as the image type, size, and position of that 
object (Figure 15).


2. Next, choose the Type tool (and select a region of text, if 
available).


The Properties panel changes to show options that 
provide control over text formatting (Figure 16).


Figure 15 Properties panel, bitmap mode


Figure 16 Properties panel, text mode


Working with layers
Layers divide a Fireworks document into discrete planes, as though the components of the illustration were drawn on 
separate tracing paper overlays. Each object in a document resides on a layer (Figure 17). You can either create 
layers before you draw or add layers as needed. The canvas is below all layers and is not itself a layer.


Figure 17 Model of layers in Fireworks
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The Layers panel displays the current state of all layers in the page of a document (Figure 18). The  active layer is 
highlighted. The stacking order is the order in which objects appear in the document and determines how objects on 
one layer overlap objects on another. Fireworks places the most recently created layer on the top of the stack. You can 
rearrange the order of layers and of objects within layers, and you can create sub layers and move objects onto them.


Masks and opacity and blend mode controls are also shown in the Layers panel. 


Figure 18 Layers panel


Expand/Collapse Layer


Active Layer


Lock/Unlock Layer


Show/Hide Layer


New/Duplicate Layer New Sub Layer New Bitmap Image


Delete Layer
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How to create a design comp
A comprehensive artwork (comp for short) is a design proposal presented by the designer to the client for approval. 
Web design comps provide a rough visual draft of the overall user interface (including graphics, interface design 
elements, navigation system, and main content areas) before specific content is placed (Figure 1).


Fireworks provides an ideal prototyping environment, seamlessly converting design comps into real-world widgets, 
websites, and applications.


Figure 1 Design comp 


The web design process
The typical web design process may be comprised of several stages, including any of the following:


1. Brief provides a statement of technical, design, and idea goals for the web project.


2. Research involves a range of investigative activities including a review of related web designs, analysis of 
competitor sites, user flows, personas, market analysis, use cases, and more.


3. Brainstorming is a conceptualizing stage based on the brief and research stages in which many ideas are 
generated in a short amount of time. 


4. Creative solution follows the brainstorming phase in which briefs, research, and ideas are combined to 
create a clear design direction. This stage can include technical specifications, information architecture 
diagrams, functioning wireframes, and design comps. This stage is often iterative, a repeating process in 
which problems are solved, designs are presented to clients for feedback, website functionality is developed 
and tested, and revisions are made.


5. Production fully realizes the web project. Design comps are finalized and integrated into the wireframe 
prototype, and the web project is scaled up to full production. 


As you can see, the design comp is an important piece of the web design process from the creative solution right to 
the production stage. 


Consider the following questions as you plan and build your design comp for a web project.
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Organizing content


How you organize content on a page highlights important features and elements of your web project. Important 
elements might be higher in the page, larger in size, or in stronger colors. Include rough descriptions of navigation, 
copy layout, graphic allocation, key headers, and other elements that appear on a screen. Identifying common 
structures between pages helps visitors understand they are in the same site as they navigate from page to page.


• Will your page banner be on each page? If yes, is it in the same place? Is it the same size?


• What font will you use for titles or headings on your content pages?


• What color will you use for titles or headings on your content pages?


• What font will you use for descriptions on your content pages?


• What color will you use for descriptions?


Navigation


For visitors of your website or application to understand the content, you must provide clear navigation. Visitors need 
to know where they are in a site, where they need to go, and how to get back to where they came from. Having a 
consistent layout grid helps orient visitors and keeps them from feeling lost. Using consistent buttons, links, and 
graphics on each page maintains a sense of place. As visitors move from page to page, provide familiar visual cues 
and navigational aids.


Here are some questions to answer:


• Where will you place the navigation bar on the page?


• What content will be on the navigation bar?


• Will the navigation bar be on every page?


• How will your navigation bar help visitors know which page they are on?


Creating a design comp with Adobe Fireworks CS6 
The following steps describe a typical proces to follow when using Fireworks to create a design comp. The design 
comp process described here uses previously-prepared files including a background image, logo, text, and a 
photographic image.


To create the canvas and import files:


1. Start Fireworks and create a new document using the 
dimensions for your web project. 


2. With Layer 1 selected, choose File > Import.


The Import dialog box (Windows) or Import File dialog 
box (Mac OS) opens.


3. Navigate to a background image you want to use, and 
click Import (Windows) or Open (Mac OS).


4. Click in the upper-left corner of the canvas to place the 
imported background at that location. 


The background image is placed on the canvas.
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5. In the Properties panel, confirm that the X and Y 
coordinates are both set to 0 (Figure 2).


6. Choose File > Import.


The Import dialog box (Windows) or Import File dialog 
box (Mac OS) opens.


7. Navigate to a logo file and click Import (Windows) or 
Open (Mac OS).


The Import Page dialog box opens (Figure 3).  


A single Fireworks PNG file can contain multiple pages. 
When you insert a PNG file, or page, containing objects 
from the master layer, the master page is converted to an 
ordinary layer, and imported. 


8. Click the Import button (Windows) or Open button (Mac 
OS) in the Import Page dialog box.


9. On the canvas, click near the top edge and to the right of 
the upper-left corner to place the imported logo at that 
location.


The logo image is placed on the canvas. 


10. Choose File > Import.


The Import dialog box (Windows) or Import File dialog 
box (Mac OS) opens.


11. Navigate to a photograph file and click Import 
(Windows) or Open (Mac OS).


12. On the canvas, click in the main content area to place the 
imported logo at that location.


The photograph is placed on the canvas. 


13. Select File > Save As and save the file as a PNG.


Figure 2 Properties panel, bitmap mode


Figure 3 Import Page dialog box


To use drawing tools, fills, and the alignment panel:


1. From the Tools panel, select the Rectangle tool.


2. In the Properties panel, click the Gradient Fill button.


The Edit Gradient pop-up window opens (Figure 4). 


3. Set the gradient type to Linear, if not already selected.


Figure 4 Properties panel, Edit Gradient window


X and Y 


Gradient Fill Color swatches


Gradient type


Solid Fill
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4. Click the color swatch on the left and select a dark-gray 
color such as HEX value #222222 (Figure 5) .


5. Click the color swatch on the right and select a slightly 
lighter gray color such as HEX value #333333.


6. Click the Gradient Fill button again to close the Edit 
Gradient window.


7. Drag to draw a rectangle shape at the bottom of the 
canvas.


This rectangle will become the web page footer.


8. Choose Select > Deselect.


9. From the Tools panel, select the Rounded Rectangle tool.


10. In the Properties panel, click the Solid Fill button and 
choose a light-gray color such as HEX value #CCCCCC.


Note: You could choose instead to add a gradient fill to 
the rounded rectangle shape.


11. Click the Solid Fill button again to close the color pop-up 
window.


12. In the Properties panel, set Stroke Color to white (HEX 
value #FFFFFF), and confirm Tip Size is 1, and Stroke 
Category is 1-Pixel Soft (Figure 6).


13. Make sure Smart Guides are visible and active. If not, 
select View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.


14. Drag on the canvas to draw a rounded rectangle suitable 
for use as a button.


15. Select the rounded rectangle shape.


16. Select Edit > Duplicate three times to create a total of 
four buttons.


As you repeat the command, duplicates of the selected 
object appear in a cascading arrangement from the 
original. Duplicates appear 10 pixels lower and 10 pixels 
to the right of the previous duplicate. The most recently 
duplicated object becomes the selected object.


17. Select the Pointer tool and drag a rounded rectangle over 
to the right until the Smart Guides appear along the top, 
and right edge of the object (Figure 7).


18. Arrange the remaining shapes in a row between the first 
and the last rounded rectangle. 


Don’t worry about the spacing, you’ll take care of that in 
the next few steps.


19. Choose Window > Align to open the Align panel 
(Figure 9).


20. Shift-click the four rounded rectangle shapes, either on 
the canvas, or in the Layers panel.


Figure 5 Color pop-up window


Figure 6 Properties panel, shape mode


Figure 7 Aligning objects using Smart Guides


Figure 8 The Align panel
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21. In the Align panel, click the Align Vertical Center button 
and the Space Evenly Horizontally button.


The rounded rectangle shapes are vertically aligned and 
spaced evenly on the canvas.


22. Select File > Save.


To use text tools:


1. Select the Text tool from the Tools panel.


Text in a Fireworks document appears inside a text block 
(a rectangle with handles).


2. Set text characteristics in the Properties panel (Figure 9):


• Font Family: Georgia


• Font Style: Regular


• Font Size: 46


• Font Color: HEX value #ECECEC


3. Click on the canvas just below the logo to create an auto-
sizing text block.


An auto-sizing text block expands horizontally as you 
type and shrinks when you remove text. Auto-sizing text 
blocks are created by default when you click on the 
canvas with the Text tool and start typing.


4. Type Shop. 


5. Choose Select > Deselect.


6. With the Text tool still selected, change Font Family to 
Verdana, and Text Size to 16 and confirm the text is left 
aligned.


7. Drag on the canvas between the Shop title and the 
photograph to create a fixed-width text block 
(Figure 10).


A fixed-width text block allows you to control the width 
of wrapped text. Fixed-width text blocks are created by 
default when you drag to draw a text block using the Text 
tool. 


8. Add placeholder text to simulate two or three paragraphs 
of text.


9. To move the text block, drag it with the Pointer tool. To 
resize it, drag a resize handle.


10. Choose Select > Deselect.


11. Select the Text tool, and change Font Family to Georgia, 
Text Size to 21, and Text Color to dark gray (HEX value 
#222222).


Figure 9 Properties panel, text mode


Figure 10 Drag with Text tool to create a fixed-
width text block


Font Family


Font Style


Font Color


Alignment


Font Size
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12. Click on the first rounded rectangle to create an auto-
sizing text block.


13. Type Shop.


14. Select the Pointer tool and drag the text block until the 
horizontal and vertical Smart Guides appear so that the 
text is centered over the rounded rectangle (Figure 11).


15. Shift-click the text block and the rounded rectangle and 
choose Modify > Group.


16. Repeat steps 12 to 15 to create three more navigation 
buttons for Designer, Our Shop, and Blog.


17. Create a text block at the bottom of the page, over the 
dark-gray footer rectangle and add some footer text.


18. Select File > Save.


Figure 11 Use Smart Guides to align text and 
objects

How to create a design comp © 2012 Adobe Systems Incorporated





		How to create a design comp

		A comprehensive artwork (comp for short) is a design proposal presented by the designer to the client for approval. Web design comps provide a rough visual draft of the overall user interface (including graphics, interface design elements, navigation...

		Fireworks provides an ideal prototyping environment, seamlessly converting design comps into real-world widgets, websites, and applications.

		Fireworks provides an ideal prototyping environment, seamlessly converting design comps into real-world widgets, websites, and applications.

		Figure 1 Design comp

		The web design process

		The typical web design process may be comprised of several stages, including any of the following:

		As you can see, the design comp is an important piece of the web design process from the creative solution right to the production stage.

		Consider the following questions as you plan and build your design comp for a web project.

		Organizing content

		How you organize content on a page highlights important features and elements of your web project. Important elements might be higher in the page, larger in size, or in stronger colors. Include rough descriptions of navigation, copy layout, graphic a...

		• Will your page banner be on each page? If yes, is it in the same place? Is it the same size?

		• What font will you use for titles or headings on your content pages?

		• What color will you use for titles or headings on your content pages?

		• What font will you use for descriptions on your content pages?

		• What color will you use for descriptions?





		Navigation

		For visitors of your website or application to understand the content, you must provide clear navigation. Visitors need to know where they are in a site, where they need to go, and how to get back to where they came from. Having a consistent layout g...

		Here are some questions to answer:

		• Where will you place the navigation bar on the page?

		• What content will be on the navigation bar?

		• Will the navigation bar be on every page?

		• How will your navigation bar help visitors know which page they are on?







		Creating a design comp with Adobe Fireworks CS6

		The following steps describe a typical proces to follow when using Fireworks to create a design comp. The design comp process described here uses previously-prepared files including a background image, logo, text, and a photographic image.

		To create the canvas and import files:

		Figure 2 Properties panel, bitmap mode

		Figure 3 Import Page dialog box



		To use drawing tools, fills, and the alignment panel:

		Figure 4 Properties panel, Edit Gradient window

		Figure 5 Color pop-up window

		Figure 6 Properties panel, shape mode

		Figure 7 Aligning objects using Smart Guides

		Figure 8 The Align panel



		To use text tools:

		Figure 9 Properties panel, text mode

		Figure 10 Drag with Text tool to create a fixed- width text block

		Figure 11 Use Smart Guides to align text and objects
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How to preview and test a web project
Because you can't control which browsers or operating systems visitors will use to view your site, it is important to 
test your site in different browsers. Although you can do some of this on your computer by installing several browsers 
and running a local testing server, it can be a challenge to review all possible combinations of browsers and operating 
systems. For a detailed overview about the purposes of a testing server, see the Dreamweaver Developer Center 
article written by David Powers, Setting up a local testing server in Dreamweaver CS5 at www.adobe.com/devnet/
dreamweaver/articles/setup_testing_server.html.


Adobe BrowserLab is an online service that lets you test your website pages in a variety of web browsers and 
operating systems. For example, the following combinations of browsers and operating systems can produce slight 
differences in how your site appears:


• Google Chrome 3.0 - Windows XP


• Microsoft Internet Explorer 8.0 - Windows XP


• Apple Safari 4.0 - Mac OS X


• Mozilla Firefox 3.0 - Mac OS X


The service works by taking screenshots of your web pages in different browsers and then displaying them on the 
BrowserLab page (Figure 1).


Figure 1 Adobe BrowserLab 


BrowserLab is integrated with Dreamweaver CS6. You can test your pages from within Dreamweaver without 
publishing your pages to a server.


View menuBrowser menus Refresh The Screen button
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Using BrowserLab in Dreamweaver
BrowserLab lets you preview local web content from within Dreamweaver, without requiring you to post it to a 
publicly-accessible server first. You can preview files from your local Dreamweaver site.


To use BrowserLab within Dreamweaver:


1. Start Dreamweaver.


2. Open a document that you want to preview in 
BrowserLab.


3. Select View > Design.


4. Choose Window > Extensions > Adobe BrowserLab.


The Adobe BrowserLab panel opens.


5. In the Adobe BrowserLab panel, choose Local/Network 
from the pop-up menu (Figure 2).


The Design view and Local/Network options direct 
BrowserLab to preview files using the open local file as 
its source for screen shots.


6. Click the Preview button.


7. When the BrowserLab home page opens, click Start 
Using BrowserLab (Figure 3).


Note: There may be a Go Back To BrowserLab button 
instead of a Start Using BrowserLab button if you have 
used the service before.


8. Enter your e-mail and password and click Sign In 
(Figure 4), or click Learn More to obtain an Adobe ID if 
you don't already have one.


9. Click the Browser pop-up menu and choose the browser/
operating system that you want to test.


10. To compare multiple browser/operating system 
combinations, choose 1-Up, 2-Up, or Onion Skin from 
the View pop-up menu (Figure 1).


Observe that the some content blocks in the illustrated 
web page do not show in the second pane. Make changes 
to your page until you are satisfied with the way it 
appears in both panes.


11. Make changes to the page, or to the CSS attached to the 
page.


12. Click the Refresh The Screenshots button in the 
BrowserLab application window.


BrowserLab previews your page without your having to 
save the local changes first.


Figure 2 BrowserLab panel


Figure 3 Start Using BrowserLab button


Figure 4 BrowserLab Sign In page
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Understanding Flash graphic file types
Before you start working in Adobe Flash Professional CS6, be sure you understand the file types associated with the 
application. You use several file types to create and manage Flash content. You can import a variety of media objects 
into a Flash document to use as the artwork and sound for Flash movies. Also, you can export several types of files 
from Flash to share a finished movie or to use in developing other applications, such as mobile apps and games. 


Adobe Flash Professional file types
In Adobe Flash Professional CS6, you can work with a variety of file types, each of which has a distinct purpose:


• FLA files are the primary files you work with in Adobe Flash Professional CS6. They contain the media, 
timeline, and script information for a Flash document. Media objects are the graphic, text, sound, and video 
objects that comprise the content of your Flash document. You use the timeline to tell Flash when specific 
media objects should appear on the Stage. You can add ActionScript code to FLA documents to control the 
behavior of media objects and to determine how media objects interact with viewers.


• Uncompressed XFL files are similar to FLA files. An XFL file and any associated files inside the same 
folder are the uncompressed equivalent of a FLA file. Using uncompressed XFL files, individuals can work 
on different elements of the same Flash project.


• SWF files, the compiled versions of FLA files, are the files you display on a web page. When you publish 
your FLA file, Flash creates a SWF file. The Flash Pro SWF file format is an open standard other 
applications support.


• AS files are ActionScript files—you can use these to keep some or all of your ActionScript code outside of 
your FLA files, which is helpful for code organization and for projects that have individuals working on 
different parts of the Flash content.


• SWC files contain reusable Flash components. Each SWC file contains a compiled movie clip, ActionScript 
code, and any other assets the component requires.


• ASC files store ActionScript that will be executed on a computer running Flash Media Server. These files 
enable the implementation of server-side logic that works in conjunction with ActionScript in a SWF file.


• JSFL files are JavaScript files that add new functionality to Adobe Flash Professional CS6. 


Best practices for adding media objects to a FLA document
Most Flash content includes a wide variety of artwork and sound you import as the building blocks of your finished 
movie. Adobe Flash Professional CS6 can use artwork created in other applications. You can import vector graphics 
and bitmaps in a variety of file formats. 


• Any graphic in a file you import into Flash must be at least 2 pixels by 2 pixels.


• You can use ActionScript code (the loadMovie method) to produce a SWF file that loads an external JPEG 
file at runtime (when someone plays the movie). Storing JPEG files outside the SWF file results in a smaller 
and faster loading movie.


• Flash offers the following options when you import vector graphics, bitmaps, and sequences of images:


◦ When you import Adobe Illustrator and Adobe Photoshop files into Flash, you can specify import 
options that preserve most of your artwork’s visual data and maintain the editability of certain visual 
attributes.


◦ When you import vector images into Flash from Adobe FreeHand, you can select options for preserving 
FreeHand layers, pages, and text blocks.


◦ When you import PNG images from Adobe Fireworks, you can import files as editable objects to 
modify in Flash or as flattened files to edit and update in Fireworks.
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Note: If you import a PNG file from Fireworks by cutting and pasting, the file is converted to a bitmap.


• Keep in mind the following behaviors when you import vector graphics, bitmaps, and sequences of images:


◦ Vector images from SWF and Windows Metafile Format (WMF) files you import directly into a Flash 
document (instead of into a library) import as a group in the current layer.


◦ Bitmaps (scanned photographs, BMP files) you import directly into a Flash document import as single 
objects in the current layer. Flash preserves the transparency settings of bitmaps. Because importing a 
bitmap can increase the file size of a SWF file, consider compressing imported bitmaps.


◦ Bitmap transparency might not be preserved when you import bitmaps by dragging and dropping from 
an application or desktop into the FLA document. To preserve transparency, use the File > Import > 
Import To Stage or File > Import > Import To Library command for importing.


◦ Any sequence of images (for example, a PICT or BMP sequence) you import directly into a Flash 
document imports as successive keyframes in the current layer.


Acceptable file types for use in a Flash document
You can import the following vector or bitmap file formats into Adobe Flash Pro CS6, regardless of whether 
QuickTime 4 is installed:


• Adobe Illustrator files (AI)


• Adobe Photoshop (PSD)


• AutoCad (DXF)


• Bitmap (BMP)


• Enhanced Windows Metafile (EMF)—Windows only


• FutureSplash Player (SPL)


• GIF and animated GIF (GIF)


• JPEG (JPG)


• PNG (PNG)


• Flash Player (SWF)


• Windows Metafile (WMF)


• Adobe XML graphic file (FXG)


You can import the following bitmap file formats into Flash Pro only if QuickTime 4 or later is installed:


• QuickTime Image (QTIF)


• TIFF (TIF)


Flash can import the following audio formats:


• Wave (WAV)


• Audio Interchange File Format (AIFF)


• MP3 (MP3)

Understanding Flash graphic file types © 2012 Adobe Systems Incorporated
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Viewing and working with XFL files
When you save a file in Flash, the default format is FLA, but the internal format of the file is XFL.You can open and 
work with XFL files in Flash the same way you would open a FLA file. When you open an XFL file in Flash, you can 
then save the file as a FLA file or as an uncompressed XFL file.


You can choose to work with your Flash files in uncompressed XFL format. With this format you can see each of the 
separate parts, or sub-files, that make up the Flash file. These parts include:


• An XML file that describes the Flash file as a whole


• Separate XML files to describe each library symbol


• Additional XML files containing publish settings, mobile settings, and others


• Folders containing external assets, such as bitmap files, used by the Flash file


When using the uncompressed XFL format, multiple people can work on different parts of the Flash file. You can also 
use a source control system to manage the changes made to each file within your uncompressed XFL file. Together 
these capabilities allow for much easier collaboration on large projects with multiple designers and developers.


Other Adobe Creative Suite applications such as Adobe After Effects can export files in XFL format. These files have 
the XFL filename extension instead of the FLA extension. Adobe InDesign can export directly in FLA format, which 
internally is XFL. This means you can work on a project in After Effects or InDesign first and then continue working 
with it in Flash. 


Adding XMP metadata to a FLA document
You can include Extensible Metadata Platform (XMP) data such as title, author, description, and copyright in your 
FLA files. XMP is a metadata format certain other Adobe applications can understand. The metadata is viewable in 
Adobe Flash Professional CS6. 


When you embed metadata, web-based search engines can return more meaningful search results for Flash content. 
The search metadata is based on the XMP (Extensible Metadata Platform) specifications and is stored in the FLA file 
in a W3C-compliant format.


A file’s metadata contains information about the contents, copyright status, origin, and history of the file. You view 
and edit the XMP metadata in Adobe Flash Professional CS6 by choosing File > File Info and entering information in 
the Info dialog box.


Depending on the selected file, the following types of metadata may appear:


• Description: Contains author, title, copyright, and other information.


• IPTC: Displays editable metadata. You can add captions to your files, as well as copyright information.


• Camera Data (Exif): Displays information assigned by digital cameras, including the camera settings used 
when the image was taken.


• Video Data: Displays metadata for video files, including pixel aspect ratio, scene, and shot.


• Audio Data: Displays metadata for audio files, including artist, album, track number, and genre.


• Mobile SWF: Lists information about SWF files, including title, author, description, and copyright.


• History: Keeps a log of changes made to images with Photoshop.


Note: The History Log preference must be turned on in Photoshop to save the log with the file’s metadata.


• Version Cue: Lists any Version Cue file-version information.


• DICOM: Displays information about images saved in the Digital Imaging and Communications in Medicine 
(DICOM) format.
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Project 2


Web design and planning
Timing: 12 to 18 hours


Project overview


In this project, student teams work on a project to build a website for a client. Each team might have a 
different client, depending on the availability of resources. The instructor can play the role of the client, a 
hypothetical organization. The client selects the topic of the site and specifies the content to be included. 
Each student team interprets the client’s needs in proposing design solutions for the site’s navigation 
scheme, page layout, look and feel, and content flow. Students write specific design documents to help 
them communicate clearly with the client.


The focus of this project is working on a team and designing for someone else, emphasizing the following: 
the design-team process for website development, team-client interaction for incorporating feedback and 
changes throughout the development of the site, and team-client communication using the design 
document and evaluating websites in preparation for the design. In Project 3: Web development and 
deployment, student teams will build and launch the client website, completing the full website production 
process.


Student product: Web production project plan and design document; website prototype, storyboard, 
wireframes, and design comps


Note: Portions of the Web design and planning project align to the Adobe Certified Associate, Web 
Communication objectives. Within the instruction steps and technical guides, the specific learning 
objectives for the exam are referenced with the following format: 1.1  


Project objectives


At the completion of the project, students will have developed the following skills:


Project management skills


• Developing a project plan


• Developing a design document


• Analyzing to select best examples


• Synthesizing content based on analysis and 
reflection


• Managing and organizing multiple tasks 
involved in design versus production


• Understanding roles and responsibilities


• Meeting deliverables


Design skills


• Communicating ideas and information through 
simple wireframes


• Providing multiple design ideas


• Synthesizing information from design review 
meetings


• Creating wireframes


• Creating design comps


• Creating storyboards


• Creating prototypes


• Applying design principles


• Applying information architecture


• Designing for usability and accessibility


• Designing consistent website pages


• Understanding and applying design aspects 
such as color theory, layout, contrast, and 
composition







2 Web design and planning © 2012 Adobe Systems Incorporated


• Designing for usability and accessibility 


• Designing for a specific audience and purpose


• Planning graphics and rich media content based 
on needs and audience


• Designing for a client while meeting client 
requirements


Research and communication skills


• Evaluating and analyzing content validity


• Editing website content


• Evaluating and analyzing website navigation


• Understanding and practicing legal use of 
images


• Understanding tools for creating animation and 
interactive content


• Critiquing designs


• Communicating purpose and goal


• Communicating and presenting design 
decisions


• Giving feedback on a project


• Asking questions to focus and clarify


• Listening and interpreting feedback


• Understanding and addressing client design 
issues


• Finalizing design with a client


Technical skills


Fireworks


• Understanding the Fireworks workspace


• Creating a wireframe


• Creating design comps


• Creating a prototype


• Exporting a prototype to Dreamweaver


Dreamweaver


• Understanding accessibility


Project materials
• Adobe Fireworks CS6 installed on all machines


• Adobe Dreamweaver CS6 installed on all 
machines


• Guide: How to design for usability


• Presentation: Web design for multiple screens


• Dreamweaver guide: How to make websites 
accessible


• Worksheet: Usability and accessibility 


• Presentation: Web project production phases


• Presentation: Writing for the web


• Worksheet: Client interview


• Worksheet: Design review


• Worksheet: Project plan


• Presentation: Introduction to information 
architecture


• Guide: Tips for information architecture


• Worksheet: Design document


• Guide: Principles and rules of copyright 


• Fireworks guide: Overview of Adobe 
Fireworks CS6 workspace


• Fireworks guide: How to create a wireframe


• Electronic file: GG_Bridge-
rough_comp_1.fw.png


• Electronic file: GG_Bridge-
rough_comp_2.fw.png


• Electronic file: GG_Bridge-
rough_comp_3.fw.png


• Fireworks guide: How to create a design comp


• Presentation: Storyboards


• Worksheet: Production storyboard


• Electronic file: prototype-export.zip


• Fireworks guide: How to create a prototype
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Background preparation resources
• Technical and content information


• Key terms


• ISTE NETS*S Standard for Students


• Adobe Certified Associate, Web Communication objectives


Project steps


1. Introduce students to the goals of the project:


• Analyze websites for purpose, audience, usability, and accessibility


• Define a plan for the web project and work with a client


• Structure the information architecture and create wireframes


• Create design comps, storyboard, and a project prototype


Website analysis
(Suggested time: 50–100 minutes)


2. Remind students of the design principles discussion and website design analysis from Project 1. 
Explain they will now look at websites to determine their purpose, usability, and accessibility. Show 
students a variety of websites and help them identify how each serves a specific purpose and 


functionality.1.1, 1.2, 2.2, 2.3 Discuss the following: 


• What is the purpose of the website?


• What is its functionality?


• Who is the audience?


• Who created the website?


• How will the audience view the website? On desktop or laptop computers? On mobile devices 
(tablet computers or smartphones)?


3. Show students websites that use rich media and discuss how designers use it to enhance the user 
experience. Discuss how the device the audience will view the website on will influence the use of rich 
media and what elements you can include in the site content and design. Some elements to discuss 
include:


• Navigation systems


• Integrated user interface


• Animated screen elements


• Rich media advertising


• Social media


Note: Rich media advertising consists of using a combination of graphics with video, audio, or 
animation. An example is banner ads.


4. Explain that in addition to the importance of using design principles, user-friendly websites also 
employ appropriate navigation and usability standards. Show students some websites and discuss some 
of these questions:
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• What categories of information do you find in the websites?


• Where are these categories located?


• What can you say about the amount of information you can find in any particular area? On the 
entire website?


• What type of navigation appears on the pages? Is it consistent?


• What navigation choices are provided?


• How does the design create consistency?


• Is the appearance consistent?


• Are design elements common among the pages?


• What page elements identify the site?


• Name some benefits of consistency, such as improved usability.


• Is the website consistent across different devices and screen sizes?


Guide: How to design for usability 2.3, 2.4


Presentation: Web design for multiple screens


Note: You can use the information from the www.usability.gov, www.useit.com, and www.w3.org/
WAI/intro/isable sites to guide your discussion on usability. 


5. Discuss accessibility and why it matters to website visitors as well as website sponsors. Discuss 
assistive technologies such as screen readers, text and media alternatives, and accessible navigation. 
Describe the Web Content Accessibility Guidelines (WCAG) 2.0 by using the W3C’s Before and After 
Demonstrations (BAD) showing how inaccessible websites were turned into accessible websites: 
www.w3.org/WAI/demos/bad/.


Dreamweaver guide: How to make websites accessible 1.4


Note: You can also use the information from the Adobe Accessibility Resource Center and the World 
Wide Web Consortium (W3C) to guide your discussion: www.adobe.com/accessibility/, www.w3.org/
WAI/eval/Overview.html, www.w3.org/TR/WCAG10/full-checklist.html, www.webaim.org/articles/
pour/, and www.w3.org/WAI/intro/aria. 


6. Put students into pairs and assign each pair two websites that address the same topic and have the same 
purpose so students can compare ease of use and accessibility. Choose topics of interest to your 
students, such as the following examples:


• Sports: www.fifa.com, www.ussoccer.com, and www.wnba.com 


• Safe driving: www.cyberdriveillinois.com/publications/rules_of_the_road/rr_chap10.html and 
www.crashprevention.org


• Skin cancer: www.melanoma.com and www.maui.net/~southsky/introto.html


7. Put students into pairs and assign each pair two websites that address the same topic and have the same 
purpose so students can compare ease of use and accessibility. Choose topics of interest to your 
students, such as the following examples:


• What types of navigation elements are used: menus, hyperlinks, images, something else?


• As you navigate, how many clicks does it generally take to get to information you are seeking?


• As you navigate, do you get to the information you are expecting?


• Is the site structure apparent?
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• How long does it take for pages to load? (Typical visitors will wait three to five seconds for a page 
to load before moving on.)


• Does the website look the same in different browsers, on different operating systems, and on 
different devices?


• Is the text readable? Is the text uniquely styled? If so, does the styling add value to the purpose?


• How does the use of text, navigation, and site structure make the site easier or more difficult for 
visitors?


• Are there clear titles, headings, or other visual elements that specifically help organize the 
information?


• Does the site contain rich media? Does rich media add to the purpose and usability of the site or is 
it unnecessary?


• Is the color contrast and brightness between the foreground and the background appropriate for 
users with impaired vision?


Worksheet: Usability and accessibility 1.4, 2.1, 2.2, 2.3, 2.4


8. Ask students to return to their two sites and rank the sites for accessibility, just as they did for usability, 
ranging from easy to difficult. Questions for guiding student inquiry might include the following:


• Do the images have alternative text (Alt text) so the text descriptions can be read by screen 
readers?


• Are all the links, including embedded links, labeled so they can stand alone?


• If there is tabular data, do tables have header rows?


• Are there clear titles and headings that help organize the information for someone using a screen 
reader?


• Is the navigation scheme positioned conveniently for someone using a screen reader?


• Can a site visitor use the tab button to access all elements on the page/site?


• Is color the only element used to convey emphasis?


Worksheet: Usability and accessibility 1.4, 2.1, 2.2, 2.3, 2.4


Define a web project
(Suggested time: 150–250 minutes)


9. Introduce the project, with information about the client organization, such as the following:


• Name of organization


• Organization mission and goals


• Product or service provided by the organization and explanation of how it works


• Background and history


• Why the organization is in search of a web-design team


10. Remind students of the phases of a client website project discussed in Project 1 and review each phase 
and task. 


Website production phases
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• Define:


◦ Goals, target audience, content, and delivery requirements for the project


◦ Project plan


◦ Content production


• Structure:


◦ Information architecture and design document


◦ Flowchart to portray the overall structure of the site


◦ Wireframes to block out the basic structure of site pages


• Design:


◦ Design of comps to provide detailed alternative designs


◦ Review of comps with client to ascertain client’s design preferences


◦ Redesign based on client feedback


◦ Production storyboard


◦ Prototype


• Build and test:


◦ Site production based on storyboards


◦ Technical and usability testing, recording bugs and design-change requirements


◦ Revision based on test results


◦ Technical and usability testing of revised site


◦ Final presentation to client and final revision


• Launch


◦ Launch plan


Presentation: Web project production phases 1.6


11. Form student design teams and, where possible, mix members with complementary strengths, such as 


visual design, technical skill, and project management. Discuss the concept of working as a team.1.6


12. Introduce the concept of writing for the web. Explain that, depending on the project, sometimes the 
client provides the content and sometimes the designer is expected to take the content and make it web 
ready. In either case, a review of the general rules of writing for the web will facilitate giving advice to 
the client and/or explaining how the content is written and presented.


Presentation: Writing for the web 1.2


Note: For this project we recommend having the client provide the content; students will practice 
writing their own web content in Project 4: Portfolios. If you will not complete Project 4, you may 
want students to follow the steps for writing for the web at this juncture.


13. In preparation for the client interview, discuss the kind of information design teams need from their 
clients about the clients’ goals and target audience. Help students identify criteria for determining 
whether content is relevant to the site goals and appropriate for the target audience. 1.2 Have students 
conduct an interview with the client.


Worksheet: Client interview 2.6







© 2012 Adobe Systems Incorporated Web design and planning 7


Note: It is recommended for this project that the student teams build a website from scratch. However, 
they can also revise an existing site for a client. If the latter, use the Design review worksheet in place 
of the Client interview worksheet.


Worksheet: Design review


14. After the interview, have teams review websites recommended by the client. Encourage teams to 
collect potential assets and design ideas as they review sites.


15. Ask teams to organize and outline their content. Have them consider technical features that might be 
relevant to convey the content provided by the client, such as forms, widgets, rollover images, pop-up 


menus, animations, rich media, video, or preparation of photographs.1.2


16. Introduce and discuss Adobe Flash, JavaScript, CSS3, and other rich media tools and their ability to 
create animation and interactive media. Discuss and analyze with your students what kind of rich 


media they can realistically create for their client sites.4.8


17. Discuss the website production phases again in the context of creating the client websites. Some things 


to discuss include:1.6 


• When the completed client site is due 


• Reasonable time frames for each phase 


• Setting due dates


• Designating task owners for each task on their lists


• Responsibility of the task owner, especially who is accountable for getting a task completed 
regardless of who actually works on the task


18. Ask students to create a project plan for organizing their tasks within the project phases.


Worksheet: Project plan 1.6


Structure a web project
(Suggested time: 150–250 minutes)


19. Introduce information architecture to the students. Some guiding points are:


• Research the needs of the audience and users.


• Identify a clear purpose and audience for the site: who they are, why they will come to the site, the 
goals of the site, and so on. 


• Determine how to organize content by determining the site’s information structure (single page, 
flat structure, index page, daisy, strict hierarchy, coexisting hierarchy).


• Collect site content and develop a content inventory.


• Create a flowchart of the site.


• Define the navigation systems (global, local, utility links).


Presentation: Introduction to information architecture 1.1, 1.2, 1.5, 2.5


Guide: Tips for information architecture 1.1, 1.2, 1.5, 2.5







8 Web design and planning © 2012 Adobe Systems Incorporated


20. Discuss how a flowchart communicates information organization. Explain the structure of a flowchart. 
Discuss the definition of a home page. Point out that the home page is the default page that opens in a 
browser if the visitor does not specify another page. Mention that the home page is sometimes called a 
menu page because it usually contains the main menu links to the first set of content pages. Some of 


these first content pages might contain submenus to other content pages.2.5


21. Ask teams to draw a flowchart for the client site.


Note: Students have several options for building their flowcharts. They can draw by hand, use visual 
design software such as Inspiration (Inspiration Software), or use the Organization Chart feature in 
Microsoft PowerPoint or Microsoft Word.


22. Ask students to think about their websites and what design elements would make their sites 


consistent,2.1 Some guiding questions include the following: 


• What font will you use for titles or headings in your content pages?


• What color will you use for titles or headings in your content pages?


• What font will you use for descriptions in your content pages?


• What color will you use for the description font?


• Where will you place the navigation bar on the page?


• What content will be on the navigation bar?


• Will the navigation bar be on every page?


• Will every page have text navigation?


• How will your navigation bar and text navigation help visitors know which page they are on?


• Does the client have a logo or other design element that could drive the design? 


23. Introduce the concept of a design document by outlining the sections students need to include, with a 
brief explanation of each section:


• Project overview: List site challenges and possible solutions to address the challenges. Students 
might include examples from other sites that address these challenges well.


• Goals, objectives, and messages: List goals, objectives, and messages of the site.


• Audience: Write a brief description of the intended audience for this site.


• Delivery requirements: List the delivery requirements for this site (browsers supported, devices 
supported, minimum connection speed). Be sure to include any constraints the delivery 
requirements place on the site content.


• Site content: Give an inventory of the home page and content pages, including standard structures 
on the pages. Be sure to indicate the use of tables, headings, and indentation to maintain page 
structure consistency and hierarchy.


• Site structure: Draw a flowchart of the site to illustrate the information architecture.


• Visual design: Include at least two color and font samples. 


Worksheet: Design document 1.1, 1.2, 1.5, 2.5, 2.6


24. Have teams write a design document, using their conclusions from the client interview and their 
knowledge of information architecture and usability.
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Note:Make sure students identify any copyrighted material they plan to include on their sites. Ask 
teams to identify in the content section of the design document any copyrighted material they plan to 
include, as well as their strategy for acquiring permission to use such material.


Guide: Principles and rules of copyright 1.3


25. Remind students of the wireframe they created in Project 1. Briefly review design principles, what’s 
involved in creating a wireframe, and why wireframes are an important part of the website design 


process.2.2, 2.5 Discuss how web page layout and design must change depending on what viewing 
devices the client wishes to support. Ask students to use Fireworks to complete the wireframes for 
their website home page and any subsequent home pages. Remind them to consider the following:


• Graphics choice and placement


• Text choice and placement


• Navigation choice and placement (for both graphical and text navigation bars)


• Color choices


• Clear visual hierarchy


• Design limitations created by delivery requirements


• Multiple design options for screens of varying sizes on a variety of viewing devices


Fireworks guide: Overview of Adobe Fireworks CS6 workspace


Fireworks guide: How to create a wireframe 2.5


Note: If you did not teach Project 1, you can refer there for more detailed steps on teaching your 
students about the function of wireframes and how to use Fireworks to create them.


Note: If the client requires the site layout and design to be viewable on several different-sized devices, 
students may need to create a separate wireframe for each device. They may choose to create a 
wireframe for desktop and laptop computers, a wireframe for tablet computers, and a wireframe for 
smartphones.


26. Ask students to present their design documents (including flowcharts), wireframes, and project plans 


to the client.2.6 Ask the client to give an assessment of how the information organization, visual 
placement, and project schedule meet their goals and address their target audience. Make sure at least 
one member of each team takes notes on the client’s comments.


27. Have teams revise their design documents, flowcharts, wireframes, and project plans in response to the 
client’s feedback.


Design a web project
(Suggested time: 200–300 minutes)


28. Remind students of the design comp they created for their widget in Project 1. Explain that they will 
create a design comp, using their wireframe, for the client website. Show students some sample design 


comps.1.6, 2.3


Electronic file: GG_Bridge-rough_comp_1.fw.png


Electronic file: GG_Bridge-rough_comp_2.fw.png


Electronic file: GG_Bridge-rough_comp_3.fw.png
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Note: If you did not teach Project 1, you can refer there for more detailed steps on teaching your 
students about the function of design comps and how to create them.


29. Ask each team to make two or more design comps of the home page and a sample content page, using 
Fireworks. Encourage teams to create comps that show varying perspectives on the pages, but remind 
them to consider the value of consistency between the home page and the content pages. 2.3 If teams 
have more than one wireframe for multiple viewing devices, have them create a design comp for each 
wireframe. 


Fireworks guide: How to create a design comp


Note: It is recommended to have your students create their color palettes by using Adobe Kuler (http:/
/kuler.adobe.com).


30. After individuals have completed their comps, ask each team to select their two best home page comps 
and their two best content page comps to share with clients.


31. Ask students to prepare a presentation for the client that includes some or all of the following:2.6


• How their two design comps address the client’s goals, audience, and content requirements


• Screenshots of the color, font, and page samples, accompanied by the reasons for the design, page 
layout, and navigation choices


• Question-and-answer session in which the client gives feedback


32. Ask the clients to give feedback to each team. At this point have each team ask their client to select the 
color and font samples and the visual layouts they prefer, indicating any changes they believe should 
be made. (If a person from outside the classroom is acting as the client, the instructor might mediate 
the question-and-answer sessions to help student teams take note of the requested changes.) Teams 


should actively listen to the clients’ feedback by doing the following:2.6


• Take notes.


• Summarize what they heard the clients say, based on their notes.


• Ask clarifying questions such as the following:


◦ Can you identify online examples that solve this problem?


◦ How would you solve this problem?


◦ Would this solve the problem?


33. Ask teams to revise the design comps based on client feedback and present their comps to the clients 
again. Ask students to get client approval for the finalized color and font samples and the page layout 
and navigation designs. Students should document these elements in their design documents before 
proceeding to production. Teams can begin to incorporate final graphics and content as parts of the 


comps are approved.2.6


34. Introduce the storyboard concept as follows:


• The typical use of a storyboard is in designing movies or animated cartoons to depict what happens 
in the story. A storyboard contains scene-by-scene drawings of the sequence of action, camera 
angles, background, and so on. As the name implies, the storyboard is meant to tell the story 
visually, with sufficient detail to enable the production crew to understand what they will create.


• A graphics storyboard shows all the elements of the graphics, indicating size, location, color, and 
font.
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• A website storyboard might go through several iterations before going into production.


• First create rough sketches to convey the big picture and the basic site structure so all team 
members understand the scope of the project. Convert these rough sketches to finished sketches 
that can be shared with other parts of an organization or an outside client.


Presentation: Storyboards 2.5


35. Help students prepare for creating their storyboards. Show them a sample production storyboard and 
describe the level of detail required. Perhaps use one team’s design comps to create a sample 
storyboard page on the board or online. Make sure students understand that their storyboards are how 
they communicate page layout as well as font and color decisions within the team, so the storyboards 
must include a high level of detail.


Worksheet: Production storyboard 2.5


36. Have teams use the Production storyboard worksheet to create storyboards for all the pages in their 
sites. Storyboards should include the following elements for each site page:


• Site name


• Page title


• Document name


• Wireframe (layout)


• Background


• Heading texts (specification of fonts, font sizes, styles, borders, margins, alignment, padding, and 
colors)


• Body texts (specification of fonts, font sizes, styles, borders, margins, alignment, padding, and 
colors)


• Description of all text, graphics, Flash movies, and video, including the order in which these 
elements are displayed


• Buttons, links, and their destinations


• Graphics, video, or Flash movie files needed for the page


37. Discuss how wireframes, design comps, and storyboards lead to building a prototype.2.5 Briefly 
explain the following:


• A prototype is a semifunctional web page that gives a realistic preview of what the page will look 
like and how the site will work. 


• Students can combine wireframes and design comps in Fireworks to make a detailed and 
comprehensive prototype they can preview for their clients. 


• Prototypes made in Fireworks can also be exported as HTML and CSS files that can be used in 
Dreamweaver for previewing the website in a web browser.


38. Using the “I do, we do, you do” method, demonstrate how to combine a wireframe and a design comp 
into a prototype. Demonstrate how to export the prototype as HTML and CSS files.


Electronic file: prototype-export.zip


Fireworks guide: How to create a prototype
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39. Allow each team time to build a prototype of the home page and several content pages based on their 
storyboards. 


40. Have each team present the prototype to their client for approval in preparation of the technical site 


build.2.6 Allow time for any necessary revisions based on client feedback.


Extension activities


You can extend the project in the following ways:


• Map an existing site: To help students understand flowcharts, have them create a flowchart for a 
simple site on the Internet. You might find a small site for students to map. For example, students 
would draw the pages linked to the home page of this site and then the pages linked to those pages. By 
clicking through the links, students will begin to understand how a flowchart relates to a constructed 
site and will be able to create their own flowcharts more easily.


• Milestones: To help students manage their time during long projects, you can create milestones that 
give intermediate deadlines within the larger project. For this activity, you might have a class 
discussion to identify deadlines for each section of the design document. The sections are


◦ Goals, objectives, and site messages


◦ Audience


◦ Goals for redesign


◦ Technical specifications


◦ Site content


◦ Site structure


◦ Visual design


• Professional designer: You might ask a professional designer to talk to the class about creating design 
documents, explaining how they are helpful in the production process and in communicating with the 
client.


• Cascading Style Sheets: To provide students with more of a foundation in Cascading Style Sheets, you 
might have teams of students research topics and then present their findings to the class. Topics could 
include the following:


◦ The emergence of CSS


◦ The current CSS standards from the W3C


◦ The benefits of using CSS


Assessment
• Project rubric


Background preparation resources
• Review the student step-by-step guides referenced in this project.


• To view video tutorials aligned with the skills required to complete this project, visit the Digital Design 
CS6 show on Adobe TV: http://tv.adobe.com/show/digital-design-cs6/
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• For more teaching and learning resources on web design, planning and other topics in this project, 
search for resources from the community on the Adobe Education Exchange: 
http://edexchange.adobe.com


• For an overview of the interface and for more information on the technical aspects of Fireworks, see 
Fireworks Help. 


• For an overview of the interface and for more information on the technical aspects of Dreamweaver, 
see Dreamweaver Help. 


• Adobe’s Website Production Management Techniques (read the information under Define on the right 
side of the page): www.adobe.com/resources/techniques/. 


• View a tutorial on information architecture: 
www.webmonkey.com/2010/02/information_architecture_tutorial/


Usability and accessibility


• Adobe Accessibility Resource Center: www.adobe.com/accessibility/


• World Wide Web Consortium (W3C): www.w3.org/WAI/eval/Overview.html


• W3C Priority 1 Checkpoints for website accessibility: www.w3.org/TR/WCAG10/full-checklist.html


• W3C Priority 2 POUR principles for website accessibility: www.webaim.org/articles/pour/ 


• The primary government source for information on usability and user-centered design: 
www.usability.gov


• Jakob Nielsen’s website on usability: www.useit.com


• Web usability checklist: www.ddj.com/184412660


Wireframes


• A free wireframe stencil kit for Adobe Fireworks that includes a variety of UI elements such as 
buttons, drop-downs, and tabs: www.dragnet.se/webbdesign/websitewireframes.html


• Adobe Proto, a Touch App for creating interactive wireframes and prototypes of websites and mobile 
apps on a tablet: www.adobe.com/products/proto.edu.html


• Sqetch, an Adobe Illustrator toolkit that includes a number of templates and elements, including iPad 
and browser chrome, GUI elements, and form elements: 
www.eleqtriq.com/2010/08/sqetch-wireframe-toolkit/


Clients


• A resource for creative ways of finding clients for school classroom projects: 
http://edexchange.adobe.com/posts/b6fde4a10e


• A client survey you can download and use: 
www.adobe.com/resources/techniques/resources/define/client_survey.rtf


Design document


• A sample design document process from the Center for Advancement in Teaching: 
http://cat.xula.edu/tutorials/planning/designdoc
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Key terms
• audience


• client communication


• design comp


• design document


• design review


• flowchart


• information architecture


• navigation


• production storyboard


• project plan


• purpose


• wireframe


ISTE NETS*S Standard for Students


This project is aligned to the ISTE NETS*S Technology Standards. Depending on the subject and content 
area the student selects you may research your own state content standards to see how this project aligns to 
your state requirements.


ISTE NETS*S: Curriculum and Content Area Standards – NETS for Students


1. Creativity and Innovation


Students demonstrate creative thinking, construct knowledge, and develop innovative products and 
processes using technology. Students:


a. apply existing knowledge to generate new ideas, products, or processes.


b. create original works as a means of personal or group expression.


2. Communication and Collaboration


Students use digital media and environments to communicate and work collaboratively, including at a 
distance, to support individual learning and contribute to the learning of others. Students:


a. interact, collaborate, and publish with peers, experts or others employing a variety of digital 
environments and media.


b. communicate information and ideas effectively to multiple audiences using a variety of media and 
formats


d. contribute to project teams to produce original works or solve problems


3. Research and Information Retrieval


Students apply digital tools to gather, evaluate, and use information. Students:


b. locate, organize, analyze, evaluate, synthesize, and ethically use information from a variety of 
sources and media. 


c. evaluate and select information sources and digital tools based on the appropriateness to specific 
tasks


4. Critical Thinking and Problem Solving


Students use critical thinking skills to plan and conduct research, manage projects, solve problems and 
make informed decisions using appropriate digital tools and resources. Students:


b. plan and manage activities to develop a solution or complete a project.


d. use multiple processes and diverse perspectives to explore alternative solutions


5. Digital Citizenship


Students understand human, cultural, and societal issues related to technology and practice legal and 
ethical behavior. Students:
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a. advocate and practice safe, legal, and responsible use of information and technology.


b. exhibit a positive attitude toward using technology that supports collaboration, learning, and 
productivity. 


6. Technology Operations and Concepts


Students demonstrate a sound understanding of technology concepts, systems, and operations. 
Students:


a. understand and use technology systems.


b. select and use applications effectively and productively.


d. transfer current knowledge to learning of new technologies. 


Adobe Certified Associate, Web Communication objectives


1.1 Identify the purpose, audience, and audience needs for a website.


1.2 Identify web page content that is relevant to the website purpose and appropriate for the target 
audience.


1.3 Demonstrate knowledge of standard copyright rules (related terms, obtaining permission, and citing 
copyrighted material).


1.5 Make website development decisions based on your analysis and interpretation of design 
specifications.


1.6 Understand project management tasks and responsibilities.


2.1 Demonstrate general and Dreamweaver-specific knowledge of best practices for designing a website, 
such as maintaining consistency, separating content from design, using standard fonts, and utilizing 
visual hierarchy.


2.2 Produce website designs that work equally well on various operating systems, browser versions/
configurations, and devices.


2.3 Demonstrate knowledge of page layout design concepts and principles.


2.4 Identify basic principles of website usability, readability, and accessibility.


2.5 Demonstrate knowledge of flowcharts, storyboards, and wireframes to create web pages and a site map 
(site index) that maintain the planned website hierarchy.


2.6 Communicate with others (such as peers and clients) about design plans.
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Assessment


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations


Client 
interview


Absent or incomplete. The interview identifies 
the client’s goals, the target 
audience, and the intended 
purpose of the website.
The interview identifies 
the content and 
information crucial to the 
website. The interview 
identifies the client’s 
preferred design 
requirements and includes 
any additional relevant 
questions.


The interview clearly 
identifies the client’s goals, 
the target audience, and the 
intended purpose of the 
website. The interview 
clearly identifies the 
content (both original and 
repurposed) and 
information crucial to the 
website. The interview 
identifies the client’s 
preferred design 
requirements and 
documents specific 
examples. The interview 
includes additional 
relevant and thorough 
questions to get or clarify 
specific information.


Project plan Absent or incomplete. Students set milestones, 
assign tasks that reflect 
equal workload among 
team members, and set 
final deadlines to plan each 
phase of the project.


Students set milestones 
that include detailed 
descriptions of tasks, 
assign tasks that reflect 
equal workload among 
team members, and set 
final deadlines to plan each 
phase of the project.


Design 
document


Absent or incomplete. Students create design 
documents that include site 
goals, objectives, and 
messages; site audience; 
delivery requirements; site 
content overview; site 
flowchart; font and color 
samples; and visual design 
mocks.


Students create design 
documents that include 
detailed analysis of the site 
goals, objectives, and 
messages; site audience; 
delivery requirements; site 
content overview; site 
flowchart; font and color 
samples; and visual design 
mocks.


Website 
wireframe


Absent or incomplete. Students create wireframes 
based on design principles 
and delivery requirements 
to organize content on 
pages.


Students create wireframes 
based on design principles 
and delivery requirements 
to organize content on 
pages. Students support 
each decision on elements 
in the wireframes with data 
and information gathered 
from research and clients.
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Website 
design comps


Absent or incomplete. Students create design 
comps that accurately 
reflect audience, goals, 
color choices, mood, 
images, text, and 
navigation choices. The 
selected comps reflect 
varied approaches to the 
design.


Students create design 
comps that accurately 
reflect audience, goals, 
color choices, mood, 
images, text, and 
navigation choices. The 
selected comps reflect 
varied approaches to the 
design. Students can 
clearly articulate the ways 
design principles are 
implemented to impact the 
audience.


Website 
storyboards


Absent or incomplete. Students create production 
storyboards, with 
information for design and 
structure of the site and its 
elements.


Students create detailed 
production storyboards, 
with information for 
design and structure of the 
site and its elements.


Website 
prototype


Absent or incomplete. Students create prototypes 
of the home page and 1–2 
content pages based on 
wireframes, design comps, 
and storyboards. The 
prototypes are 
semifunctional in 
Fireworks and can be 
exported as HTML and 
CSS for Dreamweaver.


Students create prototypes 
of the home page and 2–4 
content pages based on 
wireframes, design comps, 
and storyboards. The 
prototypes are realistic, 
semifunctional in 
Fireworks, and use client-
approved colors, fonts, 
page layout, and 
navigation. Prototypes are 
exported as HTML and 
CSS for Dreamweaver.


Teamwork Absent or incomplete. Student collaborates with 
other students as required 
to provide feedback or 
assistance. Fulfills 
assigned team roles and 
contributes equally to 
project work. Sometimes 
consults with other team 
members on major project 
decisions but makes 
minimal effort to help 
others build skills.


Student collaborates freely 
with other students to 
provide feedback or 
assistance. Fulfills 
assigned team roles and 
contributes equally to 
project work. Consults 
with other team members 
on major project decisions 
and voluntarily helps 
others build skills to 
complete the project.


Time 
management


Absent or incomplete. Student allots time for each 
phase of the design and 
development process. 
Completes most phases on 
schedule.


Student thoughtfully and 
effectively allots time for 
each phase of the design 
and development process. 
Completes all phases on 
schedule.


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations
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Adobe Flash Professional CS6 Project 7 guide

How to use rulers and guides
Rulers and guides can be very helpful in positioning objects on the Stage.


Using guides
You can drag horizontal and vertical guides from the rulers onto the Stage when the rulers are displayed. You can 
move guides, lock guides, hide guides, and remove guides. You can also snap objects to guides and change the guide 
color and snap tolerance (how close objects must be to snap to a guide). 


Adobe Flash Professional CS6 enables you to create nested timelines (i.e., movie clips within the main movie). 
Guides appear on the Stage only when the timeline in which they were created is active. 


To create a guide:


1. Make sure rulers are visible by selecting View > Rulers. 


2. Click on a ruler and drag toward the Stage (Figure 1).


A guide appears as you drag.


3. Release the mouse button button at the point you wish to 
position the guide.


The guide appears as a light blue line on the Stage 
(Figure 2).


Figure 1 Drag a ruler


Figure 2 Guide on Stage
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Locking or Unlocking Guides


When guides are locked, they won’t respond to clicking or dragging, so that you won’t accidentally move them when 
you are working with objects on the Stage. However, you can still create new guides.


To lock a guide


• Select View > Guides > Lock Guides.


This command toggles between locking and 
unlocking guides.


Note: You can also use the Lock Guides option in 
the Guides dialog box (Figure 3). To open the 
Guides dialog box, select View > Guides > Edit 
Guides. For more information, see the section titled 
Changing guide properties at the end of this guide.


Figure 3 Guides dialog box


To view or hide the drawing guides:


• Select View > Guides > Show Guides.


This command toggles between hiding and showing 
guides.


To move a guide:


• Make sure guides are showing and not locked. With 
the Selection tool, click anywhere on the guide and 
drag the guide to the desired place on the Stage.


To remove a guide:


• With guides unlocked, use the Selection tool to drag 
the guide to the horizontal or vertical ruler.

How to use rulers and guides © 2012 Adobe Systems Incorporated
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Using guides to position objects on the Stage


By activating the Snap To Guides option, you can automatically align objects with guides. As you drag objects 
toward guides, objects snap into place.


To position objects with guides:


1. Select View > Snapping > Snap To Guides (if it is not 
already selected).


2. Drag the edge of an object toward a guide.


When you get close to the guide, the object snaps to it 
(Figure 4).


3. Release the mouse.


The object remains snapped to the guide.


You can use guides to line up different objects 
(Figure 5). Guides are especially useful for aligning 
objects on different layers.


Figure 4 Snap object to guide


Figure 5 Aligning objects with guides


Changing guide properties
You can change guide colors, set guide snapping properties, and lock guides.


To change guide properties:


1. Select View > Guides > Edit Guides.


The Guides dialog box opens (Figure 6).


2. Click the Guides Color control to change guide colors.


3. Select Lock Guides to lock guides in position.


4. Click OK to close the Guides dialog box.


Figure 6 Guides dialog box

© 2012 Adobe Systems Incorporated How to use rulers and guides 3
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Project 8


Final web portfolios
Timing: 5 to 10 hours


Project overview


Portfolios communicate accomplishments, works in progress, or personal history. Individuals use a 
portfolio to showcase their work when applying for a job. Traditionally a portfolio is a large book or 
leather case containing design samples. With the Internet, portfolios can be electronic, easily and quickly 
sharing a designer’s work with anyone in the world.


In this project, students update their web portfolios from Project 4. They build a website that features work 
they have completed and work to be completed. As students create their portfolios, they plan, implement, 
and test their website designs and then reflect on and evaluate their work. The presentation of a web 
portfolio can be just as important as its content.


Student product: Final web portfolio


Note: Portions of the Final web portfolio project align to the Adobe Certified Associate, Web 
Communication objectives. Within the instruction steps and technical guides, the specific learning 
objectives for the exam are referenced with the following format: 1.1  


Project objectives


At the completion of the project, students will have developed the following skills:


Project management skills


• Conducting a review workshop


• Providing constructive criticism


• Planning and updating an existing web 
portfolio


• Organizing and managing content


• Creating flowcharts


• Creating a launch plan


Design skills


• Designing consistent pages


• Designing for a specific audience and purpose


• Providing universal navigation


• Providing consistency and accessibility


• Adapting content for readability and emphasis


Research and communication skills


• Evaluating and assessing skills


• Evaluating and assessing an existing portfolio


• Writing and editing portfolio content


• Presenting a web portfolio to a group


• Soliciting and providing feedback


• Taking notes on critique


• Investigating and researching career areas 
within web design and development


• Planning for future careers


• Understanding and practicing lifelong career 
skills:


◦ Job research skills


◦ Presentation skills


Technical skills


Dreamweaver


• Updating a web portfolio


• Adding rich media to a web portfolio
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Project materials
• Adobe Dreamweaver CS6 installed on all 


machines


• Adobe Fireworks CS6 installed on all machines


• Adobe Flash Professional CS6 installed on all 
machines


• Adobe Photoshop CS6 installed on all 
machines


• Adobe Illustrator CS6 installed on all machines


• Guide: How to plan a portfolio


• Guide: Tips for information architecture


• Guide: How to design for usability


• Guide: Peer review


• Guide: Writing for the web


• Worksheet: How to promote a website


Background preparation resources
• Technical and content information


• Key terms


• ISTE NETS*S Standard for Students


• Adobe Certified Associate, Web Communication objectives


Project steps


Updating a web portfolio
(Suggested time: 250–300 minutes)


1. Introduce this culminating activity as a way for students to reflect on their completed project work. 
Students have been focusing on the design and development of various projects; this is a good time for 
them to focus on the type of work they plan to pursue after this course.


2. Introduce students to the goals of this project:


• Select and organize content for a web portfolio.


• Update their web portfolio.


• Create a basic marketing plan.


• Launch their web portfolio online.


3. Review the concept of a portfolio, its purpose, and its audience.


4. In a class brainstorm, discuss the ways in which students plan to use their portfolios going forward and 
how that might change their target audience and purpose. Questions to aid the discussion might 
include:


• Do you plan to look for a job or internship? If so, what kind of job or internship?


• Do you plan to apply for a program or school? If so, what type of program or school?


• How would the goals of the portfolio differ depending on where you plan to go next?


• What should the portfolio contain?


• How should the content be presented?


5. To prepare students for real-world experience, allow them to research job opportunities and 
requirements on recruitment sites to help them visualize and plan for career goals and expectations. 
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6. Allow students time to review their portfolios and analyze how they might change these to represent 
their new skills and career ambitions. Explain that students are to engage in a review similar to what 
they did in Project 4, but this time reviewing their portfolios with respect to the career and learning 
goals and type of audience they plan to focus on after they finish this course.


7. Allow students time to look through their work over the entire course and reconsider the content and 
design of their portfolios. They should consider the following when writing up their lists of redesign 
tasks:


Content:


• What is the purpose of the portfolio? How does the purpose affect the type of content you should 
include? 1.1, 1.2


• Who is the intended audience for the portfolio? How does the audience affect the type of content 
you should include? 1.1, 1.2


• Does the content address the goals of the website? 1.1, 1.2


• Is the current content relevant to the purpose and audience? If not, what should you remove and 
what other projects should you include?  1.1, 1.2


• Is the language level appropriate for your intended audience? 1.2


• Do the pages have any spelling errors, punctuation errors, or grammatical errors? 1.2


Design:


• Uniformity and Consistency: Are elements repeated on content pages to help identify the portfolio 
as a complete site? What attributes of the portfolio maintain or violate consistency?2.1, 2.3


• Universal navigation: Where is the main navigation for the site located, and does it appear on all 
pages? 2.1


• Layout: Is the layout logical, or do page elements appear to be placed randomly? 2.3


• Links: Are links labeled clearly? 2.3


• Usability: Does the page load quickly? Are site visitors able to find information easily? 2.4


• Readability: Is there formatting that improves or reduces readability? 2.4


• Accessibility: Are all images labeled with alternative text (Alt tags)? Are the text and titles clear 
and easy to read for all site visitors (color, size, and so on) Do image links and hotspots (image 
maps) have alternative text labels? What features can or cannot be read by screen readers? 1.4, 2.4


• Rich media: How can rich media be used to enhance the portfolio? 1.5 Should rich media be 
incorporated into the design of the portfolio? 4.7, 4.8


8. Review the concept of a flowchart from Project 4 and ask students to create a new flowchart for this 
portfolio, incorporating the changes from the redesign tasks.


Guide: How to plan a portfolio 2.5


Guide: Tips for information architecture 1.1, 1.2, 1.5, 2.5


Guide: How to design for usability 2.4
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9. After students have had some time to devise their redesign plans, divide them into groups of three or 
four. Ask each group to review each student portfolio, one at a time, discussing the designer’s revised 
goal, target audience, and plan for redesign. Each group should provide thoughtful feedback to the 
designer with respect to planned changes. Explain that students should determine which redesign 
suggestions to implement in their own web portfolios.


Guide: Peer review 2.6


10. Allow students time to create a final list of projects and elements to include in their portfolios. 
Encourage them to add interactive elements and navigation and rich media to their portfolios. 


11. Allow students time to update their portfolios and create any additional assets in Photoshop, Illustrator, 
Fireworks, Dreamweaver, and Flash, using the various techniques they have learned. Ask students to 
create a final portfolio using a combination of what they learned in previous projects, emphasizing the 
use of CSS, templates, HTML, and Flash to create consistent, well-designed, interactive portfolios. 
Ask students to build their web portfolios based on their flowcharts.


Note: Encourage students to use the technical guides from previous projects.


12. Review the best practices of writing for the web and ask students to update any of their content as 
necessary, especially considering the goals and audience for their portfolios.


Guide: Writing for the web 1.2


Presenting and launching a web portfolio
(Suggested time: 50–100 minutes)


13. Explain that because the purpose of their portfolio is to market their skills to potential employers and/
or clients, they need to determine the following: 


• How and where they will launch the portfolio. 


• Who they will market the portfolio to. 


• How they will promote and drive traffic to the portfolio.


14. Introduce Search Engine Optimization (SEO) and the primary components of a website that search 
engines crawl to find relevant search results. Explain that students can optimize their websites for 
certain keywords that could increase their page rank in search engines. Allow time for students to 
identify the keywords that might be useful to include in the meta tags of their sites to make their pages 


easier for search engines to find. 5.7


15. Ask students to investigate how to use web search engines to promote or market a website. They can 
find information on search engines on the Submission Tips page at http://searchenginewatch.com/
webmasters/. Students should explore and contrast the following two options:


• Find a search engine that offers free submission of websites. Make a list of their submission 
procedures.


• Find a search engine or promotion site for which you pay to submit your site. State the cost and 
discuss whether the benefits of the service are worth the cost.


Worksheet: How to promote a website


16. Ask students to outline a brief launch and marketing plan for their portfolios based on their career 
research. In creating their plans, encourage students to think about the following: 
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• Their target audience and goals when selecting the organizations and methods they might use for 
promoting the site


• How they will market their skills and approach jobs of interest (for example, personal 
communication, submitting to directories)


• How they can use social media (Twitter, Facebook, Google+, blogging) to market the portfolio site


17. Instruct students to finalize and publish their web portfolios, being sure to include SEO techniques.


18. After students devise a plan, discuss how to organize a formal presentation in which they present their 


portfolio and explain the following: 2.6


• The types of jobs they are seeking, using specific examples from their research


• A plan for meeting the requirements and skill set of the jobs they are seeking


• The skills, qualifications, training, and so on necessary for a job in their career area


• What they have learned by making a portfolio and throughout the course


• What they feel they still need to learn to realize their career goals


• How they improved or changed their content or design and how the changes grew out of their 
revised purpose and target audience (they might want to include old pages of the portfolio to show 
the changes)


• Explanation of their launch and marketing plan


19. Allow students time to present their portfolios to the class.


Extension activities


You can extend the project in the following ways:


• Career/education planning: Ask students to create a five-year plan outlining the steps necessary to 
reach their career goals. This may include education, internships, jobs, and so on. Also ask students to 
begin to research and plan a resume appropriate for their desired career field.


• Reflection supplement: Ask students to write up their career goal plans and how those plans impacted 
the decisions they made in planning their portfolios. This document will help students reflect on their 
process and provide a framework for continued evolution of their portfolios as they begin to conduct a 
job search.


• ePortfolios: Ask students to create a PDF portfolio. You can use the materials from Project 5: PDF 
Portfolios, using Adobe Photoshop CS6 and Acrobat X from the Visual Design curriculum.


• Social media and blogging: Students could research ways to use social media to raise awareness of 
their web portfolios. Students can establish a social media presence by opening professional accounts 
on Twitter, Facebook, Google+, LinkedIn, or other social networks. Students could then integrate their 
social media activity into their web portfolios through social media feeds that allow students to post 
real-time news or information on their portfolios. In addition, students could start blogs and begin to 
write about their areas of interest.


Assessment
• Project rubric
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Background preparation resources
• Review the student step-by-step guides referenced in this project.


• To view video tutorials aligned with the skills required to complete this project, visit the Digital Design 
CS6 show on Adobe TV: http://tv.adobe.com/show/digital-design-cs6/


• For more teaching and learning resources on web portfolios and other topics in this project, search for 
resources from the community on the Adobe Education Exchange: http://edexchange.adobe.com


• For an overview of the interface and for more information on the technical aspects of Dreamweaver, 
see Dreamweaver Help. 


• For an overview of the interface and for more information on the technical aspects of Fireworks, see 
Fireworks Help. 


• For an overview of the interface and for more information on the technical aspects of Flash, see Flash 
Help. 


• For an overview of the interface and for more information on the technical aspects of Photoshop, see 
Photoshop Help. 


• For an overview of the interface and for more information on the technical aspects of Illustrator, see 
Illustrator Help. 


Portfolios


• U.S. Department of Education, Office of Research and Improvement, Classroom Uses of Student 
Portfolios: www.ed.gov/pubs/OR/ConsumerGuides/classuse.html 


• Advice from web professionals for building great web portfolios: 
www.smashingmagazine.com/2008/03/04/creating-a-successful-online-portfolio/; 
www.smashingmagazine.com/2009/02/26/10-steps-to-the-perfect-portfolio-website/; 
http://speckyboy.com/2011/05/08/building-a-great-web-design-portfolio-–-10-best-tips-40-examples/


• Five styles for organizing the content of a web portfolio: 
http://sixrevisions.com/web_design/five-popular-design-portfolio-website-styles/


• Information and tips for marketing a personal web portfolio: 
www.thewebsqueeze.com/web-design-articles/how-to-market-your-web-design-portfolio.html


• Examples of online portfolios: 


◦ Twenty-five recommended web portfolios: 
http://sixrevisions.com/design-showcase-inspiration/25-impressive-portfolio-web-designs/ 


◦ Information and examples of a variety of electronic portfolios: 
http://eduscapes.com/tap/topic82.htm


◦ Elements of great portfolios with examples: 
http://webdesign.tutsplus.com/articles/general/elements-of-a-great-web-design-portfolio/


◦ Gallery of Flash portfolio sites: www.pixelperfectportfolios.com/


◦ Dave Werner’s portfolio uses Flash skills and well-narrated video to give visitors a sense of his 
personal story and adds a strong voice and context to his featured work: http://okaydave.com/


Web career information


• What is a web professional: www.markdubois.info/weblog/2012/01/what-is-a-web-professional/ 


• The World Organization of Webmasters provides community education and certification resources to 
web professionals in all phases of their careers: http://webprofessionals.org/
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Key terms
• audience


• flowchart


• information architecture


• portfolio


• purpose


ISTE NETS*S Standard for Students


This project is aligned to the ISTE NETS*S Technology Standards. Depending on the subject and content 
area the student selects you may research your own state content standards to see how this project aligns to 
your state requirements.


ISTE NETS*S: Curriculum and Content Area Standards – NETS for Students


1. Creativity and Innovation


Students demonstrate creative thinking, construct knowledge, and develop innovative products and 
processes using technology. Students:


a. apply existing knowledge to generate new ideas, products, or processes.


b. create original works as a means of personal or group expression.


d. identify trends and forecast possibilities.


2. Communication and Collaboration


Students use digital media and environments to communicate and work collaboratively, including at a 
distance, to support individual learning and contribute to the learning of others. Students:


b. communicate information and ideas effectively to multiple audiences using a variety of media and 
formats


3. Research and Information Retrieval


Students apply digital tools to gather, evaluate, and use information. Students:


a. plan strategies to guide inquiry.


b. locate, organize, analyze, evaluate, synthesize, and ethically use information from a variety of 
sources and media. 


c. evaluate and select information sources and digital tools based on the appropriateness to specific 
tasks.


4. Critical Thinking and Problem Solving


Students use critical thinking skills to plan and conduct research, manage projects, solve problems and 
make informed decisions using appropriate digital tools and resources. Students::


a. identify and define authentic problems and significant questions for investigation.


b. plan and manage activities to develop a solution or complete a project.


d. use multiple processes and diverse perspectives to explore alternative solutions.


5. Digital Citizenship


Students understand human, cultural, and societal issues related to technology and practice legal and 
ethical behavior. Students:


a. advocate and practice safe, legal, and responsible use of information and technology.


b. exhibit a positive attitude toward using technology that supports collaboration, learning, and 
productivity.
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c. demonstrate personal responsibility for lifelong learning. 


6. Technology Operations and Concepts


Students demonstrate a sound understanding of technology concepts, systems, and operations. 
Students:


a. understand and use technology systems.


b. select and use applications effectively and productively.


d. transfer current knowledge to learning of new technologies.


Adobe Certified Associate, Web Communication objectives


1.1 Identify the purpose, audience, and audience needs for a website.


1.2 Identify web page content that is relevant to the website purpose and appropriate for the target 
audience.


1.4 Demonstrate knowledge of website accessibility standards that address the needs of people with visual 
and motor impairments.


1.5 Make website development decisions based on your analysis and interpretation of design 
specifications.


2.1 Demonstrate general and Dreamweaver-specific knowledge of best practices for designing a website, 
such as maintaining consistency, separating content from design, using standard fonts, and utilizing 
visual hierarchy.


2.3 Demonstrate knowledge of page layout design concepts and principles.


2.4 Identify basic principles of website usability, readability, and accessibility.


2.5 Demonstrate knowledge of flowcharts, storyboards, and wireframes to create web pages and a site map 
(site index) that maintain the planned website hierarchy.


2.6 Communicate with others (such as peers and clients) about design plans.


4.7 Include video and sound in a web page.


4.8 Add animation and interactivity to content.


5.7 Add head content to make a web page visible to search engines.
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Assessment


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations


Portfolio 
flowchart


Absent or incomplete. Flowchart shows clear 
organization of content and 
appropriate selection of 
content.


Flowchart shows clear 
organization of content and 
appropriate and complete 
selection of content 
relevant to goals and 
purpose.


Final web 
portfolio


Absent or incomplete. Portfolio reflects flowchart 
elements. Portfolio content 
pages reflect flowchart 
elements, have a common 
structure, and include 
consistent design elements 
that improve usability for 
visitors. Portfolio content 
includes information about 
future goals, highlights 
exemplary projects that 
support goals, and includes 
good usability and 
accessibility.


Portfolio reflects flowchart 
elements. Design and 
layout of the home page 
reflect good application of 
design principles and 
include elements of rich 
media. Portfolio content 
pages reflect flowchart 
elements, have a common 
structure, and include 
consistent design elements 
that improve usability for 
visitors. Content pages 
apply principles learned 
through portfolio analysis. 
Portfolio content includes 
information about future 
goals, highlights 
exemplary projects that 
support goals, and includes 
good usability and 
accessibility.





		Final web portfolios

		Project overview

		Project objectives

		Project materials

		Background preparation resources

		Project steps

		Updating a web portfolio

		Presenting and launching a web portfolio



		Extension activities

		Assessment

		Background preparation resources

		Key terms

		ISTE NETS*S Standard for Students

		Adobe Certified Associate, Web Communication objectives

		Assessment















Adobe Dreamweaver CS6 Project 3 guide

How to preview and test a web project
Because you can't control which browsers or operating systems visitors will use to view your site, it is important to 
test your site in different browsers. Although you can do some of this on your computer by installing several browsers 
and running a local testing server, it can be a challenge to review all possible combinations of browsers and operating 
systems. For a detailed overview about the purposes of a testing server, see the Dreamweaver Developer Center 
article written by David Powers, Setting up a local testing server in Dreamweaver CS5 at www.adobe.com/devnet/
dreamweaver/articles/setup_testing_server.html.


Adobe BrowserLab is an online service that lets you test your website pages in a variety of web browsers and 
operating systems. For example, the following combinations of browsers and operating systems can produce slight 
differences in how your site appears:


• Google Chrome 3.0 - Windows XP


• Microsoft Internet Explorer 8.0 - Windows XP


• Apple Safari 4.0 - Mac OS X


• Mozilla Firefox 3.0 - Mac OS X


The service works by taking screenshots of your web pages in different browsers and then displaying them on the 
BrowserLab page (Figure 1).


Figure 1 Adobe BrowserLab 


BrowserLab is integrated with Dreamweaver CS6. You can test your pages from within Dreamweaver without 
publishing your pages to a server.


View menuBrowser menus Refresh The Screen button
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Using BrowserLab in Dreamweaver
BrowserLab lets you preview local web content from within Dreamweaver, without requiring you to post it to a 
publicly-accessible server first. You can preview files from your local Dreamweaver site.


To use BrowserLab within Dreamweaver:


1. Start Dreamweaver.


2. Open a document that you want to preview in 
BrowserLab.


3. Select View > Design.


4. Choose Window > Extensions > Adobe BrowserLab.


The Adobe BrowserLab panel opens.


5. In the Adobe BrowserLab panel, choose Local/Network 
from the pop-up menu (Figure 2).


The Design view and Local/Network options direct 
BrowserLab to preview files using the open local file as 
its source for screen shots.


6. Click the Preview button.


7. When the BrowserLab home page opens, click Start 
Using BrowserLab (Figure 3).


Note: There may be a Go Back To BrowserLab button 
instead of a Start Using BrowserLab button if you have 
used the service before.


8. Enter your e-mail and password and click Sign In 
(Figure 4), or click Learn More to obtain an Adobe ID if 
you don't already have one.


9. Click the Browser pop-up menu and choose the browser/
operating system that you want to test.


10. To compare multiple browser/operating system 
combinations, choose 1-Up, 2-Up, or Onion Skin from 
the View pop-up menu (Figure 1).


Observe that the some content blocks in the illustrated 
web page do not show in the second pane. Make changes 
to your page until you are satisfied with the way it 
appears in both panes.


11. Make changes to the page, or to the CSS attached to the 
page.


12. Click the Refresh The Screenshots button in the 
BrowserLab application window.


BrowserLab previews your page without your having to 
save the local changes first.


Figure 2 BrowserLab panel


Figure 3 Start Using BrowserLab button


Figure 4 BrowserLab Sign In page
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Adobe Dreamweaver CS6 Project 4 guide

How to create forms
You can use forms to interact with or gather information from site visitors. With forms, visitors can provide feedback, 
sign a guest book, take a survey, or place an order for merchandise. In Adobe Dreamweaver CS6, you can create a 
variety of form elements, such as text fields, password fields, radio buttons, checkboxes, pop-up menus, and clickable 
images (such as a Submit button).


The Forms category in the Insert panel (Figure 1) contains buttons for creating forms and inserting form elements.


Figure 1 Forms category in the Insert panel


The data gathered in forms is usually sent to a database on a server or through e-mail. To set up the form processing, 
contact your site administrator. This guide helps you make the user interface of a form.


Setting up a form
You set up a form by inserting it and configuring options through the Properties panel.


To set up a form:


1. Open a page in Dreamweaver.


2. Place the insertion point on the page where you want to 
insert a form or draw a new div for more precise 
positioning of the form on your page. 


Note: To draw a new div, click Draw AP Div in the 
Layout category in the Insert panel, and then drag to draw 
the div. Be sure to make the div large enough to contain 
the entire form you plan to create.
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3. Select the Forms category in the Insert panel (Figure 1), 
and click Form. 


A blank form appears, with a red dotted outline 
(Figure 2). You place all form elements inside this 
outline. If you placed the form inside a div, you may need 
to click outside the div to see the entire form outline.


Form options appear in the Properties panel.


4. From the Method pop-up menu in the Properties panel 
(Figure 3), select either GET or POST.


• GET appends the form contents to the URL specified 
in the Action text box. Use GET if the form data is 
short and the results of the form will lead to a page 
that you want the visitor to be able to bookmark.


• POST sends the form contents directly to the server 
in a manner that is not visible to the visitor. Use 
POST if the form data might be long (if, for instance, 
the form includes a text field that the visitor can use 
to type an unlimited amount of text). 


5. In the Action text box, type the URL or CGI script that 
will process the form.


Note: Get this information from your site administrator.


Figure 2 New, empty form


Figure 3 Forms Properties panel


Adding form elements
Using the Forms category in the Insert panel, you can insert any combination of form elements within the red outline 
of the form. You can use tables to lay out these elements if you choose.


Using form fields


Form fields enable site visitors to enter text into a form. Form fields include the following:


• Text fields, in which a visitor types a response


• File fields, in which a visitor types the path of a file to upload to your server


Adding text fields


Text fields provide a space in which visitors can enter text.
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To add a text field:


1. Click the Text Field button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens 
(Figure 4).


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the text field in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).


The ID is used by HTML and/or Javascript code to 
distinguish this input tag from others, but it isn’t visible 
to site visitors.


3. Enter a label for the text field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


The label will be displayed next to the text field, 
indicating to the visitor what to put in the field.


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


5. In the Add Form Tag dialog box, click Yes.


The text field appears in the form (Figure 5).


6. Click in the text field (not the label) to select it.


7. In the form Properties panel (Figure 6), select one of the 
three types of text fields:


• Single Line text for short answers


• Multi Line text for long answers such as the visitor’s 
description of a problem with a purchased item


• Password text for passwords (in which asterisks 
appear in place of typed characters)


Note: You can also create a multiple-line text field by 
clicking the Text Area button in the Insert panel.


Figure 4 Input Tag Accessibility Attributes dialog 
box


Figure 5 Example of text field in the form


Figure 6 Form Text Field Properties panel


Adding a file field


A file field enables site visitors to select a file on their computers (such as a word-processing document or graphics 
file) and upload it to your server. A file field looks like other single-line text fields, except it also provides a Browse 
button. The visitor either types the path to the file they want to upload or uses the Browse button to locate and select 
the file.
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To add a file field:


1. Click the File Field button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the file field in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).


3. Enter a label for the file field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


The file field appears in your document (Figure 7).


5. Click in the file field (not the label) to select it. In the 
Properties panel, in the Char Width text box, specify the 
maximum number of characters visitors will see in the 
field (Figure 8).


6. In the Max Char text box, specify the maximum number 
of characters the field will hold.


Note: Contact your site administrator to confirm that 
anonymous file uploads are allowed before using the file 
field.            


Figure 7 File field example


Figure 8 Form File Field Properties panel


Using checkboxes and radio buttons
Visitors click a checkbox or radio button to make a choice. With checkboxes, visitors can toggle a single option on or 
off, or they can select one or more options from a group of options. With radio buttons, visitors can select only one 
option from a group of options.


To add a checkbox:


1. Click the Checkbox button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the checkbox in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).


3. Enter a label for the checkbox in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 
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4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


The checkbox button appears in your document 
(Figure 9).


5. Click the checkbox (not the label) to select it.


6. In the Checked Value text box in the Properties panel 
(Figure 10), enter a value for the checkbox.


This is the value that will be returned by the form. For 
example, for a checkbox that indicates whether a visitor 
wishes to be on a mailing list, you might set a value of 1 
for yes.


7. For Initial State, select Checked if you want an option to 
appear selected when the form first loads in the visitor’s 
browser. Otherwise, select Unchecked.


Figure 9 Example of checkbox


Figure 10 Form Checkbox Properties panel


To add a group of radio buttons:


1. Click the Radio Group button in the Insert panel to insert 
a group.


The Radio Group dialog box opens (Figure 11).


2. Enter a name in the Name text box.


3. Click the plus (+) button to add a radio button to the 
group.


4. Enter a label and (if you want) a checked value for each 
button.


5. Select an item in the radio button list, and click the up or 
down arrows to reorder the buttons.


6. Select Line Breaks to arrange the radio buttons without 
using a table. Select Table to arrange them in a table. 


7. Click OK.


The group of radio buttons is added to the form 
(Figure 12).


8. Click a radio button (not its label) to select it.


Figure 11 Radio Group dialog box


Figure 12 Example of Radio Group
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9. In the Properties panel, click Checked or Unchecked to 
indicate if this option is selected by default (Figure 13).


Figure 13 Form Radio Button Properties panel


Using list menus and drop-down menus (List/Menu)
Lists and menus allow visitors to select options from a list or pop-up menu. With a list menu, you can display 
multiple options in a confined space and allow visitors to select multiple items. Visitors can select only one item from 
a pop-up menu.


To add a list menu:


1. Click the List/Menu button (Windows) or Select (List/
Menu) button (Mac OS).


The Input Tag Accessibility Attributes dialog box opens.


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the list menu in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore ( _ ).


3. Enter a label for the list menu in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


A list/menu field appears in your document (Figure 14).


5. Click the list/menu field (not its label) to select it.


6. In the Properties panel, for Type, select List (Figure 15).


Figure 14 Example of list/menu field


Figure 15 Form List Menu Properties panel
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7. In the Height text box, enter the number of items the list 
will display.


If this number is less than the total number of items in the 
list, a scroll bar will be displayed.


8. If you want to allow visitors to select more than one item 
in the list, select Allow Multiple for Selections.


9. Click the List Values button to add the list items.


The List Values dialog box opens (Figure 16).


10. With the insertion point in the Item Label text box, enter 
the text you want to appear in the list.


11. In the Value text box, enter data you want sent to the 
server when a visitor selects the item.


If you enter no value, then the form sends the label as the 
value for that item.


12. Press Enter (Windows) or Return (Mac OS).


13. To add another item to the list, click the plus (+) button.


14. When you finish, click OK to close the List Values dialog 
box.


Figure 16 List Values dialog box


Figure 17 Form List Menu Properties panel


15. To have one of the items in the list selected by default, 
select that item in the Initially Selected text box in the 
Properties panel (Figure 18).


The Initially selected item appears in the form 
(Figure 18).


Figure 18 Form list with three items in the list


To add a drop-down menu:


1. Click the List/Menu button (Windows) or Select (List/
Menu) button (Mac OS).


The Input Tag Accessibility Attributes dialog box opens.


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the pop-up menu in the ID text box. 
You may use any combination of letters, numbers, and an 
underscore (_).


3. Enter a label for the pop-up menu in the Label text box. 
You can leave the other properties in the dialog box at 
their default values. 
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4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


A list/menu field appears in your document (Figure 19).


5. Click the list/menu field (not its label) to select it. 


6. In the Properties panel, for Type, select Menu.


7. Click the List Values button to add the menu items.


The List Values dialog box opens (Figure 20).


8. With the insertion point in the Item Label text box, enter 
the text you want to appear in the menu.


9. In the Value text box, enter data you want sent to the 
server when a visitor selects the item.


10. Press Enter (Windows) or Return (Mac OS).


11. To add another item to the menu, click the plus (+) 
button.


12. When you finish, click OK to close the List Values dialog 
box.


13. To have one of the items in the menu selected by default, 
select that item in the Initially Selected text box in the 
Properties panel. 


Note: To see the menu items in operation,  preview this 
page in a browser (Figure 21).


Figure 19 A list/menu field


Figure 20 List Values dialog box


Figure 21 Preview in a browser


Using form buttons
Form buttons control form operations. Use a form button to submit data entered into a form to the server or to reset 
the form. There are two types of form buttons: Standard text buttons are the browser's default button style, with text 
you want to display (typically Submit, Send, or Reset); graphical buttons use the graphic of your choice.


To add a standard text button:


1. Click the Button button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens.


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the button in the ID text box. You may 
use any combination of letters, numbers, and an 
underscore (_).


Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values.
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3. Don’t enter a label for the button. Click OK to close the 
Input Tag Accessibility Attributes dialog box.


Note:  A label would appear next to the button, rather 
than on it, so you don’t want a label for a button form 
element. The text on the button itself is set by the button’s 
value attribute, which you will set in the next step.


A text button appears in the document (Figure 22).


Note: In this example, a Submit button is placed below 
an existing file field.


4. Click the button to select it.


5. In the Properties panel’s Value text box, enter the text you 
want to appear on the button (Figure 23).


Note: It’s a good idea to set the value to whatever the 
button does. “Submit” is a good choice, but you might 
also consider brief phrases in the forms of commands (for 
example, “Send Message” or “Update Profile” or 
“Register”).


6. Select the type of Action (usually this is Submit Form).


Figure 22 Example of text button


Figure 23 Form Button Properties panel


Adding a graphical submit button


You can use images as submit button icons. Using an image to perform tasks other than submitting data requires 
attaching a behavior to the form object by using the Behaviors panel.


To add a graphical submit button:


1. Click the Image Field button in the Insert panel.


The Select Image Source dialog box appears (Figure 24).


2. Locate and select the image to use as the submit button 
icon; then click OK (Windows) or Open (Mac OS).


The Input Tag Accessibility Attributes dialog box opens.


3. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the button in the ID text box. You may 
use any combination of letters, numbers, and an 
underscore (_).


Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values.


Figure 24 Select Image Source dialog box
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4. Don’t enter a label for the button. Click the OK button to 
close the Input Tag Accessibility Attributes dialog box.


The graphical submit button appears in your document 
(Figure 25).


5. Click the button to select it.


6. In the Alt text box, type alternate text you want to appear 
in place of the image for text-only browsers (Figure 26). 
This should match any text displayed on the button.


Note: You can also click the folder icon beside the Src 
text box to select a new image for the button.


Figure 25 Example of graphical submit button 


Figure 26 Form Image Field Properties panel


Using jump menus for navigation
A jump menu is a pop-up menu with options that link to documents or files. It is a form element that acts as 
navigation. You can create links to documents in your website or other websites, e-mail links, links to graphics, or 
links to any file type that can be opened in a browser. Because using this type of menu will cause the browser to 
navigate to another page, don’t mix jump menus with other form elements.


To add a jump menu:


1. Click the Jump Menu button in the Insert panel.


The Insert Jump Menu dialog box opens (Figure 27).


2. Complete the dialog box.


For more information, click the Help button in the dialog 
box.


3. Click OK.


Figure 27 Insert Jump Menu dialog box

How to create forms © 2012 Adobe Systems Incorporated





		How to create forms

		Setting up a form

		Adding form elements

		Using form fields

		Adding text fields

		Adding a file field



		Using checkboxes and radio buttons

		Using list menus and drop-down menus (List/Menu)

		Using form buttons

		Adding a graphical submit button



		Using jump menus for navigation



















	
		
		
			
	
		
		
				

		
			
					
		
				
			
					
		
				
			
					
		
				
			
					
		
				

	

	
		
		
		

	
		






Adobe Flash Professional CS6 Project 7 guide

How to test a Flash project
Testing your Adobe Flash Professional CS6 content before you publish it is very important. This is especially true 
when publishing a movie for multiple screens. For example, may find your movie appears to play fine in a web 
browser, only to discover that it displays incorrectly on the Apple iPad or your mobile phone.


When testing your Flash content, it’s a good idea to perform technical, spelling, grammar, and usability tests. If 
you’re creating a mobile application, you’ll need to perform additional tests of features that are unique to mobile 
applications, including accelerometer, touch-screen, and geolocation functionality. 


Conducting a technical test
A technical test answers questions such as the following:


• Do all the buttons work properly, according to the flowchart?


• Do the text, graphics, animation, and sound match the storyboard?


• Is there proper layout and coordination of text, graphics, animation, and sound as specified in the storyboard?


• Does the content in your mobile application react as expected when the device is rotated, tilted, or laid flat?


• Do touch screen features such as click and drag, press and tap, or two-finger tap work properly?


• Do screen gesture features such as swipe and zoom work properly?


To answer these questions, test the Flash content in each target screen or device. You can test SWF content in the 
Adobe Flash Player or in a web browser. You can test mobile application content by physically connecting your 
computer to a mobile device or by using the Adobe Flash device simulator.


Previewing Flash content in the Adobe Flash Player


To test a SWF file without embedding the content in an HTML file, you can open the movie in the Adobe Flash 
Player.


To preview a SWF in the Adobe Flash Player:


1. Select Control > Test Movie > In Flash Professional.


The SWF file opens in the Flash Player window.


2. Click through the content of your movie to see how it 
runs. Make sure the buttons function properly and that 
the text, graphics, animations, and sound are properly 
coordinated.


3. Close the preview window.


Previewing Flash content in a browser


You can also test how your content will play in a web page by using the Publish Preview command. For example, if 
you plan to publish the content as an HTML file for the web, you can preview the content in an HTML file.


To preview Flash content in a browser:


1. Select File > Publish Preview > HTML.


An HTML document containing the SWF file for your content opens in your default web browser.


2. Click through the content of your movie to see how it 
runs in a web browser. Make sure the buttons function 
properly and that the text, graphics, animations, and 
sound are properly coordinated.


3. Close the browser window.
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Previewing a Flash mobile application by using the Flash device simulator


The Adobe Flash Professional CS6 device simulator enables you simulate running your application on a target mobile 
device. The device simulator is only available when your Flash document publish target is a mobile device, such as 
AIR 3.2 For Android or AIR 3.2 For iOS, as shown in the document Properties panel (Figure 1).


Figure 1 Properties panel


To preview a mobile app in the Flash device simulator:


1. Select File > Test Movie > In AIR Debug Launcher 
(Mobile).


The Simulator appears and your application opens in the Device preview window (Figure 2). You can use the 
sliders or change values in the Accelerometer, Touch And Gesture, and Geolocation sections to simulate 
common mobile application features.


Figure 2 Simulator and Device preview windows


Flash document 
publish target
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2. In the Accelerometer section of the Simulator window, 
change the X, Y, and Z values or drag the sliders to 
simulate rotating and tilting the mobile device 
(Figure 3).


3. Click the Reset button to return to the default values.


4. Expand the Touch And Gesture section in the Simulator 
window and select the Touch Layer option (Figure 4).


You can adjust and test the functionality of touch and 
gesture features, such as tapping and swiping. When you 
position the pointer over the preview window, it has a 
yellow circle attached to simulate a finger-tip (Figure 5). 
You can change the size and pressure by using the values 
at the bottom of the Simulator window.


Figure 3 Simulator, Accelerometer section


Figure 4 Simulator, Touch and Gesture section


Figure 5 Touch And Gesture simulation pointer


Reset 
button
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5. Select the feature you want to adjust or test and use the 
mouse pointer in the preview window to test the selected 
feature.   


Instructions for testing the selected feature appear at the 
bottom of the Simulator window (Figure 6).


6. Expand the Geolocation section in the Simulator window 
(Figure 7).


If your application includes geolocation features, you can 
test those here. For example, you may have an 
application that returns a list of local restaurants based on 
the longitude and latitude (location) of the device. To test 
this feature you would enter test Latitude and Longitude 
values, click Send, and evaluate the results in the Device 
preview window.


7. When you’re finished testing your mobile app, close the 
Simulator and Device preview windows.


Figure 6 Touch And Gesture option instructions


Figure 7 Simulator, Geolocation section
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Proofing the Flash content
There is no better way to proof your Flash content than to read each screen or page carefully several times, checking 
against your storyboard. Read text slowly and aloud to check for spelling and grammar errors. Have someone who is 
less familiar with your project proofread the content too.


You can also use the built-in spell checker. Before Flash will check spelling in a document, you must select your spell 
checking options in the Spelling Setup dialog box (Figure 8). Select Text > Spelling Setup to open the Spelling Setup 
dialog box.


Figure 8 Spelling Setup dialog box


To check spelling:


1. Select Text > Spelling Setup.


The Spelling Setup dialog box appears.


2. Review the options in the dialog box and make any 
changes you like.


3. Click OK to close the Spelling Setup dialog box.


4. Select Text > Check Spelling.


The Check Spelling dialog box opens (Figure 9).


5. Use the Check Spelling dialog box as you would any 
other spell checker. For example, click Change to change 
a misspelled word to the word in the Change To text box. Figure 9 Check Spelling dialog box
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Conducting a usability test
Usability tests are sessions in which you observe visitors as they use your application. Their feedback can help you 
improve the application’s organization, navigation, text, use of color, and other factors. To conduct a usability test, 
you need to do the following:


1. Define the audience for your usability test. This audience should resemble the actual users of your application.


2. Develop your goals for the usability testing project. Start by asking the following questions: What should the 
intended audience be able to get out of the application? What do you want to learn about your application? Are 
there any problem areas you’re especially concerned about, such as an unconventional navigation bar?


3. Create a test script. This is a list of tasks the test’s moderator will ask the tester to accomplish. The script should 
also include feedback and follow-up questions to be posed by the moderator. Phrase the questions asked, tasks 
presented, and opinions sought in a way that allows participants to feel they are contributing to the project rather 
than being tested by the moderator. Ask questions such as Do you like the colors? Can you read the text? Where 
would you click to get information on the company/organization?


4. Recruit your testers. Use the characteristics you initially defined for your audience. In addition to these 
characteristics, choose testers for practicality. For example, they should live close enough to the testing location 
to get there easily. You want to make the process as simple as possible for your testers. For maximum efficiency, 
usability professionals recommend a minimum of eight testers.


5. Provide a comfortable, quiet, private testing environment. Ideally, you should videotape participants. Set up the 
camera so it does not point directly at either the participant or the screen, but instead is angled in a way that 
includes both the screen and some part of the user. In professional software testing, there are usually two 
cameras: one camera records the tester's face and another records the screen. Test moderators then analyze the 
session by viewing both recordings side-by-side so that the tester’s reaction can be compared to what the tester is 
doing.


6. Observe the tester (or analyze the video). Look for latent behavior, behavior of which the participants are 
unaware. Latent behavior is found in body language or facial expressions that participants do not verbalize. An 
example of latent behavior is participants moving the pointer around the screen for a short while, looking for 
something, but not documenting that the item was difficult to find. Another example is participants sighing or 
frowning after clicking a link because they are tired of waiting for an image to load; this behavior indicates that 
an image file is too large, but the participant might not document this occurrence.


7. After completing the tests, compile and review your data. As you do so, keep your participants’ comments 
central. Resist the temptation to impose your own opinion. For example, if several users complain about the 
location of a menu, avoid concluding that “they’ll get used to it once they use it.”


For additional information, go to: http://www.utexas.edu/learn/usability/index.html or en.wikipedia.org/wiki/
Usability_testing
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How to create and edit a CSS rule
You can create and edit a CSS rule in two locations: the Properties panel and the CSS Styles panel. When you apply 
CSS styles to text by using the Properties panel or menu commands, CSS rules are embedded in the head of the 
current document. You can also use the CSS Styles panel to create and edit CSS rules and properties. 


In this guide, you review CSS rules, create and apply a class-style CSS rule by using the Properties panel, and modify 
an HTML tag-style rule by using the CSS Styles panel.


About CSS rules
A CSS formatting rule consists of two parts: the selector and the declaration (or in most cases, a block of 
declarations). The selector is a term (such as p, h1, a class name, or an id) that identifies the formatted element. The 
declaration block defines the style properties. In the following example, h1 (a heading tag) is the selector, and 
everything that falls between the braces ({and }) is the declaration block (defining the properties of the h1 heading):


h1 { 


font-family: Georgia, "Times New Roman", Times, serif;


font-size: 18px;


text-transform: uppercase;


color: #090; 


}


An individual declaration consists of two parts: the property (such as font family) and value (such as Georgia). In the 
previous CSS rule, a particular style has been created for h1 tags; the text for all h1 tags linked to this style will be 18 
pixels in size, Georgia font, uppercase, and bright green (hex value #090). 


The style (which comes from a rule, or a collection of rules) resides in a place separate from the actual text it’s 
formatting—usually in an external style sheet or in the head section of an HTML document. Thus, one rule for h1 
tags can apply to many tags at once (and in the case of external style sheets, the rule can apply to many tags at once on 
many different pages) (Figure 1). In this way, CSS provides extremely easy update capability. When you update a 
CSS rule in one place, the formatting of all the elements that use the defined style is automatically updated to the new 
style.


Figure 1 Updating a CSS rule in one place updates all elements
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There are three main types of CSS:


Class style: Similar to the styles you use in word processing and page layout programs. For example, you may 
want to format all body text in 10-point, Arial, dark green type. You can create a class style with these attributes 
and then apply this style to all body text in your website. Class names must begin with a period and can contain 
any combination of letters and numbers (for example, .myhead1). 


HTML tag style: Applies global formatting to individual HTML tags rather than to individual selections. 
Suppose you want to modify the Heading 1 paragraph style to appear always in purple text. Instead of creating a 
class style and applying it to every heading in the document, you can create an HTML tag style with these 
attributes and apply it to the Heading 1 <h1> tag. In effect, you are redefining the HTML tag.


ID style: A unique identifier (ID) for a style applied to headers, banners, menus, and other elements present in 
only one location in the document. Used once within a document or page. IDs must begin with a pound (#) sign 
and can contain any combination of letters and numbers (for example, #myID1). 


CSS rules can reside in the following locations:


Internal (or embedded) CSS style sheets are collections of CSS rules included in a style tag in the head section of 
an HTML document.


External CSS style sheets are collections of CSS rules stored in a separate, external CSS (.css) file (not an HTML 
file). You link this file to one or more pages in a website with a link or an @import rule in the head section of a 
document. 


Creating a new CSS rule from the Properties panel
In the CSS Properties panel, you can access Targeted Rules and create new ones (Figure 2). A Targeted Rule is a rule 
you are editing in the CSS Properties panel. When you have an existing style applied to text, the rule affecting the 
text’s format appears when you click inside the text on the page. You can also use the Targeted Rule pop-up menu to 
create new CSS rules and new in-line styles or apply existing classes to selected text. 


Figure 2 Properties panel, CSS mode


How you edit your CSS depends on selection level. To access rules that apply to a current selection only, you can use 
the Targeted Rule pop-up menu in the CSS Properties panel. To access all CSS rules for a page, you can use the CSS 
Styles panel. The CSS Styles panel will be reviewed in the next guide.


In this section, you use the Properties panel to create a simple CSS class-style rule to format a block of text.
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To create a new CSS rule in the Properties panel:


1. Start Dreamweaver.


2. Select File > New to create a new document.


The New Document dialog box appears (Figure 3).


3. In the Blank Page category of the New Document dialog 
box, select HTML Page Type to create a plain HTML 
page.


4. In the Layout column, select None. 


5. Click the Create button.


The new HTML page opens.


6. In the Document toolbar, click the Show Code And 
Design Views (Split) button (Figure 4).


Being able to view the code that Dreamweaver generates 
for creating styles will be useful to help you understand 
and write your own CSS syntax later on.


7. Type some text or paste text copied in another application 
in the Design view Document window. 


8. Press Enter (Windows) or Return (Mac OS) to create a 
new paragraph and add additional text.


9. Open the Properties panel (Window > Properties), if it 
isn’t already open, and click the CSS button to display 
the CSS Properties panel (Figure 2).


10. Use the Font menu to change the Font to Georgia, Times 
New Roman, Times, Serif (Figure 5).


The New CSS Rule dialog box appears (Figure 6).


Note: It is a good practice to assign a font combination 
instead of a single font. This ensures that most page 
visitors will view page text the same way. A browser uses 
the first font in the combination that is installed in the 
visitor’s system. If none of the fonts in the combination is 
installed, the browser displays the text as specified by the 
visitor’s browser preferences. 


Figure 3 New Document dialog box


Figure 4 Document window view options


Figure 5 Properties panel Font menu


Figure 6 New CSS Rule dialog box


Show Code And Design Views button
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11. In the Selector Type menu, select Class (Can Apply To 
Any HTML Element) (Figure 7).


12. Click in the Selector Name text box and type .myStyle 
(Figure 8).


Note: CSS rules must begin with a period and cannot 
contain spaces or special characters.


13. In the Rule Definition menu, select (This Document 
Only) (Figure 9).


This tells Dreamweaver to create and store the CSS (style 
sheet) in the current document only. The new style will 
not be available for use in other documents.


To create an external CSS document for your entire 
website, you would choose (New Style Sheet File). This 
is discussed in a later guide.


14. Click OK to close the New CSS Rule dialog box.


The new font is applied to the paragraph that contains the 
insertion point. The name of the style appears in the 
Targeted Rule box in the Properties panel (Figure 10).


Note: Because you didn’t select a specific word or 
character, you can continue to define this rule by 
applying additional formatting.


15. In the Properties panel, change the size to 18.


The font size in the paragraph that contains the insertion 
point changes accordingly.


Figure 7 New CSS Rule dialog box, Selector Type 
options


Figure 8 New CSS Rule dialog box, Selector 
Name options


Figure 9  New CSS Rule dialog box, Rule 
Definition options


Figure 10 Targeted Rule in the Properties panel
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16. Click the Color box in the Properties panel and select a 
new color for the text.


The Properties panel shows the targeted rule (.myStyle) 
and its formatting. The targeted rule is applied to the 
paragraph that contains the insertion point (Figure 11).


You can use this CSS rule to format additional text in 
your document.


Observe in Code view that Dreamweaver stores styles 
created with CSS directly in the head section of the 
document (Figure 12).


Figure 11 Formatted paragraph text


Figure 12 Detail of new CSS rule, Code view
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Applying CSS styles
After you create a CSS rule, you can use it to give your entire document or website a consistent appearance. You can 
apply a CSS rule to text by using the Properties panel.


To apply a CSS style:


1. Click anywhere in the paragraph that doesn’t have the 
new CSS style.


2. In the Properties panel, select myStyle (the new CSS rule 
you just created) from the Targeted Rule menu 
(Figure 13).


The new style is applied to the other paragraph 
(Figure 14).


Note: If you edit the CSS style, both paragraphs will be 
updated automatically and consistently. You will learn 
more about creating and modifying CSS in a later guide.


Figure 13 Targeted Rule menu


Figure 14 CSS style applied to both paragraphs


Using the CSS Styles panel
In the CSS Styles panel you can track the CSS rules and properties affecting a currently selected page element 
(Current mode) or all of the rules and properties available to the document (All mode). A button at the top of the 
panel enables you to switch between the two modes. You can also use the CSS Styles panel to modify CSS properties 
in both All and Current modes. 
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The CSS Styles panel in Current mode


In Current mode, the CSS Styles panel displays three panes: a Summary For Selection pane that displays the CSS 
properties for the current selection in the document, a Rules pane that displays the location of selected properties (or 
a cascade of rules for the selected tag, depending on your selection), and a Properties pane where you can edit CSS 
properties for the rule applied to the selection (Figure 15).


Figure 15 CSS Styles panel, Current mode


The CSS Styles panel in All mode


In All mode, the CSS Styles panel displays two panes: an All Rules pane, and a Properties pane. The All Rules pane 
displays a list of rules defined in the current document as well as all rules defined in style sheets attached to the 
current document. You can use the Properties pane to edit CSS properties for any rule selected in the All Rules pane 
(Figure 16).


Figure 16 CSS Styles panel, All mode


New CSS Rule Edit RuleAttach Style Sheet
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To add a CSS rule by using the CSS Styles panel:


1. Start Dreamweaver.


2. Create a new HTML document.


3. Save and name the Dreamweaver document.


4. Type some text in the document. Make sure no 
formatting is applied to the text (Figure 17).


5. Make sure the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


6. To create a new style, click the New CSS Rule button (+) 
at the bottom of the panel (Figure 15).


The New CSS Rule dialog box appears (Figure 18).


7. In the Selector Type pop-up menu, select Class. 


This option creates a new Class rule.


8. In the Selector Name text box, type a name for the style 
such as .warning.


Note: Class rule names must begin with a period and 
cannot contain spaces or special characters. If you forget 
to type the period, Dreamweaver adds this automatically.


9. In the Rule Definition pop-up menu, select (This 
Document Only) or (New Style Sheet File). 


The option (This Document Only) defines the style as 
part of the document’s internal style sheet. The option 
(New Style Sheet File) defines the style as part of an 
external style sheet.


Note: If you choose to create an external style sheet by 
selecting (New Style Sheet File), you are prompted to 
select a location for the new style sheet (.css) document.


10. Click OK.


The CSS Rule Definition dialog box appears (Figure 19).


11. Select options for Type, such as the following: 


• Select Arial, Helvetica, Sans-serif in the Font-
Family pop-up menu


• Select 12 from the Font-Size pop-up menu, and 
select px (pixels) for the measurement unit.


• Type #CC0033 in the Color text box, or select a 
color in the color picker.


Figure 17 Text with no formatting applied


Figure 18 New CSS Rule dialog box


Figure 19 CSS Rule Definition dialog box, Type 
options 
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12. To change the formatting of text blocks, select Block in 
the Category pane.


The Block category of the CSS Rule Definition dialog 
box opens (Figure 20).


13. In the Letter-Spacing text box, you can make changes 
such as typing 3 and selecting pixels for the measurement 
unit.


This setting adds space between letters. 


14. In the Text-Indent box, you can make changes such as 
typing 5 and selecting pixels for the measurement unit.


15. Click OK.


The CSS Rule Definition dialog box closes.


16. Select the document text.


17. Make sure the Properties panel is open and the HTML 
option is selected.


The Properties panel is docked at the bottom of the 
screen. If it is not open, select Window > Properties.


18. Select warning, or the name of your style, from the Class 
pop-up menu (Figure 21).


19. In the document, deselect the text by positioning the 
mouse pointer next to it and clicking once.


Observe that the format of the text has changed 
(Figure 22).


20. Make sure the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


21. Make sure All is selected in the CSS Styles panel. If no 
styles are listed under <style> in the All Rules pane, click 
the plus (+) symbol (Windows) or the disclosure triangle 
(Mac OS).


Observe that the newly created CSS rule now appears 
under <style> in the All Rules pane, indicating the new 
rule is part of a CSS style sheet. Also observe that if you 
select the style name in the All Rules pane, properties for 
the style appear in the Properties pane.


Figure 20 CSS Rule Definition dialog box, Block 
options 


Figure 21 Text Properties panel


Figure 22 Formatting applied to text
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Edit styles


After you create styles, you can still make changes to them by using the Edit Rule button.


To edit styles:


1. To view a style sheet’s rules, click the plus symbol 
(Windows) or disclosure triangle (Mac OS) beside 
<style> in the All Rules pane of the CSS Styles panel.


Dreamweaver displays the style sheet’s rules 
(Figure 23). 


2. Select the rule or style you want to edit.


3. At the bottom of the CSS Styles panel, click the Edit Rule 
button.


The CSS Rule Definition dialog box for the selected style 
appears (Figure 24).


4. Make formatting changes in the CSS Rule Definition 
dialog box. Then click OK.


The changes take effect immediately. 


If you are editing an external style sheet, the same 
changes are applied to any other documents attached to 
this style sheet.


Figure 23 CSS Styles panel


Figure 24 CSS Rule Definition dialog box


Edit Rule 

How to create and edit a CSS rule © 2012 Adobe Systems Incorporated





		How to create and edit a CSS rule

		About CSS rules

		Creating a new CSS rule from the Properties panel

		Applying CSS styles

		Using the CSS Styles panel

		The CSS Styles panel in Current mode

		The CSS Styles panel in All mode

		Edit styles















Adobe Dreamweaver CS6 Project 3 guide

How to create links
After you’ve set up a Dreamweaver CS6 site to store your website documents and have created HTML pages, you’ll 
want to create different types of links. Understanding the file path between the document you’re linking from and the 
document or asset you’re linking to is essential to creating links.


Each web page has a unique address, called a Uniform Resource Locator (URL). However, when you create a local 
link (a link from one document to another on the same site), you generally don’t specify the entire URL of the 
document you’re linking to; instead, you specify a relative path from the current document or from the site’s root 
folder. 


There are three types of link paths:


• Absolute paths provide the complete URL of the linked document, including the protocol to use (usually 
http:// for web pages). An example is, http://www.oceanviewhighschool.net/index.html. For an image asset, 
the complete URL is something like http://www.oceanviewhighschool.net/images/image1.jpg. You must use 
an absolute path to link to a document or asset in a different site.


• Document-relative paths are usually best for local links (within a website). They’re particularly useful when 
the current document and the linked document or asset are in the same folder and are likely to remain 
together. You can also use a document-relative path to link to a document or asset in another folder by 
specifying the path through the folder hierarchy from the current document to the linked document. For 
example, suppose you have a site with the structure shown in Figure 1:


Figure 1 Example site folder structure


◦ To link from contents.html to hours.html (both in the same folder), use the relative path hours.html.


◦ To link from contents.html to tips.html (in the resources subfolder), use the relative path resources/
tips.html. At each slash (/), you move down one level in the folder hierarchy.


◦ To link from contents.html to index.html (in the parent folder, one level above contents.html), use the 
relative path ../index.html. Two dots moves you up two levels in the folder hierarchy (to the root folder) 
and /index.html moves you back down one level (to the index page).


◦ To link from contents.html to catalog.html (in a different subfolder of the parent folder), use the relative 
path ../products/catalog.html. Here, .. moves you up to the root folder, and /products moves you down to 
the products subfolder, and /catalog.html moves you to the catalog page. When you move files as a 
group—for example, when you move an entire folder, so that all the files inside that folder retain the 
same relative paths to each other—you don’t need to update document-relative links between those 
files. However, when you move an individual file that contains document-relative links, or an individual 
file targeted by a document-relative link, you do need to update those links. (If you move or rename 

© 2012 Adobe Systems Incorporated How to create links 1







Project 3 guide Adobe Dreamweaver CS6


2


files using the Files panel, Dreamweaver updates all relevant links automatically.)


• Site root–relative paths describe the path from the site’s root folder to a document. You may want to use 
these paths if you are working on a large website that uses several servers, or one server that hosts several 
sites. However, if you are not familiar with this type of path, you should stick to document-relative paths.


Using Dreamweaver, you can easily select the type of document path to create for your links.


Four different types of links are discussed in this guide:


• An internal link goes to another page within in your site using a document-relative path.


• An external link goes to another site external to your own using an absolute path.


• A named anchor link goes to a specific position on a page within your site using a combination document-
relative path and anchor link.


• An e-mail link opens a blank e-mail message window in a user’s default e-mail client, with the recipient’s 
address filled in. 


Creating an internal link 
You can use the Properties panel and the Point-To-File icon to create links from an image, an object, or text to another 
document or file (Figure 2). Dreamweaver creates the links to other pages in your site using document-relative paths.


Figure 2 Properties panel


To create a link to another document in your site:


1. Start Dreamweaver.


2. Open an existing file, or create a new, blank page and 
save the file.


Note: Always save a new file before creating a 
document-relative path; a document-relative path is not 
valid without a definite starting point. If you create a 
document-relative path before saving the file, 
Dreamweaver temporarily uses an absolute path 
beginning with file:// until the file is saved; when you 
save the file, Dreamweaver converts the file:// path to a 
relative path.


Point-To-File iconLink text box Browse For File button Target menu
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3. Select text or an image in the Document window’s 
Design view.


4. Open the Properties panel (Window > Properties) and do 
one of the following:


• Drag the Point-To-File icon (target icon) to a 
document in the Files panel (Figure 2).


• Click the Browse For File button to browse to and 
select a file.


• Type the path and filename of the document in the 
Link text box.


Creating an external link
To link to a document outside your site, enter an absolute path, including the protocol (such as http://). You can enter 
these by hand or copy them from a browser address bar and paste them into the Link text box in the Properties panel. 


To add  a link to a page on another site:


1. Select an image or text you want to format as a link.


2. In the Link text box in the Properties panel, type or paste 
the address (URL) of the site to which you want to link.


Note: If you’re linking to a page outside of your site, it is 
a best practice to set the Target menu to 
target="_blank"  (Figure 3). This causes the link to 
open in a new browser window, so that the page doesn’t 
appear to be part of your site.


Figure 3 Properties panel, Target menu


Creating a link to a named anchor
To link to a particular section of a document, first create a named anchor at that location, and then link to the named 
anchor. Named anchors are frequently placed at the beginning of each topic and at the top of a document, so users can 
readily go to these locations. 


To create and link to a named anchor:


1. Position the insertion point at the location on the page 
where you want to define an anchor.


2. Select Insert > Named Anchor. 


The Named Anchor dialog box opens (Figure 4).


3. Enter a short anchor name without any spaces.


4. Click OK.


5. Select an image or text to link to the named anchor.


Figure 4 Named Anchor dialog box
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6. In the Link text box in the Properties panel, type # and 
then type or paste the anchor name. 


In the example code (Figure 5), an anchor named Top is 
placed at the top of the document, and a link to the anchor 
added at the bottom of the page.


Note: Anchor names are case-sensitive.


You can also use any ID attribute as a destination anchor 
so that links can be made to divisions, paragraphs, and 
most other elements.


Figure 5 Named Anchor dialog box


Creating a link to an e-mail address
When a user clicks an e-mail link, a new blank message window opens, using the mail program associated with the 
user’s browser. In the e-mail message window, the To box is automatically updated with the address specified in the 
e-mail link.


To create a link to an e-mail address:


1. In the Document window’s Design view, position the 
insertion point where you want the e-mail link to appear, 
or select the text or image you want to appear as the e-
mail link. 


2. Do one of the following to insert the link:


• Select Insert > Email Link.


• In the Common category of the Insert bar, click the 
Email Link button.


The Email Link dialog box opens (Figure 6).


3. In the Text box, enter text for the link.


If you selected text to format as the link, that text appears 
in the Text box.


4. In the Email text box, type the e-mail address.


5. Click OK to close the Email Link dialog box.


Figure 6 Email Link dialog box
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How to create interactive navigation
There are several options for creating interactive navigation for your web pages: You can easily create:


• graphical buttons and navigation bars in Fireworks, and import them into Dreamweaver. 


• image-based, or HTML, pop-up menus in Fireworks, and place them in a Dreamweaver file.


• rollover images that add visual interest and interaction by using Dreamweaver.


Advanced users may consider using Fireworks to create CSS-based interactive navigation. You can use the CSS 
Properties panel to extract complex CSS3 properties for buttons, such as text, border radius, and gradients..


Creating buttons and navigation bars in Fireworks
Fireworks CS6 enables you to design the look and functionality of buttons, including links and rollover features. 
After you export these buttons from Fireworks, you can import them into Dreamweaver CS6.


Building buttons


In the following steps, you create a button for export into Dreamweaver.


To build a button:


1. Start Fireworks. 


2. Create a new document. 


3. Type 200 pixels for Width and 200 pixels for Height. Type 72 pixels/inch for Resolution.


Note: At the end of this exercise, you will trim the canvas to fit the button. 


4. Save the document in the images folder of your Dreamweaver website.


5. Select Edit > Insert > New Button.


The button editor opens and the Properties panel displays button properties (Figure 1).


Figure 1 Button Properties panel


6. Deselect the Enable option for 9-Slice Scaling Guides in the Properties panel. (To learn about 9-Slice Scaling 
Guides, select Help > Fireworks Help).


Buttons contain four states:


• Up (button untouched)


• Over (pointer over button)


• Down (button being clicked)


• Over While Down (pointer over while 
button held down)


You can view each state by selecting it in the State pop-up menu in the Properties panel (Figure 1). The current 
state of the new button is Up, as shown in the Properties panel.


State pop-up menu9-slice scaling guides Enable/Disable option
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7. Use the Rectangle tool or the Ellipse tool from the Tools panel to draw a shape for the Up state. Make the 
dimensions of the shape fit the size of your navigation bar.


8. To add depth to the button, click the Add Live Filters button in the Properties panel (the plus sign next to Filters), 
and then select a bevel option from the pop-up menu:


• Bevel and Emboss > Inner Bevel


• Bevel and Emboss > Outer Bevel


9. Using the Properties panel, add color to the button. 


10. Use the Text tool to add text to the button, and center-align the text. 


The color and text of the button should match the color and font design of your page.


11. Confirm the Smart Guides are visible and active. If not, select View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.


12. Select the Pointer tool. 


13. Drag the text block until the horizontal and vertical Smart Guides appear so that the text is centered over the 
shape (Figure 2).


Figure 2 Smart Guides


14. Select Window > Object & Layout > Align (Windows) or Window > Align (Mac OS) to open the Align panel.


15. Click the button at the top of the panel, if necessary, until the label Relative To Canvas is visible (Figure 3). 


Figure 3 Align Panel


16. Use the Pointer tool and shift-click to select both the button and the text.


17. Click the Align Horizontal Center and Align Vertical Center buttons.


Later you will duplicate this first button to create the other buttons. A centered shape aligns well with other 
duplicate buttons. If the text is centered, button labels with varying numbers of characters will all be well 
aligned.


Relative To Canvas or 
Relative To Object


Align Vertical CenterAlign Horizontal
Center
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18. Click away from the shape and text to deselect them. In the Properties panel, select Over in the State pop-up 
menu (Figure 4).


Figure 4 Properties panel 


19. In the Properties panel, click Copy Up Graphic to copy the Up graphic to the Over button state (Figure 4). 


This saves you time and helps keep the look and position of the button consistent.


20. Decide how you want the button to look when the pointer rolls over the button. Then change the copied graphic 
by modifying the color or effects of the text or the shape.


21. Click away from the shape and text to deselect them. In the Properties panel, select Down in the State pop-up 
menu.


22. Click Copy Over Graphic to copy the Over graphic to this button state.


23. Decide how you want the button to look when visitors click the button. Add effects such as darkening the color.


24. (Optional) You can add a drop shadow to the shape by clicking Add Filters in the Properties panel, and then 
selecting Shadow And Glow > Drop Shadow.


For this project, you will skip the Over While Down state.


25. Click away from the shape and text to deselect them. In the Properties panel, select Active Area in the State pop-
up menu (Figure 4).


The active area of the button is shown by green shading and red lines. This shading indicates the area visitors can 
click to activate the button (Figure 5).


Figure 5 Button Active Area selected 


26. When you are satisfied with the states of your button in the Button Editor, click Page 1 at the top of the screen 
(Figure 6) to close the Button Editor and return to the Page 1 canvas.


Your button appears on the Fireworks Page 1 canvas and in the Document Library panel. 


Figure 6  Fireowrks Button Editor


State pop-up menu
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27. Click the button to select it. In the Link text box in the Properties panel, enter the name of a web page to link to 
this button (Figure 7).


Figure 7 Properties panel with Link text box


28. In the Alt text box, enter an alternative text label for the button.


Alternative text is displayed in place of the image when visitors elect not to display images in their browsers. 
Such text can also be voiced by screen readers for visitors who use them. Typically, alternative text for a button 
should be the same as the text displayed on the button.


29. Select Modify > Canvas > Fit Canvas to fit the canvas to the size of your button.


30. Select File > Save to save the new button.


Copying buttons and making the navigation bar


In the following steps, you duplicate the button you created in the previous steps to make the navigation bar.


To copy the buttons and make the navigation bar:


1. Change the size of the canvas to accommodate all the 
buttons on your navigation bar. Select Modify > Canvas 
> Canvas Size and edit the value for height or width in 
the Canvas Size dialog box.


If you have four buttons, for example, multiply the height 
or width of the first button by four (depending on 
whether your navigation bar is vertical or horizontal).


2. Select the first button. Move it to the top (or to the left 
edge) of the canvas. Select Edit > Clone.


A new instance of the button appears on top of the 
original button.


3. Drag the new button instance below  (or to the right of) 
the original button. You can also use the arrow keys to 
move the button.


4. Repeat steps 2 and 3 as many times as necessary to create 
the rest of your navigation bar (Figure 8). 


5. Click the second button and use the Properties panel to 
edit it. In the Text box, change the text to the name of the 
second button. Edit the information in the Link text box 
and the Alt text box as appropriate for this button.


6. Repeat step 5 for the remaining buttons (Figure 9).


7. To fit the canvas to your navigation bar, select Modify > 
Canvas > Fit Canvas.


8. Save the file.


Figure 8 Cloned buttons


Figure 9 Buttons with edited text labels
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Exporting a navigation bar for use in Dreamweaver


Fireworks enables you to save interactive graphics (a button, for instance) as HTML so you can import working 
buttons into a Dreamweaver document.


To export a navigation bar for use in Dreamweaver:


1. Choose File > Export.


The Export dialog box opens (Figure 10).


2. Navigate to the folder in your local root folder where you 
want to save the navigation bar.


3. Give the navigation bar file a short descriptive name.


4. Make sure the Selected Slices Only option is not selected.


5. Make sure HTML And Images is selected in the Export 
pop-up menu.


6. Make sure the Include Areas Without Slices option is 
selected.


7. Select the Put Images In Subfolder option.


8. Click Save (Windows) or Export (Mac OS).


9. Save the Fireworks document, and close Fireworks.
Figure 10 Export dialog box


Inserting the navigation bar into a Dreamweaver document


Now that you’ve created the navigation bar, you can insert it into a Dreamweaver document. You do so by using an 
option in the Insert panel.


To insert the navigation bar into a Dreamweaver document:


1. Start Dreamweaver.


2. Open the page in which you want to insert the navigation 
bar and save the Dreamweaver document before 
importing.


3. Position the insertion point where you want the 
navigation bar to appear.
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4. In the Common category on the Insert panel, click the 
Images pop-up menu and select Fireworks HTML 
(Figure 11).


The Insert Fireworks HTML dialog box opens 
(Figure 12).


5. In the Insert Fireworks HTML dialog box, click the 
Browse button, and then locate and select your 
navigation bar HTML file. 


6. Click Open.


7. In the Insert Fireworks HTML dialog box, click OK.


The navigation bar appears on the page.


8. To edit a button, select the button and then use the 
Properties panel to change settings, such as the link or 
alternative text.


9. Check that the link address and the alternative text label 
are correct for each button.


10. Save the Dreamweaver document.


11. Select File > Preview In Browser and choose a browser 
from the submenu to test button rollover functions in a 
browser (Figure 13).


Figure 11 Insert panel


Figure 12 Fireworks HTML dialog box


Figure 13 Page previewed in browser
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How to create pop-up menus
Pop-up menus are menus that are displayed in a browser when a site visitor moves the pointer over or clicks a trigger 
image. Items in a pop-up menu can have URL links attached to them for navigation.


You can use pop-up menus to display multiple links within a small space. They provide navigation flexibility without 
long download times. You can define the appearance of the pop-up menu so it matches the overall look and feel of 
your website. A pop-up menu is similar to a table: each menu item is like a table cell. You can customize the menu by 
choosing from a selection of font types, cell colors, and background image styles.


Creating pop-up menus in Fireworks CS6


In the following steps, you will first create entries for a pop-up menu, then set the menu’s appearance and position.


To create entries for a pop-up menu:


1. Start Fireworks CS6.


2. Open or create the image that will trigger the pop-up 
menu.


Note: The trigger image may be a text object or a 
graphic. Be sure to set the canvas dimensions to account 
for the size of the pop-up menu; you can trim the canvas 
after you build the menu to adjust the size.


3. Click the trigger image to select it.


4. Select Edit > Insert > Rectangular Slice to insert a slice 
over the trigger image (Figure 14).


Note: To create a slice that is not rectangular, you can use 
the Polygon Slice tool. See Fireworks Help for more 
information.


When a slice is selected, a circle with cross hairs appears 
in the center of the slice. This is called a behavior handle.


5. Click the behavior handle and select Add Pop-up Menu 
from the context menu (Figure 15).


Figure 14 Sliced image


Figure 15 Behavior handle context menu


Behavior handle
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The Pop-up Menu Editor appears (Figure 16).


6. In the Content tab of the Pop-up Menu Editor, if the 
insertion point is not already in the Text box, click twice 
in that box. Enter the text for a menu item. Click in the 
Link box, and enter the name of the file it links to.


7. To add a new menu item, click the Add Menu (+) button 
and repeat step 6 (Figure 17).


8. To delete a menu item, select the item and click the 
Delete Menu (–) button.


9. After you have entered all the menu items, click Next or 
click the Appearance tab.


Figure 16 Pop-up menu editor


Figure 17 Pop-up Menu Editor with menu entries


Setting the appearance of a pop-up menu


On the Appearance tab of the Pop-up Menu Editor, you can format the text, apply graphic styles to the Over and Up 
states, and select vertical or horizontal orientation for the pop-up menu.


To set the appearance of a pop-up menu:


1. Continue where you left off in the previous task.


2. Select either HTML or Image for Cells (Figure 18).


Note: HTML sets the menu’s appearance using only 
HTML code; this setting produces pages with smaller file 
sizes. Image gives you a selection of graphic image styles 
to use as the cell background; this setting produces pages 
with larger file sizes.


3. Select Vertical Menu or Horizontal Menu from the 
Orientation pop-up menu near the top of the Appearance 
tab.


Settings you choose immediately appear in the preview 
window near the bottom of the Appearance tab.


4. Select font type, font size, and text styles for your menu 
items.


5. Select text and background (Cell) colors for Up State and 
Over State.


These states are similar to button states. The Up state of a 
menu item is its default appearance in the menu. The 
Over state is the appearance of the menu item when the 
pointer passes over it.


Figure 18 Appearance tab of Pop-up Menu Editor


Delete Menu button


Add Menu button
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6. If Image is selected as the cell type, select a graphical 
style for the Up state and the Over state (Figure 19).


7. Click Next or click the Advanced tab (Figure 20) if you 
want to change cell or border attributes.


Typically you can use the default settings in the 
Advanced tab.


Figure 19 Graphical style for cells


Figure 20 Advanced tab of Pop-up Menu Editor


To set the position of a pop-up menu:


1. Continue where you left off in the previous task.


2. Click Next or click the Position tab in the Pop-up Menu 
Editor (Figure 21).


3. Click a Menu Position button to position the pop-up 
menu relative to the trigger slice.


Note: Alternatively, you can enter X and Y coordinates. 
Coordinates of 0, 0 align the upper left corner of the pop-
up menu with the upper left corner of the trigger slice.


4. Click Done. Then save your file.


5. To preview your pop-up menu, select File > Preview In 
Browser and select a browser from the submenu. Figure 21 Position tab of Pop-up Menu Editor
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Editing a pop-up menu


You edit a pop-up menu through the same context menu with which you created the pop-up menu.


To edit a pop-up menu:


1. To edit a pop-up menu, select the slice to which your 
menu is attached and double-click the pop-up menu’s 
blue outline in the workspace, or click the behavior 
handle and select Edit Pop-up Menu (Figure 22).


The Pop-up Menu Editor opens.


2. Set options in the Pop-up Menu Editor just as you did 
when you created your pop-up menu.


Figure 22 Behavior handle context menu


Exporting a pop-up menu for use in Dreamweaver CS6


To save the pop-up menu so it will be active on your website, export the document as HTML.


To export a pop-up menu:


1. While still in Fireworks, trim any excess canvas 
surrounding your image by choosing Modify > Canvas > 
Trim Canvas.


2. Save the file.


3. Select File > Export.


The Export dialog box opens.


4. Navigate to your local root folder.


5. Give the pop-up menu a short, descriptive name.


6. Select HTML And Images in the Export menu.


7. Make sure the option Put Images In Subfolder is selected.


Note: Putting all the exported image files in a subfolder 
is a good way to manage those files.


8. Save (Windows) or Export (Mac OS).


9. Save your document and close Fireworks.


Importing a pop-up menu into Dreamweaver


You insert a pop-up menu into Dreamweaver as you would anything else, by using the Insert panel.


To insert a pop-up menu into Dreamweaver:


1. Start Dreamweaver.
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2. Open the document into which you want to import the 
pop-up menu.


3. Position the insertion point where you want the pop-up 
menu to appear. You can also place the pop-up menu 
within a div for more precise positioning of the menu.


4. Make sure the Common category is selected in the Insert 
panel. Click the down arrow on the Images button, and 
select Fireworks HTML (Figure 23).


The Insert Fireworks HTML dialog box opens 
(Figure 24).


5. Click Browse, select the pop-up menu HTML file, and 
click Open.


Note: The Images subfolder contains the sliced images 
for your pop-up menu.


6. OK to close the Insert Fireworks HTML dialog box.


The pop-up menu is inserted into your Dreamweaver 
document.


7. Save your Dreamweaver document. 


8. Select File > Preview In Browser and select a browser 
from the submenu to test the menu and the links for the 
menu items (Figure 25).


Figure 23 Insert panel


Figure 24 Fireworks HTML dialog box


Figure 25 Testing a pop-up menu


How to create rollover images
A rollover is an image that changes when the pointer moves across it. A rollover actually consists of two images: the 
primary image (the image displayed when the page first loads) and the rollover image (the image that appears when 
the pointer moves over the primary image).


Rollover images add highlighting or design effects by drawing viewer attention when the images are swapped. One 
example is a button that highlights or changes color when the pointer passes over it.


Creating a rollover image


You create a rollover image by inserting it from the Insert panel and then setting options in the Insert Rollover Image 
dialog box.


To create a rollover image:


1. Open Dreamweaver CS6 and open the document in 
which you want to create a rollover image.
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2. Make sure the Common category is selected in the Insert 
panel. Click the down arrow on the Images button and 
select Rollover Image from the pop-up menu 
(Figure 26).


The Insert Rollover Image dialog box opens (Figure 27).


3. Use the Insert Rollover Image dialog box to set up your 
rollover:


• Image Name: Type a name for the rollover image.


• Original Image: Click Browse and select the image 
to be displayed when the page loads.


• Rollover Image: Click Browse and select the image 
to be displayed when the pointer rolls over the 
original image.


• Alternate Text: Type the text you want to appear as 
alternate text for the image.


• When Clicked, Go To URL: Click Browse and select 
the file (or type the path to the file) to be opened 
when the image is clicked.


4. Click OK to close the dialog box.


5. Save the page.


6. Select File > Preview In Browser and select a browser 
from the submenu to preview the rollover image and test 
the link.


Figure 26 Insert panel


Figure 27 Insert Rollover Image dialog box


Figure 28 Testing a rollover image: up (top) and 
over (bottom)
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Developing interactive buttons using CSS
As CSS3 gains wider support in modern devices and browsers, design elements such as interactive buttons can now 
be constructed entirely in CSS. Advanced users may prefer to create CSS-based buttons from a Fireworks design. 
You can use the CSS Properties panel to extract a design object’s properties (rounded corners, opacity, and more) and 
map the properites to HTML elements by using CSS in Dreamweaver. 


In this section, you use Fireworks and Dreaweaver to build a simple set of CSS-based navigation buttons. Fireworks 
is used to create a shape, add text, and add a drop-shadow effect. Use the CSS Properties panel to extract the shape’s 
design elements, and add them to an HTML element in Dreamweaver.


Visit the Adobe Developer Center at www.adobe.com/devnet.html to learn more about how to extend and refine your 
CSS-based interactive navigation.


To create CSS-based interactive buttons:


1. Create a new document in Fireworks and make it 200 
pixels by 200 pixels, and set the Resolution to 72 pixels/
inch.


2. Use the Rectangle tool or the Ellipse tool from the Tools 
panel to draw a shape for the button. Make the 
dimensions of the shape fit the size of your navigation 
bar.


3. Use the Gradient Fill button to add a Gradient Shape and 
set fill colors.


4. Use the Properties panel to add color and gradient to the 
button.


5. Use the Text tool to add text to the button. 


6. Use the Smart Guides to center the text over the button 
shape.


In Figure 29, the sample button is a 145x35 pixel 
rounded rectangle with a red radial gradient. Text is 
Verdana, Bold, with font size set to 15 and color set to 
white. 


7. Choose the Pointer tool from the Tools panel and select 
the button shape on the canvas.


8. Select Window >  CSS Properties.


The CSS Properties panel opens and displays the list of 
CSS properties for the selected object (Figure 30).


You will return to the CSS Properties panel after the 
HTML elements have been created in Dreamweaver. 


9. Start Dreamweaver and select File > New.


10. In the New Document dialog box, select Blank Page, 
select HTML for Page tyep, and select <none> for 
Layout. Click Create.


Figure 29 Sample Fireworks button design


Figure 30 CSS Properties panel 


Copy All button
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11. Save the new document.


12. Click the Split button in the Document toolbar 
(Figure 31).


Code view and Design view are visible in the document 
window.


You will work in Code view in the next steps. 


13. In Code view, locate the <body> tag, place the insertion 
point at the end of the opening <body> tag, and press 
Enter (Windows) or Return (Mac OS).


Figure 31 Dreamweaver Document toolbar


14. Enter (or copy and paste) the following code between the <body> tags in the Code view. If you enter the code 
directly from the keyboard, watch for code hints as you type. You can save work by double-clicking the code 
pieces you need from the lists that appear.
<ul>
   <li class="button"><a href="#">Home</a></li>
</ul>


15. Copy the complete list item Home code inside the <ul> tags and paste it three times before the closing </ul> 
tag (Figure 32).


Figure 32 Sample code


16. Replace "Home" in the three copies with "Directions", "Hours", and "Facilities", respectively (Figure 33).


This code creates an unordered list, that is associated with a button class that is not yet defined. Each list item is 
a link.


Figure 33 Sample code


17. Open the CSS Styles panel (Window > CSS Styles). If a message reminds you that you've made coding changes, 
click the Refresh button in the CSS Styles panel.
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18. In the CSS Styles panel, click the New CSS Rule button 
(Figure 34). 


The New CSS Rule dialog box opens (Figure 35).


19. Open the Selector Type menu and select Class (Can 
Apply To Any HTML Element).


20. Type .button in the Selector Name text box. 


21. Click OK to close the New CSS Rule dialog box.


The CSS Rule Definition dialog box opens.


22. Click OK to close the CSS Rule Definition dialog box 
without setting any style options. 


You will use content from the Fireworks CSS Properties 
panel to apply style options to the new empty button rule.


23. Return to Fireworks and open the CSS Properties panel.


24. Select the button shape and click the Copy All button 
(Figure 30).


The CSS properties for the graphic are extracted and 
saved to the clipboard.


25. Switch to Dreamweaver.


26. In Code view, locate the <style> tag in the head section, 
place the insertion point between the open and closing 
curly brackets that follow the .button selector,  and press 
Enter (Windows) or Return (Mac OS).


27. Select Edit > Paste to insert the saved CSS properties into 
the button selector.


28. Click in the Design view to refresh.


The background of the list items in Design view changes. 


29. Click the Live button in the Document toolbar at the top 
of the Document window to preview the initial changes 
to the button list (Figure 36).


The button design still needs a bit of refinement.


30. Switch to Fireworks, select the button text, and click the 
Copy All button in the CSS Properties panel.


31. Return to Dreamweaver, locate the closing curly bracket 
of the button selector, and paste the contents of the 
clipboard inside the bracket.


32. In Code view, enter in the following code at the end of 
the button selector declaration:
list-style: none;
This removes the default list marker.


Figure 34 CSS Styles panel


Figure 35 New CSS Rule dialog box


Figure 36 Shape attributes applied to list items


New CSS Rule


Selector text box Selector Type menu
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33. Click in the Design view to refresh.


Notice the CSS styles are applied to the text in the Design 
view (Figure 37). However, the link text has assumed the 
default color for link attributes. This can be easily fixed 
by redefining the link attribute CSS style. 


Figure 37 Text attributes applied to list items


34. Enter (or copy and paste) the following code between the .button closing curly bracket, and the closing </
style> tag (Figure 38):
a:link {color: #ffffff; text-decoration:none;}
a:hover, a:active, a:focus {text-decoration: underline;}
a:visited {color: #ffffff;}


Figure 38 Sample code


35. Click in the Design view to refresh.


The link attributes are applied to the list items 
(Figure 39).


36. Test the items in the Live view to see how the text 
becomes underlined when the mouse hovers over a link.


The other selectors proviede a keyboard navigator the 
same hover experience as the person using a mouse.


The list item buttons remain close together.  


37. In Code view, place the insertion point after list-
style:none; at the end of the .button selector 
definition, and press Enter (Windows) or Return (Mac 
OS).


A list of code hints appears. As you type characters in 
Code view, you will see a list of candidates that 
automatically complete your entry.


38. Type marg. A list of options appears (Figure 40).


39. Double-click margin-top from the list of available 
options.


40. Type 10px;. 


The top margin for the list item is now set to 10 pixels. 
The semicolon closes the property-value pair.


Figure 39 Link attributes applied to list items


Figure 40 Code hints
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41. Click in the Design view.


The list item buttons are now separated by 10 pixels that's 
been added to the top margin of each button (Figure 41).


42. Select File > Preview In Browser, and then select a 
browser to preview the interactive CSS buttons in a web 
browser (Figure 42).


Figure 41 Margin attribute applied to list items


Figure 42 Test buttons in web browser
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How to create lists
You can create numbered (ordered) lists, bulleted (unordered) lists, and definition lists from existing text or from new 
text as you type in the Document window. Definition lists do not use leading characters such as bullet points or 
numbers and are often used in glossaries or descriptions. Lists can also be nested. Nested lists are lists that contain 
other lists. For example, you might want an ordered or bulleted list nested within another numbered or unordered list.


Creating lists
In Adobe Dreamweaver CS6, you can easily create lists to organize information. You can use the Properties panel to 
set list style (Figure 1). To set the appearance of an entire list or for an individual list item, use the List Properties 
panel. You can set number style, reset numbering, or set bullet style options for individual list items or for the entire 
list.


Figure 1 Properties panel


To create a new list:


1. Open a document in Dreamweaver.


2. Place the insertion point where you want to add a list, 
then do one of the following:


• In the HTML Properties panel, click either the 
Unordered  List button or the Ordered List button 
(Figure 1).


• Select Format > List and select the type of list 
desired—Unordered (bulleted) List, Ordered 
(numbered) List, or Definition List (Figure 2).


The leading character for the specified list item 
appears in the Document window.


3. In turn, type the text for a list item, and then press Enter 
(Windows) or Return (Mac OS) to create another list 
item.


4. To complete the list, press Enter twice (Windows) or 
press Return twice (Mac OS).


Figure 2 Format menu


Unordered List


Ordered List Outdent


Indent
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To create a list using existing text:


1. Select a series of paragraphs to make into a list.


Each paragraph will become an item in the new list.


2. In the HTML Properties panel, click the Unordered or 
Ordered List button, or select Format > List and select the 
type of list desired—Unordered List, Ordered List, or 
Definition List.


The list is created (Figure 3). Figure 3 Create an ordered list


To create a nested list:


1. Select the list items you want to nest.


2. In the HTML Properties panel, click the Indent button, or 
select Format > Indent.


Dreamweaver indents the text and creates a separate list 
with the original list’s HTML attributes (Figure 4).


3. Apply a new list type or style to the indented text by 
following the same procedure used above.


Figure 4 Create a nested list 


To set list properties for an entire list:


1. In the Document window, create at least one list item. 
The new style will automatically apply to additional 
items you add to the list.


2. With the insertion point in the text of the list item, select 
Format > List > Properties to open the List Properties 
dialog box (Figure 5).


3. Set the options you want to define the list:


List Type specifies list properties while List Item 
specifies an individual item in a list. Use the pop-up 
menu to select a Bulleted List, Numbered List, or 
Definition List. Depending on the List Type you select, 
different options appear in the dialog box.


Style determines the style of numbers or bullets used for a 
numbered or bulleted list. All items in the list will have 
this style unless you specify a new style for items within 
the list.


Start Count sets the value for the first item in a numbered 
list.


4. Click OK to set the choices.


Figure 5 List Properties dialog box
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How to make websites accessible
Creating accessible web pages has never been more important than today. With the adoption of accessibility standards 
in the United States, Canada, the European Union, Australia, Japan, and other countries, designers and developers 
need to ensure that people with disabilities can access the contents of websites and web applications, as well as the 
authoring tools used to create them.


Accessibility refers to making websites and web products usable for people with visual, auditory, motor, and other 
disabilities. Examples of accessibility features for software products and websites include screen reader support, text 
equivalents for graphics, keyboard shortcuts, change of display colors to high contrast, and so on. Dreamweaver 
provides tools that make it accessible to use and tools that help you author accessible content.


Dreamweaver enables designers and developers to create accessible pages that contain useful content for screen 
readers and comply with federal government guidelines. For example, dialog boxes prompt you to enter accessibility 
attributes—such as text equivalents for an image—when you insert page elements. Then, when the image appears on 
a page for a user with visual disabilities, the screen reader voices the description.


Note: For more information about two significant accessibility initiatives, see the World Wide Web Consortium Web 
Accessibility Initiative (www.w3.org/wai) and Section 508 of the U.S. Federal Rehabilitation Act 
(www.section508.gov). 


No authoring tool can automate the development process. Designing accessible websites requires you to understand 
accessibility requirements and make ongoing decisions about how users with disabilities interact with web pages. The 
best way to ensure that a website is accessible is through deliberate planning, development, testing, and evaluation.


Accessibility preferences options
To create accessible web pages, page elements need to be marked up with information for assistive technology, such 
as screen readers. For example, each image on a page should be given a text equivalent, called alternative text (alt 
text), that a screen reader voices to users in place of the image (Figure 1).


Figure 1 Displaying alternative text


Designers often overlook accessibility features such as alt text when creating websites, but Dreamweaver CS6 
enables you to set preferences that prompt you to provide accessibility information as you’re building the page. By 
activating options in the Preferences dialog box, you'll be prompted to provide accessibility-related information for 
form objects, frames, media, images, and tables as each element is inserted in a page. 

© 2012 Adobe Systems Incorporated How to make websites accessible 1







Project 2 guide Adobe Dreamweaver CS6


2


To set the accessibility preference, choose Edit > Preferences (Windows) or Dreamweaver > Preferences (Mac OS) 
and select the Accessibility category in the Preferences dialog box (Figure 2).


Figure 2 Dreamweaver Preferences dialog box, Accessibility category


For example, if you choose the Images option in the Show Attributes list, you are prompted (Figure 3) to provide the 
alt text equivalent and a description for each image as you insert it.


Figure 3 Image Tag Accessibility Attributes dialog box
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Creating accessible tables and forms presents some challenges, but Dreamweaver CS6 simplifies the process. For 
example, as you insert a data table within Dreamweaver CS6, you're immediately prompted to provide summary 
information, a caption, and the position of heading cells in the table (Figure 4). Incidentally, by adding identifying 
heading cells—an important but often overlooked design step—you make it significantly easier for assistive 
technology users to navigate tables. 


Figure 4 Table dialog box


Creating accessible forms is also easy with Dreamweaver CS6. When you select the Form Objects option in the 
Preferences dialog box, you're prompted to provide a label for each form object, along with a shortcut key and the tab 
order position (Figure 5). Specifying the label allows assistive technology users to understand the purpose of each 
form object as they complete the form.


Figure 5 Input Tag Accessibility Attributes dialog box
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Accessibility validation
There are a number of third-party web accessibility evaluation tools that you can use to validate your completed 
websites. The W3C Web Accessibility initiative provides a comprehensive list of these tools at http://www.w3.org/
WAI/RC/tools/.


Accessible templates
Dreamweaver CS6 includes several templates designed for accessibility. These templates are visually balanced, as 
well as accessible to people with disabilities (Figure 6). They provide you with a fast and easy way to create exciting, 
engaging, and accessible content. 


Figure 6 Dreamweaver sample HTML template


How to meet accessibility requirements
The W3C Web Accessibility Initiative has developed a quick reference list Web Content Accessibility Guidelines 2.0 
requirements and techniques.


1. Text Alternatives: Provide text alternatives for any non-text content so that it can be changed into other 
forms people need, such as large print, braille, speech, symbols or simpler language.


2. Time-based Media: Provide alternatives for time-based media.


3. Adaptable: Create content that can be presented in different ways (for example simpler layout) without 
losing information or structure.


4. Distinguishable: Make it easier for users to see and hear content including separating foreground from 
background.


5. Keyboard Accessible: Make all functionality available from a keyboard.
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6. Enough Time: Provide users enough time to read and use content.


7. Seizures: Do not design content in a way that is known to cause seizures.


8. Navigable: Provide ways to help users navigate, find content, and determine where they are.


9. Readable: Make text content readable and understandable.


10. Predictable: Make Web pages appear and operate in predictable ways.


11. Input Assistance: Help users avoid and correct mistakes.


12. Compatible: Maximize compatibility with current and future user agents, including assistive technologies.

© 2012 Adobe Systems Incorporated How to make websites accessible 5
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Overview of the Adobe Dreamweaver CS6 workspace
You can access Adobe Dreamweaver CS6 tools, commands, and features by using menus or by selecting options 
from one of the Insert panels or other Dreamweaver panels. The most commonly used areas of the Dreamweaver 
workspace (Figure 1) are the Document window, the Insert panel, the Properties panel, and the other panels.


The Document window displays the current document as you create and edit it. The Insert panel contains buttons for 
creating and inserting objects such as images, tables, layers, and frames you might want to add to your web pages. 
The Properties panel displays properties for the selected object or text and enables you to modify those properties. 


The Document window and panels
The Dreamweaver workspace (Figure 1) enables you to view documents and object properties. The workspace 
places many of the most common operations in toolbars so that you can quickly make changes to your documents.


Figure 1 Dreamweaver workspace, Split view (Code and Design)


Switching between views


Dreamweaver enables you to work in a variety of views. Lay out a page graphically in Design view, work directly 
with the underlying code, split the screen into both Code and Design views, or edit in Live view which presents a 
non-editable browser-based rendering of the document as you create and edit it. Change views by using the view 
buttons.


• Code view a hand-coding environment for writing and editing HTML, JavaScript, server-language code—
such PHP or ColdFusion Markup Language (CFML)—and any other kind of code. 


Application bar Document toolbar Workspace switcher Insert panel


Files panel


Document window


Design viewCode viewProperties panel Assets 
panel


View buttons


Panel groups
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• Design view a design environment for visual page layout, visual editing, and rapid application development. 
In this view, Dreamweaver displays a fully editable, visual representation of the document, similar to what 
you would see when viewing the page in a browser.


• Code and Design view (Split view) both Code view and Design view for the same document in a single 
window.


There are also two additional views related to code that dynamically changes the page--that is, code that will change 
as users interact with the page:


• Live view similar to Design view, a more realistic representation of what your document will look like in a 
browser. Live view enables you to interact with the document exactly as you would in a browser. Live view 
is not editable. However, you can edit in Code view and refresh Live view to see your changes.


• Live Code view only available when viewing a document in Live view. Live Code view displays the actual 
code that a browser uses to execute the page, and can dynamically change as you interact with the page in 
Live view. Live Code view is not editable.


To select a view, click its button in the Document toolbar (Figure 1).


Dreamweaver workspaces


You can also manage panels by using workspaces. Workspaces are pre-arranged panel settings optimized for specific 
tasks or work styles. 


To switch between workspaces:


1. Select a new workspace, such as the Designer Compact 
workspace, from the workspace switcher in the 
Application bar (Figure 2).


The panels are rearranged.


Figure 2 Workspace switcher


To create a new workspace:


1. Make changes to an existing workspace, such as by 
opening new panels or closing open panels.


2. Choose Window > Workspace Layout > New Workspace.


The New Workspace dialog box (Windows) or Save 
Workspace dialog box (Mac OS) opens (Figure 3).


3. Enter a name for the new workspace.


4. Click OK.


The workspace is now available in the workspace 
switcher and the Workspace Layout menu.


Figure 3 New Workspace dialog box
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Panels


Depending on the selected workspace, the right side of the workspace displays panels. 


Panel groups


Panels are often arranged into groups. Panel groups are panels that are docked together. For example, the Files and 
Assets panels are docked together by default in the Designer workspace (Figure 4).


Figure 4 Panel group


• To move a panel into a group, drag the panel’s tab to the highlighted drop zone in the group.


• To rearrange panels in a group, drag a panel’s tab to a new location in the group.


• To remove a panel from a group so that it floats freely, drag the panel by its tab outside the group.


• To move a floating group, drag the title bar (the area above the tabs) (Figure 5).


Working with Panels


• Opening and closing panels:To open a panel, select it from the Window menu. To close a panel, do one of 
the following:


◦ Click the Close button at the top of a floating panel.


◦ Choose Close from the panel menu.


◦ Deselect the panel in the Window menu.


• Moving panels and panel groups. To move a panel, drag it by its tab. To move a panel group or a stack of 
floating panels, drag the title bar.To dock a panel, drag the panel until the border changes to blue. Release the 
mouse to dock the panel. To undock the panel, drag it away from the left border.


• Minimizing or maximizing panels: To minimize or maximize a panel, double-click the tab or the tab area (the 
empty space next to the tab).


• Collapsing panels: Collapsing a panel makes it available as an icon (Figure 5). To collapse or expand a 
panel, do one of the following:


◦ Click the double arrow in a floating panel's title bar.


◦ Double-click the tab area.


◦ Double-click the title bar of a floating panel or group.


Figure 5 Collapsed panel


Expand panels/Collapse To Icon buttonTitle bar


Close panel
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• Docking and undocking panels: As you move panels, you see blue highlighted drop zones. Drop zones are 
areas where you can dock the panel. If you drag to an area that is not a drop zone, the panel floats freely in 
the workspace.


• Resizing panels: To resize a panel, drag either its left or bottom border. All panels have a minimum size 
beyond which they cannot be minimized. Panels can be maximized to fill your screen.


Commonly used panels


The Files panel displays the organization of your site and enables you to open files for editing, to publish files to a 
server, or to delete files.


The Assets panel contains all site assets, elements used in a site, such as images, colors, or movies. The Assets panel 
provides two ways to view assets:


• The Site list shows all of the assets in your site.


• The Favorites list shows only the assets you’ve chosen to include in the Favorites list.


The Insert panel
The Insert panel contains buttons for creating and inserting objects such as tables, images, and links. The buttons are 
organized into several categories (Common, Layout, Forms, Data, and more), which you can choose from the 
Category pop-up menu. Additional categories appear when the current document contains server code, such as ASP 
or CFML documents.


Common category in the Insert panel 


The Common category in the Insert panel contains buttons for inserting the most commonly used objects (Figure 6).


Figure 6 Common category in the Insert panel


Hyperlink: Insert a hypertext link.


Category popup menu
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Email Link: Insert a link to an e-mail address.


Named Anchor: Insert a link to a specific location on a page.


Horizontal Rule: Insert a horizontal rule to visually separate sections on a page.


Table: Insert a table.


Insert Div Tag: Insert a div tag used for page layout.


Images: Insert an image.


Media: Insert media objects, such as Flash, Shockwave, Applets, and ActiveX.


Widget: Insert a Dreamweaver widget.


Date: Insert the current date, with an option for automatic updating when you save the document.


Server-Side Include: Use as a placeholder for commonly used code that can be reused by many pages in your site. 
When you use a SSI file the server takes the entire content of the file stored on a server and inserts it into the page, 
replacing the include code.


Comment: Insert a comment, which will not be displayed on your web page.


Head: Insert keywords, meta tags, page descriptions, and other document data that is kept in the page’s head tag.


Script: Insert or remove script, such as Javascript.


Templates: Make a template based on the current document.


Tag Chooser: Insert an HTML tag.


Layout category in the Insert panel 


From the Layout category in the Insert panel (Figure 7), you can insert tables, table elements, div tags, frames, and 
Spry widgets. You can choose between two modes for tables. Standard mode displays a table as a grid of lines. 
Expanded Tables mode adds cell padding and spacing to tables and increases table borders to make editing easier. 


Figure 7 Layout category in the Insert panel


Insert Div Tag: Insert a div tag to create a content block.
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Insert Fluid Grid Layout Div Tag: Insert a flexible-positioned div tag to display content at a variable location on the 
page.


Draw AP Div: Insert an absolutely-positioned div tag to hold content at a specific location on the page.


Spry Menu Bar: Insert a set of navigational menu buttons that display submenus when a site visitor hovers over one 
of the buttons.


Spry Tabbed Panels: Insert tabs that a site visitor can click to reveal hidden content.


Spry Accordion: Insert a set of collapsible panels that can store a large amount of content in a compact space.


Spry Collapsible Panel: Insert a panel that can hide or reveal a large amount of content when a site visitor clicks the 
tab of the panel.


Table: Insert a table.


Insert Row Above: Insert a row above the current row in a table.


Insert Row Below: Insert a row below the current row.


Insert Column to the Left: Insert a column to the left of the current column.


Insert Column to the Right: Insert a column to the right of the current column.


The Property panel
In the Property panel, you can view and change a variety of properties for the currently selected object, tool, or 
document. Each kind of element has different properties. Figure 8 shows the Properties panel for a selected image. It 
displays the source location, Alt tag, dimensions, and class.  You can edit these settings and create links in the 
Properties panel.


Figure 8 Properties panel
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What is information architecture?

		Understanding what users are looking for and allowing easy access to content and information is the overall goal. It’s all about ensuring that users can get what they came for.

		The goals of information architecture:

		Organize and label a website structure to support usability.

		Connect users to the content and organize information intuitively.

		Blueprint the site from a functional perspective to communicate easily with a client and a team.

		The information architecture step usually falls within the structure phase of web project production, before you create wireframes, design comps, and prototypes.



*
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Information architecture best practices

		Research the needs of the audience and users

		Identify a clear purpose for the site

		Inventory and assemble site content

		Assemble site content into logical groups

		Create a site map

		Design navigation systems



*
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Consider your audience

		Before you create an information architecture for your website, consider the following:

		Who is the target audience?

		What kind of user are you trying to attract to the website?



*



These important initial questions inform the way you structure content and information. You must create the information architecture of your site with your audience in mind.

*
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Identify website purpose

		Always keep the goals in mind while you’re creating the information architecture.

		What are the goals of the website? 

		What will attract viewers to the website?

		How does the purpose of the website influence the information architecture?



*
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Inventory content

		The content you plan to use on your website influences the information architecture. Consider the following questions:

		What content do you already have?

		What content do you need to create?

		Is the content suitable for the site’s audience?

		Does the content help accomplish the goals of the site?

		Is the content suitable for the site’s target screens and devices?



*
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Assemble content

		Content and structure are intertwined. 

		Assembling content into logical groups helps: 

		Establish clear and consistent site organization.

		Facilitate the task of defining the information architecture.



*
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Create a site map

*



Your site’s structure is composed of the categories and logical groups you just created. A site map serves as a bird’s-eye view of the project that enables you to see how the site is organized and how users will view the site’s content and information. The site map becomes a blueprint that shapes the structure of the site during the development process. The site map should show main areas of content and represent all the pages within each section.

*
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Design navigation systems

		Clear navigation helps connect users with the content on your site. Navigation helps users:

		Stay oriented to where they are.

		Find where they need to go.

		Know how to get back to where they came from. 

		Make sure to use familiar visual cues and navigational aids as users move from page to page.

		Clear navigation also helps your website maintain consistency.



*
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Summary

		Information architecture is a method to add organization and support usability of a website

		Information architecture helps improve discoverability, efficiency, satisfaction, consistency, and overall usability of a website.

		A site map and a clear navigation are the key components of an information architecture



*
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How to create masks
In Adobe Flash Professional CS6, a mask is a special type of layer that lets you reveal select parts of another layer. 
For example, if you want to show people walking around inside a house, and you want them to be visible when they 
pass by a window but invisible otherwise, you can use a mask. You can use masking for effects such as creating a 
spotlight or showing pictures behind images.


Creating a mask
In the following steps, you’ll create a mask by using a simple shape.


To create a mask:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Import an image to the Stage.


3. Create a new layer and name it mask. Put this layer 
directly above the layer containing the image.


4. Use a drawing tool, such as the Oval tool or the 
Rectangle tool, to define the area of the mask layer that 
you want to be transparent (Figure 1). 


Make the mask area a solid, noticeable color. This will 
help you see where the transparent area is.


5. Right-click (Windows) or Control-click (Mac OS) the 
mask layer, and select Mask from the context menu.


The two layers change to indicate that the bottom layer is 
masked. The name of the masked layer is indented under 
the name of the masking layer and its icon changes to a 
mask layer icon (Figure 2). Both of the layers are locked 
by default.


Note: To display the mask effect, lock both the mask 
layer and the layer containing the masking content. 
Unlock one or both layers to hide the effect.


6. Select Control > Test Movie > In Flash Professional to 
play the movie.


Observe that only the masked area is visible.


7. Select File > Close to close the preview window.


Figure 1 Mask layer with mask area


Figure 2 Mask applied


Mask layer Mask area
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Animating the mask
You can animate the mask so that, for example, the mask pans along a picture.


To animate the mask:


1. Continue where you left off in the previous steps.


2. On the mask layer, add a frame at frame 20.


3. On the masked layer below, also add a frame at frame 20.


4. Click the Mask layer anywhere between frames 1 and 20, 
and then select Insert > Classic Tween.


5. Unlock the mask layer, click frame 20, and move the 
mask object (Figure 3). 


6. Adjust the motion guide as necessary.


7. Select Control > Test Movie > In Flash Professional to 
play the movie.


Observe that only the masked area moves across the 
content beneath it.


8. Select File > Close to close the preview window. Figure 3 Motion tween on the mask layer
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How to create a design comp
A comprehensive artwork (comp for short) is a design proposal presented by the designer to the client for approval. 
Web design comps provide a rough visual draft of the overall user interface (including graphics, interface design 
elements, navigation system, and main content areas) before specific content is placed (Figure 1).


Fireworks provides an ideal prototyping environment, seamlessly converting design comps into real-world widgets, 
websites, and applications.


Figure 1 Design comp 


The web design process
The typical web design process may be comprised of several stages, including any of the following:


1. Brief provides a statement of technical, design, and idea goals for the web project.


2. Research involves a range of investigative activities including a review of related web designs, analysis of 
competitor sites, user flows, personas, market analysis, use cases, and more.


3. Brainstorming is a conceptualizing stage based on the brief and research stages in which many ideas are 
generated in a short amount of time. 


4. Creative solution follows the brainstorming phase in which briefs, research, and ideas are combined to 
create a clear design direction. This stage can include technical specifications, information architecture 
diagrams, functioning wireframes, and design comps. This stage is often iterative, a repeating process in 
which problems are solved, designs are presented to clients for feedback, website functionality is developed 
and tested, and revisions are made.


5. Production fully realizes the web project. Design comps are finalized and integrated into the wireframe 
prototype, and the web project is scaled up to full production. 


As you can see, the design comp is an important piece of the web design process from the creative solution right to 
the production stage. 


Consider the following questions as you plan and build your design comp for a web project.
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Organizing content


How you organize content on a page highlights important features and elements of your web project. Important 
elements might be higher in the page, larger in size, or in stronger colors. Include rough descriptions of navigation, 
copy layout, graphic allocation, key headers, and other elements that appear on a screen. Identifying common 
structures between pages helps visitors understand they are in the same site as they navigate from page to page.


• Will your page banner be on each page? If yes, is it in the same place? Is it the same size?


• What font will you use for titles or headings on your content pages?


• What color will you use for titles or headings on your content pages?


• What font will you use for descriptions on your content pages?


• What color will you use for descriptions?


Navigation


For visitors of your website or application to understand the content, you must provide clear navigation. Visitors need 
to know where they are in a site, where they need to go, and how to get back to where they came from. Having a 
consistent layout grid helps orient visitors and keeps them from feeling lost. Using consistent buttons, links, and 
graphics on each page maintains a sense of place. As visitors move from page to page, provide familiar visual cues 
and navigational aids.


Here are some questions to answer:


• Where will you place the navigation bar on the page?


• What content will be on the navigation bar?


• Will the navigation bar be on every page?


• How will your navigation bar help visitors know which page they are on?


Creating a design comp with Adobe Fireworks CS6 
The following steps describe a typical proces to follow when using Fireworks to create a design comp. The design 
comp process described here uses previously-prepared files including a background image, logo, text, and a 
photographic image.


To create the canvas and import files:


1. Start Fireworks and create a new document using the 
dimensions for your web project. 


2. With Layer 1 selected, choose File > Import.


The Import dialog box (Windows) or Import File dialog 
box (Mac OS) opens.


3. Navigate to a background image you want to use, and 
click Import (Windows) or Open (Mac OS).


4. Click in the upper-left corner of the canvas to place the 
imported background at that location. 


The background image is placed on the canvas.
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5. In the Properties panel, confirm that the X and Y 
coordinates are both set to 0 (Figure 2).


6. Choose File > Import.


The Import dialog box (Windows) or Import File dialog 
box (Mac OS) opens.


7. Navigate to a logo file and click Import (Windows) or 
Open (Mac OS).


The Import Page dialog box opens (Figure 3).  


A single Fireworks PNG file can contain multiple pages. 
When you insert a PNG file, or page, containing objects 
from the master layer, the master page is converted to an 
ordinary layer, and imported. 


8. Click the Import button (Windows) or Open button (Mac 
OS) in the Import Page dialog box.


9. On the canvas, click near the top edge and to the right of 
the upper-left corner to place the imported logo at that 
location.


The logo image is placed on the canvas. 


10. Choose File > Import.


The Import dialog box (Windows) or Import File dialog 
box (Mac OS) opens.


11. Navigate to a photograph file and click Import 
(Windows) or Open (Mac OS).


12. On the canvas, click in the main content area to place the 
imported logo at that location.


The photograph is placed on the canvas. 


13. Select File > Save As and save the file as a PNG.


Figure 2 Properties panel, bitmap mode


Figure 3 Import Page dialog box


To use drawing tools, fills, and the alignment panel:


1. From the Tools panel, select the Rectangle tool.


2. In the Properties panel, click the Gradient Fill button.


The Edit Gradient pop-up window opens (Figure 4). 


3. Set the gradient type to Linear, if not already selected.


Figure 4 Properties panel, Edit Gradient window


X and Y 


Gradient Fill Color swatches


Gradient type


Solid Fill
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4. Click the color swatch on the left and select a dark-gray 
color such as HEX value #222222 (Figure 5) .


5. Click the color swatch on the right and select a slightly 
lighter gray color such as HEX value #333333.


6. Click the Gradient Fill button again to close the Edit 
Gradient window.


7. Drag to draw a rectangle shape at the bottom of the 
canvas.


This rectangle will become the web page footer.


8. Choose Select > Deselect.


9. From the Tools panel, select the Rounded Rectangle tool.


10. In the Properties panel, click the Solid Fill button and 
choose a light-gray color such as HEX value #CCCCCC.


Note: You could choose instead to add a gradient fill to 
the rounded rectangle shape.


11. Click the Solid Fill button again to close the color pop-up 
window.


12. In the Properties panel, set Stroke Color to white (HEX 
value #FFFFFF), and confirm Tip Size is 1, and Stroke 
Category is 1-Pixel Soft (Figure 6).


13. Make sure Smart Guides are visible and active. If not, 
select View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.


14. Drag on the canvas to draw a rounded rectangle suitable 
for use as a button.


15. Select the rounded rectangle shape.


16. Select Edit > Duplicate three times to create a total of 
four buttons.


As you repeat the command, duplicates of the selected 
object appear in a cascading arrangement from the 
original. Duplicates appear 10 pixels lower and 10 pixels 
to the right of the previous duplicate. The most recently 
duplicated object becomes the selected object.


17. Select the Pointer tool and drag a rounded rectangle over 
to the right until the Smart Guides appear along the top, 
and right edge of the object (Figure 7).


18. Arrange the remaining shapes in a row between the first 
and the last rounded rectangle. 


Don’t worry about the spacing, you’ll take care of that in 
the next few steps.


19. Choose Window > Align to open the Align panel 
(Figure 9).


20. Shift-click the four rounded rectangle shapes, either on 
the canvas, or in the Layers panel.


Figure 5 Color pop-up window


Figure 6 Properties panel, shape mode


Figure 7 Aligning objects using Smart Guides


Figure 8 The Align panel


Stroke Color Tip Size Stroke Category


Align 
Vertical 
Center


Space 
Evenly 
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21. In the Align panel, click the Align Vertical Center button 
and the Space Evenly Horizontally button.


The rounded rectangle shapes are vertically aligned and 
spaced evenly on the canvas.


22. Select File > Save.


To use text tools:


1. Select the Text tool from the Tools panel.


Text in a Fireworks document appears inside a text block 
(a rectangle with handles).


2. Set text characteristics in the Properties panel (Figure 9):


• Font Family: Georgia


• Font Style: Regular


• Font Size: 46


• Font Color: HEX value #ECECEC


3. Click on the canvas just below the logo to create an auto-
sizing text block.


An auto-sizing text block expands horizontally as you 
type and shrinks when you remove text. Auto-sizing text 
blocks are created by default when you click on the 
canvas with the Text tool and start typing.


4. Type Shop. 


5. Choose Select > Deselect.


6. With the Text tool still selected, change Font Family to 
Verdana, and Text Size to 16 and confirm the text is left 
aligned.


7. Drag on the canvas between the Shop title and the 
photograph to create a fixed-width text block 
(Figure 10).


A fixed-width text block allows you to control the width 
of wrapped text. Fixed-width text blocks are created by 
default when you drag to draw a text block using the Text 
tool. 


8. Add placeholder text to simulate two or three paragraphs 
of text.


9. To move the text block, drag it with the Pointer tool. To 
resize it, drag a resize handle.


10. Choose Select > Deselect.


11. Select the Text tool, and change Font Family to Georgia, 
Text Size to 21, and Text Color to dark gray (HEX value 
#222222).


Figure 9 Properties panel, text mode


Figure 10 Drag with Text tool to create a fixed-
width text block


Font Family


Font Style


Font Color


Alignment


Font Size
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12. Click on the first rounded rectangle to create an auto-
sizing text block.


13. Type Shop.


14. Select the Pointer tool and drag the text block until the 
horizontal and vertical Smart Guides appear so that the 
text is centered over the rounded rectangle (Figure 11).


15. Shift-click the text block and the rounded rectangle and 
choose Modify > Group.


16. Repeat steps 12 to 15 to create three more navigation 
buttons for Designer, Our Shop, and Blog.


17. Create a text block at the bottom of the page, over the 
dark-gray footer rectangle and add some footer text.


18. Select File > Save.


Figure 11 Use Smart Guides to align text and 
objects
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How to correct color
Once you’ve opened an image in Photoshop, you may want to adjust color quality or light levels, convert it to black 
and white, or correct color or lens distortions. This can improve an image’s appearance and correct problems that 
arise during scanning or taking a photograph.


Note: Most of the tasks in this guide apply primarily to photographs.


Using automatic adjustments
Photoshop includes several commands to adjust image quality automatically. In many cases, these will be all you 
need. The latter part of this guide covers how to make such adjustments manually.


The Auto Color command adjusts the contrast and color of an image by searching the image to identify shadows, 
midtones, and highlights.


To use Auto Color:


1. Open the image you wish to correct.


2. Do one of the following:


• Click the Levels or Curves icon in the Adjustments 
panel (Figure 1).


• Choose Layer > New Adjustment Layer and choose 
either Levels or Curves. Click OK in the New Layer 
dialog box.


The Properties panel opens (Figure 2).


Note: You can also choose Image > Auto Color to apply 
the adjustment directly to the image layer. Keep in mind 
that this method discards image information and is 
automatic. You cannot adjust any of the options described 
in the following steps.


Figure 1 Adjustments panel


Figure 2 Properties panel with Levels options


Levels CurvesBlack and White


Minimize 
panel


Auto 
Levels
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3. In the Properties panel, Alt-click (Windows) or Option-
click (Mac OS) the Auto button.


The Auto Color Correction Options dialog box opens 
(Figure 3).


4. In the Algorithms section of the Auto Color Correction 
Options dialog box, select the Find Dark & Light Colors 
option. 


Color correction algorithms adjust tonal ranges using 
specific settings such as clippping all channels 
identically, adjusting channels individually, or finding an 
average of lightest and darkest pixels in a image. 


5. Select the Snap Neutral Midtones option.


Photoshop finds an average nearly-neutral color in an 
image and then adjusts the gamma (midtone) values to 
make the color neutral.


6. Specify the shadows and highlights that are clipped, and 
adjust the target color for the midtones. 


By default, Photoshop clips the black and white pixels by 
0.1%—that is, it ignores the first 0.1% of either extreme 
when identifying the lightest and darkest pixels in the 
image.


7. Confirm Save As Default is not selected and click OK to 
apply Auto Color.  


Photoshop applies Auto Color to the image.


Observe the changes in the photo. It should lighten in 
some areas and darken in others. Overall, the color’s 
clarity (though not its sharpness) should improve.


Figure 3 Auto Color Correction Options dialog 
box


Adjusting levels with an adjustment layer


Every image has a range of tone, from the darkest pixels to the lightest pixels. Photographs tend to look better when 
their darkest pixels are close to black and their lightest pixels are close to white, giving the photograph a wide tonal 
range. You can use the Levels command in Photoshop to adjust the darkest and lightest pixels in your picture. You 
can also adjust the midtones: the gray or gamma tones of your picture that are in the middle of the brightness range.


In an adjustment layer, you can make changes to tonal levels while preserving the original image. Nondestructive 
editing means you can experiment endlessly without worrying about losing or changing your original photo. By using 
adjustment layers to alter an image, your original remains intact. At any point, you can turn layers on or off to fine-
tune your image.


To use the Levels command through the Adjustments panel:


1. Make sure nothing in the photo is selected. (You want to 
apply your changes to the entire image.)


2. If the Adjustments panel is not visible, choose Window > 
Adjustments.
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3. In the Adjustments panel, click the Levels button 
(Figure 1). 


The Properties panel opens dispaying a histogram, levels 
options and some commonly used presets (Figure 4).


You can try some options in the Preset menu or use the 
histogram to tonal range of the image.


A histogram illustrates how pixels in an image are 
distributed by graphing the number of pixels at each 
color intensity level. The histogram shows detail in the 
shadows (shown in the left part of the histogram), 
midtones (shown in the middle), and highlights (shown in 
the right part). A histogram can help you determine 
whether an image has enough detail to make a good 
correction.


4. Drag the left (black) triangle to the point where the 
darkest colors begin.


Observe that the darker parts of the image become darker.


5. Drag the right (white) triangle to the point where the 
lightest colors begin.


Observe that the lighter parts of the image become 
lighter.


6. Drag the middle (gray) triangle slightly to the left.


Observe that the midtones lighten.


7. When the image looks right to you, close the Properties 
panel.


Note: The Adjustments panel with Levels options 
includes an Auto button. The Auto button automatically 
adjusts the black point and white point in an image. This 
may give good results in certain images that need a 
simple increase in contrast; however, because the Auto 
option adjusts each color channel individually, it may 
remove color or introduce color casts. Manually 
adjusting levels often yields more subtle adjustments to 
your images.


8. Choose Windows > Layers.


The Layers panel appears. Notice that a new adjustment 
layer named Levels 1 has been created (Figure 5). The 
original image remains unaltered in the Background 
layer.


Figure 4 Properties panel with levels options


Figure 5 Layers panel with levels adjustment layer


Adjusting lightness and darkness with the Dodge and Burn tools


The commands in the previous section change lightness and darkness in the image as a whole. Sometimes you might 
need to lighten or darken particular areas of an image. For example, you might want to lighten the shadows on 
someone’s face or brighten the colors in an area of the image without much light.


You can use the Dodge and Burn tools to change the lightness and darkness of particular areas of an image. Dodging 
and burning may seem like odd names, but like many other features in Photoshop, they are named after film-
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development processes. Dodging allows more light to show through the negative, making the area lighter, while 
burning allows less light to show, making the area darker.


Both tools are available in the Tools panel above the Pen tool. The Dodge tool appears by default. To access the Burn 
tool, click the Dodge tool and hold down the mouse button (Figure 6).


To use the Dodge tool:


1. Select the Dodge tool in the Tools panel (Figure 6).


The pointer changes to a brush. Usually, the brush 
appears as a circle.


2. You can change the size and shape of the brush in the 
Options bar (Figure 7).


Size the brush in proportion to the area you want to 
lighten.


3. Drag the brush across the photograph in the areas you 
want to lighten.


Note: Dodging requires some practice. You may want to 
keep the History panel open so you can undo your 
actions.


Figure 6 Dodge and Burn tools in the Tools panel


Figure 7 Brush options


To use the Burn tool:


1. Select the Dodge tool in the Tools panel, hold down the 
mouse button, and select the Burn tool (Figure 6).


The pointer changes to a brush. Usually, the brush 
appears as a circle.


2. You can change the size and shape of the brush in the 
Options bar (Figure 7).


Size the brush in proportion to the area you want to 
darken.


3. Drag the brush across the photograph in the areas you 
want to darken.


Note: Burning requires some practice. You may want to 
keep the History panel open so you can undo  actions.


Applying the Unsharp Mask filter


After retouching a photo, many Photoshop professionals apply a filter called the Unsharp Mask filter. When you 
apply color corrections, you can sometimes produce subtle blurriness in the image. The Unsharp Mask filter makes 
the image appear sharper by adjusting the contrast of edge detail.


Note: The Unsharp Mask filter is just one of Photoshop’s many powerful filters. Many of these apply an artistic look 
to images. You can experiment with these by selecting different options in the Filter menu.


How to apply Unsharp Mask


1. Make sure nothing in the photo is selected. (You want to 
apply changes to the entire image.)
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2. Choose Filter > Sharpen > Unsharp Mask.


The Unsharp Mask dialog box appears (Figure 8).


3. Make sure the Preview option is selected so you can see 
changes in the image as you make them.


4. Drag the Amount slider until your image is as sharp as 
you want it.


5. Drag the Radius slider to change its setting.


The Radius slider determines the number of pixels 
surrounding the edge pixels that affect sharpening. Edge 
pixels are pixels located where two different colors meet. 
The default setting is 1 pixel. Higher-resolution photos 
may benefit from a higher setting.


6. Set the Threshold setting to 0 pixels.


Threshold determines how different pixels need to be 
before they are considered edge pixels. A setting of 0 
sharpens all pixels in the image. Generally, set Threshold  
between 0 and 20 to avoid introducing unwanted “noise” 
into the image.


7. When the image looks right to you, click OK to apply 
changes and close the Unsharp Mask dialog box.


Figure 8 Unsharp Mask dialog box


Converting images to black and white
The Black & White adjustment enables you to convert a color image to grayscale while maintaining full control over 
how individual colors are converted. You can also tint the grayscale by applying a color tone to the image, to create a 
sepia effect, for example. Black & White functions like the Channel Mixer, which also converts color images to 
monochrome while allowing you to adjust color channel input.


How to convert images to black and white:


1. Do one of the following:


• In the Adjustments panel, click the Black & White 
icon.


• Choose Layer > New Adjustment Layer > Black & 
White. In the New Layer dialog box, type a name for 
the adjustment layer and then click OK.


Photoshop applies a default grayscale conversion  and the 
Properties panel opens with Black & White options 
(Figure 9).


Note: You can also choose Image > Adjustments > Black 
& White. But keep in mind that this method makes direct 
adjustments to the image layer and discards image 
information.


Figure 9 Properties panel with Black & White 
options


Enable tint Black and White
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2. In the Properties panel, manually adjust the conversion 
using the color sliders, apply an Auto conversion, or 
select a Preset grayscale mix (Figure 9).


Preset menu Select a predefined grayscale mix or a 
previously saved mix (Figure 10). To save a mix, choose 
Save Black & White Preset from the panel menu.


Auto Sets a grayscale mix based on the color values of 
the images, maximizing the distribution of gray values. 
The Auto mix often produces excellent results, or can be 
used as the starting point for tweaking gray values using 
the color sliders.


Color sliders Adjust the gray tones of specific colors in 
an image. Drag a slider left to darken or right to lighten 
the gray tones of an image’s original color.


3. (Optional) To apply a color tone such as a sepia tint, 
select the Tint option in the Properties panel (Figure 9). 
To fine-tune the tint color, click the Tint color swatch to 
open the Color Picker.


Figure 10 Black and White Preset menu 


Correct lens distortion and adjust perspective
The Lens Correction filter fixes common lens flaws such as barrel and pincushion distortion, vignetting, and 
chromatic aberration. The filter only works with 8- and 16-bits-per-channel images.


You can also use the filter to rotate an image or fix image perspective caused by vertical or horizontal camera tilt. The 
filter’s image grid makes these adjustments easier and more accurate than using the Transform command.


How to correct lens distortion


1. Choose Filter > Lens Correction.


2. Click the Custom tab  in the Lens Correction dialog box 
(Figure 11). 


3. Select the Show Grid option. As you work you may want 
to adjust the grid lines to help you judge the amount of 
correction to make. You can also use the Zoom controls 
to adjust the level of magnification.


Figure 11 Lens Correction dialog box


Show Grid optionZoom controls Custom tab

How to correct color © 2012 Adobe Systems Incorporated







Adobe Photoshop CS6 Project 1 guide

4. Set any of the following options to correct your image, 
and then click OK to close the dialog box


Remove Distortion Corrects lens barrel or pincushion 
distortion. Move the slider to straighten horizontal and 
vertical lines that bend either away from or toward the 
center of the image. You can also use the Remove 
Distortion tool  to make this correction. Drag toward the 
center of the image to correct for barrel distortion and 
toward the edge of the image to correct for pincushion 
distortion. 


Chromatic Aberration Corrects Red/Cyan, Green/
Magenta, or Blue/Yellow fringing. Zoom in on the image 
preview to get a closer view of the fringing as you make 
the correction. 


Vignette Corrects images that have darkened edges 
caused by lens faults or improper lens shading.


Amount Sets the amount of lightening or darkening along 
the edges of an image.


Midpoint Specifies the width of area affected by the 
Amount slider. Specify a lower number to affect more of 
the image. Specify a higher number to restrict the effect 
to the edges of the image.


Vertical Perspective Corrects image perspective caused 
by tilting the camera up or down. Makes vertical lines in 
an image parallel.


Horizontal Perspective Corrects image perspective, 
making horizontal lines parallel.


Angle Rotates the image to correct for camera tilt or to 
make adjustments after correcting perspective. You can 
also use the Straighten tool  to make this correction. Drag 
along a line in the image that you want to make vertical 
or horizontal.


Scale Adjusts the image scale up or down. The image 
pixel dimensions aren’t changed. The main use is to 
remove blank areas of the image caused by pincushion, 
rotation, or perspective corrections. Scaling up 
effectively results in cropping the image and 
interpolating up to the original pixel dimensions.


Note: Fixing images with similar problems is easy with 
the preset settings. You can also use some preset list of 
Lens Correction settings, available from the Settings 
menu. Lens Default uses settings that you previously 
saved for the camera, lens, focal length, and f-stop 
combination used to make an image. Previous 
Conversion uses the settings used in your last lens 
correction. Any group of custom settings you saved are 
listed at the bottom of the menu. 


5. Choose File > Save to save the image. 
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How to use rulers and guides
Rulers and guides can be very helpful in positioning objects on the Stage.


Using guides
You can drag horizontal and vertical guides from the rulers onto the Stage when the rulers are displayed. You can 
move guides, lock guides, hide guides, and remove guides. You can also snap objects to guides and change the guide 
color and snap tolerance (how close objects must be to snap to a guide). 


Adobe Flash Professional CS6 enables you to create nested timelines (i.e., movie clips within the main movie). 
Guides appear on the Stage only when the timeline in which they were created is active. 


To create a guide:


1. Make sure rulers are visible by selecting View > Rulers. 


2. Click on a ruler and drag toward the Stage (Figure 1).


A guide appears as you drag.


3. Release the mouse button button at the point you wish to 
position the guide.


The guide appears as a light blue line on the Stage 
(Figure 2).


Figure 1 Drag a ruler


Figure 2 Guide on Stage
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Locking or Unlocking Guides


When guides are locked, they won’t respond to clicking or dragging, so that you won’t accidentally move them when 
you are working with objects on the Stage. However, you can still create new guides.


To lock a guide


• Select View > Guides > Lock Guides.


This command toggles between locking and 
unlocking guides.


Note: You can also use the Lock Guides option in 
the Guides dialog box (Figure 3). To open the 
Guides dialog box, select View > Guides > Edit 
Guides. For more information, see the section titled 
Changing guide properties at the end of this guide.


Figure 3 Guides dialog box


To view or hide the drawing guides:


• Select View > Guides > Show Guides.


This command toggles between hiding and showing 
guides.


To move a guide:


• Make sure guides are showing and not locked. With 
the Selection tool, click anywhere on the guide and 
drag the guide to the desired place on the Stage.


To remove a guide:


• With guides unlocked, use the Selection tool to drag 
the guide to the horizontal or vertical ruler.
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Using guides to position objects on the Stage


By activating the Snap To Guides option, you can automatically align objects with guides. As you drag objects 
toward guides, objects snap into place.


To position objects with guides:


1. Select View > Snapping > Snap To Guides (if it is not 
already selected).


2. Drag the edge of an object toward a guide.


When you get close to the guide, the object snaps to it 
(Figure 4).


3. Release the mouse.


The object remains snapped to the guide.


You can use guides to line up different objects 
(Figure 5). Guides are especially useful for aligning 
objects on different layers.


Figure 4 Snap object to guide


Figure 5 Aligning objects with guides


Changing guide properties
You can change guide colors, set guide snapping properties, and lock guides.


To change guide properties:


1. Select View > Guides > Edit Guides.


The Guides dialog box opens (Figure 6).


2. Click the Guides Color control to change guide colors.


3. Select Lock Guides to lock guides in position.


4. Click OK to close the Guides dialog box.


Figure 6 Guides dialog box
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Overview of Adobe Photoshop CS6 workspace


Starting to work in Adobe Photoshop
The Adobe Photoshop workspace includes the command menus at the top of your screen and a variety of tools and 
panels for editing and adding elements to your image. You can also add commands and filters to the menus by 
installing third-party software known as plug-in modules.


Photoshop works with bitmapped, digitized images (that is, continuous-tone images that have been converted into a 
series of small squares, or picture elements, called pixels). You can also work with vector graphics, which are 
drawings made of smooth lines that retain their crispness when scaled. You can create original artwork in Photoshop, 
and you can import images into the program from many sources, such as:


• Photographs from a digital camera


• Commercial CDs of digital images


• Scans of photographs, transparencies, negatives, graphics, or other documents


• Captured video images


• Artwork created in drawing programs


For information on the kinds of files you can use with Adobe Photoshop CS6, see “Choosing a file format” in 
Photoshop Help.


In this guide, you’ll learn your way around the Adobe Photoshop CS6 workspace, how to create custom workspaces, 
how to open images, use the Properties panel, create new Photoshop documents, and use basic pan and zoom tools.


Exploring the Photoshop workspace
You can customize the layout and functionality of the Photoshop workspace by using the workspace switcher. 


To open Photoshop and explore the workspace:


1. Start Adobe Photoshop.


If you don’t see the Photoshop icon, choose Start > All 
Programs > Adobe Photoshop CS6 (Windows) or look in 
either the Applications folder or the Dock (Mac OS).


2. From the workspace switcher menu, confirm the option is 
set to Essentials. Choose Reset Essentials to restore the 
default workspace (Figure 1). 


The Photoshop workspace appears as shown in the 
following illustration.


Figure 1 Workspace switcher menu
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3. The default Essentails workspace in Photoshop (Figure 2) displays the main menu (Windows), or title bar (Mac 
OS). Below the main menu is the Options bar, with the Tools panel on the left, other panels, and one or more 
document windows that are opened separately.


The main menu organizes commands in individual menus.


The Options bar displays options for the currently selected tool  and the workspace switcher menu.


The document window displays the file you’re working on.


The Tools panel contains tools for creating and editing images, artwork, page elements, and so on. Related tools 
are grouped together.


Panels help you monitor and modify your work. An example is the Layers panel. Another is the Properties panel 
which provides context-sensitive tools to make quick updates to the properites of your masks, adjustments, and 
video layers. Two other panels appear beneath the document window: the Mini Bridge panel and the Timeline 
panel. 


Certain panels are displayed by default, but you can add any panel by selecting it from the Window menu. Many 
panels have menus with panel-specific options. You can separate, group, stack, and dock panels into your 
preferred layout. 


Figure 2 Adobe Photoshop CS6 interface


Workspace 
switcher 
menu
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menu
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Document 
window
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Layers 
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You can restore the default workspace at any time by 
choosing Window > Workspace > Essentials (Default) 
(Figure 3) or by  choosing Reset Essentials from the 
workspace switcher menu (Figure 1).


Figure 3 Selecting the default workspace


Customizing your workspace by using the workspace switcher
You may prefer your own panel layout when working on a document. You can save a current size and position of 
panels as a uniquely named workspace and restore that workspace even if you move or close a panel. The names of 
saved workspaces appear in the Window > Workspace menu.


To customize the workspace:


1. To create a custom workspace, move and manipulate the 
interface layout in Photoshop (Figure 4).


2. From the Workspace Swticher menu, select New 
Workspace (Figure 5).


Figure 4 Custom interface layout


Figure 5 Creating the New Workspace
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The New Workspace dialog box appears (Figure 6). 


3. Name your workspace and select the Capture options to 
save in the workspace (Keyboard Shortcuts and Menus).


4. Click Save.


Your new workspace appears in the upper-right corner of 
the interface in the workspace switcher area (Figure 7).


5. Open the workspace switcher menu. 


Even if you change to another type of workspace, at any 
time you can return to your saved workspace by 
reselecting it from the workspace switcher menu.


Photoshop also records any changes you make to your 
task-specific or saved layouts, so that if you switch to a 
different workspace and then switch back during an 
editing session, the panels will be exactly where you left 
them. 


You can restore the saved workspace at any time by  
choosing Reset [your named] Workspace from the 
workspace switcher menu (Figure 7).


Figure 6 New Workspace dialog box


Figure 7 Reselecting a saved workspace


Opening a file in Photoshop
You can open files by using the Open command or the Open Recent command.


To open a file:


1. To open a file, choose File > Open and navigate to the 
location of your image.


2. Select your file and click Open.


The file opens in its own window, called the image 
window (Figure 8).


3. To close the image file, choose File > Close or click the 
close button on the title bar of the window in which the 
photograph appears. (Do not close Photoshop.)


Figure 8 File open in the image window


How to open a file by using Adobe Bridge or Mini Bridge


You can also open a file by using Adobe Bridge, a visual file browser that helps take the guesswork out of finding the 
image file you need. There are two versions of Adobe Bridge to choose from: the full version which opens a seperate, 
full image browser window and works across the Creative Suite software family, or Mini Bridge, which allows you to 
access images directly within the Photoshop interface. The following steps illustrate how to use Mini Bridge, but you 
could just as easily use the full version to browse and open files.
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To open a file by using Adobe Mini Bridge:


1. If the Mini Bridge panel is not already open, click the 
Mini Bridge tab beneath the document window 
(Figure 9).


Note: You can also open Mini Bridge by choosing File > 
Browse In Mini Bridge.


Note: If this is the first time opening Mini Bridge, you 
may see a message stating “Bridge must be running to 
browse files” and a Launch Bridge button. Click the 
Launch Bridge button to start Bridge in the background 
and to open the Mini Bridge panel in Photoshop. 


2. Use the file navigator in Mini Bridge to browse to the 
folder where you store your images.


3. Thumbnail previews of the folder contents appear in the 
Content pane of Mini Bridge (Figure 10).


You can sort and filter images by using the View and Sort 
By Filename buttons.


4. Select a file in the Content pane and open the file by 
double-clicking its thumbnail.


The image opens in Photoshop.


Figure 9 Mini Bridge tab


Figure 10 Mini Bridge panel


Creating a new Photoshop document
You can create a new Photoshop document and define a document size, resolution, color mode, and background 
contents.


To create a new Photoshop document:


1. Select File > New.


The New Photoshop document dialog box appears, with 
options for your file (Figure 11).


2. Type a filename and values for the width and height of 
the canvas.


3. Type a value for Resolution.


For an image to be used on the web, 72 pixels/inch is 
suitable. For an image to be printed, use a higher 
resolution, from 300 to 1200 pixels/inch.


Figure 11 New Photoshop document dialog box


View button Sort By Filename button
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4. Choose a setting for Color Mode.


Color Mode determines which color method is used to 
display and print the image you’re working on. 
Photoshop bases its color modes on the color models that 
are useful for images used in publishing. Choose from 
RGB (Red, Green, Blue), CMYK (Cyan, Magenta, 
Yellow, Black), Lab Color (based on CIE L* a* b*), and 
Grayscale.


5. Choose a setting for Background Contents.


You can choose to use a white, transparent, or specific 
color background behind your image.


In the lower-right corner, notice that the file size 
information changes as you adjust the settings for the 
new file.


6. Click OK.


The new file opens in the image window, ready to use 
(Figure 12). Be sure to save your file as you work in it.


7. To save a file for the first time, select File > Save As from 
the main menu.


Figure 12 New image window
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Overview of the Tools panel
Photoshop provides an integrated set of tools with which you can produce sophisticated graphics for print, web, and 
mobile viewing (Figure 13). Some tools are arranged in groups, with only one tool shown for each group and the 
other tools in the group hidden behind that tool. A small triangle in the lower right corner of a tool icon is your clue to 
look for hidden tools. Select a hidden tool by clicking and holding down the small triangle.


Figure 13 Overview of Tools panel


The following section covers the Zoom tool. The process for selecting and using this tool is similar to that for the rest 
of the tools in the panel.
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How to select and use the Zoom tool from the Tools panel


The Tools panel—the long, narrow panel on the left side of the workspace—contains selection tools, painting and 
editing tools, foreground- and background-color selection boxes, and viewing tools.


To use the Zoom tool:


1. Notice the Tools panel  appears as a single column. Click 
the double-arrow button at the top of the Tools panel to 
toggle to a double-column view (Figure 14). Click the 
arrow again to return to a single-column panel that uses 
your screen space more efficiently.


2. Open an image, examine the status bar at the bottom of 
the image window, and notice the percentage listed on the 
left end (Figure 15).


This represents the current enlargement view, or zoom 
level of the image.


Note: In Windows, the status bar may appear across the 
bottom of the workspace.


3. Move the pointer over the Tools panel and hover over the 
magnifying-glass icon until a tool tip appears, identifying 
the tool by name and providing its keyboard shortcut 
(Figure 16).


4. Select the Zoom tool either by clicking the Zoom tool 
button in the Tools panel or by pressing Z, the keyboard 
shortcut for the Zoom tool.


5. Move the pointer over the image window. Notice that it 
now appears as a tiny magnifying glass with a plus sign 
in the center of the glass.


Figure 14 Tools panel


Figure 15 Zoom level and Status bar in an  image


Figure 16 Tool tip


Status barZoom level
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6. Click anywhere in the image window. 


The image zooms in according to a preset percentage 
level, which replaces the previous value in the status bar. 
The location you clicked when you used the Zoom tool 
becomes the center of the enlarged view. If you click 
again, the zoom advances to the next preset level, up to a 
maximum of 3200%. 


7. Click the Navigator icon in the right side of the 
workspace (or select Window > Navigator) to open the 
Navigator panel. 


Notice a red box is displayed around the zoomed area of 
the image (Figure 17). You can grab the box and move it 
around the Navigator to locate a specific area of an 
image.


8. Hold down the Alt key (Windows) or Option key (Mac 
OS) so that the Zoom tool pointer appears with a minus 
sign in the center of the magnifying glass (Figure 18), 
and then click anywhere in the image. Then release the 
Alt or Option key. 


Now the view zooms out to a lower preset magnification.  


Note: You can also hold the Alt key (Windows) or 
Option key (Mac OS) and use the mouse scroll wheel to 
zoom in and out of an image. 


Figure 17 Navigator panel showing zoom area


Figure 18 Using the Zoom tool with a minus sign


How to scroll around an image with the Hand tool


The Hand tool moves an image within its window. This is useful if you want to see a part of the image that is 
currently out of view.


To use the Hand tool:


1. Open an image and zoom in until scroll bars appear on 
the image window.


2. Select the Hand tool from the Tools panel (Figure 19). 
You can also press Shift+H.


Figure 19 Hand tool in the Tools panel


Navigator 
icon
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3. Using the Hand tool, drag to scroll around and view 
different parts of the image (Figure 20).


Figure 20 Dragging the Hand tool


Using the Navigator panel
Panning or zooming an image in the Navigator panel is another quick way to make large changes in the zoom level, 
especially when the exact percentage of magnification is unimportant. It’s also a great way to scroll around in an 
image, because the thumbnail shows you exactly what part of the image appears in the image window.


To use the Navigator panel:


1. If the Navigator panel is not visible, choose Window > 
Navigator, or click the Navigator icon in the right side of 
the workspace (Figure 17).


2. Locate the slider under the image thumbnail in the 
Navigator panel and drag it to the right.


The image in the image window enlarges (Figure 21).


3. Now drag the slider to the left and reduce the scale of the 
image in the image window.


Figure 21 Using the slider to zoom in or out
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How to create a wireframe
A wireframe is a visual guide representing the basic elements of a website. Wireframes are used to describe the 
conceptual structure or information architecture of a website or application. A well-designed wireframe includes 
three key elements: interface design, navigation system, and main content areas (Figure 1). The functional 
relationships between these element are highlighted, where detailed graphics, typographic style, and colors are 
typically not emphasized. 


Fireworks is an ideal tool to mock up wireframes. Use the following guidelines to help you create a wireframe of your 
widget or website.


Figure 1 Wireframe proposal


Wireframing workflow
This worklow outlines the general steps for developing a wireframe from scratch. The result is to a fully-functional 
interactive prototype.


1. Create pen-and-ink draft 


Using pen and paper, sketch a home page or home screen. Include all major layout design elements you want to share 
across multiple pages or screens such as navigation, content areas, titles, and logos. Consider these questions:


• Graphics What graphics will you include? Where will you place the graphics on the page or screen?


• Text What text will you include? Where will you place text on the page or screen?


• Navigation According to your flowchart, the home page or screen directly links to what pages or screens 
(what are the menu items)? Where will you place these links on your home page or screen?


2. Scan and import your draft


Use a scanner to make a digital copy of your draft wireframe, import it into Fireworks.


3. Lay out common design elements


With the sketched draft for reference, use basic drawing tools and guides in Fireworks to block out the main design 
elements in the wireframe.
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4. Create multiple wireframe pages or screens


In the Pages panel, create the desired number of pages or screens for your initial design. As the design evolves, you 
can add or subtract pages or screens as needed.


5. Add unique elements to individual pages or screens


On each page, add unique design, navigation, or form elements. In the Common Library panel, you can find many 
buttons, text boxes, and pop-up menus that speed up the design process.


6. Simulate user navigation with links


Use web objects such as slices, hotspots, or navigation buttons to link the various pages or screens of your prototype.


7. Export the finished, interactive wireframe


Fireworks offers multiple output formats for your prototype, all of which retain hypertext links for navigation within 
the prototype.


Creating a wireframe with Adobe Fireworks CS6
Use Fireworks to create a basic two-page interactive wireframe document. 


Workflow steps 1 to 3


In this section, you  sketch out your wireframe, scan and import it into Fireworks, and lay out comon design elements. 


To create a wireframe from a sketch:


1. Using pen and paper, sketch your wireframe. Include all 
major components, such as navigation, content areas, 
titles, and logos.


2. Scan the sketch into your computer. 


3. Start Fireworks and create a new document 1024 pixels 
wide and 700 pixels high. 


Note: These dimensions are those of a typical web page. 
The dimensions may differ if you're designing a widget.


4. Open the Layers panel, and create or rename two layers: 


• Wireframe


• Wireframe Sketch


Make sure the Wireframe Sketch layer is below the 
Wireframe layer (Figure 2).


5. With the Wireframe Sketch layer selected, choose File > 
Import.


The Import dialog box opens.


6. Navigate to the file you scanned in step 2, and click 
Import (Windows) or Open (Mac OS).


7. Click in the upper-left corner of the canvas to place the 
imported sketch at that location. 


You need to scale the sketch to fit the canvas. Click the 
imported sketch to select it.


Figure 2 Wireframe and Wireframe Sketch layers 
added to the Layers panel
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8. The sketch may extend beyond the edges, or not fully fit  
inside the canvas. 


9. In the Properties panel, select the Constrain Proportions 
option (Figure 3).


10. In the Width Pixel Dimension text box, type 1024, and 
confirm the X and Y coordinates are set to 0.


11. Press Tab.


The image resizes to fit the canvas width.


12. In the Layers panel, lock the Wireframe Sketch layer.


This sketch layer will be the background reference to lay 
out the wireframe elements.


13. Select the Wireframe layer.


14. Make sure rulers and guides are visible. If not, select 
View > Rulers and View > Guides > Show Guides.


15. To create a horizontal or vertical guide, click then drag 
from the corresponding ruler respectively to the edges of 
the logo area, the main content area, and the first 
navigation button (Figure 4).


Note: Guide color can be changed to be more visible 
against different backgrounds. To change the guide color, 
select Edit > Preferences (Windows) or Fireworks > 
Preferences (Mac OS)  and select the Guides And Grids 
category.


16. Select View > Guides > Lock Guides.


Locking the guides prevents you from moving them 
unintentionally.


17. Select View > Guides > Snap To Guides.


The snapping feature enables you to align objects 
precisely with the guides as long as you get close. You 
can control how close you have to get (Snap Distance) in 
Guides And Grids. preferences.


18. Select the Rectangle tool from the Tools panel.


19. In the Properties panel, make the following changes 
(Figure 5):


a. Select None from the Fill pop-up menu.


b. Select Basic > Soft Line from the Stroke pop-up 
menu.


c. Set Stroke color to dark grey.


d. Set Stroke width to 10 pixels.


20. Using the guides, draw a rectangle around the main 
content area, and logo area of the sketch (Figure 6).


As you draw, the rectangles snap to the guides.


Figure 3 Properties panel


Figure 4 Imported sketch with guides added


Figure 5 Rectangle Properties panel


Figure 6 Rectangles drawn around page elenents
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21. Select the Rounded Rectangle tool from the Tools panel.


22. Draw a rounded rectangle around the first navigation 
button of your wireframe (Figure 7).


23. Use the Pointer tool to select the rounded rectangle. Alt-
drag (Windows) or Option-drag (Mac) to the left to create 
a copy of the rectangle, and place it over the second 
navigation button in your wireframe.


Note: You may see a Fireworks warning box telling you 
that editing sub-elements of an Auto Shape may cause it 
to behave unpredictably. Select the Don’t Show Again 
option and click OK to dismiss.


24. Select Edit > Repeat Duplicate. 


This action creates a second copy with the same gap 
space between copies.


25. Continue repeating duplicates until you have created as 
many navigation buttons as needed for your wireframe 
sketch (Figure 8).


Now it's time to add the text labels. 


26. Choose Select > Deselect.


27. From the Tools panel, select the Text tool.


28. In the Properties panel, click the Fill color box and 
choose a dark color. Set the justification to Center 
Alignment and the Text Size to 30.


29. Click once in the logo rectangle and enter the text Logo.


30. Make sure Smart Guides are visible and active. If not, 
select View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.


31. Drag the text block to center it in the rectangle, and 
continue adding text labels for the navigation buttons and 
main content area.


The Smart Guides help you to create, align, edit, and 
transform objects relative to other objects.


32. Choose View > Guides > Show Guides to hide guides.


33. Once you are satisfied with the position of the text and 
rectangle elements, click the eye icon next to the 
Wireframe Sketch layer to turn off visibility of the 
background layer. 


With the sketch layer turned off, your image should look 
similar to Figure 9.


34. Select File > Save As and save the file as a PNG.


Figure 7 Rounded rectangle drawn around 
navigation button


Figure 8 Three copies of the rounded buttons 


Figure 9 Completed wireframe sketch
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Workflow steps 4 and 5


Now that you have created the very basic wireframe of the page or screen layout, the next step is to create a few pages 
or screens showing various content. Fireworks CS6 enables you to create as many pages or screens as needed, with 
shared and unique items on each page.


To create multiple wireframe pages or screens:


1. Open the Pages panel (Window > Pages) if it isn't already 
displayed on the right side of the workspace (Figure 10).


2. Right-click (Windows) or Control-click (Mac OS) the 
current page in the Pages panel, and choose Set As 
Master Page from the context menu.


3. At the bottom of the Pages panel, click the Add Page 
button twice to add two blank pages.  


The new pages display the master page in the 
background.


4. Double-click the new page names to rename them, 
respectively, as Home and Shop (or whatever name you 
are using for the  second page of your wireframe). 


5. Navigate to the Home page by selecting it in the Pages 
panel (Figure 11).


6. Use the Text tool to add a page title at the top of the main 
content area.


7. Navigate to the Shop page by selecting it in the Pages 
panel, and use the Text tool to add a page title at the top 
of the main content area in the same way as on the Home 
page.


8. Select the Rectangle tool from the Tools panel.


9. In the Properties panel, select neutral colors for Fill and 
Stroke.


10. Draw a rectangle in the main content area of the second 
page, beside the page title. This rectangle stands in as a 
placeholder for a Shop page image or text page content 
(Figure 12).


11. Select File > Save.


Figure 10 Pages panel


Figure 11 Pages panel, Home page selected


Figure 12 Adding page-level placeholder content


Pages options
menu


Add Page 
button
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Workflow step 6


In this section, you use hotspot web objects to create navigation buttons or links between the two pages of your 
prototype.


To add navigation to a wireframe:


1. Navigate to the master page by selecting it in the Pages 
panel.


2. From the Tools panel, select the Rectangle Hotspot tool 
(Figure 13).


3. Draw a hotspot over the Logo rectangle area. 


4. Draw another hotspot over the first rounded rectangle 
area (Figure 14).


5. Select the first hotspot with the Pointer tool.


6. In the Properties panel, set Link to Home.htm 
(Figure 15).


7. Select the second hotspot and set Link in the Properties 
panel to Shop.htm (or to whatever you named the second 
page).


Because the hotspots are located on the master page, 
every page will be linked to the others when export the 
Fireworks file to an interactive PDF.


8. Select File > Save.


Figure 13 Tools panel


Figure 14 Drawing hotspots


Figure 15 Properties panel


Workflow step 7


Export an interactive prototype of your wireframe to both PDF and functional HTML (Figure 16). 


An interactive PDF is ideal for facilitating the client review process because the client can click through the flow of 
the site or widget, and make comments as needed by using the tools available in Adobe Acrobat. 


Fireworks generates pure HTML that can be read by most web browsers and HTML editors. You can then preview 
your wireframe interactivity and edit these files in Dreamweaver.


Figure 16 Export wireframes from Fireworks


Rectangle Hotspot tool


Link menu
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To export an interactive PDF:


1. Choose File > Export.


The Export dialog box opens (Figure 17).


2. From the Export pop-up menu, choose Adobe PDF. 


3. Confirm that the option View PDF After Export is 
selected.


4. Specify a filename and location, and then click Save 
(Windows) or Export (Mac OS).


The wireframe is exported to PDF and opens in Acrobat.


5. Test that the wireframe links work as expected 
(Figure 18).  


Figure 17 Export dialog box


Figure 18 Testing links in Acrobat PDF


To export to HTML and images:


1. Choose File > Export.


The Export dialog box opens.


2. Navigate to a folder on your hard drive in which to 
export.


3. From the Export pop-up menu, choose HTML And 
Images.


4. Select All Pages from the Pages menu.


5. To store images in a separate folder, select the option Put 
Images In Subfolder. You can select a specific folder or 
use the Fireworks default Images subfolder.


View PDF After Export option
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6. Specify a filename, and then click Save  (Windows) or 
Export (Mac OS).


After export, you'll see the files Fireworks exported on 
your hard drive. Images and an HTML file are generated 
in the location you specified in the Export dialog box.


7. Navigate to the location of the saved file, open 
Home.htm in a browser, and test whether the wireframe 
links work as expected (Figure 19).


Figure 19 Testing HTMLin a browser

How to create a wireframe © 2012 Adobe Systems Incorporated





		How to create a wireframe

		Wireframing workflow

		1. Create pen-and-ink draft

		2. Scan and import your draft

		3. Lay out common design elements

		4. Create multiple wireframe pages or screens

		5. Add unique elements to individual pages or screens

		6. Simulate user navigation with links

		7. Export the finished, interactive wireframe



		Creating a wireframe with Adobe Fireworks CS6

		Workflow steps 1 to 3

		Workflow steps 4 and 5

		Workflow step 6

		Workflow step 7














Digital Design Project 3 Guide


© 2012 Adobe Systems Incorporated Technical features and their design solutions 1


Technical features and their design solutions


Technical feature Design solution


Pop-up menu Display multiple links in a small amount of space.


Provide navigation flexibility without long download times.


Rollover image Add highlighting or design effects with an image swap to draw visitor attention.


Indicate “hot” (or clickable) areas of the screen.


Example: Buttons that change appearance when the pointer rolls over them


Image map Help set up navigation on a website.


Example: Geographic map with hotspots or invisible buttons that link to sites 
about each country


Photo presentation Add design elements to pictures to enhance the overall design of the site.


Make changes to photograph presentation elements such as tone, color, and 
blending.


Spreadsheet table Quickly set up a table of information such as a directory, large catalog, or sched-
ule.


Form Interact with and gather information from site visitors.


Examples: Feedback form, guest book, survey, or product order form


Cascading Style Sheets Create a consistent design for all pages that easily updates multiple pages on a site.


Use with templates for managing large sites.


Rich media or animated 
content


Enhance or reinforce the mood of the site.


Add to overall message of the site.


Examples: Banner ads and cartoons


Sound Add music or sound effects to enhance visual elements or interactions.


Video Use video on websites to personalize and enhance the user’s experience.


Example: Customer testimonials
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How to produce Flash video for use on the web
Adobe Flash Professional CS6 provides a number of options for importing and publishing video with a Flash movie.


You can import the following video formats:


• Adobe Flash Video (.flv, .f4v)


• 3GPP/3GPP2 for mobile devices (.3gp, .3gpp, .3gp2, .3gpp2, .3g2)


You can import the following video formats if you have QuickTime 7 or later installed (Windows and Mac OS):


• Audio Video Interleaved (.avi)


• Digital Video (.dv)


• Motion Picture Experts Group (.mp4, .m4v, .avc)


• QuickTime Movie (.mov, .qt)


Deploying video
How you choose to deploy your video determines how you create your video content and how you integrate it with 
Flash. You can incorporate video into Flash in the following ways:


Progressively download video from a web server: Flash creates a Flash video file that downloads from a regular web 
server and plays within the published SWF file.


Stream video with Adobe Flash Media Server: This option produces the overall best performance; however, it 
requires either the Flash Media Server or a subscription to a Flash Video Streaming service. See the Adobe website 
for more information: www.adobe.com.


Embed video in the Flash document: You can embed a small, short-duration video file directly into the Flash 
document and publish it as part of the SWF file. Embedding video content directly into the Flash SWF file 
significantly increases the size of published file and is only suitable for small video files (typically less than 10 
seconds in length). This method is not recommended.


Encode video by using Adobe Media Encoder: Adobe Media Encoder CS6 converts video files into media suited for 
distribution on the web or on DVDs, iPods, tablets, cell phones, and other mobile devices.


To encode video by using Adobe Media Encoder:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Save your document.


Note: You must save the Flash document before you 
begin the video import process.


3. Click File > Import > Import Video.


The Import Video wizard appears (Figure 1).


Figure 1 Import Video wizard 
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4. Click the Launch Adobe Media Encoder button.


A message tells you that after encoding your video, you 
can return to Flash and import the video for use in your 
Flash document (Figure 2).


5. Click OK.


Adobe Media Encoder starts (Figure 3).


6. In the Media Encoder Queue panel, click the Add Source 
button (Figure 4).


7. Navigate to the files you want to encode, select them, and 
click Open.


To select more than one file, hold down Ctrl (Windows) 
or Command (Mac OS) as you select the files.


Note: You can also drag files from an open window 
directly into the Queue panel.


All files you add appear in the Queue panel (Figure 5).


Figure 2 Adobe Flash message


Figure 3 Adobe Media Encoder


Figure 4 Adobe Media Encoder, Queue panel


Figure 5 Adobe Media Encoder, Queue panel
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8. Open the Format menu for the file and select a format to 
use for encoding (Figure 6).


If you have more than one file in the Queue, the format 
you choose applies to all selected files automatically. 


9. Open the Preset menu for the file and select a preset 
(Figure 7). 


Note: To apply different settings to other files in the 
Queue panel, select them individually and set the format 
and preset one file at a time.


10. Click the Start Queue button to begin encoding 
(Figure 8).


When the encoding process is complete, close Adobe 
Media Encoder and return to Flash.


11. Click Cancel to close the Import Video wizard.


Figure 6 Format menu for a file in the Queue panel


Figure 7 Preset menu for a file


Figure 8 Start Queue button
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To use progressive download:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Save your document.


Note: You must save the Flash document before you 
begin the video import process.


3. Select a keyframe on the layer in which you want to 
import the video.


This is where the video player will be located after the 
video import is complete.


4. Click File > Import > Import Video.


The Import Video wizard appears (Figure 9).


5. Click the Browse button, navigate to the location of the 
video file you want to import, select it, and click Open.


You can use a video file located either on your computer 
or on the Internet.


6. Select Load External Video With Playback Component.


This option progressively loads your external video file 
into your Flash document.


7. Click Next.


The Skinning page of the Import Video wizard opens 
(Figure 10).


The video’s skin determines the location and appearance 
of the video controls. Visitors see this skin when Flash 
plays the video.


8. Select a skin from the Skin pop-up menu.


9. Select a skin color from the color picker.


10. Click Next.


The Finish Video Import page of the Import Video wizard 
appears. This page confirms the location of the Flash 
video file.


11. Click Finish.


The FLVPlayback object appears on the Stage 
(Figure 11).


12. Click the Play button.


The video plays in the Playback object.


Figure 9 Import Video wizard


Figure 10 Import Video wizard, Skinning page


Figure 11 FLVPlayback object on Stage


Play button
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13. Select Control > Test Movie > In Flash Professional.


The video plays in the Flash Player window. You can use 
the controls to stop, pause, fast forward, rewind, and 
change the volume of the video.


14. Close the preview window.


15. Open the folder in which you saved the Flash document.


This folder now contains two new files: an FLV file and a 
SWF for the video's skin. When you publish your Flash 
document, you need to copy both of these files to the 
same location as the Flash document.
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Peer Review


Name: _______________________________________________________ Date: ________________________


Project: _____________________________________________________


Overview
Revision is an important part of the design process. In addition to conducting review and redesign cycles personally 
and with your client, you can also benefit from peer review. Additionally, peer review occurs in many professional 
environments and it will be good practice to start on this essential skill now.


When giving peer review, be sure your points are both positive and negative. Give your critiques as suggestions, not 
commands. When receiving peer review, do not be disenchanted or feel that you did a bad job based on one review. 
Every review is different, and what one person does not approve of, the next person may find exemplary.


Process for presenting work for peer review


• When presenting your work for peer review, state the purpose, audience, and goals of your document and 
point out any concerns you have.


• To conclude, summarize the reviewer’s suggestions and offer a plan for revision.


Guidelines for giving comments and suggestions


• Before making any comments, review the entire document and make sure you understand the designer’s 
intentions. Or, if being presented work by a designer, your first response should be to reiterate the designer’s 
purpose, audience, and goals.


• After the designer’s purpose, audience, and goals are clear, ask questions of the designer, make comments, 
and offer suggestions.


• Point out both the strengths and the weaknesses of the document (design, layout, typography, and so on).


• Offer suggestions, not commands. For instance, do not use “should,” as in “You should do this….” Instead, 
use “I” statements, such as “I see that…” or “I’m confused about....”


• Be respectful and considerate of your peer’s feelings. Do not say or write anything you wouldn’t want to 
receive yourself—there is no reason to be rude.


• Make sure your comments are clear and specific so your peer knows what you are referring to. It is 
important to give specific examples and point to design principles, image composition, layout guidelines, 
and so on to make your point. Such comments as “this is unclear” or “this is too vague,” are too general to be 
helpful. Rather make a comment like, “I’m confused by this image because there is no caption identifying 
what it is”).


• If you are writing your comments, reread them before passing them on to your peer. Make sure all your 
comments make sense and are easy to follow.





		Peer Review

		Name: Date:

		Project:

		Overview

		Revision is an important part of the design process. In addition to conducting review and redesign cycles personally and with your client, you can also benefit from peer review. Additionally, peer review occurs in many professional environments and i...

		When giving peer review, be sure your points are both positive and negative. Give your critiques as suggestions, not commands. When receiving peer review, do not be disenchanted or feel that you did a bad job based on one review. Every review is diff...



		Process for presenting work for peer review

		• When presenting your work for peer review, state the purpose, audience, and goals of your document and point out any concerns you have.

		• To conclude, summarize the reviewer’s suggestions and offer a plan for revision.



		Guidelines for giving comments and suggestions

		• Before making any comments, review the entire document and make sure you understand the designer’s intentions. Or, if being presented work by a designer, your first response should be to reiterate the designer’s purpose, audience, and goals.

		• After the designer’s purpose, audience, and goals are clear, ask questions of the designer, make comments, and offer suggestions.

		• Point out both the strengths and the weaknesses of the document (design, layout, typography, and so on).

		• Offer suggestions, not commands. For instance, do not use “should,” as in “You should do this….” Instead, use “I” statements, such as “I see that…” or “I’m confused about....”

		• Be respectful and considerate of your peer’s feelings. Do not say or write anything you wouldn’t want to receive yourself—there is no reason to be rude.

		• Make sure your comments are clear and specific so your peer knows what you are referring to. It is important to give specific examples and point to design principles, image composition, layout guidelines, and so on to make your point. Such commen...

		• If you are writing your comments, reread them before passing them on to your peer. Make sure all your comments make sense and are easy to follow.















Adobe Dreamweaver CS6 Project 3 guide

How to create forms
You can use forms to interact with or gather information from site visitors. With forms, visitors can provide feedback, 
sign a guest book, take a survey, or place an order for merchandise. In Adobe Dreamweaver CS6, you can create a 
variety of form elements, such as text fields, password fields, radio buttons, checkboxes, pop-up menus, and clickable 
images (such as a Submit button).


The Forms category in the Insert panel (Figure 1) contains buttons for creating forms and inserting form elements.


Figure 1 Forms category in the Insert panel


The data gathered in forms is usually sent to a database on a server or through e-mail. To set up the form processing, 
contact your site administrator. This guide helps you make the user interface of a form.


Setting up a form
You set up a form by inserting it and configuring options through the Properties panel.


To set up a form:


1. Open a page in Dreamweaver.


2. Place the insertion point on the page where you want to 
insert a form or draw a new div for more precise 
positioning of the form on your page. 


Note: To draw a new div, click Draw AP Div in the 
Layout category in the Insert panel, and then drag to draw 
the div. Be sure to make the div large enough to contain 
the entire form you plan to create.
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3. Select the Forms category in the Insert panel (Figure 1), 
and click Form. 


A blank form appears, with a red dotted outline 
(Figure 2). You place all form elements inside this 
outline. If you placed the form inside a div, you may need 
to click outside the div to see the entire form outline.


Form options appear in the Properties panel.


4. From the Method pop-up menu in the Properties panel 
(Figure 3), select either GET or POST.


• GET appends the form contents to the URL specified 
in the Action text box. Use GET if the form data is 
short and the results of the form will lead to a page 
that you want the visitor to be able to bookmark.


• POST sends the form contents directly to the server 
in a manner that is not visible to the visitor. Use 
POST if the form data might be long (if, for instance, 
the form includes a text field that the visitor can use 
to type an unlimited amount of text). 


5. In the Action text box, type the URL or CGI script that 
will process the form.


Note: Get this information from your site administrator.


Figure 2 New, empty form


Figure 3 Forms Properties panel


Adding form elements
Using the Forms category in the Insert panel, you can insert any combination of form elements within the red outline 
of the form. You can use tables to lay out these elements if you choose.


Using form fields


Form fields enable site visitors to enter text into a form. Form fields include the following:


• Text fields, in which a visitor types a response


• File fields, in which a visitor types the path of a file to upload to your server


Adding text fields


Text fields provide a space in which visitors can enter text.
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To add a text field:


1. Click the Text Field button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens 
(Figure 4).


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the text field in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).


The ID is used by HTML and/or Javascript code to 
distinguish this input tag from others, but it isn’t visible 
to site visitors.


3. Enter a label for the text field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


The label will be displayed next to the text field, 
indicating to the visitor what to put in the field.


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


5. In the Add Form Tag dialog box, click Yes.


The text field appears in the form (Figure 5).


6. Click in the text field (not the label) to select it.


7. In the form Properties panel (Figure 6), select one of the 
three types of text fields:


• Single Line text for short answers


• Multi Line text for long answers such as the visitor’s 
description of a problem with a purchased item


• Password text for passwords (in which asterisks 
appear in place of typed characters)


Note: You can also create a multiple-line text field by 
clicking the Text Area button in the Insert panel.


Figure 4 Input Tag Accessibility Attributes dialog 
box


Figure 5 Example of text field in the form


Figure 6 Form Text Field Properties panel


Adding a file field


A file field enables site visitors to select a file on their computers (such as a word-processing document or graphics 
file) and upload it to your server. A file field looks like other single-line text fields, except it also provides a Browse 
button. The visitor either types the path to the file they want to upload or uses the Browse button to locate and select 
the file.
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To add a file field:


1. Click the File Field button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the file field in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).


3. Enter a label for the file field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


The file field appears in your document (Figure 7).


5. Click in the file field (not the label) to select it. In the 
Properties panel, in the Char Width text box, specify the 
maximum number of characters visitors will see in the 
field (Figure 8).


6. In the Max Char text box, specify the maximum number 
of characters the field will hold.


Note: Contact your site administrator to confirm that 
anonymous file uploads are allowed before using the file 
field.            


Figure 7 File field example


Figure 8 Form File Field Properties panel


Using checkboxes and radio buttons
Visitors click a checkbox or radio button to make a choice. With checkboxes, visitors can toggle a single option on or 
off, or they can select one or more options from a group of options. With radio buttons, visitors can select only one 
option from a group of options.


To add a checkbox:


1. Click the Checkbox button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the checkbox in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).


3. Enter a label for the checkbox in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 
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4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


The checkbox button appears in your document 
(Figure 9).


5. Click the checkbox (not the label) to select it.


6. In the Checked Value text box in the Properties panel 
(Figure 10), enter a value for the checkbox.


This is the value that will be returned by the form. For 
example, for a checkbox that indicates whether a visitor 
wishes to be on a mailing list, you might set a value of 1 
for yes.


7. For Initial State, select Checked if you want an option to 
appear selected when the form first loads in the visitor’s 
browser. Otherwise, select Unchecked.


Figure 9 Example of checkbox


Figure 10 Form Checkbox Properties panel


To add a group of radio buttons:


1. Click the Radio Group button in the Insert panel to insert 
a group.


The Radio Group dialog box opens (Figure 11).


2. Enter a name in the Name text box.


3. Click the plus (+) button to add a radio button to the 
group.


4. Enter a label and (if you want) a checked value for each 
button.


5. Select an item in the radio button list, and click the up or 
down arrows to reorder the buttons.


6. Select Line Breaks to arrange the radio buttons without 
using a table. Select Table to arrange them in a table. 


7. Click OK.


The group of radio buttons is added to the form 
(Figure 12).


8. Click a radio button (not its label) to select it.


Figure 11 Radio Group dialog box


Figure 12 Example of Radio Group
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9. In the Properties panel, click Checked or Unchecked to 
indicate if this option is selected by default (Figure 13).


Figure 13 Form Radio Button Properties panel


Using list menus and drop-down menus (List/Menu)
Lists and menus allow visitors to select options from a list or pop-up menu. With a list menu, you can display 
multiple options in a confined space and allow visitors to select multiple items. Visitors can select only one item from 
a pop-up menu.


To add a list menu:


1. Click the List/Menu button (Windows) or Select (List/
Menu) button (Mac OS).


The Input Tag Accessibility Attributes dialog box opens.


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the list menu in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore ( _ ).


3. Enter a label for the list menu in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


A list/menu field appears in your document (Figure 14).


5. Click the list/menu field (not its label) to select it.


6. In the Properties panel, for Type, select List (Figure 15).


Figure 14 Example of list/menu field


Figure 15 Form List Menu Properties panel
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7. In the Height text box, enter the number of items the list 
will display.


If this number is less than the total number of items in the 
list, a scroll bar will be displayed.


8. If you want to allow visitors to select more than one item 
in the list, select Allow Multiple for Selections.


9. Click the List Values button to add the list items.


The List Values dialog box opens (Figure 16).


10. With the insertion point in the Item Label text box, enter 
the text you want to appear in the list.


11. In the Value text box, enter data you want sent to the 
server when a visitor selects the item.


If you enter no value, then the form sends the label as the 
value for that item.


12. Press Enter (Windows) or Return (Mac OS).


13. To add another item to the list, click the plus (+) button.


14. When you finish, click OK to close the List Values dialog 
box.


Figure 16 List Values dialog box


Figure 17 Form List Menu Properties panel


15. To have one of the items in the list selected by default, 
select that item in the Initially Selected text box in the 
Properties panel (Figure 18).


The Initially selected item appears in the form 
(Figure 18).


Figure 18 Form list with three items in the list


To add a drop-down menu:


1. Click the List/Menu button (Windows) or Select (List/
Menu) button (Mac OS).


The Input Tag Accessibility Attributes dialog box opens.


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the pop-up menu in the ID text box. 
You may use any combination of letters, numbers, and an 
underscore (_).


3. Enter a label for the pop-up menu in the Label text box. 
You can leave the other properties in the dialog box at 
their default values. 
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4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


A list/menu field appears in your document (Figure 19).


5. Click the list/menu field (not its label) to select it. 


6. In the Properties panel, for Type, select Menu.


7. Click the List Values button to add the menu items.


The List Values dialog box opens (Figure 20).


8. With the insertion point in the Item Label text box, enter 
the text you want to appear in the menu.


9. In the Value text box, enter data you want sent to the 
server when a visitor selects the item.


10. Press Enter (Windows) or Return (Mac OS).


11. To add another item to the menu, click the plus (+) 
button.


12. When you finish, click OK to close the List Values dialog 
box.


13. To have one of the items in the menu selected by default, 
select that item in the Initially Selected text box in the 
Properties panel. 


Note: To see the menu items in operation,  preview this 
page in a browser (Figure 21).


Figure 19 A list/menu field


Figure 20 List Values dialog box


Figure 21 Preview in a browser


Using form buttons
Form buttons control form operations. Use a form button to submit data entered into a form to the server or to reset 
the form. There are two types of form buttons: Standard text buttons are the browser's default button style, with text 
you want to display (typically Submit, Send, or Reset); graphical buttons use the graphic of your choice.


To add a standard text button:


1. Click the Button button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens.


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the button in the ID text box. You may 
use any combination of letters, numbers, and an 
underscore (_).


Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values.
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3. Don’t enter a label for the button. Click OK to close the 
Input Tag Accessibility Attributes dialog box.


Note:  A label would appear next to the button, rather 
than on it, so you don’t want a label for a button form 
element. The text on the button itself is set by the button’s 
value attribute, which you will set in the next step.


A text button appears in the document (Figure 22).


Note: In this example, a Submit button is placed below 
an existing file field.


4. Click the button to select it.


5. In the Properties panel’s Value text box, enter the text you 
want to appear on the button (Figure 23).


Note: It’s a good idea to set the value to whatever the 
button does. “Submit” is a good choice, but you might 
also consider brief phrases in the forms of commands (for 
example, “Send Message” or “Update Profile” or 
“Register”).


6. Select the type of Action (usually this is Submit Form).


Figure 22 Example of text button


Figure 23 Form Button Properties panel


Adding a graphical submit button


You can use images as submit button icons. Using an image to perform tasks other than submitting data requires 
attaching a behavior to the form object by using the Behaviors panel.


To add a graphical submit button:


1. Click the Image Field button in the Insert panel.


The Select Image Source dialog box appears (Figure 24).


2. Locate and select the image to use as the submit button 
icon; then click OK (Windows) or Open (Mac OS).


The Input Tag Accessibility Attributes dialog box opens.


3. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the button in the ID text box. You may 
use any combination of letters, numbers, and an 
underscore (_).


Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values.


Figure 24 Select Image Source dialog box
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4. Don’t enter a label for the button. Click the OK button to 
close the Input Tag Accessibility Attributes dialog box.


The graphical submit button appears in your document 
(Figure 25).


5. Click the button to select it.


6. In the Alt text box, type alternate text you want to appear 
in place of the image for text-only browsers (Figure 26). 
This should match any text displayed on the button.


Note: You can also click the folder icon beside the Src 
text box to select a new image for the button.


Figure 25 Example of graphical submit button 


Figure 26 Form Image Field Properties panel


Using jump menus for navigation
A jump menu is a pop-up menu with options that link to documents or files. It is a form element that acts as 
navigation. You can create links to documents in your website or other websites, e-mail links, links to graphics, or 
links to any file type that can be opened in a browser. Because using this type of menu will cause the browser to 
navigate to another page, don’t mix jump menus with other form elements.


To add a jump menu:


1. Click the Jump Menu button in the Insert panel.


The Insert Jump Menu dialog box opens (Figure 27).


2. Complete the dialog box.


For more information, click the Help button in the dialog 
box.


3. Click OK.


Figure 27 Insert Jump Menu dialog box
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LEARNING THE LANGUAGE OF THE WEB



INTRODUCTION TO HTML AND CSS
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What is HTML?

		HTML stands for:

		Hypertext

		Markup

		Language

		A markup language, HTML elements are the building blocks of web pages.

		HTML elements use tags to structure content.



*
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Tags

HTML elements consist of tags.

Tags are enclosed by angle brackets, like this: <html>

Tags usually come in pairs, like this: <title> and </title>

Tags have a start (or opening) and end (or closing).

Tags are not displayed in a web browser.

Tags interpret how to display content between the tags.

*

<html>

	<head>

		<title></title>

	</head>

	<body>

		<h1></h1>			<p></p>

	</body>

</html>
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Tags

<html></html> describes the web page.

<head></head> describes the header.

<body></body> describes visible page content.

Common formatting tags:

<h1></h1> displays a heading, ranging from size 1 (biggest) to 6 (smallest).

<p></p> formats text as a paragraph.

<strong></strong> bolds text.

<em></em> emphasizes text, displays as italics.

<br> creates a line break.

Links:

<a href="http://www.example.com"></a> creates a link to a web page.

*
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CSS

CSS stands for:

Cascading

Style

Sheets

Describes the “look and feel” of HTML elements on a web page.

Helps separate document content (HTML) from document presentation (CSS).

Structures presentation elements such as layout, colors, and fonts.

*
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CSS

		A style sheet contains a list of rules about how elements appear on a page.

		Consists of a selector and a declaration block:

		Selectors tell which markup elements the style applies to.

		A declaration block is a list of property and value pairs that define the style.

		Can be embedded inside the HTML or linked as a separate document.



*

h1 {

	font-family: Verdana, Geneva, sans-serif;

	font-size: 24px;

	font-weight: bold;

	text-transform: uppercase;

	color: #C00;

}
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Evolution of HTML and CSS

HTML and CSS are a collection of web standards. 

HTML and CSS are a set of best practices for building websites.

HTML and CSS are constantly evolving:

HTML5 is the fifth iteration of HTML and adds tags to support multimedia elements and dynamic graphics in modern web browsers.

CSS3 defines a new set of modular rules for how HTML content will be presented within the web browser.

*
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HTML5 best practices

Use HTML5 <!doctype html> to tell a browser how to translate.

Use <meta charset="utf-8"> to tell a browser the character-set.

Use semantic markup tags <article>,  <section>,  <header>,  <nav>, and others to bring a higher level of structural meaning to documents.

Design and test content across a range of browsers and devices that support HTML5 capabilities.

*
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Introduction to game design
Electronic games are growing in popularity—and not just with kids and teens. With the ubiquity of mobile devices, 
you’ll find that just about everyone from small children to grandparents has a favorite online game. 


Gaming trends
With the popularity of mobile devices, several new trends are emerging. 


• There is renewed demand for simple and repetitive games.


• Lower-budget games created by individuals and small teams can be financially successful.


• You can find them on game arcade sites such as Newgrounds.com and AddictingGames.com.


• You can choose from dozens of game genres: action, adventure, casino, puzzle, role-playing, and more.


• For many developers, the Adobe Flash platform is the preferred tool for game development.


Figure 1 Mobile game examples


Principles of game design and development
One way to get started developing games is to use Adobe Flash Builder or Adobe Flash Professional (development 
environments) to develop a single-player game (that is, one that does not need a real-time multi-player server) that is 
published in the SWF file format and runs in Flash Player (a runtime) in a web browser.


Runtimes


A runtime is a software component designed to support the execution of computer programs. The Adobe Flash 
Platform includes two runtimes: Adobe Flash Player and Adobe AIR.


Adobe Flash Player


Adobe Flash Player is a browser plug-in that provides a multi-platform client runtime. You can build your game once 
and it will look the same in virtually any web browser and on Windows, Mac OS, or Linux operating systems. Flash 
Player plays content that has been compiled into an SWF file. Flash Player is licensed free of charge so end users can 
start playing your game without additional costs. 


Adobe AIR


Adobe AIR lets you view SWF content on your desktop without a web browser. You need to have the AIR runtime 
installed to run AIR files. The AIR runtime is licensed free of charge to end users. 
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Development environments


Adobe Flash Professional CS6 and Adobe Flash Builder 4.6. are development environments for creating SWF-based  
games and other online content.


Adobe Flash Professional CS6


In Flash Professional CS6, you can see your layouts and animations as you work with them. For that reason, it’s very 
popular with developers who create visual games. It strikes a good balance between visual design and code design.


Adobe Flash Builder 4.6


Adobe Flash Builder 4.6 is used by developers who create Rich Internet Applications (RIAs) that connect to a data 
source or web service. For example, an application that regularly updates to show current movie times could be 
created by using Flash Builder. Flash Builder is a popular tool for creating web applications and mobile apps, 
including games.


Many developers use a combination of Flash Builder and Flash Professional when developing games. For example, 
you can use Flash Professional to design the graphic elements of your game (characters, maps, effects, and so on) 
while your developer works in Flash Builder to build the final game controls and connect the game to a server and 
other players.


Key components of a game
Whether you’re building a simple single-player game or a multi-player online gaming world, there are several 
components that are common to most games. 


Input: Input refers to how the user controls the game. Basic games are typically controlled with the mouse, the 
keyboard arrow keys, or both. On mobile devices, touch gestures are the most common input method and the Flash 
Platform has robust touch support.


Sprites: In the gaming world, a sprite is a visual elements such as an alien or fish moving across the screen.   


Note: Game sprites should not be confused with the ActionScript 3.0 class “flash.display.Sprite.”


Sounds: Sound effects in games accent important events to enhance the game play experience. Sounds provide an 
important element of feedback to the player and make games interesting and fun.


Collision detection: This is the code that senses when any two sprites touch on screen, which is crucial for most 
action-oriented games.


Game loop: This is a term used by game developers to describe the programming logic that controls the game 
experience. ActionScript is the programming language you use to execute the game loop in Flash games.


Game design and development workflow
Whether you’re an individual developer creating your first single-player game, or a large corporate team designing a 
complex multi-player environment, you’ll follow a similar workflow for game design and development (Figure 2).


Figure 2 Game design and development workflow
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Plan and design


The most successful games are the product of great ideas followed by great execution. This usually involves a 
combination of sound design principles, creativity, and strong technical development skills.


Each team may work differently to develop new ideas, but the basic planning process is as follows:


1. Brainstorm to develop ideas for the game.


2. Create a storyboard or map of the game world.


3. Design your game in a game design document. 


Brainstorm


Your inspiration for great games can come from anywhere—dreams, movies, books, nature, work, cities, friends, 
family. Sometimes the best ideas are made even better by collaborative brainstorm sessions. Write down all ideas, 
including the outrageous or silly ones.


Storyboards and maps


During the storyboard and mapping process you begin to sketch out characters, backgrounds, screens, game 
mechanics, and more. Game mechanics are the core set of rules that define what makes a game unique. A game 
features a variety of game mechanics, such as keyboard input, turns, decisions, risks and rewards. During this stage, 
the artwork visually communicates your ideas. This is not your final artwork. As your game concept takes shape, add 
details to the game world. Describe the challenges to the game player. Describe the rewards. Does your game have 
characters? What is the plot or story? What motivates the character to do what he does? Does the game player view 
the action from above or from the side? Does gravity exist in the game? Can the characters be injured and die? If so, 
how? 


Design document


The design document describes the details of the game, including the technical requirements for development. In a 
team development environment, the design document is especially important. It includes final decisions regarding the 
game's visuals, game mechanics, and menus. It helps ensure all team members are on the same page during 
production.


• Who is your target audience? Are they experienced gamers with patience for difficult game play or casual 
gamers who want something easier?


• What devices will you target? A big browser window, a small phone screen, or both? Consider the unique 
characteristics of each delivery screen.


• What spoken languages will be included? How will the translation of the game be organized? What logos, 
art, menus, and other text will be affected? If the game will be localized into more than one language, what 
is your plan to accommodate them?


Develop


The following are the basic steps to developing a game with Flash technology:


1. Follow your design document.


2. Build the game in stages, creating standalone demo projects. This will help to identify and trouble-shoot aspects 
of the game that are difficult to implement or create usability issues during play.


3. Create an assets library of artwork in Flash or other Creative Suite products. Locate royalty-free sounds online.


4. Construct the menus. Games often feature screens outside of the game itself such as the introduction, 
instructions, and Game Over screen.


5. Test the game repeatedly throughout the development process to be sure it's enjoyable and challenging.
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Test


Testing can take many forms. If you are an individual developer, the testing process can involve you and a few friends 
playing the game. Try to have open eyes and an open mind, so you can see new problems and new solutions. 


Larger game development teams often have a dedicated quality assurance (QA) team of testers. This group plays the 
game and builds a list of changes and suggestions.


Regardless of the team size, a good testing process will answer these fundamental questions:


• Is it fun?


• Does it work (is it free of bugs)?


• Does it perform as expected on the desired platforms?


You can use Flash Professional CS6 to target many devices, but designing, developing and testing for multiple 
screens presents a unique set of challenges. 


For web games, test the game on a variety of computers and web browsers. Ensure it works well in all cases. Even 
when the game works great on your personal machine, it is important to keep in mind the computers and devices of 
your audience.


For mobile phones and tablets, testing can be more difficult. Differences between devices (for example, screen size, 
screen density, and input schemes) and the sheer number of devices available can complicate the process. Flash 
Professional includes mobile device support to simulate, test, and publish applications to a wide array of devices. For 
example, you can use the AIR mobile simulator to test mobile application interactions. Flash Builder and Flash 
Professional ship with a debug version of Flash Player that provides additional information (such as output tracing 
and redraw regions) as you develop and test. Flash Professional also ships with Device Central, a package of 
emulators that simulate popular mobile devices right on your computer. 


Test on each physical device if possible.


Monetize


There are two main approaches to turning games into revenue: offer games that are free to play or offer premium 
games that cost money to play.  


There are several ways to monetize free games:


• Advertisements: Place banner advertising on the HTML page surrounding the game or within the game 
itself. Advertising deals are typically paid to game developers based on the number of ads shown 
(impressions) or the quantity of traffic generated (clicks).


• Sponsorship: Place advertising, links, logos, and marketing messages within your game for a paying 
sponsor.


• Licensing: Place the advertising, links, logos, and marketing messages within your game for a paying 
sponsor and restrict the game's availability to a single site.


There are also several ways that you can make money by selling a Flash game directly to the video game community:


• Straight sale: Sell the complete game for one up-front cost.


• Freemium: Offer a free trial and then let users pay for upgrading to a complete version.


• Micro-transactions: Encourage users to convert real-world money into virtual game currency to unlock 
characters, abilities, levels, or other content. Micro-transactions and freemium games are sometimes used 
together.


• Subscriptions: Players can continue playing if they make regular payments (usually on a monthly basis). 
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Distribute


Once you’ve developed your game, select a strategy for getting the game in the hands of players. The Flash Platform 
offers several deployment options to reach your intended audience. 


Flash Platform deployment options via Flash Player:


• Web browser (PC, Mac, Linux, mobile)


• Mobile browser (Android, BlackBerry)


Note: The Apple iOS Safari web browser does not support any version of Flash Player. To deploy your game on an 
iOS device, package the game as a standalone application using Adobe AIR.


Flash Platform deployment options via Adobe AIR technology:


• Desktop (PC, Mac, Linux)


• Android (Phones and tablets)


• Apple iOS (Phones and tablets)


• BlackBerry Tablet OS (tablets)


• Internet-enabled televisions and appliances


The distribution and monetization strategy for your game is best defined during the brainstorming stage. The 
distribution strategy affects your game because the target device determines screen sizes and input styles. The 
monetization strategy you choose also affects game content. You may need to implement advertisement integration, 
links or buttons to sponsors, virtual item sales, and more.


Analyze and update


Consider the following steps to analyze and update your application before you publish it:


• Conduct usability studies and focus groups to gather user feedback.


• Update your game often after its initial launch to ensure it has the longest life possible. 


• If you’re using a subscription-based monetization strategy, release episodic content to keep subscribers 
happy.


• Make improvements to the game based on analytics and user feedback.


• Add new content, such as levels and characters.


• Fix bugs.


Choosing Input methods and features
Games designed to run in a web browser or as a standalone application on your computer rely primarily on mouse and 
keyboard input to control the game. Other devices, such as phones, tablets, or your television rely on a range of other 
inputs and may include features not typically found in computer games. One example is the use of touch-screen input 
found on most phones and tablets. Some devices feature a dedicated Back button and volume controls, but some do 
not. While there are certainly commonalities between the input styles on many popular devices, you should consider 
the best input solution for each device and customize your game as needed. 


The Flash Platform currently supports multi-touch and gestures in Flash Player 10.1 or higher in the browser, SWF 
content published for the iPhone or iPod touch, and in AIR 2 or higher. 
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Many devices have features that can be used for gaming. Here are a few examples and some considerations for each.


• Accelerometer: Many smartphones, tablets, and game consoles sense their angle of rotation by using an 
accelerometer. You can use this for aligning and moving objects on the screen.


• Application multitasking: How will your game behave when minimized and maximized? If it’s a mobile game, 
does it automatically pause when the phone rings?


• Casual connectivity: Users are not always connected to the Internet. Does your game require constant 
connectivity? Will it have an offline mode and an online mode?


• GPS/Geolocation: Devices with geolocation, including most smartphones and tablets, know where they are in 
the world. You can use this to change the game experience, unlock content, or introduce game players who are 
close to each other.


• Microphone: Use voice or sounds as an input—most current smartphones and tablets include voice input options 
as an alternative to typing text. Consider creating a character that interacts with players by having a conversation. 


• Persistence: Many mobile users play games in short bursts, starting and stopping the game when they have time 
for fun. If your game saves its progress, users can jump back into the action quickly.


• Sleep-mode: Some devices sleep when not in use. How will your game react? If the user becomes distracted and 
sets down the device, will the game pause or will it continue to consume battery life?


• Still camera: You can use a device’s built-in camera to let users add their own images to a game.


Conclusion
Flash games are everywhere. Based on their growing popularity, this is a great time to get started developing some 
games of your own. The following are examples of popular games:


• Drag-and-drop games that let players solve a puzzle or build something by selecting, dragging, and placing 
objects.  


• Character movement and adventure games that require players to guide a character through a course of 
obstacles to reach a goal.


For examples of easy-to-develop Flash games, visit: www.flashclassroom.com 


The user-friendly design, coding, and multiscreen testing features of Adobe Flash Professional CS6 make it the 
perfect tool for new game designers. 


Using Adobe Flash Professional CS6, you can turn some of your most creative ideas into fully functioning, 
marketable, and fun-to-play games. 
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Review and redesign


Student name:_________________________________________________ Date: ________________________


The questions on this worksheet will help you think about reviewing and redesigning your web project.


Questions are in the following categories:


• Meeting initial goals


• Requiring new goals


• Reflecting good design principles


• Reflecting good usability and accessibility principles


• Maintaining consistency


• Producing web projects that work equally well on various operating systems, browser versions/configurations, 
and devices


• Planning redesign changes


Meeting initial goals
What were your initial goals for the web project?


Does the web project you built match the initial goals? Why or why not?
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Requiring new goals
Do you have new goals in mind for the web project? If so, what are these and why are you changing your goals?


Reflecting good design principles
What design elements and principles did you originally incorporate into the web project?


Do you want to include new design elements or principles in your web project? If so, what are they and why do you 
want to include them?


Reflecting good usability and accessibility principles
What usability and accessibility principles did you originally incorporate into the web project?

Review and redesign © 2012 Adobe Systems Incorporated







Digital Design Project 3 worksheet

What changes do you need to make to better reflect the best practices for producing a web project that is highly 
usable and accessible?


Maintaining consistency
What techniques did you use in your web project to maintain consistency?


What changes do you need to make to better reflect the best practices for maintaining consistency?


Producing web projects that work equally well on various operating systems, browser 
versions/configurations, and devices
What operating systems, browsers, and devices did you target for your web project?
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What techniques did you use to make sure your web project worked well on the targeted operating systems, browsers, 
and devices?


What changes do you need to make to increase the usability of your web project on the targeted operating systems, 
browsers, and devices?


Are there additional operating systems, browsers, or devices your would like your web project to work well on? If so, 
what are they and why do you want to include them? What new techniques will you have to use or changes will you 
have to make to deliver your web projects on the additional operating systems, browsers, and devices?


Planning redesign changes
Based on how you answered the questions above, what changes do you need to make to your web project? Sketch 
your changes below in addition to writing about them.
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Sketch of design changes
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How to promote a website


Team name: __________________________________________________ Date: ________________________


Investigate how to use search engines on the web to promote a website. When you submit the URL for your site to a 
search engine, people can locate your site based on information you provide about your site.


Conduct a web search for “search engine submission” for search engine submission tips.


Find a search engine that offers free submission of websites.


Site name and URL: ____________________________________________________________________________


Submission procedure: __________________________________________________________________________


Find a search engine or promotion site for which you pay to submit your site.


Site name and URL: ____________________________________________________________________________


Cost to submit: ________________________________________________________________________________


Submission procedure: __________________________________________________________________________


Is this search engine or promotion site worth the cost? Why or why not? ___________________________________
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How to optimize Flash content
As with all web content, it is important to keep Adobe Flash Professional CS6 file sizes as small as possible. Even 
though connection speeds have increased in the past few years, keeping file sizes small continues to be important, 
because document size can also affect content performance, and content is now delivered on a range of devices. This 
process is known as optimizing Flash content.


The following general principles can help you optimize Flash content:


• Use symbols, animated or otherwise, for every element that appears more than once.


• When creating animation sequences, use tweened animations whenever possible. These animations use less 
file space than a series of keyframes.


• For animation sequences, use movie clips instead of graphic symbols.


• Limit the area of change in each keyframe; make the action take place in as small an area as possible.


• Avoid animating bitmap elements; use bitmap images as background or static elements.


Optimizing images
Images present one of the best opportunities for optimizing file size in Flash.


Certain fills and effects can increase the size of your Flash movie. Use the following tips to optimize these movie 
features:


• Use the Color Effect section in the Symbol Properties panel to create many different-colored instances of a 
single symbol instead of creating multiple symbols.


• Use gradients sparingly. Minimize the number of simultaneous gradients in any given frame. Filling an area 
with gradient color requires about 50 bytes more than filling it with solid color. Gradients are also more 
complex for a computer processor to handle than a solid color.


• Use alpha transparency sparingly. It can slow playback.


Optimizing bitmaps


Bitmap images take up more space than vector images (vector is Flash’s normal format). Bitmap images are imported 
into Flash. JPEGs, GIFs, and BMPs are all bitmapped. The best bitmap format to import into Flash is PNG, which is 
the native file format of Adobe Fireworks. All photos—which are usually in JPEG form—are bitmapped. When you 
create an animation with bitmap images, Flash must store one bitmap image in each frame of the animation. In 
addition, bitmap images, unlike vector images, do not scale or rotate well on the screen; and bitmap images must be 
rendered each time they change positions on the screen. This often entails changing large areas of the movie and 
slowing down playback as these areas are continually redrawn.


If you feel your Flash movie must include bitmaps, use the following tips to optimize your movie:


• Use bitmap images sparingly.


• Avoid animating bitmap images.


• Convert the bitmap image into a symbol if it appears in more than one keyframe.


Use the Trace Bitmap command


The Trace Bitmap command (Modify > Bitmap > Trace Bitmap) lets you convert a bitmap to a vector image. This 
works best with simple images made up of mostly large blocks of color. If the bitmap contains complex shapes and 
many colors, the converted vector graphic can have a larger file size than the original bitmap. Try a variety of settings 
in the Trace Bitmap dialog box to find a balance between file size and image quality.
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Compression options


Compression helps reduce the total file space occupied by bitmap images. JPEG compression is the default 
compression for all bitmap images published from Flash. In the Publish Settings dialog box, you can adjust the value 
in the JPEG Quality field from 1 (most compression, lowest quality) to 100 (least compression, highest quality). 
Because JPEG compression can result in a loss of image data, test images with different JPEG quality values to 
achieve the best balance between compression and image quality for your particular movie.


Optimizing sound
Sound is another factor that can increase Flash file size. There are several ways to use sound efficiently in a movie 
and keep file size down.


• Use MP3 compression, the smallest sound format, whenever possible.


• Keep sounds short.


• Use the lowest bit-depth and sample rate acceptable to achieve the smallest data size. Try to find a happy 
medium between quality and data size.


• Loop short sounds to create background music.


• Looping smaller event sounds can achieve longer audio playback because a small amount of sound data is 
downloaded once and used repeatedly.


• Do not set streaming sound to loop.


• Use the Event synch option to deliver the sound data all at once as needed for playback. Use Stream synch to 
deliver the sound data over the specified series of frames. Try both approaches. Then watch the size report 
closely for clogging of data near keyframes, and use the preloading techniques to trim down the amount of 
data needed per frame or per second. You can generate a size report for a Flash movie when viewing the 
Flash (.swf) settings in the Publish Settings dialog box (File > Publish Settings, click Flash (swf.), select 
Generate Size Report in the Advanced section).


For more information about best practices in Flash, see the “Best Practices” section in Using Flash (Help > Flash 
Help).
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Setting audio compression options
In the following steps, you set audio to stream and add the audio to the timeline.


To set audio compression options:


1. Import audio into the sound layer of your Flash 
document.


2. In the Properties panel, set Sync to Stream (Figure 1).


Although streaming means losing some audio quality, it 
creates a smaller SWF file and synchronizes the audio to 
the object movements on the Stage.


If your sound file is longer than the elapsed time in the 
Timeline panel (Figure 2), you’ll need to add more 
frames in the sound layer to hear the entire sound file.


3. Use the frame rate shown at the bottom of the Timeline 
panel (Figure 2) and the length of the audio to calculate 
how many frames are required to play the entire sound 
file. For example, if your sound file is five seconds, and 
the frame rate is 24 fps, the timeline must extend to at 
least 120 frames.


You can add the new frames by inserting a single frame 
further down the timeline.


4. Based on the duration of the sound clip and the 
calculation you made in step 3, select the frame in the 
timeline where the sound file will end, and extend the 
timeline by selecting Insert Timeline > Frame.


All the audio will be visible in the timeline.


Note: Do not use Insert > Keyframe, because a new 
keyframe would stop the audio before it is finished.


Figure 1 Sound section of the Properties panel


Figure 2 Timeline panel


Frame rate Elapsed 
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Review and redesign


Student name:_________________________________________________ Date: ________________________


The questions on this worksheet will help you think about reviewing and redesigning your web project.


Questions are in the following categories:


• Meeting initial goals


• Requiring new goals


• Reflecting good design principles


• Reflecting good usability and accessibility principles


• Maintaining consistency


• Producing web projects that work equally well on various operating systems, browser versions/configurations, 
and devices


• Planning redesign changes


Meeting initial goals
What were your initial goals for the web project?


Does the web project you built match the initial goals? Why or why not?
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Requiring new goals
Do you have new goals in mind for the web project? If so, what are these and why are you changing your goals?


Reflecting good design principles
What design elements and principles did you originally incorporate into the web project?


Do you want to include new design elements or principles in your web project? If so, what are they and why do you 
want to include them?


Reflecting good usability and accessibility principles
What usability and accessibility principles did you originally incorporate into the web project?
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What changes do you need to make to better reflect the best practices for producing a web project that is highly 
usable and accessible?


Maintaining consistency
What techniques did you use in your web project to maintain consistency?


What changes do you need to make to better reflect the best practices for maintaining consistency?


Producing web projects that work equally well on various operating systems, browser 
versions/configurations, and devices
What operating systems, browsers, and devices did you target for your web project?
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What techniques did you use to make sure your web project worked well on the targeted operating systems, browsers, 
and devices?


What changes do you need to make to increase the usability of your web project on the targeted operating systems, 
browsers, and devices?


Are there additional operating systems, browsers, or devices your would like your web project to work well on? If so, 
what are they and why do you want to include them? What new techniques will you have to use or changes will you 
have to make to deliver your web projects on the additional operating systems, browsers, and devices?


Planning redesign changes
Based on how you answered the questions above, what changes do you need to make to your web project? Sketch 
your changes below in addition to writing about them.
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Sketch of design changes
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How to make websites accessible
Creating accessible web pages has never been more important than today. With the adoption of accessibility standards 
in the United States, Canada, the European Union, Australia, Japan, and other countries, designers and developers 
need to ensure that people with disabilities can access the contents of websites and web applications, as well as the 
authoring tools used to create them.


Accessibility refers to making websites and web products usable for people with visual, auditory, motor, and other 
disabilities. Examples of accessibility features for software products and websites include screen reader support, text 
equivalents for graphics, keyboard shortcuts, change of display colors to high contrast, and so on. Dreamweaver 
provides tools that make it accessible to use and tools that help you author accessible content.


Dreamweaver enables designers and developers to create accessible pages that contain useful content for screen 
readers and comply with federal government guidelines. For example, dialog boxes prompt you to enter accessibility 
attributes—such as text equivalents for an image—when you insert page elements. Then, when the image appears on 
a page for a user with visual disabilities, the screen reader voices the description.


Note: For more information about two significant accessibility initiatives, see the World Wide Web Consortium Web 
Accessibility Initiative (www.w3.org/wai) and Section 508 of the U.S. Federal Rehabilitation Act 
(www.section508.gov). 


No authoring tool can automate the development process. Designing accessible websites requires you to understand 
accessibility requirements and make ongoing decisions about how users with disabilities interact with web pages. The 
best way to ensure that a website is accessible is through deliberate planning, development, testing, and evaluation.


Accessibility preferences options
To create accessible web pages, page elements need to be marked up with information for assistive technology, such 
as screen readers. For example, each image on a page should be given a text equivalent, called alternative text (alt 
text), that a screen reader voices to users in place of the image (Figure 1).


Figure 1 Displaying alternative text


Designers often overlook accessibility features such as alt text when creating websites, but Dreamweaver CS6 
enables you to set preferences that prompt you to provide accessibility information as you’re building the page. By 
activating options in the Preferences dialog box, you'll be prompted to provide accessibility-related information for 
form objects, frames, media, images, and tables as each element is inserted in a page. 
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To set the accessibility preference, choose Edit > Preferences (Windows) or Dreamweaver > Preferences (Mac OS) 
and select the Accessibility category in the Preferences dialog box (Figure 2).


Figure 2 Dreamweaver Preferences dialog box, Accessibility category


For example, if you choose the Images option in the Show Attributes list, you are prompted (Figure 3) to provide the 
alt text equivalent and a description for each image as you insert it.


Figure 3 Image Tag Accessibility Attributes dialog box

How to make websites accessible © 2012 Adobe Systems Incorporated







Adobe Dreamweaver CS6 Project 4 guide

Creating accessible tables and forms presents some challenges, but Dreamweaver CS6 simplifies the process. For 
example, as you insert a data table within Dreamweaver CS6, you're immediately prompted to provide summary 
information, a caption, and the position of heading cells in the table (Figure 4). Incidentally, by adding identifying 
heading cells—an important but often overlooked design step—you make it significantly easier for assistive 
technology users to navigate tables. 


Figure 4 Table dialog box


Creating accessible forms is also easy with Dreamweaver CS6. When you select the Form Objects option in the 
Preferences dialog box, you're prompted to provide a label for each form object, along with a shortcut key and the tab 
order position (Figure 5). Specifying the label allows assistive technology users to understand the purpose of each 
form object as they complete the form.


Figure 5 Input Tag Accessibility Attributes dialog box
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Accessibility validation
There are a number of third-party web accessibility evaluation tools that you can use to validate your completed 
websites. The W3C Web Accessibility initiative provides a comprehensive list of these tools at http://www.w3.org/
WAI/RC/tools/.


Accessible templates
Dreamweaver CS6 includes several templates designed for accessibility. These templates are visually balanced, as 
well as accessible to people with disabilities (Figure 6). They provide you with a fast and easy way to create exciting, 
engaging, and accessible content. 


Figure 6 Dreamweaver sample HTML template


How to meet accessibility requirements
The W3C Web Accessibility Initiative has developed a quick reference list Web Content Accessibility Guidelines 2.0 
requirements and techniques.


1. Text Alternatives: Provide text alternatives for any non-text content so that it can be changed into other 
forms people need, such as large print, braille, speech, symbols or simpler language.


2. Time-based Media: Provide alternatives for time-based media.


3. Adaptable: Create content that can be presented in different ways (for example simpler layout) without 
losing information or structure.


4. Distinguishable: Make it easier for users to see and hear content including separating foreground from 
background.


5. Keyboard Accessible: Make all functionality available from a keyboard.
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6. Enough Time: Provide users enough time to read and use content.


7. Seizures: Do not design content in a way that is known to cause seizures.


8. Navigable: Provide ways to help users navigate, find content, and determine where they are.


9. Readable: Make text content readable and understandable.


10. Predictable: Make Web pages appear and operate in predictable ways.


11. Input Assistance: Help users avoid and correct mistakes.


12. Compatible: Maximize compatibility with current and future user agents, including assistive technologies.
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Peer Review


Name: _______________________________________________________ Date: ________________________


Project: _____________________________________________________


Overview
Revision is an important part of the design process. In addition to conducting review and redesign cycles personally 
and with your client, you can also benefit from peer review. Additionally, peer review occurs in many professional 
environments and it will be good practice to start on this essential skill now.


When giving peer review, be sure your points are both positive and negative. Give your critiques as suggestions, not 
commands. When receiving peer review, do not be disenchanted or feel that you did a bad job based on one review. 
Every review is different, and what one person does not approve of, the next person may find exemplary.


Process for presenting work for peer review


• When presenting your work for peer review, state the purpose, audience, and goals of your document and 
point out any concerns you have.


• To conclude, summarize the reviewer’s suggestions and offer a plan for revision.


Guidelines for giving comments and suggestions


• Before making any comments, review the entire document and make sure you understand the designer’s 
intentions. Or, if being presented work by a designer, your first response should be to reiterate the designer’s 
purpose, audience, and goals.


• After the designer’s purpose, audience, and goals are clear, ask questions of the designer, make comments, 
and offer suggestions.


• Point out both the strengths and the weaknesses of the document (design, layout, typography, and so on).


• Offer suggestions, not commands. For instance, do not use “should,” as in “You should do this….” Instead, 
use “I” statements, such as “I see that…” or “I’m confused about....”


• Be respectful and considerate of your peer’s feelings. Do not say or write anything you wouldn’t want to 
receive yourself—there is no reason to be rude.


• Make sure your comments are clear and specific so your peer knows what you are referring to. It is 
important to give specific examples and point to design principles, image composition, layout guidelines, 
and so on to make your point. Such comments as “this is unclear” or “this is too vague,” are too general to be 
helpful. Rather make a comment like, “I’m confused by this image because there is no caption identifying 
what it is”).


• If you are writing your comments, reread them before passing them on to your peer. Make sure all your 
comments make sense and are easy to follow.
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How to create a design comp
A comprehensive artwork (comp for short) is a design proposal presented by the designer to the client for approval. 
Web design comps provide a rough visual draft of the overall user interface (including graphics, interface design 
elements, navigation system, and main content areas) before specific content is placed (Figure 1).


Fireworks provides an ideal prototyping environment, seamlessly converting design comps into real-world widgets, 
websites, and applications.


Figure 1 Design comp 


The web design process
The typical web design process may be comprised of several stages, including any of the following:


1. Brief provides a statement of technical, design, and idea goals for the web project.


2. Research involves a range of investigative activities including a review of related web designs, analysis of 
competitor sites, user flows, personas, market analysis, use cases, and more.


3. Brainstorming is a conceptualizing stage based on the brief and research stages in which many ideas are 
generated in a short amount of time. 


4. Creative solution follows the brainstorming phase in which briefs, research, and ideas are combined to 
create a clear design direction. This stage can include technical specifications, information architecture 
diagrams, functioning wireframes, and design comps. This stage is often iterative, a repeating process in 
which problems are solved, designs are presented to clients for feedback, website functionality is developed 
and tested, and revisions are made.


5. Production fully realizes the web project. Design comps are finalized and integrated into the wireframe 
prototype, and the web project is scaled up to full production. 


As you can see, the design comp is an important piece of the web design process from the creative solution right to 
the production stage. 


Consider the following questions as you plan and build your design comp for a web project.
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Organizing content


How you organize content on a page highlights important features and elements of your web project. Important 
elements might be higher in the page, larger in size, or in stronger colors. Include rough descriptions of navigation, 
copy layout, graphic allocation, key headers, and other elements that appear on a screen. Identifying common 
structures between pages helps visitors understand they are in the same site as they navigate from page to page.


• Will your page banner be on each page? If yes, is it in the same place? Is it the same size?


• What font will you use for titles or headings on your content pages?


• What color will you use for titles or headings on your content pages?


• What font will you use for descriptions on your content pages?


• What color will you use for descriptions?


Navigation


For visitors of your website or application to understand the content, you must provide clear navigation. Visitors need 
to know where they are in a site, where they need to go, and how to get back to where they came from. Having a 
consistent layout grid helps orient visitors and keeps them from feeling lost. Using consistent buttons, links, and 
graphics on each page maintains a sense of place. As visitors move from page to page, provide familiar visual cues 
and navigational aids.


Here are some questions to answer:


• Where will you place the navigation bar on the page?


• What content will be on the navigation bar?


• Will the navigation bar be on every page?


• How will your navigation bar help visitors know which page they are on?


Creating a design comp with Adobe Fireworks CS6 
The following steps describe a typical proces to follow when using Fireworks to create a design comp. The design 
comp process described here uses previously-prepared files including a background image, logo, text, and a 
photographic image.


To create the canvas and import files:


1. Start Fireworks and create a new document using the 
dimensions for your web project. 


2. With Layer 1 selected, choose File > Import.


The Import dialog box (Windows) or Import File dialog 
box (Mac OS) opens.


3. Navigate to a background image you want to use, and 
click Import (Windows) or Open (Mac OS).


4. Click in the upper-left corner of the canvas to place the 
imported background at that location. 


The background image is placed on the canvas.
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5. In the Properties panel, confirm that the X and Y 
coordinates are both set to 0 (Figure 2).


6. Choose File > Import.


The Import dialog box (Windows) or Import File dialog 
box (Mac OS) opens.


7. Navigate to a logo file and click Import (Windows) or 
Open (Mac OS).


The Import Page dialog box opens (Figure 3).  


A single Fireworks PNG file can contain multiple pages. 
When you insert a PNG file, or page, containing objects 
from the master layer, the master page is converted to an 
ordinary layer, and imported. 


8. Click the Import button (Windows) or Open button (Mac 
OS) in the Import Page dialog box.


9. On the canvas, click near the top edge and to the right of 
the upper-left corner to place the imported logo at that 
location.


The logo image is placed on the canvas. 


10. Choose File > Import.


The Import dialog box (Windows) or Import File dialog 
box (Mac OS) opens.


11. Navigate to a photograph file and click Import 
(Windows) or Open (Mac OS).


12. On the canvas, click in the main content area to place the 
imported logo at that location.


The photograph is placed on the canvas. 


13. Select File > Save As and save the file as a PNG.


Figure 2 Properties panel, bitmap mode


Figure 3 Import Page dialog box


To use drawing tools, fills, and the alignment panel:


1. From the Tools panel, select the Rectangle tool.


2. In the Properties panel, click the Gradient Fill button.


The Edit Gradient pop-up window opens (Figure 4). 


3. Set the gradient type to Linear, if not already selected.


Figure 4 Properties panel, Edit Gradient window


X and Y 


Gradient Fill Color swatches


Gradient type


Solid Fill
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4. Click the color swatch on the left and select a dark-gray 
color such as HEX value #222222 (Figure 5) .


5. Click the color swatch on the right and select a slightly 
lighter gray color such as HEX value #333333.


6. Click the Gradient Fill button again to close the Edit 
Gradient window.


7. Drag to draw a rectangle shape at the bottom of the 
canvas.


This rectangle will become the web page footer.


8. Choose Select > Deselect.


9. From the Tools panel, select the Rounded Rectangle tool.


10. In the Properties panel, click the Solid Fill button and 
choose a light-gray color such as HEX value #CCCCCC.


Note: You could choose instead to add a gradient fill to 
the rounded rectangle shape.


11. Click the Solid Fill button again to close the color pop-up 
window.


12. In the Properties panel, set Stroke Color to white (HEX 
value #FFFFFF), and confirm Tip Size is 1, and Stroke 
Category is 1-Pixel Soft (Figure 6).


13. Make sure Smart Guides are visible and active. If not, 
select View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.


14. Drag on the canvas to draw a rounded rectangle suitable 
for use as a button.


15. Select the rounded rectangle shape.


16. Select Edit > Duplicate three times to create a total of 
four buttons.


As you repeat the command, duplicates of the selected 
object appear in a cascading arrangement from the 
original. Duplicates appear 10 pixels lower and 10 pixels 
to the right of the previous duplicate. The most recently 
duplicated object becomes the selected object.


17. Select the Pointer tool and drag a rounded rectangle over 
to the right until the Smart Guides appear along the top, 
and right edge of the object (Figure 7).


18. Arrange the remaining shapes in a row between the first 
and the last rounded rectangle. 


Don’t worry about the spacing, you’ll take care of that in 
the next few steps.


19. Choose Window > Align to open the Align panel 
(Figure 9).


20. Shift-click the four rounded rectangle shapes, either on 
the canvas, or in the Layers panel.


Figure 5 Color pop-up window


Figure 6 Properties panel, shape mode


Figure 7 Aligning objects using Smart Guides


Figure 8 The Align panel


Stroke Color Tip Size Stroke Category


Align 
Vertical 
Center


Space 
Evenly 
Horizontally
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21. In the Align panel, click the Align Vertical Center button 
and the Space Evenly Horizontally button.


The rounded rectangle shapes are vertically aligned and 
spaced evenly on the canvas.


22. Select File > Save.


To use text tools:


1. Select the Text tool from the Tools panel.


Text in a Fireworks document appears inside a text block 
(a rectangle with handles).


2. Set text characteristics in the Properties panel (Figure 9):


• Font Family: Georgia


• Font Style: Regular


• Font Size: 46


• Font Color: HEX value #ECECEC


3. Click on the canvas just below the logo to create an auto-
sizing text block.


An auto-sizing text block expands horizontally as you 
type and shrinks when you remove text. Auto-sizing text 
blocks are created by default when you click on the 
canvas with the Text tool and start typing.


4. Type Shop. 


5. Choose Select > Deselect.


6. With the Text tool still selected, change Font Family to 
Verdana, and Text Size to 16 and confirm the text is left 
aligned.


7. Drag on the canvas between the Shop title and the 
photograph to create a fixed-width text block 
(Figure 10).


A fixed-width text block allows you to control the width 
of wrapped text. Fixed-width text blocks are created by 
default when you drag to draw a text block using the Text 
tool. 


8. Add placeholder text to simulate two or three paragraphs 
of text.


9. To move the text block, drag it with the Pointer tool. To 
resize it, drag a resize handle.


10. Choose Select > Deselect.


11. Select the Text tool, and change Font Family to Georgia, 
Text Size to 21, and Text Color to dark gray (HEX value 
#222222).


Figure 9 Properties panel, text mode


Figure 10 Drag with Text tool to create a fixed-
width text block


Font Family


Font Style


Font Color


Alignment


Font Size
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12. Click on the first rounded rectangle to create an auto-
sizing text block.


13. Type Shop.


14. Select the Pointer tool and drag the text block until the 
horizontal and vertical Smart Guides appear so that the 
text is centered over the rounded rectangle (Figure 11).


15. Shift-click the text block and the rounded rectangle and 
choose Modify > Group.


16. Repeat steps 12 to 15 to create three more navigation 
buttons for Designer, Our Shop, and Blog.


17. Create a text block at the bottom of the page, over the 
dark-gray footer rectangle and add some footer text.


18. Select File > Save.


Figure 11 Use Smart Guides to align text and 
objects
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How to plan a portfolio
The content and purpose of a portfolio can vary widely. Student portfolios typically contain examples of work as well 
as text descriptions and reflections on each piece. Three types of web portfolios showcase work, document progress 
through a project, or highlight skill growth. Examples of these three types follow.


Showcase portfolio


A showcase portfolio highlights its owner’s expertise by showing examples of best work. A student showcase would 
include a selection of finished images, designs, and websites. It might also provide a reflection in the piece or 
document of the process students followed to create it. Following is a sample category outline with associated files:


Image work


• Digital camera photographs


• Optimized images


Design work


• Widget


• Web graphics


• Rich media


Client website


• Wireframes


• Design comps


• Storyboard


• Prototype


• Completed website (illustrated on mutiple screen types)
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Portfolio flowchart


This is a sample flowchart for a showcase portfolio:
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Skill growth portfolio


A skill growth portfolio shows multiple samples of work in the same project to demonstrate increasing skill. For 
example, students include several versions of their page banners to show how the design evolved. This portfolio can 
also include reflection and discussion of redesigns. Following is a sample category outline with associated files:


Design work


Widget


• Widget (early version)


• Widget (final version)


• Wireframe self review


Client website


Wireframe


• Wireframe (early version)


• Wireframe (final version)


• Wireframe client review


Design comp


• Design comp (early version)


• Design comp (final version)


• Design comp client review


Storyboard


• Storyboard (early version)


• Storyboard (final version)


• Storyboard client review


Prototype


• Prototype (early version)


• Prototype (final version)


• Prototype client review
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Portfolio flowchart


This is a sample flowchart for a skill growth portfolio:
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Project progress portfolio


A project progress portfolio contains a more complete selection of work around a particular project. The portfolio 
reflects the span of work done on a project—showing stages from early ideas to completion. An example would be to 
show all the work students did while learning about Adobe Fireworks CS6. The portfolio would include wireframes 
and storyboards, early versions, final versions, peer review, and self-review. For this portfolio type, students will need 
to scan worksheets and other handwritten documents to create web-ready versions.
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Student portfolio


Planning a website by using information architecture is a common practice for professional designers. Designers 
create a flowchart that shows all the pages in the site and how they connect. The flowchart can also describe the 
purpose and audience for a site and provide organized lists of content.


Create a flowchart for your portfolio that shows the organization and content of your work in this course. Include the 
following:


1. Describe the purpose of the portfolio.


2. Include a list of assets in the portfolio, and organize files and projects into categories.


3. Using your category outline from step 2 as a guide, draw a flowchart for your web portfolio.
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How to create a wireframe
A wireframe is a visual guide representing the basic elements of a website. Wireframes are used to describe the 
conceptual structure or information architecture of a website or application. A well-designed wireframe includes 
three key elements: interface design, navigation system, and main content areas (Figure 1). The functional 
relationships between these element are highlighted, where detailed graphics, typographic style, and colors are 
typically not emphasized. 


Fireworks is an ideal tool to mock up wireframes. Use the following guidelines to help you create a wireframe of your 
widget or website.


Figure 1 Wireframe proposal


Wireframing workflow
This worklow outlines the general steps for developing a wireframe from scratch. The result is to a fully-functional 
interactive prototype.


1. Create pen-and-ink draft 


Using pen and paper, sketch a home page or home screen. Include all major layout design elements you want to share 
across multiple pages or screens such as navigation, content areas, titles, and logos. Consider these questions:


• Graphics What graphics will you include? Where will you place the graphics on the page or screen?


• Text What text will you include? Where will you place text on the page or screen?


• Navigation According to your flowchart, the home page or screen directly links to what pages or screens 
(what are the menu items)? Where will you place these links on your home page or screen?


2. Scan and import your draft


Use a scanner to make a digital copy of your draft wireframe, import it into Fireworks.


3. Lay out common design elements


With the sketched draft for reference, use basic drawing tools and guides in Fireworks to block out the main design 
elements in the wireframe.
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4. Create multiple wireframe pages or screens


In the Pages panel, create the desired number of pages or screens for your initial design. As the design evolves, you 
can add or subtract pages or screens as needed.


5. Add unique elements to individual pages or screens


On each page, add unique design, navigation, or form elements. In the Common Library panel, you can find many 
buttons, text boxes, and pop-up menus that speed up the design process.


6. Simulate user navigation with links


Use web objects such as slices, hotspots, or navigation buttons to link the various pages or screens of your prototype.


7. Export the finished, interactive wireframe


Fireworks offers multiple output formats for your prototype, all of which retain hypertext links for navigation within 
the prototype.


Creating a wireframe with Adobe Fireworks CS6
Use Fireworks to create a basic two-page interactive wireframe document. 


Workflow steps 1 to 3


In this section, you  sketch out your wireframe, scan and import it into Fireworks, and lay out comon design elements. 


To create a wireframe from a sketch:


1. Using pen and paper, sketch your wireframe. Include all 
major components, such as navigation, content areas, 
titles, and logos.


2. Scan the sketch into your computer. 


3. Start Fireworks and create a new document 1024 pixels 
wide and 700 pixels high. 


Note: These dimensions are those of a typical web page. 
The dimensions may differ if you're designing a widget.


4. Open the Layers panel, and create or rename two layers: 


• Wireframe


• Wireframe Sketch


Make sure the Wireframe Sketch layer is below the 
Wireframe layer (Figure 2).


5. With the Wireframe Sketch layer selected, choose File > 
Import.


The Import dialog box opens.


6. Navigate to the file you scanned in step 2, and click 
Import (Windows) or Open (Mac OS).


7. Click in the upper-left corner of the canvas to place the 
imported sketch at that location. 


You need to scale the sketch to fit the canvas. Click the 
imported sketch to select it.


Figure 2 Wireframe and Wireframe Sketch layers 
added to the Layers panel
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8. The sketch may extend beyond the edges, or not fully fit  
inside the canvas. 


9. In the Properties panel, select the Constrain Proportions 
option (Figure 3).


10. In the Width Pixel Dimension text box, type 1024, and 
confirm the X and Y coordinates are set to 0.


11. Press Tab.


The image resizes to fit the canvas width.


12. In the Layers panel, lock the Wireframe Sketch layer.


This sketch layer will be the background reference to lay 
out the wireframe elements.


13. Select the Wireframe layer.


14. Make sure rulers and guides are visible. If not, select 
View > Rulers and View > Guides > Show Guides.


15. To create a horizontal or vertical guide, click then drag 
from the corresponding ruler respectively to the edges of 
the logo area, the main content area, and the first 
navigation button (Figure 4).


Note: Guide color can be changed to be more visible 
against different backgrounds. To change the guide color, 
select Edit > Preferences (Windows) or Fireworks > 
Preferences (Mac OS)  and select the Guides And Grids 
category.


16. Select View > Guides > Lock Guides.


Locking the guides prevents you from moving them 
unintentionally.


17. Select View > Guides > Snap To Guides.


The snapping feature enables you to align objects 
precisely with the guides as long as you get close. You 
can control how close you have to get (Snap Distance) in 
Guides And Grids. preferences.


18. Select the Rectangle tool from the Tools panel.


19. In the Properties panel, make the following changes 
(Figure 5):


a. Select None from the Fill pop-up menu.


b. Select Basic > Soft Line from the Stroke pop-up 
menu.


c. Set Stroke color to dark grey.


d. Set Stroke width to 10 pixels.


20. Using the guides, draw a rectangle around the main 
content area, and logo area of the sketch (Figure 6).


As you draw, the rectangles snap to the guides.


Figure 3 Properties panel


Figure 4 Imported sketch with guides added


Figure 5 Rectangle Properties panel


Figure 6 Rectangles drawn around page elenents


Width Pixel Dimension text box


Constrain 
Proportions 
option


X and Y Positions


No Fill option
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21. Select the Rounded Rectangle tool from the Tools panel.


22. Draw a rounded rectangle around the first navigation 
button of your wireframe (Figure 7).


23. Use the Pointer tool to select the rounded rectangle. Alt-
drag (Windows) or Option-drag (Mac) to the left to create 
a copy of the rectangle, and place it over the second 
navigation button in your wireframe.


Note: You may see a Fireworks warning box telling you 
that editing sub-elements of an Auto Shape may cause it 
to behave unpredictably. Select the Don’t Show Again 
option and click OK to dismiss.


24. Select Edit > Repeat Duplicate. 


This action creates a second copy with the same gap 
space between copies.


25. Continue repeating duplicates until you have created as 
many navigation buttons as needed for your wireframe 
sketch (Figure 8).


Now it's time to add the text labels. 


26. Choose Select > Deselect.


27. From the Tools panel, select the Text tool.


28. In the Properties panel, click the Fill color box and 
choose a dark color. Set the justification to Center 
Alignment and the Text Size to 30.


29. Click once in the logo rectangle and enter the text Logo.


30. Make sure Smart Guides are visible and active. If not, 
select View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.


31. Drag the text block to center it in the rectangle, and 
continue adding text labels for the navigation buttons and 
main content area.


The Smart Guides help you to create, align, edit, and 
transform objects relative to other objects.


32. Choose View > Guides > Show Guides to hide guides.


33. Once you are satisfied with the position of the text and 
rectangle elements, click the eye icon next to the 
Wireframe Sketch layer to turn off visibility of the 
background layer. 


With the sketch layer turned off, your image should look 
similar to Figure 9.


34. Select File > Save As and save the file as a PNG.


Figure 7 Rounded rectangle drawn around 
navigation button


Figure 8 Three copies of the rounded buttons 


Figure 9 Completed wireframe sketch
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Workflow steps 4 and 5


Now that you have created the very basic wireframe of the page or screen layout, the next step is to create a few pages 
or screens showing various content. Fireworks CS6 enables you to create as many pages or screens as needed, with 
shared and unique items on each page.


To create multiple wireframe pages or screens:


1. Open the Pages panel (Window > Pages) if it isn't already 
displayed on the right side of the workspace (Figure 10).


2. Right-click (Windows) or Control-click (Mac OS) the 
current page in the Pages panel, and choose Set As 
Master Page from the context menu.


3. At the bottom of the Pages panel, click the Add Page 
button twice to add two blank pages.  


The new pages display the master page in the 
background.


4. Double-click the new page names to rename them, 
respectively, as Home and Shop (or whatever name you 
are using for the  second page of your wireframe). 


5. Navigate to the Home page by selecting it in the Pages 
panel (Figure 11).


6. Use the Text tool to add a page title at the top of the main 
content area.


7. Navigate to the Shop page by selecting it in the Pages 
panel, and use the Text tool to add a page title at the top 
of the main content area in the same way as on the Home 
page.


8. Select the Rectangle tool from the Tools panel.


9. In the Properties panel, select neutral colors for Fill and 
Stroke.


10. Draw a rectangle in the main content area of the second 
page, beside the page title. This rectangle stands in as a 
placeholder for a Shop page image or text page content 
(Figure 12).


11. Select File > Save.


Figure 10 Pages panel


Figure 11 Pages panel, Home page selected


Figure 12 Adding page-level placeholder content


Pages options
menu


Add Page 
button
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Workflow step 6


In this section, you use hotspot web objects to create navigation buttons or links between the two pages of your 
prototype.


To add navigation to a wireframe:


1. Navigate to the master page by selecting it in the Pages 
panel.


2. From the Tools panel, select the Rectangle Hotspot tool 
(Figure 13).


3. Draw a hotspot over the Logo rectangle area. 


4. Draw another hotspot over the first rounded rectangle 
area (Figure 14).


5. Select the first hotspot with the Pointer tool.


6. In the Properties panel, set Link to Home.htm 
(Figure 15).


7. Select the second hotspot and set Link in the Properties 
panel to Shop.htm (or to whatever you named the second 
page).


Because the hotspots are located on the master page, 
every page will be linked to the others when export the 
Fireworks file to an interactive PDF.


8. Select File > Save.


Figure 13 Tools panel


Figure 14 Drawing hotspots


Figure 15 Properties panel


Workflow step 7


Export an interactive prototype of your wireframe to both PDF and functional HTML (Figure 16). 


An interactive PDF is ideal for facilitating the client review process because the client can click through the flow of 
the site or widget, and make comments as needed by using the tools available in Adobe Acrobat. 


Fireworks generates pure HTML that can be read by most web browsers and HTML editors. You can then preview 
your wireframe interactivity and edit these files in Dreamweaver.


Figure 16 Export wireframes from Fireworks


Rectangle Hotspot tool


Link menu
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To export an interactive PDF:


1. Choose File > Export.


The Export dialog box opens (Figure 17).


2. From the Export pop-up menu, choose Adobe PDF. 


3. Confirm that the option View PDF After Export is 
selected.


4. Specify a filename and location, and then click Save 
(Windows) or Export (Mac OS).


The wireframe is exported to PDF and opens in Acrobat.


5. Test that the wireframe links work as expected 
(Figure 18).  


Figure 17 Export dialog box


Figure 18 Testing links in Acrobat PDF


To export to HTML and images:


1. Choose File > Export.


The Export dialog box opens.


2. Navigate to a folder on your hard drive in which to 
export.


3. From the Export pop-up menu, choose HTML And 
Images.


4. Select All Pages from the Pages menu.


5. To store images in a separate folder, select the option Put 
Images In Subfolder. You can select a specific folder or 
use the Fireworks default Images subfolder.


View PDF After Export option
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6. Specify a filename, and then click Save  (Windows) or 
Export (Mac OS).


After export, you'll see the files Fireworks exported on 
your hard drive. Images and an HTML file are generated 
in the location you specified in the Export dialog box.


7. Navigate to the location of the saved file, open 
Home.htm in a browser, and test whether the wireframe 
links work as expected (Figure 19).


Figure 19 Testing HTMLin a browser
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How to use the Assets panel
You can use the Assets panel in Dreamweaver CS6 to manage assets in the current site (Figure 1). The Assets panel 
displays assets for the site associated with the active document in the Document window. A library item is a special 
category of assets that can automatically update all instances of a library item whenever you edit the item


Figure 1 Assets panel with Site list displayed


The Assets panel provides two ways to view assets:


Site list shows all of the assets in your site, including colors and URLs that are used in any document in your site.


Favorites list shows only the assets you’ve explicitly chosen. To switch between these two views, select either 
the Site or Favorites radio button above the preview area. (These two views are not available for the Templates 
and Library categories.)


In both lists, assets fall into one of the following categories: 


Images image files in GIF, JPEG, or PNG formats.


Colors colors used in documents and style sheets, including colors of text, backgrounds, and links.


URLs external links in your current site documents, including FTP, gopher, HTTP, HTTPS, JavaScript, e-mail 
(mailto), and local file (file://) links. 


Flash files in any version of Adobe Flash. The Assets panel displays only SWF files (compressed files created 
with Flash), not FLA (Flash source) files.


Shockwave files in any version of Adobe Shockwave.


Movies QuickTime or MPEG files.


Scripts JavaScript or VBScript files. Scripts in HTML files (rather than in independent JavaScript or VBScript 
files) do not appear in the Assets panel.


Templates master page layouts used on multiple pages. Modifying a template automatically modifies all pages 
attached to it.


Library items design elements that you use in multiple pages; when you modify a library item, all pages 
containing that item are updated.


Asset categories:


Insert button


Edit button


Preview area


Images
Colors


URLs
SWF 


Shockwave


Movies


Scripts


Templates


Library
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By default, assets in a category are listed alphabetically by name, but you can sort them by type and several other 
criteria. You can also preview assets and resize the columns and the preview area.


Add an asset to a document
You can insert most assets into a document by dragging them into Code view or Design view in the Document 
window, or by using the Insert button in the Assets panel. You can either insert colors and URLs or apply them to 
selected text in Design view. (URLs can also be applied to other elements in Design view, such as images.)


To add an asset to a document:


1. Start Dreamweaver.


2. In Design view, place the insertion point where you want 
the asset to appear.


3. In the Assets panel, select from the asset category buttons 
at the left (Figure 1).


Note: Select any category except Templates. A template 
is applied to an entire document; it can’t be inserted into a 
document.


4. Select either Site or Favorites at the top of the panel, then 
select the asset.


5. Do one of the following:


• Drag the asset from the panel to the document 
(Figure 2). 


You can drag scripts into the head content area of the 
Document window; if that area isn’t visible, select 
View > Head Content.


• Select the asset in the panel and click the Insert 
button.


If the inserted asset is a color, it applies to text 
appearing after the insertion point. 


6. If you are adding an image asset, and enabled 
Accesibility preferences (Edit > Preferences > 
Accessibility in Windows, Dreamweaver > Preferences > 
Accessibility in Mac OS), you will be presented with the 
Image Tag Accessibility Attributes dialog box. Enter a 
description of the image in the Alternate Text box.


Figure 2 Drag asset from the Assets panel to the 
document window


Figure 3 Accessibilty dialog box


Edit an asset
When you edit an asset in the Assets panel, the behavior varies according to the asset type. For some assets, such as 
images, you use an external editor, which opens automatically if you have defined an editor for that asset type. You 
can edit colors and URLs in the Favorites list only. When you edit templates and library items, you make the changes 
within Dreamweaver.
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To edit an asset:


1. In the Assets panel, do one of the following:


• Double-click the asset.


• Select the asset, then click the Edit button. 


Note: If the asset must be edited in an external editor 
and one doesn’t open automatically, select Edit > 
Preferences (Windows) or Dreamweaver > 
Preferences (Mac OS), select the File Types/Editors 
category, and define an external editor for that asset 
type.


2. Make your changes.


For example, in Figure 4, Fireworks opens in order to 
edit a selected button asset.


3. When you finish, do one of the following:


• If the asset is file-based (anything other than a color 
or URL), save it (in the editor you used), and close 
the external editor.


• If the asset is a URL, click OK in the Edit URL 
dialog box.


Note: If the asset is a color, the color picker closes 
automatically after you pick a color. To dismiss the 
color picker without picking a color, press Esc.


The file is saved and updated within the Assets panel.


Figure 4 Editing a button in Fireworks


How to use libraries
You can use a library in Adobe Dreamweaver CS6 to store page elements such as images, text, sounds, or tables you 
want to reuse throughout your website (Figure 5). When you insert a library item, Dreamweaver inserts a link to the 
library item. If you later need to make changes to a library item, such as changing some text or an image, updating the 
library item automatically updates each instance of the item on every page into which you’ve inserted it.


Figure 5 Assets panel, Library category


Library button


Insert button


New Library Item


Edit button


Delete button
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Creating a library item


You create library items out of existing page elements.


To create a library item:


1. In the Document window, select the element (such as an 
image or text) to save as a library item.


2. In the Assets panel, click the Library button.


3. Click the New Library Item button  at the bottom of the 
panel (Figure 5).


4. Type a name for the new library item, then press Enter 
(Windows) or Return (Mac OS). (Figure 6).


Dreamweaver saves each library item as a separate file 
(with the file extension .lbi) in the Library folder of the 
site’s local root folder.


Figure 6 Naming a new library item


Inserting a library item


Once an item is added to the Library, you can insert it onto a page.


To insert a library item:


1. Position the insertion point in the Document window 
where you want to insert a library item.


2. In the Assets panel, click the Library button.


3. Drag a library item from the Assets panel to the 
Document window, or select an item and click the Insert 
button at the bottom of the panel (Figure 7).


Figure 7 Inserting a library item on a page


Editing a library item


Library items can be edited in their own window. The changes you make then apply to the library item everywhere 
you have previously inserted it.


To edit a library item:


1. In the Assets panel, click the Library button.


2. Select a library item.
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3. Click the Edit button at the bottom of the Assets panel.


Dreamweaver opens a new window for editing the library 
item (Figure 8). This window is much like a Document 
window. You can tell it is a library item by the .lbi 
filename extension on the document’s tab.


4. Edit the library item and then save your changes.


The Update Library Items dialog box opens, with a list of 
the files that use the library item (Figure 9).


5. Click Update to replace the original library item with 
your edited version in the files that use the library item. 


The Update Pages dialog box opens.


6. To see a report on the updating process, make sure Show 
Log is selected (Figure 10).


7. Click Close.


Figure 8 Library editing window


Figure 9 Update Library Items dialog box


Figure 10 Update Pages report

© 2012 Adobe Systems Incorporated How to use the Assets panel 5







Project 3 guide Adobe Dreamweaver CS6


6


Updating all documents to use current library items


If you do not choose to update documents that use library items as you edit individual library items, you can later 
update all pages in the site with the current version of all library items.


To documents to use current library items:


1. Select Modify > Library > Update Pages.


The Update Pages dialog box opens (Figure 11).


2. From the Look In pop-up menu, select Entire Site, and 
then select the site name from the adjacent pop-up menu. 


3. Make sure Library Items is selected in the Update 
section. 


4. Click Start.


Dreamweaver updates the documents and provides a 
report on the updating process (Figure 12). If you have 
updated documents at the time you edited library items, 
this report confirms that no additional updating was 
required.


5. Click Close.


Figure 11 Update Pages dialog box


Figure 12 Update Pages report
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Principles and rules of copyright
Copyright is protection for intellectual property.


Intellectual property consists of anything an individual has written or created. It might be music, text, pictures, 
photographs, sounds, and so on.


Fair use doctrine is part of the copyright laws. It states that limited portions of material may be used without written 
permission for certain purposes, such as reporting the news or schoolwork. It doesn’t define “limited,” though, so be 
sure you don’t overuse material. The fair use doctrine requires you to give credit to the author or creator of any 
material you use.


Creative Commons is a set of copyright licenses that allow for the distribution of copyrighted works. The range of 
four conditonal licences provide a set of “baseline rights”that allow for the distribution of copyrighted work 
worldwide, without change, at no charge. The four conditions include: Attribution, Noncommercial, No Derivative 
works, and Share-alike. Creative Commons licenses permit the mixing and matching of conditions to produce 
suitable copyright licences conditions. For more info, see: http://creativecommons.org/


Derivative works are copyrighted materials that have been altered or changed. Such material is protected by copyright 
laws. If you alter a copyrighted photograph by using computer software, that photograph is still protected, and you 
may not use it without written permission.


Academic standards for copyrighted material are higher than others. Because scholars and researchers study so many 
different ideas and are responsible for sharing those ideas with the world, they are required to satisfy higher standards 
of honesty. They must give credit not only when quoting someone else’s exact words but also for the ideas those 
words represent. As a researcher, you cannot paraphrase what someone else says and not give credit for it.


Bibliographies are lists of sources that have been used in research. When using the Internet for research or for design 
work, you need to give credit where it is due. Often, people who use graphics and images from the Internet for 
publication on their own web page create a list of image credits rather than a bibliography.


Rules of Copyright
1. You cannot use copyrighted material without written permission from the creator of the material (or from its 


copyright holder).


2. Material can be protected even if it does not display the © symbol. Even if no mention is made regarding 
copyright, you must assume that all material from another source is protected.


3. Penalties for violating copyright laws can range from mild to severe. If you break the copyright law, you might 
simply receive an e-mail message from the author asking you to stop using the material. If you publish the 
material on a website, the webmaster might shut down your site. Or you could be sued by the author or 
prosecuted by federal authorities.


4. To make sure you are not violating any copyright law, it is important that you do the following:


• Write or send e-mail to the author or creator and ask permission to use the material. Do not use it until you 
are given permission. 


• Follow the directions on the site regarding use of material. You might be asked to create a link on your page 
or to notify the author or creator. 


• Most important: Do not use any material if you don’t have written permission. 
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5. Copyright notice is no longer required to obtain protection, but it is often beneficial. Copyright notice for 
visually perceptible material should contain the following three elements:


• The symbol © (the letter C in a circle), or the word “Copyright,” or the abbreviation “Copr.”


• The year of first publication


• The name of the owner of copyright


◦ Example: © 2012 Adobe Systems Incorporated


6. Copyright notice for phonorecords and sound recordings should contain the following three elements.


• The symbol ℗ (the letter P in a circle)


• The name of the owner of copyright


• The year of first publication


7. The copyright notice should be affixed in such a way as to “give reasonable notice of the claim of copyright.”


For more information on copyrights, visit the United States Copyright Office on the Internet at www.copyright.gov. 

Principles and rules of copyright © 2012 Adobe Systems Incorporated
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Tips for information architecture
Information architecture (IA) is a method of organizing and labeling a website structure to support usability. Careful 
consideration of the content and organization of a site is the first step to creating an effective user experience. Also 
referred to as information design, structuring is about connecting users to the content and organizing information 
intuitively. It is also about blueprinting the site from a functional perspective to communicate easily with a client and 
a team. Ultimately, understanding what users are looking for and allowing easy access to content and information is 
the overall goal. It’s all about ensuring that users can get what they came for. A well-designed information 
architecture is similar to a table of contents. It helps improve discoverability, efficiency, satisfaction, and overall 
usability of a website.


[Information architecture is]…creating consistent and functional systems for 


navigation,  graphics, page layout and title languages, so that the user knows 


where to go, what to do, and encourages him or her to return.


- Web Review, Peter Monville


The information architecture step usually falls within the structure phase of web project production, before you create 
wireframes, design comps, and prototypes. 


Consider the following best practices when creating a well-designed information architecture.


Research the needs of the audience and users
Who is your target audience? What kind of user are you trying to attract to the website? These important initial 
questions inform the way you structure content and information. You must create the information architecture of your 
site with your audience in mind.


Identify a clear purpose for the site
Always keep the goals in mind while you’re creating the information architecture. Every website needs a clear goal: 
to educate, inform, entertain, market, sell, or any combination of these. Establishing clear goals helps you structure 
effective information architecture.


Inventory and assemble site content
You may be working on a new website from scratch or redesigning an existing website. Regardless, it’s important to 
perform an inventory of content you already have and describe any new content to be created. The content is the core 
of the site, so you need to know if it is suitable for your audience and supports the overall goals of the site. Another 
consideration is presenting content across multiple screens and devices. You should structure content carefully so it 
presents well on a range of computers, tablets, and smartphones.


Assemble site content into logical groups
Content and structure are intertwined. Assembling content into logical groups helps establish clear and consistent site 
organization and facilitates the task of defining the information architecture.
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Create a site map
Your site’s structure is composed of the categories and logical groups you just created. A site map serves as a bird’s-
eye view of the project that enables you to see how the site is organized and how users will view the site’s content and 
information. The site map becomes a blueprint that shapes the structure of the site during the development process. 
The site map should show main areas of content and represent all the pages within each section (Figure 1). 


Figure 1 Example site map for Coast Middle School website


Design navigation systems
Clear navigation helps connect users with the content on your site. Buttons, links, and graphics can be used from each 
screen to maintain a sense of place. Users need to stay oriented to where they are in the site, where they need to go, 
and how to get back to where they came from. Having a consistent navigation helps orient users and keep them from 
feeling lost. As users move from page to page, make sure they find familiar visual cues and navigational aids.


Summary
The information architecture, a component of the structuring stage, is complete. You have created a content site map 
and designed a set of navigation elements. Don’t underestimate the importance of the structuring phase, as it’s crucial 
to successfully realizing the next phase: design and prototyping.
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How to maintain consistency
Consistency is an important element of usability—the measure of how well visitors can accomplish tasks when using 
your website. Consistency is especially important for larger sites that contain multiple pages and content created in 
Adobe Flash Professional CS6. The more you make these pages look and feel alike, the more comfortable visitors 
will be while using them.


You should keep elements within your site consistent, but also, whenever possible, follow the conventions of other 
sites. For example, many sites locate the main navigation at the top of each page. Unless you have a very good reason 
to locate the main navigation elsewhere, you should also locate it at the top of the page. (Although design innovation 
is desirable, making sure as many visitors as possible can use your website is more important.)


Consistency is especially important in the following areas:


Navigation: Not only should navigational controls be available on every page, but they should also look the same on 
each page. Navigation should tell visitors where they are in the site’s organization, using, for example, a highlighted 
button. It should also let visitors move to other site areas easily.


Colors: Similar objects should have the same or similar colors, and different objects should have different colors. Use 
a limited palette of colors on your site. You can do so easily by tracking colors in the Swatches panel.


Buttons: Generally, all buttons should look the same or similar—with the same font, drop shadow, and beveling, for 
example. Sometimes visitors have difficulty knowing what to click, and keeping buttons similar helps them use what 
they’ve learned on a previous page. You can use the library to reuse buttons across different pages. (This has the 
added advantage of reducing the file size of your site.)


Fonts: Use a limited group of fonts. Usually, you will not need more than two or three fonts for even a large site.


Graphics: Keep graphics similar on each page. You can use the library to reuse images across different pages.


Transitions: Use similar transitions between pages. For example, if one page fades into the next page, use fades for all 
page transitions. Transitions should also have similar timing; if one lasts three seconds, they should all last three 
seconds.


Scroll bars: Many usability experts recommend using a scroll bar that looks as similar as possible to those used in 
desktop software. Make these look the same on every page.


Sound: Use sound consistently throughout your site pages. If, for example, a button on one page makes a sound when 
your visitors roll over it, you should have all buttons on all pages make such a sound.


Layout: All the pages in your site should have a similar layout: the navigation should be in the same place on every 
page, for example. Interactive areas should also be in the same place. If one page has a simple game, for example, and 
another page has an interactive chart, position these in the same area. You can use Flash templates to maintain 
consistent layouts across different pages.
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Creating a template
Templates are a good way to keep your website pages consistent. You can include navigation, fonts, graphics, and 
layout in a template so these elements appear consistent throughout your site.


To create a template:


1. Start Flash.


2. Add content to a document to serve as a template, such as 
navigation, images, buttons, and background.


3. Select File > Save As Template.


The Save As Template dialog box opens (Figure 1).


Note: If a dialog box appears first, stating that SWF 
history data will be cleared if saved as template, click 
Save As Template.


4. Enter a name for the template.


5. Select a category in the Category pop-up menu, or enter a 
new category name.


6. Enter a description for the template.


This description appears in the New From Template 
dialog box.


7. Click Save.


The template is now available as an option in the New 
From Template dialog box.


Figure 1 Save As Template dialog box
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The Dreamweaver Insert panel
In Adobe Dreamweaver CS6, the Insert panel contains buttons for inserting various types of objects, such as images 
and forms, into a Dreamweaver document.


You can use the Insert panel to create or insert content in eight categories:


• The Common category contains buttons for inserting the most commonly used objects, such as links, 
images, and tables.


• The Layout category gives you options to insert tables, table elements, div tags, frames, and Spry widgets. 
You can view tables in either Standard (default) mode or Expanded Tables mode. 


• The Forms category contains buttons for creating forms and inserting form elements.


• The Data category lets you insert dynamic elements such as recordsets, repeated regions, and record 
insertion and update forms.


• The Spry category lets you insert “widgets” that display data from other files and various interface elements 
(such as navigation bars and menus) that rely on JavaScript and CSS. (Spry widgets are not covered in this 
study, but you can read find out more about them in Dreamweaver Help (select Help > Dreamweaver Help 
and look for the section called “Building Spry pages visually.”)


• The jQuery Mobile category provides content layout options, input, UI and form controls for developing 
mobile applications using Dreamweaver.


• The InContext Editing category is used to enable end users to make simple edits to their web pages without 
help from you or additional software on their computers. Adobe InContext Editing (ICE) is an online hosted 
service that provides simple content editing capabilities within a web browser. 


• The Text category is used for working in Code view and enables you to insert a variety of text- and list-
formatting tags, such as b, em, p, h1, and ul.


• Use the Favorites category to customize a list of Insert panel buttons for fast access. You can customize this 
category by right-clicking (Windows) or Control-clicking (Mac OS) the Insert panel.


The Insert panel menu
You switch between these categories by using the Insert panel menu, which is located at the top of the Insert panel 
(Figure 1). To hide or show the Insert panel select Window > Insert.


Figure 1 Insert panel, Category pop-up menu
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To display the pop-up menu for a button, click the disclosure triangle beside the button’s icon (Figure 2).


Figure 2 Insert panel, Images pop-up menu
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Digital Design Project 6 worksheet

Client interview


Team name: __________________________________________________ Date: ________________________


Reviewer name: _______________________________________________


Interview topics


◦ Goals and target audience


◦ Content


◦ Design requirements


◦ Delivery requirements


Goals and target audience


Identify three long-term goals of your website.


What should the site inspire the audience to do after they visit?


Identify some immediate goals of your website.
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Name some key information you want the audience to gain from your site.


Describe content expectations of your target audience.


Other questions:
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Audience background


Describe characteristics of your target audience.


What is the age range of your target audience?


What is the reading level of your target audience?


Does your target audience have special requirements or disabilities?


How often is your target audience online?


Describe the most common use of the web by your target audience.
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Use a few adjectives to describe how you want the target audience to perceive your site. (Examples: prestigious, 
friendly, corporate, fun, forward-thinking, innovative, cutting-edge, serious, crazy.)


Other questions:


Content


What should be the title of your site?


What topics should be covered in your site?
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Other questions:


Design requirements


Are there any organization colors, fonts, graphics, or logos that should be included in the design?


Are there any colors or fonts you don’t want used on this site?
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What are some websites you like? Describe specific elements you like about each site, such as navigation, colors, 
layout, and other design elements.


Other questions:


Delivery requirements


What browsers (and what versions of these browsers) should this site support?


• Internet Explorer


• Mozilla Firefox


• Safari


• Google Chrome


• Other:


What platforms should this site support?


• Macintosh


• Windows


• Other:
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What devices should this site support?


• Mobile phones:


• Tablet computers:


• Other:
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How to publish web files
Once you’ve specified a local site in Dreamweaver, you can specify a remote server for your site as well. The remote 
server (often referred to as the web server) is where you publish your site files so that people can view them online. 
The remote server is simply another computer like your local computer, with a collection of files and folders on it. 
You specify a folder for your site on the remote server, just as you specified a folder for your local site on your local 
computer (Figure 1). Dreamweaver refers to the specified remote folder as your remote site.


Figure 1 Basic screen of the Servers category, Site Setup dialog box


When you set up a remote folder, you select a connection method for Dreamweaver to upload files to your web server 
and download files from your web server. The most typical connection method is FTP, but Dreamweaver also 
supports local/network, FTPS, SFTP, WebDav, and RDS connection methods. If you don’t know which connection 
method to use, ask your teacher or your school server administrator.


Connecting to a remote site
Many websites let you publish files through FTP (File Transfer Protocol). You connect to a remote site by using the 
Site Definition dialog box in Adobe Dreamweaver CS6. 


To connect to a remote site by FTP:


1. Select Site > Manage Sites.


The Manage Sites dialog box opens (Figure 2).


2. Double-click the name of the site you want to connect 
remotely.


The Site Setup dialog box opens.


Figure 2 Manage Sites dialog box
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3. Click the Servers category in the left column.


The Servers category of the Site Setup dialog box opens (Figure 3).


Figure 3 Basic screen of the Servers category, Site Setup dialog box


4. Click the Add New Server button (+).


5. Enter the FTP access information as directed by your teacher (Figure 1).


6. Click Test to test the connection.


Dreamweaver confirms the connection.


7. Click Save.


The new server appears in the list of servers in the Site Setup dialog box.


8. Click Save to close the Site Setup dialog box.


9. Click Done to close the Manage Sites dialog box.


Add New Server
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Uploading, Synchronizing, and downloading files
Once you establish an FTP connection, you can use the Get and Put commands to transfer files from the Files panel 
(Figure 4).


Figure 4 Expanded Files panel


When you transfer a document between a local and remote folder using the Files panel, you have the option of 
transferring the document’s dependent files. Dependent files are images, external style sheets, and other files 
referenced in your document that a browser loads when it loads the document.


Note: It’s usually a good idea to download dependent files when checking out a new file, but if the latest versions of 
the dependent files are already on the local disk, there’s no need to download them again. This is also true for 
uploading and checking in files: no need if up-to-date copies are already at the remote site.


To upload the entire site for the first time:


1. In the Files panel (Window > Files), select the files to 
upload.


2. Click the Expand/Collapse button in the Files panel 
toolbar (Figure 4).


The Files panel expands.


3. Click the Connects To Remote Host button in the Files 
panel toolbar.


Dreamweaver connects to the web server.


4. Select the root folder for your site in the Local (right) 
pane.


5. Click the Put Files button in the Files panel toolbar.


6. You may be presented with a dialog box asking if you 
wish to put the entire site. Click OK.


Dreamweaver uploads the site’s files and opens the 
Background File Activity dialog box (Figure 5).


Note: To upload one or more folders or files without 
uploading the entire site, select them and click the Put 
Files button.


Figure 5 Background File Activity dialog box


Connects/Disconnects Remote Host Get Files Put Files Synchronize Expand/CollapseRefresh
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To upload a revised version of an existing file:


1. Select the file you have revised.


2. Click the Put Files button in the Files panel toolbar.


Dreamweaver uploads the revised file.


Synchronizing the files on your local and remote sites


After you’ve created files in your local and remote sites, you can synchronize the files between the two sites.


Before you synchronize your sites, you can verify which files you want to put, get, delete, or ignore. Dreamweaver 
also confirms which files have been updated after you complete the synchronization.


To synchronize files:


1. (Optional) Select specific files or folders in the Files 
panel or go to the next step to synchronize the entire site.


2. Click the Synchronize button in the Files panel toolbar to 
synchronize files.


The Synchronize Files dialog box opens (Figure 6).


3. Select the direction in which you want to copy the files:


Put Newer Files To Remote uploads all the local files that 
don’t exist on the remote server or have changed since 
the last upload.


Get Newer Files From Remote downloads all the remote 
files that don’t exist locally or have changed since the last 
download.


Get And Put Newer Files places the most recent versions 
of all the files on both the local and the remote sites.


4. Choose whether to delete the files on the destination site 
that don’t have counterparts on the origin site. (This is 
not available if you select Get and Put from the Direction 
menu.)


If you select Put Newer Files To Remote and you select 
the Delete option, then any files in your remote site for 
which there are no corresponding local files are deleted. 
If you select Get Newer Files From Remote, then any 
files in your local site for which there are no 
corresponding remote files are deleted.


Figure 6 Synchronize Files dialog box 
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5. Click Preview.


Dreamweaver analyzes the local and remote folders, and 
then the Synchronize dialog box opens (Figure 7).


Note: Before you can synchronize the files, you must 
preview the actions Dreamweaver performs to 
accomplish this task. 


If the newest version of each chosen file is already in 
both locations and nothing needs to be deleted, an alert 
appears informing you that no synchronization is 
necessary. Otherwise, the Synchronize dialog box 
appears to let you change the actions (put, get, delete, and 
ignore) for those files before executing the 
synchronization.


6. Verify the action that will be performed for each file.


7. Click OK to synchronize the files.


Figure 7 Synchronize dialog box 


Downloading files to work on them


Once your website has been published, you may want to download a file so you can revise it. You do so through the 
Remote Site pane, on the left side of the expanded Files panel.


To download a file:


1. Click the Refresh button in the Files panel toolbar 
(Figure 4) to make sure the files in the Remote Site pane 
are up-to-date.


2. Select a file to download.


3. Click the Get Files button.


If the file has any dependent files, the Dependent Files 
dialog box opens (Figure 8). 


Note: If you do not click Yes within 30 seconds, the 
Dependent Files dialog box automatically closes and 
dependent files are not downloaded.


4. Click Yes.


Dreamweaver copies the file and its dependent files to 
your local folder. The downloaded files appear in the 
right pane of the expanded Files panel.


5. Click the Disconnects From Remote Host button, and 
then collapse the Files panel.


Figure 8 Dependent Files dialog box 
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WEBSITE PRODUCTION PHASES

DEFINE, STRUCTURE, DESIGN, BUILD AND TEST, LAUNCH
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Define

		Set goals, target audience, content, and delivery requirements for project.

		Develop a project plan.

		Outline the content production process.



*



Ask students if they can think of other types of balance: texture and no texture (smooth), size and scale, elements of a composition.

*







© 2012 Adobe Systems Incorporated.  All Rights Reserved. 



Structure

		Information architecture and design documents.

		Flowchart to outline the overall structure of the site.

		Wireframes to show basic structure of site pages.



*





Home
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Design

		Provide two or more design comps.

		Review comps with client. 

		Redesign based on feedback.

		Develop production storyboard.

		Design prototype wireframe.



*
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Build and test

		Build site production based on storyboards.

		Do technical, accessibility, and usability testing, recording bugs, and design-change requirements.

		Make revisions based on test results.

		Repeat technical and usability testing of revised site.

		Present site to client and do final revision.



*



The rectangle has three lines of symmetry: horizontal (blue), vertical (red), diagonal (yellow)

The triangle only has one line of symmetry: center or vertical. You can draw two other lines of symmetry from any of the vertices to the center of the opposite side.

*
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Launch

		Outline a launch plan including promotion, and search engine optimization. 



*
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How to optimize images
You can use the Optimize panel to specify optimization settings for images to be used in web pages. Exporting 
graphics from Adobe Fireworks CS6 is a two-step process. Before you export, you must optimize graphics—select 
options that make the graphics look as good as possible while restricting file size so that the graphics download as 
fast as possible.


The first step is to determine which type of file you plan to export, such as GIF, PNG, or JPEG:


• GIF (Graphic Interchange Format) is a bitmap image format best used for images with large areas of solid, 
flat color, such as simple illustrations, logos, and text. GIFs support transparency and store up to 8 bits per 
pixel that allow a single image to use 256 distinct colors. GIFs also support animations.


• PNG (Portable Network Graphics) was created to improve upon the limitations of GIFs . PNG supports 8-bit 
color and can display up to 256 colors. PNG also supports 24- and 32-bit color, suitable for compressing 
continuous-tone images. However, this may produce much larger files than GIF or JPEG format. The 
advantage of using PNG 24 and PNG 32 is they can preserve up to 256 levels of transparency in an image.


• JPEG (Joint Photograph Experts Group) is a bitmap image format best used for photographs or for images 
with subtle changes in color, gradations, or lighting. JPEG is generally used for photographic images or 
images with gradients and many colors. JPEG format does not support transparency or animation. 


Each graphic file format in Fireworks has a set of optimization options. For web file formats such as GIF and PNG, 
you can specify the amount of compression. By using the Optimize panel, you can optimize JPEGs by setting 
compression and smoothing options.


Options for GIF optimization
In the Optimize panel, you can specify the amount of compression for GIFs (Figure 1).  Fireworks optimization 
settings are similar for all 8-bit graphic file formats, which includes GIFs. 


Figure 1 GIF Optimize panel in Fireworks


Saved Settings: Use Saved Settings to select a preset image-quality setting for export. For GIF, these include GIF Web 
216, GIF WebSnap 256, GIF WebSnap 128, GIF Adaptive 256, and Animated GIF WebSnap 128.


Matte: If you want to anti-alias an image for multiple exports with different-colored backgrounds, click the Matte 
color box and select a color for the background of the image. This is useful for creating a smoother border for the 
image, particularly if the image will appear on web pages with different-colored backgrounds. 


Colors: Control the number of colors in the image. This number is automatically configured from the Saved Settings 
selection. Decreasing the number of colors decreases the file size but can also lower image quality.


Saved Settings


Export File Format


Indexed Palette


Transparency


Add Color To Transparency
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Dither: The Dither option is useful for images with many color gradations. Dithering approximates colors not in the 
current color palette by alternating two similar colors. Increasing the Dither setting can greatly increase file size, so 
consider using JPEG format instead of dithering the image.


Loss: Lower the image quality on export. Higher loss settings can yield smaller files but lower image quality. A loss 
setting of 0 is preferable, but if you need to reduce the file size of the image, a loss setting between 5 and 15 typically 
yields the best results.


Transparency: Remove the background color or halos around an image so in a web browser the background of the 
web page is visible through those areas. (This capability is a key advantage of exporting images as GIFs.) Index 
Transparency removes the background color. Alpha Transparency removes the background of an image if its canvas 
color is transparent. Use the Add Color To Transparency button (Figure 1) to remove specific colors from the image.


Optimizing a GIF image


With Adobe Fireworks CS6, you can compare different versions of the same graphic to create the best quality with 
the smallest file size. As you experiment with different optimization settings, use the 2-Up and 4-Up buttons to test 
and compare a graphic's appearance and estimated file size (Figure 2). 


Figure 2 Comparing GIF optimization settings


To optimize a GIF image:


1. Open a completed graphic in Fireworks.


4-Up Button
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2. In the Optimize panel, select GIF from the Export File Format menu (Figure 1). Then select the type of GIF you 
want from the Indexed Palette menu. 


Adaptive or Web Adaptive is best for most small web images.


3. Click the 4-Up button to compare different versions of the image (Figure 2).


Make sure the image is visible. (If necessary, use the Hand tool to drag the image into the middle.) 


4. Use the Pointer tool to select in turn each of the three alternate versions of the original image, and try different 
settings in the Optimize panel to find the smallest file size with the most acceptable quality:


• To adjust the image for many color gradations, increase the Dither setting.


• To make the file smaller, increase Loss (usually between 5 and 15).


• To remove the background color or halos around the image, select Index Transparency.


• To remove specific colors from the image, use the Add Color To Transparency button. This capability is a 
key advantage of exporting images as GIFs.


As you try different settings, note the file size and download time for each quality level.


5. To export the image version you prefer, click it and select File > Export. Name the file with a .gif extension.


6. To save the richest version of the file, select File > Save As and save the image as a Fireworks PNG file (with a 
.png extension).


Options for PNG optimization
GIF is the standard format for compressing images with flat color and crisp detail, such as line art, logos, or 
illustrations with type. Like the GIF format, the PNG-8 format efficiently compresses solid areas of color while 
preserving sharp detail. Fireworks optimization settings are similar for all 8-bit graphic file formats such as GIF, PNG 
8, TIFF 8, BMP 8, and PICT 8 (Figure 3).


PNG-24 is suitable for compressing continuous-tone images; however, it produces much larger files than JPEG 
format. The advantage of using PNG-24 is that it can preserve up to 256 levels of transparency in an image.


Figure 3 PNG-8 Optimize panel


Export File Format: Use this menu to select an image-quality setting for export. For PNG, these include PNG 8, PNG 
24, and PNG 32.


Matte: If you want to anti-alias an image for multiple exports with different-colored backgrounds, click the Matte 
color box and select a color for the background of the image. This is useful for creating a smoother border for the 


Export File Format


Transparency


Saved Settings
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image, particularly if the image will appear on web pages with different-colored backgrounds. 


Colors: Control the number of colors in the image. Decreasing the number of colors decreases the file size but can 
also lower image quality.


Dither: The Dither option is useful for images with many color gradations. Dithering approximates colors not in the 
current color palette by alternating two similar colors. Increasing the Dither setting can greatly increase file size, so 
consider using JPEG format instead of dithering the image.


Transparency: Remove the background color or halos around an image so in a web browser the background of the 
web page is visible through those areas. Index Transparency removes the background color. Alpha Transparency 
removes the background of an image if its canvas color is transparent. Use the Add Color To Transparency button to 
remove specific colors from the image.


Optimizing a PNG image


With Fireworks, you can compare different versions of the same PNG file to create the best quality with the smallest 
file size. As you experiment with different optimization settings, use the 2-Up and 4-Up buttons to test and compare a 
graphic's appearance and estimated file size (Figure 4). 


Figure 4 Comparing PNG optimization settings


To optimize a PNG image:


1. Open the completed graphic in Fireworks.


2. In the Optimize panel, select PNG 8 from the Export File Format menu.


3. Click the 4-Up button to compare different versions of the image (Figure 4). 


Make sure the image is visible in the display area. (If necessary, use the Hand tool to drag the image into the 
middle.)
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4. Use the Pointer tool to select in turn each of the three alternate versions of the original image, and try different 
settings in the Optimize panel to find the smallest file size with the most acceptable quality.


You can adjust the following settings for PNG 8:


• To adjust the image for many color gradations, increase the Dither setting.


• To remove the background color or halos around the image, select Index Transparency.


• To remove specific colors from the image, use the Add Color To Transparency button. 


You can adjust the following setting for PNG 24 and PNG 32:


• To select a matte color, click the Matte color swatch and select a color in the color picker.


• To save an image with multilevel transparency (up to 256 levels), select Transparency. The Matte option is 
disabled since multilevel transparency allows an image to blend with any background color.


As you try different settings, note the file size and download time for each quality level.


5. To export the image version you prefer, click it and select File > Export. Name the file with a .png extension.


Options for JPEG optimization
Using the Optimize panel, you can optimize JPEGs by setting compression and smoothing options (Figure 5). JPEGs 
are always saved and exported in 24-bit color, so you can't optimize a JPEG by editing its color palette. The color 
table is empty when a JPEG image is selected.


Figure 5 JPEG Optimize panel


Saved Settings: Select from preset image-quality settings for export. For JPEG, these include JPEG Better Quality and 
JPEG Smaller File.


Matte: If you want to anti-alias an image for multiple exports with different-colored backgrounds, click the Matte 
color box and select a color for the background of the image. This is useful for creating a smoother border for the 
image, particularly if the image will appear on web pages with different-colored backgrounds.


Quality: Adjust the quality of the image. Lower quality decreases file size; higher quality increases file size.


Selective Quality: Adjust the quality of only the selected part of the image while leaving the rest of the image intact. 
Areas of particular interest in an image can be compressed at a higher quality level than the rest of the image. Used 
with a JPEG mask.


Smoothing: Blurs hard edges in the image and reduces file size.


Export File Format


Saved Setings
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Optimizing a JPEG image


With Adobe Fireworks CS6, you can compare different versions of the same graphic to create the best quality with 
the smallest file size. As you experiment with different optimization settings, use the 2-Up and 4-Up buttons to test 
and compare a JPEG file's appearance and estimated file size (Figure 6).


Figure 6 Comparing JPEG optimization settings


To optimize a JPEG image:


1. Open the completed graphic in Fireworks.


2. In the Optimize panel, select JPEG from the Export File Format menu.


3. Select the 4-Up button to compare different versions of the image (Figure 6). 


Make sure the image is visible in the display area. (If necessary, use the Hand tool to drag the image into the 
middle.)


4. Use the Pointer tool to select in turn each of the three alternate versions of the original image, and try different 
settings in the Optimize panel to find the smallest file size with the most acceptable quality. 


• From the Saved Settings menu, select JPEG - Better Quality or JPEG - Smaller File for preset quality values.


• Try different values for the Quality setting.


• To make the file smaller, increase the Smoothing.


As you try different settings, note the file size and download time for each quality level.


5. To export the image version you prefer, click it and select File > Export. Name the file with a .jpg extension.
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6. To save the richest version of the file, select File > Save As and save the file as a Fireworks PNG file (with a .png 
extension).


Using a JPEG mask for further optimization (optional)


In some cases, you may want to leave points of interest in the image relatively uncompressed, while compressing 
background areas more heavily. You can do so by using a JPEG mask.


To create a JPEG mask:


1. Click the Original button to return to the (single) original 
image.


2. Use the Marquee or Lasso tool to outline the point of 
interest in your image.


3. With the point of interest selected, choose Select > Select 
Inverse.


This selects everything except the point of interest of the 
image. A marquee surrounds the inverse selection 
(Figure 7). 


4. To make changes only to the region outside the point of 
interest, select Modify > Selective JPEG > Save 
Selection As JPEG Mask. 


A highlight color appears on everything except the point 
of interest of the image.


In the Optimize panel, you can now make changes to the 
value for Selective Quality. Reducing this number retains 
the image quality of the point of interest but reduces the 
quality of the background and thereby reduces the file 
size. 


5. Click the Preview button to see the effect of your 
changes.


Figure 7 Inverse selection
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How to work with text
Adobe Flash Professional CS6 lets you add text to a Flash application in two formats:


• You can add Text Layout Framework (TLF) text.


• You can add Classic text.


Using the Text Layout Framework
TLF text provides the following enhancements over Classic text:


• You can adjust a wider range of character aspects, such as leading and tracking.


• You can rotate text more easily.


• You can flow text across multiple containers, as it does in a magazine page layout.


• You can better control the attributes of Asian text.


• You can create right-to-left text.


The Text Layout Framework is available as an option in the Properties panel. 


TLF text requires that ActionScript 3.0 and Flash Player 10 or later are specified in the publish settings of your FLA 
file. See the guide “How to publish a Flash document” for more information about publish settings.


To create TLF text:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Click the Text tool.


3. Make sure the Properties panel is open. If not, select 
Window > Properties.


4. Select TLF Text from the Text Engine menu (Figure 1).


5. Move the pointer to the Stage.


The pointer changes to a cross hair with the letter T 
attached to it.


6. Drag to create a container (Figure 2).


7. Release the mouse button and click in the container.


8. Type some text (Figure 3).


Figure 1 Text Engine menu.


Figure 2 Dragging to create a container


Figure 3 Text container
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Managing text flow for TLF text


If you fill a Flash TLF text container with more text than fits within the bounding box, a red plus symbol appears. 
This red plus indicates the text is overset. Overset text is text that does not fit in the container.You can solve the 
problem of overset text by making the container bigger, but often you will want to continue the text in another 
container, either on the same page or on another page. This is called text flow. 


For example, in Figure 4 the upper container is overset and needs to flow to the lower text container.


Figure 4 Overset text


In Figure 5, the two containers have been linked, as indicated by a line between the Out port of the top container and 
the In port of the bottom container.


Figure 5  Linked containers


Out port of text container In port of text container
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To flow text:


1. Use the Selection tool to select a container.


2. Click the Out port in the lower-right corner of the 
selected container.


The pointer changes to the loaded text icon, an arrow 
with small lines of text (Figure 6).


3. Then do one of the following:


• To link to an existing container, position the pointer 
over the target container. The pointer changes to the 
link text icon, an arrow with chain links (Figure 7). 
Click the container to link the two containers.


• To link to a new container, click or drag on an empty 
part of the Stage. Clicking creates an object of the 
same size and shape as the original; dragging lets 
you determine the size of the container.


The containers are now linked and text will flow between 
them (Figure 8).


Figure 6 Loaded text icon


Figure 7 Link text icon


Figure 8 Result of linking to a text container
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Using Classic text
You can specify three types of Classic text in the Properties panel: Static, Dynamic, and Input. The default type is 
Static. Use Static text when the text will not change, such as button and form labels. Use Dynamic text for text that 
will change as the movie plays, such as text pulled from an external database in response to a viewer’s request. Use 
Input text for requesting input from the viewer, such as a user name and password—input text is similar to a form 
field.


To use Classic text:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. In the Tools panel, select the Text tool.


3. Make sure the Properties panel is open. If not, select 
Window > Properties.


4. Select Classic Text from the Text Engine menu 
(Figure 9).


5. In the Properties panel, make sure that Static Text is 
selected in the Text Type menu (Figure 9).


6. Move the pointer to the Stage.


The pointer changes to a cross hair with the letter T 
attached to it.


7. To create an expanding-width text field, click on the 
Stage.


The text field contains a flashing insertion point. This is 
where text appears as you type. The round handle 
indicates the text field is an expanding-width one-line 
static text field (Figure 11).


8. Type the text.


The text field expands as you type.


9. Click away from the text to deselect it.


10. To create a fixed-width text field, drag on the Stage to 
create a text box. Make the box about as wide as you 
think is necessary to fit your text.


A text field is created. This text field has a square handle 
in the upper right corner (Figure 12). The square handle 
indicates that the text field is a fixed-width static text 
field.


Figure 9 Text Engine menu


Figure 10 Text Type menu


Figure 11 Expanding-width one-line static text 
field


Figure 12 Fixed-width static text field


Round handle


Square handle
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11. Type the text.


The text you type wraps to a new line when it reaches the 
right edge of the text field.


12. Drag the square handle to the right until the text is on a 
single line.


Note: Double-clicking a square handle changes it to a 
round handle and changes the text field to an expanding-
width one-line static text box.


13. Click away from the text to deselect it.


Formatting both TLF and Classic text
You can apply basic character formatting to TLF or Classic text, such as font family, font type, font style, and font 
color. You can also adjust tracking, adjust leading, and apply anti-aliasing to both formats.


To apply basic formatting to text:


1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic). 


2. In the Character section of the Properties panel, choose a 
different font family in the Font Family menu, such as 
Verdana (Figure 13).


3. Choose a different font style, such as italic or bold.


4. Set a different font size, such as 14, by using the Size 
scrubber. (You can also click the scrubber and type a 
value for Size.).


5. Choose a different font color by clicking the Color box 
and doing one of the following:


• Select a color from the Color palette (Figure 14).


• Enter a hexadecimal color value in the upper-left 
corner (Figure 14).


• Click the Color Picker icon and select a color from 
the system color picker. (When setting the text color, 
use only solid colors, not gradients. To apply a 
gradient to text, break the text apart and convert the 
text to its component lines and fills.)


6. In the Paragraph section of the Properties panel, choose 
an alignment for the text, such as left, centered, right, or 
justify.


Note: For TLF text, Flash provides additional Justify 
alignment options for the last line of text, such as Justify 
With Last Line Aligned To Start or Justify With Last Line 
Aligned To Center.


Figure 13 Properties panel, Character section


Figure 14 Color palette


Hexidecimal color 
value


Color Picker icon
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Adjusting leading and tracking


To improve readability and meet design goals, you can adjust the spacing between lines and characters—leading and 
tracking—for both TLF and Classic text.


Adjusting leading


Leading refers to the space between lines. In Classic text, leading is referred to as line spacing. You are probably used 
to differentiating between single-spaced and double-spaced text. By adjusting leading, you can fine-tune the space 
between lines. By default, leading is set to 120% of the text’s height for TLF text and 0 for Classic text. 


To adjust leading:


1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic).


2. Do one of the following:


• For TLF text, drag the Leading scrubber in the 
Character section of the Properties panel 
(Figure 15). You can also click the current Leading 
value and enter a new value. 


• For Classic text, drag the Line Spacing scrubber in 
the Paragraph section of the Properties panel 
(Figure 16). You can also click the current Spacing 
value and enter a new value.


The result of decreased leading is less space between 
lines of text. Increasing leading adds more space between 
lines of text (Figure 17).


Figure 15 Properties panel, Character section


Figure 16 Properties panel, Paragraph section


Figure 17 Increased leading
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Adjusting tracking


Tracking refers to the space between characters across a line of text. In Classic text, tracking is referred to as letter 
spacing. You adjust tracking to space the letters further apart or closer together.


To adjust tracking:


1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic).


2. Do one of the following:


• For TLF text, drag the Tracking scrubber in the 
Character section of the Properties panel 
(Figure 18). You can also click the current Tracking 
value and enter a new value.


• For Classic text, drag the Letter Spacing scrubber in 
the Character section of the Properties panel 
(Figure 19). You can also click the current Letter 
Spacing value and enter a new value.


The result of decreased tracking is less space between 
characters. Increasing tracking adds more space between 
characters (Figure 20).


Figure 18 Properties panel, Character section


Figure 19 Properties panel, Character section


Figure 20 Increased tracking
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Applying anti-aliasing


Anti-aliasing lets you smooth the edges of on-screen text. Anti-aliasing is especially useful for small font sizes. When 
anti-aliasing is enabled, all text in the current selection is affected. Anti-aliasing operates with text of all point sizes in 
the same way. You can apply anti-aliasing to TLF text or Classic text.


You can select from the following anti-aliasing options:


Use Device Fonts: The SWF file will use fonts installed on the viewer’s computer to display the fonts. This option 
doesn’t increase the size of the SWF file.You should use this option only with commonly installed fonts, such as 
Verdana or Arial.


Readability: Allows for improved legibility of embedded fonts, particularly at small sizes. To use this option, you 
must embed the font. When you embed fonts, Flash copies the font into the SWF file so that the font does not need to 
be present on the viewer’s computer. This increases the size of the SWF file slightly.


Animation: Creates a smoother animation of text by ignoring alignment and kerning information. To use this option, 
you must embed the font. When you embed fonts, Flash copies the font into the SWF file, so that the font does not 
need to be present on the viewer’s computer. This increases the size of the SWF file slightly. Animation anti-aliasing 
will be hard to read if font size is smaller than 10 points.


For Classic text, you can select two additional anti-aliasing options:


Bitmap Text (No Anti-alias): Useful for displaying small font sizes. Bitmap fonts do not contain outlines, which helps 
keep the file size of a published Flash document to a minimum.


Custom Anti-alias: Modify thickness and sharpness to control the effect anti-alias has on your text.


To set anti-aliasing:


1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic).


2. Choose an anti-aliasing option, such as Readability, from 
the Anti-Alias menu in the Character section of the 
Properties panel (Figure 21).


Figure 21 Anti-alias menu for TLF text
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Note: The Font Embedding Warning dialog box opens if 
you select Readability or Animation after selecting Use 
Device Fonts (Figure 22). You can click Embed to open 
the Font Embedding dialog box (Figure 23) and select 
which fonts to embed. You can click Not Now to 
continue without embedding fonts.


You can also open the Font Embedding dialog box by 
clicking Embed in the Character section of the Properties 
panel.


Figure 22 Font Embedding Warning dialog box


Figure 23 Font Embedding dialog box


Applying filters to text
To add interest or fulfill other design goals, you can apply graphics filters to both TLF and Classic text in Flash. 
These filters can make text appear to be raised, give text a shadow, or give text a glow. Graphics filters are available 
in the Filters section of the Properties panel.


Applying the Drop Shadow filter to text


The Drop Shadow filter makes it appear that text or an object is casting a shadow.


To add the Drop Shadow filter to text:


1. Use the Selection tool to select a text container (TLF) or 
field (Classic) with text.


Note: You cannot select the text itself to apply the filter.


2. In the Properties panel, display the Filters section 
(Figure 24).


Note: You may need to scroll down in the Properties 
panel to see the Filters section because it's at the bottom 
of the panel.


3. Click the Add Filter button in the lower-left corner of the 
panel.


Figure 24 Properties panel, Filter section


Add Filter button
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4. Select Drop Shadow in the Filters menu (Figure 25).


The text includes a drop shadow (Figure 26).


You can adjust the characteristics of the Drop Shadow, 
such as its color, in the Filters section of the Properties 
panel (Figure 27).


Figure 25 Filters menu


Figure 26 Drop shadow


Figure 27 Drop shadow properties


Other filters


You can apply several other filters to text to create interesting visual effects.


Blur


The Blur filter softens the edges and details of objects. Applying a blur to an object can make it appear to be behind 
other objects, or make an object appear to be in motion. Adjust the amount and direction of blur by using the X and Y 
text boxes.
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Glow


The Glow filter lets you apply a color around the edges of an object.


• Glow: Make the object appear to shine.


• Inner Glow: Apply the glow only within the boundaries of the object.


• Knockout: Remove the object and leave the glow. The object appears outlined in glow.


Bevel


Applying a bevel applies a highlight to the object that makes it appear to be raised above the background surface.


• Inner Bevel: Give the object a three-dimensional look by applying highlights and a shadow to the inside of the 
object.


• Outer Bevel: Give the object a three-dimensional look by applying highlights and a shadow to the outside of the 
object.


• Full Bevel: Apply both inner bevel and outer bevel effects to the object.


You can alter the bevel’s shadow and highlight colors, the type of bevel (inner, outer, or full), its strength, and the 
angle of light that falls on it.


Gradient Glow


Applying a gradient glow produces a glow look with a gradient color across the surface of the glow. The gradient 
glow requires one color at the beginning of the gradient with an Alpha value of 0. You cannot move the position of 
this color, but you can change the color.


Gradient Bevel


Applying a gradient bevel produces a raised look that makes an object appear to be raised above the background, with 
a gradient color across the surface of the bevel. The gradient bevel requires one color in the middle of the gradient 
with an Alpha value of 0.


Adjust color


You can use the Adjust Color filter to finely control the color attributes of the selected object, including contrast, 
brightness, saturation, and hue.


• Brightness: Make the object brighter or darker.


• Contrast: Increase or decrease the distinction between light and dark.


• Saturation: Increase the intensity of color. For example, raising saturation on blue text makes the text a more 
vibrant blue.


• Hue: Increase or decrease the shade of the color.

© 2012 Adobe Systems Incorporated How to work with text 11
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Designing for multiple screens

		With so many devices used to view content on the Internet, web designers must now consider how a site appears and functions on multiple screens.

		A few considerations:

		Target devices and their screen sizes

		How effectively a design scales to multiple screen sizes

		How a design appears when viewed in landscape and portrait views

		Readability of the content on small screens, such as on mobile phones

		How users interact with a site, such as navigating pages or zooming screens

		Compatibility with operating systems on devices



*

  

  

  

  



*

The question of viewing a site in landscape or portrait is important if viewers will access the site from a mobile device with auto rotation enabled. 

Compatibility with different runtimes and operating systems: It used to be that a web designer had to consider whether a site would display properly in multiple browsers, but now a designer must also consider whether features and functionality of the site work in browsers, Android devices, iOS devices, Nokia devices, Motorola devices, and so on.
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Designing for multiple screens

Decide which devices you’re targeting:

		Standard desktop monitors

		Wide-screen desktop monitors

		Laptops and netbooks

		Mobile devices such as

		Smartphones (iOS, Android, 

BlackBerry, and Windows)

		Tablets, such as iPad, Samsung Galaxy, and Kindle Fire







*



Desktop standard monitors are 4x3 aspect ratio

Desktop wide-screen monitors are 16x9 aspect ratio

*
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Trends in web design for multiple screens

You can design web content for multiple screens.  Each approach has its benefits and challenges.

		Create a responsive or flexible design that adapts automatically to each user’s screen.

		Create multiple versions of the same website and redirect users to the appropriate version of your content.

		Create native mobile applications aimed at specific mobile devices and operating systems. Suggest that mobile users download and install the mobile app instead of using their mobile web browser to view the web version of the content.





*



Multiple versions and redirecting users:  Another method for delivering a mobile design is to build an especially optimized layout for handheld devices.  For example, you create an experience specifically for your mobile users without taking away from the experience of desktop users. For this to work, you will have to route traffic on your site depending on the user’s browser agent. For example, if a mobile device user visits your site (yousitename.com), then they will automatically be redirected to  the mobile alternative URL.

*
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Responsive designs

		A responsive or flexible design scales and adapts your content to the screen and capabilities of each device. 

		Because so many devices in use, a cross-device web design is difficult to create, but there are some ways to make each website more responsive.

		The basic idea of responsive web design is that a website should respond to the device it’s being viewed on. For example:

		Adapting the layout to suit screen sizes (from widescreen desktops to phones)

		Resizing images to suit the screen resolution

		Using lower-resolution images for mobile devices

		Simplifying page elements for mobile use

		Hiding nonessential elements on smaller screens

		Providing larger, finger-friendly links and buttons for mobile users

		Detecting and responding to mobile features such as geolocation and device orientation



*

  

  

  

  



*
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When designing web content for multiple screens, you’ll need to consider how things such as page layout, fonts, navigation, buttons, and rich media affect your site’s usability when viewed on different devices.

Consider the following best practices: 

		Begin with a detailed design plan; research your target audience and devices.

		Use a consistent theme throughout your design.

		Simplify navigation and content layouts.

		Use icons to save space and improve usability.

		Include white space for better readability, especially on smaller screens.

		Limit the need to scroll, or use vertical scrolling only for longer pages. 

		Limit the use of large images (large file sizes).

		Optimize content for faster access and a better user experience.



Design best practices

*

  

  

  

  



*
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Consider these additional best practices: 

		Use video and audio sparingly (unless your site depends on it).

		Take into consideration devices without a mouse or other pointing device. For example, can viewers use the site touch screens?

		Use cookies sparingly.

		Enable automatic sign-in for secure content.

		Use Fluid Grid Layouts and CSS Media Queries in Adobe Dreamweaver CS6 to create flexible designs for multiple screens.

		Test on multiple devices or use device emulators.



Design best practices

*

  

  

  

  



*

Use cookies sparingly if one of your target screens is a mobile device. Cookie support cannot be relied upon since it may be disabled either in the device or by the mobile network. 

Enable automatic sign-in for secure content. This is especially important on a mobile device where data input is more difficult than on a desktop. If automatic sign-in is enabled, then your application should also include a link or button to sign out.

One way to test it to deploy your application on each target device. Another option is to test with device emulators. For example, Adobe Flash Professional CS6 includes a built-in mobile simulator for testing accelerometer, input, and geolocation features in a mobile application. Search online and you’ll find emulators for most devices, including Android, iPhone, Blackberry, and Windows—just to name a few.
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One of the most common challenges in designing for the small screens of mobile devices is to balance creativity with ease-of-use. Anything that simplifies your layout and navigation will work to your advantage.

These design strategies help users find and view what they’re looking for:

		Keep buttons large, with extra padding and spacing. Many devices have touch screens on which bigger buttons mean easier clicking.

		Keep navigation simple. Don’t flood a navigation bar with several options; instead choose five or fewer, and create sub-navigation if necessary. 

		Vertical navigation menus make viewing longer lists easier on many mobile input devices. 

		Use buttons (or icons) instead of standard text links for navigation.

		Avoid pop-ups or spawned windows.



Keep navigation simple

*

  

  

  

  



*
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Fluid Grid Layouts

		Adobe Dreamweaver CS6 streamlines the task of building adaptive designs for multiple screens with its integrated fluid grid.

		You can use CSS3 to create Fluid Grid Layouts that scale themselves to multiple screen sizes.



*

  

  

  

  



*
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Fluid Grid Layouts

*

  

  

  

  

In this example, a Fluid Grid Layout displays the page in a web browser.



*
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Fluid Grid Layouts

*

  

  

  

  

The Fluid Grid Layout displays the same page on a tablet.



*
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Fluid Grid Layouts

*

  

  

  

  

An now, the same page on a mobile phone.



*
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CSS media queries

The challenge is to ensure that your websites look good not only on a big screen but also on a tiny phone and everything in between.

		Media queries are an excellent way to deliver different styles to different devices, providing the best experience for each type of user. 

		A part of the CSS3 specification, media queries expand the role of the media attribute that controls how your styles are applied. 

		It has been common practice for years to use a separate style sheet for printing web pages by specifying media="print."  Media queries take this idea to the next level by allowing designers to target styles based on a number of device properties, such as screen width and orientation.



*

  

  

  

  



*
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CSS media queries

Here is an example of a simple media query:

<link rel="stylesheet" type="text/css"

 media="screen and (max-device-width: 480px)"

 href=“stylesheet.css" />

*

  

  

  

  

		If the browser displays this page on a screen that is less than 480 pixels wide, load stylesheet.css

		CSS3 also includes orientation (portrait or landscape), device-width, min-device-width, and many more media queries.

		View the examples on the next three slides to see how CSS Media Queries display the same website on three very different screens.





*
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CSS media queries

In this example, a media query is used to display the page in a web browser.

*

  

  

  

  

When viewed on a desktop, the page has a two-column layout.



*
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CSS media queries

The media query is used to display the same page on a tablet screen.

*

  

  

  

  

The layout switches to a single column to fit the narrower screen of a tablet.



*
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CSS media queries

And now, on a mobile phone.

*

  

  

  

  

Media queries restyle the page to fit the constraints of a much smaller screen.



*
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Summary

		Smart phones, tablets, and other mobile devices are everywhere, and demand for the same content on multiple screens is growing. 

		As content designers, many of the principles you’ve learned for web design apply to the creation of mobile content, but there are some important differences.

		The challenge for web designers is to ensure that your websites look good not only on a big screen but also on a tiny phone and everything in between. 

		When creating web content, you need to decide which devices you want your sites to be viewed. If you’re targeting multiple screens, consider creating a separate site targeted at each device, or make your site flexible or responsive to multiple screens.

		You can create flexible content by using Adobe Dreamweaver CS6 Fluid Grid Layouts and CSS media queries.



*

  

  

  

  



*
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How to optimize Flash content
As with all web content, it is important to keep Adobe Flash Professional CS6 file sizes as small as possible. Even 
though connection speeds have increased in the past few years, keeping file sizes small continues to be important, 
because document size can also affect content performance, and content is now delivered on a range of devices. This 
process is known as optimizing Flash content.


The following general principles can help you optimize Flash content:


• Use symbols, animated or otherwise, for every element that appears more than once.


• When creating animation sequences, use tweened animations whenever possible. These animations use less 
file space than a series of keyframes.


• For animation sequences, use movie clips instead of graphic symbols.


• Limit the area of change in each keyframe; make the action take place in as small an area as possible.


• Avoid animating bitmap elements; use bitmap images as background or static elements.


Optimizing images
Images present one of the best opportunities for optimizing file size in Flash.


Certain fills and effects can increase the size of your Flash movie. Use the following tips to optimize these movie 
features:


• Use the Color Effect section in the Symbol Properties panel to create many different-colored instances of a 
single symbol instead of creating multiple symbols.


• Use gradients sparingly. Minimize the number of simultaneous gradients in any given frame. Filling an area 
with gradient color requires about 50 bytes more than filling it with solid color. Gradients are also more 
complex for a computer processor to handle than a solid color.


• Use alpha transparency sparingly. It can slow playback.


Optimizing bitmaps


Bitmap images take up more space than vector images (vector is Flash’s normal format). Bitmap images are imported 
into Flash. JPEGs, GIFs, and BMPs are all bitmapped. The best bitmap format to import into Flash is PNG, which is 
the native file format of Adobe Fireworks. All photos—which are usually in JPEG form—are bitmapped. When you 
create an animation with bitmap images, Flash must store one bitmap image in each frame of the animation. In 
addition, bitmap images, unlike vector images, do not scale or rotate well on the screen; and bitmap images must be 
rendered each time they change positions on the screen. This often entails changing large areas of the movie and 
slowing down playback as these areas are continually redrawn.


If you feel your Flash movie must include bitmaps, use the following tips to optimize your movie:


• Use bitmap images sparingly.


• Avoid animating bitmap images.


• Convert the bitmap image into a symbol if it appears in more than one keyframe.


Use the Trace Bitmap command


The Trace Bitmap command (Modify > Bitmap > Trace Bitmap) lets you convert a bitmap to a vector image. This 
works best with simple images made up of mostly large blocks of color. If the bitmap contains complex shapes and 
many colors, the converted vector graphic can have a larger file size than the original bitmap. Try a variety of settings 
in the Trace Bitmap dialog box to find a balance between file size and image quality.
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Compression options


Compression helps reduce the total file space occupied by bitmap images. JPEG compression is the default 
compression for all bitmap images published from Flash. In the Publish Settings dialog box, you can adjust the value 
in the JPEG Quality field from 1 (most compression, lowest quality) to 100 (least compression, highest quality). 
Because JPEG compression can result in a loss of image data, test images with different JPEG quality values to 
achieve the best balance between compression and image quality for your particular movie.


Optimizing sound
Sound is another factor that can increase Flash file size. There are several ways to use sound efficiently in a movie 
and keep file size down.


• Use MP3 compression, the smallest sound format, whenever possible.


• Keep sounds short.


• Use the lowest bit-depth and sample rate acceptable to achieve the smallest data size. Try to find a happy 
medium between quality and data size.


• Loop short sounds to create background music.


• Looping smaller event sounds can achieve longer audio playback because a small amount of sound data is 
downloaded once and used repeatedly.


• Do not set streaming sound to loop.


• Use the Event synch option to deliver the sound data all at once as needed for playback. Use Stream synch to 
deliver the sound data over the specified series of frames. Try both approaches. Then watch the size report 
closely for clogging of data near keyframes, and use the preloading techniques to trim down the amount of 
data needed per frame or per second. You can generate a size report for a Flash movie when viewing the 
Flash (.swf) settings in the Publish Settings dialog box (File > Publish Settings, click Flash (swf.), select 
Generate Size Report in the Advanced section).


For more information about best practices in Flash, see the “Best Practices” section in Using Flash (Help > Flash 
Help).
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Setting audio compression options
In the following steps, you set audio to stream and add the audio to the timeline.


To set audio compression options:


1. Import audio into the sound layer of your Flash 
document.


2. In the Properties panel, set Sync to Stream (Figure 1).


Although streaming means losing some audio quality, it 
creates a smaller SWF file and synchronizes the audio to 
the object movements on the Stage.


If your sound file is longer than the elapsed time in the 
Timeline panel (Figure 2), you’ll need to add more 
frames in the sound layer to hear the entire sound file.


3. Use the frame rate shown at the bottom of the Timeline 
panel (Figure 2) and the length of the audio to calculate 
how many frames are required to play the entire sound 
file. For example, if your sound file is five seconds, and 
the frame rate is 24 fps, the timeline must extend to at 
least 120 frames.


You can add the new frames by inserting a single frame 
further down the timeline.


4. Based on the duration of the sound clip and the 
calculation you made in step 3, select the frame in the 
timeline where the sound file will end, and extend the 
timeline by selecting Insert Timeline > Frame.


All the audio will be visible in the timeline.


Note: Do not use Insert > Keyframe, because a new 
keyframe would stop the audio before it is finished.


Figure 1 Sound section of the Properties panel


Figure 2 Timeline panel


Frame rate Elapsed 
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How to prepare photographs
Photographs are an integral part of a well-designed website and there are many options for presenting photos in a web 
page. In Adobe Fireworks CS6, you can mask photos with shapes or text, adjust feathering and tones so that your 
images will work well with an overall design or theme of a website (Figure 1).


Figure 1 Masked and tinted photos and text


Masking photographs
Masking allows you to block out part of an underlying image. For example, you can paste an elliptical shape as a 
mask on top of a photograph. All areas outside the ellipse disappear as if cropped, showing only the part of the picture 
inside the ellipse.You can use masks to create cut-out effects or transparency effects on photos. You can also create 
interesting blending options for masked images. Feathering blurs the edges of a pixel selection and helps to blend the 
selected area with the surrounding pixels. Feathering is useful when you copy a selection and paste it onto another 
background. 


To mask a photograph by using the Paste As Mask command:


1. Start Fireworks and open the photograph you want to 
mask.


2. From the Tools panel, select a drawing tool such as the 
Brush, Pencil, Rectangle, or Ellipse tool and draw a 
masking region on the photo (Figure 3).


3. Position the masking region so that it overlaps the image 
into which you want to paste the contents.


The selection can be either in front of or behind the 
objects to be masked.


Figure 2 Masking region 
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4. Select Edit > Cut to cut the objects you want to use as the 
mask (Figure 3).


5. Use the Pointer tool to select the object or group you 
want to mask.


If you are masking multiple objects, they must be 
grouped.


6. Select Edit > Paste As Mask..


The objects you pasted appear to be inside or clipped by 
the mask object (Figure 4).


7. Save the file as a Fireworks PNG. 


This will let you edit the mask later.


Figure 3 Select the object to cut


Figure 4 Photograph visible through mask


To feather and add effects to a mask:


1. Select the mask thumbnail in the Layers panel 
(Figure 5).


Figure 5 Layers panel
Mask thumbnail
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2. In the Fill section of the Properties panel, select Feather 
from the Edge menu (Figure 6) and increase the Amount 
Of Feather by entering a higher number in the text box to 
the right of the Edge menu or using the slider. 


3. Deslect the Show Stroke And Fill option.


The edge of the mask is feathered (Figure 7). You can 
see the feathering better if you deselect the image. 


4. To add a glow, select the image thumbnail (not the mask) 
on the Layers panel.


5. In the Property inspector, click the Add Filters (+) button 
and select Shadow And Glow > Drop Shadow from the 
pop-up menu (Figure 8).


The Drop Shadow pop-up window opens (Figure 9).


6. Increase the Offset and Width of the glow until you can 
see it in the masked image.


7. Adjust the Softness, Opacity, and Color until you achieve 
the desired effect. 


8. When you finish, click outside the window or press Enter 
(Windows) or Return (Mac OS) to close the window.


9. Save the file and export the image as a JPEG or GIF file.


Figure 6 Properties panel


Figure 7 Feathered mask


Figure 8 Add Filters pop-up menu


Figure 9 Drop Shadow pop-up window


Set Feather Show Fill And StrokeEdge menu


Width


Opacity


Softness


Halo offset
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To create a text mask:


1. Open the photo to be masked.


2. Create text to become the mask for the image 
(Figure 10).


3. Adjust the text size and font and select Edit > Cut to 
move the text to the Clipboard.


4. Select the photo and select Edit > Paste As Mask.


Note: The image appears only in the area outlined by the 
text mask (Figure 11).


5. Click the image thumbnail in the Layers panel 
(Figure 12).


A light blue handle appears in the center of the image 
(Figure 13).


Note: If the handle falls within a light blue part of the 
masking region, it may be difficult to see. The pointer 
changes from a black arrow to a white arrow when it's 
over the handle; this can help you locate the handle 
within the masking region. 


6. Drag the handle to rearrange the position of the image 
under the mask.


7. Export the image as a JPEG or GIF file.


Figure 10 Text to mask image


Figure 11 Photograph visible through text mask


Figure 12 Image thumbnail selected


Figure 13 Text mask with handle


Image 
thumbnail


Handle
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Adjusting the color tone of photos
You can adjust the look of a photo by changing hue and saturation, or add interest by changing the photo to sepia tone 
or grayscale.


To adjust color tone:


1. Open the photo to be masked.


2. Select the bitmap image for color adjustments in the 
Layers panel.


3. Select Filters > Adjust Color > Hue/Saturation.


The Hue/Saturation dialog box opens (Figure 14)


4. Make sure the Preview option is selected.


5. Drag the Hue, Saturation, and Lightness sliders to create 
the desired color feel for the photo.


Note: As an alternative to dragging a slider, you can type 
a number in the associated text box.


6. To adjust the general color of the photo, select the 
Colorize option in the Hue/Saturation dialog box. When 
you are satisfied with your choices, click OK to close the 
dialog box.


7. To apply an antiqued look to the photo, select Commands 
> Creative > Convert To Sepia Tone.


8. To make the photo black and white, select Commands > 
Creative > Convert To Grayscale (Figure 15).


The Hue/Saturation levels are adjusted to achieve a black 
and white image.


Figure 14 Hue/Saturation dialog box


Figure 15 Image converted to black and white 
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Tips for information architecture
Information architecture (IA) is a method of organizing and labeling a website structure to support usability. Careful 
consideration of the content and organization of a site is the first step to creating an effective user experience. Also 
referred to as information design, structuring is about connecting users to the content and organizing information 
intuitively. It is also about blueprinting the site from a functional perspective to communicate easily with a client and 
a team. Ultimately, understanding what users are looking for and allowing easy access to content and information is 
the overall goal. It’s all about ensuring that users can get what they came for. A well-designed information 
architecture is similar to a table of contents. It helps improve discoverability, efficiency, satisfaction, and overall 
usability of a website.


[Information architecture is]…creating consistent and functional systems for 


navigation,  graphics, page layout and title languages, so that the user knows 


where to go, what to do, and encourages him or her to return.


- Web Review, Peter Monville


The information architecture step usually falls within the structure phase of web project production, before you create 
wireframes, design comps, and prototypes. 


Consider the following best practices when creating a well-designed information architecture.


Research the needs of the audience and users
Who is your target audience? What kind of user are you trying to attract to the website? These important initial 
questions inform the way you structure content and information. You must create the information architecture of your 
site with your audience in mind.


Identify a clear purpose for the site
Always keep the goals in mind while you’re creating the information architecture. Every website needs a clear goal: 
to educate, inform, entertain, market, sell, or any combination of these. Establishing clear goals helps you structure 
effective information architecture.


Inventory and assemble site content
You may be working on a new website from scratch or redesigning an existing website. Regardless, it’s important to 
perform an inventory of content you already have and describe any new content to be created. The content is the core 
of the site, so you need to know if it is suitable for your audience and supports the overall goals of the site. Another 
consideration is presenting content across multiple screens and devices. You should structure content carefully so it 
presents well on a range of computers, tablets, and smartphones.


Assemble site content into logical groups
Content and structure are intertwined. Assembling content into logical groups helps establish clear and consistent site 
organization and facilitates the task of defining the information architecture.
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Create a site map
Your site’s structure is composed of the categories and logical groups you just created. A site map serves as a bird’s-
eye view of the project that enables you to see how the site is organized and how users will view the site’s content and 
information. The site map becomes a blueprint that shapes the structure of the site during the development process. 
The site map should show main areas of content and represent all the pages within each section (Figure 1). 


Figure 1 Example site map for Coast Middle School website


Design navigation systems
Clear navigation helps connect users with the content on your site. Buttons, links, and graphics can be used from each 
screen to maintain a sense of place. Users need to stay oriented to where they are in the site, where they need to go, 
and how to get back to where they came from. Having a consistent navigation helps orient users and keep them from 
feeling lost. As users move from page to page, make sure they find familiar visual cues and navigational aids.


Summary
The information architecture, a component of the structuring stage, is complete. You have created a content site map 
and designed a set of navigation elements. Don’t underestimate the importance of the structuring phase, as it’s crucial 
to successfully realizing the next phase: design and prototyping.
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Introduction to HTML and CSS
Before you learn about Cascading Style Sheets (CSS), you should have a basic understanding of HTML, the 
programming language used to create web pages.


The structure and appearance of a web page is controlled by its underlying code. The programming language used to 
write this code for web pages is Hypertext Markup Language, or HTML.


If you view the code for most web pages, you will see line after line of ordinary text, surrounded by short commands 
called HTML tags. These tags are placed in brackets at the beginning and end of blocks of text and tell a web browser 
how to display or interact with information between the tags. Tags are enclosed by angle brackets (<>) and usually 
come in pairs with a start (or opening) and end (or closing) tag. The example shows two HTML tags that tell a web 
browser where a paragraph of text begins and ends (Figure 1). The HTML tags themselves are not displayed in the 
browser.


Figure 1 Sample HTML tags


When you create a web page by using Dreamweaver in Design view, the HTML code is created automatically. These 
are common tags you will see when working in Dreamweaver:


• <html></html> describes the web page


• <head></head> describes the header of the web page


• <body></body> describes visible page content


• <h1></h1> displays a heading, ranging in size from 1 (biggest) to 6 (smallest)


• <p></p> formats text as a paragraph


• <strong></strong> bolds text


• <em></em> emphasizes text, displays as italics


• <br> creates a line break


• <a href="http://www.example.com"></a> creates a link to a web page


Note: Dreamweaver uses code coloring to help you identify general categories of tags and code elements in Code 
view. 


Although HTML includes tags for displaying text, images, tables, and other page elements, it has limited precision in 
page layout and formatting—a frustration for many designers. 


Cascading Style Sheets (CSS) is a collection of formatting rules that control the appearance of content (such as 
HTML tags) in a web page. Using CSS styles to format a page separates content from presentation. The content of 
your page—the HTML code and tags—resides in the HTML file, and the CSS rules defining the presentation of the 
code reside in another file (an external style sheet) or in another part of the HTML document (usually the head 
section). Separating content from presentation mean you can more easily maintain the appearance of your site from a 
central location, because you don’t need to update every property on every page whenever you want to make a 
change. Separating content from presentation also results in simpler and cleaner HTML code, which provides shorter 
browser loading times and simplifies navigation for people with accessibility issues (for example, those using screen 
readers).


<p>This is a paragraph of text.</p>


Paragraph starting tag Paragraph ending tag
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If you have worked with styles in other programs, such as a word processor, you are already familiar with the basic 
function of CSS. In CSS, a style is simply a rule describing how to format content on a web page. A CSS (style sheet) 
is a collection of these rules.


About CSS rules
A CSS formatting rule consists of two parts: the selector and the declaration (or in most cases, a block of 
declarations). The selector is a term (such as p, h1, a class name, or an id) that identifies the formatted element. The 
declaration block defines the style properties. In the following example, h1 (a heading tag) is the selector, and 
everything that falls between the braces ({and }) is the declaration block (defining the properties of the h1 heading):


h1 { 


font-family: Georgia, "Times New Roman", Times, serif;


font-size: 18px;


text-transform: uppercase;


color: #090; 


}


An individual declaration consists of two parts: the property (such as font-family) and value (such as Georgia). In the 
previous CSS rule, a particular style has been created for h1 tags; the text for all h1 tags linked to this style will be 18 
pixels in size, Georgia font, and uppercase, and [color 090]. 


The style (which comes from a rule, or a collection of rules) resides in a place separate from the actual text it’s 
formatting—usually in an external style sheet or in the head section of an HTML document. Thus, one rule for h1 
tags can apply to many tags at once (and in the case of external style sheets, the rule can apply to many tags at once on 
many different pages) (Figure 2). In this way, CSS provides extremely easy update capability. When you update a 
CSS rule in one place, the formatting of all the elements that use the defined style is automatically updated to the new 
style.


Figure 2 Updating a CSS rule in one place updates all elements


There are three main types of CSS:


Class style: Similar to the styles you use in word processing and page layout programs. For example, you may 
want to format all body text in 10-point, Arial, dark green type. You can create a class style with these attributes 
and then apply this style to all body text in your website. Class names must begin with a period and can contain 
any combination of letters and numbers (for example, .myhead1). 
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HTML tag style: Applies global formatting to individual HTML tags rather than to individual selections. 
Suppose you want to modify the Heading 1 paragraph style to appear always in purple text. Instead of creating a 
class style and applying it to every heading in the document, you can create an HTML tag style with these 
attributes and apply it to the Heading 1 <h1> tag. In effect, you are redefining the HTML tag.


ID style: A unique identifier (ID) for a style applied to headers, banners, menus, and other elements present in 
only one location in the document. Used once within a document or page. IDs must begin with a pound (#) sign 
and can contain any combination of letters and numbers (for example, #myID1). 


CSS rules can reside in the following locations:


Internal (or embedded) CSS style sheets are collections of CSS rules included in a style tag in the head section of 
an HTML document.


External CSS style sheets are collections of CSS rules stored in a separate, external CSS (.css) file (not an HTML 
file). You link this file to one or more pages in a website by using a link or an @import rule in the head section of 
a document. 


Evolution of HTML and CSS
HTML and CSS are web standards that are constantly evolving. 


HTML5 is the fifth iteration of HTML and adds tags to support multimedia elements and dynamic graphics in 
modern web browsers and across various devices. CSS3 defines a new set of modular rules for how HTML content is 
presented in web browsers.


In Dreamweaver, you can create and edit HTML5-based web pages. Dreamweaver provides code hints for HTML5 
elements and CSS3 styles when you build pages in the Code View window. Starter layouts are also available for 
building HTML5 pages from scratch.


You should observe the following best practices when authoring HTML5 pages:


• Use <!doctype html> to tell browsers the web page is formatted with HTML5.


• Use <meta charset="utf-8"> to tell browsers which character-set is in use in the document.


• Use the semantic markup tags <article>,  <section>, <header>,  <nav>, and others to bring a higher 
level of structural meaning to HTML5 documents.


• Design and test content across a range of browsers and devices that support HTML5 capabilities.


Review these HTML5 and CSS3 resources from the W3C:


• W3C HTML5 specifications: http://dev.w3.org/html5/spec/single-page.html


• HTML5 differences from HTML4: www.w3.org/TR/html5-diff/


• W3C CSS home page: www.w3.org/Style/CSS/ 
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Project plan


Team name: __________________________________________________ Date: ________________________


Client name: _________________________________________________


Think through the phases of your client project and identify the estimated time and the date when each task will be 
finished. Identify an owner for each task who will make sure the task is completed.


Project phases Estimated hours Date due Owner


Define


Goals and target audience


Content and asset 
collection


Content and style 
information


Delivery requirements


Structure


Information architecture


Design document


Flowchart


Wireframes


Design


Design comps


Design review
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Redesign


Production storyboard


Prototype wireframe


Build and test


Site production


Technical test and bug list


Usability test


Revision


Test of revised site


Final presentation


Final revision


Launch


Search Engine 
Optimization (SEO)


Promotion plan


Put site online


Total time: = Final deadline


Project phases Estimated hours Date due Owner
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How to use templates
You can use an Adobe Dreamweaver CS6 template to create multiple pages with the same layout. In a template, you 
control which page elements should remain constant in documents based on that template and which elements can be 
changed from page to page. Templates are helpful for building a website in which most pages have the same header, 
navigation system, and other elements. Using templates helps you save time as well as create and maintain a 
consistent look when more than one person is developing a site.


Creating a template
You create templates from existing pages, setting editable regions on these pages that will hold content on each page 
created from the template.


To create a template:


1. Start Dreamweaver.


2. Build a page that contains elements designed to appear 
on all content pages such as common graphics, a 
navigation bar, and common layout structures such as div 
tags (Figure 1).


Note: You may want to create navigation elements in 
Adobe Fireworks CS6 and export them as HTML 
documents.


3. Select File > Save As Template.


4. In the Save As Template dialog box (Figure 2), give the 
template a name. You can also enter a brief description of 
the template. Then click Save. If Dreamweaver asks if 
you want to update links, click Yes.


Dreamweaver creates a Templates folder in your site root 
folder and saves your template in that folder. Template 
files have a .dwt file extension.


Figure 1 Common elements on a web page


Figure 2 Save As Template dialog box
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To create an editable region:


1. In the Layout category of the Insert panel, click Draw AP 
Div, and then drag on the page to create a new div to 
represent the editable region in the template.


Note: You also click to indicate where to place the 
editable region, but using a div gives you more control 
over page layout. 


2. With the div still selected, do one of the following to 
create an editable region:


• Select Insert > Template Objects > Editable Region.


• Right-click (Windows) or Control-click (Mac OS) 
the region and select Templates > New Editable 
Region from the context menu.


• In the Common category of the Insert panel, click the 
Templates button (Figure 3), and select Editable 
Region from the pop-up menu.


The New Editable Region dialog box opens (Figure 4).


3. In the dialog box, enter a unique name for the region, and 
click OK.


The editable region is within the selected div, and is 
enclosed in a light blue rectangle on the template 
(Figure 5).


Note: You cannot use the same name for more than one 
editable region in a particular template. Use only letters 
and numbers in the name.


4. Save and close the template.


Figure 3 Templates button on the Insert panel


Figure 4 New Editable Region dialog box


Figure 5 New editable region inside the div
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To create a document based on a template:


Once you create a template, you can use it to create new 
documents.


1. Select File > New.


2. In the New Document dialog box, select the Page From 
Template category.


The dialog box displays your sites and all of the 
templates for the selected site (Figure 6).


3. In the Sites list, select the site that contains the template 
you want to use.


4. Select the template you want to use.


5. Make sure the Update Page When Template Changes 
option is selected.


With this option selected, Dreamweaver can update all 
template-based pages if you change the template later.


6. Click Create to create a new template-based page.


The document opens in the Document window.


7. Click in one of the editable regions, and add text.


8. Move the pointer over a page area that is not editable, and 
observe that you cannot make changes.


9. Save the page.


Figure 6 Page From Template category in the New 
Document dialog box


Editing a template
You can edit a template at any time, even if you have created pages based on the template.


To edit a template:


1. Select Window > Assets.


The Assets panel opens.


2. Click the Templates button on the left side of the panel 
(Figure 7).


A list of the templates for your site appears in the lower 
pane. The upper pane displays a preview of the selected 
template. (You may need to scroll the preview pane to see 
this.)


3. Select the template you wish to edit and do one of the 
following:


• Double-click the name of the template.


• Click the Edit button at the bottom of the panel 
(Figure 7).


4. Edit the template in the Document window, changing 
non-editable elements or creating editable regions in the 
template as desired.


Figure 7 Assets panel


Templates Edit Delete
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5. Save the edited template by choosing File > Save.


The Update Template Files dialog box opens, with a list 
of the documents based on your template (Figure 8).


6. Click Update to update the documents based on the 
changes you made in your template.


The Update Pages dialog box displays a summary of the 
updates performed (Figure 9). You may need to select 
Show log to view the Status information.


7. Click Close.


Figure 8 Update Template Files dialog box


Figure 9 Update Pages dialog box


Deleting a template


To delete a template:


1. Select the template in the Assets panel.


2. Click the Delete button (trash can icon) at the bottom of 
the panel and confirm that you want to delete the 
template (Figure 7).


The template file is deleted from your site.


Documents that were based on a template you have 
deleted retain the structure and editable regions the 
template file had before you deleted it. To turn such a 
document into a normal HTML file without editable or 
locked regions, you must detach it from the template.


Detaching from a template
To remove the template structure and constraints from a document based on a template, you can detach the document 
from the template. When a document is detached from its template, you can edit any element, including the regions 
that were previously locked.


To detach a file from a template


1. To detach a document from a template, open the 
document.


2. Select Modify > Templates > Detach From Template.
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How to work with external Cascading Style Sheets
Many web professionals find that using an external style sheet--a style sheet that exists in its own file--offers a 
number of advantages over including styles in the header of an HTML file. These advantages include:


• Flexibility: With CSS stored in one file, you can easily change the appearance of all documents that refer to 
the external style sheet.


• Consistency: All documents sharing the same style sheet will have a similar appearance.


Using an external style sheet separates form from content. Separating form from content is a widely-adopted principle 
in web design which allows, among other benefits, for content to be shared in a range of contexts. 


Exporting CSS rules to an external style sheet
You can convert an internal CSS style sheet to an external one by exporting it, removing the internal CSS style sheet, 
and attaching the exported CSS style sheet to one or more web pages. 


To export a style sheet:


1. Start Dreamweaver and open the CSS Styles Panel 
(Window > CSS Styles) (Figure 1).


2. Confirm that All is selected in the CSS Styles panel.


3. Select the CSS rule you want to move to an external style 
sheet.


Note: To move more than one rule at a time, you can 
Shift-click to select multiple rules that are next to each 
other. To select multiple rules that aren’t next to each 
other, you can Control-click (Windows) or Command-
click (Mac OS) the names of the rules.


4. Right-click (Windows) or Control-click (Mac OS) the 
selected rule(s) and select Move CSS Rules in the context 
menu.


The Move To External Style Sheet dialog box opens 
(Figure 2).


Figure 1 CSS Styles panel


Figure 2 Move To External Style Sheet dialog box
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5. Select A New Style Sheet and then click OK.


The Save Style Sheet File As dialog box opens 
(Figure 3).


6. Browse to a location for the CSS file, enter a name for the 
file, and click Save.


Note: It is good practice to place CSS files in their own 
folder and good practice to name that folder css.


Dreamweaver exports the CSS file.


Figure 3 Save Style Sheet File As dialog box


To delete an internal style sheet:


1. In the CSS Styles panel under All, select <style>.


2. Click the Delete Embedded Stylesheet button (Figure 4).


Dreamweaver removes the internal style sheet. If the 
internal style sheet contains any styles still being used on 
the page, the affected text reverts to its default 
formatting, or it takes on the formatting defined in the 
external style sheet.


Figure 4 CSS Styles panel


Delete Embedded Style Sheet button
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Attaching an external style sheet
Once you create an external style sheet and attach it to multiple documents, you can instantly change any style in all 
your documents by making changes to the external style sheet.


Note: Once you start using an external style sheet, it is best to make all text formatting changes through that style 
sheet. If you make formatting changes through the Properties panel, Dreamweaver will automatically create a new 
internal style sheet.


To attach an external style sheet:


1. Open a document in Dreamweaver.


2. Confirm that the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


3. Click the Attach Style Sheet button (Figure 5).


The Attach External Style Sheet dialog box opens 
(Figure 6).


4. Click Browse, navigate to your saved style sheet, select 
it, and click OK.


5. In the Attach External Style Sheet dialog box, click OK.


Dreamweaver attaches the style sheet to your document 
(Figure 7).


The style sheet’s rules are now available in the Properties 
panel. You may need to expand the style sheet to see its 
rules.


You can attach the same style sheet to multiple 
documents. When you make changes to the style sheet, 
those changes will appear in all documents the style sheet 
is attached to.


Figure 5 CSS Styles panel


Figure 6 Attach External Style Sheet dialog box


Figure 7 Attached style sheet


Attach Style Sheet button
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Creating external style sheets
You can also create external style sheets directly from the New Document dialog box. 


To edit create an external Style Sheet:


1. Select File > New to create a new document.


The New Document dialog box opens (Figure 8).


2. In the Blank Page category of the New Document dialog 
box, select CSS for Page Type.


3. Click Create. 


The untitled CSS page opens in Dreamweaver in Code 
View (Figure 9).


4. Save the document to the site root folder.


5. Return to the HTML document in which you previously 
applied a style by using the CSS Styles panel.


6. In Code View, drag to select the two or more styles you 
previously created. Be sure to include the selectors and 
everything that falls between, including the braces 
(Figure 10).


7. Select Edit > Cut.


8. Click the newly-created CSS document in the Document 
window.


9. Place the cursor on line 4, beneath the CSS comment.


10. Select Edit > Paste.


The copied CSS styles are pasted from the Clipboard into 
the CSS document.


11. Select File > Save.


12. Return to the HTML document in the document window.


Notice in the Design View that all formating for the text 
is gone. In the next steps, you re-apply the CSS styles by 
linking to the external CSS document you just created.


13. In the CSS Styles panel, click the Attach Style Sheet 
button in the lower-right corner of the pane (Figure 5).


The Attach External Style Sheet dialog box opens 
(Figure 11).


14. Click the Browse button and browse to the external CSS 
style sheet that you saved to your site root folder, and 
confirm that the Add As: Link option is selected.


15. Click OK.


A link to the CSS document is added to Head section of 
the  file, and the CSS rules are applied to the text in the 
HTML document.


16. Save the file.


Figure 8 New Document dialog box


Figure 9 New, blank CSS document


Figure 10 Selecting CSS styles


Figure 11 Attach External Style Sheet dialog box
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Narrative summary and storyboard


Student name:_________________________________________________ Date: ________________________


To help your producer create your narrative, provide the following information:


• Description of the overall movie in the form of a rough flowchart


• List of the filenames and general settings for the movie


• Detailed storyboard sketches and descriptions for each section of the movie


Narrative flowchart


General movie settings


Filename: ____________________________________________________


Main folder (contains all files for the movie): ________________________


Image source folder:____________________________________________


Video source folder:____________________________________________


Document size: ________________________________________________


Background color: _____________________________________________


Frame rate:____________________________________________________


Audio source folder: ____________________________________________
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Storyboard #____________________ Student name: _________________________________________________Movie Title:______________________


To complete the storyboard, draw and describe the initial and final state of each section. Then describe the transition from the initial to the final state.


Description of inital state: Description of transition Description of final state:


Drawn images: Describe objects that change and how they 
change. Estimate the time for each change in 
seconds.


Drawn images:


Imported images: Imported images:


Audio (music or sound effect loop): Audio (music or sound effect loop):


Audio (spoken text): Audio (spoken text):


Displayed text: Displayed text:


Other Other
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How to work with text
Adobe Flash Professional CS6 lets you add text to a Flash application in two formats:


• You can add Text Layout Framework (TLF) text.


• You can add Classic text.


Using the Text Layout Framework
TLF text provides the following enhancements over Classic text:


• You can adjust a wider range of character aspects, such as leading and tracking.


• You can rotate text more easily.


• You can flow text across multiple containers, as it does in a magazine page layout.


• You can better control the attributes of Asian text.


• You can create right-to-left text.


The Text Layout Framework is available as an option in the Properties panel. 


TLF text requires that ActionScript 3.0 and Flash Player 10 or later are specified in the publish settings of your FLA 
file. See the guide “How to publish a Flash document” for more information about publish settings.


To create TLF text:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Click the Text tool.


3. Make sure the Properties panel is open. If not, select 
Window > Properties.


4. Select TLF Text from the Text Engine menu (Figure 1).


5. Move the pointer to the Stage.


The pointer changes to a cross hair with the letter T 
attached to it.


6. Drag to create a container (Figure 2).


7. Release the mouse button and click in the container.


8. Type some text (Figure 3).


Figure 1 Text Engine menu.


Figure 2 Dragging to create a container


Figure 3 Text container
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Managing text flow for TLF text


If you fill a Flash TLF text container with more text than fits within the bounding box, a red plus symbol appears. 
This red plus indicates the text is overset. Overset text is text that does not fit in the container.You can solve the 
problem of overset text by making the container bigger, but often you will want to continue the text in another 
container, either on the same page or on another page. This is called text flow. 


For example, in Figure 4 the upper container is overset and needs to flow to the lower text container.


Figure 4 Overset text


In Figure 5, the two containers have been linked, as indicated by a line between the Out port of the top container and 
the In port of the bottom container.


Figure 5  Linked containers


Out port of text container In port of text container
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To flow text:


1. Use the Selection tool to select a container.


2. Click the Out port in the lower-right corner of the 
selected container.


The pointer changes to the loaded text icon, an arrow 
with small lines of text (Figure 6).


3. Then do one of the following:


• To link to an existing container, position the pointer 
over the target container. The pointer changes to the 
link text icon, an arrow with chain links (Figure 7). 
Click the container to link the two containers.


• To link to a new container, click or drag on an empty 
part of the Stage. Clicking creates an object of the 
same size and shape as the original; dragging lets 
you determine the size of the container.


The containers are now linked and text will flow between 
them (Figure 8).


Figure 6 Loaded text icon


Figure 7 Link text icon


Figure 8 Result of linking to a text container
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Using Classic text
You can specify three types of Classic text in the Properties panel: Static, Dynamic, and Input. The default type is 
Static. Use Static text when the text will not change, such as button and form labels. Use Dynamic text for text that 
will change as the movie plays, such as text pulled from an external database in response to a viewer’s request. Use 
Input text for requesting input from the viewer, such as a user name and password—input text is similar to a form 
field.


To use Classic text:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. In the Tools panel, select the Text tool.


3. Make sure the Properties panel is open. If not, select 
Window > Properties.


4. Select Classic Text from the Text Engine menu 
(Figure 9).


5. In the Properties panel, make sure that Static Text is 
selected in the Text Type menu (Figure 9).


6. Move the pointer to the Stage.


The pointer changes to a cross hair with the letter T 
attached to it.


7. To create an expanding-width text field, click on the 
Stage.


The text field contains a flashing insertion point. This is 
where text appears as you type. The round handle 
indicates the text field is an expanding-width one-line 
static text field (Figure 11).


8. Type the text.


The text field expands as you type.


9. Click away from the text to deselect it.


10. To create a fixed-width text field, drag on the Stage to 
create a text box. Make the box about as wide as you 
think is necessary to fit your text.


A text field is created. This text field has a square handle 
in the upper right corner (Figure 12). The square handle 
indicates that the text field is a fixed-width static text 
field.


Figure 9 Text Engine menu


Figure 10 Text Type menu


Figure 11 Expanding-width one-line static text 
field


Figure 12 Fixed-width static text field


Round handle


Square handle
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11. Type the text.


The text you type wraps to a new line when it reaches the 
right edge of the text field.


12. Drag the square handle to the right until the text is on a 
single line.


Note: Double-clicking a square handle changes it to a 
round handle and changes the text field to an expanding-
width one-line static text box.


13. Click away from the text to deselect it.


Formatting both TLF and Classic text
You can apply basic character formatting to TLF or Classic text, such as font family, font type, font style, and font 
color. You can also adjust tracking, adjust leading, and apply anti-aliasing to both formats.


To apply basic formatting to text:


1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic). 


2. In the Character section of the Properties panel, choose a 
different font family in the Font Family menu, such as 
Verdana (Figure 13).


3. Choose a different font style, such as italic or bold.


4. Set a different font size, such as 14, by using the Size 
scrubber. (You can also click the scrubber and type a 
value for Size.).


5. Choose a different font color by clicking the Color box 
and doing one of the following:


• Select a color from the Color palette (Figure 14).


• Enter a hexadecimal color value in the upper-left 
corner (Figure 14).


• Click the Color Picker icon and select a color from 
the system color picker. (When setting the text color, 
use only solid colors, not gradients. To apply a 
gradient to text, break the text apart and convert the 
text to its component lines and fills.)


6. In the Paragraph section of the Properties panel, choose 
an alignment for the text, such as left, centered, right, or 
justify.


Note: For TLF text, Flash provides additional Justify 
alignment options for the last line of text, such as Justify 
With Last Line Aligned To Start or Justify With Last Line 
Aligned To Center.


Figure 13 Properties panel, Character section


Figure 14 Color palette


Hexidecimal color 
value


Color Picker icon
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Adjusting leading and tracking


To improve readability and meet design goals, you can adjust the spacing between lines and characters—leading and 
tracking—for both TLF and Classic text.


Adjusting leading


Leading refers to the space between lines. In Classic text, leading is referred to as line spacing. You are probably used 
to differentiating between single-spaced and double-spaced text. By adjusting leading, you can fine-tune the space 
between lines. By default, leading is set to 120% of the text’s height for TLF text and 0 for Classic text. 


To adjust leading:


1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic).


2. Do one of the following:


• For TLF text, drag the Leading scrubber in the 
Character section of the Properties panel 
(Figure 15). You can also click the current Leading 
value and enter a new value. 


• For Classic text, drag the Line Spacing scrubber in 
the Paragraph section of the Properties panel 
(Figure 16). You can also click the current Spacing 
value and enter a new value.


The result of decreased leading is less space between 
lines of text. Increasing leading adds more space between 
lines of text (Figure 17).


Figure 15 Properties panel, Character section


Figure 16 Properties panel, Paragraph section


Figure 17 Increased leading
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Adjusting tracking


Tracking refers to the space between characters across a line of text. In Classic text, tracking is referred to as letter 
spacing. You adjust tracking to space the letters further apart or closer together.


To adjust tracking:


1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic).


2. Do one of the following:


• For TLF text, drag the Tracking scrubber in the 
Character section of the Properties panel 
(Figure 18). You can also click the current Tracking 
value and enter a new value.


• For Classic text, drag the Letter Spacing scrubber in 
the Character section of the Properties panel 
(Figure 19). You can also click the current Letter 
Spacing value and enter a new value.


The result of decreased tracking is less space between 
characters. Increasing tracking adds more space between 
characters (Figure 20).


Figure 18 Properties panel, Character section


Figure 19 Properties panel, Character section


Figure 20 Increased tracking
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Applying anti-aliasing


Anti-aliasing lets you smooth the edges of on-screen text. Anti-aliasing is especially useful for small font sizes. When 
anti-aliasing is enabled, all text in the current selection is affected. Anti-aliasing operates with text of all point sizes in 
the same way. You can apply anti-aliasing to TLF text or Classic text.


You can select from the following anti-aliasing options:


Use Device Fonts: The SWF file will use fonts installed on the viewer’s computer to display the fonts. This option 
doesn’t increase the size of the SWF file.You should use this option only with commonly installed fonts, such as 
Verdana or Arial.


Readability: Allows for improved legibility of embedded fonts, particularly at small sizes. To use this option, you 
must embed the font. When you embed fonts, Flash copies the font into the SWF file so that the font does not need to 
be present on the viewer’s computer. This increases the size of the SWF file slightly.


Animation: Creates a smoother animation of text by ignoring alignment and kerning information. To use this option, 
you must embed the font. When you embed fonts, Flash copies the font into the SWF file, so that the font does not 
need to be present on the viewer’s computer. This increases the size of the SWF file slightly. Animation anti-aliasing 
will be hard to read if font size is smaller than 10 points.


For Classic text, you can select two additional anti-aliasing options:


Bitmap Text (No Anti-alias): Useful for displaying small font sizes. Bitmap fonts do not contain outlines, which helps 
keep the file size of a published Flash document to a minimum.


Custom Anti-alias: Modify thickness and sharpness to control the effect anti-alias has on your text.


To set anti-aliasing:


1. Select the Text tool and drag to select some text. Or use 
the Selection tool to select a text container (TLF) or text 
field (Classic).


2. Choose an anti-aliasing option, such as Readability, from 
the Anti-Alias menu in the Character section of the 
Properties panel (Figure 21).


Figure 21 Anti-alias menu for TLF text

How to work with text © 2012 Adobe Systems Incorporated







Adobe Flash Professional CS6 Project 7 guide

Note: The Font Embedding Warning dialog box opens if 
you select Readability or Animation after selecting Use 
Device Fonts (Figure 22). You can click Embed to open 
the Font Embedding dialog box (Figure 23) and select 
which fonts to embed. You can click Not Now to 
continue without embedding fonts.


You can also open the Font Embedding dialog box by 
clicking Embed in the Character section of the Properties 
panel.


Figure 22 Font Embedding Warning dialog box


Figure 23 Font Embedding dialog box


Applying filters to text
To add interest or fulfill other design goals, you can apply graphics filters to both TLF and Classic text in Flash. 
These filters can make text appear to be raised, give text a shadow, or give text a glow. Graphics filters are available 
in the Filters section of the Properties panel.


Applying the Drop Shadow filter to text


The Drop Shadow filter makes it appear that text or an object is casting a shadow.


To add the Drop Shadow filter to text:


1. Use the Selection tool to select a text container (TLF) or 
field (Classic) with text.


Note: You cannot select the text itself to apply the filter.


2. In the Properties panel, display the Filters section 
(Figure 24).


Note: You may need to scroll down in the Properties 
panel to see the Filters section because it's at the bottom 
of the panel.


3. Click the Add Filter button in the lower-left corner of the 
panel.


Figure 24 Properties panel, Filter section


Add Filter button
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4. Select Drop Shadow in the Filters menu (Figure 25).


The text includes a drop shadow (Figure 26).


You can adjust the characteristics of the Drop Shadow, 
such as its color, in the Filters section of the Properties 
panel (Figure 27).


Figure 25 Filters menu


Figure 26 Drop shadow


Figure 27 Drop shadow properties


Other filters


You can apply several other filters to text to create interesting visual effects.


Blur


The Blur filter softens the edges and details of objects. Applying a blur to an object can make it appear to be behind 
other objects, or make an object appear to be in motion. Adjust the amount and direction of blur by using the X and Y 
text boxes.
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Glow


The Glow filter lets you apply a color around the edges of an object.


• Glow: Make the object appear to shine.


• Inner Glow: Apply the glow only within the boundaries of the object.


• Knockout: Remove the object and leave the glow. The object appears outlined in glow.


Bevel


Applying a bevel applies a highlight to the object that makes it appear to be raised above the background surface.


• Inner Bevel: Give the object a three-dimensional look by applying highlights and a shadow to the inside of the 
object.


• Outer Bevel: Give the object a three-dimensional look by applying highlights and a shadow to the outside of the 
object.


• Full Bevel: Apply both inner bevel and outer bevel effects to the object.


You can alter the bevel’s shadow and highlight colors, the type of bevel (inner, outer, or full), its strength, and the 
angle of light that falls on it.


Gradient Glow


Applying a gradient glow produces a glow look with a gradient color across the surface of the glow. The gradient 
glow requires one color at the beginning of the gradient with an Alpha value of 0. You cannot move the position of 
this color, but you can change the color.


Gradient Bevel


Applying a gradient bevel produces a raised look that makes an object appear to be raised above the background, with 
a gradient color across the surface of the bevel. The gradient bevel requires one color in the middle of the gradient 
with an Alpha value of 0.


Adjust color


You can use the Adjust Color filter to finely control the color attributes of the selected object, including contrast, 
brightness, saturation, and hue.


• Brightness: Make the object brighter or darker.


• Contrast: Increase or decrease the distinction between light and dark.


• Saturation: Increase the intensity of color. For example, raising saturation on blue text makes the text a more 
vibrant blue.


• Hue: Increase or decrease the shade of the color.
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How to make websites accessible
Creating accessible web pages has never been more important than today. With the adoption of accessibility standards 
in the United States, Canada, the European Union, Australia, Japan, and other countries, designers and developers 
need to ensure that people with disabilities can access the contents of websites and web applications, as well as the 
authoring tools used to create them.


Accessibility refers to making websites and web products usable for people with visual, auditory, motor, and other 
disabilities. Examples of accessibility features for software products and websites include screen reader support, text 
equivalents for graphics, keyboard shortcuts, change of display colors to high contrast, and so on. Dreamweaver 
provides tools that make it accessible to use and tools that help you author accessible content.


Dreamweaver enables designers and developers to create accessible pages that contain useful content for screen 
readers and comply with federal government guidelines. For example, dialog boxes prompt you to enter accessibility 
attributes—such as text equivalents for an image—when you insert page elements. Then, when the image appears on 
a page for a user with visual disabilities, the screen reader voices the description.


Note: For more information about two significant accessibility initiatives, see the World Wide Web Consortium Web 
Accessibility Initiative (www.w3.org/wai) and Section 508 of the U.S. Federal Rehabilitation Act 
(www.section508.gov). 


No authoring tool can automate the development process. Designing accessible websites requires you to understand 
accessibility requirements and make ongoing decisions about how users with disabilities interact with web pages. The 
best way to ensure that a website is accessible is through deliberate planning, development, testing, and evaluation.


Accessibility preferences options
To create accessible web pages, page elements need to be marked up with information for assistive technology, such 
as screen readers. For example, each image on a page should be given a text equivalent, called alternative text (alt 
text), that a screen reader voices to users in place of the image (Figure 1).


Figure 1 Displaying alternative text


Designers often overlook accessibility features such as alt text when creating websites, but Dreamweaver CS6 
enables you to set preferences that prompt you to provide accessibility information as you’re building the page. By 
activating options in the Preferences dialog box, you'll be prompted to provide accessibility-related information for 
form objects, frames, media, images, and tables as each element is inserted in a page. 

© 2012 Adobe Systems Incorporated How to make websites accessible 1







Project 8 guide Adobe Dreamweaver CS6


2


To set the accessibility preference, choose Edit > Preferences (Windows) or Dreamweaver > Preferences (Mac OS) 
and select the Accessibility category in the Preferences dialog box (Figure 2).


Figure 2 Dreamweaver Preferences dialog box, Accessibility category


For example, if you choose the Images option in the Show Attributes list, you are prompted (Figure 3) to provide the 
alt text equivalent and a description for each image as you insert it.


Figure 3 Image Tag Accessibility Attributes dialog box
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Creating accessible tables and forms presents some challenges, but Dreamweaver CS6 simplifies the process. For 
example, as you insert a data table within Dreamweaver CS6, you're immediately prompted to provide summary 
information, a caption, and the position of heading cells in the table (Figure 4). Incidentally, by adding identifying 
heading cells—an important but often overlooked design step—you make it significantly easier for assistive 
technology users to navigate tables. 


Figure 4 Table dialog box


Creating accessible forms is also easy with Dreamweaver CS6. When you select the Form Objects option in the 
Preferences dialog box, you're prompted to provide a label for each form object, along with a shortcut key and the tab 
order position (Figure 5). Specifying the label allows assistive technology users to understand the purpose of each 
form object as they complete the form.


Figure 5 Input Tag Accessibility Attributes dialog box
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Accessibility validation
There are a number of third-party web accessibility evaluation tools that you can use to validate your completed 
websites. The W3C Web Accessibility initiative provides a comprehensive list of these tools at http://www.w3.org/
WAI/RC/tools/.


Accessible templates
Dreamweaver CS6 includes several templates designed for accessibility. These templates are visually balanced, as 
well as accessible to people with disabilities (Figure 6). They provide you with a fast and easy way to create exciting, 
engaging, and accessible content. 


Figure 6 Dreamweaver sample HTML template


How to meet accessibility requirements
The W3C Web Accessibility Initiative has developed a quick reference list Web Content Accessibility Guidelines 2.0 
requirements and techniques.


1. Text Alternatives: Provide text alternatives for any non-text content so that it can be changed into other 
forms people need, such as large print, braille, speech, symbols or simpler language.


2. Time-based Media: Provide alternatives for time-based media.


3. Adaptable: Create content that can be presented in different ways (for example simpler layout) without 
losing information or structure.


4. Distinguishable: Make it easier for users to see and hear content including separating foreground from 
background.


5. Keyboard Accessible: Make all functionality available from a keyboard.
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6. Enough Time: Provide users enough time to read and use content.


7. Seizures: Do not design content in a way that is known to cause seizures.


8. Navigable: Provide ways to help users navigate, find content, and determine where they are.


9. Readable: Make text content readable and understandable.


10. Predictable: Make Web pages appear and operate in predictable ways.


11. Input Assistance: Help users avoid and correct mistakes.


12. Compatible: Maximize compatibility with current and future user agents, including assistive technologies.
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@charset "utf-8";

body {
	background-color: #fff;
	font-size: 62.5%;
	margin: 0;
	padding: 0;
}
body * {
	font-size: 100%;
}
h1, h2, h3, h4, h5, h6 {
	font-weight: normal;
}
p {
	margin-bottom: 1.1em;
	margin-top: 0;
}
#main p.lastNode {
	margin-bottom: 0;
}
a:link img, a:visited img {
	border: none;
}
div.clearFloat {
	clear: both;
	font-size: 0;
	height: 0;
	line-height: 0px;
}
li.clearFloat {
	clear: both;
}
ul.symbolList {
	display: inline;
	float: left;
	list-style-type: none;
	margin: 0;
	padding: 0;
}
.AbsWrap {
	position: relative;
	width: 100%;
}
.rowWrap {
	width: 100%;
}
#main {
	margin: 0 auto 0 0;
	width: 1024px;
}
#Home_r1_c1 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 68px;
	margin-bottom: 0;
	width: 71px;
}
#Home_r1_c2 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 68px;
	margin-bottom: 0;
	width: 171px;
}
#Home_r1_c3 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 68px;
	margin-bottom: 0;
	width: 76px;
}
#colwrap1 {
	float: left;
	margin-left: 0px;
	margin-top: 0px;
	width: 706px;
}
#Home_r1_c4 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 11px;
	margin-bottom: 0;
	width: 706px;
}
#Home_r2_c4 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 57px;
	margin-bottom: 0;
	width: 133px;
}
#Home_r2_c5 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 57px;
	margin-bottom: 0;
	width: 31px;
}
#Home_r2_c6 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 57px;
	margin-bottom: 0;
	width: 133px;
}
#Home_r2_c7 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 57px;
	margin-bottom: 0;
	width: 33px;
}
#Home_r2_c8 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 57px;
	margin-bottom: 0;
	width: 132px;
}
#Home_r2_c9 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 57px;
	margin-bottom: 0;
	width: 32px;
}
#Home_r2_c10 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 57px;
	margin-bottom: 0;
	width: 133px;
}
#Home_r2_c11 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 57px;
	margin-bottom: 0;
	width: 79px;
}
#Home_r3_c1 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 523px;
	margin-bottom: 0;
	width: 71px;
}
#Home_r3_c2 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 523px;
	margin-bottom: 0;
	width: 874px;
}
#Home_r3_c11 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 523px;
	margin-bottom: 0;
	width: 79px;
}
#Home_r4_c1 {
	margin-left: 0px;
	margin-top: 0px;
	display: inline;
	float: left;
	height: 109px;
	margin-bottom: 0;
	width: 1024px;
}
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How to create transitions with motion tweens
You may have noticed from watching television or movies that transitions are a subtle but important part of telling a 
story. For example, dissolving between images can indicate a passage of time. On the web, you can use transition 
effects to create moods and to help keep your visitors interested. You can use transitions to focus the visitor’s 
attention or to indicate a preferred path through your site. One way to create transitions in Adobe Flash Professional 
CS6 is to apply effects to a motion tween.


Rotation
In the Properties panel, you can add rotation to any motion tween. Rotation can draw attention to content that is 
entering or exiting the Stage.


To add rotation to a motion tween:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Use the drawing tools to create a shape and convert the 
shape to a graphic or movie clip symbol. Make sure the 
Object Drawing option is not selected in the Tools panel. 
Make sure the new symbol is alone on its own layer. 


By default the symbol is placed in the first keyframe of 
the timeline (Figure 1). 


3. Insert a frame (not a keyframe) in the timeline where you 
want the motion tween to end (Figure 2).


Note: To make the effect last longer (take longer to 
complete) place the end frame farther down the timeline. 
You can use the Frames Per Second (fps) and Elapsed 
Time (s) values in the Timeline panel determine where to 
place the end keyframe.


4. Select the layer in the Timeline panel and select Insert > 
Motion Tween.


The motion tween span is light blue in the Timeline 
panel.


5. Select the last frame in the motion tween span and use the 
Selection tool to move the object to its ending position. 
Notice the appearance of the motion path (Figure 3).


Note: You can add multiple effects, such as changing size 
or fading to make the object appear to grow or fade in 
while it enters or fade out and shrink as it exits.


• Changing size: Reduce or increase the image 
percentage in the Transform panel with the Constrain 
options selected.


• Fading: Select the symbol and select Alpha from the 
Style menu in the Color Effect section of the 
Properties panel. Adjust the alpha setting to increase 
or decrease transparency.


Figure 1 Timeline panel


Figure 2 Motion tween start and end frames


Figure 3 Motion path
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6. Click anywhere in the motion tween span in the Timeline 
panel.


The motion tween properties appear in the Properties 
panel (Figure 4).


7. In the Rotation section of the Properties panel, select CW 
(clockwise) or CCW (counterclockwise) from the 
Direction menu (Figure 5).


8. Change the Rotate value to set the number of times you 
want the symbol to rotate (Figure 6).


9. In the Options section, select the Sync Graphic Symbols 
option (Figure 7).


This synchronizes the motion to the number of frames in 
the timeline.


10. Select Control > Test Movie > In Flash Professional to 
test the movie.


11. Close the preview window.


Figure 4 Motion tween properties


Figure 5 Direction menu in the Properties panel


Figure 6 Rotate value in the Properties panel


Figure 7 Synchronize the rotation to the timeline
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Change frame rate


The document’s frame rate determines how fast the play head moves. A frame rate of 12 frames per second (fps) 
usually gives the best results on the web. You can set the frame rate to any number between 0.01 and 120. With larger 
movies, increasing the frame rate increases the size of your published document.


If you want to change the timing of an animation, it’s usually better to change the number of frames than to change 
the frame rate.


To change the frame rate:


1. Click away from any objects on the Stage.


Document properties are shown in the Properties panel.


2. Enter a new Frames Per Second (FPS) value, such as 30,  
in the Properties section of the Properties panel 
(Figure 8).


3. Select Control > Test Movie > In Flash Professional to 
test the movie.


Observe that the animation plays faster or slower 
depending on the frame rate you set.


4. Close the preview window.


5. Change the FPS value to 6.


6. Select Control > Test Movie > In Flash Professional to 
test the movie.


Observe that the animation plays much more slowly.


7. Close the preview window.


Figure 8 Properties panel
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Fading
By creating a motion tween with different alpha settings, you can fade images in and out.


To fade images in and out:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Use the drawing tools to create a shape and convert the 
shape to a graphic or movie clip symbol. Make sure the 
new symbol is alone on its own layer. 


By default the symbol is placed in the first keyframe of 
the timeline. 


3. Insert a frame (not a keyframe) in the timeline where you 
want the fade to end.


Note: To make the effect last longer (take longer to 
complete) place the end frame farther down the timeline. 
You can use the Frames Per Second (fps) and Elapsed 
Time (s) values in the Timeline panel determine where to 
place the end keyframe.


4. Select the layer in the Timeline panel and select Insert > 
Motion Tween.


5. In the timeline, select the first frame in the motion tween 
span and click the symbol on the Stage.


6. In the Properties panel, open the Color Effect Style menu 
and choose Alpha (Figure 9).


The Alpha value changes to the last Alpha setting you 
applied. The default is 0% (transparent) (Figure 10).


7. Make sure the Alpha value is set to 0%.


The symbol on the Stage is transparent, but the blue 
outline of the symbol is still visible.


8. In the timeline, select the last frame in the motion tween 
span and click the symbol on the Stage.


9. Change the Alpha value to 100%.


10. Select Control > Test Movie > In Flash Professional to 
test the movie.


The symbol fades in.


Note: To create a fade-out, set the Alpha value to 100% 
on the starting frame and the Alpha value on the ending 
frame to 0%.


11. Close the preview window.


Figure 9 Properties panel, Color Effect Style menu 


Figure 10 Alpha value slider
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Color fades
You can use color fades to draw the viewer’s attention to an object on-screen. To create a color fade, apply a motion 
tween between two instances of the same movie clip or button symbol, and then change the color of the instances in 
the starting and ending frames.


To create a color fade:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Use the drawing tools to create a shape and convert the 
shape to a movie clip or button symbol. Make sure the 
new symbol is alone on its own layer. 


Note: It’s important that you make the object a movie 
clip or button symbol. You will use a filter to adjust the 
color and you cannot add filters to graphic symbols.


By default the symbol is placed in the first keyframe of 
the timeline. 


3. Insert a frame (not a keyframe) in the timeline where you 
want the color fade to end.


4. Select the layer in the Timeline panel and select Insert > 
Motion Tween.


5. In the timeline, select the last frame in the motion tween 
span and click the symbol on the Stage.


6. In Properties panel, click the Add Filter button and 
choose Adjust Color in the Add Filter menu (Figure 11).


7. In the Filters section of the Properties panel, use the Hue 
scrubber to change the color of the symbol (Figure 12).


As you change the value, notice the changing color of the 
symbol on the Stage.


8. Select Control > Test Movie > In Flash Professional to 
test the movie.


9. Close the preview window.


Figure 11 Properties panel, Add Filter menu


Figure 12 Hue scrubber in the Properties panel


Add Filter button
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Flipping images
Flipping images and then creating a motion tween can create an effective transition between images of roughly the 
same size. The trick is to flip the first image half way and then start fading in the second image while the first image 
is still flipping to make a smooth transition.


To flip an image:


1. Start Flash and open a new blank document 
(ActionScript 3.0). 


2. Import or create the objects you want to flip between.


3. Convert both objects to movie clip symbols and then 
remove them from the Stage. The symbols will remain in 
the document library.


Note: In this example, we imported two photos of similar 
size to the Stage, converted them to symbols, and then 
removed them from the Stage.


4. In the Timeline panel, rename Layer 1 exiting object. 
Add a new layer and rename it entering object 
(Figure 13).


5. Add the image symbols from the document library to the 
blank keyframes in each layer. One image is the entering 
object and the other is the exiting object.


6. Decide how much time is required to complete the 
transition. 


This tells you where to place the ending frames for each 
of the images for the motion tweens.


7. Insert the ending frames (not keyframes) accordingly in 
the timeline (Figure 14). 


8. For each image, select the layer in the timeline and 
choose Insert > Motion Tween.


9. Click the first frame in the top, entering object, layer. 
Select the image and change its Color Effect (in the 
Properties panel) to Alpha with an Alpha value of 0%.


10. Click the last frame in the top, entering object, layer. 
Select the image and set the Alpha Amount to 100%.


The entering image is transparent in the beginning and 
becomes visible.


11. Lock the top, entering object, layer by clicking in the 
Lock Layer column (Figure 14).


Locking the top layer makes it easier to work with the 
image in the layer below it.


Figure 13 Entering and exiting layers in the 
timeline


Figure 14 Start and end frames for the tween


Lock Layer column
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12. Click the first frame in the bottom, exiting object, layer. 
Select the image and change the Color Effect to Alpha 
with an Alpha value of 100%. 


13. Click the last frame in the bottom, exiting object, layer. 
Select the image and change the Alpha value of 0%. 


The exiting image is visible in the beginning and 
becomes transparent.


14. Click in the center frame of the tween span in the bottom, 
exiting object, layer and select Modify > Transform > 
Flip Horizontal.


The exiting object is flipped around a vertical axis 
through its center. This adds a keyframe in the center of 
the tween span (Figure 15).


15. Lock the bottom layer and unlock the top layer.


16. Click in the center of the tween span in the top, entering 
object, layer and select Modify > Transform > Flip 
Horizontal.


The entering object is flipped around a vertical axis 
through its center. A keyframe appears in the center of 
the top, entering object, tween span (Figure 16).


Note: Instead of Flip Horizontal, you can select Flip 
Vertical in both tween spands. As long as both exiting 
and entering objects flip the same way, the transition will 
work.


17. In the Properties panel, change the Easing value to -100 
(Figure 17).


18. Unlock the bottom layer and select it. In the Properties 
panel, change the Easing value to -100.


Changing the easing value adjusts the rate of change 
between tweened frames. Negative easing values cause 
the motion tween to begin slowly and accelerate at the 
end of the tween. A positive value causes the tween to 
begin rapidly and decelerate at the end. The animation 
still takes the same amount of time, regardless of the 
easing value.


19. Select Control > Test Movie > In Flash Professional to 
test the movie.


20. Close the preview window.


Figure 15 Flip keyframe in the exiting object 
tween span


Figure 16 Flip keyframe in the exiting object 
tween span


Figure 17 Properties panel, Ease value 
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Motion presets
You can also add motion presets to movie clip symbols. Motion presets are pre-configured motion tweens you can 
apply to an object on the Stage. You simply select the motion clip symbol and click the Apply button in the Motion 
Presets panel.


To add a motion preset to your symbol:


1. Start Flash and open a new blank document 
(ActionScript 3.0). 


2. Create a shape and convert it to a movie symbol.


Note: Only movie clip symbols can have motion presets 
applied to them.


3. Display the Motion Presets panel by selecting Window > 
Motion Presets.


You can preview the motion presets by selecting a preset 
from the list of Default Presets (Figure 18).


4. To apply a motion preset to the symbol on the Stage, 
select it and click the Apply button.


5. Click the Motion Editor tab (in the same panel group as 
the Timeline panel) to find the properties for the preset 
you have just applied. Make any changes you like in the 
Motion Editor.


Note: For information on using the Motion Editor, see 
the guide “How to ease tweens.” 


6. After making changes to any motion settings in the 
Motion Editor, save your customized motion preset by 
clicking the Save Selection As Preset button in the lower-
left corner of the Motion Presets panel (Figure 19).


7. Type a name for your custom preset in the Save Preset As 
dialog boxand click OK.


You will now see your motion preset under the Custom 
Presets folder of the Motion Presets panel. You can apply 
your custom motion presets to other tweens in this file or 
new files. Using presets can save significant production 
time during design and development of your projects, 
especially if you often use similar kinds of tweens.


8. Select Control > Test Movie > In Flash Professional to 
test the movie.


9. Close the preview window.


Figure 18 Motion Presets panel


Figure 19 Save Selection As Preset button 
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ActionScript for basic gaming
ActionScript 3.0 is the scripting language used to create interactivity and object movement in Adobe Flash 
Professional CS6 games. 


The level of motion and interactivity can be simple, such as solving a jigsaw puzzle, or complex, such as guiding 
characters through a virtual world of danger in search of hidden treasures.


Whether you’re an experienced game developer or just getting started, you’ll notice several elements common to 
most Flash games. Simple elements might include timed player clicks or a character moving with the arrow keys. 
More complex elements might include characters who run and jump or maneuver to avoid flying objects. This guide 
begins with a few examples of Flash game types. You then use ActionScript to produce the common movements and 
interactions that are the building blocks of these games. 


Note: This guide is intended for people who are new to ActionScript and game development but have a working 
knowledge of Adobe Flash Professional CS6. You should be familiar with layers, the timeline, the library, setting 
properties, drawing shapes, and working with symbols and instances. You should also complete the guide “How to 
get started with ActionScript.” 


Timed player interaction games
The most basic example of a Flash game is one in which the player completes a task by clicking objects or target 
areas on the screen. You can use a timer to control how much time someone has to complete the task. You can also 
keep score by tracking how long each player takes to complete the same tasks. These games are ideal as educational 
games, especially for small children.


Some examples of games that include timed player interactions:


• Eye Spy Games: Locate (click) objects that are hidden (in plain sight), blended them in with the background 
artwork. This type of activity is usually timed. 


• Find the Difference (One of These Things Is Not Like the Other): Identify (click) the differences between two 
photographs or artwork within the allowed time. Score can be kept by tracking how long it takes to find all the 
differences or by the number of differences the player identifies within the allowed time.


• Memory/Recall: The game board or virtual landscape includes several matching object pairs that are hidden from 
view. The player clicks to reveal two objects with each turn, attempting to find a match. With each turn, the 
player learns (and hopefully remembers) the location of each object pair. The objects can be playing cards or 
anything else that forms a match. For example, you could create a language game by matching English and 
Spanish words with the same meaning. Players can be timed to find all matches or can be given a fixed number 
of plays before the game ends.


Figure 1 Timed player interaction games
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Drag-and-drop games
A drag-and-drop game is one in which a player must drag objects on the screen and reposition them to complete a 
task. You can use drag-and-drop interactions to create a variety of games or applications, such as board games and 
puzzles. You can also use drag-and-drop interactions for online lessons, tests, and quizzes. 


Some examples of drag-and-drop games:


• Matching:  Players drag objects to their appropriate mates. Use this for games, online learning, and quizzes.


• Design Your Own:  Give players the unfinished version of a product and let them complete it with a collection of 
objects you provide. The activity can include an empty room player get to furnish, a mannequin they get to dress, 
a car to which they can add trim features, and so on. 


• Puzzles:  Players drag from the collection of pieces and drop them in the puzzle frame to see where they fit. 


• Word Games:  Players drag from a tray of letters to form words on a game board. 


Figure 2 Drag-and-drop games


Character movement games
Character movement games involve using input controls to move one or more characters to accomplish a goal, such 
as following a path of discovery or interacting with objects on the screen. An example of a simple character 
movement game is one in which the player moves the character from point A to point B. As the character moves, the 
game might present the player with randomly appearing objects. Some objects are meant to be avoided. Other objects 
might represent positive interactions, such as gaining points or extending play.


Some examples of character movement games:


• Adventure and Fantasy:  Players help characters run, jump, climb, swim, or fly along a journey or through a 
maze. They must avoid contact with dangerous objects or seek out positive targets and hidden treasures to gain 
bonus points or extra powers.


• Shoot and Dodge:  A game that involves colliding with or shooting moving targets such as aliens or zombies. 
Players move a character to avoid being hit by hazards or intentionally colliding the character with positive 
targets. A classic video game called Asteroids is a good example of shooting and dodging.


Figure 3 Character movement games
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Using ActionScript 3.0 to create movement and interaction in games
Now that you’re familiar with the popular game types, you can use ActionScript to produce the movement and 
interactions that are the building blocks of these games.


Creating objects and symbols for the game 


Most games include artwork and other background objects that define how and where you interact with the game. For 
example, the goal of a game might be to escape a virtual room or building. Characters might be required to navigate a 
maze or avoid colliding with other objects on the screen. 


One of the first steps to developing your game in Adobe Flash Professional CS6 is to design and place the artwork 
and other objects that appear in the game. To make the game objects interactive, they must first be converted to 
symbols and given a unique instance name in the Flash Properties panel.


Note: For information on creating and naming symbol instances, see the guide “Symbols, instances, and the library.” 
For information on designing artwork and backgrounds in Flash, see the guide “How to draw and create shapes.” 


Using the keyboard to move characters and objects


Players can interact with game characters and objects in several ways by using a variety of input devices. The most 
basic type of player interaction is to move objects and characters by pressing the arrow keys on the keyboard. Some 
games allow the character to rotate up to 360 degrees and move forward in the direction the character is pointing. 
This is a common movement for airplanes or spaceship characters. 


The following steps show how to use ActionScript code to move a character in one direction (up) by using the Up 
Arrow key. After creating this simple movement, you edit the ActionScript code to include four-directional 
movement.


To move an object up by using the keyboard:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Select the artwork or sprite to use for the moving 
character. For this activity, you can also draw a simple 
shape to represent your moving character. 


3. Convert the artwork or shape to a movie clip symbol. Set 
the symbol’s registration point to the center of the object 
(Figure 4).


4. Make sure the movie clip symbol is selected on the Stage. 
In the Properties panel, give the character the instance 
name player_mc (Figure 5).


At this point you have one symbol instance on the Stage.  
It exists in Frame 1 of Layer 1 in the timeline. It has the 
instance name player_mc.


5. In the Timeline panel, rename Layer 1 Player and add a 
new layer above it named Actions.


Figure 4 Convert To Symbol dialog box


Figure 5 Properties panel
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6. Select the blank keyframe in Frame 1 of the Actions layer. 


Next, you construct the ActionScript code to control the player_mc movie clip object. 


7. Select Window > Actions to open the Actions panel, and make sure Script Assist is turned off.


8. Enter or copy and paste the following code to create the event listeners:
stage.addEventListener(KeyboardEvent.KEY_DOWN, checkkeysdown);


stage.addEventListener(KeyboardEvent.KEY_UP, checkkeysup);


These first two lines of code set up the event listeners that “listen” for keys being pressed and released. Normally 
a game character will move when players press a key and stop when they release the key.


9. Enter or copy and paste the following code below the existing code to create the variables:
var speed=10;


var moveup=false;


These variables keep track of the player’s speed and whether the player is moving up or not.


10. Enter or copy and paste the following code below the existing code to create the function:
function checkkeysdown(mykey:KeyboardEvent) {


if (mykey.keyCode==Keyboard.UP) {


moveup=true;


   }


}


This function deals with what happens when a key is pressed. It checks to see if the Up Arrow key is pressed and 
sets the variable moveup to true.


11. Enter or copy and paste the following code below the existing code to create another function:
function checkkeysup(mykey:KeyboardEvent) {


if(mykey.keyCode==Keyboard.UP) {


moveup=false;


          }


}


This controls what happens when the Up Arrow key is released. It sets the variable moveup to false.


12. Enter or copy and paste the following code below the existing code to create the event listener:
stage.addEventListener(Event.ENTER_FRAME, gameloop);


function gameloop(evt:Event) {


if (moveup==true) {


player_mc.y-=speed;


     }


}


This section of code creates an event listener that runs continuously: the ENTER_FRAME listener. This causes 
the gameloop function to run, which moves the player’s character.


13. Select Control > Test Movie > In Flash Professional. 


14. Press the Up Arrow key to move the character. 


15. Close the preview window.
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To move objects in all four directions (optional):


You’ve learned how to move an object in one direction (up) by using ActionScript code. To make the characer move 
in other directions, you must create three more variables to track the other three movements (left, right, and 
downward) and additional code in each of the functions. The following is the final code used to move the character in 
all four directions. You can replace the code you have created so far with this entire example to move the character in 
all four directions.


stage.addEventListener(KeyboardEvent.KEY_DOWN, checkkeysdown);


stage.addEventListener(KeyboardEvent.KEY_UP, checkkeysup);


var speed=10;


var moveup=false;


var movedown=false;


var moveleft=false;


var moveright=false;


function checkkeysdown(mykey:KeyboardEvent) {


   if (mykey.keyCode==Keyboard.UP) {


   moveup=true;


   }


   if (mykey.keyCode==Keyboard.DOWN) {


   movedown=true;


   }


   if (mykey.keyCode==Keyboard.LEFT) {


   moveleft=true;


   }


   if (mykey.keyCode==Keyboard.RIGHT) {


   moveright=true;


   }


}


function checkkeysup(mykey:KeyboardEvent) {


   if (mykey.keyCode==Keyboard.UP) {


   moveup=false;


   }


   if (mykey.keyCode==Keyboard.DOWN) {


   movedown=false;


   }


   if (mykey.keyCode==Keyboard.LEFT) {


   moveleft=false;


   }


   if (mykey.keyCode==Keyboard.RIGHT) {


   moveright=false;


   }


}
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stage.addEventListener(Event.ENTER_FRAME, gameloop);


function gameloop(evt:Event) {


   if (moveup==true) {


   player_mc.y-=speed;


   }


   if (movedown==true) {


   player_mc.y+=speed;


   }


   if (moveleft==true) {


   player_mc.x-=speed;


   }


   if (moveright==true) {


   player_mc.x+=speed;


   }


}


To create boundaries for a moving object (optional):


When playing the movie, you may have noticed the object moves beyond the Stage boundary and is gone. You can 
add additional code to constrain the object’s movement to stay within the Stage boundary. To do this, edit the 
gameloop function as follows: 


function gameloop(evt:Event) {
   if (moveup==true) {
      if (player_mc.y>0){


      player_mc.y-=speed;


   }


}


   if (movedown==true) {
      if (player_mc.y<400){
      player_mc.y+=speed;
   }


}


   if (moveleft==true) {


      if (player_mc.x>0){


      player_mc.x-=speed;


   }


}


   if (moveright==true) {
      if (player_mc.x<550){player_mc.x+=speed;


      }
   }
}
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To move and rotate an object 360 degrees by using the keyboard:


1. Start Flash and open a new blank document (ActionScript 3.0).


2. Select the artwork or sprite to use for the character. You can draw a simple shape to represent your character. 


3. Convert the artwork or shape to a movie clip symbol. Set the symbol’s registration point to the center of the 
object.


4. Make sure the movie clip symbol is selected on the Stage. In the Properties panel, give the character the instance 
name player_mc.


At this point you have one symbol instance on the Stage. It exists in Frame 1 of Layer 1 in the timeline. It has the 
instance name player_mc.


5. In the Timeline panel, rename Layer 1 Player and add a new layer above it named Actions.


6. Select the blank keyframe in Frame 1 of the Actions layer. 


Next, you construct the ActionScript code to control the player_mc movie clip object. 


7. Select Window > Actions to open the Actions panel, and make sure Script Assist is turned off.


8. Enter or copy and paste the following code to add the variables:
var rotateLeft=false;


var rotateRight=false;


These variables keep track of the direction of rotation. They are set to false at the start of the game. When the 
player presses the Right Arrow key, rotateRight will be set to true, and similarly rotateLeft is set to true when the 
Left Arrow key is pressed.


9. Enter or copy and paste the following code to detect keypresses and set the appropriate values:
stage.addEventListener(KeyboardEvent.KEY_DOWN, startRotation);


function startRotation(e:KeyboardEvent):void{


   if (e.keyCode==Keyboard.LEFT){


      rotateLeft=true;


   }


   if (e.keyCode==Keyboard.RIGHT){


   rotateRight=true;


   }


}


You must also detect when the keys are released and set the variables back to false.


10. Enter or copy and paste the following code to detect when keys are released:
stage.addEventListener(KeyboardEvent.KEY_UP, stopRotation);


function stopRotation(e:KeyboardEvent):void{


   if (e.keyCode==Keyboard.LEFT){


      rotateLeft=false;


   }


   if (e.keyCode==Keyboard.RIGHT){


      rotateRight=false;


   }


}


© 2012 Adobe Systems Incorporated ActionScript for basic gaming 7







Project 5 guide Adobe Flash Professional CS6


8


So far, this code does not move the character. It only sets the variables to true or false as a result of keypresses.


11. Enter or copy and paste the following code to make the player rotate in the correct direction:
stage.addEventListener(Event.ENTER_FRAME, moveplayer);


function moveplayer(e:Event):void{


   if (rotateLeft==true){


      player_mc.rotation-=10;


   }


   if (rotateRight==true){


      player_mc.rotation+=10;


   }


}


The first line in the code adds an event listener, ENTER_FRAME, that runs constantly. This causes the function 
moveplayer to run constantly. The mc_player symbol then rotates in the appropriate direction by 10 degrees. 
Next you need to make the player character move forward. To do this you will use polar coordinates to plot a 
point in front of the character based on its angle of rotation. The character moves to the position of this new 
point. The polar coordinates method in ActionScript uses radians rather than degrees, so you must first convert 
the angle of the player to radians. You do this by multiplying the angle by pi divided by 180 (Figure 6). 
However, because the coordinates system in Flash is different from a normal coordinates system (it is rotated 90 
degrees), you must first subtract 90 from the player’s angle of rotation. Once you have calculated the angle in 
radians, you can plot a point in front of the player by using the Point.polar() method in ActionScript.


Figure 6 Formula used to convert the angle of the player to radians


12. Enter or copy and paste the following code to move the character forward in steps of 5 pixels.


Note: This code must be placed inside the moveplayer function, just before the last End bracket (}) in the code.
var radians=Math.PI/180 * (player_mc.rotation-90);


var newLocation=Point.polar(5, radians);


player_mc.x+=newLocation.x;


player_mc.y+=newLocation.y;


13. Select Control > Test Movie > In Flash Professional. 


14. Use the arrow keys to move and rotate the character. The character moves forward continuously.


15. Close the preview window.
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To create boundaries for a moving object (optional):


To prevent the character from moving offscreen, add the following code to the end of the movieplayer function, 
assuming a Stage size of 550 x 400: 


if (player_mc.x>550){


player_mc.x=0;


}


if (player_mc.x<0){


player_mc.x=550;


}


if (player_mc.y>400){


player_mc.y=0;


}


if (player_mc.y<0){


player_mc.y=400;


}


Now if you let the player character move in one direction until it exits the Stage, it will re-enter the opposite side of 
the Stage. 
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To make a character jump:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Select the artwork or sprite to use for the jumping 
character. 


3. Convert the artwork or shape to a movie clip symbol. Set 
the symbol’s registration point to the center of the object 
(Figure 7).


4. Make sure the movie clip symbol is selected on the Stage. 
In the Properties panel, give the character the instance 
name  jumpman_mc (Figure 8).


At this point you have one symbol instance on the Stage. 
It exists in Frame 1 of Layer 1 in the timeline. It has the 
instance name jumpman_mc.


Note: You might also want to add background objects, 
including moving objects the jumping man must avoid by 
jumping over. To learn how, refer to the steps on creating 
moving objects and adding collision detection later in 
this guide.


5. In the Timeline panel, rename Layer 1 Player and add a 
new layer above it named Actions.


Next, you add animation to make the player jump.


6. Double-click the movie clip symbol on the Stage to open 
the symbol in editing mode. 


7. Select the artwork or sprite you used to create the 
character symbol and convert that to another movie clip 
symbol. Name it anything you want.


Note: The artwork needs to be a symbol to create the 
motion tween animation. 


8. Insert a new frame (not a keyframe) in Frame 10 of the 
symbol’s timeline.


9. Click Frame 1 and select Insert > Motion Tween.


10. Click in Frame 10 and drag the symbol upward to a 
position that is about twice its original height.


11. Insert a new frame (not a keyframe) in Frame 20.


12. Click in Frame 20 and drag the symbol back down to its 
starting position (landing position after jumping). 


Note: You can also use the position values in the 
Properties panel to match the exact position of the object 
in Frame 1.


The symbol now includes animation of the character 
jumping (Figure 9).  


Figure 7 Convert To Symbol dialog box


Figure 8 Properties panel


Figure 9 Symbol in editing mode

ActionScript for basic gaming © 2012 Adobe Systems Incorporated







Adobe Flash Professional CS6 Project 5 guide

13. Play the animation in the Timeline panel to see the object jump. 


Right now the object will jump up and down continuously. You need to add a stop action to the symbol so the 
character remains still until it receives instructions to jump.


14. In the symbol’s timeline, add a new layer named Actions.


15. Click the blank keyframe in Frame 1 of the Actions layer, open the Actions panel, and add the following stop 
action:


stop();
This tells the movie clip that the first thing it should do is stop. The jumping animation will not occur until the 
symbol receives instructions.


16. Close the Actions panel. Click Scene 1 to exit symbol editing mode and return to the main timeline.


Now you can add the code to make the character jump.


17. Click in Frame 1 in the Actions layer in the main timeline.


18. Select Window > Actions to open the Actions panel, and make sure Script Assist is turned off.


19. Enter or copy and paste the following code to make the character jump:
stage.addEventListener(KeyboardEvent.KEY_DOWN, jump);


function jump(e:KeyboardEvent):void {


jumpman_mc.play();


}


This code adds a new event listener that detects any keypress. When a key is pressed, the function jump runs and 
instructs the jumpman_mc movie clip symbol (the jumping animation) to play.


20. Close the Actions panel. Select Control > Test Movie > In Flash Professional.


The character is initially stopped on the Stage. Press any key to make the character jump. 


You can add additional animation to the character by editing the symbol. For example, instead of using a static 
image, you can use an animated sprite that appears to be running, climbing, swimming, or flying. For 
information on creating animated sprites, see the guide “How to use sprite sheets.” 


You can combine the jumping character with an animation of a moving background that makes the character 
appear to be moving forward, or place the character among other moving objects. 


If your character will jump or move to avoid other objects, you can add collision detection to detect when the 
character hits another object and provide instructions on what to do when a collision occurs. 


21. Close the preview window.
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Creating scrolling backgrounds and moving objects that collide with your characters.


To achieve the visual effect that a character is traveling across the screen, you create a moving or scrolling 
background. Design a repeating background image that is wider than the Stage and use a tween animation to scroll 
the background across the screen. To make the character appear to be moving to the right, your background needs to 
scroll to the left. To make the character travel to the left, scroll the background to the right. 


To add more realism and excitement to the scene, you can create additional objects, such as obstacles or collectibles, 
and then use a gameloop function to move these objects continuously across the screen. 


By adding collision detection, you can also control what happens when your player comes in contact with other 
objects on the screen. For example, you can create flying objects that threaten the health or life of the player 
character. The player can move, turn, or jump to avoid or cause a collision. You can include additional code that 
creates a consequence of avoiding or colliding with an object. For example, the consequence can be losing a player’s 
life or changing the player’s score (up or down).


To create a scrolling background:


1. Continue where you left off in the preceding activity. 


2. Add a new layer to the main timeline and name it 
Background. Move the Background layer below all 
other layers in the Timeline panel.


3. Import or draw the artwork for your background. The 
artwork needs to be at least as wide as the Stage 
(Figure 10).


4. Select all of the artwork in the Background layer. 


Note: If your document includes other objects, be sure to 
select only the artwork in the Background layer. 


5. Convert the background artwork to a new movie clip 
symbol named Background. 


6. Double-click the Background symbol to open it in 
symbol editing mode.


7. Zoom out until you can see the entire Stage and the 
empty gray areas to the left and right of the Stage. A 
zoom level of 25% should work.


8. Copy and paste all of the background artwork and 
position a copy exactly to the right of the original 
artwork. Make a second copy and paste it to the left of the 
original artwork.  


You now have a background that repeats three times and 
extends well beyond the Stage boundaries (Figure 11).


9. Select all of the artwork (all three copies) and convert it 
to a new movie clip symbol. You can name it anything 
you want.


10. Position the symbol so the artwork aligns with the bottom 
and left edges of the Stage. 


This is the start point of the scrolling background motion 
tween (Figure 12).


Figure 10 Artwork in the Background layer


Figure 11 Repeating background artwork


Figure 12 Start position of the motion tween
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11. Add a frame (not a keyframe) farther down the timeline, 
such as in Frame 30. 


Note: The location of the end frame will determine how 
fast the background scrolls and, therefore, how fast the 
character appears to travel across the scene.


12. Click Frame 1 in the Background symbol’s timeline and 
select Insert > Motion Tween.


13. Click in the end frame of the motion tween span and then 
Shift-drag the symbol to the left until its right edge aligns 
with the right edge of the Stage (Figure 13).


Note: Holding down Shift as you drag locks the vertical 
position of the symbol. Make sure the Stage is covered 
during all frames of the motion tween and the 
background artwork moves horizontally but maintains 
the same vertical position throughout.


14. Play the motion tween in the Timeline panel.


15. Click Scene 1 to exit symbol editing mode and return to 
the main timeline.


16. Select Control > Test Movie > In Flash Professional.


The repeated artwork in the background movie loops 
continuously, causing the background to scroll left. If 
your Stage includes a player character in another layer, 
the character appears to travel to the right. 


Note: If the background scrolls too fast or too slowly, 
open the Background symbol in editing mode and add or 
remove frames in the motion tween span.  


17. Close the preview window.


Figure 13 End position of the motion tween


To create a moving object:


1. Continue where you left off in the preceding activity.


2. Add a new layer to the main timeline and name it 
Obstacle. Make sure the Obstacle layer is above the 
Background and Player layers. Lock all layers except the 
Obstacle and Actions layers (Figure 14). 


3. With the Obstacle layer selected, import or draw the 
artwork for the moving object.  


In this example, we created a yellow star the player must 
jump over to avoid collision (Figure 15).


4. Convert the object to a movie clip symbol. Select the 
instance of the object on the Stage and name it 
obstacle_mc in the Properties panel. 


Figure 14 Obstacle layer in the Timeline panel


Figure 15 Star artwork for the moving object
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5. Click in Frame 1 of the Actions layer, and select Window > Actions to open the Actions panel. Make sure Script 
Assist is turned off.


Note: If your Actions panel already includes the code to make the player character jump, be sure to add all new 
code below this in the Actions panel.


Next, you add the code to make the moving obstacle (in this case the star) move. This is done by repeatedly 
changing the object’s position on the X axis. The star moves from right to left—that is, in a negative direction. 
You include an event listener to make the object move continuously. The event listener runs a function called 
gameloop. 


6. Enter or copy and paste the following code to create the Enter Frame event listener and gameloop function:
stage.addEventListener(Event.ENTER_FRAME, gameloop);


   function gameloop(e:Event):void{


   obstacle_mc.x-=20;


}


The line obstacle_mc.x-=20;changes the obstacle_mc symbol (star) on the X axis by 20 pixels, moving it in a 
negative direction (to the left).


7. Select Control > Test Movie > In Flash Professional.


The moving object (obstacle_mc) moves from left to right and then disappears off the Stage to the left. What you 
really want is for yellow stars to continuously come at the player.


8. Close the preview window and return to Flash.


You could make more yellow stars and move them too, but it’s more efficient to reuse the same symbol. When 
the object moves off the screen, you can have it reappear by repositioning it.


9. Edit or copy and paste the three new lines in the following code so the gameloop function looks like this:
function gameloop(e:Event):void{


obstacle_mc.x-=20;


   if (obstacle_mc.x<-100){


   obstacle_mc.x=650;


   }


}


10. Close the Actions panel. Select Control > Test Movie > In Flash Professional.


This time the object moves left off the screen and then re-enters on the right and repeats the move continuously. 
It appears that moving objects (stars) continually fly into the path of the player character.  


Right now the objects pass right through the player character as if it wasn’t there. You can change that by adding 
ActionScript code to detect when one object collides with another and then giving Flash instructions on how the 
collision affects the objects. 


11. Close the preview window.
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Next, you add the code that gives the character player 20 lives. In Flash games, this is referred to as the player’s 
health. Each time the player character collides with an obstacle (the moving stars), he loses health. After 20 
collisions, the player’s health is gone and the game is over. 


To add collision detection:


1. Continue where you left off in the preceding activity.


2. Add a new layer to the main timeline and name it Health. 
Make sure the Health layer is above the Background,  
Player, and Obstacle layers. Lock all layers except the 
Health and Actions layers (Figure 16). 


3. Click in Frame 1 of the Health layer.


4. Select the Text tool in the Tools panel. 


5. In the Properties panel, select Classic Text in the Text 
Engine menu. Select Dynamic Text in the Text Type 
menu (Figure 17). Make the text Arial, Regular, 32 pt, 
and a color that stands out against the background.


Note: The text style must be Regular or it will not show 
up.


Dynamic text boxes can be filled in or updated by 
ActionScript. They are useful for displaying scores or 
lives in a game.


6. Drag to draw a text box in the upper-right corner of the 
Stage (Figure 18).


7. Make sure the text box is still selected. In the Properties 
panel, enter health_txt as the instance name (Figure 19).


By giving the text box an instance name, you can refer to 
it in your ActionScript code.


Figure 16 Health layer in the Timeline panel


Figure 17 Properties panel, Text tool properties


Figure 18 Dynamic text box


Figure 19 Text instance name in the Properties 
panel
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8. Click in Frame 1 of the Actions layer and open the Actions panel. Place the insertion point before the first line of 
code in the Actions panel and press Enter (Windows) or Return (Mac OS) to add a blank line. 


9. Enter or copy and paste the following code at the top of the Actions panel to establish the starting health of the 
player character:


var hitObstacle:Boolean=false; // keeps track if obstacle is hit


var health=20; 


health_txt.text=health.toString();


The first line sets up a variable that remembers the player character’s current health. At the start of the game, 
jumpman_mc has 20 lives. 


The next line displays the health of the character on the screen in the dynamic text box. The health is represented 
by a number, but a text box can display only a string of characters. The number has to be converted to a string, so 
you include toString() at the end of the code.


10. Locate the gameloop function you created in the preceding activity. Enter or copy and paste the new lines in the 
following code so the gameloop function looks like this: 


function gameloop(e:Event):void{


obstacle_mc.x-=20;


   if (obstacle_mc.x<-100){


   obstacle_mc.x=650;


   }


   if (jumpman_mc.hitTestObject(obstacle_mc)) {


   if (hitObstacle==false){ //only subtract health if hitObstacle is false


      health--;


   }


  hitObstacle=true;


      health_txt.text=health.toString();


      }


   }


The new lines of code check to see if jumpman_mc hits obstacle_mc. If so, the health changes in the text box. 
You use a special function called hitTestObject to test if one object collides with another. This is used a lot in 
games and can detect whether a player object has been hit by a bullet or a car or collides with any other object.


11. Close the Actions panel. Select Control > Test Movie > In Flash Professional.


The player character’s health begins at 20. Each time he collides with a moving obstacle (yellow stars), his health 
reduces by 1. 


Note: If each collision results in a health reduction greater than 1, that means Flash is having difficulty 
identifying the boundary of each object. Simple hit detection works best with rectangular shapes.


You can also modify the code to increase the health each time the player collects (collides with) an object. To do 
this, add an additional hitTestObject function and change health– –  to health++.   


12. Close the preview window.
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Next, you add a score board that credits players each time they achieve a goal. In this example, the goal is to avoid the 
moving objects (stars) created in the previous activities. So in addition to losing health when the character collides 
with an obstacle, they also score points when they avoid an obstacle. 


To keep score:


1. Continue where you left off in the preceding activity.


2. Add a new layer to the main timeline and name it Score. 
Make sure the Score layer is above the Background,  
Player, Obstacle, and Health layers. Lock all layers 
except the Score and Actions layers (Figure 20). 


3. Click in Frame 1 of the Score layer.


4. Select the Text tool in the Tools panel. 


5. In the Properties panel, select Classic Text in the Text 
Engine menu. Select Dynamic Text in the Text Type 
menu. Make the text Arial, Regular, 32 pt, and a color 
that stands out against the background.


Dynamic text boxes can be filled in or updated by 
ActionScript. They are useful for displaying scores or 
lives in a game.


6. Drag to draw a text box in the upper-left corner of the 
Stage (Figure 21).


7.  Make sure the text box is still selected. In the Properties 
panel, enter score_txt as the instance name (Figure 22).


By giving the text box an instance name, you can refer to 
it in your ActionScript code.


8. Click in Frame 1 of the Actions layer and select Window 
> Actions to open the Actions panel.


Figure 20 Score layer in the Timeline panel


Figure 21 Dynamic text box


Figure 22 Properties panel, Text properties
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9. Place the insertion point before the first line of code in the Actions panel and press Enter (Windows) or Return 
(Mac OS) to add a blank line. 


10. Enter or paste the following code at the top of the Actions panel:
var score=0; 


score_txt.text=score.toString(); 


These two lines set up the score and place it on the screen. The first line creates a variable that remembers the 
current score. The second line displays the score in the text box on the screen.


11. In the Actions panel, scroll down to the gameloop function. Enter or copy and paste the two new lines in the 
following code so the gameloop function looks like this:


function gameloop(e:Event):void{


obstacle_mc.x-=20;


   if (obstacle_mc.x<-100){


   obstacle_mc.x=650;


   hitObstacle=false; // reset hitObstacle when obstacle moves off screen


   score++;


   score_txt.text=score.toString();


   }


   if (jumpman_mc.hitTestObject(obstacle_mc)) {


   if (hitObstacle==false){ // only subtract health if hitObstacle is false


      health--;


   }


  hitObstacle=true;


      health_txt.text=health.toString();


      }


   }


The additional lines of code add 1 to the score (score++) each time the flying-star moving object (obstacle_mc) 
reaches the left side of the screen.


12. Close the Actions panel. Select Control > Test Movie > In Flash Professional.


Each time the moving object reaches the left side of the screen, the score increases by 1. Notice the score 
increases even when the player collides with the obstacle. The player’s score is directly related to how long she 
can maintain health.


13. Close the preview window.
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The game should end when the player’s health reaches zero. Next you add the code that does this.


To end the game:


1. Select Insert > Scene.


A new blank scene and timeline appear. This is called 
Scene 2. Scene 1 still exists, but it’s hidden from view.


2. Select the Text tool. In the Properties panel, change the 
text type to Static Text (Figure 23). Change the Family 
(font) to something different from Arial. 


Your static text should be from a different font family 
than you used for the dynamic text objects.


3. Create two text objects on the Stage that read GAME 
OVER and SCORE:.


4. Add a new layer and name it Final Score.


5. On the Final Score layer, draw a third text box to the right 
of SCORE: and change the text type to Dynamic. Change 
the Family (font) to Arial and make sure the Style is 
Regular.


Scene 2 now includes three text objects (Figure 24). The 
dynamic text box is where you’ll display the player’s 
final score after the game ends.


6. Select the dynamic text box and, in the Properties panel, 
enter score_txt as the instance name.


7. Add a new layer in the Scene 2 timeline and name it 
Actions.


Figure 23 Properties panel, text properties


Figure 24 Static and dynamic text
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8. Click in Frame 1 of the Actions layer and Select Window > Actions to open the Actions panel.


The Actions panel is empty because this is a new scene.


9. Enter or copy and paste the following code to display the player’s score in the dynamic text box in Scene 2.
 score_txt.text=score.toString(); 


10. Close the Actions panel.


11. Click the Edit Scene button (Figure 25) and choose Scene 1.


Scene 2 closes and you return to Scene 1.


Figure 25 Scene 2


12. Click the Actions layer in the Timeline panel and open the Actions panel.


13. Insert a new blank line at Line 1 and enter or copy and paste the following code to prevent the Flash movie from 
looping between Scenes 1 and 2.


stop(); 
Next you add the code to end the game when the player reaches 0 health.


Edit Scene button
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14. In the Actions panel, scroll down to the gameloop function. Enter or copy and paste the new lines in the 
following code so the gameloop function looks like this:


function gameloop(e:Event):void{


obstacle_mc.x-=20;


   if (obstacle_mc.x<-100){


   obstacle_mc.x=650;


   hitObstacle=false; // reset hitObstacle when obstacle moves off screen


   score++;


   score_txt.text=score.toString();


   }


   if (jumpman_mc.hitTestObject(obstacle_mc)) {


   if (hitObstacle==false){ // only subtract health if hitObstacle is false


      health--;


   }


  hitObstacle=true;


      health_txt.text=health.toString();


  if (health<=0){


      stage.removeEventListener(Event.ENTER_FRAME, gameloop);


      stage.removeEventListener(KeyboardEvent.KEY_DOWN, jump);


         gotoAndStop(1, "Scene 2");


      }


   }


}


The additional lines of code check to see if the jumpman_mc character’s health is less than or equal to zero. If it 
is, Flash goes to and stops on Frame 1 of Scene 2. 


The extra two lines of code prevent errors from appearing when the game ends. If you add event listeners, it is 
important that you remove them when the code is finished.


15. Close the Actions panel. Select Control > Test Movie > In Flash Professional.


Note: If your movie does not play properly, you may have accidentally removed the final right brace or added an 
extra brace when editing the gameloop function. 


As long as the jumpman character avoids the moving obstacles, the score continues to increase. As soon as the 
player’s health is depleted, the game ends and you are taken to the GAME OVER screen in Scene 2. The final 
score is shown.
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Moving and dragging objects by using the mouse


You can use drag-and-drop interactions to create a variety of games or applications, including quizzes, jigsaw 
puzzles, and touch-screen navigation. Players move objects by dragging or directing them with the mouse pointer. 


The following activity shows how to use a drag-and-drop interaction to create a simple game. The game involves 
dragging objects to design a face, but you can just as easily use drag-and-drop interactions to customize a product, 
build a puzzle, or match objects in a game or quiz.


Here is an example of a finished game (Figure 26). Players drag the objects on the right to create a face on the left.


Figure 26 Drag-and-drop game example


To create a drag-and drop interaction:


1. Start Flash and open a new blank document 
(ActionScript 3.0). In the Properties panel, select a 
background color for the document.


2. Select the Text tool and change the text type to Static 
Text. Enter some simple instructions for the game 
(Figure 26).


3. In the Timeline panel, rename Layer 1 Head.


4. Use the shape tools to draw a face shape that is about half 
the size of the Stage. Place it toward the left side of the 
Stage. Lock the Head layer in the Timeline panel.


5. Create a new layer named Eyes 1 and draw a pair of eyes 
on the right side of the Stage.


6. Select the eyes and convert the drawing into a new movie 
clip symbol.


The head on the left is the base object onto which players 
will drag objects. The Eyes 1 symbol is the first item in 
the collection of draggable objects (Figure 27).


7. Select the Eyes 1 symbol on the Stage. In the Properties 
panel, enter eyes1 as the instance name (Figure 28).


Next, you create the ActionScript code to make the 
eyes1 symbol draggable.


Figure 27 Head and Eyes 1


Figure 28 Properties panel, symbol instance name
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8. Insert a new layer named Actions.


9. Select the Actions layer, open the Actions panel, and make sure Script Assist is turned off.


10. Enter or copy and paste the following code in the Actions panel:
eyes1.addEventListener(MouseEvent.MOUSE_DOWN,pickup);


This line of code adds an event listener to the eyes1 object. An event listener listens for a specific event. In this 
case we’ve told it to listen for a mouse button being pressed down (MouseEvent.MOUSE_DOWN). This line 
also tells Flash what it should do when it detects this event. It needs to run a function called pickup. You’ll add 
the functions in a moment, but first add another event listener to detect when the mouse button is released, 
dropping the object.


11. Enter or copy and paste the next line of code below the first event listener:
eyes1.addEventListener(MouseEvent.MOUSE_UP,drop);


12. Enter or copy and paste this additional code below the two event listeners for the eyes1 symbol:
eyes1.buttonMode=true;


This tells the eyes1 symbol to appear as a button that changes the appearance of the pointer when it’s placed over 
the symbol. This tells the player it’s a draggable object. 


Next, you add the two functions that tell Flash what to do when an object is picked up or dropped. 


13. Enter or copy and paste this additional code below the first three lines of code:
function pickup (event:MouseEvent):void{


   event.target.startDrag()


   }


function drop (event:MouseEvent):void{


      event.target.stopDrag();


   }


14. Close the Actions panel. Select Control > Test Movie > In Flash Professional.


You can drag the eyes and drop them anywhere on the screen.


15. Close the preview window.


16. Use the drawing tools to create additional objects for the face. For example, draw several different sets of eyes, 
noses, and mouths from which to choose. Put each object in its own layer in the Timeline panel.


17. Convert each object to a separate movie clip symbol and give each object a unique instance name on the Stage.
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18. Afer you add some objects, change the code to include separate event listeners for each object. 


You don’t have to add new functions. The same functions work for each object. The finished code will look 
similar to this example:


eyes1.addEventListener(MouseEvent.MOUSE_DOWN,pickup);


eyes1.addEventListener(MouseEvent.MOUSE_UP,drop);


eyes1.buttonMode=true;


function pickup (event:MouseEvent):void{


   event.target.startDrag();


}


function drop (event:MouseEvent):void{


   event.target.stopDrag();


}


eyes2.addEventListener(MouseEvent.MOUSE_DOWN,pickup);


eyes2.addEventListener(MouseEvent.MOUSE_UP,drop);


nose1.addEventListener(MouseEvent.MOUSE_DOWN,pickup);


nose1.addEventListener(MouseEvent.MOUSE_UP,drop);


nose2.addEventListener(MouseEvent.MOUSE_DOWN,pickup);


nose2.addEventListener(MouseEvent.MOUSE_UP,drop);


mouth1.addEventListener(MouseEvent.MOUSE_DOWN,pickup);


mouth1.addEventListener(MouseEvent.MOUSE_UP,drop);


mouth2.addEventListener(MouseEvent.MOUSE_DOWN,pickup);


mouth2.addEventListener(MouseEvent.MOUSE_UP,drop);


nose1.buttonMode=true;


eyes2.buttonMode=true;


nose2.buttonMode=true;


mouth1.buttonMode=true;


mouth2.buttonMode=true;


19. Save and test the movie.


Note: This sample code assumes you created new symbols with instance names of eyes2, nose1, nose2, mouth1, 
and mouth2. If you did not, the sample code will return errors when you test your movie.
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Adding timers


Timers are used in games for many purposes. For example, a timer can trigger events that happen at timed intervals or 
as a countdown to the end of the game.


In this activity, you create a simple countdown timer and then use the timer to end the game.


To control the allowed time to complete a game:


1. Start Flash and open a new blank document 
(ActionScript 3.0). 


2. Rename Layer 1 Text.


3. Select the Text tool. In the Properties panel, make the 
font Arial, the style Regular, and the size 32. Select a 
color for the text that will represent a countdown clock 
on screen. 


4. In the Properties panel, select Classic in the Text Engine 
menu and Dynamic Text in the Text Type menu.


5. In the Paragraph section of the Properties panel, set the 
text alignment to Align Right.


You’ve set the properties for the countdown clock 
(Figure 29). Next you draw the dynamic text box on the 
Stage.


6. Using the Text tool, drag to draw the new dynamic text 
box on the screen where you want the countdown clock 
to appear. Make sure the text box is large enough to 
display the timer according to the font size you selected.


7. Select the dynamic text box on the Stage and give it the 
instance name timetxt in the Properties panel 
(Figure 30).


8. Insert a new layer and name it Actions.


9. Select the Actions layer and open the Actions panel. 
Make sure Script Assist is turned off.


Figure 29 Properties panel, Text properties


Figure 30 Properties panel, instance name


10. Enter or copy and paste the following code:
stop();


var timeleft=10;


This code creates a variable to keep track of the time left in the game before it ends. It is set to 10, but you can 
make this as long as you want.


Next you display the time in the text box on the Stage.


11. Enter or copy and paste the next line of code:
timetxt.text=String(timeleft);


This code takes the value of timeleft, converts it from a number into a string, and displays it in the timetxt text 
box.


Next you create a timer object called gameTimer. 
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12. Enter or copy and paste the next line of code:
var gameTimer = new Timer(1000);


The timer is set to trigger every 1000 milliseconds, or 1 second. 


13. Enter or copy and paste the next line of code:
gameTimer.addEventListener(TimerEvent.TIMER, countDown);


This event listener runs an event called countDown every second because the gameTimer has a value of 1000 
milliseconds. Next, you create the countdown function.


14. Enter or copy and paste the next lines of code:
function countDown(e:TimerEvent):void{


timeleft--;


timetxt.text=String(timeleft);


}


The function decreases the time left by 1 and updates the information in the text box. 


Finally, the timer has to start.


15. Enter or copy and paste the next line of code:
gameTimer.start();


16. Close the Actions panel. Select Control > Test Movie > In Flash Professional.


The timer text shows up on the screen and counts down backwards. The counter continues into negative 
numbers.


You need to tell the counter when to end the game and show the GAME OVER message.


To use a timer to end the game:


1. Select Insert > Scene.


Scene 2 appears with a blank timeline. Scene 1 still exists, but you don’t see it.


2. Create a static text box in the center of the Stage that reads GAME OVER. Use a font that is different from the 
one you used for the countdown clock dynamic text box in Scene 1 (something other than Arial).


3. Click the Edit Scene button and choose Scene 1.


4. Select the Actions layer. Open the Actions panel and edit the countDown function as follows:
function countDown(e:TimerEvent):void{


timeleft--;


timetxt.text=String(timeleft);


   if (timeleft<0){


      gameTimer.stop();


      gameTimer.removeEventListener(TimerEvent.TIMER, countDown);


      gotoAndStop(1, "Scene 2");


   }


}


The additional code checks to see if timeleft is less than zero. If the time runs out, the timer stops, the event 
listener is removed, and the movie goes to Scene 2.


5. Close the Actions panel and select Control > Test Movie > In Flash Professional.
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Now when the timer runs out, the GAME OVER message appears.


Add buttons to start and replay a game 


In the previous activity, you created a timer to display a game-over screen when the game ends. The game-over 
screen is a good location for a Replay (play again) button. The Replay button includes simple instructions that tell 
Flash to go to and play the game’s main scene timeline. You can also add a separate scene to use as the welcome 
screen. The welcome screen can include a Play button and instructions for the game.


To add a Replay button:


1. Continue where you left off in the preceding activity.


Note: You can also create a new game, but we’re using 
the previous file as an example because it already has a 
timer that takes players to the game-over screen when the 
game ends. You will use this screen to place the Replay 
button.


2. Click the Edit Scene button and choose Scene 2 to view 
the game-over screen (Figure 31).


3. Insert a new layer and name it Replay.


4. Select the Replay layer. Use the Text and shape tools to 
design the artwork for the Replay button (Figure 32). Do 
not use the same font used for the countdown clock 
dynamic text box in Scene 1.


5. Convert the button artwork to a button symbol.


Note: For more information on designing buttons, see the 
guide “How to create a button symbol.”


6. Select the Replay button on the Stage. In the Properties 
panel, give it the instance name replay_btn (Figure 33).


7. Insert a new layer and name it Actions.


8. Select the Actions layer and open the Actions panel.


Figure 31 Edit Scene menu


Figure 32 Artwork for the replay button


Figure 33 Properties panel, instance name


9. Enter the following code to tell Flash to go to and play Scene 1 when someone clicks the Replay button:
stop();


replay_btn.addEventListener(MouseEvent.CLICK,clickFunction);


function clickFunction(evt:MouseEvent):void {


gotoAndPlay(1,"Scene 1");


}


10. Close the Actions panel and select Control > Test Movie 
> In Flash Professional.


The movie starts by counting down, using the timer you 
created in the previous activity. When the timer runs out, 
the game-over screen in Scene 2 appears. Clicking the 
Replay button takes you back to Scene 1, and the timer 
starts again.


11. Close the preview window.
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To create a play button:


1. Continue where you left off in the preceding activity.


2. Select Insert > Scene to add a new scene to the document. 


3. Select Window > Other Panels > Scene.


The Scene panel appears (Figure 34). It includes the 
main scene of the game (Scene 1), the game-over screen 
(Scene 2), and the new scene for the welcome screen 
(Scene 3).


4. Double-click Scene 3 in the Scene panel and change its 
name to welcome.


Note: If you rename Scene 1 or Scene 2, you’ll also need 
to change the references to these scenes in your existing 
code. Changing names in the Scene panel does not update 
the code automatically.


5. Design the artwork for the Play button. Convert the 
artwork to a new button symbol and name the instance on 
the Stage start_btn. 


Note: As when creating your other static text, do not use 
the same font in your Play button that was used for the 
countdown clock dynamic text box in Scene 1.


6. In the welcome scene, insert a new layer and name it 
Actions.


7. Select the Actions layer and open the Actions panel.


Figure 34 Scene panel


Figure 35 Scene panel


8. Enter the following code to tell Flash to go to and play Scene 1 to start the game when someone clicks the Play 
(start_btn) button:


stop();


start_btn.addEventListener(MouseEvent.CLICK,clickFunction2);


function clickFunction2(evt:MouseEvent):void {


gotoAndPlay(1,"Scene 1");


}


9. Close the Actions panel.


10. In the Scene panel, drag the Welcome scene to the top of 
the list to make it the scene that plays first (Figure 35).


11. Select Control > Test Movie > In Flash Professional.


The movie starts on the Welcome screen. Clicking the 
Play button jumps to Scene 1 and starts the game (and the 
counter).


12. Close the preview window.
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		function checkkeysdown(mykey:KeyboardEvent) {

		if (mykey.keyCode==Keyboard.UP) {
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		}
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		}
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		function gameloop(evt:Event) { if (moveup==true) { if (player_mc.y>0){

		player_mc.y-=speed;

		}
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		}
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		}

		}
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		} } }
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		stage.addEventListener(KeyboardEvent.KEY_DOWN, startRotation);

		function startRotation(e:KeyboardEvent):void{

		if (e.keyCode==Keyboard.LEFT){
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		}

		if (e.keyCode==Keyboard.RIGHT){

		rotateRight=true;
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		}

		stage.addEventListener(KeyboardEvent.KEY_UP, stopRotation);

		function stopRotation(e:KeyboardEvent):void{
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		}
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		stage.addEventListener(KeyboardEvent.KEY_DOWN, jump);

		function jump(e:KeyboardEvent):void {
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		}
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		stage.addEventListener(Event.ENTER_FRAME, gameloop);

		function gameloop(e:Event):void{

		obstacle_mc.x-=20;

		}

		function gameloop(e:Event):void{

		obstacle_mc.x-=20;

		if (obstacle_mc.x<-100){

		obstacle_mc.x=650;

		}

		}

		var hitObstacle:Boolean=false; // keeps track if obstacle is hit

		var health=20;

		health_txt.text=health.toString();

		function gameloop(e:Event):void{

		obstacle_mc.x-=20;

		if (obstacle_mc.x<-100){

		obstacle_mc.x=650;

		}

		if (jumpman_mc.hitTestObject(obstacle_mc)) {

		if (hitObstacle==false){ //only subtract health if hitObstacle is false

		health--;

		}

		hitObstacle=true;

		health_txt.text=health.toString();

		}

		}

		var score=0;

		score_txt.text=score.toString();

		function gameloop(e:Event):void{

		obstacle_mc.x-=20;

		if (obstacle_mc.x<-100){

		obstacle_mc.x=650;

		hitObstacle=false; // reset hitObstacle when obstacle moves off screen

		score++;

		score_txt.text=score.toString();

		}

		if (jumpman_mc.hitTestObject(obstacle_mc)) {

		if (hitObstacle==false){ // only subtract health if hitObstacle is false

		health--;

		}

		hitObstacle=true;

		health_txt.text=health.toString();

		}

		}
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		if (obstacle_mc.x<-100){
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		score_txt.text=score.toString();

		}

		if (jumpman_mc.hitTestObject(obstacle_mc)) {

		if (hitObstacle==false){ // only subtract health if hitObstacle is false

		health--;

		}

		hitObstacle=true;

		health_txt.text=health.toString();

		if (health<=0){

		stage.removeEventListener(Event.ENTER_FRAME, gameloop);

		stage.removeEventListener(KeyboardEvent.KEY_DOWN, jump);

		gotoAndStop(1, "Scene 2");

		}

		}

		}



		Moving and dragging objects by using the mouse

		eyes1.addEventListener(MouseEvent.MOUSE_DOWN,pickup);

		eyes1.addEventListener(MouseEvent.MOUSE_UP,drop);

		eyes1.buttonMode=true;

		function pickup (event:MouseEvent):void{

		event.target.startDrag()

		}

		function drop (event:MouseEvent):void{

		event.target.stopDrag();

		}

		eyes1.addEventListener(MouseEvent.MOUSE_DOWN,pickup);

		eyes1.addEventListener(MouseEvent.MOUSE_UP,drop);

		eyes1.buttonMode=true;

		eyes1.buttonMode=true;

		function pickup (event:MouseEvent):void{

		event.target.startDrag();

		}

		function drop (event:MouseEvent):void{

		event.target.stopDrag();

		}

		eyes2.addEventListener(MouseEvent.MOUSE_DOWN,pickup);

		eyes2.addEventListener(MouseEvent.MOUSE_UP,drop);

		nose1.addEventListener(MouseEvent.MOUSE_DOWN,pickup);

		nose1.addEventListener(MouseEvent.MOUSE_UP,drop);

		nose2.addEventListener(MouseEvent.MOUSE_DOWN,pickup);

		nose2.addEventListener(MouseEvent.MOUSE_UP,drop);

		mouth1.addEventListener(MouseEvent.MOUSE_DOWN,pickup);

		mouth1.addEventListener(MouseEvent.MOUSE_UP,drop);

		mouth2.addEventListener(MouseEvent.MOUSE_DOWN,pickup);

		mouth2.addEventListener(MouseEvent.MOUSE_UP,drop);

		nose1.buttonMode=true;

		eyes2.buttonMode=true;

		nose2.buttonMode=true;

		mouth1.buttonMode=true;

		mouth2.buttonMode=true;



		Adding timers

		stop();

		var timeleft=10;

		timetxt.text=String(timeleft);

		var gameTimer = new Timer(1000);

		gameTimer.addEventListener(TimerEvent.TIMER, countDown);

		function countDown(e:TimerEvent):void{

		timeleft--;

		timetxt.text=String(timeleft);

		}

		gameTimer.start();

		function countDown(e:TimerEvent):void{

		timeleft--;

		timetxt.text=String(timeleft);

		if (timeleft<0){

		gameTimer.stop();

		gameTimer.removeEventListener(TimerEvent.TIMER, countDown);

		gotoAndStop(1, "Scene 2");

		}

		}



		Add buttons to start and replay a game

		stop();

		replay_btn.addEventListener(MouseEvent.CLICK,clickFunction);

		function clickFunction(evt:MouseEvent):void {

		gotoAndPlay(1,"Scene 1");

		}

		stop();

		start_btn.addEventListener(MouseEvent.CLICK,clickFunction2);

		function clickFunction2(evt:MouseEvent):void {

		gotoAndPlay(1,"Scene 1");

		}
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How to set document properties
For each page you create in Dreamweaver, you can specify layout and formatting properties by using the Page 
Properties dialog box (Figure 1). The Page Properties dialog box lets you specify the default font family and font 
size, background color, margins, link styles, and many other aspects of page design. You can assign new page 
properties for each new page you create, and modify those for existing pages. You can also change the Document 
Type Declaration in the Title/Encoding category of the Page Properties dialog box. For example, if you wanted to 
alter a document’s DTD from HTML 4.1 to HTML 5. Changes you make in the Page Properties dialog box apply to 
the entire page.


Dreamweaver gives you two methods for modifying page properties: CSS or HTML. Adobe recommends using CSS 
to set backgrounds and modify page properties.


Figure 1 Page Properties dialog box


Using CSS to set font, colors, margins, and background image properties
Use the Page Properties dialog box to specify several basic page layout options for your web pages, including the 
font, background color, and background image.


To set layout and formatting options for a page:


1. Open a document in Adobe Dreamweaver CS6.


2. Select Modify > Page Properties or click the Page 
Properties button in the text Properties panel.


The Page Properties dialog box opens (Figure 1).
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3. Select the Appearance (CSS) category and set the 
options.


Page Font specifies the default font family to use for the 
page. Dreamweaver uses the font family you specify 
unless another font is specifically set for a text element.


Size specifies the default font size to use in the page. 
Dreamweaver uses the font size you specify unless 
another font size is specifically set for a text element.


Text Color specifies the default color to render fonts with.


Background Color sets a background color for your page. 
Click the Background color box and select a color from 
the color picker (Figure 2).


Background Image sets a background image for the page. 
Click the Browse button, then browse to and select the 
image. Alternatively, enter the path to the background 
image in the Background Image text box. Dreamweaver 
tiles (repeats) the background image if it does not fill the 
entire window, just as browsers do.


Repeat text specifies how the background image will be 
displayed on the page:


• Select the No-repeat option to display the 
background image only once.


• Select the Repeat option to repeat, or tile, the image 
both horizontally and vertically.


• Select the Repeat-x option to tile the image 
horizontally.


• Select the Repeat-y option to tile the image 
vertically.


Left Margin and Right Margin specify the size of the left 
and right page margins. 


Top Margin and Bottom specify the size of the top and 
bottom page margins.


4. When you’ve finished making changes, click Apply to 
set the properties, and click OK to close the dialog box.


Figure 2 Set Background Color in the Page 
Properties dialog box
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Design document
The Coast Middle School’s website is in desperate need of a redesign (Figure 1). Use this sample design document to   
understand the structure phase of the web design process. You can use this design document both for new website 
projects, or redesign of an existing site. As part of this process you will perform the following steps: needs analysis, 
requirements analysis, and creative design. The needs analysis focuses on a user’s experience of a website by 
defining challenges, goals, audience, and proposes a suitable solution. The requirements analysis identifies any 
technical considerations and scope of the website project. The creative design offers two or more design options for 
the client to review, select and approve. 


The goal of this design document is to summarize the steps needed to improve function, usability and accessibility of 
the Coast Middle School website redesign project.


Figure 1 Coast Middle School website


Project overview


Site challenges


• Content and navigation: The single Coast Middle School page is too long, and requires visitors to scroll 
excessively. Too much information is contained within too few topics. For example, the About Us section 
could be broken into Athletics, Activities, and Volunteer Opportunities.


• Usablity and accessibility: The page uses old-fashioned HTML tables and anchor links that cause the page 
content to display inconsistently across a range web browsers and devices. Images contain no alternative 
text for screen readers to translate visual content of an image into a suitable format for users with assitive 
devices.
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• Look and feel: The website has an uninspired look and feel, the colors do not work well together and images 
are not visually interesting.


Proposed solution


• Content and navigation: Split the existing, single, Coast Middle School page into multiple pages organized 
by topics, with a clear and consistent navigation structure. 


• Usablity and accessibility: Develop with web browser, handheld devices, and assistive technologies in 
mind. This must include support for graphics, multimedia elements and dynamic graphics in modern web 
browsers and across various mobile and assitive devices.


• Look and feel: Redesign Coast Middle School logo and select two or three unifying colors to create a 
consistent visual identity across the site.


Site objectives


The audience will go to the site for information about the school, its faculty, and its events, as well as to find more 
ways to be involved with the school.


Site messages


The Coast Middle School cares about its students, parents, staff, teachers and the greater community.


Audience


The intended audience of the site is parents, community members, school administrators, teachers, and students. 


Site goals


The redesign should include the following:


• Make the site easy to update, to provide information about new school activities as well as changes in the 
faculty and staff.


• Incorporate a new Coast Middle School logo.


• Give more detailed information about activities, athletics, organizations, and departments because these 
groups will be creating their own websites.


• Use a calendar to inform the community about events at the school.


• Give easy access to categories of information.


• Attract the audience to increase community and parental participation in the school.


Delivery requirements


Technical requirements


Audience members will typically access this site by using a dial-up modem, cable modem, or over a wireless 
network. They might use common browsers such as Internet Explorer, Mozilla Firefox, Safari, or others. Site visitors 
may also be accessing the website using a variety of mobile devices including cellular phones or tablets. Users with 
disabilities may be using assitive devices to help render the site accessible. Web technologies including template-
based design, HTML5, and CCS3 will be used to address these technical and accessibility requirements.


Site content


Home page:


• Logo for the Coast Middle School
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• Title for the Coast Middle School


• Links to the following areas:


◦ Academics: departments, schedules, class pages, library


◦ Student Activities: athletics, clubs and organizations


◦ School Information: news, calendar, handbook, volunteering


◦ Faculty and Staff: teachers, administrators, staff


◦ About Us: mission, directory, civics, contact info, maps, links


Sample content page:


• New Coast Middle School logo


• Navigation bar


• Universal navigation to each of the following:


◦ Academics


◦ Student Activities


◦ About Us


◦ School Information


◦ Faculty and Staff


Site Structure


A proposed site map is shown in Figure 2.


Figure 2 Proposed site structure
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Creative design
In the creative design step, a clear design direction is established and may consist of wireframes, font and color 
options, and design comps. Designers present creative design plans to clients, and then make revisions based on client 
feedback. 


Font and color options


You can open the related file p2_design_document_electonic_file.fw.png in Adobe Fireworks to create your own font 
and color option document.


Design A 


The font and color palette in the first alternative design (Figure 3) has the following qualities:


• The main blue color will be used for the navigation structure and as part of the logo.


• The pink color will be used for regular text on the page.


• The black and white will be used in the logo.


Figure 3 Design A font and color options


Design B 


The font and color palette in the second alternative design (Figure 4) has the following qualities:


• The main yellow-orange color will be used for the logo and to highlight any text.


• The gradient blue-black will be used as a background for the navigation structure on all pages.


• The black and white will be any text on the page: white text on the blue-black background and black text on 
the white background.


Figure 4 Design B font and color options
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Sample design comps


Two sample design comps are based on the font and color palettes presented in the previous section.


Design A


The Coast Middle School home page design for option A (Figure 5) uses pop-up menus to manage all the content 
and links for the main navigation. It uses the blue color for the navigation and a mix of blue and pink for the logo. The 
main text on the page is similar to the pink in the logo to draw the attention of the visitor. A content page would look 
exactly like the home page, with the same navigation bar across the top. For this design, the team would need to 
create one template for use throughout the site. This design unifies the site; however, it does make it difficult for 
visitors to know when they are on the home page versus a content page.


Consider the following factors when reviewing this design:


• Consistency: The site is consistent because it uses only three colors and uses the logo and footer on every 
page.


• Ease of use: Pop-up menus make the site easy to use because visitors can jump to specific information easily 
and quickly.


• Universal navigation: A universal navigation scheme is repeated on every page.


• Layout: The layout uses white space between the logo and the footer to focus visitor attention on the content 
in the middle of the page.


This design uses the logo and color choice to create a simple site that might appeal to multiple audiences.


Figure 5 Design A design comp
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Design B


The Coast Middle School home page design comp for option B (Figure 6) uses a large navigation menu for the home 
page instead of pop-up menus. Also, a school quiz is included to entice visitors to learn about the Coast Middle 
School. The main colors and logo are used as directed.


Figure 6 Design B home page design comp


This sample content page (Figure 7) is similar to the home page with the logo, but it contains a collapsed main 
navigation bar. Also, text links at the bottom of the page make the page more accessible. The site is unified by the 
logo and footer logo.


Figure 7 Design B contnent page design comp


Consider the following factors when reviewing this design:


• Consistency: This site uses color consistently, and the logo appears on every page.


• Universal navigation: The navigation scheme is a large menu on the home page and repeats in a simpler 
form on all content pages.
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• Ease of use: The site has a main navigation scheme throughout the site and also contains text navigation at 
the bottom for visitors who have turned off viewing of graphics.


• Layout: Layout focuses visitors on the white space between logo and footer.


This design uses fonts and color to make the site more fun and more representative of students in a middle school.
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Creating user scenarios
When designing a mobile application or any other online program, be sure you research and define your target 
audience. Part of the audience analysis should include one or more user scenarios. These can be real examples based 
on interviews with actual target users or fictional stories based on the type of end user you expect (or hope) will use 
your finished product. User scenarios describe in detail what users do and why they do it. They often tell a short story 
about a person using a website or application, detailing their motivations and goals. This helps you incorporate users’ 
desires and needs into the process of designing the program and making decisions about features and functionality.


Sample user scenarios
The following are sample user scenarios from three projects: a university campus guide mobile application, an online 
photo gallery, and an online calendar of events for an academic department.


University campus guide mobile application


Vinoth Praveen, a student at Darby University, uses his Android mobile device to access current university and 
community information and to connect with other students and faculty. He commutes to campus each day and needs 
easy access to campus transportation schedules. Vinoth will use his mobile device to research class project content 
and news while on the go. He will use his mobile device to locate classes, search for classes in the course catalog, and 
look up faculty office hours. He has recently joined Facebook and Twitter and wants to use his mobile phone to find 
out about on-campus activities, clubs, and sporting events.


Bruce Elliot is a biology professor at Darby University. Bruce wants to use his mobile device to research current 
education articles, access and publish university library resources, and connect with students and other faculty.


Online photo gallery


Jugnu Metha, a creative director for a large agency, uses images from Marcus Glass Photography as source files 
when working on advertising campaigns. Jugnu accesses the Marcus Glass online photo browser application almost 
every day from his office via a high-speed network connection. He uses the photo browser to review images, 
comment on them, and select suitable ones from the collection.


Margaret Elliot is a project manager working on Jugnu’s team. Margaret often travels to visit clients and must 
present campaign designs while onsite. In spite of spotty Internet access, she needs to show Marcus Glass 
photographic images for client approval. She accomplishes this by using an AIR version of the desktop application to 
review images, comment on them, and select suitable ones from the collection while offline.


Online calendar of events for an academic department


Chonita Cravin is the administrator responsible for updating the academic calendar of events for her department. 
The calendar is hosted on the school’s internal web server, and Chonita adds and edits events via a web browser as 
they come across her desk. Chonita manages such event information as visiting lecturer series, academic deadlines, 
and gallery activities.


Bart Bryerly is a student in the department. He regularly visits the department website to view the calendar, looking 
for specific information about the visiting lecturer series. In the details view, Bart quickly and easily sees the subject, 
location, and time of each lecture. Where available, there are also links to the lecturer’s website.
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Gaming Trends

		The mobile gaming trend has created renewed demand for simple and repetitive games. 

		Lower-budget games created by individuals and small teams have become financially successful.

		You can find them on game arcade sites such as Newgrounds.com and AddictingGames.com.

		You can choose from dozens of game genres: action, adventure, casino, puzzle, role-playing, and more.

		For many developers, the Adobe Flash platform is the preferred tool for game development. 



*

  

  

  

  



*

Go to next slide for examples of why the Flash Platform is the preferred tool for many  (new) game developers.
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Flash Games

		Flash games, games created with the Adobe Flash platform, are growing in popularity—and not just with kids and teens. 

		Flash games are interactive, cross-browser, and cross-platform. 

		Users can play Flash games on personal computers and mobile devices.

		Flash games can be embedded into most popular social networking sites, such as Facebook.

		By using Adobe AIR technology, Flash games can also be deployed on iOS devices through the Apple App Store.







*
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Development environments

		Adobe Flash Professional CS6 and Adobe Flash Builder 4.6. are development environments for creating SWF-based games. 



Adobe Flash Professional CS6

		In Flash Professional CS6, you can see your layouts and animations as you work with them. For that reason, it’s very popular with developers who create visual games. It strikes a good balance between visual design and code design. 



Adobe Flash Builder 4.6

		Adobe Flash Builder 4.6 is used by developers who create Rich Internet Applications (RIAs) that connect to a data source or web service. For example, an application that regularly updates to show current movie times could be created by using Flash Builder.

		Flash Builder is a popular tool for creating web applications and mobile apps, including games. 

		Many developers use a combination of Flash Builder and Flash Professional when developing games. For example, you can use Flash Professional to design the graphic elements of your game (characters, maps, effects, and so on) while your developer works in Flash Builder to build the final game controls and connect the game to a server and other players.



*
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Tips for selecting the best  tools for a project

Use a blended designer/developer workflow for game creating by combining Adobe Flash Profession and Adobe Flash builder when: 

The project is either design or data-centric (by data-centric, we mean the game will connect to a back-end data service or data base).

The team includes both design and development resources (both graphic designers and Flex developers)

The application will bind service operations to UI components (i.e. for storing user scores or connecting players in a multi-player environment).

Use Adobe Flash Professional to design, develop, and publish games when:

The project is design-centric.

Your team includes primarily designers (not Flex developers).

The application will not bind service operations to UI components.

Use Flash Builder alone to design, develop, and publish games  when:

The project is data-centric.

Your team includes Flex developers.

The primary goal is to bind service operations to UI components.
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Runtimes

		A runtime is a software component designed to support the execution of computer programs. The Adobe Flash Platform includes two runtimes: Adobe Flash Player and Adobe AIR.



Adobe Flash Player

		Adobe Flash Player is a browser plug-in that provides a multi-platform client runtime. 

		You can build your game once and it will look the same in virtually any web browser and on Windows, Mac OS, or Linux operating systems. 

		Flash Player plays content that has been compiled into an SWF file. 

		Flash Player is licensed free of charge so end users can start playing your game without additional costs. 



Adobe AIR

		Adobe AIR lets you view SWF content on your desktop without a web browser.

		You need to have the AIR runtime installed to run AIR files.  The AIR runtime is licensed free of charge to end users.



*
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Key components of a game

These components are common to most games:

		Input

		Sprites

		Collision detection

		Sounds

		Game loop



*
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There are several components that are common to most games: 

Input: how users control the game. Basic games are typically controlled with the mouse, the keyboard arrow keys, or both. On mobile devices, touch gestures are the most common input method, and the Flash Platform has robust touch support.

Sprites:  visual elements, such as an alien or fish moving across the screen.   

(Game sprites should not be confused with the ActionScript 3.0 class, “flash.display.Sprite.”)

Collision detection: the code that senses when any two sprites touch on screen, which is crucial for most action-oriented games.

Sounds: accent important events to enhance the game play experience. Sounds provide an important element of feedback to the player and make your games interesting and fun.

Game loop: a term used by game developers to describe the programming logic that controls the game experience. ActionScript is the programming language you use to execute the game loop in Flash games. 
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Input methods

		Games designed to run in a web browser or computer rely primarily on mouse and keyboard input to control the game. 

		Other devices rely on other inputs. One example is the use of touch-screen input found on most phones and tablets. 

		The Flash Platform currently supports multi-touch and gestures in Flash Player 10.1 or later in a browser, SWF content published for the iPhone or iPod touch, and in AIR 2 or later.



*
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Game design and development workflow

*
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Whether you’re an individual developer creating your first single-player game, or a large team designing a complex multi-player environment, you’ll follow a similar workflow for game design and development.







Copyright 2012 Adobe Systems Incorporated.  All rights reserved. 



Plan & Design 

		Brainstorm to develop ideas for the game.

		Create a storyboard or map of the game world.

		Design your game in a game design planning document. 
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Brainstorm to develop ideas for the game.

Your inspiration for great games can come from anywhere—dreams, movies, books, nature, work, cities, friends, family. 

Write down all ideas, no matter how outrageous or silly.

Create a storyboard or map of the game world.

Sketch out characters, backgrounds, screens, and game mechanics. 

Game mechanics are the core set of rules that define what makes a game unique. A game features a variety of game mechanics, such as keyboard input, turns, decisions, Game mechanics—Define how the game and players interact. risks and rewards. 



Design your game in a game design planning document. 

Describe the details of the game, including the technical requirements for development.

Who is your target audience?

What spoken languages will be included? 
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Plan & Design

*

  

  

  

  

		The game design planning document should include

		Everything a developer needs to know to build the game

		Everything a player needs to know to play the game

		Your game design planning document should also include

		Objectives of the game

		Rules of play

		Scoring

		Game world screens and background layout

		Character and object (sprite) descriptions

		Sounds

		User input and controls

		Game difficulty level(s) and any stages or levels the player can achieve

		Target devices or screens





*

The game design planning document should include:

Everything a developer needs to know to build the game

Everything a player needs to know to play the game

Your game design planning document should also include:

Objectives of the game —How do players win or lose?

Rules of play

Scoring—Include number of plays (lives) per game, how to score, interactions that reduce a score, etc.

Game world screens and background layout — What are the artwork requirements?

Character and object (sprite) descriptions

Sounds—Sounds can be used to enhance the game experience.

User input and controls

Game difficulty level(s) and any stages or levels the player can achieve

Target devices or screens—Will the game run in a browser, on a phone or tablet, on Android or  iOS devices?
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Develop

		Follow your game design document.

		Build the game in stages, creating standalone demo projects. 

		Create an assets library. 

		Construct the menus. 

		Test the game repeatedly throughout the development process.
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Follow your game design document.

Build the game in stages, creating standalone demo projects. This will help to identify and trouble-shoot aspects of the game that are difficult to implement or create usability issues during play.

Create an assets library. Create artwork in Flash Professional or other Creative Suite products. Locate royalty-free sounds online.

Construct the menus. Games often feature screens outside of the game itself such as the introduction, instructions, and Game Over screen.

Test the game repeatedly throughout the development process to be sure it's enjoyable and challenging.
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Test

		A good testing process answers these fundamental questions:

		Is it fun?

		Does it work (is it free of bugs)?

		Does it perform as expected on the desired platforms?

		Testing for multiple screens presents a unique set of challenges. 

		For web games, test the game on a variety of computers and web browsers. 

		For mobile phones and tablets, the differences between devices (for example, screen size, screen density, and input schemes) and the sheer number of available devices complicates the process. 

		Flash Professional includes mobile device support to simulate, test, and publish applications to a wide array of devices. 
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A good testing process will answer these fundamental questions:

Is it fun?

Does it work (is it free of bugs)?

Does it perform as expected on the desired platforms?

Testing for multiple screens presents a unique set of challenges. 

For web games, test the game on a variety of computers and web browsers. 

For mobile phones and tablets, the differences between devices (for example, screen size, screen density, and input schemes) and the sheer number of available devices can complicate the process. 

Flash Professional includes mobile device support to simulate, test, and publish applications to a wide array of devices. 

You can use the Flash Professional AIR mobile simulator to test mobile application interactions. 

Flash Professional also ships with Device Central, a package of emulators that simulate popular mobile devices right on your computer. 

Whenever possible, you should also test on the physical devices.
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Monetize

		Two main approaches to turning games into revenue:

		Offer games that are free to play .

		Offer premium games that cost money to play.  

		Ways to monetize free games:

		Advertisements

		Sponsorship

		Licensing

		Ways to sell games to the video game community:

		Straight sale

		Freemium

		Micro-transactions

		Subscriptions
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There are two main approaches to turning games into revenue.

Offer games that are free to play .

Offer premium games that cost money to play.  

There are several ways to monetize free games.

Advertisements: Place banner advertising on the HTML page surrounding the game or within the game itself. Advertising deals are typically paid to game developers based on the number of ads shown (impressions) or the quantity of traffic generated (clicks).

Sponsorship: Place advertising, links, logos, and marketing messages within your game for a paying sponsor.

Licensing:  Place the advertising, links, logos, and marketing messages within your game for a paying sponsor and restrict the game's availability to a single site.

There are several ways to sell games to the video game community.

Straight sale: Sell the complete game for one up-front cost.

Freemium: Offer a free trial and then let users pay for upgrading to a complete version.

Micro-transactions: Encourage users to convert real-world money into virtual game currency to unlock characters, abilities, levels, or other content. Micro-transactions and freemium games are sometimes used together.

Subscriptions: Players can continue playing if they make regular payments (usually on a monthly basis). 
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Distribute

		The Flash Platform offers several deployment options to reach your intended audience. 

		Flash Platform deployment options via Flash Player:

		Web browser (PC, Mac, Linux, mobile)

		Flash Platform deployment options via Adobe AIR technology:

		Desktop (PC, Mac, Linux)

		Android (Phones and tablets)

		Apple iOS (Phones and tablets)

		BlackBerry tablet OS (tablets)

		Internet-enabled televisions and appliances

		The distribution strategy affects your game because the target device determines screen sizes and input styles. 

		The monetization strategy you choose also affects game content. You may need to implement advertisement integration, links or buttons to sponsors, virtual item sales, and more.



*
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Analyze and update

		Conduct usability studies and focus groups to gather user feedback.

		Update your game often after its initial launch to ensure it has the longest life possible. 

		If you’re using a subscription-based monetization strategy, release episodic content to keep subscribers happy.

		Make improvements to the game based on analytics and user feedback.

		Add new content, such as levels and characters.

		Fix bugs.



*

  

  

  

  



*
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Other features and considerations

		Many devices have features that can be used for gaming. Here are a few examples and some considerations for each.

		Accelerometer  Many smartphones, tablets, and game consoles sense their angle of rotation by using an accelerometer. You can use this for aligning and moving objects on the screen. 

		Application multitasking  How will your game behave when minimized and maximized? If it’s a mobile game, does it automatically pause when the phone rings?

		Casual connectivity  Users are not always connected to the Internet. Does your game require constant connectivity? Will it have an offline mode and an online mode?

		GPS/Geolocation  Devices with geolocation, including most smartphones and tablets, know where they are in the world. You can use this to change the game experience, unlock content, or introduce game players who are close to each other.





*
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You can use a device’s accelerometer to change from portrait to landscape view or to simulate gravity and the natural movement of objects on the screen.

In games that keep score or measure progress through achieving levels-of-play, players will appreciate multitasking functionality, such as automatically pausing a mobile game when receiving making a call or text message.

Connectivity is an important consideration for mobile games, especially those that run on phones or tablets, where service is often inconsistent or limited.

GPS and Geolocation typically require that users  manually enable these features on their mobile device.  Your game should detect whether or not these devices are enabled if the game depends on them.

One of the biggest divides among mobile phone users is between those who can manipulate their handset's tiny number keys to tap out text messages, e-mail or Web addresses and those who can't, won't or just don't.  But there is one universal input device that is far easier to use than any miniature keypad or even a touch screen keyboard, and it works with most smartphones and tablets: your voice. 

A simple example of a game with persistence is “Words With Friends.” These games can be turned off and resumed without losing your place or turn in the current game. 

Automatically pausing a game  when a device “sleeps” is similar to building in persistence, but pausing during sleep mode must detect the state of the device vs. a user pausing the game manually.

Although games can incorporate personal pictures and video as input in a game, for security and safety, it may be better for users to include virtual characters or avatars. 
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Other features and considerations

		Many devices have features that can be used for gaming. Here are a few examples and some considerations for each.

		Microphone  Use voice or sounds as an input—most current smartphones and tablets include voice input options as an alternative to typing text. Consider creating a character that interacts with players by having a conversation. 

		Persistence  Many mobile users play games in short bursts, starting and stopping the game when they have time for fun. If your game saves its progress, users can jump back into the action quickly.

		Sleep mode  Some devices sleep when not in use. How will your game react? If the user becomes distracted and sets down the device, will the game pause or will it continue to consume battery life?

		Still camera  You can use a device’s built-in camera to let users add their own images to a game.
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You can use a device’s accelerometer to change from portrait to landscape view or to simulate gravity and the natural movement of objects on the screen.

In games that keep score or measure progress through achieving levels-of-play, players will appreciate multitasking functionality, such as automatically pausing a mobile game when receiving making a call or text message.

Connectivity is an important consideration for mobile games, especially those that run on phones or tablets, where service is often inconsistent or limited.

GPS and Geolocation typically require that users  manually enable these features on their mobile device.  Your game should detect whether or not these devices are enabled if the game depends on them.

One of the biggest divides among mobile phone users is between those who can manipulate their handset's tiny number keys to tap out text messages, e-mail or Web addresses and those who can't, won't or just don't.  But there is one universal input device that is far easier to use than any miniature keypad or even a touch screen keyboard, and it works with most smartphones and tablets: your voice. 

A simple example of a game with persistence is “Words With Friends.” These games can be turned off and resumed without losing your place or turn in the current game. 

Automatically pausing a game  when a device “sleeps” is similar to building in persistence, but pausing during sleep mode must detect the state of the device vs. a user pausing the game manually.

Although games can incorporate personal pictures and video as input in a game, for security and safety, it may be better for users to include virtual characters or avatars. 
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Summary

		Flash games are everywhere. Based on their growing popularity, this is a great time to get started developing some games of your own. 

Some examples of popular games:

		Drag-and-drop games that let players solve a puzzle or build something by selecting, dragging, and placing objects.  

		Character movement and adventure games that require players to guide a character through a course of obstacles to reach a goal. 

		For examples of easy-to-develop Flash games, visit: www.flashclassroom.com 

		The user-friendly design, coding, and multiscreen testing features of Adobe Flash Professional CS6 make it the perfect tool for new game designers. 

		Using Adobe Flash Professional CS6, you can turn some of your most creative ideas into fully functioning, marketable, and fun-to-play games. 



*
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File naming conventions
How you name your files is important. Good file and folder names make developing your site easier (especially when 
you work with other people). They also help site visitors find your files. If you’re working with other people, it’s a 
good idea to discuss how you will name your files.


The following tips apply to all files used on the web—HTML files, image files, Flash movies, and so on.


Tip Reason Example


Give files unique, meaningful 
names.


Because you cannot put two files 
with the same name in one folder, 
all filenames need to be different. 
Use filenames that indicate the con-
tents of the files.


feedback_button.gif instead of 
button3.gif 


class-pet.jpg instead of roo-roo.jpg


Use meaningful folder names. Folders help you organize content. 
If their names are not meaningful, 
they will be less helpful.


images 
instead of 
folder_2


Use lowercase letters instead of 
uppercase (capital) letters.


Using a mix of uppercase and low-
ercase letters increases the possibil-
ity of broken links, because some 
web servers differentiate between 
upper and lowercase.


class_home.htm 
instead of Class_Picture.htm


Use file extensions (.html, .gif, .jpg) 
consistently. Although you can use 
either .htm or .html, you should be 
consistent about using one or the 
other.


Using a mix of file extensions also 
increases the possibility of broken 
links.


index.html and directions.html
instead of index.html and direc-
tions.htm


If you’re working on a Macintosh 
computer, always include a file 
extension.


Although Windows requires file 
extensions, Macintosh does not. 
Web browsers need file extensions 
in order to display files.


index.html instead of index


Use a hyphen (-) or an underscore    
( _ ) instead of a space.


Some web browsers do not recog-
nize spaces or convert them to other 
characters.


my-dog.gif or my_dog.gif 
instead of my dog.gif


Use letters and numbers. Many special symbols aren’t recog-
nized by web browsers or have spe-
cial meanings to web browsers.


my2friends.gif instead of 
me&friends.gif


Keep filenames as short as possible. Not only does this help prevent bro-
ken links, but some web servers will 
cut off names at 25 characters.


park_directions.html instead of 
directions_to_the_fourth_street_pa
rk_plus_a_map.html





		File naming conventions

		How you name your files is important. Good file and folder names make developing your site easier (especially when you work with other people). They also help site visitors find your files. If you’re working with other people, it’s a good idea to...

		The following tips apply to all files used on the web—HTML files, image files, Flash movies, and so on.

		The following tips apply to all files used on the web—HTML files, image files, Flash movies, and so on.



		class-pet.jpg instead of roo-roo.jpg

		index.html and directions.html
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How to use templates
You can use an Adobe Dreamweaver CS6 template to create multiple pages with the same layout. In a template, you 
control which page elements should remain constant in documents based on that template and which elements can be 
changed from page to page. Templates are helpful for building a website in which most pages have the same header, 
navigation system, and other elements. Using templates helps you save time as well as create and maintain a 
consistent look when more than one person is developing a site.


Creating a template
You create templates from existing pages, setting editable regions on these pages that will hold content on each page 
created from the template.


To create a template:


1. Start Dreamweaver.


2. Build a page that contains elements designed to appear 
on all content pages such as common graphics, a 
navigation bar, and common layout structures such as div 
tags (Figure 1).


Note: You may want to create navigation elements in 
Adobe Fireworks CS6 and export them as HTML 
documents.


3. Select File > Save As Template.


4. In the Save As Template dialog box (Figure 2), give the 
template a name. You can also enter a brief description of 
the template. Then click Save. If Dreamweaver asks if 
you want to update links, click Yes.


Dreamweaver creates a Templates folder in your site root 
folder and saves your template in that folder. Template 
files have a .dwt file extension.


Figure 1 Common elements on a web page


Figure 2 Save As Template dialog box
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To create an editable region:


1. In the Layout category of the Insert panel, click Draw AP 
Div, and then drag on the page to create a new div to 
represent the editable region in the template.


Note: You also click to indicate where to place the 
editable region, but using a div gives you more control 
over page layout. 


2. With the div still selected, do one of the following to 
create an editable region:


• Select Insert > Template Objects > Editable Region.


• Right-click (Windows) or Control-click (Mac OS) 
the region and select Templates > New Editable 
Region from the context menu.


• In the Common category of the Insert panel, click the 
Templates button (Figure 3), and select Editable 
Region from the pop-up menu.


The New Editable Region dialog box opens (Figure 4).


3. In the dialog box, enter a unique name for the region, and 
click OK.


The editable region is within the selected div, and is 
enclosed in a light blue rectangle on the template 
(Figure 5).


Note: You cannot use the same name for more than one 
editable region in a particular template. Use only letters 
and numbers in the name.


4. Save and close the template.


Figure 3 Templates button on the Insert panel


Figure 4 New Editable Region dialog box


Figure 5 New editable region inside the div
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To create a document based on a template:


Once you create a template, you can use it to create new 
documents.


1. Select File > New.


2. In the New Document dialog box, select the Page From 
Template category.


The dialog box displays your sites and all of the 
templates for the selected site (Figure 6).


3. In the Sites list, select the site that contains the template 
you want to use.


4. Select the template you want to use.


5. Make sure the Update Page When Template Changes 
option is selected.


With this option selected, Dreamweaver can update all 
template-based pages if you change the template later.


6. Click Create to create a new template-based page.


The document opens in the Document window.


7. Click in one of the editable regions, and add text.


8. Move the pointer over a page area that is not editable, and 
observe that you cannot make changes.


9. Save the page.


Figure 6 Page From Template category in the New 
Document dialog box


Editing a template
You can edit a template at any time, even if you have created pages based on the template.


To edit a template:


1. Select Window > Assets.


The Assets panel opens.


2. Click the Templates button on the left side of the panel 
(Figure 7).


A list of the templates for your site appears in the lower 
pane. The upper pane displays a preview of the selected 
template. (You may need to scroll the preview pane to see 
this.)


3. Select the template you wish to edit and do one of the 
following:


• Double-click the name of the template.


• Click the Edit button at the bottom of the panel 
(Figure 7).


4. Edit the template in the Document window, changing 
non-editable elements or creating editable regions in the 
template as desired.


Figure 7 Assets panel


Templates Edit Delete

© 2012 Adobe Systems Incorporated How to use templates 3







Project 3 guide Adobe Dreamweaver CS6


4


5. Save the edited template by choosing File > Save.


The Update Template Files dialog box opens, with a list 
of the documents based on your template (Figure 8).


6. Click Update to update the documents based on the 
changes you made in your template.


The Update Pages dialog box displays a summary of the 
updates performed (Figure 9). You may need to select 
Show log to view the Status information.


7. Click Close.


Figure 8 Update Template Files dialog box


Figure 9 Update Pages dialog box


Deleting a template


To delete a template:


1. Select the template in the Assets panel.


2. Click the Delete button (trash can icon) at the bottom of 
the panel and confirm that you want to delete the 
template (Figure 7).


The template file is deleted from your site.


Documents that were based on a template you have 
deleted retain the structure and editable regions the 
template file had before you deleted it. To turn such a 
document into a normal HTML file without editable or 
locked regions, you must detach it from the template.


Detaching from a template
To remove the template structure and constraints from a document based on a template, you can detach the document 
from the template. When a document is detached from its template, you can edit any element, including the regions 
that were previously locked.


To detach a file from a template


1. To detach a document from a template, open the 
document.


2. Select Modify > Templates > Detach From Template.

How to use templates © 2012 Adobe Systems Incorporated
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Project 5


Interactive games
Timing: 23 to 30 hours


Project overview


In this project, students, working in teams, begin using Adobe Flash Professional CS6 to create a simple 
interactive game with basic ActionScript 3.0. When the games are complete, the class will hold a game 
fair, with each team presenting a game. Students discover ways to use rich media and animation created 
with Flash for gaming. They develop skills evaluating effective uses of Flash on the web and in gaming, 
learn about game design, and design and build an interactive game.


The focus of this project is building Flash skills, understanding how professionals use those skills to 
strengthen communication with interaction and animation, and using Flash to create an interactive 
experience.


Student product: Interactive game


Note: Portions of the Interactive games project align to the Adobe Certified Associate, Rich Media 
Communication objectives. Within the instruction steps and technical guides, the specific learning 
objectives for the exam are referenced with the following format: 1.1  


Project objectives


At the completion of the project, students will have developed the following skills:


Project management skills


• Determining game purpose, audience, and goal


• Determining available resources and skill level 
for game development


• Writing a proposal for the game, with attention 
to scenarios and audience characterization


Design skills


• Designing a custom experience


• Making screen sketches for interactive 
experiences


Research and communication skills


• Researching, evaluating and analyzing the use 
of Flash in online gaming


• Evaluating and analyzing various game types


• Researching audience and overall gaming 
landscape


• Researching currently available games


• Researching appropriate uses of multimedia in 
gaming


• Assessing team’s technological developer skill 
level 


• Connecting goals of the game with user 
interaction and experience


• Communicating and presenting design 
decisions


• Critiquing designs


• Communicating purpose and goals


• Writing scripts for a game narrative


Technical skills


Flash


• Understanding the Flash workspace


• Using drawing tools 


• Working with layers


• Organizing layers and libraries
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• Using animation methods


• Creating interactive buttons


• Working with bitmaps


• Using basic ActionScript


• Using animation methods


• Creating and modifying text


• Creating Timeline effects


• Creating transparent buttons


• Saving and using motion presets


• Publishing Flash documents


Project materials
• Adobe Flash Professional CS6 installed on all 


machines


• Flash guide: Overview of the Adobe Flash 
Professional CS6 workspace


• Electronic file: sample_animated_face.fla


• Electronic file: sample_animated_face.swf


• Presentation: Introduction to Flash animation


• Guide and worksheet: How to analyze Flash 
content


• Presentation: Introduction to game design


• Guide: Introduction to game design


• Worksheet: Game design planning document


• Flash guide: Understanding Flash graphic file 
types


• Flash guide: How to draw and create shapes


• Flash guide: How to apply colors and gradients


• Flash guide: How to create masks


• Electronic file: mask_sample.fla


• Electronic file: mask_sample.swf


• Flash guide: How to organize content


• Flash guide: Symbols, instances, and the 
Library


• Flash guide: How to create a button symbol


• Flash guide: How to use transparent or 
invisible buttons


• Flash guide: How to use rulers and guides


• Flash guide: Understanding frames and 
keyframes


• Flash guide: How to create animations


• Flash guide: How to ease tweens


• Flash guide: How to use a motion guide with a 
motion tween animation


• Flash guide: How to create character 
animations


• Flash guide: How to use sprite sheets


• Electronic file: path_anim_sample.fla


• Electronic file: path_anim_sample.swf


• Electronic file: ease_sample_classic.fla


• Electronic file: ease_sample_classic.swf


• Electronic file: ease_sample_motion.fla


• Electronic file: ease_sample_motion.swf


• Electronic file: character_anim_sample.fla


• Electronic file: character_anim_sample.swf


• Flash guide: How to get started with 
ActionScript


• Flash guide: ActionScript for basic gaming


• Flash guide: How to publish a Flash document


• Flash guide: How to work with text


• Guide: Peer review


• Guide: Review and redesign


Background preparation resources
• Technical and content information


• Key terms


• ISTE NETS*S Standard for Students


• Adobe Certified Associate, Rich Media Communication objectives
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Project steps


1. Introduce students to the goals of the project.


• Introduce Flash animation principles.


• Analyze uses of Flash.


• Analyze existing games and introduce game design principles.


• Design a simple Flash-based game.


• Create and test a Flash-based game.


• Publish and present a game in a game fair.


Analyzing Flash
(Suggested time: 150–250 minutes)


2. Show students websites that use Flash elements. Discuss how designers use Flash to enhance the user 
experience. Some elements to discuss include:


• Navigation systems


• Integrated user interface


• Animated screen elements


• Rich media


• Interactive games


Note: Rich media consists of a combination of graphics with video, audio, or animation. 


3. Discuss the purposes for implementing content as rich media.1.2, 2.1 You might include the following:


• Incorporating audio and video


• Providing transitions


• Providing consistency


• Illustrating change over time


• Getting multiple layers of information from one part of the display


• Enriching graphics representations


• Visualizing three-dimensional structures


• Attracting attention


4. Introduce students to the interface, terminology, and basic panels in Flash. You may want to use the 
sample_animated_face.fla file to explain the following elements:


• Flash document: Where you create your Flash content. You save a Flash document as a file with a 
.fla extension. When you open Flash, the Welcome screen gives you a choice of Flash file formats: 
ActionScript 3.0, ActionScript 2.0, AIR, AIR for Android, AIR for iOS, and Flash Lite 4. The 
format you choose depends on the platform on which you plan to publish your Flash movie. 
Demonstrate and discuss document properties and settings (and how to change the document 
properties within the Properties panel and Document Settings dialog box).3.7


• Workspaces: Use preset and custom workspaces. Demonstrate how to access a preset workspace 
and how to create, modify, and delete custom workspaces.3.1 
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• Tools panel: Tools for drawing, painting, writing, selecting, moving, modifying, viewing, and 
coloring. 


• Panels: Additional tools for modifying and creating objects. Demonstrate various ways to open, 
close, expand, and collapse panels.


• Properties panel: Set or change the most commonly used attributes of objects in a Flash document 
in the Properties panel.


• Stage: Compose the content of a Flash document on the Stage. Discuss the Stage size and its 
relationship to screen resolution. 


• Timeline: Organize and control the content of a Flash document over time, using layers and 
frames. Discuss how the Timeline is used in animation and how to preview a document.3.3


• Edit bar: Indicates the current scene. On the right side, you can select the scene to open on the 
Stage or change the magnification for viewing the Stage.


• Library: Store and organize symbols in the Library.4.7


• Movie: A published Flash document. Explain the difference between FLA files and SWF files.3.7


• XFL file: XFL is an XML representation of a FLA document. It is a declarative file format. In 
Flash Professional CS6, a document uses the .fla extension but functions more like a container of 
compressed files (much like a ZIP file). It contains all of the individual files that make up the 
project, offering improved cross-product integration and workflow productivity.3.7


• Extensible Metadata Platform (XMP): You can include XMP data such as title, author, description, 
copyright, and more in your FLA files. XMP is a metadata format that certain other Adobe 
applications can understand. Embedding XMP data in your Flash document improves the ability of 
web-based search engines to return meaningful search results for Flash content.3.7


Flash guide: Overview of the Adobe Flash Professional CS6 workspace 3.1, 3.2, 3.3, 3.4, 4.2


Electronic file: sample_animated_face.fla


Electronic file: sample_animated_face.swf


5. Using the presentation, introduce students to the principles of Flash animation. You may want to use 
the sample_animated_face.fla file to explain and demonstrate the following elements:


• Frame: A single picture in a series that form the content of a Flash document. Discuss the frame 
rate and timing and the effect of frame rate on file size. The default frame rate in Flash is 24 frames 
per second. You may want to change the frame rate to show students its effect on an animation.3.3


• Keyframe: A frame where a new symbol instance appears in the Timeline. A keyframe can also be 
a frame in which you define a change to an object’s properties for a classic tween animation. 
Keyframes can also include ActionScript code to control some aspect of your document.


• Property keyframe: A frame in which you define a change to an object’s properties for an 
animation. Discuss the differences between keyframes, property keyframes, and regular frames.


• Layers: Where you organize the various content elements in a Flash document. Discuss and 
demonstrate how non-symbol shapes merge when you place one over the other in the same layer. 
Demonstrate how to add, delete, rename, and organize layers and how to lock and unlock layers to 
protect objects.3.3


• Scene: Each document can contain multiple scenes, each with its own Timeline and Stage. Scenes 
can be placed within other scenes. 


• Symbol: An element stored in a library for reuse in a Flash document. Discuss the editing modes, 
such as editing an object on the Stage versus editing a symbol.
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• Instance: A copy of a symbol when it is on the Stage. Each instance references the complete 
information stored in the corresponding library symbol, without duplicating that information. 
Using instances minimizes the file size of a Flash movie.3.8


• Tweens: An animation created by specifying a value for an object property in one frame and 
another value for that same property in another frame. 


• Motion tweening: An automated way to create smooth movement and changes over time.


• Motion guide: A way to move an object along an editable and defined path. 


• Classic tweening: A more complex form of creating smooth movement and changes over time. 
Classic tweening provides certain capabilities that motion tweening does not.


• Shape tweening: An automated way to create shape changes over time.


• Inverse kinematics: A method for animating an object or set of objects in relation to each other by 
using an articulated structure of bones. 


• Sounds: Music loops or sound effects that play during the movie or are triggered by an action.


• Actions: ActionScript statements that control an object or the Timeline when a movie is played.


Presentation: Introduction to Flash animation 2.1, 4.7, 4.10, 4.11


6. Ask students to open one or more websites, or other Flash content, to illustrate a variety of Flash 
techniques. (Alternatively, you could open such sites on the teacher workstation.) As a class, identify 
the following Flash techniques on the websites:


• Motion tweens


• Shape tweens


• Movie clips


• Buttons


• Sound (number of sounds used, number of times a sound is looped)


• Stop actions


• Go to and play actions


• Combinations of symbols (such as buttons that contain animated movie clips)


Guide and worksheet: How to analyze Flash content 1.1, 1.2


Game design
(Suggested time: 100–150 minutes)


7. Introduce and discuss game design. Explain that game design determines every detail of how the game 
will function, what win or loss criteria the game may include, how the user will be able to control the 
game, what information the game will communicate, and how hard the game will be. Some things to 
discuss include:


• Input: How the user controls the game (keyboard, mouse, gestures on mobile devices)


• Game elements: The visual elements on the screen, such as a spaceship in a flying game


• Sounds: How sounds can be used to enhance the game-playing experience


• Game play (also called game mechanics): The interactivity of the game and the choices a player 
(or players) are able to make and what happens when they make each choice


Presentation: Introduction to game design


Guide: Introduction to game design
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8. Show students both simple and complex games built with Flash. Discuss the type of game (for 
example, action or puzzle), the overall game design, the game rules, and the types or combinations of 


techniques that might be involved to create some of the more complicated effects they see.2.1


• Newgrounds games: www.newgrounds.com/games 


• Addicting games: www.AddictingGames.com/ 


• Jumpman: www.maximized.co.uk/tutorials/games/jumpman/ 


• Escape the Room: www.ictlic.eq.edu.au/begintheadventure/etrgame1.html


9. Explain a typical game design workflow 1.5 and how it is similar to the phases of website production: 


• Plan and design: Brainstorm an idea for your game with game-design planning documents, 
wireframes, design comps, storyboards, and so on.


• Develop: Combine your visual and audio assets in desired programming language (in this case, 
ActionScript 3.0).


• Test and optimize: Test your game to be sure it’s bug-free and fun to play. Improve the 
performance through optimization.


• Monetize and distribute: Determine how to get your game to your audience by offering free games 
or games that cost money to play. For Flash-based games, deploy via Flash Player and/or Adobe 
AIR. Games can be distributed through app stores, on the Internet, or through retail stores.


• Use analytics and update: Study the results of usability tests, user feedback, and such metrics as 
game plays, duration of game play, and more to improve on the game’s weaknesses. Continually 
try to polish your game and provide a better experience for the game players.


10. Explain that for this project they will be starting with very simple games with a small number of game 
plays, similar to the Jumpman and Escape the Room games you reviewed. Explain they can choose 
between a drag-and-drop or simple character-movement game and will use the included technical 
guides to customize their characters, game settings, and parameters.


11. Divide your students into teams of two or three and allow them time to brainstorm their game ideas, 
reminding them of the parameters. When they are happy with their ideas, ask them to complete their 
game design documents. Explain that each team will submit their planning documents to you for 
approval. 


Worksheet: Game design planning document 1.5, 2.4


Creating a game
(Suggested time: 450–550 minutes)


12. After you have approved each team’s game-design planning documents, explain that students will now 
learn about graphics in Flash, which will become the component assets for the game they will build. 
Review the kinds of graphics files available in Flash. Discuss and demonstrate the following: 


• The difference between bitmap images and vector images in Flash


• The definition of shape in Flash


• Drawing tools, such as shapes, lines, and brushes


• Selection tools, such as marquee, lasso, and magic wand


Flash guide: Understanding Flash graphic file types 4.2, 4.3


Flash guide: How to draw and create shapes 4.2
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13. Using the “I do, we do, you do” method, demonstrate the following skills to help them refine their 
graphics. You can use the mask_sample.fla file to illustrate these skills: 


• How to work with colors and gradients 4.2


• How to break graphics apart 3.8, 4.3


• How to trace and swap bitmaps 4.3


• How to use adaptive scaling


• How to create a masking effect 4.9


Flash guide: How to apply colors and gradients 4.2


Flash guide: How to create masks 4.9


Electronic file: mask_sample.fla


Electronic file: mask_sample.swf


14. Allow each student group time to develop the necessary graphics for their games, including characters. 


15. Introduce symbols, instances, and the Library to help your students organize their projects. 
Demonstrate how to organize content with the Library, layers, and labeling. Ask students to add assets 
to their library and demonstrate how to move assets between the Stage and the Library.


Flash guide: How to organize content 2.5, 3.3, 4.7, 4.10


Flash guide: Symbols, instances, and the Library 4.6, 4.7


16. Demonstrate how to turn graphics into buttons, symbols, instances, and movie clips. Remind them to 
create new layers and labels for each graphics symbol and instance. 


Flash guide: How to create a button symbol 4.6, 4.7, 4.8


Flash guide: How to use transparent or invisible buttons 4.6


17. Demonstrate how teams can use guides and rulers to help place their graphics on the Stage where they 
want them to be to achieve the overall game look. 


Flash guide: How to use rulers and guides 3.5


18. Introduce masking, path animation, eases, and character animation by showing students some sites that 
use these specific techniques, such as the following simple Flash games: 


• Games in a Flash – Galactic Goobers: www.gamesinaflash.com/game/Invasion-of-the-Galactic-
Goobers.html.  


• PBS Kids show Fetch! Face-Off game: http://pbskids.org/fetch/games/faceoff/game.html 


• PBS Kids show Caillou Dinosaur game: http://pbskids.org/caillou/immersivegames/?gameID=4


• Visionlearning’s Three States of Matter: http://web.visionlearning.com/custom/chemistry/
animations/CHE1.1-an-threestates.shtml
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19. As you go through the games in the previous step, point out the animation techniques used in each 
game (drag-and-drop, shooting, jumping, timing, and so on). Additionally, to introduce basic 
animation skills, discuss and demonstrate Flash animation techniques by using the electronic files:  


Flash guide: Understanding frames and keyframes 4.10


Flash guide: How to create animations 3.6, 4.10


Flash guide: How to ease tweens 3.6, 4.10


Flash guide: How to use a motion guide with a motion tween animation 4.10


Flash guide: How to create character animations 4.10


Flash guide: How to use sprite sheets


Electronic file: path_anim_sample.fla


Electronic file: path_anim_sample.swf


Electronic file: ease_sample_classic.fla


Electronic file: ease_sample_classis.swf


Electronic file: ease_sample_motion.fla


Electronic file: ease_sample_motion.swf


Electronic file: character_anim_sample.fla


Electronic file: character_anim_sample.swf


Note: If students are preparing for the Adobe Certified Associate, Rich Media Communication exam, 
their games should include an animated character so they learn how to use the Bone tool for inverse 
kinematics animations.


20. Tell students they will now animate their graphics. Explain the following, depending on the type of 
games they create: 


• For a drag-and-drop game, students can decide to animate any of the movable items. For example, 
if they have a face, they can animate the eyes, nose, and mouth.


• For a simple character-movement game, they can animate jumping, climbing, or other movements. 


• For all games, they can animate the background so it scrolls through the same or multiple scenes. 


21. Now that they have created their graphics and animations, explain they will learn about ActionScript 
so they can add interactivity to their games. Using the “I do, we do, you do” method, introduce 
students to the basic concepts of using ActionScript. Explain how to use the Code Snippets panel to 
quickly apply ActionScript code to control Timeline navigation, actions, animation, audio/video 
playback, event handling, and loading and unloading assets. Following are some key terms you might 
want to define as you step students through this process:


• class


• object


• property


• variable


• method


• function
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• event


• code snippet


Flash guide: How to get started with ActionScript 4.11


22. Building on the basic concepts of ActionScript, discuss and demonstrate some basic game features 
students can create by using ActionScript. As you go through the game features, have students identify 
how functions, event handlers, and listeners are used in the following examples: 


• How to give a button an action such as stop or play again


• How to drag and drop items


• How to add point scoring


• How to add character movement


• How to move objects across the screen


• How to create a timer


Flash guide: ActionScript for basic gaming 4.11


23. Allow each team time to add ActionScript to their games. 


Testing a game
(Suggested time: 250–350 minutes)


24. Once the teams have created the initial version of their games, pair teams and have them check each 


other’s FLA files. They should test and discuss the following: 5.1


• Select each keyframe and property keyframe and determine if more than one object is highlighted 
on the Stage. (Objects should be on separate layers if they are to be animated.)


• Select each keyframe and property keyframe and determine if an object is a shape or a symbol and 
if the correct type of tween has been applied. (Motion tweens animate symbols; shape tweens 
animate shapes.)


• In turn, select each keyframe and property keyframe along the Timeline and make sure the object 
is in the expected location on the Stage based on the point in the movie.


• Test the game against the game specifications outlined in the game-design planning document.


Note: Inform students that these techniques for checking that they have clean Flash documents will 
help later when they are looking for errors in more complex movies.


25. Once students have tested the FLA files, demonstrate how to set publishing settings and how to publish 
a preview of the game. Ask students to test their game previews to find any problems and revise the 
ActionScript as necessary. 


Flash guide: How to publish a Flash document 4.14, 5.1


26. Allow students time to revise their games as necessary, testing their games after each revision to make 
sure any problems have been solved.
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27. Once the game functions properly, explain that they will now create the opening screens for their 
games, including instructions and a play button. Explain they are doing this now so they don’t have to 
move through it each time they test the game, which could be frustrating. Using the “I do, we do, you 
do” method, demonstrate how to work with text in Flash. 


Flash guide: How to work with text 4.4, 4.5


28. Pair teams once again and have them conduct peer reviews of each other’s games. Then allow teams 
time to review and redesign aspects of their games. 


Guide: Peer review 1.6


Guide: Review and redesign


29. Have each team test their game by playing the movie and seeing if it is getting stuck anywhere. If they 
are getting stuck, make sure they review keyframes, instance names, and ActionScript.


Publishing and presenting a game
(Suggested time: 200–250 minutes)


30. Once each team has a properly functioning game, demonstrate how to publish their games as SWF 
files or as desktop AIR applications. 


Flash guide: How to publish a Flash document 4.14, 5.1


31. Explain that each team will create a booth for a class-wide game fair. Ask each team to create a basic 
poster advertising their game. Encourage students to reuse graphics from their games for their game 
posters.


32. Select a class period and ask each team to set up a game fair booth with their poster. Explain that teams 
can play each other’s games, taking notes on the games to provide feedback. 


33. After the game fair, ask students to share feedback on the games they played. Remind them to be 
respectful in their critiques. 


Guide: Peer review







© 2012 Adobe Systems Incorporated Interactive games 11


Extension activities


You can extend the project in the following ways:


• Technical Help in the Classroom: To encourage students to develop self-sufficiency, you can assign a 
small group or pair of students to research challenging skills and present their findings to the class. Ask 
them to define key terms (such as optimization) and to explain the relevance of these terms to the task 
at hand. Then ask students to give a three- to five-minute oral report at the beginning of class, 
demonstrating the skill and reporting their findings.


• Great uses of Flash: Ask students to look on the web for sites with Flash elements that inspire them. 
They should write brief descriptions of impressive elements and how they think these elements were 
created in Flash.


• School game fair: In addition to, or instead of, a classroom game fair, conduct a school-wide game fair 
where students and parents can come on a dedicated day or night to learn about and play student-
created games. 


• Fast finishers: For students who finish early, ask them to redesign and develop their games for one or 
more mobile devices.


• Design for a client: Have students design a game for a client, such as a school sports team, teacher, or 
group, where they pitch their game-design planning documents to a client or panel. 


• Interview: To help students better understand the game-design process, have students interview a game 
designer about the planning process.


• Collaborative assessment: Co-develop a rubric with your students during the design phase to be used 
for peer feedback and to promote discussion about game design and the importance of individual 
elements in the whole game. While developing the rubric, discuss and explore the essential features 
and elements of a successful game and the importance of each element of the game and how they work 
together. For example, when designing the rubric, a student may suggest that high-quality graphics are 
the most important thing in creating an excellent game. This could lead to discussions about whether a 
game can still be a great game with lower quality graphics but quality game play.


Assessment
• Project rubric


Background preparation resources
• Review the student step-by-step guides referenced in this project.


• To view video tutorials aligned with the skills required to complete this project, visit the Digital Design 
CS6 show on Adobe TV: http://tv.adobe.com/show/digital-design-cs6/


• For more teaching and learning resources on teaching game design, Flash, and other topics in this 
project, search for resources from the community on the Adobe Education Exchange: 
http://edexchange.adobe.com


• For an overview of the interface and for more information on the technical aspects of Flash, see Flash 
Help. 


• Review Adobe TV – ActionScript 101: http://tv.adobe.com/show/actionscript-11-with-doug-winnie/


• Access tutorials, articles, and other resources in the Flash developer center: 
www.adobe.com/devnet/flash/


• Visit the Flash Classroom – resources and tutorials for using Flash in the Primary/Secondary 
classroom: www.flashclassroom.com/
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• On the Maximized website, study tutorials for teaching animation and game development: 
http://maximized.co.uk/tutorials/


• Review principles of animation by Colin Maxwell: http://edexchange.adobe.com/posts/ef9de768bc


• See the Flash Showcase: www.adobe.com/cfusion/showcase/index.cfm?event=finder&


• Examples of masking and path animations; search for “mask effects” and “motion path”: 
www.flashkit.com


Game design


• Adobe Developer Connection – Game Development: www.adobe.com/devnet/games.edu.html


• Flash Game Development by Example: www.flashgamedevbook.com/


• Adobe Education Exchange – Jumpman game and tutorial by Colin Maxwell: 
http://edexchange.adobe.com/posts/a9a2119df5


• Adobe Education Exchange – Escape the Room game and tutorial by Kristine Kopelke: 
http://edexchange.adobe.com/posts/6c222552c7


• Adobe Education Exchange – First Steps in Flash Mobile Development tutorial by Kristine Kopelke: 
http://edexchange.adobe.com/posts/bc6739d213


Key terms
• ActionScript


• animation


• class


• code snippet


• event handling


• frame


• function


• game design


• game play


• graphic


• input


• instance


• inverse kinematics


• keyframe


• method


• object


• property


• scene


• symbol


• tween


• variable
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ISTE NETS*S Standard for Students


This project is aligned to the ISTE NETS*S Technology Standards. Depending on the subject and content 
area the student selects you may research your own state content standards to see how this project aligns to 
your state requirements.


ISTE NETS*S: Curriculum and Content Area Standards – NETS for Students


1. Creativity and Innovation


Students demonstrate creative thinking, construct knowledge, and develop innovative products and 
processes using technology. Students:


a. apply existing knowledge to generate new ideas, products, or processes.


b. create original works as a means of personal or group expression.


2. Communication and Collaboration


Students use digital media and environments to communicate and work collaboratively, including at a 
distance, to support individual learning and contribute to the learning of others. Students:


a. interact, collaborate, and publish with peers, experts or others employing a variety of digital 
environments and media.


d. contribute to project teams to produce original works or solve problems.


3. Research and Information Retrieval


Students apply digital tools to gather, evaluate, and use information. Students:


b. locate, organize, analyze, evaluate, synthesize, and ethically use information from a variety of 
sources and media. 


c. evaluate and select information sources and digital tools based on the appropriateness to specific 
tasks.


4. Critical Thinking and Problem Solving


Students use critical thinking skills to plan and conduct research, manage projects, solve problems and 
make informed decisions using appropriate digital tools and resources. Students::


b. plan and manage activities to develop a solution or complete a project.


d. use multiple processes and diverse perspectives to explore alternative solutions.


5. Digital Citizenship


Students understand human, cultural, and societal issues related to technology and practice legal and 
ethical behavior. Students:


b. exhibit a positive attitude toward using technology that supports collaboration, learning, and 
productivity.


6. Technology Operations and Concepts


Students demonstrate a sound understanding of technology concepts, systems, and operations. 
Students:


a. understand and use technology systems.


b. select and use applications effectively and productively.
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Adobe Certified Associate, Rich Media Communication objectives


1.1 Identify the purpose, audience, and audience needs for rich media content.


1.2 Identify rich media content that is relevant to the purpose of the media in which it will be used 
(websites, mobile devices, and so on).


1.5 Understand project management tasks and responsibilities.


1.6 Communicate with others (such as peers and clients) about design and content plans.


2.1 Identify general and Flash-specific best practices for designing rich media content for the web, mobile 
apps, and AIR applications.


2.4 Use a storyboard to design rich media elements.


2.5 Organize a Flash document.


3.1 Identify elements of the Flash interface.


3.2 Use the Property inspector.


3.3 Use the Timeline.


3.4 Adjust document properties.


3.5 Use Flash guides and rulers.


3.6 Use the Motion Editor.


3.7 Understand Flash file types. 


3.8 Identify best practices for managing file size of a published Flash document.


4.2 Use tools on the Tools panel to select, create, and manipulate graphics and text.


4.3 Import and modify graphics.


4.4 Create text. 


4.5 Adjust text properties. 


4.6 Create objects and convert them to symbols, including graphics, movie clips, and buttons.


4.7 Understand symbols and the Library.


4.8 Edit symbols and instances.


4.9 Create masks.


4.10 Create animations (changes in shape, position, size, color, and transparency).


4.11 Add simple controls through ActionScript 3.0.


4.14 Publish and export Flash documents. 


5.1 Conduct basic technical tests.
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Assessment


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations


Analyzing 
Flash


Absent or incomplete. Students research rich 
media sites and can 
identify animation 
techniques. Students 
understand when the use of 
rich media elements is 
effective, especially for 
gaming.


Students research rich 
media sites and can 
identify animation 
techniques. Students 
understand and can clearly 
articulate when the use of 
rich media elements is 
effective and can identify 
when these elements are 
not effective, especially for 
gaming.


Game design 
planning 
document


Absent or incomplete. Students create game-
design planning documents 
that identify audience and 
goals of a drag-and-drop or 
character-movement game. 
The document describes 
game elements, rules of 
play, and game narrative. 
The document includes 
sketches of the game 
environment and a logical 
storyboard. Students 
identify technical 
considerations and game 
object symbols.


Students create game-
design planning documents 
that provide detailed 
information on the 
audience and goals of a 
drag-and-drop or 
character-movement game. 
The document describes 
game elements, rules of 
play, and game narrative. 
The documents include 
detailed sketches of the 
game environment and a 
clear and logical 
storyboard. Students 
carefully identify all 
technical considerations 
and game object symbols.


Game assets Absent or incomplete. Students create necessary 
game graphics. Students 
determine the correct file 
type for graphics. Students 
create graphics that use a 
combination of drawing, 
shapes, color, and masking 
techniques. All necessary 
graphics are turned into 
symbols with instance 
names.


Students employ design 
principles to create all 
game graphics. Students 
determine the correct file 
type for graphics. Students 
create graphics that use a 
combination of drawing, 
shapes, color, and masking 
techniques. All necessary 
graphics are turned into 
symbols with appropriate 
instance names.                                                                                                                                                                                                             
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Drag-and-
drop Flash 
game


Absent or incomplete. The drag-and-drop Flash 
game has clear audience, 
goals, rules, and outcomes. 
The game includes an 
introductory screen with a 
play button, a pause and 
stop button, a play again 
button, and five drag-and-
drop objects. 


The drag-and-drop Flash 
game has clearly defined 
audience, goals, rules, and 
outcomes. The game play 
and rules are intuitive and 
fun. The game includes a 
well-written introductory 
screen with a play button, a 
pause and stop button, a 
play again button, and six 
or more drag-and-drop 
objects. The game includes 
one or more optional 
features, such as scoring, 
timer, multiple players, or 
bonus features such as 
extra points or time. 


Character-
movement 
Flash game


Absent or incomplete. The character-movement 
Flash game has clear 
audience, goals, rules and 
outcomes. The game 
includes an introductory 
screen with a play button, a 
pause and stop button, and 
a play again button. The 
game character navigates a 
course and needs to jump, 
climb, or avoid objects. 


The character-movement 
Flash game has clearly 
defined audience, goals, 
rules and outcomes. The 
game play and rules are 
intuitive and fun. The 
game includes a well-
written introductory screen 
with a play button, a pause 
and stop button, and a play 
again button. The game 
character navigates a 
course and needs to jump, 
climb, or avoid objects. 
The game includes one or 
more optional features, 
such as scoring, timer, 
multiple players, or bonus 
features such as extra 
points, time, or lives. 


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations
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Adobe Photoshop CS6 Project 1 guide

How to resize, rotate, and crop images
You will frequently want to resize and crop an image after opening it in Photoshop from a digital camera or scanner. 
Cropping means cutting some parts of the image away so only the parts you want remain.


Backing up your original
Before making any changes to an image, you should always save the image with a new filename. You will have the 
most flexibility if you save it as a PSD—Photoshop’s native format. You can generate TIFFs (for print) and JPEGs 
(for the web) from a single PSD file. For example, PSD files preserve layers, so the layers are available when you 
reopen the file.


Resizing images
When working in Photoshop, it is generally best to leave your image at as high a resolution as possible to allow for 
greater flexibility when generating images.


About pixel dimensions and resolution


The pixel dimensions (image size or height and width) of a bitmap image is a measure of the number of pixels along 
an image’s width and height. Resolution is the fineness of detail in a bitmap image and is measured in pixels per inch 
(ppi). The more pixels per inch, the greater the resolution. Generally, an image with a higher resolution produces a 
better printed image quality.


• For images to print well, they generally should have a resolution of 300 ppi.


• For most web pages, you can safely save images at 72 ppi. Because most monitors do not display resolutions 
higher than this, you can reduce file size by reducing resolution.


Note: Monitor technology and Internet connection speeds are continually evolving. However, the 72-ppi standard 
continues to be widely used, and for the most part, you can’t go wrong with it.


The combination of pixel dimension and resolution determines the amount of image data. Unless an image is 
resampled, the amount of image data remains the same as you change either the pixel dimension or resolution. If you 
change the resolution of a file, its width and height change accordingly to maintain the same amount of image data. 
And, vice versa. 
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In Photoshop, you can see the relationship between image size and resolution in the Image Size dialog box 
(Figure 1). 


To change resolution of an image:


Changing an image’s resolution affects not only its on-screen 
size but also its image quality and its printed characteristics.


1. Open an image in Photoshop.


2. Save the image with a new name.


This step preserves the original image in case you want to 
revert to it. You should always make a copy of the 
original before making changes.


3. Choose Image > Image Size.


The Image Size dialog box opens (Figure 1).


Notice that the dialog box lists two major categories of 
information about the size of the image.


• Pixel Dimensions refers to the actual number of 
pixels contained in the image. The number of pixels 
represents the amount of data in the image. Unless 
you select the Resample Image option, number of 
pixels remains the same as you resize and change the 
resolution of the image.


• Document Size refers to how the document appears 
when printed. Document size is also a starting point 
for how the document will appear in another 
document, such as an InDesign file. In later projects, 
you will place Photoshop images in InDesign files.


4. Make sure the Resample Image option is not selected.


The Resample option changes the amount of data or 
information in the image as you resize. For now, it’s best 
to leave this option deselected. 


Note: You can use resampling to make enlargements. 
However, because resampling can only estimate pixels, it 
is best to use a picture with a larger resolution in the first 
place.


5. Change the Resolution value.


Observe that the other two numbers for width and height 
change accordingly. For example, suppose an image set 
at 300 dpi measures approximately 13 by 9 inches. The 
same image when set to 72 dpi measures approximately 
54 by 36 inches (Figure 2). 


6. Click OK to close the Image Size dialog box.


Figure 1 Image Size dialog box with resolution at 
300 dpi


Figure 2 Image Size dialog box with resolution 
changed to 72 ppi
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Reducing an image’s size (pixel dimensions)


Although you will often want to keep pixel information, sometimes you need to reduce the total (pixel) size of an 
image. This step removes pixels and reduces file size. You will usually do this when preparing the image for the web 
or other electronic medium; for print, you will generally want to simply change the document’s size. (Of course, you 
may want to reduce file size for other reasons, such as to preserve hard disk space or to speed up image rendering.)


To reduce an image’s pixel dimensions:


1. Choose Image > Image Size.


The Image Size dialog box opens (Figure 3).


In the previous steps you attended only to the resolution, 
or document size of the image. This time you will ignore 
that area and focus on the pixel dimensions.


2. Select the Resample Image option near the bottom of the 
dialog box. 


Observe that the Pixel Dimensions menus and the 
Constrain Proportions option become active.


This option automatically changes the width as you 
change the height, and vice versa. For example, if you 
start with an image of 2000-pixel width and 1000-pixel 
height (a 2:1 width/height ratio) and change the width to 
1000 pixels, the height automatically changes to 500 
pixels when Constrain Proportions is checked. Generally, 
selecting this option is a good idea.


Note: You can ignore Scale Styles for now. This option 
comes into play only when you have styles applied to 
layers.


3. Choose Bicubic Sharper from the Resample Image menu. 


This option is best for reductions.


4. In the Pixel Dimensions Width box, enter the desired 
width in pixels.


You can also choose a percentage by changing the unit 
beside the Width box from Pixels to Percent.


5. Click OK to change the image’s pixel dimensions.


Note: After the size reduction, you should apply the 
Unsharp Mask filter to the image by choosing Filter > 
Sharpen > Unsharp Mask. This will clear up any 
blurriness that results from the reduction.


Figure 3 Image Size dialog box
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Rotating images
There may be times when you open an image in Photoshop to find that it is not in its proper orientation. Alternatively, 
a photograph that you have taken is just a little bit crooked. There are easy ways to fix both of these situations.


To rotate an image:


The Image Rotation commands let you rotate or flip an entire 
image. The commands do not work on individual layers or 
parts of layers, paths, or selection borders. If you want to 
rotate a selection or layer, use the Transform or Free 
Transform commands.


1. Choose Image > Image Rotation (Figure 4), and choose 
one of the following commands from the submenu:


• 180° Rotates the image by a half-turn.


• 90° CW Rotates the image clockwise by a quarter-
turn.


• 90° CCW Rotates the image counterclockwise by a 
quarter-turn.


• Arbitrary Rotates the image by the angle you 
specify. If you choose this option, enter an angle 
between 0 and 359.99 in the Angle text box. Select 
°CW or °CCW to rotate clockwise or 
counterclockwise. Then click OK.


2. Choose File > Save to save the rotated image. 
Figure 4 The Image Rotation submenu


Cropping Images
You’ll often take pictures that are larger than you need, or you'll want to reframe an image to remove unnecessary 
parts. Taking pictures that are larger than you need, at as high a resolution as possible, gives you flexibility in 
selecting parts of an image to crop. Cropping is the process of removing portions of an image to create focus or 
strengthen the composition. 


You can crop an image in Photoshop by selecting an area with one of the selection tools and using the Image > Crop 
command. The Crop tool in the Tools panel provides additional options for cropping images. You can use the Crop 
tool to select an area to crop, or set the Crop tool to trim an image to a specified aspect ratio. This guide covers how 
to use the Crop tool.


Grid overlays


A variety of grids for overlaying an image you are cropping are available from the View menu in the Options bar. The 
Rule of Thirds grid, for example, illustrates a general rule of thumb in the visual arts. This grid consists of two 
equally spaced horizontal and vertical lines. Visual interest and a strengthened composition are created when objects 
are placed along (or at the intersection of) these horizontal and vertical lines. 


To crop an image by using the Crop tool:


1. Click the Crop tool in the Tools panel (Figure 5). 


The pointer changes to the Crop tool.


Figure 5 Crop tool
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2. Choose a crop option from the list of menu of preset 
aspect ratios in the Options bar (Figure 6). 


For example, you may choose Unconstrained, which 
allows you to crop an image to dimensions that you 
specify. Alternatively, you can select from a series of 
preset aspect ratios, such as Original Ratio or other 
common ratios, such as 16:9, also known as widescreen. 
If you are processing several images and want to 
maintain a specific crop size, you can save your 
customized setting by using the Save Preset option.


3. Choose an overlay grid from the View menu in the 
Options bar (Figure 7).


4. Create a marquee selection by dragging over the part of 
the image you want to keep (Figure 8). 


The selection doesn’t have to be precise—you can adjust 
it in the next step.


A Rule of Thirds grid appears.


5. If necessary, adjust the cropping selection:


• To move the selection to another position, place the 
pointer inside the bounding box and drag.


• To scale the selection, drag a handle in any of the 
corners. To constrain the proportions, hold down 
Shift as you drag a corner handle. 


• To rotate the selection, position the pointer outside 
the bounding box (the pointer becomes a curved 
arrow), and drag. To move the center point around 
which the marquee rotates, drag the circle at the 
center of the bounding box. The selection can’t be 
rotated in Bitmap mode.


6. If necessary, use the Straighten tool to correct for camera 
tilt. Click the Straighten tool in the Options bar and then 
drag along a line in the image that you want to make 
vertical or horizontal.


7. Once you are satisfied with the crop area, press Enter 
(Windows) or Return (Mac OS).


The image is trimmed to the selected region (Figure 9).


Figure 6 Menu of preset aspect ratios


Figure 7 Menu of preset View options


Figure 8 Crop area selected


Figure 9 Crop applied
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How to use sprite sheets 
In computer graphics, a sprite is a two-dimensional image or animation that is integrated into a larger scene. Sprites 
can be static objects, but are typically used for characters and other moving objects in video games. A running or 
jumping character is one example that appears in many adventure games. 


Creating and sharing sprites
You can create your own sprites by drawing original artwork in Flash or another graphic design program and then 
using the artwork to create and animate your game characters or other objects.


You can also use sprite artwork created by other graphic designers or sprite artists. People share sprites by creating 
sprite sheets. A sprite sheet is a depiction of various sprites arranged in one graphic image file (Figure 1). The 
collection of images includes the exact frames of animation for each character or object. Sprite sheets are also used to 
store tiles for tile-based games. To use the images in a sprite sheet, you can import the file into Flash and then add the 
images to a timeline to create your sprites. 


Figure 1 Sprite sheet


Note: You can also use ActionScript to import and display images in a sprite sheet. The ActionScript defines which 
sprite sheet to use and the exact coordinates of each image. The use of ActionScript to import sprite sheet images is 
beyond the scope of this guide.


If you’ve created your own sprites in Adobe Flash Professional CS6, you can export a sprite sheet that includes the 
artwork in your Flash document library. Flash creates a single bitmap image file (PNG), including a grid of the 
artwork for your sprites. You can then share that sprite sheet with other animators and game developers. 


Using a sprite sheet to create animated characters
To create a new game sprite, you import all the necessary artwork for a character or object in a single sprite sheet. 
Sprite sheets are shared as bitmap files. After importing the bitmap image, use Trace Bitmap or Break Apart to isolate 
the artwork for each frame in the animation. You can then add the artwork to a new frame-by-frame animation, or use 
different versions of the artwork as keyframes in a Flash animation tween. 
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To import a sprite sheet:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Select File > Import > Import To Library.


The Import To Library dialog box appears (Figure 2).


3. Select the sprite sheet file and click Open.


The sprite sheet graphics file is added to the Library 
panel (Figure 3). Most sprite sheets are created with a 
contrasting background color so you can trace and isolate 
the images in Flash.


Figure 2 Import To Library dialog box


Figure 3 Library panel

How to use sprite sheets © 2012 Adobe Systems Incorporated







Adobe Flash Professional CS6 Project 5 guide

To isolate the artwork for each frame in the animation:


1. Drag a copy of the sprite sheet image file from the 
Library panel to the Stage (Figure 4).


2. Select Modify > Bitmap > Trace Bitmap.


The Trace Bitmap dialog box appears (Figure 5).


3. Make sure the Color threshold is set to 100 (the default 
value) and click OK.


Flash traces the bitmap and converts the image to a 
collection of shapes. 


4. Click away from the shapes to deselect them.


5. Select the image that represents the first frame in your 
animation (Figure 6). 


Note: Depending on the color and shape of the image, it 
may consist of a single shape or multiple shapes. You can 
marquee select or use the Lasso tools to select more 
complex images and groups of shapes.


6. Convert the selected shape to a graphic symbol. Give it a 
name that describes the character or object and its 
position in the animation sequence, such as running_01.


The new symbol appears in the Library panel (Figure 7). 
You can now use this symbol as a frame in a character 
animation to create your new sprite.


7. Convert the remaining shapes to graphic symbols and 
name them sequentially in the order they will appear in 
the animation. 


When have finished, you should have a series of 
sequentially named symbols in the Library panel.


8. Delete the symbol instances that are left on the Stage. 


You will start with an empty Stage to create your sprite.


Figure 4 Sprite sheet on the Stage


Figure 5 Trace Bitmap dialog box


Figure 6 Selected image


Figure 7 New graphic symbol in the Library panel
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To use the symbol sequence to create a sprite:


1. Select Insert > New Symbol.


The Create New Symbol dialog box appears (Figure 8).


2. Name the symbol, choose Movie Clip in the Type menu, 
and click OK. 


The new movie clip symbol appears in the Library panel 
(Figure 9). 


The timeline for the new movie clip symbol appears in 
the Timeline panel. It has one blank keyframe in Layer 1.


3. Drag the first symbol in the sequence, such as 
running_01, from the Library panel to the center of the 
Stage.


4. Insert a keyframe in Frame 2 of Layer 1.


A new instance of the same symbol appears in Frame 2.


Instead of dragging each symbol to the Stage, you will 
add your keyframes first and then swap symbols to keep 
the symbols perfectly aligned from one frame to the next.


5. Add additional keyframes until the number of frames 
equals the total number of symbols in your sprite 
animation (Figure 10). 


In this example, we inserted seven keyframes to hold the 
symbols representing seven positions of a man running. 
All of the keyframes contain instances of the same 
symbol, running_01.


Figure 8 Create New Symbol dialog box


Figure 9 New movie clip in the Library panel


Figure 10 One keyframe for each symbol
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6. Click Frame 2 in the timeline, click the symbol on the 
Stage, open the Properties panel, and click Swap 
(Figure 11).


The Swap Symbol dialog box appears (Figure 12). 


7. Select the second graphic symbol in the animation 
sequence, and click OK.


The symbol in Frame 2 is now the second symbol in the 
sequence.


8. Swap the graphic symbols in the remaining frames so 
they contain the correct images at each step in the 
sequence. 


Each frame should now contain a different image.


9. Click the Play button at the bottom of the Timeline panel 
to play the animation sequence. 


The sprite moves (in this example, the man runs), but the 
animation happens quickly because each image appears 
for only a single frame. You can slow the animation by 
adding frames.


10. Click Frame 1 and press the F5 key a few times to add 
frames (Figure 13).


Note: You can also select Insert > Timeline > Frame to 
add a frame, but pressing F5 is faster when adding 
multiple frames. If you add too many frames, press 
Shift+F5 to remove frames.


11. Click each of the remaining keyframes in turn, and press 
F5 to extend the length of time you see each symbol in 
the animation (Figure 14). 


12. When you finish adjusting the timing of the animation, 
click Scene 1 above the Stage to close the movie clip 
symbol and return to the main timeline. 


13. Drag an instance of your new movie clip symbol from the 
Library panel to the empty Stage. 


14. Select Control > Test Movie > In Flash Professional to 
view the finished sprite.


15. Close the preview window.


Figure 11 Properties panel, Swap button


Figure 12 Swap Symbol dialog box


Figure 13 Added frames for the first symbol


Figure 14 Added frames for the remaining 
symbols
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Generating sprite sheets from the Flash library
You’ve seen how to use a sprite sheet to make a simple character animation sprite. Now you export images to a new 
sprite sheet you can share with others.


To generate a sprite sheet:


1. Open the Library panel and select the images to include 
in the sprite sheet.


You can hold down the Ctrl key (Windows) or Command 
key (Mac OS) to select noncontiguous images in the 
Library panel.


2. Right-click (Windows) or Control-click (Mac OS) 
anywhere in the selection, and choose Generate Sprite 
Sheet from the context menu (Figure 15).


The Generate Sprite Sheet dialog box appears.


Figure 15 Library panel context menu
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3. In the Generate Sprite Sheet dialog box, click Browse 
(Figure 16).


The Select Destination Folder dialog box appears. 


4. Navigate to the folder where you want to save the sprite 
sheet. Enter a name for the file, and click Save.


You can select a new background for the sprite sheet. 
Selecting a background that contrasts with the images 
helps isolate the images for editing or cropping.


5. Click the Background Color swatch and pick a new color 
for the background in the sprite sheet (Figure 17).


6. Click Export.


Flash generates a single PNG file that includes the 
images you selected.


Note: You can also generate a sprite sheet from a movie 
clip symbol which includes animation. When you do, 
Flash generates a sprite sheet with a sequence of images 
from the movie clip.


Figure 16 Generate Sprite Sheet dialog box


Figure 17 Background Color palette


Exporting a bitmap (PNG) sequence
You’ve seen how to use a sequence of images to create a moving-character sprite. One way to create a sequence of 
images quickly is to export a bitmap sequence in Adobe Flash Professional CS6.


To export a bitmap sequence of images:


1. Open the Library panel and right-click (Windows) or 
Control-click (Mac OS) the movie clip sequence that 
includes animation. 


In this example, we used the movie clip of the running 
man created earlier in this guide. You can also select a 
movie clip with a motion or shape tween. 


2. Select Export PNG Sequence from the context menu 
(Figure 18).


The Export PNG Sequence dialog box appears.


Figure 18 Library panel context menu
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3. Navigate to a folder where you want to save the sequence 
of images. Name the sequence and click Save.


A second Export PNG Sequence dialog box appears with 
additional settings (Figure 19).


4. Click Export.


5. Open the folder you selected to store the sequence of 
images.


Flash created a separate file for each frame in the 
animation and named them sequentially (Figure 20). 


You can share this file with others for importing into 
another Flash document and creating new sprites.


Figure 19 Export PNG Sequence dialog box


Figure 20 PNG sequence files
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Why is writing for the web different from other writing?

		Users read information online differently than information in print.

		Online readers coming to a site after an online search often don’t know if a website will meet their needs. 

		If they do not quickly find the information they are looking for, they will deem the site of little value, no matter how well it is designed or how easy to use.

		Clear, usable content can be achieved by writing for readers with varying levels of interest. A writer’s goal should be to give all readers their desired level of information as quickly as possible. 



*
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Online reading behavior

Studies have discovered the following behaviors of online users:

		They judge websites in a fraction of a second.

		They scan content, hunting for the information they’re after, as opposed to reading word-for-word. 

		They read more slowly from screens than from print.

		Distractions and competition from online messaging, Facebook, and so on make it hard to keep users’ attention.

		Because so much information is available online, users need to determine quickly if content is worth reading and spending time with.



*
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Know your audience

		Your audience: 

		Once you identify your audience, determine various interest levels of your overall audience and try to write for each level (none, little, some, strong, and so on). 

		Create a user persona for each kind of user to help you determine how to get their attention. 

		Write as if you are speaking to your audience in person.

		Writing for all users: 

		Consider users of various reading levels. 

		Make sure all content is accessible.



*
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Writing guidelines

		Guidelines for effective communication

		Use clear, simple, and familiar language. 

		Avoid jargon, acronyms, and abbreviations.

		Use an active and objective voice.

		Be direct and concise, getting to the important points quickly.

		Put the conclusion first so readers know exactly what they will get from the content.

		Chunk content

		Chunk means a manageable bit – a small piece of information a user can easily find and understand. 

		Bold important words or phrases.

		Use lists.

		Keep content short and create space for scanning it easily.

		Use fragments or phrases instead of prose style – if you can cut a word, cut it.



*





*
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Organizing page content

		Titles

		The title is the first piece of information a user scans. Make it clear, inviting, and meaningful.

		Headings and subheadings

		Headings should be short, direct, and powerful.

		Subheadings should be descriptive so users easily learn what each section is about. Use subheadings frequently (every few paragraphs) to keep user moving through content in easy chunks.

		Sentences and paragraphs – shorter is better

		Sentences should be no longer than about 20 words. 

		Each sentence should be limited to one idea. 

		Paragraphs should have no more than about 6 sentences.

		Each paragraph should be limited to one or two ideas.



*
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Organizing page content

		Lists

		Lists are easy to scan because content is vertical. 

		Content presented in lists is usually more succinct.

		Links

		Use descriptive link text so users know where they are going.

		Link to related information.

		Design elements

		Use callouts, bold, and italics to make text easier to scan.

		Use pictures and other visual elements in place of text when appropriate.



*
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Writing for mobile devices

		Reading content on mobile devices is more difficult that reading content on a desktop computer.

		When writing for mobile users, focus their attention on the essential content.

		Defer secondary content to secondary pages to maintain focus on the most essential content.

		Writing for mobile readers requires even harsher editing than writing for the Web. Mobile use implies less patience for filler copy.

		When in doubt, leave it out. 



*

Source: http://www.useit.com/papers/webwriting/
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Best practices

		Analyze and emulate great web writing. 

		Provide accurate descriptions and keywords for search engines.

		Use web writing guidelines when repurposing print documents for the web.

		Create a style guide.

		Test your content: 

		Make sure all links work and are relevant. 

		Make sure all titles and summaries provide information about the contents of the page. 

		Read content from the view of your defined personas and make sure all users will find information quickly and accurately. 



*



For information about the differences between HTML4 and HTML5, see: http://dev.w3.org/html5/html4-differences/

*
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Conclusion

		The title, summary, and major headings should give users a broad overview of the topic. 

		The sentences and paragraphs should tell users a story. 

		Users want to take away the main ideas without being bogged down with specifics.



*
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Project 7


Mobile applications
Timing: 15 to 21 hours


Project overview


In this project, students use Adobe Flash Professional CS6 to create a school information application for 
mobile devices. Students will design and develop the home page, news, campus map, and basic navigation 
elements of the application. The school guide should allow students and faculty to quickly gain access to 
campus resources and information and connect with other students and faculty by using their mobile 
phones and tablets. 


The focus of this project is for students to learn how to create a mobile application with an easy-to-navigate 
interface. Users should be able to locate current academic news stories quickly through an RSS feed and a 
campus map powered by Google Maps. A sample project with assets is provided to demonstrate key steps 
in mobile development for your students. 


Student product: Mobile application


Note: Portions of the Mobile applications project align to the Adobe Certified Associate, Rich Media 
Communication objectives. Within the instruction steps and technical guides, the specific learning 
objectives for the exam are referenced with the following format: 1.1  


Project objectives


At the completion of the project, students will have developed the following skills:


Project management skills


• Defining purpose, goal, and users


• Synthesizing and recommending changes 
during design process


Design skills


• Connecting content and style to user needs


• Making wireframes


• Making design comps


• Consideration of screen sizes


• Designing for multiple devices and outputs


• Designing for usability


Research and communication skills


• Researching existing application marketplaces


• Analyzing similar applications


• Creating user scenarios


• Selecting what information is important


• Conducting peer review


• Critiquing designs


• Providing meaningful but not overly critical 
feedback


• Connecting goals of the application with user 
interaction and experience


• Writing and editing content for application


• Conducting usability analysis


Technical skills


Fireworks


• Creating a wireframe


• Creating a design comp


Flash


• Optimizing file size


• Creating and modifying text


• Working with text and text effects
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• Creating interactive buttons


• Using drawing tools


• Organizing layers and libraries


• Working with layers


• Creating transparent buttons


• Writing ActionScript


• Using the Device Simulator


• Publishing mobile applications


Project materials
• Adobe Flash Professional CS6 installed on all 


machines


• Adobe Fireworks CS6 installed on all machines


• Guide: Mobile application design and 
development


• Electronic file: Campus_Guide.fla


• Electronic file: Campus_Guide.swf


• Guide: Creating user scenarios


• Guide: Principles and rules of copyright 


• Fireworks guide: How to create a wireframe


• Fireworks guide: How to create a design comp


• Flash guide: How to maintain consistency


• Flash guide: How to organize content 


• Flash guide: How to work with text 


• Flash guide: How to draw and create shapes 


• Flash guide: How to optimize Flash content


• Flash guide: How to create a button symbol


• Flash guide: How to apply colors and gradients


• Flash guide: How to use rulers and guides


• Flash guide: How to get started with 
ActionScript


• Flash guide: How to set up a mobile application 
file


• Flash guide: How to resize content for multiple 
screens


• Flash guide: How to create an RSS feed


• Flash guide: How to add a Google map


• Electronic file: 
darby_campus_guide_project.zip


• Flash guide: How to test a Flash project


• Guide: How to design for usability 


• Worksheet: Usability


• Guide: Peer review


• Worksheet: Review and redesign


• Flash guide: How to publish a mobile 
application


Background preparation resources
• Technical and content information


• Key terms


• ISTE NETS*S Standard for Students


• Adobe Certified Associate, Rich Media Communication objectives


Project steps


1. Introduce the project. Explain that students will create the home page, news, and campus map pages 
and basic navigation elements of a campus guide application designed to run on mobile devices. 
Students will complete the following tasks:


• Define a mobile application.


• Design a mobile application.


• Develop a mobile application.


• Publish a mobile application.







© 2012 Adobe Systems Incorporated Mobile applications 3


Analyze mobile applications
(Suggested time: 100–150 minutes)


2. Introduce and discuss various kinds of mobile applications. Explain that they are developed for small 
handheld devices, such as mobile phones, smart phones, and tablet computers. Mobile apps can come 
preloaded on the handheld device and can also be downloaded from application stores or the Internet. 
You might look at several types of mobile applications on various mobile devices, including 
applications that have an RSS feed or a Google map. As you look at examples, discuss how mobile 
applications differ from websites. 


3. Identify and discuss best practices for developing a mobile application. Things to discuss include:


• Briefly review design principles from previous projects.2.2


• Review design and development phases.1.5


• Explore diversity of mobile devices (for example, screen size, resolution, feature support) and 
operating systems and how that affects design and content decisions.4.1


• Discuss designing for mobile devices and how it is different from designing for desktops. 


• Review best practices for navigation, images, content, audio, video, including metadata in SWFs, 
and so on when designing for mobile devices.2.1


Guide: Mobile application design and development 1.5, 2.1, 2.2


Define a mobile application
(Suggested time: 150–200 minutes)


4. Ask students to identify the goals and purpose of their campus guide application.1.2 Ask students to 


identify the needs of their audience for the application.1.1 Demonstrate the provided example of the 
Darby University campus guide application.


Electronic file: Campus_Guide.fla


Electronic file: Campus_Guide.swf


Note: To view the Darby University application example, open the Campus_Guide.fla file by clicking 
Control > Test Movie > In AIR Debug Launcher (Mobile).


5. After students have determined their goals and audience for the mobile application, introduce the 
concept of user scenarios. Explain that user scenarios describe in detail what users do and why they do 
it. They often tell a short story about a person using a website or application, detailing their 
motivations and goals so a designer can understand users’ desires and needs. To help your students 
understand user scenarios, you can show the sample from the Darby University project. 


Guide: Creating user scenarios 1.1


6. Ask your students to create two or three user scenarios for their mobile applications.1.1


Design a mobile application
(Suggested time: 150–200 minutes)


7. To help contain the project, explain that the campus guide mobile application should include the 
following features:
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• A home page with easy access to a collection of campus resources and a top-level navigation 
system for accessing all subpages.


• An easy-to-use navigation system with which users can move quickly back and forth between the 
home page and various campus information and resource pages.


• A news page that includes an RSS feed to current campus news stories.


• A campus map page powered by Google Maps.


• All pages (other than the home page) should include a Home button for returning to the home 
page.


• The news page should include two levels of content and a Read More button. The first level of 
content is a list of current news stories from which users can click the Read More button to view 
the full news story in a separate browser window on the mobile device.


8. In teams, allow students time to identify and discuss the content and basic navigation elements needed 
for their mobile applications. Review copyright when considering images to use in the project.


Guide: Principles and rules of copyright 1.4


9. Ask students to create wireframes and design comps of their mobile applications. Remind students that 
they will create the home page, news page, campus map, and basic navigation elements. They can also 
choose to include navigation elements to additional pages, even if they will not build them out in this 
project.


Fireworks guide: How to create a wireframe


Fireworks guide: How to create a design comp


Develop a mobile application
(Suggested time: 200–250 minutes)


10. The design of the pages and navigation should be consistent and the content should be organized 
effectively. Review how to design consistent pages and navigation in Flash. Instruct students to create 
a template for their pages and navigation based on their wireframes and design comps.


Flash guide: How to maintain consistency 2.1


Flash guide: How to organize content 2.5


11. To help your students prepare to create the design elements of their mobile applications, review the 
following skills in Flash:


• Working with text


• Creating and optimizing images and graphics (alternatively, discuss how to create images and 
graphics in Photoshop or Illustrator and import them into Flash)


• Using symbols, instances, and buttons


• Applying colors and gradients
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• Using guides and rulers


Flash guide: How to work with text 4.4, 4.5


Flash guide: How to draw and create shapes 4.2


Flash guide: How to optimize Flash content 3.8


Flash guide: How to create a button symbol 4.6, 4.8


Flash guide: How to apply colors and gradients 4.2


Flash guide: How to use rulers and guides 3.5


12. Ask students to collect or develop assets for their applications, such as images and graphics. If students 
have created images or graphics in another application, such as Photoshop or Illustrator, demonstrate 


how to import their assets into their Flash project. 4.3 


13. In preparation for developing the code required to power the RSS feed and the Google map, review 
ActionScript—specifically, how to work with code snippets when designing in Flash. 


Flash guide: How to get started with ActionScript 4.11


14. To prepare your students for creating a mobile application, use the “I do, we do, you do” method to 
demonstrate the following in Flash, using the sample Darby University electronic assets: 


• Setting up a mobile application for various mobile devices


• Resizing content for multiple screens


• Creating an RSS feed


• Adding a Google map


Flash guide: How to set up a mobile application file 


Flash guide: How to resize content for multiple screens 


Flash guide: How to create an RSS feed 4.11


Flash guide: How to add a Google map 4.11


Electronic file: darby_campus_guide_project.zip


Note: The darby_campus_guide_project.zip file contains the Flash project file and all source files to 
build the Darby University campus information application. The ActionScript code snippet text files 
for the home page, RSS feed, and Google map integration will assist your students in building these 
more advanced ActionScript-based elements of the mobile application. 


15. Allow time for your students to build the home page, news page, campus map, and basic navigation 
elements. 
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Review and redesign
(Suggested time: 100–150 minutes)


16. Review how to test and debug a Flash project, specifically demonstrating how to use the Device 
Simulator. 


Flash guide: How to test a Flash project 5.1


Flash guide: How to publish a mobile application 4.14, 5.1


Note: If students have access to an iOS or Android mobile device, they can debug the application 
directly on the device to test the application more completely. 


17. Review how to create a usability test and ask teams to pair up to conduct a test.


Guide: How to design for usability 5.2


Worksheet: Usability 5.2


Note: A true usability test would utilize various mobile devices for testing, but depending on time and 
resources, you may decide to conduct the tests by using the Device Simulator. 


18. Ask teams to pair up and conduct peer review of one another’s mobile applications, providing 
feedback for improvement. They should take notes during the peer review and then use the review and 
redesign document to help them organize any necessary changes.


Guide: Peer review 1.6


Worksheet: Review and redesign


19. According to the feedback from the usability tests and peer review, allow teams time to make any 
changes to their mobile applications. 


Publish a mobile application
(Suggested time: 50–100 minutes)


20. Ask teams to perform final testing and publish their application. 


Flash guide: How to publish a mobile application 4.14, 5.1


21. Remind students that they will need to publish their mobile applications to at least two devices (for 
example, an iPad and an Android phone or any other combination). Using the “I do, we do, you do” 
method, demonstrate how to publish a mobile application to another device. 


• Open a new project or save an existing document as a new file.


◦ If opening a new project: Select AIR for IOS or AIR for Android from the Type list and 
specify application settings. Copy the layers from the original project and paste them into the 
new project.


◦ If saving an existing document, select new target runtime.


• Adapt and scale the content as necessary for the target screen size. 


• Select and confirm publishing settings.


• Test and publish application. 


Flash guide: How to resize content for multiple screens 
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22. Have students create a presentation of their mobile application, identifying the following:1.6


• How the application is designed for their audience 1.1


• How the mobile application design best practices influenced their application design


Extension activities


You can extend the project in the following ways:


• Constructive feedback: To help students use more concrete feedback words, brainstorm a list of design 
features and critique terms with the class. Place these terms in a hat and have each student pick a term 
and use it when critiquing an application.


• Additional features: If time allows, ask students to add additional pages, such as information about 
faculty, transportation, schedules, library resources, sporting events, and links to the school’s Facebook 
and Twitter sites. Limit the number of pages students add, depending on the time available for students 
to complete the project.


• Peer teaching: If some groups use a guide to learn about a technical feature, have them hold a mini-
seminar to teach the rest of the class. Their presentation could include:


◦ A working example


◦ A short explanation of when and why to use this feature (design challenges it helps to solve)


◦ A step-by-step demonstration of how to use the feature


• Alternative feedback: For a different type of feedback process, you can have the evaluating team rate 
the applications with point values. For example, have them rate navigation on a scale of 1 to 10, where 
1 means the navigation is very difficult to use and not designed well and 10 means the navigation is 
completely usable and designed effectively. The design and evaluating teams can then discuss how the 
design team can implement any necessary changes.


• Fast finishers: For students who finish early, ask them to create a campus-wide advertising and 
marketing plan aimed at getting students and faculty to use their application. 


Assessment
• Project rubric


Background preparation resources
• Review the student step-by-step guides referenced in this project.


• To view video tutorials aligned with the skills required to complete this project, visit the Digital Design 
CS6 show on Adobe TV: http://tv.adobe.com/show/digital-design-cs6/


• For more teaching and learning resources on mobile applications and other topics in this project, 
search for resources from the community on the Adobe Education Exchange: 
http://edexchange.adobe.com


• For an overview of the interface and for more information on the technical aspects of Fireworks, see 
Fireworks Help. 


• For an overview of the interface and for more information on the technical aspects of Flash 
Professional, see Flash Help.
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• For more information on creating for mobile and tablets use the Adobe TV tutorial: 
http://tv.adobe.com/show/creating-for-mobile-and-tablets/.


Mobile applications


• Adobe Flash showcase for mobile: http://m.flash.com/site.php#/home


• Adobe apps, digital publications, games, and other apps created with Adobe tools: 
http://m.adobeshowcase.com/index


• Adobe AIR showcase apps for mobile developers: 
www.adobe.com/devnet/air/samples-mobile.edu.html


• Adobe Developer Connection – Mobile App Development: 
www.adobe.com/devnet/devices/mobile-apps.edu.html


• Mobile web initiative: www.w3.org/Mobile/


• A look inside mobile design patterns: www.uxbooth.com/blog/mobile-design-patters/


• Tutorials and information on creating designs for the mobile web: 
www.digitalfamily.com/mobile/index.html 


• Mobile Design and Development by Brian Fling (O’Reilly Media, Inc., 2009): 
http://proquest.safaribooksonline.com/book/programming/mobile/9780596806231


Key terms
• application


• design comp


• Device Simulator


• Google Maps


• mobile device


• output


• peer review


• RSS feed


• screen size


• usability


• user interaction


• user scenarios


• wireframe
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ISTE NETS*S Standard for Students


This project is aligned to the ISTE NETS*S Technology Standards. Depending on the subject and content 
area the student selects you may research your own state content standards to see how this project aligns to 
your state requirements.


ISTE NETS*S: Curriculum and Content Area Standards – NETS for Students


1. Creativity and Innovation


Students demonstrate creative thinking, construct knowledge, and develop innovative products and 
processes using technology. Students:


a. apply existing knowledge to generate new ideas, products, or processes.


b. create original works as a means of personal or group expression.


2. Communication and Collaboration


Students use digital media and environments to communicate and work collaboratively, including at a 
distance, to support individual learning and contribute to the learning of others. Students:


a. interact, collaborate, and publish with peers, experts or others employing a variety of digital 
environments and media.


b. communicate information and ideas effectively to multiple audiences using a variety of media and 
formats.


d. contribute to project teams to produce original works or solve problems.


3. Research and Information Retrieval


Students apply digital tools to gather, evaluate, and use information. Students:


b. locate, organize, analyze, evaluate, synthesize, and ethically use information from a variety of 
sources and media. 


c. evaluate and select information sources and digital tools based on the appropriateness to specific 
tasks.


d. process data and report results.


4. Critical Thinking and Problem Solving


Students use critical thinking skills to plan and conduct research, manage projects, solve problems and 
make informed decisions using appropriate digital tools and resources. Students::


b. plan and manage activities to develop a solution or complete a project.


d. use multiple processes and diverse perspectives to explore alternative solutions. 


5. Digital Citizenship


Students understand human, cultural, and societal issues related to technology and practice legal and 
ethical behavior. Students:


a. advocate and practice safe, legal, and responsible use of information and technology.


b. exhibit a positive attitude toward using technology that supports collaboration, learning, and 
productivity


d. exhibit leadership for digital citizenship.


6. Technology Operations and Concepts


Students demonstrate a sound understanding of technology concepts, systems, and operations. 
Students:


a. understand and use technology systems.
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b. select and use applications effectively and productively.


c. troubleshoot systems and applications.


d. transfer current knowledge to learning of new technologies.


Adobe Certified Associate, Rich Media Communication objectives


1.1 Identify the purpose, audience, and audience needs for rich media content.


1.2 Identify rich media content that is relevant to the purpose of the media in which it will be used 
(websites, mobile devices, and so on).


1.4 Demonstrate knowledge of standard copyright rules (related terms, obtaining permission, and citing 
copyrighted material). 


1.5 Understand project management tasks and responsibilities.


1.6 Communicate with others (such as peers and clients) about design and content plans.


2.1 Identify general and Flash-specific best practices for designing rich media content for the web, mobile 
apps, and AIR applications.


2.2 Demonstrate knowledge of design elements and principles.


2.5 Organize a Flash document.


3.5 Use Flash guides and rulers.


3.8 Identify best practices for managing the file size of a published Flash document.


4.1 Make rich media content development decisions based on your analysis and interpretation of design 
specifications.


4.2 Use tools on the Tools panel to select, create, and manipulate graphics and text.


4.3 Import and modify graphics.


4.4 Create text. 


4.5 Adjust text properties. 


4.6 Create objects and convert them to symbols, including graphics, movie clips, and buttons.


4.8 Edit symbols and instances.


4.11Add simple controls through ActionScript 3.0.


4.14Publish and export Flash documents.


5.1 Conduct basic technical tests.
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Assessment


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations


User 
scenarios


Absent or incomplete. Students create two user 
scenarios describing why 
each user uses the 
application and how they 
use it.


Students create three user 
scenarios describing, in 
detail, why each user uses 
the application and how 
they use it. Each user 
scenario is like a short 
story describing the person 
using the application and 
detailing their motivations 
and goals. 


Wireframe Absent or incomplete. Students create wireframes 
based on design principles 
and delivery requirements 
to organize content and 
navigation for the mobile 
application.


Students create wireframes 
based on design principles 
and delivery requirements 
to organize content and 
navigation for the mobile 
application. Students 
support each decision on 
elements in the wireframes 
with data and information 
gathered from research.


Design 
comps


Absent or incomplete. Students create design 
comps that accurately 
reflect audience, goals, 
color choices, mood, 
images, text, and 
navigation choices. The 
selected comps reflect a 
variety of approaches to 
the design.


Students create design 
comps that accurately 
reflect audience, goals, 
color choices, mood, 
images, text, and 
navigation choices. The 
selected comps reflect a 
variety of approaches to 
the design. Students can 
clearly articulate the ways 
design principles are 
implemented to impact the 
audience.


Technical test Absent or incomplete. Students create test plans 
to test technical aspects of 
the application. Students 
test the application in the 
Device Simulator, 
document bugs, and fix 
bugs.


Students create detailed 
test plans to test all 
technical aspects of the 
application. Students test 
applications in the Device 
Simulator and on various 
mobile devices. They 
clearly document and fix 
all bugs.
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Usability test Absent or incomplete. Students create user 
feedback forms and run 
usability tests with peers. 
Students document 
observations of user 
subjects and gather reports 
for user feedback from the 
test. Design teams 
implement all feasible 
suggestions from user test.


Students create detailed 
user feedback forms and 
run usability tests with 
multiple peers. Students 
clearly document 
observations of user 
subjects and gather 
detailed reports for user 
feedback from the test. 
Design teams implement 
all suggestions from user 
test and provide clear 
articulation of the impact 
these changes had on the 
overall site.


Mobile 
application


Absent or incomplete. The mobile application 
includes a home page with 
a collection of campus 
resources. The application 
features a navigation 
system with which users 
can move back and forth 
between the home page 
and current campus 
information and resource 
pages. It also features a 
news page that includes an 
RSS feed to current 
campus news stories and a 
campus map page powered 
by Google Maps. The 
application is published to 
two mobile devices. 


The mobile application 
includes a home page with 
easy access to a collection 
of campus resources. The 
application features an 
intuitive and easy-to-use 
navigation system with 
which users can move back 
and forth quickly between 
the home page and current 
campus information and 
resource pages. It also 
features a news page with 
an RSS feed to current 
campus news stories and a 
campus map page powered 
by Google Maps. The 
news page includes two 
levels of content and a 
Read More button. The 
first level of content is a 
list of current news stories. 
Users can click the Read 
More button to view the 
full news story in a 
separate browser window 
on the mobile device. The 
application is successfully 
published to two or more 
mobile devices. 


0 - Does not meet 
expectations 3 - Meets expectations 5 - Exceeds expectations
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How to create character animations


Inverse Kinematic Poses
Inverse kinematics (IK) is a method for animating an object or set of objects in relation to each other using an 
articulated structure of bones. Bones allow symbol instances and shape objects to move in complex and naturalistic 
ways with a minimum of design effort. For example, inverse kinematics lets you easily create character animation, 
such as arms, legs, and facial expressions.


You can add bones to separate symbol instances or to the interior of a single shape. When one bone moves, the other 
connected bones move in relation to the bone that initiated the movement. When animating using inverse kinematics 
you need only specify the start and end positions of objects. Inverse kinematics lets you easily create natural motion.


Figure 1 A group of several symbols with IK bones attached Figure 2 A shape with an IK armature added


A chain of bones is called an armature. The bones in an armature are connected to each other in a parent-child 
hierarchy. An armature can be linear or branched. Branches of an armature that originate at the same bone are called 
siblings. 


You can use IK in Adobe Flash Professional CS6 in two ways. The first is to articulate a series of symbol instances by 
adding a single bone to each instance (Figure 1). The bones allow the chain of symbol instances to move together. 
For example, you might have a set of movie clips that each represents different parts of a human body. By linking the 
torso, upper arm, lower arm, and hand together, you can create a realistically moving arm. You can create a branched 
armature to include both arms, both legs, and the head.


The second way to use IK is to add an armature to the interior of a shape object (Figure 2). The shape can be created 
in merge drawing mode or object drawing mode. The bones allow you to move and animate parts of the shape 
without the need to draw different versions of the shape or create a shape tween. For example, you could add bones to 
a simple drawing of a snake to enable the snake to move and curve realistically. 


You add bones to symbol instances and shapes with the Bone tool. You use the Bind tool to adjust the relationships 
between individual bones and control points of shape objects. 


You can animate armatures and their associated symbols or shapes either in the timeline or with ActionScript 3.0. You 
animate in the timeline by defining different poses for the armature in different frames. Flash interpolates the 
positions of the armature in the frames in between. For information about animating armatures with ActionScript, see 
the fl.ik classes in the ActionScript 3.0 Language and Components Reference. 


Note: To use inverse kinematics, your FLA file must specify ActionScript 3.0 as the Script setting in the Flash tab of 
the Publish Settings dialog box or the document Properties panel.
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Adding bones to symbol instances


When you add bones to symbol instances, Flash moves the instances and the associated armature to a new layer in the 
Timeline panel. This new layer is called a pose layer. Each pose layer can contain only one armature and its 
associated instances.


To add bones to symbol instances:


1. Start Flash and open a new blank document 
(ActionScript 3.0). 


2. Begin by creating the symbols that make up the moving 
parts of your character.


Note: You can import artwork and convert objects to 
symbols. You can also draw your artwork in Adobe Flash 
Professional CS6. If you create artwork by drawing 
shapes, convert each shape to a symbol. 


3. Arrange the symbols in a rough spatial configuration of 
the object you wish to animate using IK (Figure 3). 


In this example, basic shapes were converted to symbols 
and instances of those symbols were arranged on the 
Stage to form the character.


4. Click an empty part of the Stage to deselect all symbols. 


5. Select the Bone tool from the Tools panel.


You can also press the “M” key to select the Bone tool.


6. With the Bone tool, click the symbol instance that is to be 
the root or head of the armature. Then drag to a separate 
symbol instance to link it to the root instance.


As you drag, a bone appears. The mouse pointer changes 
to a small bone with a plus symbol (Figure 4). When you 
release, a solid bone exists between the two symbol 
instances. Each bone has a head (the wide end) and a tail 
(the narrow end). Each symbol instance can have only 
one attachment point. You can edit these attachment 
points later.


Note: If, when dragging to create bones, the mouse 
pointer changes to a black bone and a circle with a slash 
through it, then Flash does not know which symbol 
instances you are attempting to connect. If this happens, 
you may be pointing outside the symbol or connecting to 
a symbol with no fill. To connect to a symbol with no fill, 
try positioning the pointer over the edge of the symbol 
instance. 


Figure 3 Symbol instances on the Stage


Figure 4 Bone connecting two symbol instances
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7. To add another bone, drag from the tail of the first bone 
to the next symbol instance you want to add to the 
armature.


Note: To make it easier to drag the tail of the new bone to 
the specific location where you want it, you may want to 
turn of Snap to Objects (View > Snapping > Snap to 
Objects). 


Link objects with bones in the order of the parent-child 
relationships you want to create (Figure 5).


8. To create a branched armature, click the head of an 
existing bone where you want the branch to begin. Then 
drag to create the first bone of the new branch (Figure 6). 


An armature can have as many branches as necessary, but 
a branch cannot connect to another branch except as its 
root.


Figure 5 Linking symbols with the Bones tool


Figure 6 Branched armature
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9. Continue to add bones and branches to the armature as 
needed (Figure 7).


As you add bones to instances, Flash moves each 
instance to a new pose layer named Armature in the 
Timeline panel (Figure 8). You can rename this layer to 
better describe the armature. 


All the bones and symbol instances associated with a 
given armature reside in the same pose layer. Each pose 
layer can contain only one armature. 


Note: Flash adds the new pose layer to the timeline 
between existing layers to maintain the previous stacking 
order of objects on the Stage.


10. To reposition the elements of the armature, use the 
Selection tool to drag either the bones or the symbol 
instances themselves.


Note: To rotate a bone with its child bones without 
moving the parent bone, Shift-drag the bone.


There are many more techniques for manipulating 
armatures than can be explained in this guide. For 
detailed instructions on positioning bones and creating 
poses, refer to Adobe Flash Professional CS6 Help.


11. After completing your armature, right-click (Windows) 
or Control-click (Mac OS) frame 10 in the pose layer and 
select Insert Pose.


A keyframe appears in frame 10. You can create a new 
pose of the armature and Flash will interpolate the frames 
in between, creating the character animation.


12. With frame 10 selected, rearrange the pose as you like.


13. Select Control > Test Movie > In Flash Professional to 
preview the movie.


The symbols move in relation to each other.


14. Close the preview window.


Figure 7 Completed armature 


Figure 8 Pose layer 


Adding bones to shapes


You add bones to a single shape or to a group of shapes that are on the same layer. In either case, you must select all 
the shapes before adding the first bone. After you add bones, Flash converts all the shapes and bones into an IK shape 
object and moves the object to a new pose layer.


After you have added bones to a shape, the shape has the following limitations:


• You cannot merge an IK shape with other shapes outside it.


• You cannot rotate, scale, or skew the shape with the Free Transform tool.
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To add bones to shapes:


1. Start Flash and open a new blank document 
(ActionScript 3.0). 


2. Create a filled shape or shapes on the Stage.


Note: The shape can contain multiple colors and strokes. 
Edit the shapes so they are as close to their final form as 
possible. Once you add bones to a shape, the options for 
editing the shape become more limited. If the shape is too 
complex, Flash will prompt you to convert it to a movie 
clip before adding bones.


3. Select the entire shape on the Stage.


Note: If the shape contains multiple color areas or 
strokes, drag a selection rectangle around the shape to 
ensure that the entire shape is selected.


4. Select the Bone tool from the Tools panel.


You can also press the “M” key to select the Bone tool.


5. Click inside the shape and drag to another location within 
the shape.


As you drag, a bone appears. The mouse pointer changes 
to a small bone with a plus symbol (Figure 9). When you 
release, a solid bone exists within the interior of the 
shape. Each bone has a head (the wide end) and a tail (the 
narrow end). 


6. To add another bone, drag from the tail of the first bone 
to another location in within the shape (Figure 10).


The second bone becomes a child of the root bone. 


7. Add new bones to link areas of the shape in the order of 
the parent-child relationships you want to create. For 
example, link from shoulder to elbow to wrist.


8. To create a branched armature, click the head of an 
existing bone where you want the branch to begin. Then 
drag to create the first bone of the new branch 
(Figure 11).


An armature can have any number of branches, but a 
branch cannot connect to another branch except at its 
root.


When you add bones to a shape, Flash moves the shape to 
a new pose layer named Armature (Figure 12). You can 
rename this layer to better describe the armature.


Figure 9 Adding a bone to a shape


Figure 10 Shape with two bones


Figure 11 Branched armature


Figure 12 Pose layer
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9. To rearrange the pose of an armature, select the IK shape 
object with the Selection tool and then drag any of the 
bones to move them.


Note: There many more techniques for manipulating 
armatures than can be explained in this guide. For 
detailed instructions on positioning bones and creating 
poses, refer to Adobe Flash Professional CS6 Help.


10. After completing the first pose of your armature, right-
click (Windows) or Control-click (Mac OS) frame 10 in 
the pose layer and select Insert Pose.


A keyframe appears in frame 10. You can create a new 
pose of the armature and Flash will interpolate the frames 
in between, creating the character animation.


11. With frame 10 selected, rearrange the pose as you like.


12. Select Control > Test Movie > In Flash Professional to 
preview the movie.


The symbols move in relation to each other. You can fine-
tune this movement by shifting the anchor points in the 
bones.


13. Close the preview window.


Binding bones to shape points


By default, the control points of a shape are connected to the bone that is nearest to them. When moving bones to 
pose the armature, a shape may become disfigured. One way to prevent this is to change how the bones are bound to 
the shape. You can use the Bind tool to edit the connections between individual bones and the shape control points. In 
this way you can control how the stroke distorts when each bone moves. This technique is useful when the stroke of a 
shape does not change as you want when the armature moves.


You can bind multiple control points to a bone and multiple bones to a control point.


To bind bones to shape points:


1. Select the Bind tool in the Tools panel.


Note: The Bind tool and Bones tool share the same 
location in the Tools panel.


2. Click a bone within the shape.


The control points appear in yellow and the selected bone 
is red. (Figure 13). Control points connected to only one 
bone appear as squares. Control points connected to more 
than one bone appear as triangles.


3. To add control points to a selected bone, Shift-click a 
blue control point (one of the small blue handles that are 
not highlighted in yellow). 


4. To remove a control point from the bone, Ctrl-click 
(Windows) or Option-click (Mac OS) a control point that 
is highlighted in yellow.


Figure 13 Bone control points within a shape
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5. To highlight the bones connected to a control point, click 
the control point with the Bind tool.


The connected bones are highlighted in yellow while the 
selected control point is highlighted in red (Figure 14).


6. To add other bones to the selected control point, Shift-
click a bone.


7. To remove a bone from a selected control point, Ctrl-
click (Windows) or Option-click (Mac OS) a bone that is 
highlighted in yellow.


Figure 14 Selected control point


Changing pose properties


In addition to manually positioning the bones in an armature, you can also use the settings in the Properties panel to 
control behavior of the bones within each pose. 


To change pose properties:


1. Click a pose layer to select it.


2. Using the Selection tool, click a bone to select it 
(Figure 15).


Note: You can select a bone that connects two symbol 
instances or bones within a shape.


Figure 15 Bone selected
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3. Make sure the Properties panel is open (Figure 16).


4. Change one or more of the following properties:


• To enable springiness, drag the Strength and 
Damping scrubbers in the Spring section of the 
Properties panel. The higher the Strength, the more 
rigid the spring becomes. Damping determines how 
fast the spring is reduced: the higher the value, the 
faster the animation ends.


• To disable rotation of the selected bone around the 
joint, deselect the Enable option in the Joint: 
Rotation section of the Properties panel. To 
constrain rotation of a bone, select the Constrain 
option and then change the Min and Max values.


• To disable translation, deselect the Enable option in 
the Joint: X Translation and Joint: Y Translation 
sections of the Properties panel. Translation refers to 
how the bone stretches as the joint moves. To limit 
the amount of motion enabled along the x or y axis, 
select the respective Enable options and then change 
the Min and Max values in the respective sections of 
the Properties panel.


• To pin a joint in the armature (the junction between 
two bones), use the Selection to click on the arm of 
the bone to select it, and then select the Pin option in 
the Location section of the Properties panel. Pinning 
a bone locks the tail of the bone into place so that it 
does not move when manipulating the pose. Figure 16 Properties panel
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Digital Design Project 5 worksheet

Game design planning document


Student name:_________________________________________________ Date: ________________________


Introduction
Use this worksheet as a planning tool when you design your game. The worksheet includes design templates for two 
types of games: drag-and-drop and character movement. 


In drag-and-drop games, players must drag objects on the screen and position them in new locations, for example, to 
spell a word or solve a puzzle. 


In character movement games, players use input controls to move one or more characters to accomplish a goal, such 
as following a path of discovery or interacting with objects on the screen. For example, the player might be asked to 
move the character from point A to point B. As the character moves, the game might present the player with 
randomly appearing objects. Some objects are meant to be avoided; others might represent positive interactions, such 
as gaining points or extending play.


Guidelines


You are to create either a drag-and-drop or a character movement game. When designing your game, be sure it meets 
the following minimum requirements: 


Drag-and-drop games


• Introduction screen with game instructions.


• A button or other interaction that players must use to start the game.


• At least five drag-and-drop interactions required to complete the game. For example, if the player must 
unscramble a word to solve a puzzle, the challenge word must include at least five characters.


• A button to stop or pause the game mid-play.


• A “play again” button for starting a new game.


Character movement games


• Introduction screen with game instructions.


• A button or other interaction that players must use to start the game.


• A character that navigates a course. Include challenges such as objects or other characters to avoid, climb, or 
jump over.


• A button to stop or pause the game mid-play.


• A “play again” button used to start a new game.


Optional features for all games


• Scoring


• Timer


• Multiple plays (lives)


• Extra points (if scoring is included), additional time on the clock (if a timer is included), objects to collect for 
positive feedback (character movement game only)
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Getting started
Before you sit down at the computer, take some time to plan your game. Understanding your target audience and the 
purpose of your game can have a huge impact on the final game design, including which features to include and how 
players should control or interact with the game. 


Brainstorming


One way to start the planning process is by brainstorming, which is a process for gathering new ideas. You can do 
your brainstorming session alone, but doing it with a team is more effective. If you’re working on your game alone, 
invite some friends or family members to your brainstorming session. The team gathers in a group and throws out 
spontaneous ideas without evaluation until they hit upon something that may be useful. In this process nothing is too 
silly or far-fetched to consider. 


Follow these general brainstorming rules for best results:


• Write down everything or record the session. All ideas should be considered.


• Focus on quantity. More ideas are better.


• Withhold criticism. All ideas are welcome during a brainstorming session. Even ideas that may seem ridiculous 
at the time can lead to new and better ideas.


• Welcome unusual ideas. In the game world, anything is possible. 


• After spending some time brainstorming, go back over your list and refine the ideas to identify your favorites.


After completing your brainstorming session, write down a few of the main ideas that describe the game.


Target Audience


Your primary target audience describes who will play the game. Consider the following: 


• Age range


• Culture


• Gender


• Language


• Experience level (with electronic games, computer, mobile devices, TV game consoles)


Define the goal and rules of play


You will need to communicate (sometimes with very little screen space) the goal or objectives of the game. Ideally, 
your game will be so intuitive, that no instructions are necessary—click the Play button and with a little trial-and-
error, players learn exactly what they’re supposed to accomplish. 


More realistically, you will need at least a brief set of instructions to help players get started. Unless the game is 
extremely intuitive your instructions should include


• Goal (How to succeed, win, or score points.)


• Rules of play (Explain just enough to get started. You can store detailed rules in a separate screen.)


Characters, game board, game world, and so on


The characters and game environment should be intuitive enough that players can start without an explanation. For 
more complex games, consider adding a link to a hidden screen with detailed descriptions of characters, rules, the 
game world, scoring, and so on.
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Game design plan
Use the following sample template as a guide for planning your game.


Type of game


Some examples include


Simple timed interaction: A player completes a task by clicking objects or target areas on the screen. You can use a 
timer to control how much time the player has to complete the task. 


Drag-and-drop: You can use drag-and-drop interactions to create a variety of games or applications, such as board 
games and puzzles. You can also use drag-and-drop interactions to create online lessons, tests, and quizzes. 


Character movement: In a character movement game, players use input controls to move one or more characters to 
accomplish a goal, such as following a path of discovery or interacting with objects on the screen. Action, fantasy, 
shooting, and dodging games all involve character movement.


Simple interaction game: _____  Drag-and-drop game: _____ Character movement game: _____  Other: _____


Target audience


Primary target audience: _________________________________________________________________________


Secondary target audience: _______________________________________________________________________


Goals


Describe the primary goal or objectives of play. 
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Objects in the game


Describe the objects in the game, such as draggable game pieces.


Rules of play


Describe the rules of play.
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Introduction screen


Draft a short narrative for the game’s introduction screen.  


Technical considerations


Describe the technical specifications for the game.


Target devices and screen resolutions:
(web browsers, phones, tablets, Android or iOS devices)


Input devices:
(mouse, keyboard, touch screen)


_____________________________________________


Game environment


Describe the game world or game board. Provide as much detail as possible, including colors, backgrounds, static 
artwork, hidden objects, additional characters, pathways, and so on.


Description: ___________________________________________________________________________________
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Storyboard


A storyboard is a collection of images or sketches displayed in sequence for the purpose of pre-visualizing a motion 
picture, animation, motion graphic, or interactive media sequence, such as the flow of an electronic game. 


Create a rough storyboard of your game by sketching and describing the sequence of screens players see as they play. 
Include the game environment, backgrounds, characters, objects, and game mechanics. 


Make additional copies of these pages as needed to create your storyboard.


Game title: ___________________________________


Created by: ___________________________________


Screen #


Page # _________ of ___________________________


Date: ________________________________________


Screen #
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Game title: ___________________________________


Screen #


Screen #


Page # _________ of ___________________________


Screen #


Screen #

© 2012 Adobe Systems Incorporated Game design planning document 7







Project 5 worksheet


8  

Game object symbols


Use a table to list all game objects. Specify if a game object is draggable or a static object in the game 
environment, such as artwork or interactive buttons. If the object is a static piece of artwork, indicate that 
in the Description column.


Sample table


NAME DESCRIPTION TYPE SYMBOL 
NAME


SYMBOL 
INSTANCE 
NAME


Game piece 1 Draggable game piece Movie Clip Player 1 player1_mc


Map Static artwork Graphic Map map_graphic


Jumping man Player character Movie Clip Jump Man jumpman_mc


Villains Animated objects to avoid 
(character dies when colliding w/ 
these)


Movie Clip Villain villain1_mc; 
villain2_mc; 
villain3_mc


Land mines Objects to avoid Movie Clip Land Mine landmine1_mc; 
landmine2_mc; 
landmine3_mc; 
landmine4_mc


Bonus stars Bonus points are scored when 
colliding with these


Movie Clip Stars star1_mc; 
star2_mc; 
star3_mc; 
star4_mc; 
star5_mc


Play button Static Button Play play_btn


Play again button Static Button Play Again replay_btn
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NAME DESCRIPTION TYPE SYMBOL 
NAME


SYMBOL 
INTANCE 
NAME
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Overview of the Adobe Dreamweaver CS6 workspace
You can access Adobe Dreamweaver CS6 tools, commands, and features by using menus or by selecting options 
from one of the Insert panels or other Dreamweaver panels. The most commonly used areas of the Dreamweaver 
workspace (Figure 1) are the Document window, the Insert panel, the Properties panel, and the other panels.


The Document window displays the current document as you create and edit it. The Insert panel contains buttons for 
creating and inserting objects such as images, tables, layers, and frames you might want to add to your web pages. 
The Properties panel displays properties for the selected object or text and enables you to modify those properties. 


The Document window and panels
The Dreamweaver workspace (Figure 1) enables you to view documents and object properties. The workspace 
places many of the most common operations in toolbars so that you can quickly make changes to your documents.


Figure 1 Dreamweaver workspace, Split view (Code and Design)


Switching between views


Dreamweaver enables you to work in a variety of views. Lay out a page graphically in Design view, work directly 
with the underlying code, split the screen into both Code and Design views, or edit in Live view which presents a 
non-editable browser-based rendering of the document as you create and edit it. Change views by using the view 
buttons.


• Code view a hand-coding environment for writing and editing HTML, JavaScript, server-language code—
such PHP or ColdFusion Markup Language (CFML)—and any other kind of code. 


Application bar Document toolbar Workspace switcher Insert panel


Files panel


Document window


Design viewCode viewProperties panel Assets 
panel


View buttons


Panel groups
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• Design view a design environment for visual page layout, visual editing, and rapid application development. 
In this view, Dreamweaver displays a fully editable, visual representation of the document, similar to what 
you would see when viewing the page in a browser.


• Code and Design view (Split view) both Code view and Design view for the same document in a single 
window.


There are also two additional views related to code that dynamically changes the page--that is, code that will change 
as users interact with the page:


• Live view similar to Design view, a more realistic representation of what your document will look like in a 
browser. Live view enables you to interact with the document exactly as you would in a browser. Live view 
is not editable. However, you can edit in Code view and refresh Live view to see your changes.


• Live Code view only available when viewing a document in Live view. Live Code view displays the actual 
code that a browser uses to execute the page, and can dynamically change as you interact with the page in 
Live view. Live Code view is not editable.


To select a view, click its button in the Document toolbar (Figure 1).


Dreamweaver workspaces


You can also manage panels by using workspaces. Workspaces are pre-arranged panel settings optimized for specific 
tasks or work styles. 


To switch between workspaces:


1. Select a new workspace, such as the Designer Compact 
workspace, from the workspace switcher in the 
Application bar (Figure 2).


The panels are rearranged.


Figure 2 Workspace switcher


To create a new workspace:


1. Make changes to an existing workspace, such as by 
opening new panels or closing open panels.


2. Choose Window > Workspace Layout > New Workspace.


The New Workspace dialog box (Windows) or Save 
Workspace dialog box (Mac OS) opens (Figure 3).


3. Enter a name for the new workspace.


4. Click OK.


The workspace is now available in the workspace 
switcher and the Workspace Layout menu.


Figure 3 New Workspace dialog box
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Panels


Depending on the selected workspace, the right side of the workspace displays panels. 


Panel groups


Panels are often arranged into groups. Panel groups are panels that are docked together. For example, the Files and 
Assets panels are docked together by default in the Designer workspace (Figure 4).


Figure 4 Panel group


• To move a panel into a group, drag the panel’s tab to the highlighted drop zone in the group.


• To rearrange panels in a group, drag a panel’s tab to a new location in the group.


• To remove a panel from a group so that it floats freely, drag the panel by its tab outside the group.


• To move a floating group, drag the title bar (the area above the tabs) (Figure 5).


Working with Panels


• Opening and closing panels:To open a panel, select it from the Window menu. To close a panel, do one of 
the following:


◦ Click the Close button at the top of a floating panel.


◦ Choose Close from the panel menu.


◦ Deselect the panel in the Window menu.


• Moving panels and panel groups. To move a panel, drag it by its tab. To move a panel group or a stack of 
floating panels, drag the title bar.To dock a panel, drag the panel until the border changes to blue. Release the 
mouse to dock the panel. To undock the panel, drag it away from the left border.


• Minimizing or maximizing panels: To minimize or maximize a panel, double-click the tab or the tab area (the 
empty space next to the tab).


• Collapsing panels: Collapsing a panel makes it available as an icon (Figure 5). To collapse or expand a 
panel, do one of the following:


◦ Click the double arrow in a floating panel's title bar.


◦ Double-click the tab area.


◦ Double-click the title bar of a floating panel or group.


Figure 5 Collapsed panel


Expand panels/Collapse To Icon buttonTitle bar


Close panel
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• Docking and undocking panels: As you move panels, you see blue highlighted drop zones. Drop zones are 
areas where you can dock the panel. If you drag to an area that is not a drop zone, the panel floats freely in 
the workspace.


• Resizing panels: To resize a panel, drag either its left or bottom border. All panels have a minimum size 
beyond which they cannot be minimized. Panels can be maximized to fill your screen.


Commonly used panels


The Files panel displays the organization of your site and enables you to open files for editing, to publish files to a 
server, or to delete files.


The Assets panel contains all site assets, elements used in a site, such as images, colors, or movies. The Assets panel 
provides two ways to view assets:


• The Site list shows all of the assets in your site.


• The Favorites list shows only the assets you’ve chosen to include in the Favorites list.


The Insert panel
The Insert panel contains buttons for creating and inserting objects such as tables, images, and links. The buttons are 
organized into several categories (Common, Layout, Forms, Data, and more), which you can choose from the 
Category pop-up menu. Additional categories appear when the current document contains server code, such as ASP 
or CFML documents.


Common category in the Insert panel 


The Common category in the Insert panel contains buttons for inserting the most commonly used objects (Figure 6).


Figure 6 Common category in the Insert panel


Hyperlink: Insert a hypertext link.


Category popup menu
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Email Link: Insert a link to an e-mail address.


Named Anchor: Insert a link to a specific location on a page.


Horizontal Rule: Insert a horizontal rule to visually separate sections on a page.


Table: Insert a table.


Insert Div Tag: Insert a div tag used for page layout.


Images: Insert an image.


Media: Insert media objects, such as Flash, Shockwave, Applets, and ActiveX.


Widget: Insert a Dreamweaver widget.


Date: Insert the current date, with an option for automatic updating when you save the document.


Server-Side Include: Use as a placeholder for commonly used code that can be reused by many pages in your site. 
When you use a SSI file the server takes the entire content of the file stored on a server and inserts it into the page, 
replacing the include code.


Comment: Insert a comment, which will not be displayed on your web page.


Head: Insert keywords, meta tags, page descriptions, and other document data that is kept in the page’s head tag.


Script: Insert or remove script, such as Javascript.


Templates: Make a template based on the current document.


Tag Chooser: Insert an HTML tag.


Layout category in the Insert panel 


From the Layout category in the Insert panel (Figure 7), you can insert tables, table elements, div tags, frames, and 
Spry widgets. You can choose between two modes for tables. Standard mode displays a table as a grid of lines. 
Expanded Tables mode adds cell padding and spacing to tables and increases table borders to make editing easier. 


Figure 7 Layout category in the Insert panel


Insert Div Tag: Insert a div tag to create a content block.
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Insert Fluid Grid Layout Div Tag: Insert a flexible-positioned div tag to display content at a variable location on the 
page.


Draw AP Div: Insert an absolutely-positioned div tag to hold content at a specific location on the page.


Spry Menu Bar: Insert a set of navigational menu buttons that display submenus when a site visitor hovers over one 
of the buttons.


Spry Tabbed Panels: Insert tabs that a site visitor can click to reveal hidden content.


Spry Accordion: Insert a set of collapsible panels that can store a large amount of content in a compact space.


Spry Collapsible Panel: Insert a panel that can hide or reveal a large amount of content when a site visitor clicks the 
tab of the panel.


Table: Insert a table.


Insert Row Above: Insert a row above the current row in a table.


Insert Row Below: Insert a row below the current row.


Insert Column to the Left: Insert a column to the left of the current column.


Insert Column to the Right: Insert a column to the right of the current column.


The Property panel
In the Property panel, you can view and change a variety of properties for the currently selected object, tool, or 
document. Each kind of element has different properties. Figure 8 shows the Properties panel for a selected image. It 
displays the source location, Alt tag, dimensions, and class.  You can edit these settings and create links in the 
Properties panel.


Figure 8 Properties panel

Overview of the Adobe Dreamweaver CS6 workspace © 2012 Adobe Systems Incorporated
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How to create a wireframe
A wireframe is a visual guide representing the basic elements of a website. Wireframes are used to describe the 
conceptual structure or information architecture of a website or application. A well-designed wireframe includes 
three key elements: interface design, navigation system, and main content areas (Figure 1). The functional 
relationships between these element are highlighted, where detailed graphics, typographic style, and colors are 
typically not emphasized. 


Fireworks is an ideal tool to mock up wireframes. Use the following guidelines to help you create a wireframe of your 
widget or website.


Figure 1 Wireframe proposal


Wireframing workflow
This worklow outlines the general steps for developing a wireframe from scratch. The result is to a fully-functional 
interactive prototype.


1. Create pen-and-ink draft 


Using pen and paper, sketch a home page or home screen. Include all major layout design elements you want to share 
across multiple pages or screens such as navigation, content areas, titles, and logos. Consider these questions:


• Graphics What graphics will you include? Where will you place the graphics on the page or screen?


• Text What text will you include? Where will you place text on the page or screen?


• Navigation According to your flowchart, the home page or screen directly links to what pages or screens 
(what are the menu items)? Where will you place these links on your home page or screen?


2. Scan and import your draft


Use a scanner to make a digital copy of your draft wireframe, import it into Fireworks.


3. Lay out common design elements


With the sketched draft for reference, use basic drawing tools and guides in Fireworks to block out the main design 
elements in the wireframe.
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4. Create multiple wireframe pages or screens


In the Pages panel, create the desired number of pages or screens for your initial design. As the design evolves, you 
can add or subtract pages or screens as needed.


5. Add unique elements to individual pages or screens


On each page, add unique design, navigation, or form elements. In the Common Library panel, you can find many 
buttons, text boxes, and pop-up menus that speed up the design process.


6. Simulate user navigation with links


Use web objects such as slices, hotspots, or navigation buttons to link the various pages or screens of your prototype.


7. Export the finished, interactive wireframe


Fireworks offers multiple output formats for your prototype, all of which retain hypertext links for navigation within 
the prototype.


Creating a wireframe with Adobe Fireworks CS6
Use Fireworks to create a basic two-page interactive wireframe document. 


Workflow steps 1 to 3


In this section, you  sketch out your wireframe, scan and import it into Fireworks, and lay out comon design elements. 


To create a wireframe from a sketch:


1. Using pen and paper, sketch your wireframe. Include all 
major components, such as navigation, content areas, 
titles, and logos.


2. Scan the sketch into your computer. 


3. Start Fireworks and create a new document 1024 pixels 
wide and 700 pixels high. 


Note: These dimensions are those of a typical web page. 
The dimensions may differ if you're designing a widget.


4. Open the Layers panel, and create or rename two layers: 


• Wireframe


• Wireframe Sketch


Make sure the Wireframe Sketch layer is below the 
Wireframe layer (Figure 2).


5. With the Wireframe Sketch layer selected, choose File > 
Import.


The Import dialog box opens.


6. Navigate to the file you scanned in step 2, and click 
Import (Windows) or Open (Mac OS).


7. Click in the upper-left corner of the canvas to place the 
imported sketch at that location. 


You need to scale the sketch to fit the canvas. Click the 
imported sketch to select it.


Figure 2 Wireframe and Wireframe Sketch layers 
added to the Layers panel
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8. The sketch may extend beyond the edges, or not fully fit  
inside the canvas. 


9. In the Properties panel, select the Constrain Proportions 
option (Figure 3).


10. In the Width Pixel Dimension text box, type 1024, and 
confirm the X and Y coordinates are set to 0.


11. Press Tab.


The image resizes to fit the canvas width.


12. In the Layers panel, lock the Wireframe Sketch layer.


This sketch layer will be the background reference to lay 
out the wireframe elements.


13. Select the Wireframe layer.


14. Make sure rulers and guides are visible. If not, select 
View > Rulers and View > Guides > Show Guides.


15. To create a horizontal or vertical guide, click then drag 
from the corresponding ruler respectively to the edges of 
the logo area, the main content area, and the first 
navigation button (Figure 4).


Note: Guide color can be changed to be more visible 
against different backgrounds. To change the guide color, 
select Edit > Preferences (Windows) or Fireworks > 
Preferences (Mac OS)  and select the Guides And Grids 
category.


16. Select View > Guides > Lock Guides.


Locking the guides prevents you from moving them 
unintentionally.


17. Select View > Guides > Snap To Guides.


The snapping feature enables you to align objects 
precisely with the guides as long as you get close. You 
can control how close you have to get (Snap Distance) in 
Guides And Grids. preferences.


18. Select the Rectangle tool from the Tools panel.


19. In the Properties panel, make the following changes 
(Figure 5):


a. Select None from the Fill pop-up menu.


b. Select Basic > Soft Line from the Stroke pop-up 
menu.


c. Set Stroke color to dark grey.


d. Set Stroke width to 10 pixels.


20. Using the guides, draw a rectangle around the main 
content area, and logo area of the sketch (Figure 6).


As you draw, the rectangles snap to the guides.


Figure 3 Properties panel


Figure 4 Imported sketch with guides added


Figure 5 Rectangle Properties panel


Figure 6 Rectangles drawn around page elenents


Width Pixel Dimension text box


Constrain 
Proportions 
option


X and Y Positions


No Fill option
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21. Select the Rounded Rectangle tool from the Tools panel.


22. Draw a rounded rectangle around the first navigation 
button of your wireframe (Figure 7).


23. Use the Pointer tool to select the rounded rectangle. Alt-
drag (Windows) or Option-drag (Mac) to the left to create 
a copy of the rectangle, and place it over the second 
navigation button in your wireframe.


Note: You may see a Fireworks warning box telling you 
that editing sub-elements of an Auto Shape may cause it 
to behave unpredictably. Select the Don’t Show Again 
option and click OK to dismiss.


24. Select Edit > Repeat Duplicate. 


This action creates a second copy with the same gap 
space between copies.


25. Continue repeating duplicates until you have created as 
many navigation buttons as needed for your wireframe 
sketch (Figure 8).


Now it's time to add the text labels. 


26. Choose Select > Deselect.


27. From the Tools panel, select the Text tool.


28. In the Properties panel, click the Fill color box and 
choose a dark color. Set the justification to Center 
Alignment and the Text Size to 30.


29. Click once in the logo rectangle and enter the text Logo.


30. Make sure Smart Guides are visible and active. If not, 
select View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.


31. Drag the text block to center it in the rectangle, and 
continue adding text labels for the navigation buttons and 
main content area.


The Smart Guides help you to create, align, edit, and 
transform objects relative to other objects.


32. Choose View > Guides > Show Guides to hide guides.


33. Once you are satisfied with the position of the text and 
rectangle elements, click the eye icon next to the 
Wireframe Sketch layer to turn off visibility of the 
background layer. 


With the sketch layer turned off, your image should look 
similar to Figure 9.


34. Select File > Save As and save the file as a PNG.


Figure 7 Rounded rectangle drawn around 
navigation button


Figure 8 Three copies of the rounded buttons 


Figure 9 Completed wireframe sketch
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Workflow steps 4 and 5


Now that you have created the very basic wireframe of the page or screen layout, the next step is to create a few pages 
or screens showing various content. Fireworks CS6 enables you to create as many pages or screens as needed, with 
shared and unique items on each page.


To create multiple wireframe pages or screens:


1. Open the Pages panel (Window > Pages) if it isn't already 
displayed on the right side of the workspace (Figure 10).


2. Right-click (Windows) or Control-click (Mac OS) the 
current page in the Pages panel, and choose Set As 
Master Page from the context menu.


3. At the bottom of the Pages panel, click the Add Page 
button twice to add two blank pages.  


The new pages display the master page in the 
background.


4. Double-click the new page names to rename them, 
respectively, as Home and Shop (or whatever name you 
are using for the  second page of your wireframe). 


5. Navigate to the Home page by selecting it in the Pages 
panel (Figure 11).


6. Use the Text tool to add a page title at the top of the main 
content area.


7. Navigate to the Shop page by selecting it in the Pages 
panel, and use the Text tool to add a page title at the top 
of the main content area in the same way as on the Home 
page.


8. Select the Rectangle tool from the Tools panel.


9. In the Properties panel, select neutral colors for Fill and 
Stroke.


10. Draw a rectangle in the main content area of the second 
page, beside the page title. This rectangle stands in as a 
placeholder for a Shop page image or text page content 
(Figure 12).


11. Select File > Save.


Figure 10 Pages panel


Figure 11 Pages panel, Home page selected


Figure 12 Adding page-level placeholder content


Pages options
menu


Add Page 
button
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Workflow step 6


In this section, you use hotspot web objects to create navigation buttons or links between the two pages of your 
prototype.


To add navigation to a wireframe:


1. Navigate to the master page by selecting it in the Pages 
panel.


2. From the Tools panel, select the Rectangle Hotspot tool 
(Figure 13).


3. Draw a hotspot over the Logo rectangle area. 


4. Draw another hotspot over the first rounded rectangle 
area (Figure 14).


5. Select the first hotspot with the Pointer tool.


6. In the Properties panel, set Link to Home.htm 
(Figure 15).


7. Select the second hotspot and set Link in the Properties 
panel to Shop.htm (or to whatever you named the second 
page).


Because the hotspots are located on the master page, 
every page will be linked to the others when export the 
Fireworks file to an interactive PDF.


8. Select File > Save.


Figure 13 Tools panel


Figure 14 Drawing hotspots


Figure 15 Properties panel


Workflow step 7


Export an interactive prototype of your wireframe to both PDF and functional HTML (Figure 16). 


An interactive PDF is ideal for facilitating the client review process because the client can click through the flow of 
the site or widget, and make comments as needed by using the tools available in Adobe Acrobat. 


Fireworks generates pure HTML that can be read by most web browsers and HTML editors. You can then preview 
your wireframe interactivity and edit these files in Dreamweaver.


Figure 16 Export wireframes from Fireworks


Rectangle Hotspot tool


Link menu
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To export an interactive PDF:


1. Choose File > Export.


The Export dialog box opens (Figure 17).


2. From the Export pop-up menu, choose Adobe PDF. 


3. Confirm that the option View PDF After Export is 
selected.


4. Specify a filename and location, and then click Save 
(Windows) or Export (Mac OS).


The wireframe is exported to PDF and opens in Acrobat.


5. Test that the wireframe links work as expected 
(Figure 18).  


Figure 17 Export dialog box


Figure 18 Testing links in Acrobat PDF


To export to HTML and images:


1. Choose File > Export.


The Export dialog box opens.


2. Navigate to a folder on your hard drive in which to 
export.


3. From the Export pop-up menu, choose HTML And 
Images.


4. Select All Pages from the Pages menu.


5. To store images in a separate folder, select the option Put 
Images In Subfolder. You can select a specific folder or 
use the Fireworks default Images subfolder.


View PDF After Export option
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6. Specify a filename, and then click Save  (Windows) or 
Export (Mac OS).


After export, you'll see the files Fireworks exported on 
your hard drive. Images and an HTML file are generated 
in the location you specified in the Export dialog box.


7. Navigate to the location of the saved file, open 
Home.htm in a browser, and test whether the wireframe 
links work as expected (Figure 19).


Figure 19 Testing HTMLin a browser
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How to check links
Use the Check Links feature to search for broken links and orphaned files (files that still exist in the site but that 
aren’t linked to by any other files in the site) (Figure 1). You can search an open file, a portion of a local site, or an 
entire local site.


Checking links in a local site


Figure 1 Link Checker panel


Dreamweaver verifies links only to documents within the site; Dreamweaver compiles a list of external links in the 
selected document or documents but does not verify them.


You can also identify and delete files that are no longer used by other files in your site.


To check links in a local site:


1. Start Dreamweaver.


2. In the Files panel, select a site from the Current Sites 
pop-up menu.


3. Select Site > Check Links Sitewide.


The Broken Links report appears in the Link Checker 
panel (Figure 1).


4. In the Link Checker panel, select External Links or 
Orphaned Files from the Show pop-up menu to view 
another report. 


A list of files that fit the report type you selected appears 
in the Link Checker panel.


Note: If you select Orphaned Files as your report type, 
you can delete orphaned files from the Link Checker 
panel by selecting a file in the list and pressing the Delete 
key. 


5. Fix any broken links and check the links again.


Note: To clear the current Link Checker results, select 
Clear Results from the Link Checker Options menu.


Figure 2 Files panel


Link Checker Options menu


Current 
Sites menu
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How to apply colors and gradients
Each Flash document holds its own color palette. You can use the Color panel to apply colors that aren’t in the default 
web-safe palette of 216 colors. You can create new colors and add them to the palette, which you can save for later 
use. You can also incorporate new colors into gradient fills and store your gradients for repeated use. A gradient is a 
multi-color fill in which one color gradually changes into another.


Gradients can be helpful when creating effects, such as glows, photo-realistic spheres, solar flares, and glowing 
buttons. With Adobe Flash Professional CS6 you can create two types of gradient fills—linear and radial.


Applying colors
You apply and manage colors by using the Color panel.


To apply colors:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Use the Oval tool to create a simple shape on the Stage.


3. You can adjust the fill and stroke colors by using the 
Properties panel. To apply a color that is not in the 
current palette, use the Color panel (Figure 1).


If the Color panel is not open, select Window > Color.


4. Make sure you have selected both the stroke and fill of 
your shape.


Note: To select the stroke and fill of your shape, double-
click the shape with the Selection tool.


5. In the Color panel, click the paint bucket icon (not the 
color box next to it) to select the Fill Color section. 
Choose a color in one of the following ways:


• You can select a new fill color in the palette by 
clicking Saturation and choosing a color in the Fill 
Color control (Figure 1). Drag the Brightness 
control to adjust the tint.


• You can select a new fill color by clicking Hue, 
dragging the Color control, and choosing a tint in the 
Fill Color control (Figure 2).


• You can also enter a hexadecimal number for the 
color. This is helpful if a client provides hexadecimal 
values. 


• You can also adjust red, green, and blue values by 
dragging their scrubbers. Use the Alpha slider to 
adjust the level of transparency.


6. To browse for a color, click and drag in the color picker. 
To adjust the tint, drag the Brightness control.


Figure 1 Color panel with Saturation selected


Figure 2 Color panel with Hue selected


Fill color control


Color picker


Brightness 
control


Hexadecimal 
value


Alpha


Saturation selected


Hue 
selected


Tint picker


Color control
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As you drag, the colors you point to are shown in the 
Current Color Swatch area and in the Fill Color control 
(Figure 3). (Once you release the mouse, the new color 
displays.)


Figure 3 Picking a new color


Add colors to the palette
Once you have mixed your own colors, you can use them to create a custom palette. You do this with the Color panel 
and the Swatches panel.


To add colors to the palette:


1. Make sure the Color panel is open.


If the Color panel is not open, select Window > Color.


Note: The Color panel and the Swatches panel exist in 
the same panel group (Figure 4).


2. In the Color panel, use the color picker or the RGB boxes 
to create a new color.


3. In the Color panel menu, select Add Swatch (Figure 4).


4. Click the Swatches tab to view the Swatches panel.


The new color swatch appears at the bottom of the palette 
in the Swatches panel (Figure 5).


Figure 4 Color and Swatches panels


Figure 5 Swatches panel


Current color
Old color


New color swatch
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Web-safe colors palette


By default, the Swatches panel displays the web-safe colors palette. This palette is designed to work for all visitors’ 
monitors, including those with older monitors that display only 256 colors. Although all newer monitors work with 
more than 256 colors, some web designers recommend continuing to use this palette so your pages appear consistent 
to all visitors. (An additional benefit is that it gives you a limited range of colors from which to choose; sometimes 
it’s easier to make good choices when these choices are limited.) If you’re sure all your viewers have newer monitors, 
you can deviate from this palette by using the Color panel.


Creating gradients
You create gradients by selecting a gradient type and adding colors to the gradient.


To create gradients:


1. Use the Selection tool to double-click the oval shape on 
the Stage.


The fill and stroke are both selected.


2. Make sure the Color panel and the Swatches panel are 
both visible.


If they are not, select Window > Color or Window > 
Swatches.


3. In the Color panel, select Radial Gradient in the Color 
Type menu (Figure 6). Selections in the Color Type 
menu determine the fill style of a shape.


This color type fills the selected shape with a radial 
gradient, composed of the two colors indicated by the 
color pointers under the gradient definition bar 
(Figure 7).


Note: By default, these colors may be set to black and 
white. 


You can have up to sixteen different colors in a gradient. 
To add more, click in the gradient definition bar 
(Figure 7).


Note: Radial gradients work best on elliptical shapes.


4. Make sure Extend Color is selected as the Flow option 
(Figure 7).


Flow lets you control colors applied past the limits of a 
gradient. The Flow options are Extend Color (the default 
mode), Reflect Color, and Repeat Color.


The gradient starts out black in the center (determined by 
the left-most color stop) and transitions to white 
(determined by the right-most color stop).


5. Double-click the left color stop under the gradient 
definition bar. Use the color picker to select a new color 
for the inner color of the gradient. The gradient definition 
bar changes color.


Figure 6 Gradient options in the Color panel


Figure 7 Gradient definition bar


Extend Color 


Color stops


Gradient 
definition bar 
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6. Click in the gradient definition bar to add a new color to 
the gradient.


A new color stop appears below the gradient definition 
bar in the Color panel (Figure 8).


7. With the new color stop still selected, click or drag in the 
color picker to select a new color for the gradient. You 
can also select colors by dragging the RGB scrubbers or 
entering a hexidecimal number (or by double-clicking the 
new color stop). 


8. Change the color of the right color stop to change the 
outer color of the gradient. 


Note: Selecting a lighter inner (left) color and a darker 
outer (right) color creates the illusion of a three 
dimensional sphere (Figure 9). 


9. Deselect the shape on the Stage to see the new gradient 
applied to your shape (Figure 10). Figure 8 Color panel


Figure 9 Gradient definition bar


Figure 10 Applied gradient
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How to ease tweens
Easing is a technique for modifying the way Adobe Flash Professional CS6 calculates the property values between 
property keyframes in a tween. Without easing, Flash calculates these values so the change to the value is the same in 
each frame. You can use easing to adjust the rate of change to the values for more natural or more complex animation.


An ease is a mathematical curve you apply to the property values of a tween. The final effect of the tween is the result 
of the combination of the range of property values in the tween and the ease curve.


You can apply easing in the Motion Editor for motion tweens or in the Properties panel for classic tweens. Eases 
applied in the Motion Editor can affect a single property, a group of properties, or all properties of a tween. Eases 
applied in the Properties panel affect a single property or all of the properties included in a tween.


Flash includes a range of preset eases you can apply for simple or complex effects. In the Properties panel or Motion 
Editor, you can also create your own custom ease curves.


One of the many common uses of easing is when you have edited a motion path on the Stage and enabled roving 
keyframes to make the speed of motion consistent in each segment of the path. You can then use easing to add more 
realistic acceleration and deceleration at the ends of the path.


Easing individual properties for motion tweens in the Motion Editor
You can apply a preset ease to an individual property or a category of properties in the Motion Editor. In the following 
steps, you first create a motion tween and then add a preset ease to the tween.


To apply a preset ease:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Draw a shape on the Stage.


3. Using the Selection tool, double-click to select the shape 
fill and stroke, if present.


4. Choose Modify > Convert To Symbol. 


The Convert To Symbol dialog box appears.


5. Type a new name for the symbol in the Name text box, 
select Graphic for Type, and click OK.


6. Insert a frame at frame 40.


7. Make sure frame 40 (the end frame for the motion tween) 
is selected and select Insert > Motion Tween.


8. With frame 40 still selected, use the Selection tool to 
move the object to a different position on the Stage.


9. In the timeline, select the motion tween by clicking 
anywhere in the tween span between the start and end 
frames. 


10.  Select Motion Editor tab (Figure 1).


11. In the Motion Editor, scroll down to Eases, click the Add 
Ease button (plus sign) and select an ease, such as Stop 
And Start (Medium) (Figure 2).


Figure 1 Timeline and Motion Editor tabs


Figure 2 Add Ease button in the Motion Editor


Add Ease button
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12. Scroll up to Basic Motion, and select the ease you just 
added from the Selected Ease menu (Figure 3).


13. Press Enter (Windows) or Return (Mac OS) to preview 
the eased tween.


Note: You can also click the Play/Pause at the bottom of 
the Motion Editor to play and pause the movie.


If you chose the Stop And Start (Medium) ease, for 
example, the tween will stop briefly and then begin 
again.


14. Click the Play/Pause button to stop the preview.


15. Adjust the eases in the tween until you achieve the 
desired effect. 


See the following section for information about adjusting 
ease curves.


Figure 3 Basic Motion Selected Ease menu


Figure 4 Motion Editor playback controls


Editing ease curves for motion tweens in the Motion Editor
Eases are displayed as ease curves in the right side of the Motion Editor. You can edit the shape of preset ease curves 
and create custom ease curves.


To edit ease curves for motion tweens:


• To edit a preset ease curve, change its values in the Value 
column in the Motion Editor (Figure 5). To do so, click 
on the value and drag to the left (negative) or right 
(positive) or type a new value.


• For simple ease curves, the value is a percentage 
representing the strength of the application of the 
ease curve to the property curve. Positive values 
increase the ease at the end of the curve. Negative 
values increase the ease at the beginning of the 
curve.


• For ease curves that are waves, such as the sine wave 
or sawtooth wave, the value represents the number of 
half-cycles in the wave.


• To edit a preset ease, first add it to the list of 
available eases by using the Add Ease button in the 
Ease section of the Motion Editor.


• To edit a custom ease curve, add it to the list of eases 
and then edit the curve by using the same techniques 
for editing any other Bezier curve.


Figure 5 Editing a simple ease curve


Play/Pause button
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Easing individual properties for classic tweens in the Properties panel 
For classic tweens, the Motion Editor is not available. You create eases for classic tweens by using the Properties 
panel.


To ease a classic tween:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Add a symbol to the Stage.


Note: You may need to add a shape, image, or text first 
and convert the object to a new symbol.


3. Select frame 40 in the timeline.


4. Select Insert > Timeline > Keyframe.


The tween will last for 40 frames.


5. Make sure frame 40 is still selected and move the symbol 
to a new position on the Stage.


6. Click on the tween span in the timeline and select 
Insert > Classic Tween. 


The classic tween span is light blue with an arrow 
(Figure 6).


7. Select frame 40, select the symbol on the Stage, and 
adjust the position, color, or scale of the symbol to be as 
you want the animation to end.


8. In the timeline, click anywhere in the tween span (but not 
on a keyframe) to select the classic tween.


9. In the Tweening section of the Properties panel, enter an 
Ease value to determine the strength of the ease, such as 
-60 (Figure 7).


Note: A negative value creates an “ease in.” A positive 
value creates an “ease out.”


10. To preview the animation on the Stage, press Enter 
(Windows) or Return (Mac OS).


Note: You can also click the Play/Pause at the bottom of 
the Timeline panel (Figure 4) to play and pause the 
movie.


Figure 6 Classic tween span in the timeline


Figure 7 Properties panel, Tweening section


Ease value
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Editing ease curves for classic tweens in the Properties panel 
In the Properties panel, you can edit the shape of ease curves to create custom ease ins and ease outs.


To edit ease curves:


1. In the timeline, select the classic tween that you created 
in the previous steps. 


2. Click the Edit Easing button next to the Ease value field 
in the Properties panel (Figure 8). 


The Custom Ease In / Ease Out dialog box appears 
(Figure 9).


3. (Optional) To display the curve for a property, deselect 
Use One Setting For All Properties, and select a property 
in the menu (Figure 10).


You can add control points anywhere along the curve to 
help you manipulate the curve.


4. Click on the curve in the Custom Ease In/Ease Out dialog 
box to add a new control point. 


5. To increase the speed of the object, drag the control point 
up; to slow down the speed of the object, drag it down.


Figure 8 Properties panel, Tweening section 


Figure 9 Custom Ease In / Ease Out dialog box


Figure 10 Easing property menu


Edit Easing button
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6. To further adjust the ease curve and fine-tune the ease 
value of the tween, drag the vertex handles (Figure 11).


7. To view the animation on the Stage, click the play button 
in the lower left corner of the Ease In / Ease Out dialog 
box (Figure 11).


8. Adjust the curve until you achieve the desired effect.


9. Click OK to confirm your changes and close the Ease In/
Ease Out dialog box.


Note: If you use the Custom Ease In / Ease Out dialog 
box to apply a custom ease to a frame, the Ease value edit 
box displays '--'. If you use the edit box or the pop up 
slider to apply an ease value to a frame, the Custom Ease 
graph is set to the equivalent curve, and the Use One 
Setting For All Properties option is selected.


Figure 11 Ease curve


Play button Vertex handles
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How to create a wireframe
A wireframe is a visual guide representing the basic elements of a website. Wireframes are used to describe the 
conceptual structure or information architecture of a website or application. A well-designed wireframe includes 
three key elements: interface design, navigation system, and main content areas (Figure 1). The functional 
relationships between these element are highlighted, where detailed graphics, typographic style, and colors are 
typically not emphasized. 


Fireworks is an ideal tool to mock up wireframes. Use the following guidelines to help you create a wireframe of your 
widget or website.


Figure 1 Wireframe proposal


Wireframing workflow
This worklow outlines the general steps for developing a wireframe from scratch. The result is to a fully-functional 
interactive prototype.


1. Create pen-and-ink draft 


Using pen and paper, sketch a home page or home screen. Include all major layout design elements you want to share 
across multiple pages or screens such as navigation, content areas, titles, and logos. Consider these questions:


• Graphics What graphics will you include? Where will you place the graphics on the page or screen?


• Text What text will you include? Where will you place text on the page or screen?


• Navigation According to your flowchart, the home page or screen directly links to what pages or screens 
(what are the menu items)? Where will you place these links on your home page or screen?


2. Scan and import your draft


Use a scanner to make a digital copy of your draft wireframe, import it into Fireworks.


3. Lay out common design elements


With the sketched draft for reference, use basic drawing tools and guides in Fireworks to block out the main design 
elements in the wireframe.
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4. Create multiple wireframe pages or screens


In the Pages panel, create the desired number of pages or screens for your initial design. As the design evolves, you 
can add or subtract pages or screens as needed.


5. Add unique elements to individual pages or screens


On each page, add unique design, navigation, or form elements. In the Common Library panel, you can find many 
buttons, text boxes, and pop-up menus that speed up the design process.


6. Simulate user navigation with links


Use web objects such as slices, hotspots, or navigation buttons to link the various pages or screens of your prototype.


7. Export the finished, interactive wireframe


Fireworks offers multiple output formats for your prototype, all of which retain hypertext links for navigation within 
the prototype.


Creating a wireframe with Adobe Fireworks CS6
Use Fireworks to create a basic two-page interactive wireframe document. 


Workflow steps 1 to 3


In this section, you  sketch out your wireframe, scan and import it into Fireworks, and lay out comon design elements. 


To create a wireframe from a sketch:


1. Using pen and paper, sketch your wireframe. Include all 
major components, such as navigation, content areas, 
titles, and logos.


2. Scan the sketch into your computer. 


3. Start Fireworks and create a new document 1024 pixels 
wide and 700 pixels high. 


Note: These dimensions are those of a typical web page. 
The dimensions may differ if you're designing a widget.


4. Open the Layers panel, and create or rename two layers: 


• Wireframe


• Wireframe Sketch


Make sure the Wireframe Sketch layer is below the 
Wireframe layer (Figure 2).


5. With the Wireframe Sketch layer selected, choose File > 
Import.


The Import dialog box opens.


6. Navigate to the file you scanned in step 2, and click 
Import (Windows) or Open (Mac OS).


7. Click in the upper-left corner of the canvas to place the 
imported sketch at that location. 


You need to scale the sketch to fit the canvas. Click the 
imported sketch to select it.


Figure 2 Wireframe and Wireframe Sketch layers 
added to the Layers panel
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8. The sketch may extend beyond the edges, or not fully fit  
inside the canvas. 


9. In the Properties panel, select the Constrain Proportions 
option (Figure 3).


10. In the Width Pixel Dimension text box, type 1024, and 
confirm the X and Y coordinates are set to 0.


11. Press Tab.


The image resizes to fit the canvas width.


12. In the Layers panel, lock the Wireframe Sketch layer.


This sketch layer will be the background reference to lay 
out the wireframe elements.


13. Select the Wireframe layer.


14. Make sure rulers and guides are visible. If not, select 
View > Rulers and View > Guides > Show Guides.


15. To create a horizontal or vertical guide, click then drag 
from the corresponding ruler respectively to the edges of 
the logo area, the main content area, and the first 
navigation button (Figure 4).


Note: Guide color can be changed to be more visible 
against different backgrounds. To change the guide color, 
select Edit > Preferences (Windows) or Fireworks > 
Preferences (Mac OS)  and select the Guides And Grids 
category.


16. Select View > Guides > Lock Guides.


Locking the guides prevents you from moving them 
unintentionally.


17. Select View > Guides > Snap To Guides.


The snapping feature enables you to align objects 
precisely with the guides as long as you get close. You 
can control how close you have to get (Snap Distance) in 
Guides And Grids. preferences.


18. Select the Rectangle tool from the Tools panel.


19. In the Properties panel, make the following changes 
(Figure 5):


a. Select None from the Fill pop-up menu.


b. Select Basic > Soft Line from the Stroke pop-up 
menu.


c. Set Stroke color to dark grey.


d. Set Stroke width to 10 pixels.


20. Using the guides, draw a rectangle around the main 
content area, and logo area of the sketch (Figure 6).


As you draw, the rectangles snap to the guides.


Figure 3 Properties panel


Figure 4 Imported sketch with guides added


Figure 5 Rectangle Properties panel


Figure 6 Rectangles drawn around page elenents


Width Pixel Dimension text box


Constrain 
Proportions 
option


X and Y Positions


No Fill option
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21. Select the Rounded Rectangle tool from the Tools panel.


22. Draw a rounded rectangle around the first navigation 
button of your wireframe (Figure 7).


23. Use the Pointer tool to select the rounded rectangle. Alt-
drag (Windows) or Option-drag (Mac) to the left to create 
a copy of the rectangle, and place it over the second 
navigation button in your wireframe.


Note: You may see a Fireworks warning box telling you 
that editing sub-elements of an Auto Shape may cause it 
to behave unpredictably. Select the Don’t Show Again 
option and click OK to dismiss.


24. Select Edit > Repeat Duplicate. 


This action creates a second copy with the same gap 
space between copies.


25. Continue repeating duplicates until you have created as 
many navigation buttons as needed for your wireframe 
sketch (Figure 8).


Now it's time to add the text labels. 


26. Choose Select > Deselect.


27. From the Tools panel, select the Text tool.


28. In the Properties panel, click the Fill color box and 
choose a dark color. Set the justification to Center 
Alignment and the Text Size to 30.


29. Click once in the logo rectangle and enter the text Logo.


30. Make sure Smart Guides are visible and active. If not, 
select View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.


31. Drag the text block to center it in the rectangle, and 
continue adding text labels for the navigation buttons and 
main content area.


The Smart Guides help you to create, align, edit, and 
transform objects relative to other objects.


32. Choose View > Guides > Show Guides to hide guides.


33. Once you are satisfied with the position of the text and 
rectangle elements, click the eye icon next to the 
Wireframe Sketch layer to turn off visibility of the 
background layer. 


With the sketch layer turned off, your image should look 
similar to Figure 9.


34. Select File > Save As and save the file as a PNG.


Figure 7 Rounded rectangle drawn around 
navigation button


Figure 8 Three copies of the rounded buttons 


Figure 9 Completed wireframe sketch
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Workflow steps 4 and 5


Now that you have created the very basic wireframe of the page or screen layout, the next step is to create a few pages 
or screens showing various content. Fireworks CS6 enables you to create as many pages or screens as needed, with 
shared and unique items on each page.


To create multiple wireframe pages or screens:


1. Open the Pages panel (Window > Pages) if it isn't already 
displayed on the right side of the workspace (Figure 10).


2. Right-click (Windows) or Control-click (Mac OS) the 
current page in the Pages panel, and choose Set As 
Master Page from the context menu.


3. At the bottom of the Pages panel, click the Add Page 
button twice to add two blank pages.  


The new pages display the master page in the 
background.


4. Double-click the new page names to rename them, 
respectively, as Home and Shop (or whatever name you 
are using for the  second page of your wireframe). 


5. Navigate to the Home page by selecting it in the Pages 
panel (Figure 11).


6. Use the Text tool to add a page title at the top of the main 
content area.


7. Navigate to the Shop page by selecting it in the Pages 
panel, and use the Text tool to add a page title at the top 
of the main content area in the same way as on the Home 
page.


8. Select the Rectangle tool from the Tools panel.


9. In the Properties panel, select neutral colors for Fill and 
Stroke.


10. Draw a rectangle in the main content area of the second 
page, beside the page title. This rectangle stands in as a 
placeholder for a Shop page image or text page content 
(Figure 12).


11. Select File > Save.


Figure 10 Pages panel


Figure 11 Pages panel, Home page selected


Figure 12 Adding page-level placeholder content


Pages options
menu


Add Page 
button
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Workflow step 6


In this section, you use hotspot web objects to create navigation buttons or links between the two pages of your 
prototype.


To add navigation to a wireframe:


1. Navigate to the master page by selecting it in the Pages 
panel.


2. From the Tools panel, select the Rectangle Hotspot tool 
(Figure 13).


3. Draw a hotspot over the Logo rectangle area. 


4. Draw another hotspot over the first rounded rectangle 
area (Figure 14).


5. Select the first hotspot with the Pointer tool.


6. In the Properties panel, set Link to Home.htm 
(Figure 15).


7. Select the second hotspot and set Link in the Properties 
panel to Shop.htm (or to whatever you named the second 
page).


Because the hotspots are located on the master page, 
every page will be linked to the others when export the 
Fireworks file to an interactive PDF.


8. Select File > Save.


Figure 13 Tools panel


Figure 14 Drawing hotspots


Figure 15 Properties panel


Workflow step 7


Export an interactive prototype of your wireframe to both PDF and functional HTML (Figure 16). 


An interactive PDF is ideal for facilitating the client review process because the client can click through the flow of 
the site or widget, and make comments as needed by using the tools available in Adobe Acrobat. 


Fireworks generates pure HTML that can be read by most web browsers and HTML editors. You can then preview 
your wireframe interactivity and edit these files in Dreamweaver.


Figure 16 Export wireframes from Fireworks


Rectangle Hotspot tool


Link menu
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To export an interactive PDF:


1. Choose File > Export.


The Export dialog box opens (Figure 17).


2. From the Export pop-up menu, choose Adobe PDF. 


3. Confirm that the option View PDF After Export is 
selected.


4. Specify a filename and location, and then click Save 
(Windows) or Export (Mac OS).


The wireframe is exported to PDF and opens in Acrobat.


5. Test that the wireframe links work as expected 
(Figure 18).  


Figure 17 Export dialog box


Figure 18 Testing links in Acrobat PDF


To export to HTML and images:


1. Choose File > Export.


The Export dialog box opens.


2. Navigate to a folder on your hard drive in which to 
export.


3. From the Export pop-up menu, choose HTML And 
Images.


4. Select All Pages from the Pages menu.


5. To store images in a separate folder, select the option Put 
Images In Subfolder. You can select a specific folder or 
use the Fireworks default Images subfolder.


View PDF After Export option

© 2012 Adobe Systems Incorporated How to create a wireframe 7







Project 1 guide Adobe Fireworks CS6


8


6. Specify a filename, and then click Save  (Windows) or 
Export (Mac OS).


After export, you'll see the files Fireworks exported on 
your hard drive. Images and an HTML file are generated 
in the location you specified in the Export dialog box.


7. Navigate to the location of the saved file, open 
Home.htm in a browser, and test whether the wireframe 
links work as expected (Figure 19).


Figure 19 Testing HTMLin a browser
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How to use CSS text styles
Web typography is an important creative tool web designers use to express style and emotion that enhances the goal 
and overall message of a website. 


Image-based text gives you control of your web typography, but several limitations have led to the decline of this 
approach: increased file size, decreased accessibility, problems with search engine discoverability, and practical 
limitations on the amount of text.


Cascading Style Sheets provide a higher level of styling control over web typography, without the drawbacks of 
image-based test. With CSS, web page text results in smaller file size, greater accessibility, and improved usability 
across devices, browsers, and platforms. CSS specifies a series of font properties for a web browser to use when 
displaying text in a web page. 


Web designers seeking a broader font selection or more expressive typography (Figure 1) may choose to use web 
fonts. Web fonts are temporarily downloaded to display text in fonts that site visitors don’t need installed on their 
computers. 


Figure 1 Example of a website using web fonts: http://lostworldsfairs.com/moon/
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Changing text styles
To understand web fonts betters, consider how fonts are defined by using CSS. CSS font properties define the font 
family, boldness, size, and style of text. A font declaration for an HTML paragraph tag looks something like this:


Changing text styles for web pages is easy in the CSS Styles panel.


To change text styles:


1. Start Dreamweaver.


2. Open a document in which you want to edit a CSS font 
property.


3. Open the CSS Styles panel (Window > CSS Styles), if it 
isn’t already open (Figure 2).


4. Double-click an existing rule or property in the top pane 
of the CSS Styles panel.


The CSS Rule Definition dialog box appears (Figure 3).  


5. Change or specify any of the following properties in the 
dialog box. If a property is not important to you, don’t 
select or enter a value for that property.


Font-family sets the font family (or series of families) for 
the style. Browsers display text in the first font in the 
series that is installed on the viewer’s system. 


Font-size defines the size of the text. You can choose a 
specific size by selecting the number and the unit of 
measurement, or you can choose a relative size.


Font-style provides the options Normal, Italic, and 
Oblique. 


Line-height sets the height of the line on which the text is 
placed. This setting is traditionally called leading. 


Text-decoration adds an underline, overline, or line-
through to the text, makes the text blink, or removes any 
decoration set elsewhere.


Font-weight applies a specific or relative amount of 
boldface to the font. Normal is equivalent to 400; Bold is 
equivalent to 700. 


Font-variant sets the small caps variant on text. 
Dreamweaver does not display this attribute in the 
Document window. 


Text-transform capitalizes the first letter of each word in 
the selection or sets the text to all uppercase or lowercase. 


Color sets the text color. 


6. When you have finished, click OK. Observe the effect of 
your changes in Design view.


Figure 2 CSS Styles panel


Figure 3 CSS Rule Definition dialog box
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Using web fonts
By using the CSS @font-face embedding technique, modern web browsers download and use a wide range of font 
styles. There are two methods for delivering web fonts to site visitors: subscription-based hosted services that license 
fonts for use and free open-source fonts.


Most subscription-based, third-party services host fonts on their servers and deliver specific fonts whenever a website 
is viewed. This often requires adding code to your site, and the service instructs you on how to do so. Examples of 
subscription-based services are Adobe’s Typekit (www.typekit.com), Kernest, and Typotheque. 


Google web fonts is the service of choice for free open-source web fonts. Like subscription-based font services, 
Google offers a hosted web font service, as well as letting you download font collections for saving to a web server. 


To use Google web fonts, you must first visit the Google web fonts website and choose one or more font styles, 
review your selection, and integrate web fonts into your CSS (Figure 4). Use one of the following procedures:   


• Remote web fonts: Copy the provided link code into the <head> section of your HTML document.


• Embedded web fonts: Download the collection as a ZIP file and save to your web server.


Figure 4 Google web fonts website


In this section, you learn how to use the Google remote web font service and how to download and use Google web 
fonts. 


To use remote Google web fonts:


1. Visit the Google web fonts site at www.google.com/
webfonts. 


You may be required to register.
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2. Search or browse the selection of font families; then click 
the Add To Collection button next to each font you want 
to use.


3. Click the Review button to compare and refine your 
collection and to see the styles in a customizable sample 
layout.


4. Click the Use button, and verify the settings.


5. In Step 3 on the Use page, copy the Standard link code 
(Figure 5).


The code is saved to the clipboard.


6. Open a Dreamweaver HTML document in which you 
want to add Google web fonts.


7. Select Split view in the Document toolbar (Figure 6).


Code view and Design view are visible in the Document 
window.


8. Locate the opening <head> tag of the document, and 
place the insertion point immediately after the closing 
bracket of the tag. 


9. Press Enter (Windows) or Return (Mac OS) to create a 
line break.


10. Select Edit > Paste to add the saved clipboard code to the 
head section of the document (Figure 7). 


11. Open the CSS Styles panel (Window > CSS Styles), if it 
isn’t already open, and select All at the top of the panel.


12. Click an existing rule or style in the All Rules pane of the 
CSS Styles panel to display its properties in the 
Properties pane.


13. Return to the Google web fonts Use page, and copy the 
name of the font family you want to use in your web page  
from the list in Step 4 (Figure 8).


14. Return to Dreamweaver. In the CSS Styles panel, double-
click the rule to which you want to apply the Google web 
font.


The CSS Rule Definition dialog box appears.


15. Paste the copied font-family name into the Font-Family 
text box (Figure 3).


16. Select File > Save All.


17. Select File > Preview In Browser, and then select a 
browser where you can preview the remote Google web 
font (Figure 9).


Figure 5 Step 3 of the Use page, Google web fonts


Figure 6 Document toolbar in Dreamweaver


Figure 7 Link to Google web fonts in the head 
section


Figure 8 Step 4 of the Use page, Google web fonts 


Figure 9 Google web fonts used in headings
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To dowload and embed Google web fonts:


1. Visit the Google web fonts site at www.google.com/
webfonts. 


2. You may be required to register


.


3. Search or browse the selection of font families; then click 
the Add To Collection button next to each font you want 
to use.


4. Click the Review button to compare and refine your 
collection and to see the styles in a customizable sample 
layout.


5. Click the Use button, and verify the settings.


6. Click the Download Your Collection link in the upper-
right corner of the Use page (Figure 10).


The Download The Fonts In Your Collection dialog box 
appears (Figure 11).


7. Click the Download The Font Families In Your 
Collection As A Zip-file link to download the files to 
your computer.


8. Unzip the file and save to the location of your choice. 


9. Open the folder containing the downloaded font and 
make note of the file type. 


It will have one of four types of web font extensions: 
EOT, WOFF, TTF, or SVG. You will need this 
information in the next few steps. The font in the 
example folder is Bree Serif, Regular, and it is a TTF 
font. 


10. Switch to Dreamweaver.


11. Select Modify > Web Fonts.


The Web Fonts Manager dialog box appears (Figure 13).


Figure 10 Download your Collection link


Figure 11 Download The Fonts In Your Collection 
dialog box


Figure 12 Downloaded fonts


Figure 13 Web Fonts Manager dialog box
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12. Click the Add Font button.


The Add Web Font dialog box appears (Figure 14).


13. Click the folder icon beside the file type of your 
downloaded font, navigate to the location of the saved 
font, and select it.


14. Click Open in the Open dialog box.


The font is added to the Add Web Font dialog box.


15. Click OK to close the Add Web Font dialog box.


The font is added to the Web Fonts Manager dialog box.


16. Click Done to close the Web Fonts Manager dialog box.


17. Open the CSS Styles panel (Window > CSS Styles), if it 
isn’t already open, and select All at the top of the panel.


18. In the All Rules pane, double-click the rule to which you 
want to apply the Google web font.


The CSS Rule Definition dialog box appears.


19. In the Font-Family menu, select the Google web font that 
you downloaded and added.


20. Select File > Save All.


21. Select File > Preview In Browser, and then select a 
browser where you can preview the embedded Google 
web font (Figure 9).


Figure 14 Add Web Font dialog box
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How to apply colors and gradients
Each Flash document holds its own color palette. You can use the Color panel to apply colors that aren’t in the default 
web-safe palette of 216 colors. You can create new colors and add them to the palette, which you can save for later 
use. You can also incorporate new colors into gradient fills and store your gradients for repeated use. A gradient is a 
multi-color fill in which one color gradually changes into another.


Gradients can be helpful when creating effects, such as glows, photo-realistic spheres, solar flares, and glowing 
buttons. With Adobe Flash Professional CS6 you can create two types of gradient fills—linear and radial.


Applying colors
You apply and manage colors by using the Color panel.


To apply colors:


1. Start Flash and open a new blank document 
(ActionScript 3.0).


2. Use the Oval tool to create a simple shape on the Stage.


3. You can adjust the fill and stroke colors by using the 
Properties panel. To apply a color that is not in the 
current palette, use the Color panel (Figure 1).


If the Color panel is not open, select Window > Color.


4. Make sure you have selected both the stroke and fill of 
your shape.


Note: To select the stroke and fill of your shape, double-
click the shape with the Selection tool.


5. In the Color panel, click the paint bucket icon (not the 
color box next to it) to select the Fill Color section. 
Choose a color in one of the following ways:


• You can select a new fill color in the palette by 
clicking Saturation and choosing a color in the Fill 
Color control (Figure 1). Drag the Brightness 
control to adjust the tint.


• You can select a new fill color by clicking Hue, 
dragging the Color control, and choosing a tint in the 
Fill Color control (Figure 2).


• You can also enter a hexadecimal number for the 
color. This is helpful if a client provides hexadecimal 
values. 


• You can also adjust red, green, and blue values by 
dragging their scrubbers. Use the Alpha slider to 
adjust the level of transparency.


6. To browse for a color, click and drag in the color picker. 
To adjust the tint, drag the Brightness control.


Figure 1 Color panel with Saturation selected


Figure 2 Color panel with Hue selected


Fill color control


Color picker


Brightness 
control


Hexadecimal 
value


Alpha


Saturation selected


Hue 
selected
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Color control
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As you drag, the colors you point to are shown in the 
Current Color Swatch area and in the Fill Color control 
(Figure 3). (Once you release the mouse, the new color 
displays.)


Figure 3 Picking a new color


Add colors to the palette
Once you have mixed your own colors, you can use them to create a custom palette. You do this with the Color panel 
and the Swatches panel.


To add colors to the palette:


1. Make sure the Color panel is open.


If the Color panel is not open, select Window > Color.


Note: The Color panel and the Swatches panel exist in 
the same panel group (Figure 4).


2. In the Color panel, use the color picker or the RGB boxes 
to create a new color.


3. In the Color panel menu, select Add Swatch (Figure 4).


4. Click the Swatches tab to view the Swatches panel.


The new color swatch appears at the bottom of the palette 
in the Swatches panel (Figure 5).


Figure 4 Color and Swatches panels


Figure 5 Swatches panel


Current color
Old color


New color swatch
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Web-safe colors palette


By default, the Swatches panel displays the web-safe colors palette. This palette is designed to work for all visitors’ 
monitors, including those with older monitors that display only 256 colors. Although all newer monitors work with 
more than 256 colors, some web designers recommend continuing to use this palette so your pages appear consistent 
to all visitors. (An additional benefit is that it gives you a limited range of colors from which to choose; sometimes 
it’s easier to make good choices when these choices are limited.) If you’re sure all your viewers have newer monitors, 
you can deviate from this palette by using the Color panel.


Creating gradients
You create gradients by selecting a gradient type and adding colors to the gradient.


To create gradients:


1. Use the Selection tool to double-click the oval shape on 
the Stage.


The fill and stroke are both selected.


2. Make sure the Color panel and the Swatches panel are 
both visible.


If they are not, select Window > Color or Window > 
Swatches.


3. In the Color panel, select Radial Gradient in the Color 
Type menu (Figure 6). Selections in the Color Type 
menu determine the fill style of a shape.


This color type fills the selected shape with a radial 
gradient, composed of the two colors indicated by the 
color pointers under the gradient definition bar 
(Figure 7).


Note: By default, these colors may be set to black and 
white. 


You can have up to sixteen different colors in a gradient. 
To add more, click in the gradient definition bar 
(Figure 7).


Note: Radial gradients work best on elliptical shapes.


4. Make sure Extend Color is selected as the Flow option 
(Figure 7).


Flow lets you control colors applied past the limits of a 
gradient. The Flow options are Extend Color (the default 
mode), Reflect Color, and Repeat Color.


The gradient starts out black in the center (determined by 
the left-most color stop) and transitions to white 
(determined by the right-most color stop).


5. Double-click the left color stop under the gradient 
definition bar. Use the color picker to select a new color 
for the inner color of the gradient. The gradient definition 
bar changes color.


Figure 6 Gradient options in the Color panel


Figure 7 Gradient definition bar
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6. Click in the gradient definition bar to add a new color to 
the gradient.


A new color stop appears below the gradient definition 
bar in the Color panel (Figure 8).


7. With the new color stop still selected, click or drag in the 
color picker to select a new color for the gradient. You 
can also select colors by dragging the RGB scrubbers or 
entering a hexidecimal number (or by double-clicking the 
new color stop). 


8. Change the color of the right color stop to change the 
outer color of the gradient. 


Note: Selecting a lighter inner (left) color and a darker 
outer (right) color creates the illusion of a three 
dimensional sphere (Figure 9). 


9. Deselect the shape on the Stage to see the new gradient 
applied to your shape (Figure 10). Figure 8 Color panel


Figure 9 Gradient definition bar


Figure 10 Applied gradient
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Digital Design Project 2 worksheet

Production storyboard


Name: D. Smith                                                                                  Date: 09-20-12


Site name: Friends of the Golden Gate


Page title: Golden Gate Home Page                                                   Filename:  index.html                                   


Wireframe (everything specific to this page; common navigation elements optional)


Background color (name and/or hexadecimal value): cream (#FFFCCC)


Heading texts (fonts, styles, borders, margins, alignment, padding, colors): Arial, 18 points, bold, left-aligned, 6 pixel 
padding on top and bottom, black text.


Body texts (fonts, styles, borders, margins, alignment, padding, and colors): Body - Times New Roman, 11 points, left 
aligned, black text. Link Body - Times New Roman, 10 points, left aligned, dark brown text, underlined.


Description (what happens on the screen, such as order of display, text, and animation steps): The navigation buttons 
will all turn a shade lighter when a site visitor rolls the pointer over one of them. When the pointer is not over any of 
the navigation buttons, they all display the same darker color.


Navigation (button or link names and destinations):


Home: Goes to index.html, History: Goes to history.html, Tourist Information: Goes to tourist.html


Hours/Directions: Goes to hours.html


Links: Each link goes to one of the following:


◦ San Francisco Museum (www.sfmuseum.org/assoc/bridge00.html)


◦ Geometry of Bridge Construction (www.faculty.fairfield.edu/jmac/rs/bridges.htm)


◦ Pictures of the Golden Gate Bridge (www.pcimagenetwork.com/golden/golden.htm)


Graphics files (all graphics specific to this page): ggate_logo.png and ggate_logo.gif.
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Production storyboard worksheet


Name: _______________________________________________________ Date: ________________________


Site name:____________________________________________________


Page title: ____________________________________________________ Filename: ____________________


Wireframe (everything specific to this page; common navigation elements optional) 


Background color (name and/or hexadecimal value) ___________________________________________________


Heading texts (fonts, styles, borders, margins, alignment, padding, and colors) ______________________________


Body texts (fonts, styles, borders, margins, alignment, padding, and colors) ________________________________


Description (what happens on the screen, such as order of display, text, and animation steps)


Navigation (button or link names and destinations): ____________________________________________________


Graphics files (all graphics specific to this page) ______________________________________________________
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How to get started with ActionScript
ActionScript 3.0 is the scripting language of Adobe Flash Professional CS6. You can use ActionScript to add 
complex interactivity, playback control, and data display to your application. For example, you might want to animate 
a picture of a boy walking. By adding ActionScript, you could have the animated boy follow the pointer around the 
screen, stopping whenever he collides with a piece of animated furniture.


ActionScript is an object-oriented programming language. Object-oriented programming is a way to organize the 
code in a program, using code to define objects and then sending messages back and forth between those objects.


You don’t have to be a programmer to take advantage of ActionScript (see “Using Script Assist mode” later in this 
guide). But the following concepts will help:


• Class: The code that defines an object. This code consists of properties, methods, and events. Think of the 
blueprint of a house: you can’t live in the blueprint, but you need it so you can build the house. You use 
classes to create objects.


• Object: An instance of a class. When you instantiate an object (create an instance of it), you declare what 
class it is created from and set its properties. You can create as many objects as you want from a single 
class—if you have a bicycle class, you can create many bicycle objects, each with its own properties (one 
bicycle might be red while another might be green).


• Property: One of the pieces of data bundled together in an object. A property helps define an object—it 
provides the object’s characteristics. A song object might have properties named melody and title. You set 
the properties of an object when you create the object, but you can change them later as needed. A property 
is a variable that belongs to an object.


• Variable: A name that represents a value in the computer’s memory. As you write code, you write the 
variable’s name as a placeholder for the value. This allows you to write code even if you don’t know all the 
possible values a user might provide. If you create a variable firstName, you can tell your program to 
display the user’s first name without knowing in advance what the user’s first name is.


• Method: An action that can be performed by an object. For example, the class horse might have a method 
called gallop(). When the method gallop() is called, it shows an animation of the horse galloping from one 
point to another.


• Function: A block of code that carries out specific tasks and can be reused in your program. For example, 
you might create a function called checkEmail() to verify that a user has provided text that can actually be 
used as an e-mail address. If you ever want to update the function, you only have to do it once instead of in 
each place where e-mail addresses must be validated. You can also think of a method as a function attached 
to an object.


• Event: Something that happens in a Flash movie that ActionScript is aware of and can respond to. Many 
events are related to user interaction—for example, a user clicking a button or pressing a key on the 
keyboard. The technique for specifying certain actions that should be performed in response to particular 
events is known as event handling.


If you’ve worked with symbols in Flash, you’re already used to working with objects. Imagine you’ve defined a 
movie clip symbol—say a drawing of a rectangle—and you’ve placed a copy of it on the Stage. That movie clip 
symbol is also an object in ActionScript; it’s an instance of the MovieClip class. The main timeline of a Flash movie 
also belongs to the MovieClip class.


You can modify various characteristics of any movie clip. When a movie clip is selected, the Properties panel shows 
some of the characteristics you can change, such as its X coordinate or its width. Or you can make color adjustments 
such as changing the clip’s alpha (transparency). Other Flash tools let you make more changes, such as using the Free 
Transform tool to rotate the rectangle. Any way you can modify a movie clip symbol in the Flash authoring 
environment you can also do in ActionScript. In ActionScript, you use the methods of the MovieClip class to 
manipulate or change the properties of your movie clip.
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For more about object-oriented programming, see Programming ActionScript 3.0, “Object-oriented Programming in 
ActionScript” (in Flash, select Help > Flash Help).


Using Script Assist mode
You can add ActionScript in the authoring environment by using the Actions panel (Figure 1). The Script Assist 
mode in the Actions panel can simplify the coding process.


Figure 1 Actions panel in Script Assist mode


In Script Assist mode, you can add ActionScript to your Flash document without writing the code yourself. You 
select actions from the Actions toolbox and set the options for each action in the parameters area. You must know a 
little about what functions to use to accomplish specific tasks, but you don’t have to learn syntax (the grammar of 
ActionScript). Many designers and nonprogrammers use this mode.


One of the first things to learn is how to stop your movie at a certain spot. You will also learn how to send the 
playhead to a particular frame in the movie.


Actions toolbox


Script navigator


Parameters area


Script Assist 
button


Script pane
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To use ActionScript to stop a movie:


1. Start Flash and open a movie. Create a layer in your 
movie named actions. In the frame that corresponds to 
the end of your movie, insert a new keyframe.


2. If the keyframe is not selected, select it by clicking it.


3. Select Window > Actions to display the Actions panel.


4. If you don’t see the parameters area in the Actions panel, 
click the Script Assist button in the upper-right corner 
(Figure 2).


Classes are organized into packages. You want to add a 
stop() action to a movie clip (in this case, your timeline is 
the movie clip), so you must locate the MovieClip class. 
The MovieClip class is part of the Flash.Display 
package.


5. In the Actions toolbox on the left side of the Actions 
panel, scroll down and click the Flash.Display package to 
display the classes it contains.


6. Scroll down again to find the MovieClip class and click 
to expand it (Figure 3).


7. Click Methods to view the methods available for the 
MovieClip class.


Figure 2 Actions panel


Figure 3 Movie Clip class


Script Assist button
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8. Scroll down to the Stop method. Do one of the following: 


• Double-click the Stop method.


• Drag the Stop method into the Script pane.


Code for applying the Stop method appears in the Script 
pane (Figure 4). The first line (import 
flash.display.MovieClip();) imports the code necessary 
for the MovieClip class. The second line is the Stop 
action itself. The code not_set_yet indicates you need to 
finish the code. You can use Script Assist to do this.


9. Click in the Object field in the parameters area of the 
Actions panel.


The Insert Target Path button is now active. The target 
path helps you locate the object you are trying to control.


10. Click the Insert Target Path button (Figure 4).


The Insert Target Path dialog box appears (Figure 5).


11. Select the Relative option and click Root.


This sets the target path to this.


12. Click OK to close the Insert Target Path dialog box.


The completed script for the Stop method appears in the 
Script pane (Figure 6). This code will cause your movie 
to stop playing at the end of the movie, Frame 20.


Note: In ActionScript, this is used the same way that you 
would refer to yourself as “me” instead of using your full 
name. Remember that the main timeline is an instance of 
the MovieClip class. In Figure 6, Flash uses this to refer 
to the movie clip that Frame 20 belongs to.


13. Close the Actions panel.


Figure 4 Stop method


Figure 5 Insert Target Path dialog box


Figure 6 Stop method applied to frame 20


Insert Target Path button


Frame number
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Event handling
The technique for specifying certain actions that should be performed in response to particular events is known as 
event handling. Event handling consists of three important elements:


• The event source: Which object will trigger the event? For example, which button will be clicked, or which 
Loader object is loading the image?


• The event: What is going to happen, what interaction do you want to respond to? Identifying the event is 
important, because an object can trigger (and listen for) several events.


• The response: What action(s) do you want performed when the event happens?


When an ActionScript program is running, Adobe Flash Player just sits and waits for certain events to happen, and 
when those events happen, the player runs the specific ActionScript code you’ve specified for those events. For the 
program to know what events are important, you must create an event listener. Flash Player executes an event listener 
in response to specific events.


Adding an event listener is a two-step process:


• First, you create a function or class method for Flash Player to execute in response to the event. This function is 
sometimes called the listener function.


• Second, you use the addEventListener() method to connect the listener function with the target of the event. The 
addEventListener() method tells Flash what object to listen to, what event to listen for, and what function to 
execute in response.


To use ActionScript to go to another frame:


1. Create a button users can click to go to a particular frame 
in your movie. Make sure you place the button on the 
Stage (Figure 7).


2. Select the button and use the Properties panel to give the 
button a unique instance name (Figure 8).


3. In the main timeline of your movie, create a layer named 
actions.


4. Create a keyframe in the actions layer that corresponds to 
the keyframe where your button first appears on the 
Stage. Select this keyframe in the actions layer.


Note: If your button doesn’t appear in this frame, Flash 
will generate an error message because you are referring 
to an object that isn’t on the Stage yet.


5. Select Window > Actions to display the Actions panel.


6. If you don’t see the parameters area in the Actions panel, 
click the Script Assist button.


7. In the Actions toolbox on the left side of the Actions 
panel, scroll down and click the Flash.Events package to 
display the classes it contains.


8. Scroll down to the IEventDispatcher class and click it to 
open it.


9. Click Methods to display methods for the 
IEventDispatcher class.


Figure 7 Button instance


Figure 8 Button instance


Instance name
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10. .Double-click the addEventListener method to add it to 
the Script pane (Figure 9).


11. Click in the Object field in the parameters area of the 
Actions panel.


The Insert Target Path button is now active.


12. Click the Insert Target Path button.


The Insert Target Path dialog box appears (Figure 10).


13. Select the Relative option and select the instance name of 
your button. Click OK to close the dialog box.


The event listener is attached to the instance of your 
button (Figure 11). 


Next, you select an event to listen for.


Figure 9 The addEventListener method in the 
Actions toolbox


Figure 10 Insert Target Path dialog box


Figure 11 Event listener code in the Script pane
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14. In the Actions toolbox on the left side of the panel, select 
the CLICK property from the MouseEvent class 
(Figure 12).


To find the CLICK property, open Flash.Events, open 
MouseEvent, and open Properties.


15. In the Script pane, select the addEventListener() line to 
display the parameters for this method. Then, in the 
parameters area, click in the Type field.


16. In the Actions toolbox, double-click the CLICK property.


Script Assist adds the property to your code as  
MouseEvent.CLICK (Figure 13).


Now your code will listen for a click on the button. To 
tell the event listener how to respond when that click 
occurs, you next create a function.


17. In the parameters area, type a name for your function in 
the Listener field, such as startMovie. You can use any 
name you like, but make sure the name of the function is 
unique and contains no spaces (Figure 14).


The function name appears in the Script pane as you type. 
You have named the function, but you haven’t created it 
yet.


18. In the Actions toolbox, select the function keyword from 
Language Elements.


To find the function keyword, expand Language 
Elements. Then expand Statements, Keywords & 
Directives, and expand Definition Keyword.


19. Double-click the function keyword in the Actions 
toolbox.


The code for creating a function appears in the Script 
pane (Figure 15).


20. In the parameters area of the Script pane, type the name 
of your function in the Name field.


Note: You must type the function name exactly as you 
typed it for the AddEventListener function in Step 17. 
Function names are case-sensitive.


21. In the parameters area of the Script pane, type 
event:MouseEvent in the Parameters field.


In this field, you are naming a variable (event) and 
indicating what type of variable it is (MouseEvent).


Figure 12 CLICK property in the Actions toolbox


Figure 13 CLICK property in the Script pane


Figure 14 Function name in the Listener field


Figure 15 Function code
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22. In the parameters area of the Script pane, select Void 
from the Type pop-up menu.


Some functions return a value when called. The keyword 
void indicates that this function does not return a value.


Now you can tell the function what you want it to do 
when the CLICK event occurs.


23. In the Actions toolbox on the left side of the panel, select 
the GotoAndPlay method for the Flash.Display class 
(Figure 16).


To find the GotoAndPlay method, expand Flash.Display, 
and then expand MovieClip and Methods.


24. Select the function in the Script pane and double-click 
the GotoAndPlay method in the Actions toolbox.


The method is added to the function (Figure 17).


25. Click in the Object field in the parameters area of the 
Actions panel.


The Insert Target Path button is now active.


26. Click the Insert Target Path button to display the Insert 
Target Path dialog box.


27. Select the Relative option and select the movie clip you 
want to play when the button is clicked. If you want the 
movie in the main timeline to play, select Root to set the 
target path to this.


28. Click OK to close the Insert Target Path dialog box.


29. In the Frame field, type the number of the frame you 
want to send the playhead to. For example, if you want 
the movie to start from the beginning, type the number 1 
to play the movie’s first frame.


30. Close the Actions panel.


31. Save the movie.


32. Select Control > Test Movie > In Flash Professional to 
test the movie.


33. Select File > Close to close the preview window.


Figure 16 GotoAndPlay method


Figure 17 GotoAndPlay method in the Script pane


For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash, 
select Help > Flash Help).
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Using code snippets
In the Code Snippets panel you can start using simple ActionScript 3.0 very quickly, without knowledge of 
programming or ActionScript 3.0. You can add ActionScript 3.0 code to your Flash file to enable common 
functionality. Here are some of the code snippets you might use:


• Drag And Drop. Users can drag the symbol around the Stage.


• Move With Keyboard Arrows. Users can move the symbol with the keyboard arrows.


• Click To Go To Frame And Stop. The playhead moves to a specific frame and then stops when users click the 
symbol.


• Click To Play/Stop Sound. A sound plays when users click the symbol.


Adding a code snippet to a movie clip symbol instance


You can add code snippets to movie clip symbol instances. Symbols are stored in the library. Whenever you place a 
symbol on the Stage, you are actually placing an instance of the symbol on the Stage. For ActionScript to act on a 
symbol instance, you must give the instance a name.


To add a code snippet to a movie clip symbol instance:


1. Draw an object on the Stage, such as an oval.


2. Convert the object to a Movie Clip symbol.


3. With the object selected, open the Properties panel. 


4. In the Instance Name text box, enter a name for the 
symbol instance (Figure 18). 


5. Select Windows > Code Snippets.


The Code Snippets panel opens (Figure 19).


6. With the movie clip instance still selected, double-click 
the Animation folder in the Code Snippets panel.


Figure 18 Properties panel.


Figure 19 Code Snippets panel
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7. Select the Move With Keyboard Arrows code snippet.


8. Click the Add To Current Frame button in the Code 
Snippets panel (Figure 20).


The Actions panel opens, showing the ActionScript in the 
code snippet (Figure 21).


The Move With Keyboard Arrows code snippet lets users 
move the movie clip with the keyboard arrows when the 
movie runs. For information on other code snippets, see 
Flash Help.


9. After looking at the ActionScript you added, close the 
ActionScript window.


When you added the code snippet, Flash added a new 
layer in the Timeline panel named Actions (Figure 22).  
The ActionScript for the code snippet appears in a new 
keyframe in the Actions layer.


10. Test the movie. Observe that the object moves with the 
keyboard arrows.


Figure 20 Code Snippets panel


Figure 21 Actions panel


Figure 22 Timeline panel
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import flash.media.StageWebView;button_back_maphome.addEventListener(MouseEvent.CLICK, fl_ClickToGoToAndStopAtFrame_maphome);function fl_ClickToGoToAndStopAtFrame_maphome(event:MouseEvent):void{	webView.dispose();	gotoAndStop(1);}var webView:StageWebView = new StageWebView(); webView.viewPort = new Rectangle( 0, 80, this.stage.stageWidth, this.stage.stageHeight-80); webView.stage = this.stage;//load url with map for san francisco//note that if you are testing on the desktop - the desktop version of google maps will display (AIR debug launcher for mobile does not display google mobile maps)webView.loadURL("http://maps.google.com/maps?f=q&source=s_q&hl=en&geocode=&q=san+francisco&aq=&sll=37.0625,-95.677068&sspn=46.092115,63.808594&ie=UTF8&hq=&hnear=San+Francisco,+California&z=12");





