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How to add images
Images are common elements of most websites. You add images by inserting them from an existing file. 


In this activity, you create a simple web page by adding an image to the page.


Adding images
Many different types of graphic file formats exist, but three graphic file formats are generally used in web pages—
GIF, JPEG, and PNG. GIF and JPEG file formats are the best supported and can be viewed by most browsers. 


When you insert an image into a Dreamweaver document, a reference to the image file is generated in the HTML 
source code. To ensure that this reference is correct, the image file must be in the current site. If it is not in the current 
site, Dreamweaver asks whether you want to copy the file into the site.


After you insert an image, you can set image tag accessibility attributes that can be read by screen readers for visually 
impaired users. These attributes can be edited in HTML code.


To add an image:


1. Click on the index.html tab in the document window.


2. Position the insertion point where you want to add an 
image.


3. Select Insert > Image.


The Select Image Source dialog box opens (Figure 1).


4. Browse to the folder that contains the image you want to 
place in the document.


5. Select the image.


A preview of the image appears in the right side of the 
dialog box (Windows).


6. Click OK (Windows) or Choose (Mac OS).


If the image is not in your site folder, Dreamweaver asks 
if you want to copy the file there (Figure 2). If the image 
is already stored in your site, you can skip steps 8 and 9.


Figure 1 Select Image Source dialog box


Figure 2 File outside of root folder warning 
message


7. Click Yes.
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The Copy File As dialog box appears (Figure 3). By 
default the image will be copied to the root folder of your 
site. You can store the image in the root folder, or place 
the image in a subfolder of your site.


8. Browse to a folder in your site where you want to store 
the file, or click the Create New Folder button to create 
the destination images folder, and click Save.


The Image Tag Accessibility Attributes dialog box opens 
(Figure 4). This dialog box enables you to add a 
description to the image so that screen readers can 
interpret it.


9. Enter a brief description. You can also provide a link to a 
file with a longer description.


10. Click OK.


The image is added to your document.


11. Save the file.


Figure 3 Copy File As dialog box


Figure 4 Image Tag Accessibility Attributes dialog 
box


Set image properties
The Images Properties panel allows you to set properties for an image (Figure 5). If you do not see all of the image 
properties, click the expander arrow in the lower-right corner.


Figure 5 Properties panel, Image mode


These are a few of the commonly-used image options you can set in the Properties panel:


• W and H the width and height of the image, in pixels. Dreamweaver automatically updates these text boxes 
with the image’s original dimensions when you insert an image in a page. If you set W and H values that do 
not correspond to the actual width and height of the image, the image may not display properly in a browser. 
(To restore the original values, click the W and H text box labels, or the Reset image size button that appears 
to the right of the W and H text boxes in entering a new value.) 


Note: You can change these values to scale the display size of this image instance, but this does not reduce 
download time, because the browser downloads all image data before scaling the image. To reduce 
download time and to ensure that all instances of an image appear at the same size, use an image-editing 
application to scale images.


• Src specifies the source file for the image. Click the folder icon to browse to the source file, or type the path.


Create New File
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• Link specifies a hyperlink for the image. Drag the Point-To-File icon to a file in the Files panel, click the 
folder icon to browse to a document on your site, or manually type the URL.


• Align an image and text on the same line.


• Alt specifies alternative text that appears in place of the image for text-only browsers or for browsers that 
have been set to download images manually. For visually impaired users who use speech synthesizers with 
text-only browsers, the text is spoken out loud. In some browsers, this text also appears when the pointer is 
over the image. 


To set alignment of an image:


1. Select the image you placed in the document in the 
previous section (Figure 6).


2. Click the Align option menu and set the image alignment 
to Left  (Figure 7).


The image aligns left, and the text wraps around the 
image (Figure 8).


3. Save the file.


Figure 6 Selected image


Figure 7 Properties panel, Align options


Figure 8 Image left-aligned
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How to create and edit a CSS rule
You can create and edit a CSS rule in two locations: the Properties panel and the CSS Styles panel. When you apply 
CSS styles to text by using the Properties panel or menu commands, CSS rules are embedded in the head of the 
current document. You can also use the CSS Styles panel to create and edit CSS rules and properties. 


In this guide, you review CSS rules, create and apply a class-style CSS rule by using the Properties panel, and modify 
an HTML tag-style rule by using the CSS Styles panel.


About CSS rules
A CSS formatting rule consists of two parts: the selector and the declaration (or in most cases, a block of 
declarations). The selector is a term (such as p, h1, a class name, or an id) that identifies the formatted element. The 
declaration block defines the style properties. In the following example, h1 (a heading tag) is the selector, and 
everything that falls between the braces ({and }) is the declaration block (defining the properties of the h1 heading):


h1 { 


font-family: Georgia, "Times New Roman", Times, serif;


font-size: 18px;


text-transform: uppercase;


color: #090; 


}


An individual declaration consists of two parts: the property (such as font family) and value (such as Georgia). In the 
previous CSS rule, a particular style has been created for h1 tags; the text for all h1 tags linked to this style will be 18 
pixels in size, Georgia font, uppercase, and bright green (hex value #090). 


The style (which comes from a rule, or a collection of rules) resides in a place separate from the actual text it’s 
formatting—usually in an external style sheet or in the head section of an HTML document. Thus, one rule for h1 
tags can apply to many tags at once (and in the case of external style sheets, the rule can apply to many tags at once on 
many different pages) (Figure 1). In this way, CSS provides extremely easy update capability. When you update a 
CSS rule in one place, the formatting of all the elements that use the defined style is automatically updated to the new 
style.


Figure 1 Updating a CSS rule in one place updates all elements
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There are three main types of CSS:


Class style: Similar to the styles you use in word processing and page layout programs. For example, you may 
want to format all body text in 10-point, Arial, dark green type. You can create a class style with these attributes 
and then apply this style to all body text in your website. Class names must begin with a period and can contain 
any combination of letters and numbers (for example, .myhead1). 


HTML tag style: Applies global formatting to individual HTML tags rather than to individual selections. 
Suppose you want to modify the Heading 1 paragraph style to appear always in purple text. Instead of creating a 
class style and applying it to every heading in the document, you can create an HTML tag style with these 
attributes and apply it to the Heading 1 <h1> tag. In effect, you are redefining the HTML tag.


ID style: A unique identifier (ID) for a style applied to headers, banners, menus, and other elements present in 
only one location in the document. Used once within a document or page. IDs must begin with a pound (#) sign 
and can contain any combination of letters and numbers (for example, #myID1). 


CSS rules can reside in the following locations:


Internal (or embedded) CSS style sheets are collections of CSS rules included in a style tag in the head section of 
an HTML document.


External CSS style sheets are collections of CSS rules stored in a separate, external CSS (.css) file (not an HTML 
file). You link this file to one or more pages in a website with a link or an @import rule in the head section of a 
document. 


Creating a new CSS rule from the Properties panel
In the CSS Properties panel, you can access Targeted Rules and create new ones (Figure 2). A Targeted Rule is a rule 
you are editing in the CSS Properties panel. When you have an existing style applied to text, the rule affecting the 
text’s format appears when you click inside the text on the page. You can also use the Targeted Rule pop-up menu to 
create new CSS rules and new in-line styles or apply existing classes to selected text. 


Figure 2 Properties panel, CSS mode


How you edit your CSS depends on selection level. To access rules that apply to a current selection only, you can use 
the Targeted Rule pop-up menu in the CSS Properties panel. To access all CSS rules for a page, you can use the CSS 
Styles panel. The CSS Styles panel will be reviewed in the next guide.


In this section, you use the Properties panel to create a simple CSS class-style rule to format a block of text.
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To create a new CSS rule in the Properties panel:


1. Start Dreamweaver.


2. Select File > New to create a new document.


The New Document dialog box appears (Figure 3).


3. In the Blank Page category of the New Document dialog 
box, select HTML Page Type to create a plain HTML 
page.


4. In the Layout column, select None. 


5. Click the Create button.


The new HTML page opens.


6. In the Document toolbar, click the Show Code And 
Design Views (Split) button (Figure 4).


Being able to view the code that Dreamweaver generates 
for creating styles will be useful to help you understand 
and write your own CSS syntax later on.


7. Type some text or paste text copied in another application 
in the Design view Document window. 


8. Press Enter (Windows) or Return (Mac OS) to create a 
new paragraph and add additional text.


9. Open the Properties panel (Window > Properties), if it 
isn’t already open, and click the CSS button to display 
the CSS Properties panel (Figure 2).


10. Use the Font menu to change the Font to Georgia, Times 
New Roman, Times, Serif (Figure 5).


The New CSS Rule dialog box appears (Figure 6).


Note: It is a good practice to assign a font combination 
instead of a single font. This ensures that most page 
visitors will view page text the same way. A browser uses 
the first font in the combination that is installed in the 
visitor’s system. If none of the fonts in the combination is 
installed, the browser displays the text as specified by the 
visitor’s browser preferences. 


Figure 3 New Document dialog box


Figure 4 Document window view options


Figure 5 Properties panel Font menu


Figure 6 New CSS Rule dialog box


Show Code And Design Views button
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11. In the Selector Type menu, select Class (Can Apply To 
Any HTML Element) (Figure 7).


12. Click in the Selector Name text box and type .myStyle 
(Figure 8).


Note: CSS rules must begin with a period and cannot 
contain spaces or special characters.


13. In the Rule Definition menu, select (This Document 
Only) (Figure 9).


This tells Dreamweaver to create and store the CSS (style 
sheet) in the current document only. The new style will 
not be available for use in other documents.


To create an external CSS document for your entire 
website, you would choose (New Style Sheet File). This 
is discussed in a later guide.


14. Click OK to close the New CSS Rule dialog box.


The new font is applied to the paragraph that contains the 
insertion point. The name of the style appears in the 
Targeted Rule box in the Properties panel (Figure 10).


Note: Because you didn’t select a specific word or 
character, you can continue to define this rule by 
applying additional formatting.


15. In the Properties panel, change the size to 18.


The font size in the paragraph that contains the insertion 
point changes accordingly.


Figure 7 New CSS Rule dialog box, Selector Type 
options


Figure 8 New CSS Rule dialog box, Selector 
Name options


Figure 9  New CSS Rule dialog box, Rule 
Definition options


Figure 10 Targeted Rule in the Properties panel

How to create and edit a CSS rule © 2012 Adobe Systems Incorporated







Adobe Dreamweaver CS6 Project 1 guide

16. Click the Color box in the Properties panel and select a 
new color for the text.


The Properties panel shows the targeted rule (.myStyle) 
and its formatting. The targeted rule is applied to the 
paragraph that contains the insertion point (Figure 11).


You can use this CSS rule to format additional text in 
your document.


Observe in Code view that Dreamweaver stores styles 
created with CSS directly in the head section of the 
document (Figure 12).


Figure 11 Formatted paragraph text


Figure 12 Detail of new CSS rule, Code view
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Applying CSS styles
After you create a CSS rule, you can use it to give your entire document or website a consistent appearance. You can 
apply a CSS rule to text by using the Properties panel.


To apply a CSS style:


1. Click anywhere in the paragraph that doesn’t have the 
new CSS style.


2. In the Properties panel, select myStyle (the new CSS rule 
you just created) from the Targeted Rule menu 
(Figure 13).


The new style is applied to the other paragraph 
(Figure 14).


Note: If you edit the CSS style, both paragraphs will be 
updated automatically and consistently. You will learn 
more about creating and modifying CSS in a later guide.


Figure 13 Targeted Rule menu


Figure 14 CSS style applied to both paragraphs


Using the CSS Styles panel
In the CSS Styles panel you can track the CSS rules and properties affecting a currently selected page element 
(Current mode) or all of the rules and properties available to the document (All mode). A button at the top of the 
panel enables you to switch between the two modes. You can also use the CSS Styles panel to modify CSS properties 
in both All and Current modes. 
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The CSS Styles panel in Current mode


In Current mode, the CSS Styles panel displays three panes: a Summary For Selection pane that displays the CSS 
properties for the current selection in the document, a Rules pane that displays the location of selected properties (or 
a cascade of rules for the selected tag, depending on your selection), and a Properties pane where you can edit CSS 
properties for the rule applied to the selection (Figure 15).


Figure 15 CSS Styles panel, Current mode


The CSS Styles panel in All mode


In All mode, the CSS Styles panel displays two panes: an All Rules pane, and a Properties pane. The All Rules pane 
displays a list of rules defined in the current document as well as all rules defined in style sheets attached to the 
current document. You can use the Properties pane to edit CSS properties for any rule selected in the All Rules pane 
(Figure 16).


Figure 16 CSS Styles panel, All mode


New CSS Rule Edit RuleAttach Style Sheet
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To add a CSS rule by using the CSS Styles panel:


1. Start Dreamweaver.


2. Create a new HTML document.


3. Save and name the Dreamweaver document.


4. Type some text in the document. Make sure no 
formatting is applied to the text (Figure 17).


5. Make sure the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


6. To create a new style, click the New CSS Rule button (+) 
at the bottom of the panel (Figure 15).


The New CSS Rule dialog box appears (Figure 18).


7. In the Selector Type pop-up menu, select Class. 


This option creates a new Class rule.


8. In the Selector Name text box, type a name for the style 
such as .warning.


Note: Class rule names must begin with a period and 
cannot contain spaces or special characters. If you forget 
to type the period, Dreamweaver adds this automatically.


9. In the Rule Definition pop-up menu, select (This 
Document Only) or (New Style Sheet File). 


The option (This Document Only) defines the style as 
part of the document’s internal style sheet. The option 
(New Style Sheet File) defines the style as part of an 
external style sheet.


Note: If you choose to create an external style sheet by 
selecting (New Style Sheet File), you are prompted to 
select a location for the new style sheet (.css) document.


10. Click OK.


The CSS Rule Definition dialog box appears (Figure 19).


11. Select options for Type, such as the following: 


• Select Arial, Helvetica, Sans-serif in the Font-
Family pop-up menu


• Select 12 from the Font-Size pop-up menu, and 
select px (pixels) for the measurement unit.


• Type #CC0033 in the Color text box, or select a 
color in the color picker.


Figure 17 Text with no formatting applied


Figure 18 New CSS Rule dialog box


Figure 19 CSS Rule Definition dialog box, Type 
options 
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12. To change the formatting of text blocks, select Block in 
the Category pane.


The Block category of the CSS Rule Definition dialog 
box opens (Figure 20).


13. In the Letter-Spacing text box, you can make changes 
such as typing 3 and selecting pixels for the measurement 
unit.


This setting adds space between letters. 


14. In the Text-Indent box, you can make changes such as 
typing 5 and selecting pixels for the measurement unit.


15. Click OK.


The CSS Rule Definition dialog box closes.


16. Select the document text.


17. Make sure the Properties panel is open and the HTML 
option is selected.


The Properties panel is docked at the bottom of the 
screen. If it is not open, select Window > Properties.


18. Select warning, or the name of your style, from the Class 
pop-up menu (Figure 21).


19. In the document, deselect the text by positioning the 
mouse pointer next to it and clicking once.


Observe that the format of the text has changed 
(Figure 22).


20. Make sure the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


21. Make sure All is selected in the CSS Styles panel. If no 
styles are listed under <style> in the All Rules pane, click 
the plus (+) symbol (Windows) or the disclosure triangle 
(Mac OS).


Observe that the newly created CSS rule now appears 
under <style> in the All Rules pane, indicating the new 
rule is part of a CSS style sheet. Also observe that if you 
select the style name in the All Rules pane, properties for 
the style appear in the Properties pane.


Figure 20 CSS Rule Definition dialog box, Block 
options 


Figure 21 Text Properties panel


Figure 22 Formatting applied to text
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Edit styles


After you create styles, you can still make changes to them by using the Edit Rule button.


To edit styles:


1. To view a style sheet’s rules, click the plus symbol 
(Windows) or disclosure triangle (Mac OS) beside 
<style> in the All Rules pane of the CSS Styles panel.


Dreamweaver displays the style sheet’s rules 
(Figure 23). 


2. Select the rule or style you want to edit.


3. At the bottom of the CSS Styles panel, click the Edit Rule 
button.


The CSS Rule Definition dialog box for the selected style 
appears (Figure 24).


4. Make formatting changes in the CSS Rule Definition 
dialog box. Then click OK.


The changes take effect immediately. 


If you are editing an external style sheet, the same 
changes are applied to any other documents attached to 
this style sheet.


Figure 23 CSS Styles panel


Figure 24 CSS Rule Definition dialog box


Edit Rule 
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The Dreamweaver Insert panel
In Adobe Dreamweaver CS6, the Insert panel contains buttons for inserting various types of objects, such as images 
and forms, into a Dreamweaver document.


You can use the Insert panel to create or insert content in eight categories:


• The Common category contains buttons for inserting the most commonly used objects, such as links, 
images, and tables.


• The Layout category gives you options to insert tables, table elements, div tags, frames, and Spry widgets. 
You can view tables in either Standard (default) mode or Expanded Tables mode. 


• The Forms category contains buttons for creating forms and inserting form elements.


• The Data category lets you insert dynamic elements such as recordsets, repeated regions, and record 
insertion and update forms.


• The Spry category lets you insert “widgets” that display data from other files and various interface elements 
(such as navigation bars and menus) that rely on JavaScript and CSS. (Spry widgets are not covered in this 
study, but you can read find out more about them in Dreamweaver Help (select Help > Dreamweaver Help 
and look for the section called “Building Spry pages visually.”)


• The jQuery Mobile category provides content layout options, input, UI and form controls for developing 
mobile applications using Dreamweaver.


• The InContext Editing category is used to enable end users to make simple edits to their web pages without 
help from you or additional software on their computers. Adobe InContext Editing (ICE) is an online hosted 
service that provides simple content editing capabilities within a web browser. 


• The Text category is used for working in Code view and enables you to insert a variety of text- and list-
formatting tags, such as b, em, p, h1, and ul.


• Use the Favorites category to customize a list of Insert panel buttons for fast access. You can customize this 
category by right-clicking (Windows) or Control-clicking (Mac OS) the Insert panel.


The Insert panel menu
You switch between these categories by using the Insert panel menu, which is located at the top of the Insert panel 
(Figure 1). To hide or show the Insert panel select Window > Insert.


Figure 1 Insert panel, Category pop-up menu
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To display the pop-up menu for a button, click the disclosure triangle beside the button’s icon (Figure 2).


Figure 2 Insert panel, Images pop-up menu
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How to publish web files
Once you’ve specified a local site in Dreamweaver, you can specify a remote server for your site as well. The remote 
server (often referred to as the web server) is where you publish your site files so that people can view them online. 
The remote server is simply another computer like your local computer, with a collection of files and folders on it. 
You specify a folder for your site on the remote server, just as you specified a folder for your local site on your local 
computer (Figure 1). Dreamweaver refers to the specified remote folder as your remote site.


Figure 1 Basic screen of the Servers category, Site Setup dialog box


When you set up a remote folder, you select a connection method for Dreamweaver to upload files to your web server 
and download files from your web server. The most typical connection method is FTP, but Dreamweaver also 
supports local/network, FTPS, SFTP, WebDav, and RDS connection methods. If you don’t know which connection 
method to use, ask your teacher or your school server administrator.


Connecting to a remote site
Many websites let you publish files through FTP (File Transfer Protocol). You connect to a remote site by using the 
Site Definition dialog box in Adobe Dreamweaver CS6. 


To connect to a remote site by FTP:


1. Select Site > Manage Sites.


The Manage Sites dialog box opens (Figure 2).


2. Double-click the name of the site you want to connect 
remotely.


The Site Setup dialog box opens.


Figure 2 Manage Sites dialog box
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3. Click the Servers category in the left column.


The Servers category of the Site Setup dialog box opens (Figure 3).


Figure 3 Basic screen of the Servers category, Site Setup dialog box


4. Click the Add New Server button (+).


5. Enter the FTP access information as directed by your teacher (Figure 1).


6. Click Test to test the connection.


Dreamweaver confirms the connection.


7. Click Save.


The new server appears in the list of servers in the Site Setup dialog box.


8. Click Save to close the Site Setup dialog box.


9. Click Done to close the Manage Sites dialog box.


Add New Server
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Uploading, Synchronizing, and downloading files
Once you establish an FTP connection, you can use the Get and Put commands to transfer files from the Files panel 
(Figure 4).


Figure 4 Expanded Files panel


When you transfer a document between a local and remote folder using the Files panel, you have the option of 
transferring the document’s dependent files. Dependent files are images, external style sheets, and other files 
referenced in your document that a browser loads when it loads the document.


Note: It’s usually a good idea to download dependent files when checking out a new file, but if the latest versions of 
the dependent files are already on the local disk, there’s no need to download them again. This is also true for 
uploading and checking in files: no need if up-to-date copies are already at the remote site.


To upload the entire site for the first time:


1. In the Files panel (Window > Files), select the files to 
upload.


2. Click the Expand/Collapse button in the Files panel 
toolbar (Figure 4).


The Files panel expands.


3. Click the Connects To Remote Host button in the Files 
panel toolbar.


Dreamweaver connects to the web server.


4. Select the root folder for your site in the Local (right) 
pane.


5. Click the Put Files button in the Files panel toolbar.


6. You may be presented with a dialog box asking if you 
wish to put the entire site. Click OK.


Dreamweaver uploads the site’s files and opens the 
Background File Activity dialog box (Figure 5).


Note: To upload one or more folders or files without 
uploading the entire site, select them and click the Put 
Files button.


Figure 5 Background File Activity dialog box


Connects/Disconnects Remote Host Get Files Put Files Synchronize Expand/CollapseRefresh
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To upload a revised version of an existing file:


1. Select the file you have revised.


2. Click the Put Files button in the Files panel toolbar.


Dreamweaver uploads the revised file.


Synchronizing the files on your local and remote sites


After you’ve created files in your local and remote sites, you can synchronize the files between the two sites.


Before you synchronize your sites, you can verify which files you want to put, get, delete, or ignore. Dreamweaver 
also confirms which files have been updated after you complete the synchronization.


To synchronize files:


1. (Optional) Select specific files or folders in the Files 
panel or go to the next step to synchronize the entire site.


2. Click the Synchronize button in the Files panel toolbar to 
synchronize files.


The Synchronize Files dialog box opens (Figure 6).


3. Select the direction in which you want to copy the files:


Put Newer Files To Remote uploads all the local files that 
don’t exist on the remote server or have changed since 
the last upload.


Get Newer Files From Remote downloads all the remote 
files that don’t exist locally or have changed since the last 
download.


Get And Put Newer Files places the most recent versions 
of all the files on both the local and the remote sites.


4. Choose whether to delete the files on the destination site 
that don’t have counterparts on the origin site. (This is 
not available if you select Get and Put from the Direction 
menu.)


If you select Put Newer Files To Remote and you select 
the Delete option, then any files in your remote site for 
which there are no corresponding local files are deleted. 
If you select Get Newer Files From Remote, then any 
files in your local site for which there are no 
corresponding remote files are deleted.


Figure 6 Synchronize Files dialog box 
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5. Click Preview.


Dreamweaver analyzes the local and remote folders, and 
then the Synchronize dialog box opens (Figure 7).


Note: Before you can synchronize the files, you must 
preview the actions Dreamweaver performs to 
accomplish this task. 


If the newest version of each chosen file is already in 
both locations and nothing needs to be deleted, an alert 
appears informing you that no synchronization is 
necessary. Otherwise, the Synchronize dialog box 
appears to let you change the actions (put, get, delete, and 
ignore) for those files before executing the 
synchronization.


6. Verify the action that will be performed for each file.


7. Click OK to synchronize the files.


Figure 7 Synchronize dialog box 


Downloading files to work on them


Once your website has been published, you may want to download a file so you can revise it. You do so through the 
Remote Site pane, on the left side of the expanded Files panel.


To download a file:


1. Click the Refresh button in the Files panel toolbar 
(Figure 4) to make sure the files in the Remote Site pane 
are up-to-date.


2. Select a file to download.


3. Click the Get Files button.


If the file has any dependent files, the Dependent Files 
dialog box opens (Figure 8). 


Note: If you do not click Yes within 30 seconds, the 
Dependent Files dialog box automatically closes and 
dependent files are not downloaded.


4. Click Yes.


Dreamweaver copies the file and its dependent files to 
your local folder. The downloaded files appear in the 
right pane of the expanded Files panel.


5. Click the Disconnects From Remote Host button, and 
then collapse the Files panel.


Figure 8 Dependent Files dialog box 
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How to use the Adobe Dreamweaver Widget Browser
A web widget is a web page component containing HTML, CSS, and JavaScript. Accordions, tabbed panels, and 
calendars are examples of web widgets.


You can make your own selection of the web widgets available in Dreamweaver by using the Adobe Widget Browser 
(Figure 1). The Widget Browser is an AIR application that lets you browse, configure, and preview widgets, using a 
visual interface.


Figure 1 Adobe Widget Browser


You can browse widgets on the Adobe Exchange by using the Adobe Widget Browser, but if you want to preview 
widgets, see details, or save widgets, you’ll need to create or sign in with an Adobe ID and password. When you open 
the Widget Browser, the application window displays the Adobe Exchange view by default. This view displays all of 
the widgets available on the Adobe Exchange—those created by Adobe as well as by third-party developers.


Once you’ve saved a web widget, you can easily insert it into a web page. 


To use the Widget Browser:


1. Start Dreamweaver.


2. Select File > New to create a new document.


The New Document dialog box appears (Figure 2).


Note: You can also open an existing document to which 
you want to add a web widget.


3. Click the Blank Page category link if it’s not already 
open, and select HTML from the Page Type column and 
<none> from the Layout column.


4. Click the Create button.


5. Save the new document (File > Save).


The Save As dialog box appears.
Figure 2 New Document dialog box

© 2012 Adobe Systems Incorporated How to use the Adobe Dreamweaver Widget Browser 1







Project 1 guide Adobe Dreamweaver CS6


2


6. Navigate to your Dreamweaver site folder, name the file, 
and click Save.


7. Select Widget Browser from the Extend Dreamweaver 
menu in the Application bar (Figure 3).


The Adobe Widget Browser appears (Figure 1).


Note: You may be presented with an End User License 
Agreement if this is the first launch of the Widget 
Browser. Review the EULA, and click Accept to close it. 


8. Click the Sign In button in the upper-right corner of the 
Widget Browser window.


9. Enter your Adobe ID and password, and click Sign In.


If you don’t have an Adobe ID, click the Create Account 
button and follow the onscreen instructions to create a 
(free) Adobe account.


10. In Adobe Exchange view, review the available widgets. 
You can sort widgets by name, date created, and so on.


11. Type Spry in the Filter text box (Figure 4) and press 
Enter (Windows) or Return (Mac OS).


Six options become available. 


12. Click the Spry Image Slideshow With Filmstrip widget 
(Figure 5).


When you click the widget, the Widget Browser displays 
the Details view for the widget. The Details view 
provides more information about the widget, such as 
author, date created, and a brief summary of how the 
widget works (Figure 6).


Figure 3 Extend Dreamweaver menu


Figure 4 Adobe Widget Browser detail


Figure 5 Spry Image Slideshow With Filmstrip 
widget


Figure 6 Spry Image Slideshow With Filmstrip, Details view


Filter text box
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13. To preview the widget as it would appear in a browser, 
either click it in the Details view or click the Preview 
button at the upper-right corner of the Widget Browser.


In Preview view, you can interact with the widget as you 
would in a browser. You can also select a preset to change 
the look of the widget, or see the widget’s code by 
clicking the Code tab.


14. In either the Detail or Preview view, click the Add To My 
Widgets button in the lower-right corner of the Widget 
Browser window.


15. Review the Widget License and click Accept to close. 


The Widget Added dialog box appears and informs you 
that the selected widget has been added to My Widgets.


16. Click the Go To My Widgets button.


17. Close the Adobe Widget Browser.


To insert a web widget into a Dreamweaver document:


1. In Dreamweaver, click on the page in Design view where 
you want to insert a web widget.


2. Select Insert > Widget. 


The Widget dialog box appears (Figure 7).


3. Select the Spry Image Slideshow With Filmstrip (1.0), if 
not already selected.


Note: Only the widgets you saved in the Adobe Widget 
Browser are listed in the Widget menu. You can also 
open the Widget Browser by using the link in the dialog 
box.


4. Select the Blue option from the Preset menu.


5. Click OK.


The Spry Image Slideshow With Filmstrip is inserted into 
the document (Figure 8).


Figure 7 Widget dialog box


Figure 8 Slideshow in Design view


Widget Browser link Widget menu Preset menu
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6. In the Document toolbar, click the Live button 
(Figure 9).


Viewing the Spry Image Slideshow in Live view allows 
you to preview and test the widget as it would appear in a 
web browser (Figure 10).


7. Save the file.


The Spry Image Slideshow With Filmstrip comes with a 
selection of preset images and text. You can customize 
the Spry Image Slideshow With Filmstrip widget by 
changing text, colors, and fonts and adding your own 
images.


Figure 9 Document window view options


Figure 10 Slideshow in Live view
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Overview of the Adobe Dreamweaver CS6 workspace
You can access Adobe Dreamweaver CS6 tools, commands, and features by using menus or by selecting options 
from one of the Insert panels or other Dreamweaver panels. The most commonly used areas of the Dreamweaver 
workspace (Figure 1) are the Document window, the Insert panel, the Properties panel, and the other panels.


The Document window displays the current document as you create and edit it. The Insert panel contains buttons for 
creating and inserting objects such as images, tables, layers, and frames you might want to add to your web pages. 
The Properties panel displays properties for the selected object or text and enables you to modify those properties. 


The Document window and panels
The Dreamweaver workspace (Figure 1) enables you to view documents and object properties. The workspace 
places many of the most common operations in toolbars so that you can quickly make changes to your documents.


Figure 1 Dreamweaver workspace, Split view (Code and Design)


Switching between views


Dreamweaver enables you to work in a variety of views. Lay out a page graphically in Design view, work directly 
with the underlying code, split the screen into both Code and Design views, or edit in Live view which presents a 
non-editable browser-based rendering of the document as you create and edit it. Change views by using the view 
buttons.


• Code view a hand-coding environment for writing and editing HTML, JavaScript, server-language code—
such PHP or ColdFusion Markup Language (CFML)—and any other kind of code. 


Application bar Document toolbar Workspace switcher Insert panel


Files panel


Document window


Design viewCode viewProperties panel Assets 
panel


View buttons


Panel groups
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• Design view a design environment for visual page layout, visual editing, and rapid application development. 
In this view, Dreamweaver displays a fully editable, visual representation of the document, similar to what 
you would see when viewing the page in a browser.


• Code and Design view (Split view) both Code view and Design view for the same document in a single 
window.


There are also two additional views related to code that dynamically changes the page--that is, code that will change 
as users interact with the page:


• Live view similar to Design view, a more realistic representation of what your document will look like in a 
browser. Live view enables you to interact with the document exactly as you would in a browser. Live view 
is not editable. However, you can edit in Code view and refresh Live view to see your changes.


• Live Code view only available when viewing a document in Live view. Live Code view displays the actual 
code that a browser uses to execute the page, and can dynamically change as you interact with the page in 
Live view. Live Code view is not editable.


To select a view, click its button in the Document toolbar (Figure 1).


Dreamweaver workspaces


You can also manage panels by using workspaces. Workspaces are pre-arranged panel settings optimized for specific 
tasks or work styles. 


To switch between workspaces:


1. Select a new workspace, such as the Designer Compact 
workspace, from the workspace switcher in the 
Application bar (Figure 2).


The panels are rearranged.


Figure 2 Workspace switcher


To create a new workspace:


1. Make changes to an existing workspace, such as by 
opening new panels or closing open panels.


2. Choose Window > Workspace Layout > New Workspace.


The New Workspace dialog box (Windows) or Save 
Workspace dialog box (Mac OS) opens (Figure 3).


3. Enter a name for the new workspace.


4. Click OK.


The workspace is now available in the workspace 
switcher and the Workspace Layout menu.


Figure 3 New Workspace dialog box
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Panels


Depending on the selected workspace, the right side of the workspace displays panels. 


Panel groups


Panels are often arranged into groups. Panel groups are panels that are docked together. For example, the Files and 
Assets panels are docked together by default in the Designer workspace (Figure 4).


Figure 4 Panel group


• To move a panel into a group, drag the panel’s tab to the highlighted drop zone in the group.


• To rearrange panels in a group, drag a panel’s tab to a new location in the group.


• To remove a panel from a group so that it floats freely, drag the panel by its tab outside the group.


• To move a floating group, drag the title bar (the area above the tabs) (Figure 5).


Working with Panels


• Opening and closing panels:To open a panel, select it from the Window menu. To close a panel, do one of 
the following:


◦ Click the Close button at the top of a floating panel.


◦ Choose Close from the panel menu.


◦ Deselect the panel in the Window menu.


• Moving panels and panel groups. To move a panel, drag it by its tab. To move a panel group or a stack of 
floating panels, drag the title bar.To dock a panel, drag the panel until the border changes to blue. Release the 
mouse to dock the panel. To undock the panel, drag it away from the left border.


• Minimizing or maximizing panels: To minimize or maximize a panel, double-click the tab or the tab area (the 
empty space next to the tab).


• Collapsing panels: Collapsing a panel makes it available as an icon (Figure 5). To collapse or expand a 
panel, do one of the following:


◦ Click the double arrow in a floating panel's title bar.


◦ Double-click the tab area.


◦ Double-click the title bar of a floating panel or group.


Figure 5 Collapsed panel


Expand panels/Collapse To Icon buttonTitle bar


Close panel
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• Docking and undocking panels: As you move panels, you see blue highlighted drop zones. Drop zones are 
areas where you can dock the panel. If you drag to an area that is not a drop zone, the panel floats freely in 
the workspace.


• Resizing panels: To resize a panel, drag either its left or bottom border. All panels have a minimum size 
beyond which they cannot be minimized. Panels can be maximized to fill your screen.


Commonly used panels


The Files panel displays the organization of your site and enables you to open files for editing, to publish files to a 
server, or to delete files.


The Assets panel contains all site assets, elements used in a site, such as images, colors, or movies. The Assets panel 
provides two ways to view assets:


• The Site list shows all of the assets in your site.


• The Favorites list shows only the assets you’ve chosen to include in the Favorites list.


The Insert panel
The Insert panel contains buttons for creating and inserting objects such as tables, images, and links. The buttons are 
organized into several categories (Common, Layout, Forms, Data, and more), which you can choose from the 
Category pop-up menu. Additional categories appear when the current document contains server code, such as ASP 
or CFML documents.


Common category in the Insert panel 


The Common category in the Insert panel contains buttons for inserting the most commonly used objects (Figure 6).


Figure 6 Common category in the Insert panel


Hyperlink: Insert a hypertext link.


Category popup menu
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Email Link: Insert a link to an e-mail address.


Named Anchor: Insert a link to a specific location on a page.


Horizontal Rule: Insert a horizontal rule to visually separate sections on a page.


Table: Insert a table.


Insert Div Tag: Insert a div tag used for page layout.


Images: Insert an image.


Media: Insert media objects, such as Flash, Shockwave, Applets, and ActiveX.


Widget: Insert a Dreamweaver widget.


Date: Insert the current date, with an option for automatic updating when you save the document.


Server-Side Include: Use as a placeholder for commonly used code that can be reused by many pages in your site. 
When you use a SSI file the server takes the entire content of the file stored on a server and inserts it into the page, 
replacing the include code.


Comment: Insert a comment, which will not be displayed on your web page.


Head: Insert keywords, meta tags, page descriptions, and other document data that is kept in the page’s head tag.


Script: Insert or remove script, such as Javascript.


Templates: Make a template based on the current document.


Tag Chooser: Insert an HTML tag.


Layout category in the Insert panel 


From the Layout category in the Insert panel (Figure 7), you can insert tables, table elements, div tags, frames, and 
Spry widgets. You can choose between two modes for tables. Standard mode displays a table as a grid of lines. 
Expanded Tables mode adds cell padding and spacing to tables and increases table borders to make editing easier. 


Figure 7 Layout category in the Insert panel


Insert Div Tag: Insert a div tag to create a content block.
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Insert Fluid Grid Layout Div Tag: Insert a flexible-positioned div tag to display content at a variable location on the 
page.


Draw AP Div: Insert an absolutely-positioned div tag to hold content at a specific location on the page.


Spry Menu Bar: Insert a set of navigational menu buttons that display submenus when a site visitor hovers over one 
of the buttons.


Spry Tabbed Panels: Insert tabs that a site visitor can click to reveal hidden content.


Spry Accordion: Insert a set of collapsible panels that can store a large amount of content in a compact space.


Spry Collapsible Panel: Insert a panel that can hide or reveal a large amount of content when a site visitor clicks the 
tab of the panel.


Table: Insert a table.


Insert Row Above: Insert a row above the current row in a table.


Insert Row Below: Insert a row below the current row.


Insert Column to the Left: Insert a column to the left of the current column.


Insert Column to the Right: Insert a column to the right of the current column.


The Property panel
In the Property panel, you can view and change a variety of properties for the currently selected object, tool, or 
document. Each kind of element has different properties. Figure 8 shows the Properties panel for a selected image. It 
displays the source location, Alt tag, dimensions, and class.  You can edit these settings and create links in the 
Properties panel.


Figure 8 Properties panel
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How to make websites accessible
Creating accessible web pages has never been more important than today. With the adoption of accessibility standards 
in the United States, Canada, the European Union, Australia, Japan, and other countries, designers and developers 
need to ensure that people with disabilities can access the contents of websites and web applications, as well as the 
authoring tools used to create them.


Accessibility refers to making websites and web products usable for people with visual, auditory, motor, and other 
disabilities. Examples of accessibility features for software products and websites include screen reader support, text 
equivalents for graphics, keyboard shortcuts, change of display colors to high contrast, and so on. Dreamweaver 
provides tools that make it accessible to use and tools that help you author accessible content.


Dreamweaver enables designers and developers to create accessible pages that contain useful content for screen 
readers and comply with federal government guidelines. For example, dialog boxes prompt you to enter accessibility 
attributes—such as text equivalents for an image—when you insert page elements. Then, when the image appears on 
a page for a user with visual disabilities, the screen reader voices the description.


Note: For more information about two significant accessibility initiatives, see the World Wide Web Consortium Web 
Accessibility Initiative (www.w3.org/wai) and Section 508 of the U.S. Federal Rehabilitation Act 
(www.section508.gov). 


No authoring tool can automate the development process. Designing accessible websites requires you to understand 
accessibility requirements and make ongoing decisions about how users with disabilities interact with web pages. The 
best way to ensure that a website is accessible is through deliberate planning, development, testing, and evaluation.


Accessibility preferences options
To create accessible web pages, page elements need to be marked up with information for assistive technology, such 
as screen readers. For example, each image on a page should be given a text equivalent, called alternative text (alt 
text), that a screen reader voices to users in place of the image (Figure 1).


Figure 1 Displaying alternative text


Designers often overlook accessibility features such as alt text when creating websites, but Dreamweaver CS6 
enables you to set preferences that prompt you to provide accessibility information as you’re building the page. By 
activating options in the Preferences dialog box, you'll be prompted to provide accessibility-related information for 
form objects, frames, media, images, and tables as each element is inserted in a page. 
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To set the accessibility preference, choose Edit > Preferences (Windows) or Dreamweaver > Preferences (Mac OS) 
and select the Accessibility category in the Preferences dialog box (Figure 2).


Figure 2 Dreamweaver Preferences dialog box, Accessibility category


For example, if you choose the Images option in the Show Attributes list, you are prompted (Figure 3) to provide the 
alt text equivalent and a description for each image as you insert it.


Figure 3 Image Tag Accessibility Attributes dialog box
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Creating accessible tables and forms presents some challenges, but Dreamweaver CS6 simplifies the process. For 
example, as you insert a data table within Dreamweaver CS6, you're immediately prompted to provide summary 
information, a caption, and the position of heading cells in the table (Figure 4). Incidentally, by adding identifying 
heading cells—an important but often overlooked design step—you make it significantly easier for assistive 
technology users to navigate tables. 


Figure 4 Table dialog box


Creating accessible forms is also easy with Dreamweaver CS6. When you select the Form Objects option in the 
Preferences dialog box, you're prompted to provide a label for each form object, along with a shortcut key and the tab 
order position (Figure 5). Specifying the label allows assistive technology users to understand the purpose of each 
form object as they complete the form.


Figure 5 Input Tag Accessibility Attributes dialog box
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Accessibility validation
There are a number of third-party web accessibility evaluation tools that you can use to validate your completed 
websites. The W3C Web Accessibility initiative provides a comprehensive list of these tools at http://www.w3.org/
WAI/RC/tools/.


Accessible templates
Dreamweaver CS6 includes several templates designed for accessibility. These templates are visually balanced, as 
well as accessible to people with disabilities (Figure 6). They provide you with a fast and easy way to create exciting, 
engaging, and accessible content. 


Figure 6 Dreamweaver sample HTML template


How to meet accessibility requirements
The W3C Web Accessibility Initiative has developed a quick reference list Web Content Accessibility Guidelines 2.0 
requirements and techniques.


1. Text Alternatives: Provide text alternatives for any non-text content so that it can be changed into other 
forms people need, such as large print, braille, speech, symbols or simpler language.


2. Time-based Media: Provide alternatives for time-based media.


3. Adaptable: Create content that can be presented in different ways (for example simpler layout) without 
losing information or structure.


4. Distinguishable: Make it easier for users to see and hear content including separating foreground from 
background.


5. Keyboard Accessible: Make all functionality available from a keyboard.
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6. Enough Time: Provide users enough time to read and use content.


7. Seizures: Do not design content in a way that is known to cause seizures.


8. Navigable: Provide ways to help users navigate, find content, and determine where they are.


9. Readable: Make text content readable and understandable.


10. Predictable: Make Web pages appear and operate in predictable ways.


11. Input Assistance: Help users avoid and correct mistakes.


12. Compatible: Maximize compatibility with current and future user agents, including assistive technologies.
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How to add rich media to a web page
To add interest and interactivity, you can easily add rich media to web pages. Rich media includes most kinds of 
video, Flash videos, audio files, and interactive Flash content. 


When building web pages that will be viewed across different devices and screen sizes, consider using HTML5. 
HTML5 video is emerging to become the new standard way to show video on the web. Dreamweaver supports the 
HTML5 <video> tag that allow users to play video files in a browser, without an external plug-in or player 
(Figure 1). 


Figure 1 Viewing HTML5 video in a browser


HTML5 video
There are a few steps you need to accomplish before setting up your web page for HTML5 rich media.


• Create a video in H264 format. You can use the Adobe Media Encoder CS6 or the website www.online-
convert.com to convert video into a range of formats. If you want viewers to be able to play your video in a 
Firefox browser, you should also create a WebM or Flash (FLV) version of your video. 


• Create a poster image that is the same size and orientation as the video. This graphic provides a splash 
screen for viewers to see while the video is downloading. If no poster is specified, a browser will display the 
first frame of the video.


• Include a folder named video in your site, and place the video file and poster image in it.


Once a video is embedded in a page, you can use Live view in the Document window to render and preview rich 
media.


Note: Although you can embed rich media in your web page, Live view does not always render all videos. The audio 
and video tags are supported in Dreamweaver by using the Apple QuickTime plug-in. In Windows, if the Apple 
QuickTime plug-in is not installed, then the web page does not render the media content.
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To create the HTML5 page and video:


1. Start Dreamweaver.


2. Select File > New. 


The New Document dialog box opens (Figure 2).


3. Click the Blank Page category link if not already open, 
and select HTML from the Page Type column, and 
<none> from the Layout column.


4. Select the HTML5 document type from the DocType 
pop-up menu.


5. Click the Create button.


6. Save the new document (File > Save).


The Save As dialog box opens.


7. Navigate to your Dreamweaver site folder, name the file, 
and click Save.


8. Click the Split button in the Document toolbar at the top 
of the document window (Figure 3).


Code view and Design view are visible in the document 
window.


You work in Code view in the next steps as you set up the 
video player with the specifications for your own video 
files. 


9. In Code view, locate the <body> tag, and place the 
insertion point at the end of the the opening body tag.


10. Press Enter (Windows) or Return (Mac OS) to create a 
new line for code.


11. Type <vi and then press Tab to complete the beginning of 
the <video tag.


12. Press the spacebar and type src and then press Tab to 
complete the the source parameter.


The Browse link appears (Figure 4).


13. Click the Browse link to open the Select File dialog box.


14. Navigate to the H.264 video file you saved to the video 
folder and double-click that file to select it.


15. Press the spacebar and then double-click Controls from 
the list of code hints (Figure 5).


This adds a parameter to tell the browser to display 
playback controls with the video.


16. Press the spacebar and type po and then press Tab to 
complete the the poster parameter.


The Browse link appears.


Figure 2 New Document dialog box


Figure 3 Document toolbar


Figure 4 Code hints


Figure 5 Code hints


DocType pop-up menu
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17. Click the Browse link to open the Select File dialog box.


18. Navigate to the poster file you saved to the video folder and double-click that file to select it.


19. Press the spacebar and type prel and then press Tab to complete the the preload parameter.


20. Select Auto from the list of available options. 


The preload parameter tells the browser to load the entire video when the page loads.


Figure 6 Sample code


21. Place the insertion point after the closing preload quote.


22. Press the spacebar and then type ></.  


Dreamweaver will complete the closing tag </video>.


23. Place the insertion point before the closing tag </video>.


24. Press Enter (Windows) or Return (Mac OS) twice to create a blank line for code.


25. Enter (or copy and paste) the following code just before the closing video tag:


<p>Your browser does not support HTML5 video. Click here to download it.</p>


You’ve added text that will display in browsers that don't support HTML5, but you need to add a link to the file 
so users can download it.


26. In Code view, highlight the sentence Click Here To Download It.


27. Click in the Design window to update the preview.


28. Drag the Point-To-File icon  (target icon) at the right of the Link box in the Property inspector and point to the 
video in the Files panel.


A link is created to the video file as in Figure 7.


Figure 7 Sample code


29. Save the file (File > Save).
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30. Select File > Preview In Browser, and select a browser to 
preview the video in a web browser (Figure 8).


Figure 8 Test movie in browser


Troubleshooting support for Firefox


To this point, you’ve embedded a video file in a web page using the HTML5 Video element (tag), and added a link 
that displays a message if a viewer tries to watch the video in a browser that doesn't support HTML5. This approach 
works well across versions of current browsers including Chrome, Safari, and Internet Explorer.  Unfortunately, the 
video won't play in Firefox because it does not support H.264 video. Because Firefox does support HTML5, the text 
link to open the video in a new browser window also won't display. This problem is typical of the kind of issues you'll 
encounter with HTML5 video: it’s still a work in progress. 


You can check with the W3C for the latest information about browser support for HTML5 video at www.w3.org/
wiki/HTML/Elements/video.


To add support for a Firefox browser:


1. Add a simple message after the closing video tag:


<p>Firefox viewers click here to watch the 
video.</p>


2. Create a link to a version of the video in one of the 
formats that Firefox supports, such as WebM or Flash 
Video (FLV).
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About FLA, SWF, and FLV file types
Before you use Dreamweaver to insert content created with Adobe Flash, you should be familiar with the following 
file types:


FLA file (.fla) the source file for any project, created in Flash. This file type can be opened only in Flash (not in 
Dreamweaver or in browsers). In Flash, you can publish a FLA file as a SWF file to use in browsers.


SWF file (.swf) a compiled version of the FLA (.fla) file, optimized for viewing on the web. This file can be 
played back in browsers and previewed in Dreamweaver, but cannot be edited in Flash. 


FLV file (.flv) a video file that contains encoded audio and video data that can be played in Flash® Player. If you 
have a QuickTime or Windows Media video file, use an encoder such as Flash® Video Encoder or Sorensen 
Squeeze to convert the video file to an FLV file. 


Adding FLV video to a web page


You can easily add FLV video to your web pages without using the Flash authoring tool. You must have an encoded 
FLV file before you begin.  Dreamweaver inserts a SWF component that displays the FLV file; when viewed in a 
browser, this component displays the selected FLV file, as well as a set of playback controls. You can also use Live 
view to provide a non-editable, more realistic rendering of how the page will appear in a browser. Live view does not 
replace the Preview In Browser command, but provides another way of seeing what your page looks like “live,” 
without having to leave the Dreamweaver workspace.


To add an FLV video to a web page:


1. Start Dreamweaver and open the document in which you 
want to insert the FLV video.


2. Place the insertion point in Design view where you want 
to add the FLV video.


3. Select Insert > Media > FLV.


The Insert FLV dialog box opens (Figure 9).


4. Click the Browse button to the right of the URL text box.


5. Locate and select the Flash video (FLV), and then click 
OK (Windows) or Open (Mac OS).


6. In the Insert FLV dialog box, select Progressive 
Download Video from the Video Type pop-up menu. 


The Progressive Download Video option enables visitors 
to see movies as they download instead of waiting until 
the entire movie has downloaded.


Note: The Streaming Video option requires the use of 
Adobe Flash Media Server.


7. Fill in the Width and Height boxes.


Dreamweaver requires this information to include the 
video.


8. Select a skin from the Skin pop-up menu.


This determines the appearance of the Flash video 
playback controls (Figure 10).


Figure 9 Insert FLV dialog box


Figure 10 Flash video in a browser with Clear Skin  
selected
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9. Select the Auto Play option to cause the video to play 
when the page loads.


10. Select the Auto Rewind option to cause the video to 
rewind automatically when it reaches the end.


11. Click OK to close the dialog box and insert the video.


A Flash Video placeholder appears in your document 
(Figure 11).


Note: If the Copy Dependent Files dialog box opens, 
click OK to copy the necessary scripts to your site for 
proper playback of the video.


12. Save the document. 


13. In Design view, click the Live View button in the 
Document toolbar.


Figure 11 Flash Video placeholder


Adding  Flash movies (SWF files) to a web page


You add a Flash movie just as you would an image, by browsing to and selecting the Flash file. The file extension of 
Flash movies is SWF.


To add a SWF file to a web page:


1. Start Adobe Dreamweaver and open the document in 
which you want to insert the Flash movie.


2. Place the insertion point in Design view where you want 
to add the Flash movie.


3. Select the Common category in the Insert panel.


4. Click the down arrow on the Media button and select 
SWF in the pop-up menu (Figure 12).


The Select SWF dialog box opens (Figure 13).


Figure 12 Media pop-up menu


Figure 13 Select SWF dialog box
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5. Locate and select the Flash movie (SWF), and then click 
OK (Windows) or Open (Mac OS).


The Object Tag Accessibility Attributes dialog box opens 
(Figure 14).


6. In the Title text box, type a brief title to identify the 
movie’s contents. Then click OK.


A Flash content placeholder, rather than a scene from the 
Flash movie itself, appears in your document 
(Figure 15). This is because the page is pointing to the 
Flash SWF file. When a visitor opens this page, the 
browser plays the SWF file.


To determine how the movie plays when the page loads, 
you set options in the Properties panel.


7. Make sure the Flash content placeholder is selected.


8. In the Properties panel (Figure 15), select the Loop 
option to cause the movie to repeat as long as the visitor 
is on the page. Or, if you don’t want the movie to loop, 
make sure that the Loop option is not checked.


9. Select the Autoplay option to cause the movie to play 
when the page loads.


10. To test the movie, click Play.


Dreamweaver plays the Flash file in the document, 
showing you what visitors will see when they view the 
page in a browser.


11. When you are finished viewing the Flash movie, click 
Stop in the Properties panel.


Figure 14 Object Tag  Accessibility Attributes 
dialog box


Figure 15 Flash movie placeholder in the Document window and Properties panel
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Editing a SWF file from Dreamweaver in Flash


If you have both Flash and Dreamweaver installed, you can select a SWF file in a Dreamweaver document and use 
Flash to edit it. Flash does not edit the SWF file directly; it edits the source document (FLA file) and re-exports the 
SWF file.


To edit a SWF file from Dreamweaver:


1. In Dreamweaver, open the Properties panel (Window > 
Properties).


2. In Design view, click the SWF file placeholder to select 
it; then in the Properties panel, click Edit.


3. In Flash, browse to locate and then select the FLA file. 
Edit the FLA file as you choose.


The Flash edit bar indicates that you are modifying the 
file from within Dreamweaver (Figure 16).


4. When you finish making edits, click Done in the Flash 
edit bar (in the upper-left corner of the workspace). 


Flash updates the FLA file and re-exports it as a SWF 
file.


5. Return to Dreamweaver.


6. To view the updated file in the document, click Play in 
the Properties panel (Figure 17) or press F12 to preview 
your page in a browser window.


Figure 16 Flash edit bar


Figure 17 Flash movie, Play mode, in the Dreamweaver Document window
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Adding audio to a web page
You can add sound to a web page. There are several different types of sound files and formats, including .wav, .midi,  
.mp3, and .ogg . Some factors to consider before deciding on a format and method for adding sound are its purpose, 
your audience, file size, sound quality, and differences in devices and web browsers. 


There are two methods for adding audio to a web page: Use a plug-in or encode your page using HTML5.


When using a plug-in, remember that sound files can be handled differently and inconsistently by different browsers. 
For more information about common audio file formats along with some of the advantages and disadvantages of each 
for web design, see Dreamweaver Help, Audio File Formats.


HTML5 provides additional flexibility for adding audio files to web pages without a plug-in. However, devices and 
web browsers must support the new standard for the audio to work properly. You use the <audio> element to embed 
an audio file on a web page. As with HTML5 video files, be sure to convert your audio files into three supported 
formats: .ogg, mp3, and .wav. These sources are listed in the <audio> tag, and the browser will use the first 
recognized format.


Note: When incorporating sound files in your web pages, carefully consider their appropriate use in your web site 
and how visitors to your site use these media resources. Always provide a control to either enable or disable the 
playing of the sound, in the event that visitors don’t want to listen to the audio content.


To add an audio file by using a plug-in:


1. Start Dreamweaver and open the document in which you want to add sound.


2. In Design view, place the insertion point where you want to embed the file and select Insert > Media > Plugin.


3. Browse for the audio file and click OK (Windows) or Open (Mac OS).


4. Enter a width and height in the W and H text boxes in the Properties panel or by resizing the plug-in placeholder 
in the Document window (Figure 18).


These values determine the size at which the audio controls are displayed in the browser. Audio controls have no 
fixed dimension so find a size that is suitable for the web page in which it is used. For the example in Figure 18, 
the size is set to 257 W x 128 H. 


5. Save the file.


6. Select File > Preview In Browser, and then select a browser to preview the audio in a web browser.


Figure 18 Audio plug-in placeholder in the Document window and Properties panel
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To add an audio file by using HTML5:


1. Create a new HTML5 document, or open an existing HTML5 document in which you want to add audio.


2. Click the Split button in the Document toolbar at the top of the document window.


3. In Code view, enter (or copy and paste) the following code between the <body> tags, substituting your folder 
and filename paths for the placeholders in the code:
<audio controls>


  <source src="folder/song-title.ogg" type="audio/ogg" />


  <source src="folder/song-title.mp3" type="audio/mpeg" />


  <source src="folder/song-title.wav" type="audio/wav" /> 


   <p>Your browser does not support the audio element.</p>


</audio> 


The control attribute adds audio controls, like play, pause, and volume. The text at the end of the <audio> tag is 
for browsers that do not support the element.


The folder and filename paths for the sample site are shown in Figure 19. 


Figure 19 Sample code


4. Save the document. 


5. Select File > Preview In Browser, and then select a browser to preview the audio in a web browser (Figure 20).


Figure 20 Test audio in browser

How to add rich media to a web page © 2012 Adobe Systems Incorporated





		How to add rich media to a web page

		HTML5 video

		Troubleshooting support for Firefox



		About FLA, SWF, and FLV file types

		Adding FLV video to a web page

		Adding Flash movies (SWF files) to a web page

		Editing a SWF file from Dreamweaver in Flash



		Adding audio to a web page












Adobe Dreamweaver CS6 Project 3 guide

How to add text


Adding text to a document
To add text to a Dreamweaver document, you can type text directly in the Document window, or you can cut and 
paste text. You modify text by using the Properties panel (Figure 1). 


Figure 1 Properties panel, HTML mode


There are many additional options to working with text such as bulleted and numbered lists, adding special 
characters, and more. To learn more about adding text to a document, please see “Working with text,” in 
Dreamweaver Help.


To add text:


1. Start Dreamweaver.


2. Select File > New to create a new document.


The New Document dialog box opens (Figure 2).


3. In the Blank Page category of the New Document dialog 
box, select HTML Page Type to create a plain HTML 
page.


4. In the Layout column, select None. 


5. Click the Create button.


The new HTML page opens.


6. In the Document toolbar, click the Show Code And 
Design View button (Figure 3).


The flashing insertion point is located at the top of the 
new document in the Design view.


Note: In an existing document, you can click to place the 
insertion point where you want new text to begin.


7. Type some text or paste text copied in another application 
in the Design view document window.


8. Press Enter (Windows) or Return (Mac OS) to begin a 
new paragraph.


Dreamweaver applies the default Paragraph style to your 
text, as shown in the Properties panel (Figure 1).


Observe in Code view that Dreamweaver applies 
paragraph tags around the two new paragraphs 
(Figure 4).


9. Save the new document (File > Save).


Figure 2 New Document dialog box


Figure 3 Document window view options


Figure 4 HTML paragraph tags in Code view
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10. In the dialog box that appears, navigate to the root folder 
of your site.


11. Open the Properties panel (Window > Properties), if it 
isn’t already open, and click the HTML button to display 
the HTML Properties panel.


Dreamweaver has two Properties panels, integrated into 
one: the CSS Properties panel and the HTML Properties 
panel. In this section, you HTML Properties panel to 
apply basic HTML markup tags. In the next section you 
will use the CSS Properties panel.


When you first begin typing, there is no paragraph 
formatting applied to the text, as shown by the word 
None in the Format menu in the Properties panel.  


12. In the File Name box, type index to name the file.


Note: Avoid using spaces and special characters in file 
and folder names, and do not begin a filename with a 
numeral. In particular, do not use special characters (such 
as é, ç, or ¥) or punctuation marks (such as colons, 
slashes, or periods) in the names of files you intend to put 
on a remote server; many servers change these characters 
during upload, which will cause any links to the files to 
break.


13. Click Save.


Applying basic CSS formatting to paragraphs and text


You can also use the text Properties panel to apply Cascading Style Sheet (CSS) formatting (Figure 5). When you 
apply CSS formatting rules, Dreamweaver writes properties to the head of the document or to a separate style sheet. 
By default, Dreamweaver uses Cascading Style Sheets (CSS) to format text.


Figure 5 Properties panel, CSS mode


CSS formatting is a best practice over HTMLformatting . CSS gives web designers and developers greater control 
over web page design, while providing improved features for accessibility and reduced file size. Using CSS is a way 
to control the style of a web page without compromising its structure. By separating visual design elements (fonts, 
colors, margins, and so on) from the structural logic of a web page, CSS gives web designers visual and typographic 
control without sacrificing the integrity of the content. 


The CSS Properties panel lets you access Targeted Rules, as well as create new ones. A Targeted Rule is a rule you 
are editing in the CSS Properties panel. When you have an existing style applied to text, the rule affecting the text’s 
format appears when you click inside the text on the page. You can also use the Targeted Rule pop-up menu to create 
new CSS rules, new in-line styles, or apply existing classes to selected text. If you’re creating a new rule, you’ll need 
to complete the New CSS Rule dialog box. You will learn more about CSS and the New CSS Rule dialog box in later 
Dreamweaver guides.
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To apply CSS formatting to paragraphs and text:


1. Drag to highlight the paragraphs of text you added to the 
page.


2. In the Properties panel, click the CSS button to display 
the CSS Properties panel.


3. Use the Font menu to change the default font to Georgia, 
Times New Roman, Times, serif.


The New CSS Rule dialog box opens (Figure 6).


4. Review the settings in the New CSS Rule dialog box, in 
particular notice the Selector Name fields (Figure 7).


This shows that all instances of the paragraph element in 
the HTML document will be set with the same font 
family.


5. Click OK to close the New CSS Rule dialog box.


The new font family is applied to the selected paragraphs 
in Design view.


6. Observe in Code view that Dreamweaver store styles 
created with CSS directly in the document in the head 
section of the page (Figure 8).


7. (Optional) Click in a paragraph, or drag to highlight a 
section of text and apply new formatting such as bold, 
and Align Center. 


Observe in Code view how the body p CSS tag is updated 
to reflect the changes.


Figure 6 New CSS Rule dialog box


Figure 7 Detail of New CSS Rule dialog box


Figure 8 Detail of New CSS Rule, code view


Copying text from another document
One way to add text to a Dreamweaver document is to copy and paste text from another document.


To copy text from another document:


1. Open the document from which you want to copy text.


2. Select the text and select Edit > Copy.


3. Start Adobe Dreamweaver CS6.


4. Open the Dreamweaver document in which you want to 
paste the text.
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5. Position the insertion point in the page where you want to 
paste the copied text.


6. Select Edit > Paste.


The new text appears in the Dreamweaver document.


Note: Copied text may lose some of its original 
formatting, including line breaks and paragraph breaks. 
To insert a blank line after a section of text, position the 
insertion point at the end of the last text line and press 
Enter (Windows) or Return (Mac OS). To create a line 
break at the insertion point, press Shift+Enter (Windows) 
or Shift+Return (Mac OS).


7. To change the format of any new text in the document, 
select the text and apply a CSS rule or create a new CSS 
rule based on the format of the new text.


Linking text to other pages and e-mail addresses
After you’ve set up a Dreamweaver site to store your website documents and have created HTML pages, you’ll want 
to create connections from your documents to other documents. Before creating a link, make sure you understand 
how absolute, document-relative, and site root–relative paths work.  You can create several types of links in a 
document:


• A link to another document or to a file, such as a graphic, movie, PDF, or sound file.


• A named anchor link, which jumps to a specific location in a document.


• An e-mail link, which creates a new blank e-mail message with the recipient’s address already filled in.


• Null and script links, which you use to attach behaviors to an object or to create a link that executes 
JavaScript code. 


In this section, you will use the Point-To-File icon to create a links to another page (Figure 9), and the Properties 
panel Link boxto add a link to an e-mail address. Dreamweaver creates the links to other pages in your site using 
document-relative paths. For more information about links and other linking options, see the “Linking and 
navigation” section of Dreamweaver Help. We will also look at linking in more depth in later activities.


Figure 9 Properties panel, HTML mode


Point-to-File iconDestination link
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To create a link to another document in your site:


1. Create a new, blank page within your site and name it 
contact, and save the new document (File > Save).


Note: Always save a new file before creating a 
document-relative path; a document-relative path is not 
valid without a definite starting point.


You should now have two files open in the document 
window: index.html, and contact.html.


2. Click the Show Code And Design View button in the 
Document toolbar.


3. In the index.html page, in the Design view, create a new 
paragraph break and type the text Contact us.


4. Drag to select the just-created text.


5. Click the HTML button in the Properties panel.


6. Click on the Point-To-File icon (Figure 9).


The cursor converts to a crosshair icon and arrow.


7. Drag the arrow to the contact.html file to make a link.


The selected text is now formatted as a link, as indicated 
by the default blue underline (Figure 10). The 
destination is displayed in the Properties panel Link text 
box, and the a href html tages are appled to the text.


8. Save the file.


Figure 10 E-mail link, Code view (top) and Design 
view (bottom)


To create an e-mail link:


1. Click on the contact.html tab in the document window.


2. In the Design view, type the text Contact us.


3. Select just-created text in the Document window’s 
Design view. 


4. In the Link box of the Properties panel, type mailto: 
followed by an e-mail address (Figure 11). 


Do not type any spaces between the colon and the e-mail 
address.


5. Press Enter (Windows) or Return (Mac OS).


The selected text is now formatted as an e-mail link.


6. Save the file.


Figure 11 Properties panel, detail view
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How to use the Assets panel
You can use the Assets panel in Dreamweaver CS6 to manage assets in the current site (Figure 1). The Assets panel 
displays assets for the site associated with the active document in the Document window. A library item is a special 
category of assets that can automatically update all instances of a library item whenever you edit the item


Figure 1 Assets panel with Site list displayed


The Assets panel provides two ways to view assets:


Site list shows all of the assets in your site, including colors and URLs that are used in any document in your site.


Favorites list shows only the assets you’ve explicitly chosen. To switch between these two views, select either 
the Site or Favorites radio button above the preview area. (These two views are not available for the Templates 
and Library categories.)


In both lists, assets fall into one of the following categories: 


Images image files in GIF, JPEG, or PNG formats.


Colors colors used in documents and style sheets, including colors of text, backgrounds, and links.


URLs external links in your current site documents, including FTP, gopher, HTTP, HTTPS, JavaScript, e-mail 
(mailto), and local file (file://) links. 


Flash files in any version of Adobe Flash. The Assets panel displays only SWF files (compressed files created 
with Flash), not FLA (Flash source) files.


Shockwave files in any version of Adobe Shockwave.


Movies QuickTime or MPEG files.


Scripts JavaScript or VBScript files. Scripts in HTML files (rather than in independent JavaScript or VBScript 
files) do not appear in the Assets panel.


Templates master page layouts used on multiple pages. Modifying a template automatically modifies all pages 
attached to it.


Library items design elements that you use in multiple pages; when you modify a library item, all pages 
containing that item are updated.


Asset categories:


Insert button


Edit button


Preview area


Images
Colors


URLs
SWF 


Shockwave


Movies


Scripts


Templates


Library
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By default, assets in a category are listed alphabetically by name, but you can sort them by type and several other 
criteria. You can also preview assets and resize the columns and the preview area.


Add an asset to a document
You can insert most assets into a document by dragging them into Code view or Design view in the Document 
window, or by using the Insert button in the Assets panel. You can either insert colors and URLs or apply them to 
selected text in Design view. (URLs can also be applied to other elements in Design view, such as images.)


To add an asset to a document:


1. Start Dreamweaver.


2. In Design view, place the insertion point where you want 
the asset to appear.


3. In the Assets panel, select from the asset category buttons 
at the left (Figure 1).


Note: Select any category except Templates. A template 
is applied to an entire document; it can’t be inserted into a 
document.


4. Select either Site or Favorites at the top of the panel, then 
select the asset.


5. Do one of the following:


• Drag the asset from the panel to the document 
(Figure 2). 


You can drag scripts into the head content area of the 
Document window; if that area isn’t visible, select 
View > Head Content.


• Select the asset in the panel and click the Insert 
button.


If the inserted asset is a color, it applies to text 
appearing after the insertion point. 


6. If you are adding an image asset, and enabled 
Accesibility preferences (Edit > Preferences > 
Accessibility in Windows, Dreamweaver > Preferences > 
Accessibility in Mac OS), you will be presented with the 
Image Tag Accessibility Attributes dialog box. Enter a 
description of the image in the Alternate Text box.


Figure 2 Drag asset from the Assets panel to the 
document window


Figure 3 Accessibilty dialog box


Edit an asset
When you edit an asset in the Assets panel, the behavior varies according to the asset type. For some assets, such as 
images, you use an external editor, which opens automatically if you have defined an editor for that asset type. You 
can edit colors and URLs in the Favorites list only. When you edit templates and library items, you make the changes 
within Dreamweaver.
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To edit an asset:


1. In the Assets panel, do one of the following:


• Double-click the asset.


• Select the asset, then click the Edit button. 


Note: If the asset must be edited in an external editor 
and one doesn’t open automatically, select Edit > 
Preferences (Windows) or Dreamweaver > 
Preferences (Mac OS), select the File Types/Editors 
category, and define an external editor for that asset 
type.


2. Make your changes.


For example, in Figure 4, Fireworks opens in order to 
edit a selected button asset.


3. When you finish, do one of the following:


• If the asset is file-based (anything other than a color 
or URL), save it (in the editor you used), and close 
the external editor.


• If the asset is a URL, click OK in the Edit URL 
dialog box.


Note: If the asset is a color, the color picker closes 
automatically after you pick a color. To dismiss the 
color picker without picking a color, press Esc.


The file is saved and updated within the Assets panel.


Figure 4 Editing a button in Fireworks


How to use libraries
You can use a library in Adobe Dreamweaver CS6 to store page elements such as images, text, sounds, or tables you 
want to reuse throughout your website (Figure 5). When you insert a library item, Dreamweaver inserts a link to the 
library item. If you later need to make changes to a library item, such as changing some text or an image, updating the 
library item automatically updates each instance of the item on every page into which you’ve inserted it.


Figure 5 Assets panel, Library category


Library button


Insert button


New Library Item


Edit button


Delete button
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Creating a library item


You create library items out of existing page elements.


To create a library item:


1. In the Document window, select the element (such as an 
image or text) to save as a library item.


2. In the Assets panel, click the Library button.


3. Click the New Library Item button  at the bottom of the 
panel (Figure 5).


4. Type a name for the new library item, then press Enter 
(Windows) or Return (Mac OS). (Figure 6).


Dreamweaver saves each library item as a separate file 
(with the file extension .lbi) in the Library folder of the 
site’s local root folder.


Figure 6 Naming a new library item


Inserting a library item


Once an item is added to the Library, you can insert it onto a page.


To insert a library item:


1. Position the insertion point in the Document window 
where you want to insert a library item.


2. In the Assets panel, click the Library button.


3. Drag a library item from the Assets panel to the 
Document window, or select an item and click the Insert 
button at the bottom of the panel (Figure 7).


Figure 7 Inserting a library item on a page


Editing a library item


Library items can be edited in their own window. The changes you make then apply to the library item everywhere 
you have previously inserted it.


To edit a library item:


1. In the Assets panel, click the Library button.


2. Select a library item.
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3. Click the Edit button at the bottom of the Assets panel.


Dreamweaver opens a new window for editing the library 
item (Figure 8). This window is much like a Document 
window. You can tell it is a library item by the .lbi 
filename extension on the document’s tab.


4. Edit the library item and then save your changes.


The Update Library Items dialog box opens, with a list of 
the files that use the library item (Figure 9).


5. Click Update to replace the original library item with 
your edited version in the files that use the library item. 


The Update Pages dialog box opens.


6. To see a report on the updating process, make sure Show 
Log is selected (Figure 10).


7. Click Close.


Figure 8 Library editing window


Figure 9 Update Library Items dialog box


Figure 10 Update Pages report
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Updating all documents to use current library items


If you do not choose to update documents that use library items as you edit individual library items, you can later 
update all pages in the site with the current version of all library items.


To documents to use current library items:


1. Select Modify > Library > Update Pages.


The Update Pages dialog box opens (Figure 11).


2. From the Look In pop-up menu, select Entire Site, and 
then select the site name from the adjacent pop-up menu. 


3. Make sure Library Items is selected in the Update 
section. 


4. Click Start.


Dreamweaver updates the documents and provides a 
report on the updating process (Figure 12). If you have 
updated documents at the time you edited library items, 
this report confirms that no additional updating was 
required.


5. Click Close.


Figure 11 Update Pages dialog box


Figure 12 Update Pages report
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How to check files in and out
If you’re working in a collaborative environment, you can check files in and out from local and remote servers. If 
you’re the only person working on the remote server, you can use the Put and Get commands without checking files 
in or out.


Checking out a file is the equivalent of declaring “I’m working on this file now—don’t touch it!” When a file is 
checked out, the name of the person who checked out the file is displayed in the Files panel, along with a red check 
mark (if a team member checked out the file) or green check mark (if you checked out the file) next to the file’s icon.


Checking in a file makes the file available for other team members to check out and edit. When you check in a file 
after editing it, your local version becomes read-only and a lock symbol appears beside the file in the Files panel to 
prevent you from making changes to the file.


Dreamweaver does not make checked-out files read-only on the remote server. If you transfer files with an 
application other than Dreamweaver, you can overwrite checked-out files. However, in applications other than 
Dreamweaver, the LCK file is visible next to the checked-out file in the file hierarchy to help prevent such accidents.


Setting up a Check In/Check Out system on a remote server
Check with your instructor or your site administrator to to see if a site has already been set up. If so, you may be able 
to skip this section and proceed directly to the next section, “Checking out files.”


To set up a Check In/Check Out system on a remote server:


1. Start Dreamweaver.


2. Select Site > Manage Sites.


3. Select a site and click Edit.


4. In the Site Setup dialog box, select the Servers category 
and select an existing server and click the Edit Existing 
Server button (Figure 1).


The Basic view of the Server Setup dialog box opens.


5. Click the Advanced button. 


The Advanced view of the Server Setup dialog box opens 
(Figure 2).


6. Select Enable File Check-out if you are working in a 
team environment (or working alone but from several 
different machines).


This option is useful to let others know that you checked 
out a file for editing, or to alert yourself that you may 
have left a more recent version of a file on another 
machine. 


If you do not see Check In/Out options, it means that you 
have not set up a remote server.


7. Select the Check Out Files When Opening option if you 
want to automatically check out files when you double-
click to open them from the Files panel. 


Using File > Open to open a file doesn’t check the file 
out, even when this option is selected.


Figure 1 Site Setup dialog box


Figure 2 Server Setup dialog box, Advanced view


Edit Existing Server
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8. Set the remaining options:


Check-out Name The check-out name appears in the Files 
panel alongside any files that are checked out; this 
enables team members to communicate with the right 
person if a file they need is checked out.


Note: If you work alone from several different machines, 
use a different check-out name on each machine (for 
example, AmyR-HomeMac and AmyR-SchoolPC), so 
you’ll know where the latest version of the file is if you 
forget to check it in.


Email Address If you enter an e-mail address, then when 
you check out a file, your name appears in the Files panel 
as a link (blue and underlined) next to that file. If a team 
member clicks the link, their default e-mail program 
opens a new message with the user’s e-mail address and a 
subject that corresponds to the file and site name.


9. Click Save to close the Advanced view of the Server 
Setup dialog box.


10. Click Save to close the Site Setup dialog box.


11. Click Done to close the Manage Sites dialog box.


Checking out files
After the Check In/Check Out system is set up, you can check in and check out files on a remote server by using the 
Files panel (Figure 3).


Figure 3 Dreamweaver Files panel, expanded view with Remote and Local panes


Expand/Collapse Connect/Disconnect to Remote Host Check Out File(s)


Check In File(s)Refresh
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To check out files on a remote server:


1. Start Dreamweaver. Select your local site in the Files 
panel.


2. Click the Expand/Collapse button in the Files panel 
(Figure 4).


The Files panel expands to show both local and remote 
sites in separate panes (Figure 3).


3. Click the Connects To Remote Host button.


You are now connected to your remote site. The remote 
and local site panes are side-by-side. You can also toggle 
between these two windows when the Files panel is 
collapsed.


4. Select one or more files in the Remote Site pane and click 
the Check Out File(s) button at the top of the Files panel.


The Dependent Files dialog box appears (Figure 5).


Dependent files are files that are used or displayed in one 
of your selected files. They include any images or movies 
displayed on the page, as well as external style sheets 
linked to the page.


5. To download dependent files along with the selected 
files, click Yes. Otherwise, click No.


Dreamweaver displays a check mark beside each file you 
check out, along with your name.


Figure 4 Files panel


Figure 5 Dependent Files dialog box


Checking in files
You can edit checked-out files on your workstation. When you finish working on checked-out files, remember to 
check them back in so other team members can access them. 


To check in files to a remote server:


1. In the Files panel, select your local site from the Site 
menu.


Expand/Collapse 
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2. Select one or more checked-out or new files in the Local 
Files pane of the Files panel.


A green check mark next to a file name indicates that the 
file is currently checked out by you. A red check mark 
indicates that the file is checked out by another team 
member. You can click the Refresh button to find out the 
current status of files on the remote site (Figure 6).


3. Click the Check In button at the top of the Files panel 
(Figure 5).


The Dependent Files dialog box appears (Figure 7).


4. To check in dependent files along with the selected files, 
click Yes. Otherwise, click No. 


In the expanded view of the Files panel, Dreamweaver 
displays a lock icon in the Local Files pane next to each 
file you check in, and it clears the check mark that was 
displayed in the Remote Site pane when you checked out 
the file (Figure 8).


Provided your site administrator has enabled it, you can 
view or print any locked file in the Local Files pane. The 
lock icon reminds you that you cannot edit the file and 
save it, however, unless you first check it out.


5. Click the Expand/Collapse button to collapse the Files 
panel.


Figure 6 Checking in files 


Figure 7 Dependent Files dialog box


Figure 8 Checked in file


Undoing check out
Sometimes, after you check a file out and make changes to it, you may want to discard these changes. The Undo 
Check Out command enables you to check a file in without saving changes.


To undo check out:


1. In the Files panel, select your local site from the Site 
menu.


2. Select one or more checked-out files in the Local Files 
pane of the Files panel.


3. Right-click (Windows) or Control-click (Mac OS) and 
select Undo Check Out in the context menu.


Refresh
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Using Subversion
Many web designers and developers use software called version control software to collaborate. Version control 
software saves a copy of each file every time a user makes a change to the file. Dreamweaver integrates with a 
popular program called Subversion. Once your site administrator has set up a Subversion repository in your 
environment, you can connect your site to Subversion. For more information on configuring a site to work with 
Subversion, see Dreamweaver Help. 


Note: Many users find it helpful to use a third party diff tool that allows you to compare different versions of a file. To 
find such a program, use a web search engine such as Google to search for “diff tool.”


Getting the latest versions of files


The first time you set up a site with Subversion connected, you need to make a copy the repository files to your local 
computer.


To copy repository files to your computer:


1. Make sure that your administrator has set up an SVN 
connection.


2. Make sure the Files panel is open and Local View is 
selected. 


3. Right-click (Windows) or Control-click (Mac OS) the 
root folder in the Files panel and choose Version Control 
> Get Latest Versions from the context menu (Figure 9).


All files are copied to your local computer.


At any point, you can repeat these steps on any folder or 
file to get the latest file version of a file or file(s).


Figure 9 Files panel context menu
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Checking in files with Subversion


With Subversion enabled, you check in files just as you would normally. However, once you check in files, a dialog 
box opens asking you to commit the file to Subversion.


To check in files with Subversion:


1. Select a checked out file in the Files panel.


The CheckIn dialog box opens (Figure 10).


2. Enter a note on the version, so that other users will know 
what edits you made.


3. Click Commit.


The file is checked in and added to the repository.


Figure 10 CheckIn dialog box


Adding files to the repository


A blue plus sign on a file in the Files panel denotes a file that does not yet exist in the SVN repository.


To add a new file to the repository:


1. Make sure that your administrator has set up an SVN 
connection.


2. Make sure the Files panel is open.


3. Select the file you want to add to the repository and click 
the Check In File(s) button (Figure 11).


4. Make sure that the file is selected for Commit in the 
Commit dialog box and click OK.


Figure 11 File not added to repository


File not added to repository


Check In File(s)
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Viewing versions of files


Each time you or another user checks in a file, Suversion saves a copy of the file, retaining all previously saved 
versions. At any point, you or another user can revert a file to a previous version.


To view the version history for a file:


1. Make sure that your administrator has set up an SVN 
connection.


2. Make sure the Files panel is open and Local View is 
selected. 


3. Right-click (Windows) or Control-click (Mac OS) the 
root folder in the Files panel and choose Version Control 
> Show Revisions from the context menu.


The Revision History dialog box opens (Figure 12).


Figure 12 Revision History dialog box


To revert to an earlier version:


1. View a file’s version history.


2. Click a version to select it.


3. Click the Promote To Current button.


A dialog box opens asking if you want the selected 
revision to become the new head revision.


4. Click Yes.


The selected revision becomes the new current revision 
and a dialog box opens asking if you want to load a file 
from outside Dreamweaver.


Note: Because Subversion is not part of Dreamweaver, 
Dreamweaver checks to make sure the file change was 
intended.


Note: If you want to switch back to the original version, 
simply select it in the Revision History dialog box.
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How to check links
Use the Check Links feature to search for broken links and orphaned files (files that still exist in the site but that 
aren’t linked to by any other files in the site) (Figure 1). You can search an open file, a portion of a local site, or an 
entire local site.


Checking links in a local site


Figure 1 Link Checker panel


Dreamweaver verifies links only to documents within the site; Dreamweaver compiles a list of external links in the 
selected document or documents but does not verify them.


You can also identify and delete files that are no longer used by other files in your site.


To check links in a local site:


1. Start Dreamweaver.


2. In the Files panel, select a site from the Current Sites 
pop-up menu.


3. Select Site > Check Links Sitewide.


The Broken Links report appears in the Link Checker 
panel (Figure 1).


4. In the Link Checker panel, select External Links or 
Orphaned Files from the Show pop-up menu to view 
another report. 


A list of files that fit the report type you selected appears 
in the Link Checker panel.


Note: If you select Orphaned Files as your report type, 
you can delete orphaned files from the Link Checker 
panel by selecting a file in the list and pressing the Delete 
key. 


5. Fix any broken links and check the links again.


Note: To clear the current Link Checker results, select 
Clear Results from the Link Checker Options menu.


Figure 2 Files panel


Link Checker Options menu


Current 
Sites menu
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How to create links
After you’ve set up a Dreamweaver CS6 site to store your website documents and have created HTML pages, you’ll 
want to create different types of links. Understanding the file path between the document you’re linking from and the 
document or asset you’re linking to is essential to creating links.


Each web page has a unique address, called a Uniform Resource Locator (URL). However, when you create a local 
link (a link from one document to another on the same site), you generally don’t specify the entire URL of the 
document you’re linking to; instead, you specify a relative path from the current document or from the site’s root 
folder. 


There are three types of link paths:


• Absolute paths provide the complete URL of the linked document, including the protocol to use (usually 
http:// for web pages). An example is, http://www.oceanviewhighschool.net/index.html. For an image asset, 
the complete URL is something like http://www.oceanviewhighschool.net/images/image1.jpg. You must use 
an absolute path to link to a document or asset in a different site.


• Document-relative paths are usually best for local links (within a website). They’re particularly useful when 
the current document and the linked document or asset are in the same folder and are likely to remain 
together. You can also use a document-relative path to link to a document or asset in another folder by 
specifying the path through the folder hierarchy from the current document to the linked document. For 
example, suppose you have a site with the structure shown in Figure 1:


Figure 1 Example site folder structure


◦ To link from contents.html to hours.html (both in the same folder), use the relative path hours.html.


◦ To link from contents.html to tips.html (in the resources subfolder), use the relative path resources/
tips.html. At each slash (/), you move down one level in the folder hierarchy.


◦ To link from contents.html to index.html (in the parent folder, one level above contents.html), use the 
relative path ../index.html. Two dots moves you up two levels in the folder hierarchy (to the root folder) 
and /index.html moves you back down one level (to the index page).


◦ To link from contents.html to catalog.html (in a different subfolder of the parent folder), use the relative 
path ../products/catalog.html. Here, .. moves you up to the root folder, and /products moves you down to 
the products subfolder, and /catalog.html moves you to the catalog page. When you move files as a 
group—for example, when you move an entire folder, so that all the files inside that folder retain the 
same relative paths to each other—you don’t need to update document-relative links between those 
files. However, when you move an individual file that contains document-relative links, or an individual 
file targeted by a document-relative link, you do need to update those links. (If you move or rename 
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files using the Files panel, Dreamweaver updates all relevant links automatically.)


• Site root–relative paths describe the path from the site’s root folder to a document. You may want to use 
these paths if you are working on a large website that uses several servers, or one server that hosts several 
sites. However, if you are not familiar with this type of path, you should stick to document-relative paths.


Using Dreamweaver, you can easily select the type of document path to create for your links.


Four different types of links are discussed in this guide:


• An internal link goes to another page within in your site using a document-relative path.


• An external link goes to another site external to your own using an absolute path.


• A named anchor link goes to a specific position on a page within your site using a combination document-
relative path and anchor link.


• An e-mail link opens a blank e-mail message window in a user’s default e-mail client, with the recipient’s 
address filled in. 


Creating an internal link 
You can use the Properties panel and the Point-To-File icon to create links from an image, an object, or text to another 
document or file (Figure 2). Dreamweaver creates the links to other pages in your site using document-relative paths.


Figure 2 Properties panel


To create a link to another document in your site:


1. Start Dreamweaver.


2. Open an existing file, or create a new, blank page and 
save the file.


Note: Always save a new file before creating a 
document-relative path; a document-relative path is not 
valid without a definite starting point. If you create a 
document-relative path before saving the file, 
Dreamweaver temporarily uses an absolute path 
beginning with file:// until the file is saved; when you 
save the file, Dreamweaver converts the file:// path to a 
relative path.


Point-To-File iconLink text box Browse For File button Target menu
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3. Select text or an image in the Document window’s 
Design view.


4. Open the Properties panel (Window > Properties) and do 
one of the following:


• Drag the Point-To-File icon (target icon) to a 
document in the Files panel (Figure 2).


• Click the Browse For File button to browse to and 
select a file.


• Type the path and filename of the document in the 
Link text box.


Creating an external link
To link to a document outside your site, enter an absolute path, including the protocol (such as http://). You can enter 
these by hand or copy them from a browser address bar and paste them into the Link text box in the Properties panel. 


To add  a link to a page on another site:


1. Select an image or text you want to format as a link.


2. In the Link text box in the Properties panel, type or paste 
the address (URL) of the site to which you want to link.


Note: If you’re linking to a page outside of your site, it is 
a best practice to set the Target menu to 
target="_blank"  (Figure 3). This causes the link to 
open in a new browser window, so that the page doesn’t 
appear to be part of your site.


Figure 3 Properties panel, Target menu


Creating a link to a named anchor
To link to a particular section of a document, first create a named anchor at that location, and then link to the named 
anchor. Named anchors are frequently placed at the beginning of each topic and at the top of a document, so users can 
readily go to these locations. 


To create and link to a named anchor:


1. Position the insertion point at the location on the page 
where you want to define an anchor.


2. Select Insert > Named Anchor. 


The Named Anchor dialog box opens (Figure 4).


3. Enter a short anchor name without any spaces.


4. Click OK.


5. Select an image or text to link to the named anchor.


Figure 4 Named Anchor dialog box
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6. In the Link text box in the Properties panel, type # and 
then type or paste the anchor name. 


In the example code (Figure 5), an anchor named Top is 
placed at the top of the document, and a link to the anchor 
added at the bottom of the page.


Note: Anchor names are case-sensitive.


You can also use any ID attribute as a destination anchor 
so that links can be made to divisions, paragraphs, and 
most other elements.


Figure 5 Named Anchor dialog box


Creating a link to an e-mail address
When a user clicks an e-mail link, a new blank message window opens, using the mail program associated with the 
user’s browser. In the e-mail message window, the To box is automatically updated with the address specified in the 
e-mail link.


To create a link to an e-mail address:


1. In the Document window’s Design view, position the 
insertion point where you want the e-mail link to appear, 
or select the text or image you want to appear as the e-
mail link. 


2. Do one of the following to insert the link:


• Select Insert > Email Link.


• In the Common category of the Insert bar, click the 
Email Link button.


The Email Link dialog box opens (Figure 6).


3. In the Text box, enter text for the link.


If you selected text to format as the link, that text appears 
in the Text box.


4. In the Email text box, type the e-mail address.


5. Click OK to close the Email Link dialog box.


Figure 6 Email Link dialog box

How to create links © 2012 Adobe Systems Incorporated





		How to create links

		Creating an internal link

		Creating an external link

		Creating a link to a named anchor

		Creating a link to an e-mail address












Adobe Dreamweaver CS6 Project 3 guide

How to create lists
You can create numbered (ordered) lists, bulleted (unordered) lists, and definition lists from existing text or from new 
text as you type in the Document window. Definition lists do not use leading characters such as bullet points or 
numbers and are often used in glossaries or descriptions. Lists can also be nested. Nested lists are lists that contain 
other lists. For example, you might want an ordered or bulleted list nested within another numbered or unordered list.


Creating lists
In Adobe Dreamweaver CS6, you can easily create lists to organize information. You can use the Properties panel to 
set list style (Figure 1). To set the appearance of an entire list or for an individual list item, use the List Properties 
panel. You can set number style, reset numbering, or set bullet style options for individual list items or for the entire 
list.


Figure 1 Properties panel


To create a new list:


1. Open a document in Dreamweaver.


2. Place the insertion point where you want to add a list, 
then do one of the following:


• In the HTML Properties panel, click either the 
Unordered  List button or the Ordered List button 
(Figure 1).


• Select Format > List and select the type of list 
desired—Unordered (bulleted) List, Ordered 
(numbered) List, or Definition List (Figure 2).


The leading character for the specified list item 
appears in the Document window.


3. In turn, type the text for a list item, and then press Enter 
(Windows) or Return (Mac OS) to create another list 
item.


4. To complete the list, press Enter twice (Windows) or 
press Return twice (Mac OS).


Figure 2 Format menu


Unordered List


Ordered List Outdent


Indent
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To create a list using existing text:


1. Select a series of paragraphs to make into a list.


Each paragraph will become an item in the new list.


2. In the HTML Properties panel, click the Unordered or 
Ordered List button, or select Format > List and select the 
type of list desired—Unordered List, Ordered List, or 
Definition List.


The list is created (Figure 3). Figure 3 Create an ordered list


To create a nested list:


1. Select the list items you want to nest.


2. In the HTML Properties panel, click the Indent button, or 
select Format > Indent.


Dreamweaver indents the text and creates a separate list 
with the original list’s HTML attributes (Figure 4).


3. Apply a new list type or style to the indented text by 
following the same procedure used above.


Figure 4 Create a nested list 


To set list properties for an entire list:


1. In the Document window, create at least one list item. 
The new style will automatically apply to additional 
items you add to the list.


2. With the insertion point in the text of the list item, select 
Format > List > Properties to open the List Properties 
dialog box (Figure 5).


3. Set the options you want to define the list:


List Type specifies list properties while List Item 
specifies an individual item in a list. Use the pop-up 
menu to select a Bulleted List, Numbered List, or 
Definition List. Depending on the List Type you select, 
different options appear in the dialog box.


Style determines the style of numbers or bullets used for a 
numbered or bulleted list. All items in the list will have 
this style unless you specify a new style for items within 
the list.


Start Count sets the value for the first item in a numbered 
list.


4. Click OK to set the choices.


Figure 5 List Properties dialog box
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How to use CSS text styles
Web typography is an important creative tool web designers use to express style and emotion that enhances the goal 
and overall message of a website. 


Image-based text gives you control of your web typography, but several limitations have led to the decline of this 
approach: increased file size, decreased accessibility, problems with search engine discoverability, and practical 
limitations on the amount of text.


Cascading Style Sheets provide a higher level of styling control over web typography, without the drawbacks of 
image-based test. With CSS, web page text results in smaller file size, greater accessibility, and improved usability 
across devices, browsers, and platforms. CSS specifies a series of font properties for a web browser to use when 
displaying text in a web page. 


Web designers seeking a broader font selection or more expressive typography (Figure 1) may choose to use web 
fonts. Web fonts are temporarily downloaded to display text in fonts that site visitors don’t need installed on their 
computers. 


Figure 1 Example of a website using web fonts: http://lostworldsfairs.com/moon/
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Changing text styles
To understand web fonts betters, consider how fonts are defined by using CSS. CSS font properties define the font 
family, boldness, size, and style of text. A font declaration for an HTML paragraph tag looks something like this:


Changing text styles for web pages is easy in the CSS Styles panel.


To change text styles:


1. Start Dreamweaver.


2. Open a document in which you want to edit a CSS font 
property.


3. Open the CSS Styles panel (Window > CSS Styles), if it 
isn’t already open (Figure 2).


4. Double-click an existing rule or property in the top pane 
of the CSS Styles panel.


The CSS Rule Definition dialog box appears (Figure 3).  


5. Change or specify any of the following properties in the 
dialog box. If a property is not important to you, don’t 
select or enter a value for that property.


Font-family sets the font family (or series of families) for 
the style. Browsers display text in the first font in the 
series that is installed on the viewer’s system. 


Font-size defines the size of the text. You can choose a 
specific size by selecting the number and the unit of 
measurement, or you can choose a relative size.


Font-style provides the options Normal, Italic, and 
Oblique. 


Line-height sets the height of the line on which the text is 
placed. This setting is traditionally called leading. 


Text-decoration adds an underline, overline, or line-
through to the text, makes the text blink, or removes any 
decoration set elsewhere.


Font-weight applies a specific or relative amount of 
boldface to the font. Normal is equivalent to 400; Bold is 
equivalent to 700. 


Font-variant sets the small caps variant on text. 
Dreamweaver does not display this attribute in the 
Document window. 


Text-transform capitalizes the first letter of each word in 
the selection or sets the text to all uppercase or lowercase. 


Color sets the text color. 


6. When you have finished, click OK. Observe the effect of 
your changes in Design view.


Figure 2 CSS Styles panel


Figure 3 CSS Rule Definition dialog box
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Using web fonts
By using the CSS @font-face embedding technique, modern web browsers download and use a wide range of font 
styles. There are two methods for delivering web fonts to site visitors: subscription-based hosted services that license 
fonts for use and free open-source fonts.


Most subscription-based, third-party services host fonts on their servers and deliver specific fonts whenever a website 
is viewed. This often requires adding code to your site, and the service instructs you on how to do so. Examples of 
subscription-based services are Adobe’s Typekit (www.typekit.com), Kernest, and Typotheque. 


Google web fonts is the service of choice for free open-source web fonts. Like subscription-based font services, 
Google offers a hosted web font service, as well as letting you download font collections for saving to a web server. 


To use Google web fonts, you must first visit the Google web fonts website and choose one or more font styles, 
review your selection, and integrate web fonts into your CSS (Figure 4). Use one of the following procedures:   


• Remote web fonts: Copy the provided link code into the <head> section of your HTML document.


• Embedded web fonts: Download the collection as a ZIP file and save to your web server.


Figure 4 Google web fonts website


In this section, you learn how to use the Google remote web font service and how to download and use Google web 
fonts. 


To use remote Google web fonts:


1. Visit the Google web fonts site at www.google.com/
webfonts. 


You may be required to register.

© 2012 Adobe Systems Incorporated How to use CSS text styles 3







Project 3 guide Adobe Dreamweaver CS6


4


2. Search or browse the selection of font families; then click 
the Add To Collection button next to each font you want 
to use.


3. Click the Review button to compare and refine your 
collection and to see the styles in a customizable sample 
layout.


4. Click the Use button, and verify the settings.


5. In Step 3 on the Use page, copy the Standard link code 
(Figure 5).


The code is saved to the clipboard.


6. Open a Dreamweaver HTML document in which you 
want to add Google web fonts.


7. Select Split view in the Document toolbar (Figure 6).


Code view and Design view are visible in the Document 
window.


8. Locate the opening <head> tag of the document, and 
place the insertion point immediately after the closing 
bracket of the tag. 


9. Press Enter (Windows) or Return (Mac OS) to create a 
line break.


10. Select Edit > Paste to add the saved clipboard code to the 
head section of the document (Figure 7). 


11. Open the CSS Styles panel (Window > CSS Styles), if it 
isn’t already open, and select All at the top of the panel.


12. Click an existing rule or style in the All Rules pane of the 
CSS Styles panel to display its properties in the 
Properties pane.


13. Return to the Google web fonts Use page, and copy the 
name of the font family you want to use in your web page  
from the list in Step 4 (Figure 8).


14. Return to Dreamweaver. In the CSS Styles panel, double-
click the rule to which you want to apply the Google web 
font.


The CSS Rule Definition dialog box appears.


15. Paste the copied font-family name into the Font-Family 
text box (Figure 3).


16. Select File > Save All.


17. Select File > Preview In Browser, and then select a 
browser where you can preview the remote Google web 
font (Figure 9).


Figure 5 Step 3 of the Use page, Google web fonts


Figure 6 Document toolbar in Dreamweaver


Figure 7 Link to Google web fonts in the head 
section


Figure 8 Step 4 of the Use page, Google web fonts 


Figure 9 Google web fonts used in headings
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To dowload and embed Google web fonts:


1. Visit the Google web fonts site at www.google.com/
webfonts. 


2. You may be required to register


.


3. Search or browse the selection of font families; then click 
the Add To Collection button next to each font you want 
to use.


4. Click the Review button to compare and refine your 
collection and to see the styles in a customizable sample 
layout.


5. Click the Use button, and verify the settings.


6. Click the Download Your Collection link in the upper-
right corner of the Use page (Figure 10).


The Download The Fonts In Your Collection dialog box 
appears (Figure 11).


7. Click the Download The Font Families In Your 
Collection As A Zip-file link to download the files to 
your computer.


8. Unzip the file and save to the location of your choice. 


9. Open the folder containing the downloaded font and 
make note of the file type. 


It will have one of four types of web font extensions: 
EOT, WOFF, TTF, or SVG. You will need this 
information in the next few steps. The font in the 
example folder is Bree Serif, Regular, and it is a TTF 
font. 


10. Switch to Dreamweaver.


11. Select Modify > Web Fonts.


The Web Fonts Manager dialog box appears (Figure 13).


Figure 10 Download your Collection link


Figure 11 Download The Fonts In Your Collection 
dialog box


Figure 12 Downloaded fonts


Figure 13 Web Fonts Manager dialog box

© 2012 Adobe Systems Incorporated How to use CSS text styles 5







Project 3 guide Adobe Dreamweaver CS6


6


12. Click the Add Font button.


The Add Web Font dialog box appears (Figure 14).


13. Click the folder icon beside the file type of your 
downloaded font, navigate to the location of the saved 
font, and select it.


14. Click Open in the Open dialog box.


The font is added to the Add Web Font dialog box.


15. Click OK to close the Add Web Font dialog box.


The font is added to the Web Fonts Manager dialog box.


16. Click Done to close the Web Fonts Manager dialog box.


17. Open the CSS Styles panel (Window > CSS Styles), if it 
isn’t already open, and select All at the top of the panel.


18. In the All Rules pane, double-click the rule to which you 
want to apply the Google web font.


The CSS Rule Definition dialog box appears.


19. In the Font-Family menu, select the Google web font that 
you downloaded and added.


20. Select File > Save All.


21. Select File > Preview In Browser, and then select a 
browser where you can preview the embedded Google 
web font (Figure 9).


Figure 14 Add Web Font dialog box
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How to create data tables
In Adobe Dreamweaver CS6, you can use tables to format data. Tables are a powerful tool for presenting tabular data. 
A table consists of one or more rows; each row consists of one or more cells. After you create a table, you can easily 
modify both its appearance and its structure.


Although it is possible to use tables for page layout including text and images, this approach is now discouraged in 
favor of using CSS for layout. 


You can insert a new table from the Insert panel, or you can import a spreadsheet table created in a program such as 
Microsoft Excel. 


Inserting a table on a page
You can insert a table anywhere on a page, including within another table. You can quickly insert a standard table 
with three rows and three columns, or you can modify options to insert a custom table.


When you insert a table, a good idea is to set a header property for a row or column if you will use that row or column 
to provide labels for the information in the table. A header makes the table more accessible to people with visual 
impairments, because screen readers can recognize that a header contains labels. (Note that you must set a header row 
or column to provide such accessibility. It is not sufficient to use bold or centered text.)


To insert a table:


1. Open a document in Dreamweaver.


2. Place the insertion point in your document where you 
want the table to appear.


3. Select the Common category in the Insert panel, and 
make sure Standard mode is selected.


4. Click the Table button on the Insert panel (Figure 1).


The Table dialog box opens (Figure 2).


5. Enter the number of rows and columns.


6. Make changes to any of the options in the dialog box. For 
information about the options, click the Help button in 
the dialog box.


Applying a column header or row header in particular 
can improve the accessibility of a data table. The browser 
will display these headers slightly differently, and such 
headers are read by screen readers.


Figure 1 Common category in the Insert panel


Figure 2 Table dialog box
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To set a header row or column:


1. In the Table dialog box (Figure 2), select one of the 
options in the Header section.


For example, if you create a table that lists a collection of 
books, with columns labeled Author, Title, and Year, you 
should set the top row as a header. By default, header 
rows or columns are bolded and centered (Figure 3). 
Screen readers can read this header.


2. Click OK.


The table appears in your document.


Figure 3 Table with top row set as header


Selecting table elements
You can select an entire table, a row, or a column, or you can select a contiguous block of cells within a table. After 
you’ve selected a table or cells, you can modify the appearance of the selection or of the text contained in the 
selection.


To select an entire table:


Do one of the following:


• Click the upper-left corner of the table or click 
anywhere on the bottom edge.


• Click in a table cell, and then select Modify > Table 
> Select Table.


Selection handles appear on the selected table’s lower 
and right edges (Figure 4).


Figure 4 Selection handles on a selected table


To select rows or columns:


1. Position the pointer to point at the left edge of a row or 
the top edge of a column.


2. When the pointer changes to a selection arrow, click to 
select the row or column, or drag to select multiple rows 
or columns (Figure 5).


Figure 5 A selected column in a table


To select a single cell:


Do one of the following:


• Click in the cell. Then drag to select the cell.


• Click in the cell. Then select Edit > Select All.
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Adding rows and columns
You can add a single row or column, or you can add multiple rows or columns at the same time.


To add a row:


1. Place the insertion point in a table cell, or select an entire 
row.


2. Do one of the following:


• In the Layout category in the Insert panel, click the 
Insert Row Above button or the Insert Row Below 
button (Figure 6).


• Select Insert > Table Objects > Insert Row Above or 
Insert > Table Objects > Insert Row Below.


A new row appears above or below the insertion point or 
the selected row.


Figure 6 Layout category in the Insert panel


To add a column:


1. Place the insertion point in a table cell, or select an entire 
column.


2. Do one of the following:


• In the Layout category in the Insert panel, click the 
Insert Column To The Left button or the Insert 
Column To The Right button (Figure 6).


• Select Insert > Table Objects > Insert Column To 
The Left or select Insert > Table Objects > Insert 
Column To The Right.


A new row appears to the left or right of the insertion 
point or the selected column.
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Deleting rows and columns
You can delete a single row or column, or you can delete multiple rows or columns at the same time.


To delete rows or columns from a table:


1. Select one or more rows or columns.


2. Press Delete or Backspace.


To remove cell contents, but leave the cells intact:


1. Select one or more cells.


2. Select Edit > Clear or press Delete.


Note: If you select an entire row or column, and then 
select Edit > Clear or press Delete, Dreamweaver 
removes the entire row or column—not just their 
contents—from the table.


Resizing tables, rows, and columns
You can resize an entire table or individual rows and columns. When you resize an entire table, all the cells in the 
table resize proportionately.


To resize a table:


Select the table and do one of the following.


• To resize the table horizontally, drag the selection 
handle on the right.


• To resize the table vertically, drag the selection 
handle on the bottom.


• To resize in both dimensions, drag the selection 
handle at the lower-right corner.


To resize a column’s width:


Do one of the following: 


• Drag the right border of the column. 


• Select the column. In the Properties panel 
(Figure 7), change the number in the Column Width 
text box.


Figure 7 Table Properties panel


To resize a row’s height:


Do one of the following: 


• Drag the lower border of the row. 


• Select the row. In the Properties panel (Figure 7), 
change the number in the Row Height text box.


Column Width Row Height
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Modifying table properties
You can modify the properties of a table, its rows and columns, or its cells by using the Properties panel (Figure 8). 
Attention to table borders and cell padding (the amount of spacing between table cells) in particular can help you 
create effective table designs.


Figure 8 Table Properties panel


You can also set a row or column as a header by using the Properties panel. Table cell headers help make tables more 
useful and accessible (Figure 9).


Figure 9 Table cell Properties panel 


To modify table properties:


1. Select the table you want to modify.


2. Make changes to any of the options in the Properties 
panel (Figure 8).


To modify table row or column properties:


1. Select the row or column you want to modify.


2. Make changes to any of the options in the Properties 
panel.


To modify table cell properties:


1. In your document, select the cell or cells you want to 
modify.


2. Make changes to any of the options in the Properties 
panel (Figure 9).


To set a row or a column as header:


1. Select a row or column.


2. In the Properties panel, select the Header option.


The words in the row or column will appear centered and 
bolded (Figure 10).


Figure 10 Table with top row set as header
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Inserting a spreadsheet table
To insert a spreadsheet created in another application, such as Microsoft Excel, save the spreadsheet file in tab-
delimited (txt) or comma-separated-values format (csv). These tables are a quick way for setting up the layout for a 
catalog or directory of information.


To save a spreadsheet in TXT or CSV format:


1. Open a spreadsheet file in the program in which you 
created it, such as Microsoft Excel.


2. Select File > Save As.


3. For the file format, select either Text (Tab Delimited) or 
CSV (Comma Delimited) in the Save As Type 
(Windows) or Format (Mac OS) pop-up menu to save the 
spreadsheet as a data file.


4. Save and close the spreadsheet program.


To insert the spreadsheet into a Dreamweaver document:


1. Start Dreamweaver and open the document into which 
you want to insert the spreadsheet table.


2. Select the Data category in the Insert panel and click the 
Import Tabular Data button (Figure 11).


The Import Tabular Data dialog box opens (Figure 12)).


3. In the dialog box, click Browse and select the spreadsheet 
file. Click Open.


4. On the Delimiter pop-up menu (Figure 13), select Tab if 
you saved the spreadsheet file in tab-delimited format or 
select Comma if you saved the file in CSV format.


5. Click OK to close the Insert Tabular Data dialog box.


The contents of the spreadsheet file are displayed in a 
table on the page.


Figure 11 Import Tabular Data button on Insert 
panel


Figure 12 Import Tabular Data dialog box


Figure 13 Delimiter pop-up menu
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To sort table data: 


1. Select the table and select Commands > Sort Table.


The Sort Table dialog box opens (Figure 14). You can 
select which column to sort by and sort alphabetically or 
numerically. You can sort first by one column, and then 
sort the data further by a second column.


2. Select your sort preferences, and click OK.


Figure 14 Sort Table dialog box
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How to set document properties
For each page you create in Dreamweaver, you can specify layout and formatting properties by using the Page 
Properties dialog box (Figure 1). The Page Properties dialog box lets you specify the default font family and font 
size, background color, margins, link styles, and many other aspects of page design. You can assign new page 
properties for each new page you create, and modify those for existing pages. You can also change the Document 
Type Declaration in the Title/Encoding category of the Page Properties dialog box. For example, if you wanted to 
alter a document’s DTD from HTML 4.1 to HTML 5. Changes you make in the Page Properties dialog box apply to 
the entire page.


Dreamweaver gives you two methods for modifying page properties: CSS or HTML. Adobe recommends using CSS 
to set backgrounds and modify page properties.


Figure 1 Page Properties dialog box


Using CSS to set font, colors, margins, and background image properties
Use the Page Properties dialog box to specify several basic page layout options for your web pages, including the 
font, background color, and background image.


To set layout and formatting options for a page:


1. Open a document in Adobe Dreamweaver CS6.


2. Select Modify > Page Properties or click the Page 
Properties button in the text Properties panel.


The Page Properties dialog box opens (Figure 1).
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3. Select the Appearance (CSS) category and set the 
options.


Page Font specifies the default font family to use for the 
page. Dreamweaver uses the font family you specify 
unless another font is specifically set for a text element.


Size specifies the default font size to use in the page. 
Dreamweaver uses the font size you specify unless 
another font size is specifically set for a text element.


Text Color specifies the default color to render fonts with.


Background Color sets a background color for your page. 
Click the Background color box and select a color from 
the color picker (Figure 2).


Background Image sets a background image for the page. 
Click the Browse button, then browse to and select the 
image. Alternatively, enter the path to the background 
image in the Background Image text box. Dreamweaver 
tiles (repeats) the background image if it does not fill the 
entire window, just as browsers do.


Repeat text specifies how the background image will be 
displayed on the page:


• Select the No-repeat option to display the 
background image only once.


• Select the Repeat option to repeat, or tile, the image 
both horizontally and vertically.


• Select the Repeat-x option to tile the image 
horizontally.


• Select the Repeat-y option to tile the image 
vertically.


Left Margin and Right Margin specify the size of the left 
and right page margins. 


Top Margin and Bottom specify the size of the top and 
bottom page margins.


4. When you’ve finished making changes, click Apply to 
set the properties, and click OK to close the dialog box.


Figure 2 Set Background Color in the Page 
Properties dialog box
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How to work with external Cascading Style Sheets
Many web professionals find that using an external style sheet--a style sheet that exists in its own file--offers a 
number of advantages over including styles in the header of an HTML file. These advantages include:


• Flexibility: With CSS stored in one file, you can easily change the appearance of all documents that refer to 
the external style sheet.


• Consistency: All documents sharing the same style sheet will have a similar appearance.


Using an external style sheet separates form from content. Separating form from content is a widely-adopted principle 
in web design which allows, among other benefits, for content to be shared in a range of contexts. 


Exporting CSS rules to an external style sheet
You can convert an internal CSS style sheet to an external one by exporting it, removing the internal CSS style sheet, 
and attaching the exported CSS style sheet to one or more web pages. 


To export a style sheet:


1. Start Dreamweaver and open the CSS Styles Panel 
(Window > CSS Styles) (Figure 1).


2. Confirm that All is selected in the CSS Styles panel.


3. Select the CSS rule you want to move to an external style 
sheet.


Note: To move more than one rule at a time, you can 
Shift-click to select multiple rules that are next to each 
other. To select multiple rules that aren’t next to each 
other, you can Control-click (Windows) or Command-
click (Mac OS) the names of the rules.


4. Right-click (Windows) or Control-click (Mac OS) the 
selected rule(s) and select Move CSS Rules in the context 
menu.


The Move To External Style Sheet dialog box opens 
(Figure 2).


Figure 1 CSS Styles panel


Figure 2 Move To External Style Sheet dialog box
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5. Select A New Style Sheet and then click OK.


The Save Style Sheet File As dialog box opens 
(Figure 3).


6. Browse to a location for the CSS file, enter a name for the 
file, and click Save.


Note: It is good practice to place CSS files in their own 
folder and good practice to name that folder css.


Dreamweaver exports the CSS file.


Figure 3 Save Style Sheet File As dialog box


To delete an internal style sheet:


1. In the CSS Styles panel under All, select <style>.


2. Click the Delete Embedded Stylesheet button (Figure 4).


Dreamweaver removes the internal style sheet. If the 
internal style sheet contains any styles still being used on 
the page, the affected text reverts to its default 
formatting, or it takes on the formatting defined in the 
external style sheet.


Figure 4 CSS Styles panel


Delete Embedded Style Sheet button
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Attaching an external style sheet
Once you create an external style sheet and attach it to multiple documents, you can instantly change any style in all 
your documents by making changes to the external style sheet.


Note: Once you start using an external style sheet, it is best to make all text formatting changes through that style 
sheet. If you make formatting changes through the Properties panel, Dreamweaver will automatically create a new 
internal style sheet.


To attach an external style sheet:


1. Open a document in Dreamweaver.


2. Confirm that the CSS Styles panel is open.


If it is not, select Window > CSS Styles.


3. Click the Attach Style Sheet button (Figure 5).


The Attach External Style Sheet dialog box opens 
(Figure 6).


4. Click Browse, navigate to your saved style sheet, select 
it, and click OK.


5. In the Attach External Style Sheet dialog box, click OK.


Dreamweaver attaches the style sheet to your document 
(Figure 7).


The style sheet’s rules are now available in the Properties 
panel. You may need to expand the style sheet to see its 
rules.


You can attach the same style sheet to multiple 
documents. When you make changes to the style sheet, 
those changes will appear in all documents the style sheet 
is attached to.


Figure 5 CSS Styles panel


Figure 6 Attach External Style Sheet dialog box


Figure 7 Attached style sheet


Attach Style Sheet button
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Creating external style sheets
You can also create external style sheets directly from the New Document dialog box. 


To edit create an external Style Sheet:


1. Select File > New to create a new document.


The New Document dialog box opens (Figure 8).


2. In the Blank Page category of the New Document dialog 
box, select CSS for Page Type.


3. Click Create. 


The untitled CSS page opens in Dreamweaver in Code 
View (Figure 9).


4. Save the document to the site root folder.


5. Return to the HTML document in which you previously 
applied a style by using the CSS Styles panel.


6. In Code View, drag to select the two or more styles you 
previously created. Be sure to include the selectors and 
everything that falls between, including the braces 
(Figure 10).


7. Select Edit > Cut.


8. Click the newly-created CSS document in the Document 
window.


9. Place the cursor on line 4, beneath the CSS comment.


10. Select Edit > Paste.


The copied CSS styles are pasted from the Clipboard into 
the CSS document.


11. Select File > Save.


12. Return to the HTML document in the document window.


Notice in the Design View that all formating for the text 
is gone. In the next steps, you re-apply the CSS styles by 
linking to the external CSS document you just created.


13. In the CSS Styles panel, click the Attach Style Sheet 
button in the lower-right corner of the pane (Figure 5).


The Attach External Style Sheet dialog box opens 
(Figure 11).


14. Click the Browse button and browse to the external CSS 
style sheet that you saved to your site root folder, and 
confirm that the Add As: Link option is selected.


15. Click OK.


A link to the CSS document is added to Head section of 
the  file, and the CSS rules are applied to the text in the 
HTML document.


16. Save the file.


Figure 8 New Document dialog box


Figure 9 New, blank CSS document


Figure 10 Selecting CSS styles


Figure 11 Attach External Style Sheet dialog box
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How to create forms
You can use forms to interact with or gather information from site visitors. With forms, visitors can provide feedback, 
sign a guest book, take a survey, or place an order for merchandise. In Adobe Dreamweaver CS6, you can create a 
variety of form elements, such as text fields, password fields, radio buttons, checkboxes, pop-up menus, and clickable 
images (such as a Submit button).


The Forms category in the Insert panel (Figure 1) contains buttons for creating forms and inserting form elements.


Figure 1 Forms category in the Insert panel


The data gathered in forms is usually sent to a database on a server or through e-mail. To set up the form processing, 
contact your site administrator. This guide helps you make the user interface of a form.


Setting up a form
You set up a form by inserting it and configuring options through the Properties panel.


To set up a form:


1. Open a page in Dreamweaver.


2. Place the insertion point on the page where you want to 
insert a form or draw a new div for more precise 
positioning of the form on your page. 


Note: To draw a new div, click Draw AP Div in the 
Layout category in the Insert panel, and then drag to draw 
the div. Be sure to make the div large enough to contain 
the entire form you plan to create.
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3. Select the Forms category in the Insert panel (Figure 1), 
and click Form. 


A blank form appears, with a red dotted outline 
(Figure 2). You place all form elements inside this 
outline. If you placed the form inside a div, you may need 
to click outside the div to see the entire form outline.


Form options appear in the Properties panel.


4. From the Method pop-up menu in the Properties panel 
(Figure 3), select either GET or POST.


• GET appends the form contents to the URL specified 
in the Action text box. Use GET if the form data is 
short and the results of the form will lead to a page 
that you want the visitor to be able to bookmark.


• POST sends the form contents directly to the server 
in a manner that is not visible to the visitor. Use 
POST if the form data might be long (if, for instance, 
the form includes a text field that the visitor can use 
to type an unlimited amount of text). 


5. In the Action text box, type the URL or CGI script that 
will process the form.


Note: Get this information from your site administrator.


Figure 2 New, empty form


Figure 3 Forms Properties panel


Adding form elements
Using the Forms category in the Insert panel, you can insert any combination of form elements within the red outline 
of the form. You can use tables to lay out these elements if you choose.


Using form fields


Form fields enable site visitors to enter text into a form. Form fields include the following:


• Text fields, in which a visitor types a response


• File fields, in which a visitor types the path of a file to upload to your server


Adding text fields


Text fields provide a space in which visitors can enter text.
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To add a text field:


1. Click the Text Field button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens 
(Figure 4).


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the text field in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).


The ID is used by HTML and/or Javascript code to 
distinguish this input tag from others, but it isn’t visible 
to site visitors.


3. Enter a label for the text field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


The label will be displayed next to the text field, 
indicating to the visitor what to put in the field.


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


5. In the Add Form Tag dialog box, click Yes.


The text field appears in the form (Figure 5).


6. Click in the text field (not the label) to select it.


7. In the form Properties panel (Figure 6), select one of the 
three types of text fields:


• Single Line text for short answers


• Multi Line text for long answers such as the visitor’s 
description of a problem with a purchased item


• Password text for passwords (in which asterisks 
appear in place of typed characters)


Note: You can also create a multiple-line text field by 
clicking the Text Area button in the Insert panel.


Figure 4 Input Tag Accessibility Attributes dialog 
box


Figure 5 Example of text field in the form


Figure 6 Form Text Field Properties panel


Adding a file field


A file field enables site visitors to select a file on their computers (such as a word-processing document or graphics 
file) and upload it to your server. A file field looks like other single-line text fields, except it also provides a Browse 
button. The visitor either types the path to the file they want to upload or uses the Browse button to locate and select 
the file.
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To add a file field:


1. Click the File Field button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the file field in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).


3. Enter a label for the file field in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


The file field appears in your document (Figure 7).


5. Click in the file field (not the label) to select it. In the 
Properties panel, in the Char Width text box, specify the 
maximum number of characters visitors will see in the 
field (Figure 8).


6. In the Max Char text box, specify the maximum number 
of characters the field will hold.


Note: Contact your site administrator to confirm that 
anonymous file uploads are allowed before using the file 
field.            


Figure 7 File field example


Figure 8 Form File Field Properties panel


Using checkboxes and radio buttons
Visitors click a checkbox or radio button to make a choice. With checkboxes, visitors can toggle a single option on or 
off, or they can select one or more options from a group of options. With radio buttons, visitors can select only one 
option from a group of options.


To add a checkbox:


1. Click the Checkbox button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the checkbox in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore (_).


3. Enter a label for the checkbox in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 
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4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


The checkbox button appears in your document 
(Figure 9).


5. Click the checkbox (not the label) to select it.


6. In the Checked Value text box in the Properties panel 
(Figure 10), enter a value for the checkbox.


This is the value that will be returned by the form. For 
example, for a checkbox that indicates whether a visitor 
wishes to be on a mailing list, you might set a value of 1 
for yes.


7. For Initial State, select Checked if you want an option to 
appear selected when the form first loads in the visitor’s 
browser. Otherwise, select Unchecked.


Figure 9 Example of checkbox


Figure 10 Form Checkbox Properties panel


To add a group of radio buttons:


1. Click the Radio Group button in the Insert panel to insert 
a group.


The Radio Group dialog box opens (Figure 11).


2. Enter a name in the Name text box.


3. Click the plus (+) button to add a radio button to the 
group.


4. Enter a label and (if you want) a checked value for each 
button.


5. Select an item in the radio button list, and click the up or 
down arrows to reorder the buttons.


6. Select Line Breaks to arrange the radio buttons without 
using a table. Select Table to arrange them in a table. 


7. Click OK.


The group of radio buttons is added to the form 
(Figure 12).


8. Click a radio button (not its label) to select it.


Figure 11 Radio Group dialog box


Figure 12 Example of Radio Group
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9. In the Properties panel, click Checked or Unchecked to 
indicate if this option is selected by default (Figure 13).


Figure 13 Form Radio Button Properties panel


Using list menus and drop-down menus (List/Menu)
Lists and menus allow visitors to select options from a list or pop-up menu. With a list menu, you can display 
multiple options in a confined space and allow visitors to select multiple items. Visitors can select only one item from 
a pop-up menu.


To add a list menu:


1. Click the List/Menu button (Windows) or Select (List/
Menu) button (Mac OS).


The Input Tag Accessibility Attributes dialog box opens.


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the list menu in the ID text box. You 
may use any combination of letters, numbers, and an 
underscore ( _ ).


3. Enter a label for the list menu in the Label text box. You 
can leave the other properties in the dialog box at their 
default values. 


4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


A list/menu field appears in your document (Figure 14).


5. Click the list/menu field (not its label) to select it.


6. In the Properties panel, for Type, select List (Figure 15).


Figure 14 Example of list/menu field


Figure 15 Form List Menu Properties panel
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7. In the Height text box, enter the number of items the list 
will display.


If this number is less than the total number of items in the 
list, a scroll bar will be displayed.


8. If you want to allow visitors to select more than one item 
in the list, select Allow Multiple for Selections.


9. Click the List Values button to add the list items.


The List Values dialog box opens (Figure 16).


10. With the insertion point in the Item Label text box, enter 
the text you want to appear in the list.


11. In the Value text box, enter data you want sent to the 
server when a visitor selects the item.


If you enter no value, then the form sends the label as the 
value for that item.


12. Press Enter (Windows) or Return (Mac OS).


13. To add another item to the list, click the plus (+) button.


14. When you finish, click OK to close the List Values dialog 
box.


Figure 16 List Values dialog box


Figure 17 Form List Menu Properties panel


15. To have one of the items in the list selected by default, 
select that item in the Initially Selected text box in the 
Properties panel (Figure 18).


The Initially selected item appears in the form 
(Figure 18).


Figure 18 Form list with three items in the list


To add a drop-down menu:


1. Click the List/Menu button (Windows) or Select (List/
Menu) button (Mac OS).


The Input Tag Accessibility Attributes dialog box opens.


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the pop-up menu in the ID text box. 
You may use any combination of letters, numbers, and an 
underscore (_).


3. Enter a label for the pop-up menu in the Label text box. 
You can leave the other properties in the dialog box at 
their default values. 
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4. Click the OK button to close the Input Tag Accessibility 
Attributes dialog box.


A list/menu field appears in your document (Figure 19).


5. Click the list/menu field (not its label) to select it. 


6. In the Properties panel, for Type, select Menu.


7. Click the List Values button to add the menu items.


The List Values dialog box opens (Figure 20).


8. With the insertion point in the Item Label text box, enter 
the text you want to appear in the menu.


9. In the Value text box, enter data you want sent to the 
server when a visitor selects the item.


10. Press Enter (Windows) or Return (Mac OS).


11. To add another item to the menu, click the plus (+) 
button.


12. When you finish, click OK to close the List Values dialog 
box.


13. To have one of the items in the menu selected by default, 
select that item in the Initially Selected text box in the 
Properties panel. 


Note: To see the menu items in operation,  preview this 
page in a browser (Figure 21).


Figure 19 A list/menu field


Figure 20 List Values dialog box


Figure 21 Preview in a browser


Using form buttons
Form buttons control form operations. Use a form button to submit data entered into a form to the server or to reset 
the form. There are two types of form buttons: Standard text buttons are the browser's default button style, with text 
you want to display (typically Submit, Send, or Reset); graphical buttons use the graphic of your choice.


To add a standard text button:


1. Click the Button button in the Insert panel.


The Input Tag Accessibility Attributes dialog box opens.


2. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the button in the ID text box. You may 
use any combination of letters, numbers, and an 
underscore (_).


Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values.
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3. Don’t enter a label for the button. Click OK to close the 
Input Tag Accessibility Attributes dialog box.


Note:  A label would appear next to the button, rather 
than on it, so you don’t want a label for a button form 
element. The text on the button itself is set by the button’s 
value attribute, which you will set in the next step.


A text button appears in the document (Figure 22).


Note: In this example, a Submit button is placed below 
an existing file field.


4. Click the button to select it.


5. In the Properties panel’s Value text box, enter the text you 
want to appear on the button (Figure 23).


Note: It’s a good idea to set the value to whatever the 
button does. “Submit” is a good choice, but you might 
also consider brief phrases in the forms of commands (for 
example, “Send Message” or “Update Profile” or 
“Register”).


6. Select the type of Action (usually this is Submit Form).


Figure 22 Example of text button


Figure 23 Form Button Properties panel


Adding a graphical submit button


You can use images as submit button icons. Using an image to perform tasks other than submitting data requires 
attaching a behavior to the form object by using the Behaviors panel.


To add a graphical submit button:


1. Click the Image Field button in the Insert panel.


The Select Image Source dialog box appears (Figure 24).


2. Locate and select the image to use as the submit button 
icon; then click OK (Windows) or Open (Mac OS).


The Input Tag Accessibility Attributes dialog box opens.


3. In the Input Tag Accessibility Attributes dialog box, enter 
a unique name for the button in the ID text box. You may 
use any combination of letters, numbers, and an 
underscore (_).


Note: There are two reserved names: Submit, which 
submits the form data for processing, and Reset, which 
resets all the form fields to their original values.


Figure 24 Select Image Source dialog box
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4. Don’t enter a label for the button. Click the OK button to 
close the Input Tag Accessibility Attributes dialog box.


The graphical submit button appears in your document 
(Figure 25).


5. Click the button to select it.


6. In the Alt text box, type alternate text you want to appear 
in place of the image for text-only browsers (Figure 26). 
This should match any text displayed on the button.


Note: You can also click the folder icon beside the Src 
text box to select a new image for the button.


Figure 25 Example of graphical submit button 


Figure 26 Form Image Field Properties panel


Using jump menus for navigation
A jump menu is a pop-up menu with options that link to documents or files. It is a form element that acts as 
navigation. You can create links to documents in your website or other websites, e-mail links, links to graphics, or 
links to any file type that can be opened in a browser. Because using this type of menu will cause the browser to 
navigate to another page, don’t mix jump menus with other form elements.


To add a jump menu:


1. Click the Jump Menu button in the Insert panel.


The Insert Jump Menu dialog box opens (Figure 27).


2. Complete the dialog box.


For more information, click the Help button in the dialog 
box.


3. Click OK.


Figure 27 Insert Jump Menu dialog box
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How to create image maps
An image map is an image that has been divided into regions, or hotspots. When a visitor clicks a hotspot on your 
web page, an action occurs; for example, another web page opens. An example is a geographic map that links each 
country in the map to another page in your site or an external website containing information about that country.


Creating an image map
1. Start Adobe Dreamweaver CS6 and open the document 


in which you want to create an image map.


2. Make sure the Common category is selected in the Insert 
panel.


3. Click the down arrow on the Images button and select 
Image from the pop-up menu (Figure 1).


The Select Image Source dialog box opens.


4. Locate an image for the image map, select it, and click 
OK (Windows) or Open (Mac OS).


The Image Tag Accessibility Attributes dialog box opens.


5. Enter alternate text for the image, and then click OK.


The image is added to the page (Figure 2).


6. Select the image in the Document window. 


7. In the Properties panel, type a name for the image map in 
the Map text box.


Note: Naming conventions for image maps follow the 
same rules as filenames: no spaces or special characters.


Figure 1 Insert panel Images pop-up menu


Figure 2 Image added to document
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8. Select one of the hotspot tools located below the Map 
name, and draw a rectangle, circle, or polygon around a 
part of the image (Figure 3).


As soon as you begin drawing, you are prompted to enter 
an Alt tag for the hotspot.


9. Click OK, enter a descriptive name in the Alt text box in 
the Properties panel, and then finish drawing the hotspot.


10. After drawing your hotspot, add a link to a page in your 
site or to an external URL by using the Link text box 
(Figure 4).


Note: If you’re linking to a page outside of your site, it is 
a best practice to set the Target menu to 
target="_blank". This causes the link to open in a 
new browser window, so that the page doesn’t appear to 
be part of your site.


11. Repeat steps 8–10 to add other hotspots in the image 
map.


12. Save the page.


13. Select File > Preview In Browser and select a browser 
from the submenu to preview the page and test each link.


Figure 3 Image map drawn with the Polygon 
Hotspot tool 


Figure 4 Properties panel
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How to create interactive navigation
There are several options for creating interactive navigation for your web pages: You can easily create:


• graphical buttons and navigation bars in Fireworks, and import them into Dreamweaver. 


• image-based, or HTML, pop-up menus in Fireworks, and place them in a Dreamweaver file.


• rollover images that add visual interest and interaction by using Dreamweaver.


Advanced users may consider using Fireworks to create CSS-based interactive navigation. You can use the CSS 
Properties panel to extract complex CSS3 properties for buttons, such as text, border radius, and gradients..


Creating buttons and navigation bars in Fireworks
Fireworks CS6 enables you to design the look and functionality of buttons, including links and rollover features. 
After you export these buttons from Fireworks, you can import them into Dreamweaver CS6.


Building buttons


In the following steps, you create a button for export into Dreamweaver.


To build a button:


1. Start Fireworks. 


2. Create a new document. 


3. Type 200 pixels for Width and 200 pixels for Height. Type 72 pixels/inch for Resolution.


Note: At the end of this exercise, you will trim the canvas to fit the button. 


4. Save the document in the images folder of your Dreamweaver website.


5. Select Edit > Insert > New Button.


The button editor opens and the Properties panel displays button properties (Figure 1).


Figure 1 Button Properties panel


6. Deselect the Enable option for 9-Slice Scaling Guides in the Properties panel. (To learn about 9-Slice Scaling 
Guides, select Help > Fireworks Help).


Buttons contain four states:


• Up (button untouched)


• Over (pointer over button)


• Down (button being clicked)


• Over While Down (pointer over while 
button held down)


You can view each state by selecting it in the State pop-up menu in the Properties panel (Figure 1). The current 
state of the new button is Up, as shown in the Properties panel.


State pop-up menu9-slice scaling guides Enable/Disable option
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7. Use the Rectangle tool or the Ellipse tool from the Tools panel to draw a shape for the Up state. Make the 
dimensions of the shape fit the size of your navigation bar.


8. To add depth to the button, click the Add Live Filters button in the Properties panel (the plus sign next to Filters), 
and then select a bevel option from the pop-up menu:


• Bevel and Emboss > Inner Bevel


• Bevel and Emboss > Outer Bevel


9. Using the Properties panel, add color to the button. 


10. Use the Text tool to add text to the button, and center-align the text. 


The color and text of the button should match the color and font design of your page.


11. Confirm the Smart Guides are visible and active. If not, select View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.


12. Select the Pointer tool. 


13. Drag the text block until the horizontal and vertical Smart Guides appear so that the text is centered over the 
shape (Figure 2).


Figure 2 Smart Guides


14. Select Window > Object & Layout > Align (Windows) or Window > Align (Mac OS) to open the Align panel.


15. Click the button at the top of the panel, if necessary, until the label Relative To Canvas is visible (Figure 3). 


Figure 3 Align Panel


16. Use the Pointer tool and shift-click to select both the button and the text.


17. Click the Align Horizontal Center and Align Vertical Center buttons.


Later you will duplicate this first button to create the other buttons. A centered shape aligns well with other 
duplicate buttons. If the text is centered, button labels with varying numbers of characters will all be well 
aligned.


Relative To Canvas or 
Relative To Object


Align Vertical CenterAlign Horizontal
Center
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18. Click away from the shape and text to deselect them. In the Properties panel, select Over in the State pop-up 
menu (Figure 4).


Figure 4 Properties panel 


19. In the Properties panel, click Copy Up Graphic to copy the Up graphic to the Over button state (Figure 4). 


This saves you time and helps keep the look and position of the button consistent.


20. Decide how you want the button to look when the pointer rolls over the button. Then change the copied graphic 
by modifying the color or effects of the text or the shape.


21. Click away from the shape and text to deselect them. In the Properties panel, select Down in the State pop-up 
menu.


22. Click Copy Over Graphic to copy the Over graphic to this button state.


23. Decide how you want the button to look when visitors click the button. Add effects such as darkening the color.


24. (Optional) You can add a drop shadow to the shape by clicking Add Filters in the Properties panel, and then 
selecting Shadow And Glow > Drop Shadow.


For this project, you will skip the Over While Down state.


25. Click away from the shape and text to deselect them. In the Properties panel, select Active Area in the State pop-
up menu (Figure 4).


The active area of the button is shown by green shading and red lines. This shading indicates the area visitors can 
click to activate the button (Figure 5).


Figure 5 Button Active Area selected 


26. When you are satisfied with the states of your button in the Button Editor, click Page 1 at the top of the screen 
(Figure 6) to close the Button Editor and return to the Page 1 canvas.


Your button appears on the Fireworks Page 1 canvas and in the Document Library panel. 


Figure 6  Fireowrks Button Editor


State pop-up menu
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27. Click the button to select it. In the Link text box in the Properties panel, enter the name of a web page to link to 
this button (Figure 7).


Figure 7 Properties panel with Link text box


28. In the Alt text box, enter an alternative text label for the button.


Alternative text is displayed in place of the image when visitors elect not to display images in their browsers. 
Such text can also be voiced by screen readers for visitors who use them. Typically, alternative text for a button 
should be the same as the text displayed on the button.


29. Select Modify > Canvas > Fit Canvas to fit the canvas to the size of your button.


30. Select File > Save to save the new button.


Copying buttons and making the navigation bar


In the following steps, you duplicate the button you created in the previous steps to make the navigation bar.


To copy the buttons and make the navigation bar:


1. Change the size of the canvas to accommodate all the 
buttons on your navigation bar. Select Modify > Canvas 
> Canvas Size and edit the value for height or width in 
the Canvas Size dialog box.


If you have four buttons, for example, multiply the height 
or width of the first button by four (depending on 
whether your navigation bar is vertical or horizontal).


2. Select the first button. Move it to the top (or to the left 
edge) of the canvas. Select Edit > Clone.


A new instance of the button appears on top of the 
original button.


3. Drag the new button instance below  (or to the right of) 
the original button. You can also use the arrow keys to 
move the button.


4. Repeat steps 2 and 3 as many times as necessary to create 
the rest of your navigation bar (Figure 8). 


5. Click the second button and use the Properties panel to 
edit it. In the Text box, change the text to the name of the 
second button. Edit the information in the Link text box 
and the Alt text box as appropriate for this button.


6. Repeat step 5 for the remaining buttons (Figure 9).


7. To fit the canvas to your navigation bar, select Modify > 
Canvas > Fit Canvas.


8. Save the file.


Figure 8 Cloned buttons


Figure 9 Buttons with edited text labels
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Exporting a navigation bar for use in Dreamweaver


Fireworks enables you to save interactive graphics (a button, for instance) as HTML so you can import working 
buttons into a Dreamweaver document.


To export a navigation bar for use in Dreamweaver:


1. Choose File > Export.


The Export dialog box opens (Figure 10).


2. Navigate to the folder in your local root folder where you 
want to save the navigation bar.


3. Give the navigation bar file a short descriptive name.


4. Make sure the Selected Slices Only option is not selected.


5. Make sure HTML And Images is selected in the Export 
pop-up menu.


6. Make sure the Include Areas Without Slices option is 
selected.


7. Select the Put Images In Subfolder option.


8. Click Save (Windows) or Export (Mac OS).


9. Save the Fireworks document, and close Fireworks.
Figure 10 Export dialog box


Inserting the navigation bar into a Dreamweaver document


Now that you’ve created the navigation bar, you can insert it into a Dreamweaver document. You do so by using an 
option in the Insert panel.


To insert the navigation bar into a Dreamweaver document:


1. Start Dreamweaver.


2. Open the page in which you want to insert the navigation 
bar and save the Dreamweaver document before 
importing.


3. Position the insertion point where you want the 
navigation bar to appear.
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4. In the Common category on the Insert panel, click the 
Images pop-up menu and select Fireworks HTML 
(Figure 11).


The Insert Fireworks HTML dialog box opens 
(Figure 12).


5. In the Insert Fireworks HTML dialog box, click the 
Browse button, and then locate and select your 
navigation bar HTML file. 


6. Click Open.


7. In the Insert Fireworks HTML dialog box, click OK.


The navigation bar appears on the page.


8. To edit a button, select the button and then use the 
Properties panel to change settings, such as the link or 
alternative text.


9. Check that the link address and the alternative text label 
are correct for each button.


10. Save the Dreamweaver document.


11. Select File > Preview In Browser and choose a browser 
from the submenu to test button rollover functions in a 
browser (Figure 13).


Figure 11 Insert panel


Figure 12 Fireworks HTML dialog box


Figure 13 Page previewed in browser
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How to create pop-up menus
Pop-up menus are menus that are displayed in a browser when a site visitor moves the pointer over or clicks a trigger 
image. Items in a pop-up menu can have URL links attached to them for navigation.


You can use pop-up menus to display multiple links within a small space. They provide navigation flexibility without 
long download times. You can define the appearance of the pop-up menu so it matches the overall look and feel of 
your website. A pop-up menu is similar to a table: each menu item is like a table cell. You can customize the menu by 
choosing from a selection of font types, cell colors, and background image styles.


Creating pop-up menus in Fireworks CS6


In the following steps, you will first create entries for a pop-up menu, then set the menu’s appearance and position.


To create entries for a pop-up menu:


1. Start Fireworks CS6.


2. Open or create the image that will trigger the pop-up 
menu.


Note: The trigger image may be a text object or a 
graphic. Be sure to set the canvas dimensions to account 
for the size of the pop-up menu; you can trim the canvas 
after you build the menu to adjust the size.


3. Click the trigger image to select it.


4. Select Edit > Insert > Rectangular Slice to insert a slice 
over the trigger image (Figure 14).


Note: To create a slice that is not rectangular, you can use 
the Polygon Slice tool. See Fireworks Help for more 
information.


When a slice is selected, a circle with cross hairs appears 
in the center of the slice. This is called a behavior handle.


5. Click the behavior handle and select Add Pop-up Menu 
from the context menu (Figure 15).


Figure 14 Sliced image


Figure 15 Behavior handle context menu


Behavior handle
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The Pop-up Menu Editor appears (Figure 16).


6. In the Content tab of the Pop-up Menu Editor, if the 
insertion point is not already in the Text box, click twice 
in that box. Enter the text for a menu item. Click in the 
Link box, and enter the name of the file it links to.


7. To add a new menu item, click the Add Menu (+) button 
and repeat step 6 (Figure 17).


8. To delete a menu item, select the item and click the 
Delete Menu (–) button.


9. After you have entered all the menu items, click Next or 
click the Appearance tab.


Figure 16 Pop-up menu editor


Figure 17 Pop-up Menu Editor with menu entries


Setting the appearance of a pop-up menu


On the Appearance tab of the Pop-up Menu Editor, you can format the text, apply graphic styles to the Over and Up 
states, and select vertical or horizontal orientation for the pop-up menu.


To set the appearance of a pop-up menu:


1. Continue where you left off in the previous task.


2. Select either HTML or Image for Cells (Figure 18).


Note: HTML sets the menu’s appearance using only 
HTML code; this setting produces pages with smaller file 
sizes. Image gives you a selection of graphic image styles 
to use as the cell background; this setting produces pages 
with larger file sizes.


3. Select Vertical Menu or Horizontal Menu from the 
Orientation pop-up menu near the top of the Appearance 
tab.


Settings you choose immediately appear in the preview 
window near the bottom of the Appearance tab.


4. Select font type, font size, and text styles for your menu 
items.


5. Select text and background (Cell) colors for Up State and 
Over State.


These states are similar to button states. The Up state of a 
menu item is its default appearance in the menu. The 
Over state is the appearance of the menu item when the 
pointer passes over it.


Figure 18 Appearance tab of Pop-up Menu Editor


Delete Menu button


Add Menu button
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6. If Image is selected as the cell type, select a graphical 
style for the Up state and the Over state (Figure 19).


7. Click Next or click the Advanced tab (Figure 20) if you 
want to change cell or border attributes.


Typically you can use the default settings in the 
Advanced tab.


Figure 19 Graphical style for cells


Figure 20 Advanced tab of Pop-up Menu Editor


To set the position of a pop-up menu:


1. Continue where you left off in the previous task.


2. Click Next or click the Position tab in the Pop-up Menu 
Editor (Figure 21).


3. Click a Menu Position button to position the pop-up 
menu relative to the trigger slice.


Note: Alternatively, you can enter X and Y coordinates. 
Coordinates of 0, 0 align the upper left corner of the pop-
up menu with the upper left corner of the trigger slice.


4. Click Done. Then save your file.


5. To preview your pop-up menu, select File > Preview In 
Browser and select a browser from the submenu. Figure 21 Position tab of Pop-up Menu Editor
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Editing a pop-up menu


You edit a pop-up menu through the same context menu with which you created the pop-up menu.


To edit a pop-up menu:


1. To edit a pop-up menu, select the slice to which your 
menu is attached and double-click the pop-up menu’s 
blue outline in the workspace, or click the behavior 
handle and select Edit Pop-up Menu (Figure 22).


The Pop-up Menu Editor opens.


2. Set options in the Pop-up Menu Editor just as you did 
when you created your pop-up menu.


Figure 22 Behavior handle context menu


Exporting a pop-up menu for use in Dreamweaver CS6


To save the pop-up menu so it will be active on your website, export the document as HTML.


To export a pop-up menu:


1. While still in Fireworks, trim any excess canvas 
surrounding your image by choosing Modify > Canvas > 
Trim Canvas.


2. Save the file.


3. Select File > Export.


The Export dialog box opens.


4. Navigate to your local root folder.


5. Give the pop-up menu a short, descriptive name.


6. Select HTML And Images in the Export menu.


7. Make sure the option Put Images In Subfolder is selected.


Note: Putting all the exported image files in a subfolder 
is a good way to manage those files.


8. Save (Windows) or Export (Mac OS).


9. Save your document and close Fireworks.


Importing a pop-up menu into Dreamweaver


You insert a pop-up menu into Dreamweaver as you would anything else, by using the Insert panel.


To insert a pop-up menu into Dreamweaver:


1. Start Dreamweaver.
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2. Open the document into which you want to import the 
pop-up menu.


3. Position the insertion point where you want the pop-up 
menu to appear. You can also place the pop-up menu 
within a div for more precise positioning of the menu.


4. Make sure the Common category is selected in the Insert 
panel. Click the down arrow on the Images button, and 
select Fireworks HTML (Figure 23).


The Insert Fireworks HTML dialog box opens 
(Figure 24).


5. Click Browse, select the pop-up menu HTML file, and 
click Open.


Note: The Images subfolder contains the sliced images 
for your pop-up menu.


6. OK to close the Insert Fireworks HTML dialog box.


The pop-up menu is inserted into your Dreamweaver 
document.


7. Save your Dreamweaver document. 


8. Select File > Preview In Browser and select a browser 
from the submenu to test the menu and the links for the 
menu items (Figure 25).


Figure 23 Insert panel


Figure 24 Fireworks HTML dialog box


Figure 25 Testing a pop-up menu


How to create rollover images
A rollover is an image that changes when the pointer moves across it. A rollover actually consists of two images: the 
primary image (the image displayed when the page first loads) and the rollover image (the image that appears when 
the pointer moves over the primary image).


Rollover images add highlighting or design effects by drawing viewer attention when the images are swapped. One 
example is a button that highlights or changes color when the pointer passes over it.


Creating a rollover image


You create a rollover image by inserting it from the Insert panel and then setting options in the Insert Rollover Image 
dialog box.


To create a rollover image:


1. Open Dreamweaver CS6 and open the document in 
which you want to create a rollover image.
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2. Make sure the Common category is selected in the Insert 
panel. Click the down arrow on the Images button and 
select Rollover Image from the pop-up menu 
(Figure 26).


The Insert Rollover Image dialog box opens (Figure 27).


3. Use the Insert Rollover Image dialog box to set up your 
rollover:


• Image Name: Type a name for the rollover image.


• Original Image: Click Browse and select the image 
to be displayed when the page loads.


• Rollover Image: Click Browse and select the image 
to be displayed when the pointer rolls over the 
original image.


• Alternate Text: Type the text you want to appear as 
alternate text for the image.


• When Clicked, Go To URL: Click Browse and select 
the file (or type the path to the file) to be opened 
when the image is clicked.


4. Click OK to close the dialog box.


5. Save the page.


6. Select File > Preview In Browser and select a browser 
from the submenu to preview the rollover image and test 
the link.


Figure 26 Insert panel


Figure 27 Insert Rollover Image dialog box


Figure 28 Testing a rollover image: up (top) and 
over (bottom)
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Developing interactive buttons using CSS
As CSS3 gains wider support in modern devices and browsers, design elements such as interactive buttons can now 
be constructed entirely in CSS. Advanced users may prefer to create CSS-based buttons from a Fireworks design. 
You can use the CSS Properties panel to extract a design object’s properties (rounded corners, opacity, and more) and 
map the properites to HTML elements by using CSS in Dreamweaver. 


In this section, you use Fireworks and Dreaweaver to build a simple set of CSS-based navigation buttons. Fireworks 
is used to create a shape, add text, and add a drop-shadow effect. Use the CSS Properties panel to extract the shape’s 
design elements, and add them to an HTML element in Dreamweaver.


Visit the Adobe Developer Center at www.adobe.com/devnet.html to learn more about how to extend and refine your 
CSS-based interactive navigation.


To create CSS-based interactive buttons:


1. Create a new document in Fireworks and make it 200 
pixels by 200 pixels, and set the Resolution to 72 pixels/
inch.


2. Use the Rectangle tool or the Ellipse tool from the Tools 
panel to draw a shape for the button. Make the 
dimensions of the shape fit the size of your navigation 
bar.


3. Use the Gradient Fill button to add a Gradient Shape and 
set fill colors.


4. Use the Properties panel to add color and gradient to the 
button.


5. Use the Text tool to add text to the button. 


6. Use the Smart Guides to center the text over the button 
shape.


In Figure 29, the sample button is a 145x35 pixel 
rounded rectangle with a red radial gradient. Text is 
Verdana, Bold, with font size set to 15 and color set to 
white. 


7. Choose the Pointer tool from the Tools panel and select 
the button shape on the canvas.


8. Select Window >  CSS Properties.


The CSS Properties panel opens and displays the list of 
CSS properties for the selected object (Figure 30).


You will return to the CSS Properties panel after the 
HTML elements have been created in Dreamweaver. 


9. Start Dreamweaver and select File > New.


10. In the New Document dialog box, select Blank Page, 
select HTML for Page tyep, and select <none> for 
Layout. Click Create.


Figure 29 Sample Fireworks button design


Figure 30 CSS Properties panel 


Copy All button
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11. Save the new document.


12. Click the Split button in the Document toolbar 
(Figure 31).


Code view and Design view are visible in the document 
window.


You will work in Code view in the next steps. 


13. In Code view, locate the <body> tag, place the insertion 
point at the end of the opening <body> tag, and press 
Enter (Windows) or Return (Mac OS).


Figure 31 Dreamweaver Document toolbar


14. Enter (or copy and paste) the following code between the <body> tags in the Code view. If you enter the code 
directly from the keyboard, watch for code hints as you type. You can save work by double-clicking the code 
pieces you need from the lists that appear.
<ul>
   <li class="button"><a href="#">Home</a></li>
</ul>


15. Copy the complete list item Home code inside the <ul> tags and paste it three times before the closing </ul> 
tag (Figure 32).


Figure 32 Sample code


16. Replace "Home" in the three copies with "Directions", "Hours", and "Facilities", respectively (Figure 33).


This code creates an unordered list, that is associated with a button class that is not yet defined. Each list item is 
a link.


Figure 33 Sample code


17. Open the CSS Styles panel (Window > CSS Styles). If a message reminds you that you've made coding changes, 
click the Refresh button in the CSS Styles panel.

How to create interactive navigation © 2012 Adobe Systems Incorporated







Adobe Fireworks CS6 and Adobe Dreamweaver CS6 Project 3 guide

18. In the CSS Styles panel, click the New CSS Rule button 
(Figure 34). 


The New CSS Rule dialog box opens (Figure 35).


19. Open the Selector Type menu and select Class (Can 
Apply To Any HTML Element).


20. Type .button in the Selector Name text box. 


21. Click OK to close the New CSS Rule dialog box.


The CSS Rule Definition dialog box opens.


22. Click OK to close the CSS Rule Definition dialog box 
without setting any style options. 


You will use content from the Fireworks CSS Properties 
panel to apply style options to the new empty button rule.


23. Return to Fireworks and open the CSS Properties panel.


24. Select the button shape and click the Copy All button 
(Figure 30).


The CSS properties for the graphic are extracted and 
saved to the clipboard.


25. Switch to Dreamweaver.


26. In Code view, locate the <style> tag in the head section, 
place the insertion point between the open and closing 
curly brackets that follow the .button selector,  and press 
Enter (Windows) or Return (Mac OS).


27. Select Edit > Paste to insert the saved CSS properties into 
the button selector.


28. Click in the Design view to refresh.


The background of the list items in Design view changes. 


29. Click the Live button in the Document toolbar at the top 
of the Document window to preview the initial changes 
to the button list (Figure 36).


The button design still needs a bit of refinement.


30. Switch to Fireworks, select the button text, and click the 
Copy All button in the CSS Properties panel.


31. Return to Dreamweaver, locate the closing curly bracket 
of the button selector, and paste the contents of the 
clipboard inside the bracket.


32. In Code view, enter in the following code at the end of 
the button selector declaration:
list-style: none;
This removes the default list marker.


Figure 34 CSS Styles panel


Figure 35 New CSS Rule dialog box


Figure 36 Shape attributes applied to list items


New CSS Rule


Selector text box Selector Type menu
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33. Click in the Design view to refresh.


Notice the CSS styles are applied to the text in the Design 
view (Figure 37). However, the link text has assumed the 
default color for link attributes. This can be easily fixed 
by redefining the link attribute CSS style. 


Figure 37 Text attributes applied to list items


34. Enter (or copy and paste) the following code between the .button closing curly bracket, and the closing </
style> tag (Figure 38):
a:link {color: #ffffff; text-decoration:none;}
a:hover, a:active, a:focus {text-decoration: underline;}
a:visited {color: #ffffff;}


Figure 38 Sample code


35. Click in the Design view to refresh.


The link attributes are applied to the list items 
(Figure 39).


36. Test the items in the Live view to see how the text 
becomes underlined when the mouse hovers over a link.


The other selectors proviede a keyboard navigator the 
same hover experience as the person using a mouse.


The list item buttons remain close together.  


37. In Code view, place the insertion point after list-
style:none; at the end of the .button selector 
definition, and press Enter (Windows) or Return (Mac 
OS).


A list of code hints appears. As you type characters in 
Code view, you will see a list of candidates that 
automatically complete your entry.


38. Type marg. A list of options appears (Figure 40).


39. Double-click margin-top from the list of available 
options.


40. Type 10px;. 


The top margin for the list item is now set to 10 pixels. 
The semicolon closes the property-value pair.


Figure 39 Link attributes applied to list items


Figure 40 Code hints
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41. Click in the Design view.


The list item buttons are now separated by 10 pixels that's 
been added to the top margin of each button (Figure 41).


42. Select File > Preview In Browser, and then select a 
browser to preview the interactive CSS buttons in a web 
browser (Figure 42).


Figure 41 Margin attribute applied to list items


Figure 42 Test buttons in web browser
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How to manage files and links by using the Files panel
The Files panel in Dreamweaver helps you manage files and links. Use the Files panel to open, add, rename, or delete 
files and folders. Use the Files panel to modify links.


Opening files
Use the Files panel to view and manage the files in your Dreamweaver site. 


To open a file:


1. In the Files panel (Window > Files), select a site, server, 
or drive from the Current Sites pop-up menu (Figure 1).


2. In the Local Files section, navigate to the file you want to 
open.


3. Do one of the following:


• Double-click the files's icon.


• Right-click (Windows) or Control-click (Mac OS) 
the file's icon, then select Open.


Note: If Check In/Check Out is enabled, Dreamweaver 
will check the file out before it opens the file. If another 
visitor has checked out the file, Dreamweaver will warn 
you about the file’s status and let you know who has it 
checked out. You can then decide whether to continue 
opening the file or not.


Figure 1 Dreamweaver Files panel 


Renaming files
When you rename a file in the Files panel, Dreamweaver can automatically change links that point to this file. For 
this reason, it is always preferable to rename site files by using the Files panel instead of renaming them on your hard 
disk.


To rename a file:


1. In the Files panel, select the file or folder you want to 
rename.


2. Do one of the following to activate the name of the file or 
folder:


• Click the name, pause, and then click again.


• Right-click (Windows) or Control-click (Mac OS) 
the file or folder icon, and then select Edit > 
Rename.


3. Type the new name over the existing name.


4. Press Enter (Windows) or Return (Mac OS).


If any site links point to the file or folder, the Update 
Files dialog box opens (Figure 2).


5. Click Update to change links that point to the renamed 
file or to a file in the renamed folder.


Figure 2 Update Files dialog box


Current Sites menu
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Deleting files
When you delete a file or folder, Dreamweaver will warn you if links in other documents point to the file or folder. 


To delete a file:


1. Click the file or folder in the Files panel you want to 
delete.


1. Press Delete.


If any site links point to the file or folder, the Delete Files 
warning opens (Figure 3), giving you the opportunity to 
change the links before you delete the file.


To delete the file anyway, click Yes. To cancel your 
request to delete the file, click No.


Figure 3 Delete files dialog box


Changing links to a file
You can also change links to a file through the Files panel. It is a good practice to change links before you delete a file 
to which other files are linked.


To change links to a file:


1. Select a file in the Files panel.


1. Select Site > Change Link Sitewide.


The Change Link Sitewide dialog box opens (Figure 4).


2. In the Into Links To text box, enter the name of the file to 
which new links should point.


3. Click OK.


The Update Files dialog box opens (Figure 5).


4. Click Update.


Figure 4 Change Links Sitewide dialog box


Figure 5 Update Files dialog box


Creating a new folder
Use folders to keep your site well organized. For example, most websites use a folder named images to store all the 
images for the site.


To create a new folder:


1.  Select the site root folder (or another folder in which you 
want to create a nested folder).
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2. In the Files panel menu (Figure 6), select File > New 
Folder.


Dreamweaver creates a new folder inside the selected 
folder. The folder name is selected.


3. Enter a name for the new folder and press Enter 
(Windows) or Return (Mac OS).


Figure 6 Files panel


Panel menu
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How to deploy for multiple screens
Ethan Marcotte, a developer in Boston, coined the phrase responsive design to describe a website that adapts to the 
size of the viewer’s screen. A demonstration site built by Ethan Marcotte illustrates this concept; visit http://
www.alistapart.com/d/responsive-web-design/ex/ex-site-FINAL.html to experience responsive design (Figure 1). 
Notice that as you narrow the width of the browser window, the text reflows and the images get slightly smaller. Once 
the browser window is less than 1300 pixels wide, the images stack into two rows but continue to become smaller as 
the window narrows. When the browser narrows to 600 pixels, the content again reflows. The navigation bar moves 
to the top of the page and the image behind the logo disappears. This is all being done through percentage-based 
widths for content known as a flexible grid. For viewers, it means the content will always be properly formatted to fit 
the screens or devices on which they are viewing the it.


Figure 1 A responsive design website at three browser widths


Adobe Dreamweaver CS6 streamlines the task of building responsive design websites for multiple screens with its 
integrated Fluid Grid Layouts and CSS media queries. Dreamweaver uses Fluid Grid Layouts to create designs that 
scale themselves to multiple screen sizes and devices. CSS3 Media Queries is a more advanced option used to define 
custom CSS files for mobile, tablet, and desktop devices, permitting device-specific user interfaces to be built on the 
same HTML markup.  


Fluid Grid Layouts
Fluid Grid Layouts provides for flexible content resizing within a browser window. The browser on a device checks 
the embedded media query and uses the corresponding CSS code to display the web page. You can create a new 
document that works across multiple screens by using the Fluid Grid Layouts option (Figure 2). 


Figure 2 New Document dialog box, Fluid Grid Layout category
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To create a Fluid Grid Layout:


1. Start Dreamweaver. 


2. Select File > New Fluid Grid Layout.


The New Document dialog box appears (Figure 2).


3. In the Mobile, Tablet, and Desktop text boxes, set the 
number of grids to 2, 3, and 4, respectively.


4. Under Mobile, set the % Of Column Width to 10.


This number defines the gutter or space between each 
pair of columns in the grid.


5. Set the overall width percentage of the Mobile, Tablet, 
and Desktop layouts to 100, 100, and 88, respectively.


The grid widths are 100% for the mobile phone and tablet 
layouts. On the desktop, the width of the grid is 88%, 
which means that it will fill out 88% of the browser 
window and center the content, with equal space (6%) on 
each side.


6. Click Create. 


The Save Style Sheet File As dialog box appears 
(Figure 3).


7. Save the CSS file as grids.css in your site root folder.


The layout opens in Design view.


8. Select File > Save and save the document as grids.html 
in your site root folder.


The Copy Dependent Files dialog box appears. The files 
boilerplate.css and respond.min.js work together to  
normalize and adjust the content to display across many 
devices.


9. Click Copy in the Copy Dependent Files dialog box.


The layout is currently set to Mobile. In turn, click the 
Tablet icon and the Desktop icon in the Status bar at the 
bottom of the Document window (Figure 5) to compare 
the Fluid Grid Layouts.


10. Click the Mobile icon to switch back to the two-column 
Mobile layout.


It is a best practice in responsive design to focus on 
“mobile first,” because this format forces you to 
concentrate on content first, visual design second. 


Notice that one block of content is already in place at the 
top of the layout (Figure 6).


Figure 3 Save Style Sheets File As dialog box


Figure 4 Copy Dependant Files dialog box


Figure 5 Status bar


Figure 6 Fluid Grid Layout, Mobile layout


Mobile icon Tablet icon Desktop icon


Layout div 
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11. Open the Properties panel (Window > Properties).


12. In Design view, click the outline of the layout div 
(Figure 6) to select it.


The Div ID information appears in the Properties panel 
(Figure 7).


13. Enter header in the Div ID name text box.


14. Open the Insert panel (Window > Insert), if it is not 
already open.


15. Select Layout from the Category pop-up menu.


16. Click the Insert Fluid Grid Layout Div Tag button 
(Figure 8).


The Insert Fluid Grid Layout Div Tag dialog box appears 
(Figure 9).


17. Enter nav in the ID text box.


The option Start New Row is selected by default. This 
tells Dreamweaver and the browser to make this content 
fill the entire width of the current grid layout. Deselecting 
this option allows the element to float beside another 
element on the page. 


18. Click OK to insert the div tag into the page.


A Fluid Grid Layout div is nothing more than an HTML 
<div> element with a unique ID assigned to it.


19. Click the Insert Fluid Grid Layout Div Tag button to 
insert another Fluid Grid Layout div into the page and 
rename it content. 


You now have three stacked divs (labeled Header, Nav, 
and Content) across two columns in the Mobile layout 
(Figure 10).


20. Click the Tablet icon (Figure 5) to switch to the Tablet 
layout.


21. In Design view, click to select the Nav div.


22. Drag the right handle to narrow the width of the div to fill 
only the left column (Figure 11).


23. Click to select the Content div, and resize it to span two 
columns. 


Figure 7 Properties panel


Figure 8 Insert panel, Layout category


Figure 9 Insert Fluid Grid Layout Div Tag dialog 
box


Figure 10 Three divs across two columns


Figure 11 Resize div in Design view


Div ID name text box
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24. Click the Move Up A Row button on the right side of the Content div (Figure 12).


The Content div moves up a row, beside the Nav div (Figure 13).


Figure 12 Divs in Tablet layout, before move


Figure 13 Divs in Tablet layout, after move


25. Click the Desktop icon (Figure 5) at the bottom of the Document window to switch to the Desktop layout.


26. Arrange the divs so the Nav div spans one column and the Content div spans the remaining three columns in the 
four-column Desktop layout (Figure 14). 


You may need to scroll to see the right ends of the divs.


Figure 14 Divs in Desktop layout


27. Click grid.css in the Related Files bar at the top of the 
document window (Figure 15).


Split view opens, showing grids.css in Code view.


28. Scroll in Code view to locate the beginnings of the 
Mobile, Tablet, and Desktop layout code sections (at 
about lines 29, 58, and 89, respectively) (Figure 16).


Each time you add a Fluid Grid Layout div element to the 
page, a rule is created in the CSS for each device. Notice 
the “@media” declarations, which indicate the beginning 
of a media query. The Tablet media query, appears at 
about line 60, and it only applies when a screen has a 
width of at least 481px–in other words, most mobile 
phones would ignore these rules because their screens are 
not that wide.


29. Select File > Save All to save the document and the 
dependent files.


Figure 15 Related Files bar


Figure 16 CSS code view detail


Move Up A Row
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Preview layout
Once you’ve established a suitable Fluid Grid Layout for your content across all of the devices, you can add content 
and preview it by using the Multiscreen Preview function in Dreamweaver (Figure 17).


Figure 17 Multiscreen Preview panel


To preview the Fluid Grid Layout:


1. Use the Insert panel to add an assortment of graphics, 
text, and links to the grid.html file. You can fine-tune the 
layout of page elements by using the CSS panel.


2. Toggle among the Mobile, Tablet, and Desktop layouts to 
compare them (Figure 18). 


Figure 18 Content in Mobile layout
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3. Click the Multiscreen button in the Control panel at the 
top of the Document window (Figure 19).


The Multiscreen Preview panel opens (Figure 17).


Multiscreen Preview supports the following screen types:


• Phone (default screen size: 320 x 300 pixels)


• Tablet (default screen size: 768 x 300 pixels)


• Desktop (default screen width: 1126 pixels)


Note: If you know the dimensions of any other devices 
you want to target, you can specify additional 
orientations and styles for different devices by using the 
Design/Live View Sizes menu (Figure 20). For example, 
you can create a screen dimension of 480 x 272 pixels for 
a Sony PSP device.


The phone, tablet, and desktop dimensions used for 
previewing are set to default sizes. However, you can 
change the default sizes by clicking the Viewport Sizes 
button in the Multiscreen Preview panel.


Note: Do not use the Multiscreen Preview panel as a 
browser. It is not intended to display dynamic media such 
as movies and audio clips.


Figure 19 Control panel


Figure 20 Design/Live View Sizes menu


Design/Live View Sizes menu
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CSS Media Queries
CSS media queries extends the concept of Fluid Grid Layouts. Advanced users might consider using CSS3 media 
queries to target designs for multiple devices by specifying a different CSS file for each unique device.


You can access the Media Queries dialog box (Figure 21) by using the Design/Live View Sizes menu (Figure 20). 


Note: The Media Query Manager is not currently compatible with Fluid Grid Layouts.


Figure 21 Media Queries dialog box


For more detailed information about media queries, please see Dreamweaver Help.
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How to preview and test a web project
Because you can't control which browsers or operating systems visitors will use to view your site, it is important to 
test your site in different browsers. Although you can do some of this on your computer by installing several browsers 
and running a local testing server, it can be a challenge to review all possible combinations of browsers and operating 
systems. For a detailed overview about the purposes of a testing server, see the Dreamweaver Developer Center 
article written by David Powers, Setting up a local testing server in Dreamweaver CS5 at www.adobe.com/devnet/
dreamweaver/articles/setup_testing_server.html.


Adobe BrowserLab is an online service that lets you test your website pages in a variety of web browsers and 
operating systems. For example, the following combinations of browsers and operating systems can produce slight 
differences in how your site appears:


• Google Chrome 3.0 - Windows XP


• Microsoft Internet Explorer 8.0 - Windows XP


• Apple Safari 4.0 - Mac OS X


• Mozilla Firefox 3.0 - Mac OS X


The service works by taking screenshots of your web pages in different browsers and then displaying them on the 
BrowserLab page (Figure 1).


Figure 1 Adobe BrowserLab 


BrowserLab is integrated with Dreamweaver CS6. You can test your pages from within Dreamweaver without 
publishing your pages to a server.


View menuBrowser menus Refresh The Screen button
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Using BrowserLab in Dreamweaver
BrowserLab lets you preview local web content from within Dreamweaver, without requiring you to post it to a 
publicly-accessible server first. You can preview files from your local Dreamweaver site.


To use BrowserLab within Dreamweaver:


1. Start Dreamweaver.


2. Open a document that you want to preview in 
BrowserLab.


3. Select View > Design.


4. Choose Window > Extensions > Adobe BrowserLab.


The Adobe BrowserLab panel opens.


5. In the Adobe BrowserLab panel, choose Local/Network 
from the pop-up menu (Figure 2).


The Design view and Local/Network options direct 
BrowserLab to preview files using the open local file as 
its source for screen shots.


6. Click the Preview button.


7. When the BrowserLab home page opens, click Start 
Using BrowserLab (Figure 3).


Note: There may be a Go Back To BrowserLab button 
instead of a Start Using BrowserLab button if you have 
used the service before.


8. Enter your e-mail and password and click Sign In 
(Figure 4), or click Learn More to obtain an Adobe ID if 
you don't already have one.


9. Click the Browser pop-up menu and choose the browser/
operating system that you want to test.


10. To compare multiple browser/operating system 
combinations, choose 1-Up, 2-Up, or Onion Skin from 
the View pop-up menu (Figure 1).


Observe that the some content blocks in the illustrated 
web page do not show in the second pane. Make changes 
to your page until you are satisfied with the way it 
appears in both panes.


11. Make changes to the page, or to the CSS attached to the 
page.


12. Click the Refresh The Screenshots button in the 
BrowserLab application window.


BrowserLab previews your page without your having to 
save the local changes first.


Figure 2 BrowserLab panel


Figure 3 Start Using BrowserLab button


Figure 4 BrowserLab Sign In page

How to preview and test a web project © 2012 Adobe Systems Incorporated





		How to preview and test a web project

		Using BrowserLab in Dreamweaver












Adobe Dreamweaver CS6 Project 3 guide

How to set up a local root folder and site structure
A Dreamweaver site is a collection of all the files and assets in your website. You can create web pages on your 
computer, upload them to a web server, and maintain the site by transferring updated files whenever you save them. 
You can also edit and maintain websites that were created without using Dreamweaver.


What is a Dreamweaver “site”?
In Dreamweaver the term “site” refers to a local or remote storage location for the documents that belong to a 
website. A Dreamweaver site provides a way to organize and manage all of your web documents, upload your site to 
a web server, track and maintain your links, and manage and share files. You should define a site to take full 
advantage of Dreamweaver features.


Note: To define a Dreamweaver site, you only need to set up a local folder. To transfer files to a web server or to 
develop web applications, you must also add information for a remote site and testing server.


A Dreamweaver site consists of as many as three parts, or folders, depending on your development environment and 
the type of website you are developing:


Local root folder stores the files you’re working on. Dreamweaver refers to this folder as your “local site.” This 
folder is typically on your local computer, but it can also be on a network server.


Remote folder stores your files for testing, production, collaboration, and so on. Dreamweaver refers to this folder as 
your “remote site” in the Files panel. Typically, your remote folder is on the computer where your web server is 
running. The remote folder holds the files that users access on the Internet. Together, the local and remote folders 
enable you to transfer files between your local hard disk and web server, making it easy to manage files in your 
Dreamweaver sites. You work on files in the local folder, and then publish them to the remote folder when you want 
other people to view them.


Testing server folder is the folder where Dreamweaver processes dynamic pages. 


Understanding local and remote folder structure
When you want to use Dreamweaver to connect to a remote folder, you specify the remote folder in the Servers 
category of the Site Setup dialog box. The remote folder that you specify (also referred to as the “host directory”) 
should correspond to the local root folder of your Dreamweaver site. (The local root folder is the top-level folder of 
your Dreamweaver site.) Remote folders, like local folders, can have any title, but commonly, Internet Service 
Providers (ISPs) name the top-level remote folders for individual user accounts public_html, pub_html, or something 
similar. If you are in charge of your own remote server, and can name the remote folder anything you want, it is a 
good idea for your local root folder and remote folder to have the same name.


Figure 1 shows a sample local root folder on the left and a sample remote folder on the right. The local root folder on 
the local machine maps directly to the remote folder on the web server, rather than to any of the remote folder’s sub 
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folders, or folders that exist above the remote folder in the directory structure.


Figure 1 Sample local root folder (left), and sample remote folder (right)


Note: The above example illustrates one local root folder on the local machine, and one top-level remote folder on 
the remote web server. If, however, you are maintaining a number of Dreamweaver sites on your local machine, you 
would need an equal number of remote folders on the remote server. In such a case the above example would not 
apply, and you would instead create different remote folders within the public_html folder, and then map them to their 
corresponding local root folders on your local machine.


When you first establish a remote connection, the remote folder on the web server is usually empty. Then, when you 
use Dreamweaver to upload all of the files in your local root folder, the remote folder populates with all of your web 
files. The directory structure of the remote folder and the local root folder should always be the same. (That is, there 
should always be a one-to-one correspondence between the files and folders in your local root folder, and the files and 
folders in your remote folder.) If the structure of the remote folder doesn’t match the structure of the local root folder, 
Dreamweaver uploads files to the wrong place, where they might not be visible to site visitors. Additionally, image 
and link paths can easily break when folder and file structures are not in synch. The remote folder must exist before 
Dreamweaver can connect to it. If you don’t have a designated folder that acts as your remote folder on the web 
server, create one or ask your ISP’s server administrator to create one for you.


Setting up a local root folder
To set up a local version of your site, all you need to do is specify the local folder where you’ll store all of your site 
files. The local folder can be on your local computer or on a network server.


To set up a local root folder:


1. Identify or create the folder on your computer where you 
want to store the local version of your site files. (The 
folder can be anywhere on your computer.) You’ll specify 
this folder as your local site in Dreamweaver.


This folder is called the local root folder.


2. Start Dreamweaver.
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3. Choose Site > New Site.


The Site Setup dialog box opens (Figure 2).


4. In the Site Setup dialog box, make sure the Site category 
is selected. (It should be selected by default.)


5. In the Site Name text box, enter a name for your site. 
This name appears in the Files panel and in the Manage 
Sites dialog box; it does not appear in the browser.


6. In the Local Site Folder text box, click the Browse To 
Folder icon, browse to and select the local root folder you 
created, and click Select (Windows) or Choose (MacOS).


Your local root folder is defined in Dreamweaver.


7. Click Save to close the Site Setup dialog box. 


You can now begin working on your local site files in 
Dreamweaver.


On the right side of the Dreamweaver workspace, the 
Files panel displays the folders and files of your site 
(Figure 4). 


Note: When you’re ready, you can fill out the other 
categories in the Site Setup dialog box, including the 
Servers category, where you can specify a remote folder 
on your remote server.


Figure 2 Site Setup dialog box, Site category


Figure 3 Choose Root Folder dialog box


Figure 4 Files panel


Modifying site information
The Manage Sites dialog box is your gateway into various Dreamweaver site functions. From this dialog box, you can 
initiate the process for creating a new site, editing an existing site, duplicating a site, removing a site, or importing or 
exporting a site’s settings.
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To modify site information:


1. Select Site > Manage Sites.


The Manage Sites dialog box opens (Figure 5).


2. Select the site name and click the Edit button.


The Site Setup dialog box opens (Figure 2).


3. Click a button to select one of the options, make any 
changes you need to make, and click Save or Cancel to 
close the Site Setup dialog box. Click Done to close the 
Manage Sites dialog box..


Figure 5 Manage Sites dialog box


Edit The Currently Selected Site
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How to use CSS starter layouts
When creating a new document in Dreamweaver, you can choose one that already contains a CSS layout. 
Dreamweaver comes with many different CSS layouts from which to choose (Figure 1). The predesigned CSS 
layouts provide the following types of columns:


• Liquid layouts specify column width as a percentage of the site visitor’s browser width. The design adapts if 
the site visitor makes the browser wider or narrower, but does not change based on the site visitor’s text 
settings.


• Fixed layouts specify column width in pixels. The column does not resize based on the size of the browser or 
the site visitor’s text settings.


The New Document dialog box also includes two options for HTML5 and CSS layouts.


Figure 1 New Document dialog box


Using a starter layout
Starter layouts are available as an option in the New Document dialog box.


To use a starter layout:


1. Start Dreamweaver.


2. Select  File > New.


The New Document dialog box opens (Figure 1).


3. Select the Blank Page category if not already selected.


4. For Page Type, select HTML.


Attach Style Sheet button
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5. For Layout, select the CSS layout you want to use. 


You can choose from 16 different layouts. The Preview 
window shows the layout and gives a brief description of 
the selected layout.


The selection illustrated in Figure 1 is a 2-column liquid 
layout with a left sidebar, header, and footer is selected.


6. Select a location for the layout’s CSS from the Layout 
CSS pop-up menu:


• Add To Head adds CSS for the layout to the head of 
the page you’re creating.


• Create New File adds CSS for the layout to a new 
external CSS stylesheet and attaches the new 
stylesheet to the page you’re creating.


• Link To Existing File lets you specify an existing 
CSS file that already contains the CSS rules needed 
for the layout. This option is particularly useful when 
you want to use the same CSS layout (the CSS rules 
for which are contained in a single file) across 
multiple documents.


7. Do one of the following: 


• If you selected Add To Head from the Layout CSS 
pop-up menu (the default option), click Create. 


• If you selected Create New File from the Layout 
CSS pop-up menu, click Create, and then specify a 
name for the new external file in the Save Style 
Sheet File As dialog box. 


• If you selected Link To Existing File from the 
Layout CSS pop-up menu, add the external file to 
the Attach CSS File text box by clicking the Attach 
Style Sheet button, completing the Attach External 
Style Sheet dialog box, and clicking OK. When 
you’re finished, click Create in the New Document 
dialog box.


Note: When you select the Link To Existing File 
option, the file you specify must already have the 
rules for the CSS file contained within it.


When you put the layout CSS in a new file or link to an 
existing file, Dreamweaver automatically links the file to 
the HTML page you’re creating.


The layout opens in Dreamweaver (Figure 2).


8. (Optional) You can modify some aspects of a page (font, 
font size, colors and margins) after it’s created by 
selecting Modify > Page Properties to open the Page 
Properties dialog box (Figure 3).


Figure 2 Dreamweaver CSS starter layout


Figure 3 Page Properties dialog box
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How to troubleshoot Cascading Style Sheets
While CSS provides lots of advantages for specifying page appearance, you can run into problems with how pages 
appear, especially when you have multiple tags applied to the same text. This guide offers some ways to troubleshoot 
problems with CSS.


Using the Tag selector
The Tag selector is located in the Status bar and shows, in hierarchical order, the tags that apply to the currently 
selected page element. You can then click any tag in the hiearchy to see everything contained by the tag.


To use the Tag selector:


1. Select text, an image, or another page element. 


The Tag selector displays tags that apply to the selection. 
In the example (Figure 1), the selected text (interpreting 
the tag list from right to left) is bolded (<strong>), a list 
item (<li>), part of an unordered list (<ul>), within a div 
named maintext. (All page elements are contained within 
<body>.)


2. Click one of the tags to see what it contains (Figure 2).


Figure 1 Tag selector in the Status bar at the 
bottom of the Document window


Figure 2 Contents of selected tag
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Coloring divs to diagnose layout problems 
When you use divs for page layout, it can help to add a different background color to each element on the  page. With 
different background colors added to each element, you can spot problems such as overlapping elements or elements 
that are rendering differently than you intended them to. For example, the page in the example (Figure 3) has text that 
is misaligned, gaps in the page border, and other problems. Because all elements in the middle section have the same 
background color (white), it is difficult to tell which div is causing the problem.


Figure 3 Page with CSS layout problems


Adding different background colors to all divs (Figure 4) lets you see that the div containing the image overlaps the 
left column of text, and is overlapped by the div below it. You can then correct the problems by changing the 
dimensions of the div containing the image, and making other changes.


Figure 4 Background colors added to divs
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To add background colors to div tags:


1. Start Dreamweaver and open a file that uses CSS and 
absolutely positioned div elements.


2. Open the CSS Styles Panel (Window > CSS Styles).


3. Repeat the following steps for each div:


a. Double-click the CSS rule corresponding to the div 
tag to open the CSS Rule Definition dialog box.


b. Select Background  in the Category pane (Figure 5).


c. Select a background color from the color picker.


d. Click OK.


The background color is applied to the selected div. Figure 5 Setting background color
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How to use templates
You can use an Adobe Dreamweaver CS6 template to create multiple pages with the same layout. In a template, you 
control which page elements should remain constant in documents based on that template and which elements can be 
changed from page to page. Templates are helpful for building a website in which most pages have the same header, 
navigation system, and other elements. Using templates helps you save time as well as create and maintain a 
consistent look when more than one person is developing a site.


Creating a template
You create templates from existing pages, setting editable regions on these pages that will hold content on each page 
created from the template.


To create a template:


1. Start Dreamweaver.


2. Build a page that contains elements designed to appear 
on all content pages such as common graphics, a 
navigation bar, and common layout structures such as div 
tags (Figure 1).


Note: You may want to create navigation elements in 
Adobe Fireworks CS6 and export them as HTML 
documents.


3. Select File > Save As Template.


4. In the Save As Template dialog box (Figure 2), give the 
template a name. You can also enter a brief description of 
the template. Then click Save. If Dreamweaver asks if 
you want to update links, click Yes.


Dreamweaver creates a Templates folder in your site root 
folder and saves your template in that folder. Template 
files have a .dwt file extension.


Figure 1 Common elements on a web page


Figure 2 Save As Template dialog box
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To create an editable region:


1. In the Layout category of the Insert panel, click Draw AP 
Div, and then drag on the page to create a new div to 
represent the editable region in the template.


Note: You also click to indicate where to place the 
editable region, but using a div gives you more control 
over page layout. 


2. With the div still selected, do one of the following to 
create an editable region:


• Select Insert > Template Objects > Editable Region.


• Right-click (Windows) or Control-click (Mac OS) 
the region and select Templates > New Editable 
Region from the context menu.


• In the Common category of the Insert panel, click the 
Templates button (Figure 3), and select Editable 
Region from the pop-up menu.


The New Editable Region dialog box opens (Figure 4).


3. In the dialog box, enter a unique name for the region, and 
click OK.


The editable region is within the selected div, and is 
enclosed in a light blue rectangle on the template 
(Figure 5).


Note: You cannot use the same name for more than one 
editable region in a particular template. Use only letters 
and numbers in the name.


4. Save and close the template.


Figure 3 Templates button on the Insert panel


Figure 4 New Editable Region dialog box


Figure 5 New editable region inside the div
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To create a document based on a template:


Once you create a template, you can use it to create new 
documents.


1. Select File > New.


2. In the New Document dialog box, select the Page From 
Template category.


The dialog box displays your sites and all of the 
templates for the selected site (Figure 6).


3. In the Sites list, select the site that contains the template 
you want to use.


4. Select the template you want to use.


5. Make sure the Update Page When Template Changes 
option is selected.


With this option selected, Dreamweaver can update all 
template-based pages if you change the template later.


6. Click Create to create a new template-based page.


The document opens in the Document window.


7. Click in one of the editable regions, and add text.


8. Move the pointer over a page area that is not editable, and 
observe that you cannot make changes.


9. Save the page.


Figure 6 Page From Template category in the New 
Document dialog box


Editing a template
You can edit a template at any time, even if you have created pages based on the template.


To edit a template:


1. Select Window > Assets.


The Assets panel opens.


2. Click the Templates button on the left side of the panel 
(Figure 7).


A list of the templates for your site appears in the lower 
pane. The upper pane displays a preview of the selected 
template. (You may need to scroll the preview pane to see 
this.)


3. Select the template you wish to edit and do one of the 
following:


• Double-click the name of the template.


• Click the Edit button at the bottom of the panel 
(Figure 7).


4. Edit the template in the Document window, changing 
non-editable elements or creating editable regions in the 
template as desired.


Figure 7 Assets panel


Templates Edit Delete
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5. Save the edited template by choosing File > Save.


The Update Template Files dialog box opens, with a list 
of the documents based on your template (Figure 8).


6. Click Update to update the documents based on the 
changes you made in your template.


The Update Pages dialog box displays a summary of the 
updates performed (Figure 9). You may need to select 
Show log to view the Status information.


7. Click Close.


Figure 8 Update Template Files dialog box


Figure 9 Update Pages dialog box


Deleting a template


To delete a template:


1. Select the template in the Assets panel.


2. Click the Delete button (trash can icon) at the bottom of 
the panel and confirm that you want to delete the 
template (Figure 7).


The template file is deleted from your site.


Documents that were based on a template you have 
deleted retain the structure and editable regions the 
template file had before you deleted it. To turn such a 
document into a normal HTML file without editable or 
locked regions, you must detach it from the template.


Detaching from a template
To remove the template structure and constraints from a document based on a template, you can detach the document 
from the template. When a document is detached from its template, you can edit any element, including the regions 
that were previously locked.


To detach a file from a template


1. To detach a document from a template, open the 
document.


2. Select Modify > Templates > Detach From Template.
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How to lay out a web page with CSS
A CSS page layout uses the Cascading Style Sheets format, rather than traditional HTML tables or frames, to 
organize the content on a web page. The basic building block of the CSS layout is the div tag—an HTML tag that in 
most cases acts as a container for text, images, and other page elements. When you create a CSS layout, you place div 
tags on the page, add content to them, and position them in various places. Unlike table cells, which are restricted to 
existing somewhere within the rows and columns of a table, div tags can appear anywhere on a web page. You can 
position div tags absolutely (by specifying x and y coordinates), or relatively (by specifying their distance from other 
page elements). You can also position div tags by specifying floats, paddings, and margins—the preferred method by 
today’s web standards.


Creating CSS layouts from scratch can be difficult because there are so many ways to do it. You can create a simple 
two-column CSS layout by setting floats, margins, paddings, and other CSS properties in a nearly infinite number of 
combinations. Additionally, the problem of cross-browser rendering causes certain CSS layouts to display properly in 
some browsers and improperly in others. Dreamweaver makes it easy for you to build pages with CSS layouts by 
providing 16 pre-designed layouts that work across different browsers.


Using the pre-designed CSS layouts is the easiest way to create a page with a CSS layout, but you can also create CSS 
layouts by using absolutely-positioned elements (AP elements). An AP element in Dreamweaver is an HTML page 
element—specifically, a div tag or any other tag—that has an absolute position assigned to it (Figure 1). The 
limitation of Dreamweaver AP elements, however, is that since they are absolutely positioned, their positions never 
adjust on the page in relation to the size of the browser window.


Once you become more experienced you will be able to create page layouts by inserting div tags manually and 
applying CSS positioning styles to them.


Figure 1 AP elements in the Dreamweaver Document window


Inserting an AP div tag
Start this activity by creating a new, blank page and inserting an AP div tag. AP elements can contain text, images, or 
any other content that you can place in the body of an HTML document.
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To insert an AP div tag:


1. Start Dreamweaver.


2. Select File > New.


The New Document dialog box opens (Figure 2).


3. With the Blank Page category selected, click HTML 
under Page Type and <none> under Layout.


4. Click Create.


A new untitled HTML document opens.


5. Save the new page.


The new file is added to the Files panel.


6. Select the Layout category in the Insert panel and 
confirm the Standard mode button is selected (Figure 3)


7. Click the Draw AP Div button.


The mouse pointer chanages to a cross when you move it 
over the Document window.


8. To create the div that will define an area of your page, 
drag a rectangle in the Dreamweaver document. 


9. Click the border of the div to select it.


Handles appear along the border (Figure 4) and the div 
properties appear in the Properties panel. 


Figure 2 New Document dialog box


Figure 3 Insert panel, Layout category


Figure 4 Div inserted and selected
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10. Make sure the Properties panel is open (Figure 5). 


It is docked at the bottom of the screen. If the Properties 
panel is not open, select Window > Properties.


11. Click in the CCS-P Element ID box and enter a name for 
the div. 


Choose a unique name that will help you remember the 
div’s contents, such as header or navigation.


Note: “CSS-P” is a commonly accepted abbreviation for 
“CSS Positioning”.


12. Click the Bg Color box and select a color in the color 
picker. 


The div changes to the selected color. 


13. Click once outside the new div to deselect it. 


A thin black line appears around the div. This line does 
not appear in a browser. If you do not see the line, select 
View > Visual Aids > CSS Layout Outlines.


14. Continue adding divs for all the sections on your page. 
You can place divs directly alongside one another 
(Figure 6).


15. Open the AP Elements panel (Window > AP Elements).


You’ll see that Dreamweaver has added the new divs to 
the list of AP Elements (Figure 7). 


Note: Select Prevent Overlaps to constrain the positions 
of AP elements when they are created, moved, and 
resized, so that they don’t overlap.


16. Save your page.


Figure 5 Properties panel


Figure 6 Multiple divs on page


Figure 7 AP Elements panel


Resizing divs
You can resize an individual div or simultaneously resize multiple divs to make them the same width and height.


Note: If the Prevent Overlaps option is selected in the AP Elements panel, you will not be able to move a div so that 
it overlaps another div.


CSS-P Element ID box
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To resize a div:


1. Select a div by clicking its border or by clicking the div’s 
name in the AP Elements panel.


2. Do one of the following to resize the div:


• To resize by dragging, drag any of the div’s resize 
handles (Figure 8).


• To resize one pixel at a time, hold down Control 
(Windows) or Option (Mac OS) while pressing an 
arrow key.


Note: The arrow keys move the right and bottom 
borders of the div; you can’t resize the top and left 
borders with this technique.


• In the Properties panel, type values for width (W) 
and height (H).


Figure 8 Resize by dragging


Moving divs
You can move divs in Design view in much the same way you move objects in most basic graphics applications.


Note: If the Prevent Overlaps option is selected in the AP Elements panel, you will not be able to move a div so that 
it overlaps another div.


To move a div:


1. Select one or more divs.


2. Do one of the following:


• To move by dragging, drag the div’s selection handle 
(Figure 9).


• To move one pixel at a time, use the arrow keys.


Figure 9 Moving a div


Adding content to divs
You can add images, text, and other content (such as Flash movies) to your divs just as you would elsewhere in a web 
page.


To add content to a div:


1. To insert an image in a div, click in the div and select 
Insert > Image.


Note: Make sure the div is sized large enough to hold the 
image or other content. If the div is sized smaller than the 
image, the div may not display correctly in all browsers.


Div resize handle


Selection handle

How to lay out a web page with CSS © 2012 Adobe Systems Incorporated







Adobe Dreamweaver CS6 Project 3 guide

2. In the Select Image Source dialog box, locate and select 
an image to insert (such as a page banner). Then click OK 
(Windows) or Open (Mac OS).


The image appears in the div (Figure 10).


3. To format the image in the div, select the image and 
select formatting elements in the Properties panel.


4. To add text to a div, click in the div and type text or paste 
text copied from another document.


Figure 10 Div with image added


Viewing div tags by using Live view
You can use a feature called Inspect mode in Live view to view the code generated by adding the div tags.  


To view div tags using by using Inspect mode in Live view:


1. Click the Live button in the Control panel (Figure 11).


Live view is enabled. This means that the page appears as 
it will in a web browser.


2. Click the Live button again to deactivate Live view.


3. Click the Split button. 


Code and Design view (Split view) view is enabled. This 
lets you see the code alongside the design display. 


4. Click the Live button again to activate Live Code view.


5. In the Design view, click on a div’s selection handle, or 
an image placed within a div and observe that the div tag 
is highlighted in the Code view (Figure 11).


Figure 11 Split Code/Live view


DivHighlighted tag


Live button
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